FOCUS AREAS

Resources for Intelligence Platform Migration

Quick Links

Analysis Report Messages

Migration

SAS® Data Integration Studio Server Data

SAS Data Integration Studio is the new name for SAS ETL Studio, a change that took place with version 3.3.

For any updates or hot fixes that are required before you can migrate, see the baseline requirements topic.

As noted in SAS Intelligence Platform: Migration Guide, post-migration tasks are required. For more information, see SAS 9.3 Guide to Software Updates.

Messages

caution Migration of this SAS environment is not recommended. This version of SAS Data Integration Studio Server Data is not at the required version and needs to be upgraded in order to use the automated migration processes. See http://support.sas.com/migration/utilitynotes for more information.
This message indicates that you must fulfill the baseline requirements for Data Integration Studio, which are documented in the the baseline requirements topic. An administrator performs the upgrade iteratively on one client per each SAS Metadata Server. After you complete the upgrade, run the SAS Migration Utility again. When the baseline requirements are met, this message does not appear in the Analysis Report.

caution SAS Data Integration Studio Server Data found metadata that is not correct for version 3.4 of the SAS Data Integration Studio. Product needs to be upgraded to latest version before migration. Ensure the Update Metadata for SAS Data Integration Studio plug-in has been run from SAS Management Console. Metadata server is required be at version 9.1.3SP4 with hotfix E9BA20 applied.
One or more SAS Metadata Repositories is not at the baseline. See above.

caution SAS Data Integration Studio Server Data found metadata that is not correct for version 3.4 of the SAS Data Integration Studio. The server version is version-number, it should be greater than or equal to version-number. Metadata server needs to be upgraded to 9.1.3SP4 with hotfix E9BA20 or later before migration.
The custom tree conversion has been run, but the metadata server is not at the SAS 9.1.3 SP4 baseline. See above.

caution SAS Data Integration Studio Server Data found metadata that is not correct for version 3.4 of the SAS Data Integration Studio. Metadata server needs hotfix E9BA20 or later applied and client updates before migration.
The metadata server is at the baseline, but the correct hot fix has not been applied. See above.
Checked-Out Metadata

In the Analysis Report, project repositories are listed in SAS Metadata Server messages if you are migrating from SAS 9.1.3. Project repositories will be reinitialized in the target SAS deployment, and the previous deployment's metadata will be deleted. Check in any metadata that you want to migrate.


Contributing to Migration

The migration team appreciates your feedback. Send e-mail to Migration.Feedback@sas.com with questions and comments for our developers, testers, and writers.