FOCUS AREAS

Hot Topics

Related Links

Software

Migration

SAS AppDev Studio


Upgrading to a Recent Release

See SAS AppDev Studio Eclipse Plug-ins: Migration Guide, which is available for a number of recent releases of the software with the SAS AppDev Studio Software documentation.

Peaceful Coexistence

Some sites perform a phased migration to the newest SAS release. This means you install a new release side-by-side with the previous release, and move your applications gradually rather than all at once.

Note that SAS AppDev Studio 3.3 does not support SAS 8.2. Therefore, if any of your projects and reports must continue to run against SAS 8.2, you must maintain a previous version of SAS AppDev Studio. You can install SAS AppDev Studio 3.3 side-by-side with SAS AppDev Studio 3.2.


Upgrading to Earlier Releases

SAS AppDev Studio customers can upgrade from Version 2.0 to Version 3.0, which supports SAS 9.1 as well as SAS Release 8.2. For requirements and migration information, see the SAS AppDev Studio 3.0 Migration Guide, which is available from the archives of the SAS AppDev Studio Developer's Site. For licensing information, speak to your SAS sales representative.

Peaceful Coexistence

Some sites perform a phased migration to SAS 9. This means you install SAS 9 side-by-side with SAS 8.2 and move your applications gradually rather than all at once. You can convert single SAS AppDev Studio 2.0 projects and reports to 3.0 in this way. See the SAS AppDev Studio 3.0 Migration Guide for important instructions.

Meanwhile, you can continue to use the remainder of 2.0 projects and reports against a SAS 9.1 or later server; however, this practice is not supported because some sites might experience problems.

Although Version 2.0 and 3.0 projects and reports can run concurrently on an end-user machine, you cannot install SAS AppDev Studio Version 3.0 side-by-side with Version 2.0 on a developer machine.