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ABSTRACT 

SAS® Enterprise Guide® continues to add easy-to-use features that enable you to work more efficiently. 
For example, you can now debug your DATA step code with a DATA step debugger tool; upload data to 
SAS® Viya™ with a point-and-click task; control process flow execution behavior when an error occurs; 
export results to Microsoft Excel and Microsoft PowerPoint destinations with the click of a button; zoom 
views; filter the data grid with your own WHERE clause; easily define case-insensitive filters; and 
automatically get the latest product updates. Come see these and more new features and enhancements 
in SAS Enterprise Guide 7.11, 7.12, and 7.13. 

INTRODUCTION 

The SAS Enterprise Guide 7.1 family of releases continues to grow.  With each release, we’ve added new 
features and enhancements that are direct responses to customer feedback.  (So keep letting us know 
improvements you’d like to see!) 

Table 1 shows the current releases in the SAS Enterprise Guide 7.1 family and the date each version was 
released. 

SAS Enterprise Guide Version Date Released 

7.1 October 2014 

7.11 May 2015 

7.12 February 2016 

7.13 November 2016 

Table 1. SAS Enterprise Guide 7.1x Versions and Their Release Dates 

I wrote a previous paper titled, “Find What You Are Looking For and More in SAS Enterprise Guide” 
(Smith, 2015).  That paper covers the new features in the first 7.1 release. 

While the initial 7.1 release is the largest in scope, each subsequent release adds notable new value.  
This paper will familiarize you with the main new features and enhancements in SAS Enterprise Guide 
versions 7.11, 7.12, and 7.13 and show you how they can increase your productivity. 

NEW FEATURES IN SAS ENTERPRISE GUIDE 7.11 

On the heels of the 7.1 release, our first 7.1x update provided the highly requested WHERE expression 
filtering in the data grid.  It also provided easy case-insensitive filters, Check for Updates, copy and paste 
support for prompts, and notification of external file changes.  We’ll take a look at each. 

WHERE EXPRESSION FILTERING IN THE DATA GRID 

Many users of SAS Display Manager remember and like the ability to create WHERE expressions to 
visually filter their data in VIEWTABLE.  With this VIEWTABLE feature in mind, SAS Enterprise Guide 
7.11 introduced a similar feature for easily filtering the data you are viewing. This new feature enables 
you to directly type a WHERE expression to immediately filter the data in the data grid. 

To use the feature, toggle the new Where button on the contextual toolbar above the data grid (see 
Display 1).  Enter your desired WHERE expression in the text field that is displayed.  Press Enter to apply 
the expression.  The data grid will then be refreshed to show only the records that meet the criteria in 
your expression. 
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Note: There is no need to precede your WHERE expression with the keyword “where”.  In fact, that 
causes an error, so avoid. 

Display 1 shows a WHERE expression being used to filter data in the data grid. 

 

Display 1. WHERE Expression Filtering in the Data Grid 

You can clear the expression to view the original, unfiltered data by pressing the  icon to the right of the 
expression field or deleting the expression text and pressing Enter.  You can also recall recently applied 
expressions by pressing the drop-down button to the right of the expression field. 

SAS Enterprise Guide provides several other ways of filtering data.  For example, you can use the basic 
Filter and Sort task, the more advanced Query Builder task, or take full control and submit your own 
SAS code to filter data.  Those methods differ from the WHERE expression filtering in that they create 
new output data sets or views, rather than simply filtering the data being viewed. 

Using the WHERE expression filtering requires familiarity with at least basic WHERE expression syntax.  
Press the question mark button to the right of the expression field to access help for the feature, including 
basic syntax help. 

The WHERE expression filtering in the data grid is a welcome addition and saves you time when you 
want to quickly filter the data you are viewing. 

CASE-INSENSITIVE FILTERS 

String comparisons in the SAS language are case-sensitive by default.  For example, the following query 
returns “Thomas” (since “Thomas” contains lowercase “ma”), but not “Mary” (since “Mary” contains 
uppercase “M”, lowercase “a”): 

   proc sql; 

   select name from sashelp.class 

   where name contains "ma"; 

   quit; 

Similarly, character filters defined in the Filter & Sort and Query Builder tasks in SAS Enterprise Guide 
are case-sensitive.  Case-insensitive filters are commonly desired, but there was not previously an easy 
way to create them.  Prior to version 7.11, creating a case-insensitive filter in these tasks required using 
the Advanced Filter Builder to manually code your own case-insensitive filter expression.  For example, 
you might use the UPPER function on both operands as in the following expression: 

   UPPER(t1.Name) contains UPPER("ma") 

Version 7.11 greatly simplified the creation of case-insensitive filters with the addition of a Match case 
option in the Filter and Sort and Query Builder tasks. 
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Display 2 shows the Match case option in the Query Builder and a preview of the resultant code when 
the option is unchecked.  Notice that the UPPER function is automatically inserted on both sides of the 
operator, so the filter becomes case-insensitive. 

 

Display 2. The Match Case Option in the Query Builder 

Display 3 shows the Match case option in the Filter and Sort task. 

 

Display 3. The Match Case Option in the Filter and Sort Task 

The Match case option is checked by default in both tasks, so that the default behavior is still case-
sensitive. 

Note: In the Query Builder, Match case can be set independently for each filter, so you can mix and 
match case-sensitive and case-insensitive filters in the same query.  In the Filter and Sort task, Match 
case cannot be set independently for each filter.  The option in the Filter and Sort task controls whether 
all the filters are case-sensitive or case-insensitive. 

Creating case-insensitive filters in the Filter and Sort and Query Builder tasks is much easier now with the 
addition of the Match case option. 
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CHECK FOR UPDATES 

Modern software development has trended toward regular, if not continuous, delivery.  Perhaps like me, 
you regularly receive a notification on your smartphone that several applications have automatically been 
updated.  More regular updates necessitate making it easy for users to get those updates. 

Toward this end, SAS Enterprise Guide 7.11 added a Check for Updates feature.  This feature makes it 
incredibly easy for users to get the most current version of the software, including the latest features and 
fixes. 

The Check for Updates feature allows you to update to newer versions in addition to minor updates 
(traditionally known as hot fixes).  For example, the Check for Updates feature allows you to update 7.11 
or 7.12 to 7.13 (currently the latest version of Enterprise Guide).  You can also update 7.13 to 7.13 HF1 
(currently the latest 7.13 hot fix). 

The Check for Updates feature automatically checks for updates at application start-up.  If an update is 
available, you are notified and prompted whether you want to apply the update.  (See Display 4.)  If you 
accept the update, a simple one-click process downloads and installs the update. 

Display 4 shows SAS Enterprise Guide notifying you that an update is available. 

 

Display 4. Notification That an Update Is Available 

Display 5 shows the confirmation dialog box that is shown after an update has been installed. 

 

Display 5. Confirmation After Applying an Update 
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Note: End-users who do not have permissions to install software on their machines will not be able to use 
this feature to update their SAS Enterprise Guide.  If desired, administrators can disable the feature 
completely.  See “Configure SAS Enterprise Guide to Hide the Check for Updates Option” (SAS Institute 
Inc. 2016b).  Users can also choose to disable the automatic checking for updates by unchecking 
Automatically check for updates in Tools->Options->General.  If your admin has not disabled the 
Check for Updates feature, you can check for updates at any time from the Help->Check for Updates 
menu. 

Check for Updates is an incredibly easy way to keep your SAS Enterprise Guide software up-to-date. 

COPY/PASTE SUPPORT FOR PROMPTS 

Prompts are a convenient way to make your SAS Enterprise Guide projects more dynamic and 
interactive.  For example, rather than hardcoding a value, you can define and associate a prompt with a 
program or query.  This results in the user being prompted for the value when the program or query is 
run. 

Prior to SAS Enterprise Guide 7.11, you could not copy and paste a prompt.  Therefore, if you wanted a 
similar prompt, you had to create a new one from scratch.  Starting in 7.11, you can now copy and paste 
prompts in the Prompt Manager.  Prompts can now be copied and pasted into the same project or into 
another project (open in another instance of SAS Enterprise Guide). 

Display 6 shows the Copy and Paste context menu items on a prompt that itself was pasted from a copy. 

 

Display 6. Copying and Pasting Prompts 

Copying and pasting a prompt can save time over creating a new one from scratch. 

NOTIFICATION OF EXTERNAL FILE CHANGES 

Responsible text editor applications monitor currently open files and gracefully handle changes made to 
them outside of their application.  Otherwise, collisions can easily occur between multiple users or 
processes editing the same file at the same time.  Without realizing other changes have been made to a 
file since they started editing, the last author would likely unintentionally overwrite the previous author’s 
changes. 

Starting in 7.11, if a program or other text-based file is open in the SAS Enterprise Guide editor and the 
file changes outside of SAS Enterprise Guide, SAS Enterprise Guide notifies you that the file has been 
modified outside of the editor.  You are also prompted whether to reload the editor with the latest changes 
or keep your current version. 

Display 7 shows the notification dialog box that is displayed when an open file is modified outside of the 
editor. 
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Display 7. Notification of External File Changes 

The SAS Enterprise Guide editor is now more responsible at handling concurrent editors, thus avoiding 
unintentional overwrites and loss of work. 

NEW FEATURES IN SAS ENTERPRISE GUIDE 7.12 

We continued the trend of adding targeted new functionality in our 7.12 release.  The most notable 
changes are the new Microsoft Excel and Microsoft PowerPoint output destinations, the ability to zoom in 
and out, improved handling of externally referenced files, and better saving behavior. 

EXCEL AND POWERPOINT OUTPUT DESTINATIONS 

Reports and analysis are very frequently shared in Microsoft Excel spreadsheets and Microsoft 
PowerPoint presentations.  To assist in getting SAS results into these two common formats, the SAS® 
Output Delivery System (ODS) added production destinations for both Excel and PowerPoint in the third 
maintenance release for SAS 9.4.  In response, SAS Enterprise Guide 7.12 added both Excel and 
PowerPoint as built-in results formats. 

Note: The Excel and PowerPoint results formats can be used only with a SAS server running the third 
maintenance release for SAS 9.4 or later, since that is when the corresponding ODS destinations became 
available. 

As with the other results formats, Excel and PowerPoint can be turned on globally in Tools->Results-
>Results General->Results Formats or on an individual element in the element’s Properties->Results.  
Properties specific to the Excel and PowerPoint results format can be set in Tools->Results->Excel and 
Tools->Results->PowerPoint, respectively. 

Display 8 shows the new Excel and PowerPoint results formats in the global options, in addition to 
example output in the process flow. 
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Display 8. Excel and PowerPoint Results Options and Output 

You can certainly write your own ODS code to use the Excel and PowerPoint destinations, but it is much 
easier to just check a box and have SAS Enterprise Guide generate the code for you.  The new Excel and 
PowerPoint results formats in SAS Enterprise Guide 7.12 make it very easy to get SAS results into Excel 
spreadsheets and PowerPoint presentations. 

ZOOM IN OR OUT 

SAS Enterprise Guide 7.12 now supports zooming in and out of programs, logs, other text in the editor, 
the data grid, the process flow, and HTML results.  You can adjust your view by decreasing the zoom 
level to show more content or increasing the zoom level to make the content more visible.   

The zoom level can be adjusted several ways: 

1. Ctrl + Mouse Wheel. (standard) 

2. Ctrl +/-. 

3. Zoom control on status bar. 

  

4. View->Zoom menu. 

 

SAS Enterprise Guide 7.13 further enhanced zooming by adding the Ctrl+0 keyboard combination to 
reset the zoom level to 100%, similar to various browsers. 

The zooming feature enables you to easily adjust views to a comfortable viewing size. 

IMPROVED HANDLING OF EXTERNALLY REFERENCED FILES 

A SAS Enterprise Guide project is a convenient container for organizing related content.  In fact, any file 
can be added to a project, not just SAS programs. 
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When an external file is added to SAS Enterprise Guide, the project stores a reference (also known as a 

shortcut) to the file.  You can identify an external file reference by the shortcut icon overlay ( ) in the 
bottom left of the node icon. 

SAS Enterprise Guide 7.12 provides significantly better support for externally referenced files in the 
following ways: 

1. The icons for file shortcut nodes are retrieved from Windows and correspond with the Windows 
default application associated with the file type.  Therefore, the icons are consistent with how they 
appear in Windows Explorer or on the Windows Desktop. 

2. If SAS Enterprise Guide does not have a built-in viewer for a file type, it is opened in the Windows 
associated application by default. 

3. If SAS Enterprise Guide does have a built-in viewer for a file type, it is opened in SAS Enterprise 
Guide by default.  However, you can explicitly choose to open the file in the Windows associated 
application instead, by selecting the Open <filename> with Windows Default context menu item. 

4. You can easily navigate to the physical location of the externally referenced file by selecting the new 
Open File Location context menu item.  Windows Explorer will open to the folder that contains the 
external file and the external file will be selected. 

Display 9 shows the new Open <filename> with Windows Default and Open File Location context 
menu items on file shortcut nodes.  Also notice that the icons of shortcut nodes match the icon of their 
respective associated applications. 

 

Display 9. New Icons and Context Menu Items for Externally Referenced Files 

These enhancements make it much more convenient for storing references to and accessing files related 
to your SAS content from within one conveniently organized project. 

SAVE ALL AND SAVE CONTEXTUAL 

SAS Enterprise Guide 7.12 added a Save All feature and changed the behavior of the default Save 
operation to be a more intuitive contextual save. 

Prior to this change, the standard Save operation (Ctrl+S) always saved the SAS Enterprise Guide 
project.  This was particularly confusing when editing an external SAS program.  For example, Ctrl+S is a 
standard keyboard shortcut for saving a document you are editing.  However, if you were editing a .sas 
file and pressed Ctrl+S, SAS Enterprise Guide did not save the .sas file.  Rather, it saved the SAS 
Enterprise Guide project.  Then, realizing the user probably actually expected the .sas file to be saved, 
Enterprise Guide would prompt the user if they also wanted to save the program.  This was not a very 
good experience.  The expected behavior is that pressing Ctrl+S automatically saves the document you 
are editing, without prompting.  This is how SAS Enterprise Guide now behaves. 

The default save (Ctrl+S) is now contextual.  If you are working on an embedded program, the default 
save saves the project, since embedded programs are stored in the project (first scenario in Display 10).  
If you are working on an external file, the default save saves the external file (second scenario in Display 
10).  The default save behavior for all other items that are not independently savable is to save the project 
(third scenario in Display 10). 
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Display 10 shows an example of how the new contextual save changes depending on what item is active.  
It also shows the new Save All menu item. 

 

Display 10. File Menu When Different Items Are Active 

Since the default Save is now contextual rather than saving the Project, users still needed a way to save 
the project at any time.  Therefore, SAS Enterprise Guide 7.12 also added a new Save All menu item and 
toolbar button.  The Save All command saves the project and all open items with unsaved changes. 

Saving now works the way it should – as you expect. 

NEW FEATURES IN SAS ENTERPRISE GUIDE 7.13 

Currently the most recent release in the 7.1 family, SAS Enterprise Guide 7.13 is making its mark with the 
well-received DATA step debugger.  Several other notable enhancements are the ability to control 
execution on error, the Upload to CAS task, the ability to scroll horizontally with Shift + Mouse Wheel, 
changing the default graph format to PNG, and the ability to rename the label of any data node. 

DATA STEP DEBUGGER 

The DATA step procedure is a programming language unto itself.  It supports conditional logic, looping, 
arrays, and other characteristics of common programming languages. 

As with any programming language, logic errors slip into DATA step code written by even the most 
talented programmers.  Whether by mistake or misunderstanding, “bugs” happen. 

Having a structured way to debug code is imperative.  You can always write lots of PUT statements and 
inspect the log, but there is a better way. 

Base SAS® has long provided a command-driven DATA step debugger.  The DATA step debugger in 
Base SAS is activated by adding the “debug” option to your DATA statement.  For example: 

   data _null_ / debug; 

When you submit a DATA step with the debug option, the SAS Display Manager goes into the DATA step 
debugger mode.  (See Display 11.)  A Debugger Source window shows the source of the DATA step 
being debugged, any breakpoints that are set, and it highlights the current executing line.  A Debugger 
Log window provides a command line, logs the commands issued, and logs the resultant output. 

Display 11 shows the DATA step debugger windows in SAS Display Manager. 
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Display 11. The DATA Step Debugger in Base SAS 

Once in the DATA step debugger mode, you can enter a number of DATA step debugger commands to 
step through execution of the DATA step, set breakpoints, view variable values, and so on.  It is very 
useful for finding logic errors in your DATA step code.  

SAS Enterprise Guide users, particularly those familiar with the DATA step debugger in Base SAS, have 
long wanted similar debugging capabilities in SAS Enterprise Guide.  I’m happy to say that we now have 
this ability starting in SAS Enterprise Guide 7.13.  In fact, it is an easier-to-use interface! 

To debug a DATA step in SAS Enterprise Guide, first enable DATA step debugging by toggling the green 
“bug” icon on the contextual toolbar of a program.  Green gutters will appear to the left of code that is 
capable of being debugged.  As the name implies, only DATA step code can be debugged, so the green 
gutters will only appear next to DATA steps. 

Display 12 shows the green “bug” icon on the toolbar that toggles the green gutters.  The green gutters 
identify the regions of SAS code (DATA steps) that are capable of being debugged. 

 

Display 12. Launching the DATA Step Debugger in SAS Enterprise Guide 
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To begin debugging a DATA step, click anywhere in the green gutter.  Or, with focus in the DATA step 
code, press F5.  The DATA Step Debugger window will appear.  (See Display 13.) 

Note: Debugging will start with the server in its current state.  Make sure to run any dependent code prior 
to debugging your DATA step, if necessary. 

 

Display 13.  The DATA Step Debugger Interface in SAS Enterprise Guide 

The DATA Step Debugger window shows the DATA step code being debugged.  The currently executing 
line of code is highlighted yellow.  Any lines with breakpoints set are indicated with a red circle next to the 
line number.  All the currently defined variables and their values are displayed.  Values that changed 
since execution last stopped are colored red, making it easy for you to visually identify changes.  And 
finally, there is a debug console that provides a command-line entry and log, similar to the Debugger Log 
window in the DATA step debugger in Base SAS. 

From the DATA Step Debugger window, you can perform standard debugging operations by clicking 
buttons or pressing keyboard shortcuts.  For example, you can step line-by-line through your code (F10), 
set breakpoints (F9), clear all breakpoints (Shift+F9), inspect variable values, and continue execution 
(F5). 

Slightly more advanced features include the ability to “watch” variables or edit variable values while 
debugging.  “Watching” a variable will cause execution to halt anytime the value of that variable changes.  
To “watch” a variable, simply check the Watch check box next to the variable.  To edit a variable value 
while debugging, click the value, and then type the desired value in the edit field that appears. 

If you want full control, the DATA step debugger in SAS Enterprise Guide supports almost all the same 
commands supported by the DATA step debugger in Base SAS.  See the chapter, “Dictionary of DATA 
Step Debugger Commands” in Base SAS® 9.4 Utilities: Reference (SAS Institute Inc. 2013a), for a list of 

commands.  Or you can press the  icon to the right of the command line (see Display 13) for a listing of 
the supported commands and their respective syntax.  You can enter these commands on the command 
line in the Debug Console section of the DATA step debugger in SAS Enterprise Guide.  For example, 
you could set conditional breakpoints to break on a line only when a certain condition is met.  The 
following command will set a breakpoint on line 15 that only halts execution when the MSRP variable 
value is less than 30000: 

   break 15 when MSRP < 30000 
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The DATA step debugger in SAS Enterprise Guide is an intuitive and user-friendly interface for stepping 
through and understanding your DATA step code.  It can also help you more efficiently track down logic 
errors in your DATA step code. 

For a more comprehensive look at this feature, read the paper “Step through Your DATA Step: 
Introducing the DATA Step Debugger in SAS® Enterprise Guide®” (Flynn 2017). 

CONTROL EXECUTION ON ERROR 

The process flow in SAS Enterprise Guide allows you to compartmentalize your work, control the order of 
execution, and more easily visualize your process.  An error during the running of that process or project 
often represents a critical failure with downstream consequences.  It is typically something a user wants 
to immediately investigate, rather than allowing processing to continue.  However, prior to 7.13, SAS 
Enterprise Guide would continue running a process flow or project even if an error occurred in one of the 
nodes.  There was previously no way to control this behavior. 

SAS Enterprise Guide 7.13 added an Action to take on errors during execution option to allow you to 
control the behavior to take when an error occurs while running a process flow or project.  The option can 
be set for the entire project on the Code Submission tab of the project properties (File->Project 
Properties).  Or the option can be set on an individual item via the Code Submission tab of the item’s 
properties. 

There are three settings for the option: 

 Stop all items. If an error occurs, do not run any additional items. 

 Stop current branch. If an error occurs, do not run any items downstream of the item that generated 
the error.  (This is the default.) 

 Continue execution.  Even if an error occurs, continue running all items.  (This was the default for 
releases earlier than SAS Enterprise Guide 7.13.) 

Display 14 shows the project option and the three settings for controlling the behavior that SAS Enterprise 
Guide takes when an error occurs during execution of a process flow or project. 

 

Display 14. Action to Take on Errors during Execution Option 
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Being able to avoid unnecessary processing or to continue unfazed, depending on how you wish to 
handle errors that occur while running your process flow or project, can save you valuable time. 

UPLOAD TO CAS 

In support of the latest in-memory server technology in SAS, SAS Enterprise Guide 7.13 added the 
Upload to CAS task, which allows users to easily load data into the CAS server for use in SAS Viya and 
SAS Visual Analytics. 

The Upload to CAS task is very similar to the Upload to LASR task added in SAS Enterprise Guide 7.1.  
Both provide easy-to-use, repeatable, point-and-click tasks for getting data into the respective in-memory 
servers in SAS. 

Display 15 shows the interface for the Upload to CAS task.  Notice it is a very simple interface.  You 
simply specify the destination server, library, and table, optional credentials, then run. 

 

Display 15. The Upload to CAS Task Interface 

Display 16 shows the Upload to CAS task being used at the end of a process flow following data 
preparation steps. 
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Display 16. Data Preparation Followed By Uploading Data to CAS 

Note: Using the Upload to CAS task requires prior configuration by your SAS administrator.  For example, 
it requires SAS/CONNECT® to be installed on both your SAS®9 server and your CAS server.  It also 
requires a SAS/CONNECT spawner to be running on your CAS server, and it requires that your libraries 
be defined. 

The Upload to CAS task makes it incredibly easy to load the output of your data preparation into the CAS 
server for use in SAS Viya and SAS Visual Analytics. 

SHIFT + MOUSE WHEEL TO SCROLL HORIZONTALLY 

Using a mouse wheel to scroll vertically is a de facto standard that most folks are familiar with, if not 
heavily dependent on.  For example, it is very convenient being able to scroll a web page or document 
vertically with your mouse wheel, rather than having to precisely move your mouse to the vertical scroll 
bar thumb and explicitly dragging it. 

The value the mouse wheel provides for “tall” content can also be provided for “wide” content.  For 
example, some browsers support Shift + Mouse Wheel for scrolling a web page horizontally.  Same as for 
vertical scrolling with the mouse wheel, this horizontal scrolling shortcut allows you to easily scroll without 
having to move your mouse to the horizontal scroll bar thumb and explicitly dragging it. 

SAS Enterprise Guide 7.13 added the ability to scroll views horizontally using Shift + Mouse Wheel.  The 
feature works with programs, logs, other text files in the editor, data in the data grid, and the process flow.  
It’s a great way for quickly navigating and visualizing content that is larger than your screen real-estate, 
for example, wide data.  Combine that with Ctrl + Mouse Wheel for zooming, and you can zoom in/out, 
scroll vertically, and scroll horizontally without ever having to move your mouse. 

CHANGE DEFAULT GRAPH FORMAT FROM ACTIVEX TO PNG 

The default graph format changed in SAS Enterprise Guide 7.13 from ActiveX to PNG.  (See Display 17.) 

The main driver of this change was security related.  ActiveX controls are a security risk.  As a result, 
browsers have trended away from allowing ActiveX controls.  Static PNGs do not pose security concern 
and are pretty much universally supported. 

Another reason for the change was to be more consistent with SAS® Studio.  By using the same graph 
format by default, SAS Enterprise Guide and SAS Studio will generate more visually consistent results 
when the same user code is submitted. 
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Both graph formats are still available, but new installations will default to PNG rather than ActiveX.  If you 
upgrade an existing installation, your previous graph format will be preserved.  If you reset your options, 
the graph format will be reset to PNG, the new default.  You can still change your graph format at any 
time. 

There are differences, both visually and functionally, in the output generated by these two graph formats.  
There are advantages and disadvantages to both.  For example, ActiveX uses an ActiveX control for 
client-side rendering, whereas PNG is a static image generated on the server.  As a client-side renderer, 
ActiveX can provide more interactive features than PNG, such as changing chart types and other graph 
properties on the fly.  However, as a static image generated on the server, PNG can support many more 
data points, for example, as in a scatter plot, and is more portable and widely supported.  There are more 
differences in these two graph formats, which you can explore in the respective documentation or just try 
out for yourself. 

A side-effect of changing the default graph format to PNG is that a number of features in the built-in 
Graph tasks in SAS Enterprise Guide did not work.  The built-in Graph tasks leverage a number of 
features that are specific to ActiveX, which do not have an equivalent in the PNG format.  We decided the 
best course of action was to compromise by adding a new graph format option specifically for the built-in 
graph tasks (see Display 17), such that we could leave their default as ActiveX.  This would ensure that 
users have the best out-of-box experience when using the Graph tasks, yet other tasks and programs 
could still use the new default PNG graph format. 

Display 17 shows the Graph Format now defaulting to PNG as well as the new Graph Format for Built-in 
Graph Tasks option still defaulting to ActiveX. 

 

Display 17. New Graph Format Default and Graph Tasks Option 

ALLOW RENAMING OF ANY DATA NODE LABEL 

A really nice aspect of SAS Enterprise Guide is the fact that it allows you to give user-friendly names to 
most nodes in your project.  Prior to 7.13, SAS Enterprise Guide would only let you rename data nodes 
that were stand-alone or used as input.  You were not able to rename output data nodes. 
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It could be particularly frustrating for output data from tasks that were clearly using a label, but did not 
allow the user to change the label.  For example, the output data from the Import Data task was typically 
labeled, “Data Imported from <fileImported>” and the output data from the Summary Statistics task was 
typically labeled, “Summary Statistics for <inputTable>”. 

This was an unnecessary limitation.  SAS Enterprise Guide 7.13 now supports renaming the label for any 
data node. 

Display 18 shows the label of an output data node being edited, which was not previously supported. 

 

Display 18. Renaming an Output Data Node Label 

Being able to provide useful labels to any data node makes it easier to read and understand a process 
flow. 

CONCLUSION 

SAS Enterprise Guide 7.11, 7.12, and 7.13 each add valuable new features and enhancements in various 
areas of the product.  I hope you are now more aware of these convenience features at your disposal and 
that you’ll find creative ways to use them to be more productive, so you can focus your brain power on the 
really important problems. 
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