Leverage Your Reports in SAS® Visual Analytics: Using SAS® Theme Designer
Meenu Jaiswal, SAS Institute Inc.

ABSTRACT
Is uniqueness essential for your reports? SAS® Visual Analytics provides the ability to customize your reports to make them unique using SAS® Theme Designer (Classic). SAS Theme Designer (Classic) can be accessed from the SAS Visual Analytics Hub to create custom themes. SAS Theme Designer (Classic) enables you to customize your reports to meet your branding needs and to ensure a unified look across your company. The report themes affect the colors, fonts, and other elements that are used in tables and graphs. The paper explores how to access SAS Theme Designer (Classic) from the SAS Visual Analytics home page, how to create and modify report themes that are used in SAS® Visual Analytics, how to create report themes from imported custom themes, and how to import and export custom report themes.

INTRODUCTION
The purpose of this paper is to provide an overview to everyone who would like to have a unique look and feel for their reports in SAS® Visual Analytics using SAS® Theme Designer (Classic). SAS Theme Designer (Classic) is a Flex web application, which enables you to easily customize your reports in SAS Visual Analytics. You can use SAS Theme Designer (Classic) to create and deploy simple, visually appealing, and customized themes. A theme defines the overall look and feel of an application. A well-designed theme can create a strong visual identity across a product or set of products. You might not want to view your SAS reports in the default report theme. You might instead want to apply your own branding and customization to help the reports fit in with the rest of your software environment. SAS provides a default report theme. However, users can customize their themes by using SAS Theme Designer (Classic).

WHAT IS SAS VISUAL ANALYTICS
SAS Visual Analytics is an easy-to-use, web-based product that leverages SAS high-performance analytic technologies. SAS Visual Analytics empowers organizations to explore huge volumes of data very quickly to identify patterns, trends, and opportunities for further analysis. SAS® Visual Data Builder (the data builder) enables users to summarize data, join data, and enhance the predictive power of their data. Users can prepare data for exploration and mining quickly and easily. The highly visual, drag-and-drop data interface of SAS® Visual Analytics Explorer (the explorer), combined with the speed of SAS® LASR™ Analytic Server, accelerates analytic computations and enables organizations to derive value from massive amounts of data. This creates an unprecedented ability to solve difficult problems, improve business performance, predict future performance, and mitigate risk rapidly and confidently. SAS® Visual Analytics Designer (the designer) enables users to quickly create reports or dashboards, which can be viewed on a mobile device or on the web.

SAS Visual Analytics empowers business users, business analysts, and IT administrators to accomplish tasks from an integrated suite of applications that are accessed from a home page. The central entry point for SAS Visual Analytics enables users to perform a wide variety of tasks such as preparing data sources, exploring data, designing reports, as well as analyzing and interpreting data. Most important, reports can be displayed on a mobile device or in SAS Visual Analytics Viewer (the viewer).

CREATING REPORTS IN SAS VISUAL ANALYTICS DESIGNER
You can create a well-designed report in SAS Visual Analytics Designer (the designer).

The report created with the default report theme SAS Snow in The designer is displayed in Figure 1.
VIEWING REPORTS IN SAS VISUAL ANALYTICS VIEWER

For users with a report viewing role, the viewer enables them to view report content.

To open a report in the viewer:

On SAS Home, click the object inspector icon next to a report, and then click View.

Figure 2 shows an example of a report in SAS Visual Analytics Viewer:

Here you can see that every report that you or other users are creating will have a similar look and feel. Even if you have created one report to show the product sale and another report to show the actual sale versus the predicted sale, both of the reports will have the same look. You would like to have uniqueness in your reports using custom themes.

VIEWING REPORTS IN SAS VISUAL ANALYTICS VIEWER USING CUSTOM THEMES

Figure 3 displays the report using the default report theme SAS Snow.
Figure 3. Default Report Theme: SAS Snow

Figure 4 displays Apple branding for their application and reports. Similarly, Figure 5 and Figure 6 display the reports using the custom themes for Nokia and IBM branding.

Figure 4. Custom Theme: Apple (Red) Theme
Figure 5. Custom Theme: Nokia (Dark) Theme
Figure 6. Custom Theme: IBM Blue Theme

Figure 7 and Figure 8 display the reports using themes preferred by different universities.

Figure 7. Custom Theme: Duke University Theme
Figure 8. Custom Theme: US University Theme

Similarly, you can create various custom themes using the base themes and apply the custom themes to different reports. Figures 9–12 display reports using the themes preferred by different car brands.
To create all these different themes you can use SAS Theme Designer (Classic). In this way you can customize your reports with your preferred report themes.

ABOUT APPLICATION AND REPORT THEMES IN SAS VISUAL ANALYTICS

An application theme is the collection of colors, graphics, and fonts that appear in the application. SAS Visual Analytics provides the following application themes: SAS Corporate (default theme), SAS Blue Steel, SAS Dark, SAS High Contrast, and SAS Light.

Report themes are available in the designer. The designer provides the following report themes: SAS Snow, SAS Light, SAS Dark, or SAS High Contrast. SAS Snow is the default report theme.

WHAT IS SAS THEME DESIGNER (CLASSIC)?

SAS Theme Designer (Classic) enables you to customize the SAS product line to meet your branding needs and to ensure a unified look across all eligible applications. Having a consistent look and feel ensures that the user's transition from one application to the next is as seamless as possible.

SAS Theme Designer (Classic) includes the following key features:

- A complete graphical user interface (GUI). All tasks can be done with simple point-and-click actions.
- The implementation and deployment of custom themes are entirely within the designer's control. You do not need to redeploy applications or restart web application servers. With a single click, you can make a new or updated custom theme available to all users in all eligible applications.
- A site can implement multiple custom themes. All deployed themes are available to all end users in all
eligible applications.

- You can change the default theme. This is a single setting that applies to all eligible applications and affects all users (except those users who have specified a personal default theme).
- Custom themes that you create in SAS Theme Designer (Classic) are retained and available after deployment-related activities such as software upgrades.
- Custom themes that were designed with previous versions of the application are easily migrated and updated.
- Custom themes can be easily exported or imported between environments.

**WHO CAN ACCESS SAS THEME DESIGNER (CLASSIC)**

To access this application, you must be assigned the Customize Themes capability, which is part of the Theme Designer (Classic): Administration role.

**HOW TO ACCESS SAS THEME DESIGNER (CLASSIC)**

SAS Theme Designer (Classic) is a web application that you can access from within a web browser. The address for SAS Theme Designer (Classic) is `http://machine.port/SASThemeDesignerForFlex`.

Figure 13 shows the sign-in screen for SAS Theme Designer (Classic).

![Sign In to SAS](image)

**Figure 13. Sign-In Screen for SAS Theme Designer (Classic)**

**ACCESSING SAS THEME DESIGNER (CLASSIC) FROM THE SAS VISUAL ANALYTICS HOME PAGE**

You can access SAS Theme Designer (Classic) while working on the SAS Visual Analytics home page. This provides the opportunity to create and modify themes that are used in SAS Visual Analytics. When you create a theme in SAS Theme Designer (Classic), an application theme is created. In SAS Visual Analytics 6.2, a report theme is automatically generated for use in SAS Visual Analytics. Here are the steps to access SAS Theme Designer (Classic) from the SAS Visual Analytics home page:

- On the Home banner, select the Side menu. Select the option SAS Theme Designer (Classic) as shown in Figure 14. This opens SAS Theme Designer (Classic). You can now create and modify custom themes for use in SAS Visual Analytics. Once you deploy the theme, it is available for use in SAS Visual Analytics.
- Once you have finished your modifications to a theme, you can return to the SAS Visual Analytics home page by selecting the Home button. This button is now available on the top left banner.
Figure 14. Access SAS Theme Designer (Classic) from the SAS Visual Analytics Home Page

You can also access SAS Theme Designer (Classic) from SAS Report Designer as shown in Figure 15. The Customize Theme button is displayed on the Styles tab for users who have the Customize Themes capability.

Figure 15. Access SAS Theme Designer (Classic) from the Styles Tab

CREATE AND DEPLOY A CUSTOM THEME

Once you access SAS Theme Designer (Classic) using the methods mentioned above, you can use predefined base themes to create custom themes in SAS Theme Designer (Classic). The following steps show you how to create and deploy a custom theme.

1. Launch SAS Theme Designer (Classic).

2. When prompted by the application to choose a task, click Create a Theme on the initial screen, as shown in Figure 16.

Figure 16. Click Create a Theme

3. In the New Theme dialog box as shown in Figure 17, select one of the predefined base themes.
In Figure 18, the SAS Light base theme is selected. Click OK. The new theme is generated and ready to customize. The initial look and feel of the theme is determined by the predefined base theme that you selected. In the right pane, different components of the theme are displayed. The right pane provides an automatic and instant preview as you work. The left pane contains the user interface components that you can modify for your custom theme.

Figure 19 displays a custom theme that is created from the SAS Light base theme.

4. Select the components that you want to change from the User Interface Components pane. The impact of each change is instantly shown in the right pane.

All of the design elements are listed in the User Interface Components pane. The sample application on the right contains examples of all of the available components. Changes that you make to certain user interface components affect other components. For example, if you change the color for Button, the colors for Tabs and Accordion change.
One place to begin changing your custom theme is the **Global Settings** menu on the User Interface Components pane. You can change text color, hover and selection colors, and the font type that is applied to the custom theme.

Figure 20 displays the Global Settings changes. The text color is changed to red, the selection color is changed to blue, and the hover color is changed to yellow. The font type has been changed to Segoe UI.

To save your work at any time, select **File → Save** and deploy from the main menu.

When you are ready to deploy the new theme, select **File → Save and deploy** from the main menu, as shown in Figure 21.

The Save As window appears. The default theme name is **New Custom Theme**, as shown in Figure 22.
As shown in Figure 23, in the Save As window, enter a name for the custom theme. Click OK. The theme is saved and deployed.

![Save As Window](image)

**Figure 23. Save as MyCustomTheme**

A confirmation message is then displayed, as shown in Figure 24.

![Save and Deploy Window](image)

**Figure 24. Custom Theme MyCustomTheme Successfully Saved and Deployed**

**DEPLOY A CUSTOM THEME**

As an alternative to the one-step save-and-deploy feature, you can deploy a custom theme that has already been saved. The result is identical to the one-step approach.

1. From the main menu of SAS Theme Designer (Classic), select **Tools → Deploy**, as shown in Figure 25.

![Select Deploy Tools Menu](image)

**Figure 25. Select Deploy Tools Menu**

2. In the Deploy window shown in Figure 26, select the theme. Note that the predefined themes are not listed because they are always deployed.

![Deploy Custom Theme](image)

**Figure 26. Deploy Custom Theme**

3. When you are ready to deploy the new theme, select **File → Deploy** from the main menu. Click OK. A confirmation window is displayed, as shown in Figure 27.
The theme is now available for use.

**MODIFY A CUSTOM THEME**

When you open SAS Theme Designer (Classic), you can choose to create a new custom theme or to modify an existing custom theme. To modify an existing custom theme, click **Modify a Theme** on the initial screen, as shown in Figure 28.

![Figure 28. Click Modify a Theme](image)

The Open Theme window appears, as shown in Figure 29. Select the custom theme that you want to modify and select **OK**.

![Figure 29. Select the Custom Theme to Modify](image)

The custom theme is loaded and then you can make changes to the theme.

**EXPORT A CUSTOM THEME**

SAS Theme Designer (Classic) enables you to export a theme. You can export a custom theme from SAS Theme Designer (Classic) to a specific folder.

To export a custom theme, follow these steps:

1. From the main menu of SAS Theme Designer (Classic), select **Tools → Export Theme**, as shown in Figure 30.
Figure 30. Click Export Theme

2. Select the theme that you want to export. Click OK. A second window is displayed, as shown in Figure 31. Select Yes.

Figure 31. Confirm to Export Theme

3. Navigate to the folder where you want the theme to be exported.

The theme is exported and saved with a .tdf file extension.

IMPORT A CUSTOM THEME

SAS Theme Designer (Classic) enables you to import a custom theme. You can import a custom theme from a specific folder to SAS Theme Designer (Classic).

To import a custom theme, follow these steps:

1. From the main menu of SAS Theme Designer (Classic), select Tools ➔ Import Theme, as shown in Figure 32.

Figure 32. Click Import Theme

2. In the dialog box that is displayed, select the TDF theme file that you want to import from your local hard drive. Click Open.

The theme is imported and is available within SAS Theme Designer (Classic).

Note: If a theme with the same name already exists within SAS Theme Designer (Classic), it cannot be imported. Any valid theme that is in the correct format can be imported, including themes that were exported without a .tdf extension.

CREATING REPORT THEMES FROM IMPORTED CUSTOM THEMES

When a custom application theme is created in SAS Theme Designer (Classic), a coordinating custom report theme is automatically created. This also applies to custom application themes that are imported from previous releases of SAS Theme Designer (Classic).

In order to create the report theme, custom application themes from previous releases must be exported and then imported. Custom application themes created with a release prior to release 4.1 can be exported for use in one of two scenarios:

1. A custom application theme that is created in SAS Theme Designer (Classic) 3.5 is exported from
one server and is then imported to SAS Theme Designer (Classic) 4.7 on a different server.

2. If a server is being updated (in place) from release 3.5 to 4.7 on the same machine, custom application themes are exported as 3.5 themes and then imported and deployed as 4.7 themes.

With either scenario, the custom application theme is exported, imported, and deployed. To promote custom application themes that were created in previous releases, follow these steps:

1. In the previous release of SAS Theme Designer (Classic), export all custom themes using the Export Theme function. SAS Theme Designer (Classic) creates a single .tdf file that contains all exported themes. You can choose a specific folder to save the file.

2. If you are exporting and importing themes on a server that was updated (in place) from release 3.5 to 4.1 (or later release) on the same machine, then you must export and then delete all custom themes that are available in SAS Theme Designer (Classic). This is because the Import Theme function does not overwrite an existing theme.

3. Using SAS Theme Designer (Classic) on the destination server, import the .tdf file that was generated with the Import Theme function.

4. You can now deploy the themes that you want to be available for use in other applications. Use the Deploy function in SAS Theme Designer (Classic).

5. In Figure 33, CustomThemeLightDec46 and CustomThemeDarkDec46 are exported from the previous release, and imported and deployed in the later release of SAS Theme Designer (Classic).

![Figure 33. Deploy Custom Theme Imported from Previous Release](image)

For each of the custom application themes that were imported and deployed, a corresponding report theme is now available for use in SAS Visual Analytics Designer. Custom application themes must be deployed for use as report themes in SAS Visual Analytics Designer.

In Figure 34–36, you can see that for the CustomThemeLightDec46 and CustomThemeDarkDec46 themes that were imported from the previous release and deployed, a corresponding report theme is now available for use in SAS Visual Analytics Designer.
Figure 34. Themes Deployed from Previous Release are Available for Use

Figure 35. Custom Light Theme from Previous Release Applied on Report
Figure 36. Custom Dark Theme from Previous Release applied on Report

Note: This process applies only to custom application themes that are created in previous releases. You cannot promote base themes from previous releases.

CONCLUSION

Using SAS Theme Designer (Classic) you can create and deploy simple, visually appealing, and customized report themes to give a unique look to your report.

MORE ABOUT THEMES, LIMITATIONS, AND DOCUMENTATION

ABOUT THE PREDEFINED BASE THEMES

When you choose a base theme, select the theme that is most similar to your desired color palette. You can then modify the theme as needed and save it as a new, custom theme. There are five predefined base themes that override the Flex standard styles:
SAS Blue Steel
The SAS Blue Steel theme enables you to modify the application banner and splash screen components. You can replace the banner logo with a customized logo. In release 3.5 and later, you can customize the two splash screens.

SAS Corporate
The SAS Corporate theme is the default theme for SAS Theme Designer (Classic). Colors for this theme are based on a navy blue palette. The SAS Corporate theme enables you to modify the application banner and splash screen components. You can replace the banner logo with a customized logo. In release 3.5 and later, you can customize the two splash screens.

SAS Dark
The SAS Dark theme is implemented in a minimal way, without custom graphical skins. The SAS Dark theme is based on darker, charcoal gray tones, and should be used if a company’s theme contains a dark palette. The SAS Dark theme can be customized extensively. The full range of components on the User Interface Components pane is available for customization.

SAS High Contrast
The SAS High Contrast theme improves the accessibility of the text and interface for visually impaired users. The SAS High Contrast theme uses a black background, with white outlines, text, and icons. A currently selected (active) item is aqua color and previously selected items are purple. The full range of components on the User Interface Components pane is available for customization.

SAS Light
The SAS Light theme is implemented in a minimal way, without custom graphical skins. The SAS Light theme uses shades of light gray, beige, and white for its color palette. It should be used if a company’s theme contains an overall light palette. The SAS Light theme can be customized extensively. The full range of components on the User Interface Components pane is available for customization.

LIMITATIONS OF SAS THEME DESIGNER (CLASSIC)
When you use the SAS Theme Designer (Classic), it is important to understand the following points:

- Not all aspects of an application’s appearance are customizable. SAS Theme Designer (Classic) enables you to modify a rich, carefully selected subset of design elements. The intent is to offer maximum visual impact with minimal effort and minimal risk of unintended results.
- This application is not optimized for large numbers of themes or deeply nested hierarchies. It is intended for occasional, highly targeted use.
- This application does not offer manual editing of a theme or direct interaction with configuration files. For SAS application themes, SAS does not support direct interaction with source files. All work should be performed from within SAS Theme Designer (Classic).
- This application does not offer a step-by-step "undo" function.
- This application does not offer history or versioning of files.
- You cannot alter, delete, or undeploy any of the predefined themes provided by SAS.
- You cannot hide a deployed theme from anyone. All deployed themes are available to all end users in all the eligible applications.
- You cannot preload a custom color palette into SAS Theme Designer (Classic).

WHERE TO FIND MORE INFORMATION
The most recent version of this document is available from the SAS Theme Designer (Classic) product documentation page on the SAS support site http://support.sas.com/documentation/onlinedoc/flexdesign.
ACKNOWLEDGMENTS

Sincere thanks are given to Pat Berryman, Sherry Parisi, LanChien Hsueh, Sreelekha Ashok, Anita P, Aniket Vanarase, Abhijeet Umredkar, Anuja Yadwad, Girish Kolapkar, Prajakta Salvi, and Manoj Jape for reviewing this paper.

CONTACT INFORMATION

Your comments and questions are valued and encouraged. Contact the author at:

    Meenu Jaiswal
    SAS Research and Development (India) Pvt. Ltd.
    Level 3, Tower 5, Cybercity, Magarpatta City, Pune, India-411013
    Meenu.jaiswal@sas.com

SAS and all other SAS Institute Inc. product or service names are registered trademarks or trademarks of SAS Institute Inc. in the USA and other countries. ® indicates USA registration.

Other brand and product names are trademarks of their respective companies.