ABSTRACT
Have you been programming in SAS for a while and just aren’t sure how SAS Enterprise Guide can help you?

This presentation demonstrates how SAS programmers can use SAS Enterprise Guide 5.1 as their primary interface to SAS, while maintaining the flexibility of writing their own customized code.

We explore:
• navigating and customizing the SAS Enterprise Guide environment
• using SAS Enterprise Guide to access existing programs and enhance processing
• exploiting the enhanced development environment including syntax completion and built-in function help
• using SAS® Code Analyzer, Report Builder, and Document Builder
• adding Project Parameters to generalize the usability of programs and processes
• leveraging built-in capabilities available in SAS Enterprise Guide to further enhance the information you deliver.

Our audience is SAS users who understand the basics of SAS programming and want to learn how to use SAS Enterprise Guide. This paper is also appropriate for users of earlier versions of SAS Enterprise Guide who want to try the enhanced features available in SAS Enterprise Guide 5.1.

INTRODUCTION
This presentation is designed as a Hands-On Workshop, where the participants follow along and step through the usage and features of SAS Enterprise Guide. This paper follows a similar format.

I KNOW HOW TO PROGRAM IN SAS – HOW DO I NAVIGATE SAS ENTERPRISE GUIDE?
With all the windows and views and menus available in Enterprise Guide, it is hard to know where to start! For many “long – time” SAS programmers, the initial view can send them running right back to their programming environment. But, trust us, the benefits of Enterprise Guide are worth the time it takes to get used to all the features.
GETTING STARTED

The first time you open Enterprise Guide, you will see the Welcome to SAS Enterprise Guide Screen.

![Welcome to SAS Enterprise Guide Screen]

This screen gives you the option of launching the Enterprise Guide tutorial or working with new or existing programs, data, or projects. If you do not want this to be your default screen when you open Enterprise Guide, you can check the box labeled Don’t show this window again. Close the window, to be taken to the default view of Enterprise Guide.

The main menu (menu bar at top of screen) allows you to access the various tasks and views that are available to you. Although you may also access the tasks and views through tabs and shortcut buttons, the main menu organizes them into logical categories, making them easy to find.

![Main Menu of SAS Enterprise Guide]

As SAS Programmers, you know that the tasks you are expected to perform are seldom simple. More often than not, there are a series of SAS programs that you run in a sequence, with different types of output directed to different locations, along with all the intermediate and final SAS datasets that are generated.
Enterprise Guide provides a mechanism to organize your work by allowing you to group sequences of tasks, data items and results into **Projects**. All of the code and tasks that you run within an Enterprise Guide session are part of your active Project and are each displayed as separate nodes within the **Process Flow** view and **Project Tree** view.

These nodes can be linked and organized in a logical sequence to form a **Process Flow**. You can save your Process Flow as a part of a Project; and anytime the project is opened the same sequence of tasks can be easily executed. This helps you and your organization distribute and share information easily. The **Process Flow** view is used to display all of the **task**, **data** and **code nodes** that make up your Process Flow.

There are a number of ways that you can access your Process Flow view. From the main menu, select **View ➔ Process Flow**. You can also select **F4** or click the Process Flow tool in the menu bar. Once you begin building a flow, you will notice that the **Process Flow** view also displays the connections between your work components. Again, this allows you to see and visually inspect the organization of tasks, code and data associated with a Project.

You may prefer the **Project Tree** view (in the upper left of the above screen), which provides a more traditional “Windows Explorer” hierarchical view of your projects. Select **View ➔ Project Tree** from the main menu to open the **Project Tree** view. Note that the Project Tree view does not display the flow (connection) within your projects.

The **Server List** appears in the lower left of the above screen. Use it first to begin exploring your data.

**UNDERSTANDING YOUR DATA – ENTERPRISE GUIDE MAKES IT EASY!**

Before you start any new programming task, you first need to understand your data. In Enterprise Guide 5.1, the new **Data Explorer** tool enables you to look at the values and composition of your data so you can be sure that the data actually contains what you are expecting before you start your work.

The Data Explorer enables you to create different views of the data by sorting or filtering data values and selecting desired columns. Once you have a view that is useful, you can add the data to your Enterprise Guide project to use in your reporting or analysis. The Data Explorer will also compute basic statistics so you can identify potential trouble spots like missing data or outliers, that may cause unexpected results in your final reporting and analytics.

Throughout this paper, you will use the SHOES dataset in the SASHELP library so let’s use the Data Explorer to take a closer look at this data.

To open the Data Explorer, you need to navigate to the dataset/table that you want to explore. You can use either the **Server View** or the **Main Menu** to access the Data Explorer. In the **Server View**, expand the SERVERS by selecting the plus sign. All available servers will be listed. Since we are running on a local instance of SAS, you will see the Local server showing. Expand the Local server to see the Files and Libraries that you have available to you. Expand the SASHELP library and navigate to the SHOES dataset.

Right Click on the Shoes dataset and select **Explore**. This launches the Data Explorer.
In addition to the above sequence, you can also launch the Data Explorer from the main menu by selecting File ➔ Open ➔ Data Exploration. This will also enable you to navigate to the data that you want to explore.

Using the Data Explorer, you can understand your data better before you use it in your code or project. To the right of the data, you can move between the Data View List, Quick Stats and Tool views.

The Data View allows you to select the columns of interest, filter the data and sort the data. By default, all columns are shown, no filters are applied and the data are not sorted. The Explorer provides some basic properties such as the number of observations and variables in the data.

As you add filter conditions, or specify which columns to select, the changes are displayed under Pending Updates and are not applied to the data until you select Apply Updates.

In this example, select a subset of the columns and request Sales for Asia only. The updates appear to the right under Pending Updates. The updates are not applied until you select Apply Updates.

To remove Pending Updates, select the x beside the update.
Quick Stats provides basic statistics on the variables in our data. When you select Quick Stats, you are shown all of the columns grouped by type (character, numeric, date, etc.).

You can produce statistics on individual columns by clicking the Run Stats button next to the column name, ( ), or you can produce statistics on all columns in the data by selecting Click to Run all Statistics.

The green spinning top will show you which column’s statistics are being computed. Depending on the size of your dataset, this can obviously take a considerable amount of time so you are also given the option to Cancel the running Statistics (Click to Cancel Running Jobs).

Once the data summarization is complete, you can view a variety of statistics based on the variable type. For character variables you get the distinct values and counts along with a frequency bar chart and basic statistics for the top occurring values. To see the details of the charts provided, click on them and they are enlarged.
For numeric variables you are given the average, count, sum, number of missing values (if any), the minimum value and the maximum value. The generated charts give you additional information on the frequency counts and the distribution of the data. This type of data is useful in many ways; it allows you to identify the unit of measure that a particular column may be represented in (i.e., Dollars vs. cents); you can also rule out missing data values that may have impacted statistics that you are calculating in your reports.

**Tools** allows you to change the options available within the Data Explorer to adapt to your preferences.

Using the Data Exploration tool, you are able to get a general understanding of what your data contains before you start to use it in your analysis and reporting. Now that you’ve seen the data and have ruled out issues that could skew your results, you are ready to use SAS to produce reporting.
I AM A PROGRAMMER – HOW DO I RUN MY FAVORITE PROGRAM IN ENTERPRISE GUIDE?

Enterprise Guide enables you to easily run existing SAS programs, using similar steps to what you would follow using the SAS Display Manager windows. Let's run a simple program and review the log and results using Enterprise Guide. Throughout this workshop, we will be using the Shoes dataset from the SASHELP library.

To run an existing program using Enterprise Guide (See Appendix – Program_1.sas for example program),

- from the **Main Menu**, select **File ➔ Open ➔ Program**
- navigate to the location of your program
- select **Program_1.sas**. The program opens in a new window tab.
To view the process flow and then run the program,

- select the **Process Flow** shortcut on the menu bar. Notice that a code node, Program_1 is added to your **Process Flow** and **Project Tree** views. Notice the shortcut symbol with the code node, reminding you that this is a pointer to the locally stored version of Program_1

![SAS Enterprise Guide](image)

- run the program by selecting **Run On Local** from the POP MENU in the code node, OR by selecting **Run** from the context menu in the **Process Flow** view.

![SAS Enterprise Guide](image)

In this instance, we are running the SAS program using the Local version of SAS. You can change your connection settings to switch from a local SAS instance to a server instance or to switch from one server to another in the Administration panel of your Options screen (**Tools** ➔ **Options** ➔ **Administration**). The remainder of the examples in this paper assume that we are running on the Local Server.

When the program completes running, the **Process Flow** view shows the components created by program_1, as additional nodes.

![SAS Enterprise Guide](image)

**Helpful Hint:** To change the type of Results generated by a code node or task, right click on the node and select **properties**. Under the **Results**, click the checkbox beside the type of output you want to generate.
VIEWING LOGS AND RESULTS

In the above window, notice that the only symbol attached to the code node is the shortcut symbol. However, if your program resulted in an error or warning, you would see an additional symbol such as an exclamation point. When you rest your mouse over the code node, in addition to providing basic information about your program, you may also be informed to check for warnings or errors.

To review the log messages, select Program_1 in the Context Menu, and then select the Log tab. As always, carefully check your log for any messages that require attention. Notice the Data and Results tabs that are also available.

Helpful Hint: If you would like your SAS Log to open automatically when you have an error, check the Display SAS Log when Errors Occur option in your Results settings.

Helpful Hint: If you received an error or warning message about unsupported device ‘ACTIVEX’ for PDF destination, you can either

- Add options dev = actximg; to your SAS code prior to the ods pdf statement, or,
- Change the default graphics driver from ActiveX to ActXImg using Tools ➔ Options ➔ Results ➔ Graph and select Graph Format of ActiveX image (SAS V9)

Since our example program produces an Excel Spreadsheet report and a PDF report as output, you can use your normal process for opening and reviewing the results (such as Windows Explorer). Or, you can select the results from the Process Flow view to view the output. Each type of generated result will display as its own result node in your Process Flow view. Further, if you select Program_1 from the Context Menu, you will see the program, log, and each output displaying in a separate tab, as below.

Note that when you select output such as an excel spreadsheet, you will be prompted about downloading the results.
CUSTOMIZING THE WINDOWING ENVIRONMENT
Everyone has different preferences about how Enterprise Guide windows should work, and Enterprise Guide provides
the flexibility for you to create a work space that works best for you. For example, Enterprise Guide windows can be
• docked and undocked
• resized to make best use of the real estate
• hidden so that you only display what you need and use
• opened as new horizontal or vertical tabs
• easily reopened using the main menu or shortcut buttons.

Helpful Hint: Unhappy with your window changes? Select the Restore Window Layout button in the Options window.

GOODIES FOR THE PROGRAMMER – FOR EDITING
Enterprise Guide 5.1 includes many productivity enhancement tools for the programmer:

• Integrated Documentation — if you rest your mouse over a SAS keyword, a pop-up window displays the SAS documentation describing the keyword or syntax.
• **Syntax Suggestion / Autocomplete when coding** – When you enter the first 2 letters of a SAS keyword, a list will pop-up displaying possible keywords you can select from. This includes available PROC options.

![Syntax Suggestions](image1.png)

**NOTE:** Syntax suggestions INCLUDE user-defined Macro Variables and Macro names as long as they are defined through the active program. Macros and Macro Variables created through an autoexec are not included.

• **Autocomplete for SAS libraries, datasets and dataset column names**

![Autocomplete](image2.png)

• **Parenthesis Matching** – very helpful for debugging macros, complicated expressions, and SQL code. This also works for brackets ([ ]) and braces ( { } ).

![Parenthesis Matching](image3.png)

While all of these goodies are handy, they may also annoy you if you do not want help. **How do you turn these features off?** To turn any of the autocomplete features off, go to **Tools → Options → SAS Program → Editor Options.**
THAT WAS PAINLESS, BUT I NEED TO BE ABLE TO CHANGE CODE?
Suppose that you need to enhance existing code, rather than just run it. Navigate to the Program_1 code node and double click to open it if it isn’t already open; or select the tab if the code is already open. Once the code is open, you can make changes; you will find the editor commands are identical to the SAS Editor. Then simply rerun the code and review your results. You can save your changes from the main menu by selecting File ➔ Save. Remember, each time you save a code node, you are actually saving (or replacing) a .sas program file.

If you have selected ‘Open the LOG when errors occur’ in your Options, then your log will now automatically appear if there are issues.

Helpful Hint: If you would like to run just a section of the code, highlight and submit just like you do in the SAS Display Manager Editors.

WORKING WITH DATA
When we ran Program_1, the generated dataset opened in a new tab called Output. If your program creates more than one dataset, you can select the dataset you want to look at by using the dropdown at the top of the output tab.
WOW – THAT’S EASY – ARE GRAPHICS EASY TOO?
You have now submitted and modified existing code in Enterprise Guide, so let’s work on a task from scratch. A picture is worth a thousand words, so it is time to see how Enterprise Guide does with graphics. Using the same sales data created in the first example program (Program_1), you will produce a vertical bar chart of Sales by Region.

- Select Tasks ➔ Graph ➔ Bar Chart from the main menu. This opens the Bar Chart Wizard.
- In the Bar Chart screen, double click on Simple Vertical Bar
- In the Task Roles screen
  o Drag Region to Column to Chart
  o Drag Sales to Sum of.
- In the Appearance ➔ Layout Screen, uncheck the 2D box and then change the Shape to Cylinder from the drop down list
- In the Titles screen
  o Click on Graph
  o Uncheck Use Default Text and enter your own title for your graph.
- To see what code was generated, click on Preview Code.
- Close the Code Preview Window
- Click on Run to create the Bar Chart
- The bar chart opens automatically in a new Tab in your Enterprise Guide session.

Notice that there are now tabs for the input data, code, log, and results. Additionally, the Context Menu allows you to easily Modify Task if you have changes to make.
LEVERAGING CODE THAT ENTERPRISE GUIDE BUILDS

Behind the scenes, Enterprise Guide created “correct” code! Like most SAS programmers, you would probably like to re-use the code elsewhere.

To access and then save the generated code,
- In the Context Menu Bar in the Process Flow window, click on the Code tab (see above window)
- Select the AXIS, GOPTIONS, TITLE, and FOOTNOTE statements and the PROC GCHART statements
- Right click anywhere on the highlighted code, and select Copy
- Move to the Process Flow Window.

To insert the copied code into a new program, select File ➔ New ➔ Program. A blank code node will open in the Project window. Paste the copied code and change the dataset name on the PROC GCHART statement to Ex_Shoes_Data. Save the new code node, by selecting File ➔ Save Code As ➔ Local Computer, and provide the name Program_2.

The new code can now be run in the usual fashion. You can make any additional updates and customizations to code that you’ve just pasted, such as changing the appearance of the LEGEND or adding a WHERE clause to subset the data being graphed.

Helpful Hint: The Task Status Window shows you the status of the code or task you are running. If you are running large SAS programs, the Task Status will tell you which task or Procedure is currently running. You can open your Task status view from your Main menu. Select View ➔ Task Status.

Each of the built-in tasks will generate SAS code as you step through the Task Panes. This serves as a great way to learn how to code new SAS Procedures since the syntax is available to view and edit.
CUSTOMIZING THE GRAPH FORMAT

By default, graphs are generated as interactive ActiveX graphs, which are cool but can use up a lot of system resources. You may prefer or require a more static format such as HTML or JPEG. You can easily change the default in the Graph Results settings of Options.

Select **Tools** ➤ **Options** ➤ **Results** ➤ **Graphs** and select a different format from the drop down list.

ADDITIONAL GRAPHING FEATURES

There are lots of features in Enterprise Guide that make graphs easy to produce. You should explore the variety of ways to visualize your data, including the Tile Chart which allows you to display magnitudes by size and colour.

In this Tile Chart example, the size of the rectangles represent the number of stores in each region; the bigger the rectangle, the more stores in the region. The color represents the Sales, and the legend shows that the darker the green, the higher the dollar value of the sales. Create a Tile chart by launching the Graph Tile Chart Task.

Select **Tasks** ➤ **Graphs** ➤ **Tile Chart**

Enterprise Guide also has a Built-in task that allows you to produce Maps. These require specific mapping data and will not be discussed in this paper.

Other features include:
- Context based menu bar when looking at Graph Results, allowing you to quickly modify the graph task and refresh the graph
- Each graph type has a detailed wizard, including options to control the graph output
- You can save your graph task preferences in a template that can be reused so that you can define appearance attributes, headers, footers etc. only once and save them in a template.

**Helpful Hint:** Viewing the task properties will give you some general info about the task that was run. This includes the task label, how long the task took to run the last time it was executed, the server where the code was executed and the input data used.
A NEW WAY TO ORGANIZE YOUR PROGRAMS

During program development and testing, do you often work with just one set of steps at a time, confirming results before you move on? If you do, that same logic can easily be applied to your code in Enterprise Guide by defining your program as a series of code nodes. Code nodes can be linked together in the Process flow window, thus providing a clear picture of the steps and intermediate results.

To link the new Program_2 code node to the first code node,
 right click on the Program_1 code node in your Process Flow window
 select Link Program_1 to...
 select Program_2 and click OK.
 You now see the link between the two nodes and have the option of running either a single code node or running the branch that starts with Program_1.

To run both code nodes, right click on your Program_1 code node and select Run Branch from Program_1. Once the code in Program_1 has run, Enterprise Guide will automatically run Program_2, generating and displaying all intermediate results along the way.

Helpful Hint: To remove a link between tasks or Code nodes, right click anywhere on the joining arrow and select Delete. This will only delete the linkage, not the code nodes.

You’ll notice that a separate log node is generated for each code node. By turning on Project Logging, you can easily tell Enterprise Guide that you’d like a single SAS log to be generated for all of the tasks and code nodes in your Project. This single Project Log will be created in addition to the individual logs created for each task or code node.

Helpful Hint: If Project Logging is turned on, the log represents a running log of the entire project. To turn on the Project Logging, select Project Log in the Context Menu of the Process Flow, and then select Turn On.

Helpful Hint: When working with several tasks and code nodes in a single project, you can export all of the generated SAS code as a single .sas file by selecting File ➔ Export ➔ Export All Code. Enterprise Guide will scan through your project to find all executable code and save it to a single .sas file. You can select export all the code or select only parts of your project.

SAVING THE PROJECT
At this point, save the Project so it is available for another day.
• Select File ➔ Save Project As ➔ Local Computer
• Navigate to the file path where you would like to save your project.
• Enter a name for your Project, and Click ok.

The next time you open your saved project; you will see the code nodes and links that you defined in this session. Note that any temporary work datasets that you may have created in your session will not be saved with your project. You can easily recreate the work datasets by re-running the project the next time you open it.
HELP FOR YOUR LEGACY CODE, TOO
You probably have a lot of multi-step programs that would take you a lot of time to change into a Process Flow. The Code Analyzer allows you to

- Turn your multi-step SAS Program into a Process Flow
- Create instant documentation including:
  - What steps are run
  - How long the steps take
  - What data is used and created in each step.

In the Program context menu bar, select Analyze Program ➔ Analyze Program Flow. Then select Begin Analysis.

Once analysis is complete, select Create process Flow.
A new flow is added to your project called Program_1 (defaults to the name of your program node). Note that the Code Analyzer did not run the code and produce results.

Run the new flow by right clicking on the starting dataset (SASHELP.SHOES) and selecting Run Branch from SASHELP.SHOES.

MULTIPLE FLOWS IN THE SAME PROJECT
When there are multiple flows within a project, how can you easily switch between Process Flows?
- Use the Project Tree view and select the flow you want to look at
- Use the Drop Down at the top of the Process Flow view.

Helpful Hint: When working with multiple flows, it’s a good idea to rename the flows to something meaningful.
Right click on the Process flow in the Project Tree and select Rename.
CREATING REPORTS IN ENTERPRISE GUIDE

As experienced SAS programmers, you probably have a lot of familiarity with certain PROCs. However, since the SAS language is extensive, there are probably many areas that you have not explored. One of the benefits of using Enterprise Guide is that **Tasks** guide you through requirements and enable you to quickly produce results without having to learn new syntax and procedures.

Use the **Report Wizard** to produce a detailed listing of the data.

1. Select **Tasks** ➔ **Describe** ➔ **List Report Wizard**
   
   Step 1 allows you to select the data you want to report on.
   
   2. Select **Edit** and navigate to the `work.ex_shoes_data` dataset.
   
   3. Then select **Browse** ➔ **Libraries** ➔ **Work**
   
   4. Select **ex_shoes_data**
   
   5. Select **OK** to return to the Step 1 window.

To define the report layout, select **Edit** and select **Assign Columns**

- Under the Selected Columns, select the **Stores** column
- Use the drop down on the right to change **Show sum value (SUM)** to **Display all Values**
- Remove two columns by selecting **Inventory** and **Returns** and then click on the **X** on the right of the Selected Columns area.
- Select **OK** to return to the Step 2 window.
Step 3 allows you to define totals for your report.

- In the **Select Totals** window, select **Sales**
- Select **Edit** to control how subtotals are handled
- Select **Totals by Region**
- Select **OK** to return to Step 3 window
- Notice that the visual of the sample report shows SALES totaled and also shows region subtotals.
- Click **Next** to move to Step 4.

- In the Step 4 window, provide titles and footnotes, and select **Finish**
- The report displays, along with the Context Menu Bar enabling you to easily make changes and view the Log, Code, Input Data, and Results.

Select the **Code** tab and review the generated code. Notice it is similar to the PROC REPORT code used in Program_1.sas.
COMBINING TASKS FOR QUICK AND EASY REPORTS
The Report Builder allows you to easily combine the output from different tasks and programs into a single page. You can control the layout and place graphs and tables side by side without having to build complicated templates in Proc GREPLAY. You can also easily add text blocks (for titles, footnotes and commentary) and images such as your organization’s logo. The final output can then be saved and exported as PDF and HTML or shared in the SAS Report format.

Create a new report by selecting File ➔ New ➔ Report. Then select which Task output you want to include in your Dashboard by highlighting the item and dragging it to the Report layout grid.

Then click Insert Text and add the text “This is a Shoes Sales Report for January 2010”. Change the font of the text to 16 pt and rearrange the report layout to match the below layout.

Once the report is generated, Click Page View and change the layout to Landscape.

To export the report as PDF, Click Export in the context based menu bar and select Export as Step in Project. The Report is highlighted. Click Next. Select Portable Document Format (.pdf) and specify the Location to save Report, and choose an appropriate location. Under Output Options, Uncheck Overwrite Existing output. Select Next ➔ Finish.
HOW CAN I ADD SOME FLEXIBILITY TO MY PROJECTS?

Project Prompts are user prompts that are passed as macro variables to your SAS code. By adding prompts to your project, you give the user some flexibility in customizing the results. The user can enter values or select from a list of values that you provide. In our example, we would like the user to be able to create this same report for one or more regions existing in our data.

To begin creating project prompts

- Select **View** ➔ **Prompt Manager**
- Click **Add** to add a new prompt

In the **Add New Prompt** window

- Under the **General** tab, enter
  - **RegionID** in the name section to assign the macro variable name
  - **Please Select a Region** in the Displayed text section, to define the text the user will see when the prompt is displayed.
Select the **Prompt Type and Values** tab

- In the **Prompt Type** dropdown, select **Text**
- In the **Method for populating Prompt** dropdown, select **User selects values from a static list**
- Select **Get Values** to identify the source of the static list
- Select **Browse** to load values from **SASHELP.SHOES**
  Servers ➔ Local ➔ Libraries ➔ SASHELP ➔ Shoes
- From the **columns** dropdown, in the **Unformatted Values** section, select **Region**
- From the **columns** dropdown, in the **Formatted Values** section, select **Region**
- In the **Available Values** section, under the **Browse** tab, select **Get Values**
- Move all of the values over to the **Selected Values** window
- Select OK
- In the **List of Values**, designate **Canada** as the **Default** value and Select OK.

**RegionID** now appears in the **Prompt Manager** view and is available to use as a prompt. Now we need to modify the program to accept prompts. From the **Process Flow** window:

- **Right click** on the **Program_1 Code Node** and select **Properties**
- From the Properties window, select **Prompts** and Click **Add**
- Select **RegionID** and click OK
- Click OK again to close the Program node Properties window

Now, modify the program so that the prompts control the data selected.

- **Open** the **Program_1 code node**
- **ADD where Region = "&regionID"** in the **Ex_Shoes_Data data step**
- **Save** the changes to **Program_1**
- **Right click** on the **Program_1 code node**, **Select Run Branch From Program_1**
- **When prompted to select a Region**, select **Asia** from the drop down list. Click **Run**.

If we take a look at the **Ex_Shoes_Data** dataset and subsequent graph and report, only observations with a **regionID** of ‘Asia’ are included.
ADDING FLEXIBILITY TO your PROJECT WITH CONDITIONAL PROCESSING
As we have seen with parameters, macro variables enable code flexibility since the user can provide selections and input. But, if you have processes that should only be run under certain conditions, perhaps regardless of a user preference, Enterprise Guide enables you to **run a branch conditionally**. For example, you can

- Run different branches depending on system parameters such as time or date
- Add error / exception handling logic
- Let the user control which branch is run via project prompts.

For more information on Conditional Processing, refer to the SAS Online Documentation or to the many SAS Global Forum papers on the topic.

OK – ENTERPRISE GUIDE REALLY WILL HANDLE MY NEEDS BUT HOW CAN I OFFLOAD SOME OF MY WORK (OR DO MORE WORK IN LESS TIME)?
For most SAS programmers, it is a rare occurrence to write a program that is never used again. More typically, you write programs that either run in production, or that are rerun with different input (prompts) on a regular basis. Furthermore, YOU are not always the person that runs the job after it is written. Someone else may be responsible for providing input prompts (changes) and running your code when results are needed. With this in mind, we explore how you can easily set up your code so that others can access and get the results they need. You will do this by creating a Stored Process.

A **Stored Process** is a SAS program that is typically located on a central server (ie: available to multiple users across multiple clients) so that users can run the SAS Code but can’t change the SAS code. Designed properly, the Stored Process enables user input to maximize the applicability of the code. For example, you

- can embed business rules and logic so that everyone is creating consistent results
- have change control around any coding updates
- can make your code available to more people
- can provide the users with input prompt choices to take care of minor tweaks in the requirements
- can add cascading prompts to make User input easier and more flexible.

For more information on creating and using Stored Processes, refer to the SAS Online Documentation or to the many SAS Global Forum papers on the topic.

I’M TOLD I’M RUNNING ON A SERVER – WHAT DOES THAT MEAN?
When you are running in a ‘Server environment’, SAS is installed on a central server somewhere and is not installed locally on your machine. There are some significant differences between running on a Server environment and running SAS locally but before we talk about what is happening behind the scenes, let’s take a look at the major components of a Server Environment: the metadata server; the Object Spawner; the SAS Application Server; and the Database where your data are located.

- The **Metadata server** stores all of the central metadata about users, and the data and processes that they are allowed to access.
- The **SAS Application Server** is an execution server that allows for distributed processing through various clients -- in plain English, this is where SAS is actually installed. This allows you to run your SAS programs from different clients (ie.SAS Enterprise Guide, Excel, a web interface) without actually needing SAS on your local computer.
- The **Object Spawner** essentially acts as a gatekeeper and controls your links to the other servers.
- **Databases** house our data. Often, the data that you are working with will not be in SAS datasets but rather in Database tables such as Teradata, Oracle, or DB2.
When you submit a task or a program from Enterprise Guide in a Server Environment, the following will occur:

1. Your Enterprise Guide session connects to an Object Spawner.
2. You connect to the metadata server through the Object Spawner. The metadata server verifies your credentials (password and user ID).
3. Once credentials are verified, the Object Spawner starts up a dedicated SAS session for you on the SAS Application Server. It also creates a temporary Work space library for you that persists as long as your Enterprise Guide session is connected.
4. If your program or SAS Task uses data that is on a Database (eg. Teradata, Oracle, DB2, Netezza), the SAS Application Server will connect to the database server.

---

There are several important things to keep in mind when running Enterprise Guide in a server environment.

First off, as we mentioned above, when you first launch Enterprise Guide, a temporary workspace library is created on the server that will be dedicated to your Enterprise Guide session. This is where your WORK library is located. When you disconnect your Enterprise Guide session, that temporary workspace location is deleted. As you keep working and creating more and more temporary datasets in your work library, the workspace location dedicated to your session is getting bigger and bigger. You may not need many of those datasets anymore but until you delete them or disconnect your EG session, you’re still using up that space. It’s therefore best practice to either delete any large datasets that you’re no longer using, or to disconnect your Enterprise Guide session once your work is finished so the space can be released.
Secondly, you may find that when you run your SAS programs through Enterprise Guide in a server environment, things sometimes seem to take longer to run. Most SAS programmers will assume that Enterprise Guide is slowing down their work but more often than not, it is the movement of data that is creating the bottleneck. When data resides on a database for example, it has to move from the database, to the SAS server and then to Enterprise Guide. These extra steps can add to how long it takes to run your jobs when you’re dealing with large amounts of data. In order to minimize the amount of data that is being moved, you want to make sure that the Database is doing as much of the work as possible and then passing only the results back to SAS and the Enterprise Guide session. This can be done by using indexes, partitions and keys that exist on the database tables. It can also be done by taking advantage of SAS/Access engines.

SAS/Access engines are designed to translate many SAS functions into functions that can be understood and performed by the Database. For example, the SAS/Access engine for Oracle will translate the SAS Datetime function into the SYSDATE function in Oracle.

If a SAS query command can’t be translated into a Database command, the database is going to pass back ALL of the data to the SAS server so that it can process the command. This is what is going to slow down your performance causing longer query times, excessive server usage and slower server response for other users. Therefore, when writing queries against large databases, wherever possible, you want to ensure that joins, filters and SAS functions are passed to the database to perform.

Finally, there are a number of SAS coding techniques that are either not well suited for use in a Server Environment, or will not work at all in a Server Environment.

- **X** Writing to or reading from your local C: drive is not going to work. The server will not recognize your C: drive as a valid location.
  - **✓** Workaround: You can use the Import and Export Wizard to access files on your PC. You can also use the Upload and Download tasks to read and write SAS datasets to your local computer.
- **X** Using ENDSAS or ERRORABEND will disconnect you from the server completely. Your Work library and log are lost.
  - **✓** Workaround: Use Conditional Flows to build error handling into your projects
- **X** SAS/AF is not available.
  - **✓** Workaround: Use Project Prompts and macros in your code to get interactive input from your users.
- **X** DDE (Dynamic Data Exchange) will not work using Enterprise Guide in a Server Environment.
  - **✓** Workaround: Using the Excel Libname engine provides flexibility when working with Excel spreadsheets and is easier to use than DDE.
- **X** X Command and SYSTASK are disabled by default.
  - **✓** Workaround: Might be a long shot, but plead your case to your Server Administrator to have this enabled if this is truly needed.
- **X** Rsubmit commands are no longer needed since you’ve already established the server connection when you logged into Enterprise Guide.

While a Server Environment will introduce differences that are going to affect how you create your SAS code in Enterprise Guide, don’t panic – remember, under the covers its still SAS.
I WANT TO IMPRESS MY CO-WORKERS – HOW ABOUT SOME USEFUL TIPS AND TRICKS?

TIP 1: USE ORDERED LISTS

Goal: What if we have 3 SAS jobs that we’d like to run, one after the other? Or perhaps we have some processes that we’d like to submit at the end of the day so we can have the results ready the next morning. In this case, we don’t really want to build a project; we want to be able to submit a ‘list’ of SAS jobs or tasks that we want Enterprise Guide to run.

Solution: This is where we would ‘Create an Ordered List’. The Ordered List task in Enterprise Guide allows you to specify a list and sequence of tasks and jobs that you want Enterprise Guide to run.

To create an ordered list, go to File ➔ New ➔ Ordered List.

TIP 2: SHARING YOUR PROJECT WITH OTHERS

If you have notes embedded in your projects, you can email those results to yourself or others in your organization. This is a great way to let people know that a report is ready to view or data has been refreshed. When you combine notes with conditional process flows, you can alert others when your project has encountered some unexpected data or hasn’t completed successfully.

Notes are also a great way to document important details about your process and keep them embedded in your project. You can use notes to list the inputs used on your process or the results that are produced. You can also use them to provide instructions on how and when the project should run,

To add a note to your project, select File ➔ New ➔ Note. Use the linking feature to attach the note to a specific task, program or results node.

TIP 3: AUTOMATICALLY BACK UP YOUR PROJECT

How many times have you spent an afternoon on a SAS Project and just when you’re almost done and ready to save it, the power goes out or you’ve inadvertently kicked the plug. Your EG session is gone, along with an afternoon’s worth of work. First things first – ENABLE PROJECT RECOVERY. This feature autosaves your project at set intervals so you can specify how often you want the Project to be saved.

To enable project recovery, go to Tools ➔ Options ➔ Project Recovery ➔ Check ‘Enable Project Recovery’.

TIP 4: AVOID OPENING LARGE DATA UNLESS YOU HAVE TO

By default, when data is added to your project, Enterprise Guide opens that data into a new Data tab. This is fine and even helpful when you are working with small SAS Datasets however, this can bring Enterprise Guide to a stand still when working with large amounts of data in a database. As described above, all of the data has to move between the database server, to the SAS Server to your Enterprise Guide session.

To make the data available to your project but avoid opening it automatically:

- Select Tools ➔ Options ➔ Data
- UNCHECK ‘Automatically open data when added to project’.

TIP 5: EXPORT YOUR PROJECT TASKS AS SAS CODE

Once you’ve completed all of your exploratory work, you may end up with a mix of tasks and custom program nodes. You can save all of them or a subset of them as a single SAS file which you may then want to run in Batch mode. When exporting the Code in your project, Enterprise Guide scans through your project and assembles all of the SAS code that was either generated by a task or was written in a custom program node. You can then select which parts of the project you want to include in the final SAS file and the order in which the SAS code should appear.

To export all or parts of your project to a SAS File, select File ➔ Export ➔ Export all Code in Project
TIP 6: FORMATTING CODE – EASILY
Do you inherit code that is poorly formatted? There is relief!!!

Open the program node, right click and select **Format Code**

```
data Ex_Shoes_Data;
    set sashelp.shoes;
    where region = Iowa;
    label AverageSalesPerStore=
        "Average Sales Per Store";
    format AverageSalesPerStore 16.2;
run;
```

**Helpful Hint:** To specify formatting preferences, override the options in **Tools** ➔ **Options** ➔ **SAS Programs** ➔ **Editor Options** ➔ **Indenter tab**.

This allows you to set the spacing on indents and select which statements signal a new line.

TIP 7: ENJOY AUTOEXEC PROCESSING – EVEN IN EG

You may be familiar with using an `autoexec.sas` file to enable setting up your SAS environment at startup. It works in Enterprise Guide too! Just add a **Process Flow** to your **Project** called **AUTOEXEC**.

Enterprise Guide will run the flow when you open the project. This is handy for setting up libraries, controlling options, etc.

One thing to remember when including an AUTOEXEC flow in your project, you have to let Enterprise Guide know that you want the flow to run automatically every time the project is open. To do this one extra step, go to **Tools** ➔ **Options** ➔ **General**. Make sure that “Automatically run ‘Autoexec’ process flow when project opens” is checked.

---

28
TIP 8: EASY VIEWING WITH SPLIT SCREENS

Enterprise Guide provides split screen options that enable you to explore tasks, programs and data side-by-side.

Option 1: Split screen to view different sections of same tab
Right click on the view you are looking at
Select Split – Select Stacked, Side by Side or Both

Option 2: Split screen to view different tabs
Select View from the Main Menu
Click Workspace layout
Select Stacked or side by side.

Each view will have a drop down at the top left corner that allows you to select what you want to view.

TIP 9: RUNNING TASKS IN PARALLEL

We saved the most exciting tip for last! Starting in EG 5.1, you can run tasks and process flow paths in parallel on the same server instead of having to wait for them to run one at a time. This can be enabled at the task level or at the Project level.

• To set tasks to run in parallel, go to File ➔ Project Properties.

• Go to the Code Submission window and make sure that the “Allow parallel execution on the same server” box is checked.
Now if you are running more than one task in separate branches, you'll notice that they aren't cued up waiting to run one after the other. They will run at the same time.

You can also control this at the individual task level by right clicking on the task, and selecting Task Properties. Under the Code Submission view, you can select to either use the settings set at the Project level, or customize the options for this specific task:

A word of caution when you are using this functionality; because you may be launching more than one workspace server connection when running in parallel, changes that you make in one session (adding macro variables, libraries etc) may not get picked up in the tasks or code that is running in the other session. So you really need to make sure that the tasks can run independently when using this option.
CONCLUSION
Enterprise Guide provides a powerful environment and toolset for end-to-end information delivery. As a SAS programmer, you can easily begin taking advantage of Enterprise Guide to provide a flexible reporting and analytics environment to meet your organization's business needs.

RECOMMENDED READING
To gain a more complete understanding of Enterprise Guide the authors recommend the following

- SAS Documentation including “What’s New” and “Getting Started with SAS Enterprise Guide – free learning tutorial” available at
  http://support.sas.com/documentation/onlinedoc/guide/

If you are using an earlier version of Enterprise Guide, please see Proceedings Papers from versions 4.1, 4.2, and 4.3 at http://www.sascommunity.org/wiki/Presentations:Marie_Papers_and_Presentations

CONTACT INFORMATION
Your comments and questions are valued and encouraged. Contact the authors at:

Marje Fecht
Prowerk Consulting
marje.fecht@prowerk.com
www.prowerk.com

Rupinder Dhillon
Dhillon Consulting
Rupinder@dhillonconsulting.com
www.dhillonconsulting.com

SAS and all other SAS Institute Inc. product or service names are registered trademarks or trademarks of SAS Institute Inc. in the USA and other countries. ® indicates USA registration.
Other brand and product names are trademarks of their respective companies.
APPENDIX – PROGRAMS

PROGRAM_1.SAS
/********************************************/
/* Example Program 1 - Output Excel Spreadsheet and PDF w/ Shoes data */
/* Note: multiple statements on a line to demonstrate features */
/********************************************/
data Ex_Shoes_Data;
  set sashelp.shoes;
  AverageSalesPerStore = sales / stores;
  label AverageSalesPerStore = 'Average Sales Per Store';
  format AverageSalesPerStore dollar12.2;
run;

ods listing close;
ods tagsets.ExcelXP path = 'C:\HOW\Fecht'
  file='EG Basic_Report.xls' style=statdoc
  options (sheet_name       = 'Example 1'
              frozen_headers = 'Yes'    autofilter     = 'All' );
  title "Simple SAS Code Example 1";
proc print data=Ex_Shoes_Data noobs label ;
run;
ods tagsets.ExcelXP close;    ods listing;

/********************************************/
/* Create PDF Report                     */
/********************************************/
ods listing close;
ods pdf file = 'C:\HOW\Fecht\EG Shoes_Report.pdf';
proc report data = Ex_Shoes_Data;
  column ("Location" (Region Subsidiary Stores))
    Product
      ("Sales"    (Sales AverageSalesPerStore))
    ;
  define region / order "Region";
  define Subsidiary / order "Subsidiary";
  define Stores / display "Number of Stores";
  define Product / display "Product";
  define Sales / Sum "Sales";
  define AverageSalesPerStore / Sum "Avg Sales per Store";
  break after region / summarize;
  rbreak after / summarize;
run;
ods pdf close;
ods listing;