ABSTRACT

As a longtime Base SAS® programmer, whether to use a different application for programming is a constant question when powerful applications such as SAS® Enterprise Guide® are available. This paper provides some important tips for the programmer, such as the best way to use the code window and how to take advantage of system-generated code in SAS Enterprise Guide 5.1. This paper also explains the differences between some of the functions and procedures in Base SAS and SAS Enterprise Guide. It highlights features in SAS Enterprise Guide such as process flow, data access management, and report automation, including formatting using XML tag sets.

INTRODUCTION

SAS Enterprise Guide is more flexible software and user friendly to a beginner or an advanced level programmer. You can write code in the programming window similar to Base SAS or you can use the Point and Click method in which Enterprise Guide writes code for you. If you think about how Enterprise Guide performs tasks, SAS Enterprise Guide does not analyze data itself, whenever you use Point and Click on any control or perform any task Enterprise Guide submits this information to the SAS server and SAS generates the necessary code to handle the task.

This paper illustrates some of the important tips for programmer analysts moving forward from Base SAS to Enterprise Guide, further highlights the best possible way to use the code window just like Base SAS as well as system generated code in SAS Enterprise Guide 5.1. It also discusses the difference between using some of the functions and procedures between the two versions. This paper further highlights a number of features in SAS Enterprise Guide such as process flow, data access management and report automation process including formatting aspects using xml tag sets similar to Base SAS. In this paper each topic is composed of the below mentioned points, so the user can easily locate each control and perform their task.

- **Navigational Tip** will demonstrate an easy way to locate important controls from menu bar or in the optional window.
- **Brief description of each Point and Click control** and further discuss its function to perform our task.
- **Screen shots** will be helpful in most scenarios, however all screen shots for every step are not included because of space constraint.
- **Helpful Tips** provides useful hints on possible options or short cut key functions.

Let us begin with opening both Base SAS and Enterprise Guide windows and start exploring some of the most important controls to perform our tasks.

**CODE WINDOW SIMILARITIES:**

**Navigational Tips:** File → New → Program
When you open Base SAS program the Editor window (same as code window) opens by default where you can write code and select to display results. To open the code program window in Enterprise Guide you have to open from the menu bar. You have all the basic functionality to write code for analysis and reporting similar to Base SAS, but unlike the RUN icon, you have two options to run code, either you can highlight code and RUN SELECTION or you select RUN to execute entire code.

**Base SAS Program Editor Window**

![Base SAS Program Editor Window](image)

The Task panel displays a series of tasks that are running in your project. When DATA step or PROC step runs without any errors, results will be outputted and the log window will show you details for review. If you have multiple process flows or programs in the project, all process flows or programs appear in RUN, then you have an option to run corresponding run selection.

**Enterprise Guide Programming Window**

![Enterprise Guide Programming Window](image)

Run Selections for highlighted code and Run for entire program.
By default, dataset results will be output as SAS reports, however, you have an option to choose as HTML, PDF, RTF, or text outputs. Log errors will be output in log windows. The below-mentioned output results and log windows were generated from Enterprise Guide 5.1.

**Helpful Tips:**

1. Check **Display Log When Error Occurs** option in results settings (Tools > options – Results) to automatically display when error generated.

**CODE SYNTAX HELP FOR PROGRAMMERS**

Enterprise Guide 5.1 has an excellent auto-complete feature for programmers where you can place your mouse over or while typing key words. This feature will be very useful for code syntax, so that you can avoid looking for help or searching for code syntax in most of the scenarios. If you place your mouse over the SAS keyword, Enterprise Guide will automatically display documentation for possible options for that keyword. It will also display a list of variables in a dataset that you can select. When you type two letters of the SAS keyword, a dropdown list will pop up for you to choose available functions or procedure. Enterprise Guide 5.1 will also display available project libraries or datasets while typing code.

**Popup window showing integrated documentation**

```sas
proc print sashelp.cars;
run;
```

Keyword: **PRINT**

**Syntax:**

```sas
PROC PRINT options;
BY variable;
FOOTNOTE variable=type;
FORMAT variable=type;
OBS option;
RUN CANCEL option;
SYMBOL option;
SYSECHO option;
TABLE option;
TABLES option;
VBAR option;
WHERE option;
```

The **PRINT** procedure prints the observations in a SAS data set, using all or some of the variables. You can create a variety of reports ranging from a simple listing to a highly customized report that groups the data and calculates totals and subtotals for numeric variables.

Search: The Product Documentation, Samples & SAS Notes, Papers

**Drop down list showing syntax suggestions**

```sas
proc freq sashelp.ca:
data;
```

- RUN CANCEL
- SYMBOL
- SYSECHO
- TABLE
- TABLES
- TEST
- TITLE
- WEIGHT
- WHERE
PROCESSFLOW USING PONT-AND-CCLICK METHOD

Navigational Tips: File → New → Project or Process Flow

SAS Enterprise Guide 5.1 provides a good visual interface for analysts and programmers; the main project window has Project Tree, Process Flow and Server List panels as shown below. If you are an experienced SAS programmer you have an option to write code in the programming window or take advantage using available handy tools in Enterprise Guide. To get familiar with most of the controls, the best suggestion would be completing one project in Enterprise Guide. You can simply click or drag on the process flow window and the system generates code for you to review. Another advantage in Enterprise Guide is that you can use the combination of writing code and be able to link your program output results anywhere in the process flow.

Helpful Tips: You can get back to Process Flow window at any point by clicking F4 Key (View → Process Flow).
DATA ACCESS LIBRARIES:


SAS Data libraries store files in a particular location. SAS Enterprise Guide lists libraries that are defined in metadata as well as any libraries in shared drives irrespective of databases. You can write your own LIBNAME statement in the programming window as shown below or there is an option that allows you to specify code that will be automatically executed every time you run your project in Enterprise Guide.

You also can assign LIBNAME statements by selecting Tools   Options   SAS program then check insert custom code before submitted code check box then click on Edit button to enter your LIBNAME statements as shown below.
ASSIGN PROJECT LIBRARY TASK

Navigational Tips: Tolls ➔ Assign Project Library

You have an option to add your LIBREF by following all 4 steps then Enterprise Guide will add an icon to your project in the project tree window.

Helpful Tips: You can assign as many libraries to the process flow to import and export SAS files. You also have an option adding LIBNAME statements in the Programming Window.

WORKING WITH LOG WINDOW:

Navigational Tips: View ➔ Project Log

You can review your log in the Project Log Window. Enterprise Guide will generate these symbols as icons which appear in the Project Tree window for errors or warnings generated. You can also check the Project Log window for more details.
**Helpful Tips:** You have an additional option to clear the log or turn off log as shown on the left corner of the Project Window. You can collapse by hitting Alt + Ctrl + “-” (minus sign) and to expand Alt + Ctrl + “+” (Plus sign) for log details.

**ADDING NOTES:**

Navigational Tips: File  ➤  New  ➤  Note

Enterprise Guide has a nice feature that allows you to add notes to your project for documentation; when you save the project a Note Window appears in the Project Tree window.

![Image of Enterprise Guide interface](image1.png)

**Helpful Tips:** You can add many notes to each program or each Process flow for documentation purpose.

**WORKING WITH DATASETS**

Navigational Tip: File  ➤  Open  ➤  Data  ➤

SAS Enterprise Guide gives you an excellent additional feature to work with single SAS dataset or multiple SAS files by Point and Click to do further analysis and generate report or to plot your choice of Graphs and then email to the recipient.

![Image of Enterprise Guide interface](image2.png)

**Helpful Tips:** Explore the above highlighted features by choosing each option.
DATASET PORC CONTENTS

Navigational Tips: Click on Properties → Properties → Copy to Clipboard-Paste on Excel or Notepad.

You can very easily display each variable list and their field type by highlighting the dataset, right mouse click to select properties, then select column option as shown below. Click on Copy to Clipboard button, then open Excel or notepad and see a detailed list of all variables which is similar to PROC CONTENTS in Base SAS.

TO LIMIT OUTPUT OBSERVATIONS

Navigational Tip: Query Builder → Options for this Query – Results ✓ Check Limit number of matching rows Option – Enter Number of rows

You can limit your output observations by entering rows as shown below; this function is just like the OBS function in Base SAS.
DATA EXPLORATION

Navigational Tip: File → Open → Data Exploration

Enterprise Guide 5.1 has a new feature called the Data Exploration tool, which enables you to look at data structure and validate your data before moving to the next step. Data Explorer will allow you to select columns, filter and also has a sort option on each dataset. Additional options are available to conduct minimal statistics such as average, distinct counts values and sum functions available in data exploration window. You can also look into missing and non-missing values and frequency counts, additional features including quick bar charts and reports by the Point and Click method. You always have the option to insert new columns or modify existing columns and format variable as you need for analysis and reporting.

WORKING WITH QUERY BUILDER:

Navigational Tips: Highlight dataset - Tasks → Data → Query Builder

You can take good advantage with the Query Builder by using the Point and Click method in Enterprise Guide. You can select, modify, sort, filter and subset data by joining and adding tables. You can also create new columns from an existing column using mathematical operators. The Query builder flow diagram by the Point and Click method is shown below; you have an option to choose the highlighted or to select desired columns and sort data. You can choose Filter Data tab and add filter condition. You can add more conditional statements using AND or OR operators for each filter conditions.
Helpful Tips:  ✔️ Check Select distinct rows only to output distinct rows in order to select columns in Select Data tab.

You can join tables by simply dragging datasets on the Project Tree window. The SAS system automatically joins and writes code for you using PROC SQL. When you join tables together, one table may not match all rows contained in the other table (by default nonmatching rows will be deleted), however, you can control which rows to keep by using join conditions from each table. The following graphic diagram shows you how to control your required rows by using join conditions.
Table Join Conditions in Query Builder

Query builder is generated PROC SQL code, notice highlighted area showing available options to validate your data. PROC SQL in Enterprise Guide support PERL regular expression for text manipulation similar to data step in Base SAS.

You can accomplish more tasks using the built in Computed Column tool in Query Builder, where you have an option to add new computed columns and choose Summarized Column or Advance Expression as shown below. You can type available functions to modify text or compute values and rename this column. For easy reference all available functions and their descriptions are listed in the Function folder. In this example, the INTNX function is used in the expression window to calculate date range and you can use similar functions to automate reports by passing the system generated DATETIME function.
APPEND TABLES

Navigational Tip: Tasks ▶ Data ▶ Append Table.

Enterprise Guide has an Append Table task available to stack tables similar to Base SAS. You can append two or more tables that contain common names. The following code window explains how to append two tables using the UNION operator.

Helpful Tips: It is good practice to maintain the same column names when you append two or more tables; if the columns are not matching between tables, this task will add as a new column to the appended table.
SUMMARY STATISTICS

Navigational Tips: Task ▶ Describe ▶ Summary Statistics

You can compute either summary statistics task or wizard as shown in the below window. More built-in options are available for you to select list data, Summary Tables, Distribution Analysis, One-way Frequencies and table as well as other analysis options available to arrive at your desired output results. You can modify the existing PROC SQL code as shown below:

![Summary Statistics Window]

MODIFY AND INSERT CODE

Navigational Tips:

Enterprise Guide has a great facility called the Programming Window and output results can be linked anywhere in the work flow. The below example is a dataset program linked in middle of the work flow. You can make changes or insert code in the Programming Window and then save the project by selecting File ▶ Save.
Helpful Tips: If you make changes in Query Builder generated code, Enterprise Guide saves this as a different Program in Project Flow window.

PROJECT RECOVERY

Navigational Tips: Toots › Options › Project Recovery

Enterprise Guide has the option to recover your project if the system crashes or you lose your previous version. You can recover projects at certain intervals by setting the option as shown below:

PROMPT MANAGER

You can use Prompts to create macro variables. When a prompt is created a global macro variable is generated in SAS code. You can use this macro variable anywhere in your project. The following example shows how to generate a date range macro variable and use this variable in PROC report.
EXPORT AND IMPORT FILES:

Navigational Tips: File  Import Data (or Export Data)

SAS Enterprise Guide facilitates very easy way to IMPORT/EXPORT Excel, Access or other text files and guided by wizards in each step.

The below example demonstrates importing a pipe delimited flat file; you will be able to format each variable as you move on to the next wizard step.

Helpful Tips: You always have an option to write code in programming window if you import a flat file with mixed input type or a more complex file layout.
REPORT OUTPUT OPTIONS

Navigational Tips: Tools Options - Results - Results General

Enterprise Guide is easy to use and give you access to generate list reports and summary tables using the TABULATE Procedure. You have the option to output your report as SAS Report, HTML, PDF, RTF or Text Formats as shown below:

LIST REPORTS

Navigational Tips: Task  ➔  Describe  ➔  List Data (or List Report Wizard)

You can follow an easy way to generate List Report by following the List Report Wizard option as shown below:

STYLE SHEET MANAGER

Navigational Tips: Tools  ➔  Style Manager (Press Edit to add new style sheet).

Enterprise Guide has nice feature to use built-in Style Sheets; below are some of the examples of the various style sheets. Using style sheet, it is easy to maintain a set of standard reports or graphs to meet your business standards.
You can customize the style sheet as needed. You can import image files (jpg, Bitmaps, jpeg) on the report or a graph and then you can add title and footnote.

**GRAPH OUTPUT**

**Navigational Tips: Tools ➤ Graphs**

Enterprise Guide has a very handy way to create a wide range of graphs as is shown in the dropdown list. Chart wizard will help to adjust axis, labels, colors and other plotting options. You can use your pre-defined style sheet to display standard graphs every time you follow the same layout.
MICROSOFT OFFICE ANALYTICS:

Navigational Tips: Open Excel ➔ SAS Data – Import SAS dataset on Excel Sheet

You can explore an easy way to share your data using Excel worksheets or pivot tables suing Microsoft Office Analytics; before using this facility, make sure that you have the SAS Add-In 5.1 for Microsoft Office in Excel Add-in options. You can automate your Excel report in such a way that whenever you change your data or run your program for a different timeframe, the data will automatically reflect the current data.

Step-1: Make sure SAS Microsoft Add-Inn

Step-2: Open Excel and import SAS dataset

Step-3: Select Worksheet or Pivot table

Step-4: Set Options to display results in Excel
STORED PROCESS

Current corporate technology is focusing more on web services to share data display across mobile devices. Enterprise Guide has an excellent feature called Stored Process option to store SAS Code on a central server (Store Process Repository). The SAS program can be deployed in a variety of clients such as SAS Add-In for Microsoft Office or web services.

SCHEDULING REPORTS:

Navigational Tips: File » Schedule Reports – Window Scheduler Options

Enterprise Guide has an easy way to schedule your report by choosing schedule report from file menu bar which automatically opens the windows scheduler. You can set project/program path and VB Script file will be generated in the path, then you can set password. In setting tab choose Wake the computer to run this task option. After completion of your report and ready to display and send this report to recipient, you can set Windows scheduler to invoke your project on timely manner. You have an option to link PROC REPORT program using XML tag sets and email program for complete automation (see appendix for details).

Helpful Tips: if you want to schedule all your reports on the server side, you need to have Management Council installed on SAS Enterprise Guide server. You can use LSF (Load Sharing Facility) to schedule to run all your programs on batch mode.

---

2 In appendix section you PROC REPORT using xml tag sets and email program is included, you can take advantage using code sample and link to the process flow for complete automation.
CONCLUSION

In this paper I have provided easy access controls using the Point and Click windows environment in Enterprise Guide 5.1 version. No matter whether you are an experienced SAS Programmer or just a beginner, you can certainly take advantage of Enterprise Guide 5.1 which is user friendly and a very flexible reporting and analytics environment to meet your organization goals.

REFERENCES


ACKNOWLEDGMENTS

I would like to acknowledge Tom Donia, VP Corporate Medical Economics, AmeriHealth Caritas, and Roy Oaks, Director, Corporate Medical Economics, AmeriHealth Caritas for their support and encouragement.

I would like to acknowledge J. Daniel Knapp, Senior Manager, PerformRx for assistance with proof reading and editing.

AmeriHealth Caritas is the nation’s leader in the health care solutions with more than 30 years of experience managing care for individuals and families in publicly funded program.

CONTACT INFORMATION

Your comments and questions are valued and encouraged. Contact the author:

Anjan Matlapudi
Corporate Medical Informatics
AmeriHealth Caritas Family of Companies
3rd Floor, 200 Stevens Drive, Philadelphia, PA 19113.
E-mail: amatlapudi@amerihealthCaritas.com or anjanmat@gmail.com

SAS and all other SAS institute Inc. product or service names are registered trademarks or trademarks of SAS Institute Inc. in the USA and other countries. ® Indicates USA registration.

Other brands and product names are trademarks of their respective companies.
**APPENDIX - PROGRAMS**

***************************************************************************/
* PROC REPORT Using XML Tagsets
***************************************************************************/
style=Printer;
*** tagset options ---**;
ods tagsets.ExcelXP options(embedded_titles='yes'
embedded_footnotes='yes'
print_header = '&C&A&RPage &P of &N'
print_footer = '&Printed &D at &T'
autofilter = '1-2'
suppress_bylines='yes'
sheet_interval='bygroup' sheet_Name="Car Report"
width_points='1' width_fudge='1'
absolute_column_width='143,110,36,58.5,58.5,57.75'
frozen_headers='yes'
autofit_height='yes');
title justify=left "Proc Report using XML Tagsets";
proc report data= SASHELP.cars  nowd  split='#'
style(report)=
[borderwidth=
0.2
asis=off
frame       = HSIDES
rules       = groups
cellpadding = 1.0
cellspacing = 1.0]
style(header)=[background=Silver bordercolor=#FF8080
font = Fonts('headingFont')]
;
columns Make Model Type Invoice ;
define Make/'Car Brand'      style()={just=left cellwidth=1.0 in};
define Model/'Car Model'      style()={just=left cellwidth=2.0 in};
define Type/'Type'         style()={just= left cellwidth=0.7 in};
define Invoice/'Price'        style()={just=right cellwidth=1.0 in};
format Invoice dollar12.2 ;
compute Make;
* Placeholder for row alternat color highlighting;
RowNum+1;
if (mod(RowNum, 2) ne 0)
then call define(_row_, 'style', 'style=[background=#FFFFCC]');
endcomp;
run;
ods rtf close;
ods tagsets.ExcelXP close;
quit;
***************************************************************************/
* Program for Email Option in SAS Enterprise Guide 5.1 V
***************************************************************************/
FILENAME myemail EMAIL from="amatlapudi@amerihealthcaritas.com"
to="amatlapudi@amerihealthcaritas.com"
TYPE = "TEXT/HTML"
SUBJECT = "Global SAS Report";
data _null_;
file myemail;
put '<html><head>';
Hello Attendees,

Report is completed.

You can access this report by clicking the following hyperlink:

<a href="C:\Global SAS 2014">XML Tagset Report (Please Change the extinction from .xls to xlsx)</a>

Thank you and have a Nice day!

Anjan Matlapudi