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ABSTRACT

“No way. Not gonna happen. | am a real SAS® programmer.” (Spoken by a Real SAS Programmer.) SAS® Enterprise
Guide® sometimes gets a bad rap. It was originally promoted as a code generator for non-programmers. The truth is,
however, that SAS Enterprise Guide has always allowed programmers to write their own code. In addition, it offers
many features that are not included in PC SAS®.

INTRODUCTION

There are many papers on the many features of SAS Enterprise Guide, but many do not focus on writing SAS code.
Experienced SAS Programmers often think that SAS Enterprise Guide is only for people who do not know how to code.
This paper describes ten features of interest to people who like to write code but have not used SAS Enterprise Guide.

1. WRITING CODE

SAS Enterprise Guide makes it quick and easy to write code: File > New > Program:
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Display 1. New SAS program

You can also click the New icon =N and select Program.

A blank Program tab opens. Start typing SAS code as usual.

Go to Program > Editor Options... to customize settings.



2. RUNNING SHORTCUTS

SAS Enterprise Guide includes many shortcuts specifically for programmers. Some of those shortcuts include:

Shortcut Action Function Key Action
Ctrl+/ Comment line F3 or F8 Run program (or selection)
Ctrl+Shift+F Display formats F1 Help

Ctrl+Shift+l Display informats

Ctrl+Shift+F1 | Display functions

Ctrl+Shift+F2 | Display macro functions

Ctrl+L Display libraries

Table 2. Select keyboard shortcuts and function keys

Go to Program > Enhanced Editor Keys... to see all shortcuts.

SAS Enterprise Guide also lets you define your own shortcuts via keyboard macros. You can write them from scratch:
Program > Editor Macros > Macros > Create... Highlight any item in the Commands box and click the arrow to add.

It can be easier to use the macro record feature to see how things work: Program > Editor Macros > Record New.
Perform any desired actions and then turn off macro recording with Program > Editor Macros > Stop Recording.

You are prompted for a keyboard macro name and macro description (optional). You can also assign a shortcut to
run the keyboard macro. Go to Program > Editor Macros > Macros > Edit... to view or modify a keyboard macro.

Create keyboard macros for your common editing tasks. For example, to delete a line, repeat a line, or select a step.

3. USING VISUALS

SAS Enterprise Guide includes visual cues that are useful to coders. In the Program tab, for example:

l &) Progam |_l Log [ £ Output Data)

e Save = b Run = Stop | Selected Server: Local (Connected) = % | Analyze Program = | Export ~ Send To - Create = Qm»mm

*1. No WARNING or ERROR;

-data temp;
set sashelp.class;
where sex='F';

run;
*2. WARNING;

porc print data=temp;

var age;

title '"PRINT of Females';
run;

#] Program* = not saved
#] Program = saved
&) Program = WARNING

.ﬂ Program = ERROR

Display 3. Program tab

Use visuals for instant information—but you should still always inspect your SAS Log carefully!



4. VIEWING DATA SETS
SAS Enterprise Guide makes it easy to view SAS data sets. Click on the Output Data tab:

| [%] Program* | = Log| Bl OutputData |

9 | €1 Filter and Sort B Query Builder

Data -~ Describe ~ Graph -~ Analyze -

Export - Send To ~

L Name L7, Sex iz Age iz Height Weight
1 |Alfred M 14 69 1125
2 |Alice F 13 56.5 a4
3 |Barbara F 13 65.3 98
4 |Carol F 14 62.8 1025
5 |Henry M 14 63.5 102.5
6 |James M 12 57.3 83
7 |Jane F 12 55.8 345
8 |Janet F 15 625 1125
9 |Jeffrey M 13 62.5 84
10 |John M 12 59 %95
11 |Joyce F 1 51.3 50.5
12 [Judy F 14 64.3 80
13 |Louise F 12 56.3 77
14 (Mary F 15 66.5 112
15 |Philip M 16 72 150
16 |Robert M 12 64.8 128
17 |Ronald M 15 67 133
18 | Thomas M 11 575 85
19 | William M 15 66.5 12

Display 4a. Output Data tab

£ indicates a character variable

i@ indicates a numeric variable

[&] indicates a date variable (any variable with a SAS date format assigned)

Roll over any column header to display the variable type, length, and label.

(You can view any SAS data set in any library from the Server List window displayed on the lower left by default. Click

on Servers, the server name (or Local for PC SAS), then Libraries, any library, and double-click on any SAS data set.)

Click the Properties icon [ on the upper right and General, Columns, Advanced, and Summary to display metadata.
No PROC CONTENTS required:

-

Eﬂ Properties for TEMP

|

General Columns

Advanced

Summary Name
Name
Sex
Age
Height
Weight

Type
Character
Character
Numeric
Numeric
Numeric

Display 4b. Data set properties
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5. GETTING HELP

SAS Enterprise Guide makes it simple to get help. Roll the mouse over any keyword (e.g., SET) and pause:

[#) Program* ||§] Logl,ﬁgﬁ| OutputData|
Save - F Run - [ Stop | Selected Server: Local (Connected) ~ % | Analyze
-ldata temp;
set sashelp.class;

Keyword: SET

Context: [DATA STEP] SET statement

Syntax: SET <SAS-data-set(s) <(data-set-options(s) }>> <options>;
Reads an observation from one or more SAS data sets.

Search: The Product Documentation. Samples & SAS Notes, Papers

Display 5. Help and hyperlinks

Click on any of the hyperlinks for more information:
The first hyperlink (SET) searches support.sas.com

The Product Documentation searches online documentation

Samples & SAS Notes searches sample code and SAS Notes

Papers searches technical papers and conference proceedings

6. USING AUTOCOMPLETE

SAS Enterprise Guide suggests ways to complete keywords as you type. It also suggests options, librefs, data set
names, variables, and macro variables:

(i) MAPS [[] Aacomp

(i) MAPSGFK [7] ADOMsG

(i) MAPSSAS |7 ADSMSG

(i) SASHELP |5 AFmsG

(i) SASUSER [ AR

[[“] temp [["] APPLIANCESERIES
(i) WORK |73 AsSCMGR

[[] BuT
Sdata temp; [ BUY
set libref.filename;

where sex='F"';
run;

-proc print data=libref.filename;
title 'PRINT of Females in SASHELP.CLASS';
run;

-proc means data=libref.filename;
var variable[s];

title 's ary statistics on Females';
run;

b Age

Wb Height

2 Weight

Display 6a. Autcomplete suggestions

Accept a suggestion by typing the Space, Enter, or Tab key or specific symbols. (See Display 6c.)



Alternately, keep typing to ignore suggestions.
Autocomplete also walks you through function arguments step by step and displays context-specific options:

sidata temp2;

set sashelp.class;

first_initial=substr(
4 1of 2w SUBSTR(string, position <, length>)
string:

Specifies a character constant, variable, or expression.

©proc freq data=temp —————)  § COMPRESS

tables age*sex/ (¥ FORMCHAR(1.2.7)=
' FORMCHAR=
i NLEVELS =— PROC FREQ statement options
i NOPRINT
' ORDER=
' PAGE
& AGREE o
oF ALL £
(' ALPHA=
# BDT
#' BINOMIAL ~— TABLES statement options
£F BINOMIALC
(¥ CELLCHI2
¥ CHISG
P CL -

Display 6b. Function help, PROC options, and statement options

Customize settings with Program > Editor Options... > Autocomplete tab:

r
Enhanced Editor Options - - u

| General | Appearance |} Autocomplete | indenter |

Enable Autocomplete

Autocomplete on: | Second character -

Commit a selection when typing any of these symbols
il
Add spaces when committing with these symbols:

S Y

] add spaces when committing value4ype options (j.e. options ending with "=")
Commit selection when pressing the SPACEBAR key
Commit selection when pressing the ENTER or TAB key

Autocomplete these Keywords

Global statements Macro vanables
Procedure options Macro definitions
Procedure statements Macro Statements

DATA step statements ] Automatic macro varables
Librefs and SAS data ssts | ARM macros

SAS Colors
545 colorfomat:

Integrated Syntax Help

Search Engine:

L

Display 6c. Autocomplete settings



You can try using Autocomplete on Third character via the drop-down or turn off autocomplete for types of Keywords
by unchecking specific boxes.

Recommendation: give Autocomplete a try. It is easy to ignore when you do not need it but invaluable for reminders.
Note that you can roll over suggestions (e.g., PROC options) to get additional help.

7. FORMATTING RESULTS

SAS Enterprise can produce results in different formats: Tools > Options... > Results General:

e B
Options ﬁ
General Results > Results General
Project Views
Project Recoveny
Results Result Formats
Results General [7] SAS Report [C]HTML [C]eDF
Yiewer
SAS Report [EIRTE Text output
HTML Default: Text output
RTF
PDF Managing Results
Graph
Stored Process Replace results: ’F{eplace without prompting -

Display 7a. Result Formats

The default result format is SAS Report. Check one or more boxes; SAS “publishes” the results to each destination:

&] Program [ [Z] Log [ 573 Output Data | ) Resuts - SAS Report | £ Resuts - HTML | ) Resuts - PDF | ) Resuts - RTF | [} Resuts - Listing|
&l Save » b Run v 11 Stop | Selected Server: Local (Connected) ~ % | Analyze Program ~ | Export + Send To v Create ~ Properties
-idata temp;
set sashelp.class;
where sex='F';
run;

*Turn on SAS Report, HTML, PDF, RTF, and Text output;
-proc print data=temp;

title 'PRINT of Females';

run;

PRINT of F I PRINT of Females JPRINT of Females
PRINT of Females | PRINTofFemales |  pr/n7 of Females )
Obs Name
Obs/Name |Sex|Ag| ©bs Name Sex Ag\ [GETSime [Sex|age | .Obs|Name |Sex|Age
1 Alice F 1 1 Alice F 1 8l stice |F T 1| Alice F 13 i T
2 Barbara F 1 2 Barbara F 1 . [— l.’"‘ 2|Barbana | F 13 > Bathari
3/Carol Y[ 3l |F A 3fcal |F | 14 Cacl |F | U4
. 3 [of 1
4) F 1 4 Jane F 1 4| Jane F 12 are
ane ! 4| Jane F 12 4 Jane
5 Janet F 1 5 Janet F 1 8|janet |F 13 5|Janet |(F 15 5 Janet
6 Joyce F 1] 6 Joyce F 1 6|ioyce |F | 11 6|Joyee [F | 11 6 Joyce
7Judy F B 7y F1 7|may |F | 14 7|dy |F | 14 7 Judy
8 Louise F 1| 8 Louise F 1 8| Louise [F 12 8| Louise |F 12 8 Louise
9 Mary F 1 9 Mary F 1 9|Mary |[F 15 9[Mary |F 15 S Mary

Display 7b. Multiple Result Formats

Choose a style with Tools > Style Manager... (optional).

There is a separate tab for each result format. Note that producing results as Text output is usually the fastest. More
than one result format can be checked, but it takes time to publish to multiple destinations.

Output will be sent to all open destinations. You can programatically save respective output to specific destinations or
write to external files with ODS destination statements.



8. STORING EVERYTHING
SAS Enterprise Guide saves the Program, Log, and Results as a single file: File > Save Project As...:

@ SAS Enterprise Guide - For Coders Only - The Enterprise Guide Experience.egp —

File Edit View Tasks Program Tools Help |E-&- 8|4 o 03 B X |8 o [~ |Eeg Process Flow

|Broject Tree ISR demos - store everything -

Elgqg Process Flow [#] Program® ||~§"| Log | ) Results|
=3 Pragrams

_____ & demo 1- standard shortcuts Save = B Run - [ Stop | Selected Server: Local - % | Analyze Program - |
----- [#] demo 2 - custom shortcuts = ha'l;a temp;

----- [#] demo 3 - use visuals .

----- [#] demo 4 - view data sets set sashelp.class;

----- [#] demo 5- gethelp where sex='F"';

----- [#] demo 6 - autocomplete .

----- [#] demo 7 - output formats run;

----- @ demo 8 - store everything

@@v| | » Computer » OS(C) » Files » SAS Global Forum » 2014 - | +y | | Search 2014
Organize ~ Include in library Share with = Bum New folder =E
-~
4% Favorites l; Name Date modified Type
M Desktop # For Coders Only - The Enterprise Guide Experience.egp  2/19/2014 11:04 PM  SAS Enterprise Guide Project

Display 8. Saving a project

Alternately, click the Save Project button G to save the current project.

Everything except SAS data sets is saved in a single Enterprise Guide Project (.EGP) file. Temporary data sets
are available during the SAS Enterprise Guide session but deleted when it is closed. Permanent data sets are
stored outside of the project file in the location specifed in your code.

9. RUNNING “BATCH”

SAS Enterprise Guide can store multiple Program, Log, and Results in a single Enterprise Guide Project file.

Click on a Program in the Project Tree window (displayed on the upper left by default) to view any given set
of Program, Log, and Results.

Storing mutiple programs in a single Enterprise Guide Project file allows you to organize a series of related
programs to run in a specific sequence. You can run individual programs, especially while they are still being
debugged, and then run the entire project (i.e., all programs) with File > Run project name:

SAS Enterprise Guide - For Coders Only - The Enterprise Guide Experient

File | Edit View Tasks Program Tools Help |8-&- @/

B New 3
= Open 3
SAS Enterprise Guide - For Coders Only - The Enterprise Guide Experience.egp Close Project

File Edit View Tasks ngram Tools Help |E' ﬁ" % | é of By IE G Save For Coders Only - The Enterprise Guide Experience  Ctrl+S
=

Save For Coders Only - The Enterprise Guide Experience As..

Save demo 9 - run batch Ctrl+5Shift+5

Save demo 9 - run batch As...
ngg Process Flow [#] Program ] Log
=-[3J Programs ) & Import Data

[#) demo 1- standard shortcuts Save - B Run ~ @ Stop | Selected Server: [ RunFor Coders Only - The Enterprise Guide Experience
IQ demo 2 - custom shortcuts |‘k demo 9: Schedule For Coders Only - The Enterprise Guide Experience

@, demo 3 - use visuals . L Export 3
IQ demo 4 - view data sets Run programs individu Send To »

. . 5 op

& demo 5 -gethelp File > Run [project (| ™o
Ig demo 6 - autocomplete [fy Page Setup for demo 9 - run batch...
.[#] demo 7 - output formats Print Preview for demo 9 - run batch
--[#] demo 8 - store everything &, Print demo 9 - run batch... Ctrl+P
@ dema 3 - run batch Project Properties

Ig demao 10 use tasks Recent Projects »

Recent Programs v

Display 9. Running multiple programs



10. USING TASKS

SAS Enterprise Guide includes tasks that generate code. While SAS programmers prefer to write their own code,
tasks are useful to explore new or infrequently used procedures step by step. For example: Tasks > Describe >
Summary Tables Wizard...:

{] Ssummary Tables for Local:WORK.TEMP - ﬁ

3 of6 Select classification variables §Sas

[ Columns: Add Preview:
Age | Height | Weight
{Optional) Sum | Sum Sum
Click Add to insert & column variable. 999 999 999
X Sex 999 999 999
[ Rows: Add Total 999 999 999
4 Sex

Pages: Add ()
(Optional

I | <Back || Neww || Enmsh || cancel || Hep

S

Display 10a. Summary Tables wizard

Note that the wizard supplies a helpful preview of what the table will look like. When finished, click the Code tab:

- PROC TABULATE
DATA=WORK.TEMP

VAR Age Height Weight;

CLASS Sex / ORDER=UNFORMATTED MISSING;
TABLE

/* ROW Statement */

Sex

all = 'Total"' ,

/* COLUMN Statement */
(Age * Sum={LABEL="Sum"} Height * Sum={LABEL="Sum"} Weight * Sum={LABEL="Sum"} )

RUN; QUIT;
TITLE; FOOTNOTE;

Display 10b. Generated code

SAS Enterprise Guide generates documented code that can be used as-is or edited as needed. You are still a coder!



CONCLUSION

SAS Enterprise Guide helps SAS programmers write, save, run, and organize SAS programs. Check it out, try it
out, and see which features are most helpful to you.

CONTACT INFORMATION

Your comments and questions are valued and encouraged. Contact the author at:

Christopher J. Bost

MDRC

16 East 34™ Street

New York, NY 10016

(212) 340-8613
christopher.bost@mdrc.org
chrisbost@gmail.com
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