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For All the Hats You Wear: SAS® Enterprise Guide® Has Got You Covered 
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ABSTRACT  

Are you new to SAS® and trying to figure out where to begin? Are you a SAS programmer already comfortable with 
code but unsure about new tools? Are you a statistician seeking to apply your techniques in a new way? Are you a 
data manager just trying to get your data in shape? Perhaps you are a Jack (or Jill) of all trades trying to manage 
work in the simplest way possible. Regardless of your background, SAS® Enterprise Guide® is full of features and 
techniques to help you achieve your objective. In this paper, we show how you can turn SAS Enterprise Guide into 
your tool to get work done without conforming to an entirely new way of working just to become productive. 

INTRODUCTION 

Just as there is no "typical SAS user," there is no such thing as a "typical SAS Enterprise Guide user." 

SAS Enterprise Guide is used by people in all types of job roles (with all levels of expertise) to accomplish all sorts of 
work.  In this paper, we will focus on the following discrete roles. However, the chances are good that any SAS user 
that you select out of a crowd will fall somewhere in-between: 

 The Newbie 

 The Business Analyst 

 The Programmer 

 The Statistician 

 The Data Scientist 

 The Administrator 

 The Consultant 

THE NEWBIE 

Traditionally, if you wanted to "learn SAS" (for your job, academic class, or for fun), you had to "learn how to program 
in SAS."  While the SAS programming language remains the most flexible method for bending SAS to your will, you 
no longer have to learn how to program in order to become productive. 

SAS Enterprise Guide offers the ability to accomplish hundreds of common tasks without requiring you to write any 
code or even to understand very many of the SAS related nuances, such as formats, the Output Delivery System 
(ODS), procedures, and the DATA step. 

A person who is new to SAS can become productive quickly with these few tasks. 

Import Data (File menu) – a wizard interface that makes it easy to import a Microsoft Excel spreadsheet or comma-

separated values (CSV) file.  When you point the Import Data task toward an XLS, XLSX, or CSV file, the task does a 
good job of detecting data characteristics, such as column types.  Often you will be able to just click Finish without 

selecting any additional options.  If your data is formatted in a nonstandard way, the wizard provides all of the tools 
you need to modify the results. 

Filter and Sort (Tasks->Data menu) – a simple filter tool that allows you to select columns, apply one or more filters 

to narrow the results, and sort the result.  It is a more approachable user interface than the full-on Query Builder, 
which all users will encounter eventually but might not need right away. 

List Report (Tasks->Describe menu) – a wizard that makes  reports simple but provides enough flexibility for 

custom column layouts, totals and subtotals, and more. 

Bar Chart, Scatter Plot, Line Plot (Tasks->Graph menu) – these basic graph tasks provide a "wizard" view for 

getting started but can be later used with an "advanced" view to access more options. 

Report builder (File->New Report menu) – each task you run produces a result, and the Report Builder allows you 

to assemble those parts into a combined report. 

Aside from formal instructor-led training, one of the best ways for a new user to get started is to follow the Getting 
Started tutorial (accessible from the SAS Enterprise Guide Help menu).  The tutorial covers the basics of importing 

data, applying filters, and creating basic reports and graphs. 
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THE BUSINESS ANALYST 

In the business world, it sometimes seems that spreadsheets are the currency by which information is exchanged.  If 
that is true, then SAS is the "gold" standard that analysts use to keep that information in good standing. 

An effective business analyst: 

 understands the questions that the organization asks 

 knows which of those questions can be answered by data in the enterprise (and similarly, which questions 
cannot) 

 crafts a report that both answers the questions and communicates meaning to the stakeholders 

 establishes a process to "operationalize" these reports as appropriate 
 

A business analyst can "harvest" data from spreadsheets and ultimately deliver results using spreadsheets, but along 
the way, the business analyst must maintain the integrity of the data and its meaning. 

In addition to the basic tools used by The Newbie, a business analyst might spend more time exploring the data to 
determine what it might reveal.  The tools for this include: 

Characterize Data (Tasks->Describe menu) – provides some quick metrics on the contents of a data source, 

including frequency counts, date ranges, and summary statistics.  The results can reveal important knowledge about 
the data columns, such as how many records contain missing values.  The information you find will help in the next 
step of the analysis. 

Scatter Plot Matrix (Tasks->Graph menu) – by plotting all of the numerical variables against each other in one 

matrix, you can quickly see which variables might have a direct relationship.  In the SAS vernacular, this approach is 
sometimes called "PROC EYEBALL" – a technique that provides at-a-glance insight.  (It is not an actual SAS 
procedure!) 

Query Builder (Tasks->Data menu) – the big brother of the Filter and Sort task, this tool provides a one-stop shop 

for data filtering, joining, and manipulation via calculate columns and grouping.  The Query Builder uses SQL under 
the covers, an approach that is familiar to any professional who works with databases. 

The project metaphor in SAS Enterprise Guide allows an analyst to organize work for effective reuse.  With careful 
organization and documentation, it is easy for a business analyst to go back and answer the question "How did you 
arrive at these results?"  The project file is the recipe, while the data serves as the main ingredient. 

 

Figure 1. A Project That Shows a Business Analyst at Work 

THE PROGRAMMER 

Experienced SAS programmers can become very productive in SAS Enterprise Guide.  However, many programmers 
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face these common challenges as they get started: 

 SAS Enterprise Guide is a different interface from traditional SAS (often called Display Manager or simply "Base 
SAS"). Many professionals who have used SAS for years can stumble in their productivity as they adopt a new 
interface.  User-interface specialists call this negative transfer of learning.  That is, it is actually more difficult to 
get work done in SAS Enterprise Guide because you already knew how to do   the work in traditional SAS, and 
your prior knowledge of what keys to press and where to click is not of much help (and might be a hindrance!). 

 When an experienced SAS programmer first "makes the switch" to SAS Enterprise Guide, it is often because the 
SAS environment has been rearranged to support central management of a SAS server (instead of having a 
copy of "PC SAS" on each desktop machine).  This change in the SAS environment presents not only a change 
in the UI but a change in "geography."  Instead of all data, programs, and results residing on each user's PC, 
these "assets" are now distributed throughout the computing environment.  Figure 2 shows the new layout, with 
the dotted vertical line representing a network layer. 

 

Figure 2. The New Topology of a SAS Programmer with SAS Enterprise Guide 

The SAS Enterprise Guide application runs locally on your desktop. The SAS Workspace session (which 
accesses data and cranks through your analysis) runs on a remote machine. If you are accustomed to "PC SAS" 
running  on your local machine, you might be forced to rethink a few of your processes. 

The secret to becoming a happy programmer in SAS Enterprise Guide is to allow enough time and attention for the 
transition.  Through formal training or self-paced learning, the experienced programmer (let us not use the term "old 
dog") can revise work routines and perhaps even make some improvements along the way. 

On the bright side, SAS Enterprise Guide has some exclusive advantages for programmers: 

 The Program Editor is "syntax aware" and has autocomplete for most SAS keywords.  It also has  tooltips that 
can, in many cases, replace the need to go to a separate syntax reference for documentation. 

 When you do need more reference help, the SAS OnlineDoc is just a click away as part of the built-in reference 
tips (starting in SAS Enterprise Guide 5.1 and later). 
 

 
 
 

 The Program Editor has a "code tidy" feature that can indent your program statements and break up complex 
program lines into easy-to-read segments.  With a keystroke (Ctrl+I), your program becomes easier to read 
without changing any of the programming logic or data. 
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 The SAS Enterprise Guide project and process flow metaphor provides a convenient way to organize multiple 
programs into a logical sequence.  You can still save your programs to the file system for use by other tools, while 
SAS Enterprise Guide makes it easier to maintain your work. 

 

 

Figure 3. A Project That Shows Which Programs Will Run in What Order 

THE STATISTICIAN 

A trained statistician is usually accustomed to writing program code to get answers, but that does not mean that all 
statisticians enjoy programming as an activity.  SAS Enterprise Guide offers dozens of built-in tasks that compute 
basic and advanced statistics.  If you need to calculate the mean, sum, standard deviation, or frequency count for a 
variable, you will find it pretty easy to accomplish in SAS Enterprise Guide. The corresponding tasks in the menus 
have names like "Summary Statistics" or "One-way Frequencies."  

But sometimes your needs are a little more "exotic," and you cannot immediately find what you need from the menus.  
In that case, here are the four steps to find the statistics you need within SAS Enterprise Guide. 

Step 1. Find out how SAS supports the statistic 

One of the most popular SAS notes on support.sas.com is SAS Note 30333: "FAStats: Frequently asked-for 
statistics This note lists statistical terms from "Alpha" to "Zero-inflated models." Most entries include a reference to a 
SAS procedure and option that can be used to calculate the statistic. Some entries provide links to more 
documentation to help you with the approach and even to more information about the theories behind the statistic. 

Step 2. Find out whether SAS Enterprise Guide has a corresponding task 

After you learn the name of the SAS procedure that you might use to calculate the statistic, you need to find out 
whether SAS Enterprise Guide has a task that supports that procedure. You can find a list of SAS tasks and 
associated procedures on support.sas.com. 

Or, you can simply look in the task list within SAS Enterprise Guide. Select View->Task List, and then change the 

view to show the Tasks by Name. This view shows a list of all of the tasks and their associated SAS procedures. You 
can sort the list by clicking on the SAS Procedure column heading, which will make it easier to find whether the 
procedure that you need is listed. 

Step 3. Explore the task to find the exact option to check 

If you have identified a SAS procedure and a SAS Enterprise Guide task that supports it, then the next step is to find 
the exact option in the task that triggers the statistic. 

For example, let us assume you are looking to calculate odds ratios using the Wald method. The FASTats note points 
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you to a number of SAS procedures, including PROC LOGISTIC and the CLODDS= option. The SAS Enterprise Guide 

task list shows that LOGISTIC is supported by (surprise!) the Logistic Regression task. If you open the Logistic 
Regression task and hunt around for a bit, you will find the Wald option within the Conditional odds ratios grouping on 

the Model: Options page. 

Pro tip: The SAS Enterprise Guide help contains detailed listings of all of the supported options among all of the 
tasks. If you choose Help->SAS Enterprise Guide Help from the main menu and enter "Wald" in the Search tab, it 

will lead you right to the Logistic Regression task (as well as a few others). (Note that the index might not include the 
all of the option names for every task.) 

Step 4. If needed, find a programming example for the statistic 

SAS Enterprise Guide does not offer a task for every single SAS procedure, and the tasks do not support every 
single procedure option. But that does not mean that SAS Enterprise Guide does not support the statistic. It simply 
means that you might have to write a bit of code to get to it. 

In addition to the FASTats note (which will point you to the correct SAS language elements that you need for your 
program), the SAS samples collection might include an example of what you need. (If you cannot find the example 
you need, ask your peers in the SAS Statistical Procedures forum on communities.sas.com!) 

THE DATA SCIENTIST 

Recently, the term "Data Scientist" has enjoyed a surge of new use in our SAS-related lexicon.  I am including the 
term in this paper as a separate job role (to be trendy!), but I believe that a data scientist is actually a combination of 
a business analyst, statistician, and programmer.  Figure 4 shows an example of a rich process flow that contains a 
variety of content – something that a data scientist (or a savvy business analyst) might come up with. 

 

Figure 4. A Mix-and-match Approach to Gathering, Prepping, Analyzing, and Reporting 

A true data scientist might switch among different tools that support analytical disciplines, such as SAS® Enterprise 
Miner

TM
 for predictive analytics or SAS® Forecast Studio for forecasting.  SAS Enterprise Guide provides flexible 

access to data and to a programming environment that can complement the use of those tools. 

THE ADMINISTRATOR 

SAS Enterprise Guide is not the primary tool recommended for SAS administration; that is the job of SAS 
Management Console.  However, since SAS Enterprise Guide users are often the beneficiaries (or victims) of SAS 
administration, it is helpful for the SAS administrator to have access to SAS Enterprise Guide as well. 

In SAS Enterprise Guide, an administrator can see what the end users see.  You can test the behavior of SAS 
libraries. You can also verify the connections to the SAS Metadata Server and the SAS Workspace Servers.  In short, 
you can use SAS Enterprise Guide to confirm that the users you support are receiving a good and productivity-
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inducing experience. 

You can even perform some light maintenance tasks within the application.  For example, you can move SAS data 
sets into place by using Tasks->Data->Upload Data Files to Server.  You can register or update tables in SAS 
metadata libraries with Tools->Update Metadata Library.  The SAS Enterprise Guide Explorer tool (found in the 
Tools menu) can also provide a complete view of your SAS environment: servers, libraries, SAS Folders, stored 

processes, information maps, and more. 

 

Figure 5. SAS Enterprise Guide Explorer Provides a View into Your BI Environment 

THE CONSULTANT 

As with consultants in other technical disciplines, a SAS consultant is a "hired gun" – somebody who is brought in to 
solve a particular problem or to establish a process for a paying client.  In this situation, it is understood that the 
consultant is engaged for only a limited time. 

In addition to the expertise offered by the consultant, a customer is usually interested in what is going to happen 
when the consultant is no longer nearby.  How will the customer continue to leverage the work that the consultant has 
completed? 

SAS Enterprise Guide can be an excellent delivery platform for capturing expertise that the non-experts can use.  
Consultants can create reusable content that "bottles" the expertise they bring without requiring the same level of 
expertise from the end users who consume it later.  Here are a few examples of reusable content: 

SAS stored processes – a SAS program that is stored centrally and can be run "on demand" in SAS Enterprise 

Guide, the SAS Add-In for Microsoft Office, or other user-friendly UIs.  Stored processes can surface prompts, so that 
end users can run the same program for different scenarios without ever having to see (let alone modify) the SAS 
program statements.  SAS Enterprise Guide makes it easy to create and run stored processes. 

Projects and process flows – SAS Enterprise Guide allows you to organize your work in projects. Process flows 

within those projects can help others to understand what your work does and how it is assembled.  By leaving you a 
project that is well organized and annotated with notes for documentation, a consultant can provide greater visibility 
into the work than if you simply had a folder full of SAS programs. 

Custom tasks – perhaps the ultimate in customization, a consultant with the right skills can add new features to SAS 

Enterprise Guide as custom tasks.  A custom task can represent a process that is specific to an industry or to an 
organization, or a custom task might simply help with a SAS capability that is difficult to use without programming. 
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Figure 6. A Custom Task That Provides a Simple Method for a Common Operation 

CONCLUSION 

SAS Enterprise Guide is often called "the Swiss-army-knife" of SAS tools, because you can use it for a little bit of 
everything.  Regardless of your job role or task, if you need access to SAS technology, SAS Enterprise Guide can 
provide you with a gateway to the features that you need.  It's a tool that can be used by novices and experts alike, 
and it can help you on your journey towards greater productivity with your data and more proficiency with SAS. 

RECOMMENDED READING  

 The Little SAS
®
 Book for SAS Enterprise Guide

®
 4.2 by Susan Slaughter and Lora Delwiche. (SAS Press, 2010) 

Even though it is a few releases "old," the guidance in this book is still helpful for learning how to perform specific 
tasks for all job roles using SAS Enterprise Guide. 

 SAS
®
 For Dummies

®
, Second Edition by Chris Hemedinger and Stephen McDaniel. (Wiley and Sons, 2010) 

Really! This book provides an introduction to the world of SAS for all personas: data managers, report writers, 
and statisticians.  SAS Enterprise Guide is featured heavily in the book. 

 Building Business Intelligence Using SAS
®
: Content Development Examples by Tricia Aanderud and Angela 

Hall. (SAS Press, 2012) 
This book shows how you can use SAS Enterprise Guide -- and other tools -- to create relevant content for your 
entire organization. 
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