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ABSTRACT

SAS Enterprise Guide seem alien to you? Let's walk through the many SAS Enterprise Guide features using some
UFO sightings data. During the presentation, you will walk through some basics, learn how to change the advanced
options, and explore some newer features of SAS Enterprise Guide.

INTRODUCTION

If you just started using SAS Enterprise Guide or have been using it for a while, you might suspect the tool is a gift
from the aliens. This paper uses UFO sightings collected on the National UFO Reporting Center web site to show you
how to use the basic and hidden features of the tool.

UNDERSTANDING THE WINDOW LAYOUT

SAS Enterprise Guide uses a project to organize your work. The project shown in Figure 1 has data from the UFO
library called FULL_MOON_PHASES and one program that contains SAS Code. The application has three areas to
control your work:
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Figure 1. Window Overview of a Project

IMPORTING DATA INTO SAS ENTERPRISE GUIDE

The National UFO Reporting Center (http://www.ufocenter.com) allows you to report any UFO sightings. When
reporting the sighting, you list when, where, the shape, duration of encounter, and then a summary of the event. The
data was downloaded into a Microsoft Excel spreadsheet that you can import into SAS Enterprise Guide.

NUFOER.C Home

Date / . .

City State Shape Duration Summary Post

Time
5/7/12  Milwaukee WI Diamond approx 5mins Strange bright light which suddenly appeared in  5/13/
22:40 the south western sky over lake michigan..near

milwaukee. Semblance of lights of a plan

4/28/12  Algoma WI  Unknown 1 minute 4 brightly lit crafts traveling at different speeds, 5/13/
21:55 low elavation, with no sound present.

Figure 2. UFO Data Example
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Use the Import DataTask

You can import spreadsheet data into SAS Enterprise Guide easily. Use the File > Import Data to import Excel, CSV,
or other text files. A task, which is similar to the wizards found in other products, guides you through the four-step
process and the result appears in the Process Flow area, as shown in the following figure. You can rerun the task at
any time if the spreadsheet data changes.

If you are not satisfied with the results, click the Modify Task button above the dataset to make changes.

[
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Figure 3. Using the Import Data Task

EXPLORE NEW DATA QUICKLY

Once you have imported the spreadsheet data into SAS Enterprise Guide — you can review the data easily using the
Characterize Data task. From the Process Flow area, select Describe > Characterize Data. From the Characterize
Data task accept the defaults and select Finish to see the results. The results appear in the Process Flow area and
include summaries, graphs, and frequencies for all variables.
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Figure 4. Using the Characterize Data Task
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ADD DETAILS OR REMINDERS WITH THE NOTES FEATURE

Use Notes to add any information about the program or task results. Select File > New > Note to insert a note. In the
following figure, you can see a Note in the project tree and its content in the process flow area. Notes can have
reminders for how data is setup, information for other programmers, or just a quick place to keep a reminder.

Double-click the Note (or other objects) in the Project Tree to rename it.

SAS Enterprise Guide - EG_25_Tips_Presentation.egp
File Edit View Tasks Program Tools Help |8~ 5~ @ | & o= 0y (% X | 5 o |7+ |8egProcess Flow ~

Note ~

38?.‘? Process Flow Export » Send To ~ | [&5] Properties
E} FULL_MOON_PHASES
D gj UFO_DATA_4_IMPORT x
5 g3 Import Data (UFO _4_IMPORT xisx
B Ea Data Imported froi _DATA_4_IMPORTx
i o ’ ata

Data includes international sightings since 1921.
City variable has too many mis-spellings to be useful.

Data owner specified ones that appeared to be a hoax.

E) [__I Programs
[ﬂ Step 1 - Import Data

Figure 5. Add Notes to the Project

USE MULTIPLE PROCESS FLOWS TO ORGANIZE YOUR CODE

You can add as many programs as you want. Programs are listed in the Programs folder in the Project Tree.

e To open an existing program, select File > Open > Program. When a program is opened it is considered
referenced since it is stored outside of SAS Enterprise Guide.

e To add a program where you can place your code, select File > New > Program. This is an embedded program
because it is saved within SAS Enterprise Guide. You can avoid the point-and-click environment this way.

You can have more than one process flow, which allows you to organize the programs into separate areas. Select
File > New > Process Flow to add more process flows. InFigure 6, you can see three different process flows that
use a combination of embedded programs and referenced programs. The reference programs have a small arrow in
the left corner of the icon.

P

98‘28"“'”“ Data (@@ B U:-- tz2n5c5 Documents Wiy SAS Fies93\UF0 Anolysi
------ Ezi FULL MOON PHASE Include in library » Share with v New folder
- UFO_DATA_4_IMPO
EJEEE Data Imported from UF
EJ[:j Programs
[Eﬁ Step 1 - Import Data
E] 8\,3 Explore Data
--r |_| Programs

Organize v

|# Step 1 - Import Data.sas

@-Qv! 4 » Network » CHARLESTON » raw_data

S @ Step 2 Rewew Data Organize v Include in library v New folder
8% Hello World.sas ] all.xlsx
[E] Other SAS ng’ams a SAS File @‘u Microsoft Excel Worksheet
108 bytes 163 MB

B- [_| Programs
..... %) Hello World
...[#&] Macro Code - Check Log

Figure 6. Use Multiple Process Flows
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LET SAS DO THE HEAVY LIFTING

Many programmers do not realize that you can use a combination of tasks and coding to accomplish results quickly.
SAS Enterprise Guide has many ways to make the coding process easier. In this example, use the Query Builder to
start the code and then copy that code into your program.

QUERY BUILDER WRITES YOUR SQL CODE

When you have a large dataset with many variables or tricky variable names use the Query Builder to write the code,
which you can access by right-clicking the dataset name and select Query Builder. Query Builder allows you to join
tables, filter data, and sort data. The tasks outputs SQL code, so anything possible with SQL can be done.

In the Query Builder window, drag the variables names to the Select Data pane and click Run to see the results.

R

£34 Query Builder for LocakWORK.UFO_DATA_4 IMPORT

Queryname: Query Builder Output name: WORKQUERY_FOR_UFO_DATA 4|
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Figure 7. Use Query Builder to Write Your Code

From the Query Builder Code process flow, cut and paste the code into your program and make any changes, as
shown in Figure 8. You can change the output dataset, add new variables, or change the existing variables.

¢

Query Builder ~

[ E3 input Data | (=) Code |[Z] Log | &3 Output Data 3 j
[&] Modify Task | Export v Send To v Create ~ Properties
1i %_eg_conditional_dropds(WORK.QUERY_FOR_UF .}
i [ Save v - Run ~ 11 Stop | Selected Server: Local ~ % | Analyze Program ~ Expo(
3 -PROC SGL: 1/ LIBNAME UFO BASE "C:\data\UFO_STUDY" ;
4 CREATE TABLE WORK.QUERY_FOR_UFO_DATA 4 2
5 SELECT t1.statecode, 3 =PROC SQL;
6 t1.shape, | - CREATE TABLE }JFO.UFO_SIGHTSI AS
7 t1.dt_witness, 5 SELECT DISTINCT
8 t1.duration 6 upcase(t1.statecode) as Statecode,
9 FROM UFO.UFO_DATA 4_I L propcase(t1.shape) as Shape,
- T Once the code is in your t1.summary
10 WHERE t1.summary NOT program, you can add Pl
11 ORDER BY t1.statecode, new variables, change t .dt_Wltl:\eSS :
40, the current ones, rename Year(dt_witness) as Year,

the dataset, and so on! intnx('month', dt_witness, 0) as Mont

. DAY (dt_witness) as DayofMonth, >

To run the code use Program > Run or F8 to run the code. You can also select sections of the code and use F8 to
run only the needed areas.

Shortcut! Type Ctrl+ / to comment code and Ctrl+Shift+/ to uncomment the code.

Figure 8. Copy code from the task to prevent typing
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Auto Complete Helps You Remember

Starting with SAS Enterprise Guide 4.3, SAS introduced the auto complete feature. With AutoComplete, SAS
suggests the next coding statement, such as libraries and dataset names.

This feature is particularly useful when 1! %let name = Jane;

working with macros. It has all of the 2! wmlet day = 3:

macro and macro variables available. 3 smlet month = DEG:

Notice in Figure 9 when you type &m, the 4

tool lists all macro variables. Likewise 5iz%macro test_it:

when you type &t , the tool lists all 6 proc print data=temp;
macros, including the one just created. 7 where month F &mf
When you are working with huge o P & day
programs, this feature helps you 9; %mend; & month
remember the exact names to ensure 10 b=t & name
accuracy and saves programming time

since you do not have to scroll around g e T

looking for the code. g g

' % SYSLPUT
;

i % SYSMACDELETE =
You can control this feature from the o SYSMSTORECLEAR
Program > Editor Options > % SYSRPUT 5
Autocomplete if you find it % test it
annoying. % WINDOW -

Figure 9. Autocomplete works well with Marcos

Use a Task to Create a Map

Tasks are helpful when you are learning a new PROC or when you do not use the feature often, such as with the
MAP feature. You may need to shape your data to work with the specific map dataset. For instance, the MAPS.US
uses a STATECODE variable that contains the abbreviation (CA, NC, NY and so on) for each US state.

The UFO_SIGHTS dataset contains observations from several years so an additional variable that contains the count
by state and year was added. This variable is what controls the color for each state. The more sightings for the
state, the darker the state appears.

us - ;

|?“? Filter and Sort Elg Query Builder | Data » Describe » Graph » Analyze ~ | Export + Send T

e
— = — T ‘DE 3 0.0566841
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0.05890517,

7 ; i B 7 0.2514294656

8 |oC ' T WO, . ... .. | T 5
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105 02056828538 0136450
&7 53 2011 ESTHR

Figure 10. Ensure your dataset is setup properly for the task
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To run the task, you need to select the UFO_SIGHTS dataset and then Tasks > Graphs > Map Chart. The Map
Chart tasks guides you through the process.

Use the Preview pane to see how your other choices appear in the map before running the output.

g - = - -
# Map Chart for: UFO:UFO_SIGHTS o et i ——
2011 UFO Sightings by State
l'g!llza_.gChaﬂ Data
Appearance
Mapping
Layout
Colors Map Data Source: MAPS.US
Legend
Chart Area Map Filter:
Titles
i Response Data Source: ~ UFO.UFOSIGHTS
roperties
Response Data Filter: Year =2011
ID Variable(s) Role (For variables in the MAP and RESP(
Task roles: Col e <58
st || o e —
X @ i D Y T e o wvw«m
TAT
/A STATECODE 4 ETATECOE
Other Roles (For variables in RESPONSE data set): E
Task roles: Columns to assign:
Name -~ 15| Response (Limi: 1)
/A Statecode ] (@ % CriByState
/A Shape .
/A summary &
‘N—J‘-—.—.

Figure 11. Use tasks to learn or use unfamiliar procedures

CHECK THE LOG

In Figure 12 we :| ) Log |7 Output Data | &) Resuts]
introduce an error by
commenting out the Expo¥ + Send To v Create ~ | § & \L&Pm_]ect Log | [E] Properties
source dataset. 1‘\28 BES Use these arrows (.:
T—h Ll ssumnarys to go to the next
When you run the code, 1 - tl.dt_witness, Error or Warning in
the Log tab appears 1] gﬂ P = Year (dt_witness) as Year, the log.
immediately to alert you 3 X rogram Month (dt_witness) as Month , =
there is an issue. In 4 DAY (dt_witness) as DayofMonth,
addition, notice the 22; 34 tl.duration,
Program tab icon 22l 95 * af poEee, =
Changed to include a 24! 3¢ count (*) as CntByState
red X. 25! 37 F s FROM WORK.UFO_DATA_‘!_IMPORT e/
26 38 WHERE tl.summary NOT CONTAINS ' (HORX)' L=
' 27
When repeiving a gg 32
new prqject, scan 30{ ERROR 22-322: Syntax error, expecting one of the following: a gquote:
the Project Tree to 31 FROM, INFORMAT, INTO, LABEL, LEN, LENGTH, TRANSCODE.
see if there are any 32
errors (see 33i ERROR 76-322: Syntax error, statement will be ignored.
example in Figure 34
6. Use Multiple 35 and statecode in (select statecode from maps.us)
Process Flows L 38 th.. BEATECOMM 0 o BBt sl

Figure 12. Log file available after program completes
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CHANGE THE WINDOW LAYOUT

You can arrange the e
process flow areato e Edt View Tess Progam ook Hep |8 WIS ¥ BB X0, | Bog Import Data ~ ks

see the log and code

@
at the same time. i &4 Progem (%] Log [ 5 Ouput Data | @ Resuts| T Single
= | [ Save Run ~ @ Stop ISdmdmlxd(Cmm'\IMMPwm-IIEl Stacked s
Select the Workspace |8 |~ 43 1. duration, -
Layout icon and then B 14 1 as Count, (7] SideBy Side
the layout you want, 5‘ 15 state | &
which can be =1 16 /= Program 4_IMPORT t1%/
. g A4
Stacked or Side By 17 y T CONTAINS ' (HOAX)'
Side. 18 and statecode in (select statecode from maps.us)
| inal 19 group by year, statecode
Select Smg e_to 20 order by year, statecode
return to the single e - v
. L »
view layout.
Step 1 - Import Data ~ x
You can select the 2 g &) o5 (] O Do | Fnt
tabs from each area Bport + Send ToWCreste - | 4 |3 Project Log | [F Properties
to show the program, 22] 34 1 as Count,
log, data, or results. 28 % count(*) as CntByState
24, 36 SeC SelifQuRATA 4 IMPORT t1%/
Q 25| a7 OT CONTAINS * (HOAX) ' B |
20
Shortcut! Select 27 "
Ctrl + M to ::l 76
HI ERROR 22-322: Syntax error, expecting one of the following: a quoted string, ',', AS, FORMAT,
create maXImlze 30 FROM, INFORMAT, INTO, LABEL, LEN, LENGTH, TRANSCOOE.
the project flow =
space. 32| ERROR 76-322: Syntax error, statement will be ignored.
33
34] 38 and statecode in (select statecode from maps.us) v

Figure 13. Change the layout in the Process Flow

CHANGE THE OUTPUT OPTIONS

You can change the format of your output so that the final report goes to HTML, PDF, RTF or just listing. Select
Tools > Options and then Results General. The next time you run the code or task, the results are in all the
selected formats.

Many users find HTML output generates quicker when you have larger results.

Options
General Results > Results General
Project Views
Project Recovery
Results Result Formats
D o SAS Report [V] HTML (7] PDF
viewer
SAS Report [CIRTF Text output
HTML Default: SAS Report
RTF |SAS Repo v
PDF Managing Results
- g Laamen L VOSBRSS A s v ST SIS

Figure 14. Choose different results
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To send your data or results to a Microsoft Office location, select the Send To menu and the desired application.
You can also send your Output Data to Microsoft Excel.

[ 84 Program [ [2] Log [ 73 Output Data| @ Resuts |
€9 Refresh | Export v | Send To ~| Create ~ Publish | [&] Properties
E-mail Recipient... X
E-mail Recipient as a Step in Project... UFO Sightings by Month
Internet Explorer Month Frequency clt"r"ewq:.laet'n‘::ey
Microsoft Word Jul 1654 1654
| Microsoft Excel l Aug 1256 2910
: - Sep 172 4082
Microsoft PowerPoint Oct 1089 5171
Jun 877 6048
mv y} |6921

Figure 15. Quickly place results in MS Office Applications

Update the Code and Log Schemes

You can change the colors used in your code or log. The color cues assist in navigating the code or log. To change
the look, select Programs > Editor Options and then the Appearance pane.

To change the code, do the

following: Enhanced Editor Options
1. Select SAS Program General | Appearance | Autocomplete | Indenter
File Or.SAS Log File Q File type: [SAS Program File ,\
from File type.
Scheme: v || Savehs..
2. Select the element you il [ [L‘
want to change, such as B
Comments. Name: Size:
3. You can change the (5AS Monospace g 1 =
font, foreground color, _File elements
background color and 2 )Comments P : ; '
9 “&n‘eﬂi line number | Formound: DWhlle
font style. The results Data/CARDS lines J
show in the Preview Date/Time constant 3
Defined keyword
area. Formats/Infomats
Macro definition
Select Ok to accept the changes Macro keyword
d ret t Macro reference
and return to your program or Macro section word (AMACRO, %MEND) z
select Save As to save the < ’
options. e
Q ik * ----- some sample code ----- */ =
Change your error statement 2%%1nc1ude %sunquote (&open.gtestit&close); 3
in the log to be bright yellow 3
with red text as shown in 4ifilename xyz printer "HP Laserjet IIISi" altdest='c
Figure 13 so it is easy to e SSidata PALLI ™o - PRSP N, P
locate.
Figure 16. Making changes to the code
CONCLUSION

SAS Enterprise Guide is a feature rich application that makes programming tasks easier. Using the tasks, editor
features, and options, you can improve your programming speed and accuracy. You can learn more tips from the
Business Intelligence for SAS BI Users (http://www.bi-notes.com) blog.



http://www.bi-notes.com/
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