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ABSTRACT 

Customers and clients just want it to work. Management wants it to be secure and “intuitive” while sliding you a list of 
ten new unrelated “action items” needed, “when you aren’t busy”. You are in the middle, the grease between the 
cogs. When your phone rings, it isn’t going to be someone gushing about how smooth everything is running. Sound 
familiar? If part of your work is administering and supporting people using SAS Enterprise Guide, then don’t miss this 
talk. We cover deployment issues, environment customization, handling libraries, roles, SAS® Grid Manager support, 
migration, and project maintenance. Come learn about the SAS Enterprise Guide tools designed to make 
administrative life just a bit easier. 

INTRODUCTION 

This paper focuses on administration topics specific to SAS Enterprise Guide. The administration of the SAS 
Intelligence Platform is traditionally done through SAS Management Console, which allows the control of “metadata” 
used by various SAS components to locate and consume resources (libraries, folders, security settings, and so on).  
SAS Enterprise Guide is often offered with this platform as a way of extending its power and improving its 
approachability. SAS Enterprise Guide is a Microsoft Windows application giving users a familiar paradigm in which 
to work.  

Understanding how SAS Enterprise Guide fits in your environment improves your ability to successfully administer it.  
SAS Enterprise Guide communicates with a SAS Metadata Server, which defines and controls access to resources in 
your organization. SAS Enterprise Guide also requires a local or remote SAS Workspace Server used to process 
SAS language code. The extensibility of SAS Enterprise Guide allows it to be leveraged by numerous SAS and third-
party components. For example, with a SAS Stored Process Server, SAS Enterprise Guide can create and execute 
SAS Stored Processes. With a SAS OLAP Server or a third-party OLE DB-compatible OLAP provider, SAS 
Enterprise Guide can explore OLAP cubes. With SAS Web Infrastructure Platform services and SAS Content Server, 
SAS Enterprise Guide can save and access content in a central content repository. SAS Enterprise Guide can also 
leverage SAS Grid Manager, SAS

 ®
 Forecast Server, SAS

 ®
 Enterprise Miner ™, DBMS data servers, and more. 

CUSTOMIZING YOUR DEPLOYMENT 

One of the first goals of an administrator is planning how to get the appropriately configured software into the hands 
of your users. A standard deployment of SAS Enterprise Guide and some instruction will get your users up and going.  
However, if you want more control over your deployment and less instruction for your end users, you have the ability 
to customize your deployment. It is a good idea to consider whether you want to deploy SAS Enterprise Guide with a 
custom connection profile and/or custom options. A custom deployment allows you to preset options so that users 
have fewer configuration details to worry about; meaning you have fewer questions to (repeatedly) answer. 

DEPLOYING WITH A CUSTOMIZED CONNECTION PROFILE 

Since a SAS Metadata Server is the window through which SAS Enterprise Guide sees the rest of the SAS world, the 
first step in using SAS Enterprise Guide is configuring a profile to access it.  A profile contains the information needed 
to make a connection to a SAS Metadata Server. 
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Display 1. Example Profile Settings 

If your planned deployment includes a SAS Metadata Server, a profile called “My Server” will be created 
automatically for your SAS Enterprise Guide client installations, which points to this server. Your SAS Enterprise 
Guide users will be saved the step of manually creating this profile. SAS Enterprise Guide will automatically connect 
to your configured SAS Metadata Server when the application is started. Generally, an installation will use only a 
single SAS Metadata Server. However, certain advanced installations might wish to target different SAS Metadata 
Servers, or environmental changes might cause the connection information to change.  

If your SAS Metadata Server connection information does change, your users will have to take manual steps to 
update their profiles to accommodate these changes. Updating profile information in SAS Enterprise Guide is very 
straightforward. However, it can be made even easier by storing a desired profile configuration in a shared location 
and directing your users to reference it. 

To create a shared profiles configuration: 

1. From within SAS Enterprise Guide, select Tools►SAS Enterprise Guide Explorer. 

2. From within SAS Enterprise Guide Explorer, select Tools►Profile Deployment Wizard. 

3. On page 2 of the wizard, make any desired changes to your current local profiles as well as specifying the 
default active profile, if you have more than one. The profiles defined here, as well as the active profile, will be 
stored in the shared profiles configuration. 

4. On page 3 of the wizard, you can test each profile connection if desired. 
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5. On page 4 of the wizard, provide the shared network location where you plan to store the shared profiles 
configuration. It needs to be a location that the SAS Enterprise Guide client machines can access. 

6. On page 5 of the wizard, specify a temporary location to save the SDSUpdate.xml and SDSControl.xml files, and 
then click Next and Finish. 

7. Move or copy the SDSUpdate.xml file, which is the profiles configuration without user IDs and passwords, from 
the temporary location where you saved it to the shared network location you specified in the wizard, ensuring 
that the path is identical. 

 

Display 2. Profile Deployment Wizard 

Now that you have created a shared profile configuration, the SAS Enterprise Guide clients will have to be configured 
to reference it, which can be done by following these steps: 

1. Click the connection link, which is on the right side of the status bar at the bottom of SAS Enterprise Guide (see 
Display 3), to bring up the Connections dialog box. 

  

Display 3. Connected Profile Link 

2. In the Connections dialog box, click the Updates tab. 

3. Check the Update configuration automatically option and specify the path to the folder that contains the 

shared profiles configuration file, SDSUpdate.xml. 

4. Optional. Click Check for updates now to immediately replace your personal profiles configuration with the 

shared profiles configuration. 
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Display 4. Automatic Profiles Configuration Updates 

When the Update configuration automatically option is set, the SAS Enterprise Guide client will check at start-up to 

see if the shared profiles configuration at the specified location has changed. If it has changed, the local profiles 
configuration will be replaced by the shared one, so any customizations your users have made will be lost! Make sure 
your users know to back up their profiles configuration if they make changes they do not want to lose when 
automatically updated. 

If you have not already deployed SAS Enterprise Guide, or you are planning a new deployment, instead of instructing 
your users to manually reference the shared configuration file, you can do it for them. You have the ability to deploy 
the SAS Enterprise Guide clients pre-configured to use the shared profiles configuration, such that the clients will 
automatically pick up any updates made to the shared profiles configuration. To achieve this, copy the 
SDSControl.xml file you created earlier, which contains the automatic update instructions, to the SAS Enterprise 
Guide product directories in your SAS Software Depot. 

Note: In a 9.3 SAS Software Depot, the SAS Enterprise Guide product directories should begin with \SAS 

Software Depot\products\eguide__93, with different folders for different languages and platforms.  For 

example, \SAS Software Depot\products\eguide__93130__win__en__sp0__1 is for English on a 32-bit 

Microsoft Windows platform. You will need to copy the SDSControl.xml file to all the SAS Enterprise Guide product 
directories you want automatically configured. 

When the SAS Deployment Wizard installs your SAS Enterprise Guide clients, the SDSControl.xml file, if present in 
the appropriate SAS Enterprise Guide product directory, will also be deployed to the client machines. You can 
confirm that the SDSControl.xml file was properly deployed by ensuring the Update configuration automatically 
option and the Location of update file options discussed earlier are set appropriately after a fresh client installation.  

You can also make sure that the SDSControl.xml file exists on the client in the “all users” shared settings location (for 
example, %allusersprofile%\SAS\SharedSettings\5.1), which will cause it to be copied to the user application data 
location of each SAS Enterprise Guide user on the machine. 

 

DEPLOYING WITH CUSTOMIZED OPTIONS 

SAS Enterprise Guide surfaces lots of options from the Tools►Options menu that allow users to customize the 

behavior of the application. Many of these options are personal preferences while others have a direct impact on 
performance and server utilization. For example, a data source from a Base SAS engine library is locked when simply 
being viewed in the data grid. The Close data grid after period of inactivity option on the Data►Performance 
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panel, will close an inactive data grid after 30 minutes by default, releasing the lock on that data source. It is a very 
good idea to keep this option turned on and assigned a relatively short time period, so one of your users does not 
unintentionally prevent other individuals or processes from accessing the data. As an administrator, it is a good idea 
to be aware of these sorts of options and the impact they can have. 

 

Display 5. SAS Enterprise Guide Options 

Similar to deploying custom profiles, SAS Enterprise Guide provides the ability to deploy customized default options.  
Once you have familiarized yourself with the capabilities of the product, you might decide you want your users to start 
with a default set of options different from out-of-the box defaults. You can achieve this with the following steps: 

1. From within SAS Enterprise Guide, select Tools►SAS Enterprise Guide Explorer. 

2. From within SAS Enterprise Guide Explorer, select Tools►Customize Enterprise Guide Options. 
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3. You will be presented with the same options dialog box that appears when you select Tools►Options in SAS 

Enterprise Guide. Set the options as you desire. 

4. Click Save As and save the EGOptions.xml file to a temporary location. 

5. Copy the EGOptions.xml file to the SAS Enterprise Guide product directories in your SAS Software Depot that 
you want to be automatically configured. 

When the SAS Deployment Wizard installs your SAS Enterprise Guide clients, if the EGOptions.xml file is present in 
the SAS Enterprise Guide product directory, it will be deployed to the client machines.  You can confirm the 
EGOptions.xml file was properly deployed to the client by ensuring it exists in the SAS Enterprise Guide installation 
directory (for example, C:\Program Files\SASHome\SASEnterpriseGuide\5.1) and the customized options 

appear in Tools►Options in SAS Enterprise Guide. Clicking Reset All changes all the options back to your 

customized defaults. 

If you are deploying both customized profiles and options, both the SDSControl.xml and EGOptions.xml files will need 
to be in the SAS Enterprise Guide product directories in your SAS Software Depot before your client installations. 

AUTOMATING CLIENT INSTALLATIONS 

SAS Enterprise Guide is installed using the SAS Deployment Wizard, which must be run on every client machine.  
However, the SAS Deployment Wizard offers a record and playback feature that enables you to automate your client 
installations. This feature is useful for deploying SAS Enterprise Guide to many machines and preventing your users 
from having to manually provide input during the installation. It requires you to record a response file that contains the 
desired responses to the SAS Deployment Wizard page options. You then run the SAS Deployment Wizard on each 
client with the response file as input. For more information, see the SAS 9.3 Intelligence Platform: Installation and 
Configuration Guide. 

CUSTOMIZING THE INTERFACE WITH ROLES 

SAS Enterprise Guide is a powerful tool and contains many features. As someone wise once said, “With great power 
comes great responsibility.” As an administrator, you have the ability to relieve your users of some of that 
responsibility by controlling their access to certain features of the product through the use of roles. 

Roles are defined in metadata and configured using the User Manager plug-in in SAS Management Console. When 
SAS Enterprise Guide Server Data is installed on the SAS Metadata Server, the SAS Enterprise Guide role metadata 
comes with four predefined roles: 

 

Role Name Role Description 

Enterprise Guide: Advanced Provides all capabilities in SAS Enterprise Guide. 

Enterprise Guide: Analysis Provides basic data analysis, reporting, and other capabilities. 

Enterprise Guide: OLAP Supports viewing OLAP cubes in the OLAP Analyzer and provides other 
capabilities. 

Enterprise Guide: Programming Provides SAS programming, stored process authoring, and other capabilities. 

Table 1. Predefined SAS Enterprise Guide Roles 

A role contains a collection of capabilities that define which specific features of the product are available to the 
members of that role. Roles allow you to customize the application interface for different individuals or groups, based 
on their responsibilities. Consider the responsibilities of your users and decide if it makes sense to subset the 
functionality they have access to. 

By default, the PUBLIC group is a member of the Enterprise Guide: Advanced role, thus every user will have access 
to all the SAS Enterprise Guide features. If you decide to provide your users with targeted functionality, you will first 
need to remove PUBLIC from the Enterprise Guide: Advanced role. Then, you can either assign your users to one of 
the four predefined roles, or you can create new roles. I recommend creating new roles over altering one of the 
predefined roles, since there is no automatic way to revert the capability settings in the predefined roles to their 
defaults. 
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Display 6. Enabling or Disabling Role Capabilities in SAS Management Console 

In Display 6, notice I created a custom role with all the Describe tasks disabled. I added a user as a member of the 
role, then when I log on to SAS Enterprise Guide as that user, the Functions: Restricted link appears on the status 
bar next to the active connection. The Functions: Restricted link appears only if you have one or more capabilities 
disabled. 

 

Display 7. Restricted Functions Link on Status Bar 

If you click the Functions hyperlink, it brings up the Function Settings dialog box, which lists the capabilities that you 

do and do not have access to. 
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Display 8. Restricted Functions List in SAS Enterprise Guide 

In Display 9, notice the Describe category and others do not appear on the Tasks menu on the left as a result of the 
disabled capabilities. When a capability is disabled, the associated feature is not displayed in the application. 
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Display 9. Customized Interface from Disabled Capabilities 

Custom tasks, which extend the functionality of SAS Enterprise Guide, can be registered in metadata and then 
enabled or disabled the same as built-in tasks. Use the Task Import Wizard on the Tools menu of the SAS Enterprise 

Guide Explorer tool to import custom tasks into metadata roles. 

It is very important to note that disabling capabilities is not a substitute for security! Rather, roles simply provide a way 
to customize the application interface per user responsibilities. For example, if you disable the Modify All Options 
capability, a user will not be able to edit any of the options in the Options dialog box in SAS Enterprise Guide. 
However, this will not prevent them from directly editing the EGOptions.xml file to make changes. 

MANUALLY IMPORTING ROLE METADATA 

Role metadata is version specific and independent. You must have each version of the SAS Enterprise Guide Server 
Data installed to be able to configure roles for the corresponding client versions. For example, if you have SAS 
Enterprise Guide users on versions 5.1 and 4.3, you will need both SAS Enterprise Guide Server Data 5.1 and 4.3 
installed on your SAS Metadata Server to control both. When multiple versions are installed, each version will appear 
in each role as a separate application and will need to be configured independently. 

Getting multiple versions of SAS Enterprise Guide Server Data on a SAS Metadata Server can be tricky if not 
migrating your metadata, since software orders include only the version associated with the SAS Enterprise Guide 
version in the order.  For example, suppose you want to upgrade your clients to a newer SAS Enterprise Guide 
version, but you don’t want to upgrade your metadata server.  If you want the new SAS Enterprise Guide clients to 
honor role capabilities, you’ll have to put the new client role metadata on your existing metadata server.  The 
ApplicationMetadataUtility tool (part of the SAS Platform Object Framework) will help you achieve this.  Here are the 
steps for manually importing SAS Enterprise Guide Server Data 5.1 using a 9.3 software depot (the steps should be 
very similar for other versions) into a metadata server: 

1. Make sure you have a good backup of your metadata repositories. 

2. Copy the eguidedata_appSC.appxml.orig file from your 9.3 depot location \SAS Software Depot 
\products\eguidedata__93130__prt__xx__sp0__1\eguidedata_gen.zip\Config\Deployment\M

etadata\ and save it as EG51.appxml in a temporary location. This file has an Application element at the top 

with values that we will need to manually substitute. 

3. Open the eguidedata_default.properties file from your 9.3 depot location \SAS Software Depot 

\product_data\eguidedata__93130__prt__xx__sp0__1\configure\ to find the substitution values. 

4. Open the eguidedata_config.xml file from your 9.3 depot location \SAS Software Depot 

\products\eguidedata__93130__prt__xx__sp0__1\eguidedata_gen.zip\Config\ and search for 

the “filterset” elements to see exactly how the substitution values are mapped. 

5. Replace the keys in the Application element in EG5.1.appxml with the proper substitution values.  Here is an 
example for 5.1: 

 <Application 

  Name="Enterprise Guide 5.1" 

  ProductName="Enterprise Guide 5.1" 

  ClassIdentifier="eguidedata" 

  Desc="Enterprise Guide 5.1" 

  Major="5" 

  Minor="1" 

  SoftwareVersion="5.1" 

  SpecVersion="5.1" 

  Folder="/System/Applications/SAS Enterprise Guide/Enterprise Guide Srvr 

Data 5.1" 

  Platform="" 

  ProductIdentifier="" 

  SpecVendor="" 

  Vendor="" 

  VendorIdentifier="" 

 > 

6. If using the 9.2 ApplicationMetadataUtility with an appxml file from a 9.3 software depot, you’ll need to remove 
the xmlns= attribute from the root ApplicationMetadata element at the top of the EG5.1.appxml file as well as 
comment out the Custom Tasks category element (search for CategoryName="eguide_CustomTasks") by 
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wrapping it with HTML-style commenting (<!--  and -->), since these are not valid in the 9.2 
ApplicationMetadataUtility. 

7. From a machine with the SAS Platform Object Framework installed, run the ApplicationMetadataUtility (located in  
C:\Program Files\SAS\SASPlatformObjectFramework\9.2 for 9.2 or 

\SASHome\SASPlatformObjectFramework\9.3 for 9.3) from a command line with the following command: 

ApplicationMetadataUtility.exe –host <hostname> -port <port> -user <userid> -

password <password> <xmlFile> 

Where <hostname> is your metadata server host name, <port> is your metadata server port, <userid> is the user 
id to login to the metadata server, <password> is the password to login to the metadata server for the specified 
userid, and <xmlFile> is your edited EG5.1.appxml file name. 

After running the ApplicationMetadataUtility, you should see the new application and related capabilities on the 
Capabilities tab of each role in the User Manager plugin in SAS Management Console. 

You can use similar steps to import older client role metadata into a newer metadata server.  For example, if you 
have a 9.3 metadata server with SAS Enterprise Guide 5.1 role metadata only (no 4.3 role metadata), but you have 
SAS Enterprise Guide 4.3 clients, you can import 4.3 role metadata into your 9.3 metadata server using the 
ApplicationMetadataUtility. 

Another way to achieve this is to export the desired role metadata from an existing metadata server and then import it 
into your target metadata server.  Of course, it requires having access to a server that already contains the desired 
role metadata. 

If you make a mistake or just want to start over, you can delete the imported role metadata by going to the Folders 
view in SAS Management Console, navigating to \System\Applications, expand SAS Enterprise Guide, right-

click the desired version sub-folder, and then click Delete. 

ADMINISTERING ACCESS TO DATA 

After figuring out how to get the configured and customized software to your users, the most important next step is to 
figure out how to give them access to the appropriate data. After all, it is all about the data! 

SAS accesses data through libraries and there are lots of ways to assign libraries. This is a larger topic than I can 
adequately cover here. I recommend reading the SAS 9.3 Intelligence Platform: Data Administration Guide to 
thoroughly explore the topic. Ultimately, you will define libraries in metadata to match your users to their appropriate 
level of data access. However, there are some unique library considerations for SAS Enterprise Guide. 

SAS Enterprise Guide lists libraries that are defined in metadata as well as any libraries that are currently assigned 
on the server. Libraries denoted with a yellow icon are currently assigned, and libraries with an uncolored icon are 
defined in metadata, but not currently assigned. Therefore, a library with an initial yellow icon is a pre-assigned library 
(perhaps by a LIBNAME statement in an autoexec file or the pre-assigned option is checked in the library’s metadata 
definition and the METAAUTOINIT option is turned on). SAS Enterprise Guide retrieves information about each 
library, so having many, especially pre-assigned, libraries can have a negative performance impact. 
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Display 10. Libraries in Server List 

SAS Enterprise Guide provides an Assign Project Library wizard from the Tools menu. The Assign Project Library is 

a point-and-click way to create a repeatable library assignment as a step in a project. A SAS language LIBNAME 
statement is generated from the wizard settings and executed on the selected server, which means it is active only  
for the duration of the workspace session. It has the same behavior as a user submitting a LIBNAME statement in a 
program. Other users are unaffected. 

By contrast, the SAS Enterprise Guide Explorer, accessed from the Tools menu in SAS Enterprise Guide, allows a 

user with appropriate permissions to define and configure libraries in metadata, similar to the way it is done in SAS 
Management Console. Since defined in metadata, configuring a library this way does impact other users and 
applications. 

One of the most important things to understand related to data access and SAS Enterprise Guide is that SAS 
Enterprise Guide does not force users to work in a metadata-aware context. What this means is that a user with the 
ability to submit code can submit a LIBNAME statement (or use the Assign Project Library wizard, or any of a number 
of other ways) to get direct access to the physical data, bypassing any metadata layer permissions that might have 
been applied to defined libraries. 

RESTRICTING USERS TO LIBRARIES DEFINED IN METADATA 

As an administrator, it can be frustrating to realize that end users can subvert your efforts by bypassing the metadata 
layer permissions. All it takes is submitting a SAS LIBNAME statement to the physical location of the data. I recently 
saw an attempt to plug this hole by creating a statement-style macro called LIBNAME and putting it in a stored, 
compiled macro catalog: 

libname mstore "C:\SAS\Config\Lev1\SASApp\SASEnvironment\SASMacro"; 

options implmac mstored sasmstore=mstore; 

%macro libname(p1, p2, p3, p4, p5, p6, p7, p8) /stmt store des="Disable Libname"; 

%put ERROR: Use of the Libname statement is not allowed; 

%mend; 

Then, when users submit a LIBNAME statement they will get an error in the log with the message specified in the 
macro: 
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29         libname foo 'C:\temp'; 

ERROR: Use of the Libname statement is not allowed 

First, enabling statement-style macros has performance overhead. Second, if users figure out it was just a macro, 
they could define their own macro named “LIBNAME” that would override it, and thus regain full access to the 
LIBNAME statement: 

37         %macro libname; 

38         %mend; 

39         libname foo 'C:\temp'; 

NOTE: Libref FOO was successfully assigned as follows:  

Third, this would do nothing to prevent users from directly reading the binary data stream and writing it back out to a 
location they have access to: 

filename in "c:\tmp\secret.sas7bdat"; 

filename out "%sysfunc(getoption(work))\notsecret.sas7bdat"; 

data _null_; 

length fin 8 fout 8; 

r = '20'x; 

fin = fopen('in','I',1,'B'); 

fout = fopen('out','O',1,'B'); 

  do while(fread(fin)= 0); 

    rc = fget(fin,r,1); 

rc = fput(fout, r); 

rc =fwrite(fout); 

  end; 

rc = fclose(fin); 

rc = fclose(fout); 

run; 

You could disable the Create or Modify SAS Program capability, which would completely remove their ability to 
submit code from the program editor. However, you would have to also disable the Add or Modify Custom Code to 
SAS Task and the Create or Modify SAS Stored Process capabilities, since they are both other places user-code 
could be executed to access the data. At this point, you are severely limiting the usefulness of the product, yet holes 
still remain. Users could still write a custom task or a simple application using IOM interfaces to submit their own 
code. 

As long as users have the necessary host operating system permissions, they will be able to directly access and read 
a SAS table. So, what this boils down to is that any real data security must be put in place at the physical host 
operating system layer. 

RESTRICTING ACCESS TO PHYSICAL DATA THROUGH INFORMATION MAPS 

SAS Information Maps contain business metadata that is applied to data sources. They allow users to work with a 
more user-friendly representation of the data, instead of working directly with the raw data sources. It is not 
uncommon for administrators to want to force their users to be able to access data only through information maps, 
and not be able to access the source data. The query executed by the INFOMAPS engine is done on your behalf on 
a standard workspace server, using your credentials. Therefore, for the information map to be able to retrieve the 
data, you have to be able to retrieve the data, which means you cannot restrict access to the physical data in this 
default configuration. However, you can restrict access to the physical data by configuring server-side pooling. The 
SAS Pooled Workspace Server runs with the service account sassrv, so if you give sassrv host access to the data 
and deny host access to your users, the INFOMAPS engine will still be able to access the physical data through the 
SAS Pooled Workspace Server, but your end users will not be able to. Be aware this mediated access approach has 
a performance side effect, since the INFOMAPS engine will have to use remote access to access the data. When 
opening an information map in this configuration, an error in the log will indicate that direct access was not possible 
and that it is reverting to remote access, which should then access the information map data just fine, although 
potentially slower. So, don’t be alarmed by the error. 

INTEGRATING WITH SAS GRID MANAGER 

SAS Grid Manager provides enterprise scheduling, workload management, and parallel workload management in a 
distributed grid environment. SAS Enterprise Guide can be configured for seamless submission to the SAS grid, 
leveraging the workload management capabilities of the grid. Prior to 5.1, each SAS Enterprise Guide client had to be 
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manually configured to use the SAS grid. (See http://support.sas.com/rnd/scalability/grid/download.html.) Integration 
with the SAS grid has been significantly improved with SAS Enterprise Guide 5.1. 

SAS Enterprise Guide 5.1 automatically detects the presence of a grid by looking for a grid server definition in 
metadata. If it finds one, it is also automatically configured. It is no longer necessary to manually configure pre- and 
post-code for initializing and destructing the grid connection. The server list icons now indicate the presence of a grid 
with a pound (#) symbol, as well as the connected state of both the workspace server (green check mark) and the 
grid (green background on the pound symbol). 

 

Display 11. Server Icon Indicates Presence and Connected State of Grid 

GETTING CONNECTED TO THE GRID 

Use of the grid can be controlled by an administrator through metadata or left to the end users. You can force your 
end users to use the grid by adding an extended attribute named “EGGridPolicy” on the logical grid server with a 
value of Force. 

 

Display 12. Forcing Users to Use the Grid 

If the grid policy is not forced in metadata, then users can control usage of the grid at the project level or individual 
task level. To enable the grid at a project level, select File►Project Properties►Code Submission, and then check 
Use grid if available. 
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Display 13. Using the Grid at the Project Level 

While the project grid setting applies to all project items by default, the usage of the grid can be overridden at the 
individual task level. You can access this override setting by right-clicking the item, clicking Properties, and then 
clicking the Code Submission page. 
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Display 14. Using the Grid at the Task Level 

 

CONTROLLING WHEN THE GRID CONNECTION IS MADE 

There are several considerations in deciding when to make a connection to the grid: 

When Connection Is Made Pros Cons 

Connect as soon as we connect to a 
workspace. 

 Grid-specific libraries are 
available right away. 

 There is extra overhead (in 
time) connecting to the grid. 

 If there is a problem 
connecting to the grid, it 
could prevent us from using 
the workspace server. 

 If we don’t need the grid, we 
are taking up grid slots 
unnecessarily. 

Defer connecting to the grid until we 
actually run a task on the grid. 

 Don’t pay the extra 
overhead until we know we 
need it. 

 If the workspace works, but 
the grid doesn’t, we can still 
use the workspace. 

 The first time you create a 
task, the grid-specific 
libraries are not available to 
use. 
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 We don’t want to waste grid 
slots unnecessarily.  

Table 2. Pros and Cons of Different Grid Connection Timing 

 

SAS Enterprise Guide allows users to control when they feel it is best to make a grid connection by selecting  
Tools►Options►SAS Programs►Initialize grid (if available) when connecting to a workspace.  Connection to 

the grid is deferred by default. If the connection to the grid is deferred, the user has the ability to explicitly connect to 
the grid at any time by right-clicking the server in the server list and clicking Connect to Grid. Users might explicitly 

connect to the grid, so they get access to the Gridwork library, which is assigned as a result, from within tasks. 

 

HOW TO KNOW IF A TASK IS RUNNING ON THE GRID 

The task status view now has a Server Type column. If a task is running on the grid, it will show Grid. If it is running 
on a workspace server, it will show Workspace. 

 

Display 15. Server Type Displayed in Task Status View 

 

With minimal configuration, accessing your grid environment in SAS Enterprise Guide 5.1 just works! 

PROMOTING PARALLEL EXECUTION 

Why do one thing at a time if you can do two? With minimal configuration, SAS Enterprise Guide can run independent 
jobs in parallel. Your users will certainly appreciate their jobs finishing faster. 

One workspace session, which corresponds to one sas.exe process, is spawned when an instance of SAS Enterprise 
Guide connects to a SAS Workspace Server. The spawned workspace session is reused throughout the SAS 
Enterprise Guide session, unless explicitly disconnected. Therefore, when you run more than one job against the 
same SAS Workspace Server context (for example, SASApp), the jobs are run sequentially using the one sas.exe 
process. Each job has to wait its turn in line for execution on the server. 

In Display 16, there are three independent programs in the process flow, yet only the first program is currently 
executing. Notice in the Task Status window that all three programs are associated with one workspace server 
(SASApp), and therefore, the other two programs are waiting. Program3 is waiting on Program2 to finish and 
Program2 is waiting on Program1 to finish. The example uses three independent programs for the sake of clarity; 
instead of individual programs, they could easily be long, complex process flow branches. 
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Display 16. Independent Programs Running Sequentially 

 

By defining two or more logical SAS Workspace Servers (for example, SASApp2, SASApp3, and so on), you enable 
your users to run independent jobs in parallel by associating the jobs with different logical servers. Use the Server 
Manager plug-in in SAS Management Console to create additional server definitions, though we will not cover that 
here. To associate a program with a different server in SAS Enterprise Guide, right-click the program, click Select 
Server, and then click the desired server. This approach works even if the additional server contexts are defined 

against the same physical server. A workspace session will be spawned for each workspace server context, allowing 
multiple jobs to be run in parallel and leveraging the multiple cores on your server. 

In Display 17, notice that Program1 and Program2 are executing simultaneously, while Program3 is waiting on 
Program1. Program1 and Program2 are able to run at the same time, because they are using separate workspace 
sessions as a result of running them on different logical servers (SASApp and SASApp2). Program3 is still associated 
with SASApp, and therefore, is waiting on Program1 to finish. 
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Display 17. Independent Programs Running Simultaneously on Different Logical Servers 

 

Having to create additional server contexts and keep them in sync is a drawback to this approach. Even without 
multiple logical servers, your users can leverage multiple workspace sessions by executing jobs from multiple 
instances of SAS Enterprise Guide. This alternative approach of working out of multiple SAS Enterprise Guide 
instances has its own obvious pain. 

SAS Enterprise Guide, starting with 5.1, supports executing independent jobs in parallel on the same logical server. It 
achieves this by requesting additional workspace server sessions as needed, using the same server context. This 
feature (off by default) must be turned on one of two ways: 

 From the File menu, select Project Properties►Code Submission. Then check Allow parallel execution on 
the same server. Setting the option here at the project level causes it to apply to everything in the project by 

default. 

 Right-click a program, select Properties►Code Submission, and then click Customize code submission 
options. Check Allow parallel execution on the same server. Setting the option here at the element level 

causes it to apply only to the element. 

When the Allow parallel execution on the same server option is enabled, if independent jobs are identified, 

additional workspace sessions will be requested to run them at the same time. Also, realize that since multiple 
workspaces sessions are being used, anything specific to the state of a workspace session will not exist in the other 
workspace sessions. Submitting a LIBNAME statement, setting an option, creating a macro variable or function, or 
creating data in the Work library are all examples of operations that affect workspace server state and would not be 
available in other workspace sessions. 
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Display 18. Independent Programs Running Simultaneously on Same Logical Server 

 

Another point worth noting is that combining the Allow parallel execution on the same server option with the Use 
grid if available option will result in multiple workspace sessions, and therefore, multiple grid nodes running in 

parallel, which can be very powerful. 

MIGRATING PROJECTS 

Upgrading SAS Enterprise Guide client versions often does not require a platform upgrade. For example, 4.2, 4.3, 
and 5.1 are all compatible with 9.2 servers. Versions 4.3 and 5.1 are also compatible with 9.3 servers. However, a 
SAS Enterprise Guide project file is upgraded when opened in a more current client version and you cannot go 
backward. Therefore, it is important not to open and save (overwrite) your projects in a new version of the client 
unless you know you are not going to open it again in the previous version of the client. For example, suppose you 
have a side-by-side installation of SAS Enterprise Guide 4.3 and 5.1. Once you open and save your 4.3 projects in 
5.1, you will no longer be able to open the projects again in 4.3. Likewise, if you send a project to someone, they will 
have to have the version of the client that the project was saved in or later. (This also applies to projects saved on 
metadata servers.) 

When you do encounter platform or hardware changes, there are tools for batch updating your project references.  
The primary tool is the Migration wizard (MigrationWizard.exe), which can be found in the SAS Enterprise Guide 
installation directory. The Project Maintenance dialog box (which you open by selecting Tools►Project 
Maintenance serves a similar purpose but is for the currently open project, whereas the Migration wizard can handle 

lots of projects at a time. By following the steps in the wizards, you can map old resources (servers, libraries, and 
data sets) to new resources, thereby updating your projects’ references appropriately. 
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Display 19. Mapping Old Resources to New Resources 

 

OTHER CONSIDERATIONS 

JUST SAY NO TO SHELL ACCESS REQUESTS 

The XCMD option (or ALLOWXCMD spawner option) would give your users the ability to execute shell commands on 
your server, which could result in potentially harmful operations such as file deletion. As a result of the security risks, 
it is very unlikely you want your users to be able to execute shell commands on your server. Fortunately, NOXCMD is 
the default. To avoid potential risk, it is a best practice to keep it that way. 

x 'del *.*'; /* Oh no! ; 

CONCLUSION 

SAS Enterprise Guide has a number of features to help with customized deployments, data access management, 
grid computing, parallel processing, and project migration. Understanding and promoting these features will help your 
users get the most out of SAS Enterprise Guide. 
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 SAS Intelligence Platform: Desktop Application Administration Guide 

 SAS Intelligence Platform: Installation and Configuration Guide 

 SAS Intelligence Platform: Security Administration Guide 
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