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Getting Up to Speed with PROC REPORT
Kimberly LeBouton, K.J.L. Computing, Rossmoor, CA

ABSTRACT

Learning the basics of PROC REPORT can help the new SAS® user avoid hours of headaches. PROC REPORT can
often be used in lieu of PROC TABULATE or DATA _NULL_ reporting--two areas that have driven the new SAS user
crazy!!l With the added capabilities of ODS, PROC REPORT can look as sharp as an EXCEL report. This paper will
show how to use PROC REPORT in both a windowing and non-windowing environment using SAS Version 9.

INTRODUCTION

The PROC REPORT windowing environment is a great code generator. | often have the initial code generated in the
windowing environment, and then “tweak” the code in the non-windowing environment. You can even use the
windowing environment with a mainframe, although it is a little easier in a GUI environment (e.g., Windows or UNIX).

WINDOWING ENVIRONMENT

To use PROC REPORT in the windowing environment, you have several from the Menu Bar.
Solutions 2 Report Writing = Design Report
or
Tools = Report Editor

If you prefer to code, submit the following from the SAS editor.

options nocenter;
proc report data=sashelp.class;
run;

Note: This paper will be using the CLASS data set provided as an example data set when you license SAS/ASSIST.
See Appendix | for details on how to get access to this data set.

The following screen will appear.
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This screen is the default report, which looks very similar to “vanilla” PROC PRINT. The value of PROC REPORT is
in its grouping capabilities, which include summarizing. The report will now be reorganized interactively to group by
Sex.

PROC REPORT works from left to right. Thus, if you want a grouping by Sex, then you need to move Sex before
Name. To reorder the report, highlight the Sex label. Choose the following sequence either from the Menu or by
clicking the right mouse button.

Edit © Move selected item = to the left of the next selected item

The screen from SAS V9.13 for Windows will ook like the following.
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Nothing seems to happen. The next step is to highlight the Name label. The Sex column should move to the left of
Name. The report should look the same, except for the column change.

Now you decide that all of the F’'s for females and M’s for males are cluttering the report. You only want one F and
one M to designate the group. To do this, follow the next sequence of push buttons.

Edit > Define selected item 2 Group = OK
Now you would like a line break between each grouping.
Edit © Summarize information = After item = Skip line after break > OK
Now you will proceed onto a slightly more difficult change. You would like to have the data sorted by age. Because
PROC REPORT works from left to right, you cannot sort the Age column with Name to the left of it. To further
complicate things, you really like where Age is located. You need to have Age have two columns on our report, but
you do not want to see the column to the left of Name. To do this, you need to follow the next sequence after
highlighting Name:
Edit > Add item - Data column - Left > Age = F3 key to End

The report now has two Age columns, and you do not want that look. You will now need to sort the data and remove
the new column from the report layout. To do this, highlight the new Age column and do the following.

Edit = Define = Order = No print = OK
Now you would like to get some summary statistics for the GENDER grouping and for an overall total.

To get the summary statistics for Sex do the following:



Edit 2 Summarize information 2 After item = Overline summary < Summarize analysis columns 2 OK

The default summary statistic is the SUM calculation. The MEAN is the preferred summary statistic. To make this
change, you will need to modify the Age, Height and Weight columns. After highlighting Height, follow the sequence
below.

Edit = Define = change SUM to MEAN under Statistics > OK

The screen looks like below.
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Do the same sequence for Age and Weight.
For an overall total, follow this sequence. Again this is a SUM calculation, which will be changed later to MEAN.
Edit > Summarize information - At the bottom > Summarize analysis columns 2> OK

To do a clean up the format by lining up the decimal places to the right for Age, Height and Weight, follow this
sequence.

Edit > Define selected item - enter 8.2 in format 2 OK
If you forget the format you want to use enter a ? on the format field and modify the format screen.
Keep in mind that you could have gotten a similar looking report with PROC PRINT, but you also would have had to
sort your data first. You have achieved an ordered report without sorting the data first—PROC TABULATE could

have done something similar too.

Speaking of PROC TABULATE, you can have the boxed look with PROC REPORT too. For the final interactive
option, turn on box.

Tools = Options = Report...
A ROPTION dialogue box will appear. From this dialogue box, check Box and then OK.

Your report hopefully looks like the following.
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Now you would like to save the report statements that were generated from of the interactive work. Following is the
sequence that will return the code.

Tools = REPORT Statements = File = Save as = Write to file = enter file name
What if you have not finished the interactive report, but you need to stop what you are doing? You can save your
report profile by entering the following sequence. Before you enter this sequence, make sure that have created a
catalog in a library.

File > Save Report

A dialogue box will ask you for the Libname, Catalog, Report Name, and Description. After entering the information,
push the OK button to save.
To close the Report window, File > Close
To reopen the saved interactive report, start interactive PROC REPORT with the data used to create the saved
report. (See initial code provided under WINDOWING ENVIRONMENT at the beginning of this paper.) Enter the
following to Open the previously saved interactive report.

File 2 Open Report

Locate the Libname, Catalog, and Report Name.

NON-WINDOWING ENVIRONMENT

The SAS code that was generated from the interactive work in the windowing environment section is shown in Figure
1. Each line of code will be explained in detail and “tweaked” a little bit to now run in a non-windowing environment
(a.k.a., batch). The SAS code generated in the Windowing Environment was left justified. | added the indenting for
readability.



OPROC REPORT @DATA=SASHELP.CLASS ©LS=80 PS=44 @SPLIT="/" NOCENTER ©BOX;
OCOLUMN SEX AGE NAME AGE=_Al1 HEIGHT WEIGHT;

DEFINE SEX / ORDER FORMAT= $1. WIDTH=6 SPACING=2 LEFT "Gender";
@DEFINE AGE / ORDER FORMAT= BEST9. WIDTH=9 SPACING=2 NOPRINT RIGHT
""Age in years';
DEFINE NAME / ORDER FORMAT= $8. WIDTH=8 SPACING=2 LEFT "First name';
DEFINE _Al1 / SUM FORMAT= BEST9. WIDTH=9 SPACING=2 RIGHT
""Age in years';

DEFINE HEIGHT / SUM FORMAT= 8.2 WIDTH=9  SPACING=2  RIGHT
"Height in inches"

DEFINE WEIGHT / SUM FORMAT= 8.2 WIDTH=9 SPACING=2 RIGHT
"Weight in pounds™;

OBREAK AFTER SEX / OL SKIP SUMMARIZE;

RBREAK AFTER / SUMMARIZE;
RUN;

Figure 1 SAS code created from windowing environment.

O The first line of code generated is PROC REPORT. To work in a non-windowing environment, the PROC
REPORT statement will need to be rewritten with the NOWINDOWS option.

PROC REPORT DATA=SASHELP.CLASS LS=80 PS=44 SPLIT="/" NOCENTER BOX NOWINDOWS;

@ Like other PROCs, you can designate the data to be used with DATA= or default to the most recently created data
set. In this example, a permanent SAS data set was used.

The remaining options are for formatting the overall report.

© The SPLIT="/"" works the same way as PROC PRINT for labels on specific variables. The label will be split to a
new line at the /. If you want to use / as part of your label, then you'll need to pick a different character for split=.

O The LS and PS are exactly the same as those used in the global OPTION statement for linesize and pagesize,
respectively.

Note: PROC REPORT honors the first LS and PS that it finds. When running my SAS report from Microsoft
Windows, | like to remove the LS and PS command. This allows me to control my fonts and paper orientation from
the Menu Bar using File Print = Setup.

© The BOX option outlines the detail lines of the report, similar to PROC TABULATE.

@®The COLUMN statement describes the arrangement of columns and headers.

In this example, the COLUMN statement works like a VAR statement in PROC PRINT. This statement shows the
order of the SAS variables that are to be processed and possibly printed. The AGE=_A1 is the only unclear piece of

code. _Alis the alias for AGE. The DEFINE statement will further clarify the need and use of an alias.

The COLUMN statement can also provide detailed header information. You might want to have a special label across
the HEIGHT and WEIGHT variables. The do this, the COLUMN statement needs to be rewritten as follows:

COLUMN SEX AGE NAME AGE=_Al ("*Body Size*" HEIGHT WEIGHT);

® The DEFINE statement specifies how to use the specific variable that was defined in the column statement. The
variable can be either a SAS variable or a computed variable created in PROC REPORT. The AGE and _Al
DEFINE statements will be used to explain how to use the DEFINE statement.



Remember that _Al variable is an alias of AGE. Because the report has AGE sorted within GENDER, the AGE
variable needed to follow GENDER, but the report was to keep AGE in the same location as the original report. Thus,
the DEFINE STATEMENT FOR age includes the option NOPRINT, along with the option of ORDER.

DEFINE AGE / ORDER FORMAT=BEST9. WIDTH=9 SPACING=2 NOPRINT RIGHT
""Age in years';

To begin a DEFINE statement, start with DEFINE followed by the report item and then a slash (/).

DEFINE _Al1 / SUM FORMAT= BEST9. WIDTH=9 SPACING=2 RIGHT "Age in years';

The report item for this example is _Al. The report item can be a SAS variable, computed variable, or an alias of
either of these two variables.

After the slash, there are many options. Some of these options are obvious, but other are better understood with a
SAS Documentaion. To find out what the WIDTH option does, enter the following sequence from the SAS 9.2
Documentation, see
http://support.sas.com/documentation/cdl/en/proc/61895/HTML/default/a002473627.htm#a003072093.

The following screen should appear.

-
count or observations.

WIDTH=column-width
defines the width of the column in which PROC REPORT displays report-item.

Default: A column width that is just large enough to handle the format. If there is no f
uses the value of the COLWIDTH= option in the PROC REPORT statement

Range: 1 to the value of the SAS system option LINESIZE=
Restriction: This option has no effect on ODS destinations other than traditional SAS mq

Interaction: WIDTH= in an item definition overrides the value of COLWIDTH= in the PR
the ROPTIONS window.

Tip: When you stack items in the same column in a report, the width of the item t
stack determines the width of the column.

Featured Calculating Percentages
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O The BREAK and RBREAK statement work in a similar manner, and so, they will be discussed together. The
BREAK statement allows for a break at a grouped or ordered variable. The break can be a summary line, page
break, or a line space. It can be before or after the grouped data. The RBREAK statement is a summary line for the
completed report. It can be at the start or end of the report.

CONCLUSION
PROC REPORT is a very powerful tool that is easy to use. This paper has explored generating SAS code using
PROC REPORT in an interactive mode, and then later modifying that code to work in a non-windowing environment.

Appendix Il provides several other techniques for quickly generating PROC REPORT code.



APPENDIX |
The CLASS data set used in this paper is provided with SAS/ASSIST. To have the data saved in your SASHELP
library, click on the following sequence of icons/menus:

SETUP - Sample data sets... > Create sample data sets... 2 Select CLASS = OK

APPENDIX II

NOEXEC Method
This is my current favorite, which | learned last year from sasCommunity Tip of the Day. See
http://www.sascommunity.org/wiki/Tips:Jump-start PROC_REPORT.

proc report data=sashelp.class noexec list;
run;

This method works outside of the windowing environment. The generated code is written to the SAS log. | am
especially fond of this method, if I've forgotten a variable in my report and | want a quick DEFINE statement
generated.

%thm was not covered in this paper that could also increase your speed in generating PROC REPORT code
is to add PROMPT to the following code:
proc report data=sashelp.class prompt; run;
This will open the PROMPT facility. This facility will guide you through the report windowing procedure.
Enterprise Guide 4.3 and higher List Report Data Task

The following will quickly generate PROC REPORT code that can be easily edited. Unlike the SAS windowing
method, this Task can also generates ODS code.

File > Open > Data = <choose data source>
Task = Describe Data 2 List Report Data 2 Finish

This Task is far more powerful than what | have presented, but it is beyond the scope of this paper.
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