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ABSTRACT  

For many users, the most common Web content will consist of SAS® reports. These are dynamic views of a SAS 
information map. Once an information map has been constructed, it can be displayed as a table or chart (or both) in a 
multi-page report. Web reports are created using SAS® Web Report Studio, a middle tier application that runs in a 
servlet container, that is, as a Web program. You do not need to have anything installed on your desktop except for 
Firefox or Internet Explorer. This paper will demonstrate how to create a complex Web report from SAS data or from 
an OLAP cube using the SAS Web Report Studio product in SAS® BI Server 9.2. 

INTRODUCTION  

Traditional SAS DATA and PROC step programming has served us well for over 30 years. Anyone paying attention 
however will have noticed that SAS has introduced a great many new products that build on the older technologies 
but which provide another level of functionality via a Web interface. The documentation for these products consists of 
literally dozens of reference manuals, user guides, technical white papers and road maps, not to mention the online 
help. The intent of this paper is to describe some of these products and provide examples from the perspective of the 
SAS user.  

SAS/IntrNet has been around for more than a decade, and provides a reasonable level of functionality for dynamic 
access to SAS data and reports. Web 2.0, however, is personal. The new SAS products are a sophisticated response 
to this change in approach. A “portal” in Web jargon is a site that provides customized content, including links to other 
sources, as well as allowing users to collaborate and share resources. The SAS

®
 Information Delivery Portal is 

designed to let each user personalize the appearance and content of Web pages using SAS software. In order to 
support this level of customization, SAS has developed a set of Java Web applications which can be bundled 
together in different configurations. In particular, the Enterprise Business Intelligence (EBI) software suite includes all 

of the components necessary to build customized portals. Note that these products are available in various 
combinations and as usual the best resource for identifying what might be needed for your organization is your SAS 
sales representative. 

Probably the most important of these new products is SAS Web Report Studio, designed to ease the load on IT 
departments by allowing end users to prepare and maintain routine reports. At the same time, it empowers users to 
create and design reports that meet their own individual needs. While this is probably a good idea, it all depends on 
what you mean by an “end user.”  Experience suggests that managers and executives do not have the time or 
interest in learning how to create their own custom reports. In practice, the most common users are analysts and 
programmers, who are accustomed to developing content in PROC REPORT or PROC TABULATE. Long-time SAS 
users may feel frustrated by the Web Report Studio approach, since it is entirely point-and-click and does not offer 
the user much opportunity to get under the hood and tinker. Remember though, that the point of the application is to 
simplify and speed-up the process of getting and disseminating information. And for that, the Web Report Studio 
application can be extraordinarily effective, allowing analysts to create reports in a fraction of the time that the older 
batch approach required. 

In addition, another required product is SAS Information Map Studio, a GUI application for creating information maps 

from OLAP cubes or underlying SAS or database tables. If the data source is one or more SAS datasets you can 
specify table joins but you can only have a single cube as a data source. The idea is that complex views of the data 
can be constructed by business users with no knowledge of SQL. There is a batch version of the interface, PROC 
INFOMAPS, which provides the same functionality in a more traditional SAS approach. The GUI is very simple to 
use, however, and would usually be the first choice for creating or modifying an Information Map. 

Web Report Studio is a Java Web application for constructing SAS reports, based on using SAS Information Maps to 
display standardized tabulations and graphical presentations accessed via a client browser. Complex reports 
including tables and charts can be created by users with no Java programming skills, simply by using a standard 
point-and-click interface. There are actually two components included under this product: SAS Web Report Studio, 
used to create and edit reports, and SAS Web Report Viewer for displaying the results. The online documentation 
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SAS Web Report Studio 4.2: User’s Guide includes detailed information about this product and how to use the many 
features (see the references at the end of the paper). This paper is intended as a brief introduction to SAS Web 
Report Studio and to using Information Maps.  

Getting Started Using the Report Wizard 

The first step is to connect to the Web application. Web Report Studio, as noted above, is a Java Web application, 
accessed from a client browser. The URL will vary depending on your installation, but generally speaking you will 
need to log-in via TCP port 8080, as shown below, where hostname is the fully qualified name of your SAS 
Application server: 

http://hostname:8080/SASLogon/index.jsp?_sasapp=Web+Report+Studio+4.2& 

Login credentials will be supplied by you SAS administrator. After connecting to SAS Web Report Studio, the startup 
screen displays three options: create a report in Edit mode, use the Report Wizard, or use a template. The lower half 
of the form lists the existing reports that you can open. 

 

Figure 1. SAS Web Report Studio initial splash screen 

New using Report Wizard is a good place to get started. By default, the Wizard opens with the data source set to the 
most recently used Information Map (see Figure 2 below). You can change the source by clicking on the Change 
Source button, which brings up a file browser. The map based on the shoe sales table is selected. 

Beyond the BasicsSAS Global Forum 2010

 

http://hostname:8080/SASLogon/index.jsp?_sasapp=Web+Report+Studio+4.2&


3 

 

Figure 2. Select Data Source 

Click the OK button to return to the Wizard. Click the double arrow button in the center to make all the items available 
for the report: you can of course select them individually, but there is no problem with having all of them available. 
Once you have selected the items, the Next button will be accessible (not grayed out).  

 

Figure 3. Report Wizard: Step 1 
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In the second step, you are given a choice of filtering the data; this is the same as specifying a WHERE clause in 
SQL. No filters are selected, since for the moment we want to see all the data.   

 

Figure 4. Report Wizard: Step 2 

For the four measures, you can change the SAS display format by clicking on Define. One interesting option is the 
ability to preview the data and even export it to MS Office, as shown in Figure 5. 

 

Figure 5. Report Wizard: Preview Data 
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The next step is to create Group Beaks; data from different categories. We want a new report page for each value of 
the variable region. 

 

Figure 6. Report Wizard: Step 3 

Next, there is a required choice of a graph, a table or both. Choose both, and select the items to be displayed. A 
crosstab table is selected that will show sales by product and subsidiary. The graph will display the same data as the 
table, in a bar chart. 

 

Figure 7. Report Wizard: Step 4 
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Finally, we can choose header and footer labels. The banner is specified in the theme, which will be discussed later. 
For now, we can add a title and put the date in the footer. 

 

Figure 8. Report Wizard: Step 5 

Click Finish to generate the report. This opens the report in Edit mode for any further tweaks. At this point it is a good 
idea to save the report by selecting File>Save from the main menu. This brings up a Save As dialog with various 
options as shown. A name and description have been added; the report will be saved in the Shared Data/Reports 
metadata location. The report will now be available to any user with permission to access this folder. 

 

Figure 9. Save Report 
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After saving the report you are returned to Web Report Studio Edit mode. 

 

Figure 10. Edit Report 

Click on the Table of Contents Options link to bring up the Rename Section dialog to change the name from Section1 
to Region. Then select the View tab to display the report as it will appear in a browser. Be patient while the report is 
created. Large datasets will take a while, which is why it is a good idea to use an OLAP cube as a data source. After 
a few moments, the report should appear. 

 

Figure 11. Sample Report 
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As requested, we see a crosstab and a bar chart of summary data. Web Report Studio is doing the aggregation for 
you. In the next section, we shall see how to use pre-summarized data to speed up the results. 

Building a Web Report from an OLAP Cube 

In the next example, some of the power and flexibility of Web Report Studio will be demonstrated. Three new 
concepts will be explored: 

 Using an OLAP cube as the data source for a Web Report 

 Adding computed expressions 

 Manually adding sections to a report 

Start by opening Web Report Studio in a browser window as before, log in and select New report from the splash 
screen. In the main menu in the Edit pane, click on Data>Select Data. (Initially this is the only choice that is not 
grayed out from the drop down menu.) Click on Change Source to see a list of the available Information Maps. This 
brings up a navigation tree that points to the last data source used. 

 

Figure 12. Select Data Source 

Highlight the desired map as shown and click OK. This will return you to the Data Source screen. Click the double 
arrow to select all of the items. (As before, you can select all or just some of them, but there is no reason not to have 
them all available.) 

 

Figure 13. Select Data Items 
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Remember, this is aggregate data, so the total sales is likely to be affected by the number of stores; also, for decision 
support purposes, it would be useful to remove returns from sales. Web Report Studio allows the user to add 
expressions that are mathematical functions of the measures. Click on the Custom tab and supply a name, such as 

“Net Sales per Store”. Use the operator buttons to construct an expression; the arrow button in the center moves a 
selected measure to the Expression panel. Now (important note), click the Add button to copy the expression to the 
Custom Items panel. If you do not explicitly add the expression you will not be able to use it. In the example below, 
the Add and Change buttons are deselected, which is the default behavior after an expression has been added; only 
Remove is available. 

 

Figure 14. Adding a Custom Expression 

Click OK to return to the Edit screen. Note that the Section Data panel now includes the new measure. There is a 

series of icons that appear under the Edit and View tabs. Tool tips are available to identify which is which. Click on 
the second from the left Insert Crosstab, as shown. 

 

Figure 15. Insert Crosstab 

Beyond the BasicsSAS Global Forum 2010

 



10 

There are several ways to add data items to the crosstab; one way is to click on Data>Assign Data from the main edit 
menu, or you can right click on the table placeholder. Either way, you should see a chooser dialog. 

 

Figure 16. Arrange Data Items 

By clicking on Move Items, as shown, you can choose which fields go in the rows or columns. For the initial section, 
the Area dimension can be moved to the rows while two measures Net Sales per Store and Number of Stores can be 
the columns. (You can highlight more than one item at a time to move.) Click on the View tab and you should see 
something like the following. 

 

Figure 17. Web Report of Shoe Sales OLAP Cube 
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Notice the difference from the first example, which was based on a table not a cube: next to each region name are 
two icons, a plus sign (expand) and a down arrow (drill down). In the example, Asia has been expanded to show the 
values for the three subsidiaries in the region.  

The drill-down arrow displays just the row level observations for the region, in this case Africa. Note the “breadcrumb” 
trail at the top of Figure 18, allowing you to return to the aggregate display. 

 

Figure 18. Drill-down to detail observations. 

Save the report! Be careful typing the name of the report, since there is no way to change it without using SAS 
Management Console. Click on File>Save as from the Web Report Studio Edit menu (not the browser menu). 

 

Figure 19. Saving the Report 

Beyond the BasicsSAS Global Forum 2010

 



12 

To sort the table rows, right click on the column heading and choose Sort Columns Data. You can do this either from 
the Edit tab or the View tab. Figure 20 shows that Net sales per Store are highest in the Middle East and lowest in 
South America. 

 

Figure 20. Sort table by rows 

Formatting the Report 

Back in the 1970s, during the Neolithic period of computing, a programmer and caving enthusiast named Will 
Crowther invented a text-based game called “Adventure”. The point of the game was to explore an underground 
cavern and to collect the treasures you find there. This was arguably the ancestor of today’s multi-player role-playing 
games. Adventure is memorable for many of its prompts, but perhaps the most famous is “You are in a maze of twisty 
little passages, all alike." There was also a magic word “Xyzzy” to teleport the player to another location in the maze.  

Formatting reports in Web Report Studio is a lot like playing Adventure, with surprises around each corner. There are 
lots of options. Start by renaming the section “Overall” as shown in the first example. (From the Edit tab, select 
Options>Rename Section in the Table of Content panel.) Then click on View on the edit menu and uncheck Applied 
Filters and Data Panel to remove these elements, and choose Report Style>Festival. Right click on the Region 
column heading and select Expand All.  

To add or change the display format for a measure, switch to the Edit tab (not the View tab), right click on the variable 
label in the Section Data panel and select Format. This will bring up a dialog that allows you to select a format for the 
measure. 
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Figure 21. Formatting a Measure 

To add a total row or column, right click on the table (in Edit or View mode) and choose Total. This will bring up a 
form that allows you to select row or column totals and their location on the resulting table. 

 

Figure 22. Adding Totals to a Report 
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The resulting report should now look like the following. Note that the total row for Net Sales per Store is the average, 
while for Number of Stores it is the sum. Web Report Studio automatically uses the correct statistic for the totals. 

 

Figure 23. Shoe Sales with Report Style (Partially expanded) 

In addition to the four standard report styles (Plateau, Seaside, Meadow and Festival), you can change report styles 
and colors by going to File>Properties and selecting the Format tab. 
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Figure 24. Modify Report Format 

You can change the default report style by clicking on Preferences in the upper right of the title bar and selecting the 
Report Creation tab. Finally, an organization can develop a custom theme for all Web Applications. The details of this 
are beyond the scope of this discussion, but see “Administering SAS Web Application Themes” in the SAS 9.2 
Intelligence Platform: Web Application Administration Guide.  

Adding a New Section 

The easiest way to create new report tabs is to open the Edit tab and click on Insert>New Section from the Web 
Report Studio edit menu. This brings up a handy section wizard that allows you to clone previous report sections. 

 

Figure 25. Adding a Report Section 

Drag a table icon to the report palette and right click on the table to select Assign Data. Move Product Type to rows 
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and Net Sales per Store and Number of Stores to the column dimension.  

Next, click on Table of Contents Options and choose Group Breaks.  

 

Figure 26. Add Group Breaks 

You should now get a new report page for each region. After sorting by columns, the report should look like the 
following, complete with a table of contents. As you can see, sandals are not a big seller in the US. 

 

Figure 27. Report by Region 
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There are many more options in Web Report Studio, which are described in detail in the User’s Guide. For now, this 
should be enough to get started with building dynamic Web sites.  

CONCLUSION 

In conclusion, SAS Web Report Studio is a powerful and complex tool for creating customized analytic reports. For 
many users, it can be a viable alternative to the older SAS/InterNet technology. Setting up and maintaining SAS BI 
Server is a significant commitment of time and resources, but once the server has been configured, users with a 
modicum of training in the application can create individual and shared reports with a minimum of time and effort. 
Web Report Studio provides two major advantages over batch programming with PROC FREQ, PROC REPORT or 
PROC TABULATE. First, the client need only have a Web browser such as IE8 or Firefox 3. It is not necessary to 
install PC SAS on the client. Second, users do not need to learn the syntax for these procedures. Instead, tabulations 
can be prepared using a (somewhat) intuitive graphical user interface. SAS has positioned this product for managers 
and executives, but is reality it will be of most value to SAS programmers who want to take advantage of using a Web 
application to design and quickly disseminate reports. 
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