
1 

Paper 331-2009 
 

ODS Graphics Designer 
An Interactive Tool for Creating Batchable Graphs 

Sanjay Matange, SAS Institute Inc., Cary, NC 
 

ABSTRACT  
The SAS/GRAPH® ODS Graphics Designer provides an intuitive GUI interface for creating analytical graphs. The 
software provides a visual gallery of commonly used graphs. You can create your custom graph starting from the 
gallery, or from a blank graph. You can further build up the graph by dragging and dropping additional plots and graph 
features from the “Elements Panel”. Titles and footnotes can be added and edited directly on the graph. You can build 
complex graphs with multiple cells, building up layered graphs in each of cell. You can build classification panels 
using up to two class variables. The graphs can be saved in the extensible graph gallery to the file system.  Saved 
graphs can be run in batch with different data using the SGDESIGN procedure. 

INTRODUCTION 
Effective graphs are an essential part of a data analysis or a report.  A carefully constructed graph can reveal 
associations, clarify differences, and show patterns that are not apparent in the underlying data.  The ODS Graphics 
system provides the ability to create modern analytical graphs using syntax-based tools such as the SAS/GRAPH 
Graph Template Language (GTL) and the SAS/GRAPH Statistical Graphics (SG) procedures.  The GTL is also used 
to define the automatic graphs created by many analytical procedures. 

Although these tools provide the SAS user powerful syntax to create complex graphs, often a user wants the ability to 
create graphs quickly to obtain various views of the data.  Many users who are not familiar with the SAS/GRAPH 
procedure syntax would prefer to use an interactive tool to create their graphs.  Even many experienced SAS/GRAPH 
programmers could use an interactive way to create the graph without having to resort the trial-and-error approach 
needed with syntax-based tools.  

The new ODS Graphics Designer application (henceforth called “the Designer”) provides just such an interactive 
process to create your graphs.  This tool provides a GUI-based, interactive interface to many of the same features 
that are available in GTL.   This application uses the 80/20 rule to provide the 20% features from GTL needed to 
create 80% of the graphs.  The application provides a gallery of commonly used graphs and a building-block 
approach to constructing many different types of graphs. 

Audience:  The audience for the Designer consists of SAS users who are knowledgeable in DATA step and STAT 
procedures and who need to create graphs to explore the data or to present the results of their analyses. These users 
might not be knowledgeable in SAS/GRAPH software and might use third-party software to do their graphics. 

STARTING THE DESIGNER 
Start SAS in DMS mode, and submit the following code in the program window: 
 

%sgdesign; <submit> 

 

Figure 1. SAS Window 
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The Designer GUI window is launched.  When the application starts, the following tasks are done: 
 

•  A new (internal) SAS session is launched and the Designer software connects to this session.  Pertinent 
information about all assigned libraries and formats are sent to the Designer. 

• Some sample data sets needed by Designer sample graphs are created. 
 

If you assign new libraries or define new formats in the DMS session after the Designer is launched, the Designer will 
not know about these.  Resubmit the macro with REFRESH=Y option to send this information to the Designer.  

 
%sgdesign (refresh=y); <submit> 

 
THE DESIGNER GUI   
 
When the software starts, you see the Designer application in a separate window with the following features: 

• the Menu Bar along the top 
• the Toolbar with common items 
• the Graph Gallery, a gallery of commonly used graphs organized in tabs 
• a set of plots and insets on the left side, initially inactive 

 

 
Figure 2. The Designer GUI 

 
THE GRAPH GALLERY 
 
The Graph Gallery contains a tabbed set of commonly used graphs, organized as follows: 

• Basic   – Common graphs 
• Grouped – Graphs showing grouped data 
• Analytical – Graphs commonly used for analysis of data 
• Custom   – A set of graphs showing the possible ways to combine the plots 
• Matrix   – A set of Scatter Plot Matrix graphs 
• Panels   – A set of Classification Panel Graphs 
• MyGraphs – A user defined group 

 

 
Figure 3. Graph Gallery Tabs 
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CREATING A NEW GRAPH FROM THE GRAPH GALLERY 
 
You can create a new graph from the Graph Gallery as follows: 
 

• Select a graph from the Graph Gallery, and select OK. For example, to create a histogram, select the 
Histogram from the Basic tab of the Graph Gallery, and click OK.   

• A new histogram is created, and the Assign Data dialog box is launched.  Note that the histogram has 
SASHELP.CLASS pre-assigned as a placeholder data set.  Also, the X role is set to HEIGHT.  This is done 
to show a visual representation of the selected graph type. 

 

 
Figure 4. Selecting a Graph 

 
Figure 5 shows the Assign Data dialog box for setting the various roles for the histogram.  You can select the 
desired library and data set, and also the desired X roles for the graph.   
The default X axis is the lower axis, and the Y axis is the left-hand axis.  You can change these settings. 

• For this example, select the following settings: 
o Library = sashelp    
o Data set =  Cars 
o X = Horsepower 

 
• Press OK to create the histogram.After 

you click OK, the histogram is created, 
and the Graph Gallery is hidden.  Note that 
the Plots and Insets panels at the left of 
the window are now enabled.  Figure 6 
shows the result. 

• The graph has a title at the top, with the 
placeholder text “Type in your title…” and 
a footnote at the bottom “Type in your 
footnote…”  You can click on these objects 
and customize them to your needs.  To 
remove the title, click the right mouse 
button on the title and select Remove 
Title. 

 

Figure 5. Assign Data Dialog Box 

Figure 6 Histogram 
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ADDING PLOTS TO THE GRAPH 
   
On the left side of the Designer window there are two panels of objects 
as shown in Figure 7 : 

• A Plot Layers panel that contains a number of different plot 
types that can be added to most graphs.  To add a plot to a 
cell of a graph, drag and drop the icon of the plot from the Plot 
Layers panel to the cell.  

• An Insets panel that contains a number of inset objects that 
can be placed inside a cell. 

• To add a new plot to the graph, click on the icon for the plot or 
inset, and then drag and drop it on the graph cell.   Multiple 
plots from the Plot Layers panel can be added to a cell in a 
graph, as long as the data types are compatible.   

• The following plot types can be mixed in a cell: 
 Scatter, Series, Band, Needle, Step, Vector, Regression, 

Loess, PBSpline, Ref Lines, Drop Lines, Contour Ellipse, 
Line 

 Bar, Series, Ref lines, Drop Lines 
 Histograms, Density, Fringe, Ref Lines 

• The GUI provides an indication when a plot cannot be 
combined with existing plots in a cell. 

• You can also drag and drop an inset from the Insets panel 
into a cell.  Legends and entries can be placed in one of nine 
locations around the cell. 
 

ADD A KERNEL DENSITY PLOT 
 
To add a kernel density plot to the histogram, drag and drop the Kernel icon on top of the histogram in the graph.   

• An Assign Data dialog box is displayed, as shown in Figure 8. 
• For convenience, the kernel density can be estimated for one of the existing plots in the cell listed in the 

drop-down box by using the Fit an existing plot option.  In this case, there is only one existing histogram in 
this graph. 

• If you wish, you can assign specific variables to the X role of the density plot.  To do that, deselect the Fit to 
existing plot option to enable variables selection.   Select OK. 

• A kernel density plot is added to the graph on top of the histogram. We have previously updated the title and 
the footnote.   The resulting graph is shown in Figure 9. 

 

 
            Figure 9. Graph with Kernel Density Plot 

 

Figure 7. Plot Layers and Insets  

Figure 8. Assign Data Dialog Box 
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ADDING A NORMAL DENSITY PLOT 
 
To add a normal density plot to the graph, drag and drop the Normal icon on top of the histogram plot in the graph.   

• An Assign Data dialog box is displayed.     
• Select OK. 

 

 
Figure 10. Graph with Kernel Density and Normal Density Plots 

 
In Figure 10, both the kernel and normal density curves have the same visual properties.  To address this, you can 
customize the visual properties of the plots in the graph.  To do this, select one of the plots in the graph with the right 
mouse button, and select Plot Properties from the pop-up menu. 
 

 
Figure 11. Assigning Plot Properties 

 
 
SELECTING A PLOT 
 
As you select different plots in the graph, the selected plot is displayed at full strength, while the other plots in the 
same cell of the graph are dimmed, as shown in Figure 11.  The normal density plot is currently selected, and the 
other plots are dimmed.  Select the Plot Properties menu.  The Cell Properties dialog box is displayed. 
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SETTING PLOT PROPERTIES 
 
The visual properties of a plot can be customized using the 
associated Cell Properties dialog box.   Because we launched this 
from the normal density plot, the dialog box is displayed with the Plots 
tab selected.  Within this, normal is preselected in the Plot field, as 
shown in Figure 12. 
 

• The Plots tab of the dialog box is selected. 
• The name of the plot being edited is shown in the Plot field.  

All plots in the cell of the graph are listed here, and you can 
change to any other plot if needed. 

• In this case, we are editing the properties of the normal plot. 
• Based on the plot type, the user can customize different 

visual attributes of the plot.  For the normal density curve, 
you can change its color, pattern, thickness, and 
transparency. 

• The Legend Label field shows the name that will be 
displayed in a legend if needed. 

• The Style Element field at the top allows a user to select a 
named Style Element bundle from ODS Styles, which 
contains more than one attribute at a time. 

• In this case, let us set a Dash pattern from the drop down list 
for Pattern.  Select OK.  The resulting graph is shown in 
Figure 13. 

 

ADDING A CELL LEGEND 
 
Figure 13 also shows a discrete legend in the upper right corner of the cell.  This is added by a simple drag and drop 
of the Discrete Legend icon from the Insets panel on the left to the desired location in the cell. 
 

 
Figure 13. Graph with Dash Pattern for Normal Density Curve 

 

Figure 12. Cell Properties Dialog Box 

SAS PresentsSAS Global Forum 2009

 



7 

When a discrete legend is placed in a cell, all the plots in the cell are represented in the 
legend by default.  The Legend context menu can be displayed by clicking the right 
mouse button on the legend as shown in Figure 14.  It has the following entries: 

• Legend Contents 
• Legend Properties 
• Remove Legend 

 
To customize the contents shown in the legend, select Legend Contents from the pop-
up menu to launch the Legend Contents dialog box, as shown in Figure 15. 
 
 
 
LEGEND CONTENTS 
 
This dialog box displays the information on the contents of the legend.  
By default, all the plots in the cell are represented in the legend.   The 
dialog box shows the following: 
 

• names of all the plots that can be included in the legend. 
• a check box indicating if the plot is included. 
• the string that will be displayed in the legend to represent each 

plot.  For grouped plots, these come from the data.  For non-
grouped plots, this string comes from the plot name and can be 
edited.  Here we have capitalized the first letters for both Normal 
and Kernel.  

 
We have also unchecked the histogram to exclude it from the legend.  The resulting legend is shown in Figure 16. 
 

 
Figure 16. Legend for the Graph 

 
 
LEGEND PROPERTIES 
 
Figure 17 shows the Legend Properties dialog box that you can use to customize the 
appearance of the Legend.  These include the following: 
 

• the legend title and appearance properties for the title. 
• the fill and outline colors for the background. 
• the position of the legend.  You can select one of the nine compass positions 

or Automatic, which will place the legend in the position of minimum overlap 
with data. 

• the arrangement of the legend entries and wrapping. 
 

 
GLOBAL LEGEND 
 
If you prefer an exterior legend at the bottom of the graph, instead of the legend inside 
the cell, select Insert > Global Legend.  Now you can customize it like the cell legend. 
 

Figure 14 

Figure 15. Legend Contents  

Figure 17. Legend 
Properties 
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ANATOMY OF A GRAPH 
 
The Designer supports the creation of many different types of graphs.  These can generally be 
classif ied into “single-cell” or “mult i-cell” graphs.  Although the terms “graph,” “plot,”  and “chart” 
are often used loosely in the industry, we have assigned specif ic meaning to each term.  It  is 
useful to have a consistent terminology for the various components of graphs.  For this topic, we 
use an example of a two-cell graph shown in Figure 18. 
   

•  Graph :   The entity created by the Designer, individually saved as a f i le or image.  A graph 
is generally made up of the fol lowing: 
o  one or more t i t les at the top 
o  one or more footnotes at the bottom 
o  one or more legends 
o  one or more cells that contain the visuals representing the data  

 
•  Cell :   An independent rectangular subregion in the graph.  Each cell can contain one or 

more plots and other text entries and legends.  A graph can have one or more cells.  The 
graph in Figure 13 has only one cell.  
 

•  Plot :   The visual element that represents the data, such as a scatter plot, a series plot, a 
box plot, a histogram, a bar chart, and so on.  All  of these are referred to by the generic 
term “plot.”  Plots that share the same type of data per axis can be placed in layers. 

 
• Axes :   Each cell has a set of axes that are shared by all  the plots in the cell.   The axes 

are not control led by the plot.  In case of mult i-cell  plots, each cell can have its own axes, 
or columns and rows of cells may share common external axes.  
    

 
Figure 18. Example of a Two-Cell Graph  
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CONTEXT MENUS   
 
Various actions on the graph components can be done by using the context menus.  These are 
displayed by cl icking the right mouse button on different parts of the graph. You can use the 
context menus to perform the fol lowing actions: 
 

•  assign data for individual plots in the graph 
•  set plot properties for individual plots in the graph 
•  set axis properties, including label, t icks, and t ick values  
•  set legend properties, including legend contents 
•  set graph properties, which are the sett ings for the whole graph in one image 
•  adjust cell  contents 
•  set properties for t i t les and footnotes 

 
 
ASSIGN DATA 
 
This dialog box is f irst displayed when a new graph is created 
from the Graph Gallery, or when a new plot is added to a graph 
using the drag-and-drop method.  When first displayed for a new 
plot, the dialog box can assign data only for that particular plot.  
This dialog box can also be displayed by selecting one of the 
plots in the graph with the right mouse button, and selecting the 
Assign Data menu entry.    
 

•  Click on the histogram with right mouse, and select 
Assign Data to display the Assign Data dialog box for 
the histogram, as shown in Figure 19 

•  Note that the Plot Variables tab is active, and the Panel 
Variables  tab is inactive.  We wil l  discuss panel 
variables later.  

•  Note that this dialog box has a drop-down l ist called Plot  
that l ists al l  the plots in this cell ,  as shown in Figure 19.  
Histogram is selected by default. 

•  Change the X role assignment if  needed.  
•  You can also change the name of the plot.  
•  You can change the axis assignments to display either 

the default axes X (bottom) and Y (right), or select the 
combinations you need.   

•  Before you select OK ,  you can select any one of the 
other plots in this cell .   Select kernel  from the Plot  
drop-down l ist.  Now, the dialog box for data assignment 
for the kernel density plot is displayed, as shown in 
Figure 20.  

•  Note:   The Fit to existing plot  option is selected for the 
kernel density plot, and histogram is selected as the 
f i t ted plot.  The histogram wil l  automatically change to 
use whichever data column the histogram is assigned.   

 

SET PLOT PROPERTIES 
 
Various plot properties can be set for any of the plots in the graph by using the Cell Properties 
dialog box. The Cell Properties dialog box includes three tabs, as fol lows: 
 

•  General Tab:  For edit ing the f i l l  and outl ine sett ings for the cell background 
•  Plots Tab:  For edit ing various properties for al l  the plots in the cell 
•  Axes Tab:  For edit ing various properties for al l  the internal axes for the cell 

 

Figure 20. Data Assignment for 
Kernel Density Plot 

Figure 19. Assign Data Dialog Box

SAS PresentsSAS Global Forum 2009

 



10 

GENERAL TAB   
 
To edit the background f i l l  and outl ine sett ings, cl ick the right 
mouse button in the cell background, and select Plot Properties.   
Because no plot was selected, the Cell Properties dialog box is 
displayed with the General  tab activated, as shown in Figure 21.  
This tab shows the controls you can use to edit the f i l l  and outl ine 
sett ings. 
 
PLOTS TAB   
 
To edit the properties for any of the plots in the cell ,  cl ick the right 
mouse button on one of the plots, and select Plot Properties.   The 
plot is selected, and the Cell Properties dialog box is displayed, 
with the Plots  tab selected, as shown in Figure 22. 
 
At the top of the tab is the plot l ist that displays a l ist of al l  the plots 
that are currently included in the cell.   The selected plot is shown 
as selected in this drop-down l ist.  Below this l ist are various 
controls to customize specif ic features of the selected plot.  These 
vary based on the type of the plot.   
 
In this case, we have selected histogram.   For a histogram, you 
can customize the fol lowing features: 

•  Fi l l  options: The Style Element  specif ies the element from 
which the visual attr ibutes are to be obtained. The default 
element is GraphDataDefault .  You can select another 
element from the l ist. Or you can specify a specif ic f i l l  
color using the Color  drop-down l ist. The default Auto  
value is derived from the Color attr ibute of the selected 
element. 

•  Outl ine options: The Style Element  specif ies the element 
for sett ing al l  the visual attr ibutes of the outl ine. The 
default is GraphDataDefault .  You can select another 
element from  the l ist to set al l  the attr ibutes. Or you can 
set each attr ibute individually using the individual controls. 
The default Auto  value is derived from the appropriate 
attr ibute of the element.   

•  Legend Label :   This f ield specif ies the string to be shown in 
the legend for this plot. 

 
You can select any other plot in the cell  for customizing its 
attr ibutes.  
 
AXES TAB    
 
Most cells have up to four axes.  These are as fol lows: 
 

•  X: The horizontal axis at the bottom edge of the cell  
•  Y: The vert ical axis at the left edge of the cell  
•  X2: The horizontal axis at the top edge of the cell 
•  Y2: The vertical axis at the right edge of the cell  

 
To edit the properties of any one of the four axes of the cell,  select 
the axis to be edited with the right mouse button, and select Axis 
Properties.   The Cell Properties dialog box is displayed, with the 
Axes  tab selected, as shown in Figure 23. 

Figure 21. General Tab 

Figure 22. Plots Tab 

Figure 23. Axes Tab 
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Only the axes that have plots associated with them are enabled.  See the “Assign Data” section 
and Figure 19.  The active axes are included in the Axis  drop-down l ist.  The cl icked axis is 
selected in this l ist for customizing.  You can select any of the four axes for customizing.   
 
Various sett ings can be customized using the f ive tabs: 
 

•  Display:    Control the display of various parts of the axis, such as the label, values, 
grids, and t ick marks.  Also set the axis label str ing.  See Figure 23. 

•  Label & Value:   Set the attr ibutes for the axis label and values, such as the font face, 
size, color, and so on.  See Figure 24. 

•  Grid:   Set the attr ibutes for the grid l ines, such as the color, pattern, and thickness.  
See Figure 25. 

•  Advanced:   Control other sett ings for axis, such as type, axis range, t ick sequence, 
and reverse.  See Figure 26. 

 

 

 

 

 

 

 

 

 

 

 

 

 

LEGENDS   

Legend properties can be edited using the Legend context menus.  Select the 
legend with the right mouse button, and select the Legend Properties menu entry.  
Legend properties can be edited as shown in Figures 14, 15 and 17. 

 
CELL CONTENTS 
 
Each cell can contain mult iple plots and insets as fol lows: 

•  Plots are placed in a stack, with the last one drawn on top.   
•  Insets such as legends and entries are drawn on top of plots. 

 
The order of stacking these items in the cell can be customized.  
Press the right mouse button anywhere in the cell and select Cell 
Contents  to display the dialog box shown in Figure 27. 

 
Plots:   The upper tabbed section shows the l ist of plots currently 
existing in the cell.   The plots are rendered in the order they are 
placed, with the last one (shown on top) drawn last.  You can change 
the order of the plots by selecting one of the plots and then cl icking 
the up or down arrows on the right.      
 
Insets:   This section includes the l ist of insets such as legends and entries.  These are always 
drawn on top of the plots, but do have a drawing order amongst themselves. 

 

Figure 24. Axis Label, Value Figure 26. Axis AdvancedFigure 25. Axis Grid

Figure 27. Cell Contents 
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GRAPH PROPERTIES  
 
The properties for the entire graph can be edited using this dialog 
box.  Click the right mouse button anywhere in a cell,  axis legend, 
t i t le, or footnote, and select the bottom menu entry Graph 
Properties to display this dialog box, as shown in Figure 28.  You 
can customize the fol lowing properties of the Graph: 
 

•  Style :   Select one of the many SAS shipped styles or one 
of your own customized styles for this graph. 

•  Background options:   Select a background color. 
•  Size :   Set the output size of the Graph.  Selecting the Keep 

Aspect Ratio  option retains the current aspect ratio when 
changing either the width or the height. 

•  Common Axes:   These check boxes are for use of common 
axes when there is more than one cell in the graph.  More 
on this topic later. 

 
 
TITLES AND FOOTNOTES  
 
Select a t i t le with r ight mouse button and then select the Title Properties to display the Text 
Properties dialog box.  You can do the same for footnotes. 
 
Note:   All  context dialog boxes are available from the Format  menu. 

 

Creating a Graph from Scratch   
 
Select File > New > Blank Graph  to start building a new graph from scratch.  A new blank graph 
is displayed.  Drag and drop plot icons from the Plots Panel as shown in Figure 7.  To add a t i t le 
or a footnote, cl ick on the Title or Footnote icon in the menu bar, or select Insert > Title or 
Insert > Footnote .     
 
Saving a Graph   
 
Select File > Save As to save your graph as a SAS Graph 
Designer (SGD) f i le. 
 
 
Save in the Graph Gallery   
 
Any graph can be saved in the Graph Gallery.  To do this, select 
the File > Save In Graph Gallery menu item.  This action displays 
the Save In Graph Gallery dialog box.  A default icon for the graph 
is automatically created from the current graph.  Fi l l  out the other 
f ields in the dialog box as shown in Figure 29, and cl ick OK .  
 

•  Group name :   You can save a Graph to a user group in the Gallery.  Graphs cannot be 
saved to the groups shipped with the software.  Select a user group from the drop-down 
l ist.  To create a new group, select the New Group  button.   

•  Graph name :   Provide a unique name.  
•  Icon :   Accept the default icon, or select your own using the Browse button.  This icon 

represents this graph in the Graph Gallery. 
•  Tooltip:  Provide a text str ing to show in the toolt ip.  

 
 

Figure 28. Graph Properties 

Figure 29. Save In Gallery
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OPEN A GRAPH 
 
Select File > Open  to open a previously saved graph.  The Open 
dialog box is displayed, as shown in Figure 30.  
 

•  In the Thumbnails view, al l  SGD fi les are represented with 
the SGF fi le icon.   In Figure 30, the ACF.sgd f i le is shown 
with such an icon. 

•  I f  the associated image icon of the graph is available, the 
graph icon is shown.  For example, in Figure 30, the 
CarsHistogram.sgd f i le is represented with the actual 
representative image of the graph. 

 
 
 
MULTI-CELL GRAPHS 
 
So far, we have seen how you can create single-cell graphs in the Designer.  In addit ion to a t i t le, 
a footnote and global legend, these graphs have only one cell with one or more plots from data.  
Mult i-cell  plots are a very powerful way of visualizing data to see data side-by-side, and for 
classif ication panels where the data is subset by one or more class variables.  Different types of 
mult i-cell  graphs include the fol lowing: 
 

•  Gridded graph :  A graph with mult iple cells in a grid without shared axes 
•  Lattice graph :   A graph with mult iple rows and columns with shared axes 
•  Classification panel :  A graph with data classif ied by one or more class variables 
•  Scatter plot matrix:   A graph showing pair-wise relationships between variables 

 
In general, al l  the techniques described t i l l  now for use with single-cell graphs wil l  be reused in 
the mult i-graph scenario.  Instead of dropping all  the plots and insets in one cell,  you can place 
them in the appropriate cell  of the grid. 
 
 
GRIDDED GRAPHS  
 
This graph is made up of mult iple independent cells in a regular grid of rows and columns.  Each 
cell may contain one or more plots and insets.  Let us start with the graph shown in Figure 13, and 
create one used in Figure 18 (Anatomy of a Graph). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 30. File Open  

Figure 31. Add a Column Figure 32. Two Cell Gridded Graph 
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ADD A COLUMN    
 
We have to add a new cell to the graph, and then populate it  as fol lows:   

•  Click the right mouse button in the cell of the graph in Figure 31, and select Add a 
Column  from the context menu.  

•  The graph is split  into two columns, and a new blank cell is added to the right of the 
previous single cell.   The rest of the graph is unchanged.  Now we have the beginnings of 
a mult i-cell  Graph, as shown in Figure 32.  

•  The new empty cell has a hint (drop a plot here…) ,  indicating that new plots and insets 
can now be dropped into the new cell.  Now, drag and drop the Box icon from the Plots 
Panel into the new blank cell.   Assign the plot variables, as shown in Figure 33. 

•  In this case, let us assign HORSEPOWER as the Y (analysis) variable, and ORIGIN as the 
X (group) variable.  We also assign the Y axis to the Y2 (right-hand side) vert ical axis.  

•  The result ing two-cell graph is shown in Figure 34.  Note that the right-hand cell has the Y 
axis plotted on the right side, as requested in the Assign Data dialog box. 
 

•  
•  
•  
•  
•  
•  
•  
•  
•  
•  
•  
•  
•  

 
 

LATTICE GRAPHS  
 
A latt ice graph is similar to the gridded graph, with one important difference.  Rows and columns 
of these graphs can share common axes.  In the graph shown in Figure 34, each X and Y axis has 
a different variable, measure, or statist ic plotted on it .   So it  does not make much sense to share 
the axes.   

 
Sharing of axes implies the fol lowing: 

•  The data ranges are shared and the union of the data ranges are used for al l  axes. 
•  Various axis offsets and thresholds are equalized across all  axes. 
•  Axis type and label are shared.  Often, these have to be set by the user. 

 
Start ing with the graph from Figure 13, let us use the fol lowing actions to create a one-column, 
three-row graph as fol lows: 

•  Using the cell context menu select Add a Row .  This creates a new blank cell .  
•  Drag and drop a Fringe icon into the new cell.  
•  Set the fr inge X variable to HORSEPOWER. 
•  Use the cell context menu in the fr inge plot, and select Add a Row .  This creates another 

new blank cell under the fr inge plot cell .  
•  Drag and drop a Box(H)  (Horizontal Box Plot) icon into the new cell.  
•  Set the box plot Y variable to HORSEPOWER.  Leave the X variable blank. This results in 

the graphic shown in Figure 35. 

Figure 33. Box Plot Assign Data 

Figure 34. Two-Cell Gridded Graph 
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Notice that in Figure 35, al l  cells have equal height 
and each cell has its own X axis.  Even though each 
axis has the same X variable, the axis ranges are 
not necessari ly equal, and the axes might not be 
l ined up.  The histogram axis shows tick marks from 
0-500, while the other plots do not. 
 
In this case, i t  is important that the three plots l ine 
up to show the correct relative distr ibutions.  To do 
this, we have to make all  three cells use a common 
column axis. 
 
Common Column Axis:  As shown in Figure 35, 
select one of the X axes with the right mouse 
button, and select the Common Column Axis menu 
item. 
 
Row Weights:   To provide more space for the top 
cell,  you can interactively resize the heights of the 
cells.  Hover the cursor just above the bottom cell,  
and you wil l  see a vertical cursor and a dashed l ine 
as shown in Figure 36.  Click and drag the l ine to 
resize the cell .    
 
Resize the bottom two cells to have a smaller 
height as shown in Figure 36. 
   
 
 
 
 
 
CLASSIFICATION PANELS 
 
This graph displays a regular grid of cells based on one 
or more classif ication variables.  Each cell displays a 
common set of plots, for a subset of the data based on 
the classif ication variable. 
 
Classif ication panels can be created in one of two ways: 
 

1. Convert a single-cell graph into a classif ication 
panel by adding class variables using the Panel 
Variables  tab. 

2. Start from the Panels tab of the Graph Gallery.  
This tab has many representative cases of data 
panel and data latt ice panels.  

 
FROM A SINGLE-CELL GRAPH 
 
Let us take the example of the graph showing the 
distr ibution of horsepower, as shown in Figure 9.  This 
graph shows the distr ibution over al l  the different cars in 
the data set.  To view the same data classif ied by the 
country of origin, let us use ORIGIN as the classif ication 
variable. 

Figure 36. Three-Row Graph 

Figure 35. Three-Row Graph 

Figure 37. Panel Variables 
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Since ORIGIN has three values, let us make the graph tal ler to accommodate the new graph. 
 

•  Select Graph Properties from the context menu, and 
change the graph width=300, graph height=450. 

•  Select the histogram with the right mouse button, and 
select Assign Data.   The Assign Data dialog box is 
displayed.  This dialog box has two tabs under the 
Data Set  f ield. 

o  Plot Variables:   Sets the variables to be used 
for the histogram. 

o  Panel Variables:   Sets the Row or Column 
class variables. 

•  Select the Panel Variables tab as shown in Figure 37. 
•  In this tab, you have two options for the type of latt ice 

graph.  These are as fol lows: 
o  Data Lattice:   You can specify a row or a 

column class variable, or both.  Each row and 
column is labeled with the value of the class 
variable. 

o Data Panel:   You can specify up to two class 
variables, and each cell is individually labeled 
with the value of each class variable.  

•  Data Lattice is selected by default.  We wil l  accept 
this sett ing for this case. 

•  You can select a Row and a Column class variable.  
Click the Row  drop-down box, and select ORIGIN .  

•  Click OK  to obtain the graph as shown in Figure 38. 
 
Figure 38 shows the distr ibution plot classif ied by the ORIGIN variable.  ORIGIN has three levels, 
“Asia”, “Europe” and “USA.”  Since we set ORIGIN as the Row class variable, the graph is 
automatically spli t  into a panel of three rows with one cell each.  Each row is labeled with the 
value of the class variable.  The entire column has a common X axis. 
 
Note:   Some single cell graphs containing ell ipses or mult iple axes (Y & Y2) cannot be converted.  
In such cases, the Panel Variable tab is inactive. 
 

FROM THE GRAPH GALLERY 
 
Let us create a three-cell column latt ice graph of MPG by Drivetrain and Country of origin.  Select 
the View Graph Gallery icon from the Menu Bar to display the Graph Gallery.  Select the Panels 
tab.  This tab includes various types of classif ication panels.  You can select the kind of panel you 
want, without regard for the actual plot in the cell.   The plot can easily be  changed. 
 

•  Click on Column Lattice .   Select OK .  A two-column latt ice is displayed using the 
work.heart data set, with SEX as the column class variable.   

•  Change the data set to sashelp.cars, and set the Column variable to ORIGIN.  
•  Click OK .   Select Continue on the warning dialog box to get a three cell blank graph. 
•  Drag and drop a Bar   object in one of the cells.  The Assign Data dialog box is displayed.   
•  Set the category variable to DRIVETRAIN and the response variable to MPG_CITY.   
•  Set Statist ics to MEAN, and change the Name to “City”.  Click OK .  Now each cell of the 

graph displays a bar chart with a header showing the class value. 
•  Select Graph Properties from any context menu, deselect Keep Aspect Ratio  and change 

the size of the graph to 500x300. 
•  Drag and drop another Bar  object in a cell .   The Assign Data dialog box is displayed.  
•  Set the category variable to DRIVETRAIN and the response variable to MPG_HIGHWAY.  

Set Statist ics to MEAN, and change the Name to “Highway”.  Press OK .  A second bar chart 
is displayed in each cell overlaying the previous bar.  The width of the new bar is narrower 
by default.  This can be set in the plot properties. 

Figure 38. Panel Variables 
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•  Select the Plot Properties context menu to display the Cell Properties dialog box.  Select 
the City plot, and change its Fill Style Element  to GraphData1 ,  and Transparency to 
40%.  Do not press OK  yet. 

•  Select the Highway plot, and change its Fill Style Element  to GraphData2 ,  and 
Transparency to 40%.    Press OK .  

•  Customize the t i t le and remove the footnote. 
•  Insert a global legend, and select both bar charts in the dialog box.  Press OK .  
•  Select the Y axis context menu, change the label to “MPG”, and turn on the grid l ines to 

get the graph as shown in Figure 39. 
 

 
Figure 39. Classification Panel 

 
 
SCATTER PLOT MATRIX 
 
This is a graph showing pair-wise relationships between mult iple variables of a data set.  You can 
create both square and rectangular matrices, with or without confidence or prediction el l ipses.  For 
square matrices, you can have the diagonal cells display the variable name, or a distr ibution plot 
of the variable. 
 
Scatter plot matrices are special plots that cannot be combined with any other plot.  You can 
create a scatter plot matrix only from the Matrix tab of the Graph Gallery, as shown in Figure 40. 
 

 
Figure 40. Matrix Tab of the Graph Gallery 
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SHARED VARIABLE (SV) GRAPHS 
 
Another important  category of graphs is what we call the shared variable (SV) graphs.  These 
graphs are built  the same way as the other graphs we have discussed so far with the fol lowing 
addit ional requirements: 

•  The entire graph must be created from one data set.  
•  First, the user must define the variables that wil l  be used to make the graph. 
•  Then, al l  plots can be defined using only these pre-defined shared variables.  

 
The need for and benefits of an SV graph wil l  be clear with the fol lowing use case.  Let us take the 
graph in Figure 36.  This is a mult i-cell  graph, with three cells.  Each cell has one or more plots in 
i t .   Note that al l  plots use only one variable, HORSEPOWER. 
 
This is a very useful graph to visualize the distr ibution of a measure.  In fact, after you have built  
this graph, you might want to reuse it to view the distr ibution of some other variables in the same 
or different data set.  Let us say you now want to visualize the distr ibution of the MPG_CITY 
variable.  Here is what you would have to do to get that graph. 
 

1. Top Cell:   Change the variable for the histogram 
from HORSEPOWER to MPG_CITY. 
Because the two density plots are l inked to the 
histogram, these wil l  change automatically. 

2. Middle Cell :   Change the variable for the fr inge plot 
to MPG_CITY. 

3. Bottom Cell :   Change the Y (analysis) variable for 
the box plot to MPG_CITY. 

4. Because the X axis is shared, during the change 
you wil l  see some odd behavior for the X axis, as it 
wil l  briefly display data from both HORSEPOWER 
and MPG_CITY. 

 
Clearly, we need a way to be able to do this easily and 
quickly.  Such plots are often made using many different 
plots, but with a few (or one) variables.   
 
The SV plot is designed for such usage.   To build such a 
plot, you f irst define the variable or variables you want to 
use in a graph.  In this case, we define a shared variable 
V1 and assign it  to HORSEPOWER.  Then, for each of the 
plots in the graph, we wil l  use V1.  Later, to change the 
graph from HORSEPOWER to MPG_CITY, al l  we need to 
do is to change the assignment of V1 to MPG_CITY. 
 
CREATE AN SV GRAPH  
 

•  Select File > New > Blank Shared Variable Graph .   
A blank SV graph is created, and the Assign Data 
dialog box is displayed, as shown in Figure 41. 

•  Select the l ibrary and data set you want to use.  Let 
us use SASHELP.CARS.  

•  Note the new Shared Variables  tab to the left of 
the tabbed panes.   The other tabs are present, but 
currently disabled.  

•  Assign the variable or variables you want to use in 
your graph.  In this case, we wil l  assign V1 to 
HORSEPOWER using the Variables  drop-down l ist.  
By default, the Type  is Any.   Change it to Numeric .    

•  Note :   You can add more shared variables by 
selecting the Add a Variable button.  

Figure 41. Panel Variables 

 
Figure 42. Blank Graph 
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•  Select the right mouse button in the cell area, and 
select Add a Row .   Do this action again to obtain a 
blank graph with three stacked cells.  

•  Move the cursor to the region between the bottom 
two cells ,  and drag the dotted l ine down to resize 
the cell.   Repeat the same for the upper  cells.  The 
result ing blank graph is shown in Figure 42.  

•  Drag and drop a Histogram  icon in the top cell.   The 
Assign Data dialog box for the histogram is displayed, 
as shown in Figure 43.  

• Note:  The data set is SASHELP.CARS, and cannot be 
changed.  The Panel Variables and Plot Variables tabs are 
now active, and the Plot Variables tab is selected. 

• Set the X (analysis variable) to V1 (HORSEPOWER).   Note that 
only the variables previously assigned in the Shared Variables 
tab are available in the drop-down lists for the plots. 

• Drag and drop the two density graphs on top of the histogram.  Set X to V1 in both cases and customize 
them as we did earlier. 

• Drag and drop the Fringe plot with X set to V1 in the middle cell.  Drop a Box plot with Y set to V1 in the 
bottom cell to produce the graph as shown in Figure 44. 

 
 

 
 Figure 44. Shared Variable Graph 

 
Now, to change this plot from HORSEPOWER to MPG_CITY, you just need to bring up the Assign 
Data dialog box, and in the Shared Variable tab, reassign the V1 SV to MPG_CITY or any other 
data set variable. 
 
This can also be done when running this graph in batch mode using the SGDESIGN procedure. 

Figure 43. Panel Variables 
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STYLES 
 
APPLYING A STYLE  
 
You can change the Style of a Graph to any one of the SAS styles shipped with the system by 
using the Format > Style > StyleName  menu.  The recent f ive styles are l isted in the menu.  
Other styles can be accessed from the More Styles dialog box, including any custom styles.  In 
Figure 45, we have changed the style of the graph to Analysis .  
 

 
Figure 45 – Classification Panel with Analysis style 

 
EDITING OR CREATING A STYLE   
 
You can edit a SAS style, and  save it as a custom style.  Start the Style Editor tool from the Tools 
> Style Editor menu.  The Style Editor is displayed, as shown in Figure 46.  You can edit the 
current style or create a new style.   
 
Note:   Styles supplied by SAS cannot be changed.  You can edit one of the styles supplied by 
SAS, but then it has to be saved under a new name.  This is a restrict ion in the Designer, and not 
in the styles themselves. 
 

 
Figure 46. Graph Style Editor 
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VIEW CODE 
 
As mentioned earl ier, the Designer is a GUI-based interactive application that leverages the 
feature set of the GTL syntax behind the scenes.  As you build a graph, the necessary 
STATGRAPH template is created using the appropriate GTL syntax.  You can view the syntax for 
the currently active graph by selecting View > Code.  
 

Figure 47. Distribution Plot Figure 48. Code for the Plot 
 
Figure 47 shows the distr ibution plot we created earl ier.  To view the STATGRAPH template code 
for this graph, select the graph, and then select View > Code.   The code for the graph is 
displayed in the Code window, as shown in Figure 48.   
 
We wil l  not go into the details of the GTL code here as that is beyond the scope of this document.  
However, Figure 48 shows the fol lowing structure of the template:  
 

•  the PROC TEMPLATE statement and the DEFINE STATGRAPH statements. 
•  the outermost  BEGINGRAPH – ENDGRAPH block. 
•  an ENTRYTITLE statement for the t i t le at the top. 
•  an ENTRYFOOTNOTE statement for the footnote at the bottom. 
•  a LAYOUT LATTICE – ENDLAYOUT block.  This block al lows for two cells. 

o  a LAYOUT OVERLAY  – ENDLAYOUT block defining the left cell .  
 a HISTOGRAM statement. 
 a DENSITYPLOT statement for the kernel density curve. 
 a DENSITYPLOT statement for the normal density curve. 
 a DISCRETELEGEND statement for the legend in the top right corner. 

o  a LAYOUT OVERLAY – ENDLAYOUT block defining the right cell .    
 a BOXPLOT statement. 

 
You can cut and paste this code in a SAS Program Editor window and run the program to create 
this template.  You can create the graph using the SGRENDER procedure. 
 
 
THE SGDESIGN PROCEDURE 
 
Any graph produced by the Designer and saved as an SGD fi le can be sent to any ODS destination 
by using the SGDESIGN procedure.  The basic syntax of the procedure is as fol lows: 
 

PROC SGDESIGN SGD=”sgd-file-name”; 
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I f  the graph shown in Figure 39 is saved to the CarsPanel.sgd f i le on the C: drive, then this graph 
can be sent to the HTML destination by using the fol lowing syntax.  The graph uses the original 
data set that was used when creating the graph. 
 

ods html; 
proc sgdesign sgd=’c:\CarsPanel.sgd’;  run; 
ods html close; 
 

You can create a graph from a different data set as long as the new data set has variables of the 
same name and type.  
 

data sedans; 
  set sashelp.cars; 
  where type="Sedan"; 
run; 
 
ods html; 
proc sgdesign sgd="c:\CarsPanel.sgd" data=sedans;  run; 
ods html close; 
 

 
SHARED VARIABLE GRAPHS  
 
For running an SV graph using this procedure, the shared variables can be set using the 
DYNAMIC option of the procedure.  So, the graph shown in Figure 44 can be run for different 
variables by sett ing the dynamic V1 to other variable names as fol lows: 
 

ods html; 
 
proc sgdesign sgd=’c:\SVHistogram.sgd’; 
  dynamic V1=”MPG_City”;  run; 
 
proc sgdesign sgd=’c:\ SVHistogram.sgd’ data=sashelp.heart; 
  dynamic V1=”Cholesterol”;  run; 
 
ods html close; 

 
 

THE SGDESIGN MACRO 
 
The %SGDESIGN macro is the method for starting the ODS Graphics Designer application. Normally, you would 
invoke it without any parameters from the Program Editor in DMS mode: 
 
 %sgdesign; 
 
This macro does not work when invoked from the command prompt. It also does not work in batch mode.  
The following is a common option for this macro: 
 
REFRESH= Y | N 

If you add or modify any data sets or format options, you should run %sgdesign(refresh=y) to pick up 
your changes. These changes will not be reflected in the Designer otherwise. Default = N. 

 
Using the %SGDESIGN Macro:  To start the Designer normally, submit the fol lowing code: 
 

 %sgdesign;                                  
 
To pick up any new libraries, data sets or format-related option changes in the DMS session while designer is 
running, submit the following code: 
 
 %sgdesign(refresh=y)

SAS PresentsSAS Global Forum 2009

 



23 

SOME SAMPLES 
 
Layouts, plots, and insets with legends, t i t les, and footnotes can be combined in innumerable ways 
to produce the graph you need.  Here are some common examples. 
 

  

  

Figure 49 - Samples 
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CONCLUSION 
The ODS Graphics Designer is a powerful application to create analytical graphs that uses an interactive, GUI-based 
process.  The application is based on the same underlying technology as that which creates the graphs in the ODS 
Graphics system, so the output is consistent in features and appearance with the rest of the ODS graphics output.  
Now you can do all your work within the SAS environment, and do not need to export your data to other software just 
for graphics.   

Additionally, any graphs you build can be run in batch with different data and variable assignments using the 
SGDESIGN procedure.  You can also use the Designer as a learning tool to come up to speed on GTL programming.  
The Designer builds STATGRAPH templates to do the graphs, and you can view these templates as you change your 
graph step by step.  To go beyond the Designer feature set, you can cut and paste the GTL code into a SAS Program 
Editor window and extend it as needed. 
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