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1.1 SAS Enterprise Guide Windows 
SAS Enterprise Guide has many windows. You can customize the appearance of SAS Enterprise 
Guide—closing some windows, opening others, and resizing them all—until it looks just the 
way you want. Then SAS Enterprise Guide will remember those settings so the next time you 
open it, everything will be just where you left it.  

Here is SAS Enterprise Guide with its windows in their default positions.  

  

Some windows are open by default while some are closed or hidden behind other windows. You 
can open or unhide the major windows using the View menu.  

Docked windows  Some of the windows in SAS Enterprise Guide are docked. Most of the 
docked windows can appear on the left or right side of the application. To change a window 
from one side to the other, click the down arrow (▼) in the upper-right corner of the window 
and select Dock Left or Dock Right from the pop-up menu. From this menu, you can also select 
Auto Hide. If you hide a window, it will be reduced to a tab along the side. To view a hidden 
window, position your cursor over the window’s tab. When you move the cursor out of the 
window, it will be reduced to a tab again. To unhide a window, click its tab or select it from the 
View menu. These windows are docked: 

Project Tree  The Project Tree window displays the items in a project in a hierarchical 
tree diagram. This window is open by default. 

Workspace showing  
the Process Flow 

Resources pane showing 
the Server List 

Project Tree 
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Server List  The Server List window lists available SAS servers, and the files and SAS 
data libraries on those servers. A SAS server is any computer on which SAS software is 
installed. The computer on which you run SAS Enterprise Guide may or may not be a 
SAS server. This window appears in the Resources pane, and is open by default. 

Task List  The Task List window lists all available tasks and task templates. Using the 
drop-down list at the top of this window, you can choose to display tasks by category, 
tasks by name, or task templates. You can open a task by double-clicking its name in 
this window. This window appears in the Resources pane, and is closed by default. To 
open this window, click its icon in the Resources pane. 

 SAS Folders  The SAS Folders window lists any folders that have been defined in 
metadata. This window appears in the Resources pane, and is closed by default. To open 
this window, click its icon in the Resources pane. 

 Prompt Manager  The Prompt Manager window lists any prompts defined for the 
current project. This window appears in the Resources pane, and is closed by default. 
To open this window, click its icon in the Resources pane. 

Task Status  The Task Status window displays notes about tasks that are currently 
running. This window is different from other docked windows because it is docked to 
the bottom of the application, and you cannot move it or reduce it to a tab. This window 
is closed by default. To open the Task Status window, select it from the View menu.  

Workspace  The workspace is not itself a window, but it is very important. This is where the 
Process Flow and document windows appear. The workspace is always there and cannot be 
closed. However, you can open and close individual items inside the workspace.  

Process Flow  The Process Flow window displays the items in a project and their 
relationship using a process flow diagram. You can open only one project at a time, but 
you can create as many process flows as you wish inside a single project. You can open 
the Process Flow by selecting it from the View menu, by double-clicking its name in the 
Project Tree, by selecting it from the drop-down list at the top of the workspace, by 
selecting the  drop-down list on the menu bar, or by pressing F4.  

 Document windows  The document windows display your data, results, programs, 
logs, and notes. There is a different type of icon for every kind of document. This icon 
represents a SAS data table.  

Menus and tools  The menus and tools across the top of SAS Enterprise Guide (also called 
the menu bar) are always the same. However, the menus and tools inside the workspace (also 
called the workspace toolbar) change. For example, the options above a Process Flow are 
different from the options above a data table. You can also right-click many objects to open a 
pop-up menu for that object. So you can see that there are often several ways to do the same 
thing. This book cannot list all the ways to do every action, but with a little exploration you can 
find them.  

Restoring windows  Once you have rearranged your windows, you may decide you want 
them back where they started. To restore them to their original locations, select Tools ► Options 
from the menu bar. Then in the General page of the Options window, click Restore Window 
Layout. 
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1.2 Splitting the Resources Pane and Workspace 
The Resources pane and the workspace are busy places. The Resources pane is home to four 
windows, while the workspace accommodates even more. By default, you can see only one item 
at a time, but you can see more if you split the Resources pane or workspace.  

Splitting the 
Resources pane  To 
split the Resources 
pane, click the down-
arrow (▼) at the top of 
the pane, and select 
Show Multiple from 
the pull-down list. At 
first, you will only see 
one window because 
only one window is 
open.  

 

 

 

 

To open other windows, 
click their icons: Task 

List , SAS Folders 

, Server List , 

or Prompt Manager .  
You can open all four 
windows at once in the 
Resources pane if you 
wish. In this example, 
two windows are open, 
the Task List and the 
Server List. 

To return the Resources 
pane to normal, click the 
down-arrow and select  

                                                                                                                                Show One.  
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Maximizing the workspace  It may be helpful to make the workspace as large as possible 
before you split it. To do this, select View ► Maximize Workspace from the menu bar. When 
you maximize the workspace, the Project Tree and Resources pane become tabs pinned to the 
edge of SAS Enterprise Guide. You can temporarily expand those windows by moving the 
cursor over a tab. When you move the cursor away, the window will be reduced to a tab again. 
To return the workspace to its normal size, select View ► Maximize Workspace again. 

Splitting the 
workspace  You 
can split the 
workspace into two 
pieces. First, open 
any items you wish to 
view. Then click the 
Workspace Layout 
icon on the menu bar 

, and select 
either Stacked or 
Side By Side from 
the pull-down list. 
You can also do this 
by selecting View ► 
Workspace Layout 
from the menu bar. 

You can click the 
down-arrow at the 
top of the workspace 
to view a drop-down 
list of all items that 
are currently open. To 
display an item, select 
it from the list.  

To unsplit the 
workspace, click the 
Workspace Layout 
icon again, and select 
Single from the pull-
down list. You can 
also click one of the 
Xs in the upper-right 
corners to close that 
section of the  

                                                                                                                                    workspace. 
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1.3     Projects 
In SAS Enterprise Guide, all the work you do is organized into projects. A project is a collection 
of related data, tasks, results, programs, and notes. Projects help you by keeping track of 
everything, even if your data are scattered in many directories or on more than one computer. 
That way, when you come back to an old project six months or a year later, you won’t be left 
wondering which data sets you used or what reports you ran.  

You can have as many projects as you like, and you can use a data set over and over again in 
different projects, so there is a lot of flexibility. However, you can have only one project open at a 
time. Also, if you share a project file with someone else, that person must have access to your 
data files and any other items you reference. 

To create a new project, select File ► New ► Project from the menu bar. To open an existing 
project, select File ► Open ► Project and navigate to your project. 

Project Tree and Process Flow  The Project Tree window displays projects in a 
hierarchical tree diagram, while the Process Flow window displays projects using a process flow 
diagram. In either window, the items in your project are represented by icons, and connected to 
show the relationship between items. Here are examples of a Project Tree and a Process Flow 
showing the same project. This project contains several types of items: data, tasks, results, a 
program, and a note.  

          

Data  Data files in a project may be SAS data tables, raw data files, or files from other 
databases or applications, such as Microsoft Excel spreadsheets. Projects contain 
shortcuts to data files, not the actual data. If you delete a project, your data files will still 
exist. This icon represents a SAS data table. 

Tasks Tasks are specific analyses or reports that you run, such as List Data or Bar 
Chart. Every time you run a task, SAS Enterprise Guide adds an icon representing that 
task. This icon represents the Bar Chart task. 

Results  Results are the reports or graphs produced by tasks you run. Results are 
represented by icons labeled with the type of output (SAS Report, HTML, PDF, RTF, or 
text) and the name of the task. This icon represents output in SAS Report format. 
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Notes  Notes are optional text files you can use to document your work, or record 
comments or instructions for later use. To create a note, select File ► New ► Note from 
the menu bar. A text window will open, allowing you to type whatever you wish.  

Programs  Programs are files that contain SAS code. You can open existing programs 
in SAS Enterprise Guide, or you can write new programs. 

Showing properties and opening items  You can display the properties for any item by 
right-clicking its icon in the Project Tree or Process Flow and selecting Properties from the pop-
up menu. You can open any item by double-clicking its icon, or by right-clicking its icon and 
selecting Open from the pop-up menu.  

 

Renaming and deleting items  You can rename most items by right-clicking the item and 
selecting Rename from the pop-up menu. You can delete an item in a project by right-clicking 
and selecting Delete. Note that if you delete data from a project, only the shortcut to that data is 
deleted, not the actual data file.  

Saving a project  To save a project, select File ► Save project-name or File ► Save project-
name As from the menu bar. Each project is saved as a single file and has a file extension of .egp. 
You can save data, programs, and results in separate files by right-clicking the icon for that item 
and selecting Export from the pop-up menu. 
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1.4 Managing Process Flows 
In SAS Enterprise Guide, you can have only one project open at a time. However, you can have 
an unlimited number of process flows within a single project. So, if you have a complex project, 
you may want to divide it into several process flows.  

Adding new process flows  To add a 
new process flow to a project, select File ► 
New ► Process Flow from the menu bar, or 
right-click the current process flow and 
select New ► Process Flow from the pop-
up menu. No matter how many process 
flows you create, the Project Tree will show 
all of them in a single tree diagram. 

When you right-click a process flow, the 
pop-up menu displays options for 
customizing the appearance of that process 
flow. Options include Grid, Layout, Auto 
Arrange, Zoom, and Background Color. 

To view a process flow, double-click its 
name in the Project Tree, or click the down-
arrow (▼) above the workspace to open a 
pull-down list. 

When you add a new process flow, it is named Process 
Flow n. To give a process flow a more descriptive name, 
right-click its name in the Project Tree and select Rename 
from the pop-up menu. To delete a process flow, right-
click its name in the Project Tree and select Delete from 
the pop-up menu. 

Moving and copying items  To move items from 
one process flow to another, hold down the control key 
(CTRL), and click all 
the items you want to 
move. Then right-
click, and select Move 
to ► process-flow-
name from the pop-up 
menu. In this 
example, three items 
are being moved to 
the process flow 
named TourReports.  
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Copying items is similar to moving items except that you cannot copy results. Select the items to 
be copied using control-click. Then right-click the items and select Copy from the pop-up menu, 
and right-click the target process flow and select Paste.  

Linking items  When you run a process flow, items are   
executed from top left to bottom right, following the 
branches created by links between items. You can add links 
between items to show relationships that may not be clear, 
or to force items to run in a particular order. For example, if 
you create a format that is used by a task, you might want 
to add a link indicating that the task follows the format. To 
add a link, right-click the initial item and select Link item-
name to from the pop-up menu. A Link window will open 

showing all the 
other items to which 
you can link. Select 
the item to which 
you want to link, 
and click OK.  

 

 In this process flow, the Volcanoes data icon has been linked 
to a program icon to show that this program uses the 
Volcanoes data table. Notice that when you add links they 
use a dashed line instead of a solid line.  

To delete a link that you previously added, right-click the 
icon for that link in the Project Tree and select Delete 
from the pop-up menu.  

 

 

Printing process flows You can print a 
copy of your process flow. To control page 
size and orientation, click the process flow 
and select File ► Page setup for Process Flow 
from the menu bar. To preview a printout, 
select File ► Print preview for Process Flow. 
To print the process flow, select File ► Print 
Process Flow. Here is the Print preview 
window for the VolcanoReports process flow.  
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1.5     Running and Rerunning Tasks 
Running tasks is, of course, what SAS Enterprise Guide is all about. Regardless of which task 
you choose to run, the basic steps are the same: open the task, select the data, and then run the 
task.  

Opening a task  To 
open a task, select it from 
the Tasks menu, or click its 
name in the Task List 
window, or open a Data 
Grid and then select the 
task from the workspace 
toolbar. The window for 
that task will open. In this 
example, the List Data task 
is being selected in the 
Task List window.  

Selecting the data 
table  When you open a 
task, it will use the data 
table that is currently 
active. If a Data Grid is 
open, then that data table 
will be active. You can also 
make a data table active by 
simply clicking its icon in 
the Project Tree or Process 
Flow before you open a 
task.  

After you open a task, you 
can change the data table 
by clicking the Edit button 
in the Data page of the 
task window. The Edit 
Data and Filter window 
(not shown) will open 
where you can choose an 
alternate data table for the 
task. See section 5.1 for 
details about the Edit Data 
and Filter window. 
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Running a task  Every task includes a Data page where you assign variables to task roles. 
Using the selection pane on the left, you can open other pages. The preceding image shows the 
List Data task, which has four pages: Data, Options, Titles, and Properties. When you are 
satisfied with all the settings, click the Run button. If you have more than one SAS server, your 
task will run on the same server where the data table is stored. If you decide you want to stop a 

task while it’s running, select Program ► Stop from the menu bar, or click the Stop button  on 
the workspace toolbar above the Process Flow. When the task has finished running, the results 
will be displayed in the workspace.  

Rerunning a task  
To make changes to a 
task and run it again, 
first reopen the task 
window. You can do 
this by clicking Modify 
Task on the workspace 
toolbar for the Results 
tab. You can also 
reopen a task by right-
clicking the task icon in 
the Project Tree or 
Process Flow, and 
selecting Modify task-
name from the pop-up 
menu.  

 

Once the task window   
is open, you can make 
changes. Then click the 
Run button to rerun 
the task.  

If you just want to 
rerun a task without 
reopening the task 
window, click Refresh 
on the workspace 
toolbar for the Results 
tab. You can also right-
click the task icon in 
the Project Tree or 
Process Flow, and 
select Run from the 
pop-up menu.  
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1.6 Creating and Exporting Task Templates 
Even with the simplest tasks, there are many ways to customize your results. Once you have 
spent a lot of time changing titles, choosing options, and specifying a style; you might wish you 
could save all those settings and use them to create new results. With task templates, you can.  

Task templates allow you to save tasks in a form that is independent of data. In other words, task 
templates save all your settings except the assignment of variables to task roles and certain data-
dependent options. Most tasks can create templates, but a few of the more data-driven tasks 
(including Summary Tables and Append Table) cannot. SAS programmers will be interested to 
know that task templates are unrelated to the various kinds of templates created by the Output 
Delivery System. 

Creating a task template  To 
create a task template from a task 
that you have already run, select 
Tasks ► Task Templates ► Task 
Template Manager from the menu 
bar. This opens the Task Template 
Manager. Click New to open the 
New Task Template window. 

 

 

 

In the New Task Template window, type a name for the 
new template in the Name box. You can type an optional 
description in the Description box if you wish. The area 
labeled Create template from task lists all the tasks 
currently in the project. Choose a task by clicking its name. 
Then click Create. The new task template will be listed in 
the Task Template Manager. Click Close.  

You can also create task templates directly from tasks. If the 
task window is open, then you can click the down-arrow 
(▼) on the Run button, and select Create Template from the 
pull-down list.  

To delete a task template, simply open the Task Template 
Manager, click the task template name, and click Delete.  
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Using a task template  Once you create a task template, unless you delete it, it will be 
available to you every time you open SAS Enterprise Guide. There are two ways to open a task 
template. You can select Tasks ► Task Templates ► task-template-name from the menu bar, or 
you can open the Task List window, select Task Templates from the drop-down list, and click the 
name of your task template.  

By default, when you open a task template, it uses the active data table. After you open a task 
template, you can choose a different data table by clicking the Edit button in the Data page. 

 
Exporting a task template  When you create a task template, it will be saved in a default 
location. This location is associated with your Windows user account. To share task templates with 
other people (including anyone who uses the same computer, but a different Windows account), 
you must export the templates. To 
do this, open the Task Template 
Manager, and click Export. SAS 
Enterprise Guide will prompt you to 
select the templates you wish to 
export, and to specify a location for 
saving them. 

To import task templates, open the 
Task Template Manager and click 
Import. Then navigate to the 
location of the task templates you 
wish to import.  
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1.7 SAS Data Tables 
SAS Enterprise Guide can read and write many kinds of data files (see Chapter 2 for more on this 
topic), but for most purposes, you will want to have your data in a special form called a SAS data 
table. When you open a SAS data table, it is displayed in the workspace in a Data Grid. The 
following Data Grid shows the Tours data table that was created in Tutorial A. A new tour has 
been added for the volcano Lassen.  

 

 

 

Terminology  In SAS Enterprise Guide, rows are also called observations, columns are also 
called variables, and data tables are also called data sets. SAS Enterprise Guide uses all these 
terms. Some tasks use the term columns and others refer to variables, depending on the context.  

Data types and data groups   In SAS Enterprise Guide, there are two basic types of data: 
numeric and character. Numeric data are divided into four data groups: numeric, currency, time, and 
date. For each of these, SAS Enterprise Guide has special tools: informats for reading that type of data, 
functions for manipulating that type of data, and formats for displaying that type of data. SAS 
Enterprise Guide uses a different icon to identify each kind of data. 

 Character data may contain numerals, letters, or special characters (such as $ and !) and 
can be up to 32,767 characters long. Character data are represented by a red pyramid 
with the letter A on it. 

  Currency data are numeric values for money and are represented by a picture of the 
dollar, euro, and yen symbols. 

  Date data are numeric values equal to the number of days since January 1, 1960. The 
table below lists four dates, and their corresponding SAS date and formatted values: 

Date                            SAS date value      MMDDYY10. formatted value 
January 1, 1959          -365                           01/01/1959 
January 1, 1960          0                                01/01/1960 
January 1, 1961          366                            01/01/1961 
January 1, 2010 18263                         01/01/2010 

Columns 
(also called Variables) 

Rows  
(also called Observations) 

Data Table  
(also called a Data Set) 
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You will rarely see unformatted SAS date values in SAS Enterprise Guide. However, 
because dates are numeric, you can use them in arithmetic expressions to find, for 
example, the number of days between two dates. Datetime values are included in this 
data group, and are the number of seconds since January 1, 1960. Date data are 
represented by a picture of a calendar. 

Time data are numeric values equal to the number of seconds since midnight. Time data 
are represented by a picture of a clock.  

Other numeric data, that are not dates, times, or currency, are simply called numeric. 
They may contain numerals, decimal places (.), plus signs (+), minus signs (-), and E for 
scientific notation. Numeric data are represented by a blue ball with the numbers 1, 2, 
and 3 on it. 

Numeric versus character  If the values of a column contain letters or special characters, 
they must be character data. However, if the values contain only numerals, then they may be either 
numeric or character. You should base your decision on how you will use the data. Sometimes data 
that consist solely of numerals make more sense as character data than as numeric. Zip codes, for 
example, are made up of numerals, but it just doesn’t make sense to add or subtract zip codes. Such 
values work better as character data. 

Column names  Column names in SAS Enterprise Guide may be up to 32 characters in length, 
and can begin with or contain any character, including blanks. 

Moving data between SAS Enterprise Guide and Base SAS  Any data created in 
SAS Enterprise Guide can be used in Base SAS, but the default rules for naming variables are 
different. Base SAS uses the VALIDVARNAME=V7 SAS system option, while SAS Enterprise 
Guide uses VALIDVARNAME=ANY. For the sake of compatibility, you may want to follow these 
rules when naming columns: choose column names that are 32 characters or fewer in length, start 
with a letter or underscore, and contain only letters, numerals, and underscores.  

Missing data  Sometimes, despite your best efforts, your data may be incomplete. The value of 
a particular column may be missing for some rows. In those cases, missing character data are 
represented by blanks, and missing numeric data are represented by a single period (.). In the 
preceding Data Grid, the value of Price is missing for the tour of Lassen, and its place is marked by 
a period. The value of Difficulty is missing for the same tour and is left blank.  

Documentation stored in SAS data tables  In addition to your actual data, SAS data 
tables contain information about the data table, such as its name, the date that you created it, and 
the version of SAS you used to create it. SAS also stores information about each column in the data 
table, including its name, type, and length. This information is sometimes called the descriptor 
portion of the data table, and it makes SAS data tables self-documenting. This information is what 
you see in the Properties windows for data tables and columns. These Properties windows are 
described in more detail in the next two sections. 
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1.8 Properties of Data Tables 
Someday you may be given a SAS Enterprise Guide project that was created by someone else. If 
you are unsure what the project does, then it would be a good idea to start by checking the 
properties of the data tables.   

Opening the Properties window  To display information about a data table, first open it 
in a Data Grid by double-clicking the data icon in the Project Tree or Process Flow. Then click the 

Properties icon  on the workspace toolbar to open the table Properties window. 

 

You can also right-click a data icon in the Project Tree or Process Flow, and select Properties from 
the pop-up menu.
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General page  
When the table 
Properties window 
opens, it displays the 
General page. The 
General page lists basic 
information about the 
table: its name, when it 
was created and last 
modified, and whether 
it is a SAS data table or 
some other type of file.  

 

 

 

 

 

 

Columns page  If 
you click Columns in 
the selection pane on 
the left, the Columns 
page will open. Here, 
SAS Enterprise Guide 
displays information 
about each column: its 
name, type, length, 
format, informat, and 
label. You cannot 
change the properties 
of columns in the 
Properties window for 
a data table. To make 
changes, use the 
Properties window for 
an individual column 
as described in the 
next section.  
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1.9 Properties of Columns 
The column Properties window displays properties for an individual column. You can use this 
window inside a task to change labels and display formats, but those changes will apply only to 
the results of that task rather than the original data table. However, if you open the column 
Properties window inside a Data Grid, then any changes you make will be saved with the data 
table. 

Setting the update mode  The Data Grid opens in read-only mode. In this mode you 
cannot edit the data, and you cannot change column properties. To switch to update mode, select 
Edit ► Protect Data from the menu bar. This toggles the data table from read-only to update 
mode. To return to 
read-only mode, 
select Edit ► Protect 
Data again. 

Opening the 
Properties 
window  To open 
the column 
Properties window, 
right-click the 
header of a column 
and select 
Properties from the 
pop-up menu. In 
this Data Grid, 
Properties is being 
selected for the 
column Height. 

General page  The Properties 
window has several pages. If there is no 
selection pane on the left, then the data 
table is in read-only mode and you 
need to switch to update mode. 

The General page displays basic 
information for the column: its name, 
label, type, group, and length. You can 
change any of these properties. In this 
example, the column name has been 
changed to HeightMeters, and the label 
to Height in Meters. This column is 
numeric and has a length of 8.  
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Informats page  Click Informats in the 
selection pane on the left to open the 
Informats page. Informats (also called input 
formats or read-in formats) tell SAS 
Enterprise Guide how to interpret input 
data. There are different informats for 
character, numeric, date, time, and currency 
data. In this example, the column uses the 
default numeric informat, w.d, with a width 
of 6 and no decimal places. This informat 
can be written as 6.0. See the next section 
for a table of commonly used informats.  

In SAS Enterprise Guide 4.2, you can use 
informats when you import data files, and 
when you write SAS programs. However, 
informats are not used when you type data 
values into a Data Grid. Instead, the Data 
Grid uses the data type and data group that 
you specify to determine how to interpret 
any data values you enter. 

Formats page  Click Formats in the 
selection pane on the left to open the 
Formats page. Formats (also called display 
formats) tell SAS Enterprise Guide how data 
should look in Data Grids or reports. There 
are different formats for character, numeric, 
date, time, and currency data. In this 
example, the format COMMAw.d with a 
width of 6 and no decimal places has been 
selected. This format can be written as 
COMMA6.0. See section 1.11 for a table of 
commonly used formats. 

 

 

 

 

Results  Here is the Data 
Grid showing the new name, 
HeightMeters, and the 
format with commas.  
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1.10 Selected Informats 
SAS informats (also called input formats or read-in formats) tell SAS Enterprise Guide how to 
interpret input data. You can specify informats when you import data, in a SAS program, or in a 
Data Grid. However, in SAS Enterprise Guide 4.2, informats are not used to interpret data that you 
type into a Data Grid. Here are a few of the many informats available in SAS Enterprise Guide. 

Informat Definition Width range Default width 

Character    

$w. Reads character data—trims leading blanks 1–32,767 none 

$UPCASEw. Converts character data to uppercase 1–32,767 8 

Date, Time, and Datetime1 

ANYDTDTEw. Reads dates in any form—when dates are 
ambiguous, uses the DATESTYLE system 
option to determine 

5–32 9 

DATEw. Reads dates in the form: ddmonyy or 
ddmonyyyy 

7–32 7 

DATETIMEw. Reads datetime values in the form: 
ddmonyy hh:mm:ss.ss 

13–40 18 

DDMMYYw. Reads dates in the form: ddmmyy or 
ddmmyyyy 

6–32 6 

JULIANw. Reads Julian dates in the form: yyddd or 
yyyyddd 

5–32 5 

MMDDYYw. Reads dates in the form: mmddyy or 
mmddyyyy 

6–32 6 

TIMEw. Reads time in the form: hh:mm:ss.ss 
(hours:minutes:seconds—24-hour clock) 

5–32 8 

Numeric 

w.d Reads standard numeric data 1–32 none 

COMMAw.d Removes embedded commas and $, 
converts left parentheses to minus sign 

1–32 1 

PERCENTw. Converts percentages to proportions 1–32 6 

 

1  SAS date values are the number of days since January 1, 1960. Time values are the number of seconds past midnight, and 
   datetime values are the number of seconds past midnight on January 1, 1960. 
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The examples below show input data and resulting data values for each informat. The results 
shown are unformatted data values. See sections 3.1 and 3.2 for information about assigning 
display formats. 

 

Informat Input data Results Input data Results 

Character 

$10. Lassen Lassen St. Helens St. Helens 

$UPCASE10. Lassen LASSEN St. Helens ST. HELENS 

Date, Time, and Datetime 

ANYDTDTE10. 

 

01jan1961 
1961001 

366 
366 

31.01.1961 
01/31/61 

396 
396 

DATE9. 1jan1961 
 

366 31 jan 61 396 

DATETIME14. 1jan1960 10:30 
 

37800 1jan1961 10:30 31660200 

DDMMYY10. 01.01.1961 

 

366 31/01/61 396 

JULIAN7. 1961001 
 

366 61031 396 

MMDDYY10. 01-01-1961 
 

366 01/31/61 396 

TIME8. 10:30 
 

37800 10:30:15 37815 

Numeric 

5.1 1234 123.4 -12.3 -12.3 

COMMA10.0 $1,000,001 1000001 (1,234) -1234 

PERCENT5. 5% 0.05 (20%) -0.2 
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1.11 Selected Standard Formats 
SAS formats (also called display formats) tell SAS Enterprise Guide how to display or print data. 
You can apply formats in a column Properties window in a Data Grid, a task, or a query. Here are a 
few of the many formats available in SAS Enterprise Guide. 

Format Definition Width range  Default width 

Character 
$UPCASEw. Converts character data to uppercase 1–32767 Length of variable or 8 
$w. Writes standard character data—default for 

character data 
1–32767 Length of variable  

or 1 
Date, Time, and Datetime1 
DATEw. Writes SAS date values in form ddmonyy or 

ddmonyyyy 
5–9 7 

DATETIMEw.d Writes SAS datetime values in form 
ddmmmyy:hh:mm:ss.ss 

7–40 16 

DTDATEw. Writes SAS datetime values in form ddmonyy 
or ddmonyyyy 

5–9 7 

EURDFDDw. Writes SAS date values in form dd.mm.yy or 
dd.mm.yyyy 

2–10 8 

JULIANw. Writes SAS date values in Julian date form 
yyddd or yyyyddd 

5–7 5 

MMDDYYw. Writes SAS date values in form mm/dd/yy or 
mm/dd/yyyy—default for dates 

2–10 8 

TIMEw.d Writes SAS time values in form hh:mm:ss.ss—
default for times 

2–20 8 

WEEKDATEw. Writes SAS date values in form 
day-of-week, month-name dd, yy or yyyy 

3–37 29 

WORDDATEw. Writes SAS date values in form 
month-name dd, yyyy 

3–32 18 

Numeric 

BESTw. SAS System chooses best format—default 
format for numeric data 

1–32 12 

COMMAw.d Writes numbers with commas 2–32 6 

DOLLARw.d Writes numbers with a leading $ and commas 
separating every three digits—default for 
currency 

2–32 6 

Ew. Writes numbers in scientific notation 7–32 12 
EUROXw.d Writes numbers with a leading € and periods 

separating every three digits 
2–32 6 

PERCENTw.d Writes numeric data as percentages 4–32 6 
w.d Writes standard numeric data 1–32 none 

1 SAS date values are the number of days since January 1, 1960.  Time values are the number of seconds past midnight, and 
  datetime values are the number of seconds past midnight on January 1, 1960. 
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The examples below show unformatted data values and formatted results for each display format. 

 
 
Format Data value Results Data value Results 

Character 
$UPCASE10. Lassen LASSEN St. Helens ST. HELENS 
$6. Lassen 

 
Lassen St. Helens St. He 

Date, Time, and Datetime 
DATE9. 
 

366 01JAN1961 396 31JAN1961 

DATETIME16. 
 

37800 01JAN60:10:30 2629800 31JAN60:10:30 

DTDATE9. 
 

37800 01JAN1960 2629800 31JAN1960 

EURDFDD10. 
 

366 
 

01.01.1961 396 31.01.1961 

JULIAN7. 366 
 

1961001 396 1961031 

MMDDYY10. 
 

366 01/01/1961 396 01/31/1961 

TIME8. 
 

37800 
 

10:30:00 37815 10:30:15 

WEEKDATE15. 366 
 

Sun, Jan 1, 61 396 Tue, Jan 31, 61 

WORDDATE12. 366 
 

Jan 1, 1961 396 Jan 31, 1961 

Numeric 

BEST10. 
BEST6. 

1000001 
1000001 

1000001 
1E6 

-12.34 
100001 

-12.34 
100001 

COMMA12.2 1000001 1,000,001.00 -12.34 -12.34 

DOLLAR13.2 
 

1000001 $1,000,001.00 -12.34 $-12.34 

E10. 1000001 1.000E+06 -12.34 -1.234E+01 

EUROX13.2 
 

1000001 €1.000.001,00 -12.34 €-12,34 

PERCENT9.2 0.05 5.00% -1.20 (120.00%) 

10.2 1000001 1000001.00 -12.34 -12.34 
 

Slaughter, Susan J., and Delwiche, Lora D. The Little SAS® Book for Enterprise Guide® 4.2. Copyright © 2010, SAS Institute Inc., 
Cary, North Carolina, USA. ALL RIGHTS RESERVED. For additional SAS resources, visit support.sas.com/publishing. 



156     The Little SAS Book for Enterprise Guide 4.2 
 
 

 

1.12 Scheduling Projects to Run at Specific Times  
Sometimes you may want to create a project now, but run it later.  For example, if you have data 
files that are updated on a regular basis, you might want to automatically rerun the project once 
a week using the new data. Or, if your data files are very large, you might want to run your 
projects at night so that SAS Enterprise Guide is not using valuable resources during work 
hours.  

Opening the Schedule window  You 
can schedule a complete project or just a process 
flow. To schedule a project, select File ► 
Schedule project-name from the menu bar.  To 
schedule a process flow, right-click the name of 
the process flow in the Project Tree and select 
Schedule process-flow-name from the pop-up 
menu. This opens the Microsoft Windows Task 
Scheduler with the Task tab on top. When you 
schedule a project, SAS Enterprise Guide creates 
a script that is saved in a file on your computer. 
The name and path of this script is displayed in 
the Run box. The Start in box displays the 
folder in which the script will run. Your 
computer and user name are displayed in the 
Run as box.   

If you will not be logged on at the time the 
project runs, then make sure the box next to 
Run only if logged on is unchecked, and click 
the Set password button to open the Set Password 
 window. Enter the password for your user 
name (the same password you use when you log 
on to your computer), and click OK.  

 

Setting the run frequency  To tell SAS 
Enterprise Guide when to run the project, click 
the Schedule tab.  Click the New button. Then 
select the frequency to run the project from the 
drop-down list under Schedule Task. You can 
schedule your project to run just once at a 
specified time as shown here, or you can 
schedule your project to run on a regular basis. 
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Setting the date and time  To set the 
time the project will start running, click the 
up and down arrows on the Start time box, or 
simply click the time and type a new value. 
To choose a date other than today, click the 
down-arrow in the Run on box and select a 
date from the pull-down calendar.  

Other settings  If you click the Settings 
tab, you will see other options, including the 
maximum length of time a project will be 
allowed to run, and whether it will run if 
your computer has gone into sleep mode.  

When you are satisfied with all the settings, 
click OK to schedule the project. 

Running the project  The project will 
not run if it is open or if the computer is 
turned off at the time the project is scheduled 
to run. However, if you have a different 
project open, the scheduled project will still run.  

Viewing the 
results  To see the 
results of your 
scheduled run, open 
the project after it has 
completed running. If 
you are not sure 
whether a project ran, 
you can confirm this 
by opening the 
Properties window for 
that project. To open 
the Properties 
window for a project, 
select File ► Project 
Properties from the 
menu bar. The Last 
modified field shows 
the date and time that 
the project last ran. 
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1.13   Editing SAS Programs Generated by a Task 
If you are a SAS programmer, you may want to make a few changes to the programs generated 
by SAS Enterprise Guide. There is more than one way to do this. You can insert your own SAS 
code into the program associated with a task, or you can save the code generated by a task in a 
separate file which you can then edit and run. 

Previewing code 
generated by a task  
Many task windows 
have a Preview code 
button in the lower-left 
corner. If you click this 
button, SAS Enterprise 
Guide will open a Code 
Preview window 
displaying the code that 
SAS Enterprise Guide 
has written for that task.   

 

 

 

 

 

 
Inserting code in a 
task  Here is a Code 
Preview window for a 
List Data task. You can 
see that it uses PROC 
PRINT.  If you want to 
add code to the task, 
click the Insert Code 
button. This opens a User 
Code window. You 
cannot edit the existing 
code generated by a task, 
but the User Code 
window allows you to 
add code at specific 
points in the program. 
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In the User Code window, 
double-click <double-click 
to insert code> at the point 
where you wish to add your 
own custom code. An Enter 
User Code window will 
open. Type the custom code 
you wish to add. When you 
are done, click OK. Your 
new code will appear in the 
User Code window. Click 
OK in the User Code 
window. When you run the 
task, SAS Enterprise Guide 
will run the code you 
inserted along with  
the code generated by the task.  

 

 

Editing code generated by a task  If you want to be able to edit the entire program 
generated by a task, or code from tasks that do not have a Preview code button, you can make a 
copy of the program, and then edit it. To do this, run the task, and then right-click the task icon 
in the Project Tree or Process Flow, and select Add As Code Template. SAS Enterprise Guide 
will open a Program window containing the code generated by the task.  

You can edit this code in any way 
you wish. Because this code is a 
copy of the code generated by the 
task, any changes you make here 
will not affect the task, nor will 
any changes you make to the task 
be reflected in this code.  

When you have made all the 
changes you wish and are ready 
to run the program, click Run on 
the workspace toolbar for the 
Program window. Your program 
will run on the server that has 
been set as your default. To  
choose a different server, click 
Select Server. If you decide you want to stop a program while it’s running, click the Stop  

button  on the workspace toolbar for the Program window. You can also use the Program 
menu on the menu bar to control execution of your program. 

Programs created in this way are embedded in your project, and are not saved as separate files. 
For more information on embedding programs, see the next section. 
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1.14 Writing and Running Custom SAS Programs  
You can accomplish a lot using tasks in SAS Enterprise Guide, but sometimes you may need to 
do something for which there is no predefined task. At those times, you can run a SAS program 
that was written outside SAS Enterprise Guide, or you can write a new one. 

Writing a new SAS 
program  To create a new SAS 
program, open an empty 
Program window by selecting 
File ► New ► Program from the 
menu bar. A Program window 
will open in the workspace. The 
program editor in SAS Enterprise 
Guide is syntax-sensitive, which 
means that SAS keywords are 
displayed in blue, comments are 
green, quoted strings are 
magenta, and so forth. 

Opening an existing SAS 
program  If you have existing 
SAS programs that you want to include in your project, you can open them by selecting File ► 
Open ► Program from the menu bar. Navigate to the existing SAS program and click Open. This 
opens a Program window in the workspace, where you can edit the program. 

Saving a program in a 
file  Any new programs you 
write are automatically 
embedded in your project. This 
means that the program’s code 
does not exist in a file outside of 
the project. To save a SAS 
program outside its project, click 
Save on the workspace toolbar 
for the Program window, or 
right-click the program icon in 
the Project Tree or Process Flow 
and select Save program-name 
As from the pop-up menu. You 
can also save a program from the 
Properties for program-name 
window. To view the properties 
of a program, click Properties on 
the workspace toolbar for the 
Program window, or right-click 
the program icon in the Project 
Tree or Process Flow and select 
Properties from the pop-up menu. Then in the General page, click Save As. If you save the  
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program in a file, then it is not embedded, and any changes you make to it in SAS Enterprise Guide 
will be saved in the file rather than as part of your project. The icon for a program saved in a file 
includes a little arrow indicating that the project contains a shortcut to the program rather than 

the actual program . 

Embedding a program in 
a project  When you open a 
SAS program that has been 
saved in a separate file, it is not 
automatically embedded in your 
project. If you want to embed 
the program in your project, 
then open the Properties 
window for the program and 
click Embed. After you embed 
the program, any changes you 
make to it in SAS Enterprise 
Guide will be saved as part of 
your project rather than in the 
separate file. The icon for 
embedded code looks like 

this . 

 

Running your program  
When you are ready to run your 
program, click Run on the 
workspace toolbar for the 
Program window. Your program 
will run on the server that has 
been set as your default. To 
choose a different server, click 
Select Server. If you decide you 
want to stop a program while it’s 
running, click the Stop button  
on the workspace toolbar for the 
Program window. You can also 
use the Program menu on the 
main menu bar to control your 
program. 
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1.15 Viewing Program and Project Logs 
A SAS log is a record of what SAS did. Just about everything you do in SAS Enterprise Guide 
generates a SAS log. Logs contain the actual code that SAS ran, plus any error messages, 
warnings, or notes. 

Different types of logs  A program log is the log that is generated when you run a SAS 
program. Tasks generate logs too, but when you run tasks, you have little need to view the task 
log. That is because tasks rarely produce errors or warnings. Every time you rerun a program or 
task, the old log is replaced with a new one.  

The Project Log, on the other hand, is a single cumulative record of everything that has been run 
in a particular project. By default, the Project Log is turned off. Once you turn the Project Log on, 
nothing disappears from it unless you clear the log.  

Viewing a program log  After a program runs, the results are displayed in the workspace. 
To open the program log, click the tab labeled Log. Here is a portion of the program log 
generated by the SAS program in the preceding section.   

 
 
One of the first things you will notice when you look at a log is that it contains more lines of SAS 
code than were in your original program. That is because SAS Enterprise Guide adds 
housekeeping statements to the beginning and end of your program to make sure that it runs 
properly when it is passed to your SAS server.  

If your program contains any errors, its icon will include a red X . Programs that contain 

warnings (but no errors) have icons with yellow triangles . Even if there are no errors or 
warnings, it is a good habit to check the program log when you write your own SAS programs. 
Just because a program runs without errors or warnings does not mean that it produced the 
correct results. 
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Viewing the Project Log  To turn on the Project Log, first open it by clicking Project Log 
on the workspace toolbar for the Process Flow or selecting View ► Project Log from the menu 
bar. Then on the workspace toolbar for the Project Log, click Turn On. Once the Project Log is 
turned on, it will keep a continuous history of everything that runs in that project.  

 

The Project Log includes the date and time when each action occurred. Click the plus sign (+) to 
expand a section, or the minus sign (-) to collapse it. You can also split the Project Log into two 
pieces by clicking and dragging the top border (the line just below the workspace toolbar) of the 
Project Log window. 

 

To clear the Project Log, click Clear Log on the workspace toolbar for the Project Log. To turn it 
off, click Turn Off.  
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1.16 Using the Options Window 
The Options window allows you to change many default behaviors in SAS Enterprise Guide. To 
open the Options window, select Tools ► Options from the menu bar.  

Changing the way data are handled  To see options for data, click Data General in the 
selection pane on the left. If you have large data tables, columns might be easier to find if they 
are arranged in alphabetical order. To list columns alphabetically in task windows, check the box 
in front of Display columns in alphabetical order. By default, the Data Grid uses column names, 
not labels, for column headers. To change this, check the box in front of Use labels for column 
names. If you have large data tables on remote servers, you may be able to improve performance 
by unchecking Automatically open data when added to project.  

 

Changing the default titles and footnotes  To change the default titles and footnotes,  
click Tasks General in the selection pane on the left. In this page, you can specify new default 
titles and footnotes, or set them to blank. Some tasks include in the results the name of the SAS 
procedure used by that task. In these results you will see titles like “The FREQ Procedure” or 
“The ANOVA Procedure.” You can eliminate these titles by unchecking the box labeled Include 
SAS procedure titles in results. 
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Changing the default result format and style  To change the default format for 
results, click Results General in the selection pane on the left to open the Results General page 
(not shown). Then check all the formats you want to use: SAS Report, HTML, PDF, RTF, or text 
output. To change the default style for results, click the name of the format (such as PDF) in the 
selection pane on the left to open a page for that format (not shown), and then select a style. See 
Tutorial B or Chapter 11 for more about changing result formats and styles. 

Running code automatically  If you have SAS code that you would like to run 
automatically, click SAS Programs in the selection pane on the left to open the SAS Programs 
page (not shown). Select an option under the heading Additional SAS code. Then click Edit, 
type your code in the Edit window, and click Save. The option Submit SAS code when server is 
connected is particularly useful for submitting LIBNAME statements. You can also click Custom 
Code in the selection pane on the left, and specify code to be run before or after tasks. 

Restoring the window layout  To restore windows to their default layout, click General 
in the selection pane on the left to open the General page (not shown). Then click the Restore 
Window Layout button.  

Saving and resetting options  To close the Options window and save the changes you 
have made, click OK. Once you set options, they stay in effect for future SAS Enterprise Guide 
sessions. If at a later time, you decide you want to restore everything in the Options window to 
the default settings, simply click the Reset All button in the lower left corner.
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