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1.7 Submitting a Program in the SAS Windowing Environment 
Naturally after going to the trouble of writing SA S programs, you want to see some results. As 
we have already discussed, there are several ways of submitting SAS programs. If you use the 
SAS windowing environment, then you can edit an d submit programs, and see results all within 
the windowing environment. 

Getting your program into the editor  The first thing you need to do is get your 
program into the Editor window. You can either ty pe your program into the editor, or you can 
bring the program into the Editor window from a file. The commands for editing in the editor 
and for opening files should be familiar. SAS tries to follow conventions that are common for 
your operating environment. For example, to open a file in the editor, you can select Open from 
the File pull-down menu. For some oper ating environments you may have an Open icon on the 
toolbar, and you may also have the option of pastin g your file into the editor from the clipboard.  

Submitting your program  Once your program appears in the editor, you execute it using 
the SUBMIT command. Depending on your operat ing environment, you have a few choices on 
how to execute the SUBMIT command.  

        Use the Submit  icon on the toolbar. 
 

Make the Editor window active and enter SUBMIT in 
the command line area of your SAS session. 

 

 Make the Editor window active and select Submit  
from the Run pull-down menu. 

 

 

The figure to the right shows a 
program in the Enhanced Editor in the 
Windows operating environment 
ready to be submitted using the 
Submit  icon on the toolbar. 
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Viewing the SAS Log and Output  If you are using the Enhanced Editor (Windows 
operating environment), after you submit your program, the program remains in the Enhanced 
Editor window and the results of your program go into the Log and Output windows. If you are 
using the Program Editor (all other operating environments) then your results also go into the 
Log and Output windows, but your program disappears from the Program Editor window. At 
first it may be a shock for you to see your program disappear in front of your eyes. Don’t worry; 
the program you spent so long writing is not gone forever. If your program produced any 
output, then you will also get new entries in the Results window. The Results window is like a 
table of contents for your SAS output and is discussed in more detail in section 1.9. This figure is  
an example of what your screen might look like after you submit a program from the Enhanced 
Editor. 

You may not see all three of the 
programming windows (Editor, 
Log, and Output) at the same 
time. In some operating 
environments, the windows are 
placed one on top of the other. 
You can bring a window to the 
top by clicking on it, typing its 
name in the command line area, 
or selecting it from the Window 
menu. 

Getting your program 
back  Unfortunately for most of 
us, our programs do not run 
perfectly every time. If you have an error in your program, you will most likely want to edit the 
program and run it again. If you are using the Enhanced Editor, then your program will remain in 
the window after you submit it. However, if you are using the Program Editor window, you will 
need to get your program back in the Program Editor window using the RECALL command. You 
have two choices for executing the RECALL command. 

Make the Program Editor the active window, then enter 
RECALL in the command line area of your SAS session. 

 

Make the Program Editor the active window, then select 
Recall Last Submit from the Run pull-down menu. 

 

The RECALL command will bring back the last block of 
statements you submitted. If you use the RECALL 
command again, it will insert the block of statements 
submitted before the last one, and so on and so on, until 
it retrieves all the statements you submitted. 
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1.8 Reading the SAS Log 
Every time you run a SAS job, SAS writes messages in your log. Many SAS programmers 
ignore the SAS log and go straight to the output. That’s understandable, but dangerous. It is 
possible⎯and sooner or later it happens to all of us⎯to get bogus results that look fine in the 
output. The only way to know they are bad is to check the SAS log. Just because it runs doesn’t 
mean it’s right. 

Where to find the SAS log  The location of the SAS log varies depending on the operating 
environment you use, the mode you use (SAS windowing environment, noninteractive, or 
batch), and local settings. If you submit a program in the windowing environment, you will, by 
default, see the SAS log in your Log window as in the following figure.  

If you submit your program in batch 
or noninteractive mode, the log will  
be written to a file that you can view 
or print using your operating 
environment’s commands for 
viewing and printing. The name 
given to the log file is generally 
some permutation of the name you 
gave the original program. For 
example, if you named your SAS 
program Marathon.sas, then it is a 
good bet that your log file will be 
Marathon.log. At some installations 
the log and output files are written 
to a single file, so don’t be surprised 
if you find them together. 

What the log contains  People tend to think of the SAS log as either a rehash of their 
program or as just a lot of gibberish. OK, we admit, there is some technical trivia in the SAS log, 
but there is also plenty of important information. Here is a simple program that converts miles to 
kilometers and prints the result: 

* Create a SAS data set named distance; 
* Convert miles to kilometers; 
DATA distance; 
   Miles = 26.22; 
   Kilometers = 1.61 * Miles; 
RUN; 
* Print the results; 
PROC PRINT DATA = distance; 
RUN; 
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If you run this program, SAS will produce a log similar to this: 

 NOTE: Copyright (c) 2002-2008 by SAS Institute Inc., Cary, NC, USA. 
 NOTE: SAS (r) Proprietary Software Version 9.2 (TS1M0) 
       Licensed to XYZ Inc., Site 0099999001. 
 NOTE: This session is executing on the W32_VSPRO  platform. 
 
 NOTE: SAS initialization used: 
       real time            1.40 seconds 
       cpu time             0.96 seconds 
 

 1    * Create a SAS data set named distance; 
 2    * Convert miles to kilometers; 
 3    DATA distance; 
 4       Miles = 26.22; 
 5       Kilometers = 1.61 * Miles; 
 6    RUN; 
 

 NOTE: The data set WORK.DISTANCE has 1 observations and 2 variables. 
 NOTE: DATA statement used (Total process time): 

       real time           0.03 seconds 
       cpu time            0.03 seconds 
 
 7    * Print the results; 

 8    PROC PRINT DATA = distance; 
 9    RUN; 
 
 NOTE: There were 1 observations read from the data set WORK.DISTANCE 
 NOTE: PROCEDURE PRINT used (Total process time): 

       real time           0.01 seconds 
       cpu time            0.00 seconds 

The SAS log above is a blow-by-blow account of how SAS executes the program.  

 It starts with notes about the version of SAS and your SAS site number.  

 It contains the original program statements with line numbers added on the left. 

 The DATA step is followed by a note containing the name of the SAS data set created 
(WORK.DISTANCE), and the number of observations (1) and variables (2). A quick glance 
is enough to assure you that you did not lose any observations or accidentally create a lot 
of unwanted variables.  

 Both DATA and PROC steps produce a note about the computer resources used. At first 
you probably won’t care in the least. But if you run on a multi-user system or have long 
jobs with large data sets, these statistics may start to pique your interest. If you ever find 
yourself wondering why your job takes so long to run, a glance at the SAS log will tell you 
which steps are the culprits. 

If there were error messages, they would appear in the log, indicating where SAS got confused and 
what action it took. You may also find warnings and other types of notes which sometimes indicate 
errors and other times just provide useful information.  
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1.9 Viewing Your Results in the Output Window 
How you view or print your output depends on how you submit your program. If you submit your 
program in the SAS windowing environment, then your output will, by default, go to the Output 
window. If you choose another way to submit your program, either batch or noninteractive, then 
your output will probably be in a file on your computer. Use your operating environment’s 
commands to view and print the output  file (also called the listing). For example, if you execute 
your SAS program in noninteractive mode on a UNIX system, then your output will be in a file 
with an extension .lst. To view the file, you can use either the cat or more commands, and to print 
the file you would use your system’s command for printing files (usually you would type either lp 
or lpr). 

The Output window  After submitting your program in the SAS windowing environment, 
your results will go to the Output window. If you have the SAS Explorer option turned on (some 
operating environments have this turned on by default, while others do not), then you will also 
see a listing of the different parts of your output in your Results window. The following figure 
shows what your Output window might look like after submitting a simple program under 
Windows. 

Printing or saving the 
contents of the Output 
window  If you want to 
print or save the entire 
contents of the Output 
window, first make the 
Output window active by 
clicking in it, then select either 
Print or Save As from the 
File pull-down menu. If you 
are not using a personal 
computer, then your 
environment may not be set 
up for printing from within 
SAS. If you cannot print from 
within SAS, then save the 
output to a file and use your 
system’s command for 
printing files. 

The Results window  When you have a lot of output, the Results window can be very 
helpful. The Results window is like a table of contents for your output. It lists each procedure 
that produces output, and if you open, or expand, the procedure in the Results tree, you can see 
each part of the procedure output. The following figure shows what your screen might look like 
if you ran the ANOVA (Analysis of Variance) procedure. 
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There is one entry in the 
Results window for the 
ANOVA procedure. Notice 
that in the Output window, 
you see the end of the 
procedure’s output. If you 
expand the ANOVA 
procedure in the results 
tree, by clicking the plus (+) 
signs, then you will see all 
the different parts of the 
ANOVA output. Double-
click the output you want 
to see, and it will appear at 
the top of the Output 
window. The following 
figure shows what your 
Output window would 
look like after you double-  

                                                                                                                                              click on the Overall  
                                                                                                                                              ANOVA item in the Results  
                                                                                                                                              window. 

Printing or saving parts of 
the output  Using the Results 
window, it is possible to print or 
save just the parts of the output 
you want. First highlight the item 
you want in the Results window, 
then bring up the context-
sensitive menu. In the Windows 
operating environment you do 
this with the right mouse button; 
in other operating environments, 
it may be the middle or right 
mouse button. Then select either 
Print or Save As from the pop-
up menu. You may also be able to 
print or save from the File pull-
down menu once you highlight 
the output part you want. If your SAS environment is not set up for printing from within SAS, then 
save your results to a file and use your operating environment’s command for printing files. 
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1.10 Creating HTML Output 
If you are using the SAS windowing environment, then you can create output in Hypertext 
Markup Language (HTML) format with just a few clicks of your mouse.1  

The Preferences window  To turn on HTML output (in Windows, UNIX, or OpenVMS2), 
select Options-Preferences from the Tools menu. This opens the Preferences window. Click 
the Results tab to bring it to the front. Here is what the Results portion of the Preferences window 
looks like in Windows. 

 

 

 

 

 

 

 

 

 

 

When you first open this window, you will see a check next to Create Listing. Listing is the 
default type of output, and it is what you see in the Output window if you are using the SAS 
windowing environment, or in the output or listing file if you are running in batch mode. You can 
turn on HTML output by clicking the box next to Create HTML. To turn off the listing or HTML 
output, just click to un-check it.  

In the Preferences window, you can also select a style for HTML output by clicking the arrow next 
to the Style box and scrolling through the list of styles provided with SAS. When you are done with 
the Preferences window, click the OK button. 

The Results Viewer and Results windows  Once you have turned on HTML output, 
then every time you run a program, your output will automatically appear in the Results Viewer 
window. The following figure shows what you see after running two simple procedures: MEANS 
and PRINT. Two windows are showing: the Results Viewer window displaying the HTML output, 
and the Results window listing all the pieces of output in tree form. 

 
1 If you are not using the SAS windowing environment, you can still produce HTML output by using ODS statements (see  
  chapter 5).  

2 If you are using z/OS, you will need to modify your registry settings in order to generate HTML interactively. Contact your  
  site’s SAS Support Personnel  for more information. 
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The Results Viewer window shows you only one piece of output at a time, but you can tell that SAS ran 
both procedures by looking at the list in the Results window. You can expand the list by clicking the plus 
(+) signs, or collapse it by clicking the minus (-) signs. Since both the listing and HTML output were 
turned on, each procedure produced two pieces of output: one for listing, and one for HTML. You can 
display any piece of output by double-clicking its name in the Results window. 

To save a piece of output in a file, make the Results Viewer window active by clicking it, then click 
the File menu, and choose Save As…. To print a piece of output, select Print from the File menu. 

The preceding screen used the DEFAULT style which is the default for HTML output. To see the 
same output with a different style, just choose a different style in the Preferences window, and re-
run your program. Here is the output from the same program using the D3D style. 

 

 

 

 

 

Results 
window 

Results Viewer 
window 



22      The Little SAS Book 
 
 

1.11   SAS Data Libraries  
Before you can use a SAS data set, you have to tell SAS where to find it. You do that by setting up a 
SAS library. A SAS library is simply a location where SAS data sets (as well as other types of SAS 
files) are stored. Depending on your operating environment, a SAS library might be a folder or 
directory on your computer, or it might be a physical location like a hard drive, flash drive, or CD. 
To set up a library, all you have to do is make up a name for your library and tell SAS where it is. 
There are several ways to do this including using the LIBNAME statement (covered in sections 2.19 
to 2.20) and using the New Library window in the SAS windowing environment. 

When you start the 
SAS windowing  
environment, you see 
the basic SAS windows 
including the SAS 
Explorer window on 
the left. (If the Explorer 
window is under the 
Results window, click 
its tab to bring it 
forward.)  If you 
double-click the 
Libraries icon, Explorer 
will open the Active 
Libraries window 
showing all the  
libraries that are 
currently defined. To 
go back to the previous window within Explorer, choose Up one level from the View menu, 

or click in the Explorer window to make it active and then click the Up One Level button   
on the toolbar. 

The Active Libraries window  When you open the Active Libraries 
window, you will see at least three libraries: SASHELP, SASUSER, and 
WORK. You may have other libraries for specific SAS products (such as 
the MAPS library for SAS/GRAPH software), or libraries that have been 
set up by you or someone you work with. The SASHELP library contains 
information that controls your SAS session along with sample SAS data 
sets. The WORK library is a temporary storage location for SAS data sets. 
It is also the default library. If you create a SAS data set without 
specifying a library, SAS will put it in the WORK library, and then delete 
it when you end your session. If you make changes to the default settings 
for the SAS windowing environment, this information will be stored in 
the SASUSER library. You can also store SAS data sets, SAS programs, 
and other SAS files in the SASUSER library. However, many people prefer 
to create a new library for their SAS files. 
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Creating a new library  You can create new SAS libraries using 
the New Library window. To open this window, either left-click in 
the Active Libraries window (to make it active) and choose New from 
the File menu, or right-click in the Active Libraries window and 
choose New from the pop-up menu. 

 

 

 

 

 

 
 

In the New Library window, type the 
name of the library you want to create. 
This name is called a libref which is 
short for library reference. A libref 
must be 8 characters or fewer; start 
with a letter or underscore; and 
contain only letters, numerals, or 
underscores. In this window, the name 
BIKES has been typed in as the libref. 
In the Path field, enter the complete 
path to the folder or directory where 
you want your data sets to be stored, 
or choose the Browse… button to 
navigate to the location. If you don’t 
want to define your library reference 

every time you start up SAS, then check the Enable at startup box. Click OK and then your new library 
reference will appear in the Active Libraries window.  

Here is the Active Libraries window showing the newly created 
BIKES library. 
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1.12   Viewing Data Sets in the Viewtable Window 
In addition to listing your current libraries and creating new libraries, you can also use SAS 
Explorer to open SAS data sets for viewing in Viewtable. When you are writing programs it is 
always a good idea to check the data sets you create to make sure they are correct. Viewtable is 
one way you can look at your SAS data sets. 

 Start by double-clicking the Libraries icon in the Explorer window as 
shown in the previous section. This will open the Active Libraries 
window showing all the libraries that are currently defined on your 
system. If you double-click a library icon, SAS will open a Contents 
window showing you all the SAS files in that particular library. 

To go back to the previous window within Explorer, choose Up one 
level from the View menu, or click in the Explorer window to make it 

active and then click the Up One Level button  on the toolbar. 
 

 

The Contents window  This window shows the contents of a 
library. SAS data sets are represented by an icon showing a little table 
of data and a red ball, so the library shown on the right contains three 
data sets named CUSTOMERS, MODELS, and ORDERS. If you 
double-click a data set, SAS will open a Viewtable window showing 
that data set. (If you don’t yet have any SAS data sets of your own, 
you can view sample data sets that are provided with SAS in the 
SASHELP library. The CLASS data set in the SASHELP library is a 
good one to view.)  

The Viewtable window  This window allows you to create, 
browse, and edit data sets. When you first open SAS data sets, the 
data are in browse mode so you cannot make any changes. To switch 
to edit mode, select Edit Mode from the Edit menu. Creating and 
editing data sets using Viewtable is discussed in more detail in section 2.2. This picture shows 
the data set named MODELS from the BIKES library.  
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Changing column headings  By default, Viewtable uses variable labels for column 
headings or, if a variable does not have a label, the variable name is displayed. Sometimes you 
may want to see the actual variable names instead of the labels. To do this, click the Viewtable 
window to make it active, then select Column Names from the View menu. Here is the 
MODELS SAS data set showing the column (also called variable) names instead of the labels. 
 
 
 
 
 
 
 
 
 
 
 
Column options  If you right-click a column heading, several options will appear in the pop-
up menu. You can control colors, fonts, and view the column attributes. You can choose to sort 
the data by the values in the column. If you are not in edit mode, then you are given the option 
of creating a new data set containing the sorted data. You can also hide or hold columns. If you 
choose to hide a column, the data will not be visible in the current Viewtable session. To unhide 
a column, select Hide/Unhide from the Data menu item to open the Hide/Unhide window. In 
this window you can change the visibility of all columns. When you choose to hold a column, it 
and every column to the left of it will always be visible, even when you scroll to the right. 
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                1.13   Viewing the Properties of Data Sets with SAS Explorer 

The Properties window for a SAS data set contains some very useful information, such as the 
date and time the data set was created, the number of observations, all the variable names, and 
the attributes of the variables. The Properties window contains information similar to the output 
produced by the CONTENTS procedure described in section 2.22. 

Opening the Properties window To open the 
Properties window, start by double-clicking the 
Libraries icon in the Explorer window and then 
double-clicking the library containing the SAS data 
set. SAS will display the contents of the library in the 
Explorer window. Right-click the icon for the data 
set, and select Properties from the pop-up menu. 
This opens the Properties window with the General 
tab on top.1 
 

 

 

 

 

 

 

 

The General tab   This window 
displays information about the data set 
such as the date it was created and the 
number of rows (or observations) and 
columns (or variables).  

  

 

 

 

 

 

1 The Properties windows shown here are from SAS 9.2 in the Windows operating environment. If you are using a different  
  version of SAS, or if you are using a different operating environment, your windows may have a different look.   
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The Columns tab  If you click the 
Columns tab, SAS displays information 
about the columns (or variables)  in that 
data set. The variable name, type, and 
length are displayed along with any 
formats or informats assigned to the 
variable. The variable labels are also 
displayed in this window, but to see them, 
you need to scroll to the right. 

 

 

 

 

 

 

You can also sort any of these columns 
alphabetically by clicking the column 
heading, or use the Find feature to look for 
specific variables. This window shows the 
variables sorted by name. If you have lots of 
variables in your data set, using the Sort 
and Find features can make your work 
easier.  
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                1.14  Using SAS System Options 

System options are parameters you can change that affect SAS⎯how it works, what the output 
looks like, how much memory is used, error handling, and a host of other things. SAS makes 
many assumptions about how you want it to work. This is good. You do not want to specify 
every little detail each time you use SAS. However, you may not always like the assumptions 
SAS makes. System options give you a way to change some of these assumptions.  

Not all options are available for all operating environments. A list of options specific to your 
operating environment appears in the SAS Help and Documentation. You can see a list of system 
options and their current values by opening the SAS System Options window or by using the 
OPTIONS procedure. To use the OPTIONS procedure, submit the following SAS program and 
view the results in the SAS log: 

PROC OPTIONS; 
RUN; 

There are four ways to specify system options. Some options can be specified using only some of 
these methods. The SAS Help and Documentation for your operating environment tells you 
which methods are valid for each system option: 

1. Your system administrator (this could be you if you are using a PC) can create a SAS 
configuration file which contains settings for the system options. This file is accessed by 
SAS every time SAS is started. 

2. Specify system options at the time you start up SAS from your system’s prompt (called 
the invocation). 

3. Change selected options in the SAS System Options window if you are using the SAS 
windowing environment. 

4. Use the OPTIONS statement as a part of your SAS program. 

The methods are listed here in order of increasing precedence; method 2 will override method 1, 
method 3 will override method 2, and so forth. If you are using the SAS windowing 
environment, methods 3 and 4, the SAS System Options window and OPTIONS statement, will 
override each other⎯so whichever was used last will be in effect. Only the last two methods are 
covered here. The first two methods are very system dependent; to find out more about these 
methods see the SAS Help and Documentation for your operating environment.  

OPTIONS statement  The OPTIONS statement is part of a SAS program and affects all steps 
that follow it. It starts with the keyword OPTIONS and follows with a list of options and their 
values. For example 

OPTIONS LINESIZE = 80 NODATE; 

The OPTIONS statement is one of the special SAS statements which do not belong to either a PROC 
or a DATA step. This global statement can appear anywhere in your SAS program, but it usually 
makes the most sense to let it be the first line in your program. This way you can easily see which 
options are in effect. If the OPTIONS statement is in a DATA or PROC step, then it affects that step 
and the following steps. Any subsequent OPTIONS statements in a program override previous ones. 
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The SAS System Options 
window  You can view and 
change SAS system options through 
the SAS System Options window. 
Open it either by typing OPTIONS in 
the command line area on your 
screen, or by selecting it from the 
Tools pull-down menu. To change 
the value of an option, first locate the 
option by clicking on the appropriate 
category on the left side of the 
screen. A list of options and their 
current values will appear on the 
right side of the screen. Right-click 
the option itself to modify the value or set it to the default. 

Common options The following are some common system options you might want to use: 

CENTER | NOCENTER Controls whether output is centered or left-justified.  
 Default: CENTER. 

DATE | NODATE Controls whether or not today’s date will appear at the 
  top of each page of output. Default: DATE. 

LINESIZE = n Controls the maximum length of output lines.  
 Possible values for n are 64 to 256. Default varies. 

NUMBER | NONUMBER Controls whether or not page numbers appear on each  
 page of SAS output. Default: NUMBER. 

ORIENTATION = PORTRAIT Specifies the orientation for printing output.  
ORIENTATION = LANDSCAPE Default: PORTRAIT 

PAGENO = n Starts numbering output pages with n. Default is 1. 

PAGESIZE = n Controls the maximum number of lines per page of output.  
 Possible values for n are 15 to 32767. Default varies. 

RIGHTMARGIN = n Specifies size of margin (such as 0.75in or 2cm) to be used for  
LEFTMARGIN = n printing output. Default: 0.00in. 
TOPMARGIN = n 
BOTTOMMARGIN = n 

YEARCUTOFF = yyyy Specifies the first year in a hundred-year span for interpreting  
 two-digit dates. Default: 1920. 
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