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1.1 SAS Enterprise Guide Windows 
SAS Enterprise Guide has many windows. You can customize the appearance of SAS Enterprise 
Guide—closing some windows, opening others, and rearranging them all—until it looks just the 
way you want. Then SAS Enterprise Guide will save those changes so the next time you open it, 
everything will be just where you left it.  

Here is SAS Enterprise Guide with its windows in their default positions.  

  

Docking windows  Some of the windows in SAS Enterprise Guide are docking windows. 
Docking windows appear around the edges of the application. You can undock a window by 
clicking its title bar and dragging it. To dock it, drag it to an edge of the application until it 
changes shape, and then release it. Some docking windows are open by default while others are 
closed. If a docking window is closed, you can open it using the View menu. Here are the basic 
docking windows: 

Project Explorer  The Project Explorer displays the items in a project in a hierarchical 
tree diagram. This window is open by default. 

Task Status  The Task Status window displays notes about any tasks that are 
currently running either locally or on a remote server. This window is open by default.  

Toolbar 

Workspace displaying 
the Project Designer 

Task List 
window 

Task Status window 

Menu bar 

Project Explorer 
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Task List  The Task List window is also open by default, but it is minimized and 
appears as a tab on the right side. To expand the Task List window, move your cursor 
over the Task List tab. This window lists all available tasks. You can view tasks sorted by 
category or in alphabetical order by clicking the tabs at the top of the window. To open a 
task, select it from the menu bar, or click its name in the Task List window. 

Server List  The Server List window lists available SAS servers, and the files and SAS 
data libraries on those servers. This window is closed by default. 

Binder List  The Binder List window lists available binders and their contents, and is 
closed by default. See section 2.2 for more information about binders. 

SAS Folders  The SAS Folders window lists any stored processes available to you, 
and is closed by default.  

What is  The What is window displays information describing menus and tools, and is 
closed by default. See section 1.14 for more information about using the What is window. 

Project Log  The Project Log window displays a single log for your entire project, and 
is closed by default. 

Pinning windows  You can minimize docking windows by clicking the pushpin icon  in 
the upper-right corner. SAS Enterprise Guide will reduce that window to a tab along the edge of 
the SAS Enterprise Guide application. Then, when you move the cursor over the tab, the window 
will expand. When you move the cursor out of the window, it will be reduced to a tab again. To 

unpin a window, click the sideways pushpin icon . 

Workspace  The workspace is not itself a window, but it is very important. This is where the 
Project Designer and document windows appear. The workspace is always there and cannot be 
closed. However, you can open and close individual items inside the workspace.  

Project Designer  The Project Designer displays the items in a project and their 
relationship using a process flow diagram. You can display only one project at a time in 
the Project Designer, but you can create as many process flow diagrams as you wish 
inside a single project. You can turn the Project Designer into a docking window by 
right-clicking its tab and selecting Dockable from the pop-up menu. To reverse this, 
right-click the Project Designer’s title bar and uncheck Dockable. 

Document windows  The document windows display your data, results, code, logs, 
and notes. There is a different type of icon for every kind of document. This icon 
represents a SAS data table.  

Restoring windows  Once you have rearranged your windows, you may decide you want 
them back where they started. To restore them to their original locations, just select Tools ► 
Options from the menu bar. Then, in the General page of the Options window, click Reset 
Docking Windows. 
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1.2 Projects 
In SAS Enterprise Guide, all the work you do is organized into projects. A project is a collection 
of related data, tasks, results, code, logs, and notes. Projects help you by keeping track of 
everything, even if your data are scattered in many directories or on more than one computer. 
That way, when you come back to an old project six months or a year later, you won’t be left 
wondering which data sets you used or what reports you ran.  

You can have as many projects as you like, and you can use a data set over and over again in 
different projects, so there is a lot of flexibility. However, you can have only one project open at a 
time. Also, if you share a project file with someone else, that person must have access to your 
data files and any other items you reference. 

To create a new project, select File ► New ► Project from the menu bar. To open an existing 
project, select File ► Open ► Project and navigate to your project. 

Project Explorer and Project Designer  The Project Explorer displays projects in a 
hierarchical tree diagram, while the Project Designer displays projects using a process flow 
diagram. In either window, the items in your project are represented by icons, and connected to 
show the relationship between items. Here are examples of a Project Explorer and a Project 
Designer showing the same project. This project contains several types of items: data, tasks, 
results, code, logs, and a note.  

          

Data  Data files in a project may be SAS data tables, raw data files, or files from other databases 
or applications, such as Microsoft Excel spreadsheets. Projects contain pointers to data files, not 
the actual data. If you delete a project, your data files will still exist. 

Tasks Tasks are specific analyses or reports that you run, such as Analysis of Variance or Bar 
Chart. Every time you run a task, SAS Enterprise Guide adds an icon representing that task. 

Results  Results are the reports or graphs produced by tasks you run. Results are represented 
by icons labeled with the type of output (HTML, PDF, RTF, SAS Report, or text) and the name of 
the task.  

Notes  Notes are optional text files you can use to document your work, or record comments or 
instructions for later use. To create a note, select File ► New ► Note from the menu bar. A text 
window will open, allowing you to type whatever you wish.  
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Showing properties and opening items  You can display the properties for any item by 
right-clicking its icon in the Project Explorer or Project Designer and selecting Properties from 
the pop-up menu. You can open any item by double-clicking its icon, or by right-clicking its icon 
and selecting Open from the pop-up menu.  

 

Code and log files Code files are SAS programs, either ones that SAS Enterprise Guide 
writes when you run a task, or ones that you have written. Log files are text files written by SAS 
that contain details about how a particular task ran. When you run a task, code and log icons are 
automatically added to the Project Explorer, but not to the Project Designer. To display a code 
file, double-click the icon for Last Submitted Code in the Project Explorer or right-click the icon 
and select Open from the pop-up menu. To display a log file, double-click the log icon in the 
Project Explorer or right-click the log icon and select Open from the pop-up menu. If you want 
the code and log to appear automatically in the Project Designer, select Tools ► Options from the 
menu bar. In the selection pane on the left, click Project Views and then check the boxes next to 
Show generated code items and Show SAS output log.  

Renaming and deleting items  You can rename most items by right-clicking the item and 
selecting Rename from the pop-up menu. You can delete an item in a project by right-clicking 
and selecting Delete. Note that if you delete data from a project, only the pointer to that data is 
deleted, not the actual data file.  

Saving a project  To save a project, select File ► Save project-name or File ► Save project-
name As from the menu bar. Each project is saved as a single file and has a file extension of .egp. 
You can save results, code, and logs as separate files by right-clicking and selecting Export from 
the pop-up menu. 
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1.3 Managing Process Flows 
In SAS Enterprise Guide, you can have only one project open at a time. However, you can have 
multiple process flows within a single project. So, if you have a complex project, you may want 
to divide it into several process flows.  

Adding new process flows  To 
add a new process flow to a project, 
select File ► New ► Process Flow from 
the menu bar, or right-click the current 
process flow and select New ► Process 
Flow from the pop-up menu.  

Note that no matter how many process 
flows you create in the Project 
Designer, the Project Explorer always 
shows your entire project in a single 
tree diagram. 

Renaming process flows  When you open a new 
process flow, it is named Process Flow n. To give your 
process flows more descriptive names, right-click the tab 
for each process flow and select Rename from the pop-up 
menu. Then type the new name in the Rename window 
and click OK. 

    

Moving and copying items  To move items from one process flow to another, hold down 
the control button, and click the items you want to move. Then right-click, and select Move to ► 
process-flow-
name from the 
pop-up menu. In 
this example, three 
items are being 
moved.  
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Copying items is similar to moving items except that you cannot copy results. Select the items to 
be copied using control-click. Then right-click the items and select Copy from the pop-up menu, 
and right-click the target process flow and select Paste.  

Linking items  You can add links between items to 
show relationships that may not be clear, or to force 
items to run in a particular order. For example, if you 
create a format that is used by a task, you might want to 
add a link indicating that the task follows the format. To 
add a link, right-click the initial item and select Link 
item-name to from the pop-up menu. A Link window 
will open showing all the other items to which you can 

link. Select the 
item to which 
you want to link, 
and click OK. 

 

 

In this process flow, the Volcanoes data table has been 
linked to a code icon to show that this code uses the 
Volcanoes data table. Notice that links you add use a 
dashed line instead of a solid line.  

 

 

 

 

 

Printing process flows You can 
print a copy of your process flow. To 
control page size and orientation, 
right-click the process flow and 
select Page setup. To preview a 
printout, right-click and select Print 
preview. To print the process flow, 
right-click and select Print. Here is 
the Print preview window for the 
Volcanoes process flow. 
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1.4 Maximizing and Splitting the Workspace 
The workspace is where you see the Project Designer and the document windows (data, results, 
code, logs, and notes). By default, you see these items one at a time, but you can enlarge and 
divide the workspace so you can see two or more items side by side.  

Maximizing the 
workspace  To 
make the workspace 
as large as possible, 
select View ► 
Maximize 
Workspace from the 
menu bar or click the 
Maximize 
Workspace button 
on the toolbar 
          

. 

 

 

 

 

When you maximize 
the workspace, the 
Project Explorer and 
Task Status windows 
become tabs pinned 
to the edges of the 
SAS Enterprise 
Guide application. 
You can temporarily 
expand those 
windows by moving 
the cursor over the 
tab. When you move 
the cursor away, the 
window will be 
reduced to a tab 
again. 
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Splitting the workspace  You can display the Project Designer and document windows 
side by side or one above the other. First, open all the items you wish to view. Then, in the 
workspace, right-click the tab for one item and select either New Horizontal Tab Group or New 
Vertical Tab Group. This splits the workspace in two. Repeat this until all the documents you 
wish to see are visible. 

 

This example shows 
the workspace split 
into three vertical 
sections. The first 
section displays the 
Project Designer, the 
second the Volcanoes 
data set, and the last 
the result of a List 
Data task. 

 

 

 

 

 

 
Unsplitting and restoring the workspace  To move 
documents from one section of the workspace to another, 
right-click a tab and select Move Previous or Move Next 
from the pop-up menu. The item you move will appear on 
top of the other items in that section. To completely unsplit 
the workspace simply move the items until they are all in a 
single section. 

To return the workspace to its normal size, either select View Maximize ► Workspace from the 
menu bar or click the Maximize Workspace button on the toolbar. You can unsplit the workspace 
and restore it to normal size at the same time by selecting Tools ► Options from the menu bar and 
clicking the Reset Docking Windows button. 
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1.5 Running and Rerunning Tasks 
Running tasks is, of course, what SAS Enterprise Guide is all about. Regardless of which task 
you choose to run, the basic steps are the same: select the data, open the task and select settings, 
and then run the task.  

Setting the active 
data table  SAS 
Enterprise Guide will 
run a task using the 
data table that is 
currently active. The 
name of the active data 
table appears in the 
Active Data box on the 
left side of the toolbar. 
To change to one of the 
other data tables in 
your project, click the 
down arrow in the 
Active Data box and 
select another data 
table from the pull-
down list, or just click 
the data table icon in 
the Project Explorer or Project Designer. This example shows the Tours data table being selected. 

Opening a task  
To open a task, select 
it using menus or click 
its name in the Task 
List window. The 
window for that task 
will open. In this case, 
the List Data task is 
being selected from 
the Task List window. 
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Running a task  In 
the task window, you 
assign variables to task 
roles and then select 
options. When you are 
satisfied with all the 
settings, click the Run 
button.  

If you decide you want 
to stop a task while it’s 
running, click the Stop 

button on the 
bottom line of the 
toolbar, or select Code 
► Stop from the menu 
bar. 

 

Rerunning a task  
To make changes to a 
task and run it again, 
first reopen the task by 
right-clicking the task 
icon in the Project 
Explorer or Project 
Designer, and selecting 
Open from the pop-up 
menu. You can also 
reopen the task by 
double-clicking the 
task icon. Once the task 
window is open, you 
can make changes. 
Then click the Run 
button to rerun the 
task.  

If the data have been 
updated and you want 
to rerun a task without 
making any changes to the task settings, you can right-click the task icon and select Run task-
name  to run just that one task, or select Run Branch From task-name to run that task and any 
items that are downstream in the process flow. 
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1.6 SAS Data Tables 
SAS Enterprise Guide can read and write many kinds of data files (see Chapter 2 for more on this 
topic), but for most purposes, you will want to have your data in a special form called a SAS data 
table. When you open a SAS data table, it is displayed in the workspace in a Data Grid. The 
following Data Grid shows the Tours data table. A new tour has been added for Lassen.  

 

 

 

Terminology  In SAS Enterprise Guide, rows are also called observations, columns are also 
called variables, and data tables are also called data sets. SAS Enterprise Guide uses all these 
terms. Some tasks refer to columns and others to variables, depending on the context.  

Data types and data groups   In SAS Enterprise Guide, there are two basic types of data: 
numeric and character. Numeric data are divided into four data groups: numeric, currency, time, and 
date. For each of these, SAS Enterprise Guide has special tools: informats for reading that type of data, 
functions for manipulating that type of data, and formats for displaying that type of data. SAS 
Enterprise Guide uses a different icon to identify each kind of data in Data Grids and tasks. 

 Character data may contain numerals, letters, or special characters (such as $ or !) and 
can be up to 32,767 characters long. Character data are represented by a red pyramid 
with the letter A on it. 

  Currency data are numeric values for money and are represented by a picture of the 
dollar, euro, and yen symbols. 

  Date data are numeric values equal to the number of days since January 1, 1960. The 
table below lists four dates, and their corresponding SAS date and formatted values: 

Date SAS date value MMDDYY10. formatted value 
January 1, 1959  -365 01/01/1959 
January 1, 1960  0 01/01/1960 
January 1, 1961  366 01/01/1961 
January 1, 2007 17176 01/01/2007 

Columns 
(also called Variables)

Rows  
(also called Observations) 

Data Table  
(also called a Data Set) 
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You will rarely see unformatted SAS date values in SAS Enterprise Guide. However, 
because dates are numeric, you can use them in arithmetic expressions to find, for 
example, the number of days between two dates. Datetime values are included in this 
data group, and are the number of seconds since January 1, 1960. Date data are 
represented by a picture of a calendar. 

Time data are numeric values equal to the number of seconds since midnight. Time data 
are represented by a picture of a clock.  

 Other numeric data that are not dates, times, or currency are simply called numeric. They 
may contain numerals, decimal places (.), plus signs (+), minus signs (-), and E for 
scientific notation. Numeric data are represented by a blue ball with the numbers 1, 2, 
and 3 on it. 

Numeric versus character  If the values of a column contain letters or special characters, 
they must be character data. However, if the values contain only numerals, then they may be either 
numeric or character. You should base your decision on how you will use the data. Sometimes data 
that consist solely of numerals make more sense as character data than as numeric. Zip codes, for 
example, are made up of numerals, but it just doesn’t make sense to add, subtract, multiply, or 
divide zip codes. Such numbers work better as character data. 

Column names  Column names in SAS Enterprise Guide may be up to 32 characters in length, 
and can begin with or contain any character, including blanks. 

Using SAS Enterprise Guide data in Base SAS  Any data created in SAS Enterprise 
Guide can be used in Base SAS, but the default rules for naming variables are different in Base SAS 
because Base SAS uses the VALIDVARNAME=V7 system option, while SAS Enterprise Guide uses 
VALIDVARNAME=ANY. For the sake of compatibility, you may want to follow these rules when 
naming columns: choose column names that are 32 characters or fewer in length, start with a letter 
or underscore, and contain only letters, numerals, and underscores.  

Missing data  Sometimes despite your best efforts, your data may be incomplete. The value of a 
particular column may be missing for some rows. In those cases, missing character data are 
represented by blanks, and missing numeric data are represented by a single period (.). In the 
preceding Data Grid, the value of Price is missing for the tour of Lassen, and its place is marked by 
a period. The value of Difficulty is missing for the same tour and is left blank.  

Documentation stored in SAS data tables  In addition to your actual data, SAS data 
tables contain information about the data table, such as its name, the date that you created it, and 
the version of SAS you used to create it. SAS also stores information about each column in the data 
table, including its name, type, and length. This information is sometimes called the descriptor 
portion of the data table, and it makes SAS data tables self-documenting. This information is what 
you see in the Properties windows for data tables and columns, which are described in more detail 
in the next two sections. 
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1.7 Properties of Data Tables 
Someday you might be given a SAS Enterprise Guide project that was created by someone else. 
If you want to figure out what it does, the first thing you would probably do is read any notes. 
The next thing you would probably do is check the properties of the data tables.  

Opening the Properties window  You can display information about a data table by 
right-clicking its icon in the Project Explorer or Project Designer and selecting Properties from 
the pop-up menu. In the following window, Properties is being selected for the Volcanoes data 
table. 
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General page  
When the table 
Properties window 
opens, it displays the 
General page. The 
General page lists basic 
information about the 
table: its name, when it 
was created and last 
modified, the number 
of rows and columns, 
and whether it is 
indexed or 
compressed.  

 

 

 

 

 

 Columns page  If 
you click Columns in 
the selection pane on 
the left, the Columns 
page will open. Here, 
SAS Enterprise Guide 
displays information 
about each column: its 
name, type, length, 
format, informat, and 
label. You cannot 
change the properties 
of columns in the 
Properties window for 
a data table. To make 
changes, use the 
Properties window for 
an individual column 
as described in the 
next section. 
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1.8 Properties of Columns 
The column Properties window displays properties for an individual column. If you open the 
column Properties window from a Data Grid, you can make changes to those properties. 

Setting the update 
mode  If the words 
read-only appear after 
the name of the data 
table at the top of the 
Data Grid, then the 
table is in read-only 
mode and you will not 
be able to make 
changes. To switch to 
update mode, select 
Data ► Read-only from 
the menu bar. This 
toggles the data table 
from read-only to 
update mode.  

 

Opening the Properties window  To open the column Properties window, right-click the 
header of a column and select Properties from the pop-up menu. In the preceding Data Grid, 
Properties is being selected for the column Height. 

General page  The 
Properties window has several 
pages. If there is no selection 
pane on the left, then the data 
table is in read-only mode and 
you need to switch to update 
mode. 

The General page displays basic 
information for the column: its 
name, label, type, group, and 
length. You can change any of 
these properties. In this 
example, the column name has 
been changed to HeightMeters, 
and the label to Height in 
Meters. This column is numeric 
and has a length of 8. 
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Informats page  Click Informats 
in the selection pane on the left to 
open the Informats page. Informats 
(also called input formats or read-in 
formats) tell SAS Enterprise Guide 
how to interpret input data. If you 
edit the data table, SAS Enterprise 
Guide will use informats to interpret 
any values you type. There are 
different informats for character, 
numeric, date, time, and currency 
data. In this example, the column 
uses the default numeric informat, 
w.d, with a width of 12 and no 
decimal places. This informat can be 
written as 12.0. See the next section 
for a table of commonly used 
informats.   
 

Formats page  Click Formats in the 
selection pane on the left to open the 
Formats page. Formats (also called 
display formats) tell SAS Enterprise 
Guide how data should look in Data 
Grids or reports. There are different 
formats for character, numeric, date, 
time, and currency data. In this 
example, the format COMMAw.d with 
a width of 6 and no decimal places has 
been selected. This format can be 
written as COMMA6.0. See section 1.10 
for a table of commonly used formats. 

 

 

 

 Results  Here is 
the Data Grid 
showing the new 
name, 
HeightMeters, and 
format with 
commas.  
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1.9 Selected Informats 
SAS informats (also called input formats or read-in formats) tell SAS Enterprise Guide how to 
interpret input data. You can specify informats in the column Properties window of a Data Grid, or 
in the Column Options page when reading data. Here are a few of the many informats available in 
SAS Enterprise Guide. 

Informat Definition Width range Default width 

Character    

$w. Reads character data—trims leading blanks  1–32,767 none 

$UPCASEw. Converts character data to uppercase 1–32,767 8 

Date, Time, and Datetime1 

ANYDTDTEw. Reads dates in any form—when dates are 
ambiguous, uses the DATESTYLE system 
option to determine 

5–32 9 

DATEw. Reads dates in the form: ddmonyy or 
ddmonyyyy 

7–32 7 

DATETIMEw. Reads datetime values in the form: 
ddmonyy hh:mm:ss.ss 

13–40 18 

DDMMYYw. Reads dates in the form: ddmmyy or 
ddmmyyyy 

6–32 6 

JULIANw. Reads Julian dates in the form: yyddd or 
yyyyddd 

5–32 5 

MMDDYYw. Reads dates in the form: mmddyy or 
mmddyyyy 

6–32 6 

TIMEw. Reads time in the form: hh:mm:ss.ss 
(hours:minutes:seconds—24-hour clock) 

5–32 8 

Numeric 

w.d Reads standard numeric data 1–32 none 

COMMAw.d Removes embedded commas and $, 
converts left parentheses to minus sign 

1–32 1 

PERCENTw. Converts percentages to numbers 1–32 6 

 

1  SAS date values are the number of days since January 1, 1960. Time values are the number of seconds past midnight, and 
   datetime values are the number of seconds past midnight on January 1, 1960. 
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The examples below show input data and resulting data values for each informat. The results 
shown are unformatted data values. See sections 3.1 and 3.2 for more information about assigning 
display formats. 

 

Informat Input data Results Input data Results 

Character 

$10. Lassen Lassen St. Helens St. Helens 

$UPCASE10. Lassen LASSEN     St. Helens ST. HELENS 

Date, Time, and Datetime 

ANYDTDTE10. 01jan1961 

1961001 

366 

366 

31.01.1961 

01/31/61 

396 

396 

DATE9. 1jan1961 
 

366 31 jan 61 396 

DATETIME14. 1jan1960 10:30
 

37800 1jan1961 10:30 31660200 

DDMMYY10. 01.01.1961 

 

366 31/01/61 396 

JULIAN7. 1961001 
 

366 61031 396 

MMDDYY10. 01-01-1961 
 

366 01/31/61 396 

TIME8. 10:30 
 

37800 10:30:15 37815 

Numeric 

5.1 1234 123.4 -12.3 -12.3 

COMMA10.0 $1,000,001 1000001 (1,234) -1234 

PERCENT5. 5% 0.05 (20%) -0.2 
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1.10 Selected Standard Formats 
SAS formats (also called display formats) tell SAS Enterprise Guide how to display or print data. 
You can apply formats in the column Properties window of a Data Grid, in the Properties window 
within a task, or in a query. Here are a few of the many formats available in SAS Enterprise Guide. 

Format Definition Width range  Default width 

Character 

$UPCASEw. Converts character data to uppercase 1–32767 Length of variable or 8 

$w. Writes standard character data—default for 
character data 

1–32767 Length of variable  
or 1 

Date, Time, and Datetime1 

DATEw. Writes SAS date values in form ddmonyy or 
ddmonyyyy 

5–9 7 

DATETIMEw.d Writes SAS datetime values in form 
ddmmmyy:hh:mm:ss.ss 

7–40 16 

DTDATEw. Writes SAS datetime values in form ddmonyy or 
ddmonyyyy 

5–9 7 

EURDFDDw. Writes SAS date values in form dd.mm.yy or 
dd.mm.yyyy 

2–10 8 

JULIANw. Writes SAS date values in Julian date form 
yyddd or yyyyddd 

5–7 5 

MMDDYYw. Writes SAS date values in form mm/dd/yy or 
mm/dd/yyyy—default for dates 

2–10 8 

TIMEw.d Writes SAS time values in form hh:mm:ss.ss—
default for times 

2–20 8 

WEEKDATEw. Writes SAS date values in form 
day-of-week, month-name dd, yy or yyyy 

3–37 29 

WORDDATEw. Writes SAS date values in form 
month-name dd, yyyy 

3–32 18 

Numeric 

BESTw. SAS System chooses best format—default 
format for numeric data 

1–32 12 

COMMAw.d Writes numbers with commas 2–32 6 

DOLLARw.d Writes numbers with a leading $ and commas 
separating every three digits—default for currency 

2–32 6 

Ew. Writes numbers in scientific notation 7–32 12 

EUROXw.d Writes numbers with a leading € and periods 
separating every three digits 

2–32 6 

PERCENTw.d Writes numeric data as percentages 4–32 6 

w.d Writes standard numeric data 1–32 none 

1 SAS date values are the number of days since January 1, 1960.  Time values are the number of seconds past midnight, and 
  datetime values are the number of seconds past midnight on January 1, 1960. 
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The examples below show unformatted data values and formatted results for each display format. 
 
 

 
Format Data value Results Data value Results 

Character 

$UPCASE10. Lassen LASSEN St. Helens ST. HELENS 

$10. Lassen 

 

Lassen St. Helens St. Helens 

Date, Time, and Datetime 
DATE9. 
 

366 01JAN1961 396 31JAN1961 

DATETIME16. 
 

37800 01JAN60:10:30 2629800 31JAN60:10:30 

DTDATE9. 
 

37800 01JAN1960 2629800 31JAN1960 

EURDFDD10. 
 

366 
 

01.01.1961 396 31.01.1961 

JULIAN7. 366 
 

1961001 396 1961031 

MMDDYY10. 
 

366 01/01/1961 396 01/31/1961 

TIME8. 
 

37800 
 

10:30:00 37815 10:30:15 

WEEKDATE15. 366 
 

Sun, Jan 1, 61 396 Tue, Jan 31, 61 

WORDDATE12. 366 
 

Jan 1, 1961 396 Jan 31, 1961 

Numeric 

BEST10. 
BEST6. 

1000001 

1000001 

1000001 

1E6 

-12.34 

100001 

-12.34 

100001 

COMMA12.2 1000001 1,000,001.00 -12.34 -12.34 

DOLLAR13.2 
 

1000001 $1,000,001.00 -12.34 $-12.34 

E10. 1000001 1.000E+06 -12.34 -1.234E+01 

EUROX13.2 
 

1000001 €1.000.001,00 -12.34 €-12,34 

PERCENT9.2 0.05 5.00% -1.20 (120.00%) 

10.2 1000001 1000001.00 -12.34 -12.34 
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1.11 Scheduling Projects to Run at Specific Times  
Sometimes you may want to create a project now, but run it later.  For example, if you have data 
that are updated on a regular basis, you might want to automatically rerun the project once a 
week using the new data. Or, if your data files are very large, you might want to run your 
projects at night so that SAS Enterprise Guide is not using valuable resources during work 
hours. 

Scheduling a project  To schedule a 
project, select Tools ► Schedule Project from 
the menu bar. This opens the Schedule 
window with the Task page displayed. When 
you schedule a project, SAS Enterprise Guide 
creates a script that is saved in a file on your 
computer. The name and path of this script is 
displayed in the Run box. The Start in box 
displays the folder in which the script will 
run. Your computer and user name are 
displayed in the Run as box.   

If you will not be logged on at the time the 
project runs, then make sure the box next to 
Run only if logged on is unchecked, and 
click the Set password button to open the Set 
Password window. Enter the password for 
your user name (the same password you use 
when you log on to your computer), and 
click OK.  

 

Setting the run frequency  To tell SAS 
Enterprise Guide when to run the project, 
click the Schedule tab of the Schedule 
window.  Click the New button. Then select 
the frequency to run the project from the 
drop-down list under Schedule Task. You 
can schedule your project to run just once at a 
specified time as shown here, or you can 
schedule your project to run on a regular 
basis. 
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Setting the date and time  To set the 
time the project will start running, click the 
up and down arrows on the Start time box, 
or simply click the time and type a new 
value. To choose a date other than today, 
click the down arrow in the Run on box and 
select a date from the pop-up calendar.  

Other settings  If you click the Settings 
tab, you will see other options, including 
the maximum length of time a project will 
be allowed to run and whether it will run if 
your computer has gone into sleep mode.  

When you are satisfied with all the settings, 
click OK to schedule the project. 

 

 

 

Running the project  The project will not run if it is open or if the computer is turned off at 
the time the project is scheduled to run. However, if you have a different project open, the 
scheduled project will still run.  

Viewing the 
results  To see the 
results of your 
scheduled run, open 
the project after it has 
completed running. If 
you are not sure 
whether a project ran, 
you can confirm this by 
opening the Properties 
window for that 
project. To open the 
Properties window for 
a project, select File ► 
Properties from the 
menu bar. The Last 
modified field shows 
the date and time that 
the project last ran. 
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1.12   Viewing and Editing SAS Code Generated by a Task 
If you are a SAS programmer, you’ll probably want to see the SAS code generated by SAS 
Enterprise Guide. Sometimes, you may also want to edit the SAS code generated by SAS 
Enterprise Guide. There is more than one way to do this. You can insert your own custom code 
into the SAS program written by a task, or you can save the code generated by a task in a 
separate file which allows you to edit any part of the program. 

Viewing code 
generated by a task  
Many task windows 
have a Preview code 
button in the lower-left 
corner. If you click this 
button, SAS Enterprise 
Guide will open a Code 
Preview window 
displaying the code that 
SAS Enterprise Guide 
has written for that task.   

 

 

  

 
Inserting code in 
a task  Here is a 
Code Preview 
window for a List 
Data task. You can see 
that it uses PROC 
PRINT.  If you want to 
add code to the task, 
click the Insert Code 
button. This opens a 
User Code window. 
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You cannot edit the existing 
code generated by a task, 
but the User Code window 
allows you to add code at 
specific points in the 
program. In the User Code 
window, double-click 
<double-click to insert 
code> at the point where 
you wish to add your own 
custom code. An Enter User 
Code window will open. 
Type the custom code you 
wish to add. When you are 
done, click OK. Your new 
code will appear in the User Code window. Click 
OK in the User Code window. When you run the 
task, SAS Enterprise Guide will run the code you 
inserted, in addition to the code generated by the 
task.  

Editing code generated by a task  If you 
want to be able to edit the entire program generated by a task, or code from tasks that do not 
have a Preview code button, you can make a copy of the generated code, and then edit it. To do 
this, run the task, and then right-click the task icon in the Project Explorer or Project Designer, 
and select Add As Code Template. SAS Enterprise Guide will open a code window in the 
workspace containing the code generated by the task.  

You can edit this code in any 
way you wish. Because this 
code is a copy of the code 
generated by the task, any 
changes you make here will not 
affect the task, nor will any 
changes you make to the task be 
reflected in this code. When you 
have made all the changes you 
wish to the code and are ready 
to run it, select Code ► Run 
program-name On server-name 
from the menu bar. To choose a 
different server, select Code ► 
Select Server.  

Code created in this way is embedded in your project, and is not saved as a separate file. For 
more information on embedding code, see the next section. 
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1.13 Writing and Running Custom SAS Code  
You can accomplish a lot using tasks in SAS Enterprise Guide, but sometimes you may need to 
do something for which there is no predefined task. At those times, you can open a SAS program 
that was written outside SAS Enterprise Guide or you can write a new one. 

Writing a new SAS 
program  To create a new 
SAS program, open a new 
Code window by selecting 
File ► New ► Code from the 
menu bar. An empty Code 
window will open in the 
workspace. The code editor in 
SAS Enterprise Guide is 
syntax-sensitive, which means 
that SAS keywords are 
displayed in blue, comments 
are green, quoted strings are 
pink, and so forth. 

Opening an existing 
SAS program  If you have existing SAS programs that you want to include in your project, 
you can open them by selecting File ► Open ► Code from the menu bar. Navigate to the existing 
SAS program and click Open. This opens a Code window in the workspace, where you can edit 
the program. 

Saving code in a file  Any 
new programs you write are 
automatically embedded in your 
project. This means that the 
program’s code does not exist in a 
file outside the project. To save the 
SAS code outside the project, right-
click the code icon in the Project 
Explorer or Project Designer and 
select Save Code As from the pop-
up menu. You can also save code 
from the Properties window. To 
view the properties of code, right-
click the code icon in the Project 
Explorer or Project Designer and 
select Properties from the pop-up 
menu. Then in the General page, 
click Save As. If you save the code 
in a file, then the program is not 
embedded, and any changes you 
make to the code in SAS Enterprise 
Guide will be saved in the file rather than as part of your project. 
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The icon for code saved in a file 
includes a little arrow indicating 
that the project contains a 
shortcut to the code rather than 
the actual code.  

Embedding code in a 
project  When you open a SAS 
program that has been saved in 
a separate file, it is not 
automatically embedded in 
your project. If you want to 
embed the program in your 
project, then open the Properties 
window for the code and click 
the Embed button. After you 
embed the code, any changes 
you make to the code in SAS 
Enterprise Guide will be saved 
as part of your project rather 
than in the file. The icon for 
embedded code looks like this.  

Running your code and viewing the SAS log  When you are ready to run your code, 
select Code ► Run program-name On server-name. To choose a different server use Code ► 
Select Server. When you run code in SAS Enterprise Guide, if there is an error, the default action 
is to open a SAS log window in the workspace. If there are no errors, then the SAS log will not 
open automatically. To open the SAS log, double-click the icon for the log in the Project Explorer. 
Here is a portion of the SAS log generated by the SAS program at the beginning of this section.  
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1.14 Using SAS Enterprise Guide Help 
In SAS Enterprise Guide, help is never far away. You can find help via the Help menu, of course, 
but you can also find help inside many windows. 

What is window  To open the What is window, select View ► What is from the menu bar. Then 
point the cursor at a menu item or tool, and the What is window will describe that menu item or tool.  

 

Context-sensitive help  The List Data window provides a good example of the context- 
sensitive help provided inside task windows.  

 

Animated Help 

 Help Box 

Help Button 

What is Window 
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There are three main types of context-sensitive help: 

 Animated help demonstrates how to assign variables to task roles.  

 The Help box near the bottom of the window displays textual help. As you move your 
cursor around the window, the text automatically changes to describe what the cursor 
is pointing to. 

 The Help button in the right corner gives you more extensive help. When you click it, 
the SAS Enterprise Guide Help window opens.  

SAS Enterprise Guide Help  If you click the Help button in a task window, SAS 
Enterprise Guide will open the Help window and display information about the current task. 
You can also open the Help window by selecting Help ► SAS Enterprise Guide Help from the 
menu bar, but then it’s up to you to find the right section of help for your needs. 

 

The Help window has two main panes: the Navigation pane on the left, and the Topic pane on 
the right. In the Navigation pane, you can choose from four tabs. 

 The Contents tab shows an expandable table of contents for the SAS Enterprise Guide 
documentation.  

 The Index tab allows you to browse the index for both SAS Enterprise Guide and SAS 
syntax help. If you type a keyword or part of a keyword, you will jump to that part of 
the index.  

 The Search tab finds every occurrence of the words you type, in both the SAS Enterprise 
Guide and SAS syntax help.  

 The Favorites tab allows you to make a list of your favorite help topics so that you can 
find them more easily in the future. 
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1.15 Using the Options Window 
The Options window allows you to change many default behaviors in SAS Enterprise Guide. To 
open the Options window, select Tools ► Options from the menu bar. 

Data General options  To open the Data > Data General page, click Data General in the 
selection pane on the left.  

 

If you have large data tables, columns might be easier to find if they are arranged in alphabetical 
order. To list columns alphabetically in task windows, check the box in front of Display columns 
in alphabetical order.  

By default, the Data Grid uses column names, not labels, for column headers. To change this, 
check the box in front of Use labels for column names. 

If you have large data tables on remote servers, you may be able to improve performance by 
unchecking Automatically open data when added to project.  

Tasks General options  To open the Tasks > Tasks General page, click Tasks General in the 
selection pane on the left.  

At the top of this page, you can type a new default title and footnote, or set them to blank.  
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Near the bottom of the page is another useful option. Some tasks in SAS Enterprise Guide 
include in the results the name of the SAS procedure used by that task. In these results, you will 
see titles like “The FREQ Procedure,” or “The ANOVA Procedure.” You can eliminate these titles 
by unchecking the box for Include SAS procedure titles in results. 

 

Restoring the default windows  To restore windows to their default layout, click General 
in the selection pane on the left. Then click the Reset Docking Windows button.  

Changing the default output type or style  To change the default output type, click 
Results General in the selection pane on the left, and check the type of output you want. To 
change the default output style, click HTML, RTF, PDF, or SAS Report in the selection pane on 
the left. Then select the output style you want. See Tutorial C or section 10.2 for more 
information about changing output styles. Section 4.13 discusses changing the output type for 
queries, and section 9.6 discusses changing the output type for graphs. 

Saving and resetting options  Click OK to close the Options window and save the 
changes you have made. Once you set options, they stay in effect for future SAS Enterprise 
Guide sessions. If at a later time, you decide you want to restore everything in the Options 
window to the default settings, simply click the Reset All button in the lower left corner. 
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