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ABSTRACT

SAS Enterprise Guide allows you to define parameters, and then use those parameters in your project. Parameters
are simply macro variables. When you run a project containing parameters, SAS Enterprise Guide prompts you to
assign values to those macro variables. Using parameters, you can create a project, and then customize it at the time
you run it.

In SAS Enterprise Guide 4.1, there are three ways to use parameters: as a variable name in a task, in the filter
condition of a query, or in SAS code. This paper covers all three types of parameters, showing how to define
parameters, how to insert them in your project, and then how to run the final project using the parameters.

INTRODUCTION

Subsetting data and running reports is easy in SAS Enterprise Guide. It is also easy to reopen a query or task, make
a change, and then rerun your project. But it can be even easier to make changes if you use parameters. With
parameters, you don’t have to reopen the query or task to make changes. You just run the project, and SAS
Enterprise Guide will prompt you for the changes.

This paper starts with a simple project consisting of a task, a query, and SAS code—without using parameters. Then
we create parameters, and add them to the task, query and code.

RUNNING A LIST REPORT WITHOUT PARAMETERS

This paper uses a data table, named World, which contains data about all the countries in the world. To create a
simple detail report, click the data icon in the Project Explorer or Project Designer to make it active, and select
Describe » List Data from the menu bar. The List Data window will open.
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In the List Data window, assign variables (also called columns) to task roles.

Hands-on Workshops
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To specify a title for the report, click Titles in the selection pane on the left. Then uncheck the Use default text
option, and type the new titles in the box below. When you are satisfied, click Run.
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The new list report will appear in the workspace.
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FILTERING DATA IN A QUERY WITHOUT PARAMETERS

Open the Query Builder by right-clicking the data icon in the Project Explorer or Project Designer and selecting Filter
and Query from the pop-up menu. You can also click the data icon to make it active, and then select Data » Filter
and Query from the menu bar.
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In the Query window, highlight all the columns (also called variables) that you want to keep in the subsetted data
table, and drag the column names to the Select Data tab. If you want to keep all the columns, you can drag the data
table name instead.
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Click the Filter Data tab. Then click the column you want to use for subsetting the data, and drag it to the Filter Data
tab. In this example, the column Yearlnd is being dragged to the Filter Data tab. The Edit Filter window will open.
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In the Edit Filter window, specify an Operator and Value. In this example, the operator is set to Greater than or
equal to, and the value is set to 1990 so this filter will select all countries that became independent on or after 1990.
When you are satisfied with the settings, click OK to return to the Query window.
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The Filter Data tab in the Query window will display the new filter. Click Run and SAS Enterprise Guide will run the
query and display the results in a Data Grid.
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In this example, the new data table includes only the 27 countries that have become independent since 1990.

T
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RUNNING SAS CODE WITHOUT PARAMETERS
To open an empty Code window so you can write a SAS program, select File » New » Code from the menu bar. Then
type your program using the syntax-sensitive editor.
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EIPROC FREQ DATA = 'o:h)yMy3iSdata' Torld';
WHERE ¥earInd >= 1990;
TABLES Region:
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TITLEZ "For Each WValue of BEegion®:
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To run the code, click the code icon to make sure it’s active, and select Code » Run program-name On server-
name from the menu bar where program-name is the name of your program (such as Code), and server-name is the
server you want to run SAS on (such as Local). The results will appear in the workspace. Note that in this case you
could accomplish the same result without writing any SAS code by using a query to subset the data, and using that
data as the input for a One-Way Frequencies task.
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We now have a simple project consisting of a data table, a List Data task, a query, and SAS code. We are ready to

add parameters.
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CREATING PARAMETERS FOR VARIABLE NAMES

To create a variable name parameter that can be used in a task, first open the Parameters Manager by selecting
Tools » Parameters (Macro Variable) Manager from the menu bar. In the Parameters Manager, click Add to open

the Add New Parameter window.
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In the General tab of the Add New
Parameter window, you specify a Display
name, a SAS code name, and a
Description, and then choose the Data
type from a pull-down list. The display
name is the text you will see when you run
the task. The SAS code name will be the
name of your macro variable. The SAS
code name must be 32 characters or fewer
in length; start with a letter or underscore;
and contain only letters, numerals, or
underscores. The description is optional
and appears only in this window.

In this example, the display name is Select
a Grouping Variable for the Report, the
SAS code name is GroupingVariable, and
the data type will be Variable name.
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The new parameter will appear in the Parameters Manager window. Click Close.
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USING PARAMETERS IN TASKS
To use a parameter in an existing task, reopen the task by double-clicking the task icon in the Project Explorer or
Project Designer. In the task window, the list of variables will now include any variable name parameters. You can tell

which variables are parameters because their icons include a little ampersand symbol ﬁ‘ You can drag the
parameters to task roles just like other variables.
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You can also use parameters in titles and footnotes. To specify a title for the report, click Titles in the selection pane
on the left. Then uncheck the Use default text option, and type the new titles in the box below. When you type the
parameter name into a title, you must put an ampersand in front of its name. In this example, the parameter name is

&GroupingVariable. When you are satisfied, click Run.
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A window will open prompting you to choose a value for the parameter. Choose the value for the parameter, and click
Run. In this case, LandGroup was chosen, but you could choose some other variable name from the list.
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The results will be displayed in the workspace.
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CREATING PARAMETERS FOR DATA VALUES
To create a parameter that can be used in the filter condition of a query, first open the Parameters Manager. You can

do this inside the Query window by clicking the Parameters button, or from the menu bar by selecting
Tools » Parameters (Macro Variable) Manager. The Parameters Manager will display any parameters that have
already been defined for this project. In the Parameters Manager, click Add to open the Add New Parameter window.
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In the General tab of the Add New
Parameter window, you specify a Display
name, a SAS code name, and a
Description, and then choose the Data
type from a pull-down list. The display
name is the text you will see when you run
the query. The SAS code name will be the
name of your macro variable. The SAS
code name must be 32 characters or
fewer in length; start with a letter or
underscore; and contain only letters,
numerals, or underscores. The description
is optional and appears only in this
window.

In this example, the display name is
Select Countries Independent Since
Year, the SAS code name is
StartingYear, and the data type will be
Integer.

Click the Data Type and Values tab. Here
you specify the Data value type and the
appropriate data values. In this example,
the data value type is Any integer value
is allowed, and the default value has
been set to 1990. When you are satisfied
with all the settings, click Add and Close.
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Your new parameter will now be listed in the Parameters Manager. Click Close.
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USING A PARAMETER IN THE FILTER CONDITION OF A QUERY
To use a parameter in an existing query, open the Query window by double-clicking the query icon in the Project
Explorer or Project Designer. In the Query window, click the Filter Data tab and click the Edit Filter button on the right

side. The Edit Filter window will open.
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In the Edit Filter window, click the down-arrow on the Value box. Click the Parameters tab, and select the name of
the parameter you want to use.
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The parameter name will now be listed in the Value box. Click OK.
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The new filter using the parameter will be displayed in the Query window. Click Run to rerun the query.
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When you run the query, a window will open prompting you to specify a value for the parameter. In this example, 1950
has been typed in. When you are satisfied, click Run and SAS Enterprise Guide will run the query using the value you

specified.
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The results of the query will appear in a Data Grid. In this example, the new data table contains the 113 countries that
have become independent since 1950.

& SAS Enterprise Guide - ParametersHOW

é File Edit ‘Wiew Code Data Descrbe Graph  Analyze  Add-In OLAP  Tools  Window  Help
g - B”‘, - % | 5 ¥ B X | B |Q\ il gquroject Designer E|Maximize Watkspace %Task Status
% Query_for_world (Query for world (P = E ol .
Project Explorer | Beg Project Designer | Query_for_World [read-onk) | x [N
]ParametersHDW 4{& i:ounlry é& Region @ Yearlnd |@ IndE"mup @ | Q
bog Process Flow - . ; ! =
B"Ea \world 1 Algena Alrica 1962 194K to prezent 5
= [B LitData B | ~ngole Lafica : -
: Last Submitted Code | |3 d Barb 1346 to present
Z] Log 4
8 HTML - List Data 5 134E to present
BE} Gueny For 'World 6 1946 to present
-~ [E] Last Submitted Code 7
| Log 8 1946 to present
1 Qluery_for_world 9 Barbados
- @ de 10 |Belas
g L N |Belee
L8 HTML - Code 12 |B i
13 - Europe 1946 to prezent
14  Afiica 1966 1346 topresent
@ |
Task Status
Task Shatus Queus | Server
i; ik 1ii] _|l| i: lilf | l
Ready ﬂ [Unkhawi] connected ta localhost

USING PARAMETERS IN SAS CODE

To reopen an existing code file, double-click its icon in the Project Explorer or Project Designer. Then edit the code. In
this example, the parameters &StartingYear and &GroupingVariable have been added to the program. Notice that
this is just a normal SAS program that uses macro variables.

| Bag Project Designer [&] Code*

S PROC FREQ DATA = 'c:'\My3iSdata' Torld';
WHERE YearInd »>= &3tarting¥ear:
TABLES &GroupingWariable;
TITLE]1l "Countries That Becamwe Independent in &Starting¥ear or Later™;
TITLEZ "For Each WValue of &GroupingVarisble™:
RUH;

( | {1} | } |
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Hands-on Workshops

When you create parameters in the Parameter Manager and then use them in code, you need to associate the
parameters with the code. To do that, right-click the code icon in the Project Explorer or Project Designer, and select
Properties. Then, in the Properties for Code window, click Parameters in the selection pane on the left, and click the
Add button. This opens the Select Parameters window.

Ed Properties for Code

General Parameters
Fesults
Farameters :
Summary Project parameters used:
\ 545 Mame Dizplay MNarne Data Type >

L M

Thiz item doez not use any parameters that are defined in the project.

Click
Parameters

| |

Agzociates exigting parameters with the code.

More [F1)...

[ ok

,][ Cancel J

The Select Parameters window lists all the parameters currently defined in the project. Use control-click to highlight
the names of all the parameters you want to use in the code. Then click OK.

EY Select Parameters

Select
parameters

0K Q[ Cancel ]A
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The parameters will appear in the Properties for Code window. Click OK.

Ed Properties for Code

Hands-on Workshops

General
Fesults
Farameters
Summary

gl sl

Parameters

Project parameters uzed:

SA5 Mame Dizplay MName Data Type i
Groupingyariable  Select a Grouping Yariable for the...  Wariable name
Starting''ear Select Countries Independent Sin...  Integer L
L — il — ) (&)
Add... Femove Farameter Manager...

Saves vour changes and clozes this window,

More [F1)...

[, ] %J[ Cancel J

To run the code, click the code icon to make sure it's active, and select Code » Run program-name On server-
name from the menu bar. When you do this, a window will open prompting you to select values for each parameter.

After you have set the values

for the parameters, click Run.

E£ Select values for these parameters

]

Select a Grouping Wariable for the Report

Select Countriez Independent Since Year

|F|egion vl =

1350

)Sas.

Run N[ Cancel ]A
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The output from the SAS code will appear in the workspace.

& SAS Enterprise Guide - ParametersHOW
File Edit Wiew Code Data Describe Graph  Analvze  Add-In OLAP  Toaols  Window  Help

= _'; - f?".!q ;l‘ ¥ B [ = 3 o Q| gug Project Designer E|Ma><|m|ze ‘Workspace %Taskstatus .
Query_for_world (Query for World (P~ _ PoE .

1 r W____,jd gqg Project Designer @ HTML- l:c.lda. " m
TP, ParametersHO & |
i=-fg Process Flow Countries That Became Independent in 1950 or Later i

= &3 World ] -
S-[B ListData | For Each Value of Region
1 Last Submitted C}
% Log
2 HTML-LitDatd The FREQ Procedure
= {5 Quen for word
E] Last Submitted Code Cumulative Cumulative
E] Log Region Frequency Percent Frequency Percent
Ej Buery_for_WWaorld
=[] Code Africa 49 43.36 49 23.36
ﬁ Log
{# HTML -Code Asia 22 19.47 71 62.83
Australia/Pacific 13| 11:50 84 7424
Europe 186 14.18 io00 88.50
North America 11 9:.73 111 98.23
South America 2 s Kirfr 113 100.00
=
E—— 24
Status (ueue | Server
Feady 1§ [Urknown] connected ta lacalhast
CONCLUSIONS

Using parameters in SAS Enterprise Guide allows you to create projects that are flexible. First you use the
Parameters Manager to define your parameters. Next you insert the parameters into tasks, queries, or SAS code.
Then every time you run the project, a window will open prompting you to select values for the parameters.
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