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CHAPTER

Introduction to SAS OnDemand for
Academics

TTUETOAUCEION ... e eeeeieeee ettt e e e e et e e e e e e e eabbeaeeeeeessasssaaeeeaeaassssaaseaaaeaasssssaseeaeeaassssasaeeesananssssseaeesananees 1

CLICTLE SOFEUIATE ...veeeveeeeeee e eeee e te e ettt e e e tteeestteeeestaeeeeseraeeasesaeeasssaeaasssaeesssaeeesssaeeenssaeesasseeeanssseesassseesansnen 1

Server Software - SAS ENLerpriSe GUIAER ...........cccueeeeeiueieeciieeeeiieeeeiieeesitteeassseessssseeessseeessssesessssessssssesesnnns 2

Server Software - SAS ENEerPriSe MITIET ............uveeeieeeeeciiieeeeeeeeeeiivteeeeeaeseitsseeeasessssssssseesasssssssssssesssssssssses 2

Server Software - SAS FOrecast Server (BEEQ) ............cccecuueeieeieeeciirieeeeeeaeeiisreeesseassissssesessssssssssssssssssssssssses 2
Introduction

SAS OnDemand for Academics provides an online delivery model for teaching and
learning data management and analytics. By connecting to a SAS-hosted server over the
Web, users access the analytical power of SAS software through a user-friendly, point-
and-click interface.

The advantages of using SAS OnDemand for Academics include:

O Students and professors gain immediate online access to SAS software — with no
configuration or support concerns.

O Students, including both onsite and distance learners, can use SAS whenever or
wherever they please - no more waiting for a seat in a campus computer lab or
having to buy and install software.

O SAS allows professors to teach data management and analytics, providing
multiple software applications without maintenance or IT overhead.

O SAS has been used in colleges and universities for more than 30 years.
O With quick access to award-winning software for data management and analytics,
students gain valuable SAS skills that are highly sought after in the job market.

The following sections list the SAS software available with SAS OnDemand for
Academics.

Client Software

Instructors can choose to use one of the following software applications when they
register a course with SAS OnDemand for Academics:

O SAS Enterprise Guide
Q SAS Enterprise Miner
O SAS Forecast Server (Beta)

When students register for the course, they must select the same software application
that their instructor has chosen to use.
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Server Software - SAS Enterprise Guide

The following products are available on the hosted SAS server that supports SAS
OnDemand for Academics: Enterprise Guide:

Sy Oy Sy Ay

Base SAS

SAS/STAT software

SAS/GRAPH software

SAS/ETS software

SAS/OR software, including OPT, PRS, IVS, and LSO
SAS/IML software

SAS/CONNECT software

SAS High-Performance Forecasting

SAS/ACCESS Interface to PC Files

Server Software - SAS Enterprise Miner

The following products are available on the hosted SAS server that supports SAS
OnDemand for Academics: Enterprise Miner.

[y Sy Ay Ry vy Ry Ay

Base SAS

SAS/STAT software

SAS/GRAPH software

SAS/ETS software

SAS/OR software, including OPT, PRS, IVS, and LSO
SAS/IML software

SAS/CONNECT software

SAS Enterprise Miner

SAS Credit Scoring

SAS Text Miner

SAS High-Performance Forecasting
SAS/ACCESS Interface to PC Files

Server Software - SAS Forecast Server (Beta)

The following products are available on the hosted SAS server that supports SAS
OnDemand for Academics: Forecast Server:

Sy Iy S [y

Base SAS

SAS/STAT software

SAS/GRAPH software

SAS/ETS software

SAS/OR software, including OPT, PRS, IVS, and LSO
SAS/IML software

SAS/CONNECT software

SAS Enterprise Miner

SAS Credit Scoring
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SAS Text Miner

SAS High-Performance Forecasting
SAS/ACCESS Interface to PC Files
SAS/ACCESS Interface to MYSQL
SAS Forecast Studio

SAS/IML Studio

Server Software - SAS Forecast Server (Beta)

3
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SAS OnDemand for Academics: Enterprise Guide

This manual guides students through recommended steps for registering for and using
SAS OnDemand for Academics.
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Chapter 2

Step 1. Confirm system requirements

Check these guidelines to ensure you can access the software. Your system must meet
these requirements for SAS OnDemand for Academics: Enterprise Guide to be fully

supported.
Supported/Required Notes
Operating Microsoft Windows 7 Home  Macintosh operating systems are not
systems Premium and above (32-bit supported
or 64 bit)
Microsoft Windows Vista Other versions of Microsoft Windows
Home Premium (32-bit or 64 Vista might work but have not been
bit) fully tested and, therefore, are not
supported by SAS.
Microsoft Windows XP If missing, Microsoft NET Framework
Professional version 3.5 Service Pack 1 will be
installed for users of Microsoft
Windows XP Professional. Depending
on the files required, installation could
take from5 to 90 minutes.
Internet Microsoft Internet Explorer  Other internet browsers might work
browser 8 or earlier but have not been fully tested and are
thus not supported by SAS.
Hard disk Approximately 80 MB of You will be prompted to install
space free hard disk space Microsoft .NET if it is not on your

machine.This will require additional
disk space.

Step 2.

Set up your SAS OnDemand for Academics account

There are several important steps you must follow to set up a SAS OnDemand for
Academics account, such as creating a SAS profile and registering for your course. The
online process uses a series of windows to guide you.

About the SAS OnDemand for Academics Control Center

Your starting point for accessing SAS OnDemand for Academics is the SAS OnDemand
for Academics Control Center Web site. You will use it to register, acquire a license, and
view course information.

http://support.sas.com/ctx3/sodareg/index.html

Your SAS OnDemand for Academics Home Page is created during the registration
process and is part of the SAS OnDemand for Academics Control Center. You will be
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taken to your Student Home Page once you have set up an account. You access your
home page to register for or view information associated with courses.

About your SAS Profile account

A SAS Profile is an account that you can create to access specific information and
resources from the SAS Web site. If you are a current SAS user, you might already have
a SAS Profile. If you are a new SAS user, a SAS Profile is created for you when you
register for SAS OnDemand for Academics.

An important part of your SAS Profile account is a SAS Profile password that you are
prompted to enter each time you access the SAS OnDemand for Academics Control
Center.

Note: Your SAS Profile password must be changed every 6 months for security
purposes. You will receive an e-mail when your password is approaching expiration.
To reset your SAS profile, visit My SAS Profile page at this location:

https://www.sas.com/profile/user/login.htm

Important information hefore you begin

As you begin setting up your account, it's helpful to keep the following in mind:

O You will need access to your e-mail account. When you begin registration, you will
be prompted to enter an e-mail address. Enter the e-mail address of an account
that you can access easily while completing your registration.

O You will receive an e-mail during the initial registration process that you must
open and act upon to continue. The e-mail prompts you to click a link to verify
your e-mail address. Its primary purpose is to confirm that you are using a valid
e-mail address and that someone else is not attempting to register you without
your knowledge.

O Ifyou do not receive the e-mail, please check your junk e-mail folder.

Register for a course

You must register to select and get access to the SAS software being used for the course.
During registration, you will be required to select a university, an instructor, and a
course. Visit the SAS OnDemand for Academics Control Center to begin:

http://support.sas.com/ctx3/sodareg/index.html
1 Enter your e-mail address in the text box to get started

2 Follow the instructions.

Visit the following location to print step-by-step instructions:

http://www.sas.com/govedu/edu/programs/enterprise_guide student.pdf

Step 3. Access and use the software

Ideally, you should perform this step before you begin your first assignment using SAS
OnDemand for Academics software.
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Access your SAS OnDemand for Academics account

Your SAS OnDemand for Academics account enables you to view and/or edit information
associated with courses. You will have access to this information after you have initially
registered for SAS OnDemand for Academics.

To access an existing SAS OnDemand for Academics account:

1 Access the SASOnDemand for Academics Control Center at the following Web
site: http://support.sas.com/ctx3/sodareg/index.html

2 Enter your e-mail address and your SAS Profile password and then click Enter.

Install SAS Enterprise Guide

To use SAS Enterprise Guide from SAS OnDemand for Academics account, you must
first install a copy of the software on your computer. Follow these steps to install SAS
Enterprise Guide software:

1 Log on to your SAS OnDemand for Academics Control Center using your e-mail
address and your SAS Profile password.

2 Scroll to the bottom of your Home Page to see a table that lists the courses that
you have registered.

3 Click Download Client for the appropriate course.

After the software client is downloaded and installed, you can begin using the
software and accessing the SAS Server.

For step-by-step guidance including graphics, you can download “SAS OnDemand for
Academics: Enterprise Guide Student Registration Instructions” from
http://www.sas.com/govedu/edu/programs/enterprise_guide_student.pdf or visit the SAS
OnDemand for Academics Web site at http:/www.sas.com/academics.

Access the SAS Server

You are prompted to connect to the SAS Server each time you start SAS OnDemand for
Academics: Enterprise Guide. The server (which is hosted at SAS Institute Inc.)
remotely processes any submitted SAS files or projects and returns results to your
computer.

If you are unable to use a SAS OnDemand for Academics software application to
perform processing, make sure that you have a working Internet connection.

If your Internet connection is working normally, you can check the SAS Server Status
Web page (https://www.ondemand.sas.com/status/oda/) to determine if appropriate
servers are available or temporarily down for maintenance.

Avoid connection time-outs

Avoid leaving open connections on the server. An open connection to the SAS Server
will likely disconnect (time out) after one hour (or less) if the connection is idle (that is,
you have not performed any processing). Many firewalls disconnect open sessions after
an hour of idle time (or less). SAS recommends that you complete your work, save it, and
then exit SAS OnDemand for Academics: Enterprise Guide before you leave the
computer.
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SAS Server maintenance and availahility

SAS makes its best efforts to make the server available as much as possible and to keep
unexpected downtime to a minimum. There could be limited times when the server is
unavailable because SAS is performing maintenance, testing, or performance
enhancement tasks.

O Ifserver maintenance is needed, SAS will try to perform this work during
nontraditional usage hours to lessen any impact to users.

O SAS uses the third Saturday of each month to perform scheduled maintenance on
its systems (if needed). Therefore, the server might be unavailable for a portion of
time on the third Saturday of each month.

To determine if SAS servers are available, visit the SAS Server status Web page:
(https://www.ondemand.sas.com/status/oda/).

Requesting SAS Server availahility notification

If you would like to be notified when the SAS Server is unavailable due to extended
maintenance or due to unforeseen circumstances, please subscribe to the
SASONDEMANDSERVER-L mailing list:

1 Send e-mail to LISTSERVELISTSERV.SAS.COM.
2 In the body of the e-mail, type subscribe SASONDEMANDSERVER-L

3 Send the e-mail (no subject line is needed). Follow any instructions you receive via
e-mail.

To unsubscribe from SASONDEMANDSERVER-L, perform the following steps:
1 Send e-mail to LISTSERVRLISTSERV.SAS.COM.
2 In the body of the e-mail, type unsubscribe SASONDEMANDSERVER-L

3 Send the e-mail (no subject line is needed)

Step 4. Review the hasics for working with data and results

Before attempting course exercises, we recommend that you review the basics of
working with SAS data sets and results in SAS OnDemand for Academics: Enterprise
Guide.

Working with data

To ensure that you do not lose your work, you should cover the basics of uploading and
downloading files from the SAS Server.

Storing data

There are two ways to store data for use with SAS OnDemand for Academics:

O Instructors can choose to store data for course exercises on the SAS Server. You
can access the data using a LIBNAME or FILENAME statement that your
instructor will provide you.
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O Instructors or students can store the data that they want to use on a data source
that can connect to their PC. Sources could include a local file system, university
space (such as AFS or NFS space), or even portable disk drives.

Uploading data files to the SAS Server.

If the data that you want to use is not already available from the SAS Server, then you
can use the Upload Data Files to Server task available within S4S OnDemand for
Academics: Enterprise Guide.

The Upload Data Files to Server ask enables you to select one or more SAS data sets
(*.sas7bdat) from your local Microsoft Windows file system and copy them to the SAS
Server (the SAS Cloud) for processing. You must perform this step in order to work with
any local SAS data sets because the SAS Server cannot access any data on your local
drives.

The task generates a log that summarizes the data files that were copied, the byte size,
timings for each file and for all of the files as a group, and any errors that occurred
during the transfer. By default, all data files are added as output data in your SAS
Enterprise Guide project so that they can be used in the project.

Note: Since any modifications that you make to the data will not be saved once you
end your session, you might want to download any data files that you have changed
from the SAS Server to your local PC after you have finished your work.

To upload a data set:
1 Select SAS data sets to upload.
2 Specify the upload options.

To select the SAS data sets to upload:

1 Select Tasks » Data » Upload Data Files to Server. The Upload Data Files to
Server window opens.

2 Select Add to select the SAS data sets that you want to copy. The Open dialog box
opens.

3 Select the name of the file that you want to copy. To select more than one file, hold
down the CTRL key while selecting the files that you want to add. Files must be
SASTBDAT files.

4 Select Open to add the files to the list of data sets that you want to copy. Note that
all files that are copied are given lowercase names on the target server.

5 Select Next to specify the upload options. The Upload Data Files to Server window
opens. This window specifies the name of the SAS server and the destination SAS
library for your project. To specify the upload options:

O Ifyou want overwrite any existing files on the SAS server that have the same
name as the files that you are copying, select the Overwrite existing files with
the same name check box. By default, existing files are not overwritten.

O Ifyou do not want to add the data sets that you are copying to your current
SAS Enterprise Guide project, clear the Add data files to your current project
check box. By default, the copied data sets are added to the current project.

Note: The SAS Server for SAS OnDemand for Academics is selected by default,
and cannot be changed.
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Note: The WORK library is the destination SAS library by default and should
not be changed. The WORK library is specified because it is the only location on
the SAS Server that you have the ability to temporarily store data for processing.
Selecting any library other than WORK will result in an error.

6 Select Finish to copy the data sets to the SAS Server. A log is created and appears
in the SAS Enterprise Guide Project Explorer.

Downloading data files from the SAS Server

The Download Data Files to PC task enables you to select one or more SAS data sets
(*.sas7bdat) from the SAS Server and copy them to your local Microsoft Windows file
system. It is important to complete this step if you have modified any SAS data sets that
you want to use again in the future.

The task generates a log that summarizes the data files that were copied, the byte size,
timings for each file and for all of the files as a group, and any errors that occurred
during the transfer.

To download a data set:
1 Select the SAS data sets to download.
2 Specify the download options.

To select the SAS data sets to download:

1 Select Tasks » Data » Download Data Files to PC. The Download Data Files to PC
window opens.

2 Select Add to select the SAS data sets that you want to copy. The Open dialog box
opens.

3 Select the name of the file that you want to copy. To select more than one file, hold
down the CTRL key while selecting the files that you want to add. Files must be
SASTBDAT files. All files that are copied are given lowercase names in the target
folder.

Select Open to add the files to the list of data sets that you want to copy.

Select Next. The Download Data Files to PC window opens. To specify the
download options, follow these steps:

Q Type the path of the folder to which you want to copy the files or select Browse
to select a folder. The default location is your My Documents folder.

O Ifyou want to overwrite any existing files in your PC folder that have the
same name as the files that you are copying, select the Overwrite existing files
with the same name check box. By default, existing files are not overwritten.

6 Select Finish to copy the data sets. A log is created and appears in the SAS
Enterprise Guide Project Explorer.

Accessing data using SAS OnDemand for Academics: Enterprise Guide

The SAS Server includes sample SAS data sets that you might choose to use.
Additionally, if course files and SAS data sets have been uploaded to the SAS Server,
then you can access these SAS data sets as well. To access the SAS data sets, do the
following:

1 Start SAS OnDemand for Academics: Enterprise Guide and log on.
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Select File » Open » Data.
Select Servers.

Double click on SAS Apps.
Double click on Libraries.

Double click on the appropriate library (such as MAPS or SASHELP or the library
that you have assigned using a LIBNAME statement).

7 Double click on the SAS data set that you want to use.

Note: Remember that if you modify a SAS data set that exists on the SAS Server and
you want to save that SAS data set, you must download the data set to a local drive. If
you do not, your modifications will be lost when you end your session.

Additionally, some of the SAS data sets available from the SAS Server might be too
large to download locally unless you have modified them to make them smaller. In this
case, it is recommended that you work with the original SAS data sets only while
connected to the SAS Server.

S Ol A W DN

Accessing grayed-out SAS libraries from the SAS Server

The SAS Server includes sample SAS data sets that you might choose to use. Some of
the sample SAS Libraries might appear to be grayed out, but they are still available for
use.

Typically, grayed out SAS Libraries appear for users in Europe and were originally
intended for use with another SAS software application, such as SAS Enterprise Miner.

1 Start SAS OnDemand for Academics: Enterprise Guide and log on.
2 Select File » Open » Data.

3 Select Servers.

4 Double click on SAS Apps.

5 Double click on Libraries.

6

Right click on the grayed out SAS Library that you would like to access and then
click Assign.

7 Double click on the SAS data set that you want to use.

Uploading data files to the SAS Server versus opening SAS data sets

If you have access to a local SAS data set, you can choose File » Open » Data and select
the appropriate SAS data set. However, this is not the preferred method. Instead, SAS
recommends that you upload the SAS data set to the SAS Server. This will improve data
transfer speed and it will ensure that the step is recorded as part of your project.

Working with data files other than SAS Data Sets

If you want to work with data other than SAS data sets (such as comma delimited files
or text files), you can import the files in to SAS OnDemand for Academics: Enterprise
Guide. To import files that are not SAS data sets, follow these steps:

1 Select File » Import Data.
2 Select Local Computer.
3 Find and select the data file that you want to use.



SAS OnDemand for Academics: Enterprise Guide  Step 4. Review the basics for working with data and results 13

Working with compressed SAS Data Sets

SAS does not recommend that you work with compressed SAS data sets when using
SAS OnDemand for Academics: Enterprise Guide. If you have a compressed SAS data
set, you can use the COMPRESS=NO option to remove compression.

Assigning LIBNAME and FILENAME statements

The SAS Server is unable to recognize or access the local drives of your PC. Therefore, if
your SAS program includes a LIBNAME or FILENAME statement that refers to a local
path (such as a location on your C: drive), then you will receive processing errors.

Instructors have the ability to store SAS data sets and other data files on the SAS
Server. If your instructor has taken advantage of this feature, then you will receive
either a LIBNAME statement or a FILENAME statement from your instructor that you
can use to access the appropriate data.

Note: LIBNAME or FILENAME statements are case-sensitive. Please copy them or
type them in exactly as they appear to avoid permissions errors.

If you do have local SAS data sets that you want to use, it is recommended that you
upload them. You can then refer to the uploaded SAS data sets in your code or in your
projects. Additionally, if you modify the SAS data sets that you upload and you want to
use them again, you should download the SAS data sets from the SAS Server prior to
exiting SAS OnDemand for Academics.

Accessing data with LIBNAME or FILENAME statements

Once a SAS data set or a data file has been uploaded to the SAS Server, users can access
the data using the appropriate LIBNAME or a FILENAME statement. The LIBNAME
or FILENAME statement to use is provided to you during the course registration
process. You can access this information at any time:

1 Log on to your SAS OnDemand for Academics Home Page.
2 Start SAS OnDemand for Academics: Enterprise Guide.

3 Create or open a SAS program.
4

Assign the LIBNAME or FILENAME statement in your code in order to access
your data. Remember LIBNAME and FILENAME statements are case-sensitive.

Working with INFILE statements

An INFILE statement identifies an external data file to read with an INPUT statement.
If you plan to use an INFILE statement or are asked to use an INFILE statement to
access data, then you must use a fully qualified path in your statement.

For example, if country.dat exists in a course directory called
/courses/u_0/i 123/c_105, then the INFILE statement to access this data file
would be:

infile '/courses/u 0/i 123/c_105/country.dat’';

However, if you specified a path that is not fully qualified (such as the following), then
an error would be produced:

infile ‘country.dat’;

Students must use the INFILE statement (with the fully qualified path) that your
instructor provides.


http://support.sas.com/ctx3/sodareg/index.html
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Working with INFILE statements and Microsoft Windows data files

If you import or upload a raw data file (such as a text file or a comma separated value
file) from a PC using the Microsoft Windows operating system, the file might contain
carriage-return characters. These carriage-return characters will cause errors when you
attempt to read the file on the UNIX version of SAS used by SAS OnDemand for
Academics servers.

For example, using the following INFILE statement could cause data processing or data
display errors:

infile newemps dlm=',"';
These errors can be avoided by using the following INFILE statement:
infile newemps dlm=',' TERMSTR=CRLF;

For more information about the TERMSTR option, search for TERMSTR in SAS 9.1.3
Online Documentation at http://support.sas.com/documentation .

Saving Work

SAS OnDemand for Academics: Enterprise Guide is unable to store your work on the
SAS Server (the SAS Cloud). Instead, you must save any work (SAS Enterprise Guide
projects, SAS files, output files, and so on) to a hard disk drive that you can access prior
to ending your session.

To save any work within SAS OnDemand for Academics: Enterprise Guide, start by
selecting one of the following options:

O To save a file, choose File » Save or File » Save As

0 To save a project, choose File » Save Project or File » Save Project As

Working with Results

With SAS OnDemand for Academics: Enterprise Guide, you have the ability to select the
type of result format that you want to produce. By default, the result format is set to
HTML.

Working with the PDF result format

If you choose to use the PDF result format, then certain graphics will appear distorted
unless you also change the default graph format to GIF or JPEG.

Complete the following steps if you want to use the PDF result format and ensure that
graphs render appropriately:

1 Open SAS OnDemand for Academics: Enterprise Guide.

Select Tools » Options.

From the left side of the screen, select Results General from the tree.
Select PDF.

From the left side of the screen, select Graph from the tree.

From the Graph Format drop down menu, select GIF or JPEG.

o Ol A W DN
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Result formats and associated graph formats

The default graph format is ActiveX, which typically provides the best results for HTML
and SAS Report result formats. If you need to use a result format such as PDF, which
does not support interactive graphics types, you will also need to change the graph
format to a static device type such as GIF or JPEG. The following table references result
formats and the graph formats that each supports:

Result Format Supported Graph Formats

HTML ActiveX, Java, GIF, JPEG, SAS EMF
SAS Report ActiveX, GIF, JPEG

PDF GIF, JPEG, SAS EMF

RTF ActiveX, GIF, JPEG, SAS EMF

Text (Listing) None

Step 5. Finding Help for Common Problems

Please check the commonly asked questions about SAS OnDemand for Academics:
Enterprise Guide in this section and follow the procedures below for additional help.

Where can students find help

Students should be asked to follow the steps below to resolve any support issues they
encounter:

Step One: Review Commonly Asked Questions, SAS Notes, and SAS Documentation

Use the key word ‘ondemand academics' to search for issues specific to SAS OnDemand
for Academics from these sources:

O Commonly Asked Questions about SAS OnDemand for Academics in this manual

O SAS Notes, a database of common technical issues found at
http://support.sas.com/notes

O SAS Product Documentation on http:/support.sas.com/documentation

Step Two: Contact Your Instructor

If you are a student and you have questions about using SAS OnDemand for Academics,
contact your instructor. Instructors can point students toward educational resources and
help ensure that offerings are used correctly.

If further assistance is needed, then your instructor can contact SAS Technical Support.

Commonly Asked Questions: SAS OnDemand for Academics: Enterprise
Guide

O Does SAS OnDemand for Academics: Enterprise Guide have all the same features
as SAS Enterprise Guide?

Certain features of SAS OnDemand for Academics: Enterprise Guide have been
disabled because they are not practical in this setting. For example, the ability to
schedule projects is not available. Note that the online help system documents all
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SAS Enterprise Guide features, including those that might be unavailable in this
offering.

O Can I download SAS OnDemand for Academics clients on to more than one
machine?

Yes. For example, you might download a client on to a personal computer at home
as well as a laptop if you use both machines to complete assignments.

O I'm using the keyboard to install SAS OnDemand for Academics: Enterprise
Guide. How do I change focus on the initial installation window?

QO When the initial installation window appears, the focus is on Step 1: Verify
System Requirements. To select this option, press ENTER.

Q After Step 1 has completed, you must press TAB to move focus to Step 2
(Install SAS Enterprise Guide).

Q After you have moved the focus to Step 2, press ENTER to begin the SAS
Enterprise Guide installation process.

0 Ihave installed SAS OnDemand for Academics: Enterprise Guide, but I am not
getting prompted to log on to it when I start the application. What should I do?

Please make sure that you ran the System Requirements Wizard during
installation. When you start the process of installing SAS OnDemand for
Academics: Enterprise Guide, an initial installation window provides you with two
choices:

1 Verify System Requirements
2 Install SAS Enterprise Guide

If you did not perform Step One (Verify System Requirements), then Microsoft
.NET 1.1 will not be installed and will likely cause the error that you are
experiencing.

To correct the situation, simply start the setup.exe file that you downloaded from
the SAS Download Manager. When the installation window appears, choose Step
One. After the System Requirements Wizard runs and installs Microsoft NET 1.1
on your machine, then you should be able to use SAS OnDemand for Academics:
Enterprise Guide.

Note: If Microsoft .NET 1.1 hangs during the installation process, then please
follow the instructions in SAS Note 16884 at http:/support.sas.com/notes/.

For more information and possible answers to your issue, please review the
following SAS Usage Notes:

Q SAS Note 34715
a SAS Note 20939
Q SAS Note 20437

O Iam getting an error when attempting to run SAS OnDemand for Academics:
Enterprise Guide after installing it on Microsoft Windows Vista. What should I
do?

Please make sure that you ran the System Requirements Wizard during
installation. When you start the process of installing SAS OnDemand for



SAS OnDemand for Academics: Enterprise Guide  Step 5. Finding Help for Common Problems 17

Academics: Enterprise Guide, an initial installation window provides you with two
choices:

O Verify System Requirements.
O Install SAS Enterprise Guide

If you did not perform Step One (Verify System Requirements), then Microsoft
.NET 1.1 Vista might include a newer version of the Microsoft NET Framework
that is incompatible with SAS OnDemand for Academics: Enterprise Guide.

To correct the situation, simply start the setup.exe file that you downloaded from
the SAS Download Manager. When the installation window appears, choose Step
One. After the System Requirements Wizard runs and installs Microsoft .NET 1.1
on your machine, then you should be able to use SAS OnDemand for Academics:
Enterprise Guide.

Note: If Microsoft .NET 1.1 hangs during the installation process, then please
follow the instructions in SAS Usage Note 16884.

0 Ihave installed SAS OnDemand for Academics: Enterprise Guide, but I receive
the following error when I try to run the application: "The SAS workspace
manager is not installed or registered on this machine...." What should I do?
This issue is most prevalent with users who are running the Microsoft Windows
Vista operating system. If you encounter this message, then download SAS
Integration Technologies Client for Windows.

After you download the client, right click on the file and choose Run as
Administrator (if possible). Otherwise, simply double-click on the file to install the
client.

If the above task does not fix the issue, please verify that you have properly
installed the Microsoft .NET 1.1 Framework. Click here for more information.

0 How do Ilog on to SAS OnDemand for Academics: Enterprise Guide?

When you open SAS OnDemand for Academics: Enterprise Guide, The Credentials
Required window appears:

Credentials Required x|

SAS Metadata Repository
sascloud.sas.com

@ .=mith )

Paszward: I xxxxxxxx

(]9 I Cancel |

You must use this window to log on to the SAS Server (the SAS Metadata
Repository) so that you can perform SAS processing.
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~ Getting Started

A Your SAS Server userid it sas.instructor

Use this userid when you log on w e SAS Server.

= Reqister a course:
Registering a course will make it available to your students.

To edit course information or review helpful details about courses, click on the course fitle. To obtain the software for a course
select the link in the Download column.

To log on, enter the following information:

1 In the User field, enter your SAS Server user ID. This user ID is also
displayed on your SAS OnDemand for Academics Home Page:

2 In the Password field, enter your SAS Profile password. There are two times
when you might have supplied a SAS Profile password: either when you
originally created a SAS Profile or when you registered for SAS OnDemand for
Academics.

O How do I find out more information about using SAS OnDemand for Academics:
Enterprise Guide?

After you have downloaded and installed the client software application that you
plan to use, you can refer to the options on its Help menu. You can also refer to
the “Learning Resources for SAS OnDemand for Academics” appendix in this
manual.

0 Can I access the Program Editor, Log, and Output windows using SAS OnDemand
for Academics: Enterprise Guide?

Yes. You can access and use traditional SAS Programming windows. For example,
select File » New » Program or File » Open » Program to access the Program
Editor. After you run a SAS program, the Log and Output windows will display (if
appropriate).

O Will SAS OnDemand for Academics: Enterprise Guide work if I already have SAS
Enterprise Guide installed on my computer?

Yes. Both versions can be installed on the same computer and will work
independently.

0 How do I work with data in SAS OnDemand for Academics: Enterprise Guide?

SAS OnDemand for Academics: Enterprise Guide works in conjunction with the
SAS Server. The easiest way to work with data is to ensure that the SAS Server
has access to that data. You can do this by using existing sample data sets on the
SAS Server, uploading data files to the SAS Server, or accessing data that an
instructor has chosen to store on the SAS Server.

O How do I share data with other users who are using SAS OnDemand for
Academics: Enterprise Guide?

If you have data that you want to share with other users, you must place it in a
location that others can access, such as a shared network drive. Users can then
access the data in one of two ways:

O Users can select File » Open, and then choose Project, Data, or Program. A
user can then select the Local Computer source and navigate to the drive and
directory path that contains the data that you want them to use.

O Users can select Tasks » Data » Upload Data Files to Server. The user will
be given the option of navigating to the appropriate drive and directory to find
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the SAS data set that you want them to use. This data will then be uploaded to
the SAS Server and made available for processing.

Note: This is the preferred method for sharing SAS data sets because it is
faster than opening a SAS data set.

Only instructors have the ability to store data on the SAS Server. Once the data is
stored, instructors can share a LIBNAME or FILENAME statement with users so
that they can access the data.

O How do I upload local Data Files from my PC to the SAS Server?

You can use SAS OnDemand for Academics: Enterprise Guide to upload local SAS
data sets to the SAS Server for processing. From SAS Enterprise Guide, select
Tasks P Data » Upload Data Files to Server. Then follow the steps in the
wizard that appears. Refer to “Uploading files to the SAS Server” for SAS
OnDemand for Academics: Enterprise Guide.

O How do I download Data Files from the SAS Server to my PC?

You can use SAS OnDemand for Academics: Enterprise Guide to download SAS
data sets from the SAS Server to your PC. From SAS Enterprise Guide, select
Tasks » Data » Download Data Files to PC. Then follow the steps in the
wizard that appears. Refer to “Downloading files to the SAS Server” for SAS
OnDemand for Academics: Enterprise Guide.

QO Can I use data other than SAS data sets?

Yes. If you want to work with data other than SAS data sets (such as comma
delimited files or text files), you can import the files into SAS OnDemand for
Academics: Enterprise Guide. To import other data, follow these steps:

1 Select File » Import Data.
2 Select Local Computer.
3 Find and select the data file that you want to use.

Additionally, if your instructor has stored data files other than SAS data sets on
the SAS Server, then he or she will provide you with a FILENAME statement that
you can use to access the data.

O Iam trying to use an INFILE statement to access data, but it is causing errors.
How should I use an INFILE statement?

You must use a fully qualified path when using an INFILE statement within SAS
OnDemand for Academics: Enterprise Guide. Additionally, INFILE statements are
case-sensitive. Please ensure that you are entering the INFILE statement
appropriately. Refer to “Working with INFILE statements” for SAS OnDemand for
Academics: Enterprise Guide.

Q I uploaded a file and am referring to the file using an INFILE statement, but not
all of the fields are being read correctly. What is happening?

This could be the result of uploading a text file or a comma separated value file
from a PC that uses the Microsoft Windows operating system. Adding the
TERMSTR option to your INFILE statement might correct the issue.

0 Ihave copied code in to the code (Program) window, but I am getting errors when I
try to run the code. What is happening?

This could be the result of hidden or special characters in the code that you copied
in to the Code window. One way to resolve this issue is to simply type in the code
instead of copying the code. If the amount of code is too much to type, then you
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could try saving the code as a text file to remove any special characters or
formatting and then copying the code in to the Code window. For more
information and options, search for SAS Note 16658 on
http://support.sas.com/notes.

0 How do I save my projects or files from within SAS OnDemand for Academics:
Enterprise Guide?

You must save all your work to your local computer because any work you have
completed (and any data that you have uploaded to the SAS Server, if applicable)
will be lost when you end your SAS OnDemand for Academics session.

When you choose to save your work or if you are prompted to save your work,
select Local Computer instead of SAS Servers, and then proceed to save your
work to the appropriate local directory.

O Ireceived an error message when trying to save work using SAS OnDemand for
Academics: Enterprise Guide. What's wrong?

You may receive an error message such as this:

“An error occurred saving the file. Location must be configured as a WebDAV
URL”

In this case, it's likely that you were trying to save your work to the SAS Servers
instead of to your local computer. To avoid this error when you save your work,
select Local Computer instead of SAS Servers. You can then select the local
directory to which you want to save your work.

O I'm using Output Delivery System (ODS) statements in SAS OnDemand for
Academics: Enterprise Guide in order to write results files (PDF, RTF). How do I
save these files locally?

With SAS OnDemand for Academics: Enterprise Guide, you are unable to write
ODS statements that direct files to your local directories. All SAS statements will
run on the SAS Server only. However, you can enable different output results
formats:

1 Select Tools » Options.
2 From the tree on the left side of the window, select Results.
3 Select the results format(s) that you want to produce, such as PDF or RTF.

Your SAS code will now produce the output results that you selected and
download them from the SAS Server. To save these results permanently, right
click on each results file and then select Export.

Note: Due to graph device restrictions on the SAS Server, if your PDF output
contains any charts, then you will need to specify GIF or JPG as the graph device
format.

0 Can I convert the HTML or SAS Report output that I produce with SAS
OnDemand for Academics: Enterprise Guide into PDF files?

There is no way to accomplish this from within SAS OnDemand for Academics:
Enterprise Guide. However, you could export the output files and then use a
freeware PDF printer driver to accomplish this goal. To export your output, right
click on the appropriate file and then select Export.
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0 How do I view or print multiple output files at the same time using SAS
OnDemand for Academics: Enterprise Guide?

There are two ways to combine results to make one “viewable/printable”
document:

Q Select Tools » Create HTML Document. This option lets you take the
HTML output files you've created in your project and combine them into a
single HTML document, which you can save and print.

O Select File » New » Report. This option works only when you use SAS Report
instead of HTML as your output format. SAS Report output looks like HTML
on the screen, but prints like a PDF (page-oriented). The report builder
interface enables you to combine output from various tasks, arrange the
output the way you like, add headers and footers and images, and control
aspects of page layout and margins.
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Step 1. Confirm system requirements

Check these guidelines to ensure you can access the software.

Confirm requirements for full support

Your system must meet these requirements for SAS OnDemand for Academics:
Enterprise Miner to be fully supported.

Supported

Not Supported

Operating
systems

Java Runtime
Environment

Hard disk space
Internet browser
Internet
connection

Network
bandwidth

Any system that supports the Sun
Microsystems (Oracle) Java Runtime
Environment (JRE). Typically, this
includes Unix, Linux, and various
Microsoft Windows operating systems,
such as Microsoft Windows XP and
Microsoft Windows Vista.

Java Runtime Environment (JRE) Version
1.6.0_18.

Note: You will be prompted to check for
this JRE and install it when you access
SAS Enterprise Miner.

At least 50 MB of free hard disk space
Any browser that supports JRE 1.6.0 18
High speed, including broadband (cable),
DSL (phone), and wireless connections.

Note: Individual usage experience
depends on speed and reliability of
connection.

For best performance, at least 1000
Kbit/sec is recommended.

Macintosh operating systems

Note: Virtualized
environments might not work.
It is recommended that
supported operating systems
run on a physical CPU.

JRE 1.6.0_20 is not
compatible.

Note: Other JREs from the
1.6 series might series might
work.

Verify and install a Java Runtime Environment (JRE)

After you have registered for a course that uses SAS OnDemand for Academics:
Enterprise Miner, you must verify that you have an appropriate Java Runtime
Environment (JRE) installed or install an appropriate JRE. This process needs to be
completed only once.

Note: Consider printing these instructions before you begin as some of the steps
might require you to move to other Web sites.
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Step One: Verify whether a JRE (and Java Web Start) is installed
To verify whether you have a JRE installed, try the following:

Open a Command Prompt window. Select Start » Run.
Type CMD in the Run window.

On the Command Prompt window, type start javaws.

B W N =

If the above command opens a Java Web Start window similar to the following,
then you have a JRE (and Java Web Start) installed.

Java(TM) Web Start 1.6.0_06 ﬂ

L3
\!:) Usage:  javaws [run-opkions] <jnlp-file=
javaws [control-opkions]

where run-options include:

-verbose display additional output

-offline run the application in offline mode

-syskem run the application fram the system cache only
-#nosplash run without showing a splash screen
-J<option= supply option to the vm

-waik start java process and waik For its exit

control-opkions include:

-yigwer show the cache viewer in the java contral panel
-uninstall remove all applications from the cache
-uninstall <jnlp-file:> remove the application from the cache

-import [import-options] <jnlp-file>  import the application to the cache

import-options include:

-silent impoart silently (with no user interface)
-syskem import application inko the system cache
-codebase =url=  retrieve resources From the given codebase
-shortout install shorteuts as if user allowed prompt
-associakion install associations as if user allmwed prompk

If you have a JRE installed, then continue to Step Two.

If the above command did not work, then you likely do not have a JRE
installed. Continue to Step Three.

Step Two: Ensure that you are using only the recommended Java Runtime Environment

We recommend that you use Java Runtime Environment (JRE) 1.6.0_18 to run SAS
OnDemand for Academics: Enterprise Miner. Only JREs with U.S. Export Control
Classification Numbers of 5D992 are approved for use with SAS products.

Note: Other JREs from the 1.6 series might also work (excluding JRE 1.6.0_20,
which is incompatible).

1 From a Command Prompt window, start Java Web Start. Type start javaws -
viewer and then press ENTER.

2 Ifthe Java Cache Viewer window appears, close it so that you can see the Java
Control Panel window. The Java Control Panel window often opens behind the
Java Cache Viewer window.

3 From the Java Control Panel window, select the Java tab.

From the Java Application Runtime Settings area (the bottom half of the
window), click View (the second “View” button on the window).
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5 In the Enabled column, check only one JRE (uncheck any other JREs that are
checked). We recommend that you check JRE 1.6.0_18.

If JRE 1.6.0_18 is unavailable, then you can test SAS OnDemand for Academics:
Enterprise Miner with your current JRE. To do so, you can start from your SAS
OnDemand for Academics Home Page.

If your current JRE does not work or if you want to install the recommended JRE,
continue to Step Three. Otherwise, configuration is complete.

Step Three: Install the recommended Java Runtime Environment and Java Web Start
Installing the recommended JRE will also install Java Web Start on your system.

Note: If you completed Step Two above, repeat this step to ensure that only JRE
1.6.0_18 is selected.

1 Access the appropriate list of Java SE Downloads at this location:

http://www.oracle.com/technetwork/java/javasebusiness/downloads/java
-archive-downloads-javase6-419409.html#jre-6ul8-oth-JPR

Alternatively, you can access the Java SE 6 Downloads archive page at
http://www.oracle.com/technetwork/java/archive-139210.html
then click Java SE 6. On the Java SE 6 Downloads page, select Java SE
Development Kit SE 6ul8 from the list to view a table of all downloads by
operating system.

Click the radio button above the table to Accept License Agreement.

Select jre-6ul8-windows-i586.exe under Download column.

You will be prompted to sign in to your Oracle Web account. If you do not have
an account, you will be prompted to create one.

5 After you are signed in, launch the download and select Run to begin the
installation process.

6 (Optional) If you completed Step Two above, repeat this step to ensure that
only JRE 1.6.0_18 is selected.

Step 2. Set up your SAS OnDemand for Academics account

There are several important steps you must follow to set up a SAS OnDemand for
Academics account, such as creating a SAS profile and registering for your course.
The online process uses a series of windows to guide you.

About the SAS OnDemand for Academics Control Center

Your starting point for accessing SAS OnDemand for Academics is the SAS
OnDemand for Academics Control Center Web site.You will use it to register, acquire
a license, and view course information.

http://support.sas.com/ctx3/sodareg/index.html

Your SAS OnDemand for Academics Home Page is created during the registration
process and is part of the SAS OnDemand for Academics Control Center. You will be
taken to your Student Home Page once you have set up an account. You access your
home page to view information associated with courses.
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About your SAS Profile account

A SAS Profile is an account that you can create to access specific information and
resources from the SAS Web site. If you are a current SAS user, you might already
have a SAS Profile account. If you are a new SAS user, a SAS Profile is created for
you when you register for SAS OnDemand for Academics.

An important part of your SAS Profile account is a SAS Profile password that you are
prompted to enter each time you access the SAS OnDemand for Academics Control
Center.

Note: Your SAS Profile password must be changed every 6 months for security
purposes. You will receive an e-mail when your password is approaching expiration.
To reset your SAS profile, visit My SAS Profile page at this location:
https://www.sas.com/profile/user/login.htm.

Important information hefore you begin

As you begin setting up your account, it's helpful to keep the following in mind:

O You will need access to your e-mail account. When you begin registration, you
will be prompted to enter an e-mail address. Enter the e-mail address of an
account that you can access easily while completing your registration.

O You will receive an e-mail during the initial registration process that you must
open and act upon to continue. The e-mail prompts you to click a link to verify
your e-mail address. Its primary purpose is to confirm that you are using a
valid e-mail address and that someone else is not attempting to register you
without your knowledge.

O If you do not receive the e-mail, please check your junk e-mail folder.

Register for a course

You must register to select and get access to the SAS software being used for the
course. During registration, you must select a university, an instructor, and a
course.

1 Visit the SAS OnDemand for Academics Control Center to begin:
http://support.sas.com/ctx3/sodareg/index.html

2 Enter your e-mail address in the text box to get started
3 Follow the instructions.

Visit the following location to print or view step-by-step instructions:

http://www.sas.com/govedu/edu/programs/enterprise miner student.pdf

Step 3. Access and use the software

Ideally, you should perform this step before you begin your first assignment using
SAS OnDemand for Academics software.
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Access your SAS OnDemand for Academics account

Your SAS OnDemand for Academics account enables you to view information
associated with courses. You will have access to this information after you have
initially registered for SAS OnDemand for Academics.

To access an existing SAS OnDemand for Academics account:

1

Access the SAS OnDemand for Academics Control Center at the following Web
site: http://support.sas.com/ctx3/sodareg/index.html

Enter your e-mail address and your SAS Profile password and then click
Enter.

Access SAS Enterprise Miner

After you have configured your system to support SAS OnDemand for Academics:
Enterprise Miner, you can start the application by following these steps:

1
2

5

Log on to your SAS OnDemand for Academics Home page.

From the Manage Courses area, select Get Software next to the appropriate
course. Selecting this link will open a window that includes information about
how to configure your system as well as how to start the application.

Click the link that is used to start SAS OnDemand for Academics: Enterprise
Miner (http://emcloud.oda.sas.com:16098/EnterpriseMiner/main.jnlp) .

If you are presented with a security warning such as the following, select Run.

|
The application's digital signature has an error. Do you / ' \
want to run the application? Lom

Hame: SAS Enterprize Miner 55
Publisher: SAS Institute Inc

From: http: ffemcloud oda sas com 16098

™ Blways trust content from this puklisher

Run Cancel

I"rl The digital signature was generated with a trusted oerlificate but
) has expited

Mare Information...

In the User Name field, enter your SAS Server user ID. This user ID is also
displayed on your SAS OnDemand for Academics home page:

* Getting Started

A Your SAS Server userid it sas.instructor

Use this userid when you log on w e SAS Server.

= Register a course:
Registering a course will make it available to your students.

To edit course information or review helpful details about courses, click on the course title. To obtain the software for a course
select the link in the Download column.

Note: Your SAS Server user ID is case sensitive and should be entered in all
lowercase. If you enter your SAS Server user ID using uppercase or mixed case
letters, you might be able to log on, but certain tasks might not perform

properly.
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6 In the Password field, enter your SAS Profile password. There are two times
when you might have supplied a SAS Profile password: either when you
originally created a SAS Profile or when you registered for SAS OnDemand for
Academics.

7 Click Log On.

To start SAS OnDemand for Academics: Enterprise Miner in the future, you
can perform the previous steps or simply save the following URL as a
bookmark and use it:
http://emcloud.oda.sas.com:16098/EnterpriseMiner/main.jnlp.

Access the SAS Server

You are prompted to connect to the SAS Server each time you start SAS OnDemand
for Academics: Enterprise Miner. The server (which is hosted at SAS Institute Inc.)
remotely processes any submitted SAS files or projects and returns results to your
computer.

Make sure that you have a working Internet connection if you are unable to use a
SAS OnDemand for Academics software application to perform processing. If your
internet connection is working normally and you are still unable to perform
processing, it is likely that the SAS Server is temporarily unavailable. Please try to
use the server again later. You can also log on to the SAS OnDemand for Academics
Control Center. The SAS OnDemand for Academics Control Center typically provides
a message if the SAS Server is unavailable or expected to be unavailable in the near
future.

SAS Server maintenance and availahility

SAS makes its best efforts to make the server available as much as possible and to
keep unexpected downtime to a minimum. There could be limited times when the
server is unavailable because SAS is performing maintenance, testing, or
performance enhancement tasks.

O Ifserver maintenance is needed, SAS will try to perform this work during
nontraditional usage hours to lessen any impact to users.

O SAS uses the third Saturday of each month to perform scheduled maintenance
on its systems (if needed). Therefore, the server might be unavailable for a
portion of time on the third Saturday of each month.

To determine if SAS servers are available, visit the SAS Server status Web page:
(https://www.ondemand.sas.com/status/oda/).

Requesting SAS Server availahility notification

If you would like to be notified when the SAS Server is unavailable due to extended
maintenance or due to unforeseen circumstances, please subscribe to the
SASONDEMANDSERVER-L mailing list:

1 Send e-mail to LISTSERVRLISTSERV.SAS.COM.
2 In the body of the e-mail, type subscribe SASONDEMANDSERVER-L

3 Send the e-mail (no subject line is needed). Follow any instructions you receive
via e-mail.
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To unsubscribe from SASONDEMANDSERVER-L, perform the following steps:
1 Send e-mail to LISTSERVRLISTSERV.SAS.COM.
2 In the body of the e-mail, type unsubscribe SASONDEMANDSERVER-L

3 Send the e-mail (no subject line is needed)

Step 4. Review the hasics for working with data, results, and

projects

Before attempting course exercises, we recommend that you review the basics of
working with SAS data sets, models, and results in SAS OnDemand for Academics:
Enterprise Miner.

Working with data

To ensure that you do not lose your work, you should cover the basics of accessing
and using data from the SAS Server. SAS OnDemand for Academics: Enterprise

Miner uses the SEMMA project model to organize work and options for accessing

data are specific to this product.

Before you access the appropriate data sets for your exercises, you must assign a SAS
library to your projects using one of the following methods using a project using Start
Code or submitting a LIBNAME statement.

Assigning a SAS Library to a project using Start Code

SAS OnDemand for Academics: Enterprise Miner enables you to include Start Code
for your projects. After you have specified this code, it will be run any time that the
project is started and can save you time and effort. For example, you might want to
assign a LIBNAME statement through Start Code so that a project can always access
specific SAS data sets.

Using Start Code with a new project:
1 Start SAS OnDemand for Academics: Enterprise Miner.

2 Select New Project. From the New Project wizard, select a name for your
project, select the default values on the remaining wizard screens, and then
select Finish.

3 From the Property tree on the left, locate the Project Start Code property.
4 Click the ellipsis ... button.
5 Enter the appropriate Start Code and then click either Run Now or OK.

Note: If you want to use project Start Code to access SAS data sets that use a
format file, then you must also specify the FMTSEARCH option in your start code.

Using Start Code with an existing project:
1 Start SAS OnDemand for Academics: Enterprise Miner.
2 Open the appropriate project.
3 From the Property tree on the left, locate the Property Code property.
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4 Click the ellipsis ... button.
5 Enter the appropriate Start Code and then click either Run Now or OK.

Note: If you want to use project Start Code to access SAS data sets that use a
format file, then you must also specify the FMTSEARCH option in your start-up
code.

Assigning a SAS Library using LIBNAME statements

You can access the Program Editor by selecting View » Program Editor from
within SAS OnDemand for Academics: Enterprise Miner.

Instructors have the ability to store SAS data sets on the SAS Server. If your
instructor has taken advantage of this feature, then you must use the appropriate
LIBNAME statement for your course to access that data.

Note: LIBNAME statements are case-sensitive. Please copy them or type them in
exactly as they appear to avoid permissions errors.

Accessing data using SAS OnDemand for Academics: Enterprise Miner

The SAS Server includes various SAS libraries (and their corresponding SAS data
sets). As an instructor, you might want to use one or more of the SAS data sets from
SASHELP, MAPS or other SAS-provided libraries to ensure that all your students
have access to the data. To access sample data sets on the SAS Server:

1 Start SAS OnDemand for Academics: Enterprise Miner.
2 Create a new project or open an existing project.

3 In the tree on the left, right-click on Data Source and then select Create
Data Source.

4 The Source drop down box defaults to SAS Table. Click Next to accept the
default value and move to the next step in the wizard.

Next to the Table field (which will be blank), click Browse.
Use the Library drop down to select the appropriate library.

Select the SAS data set that you want to use and then continue with the
wizard.

Accessing SAS Enterprise Miner course data on the SAS Server

Additionally, SAS OnDemand for Academics stores SAS data sets associated with the
teaching materials from SAS Enterprise Miner courses on the SAS Server. To view
these:

1 Start SAS OnDemand for Academics: Enterprise Miner.
2 Create a new project or open an existing project.

3 In the tree on the left, right-click on Data Source and then select Create
Data Source.

4 From the Source drop down, select Metadata Repository and then click
Next.

Next to the Table field, click Browse.
Use the Library drop down to select the appropriate library.
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7 Select the SAS data set that you want to use and then continue with the wizard
or data files to the SAS Server for use in specific courses.

Accessing grayed-out SAS libraries from the SAS Server

The SAS Server includes sample SAS data sets that you might choose to use. Some of
the sample SAS Libraries might appear to be grayed out, but they are still available
for use.

Typically, grayed out SAS Libraries appear for users in Europe and were originally
intended for use with SAS Enterprise Miner.

1 Start SAS OnDemand for Academics: Enterprise Miner and log on.
Select File » Open » Data.

Select Servers.

Double click on SAS Apps.

Double click on Libraries.

o 1 A W N

Right click on the grayed out SAS Library that you would like to access and
then click Assign.

7 Double click on the SAS data set that you want to use.

Working with projects

SAS OnDemand for Academics: Enterprise Miner uses the SEMMA model to
organize data mining projects. SAS recommends that you share the following
information with your students so they can use the interface most effectively.

Understanding Project Storage Quotas

Each SAS OnDemand for Academics: Enterprise Miner user has a large project
storage quota. An e-mail message is sent to any user who has used 75% of their
storage quota.

If the project storage quota is reached, then SAS OnDemand for Academics:
Enterprise Miner will stop functioning properly. To avoid this, consider deleting any
unnecessary projects prior to reaching your quota to ensure that SAS OnDemand for
Academics: Enterprise Miner continues to work properly.

If you do reach your quota and then delete unnecessary projects to create more
project storage space, then the last project that you were working with could be
impacted. If the project runs incorrectly after removing unnecessary projects, then
you might need to rebuild the diagrams for this project.

Creating New Projects

When you create a new project, you will use the Create New Project wizard. Step
Three of this wizard enables you to select a SAS folder in which to store your project.
Even though you have the ability to browse in this step, please accept the default
project storage location:

/Users/your-user-id/My Folder

Accepting the default project storage location will ensure that your projects can be
accessed appropriately by SAS OnDemand for Academics servers.
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If you select Browse and attempt to store your project in a location other than the
default, the following error will result:

Eror x|

Exception occurred updating the 545 Metadata
Repositary,

To correct this error, change the location where your project will be stored back to the
default location: /Users/your-user-id/My Folder

Opening Existing Projects

To find and open an existing project, perform the following steps:
Start SAS OnDemand for Academics: Enterprise Miner.
Click Open Project.

From the Open Project window, open the My Folder folder.

Select the project that you want to open.
Click OK.

gl A W N =

Creating model packages

With SAS OnDemand for Academics: Enterprise Miner, users can create model
packages (also known as SAS Package Files or .spk files). Model packages can be
created from any node in a diagram. Typically, you create a model package when you
are satisfied with your model and you want to preserve it or share it with someone
else.

In most cases, you create the model package from the last node of a process in a
diagram. This ensures that the model package will include the entire process flow.

Differences hetween project model packages and exported project
diagrams

With SAS OnDemand for Academics: Enterprise Miner, a user can create a model
package and send it as a SAS Package File (.spk), or export a diagram as an XML file
(.xml). If a specific project takes a long time to run, having the model package (with
the associated results) can be advantageous.

Exported diagrams contain no results. After a project's diagram has been exported as
an XML file, it can be shared as an attachment in an e-mail message or by placing
the file on a shared network directory. To use the shared file, it must be imported in
to SAS OnDemand for Academics: Enterprise Miner and then the appropriate path of
the diagram would have to be run to produce results.

Note that neither model packages nor exported diagrams include the actual data that
is referenced. To rerun the project, you must have access to the original data or use
the LIBNAME statement that points to the original data if that data is stored on the
SAS Server.
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Sharing homework assignments

There are three ways that you can share homework assignments: either by creating
and registering a project model package, by sharing a project model package, or by
sharing a project diagram. As an instructor, you will want to review these methods,
decide which method aligns with course objectives, and be able to answer any
questions your students may have about the process.

Submitting homework assignments

With SAS OnDemand for Academics: Enterprise Miner, students can create and
submit an entire project model package, or export a project diagram and share the
exported file.

Ultimately, the choice is up to the instructor. The decision might be made based on
whether or not the instructor needs access to project results or diagram files.

To submit a project model package to an instructor:

1 Create a project or open an existing project within SAS OnDemand for
Academics: Enterprise Miner.

Highlight the appropriate node within a diagram.
Select Actions » Create Model Package.

In the Input dialog box, enter a name for the model package. To ensure that
you choose a unique file name, you might want to include your name or initials
as part of the file name. This will ensure that an instructor can distinguish one
submitted model package from another.

5 From the Project Panel on the left side of SAS OnDemand for Academics:
Enterprise Miner, expand the Model Packages folder.

6 Right click on the appropriate model and then click Save As. You will be
prompted to save the model as a SAS Package File (.spk).

7 Share the appropriate .spk file with your instructor (through e-mail or through
a shared network directory).

To submit an exported project diagram to an instructor:

1 Create a project or open an existing project within SAS OnDemand for
Academics: Enterprise Miner. Ensure that your project includes a diagram.

2 From the Project Panel on the left side of SAS OnDemand for Academics:
Enterprise Miner, expand the Diagrams folder.

3 Right click on the appropriate diagram and then select Save As. Save the
diagram as a .XML file. To ensure that you choose a unique file name, you
might want to include your name or initials as part of the file name. This will
ensure that an instructor can distinguish one submitted diagram from another.

4 Share the . XML file with your instructor (through e-mail or through a shared
network directory).

Collahorating

Students can collaborate with each other while using SAS OnDemand for Academics:
Enterprise Miner in one of two ways:
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O by saving an entire project as a model package and then sharing the model
package

O by exporting project diagrams as XML files and then sharing those files with
each other.

The choice might be determined by whether or not the students need to share the
results of a project. Exported diagrams do not contain results while model packages
do.

Note: Neither model packages nor exported diagrams include the actual data that
is referenced. To rerun the project, you must have access to the original data or have
the LIBNAME that points to the original data if that data is stored on the SAS
Server.

To share a project model package:

1 Create a project or open an existing project within SAS OnDemand for
Academics: Enterprise Miner.

Highlight the appropriate node within a diagram.
Select Actions » Create Model Package.

In the Input dialog box, enter a name for the model package. To ensure that
you choose a unique file name, you might want to include your name or initials
as part of the file name. This will ensure that your peers can distinguish one
model package from another.

5 From the Project Panel on the left side of SAS OnDemand for Academics:
Enterprise Miner, expand the Model Packages folder.

6 Right click on the appropriate model package and then select Save As. Save
the model package as an .spk file.

7 Share the .spk file as needed (through e-mail or through a shared network
directory).

Note: The user who receives the model package can start SAS OnDemand for
Academics: Enterprise Miner and choose File » Open Model Package to open the
package and view the diagram and results. The user will be unable to make any
changes or rerun the diagram nodes. However, the user can choose Action »
Recreate Diagram to recreate the diagram within the current project. Once the
diagram is recreated, the user will have a working copy of the diagram, just as if they
imported the appropriate diagram.xml. The user must run a diagram path to produce
any results.

To share a project diagram:

1 Create a project or open an existing project within SAS OnDemand for
Academics: Enterprise Miner. Ensure that your project includes a diagram.

2 From the Project Panel on the left side of SAS OnDemand for Academics:
Enterprise Miner, expand the Diagrams folder.

3 Right click on the appropriate diagram and then select Save As. Save the
diagram as a .XML file. To ensure that you choose a unique file name, you
might want to include your name or initials as part of the file name. This will
ensure that your peers can distinguish one diagram from another.

4 Share the . XML file as needed (through e-mail or through a shared network
directory).
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To use a shared project diagram:

1
2
3
4

Start SAS OnDemand for Academics: Enterprise Miner.
Create a new project or open an existing project.

Select File » Import Diagram from XML.

Import the appropriate diagram XML file.

Step 5. Finding Help for Common Problems

Please check the commonly asked questions about SAS OnDemand for Academics:
Enterprise Miner in this section and follow the procedures below for additional help.

Where can students find help

Students should be asked to follow the steps below to resolve any support issues they
encounter:

Step One: Review Commonly Asked Questions, SAS Notes, and SAS Documentation

Use the key word ‘ondemand academics’ to search for issues specific to SAS
OnDemand for Academics from these sources:

Q

a

a

Commonly Asked Questions about SAS OnDemand for Academics in this
manual

SAS Notes, a database of common technical issues found on
http://support.sas.com/notes

SAS Product Documentation on http:/support.sas.com/documentation

Step Two: Contact Your Instructor

If you are a student and you have questions about using SAS OnDemand for
Academics, contact your instructor. Instructors can point students toward
educational resources and help ensure that offerings are used correctly.

If further assistance is needed, then your instructor can contact SAS Technical
Support.

Commonly Asked Questions: SASOnDemand for Academics:
Enterprise Miner

Q

Does SAS OnDemand for Academics: Enterprise Miner have all the same
features as SAS Enterprise Miner?

The version of SAS Enterprise Miner available through SAS OnDemand for
Academics does have a few differences.

O You must accept the default project storage location when creating new
projects.

O Your projects are stored within the My Folder folder.

O Certain nodes are unavailable, might not function properly, or are
experimental. For example, the File Import node is unavailable.
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0 Can I use SAS OnDemand for Academics: Enterprise Miner if I already have
SAS Enterprise Miner on my PC?

Yes. SAS OnDemand for Academics: Enterprise Miner is mutually exclusive
from any other version of SAS Enterprise Miner and should not cause any
conflicts or reset any file type associations.

Please note that the projects that you create with each version of SAS
Enterprise Miner are also mutually exclusive. If necessary, you can save a
project diagram xml file created in one version of SAS Enterprise Miner and
import it in to another version. However, for this to work, you must have access
to the necessary data on the appropriate PC as well.

0 How do I configure my PC to use SAS OnDemand for Academics: Enterprise
Miner?

In order to use SAS OnDemand for Academics: Enterprise Miner, you must first
ensure that your PC is properly configured. It is especially important that the
appropriate version of the Java Runtime Environment is installed on your
machine. Refer to “Verify and install Java Runtime Environment (JRE)” for
SAS OnDemand for Academics: Enterprise Miner.

O How do I start SAS OnDemand for Academics: Enterprise Miner?

After you have configured your system to support SAS OnDemand for
Academics: Enterprise Miner, you can start the application by following these
steps:

1 Log on to your SAS OnDemand for Academics Home page.

2 From the Manage Courses area, select Get Software next to the
appropriate course. Selecting this link will open a window that includes
information about how to configure your system as well as how to start the
application.

3 Click the link that is used to start SAS OnDemand for Academics:
Enterprise Miner
(http://emcloud.oda.sas.com:16098/EnterpriseMiner/main.jnlp).

4 Ifyou are presented with a security warning such as the following, select
Run.

Warning - Security ll

The application's digital signature has an error. Do you
want to run the application?

& —

Hame: SAS Enterprize Miner 5.3
Publisher: SAS Institute Inc.

From: hittp: flemcloud .oda 255 com: 16095

Run Cancel

W ' I The digital signature was generated with a trusted cenificate but
has expirad.

Mare Information...
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5 In the User Name field, enter your SAS Server user ID. This user ID is
also displayed on your SAS OnDemand for Academics home page:

~ Getting Started

A Your SAS Server userid it sas.instructor

Use this userid when you log on w wmie SAS Server.

» Register a course;
Registering a course will make it available to your students.

To edit course information or review helpful details about courses, click on the course title. To obtain the software for a course
select the link in the Download column.

Note: Your SAS Server user ID is case sensitive and should be entered in
all lowercase. If you enter your SAS Server user ID using uppercase or
mixed case letters, you might be able to log on, but certain tasks might not
perform properly.

6 In the Password field, enter your SAS Profile password. There are two times
when you might have supplied a SAS Profile password: either when you
originally created a SAS Profile or when you registered for SAS OnDemand for
Academics.

7 Click Log On.

To start SAS OnDemand for Academics: Enterprise Miner in the future, you can
perform the previous steps or simply use the following URL:
http://emcloud.oda.sas.com:16098/EnterpriseMiner/main.jnlp.

Q Ireceive the following error when trying to log on to SAS OnDemand for
Academics: Enterprise Miner: “An RMI registry could not be found... “. What
should I do?

This error message typically indicates that you did not complete some or all of
the configuration steps necessary. You should review or complete the
configuration steps and then try to log on again. You only have to complete the
configuration steps once in order to use SAS OnDemand for Academics:
Enterprise Miner.

O Ireceive the following error when trying to log on to SAS OnDemand for
Academics: Enterprise Miner: "Could not log on. Contact your administrator for
the correct username and password." What should I do?

If Microsoft Windows Vista prompted you to block javaw.exe when
attempting to start SAS OnDemand for Academics: Enterprise Miner and you
chose to block the file, then this error message occurs.

To correct this situation, you must open Windows Firewall and unblock the
javaw.exe file. For example, on Microsoft Windows Vista Home Premium
Edition, the following steps might work:

Q Select Start » Control Panel » Windows Firewall.
O Click the Change Settings link.

O Select the Exceptions tab.

QO Find javaw.exe and make sure it is unchecked.

For more information, refer to Microsoft Windows Vista help or contact your
system administrator.
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O Ireceive the following error when trying to log on to SAS OnDemand for
Academics: Enterprise Miner: “Network Error. The connection to the Analytics
Platform has been lost. This client session must be terminated.” What should I
do?

This error message typically occurs if you have left SAS OnDemand for
Academics: Enterprise Miner open, but have left it idle for a period of time.
Close SAS OnDemand for Academics: Enterprise Miner and restart it to try and
resolve the issue.

O Ireceive the following error in my SAS log when trying to use a SAS catalog
file that I have uploaded to the SAS Server: "ERROR: File LIBRARY
NAME.CATALOG NAME.CATALOG was created for a different operating
system." What is wrong?

This error message typically occurs if you have tried to use a SAS catalog file
that was created using an operating system other than Unix. To resolve the
issue, refer to “Storing SAS catalog Files on the SAS Server” for SAS
OnDemand for Academics: Enterprise Miner. This topic includes usage
information and sample code.

0 How do I save my work in SAS OnDemand for Academics: Enterprise Miner?

There is no Save button in this application. Your project is automatically saved
for you while you work. When you are done working, select File » Close this
Project to ensure that your project saves properly.

O How do I submit homework using SAS OnDemand for Academics: Enterprise
Miner?

There are three ways that you can share homework assignments: either by
creating and registering a project model package, by sharing a project model
package, or by sharing a project diagram. Your instructor will tell you the
method that he or she would like you to use.

O How do I collaborate using SAS OnDemand for Academics: Enterprise Miner?

You can collaborate by sharing an entire project model package or a project
diagram. For more information, see these topics: “Differences between Project
model packages and exported project diagrams” and “Collaborating” for SAS
OnDemand for Academics: Enterprise Miner.

O Can I use a project model package or project diagram from older versions of
SAS Enterprise Miner?

Some project model packages and project diagrams created in older versions of
SAS Enterprise Miner work fine while others do not. If you try to use a project
or diagram created with an older version of SAS Enterprise Miner and the
application becomes unresponsive, close the application and avoid using the
project model package or project diagram in the future.

O My project or diagram is unresponsive or no longer opens. What's wrong?

If you have lost a connection to the SAS Server while working on your project
or diagram or if you did not properly close SAS OnDemand for Academics:
Enterprise Miner, then a lock file might have been created. This lock file could
cause your diagram or project to appear unresponsive or it could prevent your
diagram or project from opening at all. Try the following to correct the issue:

O Ifthe lock has just happened, try waiting about five minutes. In many
cases, locked files correct themselves.
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Notes:

O Ifyou are unsure of when the lock occurred or if it has been longer than five
minutes, close the project, log out of SAS OnDemand for Academics:
Enterprise Miner, and then log back in.

Q Ifthe problem persists, please contact SAS Technical Support. Send e-mail
to support@sas.com. Specify that you are using SAS OnDemand for
Academics: Enterprise Miner.

Q SAS recommends that you close your diagrams and/or projects before
exiting SAS OnDemand for Academics: Enterprise Miner or before
disconnecting from your Internet connection.

O An open connection to the SAS Server will likely disconnect (time out) after
one hour if the connection is idle (that is, you have not performed any
processing). Many firewalls disconnect open sessions after an hour of idle
time, and this could lead to locked files. SAS recommends that you
complete your work, save it, and then exit SAS OnDemand for Academics:
Enterprise Miner before you leave the computer.

When I open SAS OnDemand for Academics: Enterprise Miner, I no longer see
my projects. What is wrong?

This behavior can occur if you log on to SAS OnDemand for Academics:
Enterprise Miner using a mixed case or upper case SAS Server user ID. Please
close SAS OnDemand for Academics: Enterprise Miner and log on again. Make
sure that you use all lowercase letters for your SAS Server user ID.

Can I create a SAS Library using SAS OnDemand for Academics: Enterprise
Miner?

No. However, you can work with available SAS Libraries or assign LIBNAME
statements.

I have been provided with a LIBNAME statement for my course. How do I
assign it?

If your instructor has provided a LIBNAME statement for your course, you can
assign it in one of two ways:

O Assign the LIBNAME statement as part of your project Start Code to
ensure that the SAS Library is available throughout your project; this
LIBNAME statement will also execute each time that you start your
project.

O Assign the LIBNAME statement within a project using the SAS
OnDemand for Academics: Enterprise Miner Program Editor window.

I am using a SAS data set that requires a format file. How do I define the path
to the format file?

You can define a path to a format file using project Start Code.
I either have or might reach my project storage quota. What do I do?

If you exceed your project storage space quota, then SAS OnDemand for
Academics: Enterprise Miner will stop processing nodes properly. To resolve
this situation, delete existing projects that you no longer need in order to free
up project storage space.
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The last project that you created or were working with when you met your
project storage space quota could be impacted (even after you delete existing
projects to create more space). If such a project appears to run incorrectly, then
you might need to rebuild the diagrams for this project.
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SAS OnDemand for Academics: Forecast Server

This manual guides students through recommended steps for registering for and
using SAS OnDemand for Academics.

Step 1. Confirm system requirements

Check these guidelines to ensure you can access the software.

Confirm requirements for full support.

Your system must meet these requirements for SAS OnDemand for Academics:
Forecast Server to be fully supported.

Supported Not Supported
Operating Any system that supports the Sun Macintosh operating systems
systems Microsystems (Oracle) Java Runtime
Environment (JRE). Typically, this Note: Virtualized
includes Unix, Linux, and various environments might not work.
Microsoft Windows operating systems, It is recommended that
such as Microsoft Windows XP and supported operating systems
Microsoft Windows Vista. run on a physical CPU.
Java Runtime Java Runtime Environment (JRE) Version JRE 1.6.0 20 is not
Environment 1.6.0_18. compatible.

Note: You will be prompted to check for  Note: Other JREs from the
this JRE and install it when you install 1.6 series might series might
SAS Forecast Server. work.

Hard disk space At least 50 MB of free hard disk space
Internet browser ~ Any browser that supports JRE 1.6.0 18

Internet

connection

High speed, including broadband (cable),
DSL (phone), and wireless connections.

Note: Individual usage experience
depends on speed and reliability of
connection.
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Supported Not Supported

Network
bandwidth

For best performance, at least 1000
Kbit/sec is recommended.

Verify and install a Java Runtime Environment (JRE)

After you have created a course (if you are an instructor) or registered for a course (if
you are a student) that uses SAS OnDemand for Academics: Enterprise Miner, you
must verify that you have an appropriate Java Runtime Environment (JRE) installed
or install an appropriate JRE. This process needs to be completed only once.

Note: Consider printing these instructions before you begin as some of the steps
might require you to move to other Web sites.

Step One: Verify whether a JRE (and Java Web Start) is installed
To verify whether you have a JRE installed, try the following:

1 Open a Command Prompt window. Select Start » Run.
2 Type CMD in the Run window.

3 On the Command Prompt window, type start javaws.

4

If the above command opens a Java Web Start window similar to the following,
then you have a JRE (and Java Web Start) installed.

Java(TM}) Web Start 1.6.0_06 1[

\E) Usage: javaws [run-options] <jnlp-file>
javaws [control-options]

where run-options include:

-verbose display additional output

-offline run the application in offline mode

-syskem run the application from the system cache only
-¥nosplash run without showing a splash screen
-J<option = supply option to the vm

-ait start java process and wait For its exit

control-options include:

-viewer show the cache viewer in the java control panel
-uninstall remove all applications from the cache
-uninstall <jnlp-file= remove the application from the cache

-impart [import-options] <jnlp-file=  import the application ko the cache

impart-options include:

-silent import silently {with no user inkerface)
-syskem import application into the system cache
-codebase <url= retrieve resources from the given codebase
-shorkeut install shortcuts as if user allowed prompt
-association install associations as if user allowed prompt

If you have a JRE installed, then continue to Step Two. If the above command did not
work, then you likely do not have a JRE installed. Continue to Step Three.

Step Two: Ensure that you are using only the recommended Java Runtime Environment

We recommend that you use Java Runtime Environment (JRE) 1.6.0_18 to run SAS
OnDemand for Academics: Forecast Server. Only JREs with U.S. Export Control
Classification Numbers of 5D992 are approved for use with SAS products.
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Note: Other JREs from the 1.6 series might also work (excluding JRE 1.6.0_20,
which is incompatible).

1 From a Command Prompt window, start Java Web Start. Type start javaws -
viewer and then press ENTER.

2 Ifthe Java Cache Viewer window appears, close it so that you can see the Java
Control Panel window. The Java Control Panel window often opens behind the
Java Cache Viewer window.

From the Java Control Panel window, select the Java tab.

From the Java Application Runtime Settings area (the bottom half of the
window), click View (the second “View” button on the window).

5 In the Enabled column, check only one JRE (uncheck any other JREs that are
checked). We recommend that you check JRE 1.6.0_18.

If JRE 1.6.0_18 is unavailable, then you can test SAS OnDemand for Academics:
Forecast Server with your current JRE. To do so, you can start from your SAS
OnDemand for Academics Home Page.

If your current JRE does not work or if you want to install the recommended JRE,
continue to Step Three. Otherwise, configuration is complete.

Step Three: Install the recommended Java Runtime Environment and Java Web Start
Installing the recommended JRE will also install Java Web Start on your system.

Note: If you completed Step Two above, repeat this step to ensure that only JRE
1.6.0_18 is selected.

1 Access the appropriate list of Java SE Downloads at this location:

http://www.oracle.com/technetwork/java/javasebusiness/downloads/java-
archive-downloads-javase6-419409.html#jre-6ul8-oth-JPR

Alternatively, you can access the Java SE 6 Downloads archive page at

http://www.oracle.com/technetwork/java/archive-139210.html then click Java
SE 6. On the Java SE 6 Downloads page, select Java SE Development Kit SE
6ul8 from the list to view a table of downloads by operating system.

Click the radio button above the table to Accept License Agreement.
Select jre-6ul8-windows-i586.exe under Download column.

You will be prompted to sign in to your Oracle Web account. If you do not have
an account, you will be prompted to create one.

7 After you are signed in, launch the download and select Run to begin the
installation process.

8 (Optional) If you completed Step Two above, repeat this step to ensure that
only JRE 1.6.0_18 is selected.

Step 2. Set up your SAS OnDemand for Academics account

There are several important steps you must follow to set up a SAS OnDemand for
Academics account, such as creating a SAS profile and registering for your course.
The online process uses a series of windows to guide you.


http://support.sas.com/ondemand/emconfig.html#two
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About the SAS OnDemand for Academics Gontrol Genter

Your starting point for accessing SAS OnDemand for Academics is the SAS
OnDemand for Academics Control Center Web site. You will use it to register,
acquire a license, and view course information.

http://support.sas.com/ctx3/sodareg/index.html

Your SAS OnDemand for Academics Home Page is created during the registration
process and is part of the SAS OnDemand for Academics Control Center. You will be
taken to your Instructor Home Page once you have set up an account. You access
your home page to view information associated with courses.

About your SAS Profile account

A SAS Profile is an account that you can create to access specific information and
resources from the SAS Web site. If you are a current SAS user, you might already
have a SAS Profile. If you are a new SAS user, a SAS Profile is created for you when
you register for SAS OnDemand for Academics.

An important part of your SAS Profile account is a SAS Profile password that you are
prompted to enter each time you access the SAS OnDemand for Academics Control
Center.

Note: Your SAS Profile password must be changed every 6 months for security
purposes. You will receive an e-mail when your password is approaching expiration.
To reset your SAS profile, visit My SAS Profile page at this location:
https://www.sas.com/profile/user/login.htm.

Important information hefore you begin

As you begin setting up your account, it's helpful to keep the following in mind:

O You will need access to your e-mail account. When you begin registration, you
will be prompted to enter an e-mail address. Enter the e-mail address of an
account that you can access easily while completing your registration.

O You will receive an e-mail during the initial registration process that you must
open and act upon to continue. The e-mail prompts you to click a link to verify
your e-mail address. Its primary purpose is to confirm that you are using a
valid e-mail address and that someone else is not attempting to register you
without your knowledge.

O If you do not receive the e-mail, please check your junk e-mail folder.

About SAS Forecast Server environments

SAS Forecast Server requires that an environment be established and that projects
exist within an environment. With SAS OnDemand for Academics: Forecast Server,
each course is set up to be its own environment by default. Any user within that
course is automatically a part of that environment and can create and work with
projects within that environment.

SAS Forecast Server is also a collaborative tool. This means that all users within a
specific course can view and work with the projects in that course's environment.
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Register for a course

You must register to select and get access to the SAS software being used for the
course. During registration, you must select a university, an instructor, and a
course.

1 Visit the SAS OnDemand for Academics Control Center to begin:
http:/support.sas.com/ctx3/sodareg/index.html

2 Enter your e-mail address in the text box to get started
3 Follow the instructions.

Visit the following location to print or view step-by-step instructions:

http://www.sas.com/govedu/edu/programs/forecastserver student.pdf

Step 3. Access and use the software

Ideally, you should perform this step before you begin your first assignment using
SAS OnDemand for Academics software.

Access your SAS OnDemand for Academics account

Your SAS OnDemand for Academics account enables you to view and/or edit
information associated with courses. You will have access to this information after
you have initially registered for SAS OnDemand for Academics.

To access an existing SAS OnDemand for Academics account:

1 Access the SASOnDemand for Academics Control Center at the following Web
site: http://support.sas.com/ctx3/sodareg/index.html

2 Enter your e-mail address and your SAS Profile password and then click
Enter.

Locate the name of your SAS Forecast Server environment

Each course registered using SAS Forecast Server will have a unique course
environment. Instructors can locate the name of their course environment by
following these steps:

1 Log on to your SAS OnDemand for Academics Home page.
2 From the Course table, locate the appropriate course.

3 Click Get Software.
4

Review the section called Starting SAS OnDemand for Academics: Forecast
Server. The environment for your course will be listed in step 3.

Access SAS Forecast Server

After you have reconfigured your system to support SAS OnDemand for Academics:
Forecast Server and registered your course, you can start the application by following
these steps:

1 Log on to your SAS OnDemand for Academics Home page.
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2 From the Manage Courses area, select Get Software next to the appropriate
course. Selecting this link will open a window that includes information about
how to configure your system as well as how to start the application.

3 Click the link that is used to start SAS OnDemand for Academics: Forecast
Server (http://emcloud.oda.sas.com:16401/Forecasting/main.jnlp).

If you are presented with a security warning, select Run.

5 In the User Name field, enter your SAS Server user ID. This user ID is also
displayed on your SAS OnDemand for Academics home page:

* Getting Started

A Your SAS Server userid it sas.instructor

Use this userid when you log on w e SAS Server.

= Register a course:
Registering a course will make it available to your students.

To edit course information or review helpful details about courses, click on the course title. To obtain the software for a course
select the link in the Download column.

Note: Your SAS Server user ID is case sensitive and should be entered in all
lowercase. If you enter your SAS Server user ID using uppercase or mixed case
letters, you might be able to log on, but certain tasks might not perform properly.

6 In the Password field, enter your SAS Profile password. There are two times
when you might have supplied a SAS Profile password: either when you
originally created a SAS Profile or when you registered for SAS OnDemand for
Academics.

7 Click Log On.
To start SAS OnDemand for Academics: Forecast Server in the future, you can

perform the previous steps or simply save the following URL as a bookmark and use
it: http://emcloud.oda.sas.com:16401/Forecasting/main.jnlp

Access the SAS Server

You are prompted to connect to the SAS Server each time you start SAS OnDemand
for Academics: Forecast Server. The server (which is hosted at SAS Institute Inc.)
remotely processes any submitted SAS files or projects and returns results to your
computer.

Make sure that you have a working Internet connection if you are unable to use a
SAS OnDemand for Academics software application to perform processing. If your
internet connection is working normally and you are still unable to perform
processing, it is likely that the SAS Server is temporarily unavailable. Please try to
use the server again later. You can also log on to the SAS OnDemand for Academics
Control Center. The SAS OnDemand for Academics Control Center typically provides
a message if the SAS Server is unavailable or expected to be unavailable in the near
future.

SAS Server maintenance and availahility

SAS makes its best efforts to make the server available as much as possible and to
keep unexpected downtime to a minimum. There could be limited times when the
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server is unavailable because SAS is performing maintenance, testing, or
performance enhancement tasks.

O Ifserver maintenance is needed, SAS will try to perform this work during
nontraditional usage hours to lessen any impact to users.

O SAS uses the third Saturday of each month to perform scheduled maintenance
on its systems (if needed). Therefore, the server might be unavailable for a
portion of time on the third Saturday of each month.

To determine if SAS servers are available, visit the SAS Server status Web page:
(https://www.ondemand.sas.com/status/oda/).

Requesting SAS Server availahility notification

If you would like to be notified when the SAS Server is unavailable due to extended
maintenance or due to unforeseen circumstances, please subscribe to the
SASONDEMANDSERVER-L mailing list:

1 Send e-mail to LISTSERVRLISTSERV.SAS.COM.
2 In the body of the e-mail, type subscribe SASONDEMANDSERVER-L

3 Send the e-mail (no subject line is needed). Follow any instructions you receive
via e-mail.

To unsubscribe from SASONDEMANDSERVER-L, perform the following steps:
1 Send e-mail to LISTSERVRLISTSERV.SAS.COM.
2 In the body of the e-mail, type unsubscribe SASONDEMANDSERVER-L

3 Send the e-mail (no subject line is needed)

Step 4. Review the hasics for working with data and results

Before attempting course exercises, we recommend that you review the basics of
working with SAS data sets, models, and results in SAS OnDemand for Academics:
Forecast Server.

About project storage

By default, all SAS OnDemand for Academics: Forecast Server projects are stored on
the SAS server. Due to the architecture of this offering, there is no way to save your
projects locally.

The large size of projects and their forecasts might also prove to be problematic to
save locally. In a teaching setting, sharing the results of your forecasting projects
should be sufficient.

Working with forecasting project results

Students can share their results (graphs) with instructors should that be necessary
to support course assignments. Instructors can also save or share the results of their
forecasting project work. To do so:

1 Start SAS OnDemand for Academics: Forecast Server.
2 Open the appropriate project.


http://supportexp.unx.sas.com/ondemand/learn_fs.html#fsresults
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Rerun the project (if necessary) to produce the appropriate graph.
Select Tools » Reports and Stored Processes.

From the Output Options, select a report format and then click Run.

o o1 A W

Save the report or export the report data to another program. For example, if
you choose HTML as the report format, you can generate the report, right click
on the report, and then export the data to Microsoft Excel. If you choose CSV as
the report format, then the report will generate within Microsoft Excel
(provided that you have the application) by default.

7 Share the report as needed.

Step 5. Help for Common Problems

Please check the commonly asked questions about SAS OnDemand for Academics:
Forecast Server in this section and follow the procedures below for additional help.

Where can students find help

Students should be asked to follow the steps below to resolve any support issues they
encounter:

Step One: Review Commonly Asked Questions, SAS Notes, and SAS Documentation

Use the key word 'ondemand academics' to search for issues specific to SAS
OnDemand for Academics from these sources:

O Commonly Asked Questions about SAS OnDemand for Academics in this
manual

O SAS Notes, a database of common technical issues found on
http://support.sas.com/notes

O SAS Product Documentation on http:/support.sas.com/documentation

Step Two: Contact Your Instructor

If you are a student and you have questions about using SAS OnDemand for
Academics, contact your instructor. Instructors can point students toward
educational resources and help ensure that offerings are used correctly.

If further assistance is needed, then your instructor can contact SAS Technical
Support.

Commonly Asked Questions for SAS OnDemand for Academics:
Forecast Server

O How do I configure my PC to use SAS OnDemand for Academics: Forecast
Server?

In order to use SAS OnDemand for Academics: Forecast Server, you must first
ensure that your PC is properly configured and that you have the appropriate
Java Runtime Environment installed. For step-by-step instructions, see “Step
1: Confirm system requirements” for SAS OnDemand for Academics: Forecast
Server
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Notes:

How do I start SAS OnDemand for Academics: Forecast Server?

After you have configured your system to support SAS OnDemand for
Academics: Forecast Server, you can start the application:

1 Log on to your SAS OnDemand for Academics Home page.

2 From the Manage Courses area, select Get Software next to the
appropriate course. Selecting this link will open a window that includes
information about how to configure your system as well as how to start the
application.

3 Click the link that is used to start SAS OnDemand for Academics: Forecast
Server (http://emcloud.oda.sas.com:16401/Forecasting/main.jnlp) .

4 Ifyou are presented with a security warning when you attempt to start
SAS OnDemand for Academics: Forecast Server, select Run.

5 In the User Name field, enter your SAS Server user ID. This user ID is also
displayed on your SAS OnDemand for Academics home page:

Note: Your SAS Server user ID is case sensitive and should be entered in
all lowercase. If you enter your SAS Server user ID using uppercase or
mixed case letters, you might be able to log on, but certain tasks might not
perform properly.

6 In the Password field, enter your SAS Profile password. There are two
times when you might have supplied a SAS Profile password: either when
you originally created a SAS Profile or when you registered for SAS
OnDemand for Academics.

7 Click Log On.

To start SAS OnDemand for Academics: Forecast Server in the future, you
can perform the previous steps or simply use the following URL:
http:/emcloud.oda.sas.com:16401/Forecasting/main.jnlp.

When I start SAS OnDemand for Academics: Forecast Server, the software
application appears to be named SAS Forecast Studio. Am I using the correct
software?

Yes. SAS Forecast Server is the name of the software offering. However, SAS
Forecast Studio is the name of the graphical user interface that is used to
access SAS Forecast Server functionality.

What is the name of my SAS Forecast Server Environment?

Each course registered using SAS Forecast Server will have a unique course
environment.

Students will need to contact their instructor if they do not know which
environment to select.

How do I select a SAS Forecast Server Environment?
You can select your course environments by doing the following:
1 Log on to SAS Forecast Server.

2 From the Project window, select your course environment from the
Environment drop down menu.

Students must contact their instructors if they do not know which environment
to select.
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Step 1. Confirm system requirements

Check these guidelines to ensure you can access the software.

Confirm requirements for full support

Your system must meet these requirements for SAS OnDemand for Academics:
Enterprise Miner to be fully supported.

Supported Not Supported
Operating Any system that supports the Sun Macintosh operating systems
systems Microsystems (Oracle) Java Runtime
Environment (JRE). Typically, this Note: Virtualized
includes Unix, Linux, and various environments might not work.
Microsoft Windows operating systems, It is recommended that
such as Microsoft Windows XP and supported operating systems
Microsoft Windows Vista. run on a physical CPU.
Java Runtime Java Runtime Environment (JRE) Version JRE 1.6.0 20 is not
Environment 1.6.0 18. compatible.

Note: You will be prompted to check for  Note: Other JREs from the
this JRE and install it when you access 1.6 series might series might
SAS Enterprise Miner. work.

Hard disk space At least 50 MB of free hard disk space

Internet browser  Any browser that supports JRE 1.6.0 18

Internet High speed, including broadband (cable),

connection DSL (phone), and wireless connections.

Note: Individual usage experience
depends on speed and reliability of

connection.
Network For best performance, at least 1000
bandwidth Kbit/sec is recommended.

Verify and install a Java Runtime Environment (JRE)

After you have registered for a course that uses SAS OnDemand for Academics:
Enterprise Miner, you must verify that you have an appropriate Java Runtime
Environment (JRE) installed or install an appropriate JRE. This process needs to be
completed only once.

Note: Consider printing these instructions before you begin as some of the steps
might require you to move to other Web sites.
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Step One: Verify whether a JRE (and Java Web Start) is installed
To verify whether you have a JRE installed, try the following:

Open a Command Prompt window. Select Start » Run.
Type CMD in the Run window.

On the Command Prompt window, type start javaws.
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If the above command opens a Java Web Start window similar to the following,
then you have a JRE (and Java Web Start) installed.

Java(TM}) Web Start 1.6.0_06 ﬂ

\}4) Usage: javaws [run-options] <jnip-file=
javaws [conkrol-opkions]

where run-options include:

-verbose display additional output:

-offline run the application in offline mode

-syshem run the application from the syskem cache only
-znosplash run without showing a splash screen
-J=option= supply option to the vm

-waik start java process and waik Faor its exit

control-options include:

-yigmer show the cache viewer in the java control panel
-uninstall remove all applications from the cache
-uninstall <jnlp-File = remove the application from the cache

-impart [import-options] <jnlp-file=  import the application to the cache

import-options include:

-silent import silently {with no user interface)
-syskem import application inko the system cache
-todebase <url=  retriewe resources from the given codebase
-shortout install shortcuts as if user allowed prompk
-associakion install associations as if user allowed prompk

If you have a JRE installed, then continue to Step Two.

If the above command did not work, then you likely do not have a JRE
installed. Continue to Step Three.

Step Two: Ensure that you are using only the recommended Java Runtime Environment

We recommend that you use Java Runtime Environment (JRE) 1.6.0_18 to run SAS
OnDemand for Academics: Enterprise Miner. Only JREs with U.S. Export Control
Classification Numbers of 5D992 are approved for use with SAS products.

Note: Other JREs from the 1.6 series might also work (excluding JRE 1.6.0_20,
which is incompatible).

1 From a Command Prompt window, start Java Web Start. Type start javaws -
viewer and then press ENTER.

2 Ifthe Java Cache Viewer window appears, close it so that you can see the Java
Control Panel window. The Java Control Panel window often opens behind the
Java Cache Viewer window.

3 From the Java Control Panel window, select the Java tab.
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4 From the Java Application Runtime Settings area (the bottom half of the
window), click View (the second “View” button on the window).

5 In the Enabled column, check only one JRE (uncheck any other JREs that are
checked). We recommend that you check JRE 1.6.0_18.

If JRE 1.6.0_18 is unavailable, then you can test SAS OnDemand for Academics:
Enterprise Miner with your current JRE. To do so, you can start from your SAS
OnDemand for Academics Home Page.

If your current JRE does not work or if you want to install the recommended JRE,
continue to Step Three. Otherwise, configuration is complete.

Step Three: Install the recommended Java Runtime Environment and Java Web Start
Installing the recommended JRE will also install Java Web Start on your system.

Note: If you completed Step Two above, repeat this step to ensure that only JRE
1.6.0_18 is selected.

1 Access the appropriate list of Java SE Downloads at this location:

http://www.oracle.com/technetwork/java/javasebusiness/downloads/java-
archive-downloads-javase6-419409.html#jre-6ul8-oth-JPR

2 Alternatively, you can access the Java SE 6 Downloads archive page at

http://www.oracle.com/technetwork/java/archive-139210.html then click Java
SE 6. On the Java SE 6 Downloads page, select Java SE Development Kit SE
6ul8 from the list to view a table of all downloads by operating system.

Click the radio button above the table to Accept License Agreement.
Select jre-6ul8-windows-i586.exe under Download column.

You will be prompted to sign in to your Oracle Web account. If you do not have
an account, you will be prompted to create one.

6 After you are signed in, launch the download and select Run to begin the
installation process.

7 (Optional) If you completed Step Two above, repeat this step to ensure that
only JRE 1.6.0_18 is selected.

Step 2. Set up your SAS OnDemand for Academics account

There are several important steps you must follow to set up a SAS OnDemand for
Academics account, such as creating a SAS profile and registering for your course.
The online process uses a series of windows to guide you.

About the SAS OnDemand for Academics Gontrol Center

Your starting point for accessing SAS OnDemand for Academics is the SAS
OnDemand for Academics Control Center Web site.You will use it to register, acquire
a license, and view course information.

http://support.sas.com/ctx3/sodareg/index.html

Your SAS OnDemand for Academics Home Page is created during the registration
process and is part of the SAS OnDemand for Academics Control Center. You will be


http://support.sas.com/ondemand/emconfig.html#two

56 Step 3. Access and use the software  Chapter 4

taken to your Student Home Page once you have set up an account. You access your
home page to view information associated with courses.

About your SAS Profile account

A SAS Profile is an account that you can create to access specific information and
resources from the SAS Web site. If you are a current SAS user, you might already
have a SAS Profile account. If you are a new SAS user, a SAS Profile is created for
you when you register for SAS OnDemand for Academics.

An important part of your SAS Profile account is a SAS Profile password that you are
prompted to enter each time you access the SAS OnDemand for Academics Control
Center.

Note: Your SAS Profile password must be changed every 6 months for security
purposes. You will receive an e-mail when your password is approaching expiration.
To reset your SAS profile, visit My SAS Profile page at this location:
https://www.sas.com/profile/user/login.htm.

Important information hefore you begin

As you begin setting up your account, it's helpful to keep the following in mind:

O You will need access to your e-mail account. When you begin registration, you
will be prompted to enter an e-mail address. Enter the e-mail address of an
account that you can access easily while completing your registration.

O You will receive an e-mail during the initial registration process that you must
open and act upon to continue. The e-mail prompts you to click a link to verify
your e-mail address. Its primary purpose is to confirm that you are using a
valid e-mail address and that someone else is not attempting to register you
without your knowledge.

O If you do not receive the e-mail, please check your junk e-mail folder.

Register for a course

You must register to select and get access to the SAS software being used for the
course. During registration, you must select a university, an instructor, and a
course.

1 Visit the SAS OnDemand for Academics Control Center to begin:
http://support.sas.com/ctx3/sodareg/index.html

2 Enter your e-mail address in the text box to get started
3 Follow the instructions.

Visit the following location to print or view step-by-step instructions:
http://www.sas.com/govedu/edu/programs/enterprise_miner_student.pdf

Step 3. Access and use the software

Ideally, you should perform this step before you begin your first assignment using
SAS OnDemand for Academics software.
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Access your SAS OnDemand for Academics account

Your SAS OnDemand for Academics account enables you to view information
associated with courses. You will have access to this information after you have
initially registered for SAS OnDemand for Academics.

To access an existing SAS OnDemand for Academics account:

1

Access the SAS OnDemand for Academics Control Center at the following Web
site: http://support.sas.com/ctx3/sodareg/index.html

Enter your e-mail address and your SAS Profile password and then click
Enter.

Access SAS Enterprise Miner

After you have configured your system to support SAS OnDemand for Academics:
Enterprise Miner, you can start the application by following these steps:

1
2

5

Log on to your SAS OnDemand for Academics Home page.

From the Manage Courses area, select Get Software next to the appropriate
course. Selecting this link will open a window that includes information about
how to configure your system as well as how to start the application.

Click the link that is used to start SAS OnDemand for Academics: Enterprise
Miner (http://emcloud.oda.sas.com:16098/EnterpriseMiner/main.jnlp) .

If you are presented with a security warning such as the following, select Run.

X
The application’s digital signature has an error. Do you '
want to run the application? L.

Hame: SAS Erterprise Miner 5.3
Publisher: SAZ Institute Inc.

From: hittg: emcloud ocia sas5.com: 16095

™ Always trust contert from this publisher

Run Cancel

\"r\ The digital signature was generated with a trusted cetificate but

hore Infarmation...
has expired

In the User Name field, enter your SAS Server user ID. This user ID is also
displayed on your SAS OnDemand for Academics home page:

* Getting Started

A Your SAS Server userid it sas.instructor

Use this userid when you log on w wuie SAS Server.

= Register a course:
Registering a course will make it available to your students.

To edit course information or review helpful details about courses, click on the course title. To obtain the software for a course
select the link in the Download column.

Note: Your SAS Server user ID is case sensitive and should be entered in all
lowercase. If you enter your SAS Server user ID using uppercase or mixed case
letters, you might be able to log on, but certain tasks might not perform
properly.

In the Password field, enter your SAS Profile password. There are two times
when you might have supplied a SAS Profile password: either when you
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originally created a SAS Profile or when you registered for SAS OnDemand for
Academics.

8 Click Log On.
To start SAS OnDemand for Academics: Enterprise Miner in the future, you can

perform the previous steps or simply save the following URL as a bookmark and use
it: http://emcloud.oda.sas.com:16098/EnterpriseMiner/main.jnlp.

Access the SAS Server

You are prompted to connect to the SAS Server each time you start SAS OnDemand
for Academics: Enterprise Miner. The server (which is hosted at SAS Institute Inc.)
remotely processes any submitted SAS files or projects and returns results to your
computer.

Make sure that you have a working Internet connection if you are unable to use a
SAS OnDemand for Academics software application to perform processing. If your
internet connection is working normally and you are still unable to perform
processing, it is likely that the SAS Server is temporarily unavailable. Please try to
use the server again later. You can also log on to the SAS OnDemand for Academics
Control Center. The SAS OnDemand for Academics Control Center typically provides
a message if the SAS Server is unavailable or expected to be unavailable in the near
future.

SAS Server maintenance and availability

SAS makes its best efforts to make the server available as much as possible and to
keep unexpected downtime to a minimum. There could be limited times when the
server is unavailable because SAS is performing maintenance, testing, or
performance enhancement tasks.

Q Ifserver maintenance is needed, SAS will try to perform this work during
nontraditional usage hours to lessen any impact to users.

O SAS uses the third Saturday of each month to perform scheduled maintenance
on its systems (if needed). Therefore, the server might be unavailable for a
portion of time on the third Saturday of each month.

To determine if SAS servers are available, visit the SAS Server status Web page:
(https://www.ondemand.sas.com/status/oda/).

Requesting SAS Server availahility notification

If you would like to be notified when the SAS Server is unavailable due to extended
maintenance or due to unforeseen circumstances, please subscribe to the
SASONDEMANDSERVER-L mailing list:

1 Send e-mail to LISTSERVELISTSERV.SAS.COM.
2 In the body of the e-mail, type subscribe SASONDEMANDSERVER-L

3 Send the e-mail (no subject line is needed). Follow any instructions you receive
via e-mail.

To unsubscribe from SASONDEMANDSERVER-L, perform the following steps:
1 Send e-mail to LISTSERVRLISTSERV.SAS.COM.
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2 In the body of the e-mail, type unsubscribe SASONDEMANDSERVER-L

3 Send the e-mail (no subject line is needed)

Step 4. Review the hasics for working with data, results, and
projects
Before attempting course exercises, we recommend that you review the basics of

working with SAS data sets, models, and results in SAS OnDemand for Academics:
Enterprise Miner.

Working with data

To ensure that you do not lose your work, you should cover the basics of accessing
and using data from the SAS Server. SAS OnDemand for Academics: Enterprise

Miner uses the SEMMA project model to organize work and options for accessing

data are specific to this product.

Before you access the appropriate data sets for your exercises, you must assign a SAS
library to your projects using one of the following methods using a project using Start
Code or submitting a LIBNAME statement.

Assigning a SAS Library to a project using Start Code

SAS OnDemand for Academics: Enterprise Miner enables you to include Start Code
for your projects. After you have specified this code, it will be run any time that the
project is started and can save you time and effort. For example, you might want to
assign a LIBNAME statement through Start Code so that a project can always access
specific SAS data sets.

Using Start Code with a new project:
1 Start SAS OnDemand for Academics: Enterprise Miner.

2 Select New Project. From the New Project wizard, select a name for your
project, select the default values on the remaining wizard screens, and then
select Finish.

3 From the Property tree on the left, locate the Project Start Code property.
4 Click the ellipsis ... button.
5 Enter the appropriate Start Code and then click either Run Now or OK.

Note: If you want to use project Start Code to access SAS data sets that use a
format file, then you must also specify the FMTSEARCH option in your start code.

Using Start Code with an existing project:

1 Start SAS OnDemand for Academics: Enterprise Miner.
Open the appropriate project.

Click the ellipsis ... button.

2

3 From the Property tree on the left, locate the Property Code property.

4

5 Enter the appropriate Start Code and then click either Run Now or OK.
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Note: If you want to use project Start Code to access SAS data sets that use a
format file, then you must also specify the FMTSEARCH option in your start-up
code.

Assigning a SAS Library using LIBNAME statements

You can access the Program Editor by selecting View --> Program Editor from
within SAS OnDemand for Academics: Enterprise Miner.

Instructors have the ability to store SAS data sets on the SAS Server. If your
instructor has taken advantage of this feature, then you must use the appropriate
LIBNAME statement for your course to access that data.

Note: LIBNAME statements are case-sensitive. Please copy them or type them in
exactly as they appear to avoid permissions errors.

Accessing data using SAS OnDemand for Academics: Enterprise Miner

The SAS Server includes various SAS libraries (and their corresponding SAS data
sets). As an instructor, you might want to use one or more of the SAS data sets from
SASHELP, MAPS or other SAS-provided libraries to ensure that all your students
have access to the data. To access sample data sets on the SAS Server:

1 Start SAS OnDemand for Academics: Enterprise Miner.
2 Create a new project or open an existing project.

3 In the tree on the left, right-click on Data Source and then select Create
Data Source.

4 The Source drop down box defaults to SAS Table. Click Next to accept the
default value and move to the next step in the wizard.

Next to the Table field (which will be blank), click Browse.
Use the Library drop down to select the appropriate library.

Select the SAS data set that you want to use and then continue with the
wizard.

Accessing SAS Enterprise Miner course data on the SAS Server

Additionally, SAS OnDemand for Academics stores SAS data sets associated with the
teaching materials from SAS Enterprise Miner courses on the SAS Server. To view
these:

1 Start SAS OnDemand for Academics: Enterprise Miner.
2 Create a new project or open an existing project.

3 In the tree on the left, right-click on Data Source and then select Create
Data Source.

4 From the Source drop down, select Metadata Repository and then click
Next.

Next to the Table field, click Browse.
Use the Library drop down to select the appropriate library.

Select the SAS data set that you want to use and then continue with the wizard
or data files to the SAS Server for use in specific courses.
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Accessing grayed-out SAS libraries from the SAS Server

The SAS Server includes sample SAS data sets that you might choose to use. Some of
the sample SAS Libraries might appear to be grayed out, but they are still available
for use.

Typically, grayed out SAS Libraries appear for users in Europe and were originally
intended for use with SAS Enterprise Miner.

1 Start SAS OnDemand for Academics: Enterprise Miner and log on.
Select File --> Open --> Data.

Select Servers.

Double click on SAS Apps.

Double click on Libraries.
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Right click on the grayed out SAS Library that you would like to access and
then click Assign.

7 Double click on the SAS data set that you want to use.

Step 4. Review the basics for working with data, results, and projects

Working with projects

SAS OnDemand for Academics: Enterprise Miner uses the SEMMA model to
organize data mining projects. SAS recommends that you share the following
information with your students so they can use the interface most effectively.

Understanding Project Storage Quotas

Each SAS OnDemand for Academics: Enterprise Miner user has a large project
storage quota. An e-mail message is sent to any user who has used 75% of their
storage quota.

If the project storage quota is reached, then SAS OnDemand for Academics:
Enterprise Miner will stop functioning properly. To avoid this, consider deleting any
unnecessary projects prior to reaching your quota to ensure that SAS OnDemand for
Academics: Enterprise Miner continues to work properly.

If you do reach your quota and then delete unnecessary projects to create more
project storage space, then the last project that you were working with could be
impacted. If the project runs incorrectly after removing unnecessary projects, then
you might need to rebuild the diagrams for this project.

Creating New Projects

When you create a new project, you will use the Create New Project wizard. Step
Three of this wizard enables you to select a SAS folder in which to store your project.
Even though you have the ability to browse in this step, please accept the default
project storage location:

/Users/your-user-id/My Folder

Accepting the default project storage location will ensure that your projects can be
accessed appropriately by SAS OnDemand for Academics servers.
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If you select Browse and attempt to store your project in a location other than the
default, the following error will result:

eror x|

Exception occurred updating the 545 Metadata
Repositary,

To correct this error, change the location where your project will be stored back to the
default location: /Users/your-user-id/My Folder

Opening Existing Projects

To find and open an existing project, perform the following steps:
Start SAS OnDemand for Academics: Enterprise Miner.
Click Open Project.

From the Open Project window, open the My Folder folder.

Select the project that you want to open.
Click OK.
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Creating model packages

With SAS OnDemand for Academics: Enterprise Miner, users can create model
packages (also known as SAS Package Files or .spk files). Model packages can be
created from any node in a diagram. Typically, you create a model package when you
are satisfied with your model and you want to preserve it or share it with someone
else.

In most cases, you create the model package from the last node of a process in a
diagram. This ensures that the model package will include the entire process flow.

Differences hetween project model packages and exported project
diagrams

With SAS OnDemand for Academics: Enterprise Miner, a user can create a model
package and send it as a SAS Package File (.spk), or export a diagram as an XML file
(.xml). If a specific project takes a long time to run, having the model package (with
the associated results) can be advantageous.

Exported diagrams contain no results. After a project's diagram has been exported as
an XML file, it can be shared as an attachment in an e-mail message or by placing
the file on a shared network directory. To use the shared file, it must be imported in
to SAS OnDemand for Academics: Enterprise Miner and then the appropriate path of
the diagram would have to be run to produce results.

Note that neither model packages nor exported diagrams include the actual data that
is referenced. To rerun the project, you must have access to the original data or use
the LIBNAME statement that points to the original data if that data is stored on the
SAS Server.
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Sharing homework assignments

There are three ways that you can share homework assignments: either by creating
and registering a project model package, by sharing a project model package, or by
sharing a project diagram. As an instructor, you will want to review these methods,
decide which method aligns with course objectives, and be able to answer any
questions your students may have about the process.

Submitting homework assignments

With SAS OnDemand for Academics: Enterprise Miner, students can create and
submit an entire project model package, or export a project diagram and share the
exported file.

Ultimately, the choice is up to the instructor. The decision might be made based on
whether or not the instructor needs access to project results or diagram files.

To submit a project model package to an instructor:

1 Create a project or open an existing project within SAS OnDemand for
Academics: Enterprise Miner.

Highlight the appropriate node within a diagram.
Select Actions » Create Model Package.

In the Input dialog box, enter a name for the model package. To ensure that
you choose a unique file name, you might want to include your name or initials
as part of the file name. This will ensure that an instructor can distinguish one
submitted model package from another.

5 From the Project Panel on the left side of SAS OnDemand for Academics:
Enterprise Miner, expand the Model Packages folder.

6 Right click on the appropriate model and then click Save As. You will be
prompted to save the model as a SAS Package File (.spk).

7 Share the appropriate .spk file with your instructor (through e-mail or through
a shared network directory).

To submit an exported project diagram to an instructor:

1 Create a project or open an existing project within SAS OnDemand for
Academics: Enterprise Miner. Ensure that your project includes a diagram.

2 From the Project Panel on the left side of SAS OnDemand for Academics:
Enterprise Miner, expand the Diagrams folder.

3 Right click on the appropriate diagram and then select Save As. Save the
diagram as a .XML file. To ensure that you choose a unique file name, you
might want to include your name or initials as part of the file name. This will
ensure that an instructor can distinguish one submitted diagram from another.

4 Share the . XML file with your instructor (through e-mail or through a shared
network directory).
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Collaborating

Students can collaborate with each other while using SAS OnDemand for Academics:
Enterprise Miner in one of two ways:

O by saving an entire project as a model package and then sharing the model
package

O by exporting project diagrams as XML files and then sharing those files with
each other.

The choice might be determined by whether or not the students need to share the
results of a project. Exported diagrams do not contain results while model packages
do.

Note: Neither model packages nor exported diagrams include the actual data that
is referenced. To rerun the project, you must have access to the original data or have
the LIBNAME that points to the original data if that data is stored on the SAS
Server.

To share a project model package:

1 Create a project or open an existing project within SAS OnDemand for
Academics: Enterprise Miner.

Highlight the appropriate node within a diagram.
Select Actions » Create Model Package.

In the Input dialog box, enter a name for the model package. To ensure that
you choose a unique file name, you might want to include your name or initials
as part of the file name. This will ensure that your peers can distinguish one
model package from another.

5 From the Project Panel on the left side of SAS OnDemand for Academics:
Enterprise Miner, expand the Model Packages folder.

6 Right click on the appropriate model package and then select Save As. Save
the model package as an .spk file.

7 Share the .spk file as needed (through e-mail or through a shared network
directory).

Note: The user who receives the model package can start SAS OnDemand for
Academics: Enterprise Miner and choose File » Open Model Package to open the
package and view the diagram and results. The user will be unable to make any
changes or rerun the diagram nodes. However, the user can choose Action ->
Recreate Diagram to recreate the diagram within the current project. Once the
diagram is recreated, the user will have a working copy of the diagram, just as if they
imported the appropriate diagram.xml. The user must run a diagram path to produce
any results.

To share a project diagram:

1 Create a project or open an existing project within SAS OnDemand for
Academics: Enterprise Miner. Ensure that your project includes a diagram.

2 From the Project Panel on the left side of SAS OnDemand for Academics:
Enterprise Miner, expand the Diagrams folder.

3 Right click on the appropriate diagram and then select Save As. Save the
diagram as a .XML file. To ensure that you choose a unique file name, you
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might want to include your name or initials as part of the file name. This will
ensure that your peers can distinguish one diagram from another.

4 Share the .XML file as needed (through e-mail or through a shared network
directory).

To use a shared project diagram:
1 Start SAS OnDemand for Academics: Enterprise Miner.
2 Create a new project or open an existing project.
3 Select File » Import Diagram from XML.
4 Import the appropriate diagram XML file.

Step 5. Finding Help for Common Problems

Please check the commonly asked questions about SAS OnDemand for Academics:
Enterprise Miner in this section and follow the procedures below for additional help.

Where can students find help

Students should be asked to follow the steps below to resolve any support issues they
encounter:

Step One: Review Commonly Asked Questions, SAS Notes, and SAS Documentation

Use the key word 'ondemand academics' to search for issues specific to SAS
OnDemand for Academics from these sources:

O Commonly Asked Questions about SAS OnDemand for Academics in this
manual

O SAS Notes, a database of common technical issues found on
http://support.sas.com/notes

O SAS Product Documentation on http:/support.sas.com/documentation

Step Two: Contact Your Instructor

If you are a student and you have questions about using SAS OnDemand for
Academics, contact your instructor. Instructors can point students toward
educational resources and help ensure that offerings are used correctly.

If further assistance is needed, then your instructor can contact SAS Technical
Support.

Commonly Asked Questions: SASOnDemand for Academics:
Enterprise Miner
O Does SAS OnDemand for Academics: Enterprise Miner have all the same
features as SAS Enterprise Miner?

The version of SAS Enterprise Miner available through SAS OnDemand for
Academics does have a few differences.
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O You must accept the default project storage location when creating new
projects.

O Your projects are stored within the My Folder folder.

0 Certain nodes are unavailable, might not function properly, or are
experimental. For example, the File Import node is unavailable.

0 Can I use SAS OnDemand for Academics: Enterprise Miner if I already have
SAS Enterprise Miner on my PC?

Yes. SAS OnDemand for Academics: Enterprise Miner is mutually exclusive
from any other version of SAS Enterprise Miner and should not cause any
conflicts or reset any file type associations.

Please note that the projects that you create with each version of SAS
Enterprise Miner are also mutually exclusive. If necessary, you can save a
project diagram xml file created in one version of SAS Enterprise Miner and
import it in to another version. However, for this to work, you must have access
to the necessary data on the appropriate PC as well.

0 How do I configure my PC to use SAS OnDemand for Academics: Enterprise
Miner?
In order to use SAS OnDemand for Academics: Enterprise Miner, you must first
ensure that your PC is properly configured. It is especially important that the
appropriate version of the Java Runtime Environment is installed on your
machine. Refer to “Verify and install Java Runtime Environment (JRE)” for
SAS OnDemand for Academics: Enterprise Miner.

O How do I start SAS OnDemand for Academics: Enterprise Miner?
After you have configured your system to support SAS OnDemand for

Academics: Enterprise Miner, you can start the application by following these
steps:

1 Log on to your SAS OnDemand for Academics Home page.

2 From the Manage Courses area, select Get Software next to the
appropriate course. Selecting this link will open a window that includes
information about how to configure your system as well as how to start the
application.

3 Click the link that is used to start SAS OnDemand for Academics:
Enterprise Miner
(http://emcloud.oda.sas.com:16098/EnterpriseMiner/main.jnlp).

4 Ifyou are presented with a security warning such as the following, select
Run.
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Warning - Security B

x|
The application’s digital signature has an error. Do you '
want to run the application? /e

Hame: SAS Enterprize Miner 5.3
Publisher: SAS Institute Inc.

From: hitp: femcloud .oda sas . com: 16095

Run Cancel

W The digital signatura was generated with a trusted cedificate but b (L e o

has expired.

5 In the User Name field, enter your SAS Server user ID. This user ID is
also displayed on your SAS OnDemand for Academics home page:

* Getting Started

A Your SAS Server userid it sas.instructor

Use this userid when you log on w e SAS Server.

= Register a course:
Registering a course will make it available to your students.

To edit course information or review helpful details about courses, click on the course titie. To obtain the software for a course
select the link in the Download column.

Note: Your SAS Server user ID is case sensitive and should be entered in all
lowercase. If you enter your SAS Server user ID using uppercase or mixed case
letters, you might be able to log on, but certain tasks might not perform
properly.

6 In the Password field, enter your SAS Profile password. There are two
times when you might have supplied a SAS Profile password: either when
you originally created a SAS Profile or when you registered for SAS
OnDemand for Academics.

7 Click Log On.

To start SAS OnDemand for Academics: Enterprise Miner in the future, you can
perform the previous steps or simply use the following URL:
http://emcloud.oda.sas.com:16098/EnterpriseMiner/main.jnlp.

Q Ireceive the following error when trying to log on to SAS OnDemand for
Academics: Enterprise Miner: "An RMI registry could not be found... ". What
should I do?

This error message typically indicates that you did not complete some or all of
the configuration steps necessary. You should review or complete the
configuration steps and then try to log on again. You only have to complete the
configuration steps once in order to use SAS OnDemand for Academics:
Enterprise Miner.

Q Ireceive the following error when trying to log on to SAS OnDemand for
Academics: Enterprise Miner: “Could not log on. Contact your administrator for
the correct username and password.” What should I do?
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Q If Microsoft Windows Vista prompted you to block javaw.exe when
attempting to start SAS OnDemand for Academics: Enterprise Miner and you
chose to block the file, then this error message occurs.

To correct this situation, you must open Windows Firewall and unblock the
javaw.exe file. For example, on Microsoft Windows Vista Home Premium
Edition, the following steps might work:

O Select Start --> Control Panel --> Windows Firewall.
Q Click the Change Settings link.

Q Select the Exceptions tab.

O Find javaw.exe and make sure it is unchecked.

For more information, refer to Microsoft Windows Vista help or contact your
system administrator.

Q Ireceive the following error when trying to log on to SAS OnDemand for
Academics: Enterprise Miner: "Network Error. The connection to the Analytics
Platform has been lost. This client session must be terminated." What should I
do?

This error message typically occurs if you have left SAS OnDemand for
Academics: Enterprise Miner open, but have left it idle for a period of time.
Close SAS OnDemand for Academics: Enterprise Miner and restart it to try and
resolve the issue.

Q Ireceive the following error in my SAS log when trying to use a SAS catalog
file that I have uploaded to the SAS Server: "ERROR: File LIBRARY
NAME.CATALOG NAME.CATALOG was created for a different operating
system." What is wrong?

This error message typically occurs if you have tried to use a SAS catalog file
that was created using an operating system other than Unix. To resolve the
issue, refer to “Storing SAS catalog Files on the SAS Server” for SAS
OnDemand for Academics: Enterprise Miner. This topic includes usage
information and sample code.

O How do I save my work in SAS OnDemand for Academics: Enterprise Miner?

There is no Save button in this application. Your project is automatically saved
for you while you work. When you are done working, select File --> Close this
Project to ensure that your project saves properly.

O How do I submit homework using SAS OnDemand for Academics: Enterprise
Miner?

There are three ways that you can share homework assignments: either by
creating and registering a project model package, by sharing a project model
package, or by sharing a project diagram. Your instructor will tell you the
method that he or she would like you to use.

QO How do I collaborate using SAS OnDemand for Academics: Enterprise Miner?

You can collaborate by sharing an entire project model package or a project
diagram. For more information, see these topics: “Differences between Project
model packages and exported project diagrams” and “Collaborating” for SAS
OnDemand for Academics: Enterprise Miner.

O Can I use a project model package or project diagram from older versions of
SAS Enterprise Miner?
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Some project model packages and project diagrams created in older versions of
SAS Enterprise Miner work fine while others do not. If you try to use a project
or diagram created with an older version of SAS Enterprise Miner and the
application becomes unresponsive, close the application and avoid using the
project model package or project diagram in the future.

Q My project or diagram is unresponsive or no longer opens. What's wrong?

If you have lost a connection to the SAS Server while working on your project
or diagram or if you did not properly close SAS OnDemand for Academics:
Enterprise Miner, then a lock file might have been created. This lock file could
cause your diagram or project to appear unresponsive or it could prevent your
diagram or project from opening at all. Try the following to correct the issue:

Q Ifthe lock has just happened, try waiting about five minutes. In many
cases, locked files correct themselves.

Q Ifyou are unsure of when the lock occurred or if it has been longer than five
minutes, close the project, log out of SAS OnDemand for Academics:
Enterprise Miner, and then log back in.

O If the problem persists, please contact SAS Technical Support. Send e-mail
to support@sas.com. Specify that you are using SAS OnDemand for
Academics: Enterprise Miner.

Notes:

Q SAS recommends that you close your diagrams and/or projects before
exiting SAS OnDemand for Academics: Enterprise Miner or before
disconnecting from your Internet connection.

Q An open connection to the SAS Server will likely disconnect (time out) after
one hour if the connection is idle (that is, you have not performed any
processing). Many firewalls disconnect open sessions after an hour of idle
time, and this could lead to locked files. SAS recommends that you
complete your work, save it, and then exit SAS OnDemand for Academics:
Enterprise Miner before you leave the computer.

O When I open SAS OnDemand for Academics: Enterprise Miner, I no longer see
my projects. What is wrong?

This behavior can occur if you log on to SAS OnDemand for Academics:
Enterprise Miner using a mixed case or upper case SAS Server user ID. Please
close SAS OnDemand for Academics: Enterprise Miner and log on again. Make
sure that you use all lowercase letters for your SAS Server user ID.

O Can I create a SAS Library using SAS OnDemand for Academics: Enterprise
Miner?
No. However, you can work with available SAS Libraries or assign LIBNAME
statements.

0 Ihave been provided with a LIBNAME statement for my course. How do I
assign it?
If your instructor has provided a LIBNAME statement for your course, you can
assign it in one of two ways:

O Assign the LIBNAME statement as part of your project Start Code to ensure
that the SAS Library is available throughout your project; this LIBNAME
statement will also execute each time that you start your project.
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a

a

Assign the LIBNAME statement within a project using the SAS OnDemand for
Academics: Enterprise Miner Program Editor window.

I am using a SAS data set that requires a format file. How do I define the path
to the format file?

You can define a path to a format file using project Start Code.
I either have or might reach my project storage quota. What do I do?

If you exceed your project storage space quota, then SAS OnDemand for
Academics: Enterprise Miner will stop processing nodes properly. To resolve
this situation, delete existing projects that you no longer need in order to free
up project storage space.

The last project that you created or were working with when you met your
project storage space quota could be impacted (even after you delete existing
projects to create more space). If such a project appears to run incorrectly, then
you might need to rebuild the diagrams for this project.
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Commonly Asked Questions for SAS OnDemand for Academics

This appendix answers questions that apply to all SAS OnDemand for Academics
software products. For help with specific products, see “Commonly Asked Questions”
for the SAS OnDemand for Academics software that you are using.

General/Cost/License

0O How long is my license period?
The license period lasts six months.
0 What is the cost?
It is free for professors and free to students in registered classes.

O Is SAS OnDemand for Academics accessible to users with disabilities?

SAS is aware that academic and other institutions are required to satisfy the
accessibility standards contained in Sections 504 and 508 of the Rehabilitation Act (29
U.S.C. 794d) with respect to their use of electronic and information technology. SAS has
tested SAS OnDemand for Academics and SAS OnDemand for Academics: Enterprise
Guide against relevant standards with the assistance of students who use assistive
technologies.

Availahility and Installation

O Who can use SAS OnDemand for Academics?

SAS OnDemand for Academics is available only to college instructors and their
students.

We recommend that instructors test the use of this offering before including it in a
course to ensure performance is acceptable.

0 What can I expect during the registration process?
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There are several parts to the registration process, so it's helpful to keep the
following in mind:

O The registration process uses a series of windows to guide you.

O You will need access to your e-mail account during the registration process.
When you begin registration, you will be prompted to enter an e-mail address.
Enter the e-mail address of an account that you can access easily while
completing your registration.

O You will receive an e-mail during the initial registration process that you must
open and act upon to continue. The e-mail prompts you to click a link to verify
your e-mail address. Its primary purpose is to confirm that you are using a
valid e-mail address and that someone else is not attempting to register you
without your knowledge.
O Which Internet browsers can I use with SAS OnDemand for Academics?

An Internet browser is required to use the SAS OnDemand for Academics Control
Center (registration, course selection, and so on) as well as to download SAS
OnDemand for Academics software. We recommend Microsoft Internet Explorer 7
(or earlier) for Microsoft Windows systems. Safari and Mozilla Firefox might be
appropriate for Macintosh systems. While other browsers might work with the
offering, they have not been fully tested.

O What is a SAS Profile?

A SAS Profile is an account that you can create to access specific information and
resources from the SAS Web site. If you are a current SAS user, you might already
have a SAS Profile. If you are a new SAS user, a SAS Profile will be created for
you when you register for SAS OnDemand for Academics.

General Usage

0 How do Ilog on to my SAS OnDemand for Academics Home Page?

Your SAS OnDemand for Academics Home Page is part of the SAS OnDemand for
Academics Control Center. The Control Center is used by students to register and
view course information. The Control Center is used by instructors to register,
create courses, view course information, edit course information, and delete
courses.

To log on to your SAS OnDemand for Academics Home Page, see “Access your SAS
OnDemand for Academics account” for the SAS OnDemand for Academics
software that you are using.

O I've used the correct log on values and I still can't connect to the SAS Server to
perform processing. What's wrong?
There are a few common reasons why you might not be able to connect:
Q@ You might have a brand new account. Your account will be activated within 15
minutes of registration, and then you'll gain access to the SAS Server.
Q The SAS Server might be temporarily down for maintenance.
Q Your account status might be Pending.

O Your SAS Profile password might have expired. This password must be reset
after 180 days (approximately six months). For more information, see
Resetting your SAS Profile Password.

O Your SAS Profile password might be too weak. See “What is a SAS Profile?” for
the SAS OnDemand for Academics software that you are using.
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O Your account might have expired. Student accounts are valid for the duration
of the registered course (plus a grace period to ensure that assignments can be
completed).

Q The SAS Server might be down at certain times for maintenance, testing, or
enhancements. If you are unable to connect, make sure that you have a
working Internet connection. If you do and you still cannot connect, please try
again at a later time. For more details, see “SAS Server maintenance and
availability” for the SAS OnDemand for Academics software that you are
using.

O My connection to the SAS Server failed after I left my machine. What happened?
An open connection to the SAS Server will likely disconnect (time out) after one
hour (or less) if the connection is idle (that is, you have not performed any
processing). Many firewalls disconnect open sessions after an hour of idle time (or
less). SAS recommends that you complete your work, save it, and then exit SAS
OnDemand for Academics before you leave the computer.

O Can I collaborate with other users?
Currently, there are a few ways that you can collaborate:
O You can share files through network storage space that both parties can access
(such as AF'S or NFS mounted drives).

Q If an instructor chooses to store data on the SAS Server for a course, then the
students in that course can all share the same data by using the LIBNAME or
FILENAME statement that the instructor provides.

O You could consider using third party tools, such as www.blackboard.com.

O Can I point to local SAS data sets or files using a LIBNAME or a FILENAME
statement?

No. The SAS Server is unable to access or recognize the local drives of your PC. If
you write a LIBNAME statement or a FILENAME statement that references a
local directory path, you will receive processing errors. Can I store files on the
SAS Server?

Only instructors have the ability to store data files on the SAS Server. Once a data
file has been stored on the SAS Server, students can access it using an appropriate
LIBNAME or FILENAME statement provided by the instructor.

0 Ihave uploaded a SAS data set, but I can't see or access it. What is wrong?
Please be sure that the SAS data set that you uploaded is named using all
lowercase letters. Our hosted servers use Unix; they do not recognize mixed or
uppercase letters. If you have uploaded a SAS data set that uses mixed or
uppercase letters, simply rename the SAS data set to use all lowercase letters
(with no spaces in the name) and then upload the SAS data set again.

O Is there a limit to the number of times I can submit SAS jobs to the SAS Server?
No. There is no limit.

O Can I use the SAS Server with other SAS software that I have licensed?
No. The SAS Server has been configured to support only software client
applications associated with SAS OnDemand for Academics.

O Ireceived an error message when trying to create a folder on the SAS Server.
What's wrong?
You may receive an error message such as this:

“A call to the metadata repository failed. See details for more information.”
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In this case, it's likely that you were trying to create a folder on the SAS Server.
This behavior is not currently supported because it is not possible to save your
work on the SAS Server. Instead, please save any work to a local folder. When
prompted to save your work, select Local Computer instead of SAS Servers and
then select the appropriate local directory.

General Support

a

What should I do if I forget my password?

You need to use a password to log on to SAS OnDemand for Academics or to
connect to the SAS Server (SAS Cloud) when prompted by SAS OnDemand for
Academics: Enterprise Guide. In all cases, your password is the same as your SAS
Profile password. If you have forgotten your SAS Profile password, then follow
these steps:

Use the My Profile page to update your SAS Profile password:
(https://www.sas.com/profile/user/login.htm) .

Note: Your password must meet the following criteria:

a. It cannot be the name that you used to register or exceed two consecutive
characters from that name. For example, if you registered as 'Jonathan Smith',
you could not use either 'Jonathan' or 'Smith' and you could not include three
consecutive characters such as 'jon' or 'ith'.

b. It must be at least eight characters in length.
c. It must contain characters from three of the following four categories:
Q English uppercase characters (A through Z)
O English lowercase characters (a through z)
Q Base 10 digits (0 through 9)
0 Non-alphabetic characters (for example, !, $, #, %)

Access SAS OnDemand for Academics.

Enter your e-mail address and use your updated SAS Profile password when you
are prompted to enter a password.

When appropriate, use your updated SAS Profile password (along with your SAS
Server User ID) to log on to a SAS OnDemand for Academics software application.
Q IfI have trouble with my software, how do I get support?
Please refer to the information in this manual under “Step 8. Help for
Common Problems” for the software being used in your course.
O When will my SAS OnDemand for Academics license expire?
SAS OnDemand for Academics student licenses are good for the duration of
the registered course (plus a short grace period to ensure that students can
complete assignments).
Q How can I check my account status?
To determine the status of your SAS OnDemand for Academics account, do the
following:
1  Access SAS OnDemand for Academics Control Center
(http://support.sas.com/ctx3/sodareg/index.html)
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2 Enter your e-mail address and your SAS Profile password and then click
Enter.

3 Review the Status Indicator at the top of your SAS OnDemand for
Academics home page. Your status will be one of the following values:

O Active - You are a current user and your account is working properly.

0 Pending - You have a user ID, but it is not yet active. If you are a
student, your status will change to Active after you registered for a
course license.

If you have completed registration steps (including creating a course if
you are an instructor or registering for a course license if you are a
student) and you still see a status of Pending, then log out of the SAS
OnDemand for Academics Control Center and then log back in. Repeat
this step until your status changes to Active.

0 Password Expired - Your SAS Profile password has expired.

O Disabled - Your account has expired or the SAS Administrator has
turned off your license in accordance with the terms of the legal
agreement. If your account has expired, you can enable your account
again by registering for another SAS OnDemand for Academics course
(if your instructor chooses to teach a course with SAS OnDemand for
Academics).
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Learning Resources for SAS OnDemand for Academics

This appendix lists resources that are available for instructors and students on
http://support.sas.com. Some resources are offered at no cost; others are available for
purchase only.

Note: If any of the supporting materials identified in this appendix are not inherently
accessible and you require an accessible format, please send e-mail to
ondemandacademics@sas.com. SAS will work with you to provide an accessible
format.

Training and Usage Videos

SAS has designed following videos have been designed to help you learn more about SAS
OnDemand for Academics or to help you learn how to perform tasks quickly. The titles
listed below are available at no cost at http:/support.sas.com/ondemand/videos.html.

Professors
Registering for SAS OnDemand for Academics: For Professors

Creating a course for SAS OnDemand for Academics: For Professors
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Uploading SAS Data Sets to the SAS Servers using FTP: For Professors
Using a LIBNAME Statement: For Professors

Students

Registering for SAS OnDemand for Academics: For Students
Using a LIBNAME Statement: For Students

Using a FILENAME Statement: For Students

e-Learning Courses

SAS provides many e-Learning courses (e-Courses) to help you learn how to use our
software. The following e-Courses have been specifically designed to work with SAS
OnDemand for Academics:

SAS Programming 1: Essentials

SAS Programming 2: Data Manipulation Techniques

SAS Programming 3: Advanced Techniques and Efficiencies

SAS Macro Language 1: Essentials

SAS SQL 1: Essentials

SAS Enterprise Guide 1: Querying and Reporting

SAS Enterprise Guide: ANOVA, Regression, and Logistic Regression
O Applied Analytics Using SAS Enterprise Miner

O0000D0DD

If you are a student, review the Academic Discounts site for promotional information or
ask your customer representative for details. Students are eligible to receive 50% off any
of the e-Courses that have been designed to work with SAS OnDemand for Academics
software.

To purchase any of the e-Learning courses mentioned, you can:
Q order online from SAS e-Learning
(http://support.sas.com/training/elearn/index.html)
Q call toll free at 1-800-333-7660

O access the training registration form
(http://support.sas.com/training/us/regform.pdf)

Teaching materials

For a list of available teaching materials from SAS, visit SAS Global Academics Web site
at the following location: http:/support.sas.com/learn/ap/tkit/.
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Enterprise Guide resources

The following training and reference materials for SAS OnDemand for Academics:
Enterprise Guide are available at no cost:

Tutorial

If you are new to SAS Enterprise Guide or want to learn more about using SAS
Enterprise Guide, you will find the free Getting Started tutorial helpful. As you
complete the topics in this tutorial, you will learn to use the main features of SAS
Enterprise Guide.

After you have completed your registration and downloaded the software, you can access
this online tutorial by doing the following:
O Select Start » Programs » SAS » Enterprise Guide 4.2 OnDemand. The
Credentials Required window opens.

0 Enter your SAS Server user ID. You can find this user ID on your SAS OnDemand
for Academics home page.

0O Enter the password associated with your SAS Profile account.

O Select OK. The SAS Enterprise Guide window opens. You are now logged on to
the SAS Server.

O Select Tutorial: Getting Started with SAS Enterprise Guide from the
Welcome to SAS Enterprise Guide window.

Online SAS Enterprise Guide Demonstration

To see SAS Enterprise Guide in action, visit the following Web site:
http://www.sas.com/govedu/edu/egdemo/itour_flash.html

Online Practice Exercises, Statistics Information, and Sample SAS Data Sets

For instructions about how to perform all of the basic statistics taught in an
introductory statistics class, a library of SAS data sets and a library of practice
exercises, visit the SAS Online Resources for Statistics Education site at
http://support.sas.com/learn/statlibrary/.

Product Documentation

SAS Enterprise Guide online documentation is available from the Product
Documentation area on http://support.sas.com/documentation/.

Books

A number of books from SAS Publishing are available for SAS Enterprise Guide. You
can use the SAS Bookstore Web site (http:/support.sas.com/publishing/) to find the
books, review portions of each book, and place orders. You use the site’s search feature
to locate topics or products of interest such as for Enterprise Guide or Base SAS.
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White Papers

You can access the following titles by visiting the locations provided below:

QO A SAS Programmer’s Guide to SAS Enterprise Guide
http://supportexp.unx.sas.com/ondemand/pdf/SGF07_EG_for_Programmers.pdf

0 Dynamic Projects in SAS Enterprise Guide - How to Create and Use Parameters
http://supportexp.unx.sas.com/ondemand/pdf/SGF07_Parameters_in_EG.pdf

O Introduction to SAS Enterprise Guide 4.1 for Statistical Analysis
http://supportexp.unx.sas.com/ondemand/pdf/SUGI31_EGuide4-10verview.pdf

Enterprise Miner resources

Product Documentation

To access product documentation, sample data, and more, go to SAS Enterprise Miner
from the Product Documentation area at http:/support.sas.com/documentation/.

Books

A number of books from SAS Publishing are available for SAS Enterprise Miner. You
can use the SAS Bookstore Web site (http:/support.sas.com/publishing/) to find the
books, review portions of each book, and place orders. You use the site’s search feature
to locate topics or products of interest such as for Enterprise Miner or data mining.

Forecast Server resources

Product Documentation

To access product documentation, sample data, and more, go to SAS Forecast Server on
the Product Documentation area at http:/support.sas.com/documentation/.

Books

A number of books from SAS Publishing are available for SAS Forecast Server. You can
use the SAS Bookstore Web site (http:/support.sas.com/publishing/) to find the books,
review portions of each book, and place orders. You use the site’s search feature to
locate topics or products of interest such as for Forecast Server or forecasting.
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SAS OnDemand for Academics with JMP Software

If you have purchased and installed JMP software (Version 8 or 9) in the United States,
then you can use JMP to connect to the hosted SAS servers that are used by SAS
OnDemand for Academics. This will enable you to integrate JMP and SAS together.
To integrate with SAS using this method, you must:

O register to use SAS OnDemand for Academics

0O download sas.rutil.jar file and place it in the appropriate directory

O create a SAS server profile within JMP

O connect to the SAS server from JMP.

Step One:

Registering to use SAS OnDemand for Academics

This step needs to be performed only once.

If you are a student, perform the following steps. Note that your instructor must have
registered a course before you can register.

1 Access SAS OnDemand for Academics.

2 Register as a student. Select the appropriate university and the course that is
associated with your instructor.

During the registration process, a user ID and password will be created for you.

Step Two:

Downloading and installing the sas.rutil.jar file

For JMP to work properly with the SAS OnDemand for Academics hosted servers, you
must have the sas.rutil.jar file. This file is export controlled. It can only be used within
the United States by United States citizens or legal residents of the United States. The
file may not be shared with any party to whom the United States prohibits access to the
file.
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Download the file from the Jar File Download Page at this location:
http://support.sas.com/demosdownloads/sysdep_t1.jsp?packageID=000747

Place the file in the appropriate location.

Q Ifyou are using a PC with the Microsoft Windows operating system, place the
jar file in the following location:

C:\Program Files\SAS\JMP\9\Jjmptojava\l9.2

(If your computer's hard drive is not labeled as 'C', then replace C with the
appropriate letter)

O Ifyou are using a Macintosh PC, then do the following:

Navigate to the Applications folder.

Press Control and then click on JMP 8 or JMP 9.

Select Show Package Contents » Contents » Frameworks » jmptojava b 9.2
» jars. Place the jar file in this location.

Step Three: Creating a SAS Server Profile within JMP

This step needs to be performed only once.

1
2
3

0o N o o

9

Start JMP.
Select File » SAS » Server Connections.

In the SAS Server Connections window, select 9.2 from the SAS Server Version
drop down field.

In the SAS Server Connections window, click Metadata Server Profiles to open
the Manage Metadata Server Profiles window.

Click Add. Enter a profile name and description.
In the Machine field, enter sas92cloud.sas.com
In the Port field, enter 18561

In the User name field, enter your SAS Server user ID. This user ID is also
displayed on your SAS OnDemand for Academics home page.

In the Password field, enter your SAS Profile password.

10 In the Authentication Domain field, enter DefaultAuth.
11 Click Save.

Step Four: Connecting to the SAS Server using JMP

This step should be performed any time that you want to connect to hosted SAS servers.

1
2
3

Start JMP.
Select File » SAS » Server Connections.

In the SAS Server Connections window, click Metadata Server Profiles to open
the Manage Metadata Server Profiles window.

Click the name of the profile that you created for the SAS server.
Click Connect.
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Note: To disconnect from the SAS Server, return to the Manage Metadata Server
Profiles window and click Disconnect.
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