Introduction to SAS Simulation Studio
Chapter 3
Introduction to SAS Simulation Studio

Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Simulation Studio Graphical User Interface</td>
<td>19</td>
</tr>
<tr>
<td>Installing and Starting Simulation Studio</td>
<td>20</td>
</tr>
<tr>
<td>Installing Simulation Studio</td>
<td>20</td>
</tr>
<tr>
<td>Starting Simulation Studio</td>
<td>21</td>
</tr>
<tr>
<td>Configuring Simulation Studio</td>
<td>21</td>
</tr>
<tr>
<td>Launching Local SAS and JMP Servers</td>
<td>22</td>
</tr>
<tr>
<td>Using a Remote SAS Server</td>
<td>23</td>
</tr>
<tr>
<td>Simulation Studio Menu and Toolbar</td>
<td>24</td>
</tr>
<tr>
<td>Block Template Display Area</td>
<td>25</td>
</tr>
<tr>
<td>Simulation Studio Projects</td>
<td>26</td>
</tr>
<tr>
<td>Project Explorer</td>
<td>26</td>
</tr>
<tr>
<td>Project Window</td>
<td>27</td>
</tr>
<tr>
<td>Log, Trace, and Animation Tabs</td>
<td>30</td>
</tr>
<tr>
<td>Project Status Bar</td>
<td>30</td>
</tr>
</tbody>
</table>

Simulation Studio Graphical User Interface

As mentioned in Chapter 2, “Overview of SAS Simulation Studio,” Simulation Studio provides a graphical user interface (GUI) and a batch interface. Initially, most users typically use the Simulation Studio GUI to build and execute simulation models. This chapter provides a high-level overview of Simulation Studio from the GUI perspective and discusses the major components of the application framework. The batch interface is detailed in Chapter 13, “Batch Execution.”
When you start the Simulation Studio application, the graphical user interface opens on your computer screen as shown in Figure 3.1. This window consists of six main areas: menu, toolbar, block template display area, project explorer, project desktop, and project status bar. The following sections provide details about each of these areas, as well as how to launch the application.

---

**Installing and Starting Simulation Studio**

### Installing Simulation Studio

The installation program for Simulation Studio asks where you want to install the software on your computer. The default location is `\Program Files\SASHome\SASSimulationStudio\14.1`. If you choose the default location, the installation software loads the software and adds an entry for Simulation Studio to the **Start** menu.
Simulation Studio requires you to have a valid version of SAS/OR software installed on your computer. It also needs to know the location of SASHome on your system. This information is part of the Simulation Studio configuration data and must be supplied to Simulation Studio for the application to launch.

Starting Simulation Studio

To start Simulation Studio, you can either double-click the Simulation Studio desktop icon or select the Simulation Studio entry from the Start menu (Start ► Programs ► SAS ► Simulation Studio 14.1.)

Configuring Simulation Studio

When you attempt to launch the Simulation Studio application for the first time, it has not yet acquired all of the configuration data it needs. The message “SAS Simulation Studio configuration data not specified” appears because at this point Simulation Studio does not know where to look for SAS license information on your machine. Then Simulation Studio displays the SAS Simulation Studio Configuration dialog box for you to enter the necessary information. (See Figure 3.2.) In the box SASHOME Path, enter the directory for SASHome. A common default path for this location is \Program Files \SASHome. To open the SAS Simulation Studio Configuration dialog box after the initial launch, you select Tools ► Configuration from the main Simulation Studio menu.

Figure 3.2 Configuration Dialog Box
If you have both SAS and JMP software installed, you can select either SAS Data Set or JMP Data Table for your default data format. (This format information is used for reading and writing data when the filename extension is not provided with an input or output filename.)

SAS Simulation Studio communicates with SAS Workspace Servers to process the input and output requests of SAS data sets in data streaming and collecting blocks, such as the Numeric Source and Bucket blocks. It also supports the submission of SAS programs to the SAS Workspace Servers from the SAS Program block. Currently, you can use up to two SAS Workspace Servers:

- One server can reside on the local machine where Simulation Studio is installed and running.
- Another SAS server can be on a remote machine and used as a remote server.

**Note:** In the SAS Simulation Studio Configuration dialog box (shown in Figure 3.2), the only required field is the SASHOME Path. The remote and local SAS Workspace Server fields are optional. For information about configuring and using the local and remote SAS servers, see the sections “Launching Local SAS and JMP Servers” on page 22 and “Using a Remote SAS Server” on page 23.

When you run a Simulation Studio model on a multicore machine by selecting the Parallel Mode option from the Run menu, different design points and replications are distributed on different cores simultaneously. The actual distribution of design points and replications depends on the number of cores available and the total number of design points and replications that are selected to run. You can select Preferred Number of Threads to Use for Parallel Run Mode to specify the number of threads to use in parallel mode. The maximum value is machine-dependent, the minimum value is 2, and the default is less than the actual number of cores. If the machine is not multicore, then the Preferred Number of Threads to Use for Parallel Run Mode option is not available. For more information about using the Parallel Mode option, see the section “Running a Model in Parallel Mode” on page 38 in Chapter 4, “Simulation Models.”

---

**Launching Local SAS and JMP Servers**

If you want to read or save data, submit SAS code, or interact with JMP software locally during a Simulation Studio session, you need to have a SAS Workspace server or JMP server running locally on your computer.

Simulation Studio provides two different methods for connecting to a local SAS Workspace Server. First, you can use the default local workspace server that is launched when Simulation Studio requires it. This default local workspace server does not require configuration or credentials and is also available when running in batch mode. No action is required to use the default local SAS Workspace Server in either interactive or batch mode. **Note:** In releases of Simulation Studio prior to 14.1, you had to launch the local SAS server manually using the SAS_Sim_Server.bat file. This step is no longer required.

As an alternative, you have the option to connect to the SAS Simulation Studio Object Spawner for SAS services using credentialing. To use this approach, you specify a port number in the Local SAS Workspace Server section of the SAS Simulation Studio Configuration dialog box (shown in Figure 3.2). You also are required to provide local credentials in the User Credentials for SAS Workspace Server dialog box, which you can open by selecting Tools>Server Credentials from the main Simulation Studio menu. Once you enter a port number for the local SAS Workspace Server, SAS Simulation Studio will no longer use its default local SAS Workspace Server.

The Configure SAS Simulation Studio step of the SAS Simulation Studio install process provides the default port number 58591 for you to use to connect to the SAS Simulation Studio Object Spawner for SAS.
services. If you chose to skip the **Configure SAS Simulation Studio** step during the installation process, then you will not be able to connect to the SAS Simulation Studio Object Spawner for SAS services.

**NOTE:** If you are using the the SAS Simulation Studio Object Spawner for SAS services and want to run Simulation Studio in batch mode, then you must first launch Simulation Studio, provide the local port number and your local credentials and then leave Simulation Studio open.

The local JMP server must be launched manually. The server script is installed in the `launchSASServer` directory under your Simulation Studio installation directory. To launch the Simulation Studio JMP server, you open and run the JMP script file named `JMP_Sim_Server.JSL`. If you double-click the file `JMP_Sim_Server.JSL`, the encrypted script file will open in JMP. You then right-click in the JMP script window and select **Run Script**. You can minimize the JMP window, but it must remain open for Simulation Studio to communicate with JMP.

---

**Using a Remote SAS Server**

In the Remote SAS Workspace Server section of the SAS Simulation Studio Configuration dialog box (shown in Figure 3.2), you use the **Host Name** field to specify either the host name or the Internet Protocol (IP) address of the remote server. In the **Port Number** field, specify the TCP/IP port number for the remote SAS Workspace Server session on the remote server. Simulation Studio uses this port number to access the services provided by the remote SAS Workspace Server. Select either **Unix** or **Windows** for the **Host System Type** of the remote server. In the **Default File Path** field, specify the default file input and output root directory or folder path for the data input and output requests. Use the appropriate UNIX or Windows path format convention when specifying the path and make it consistent with the specified **Host System Type** of the remote server.

All data streaming blocks, such as the Numeric Source and Observation Source blocks, have the option **Load From Remote SAS Workspace Server**. When this option is checked, data are read from the specified location on the remote SAS workspace server. All data collecting blocks, such as the Number Holder and Bucket blocks, have the option **Submit to Remote SAS Workspace Server**. Selecting this option saves any collected data to a location on a remote SAS workspace server. The option **Submit to Remote SAS Workspace Server** is also available in the SAS Program block. When this option is checked, the specified SAS program on the local machine is executed on the remote SAS workspace server. You specify the remote SAS workspace server information in the SAS Simulation Studio Configuration dialog, available from the **Tools** menu. See Figure 3.2.

The options **Submit to Remote SAS Workspace Server** and **Load From Remote SAS Workspace Server** can be set in the block properties dialog box for a specific block. Also, right-clicking on a model name in the Project Explorer and choosing the option **Remote Service Host** opens a dialog box where you can select the blocks in the model for which the **Submit to Remote SAS Workspace Server** and **Load From Remote SAS Workspace Server** options should be checked. If any block in a model has either of these options checked, then you also are required to provide the necessary credentials to access the remote SAS Workspace server. You select **Tools**►**Server Credentials** from the main Simulation Studio menu to open the User Credentials for SAS Workspace Server dialog box. If you are running in batch mode and using a remote SAS Workspace Server, then you must first launch Simulation Studio, provide your remote host credentials and then leave Simulation Studio open.
Simulation Studio Menu and Toolbar

The main Simulation Studio menu consists of six items: **File**, **Template**, **Run**, **Analyze**, **Tools**, and **Help**. Use the **File** menu (shown in Figure 3.3) to open, create, close, and save projects, models, and experiments in Simulation Studio. When you open or create a new project, Simulation Studio opens a new project window in the Project Desktop area of the GUI and updates the Project Explorer accordingly. If this is a new project, a new (empty) model and experiment are also created. When an existing project is opened, all models and experiments in that project are opened and entries are created for them in the Project Explorer.

**Figure 3.3** File Menu

![File Menu](image)

A Simulation Studio template stores information about a collection of Simulation Studio blocks. Template details are provided in Chapter 11, “Block Templates.” Use the **Template** menu to open, create, close, and save Simulation Studio templates. Opening a template adds the template name to the Template list box in the Block Template Display area of the application. You can use this list box to determine which template palette is visible in the Block Template Display area of the application. Select **Template** > **Close** to remove the current template name from the Template list box and also remove the associated blocks from the Template palette. Select **Save** or **SaveAs** to save the current template to disk storage. More details about templates are provided in Chapter 11, “Block Templates.”

The **Run** menu (Figure 3.4) controls the model execution and animation. Many of the controls are also found on the toolbar. The functionality that is associated with the model execution controls **Start**, **Augment**, **Pause**, **Reset**, and **Parallel Mode** is discussed in Chapter 4, “Simulation Models.” Select **Show** to enable or disable the simulation clock, replication count, or animation for the current model. When visible, the simulation clock and replication count appear in the upper right corner of an individual Project window.
To access the JMP distribution-fitting platform, select Analyze ► Fit Distribution. To open the configuration dialog box (Figure 3.2), select Tools ► Configuration. You can use the Help menu to access online documentation for Simulation Studio and SAS Technical Support.

The toolbar (Figure 3.5) provides quick access to most of the functionality on the Run menu. The animation icon acts as a toggle switch for turning execution animation on and off. The parallel mode icon acts as a toggle switch for turning parallel mode on and off. The remaining toolbar buttons are discussed in Chapter 4, “Simulation Models.”

The Block Template Display area (Figure 3.6) consists of two components. The Template list box contains the names of all the templates currently loaded into Simulation Studio. The selection displayed in the Template list box represents the currently active template. In Figure 3.6 the template labeled Standard is active. The area immediately below the list box, called the Template Palette area, displays the templates for the individual blocks contained in the currently active template.

You can change the format of the displayed items in the Template Palette area by using the pop-up menu available on the Block Template Display area background. Display options include Large Icons, Small Icons, List, Text Only, and Icons Only. You can also use this pop-up menu to view specific information about an individual block. Selecting Block Info from the pop-up menu opens a dialog box to display information about the corresponding block. This information includes the block name, class path, icon, and tooltip associated with the block. Menu options are also available via the pop-up menu to remove blocks from and import blocks to the template.

When you rest the pointer on an individual block icon in the Template Palette, a tooltip appears that contains a brief description of the block. The Template Palette area is your source for blocks when you are using...
the Simulation Studio GUI to build your simulation model. To add blocks to your simulation model, drag template icons from the Template Palette into a Model window. This process creates an instance of the associated block in your model. Templates are discussed in detail in Chapter 11, “Block Templates.”

**Figure 3.6 Template Display Area**

---

**Simulation Studio Projects**

A project in Simulation Studio (ideally) contains models and experiments that are in some way associated with each other and helps to provide organizational structure to all of your models and experiments. A project must contain at least one model and experiment, but there is no limit to how many models and experiments can be in a project. Any number of projects can be loaded into Simulation Studio at one time. In addition to organizing models and experiments, projects provide storage for factor and response definitions that can be shared across models and experiments in that project. Factors and responses are discussed in Chapter 5, “Experiments.”

---

**Project Explorer**

The Project Explorer (located on the top left side of the GUI in Figure 3.1) uses a tree structure to display the projects, associated models, and experiments that are currently loaded into the application. **Figure 3.7** shows a Project Explorer with two projects loaded: crane and repairshopDOE, each with one model and one experiment.
Selecting a project, model, or experiment name listed in the Project Explorer hierarchy causes the windows associated with that item to activate and pop to the top in the Project window. The activated model and experiment names are shown in **bold**. Up to one model and one experiment in a project can be activated.

Context-sensitive pop-up menus are available on the items displayed in the Project Explorer. You can right-click a project to open a dialog box to edit factors and responses associated with the project and also to change the base directory location where any simulation results are stored. You can right-click a model to open the Anchors dialog box to associate block parameters in a model to project factors and responses and also to set flags in blocks for automatically saving results. You can right-click an experiment to open a dialog box to include factors and responses. Factors, responses, and anchors are detailed in Chapter 5, “Experiments.”

---

**Project Window**

Each project loaded into Simulation Studio has a Project window associated with it in the Project Desktop area of the GUI. A newly created Project window is displayed in Figure 3.8. Each Project window has a desktop area at the top and a tabbed window at the bottom. The Project Desktop area contains any Model windows and Experiment windows associated with the project. When a new Project window is first created, it has one (empty) Model window, one Experiment window, and at the bottom of the frame, **Log**, **Trace**, and **Animation** tabs. Project windows can be minimized as needed using controls on the Project window frame. To open the Factor and Response definition dialog boxes, right-click on the background of a Project window frame. See Chapter 5, “Experiments,” for details about factors and responses.
Model Window

Each model in a project has a Model window associated with it. You use this window to graphically construct and display a simulation model. You drag a block from the Template Palette into a Model window to create an instance of the block associated with that template in your model. You connect the blocks in your model by creating links between ports on the various blocks. You can right-click or double-click an individual block to open a dialog box where you can modify parameters associated with the block. Interacting with blocks and models is discussed in detail in Chapter 4, “Simulation Models.” Closing a Model window deletes the window and removes the model entry from the Project Explorer. **Note:** Modified models are not automatically saved upon closing. You will however be prompted and asked whether you want to save the model before it is closed. Figure 3.9 displays a sample Model window that contains a simple M/M/1 model.
You use Experiment windows to control the initialization and running of simulation models. Each experiment in a project has an Experiment window in the Project window. By default, each Experiment window contains columns for controlling the start and end times of a simulation run (or design point) along with a column for designating how many times you want to repeat this run. An experiment must have at least one design point in order to run an associated simulation model.

You can use an Experiment window to control initialization of block parameters before running a simulation model. Any factor or response defined on the project can be included in an experiment. Using this and other features of experiments is discussed in Chapter 5, “Experiments.”

As with a Model window, closing an Experiment window deletes the window and removes the experiment entry from the Project Explorer. Figure 3.10 shows a sample Experiment window including a factor labeled maxentities and a response labeled Number Serviced. To modify the content of an Experiment window, right-click on the background of the Experiment window and select the appropriate item from the pop-up menu.
Log, Trace, and Animation Tabs

Each Project window also contains a Log, Trace, and Animation window in a tabbed format along the bottom of the Project window frame. (See Figure 3.8.) The Log tab displays log messages from either the currently running or most recently run model. Each log message has a Severity Level associated with it along with the source and simulation time of the message. If you click on a message in the log, the block in the model that generated the message will be highlighted.

The Tracer feature must be enabled for trace messages to appear in the Trace tab. You enable the Tracer feature by using a pop-up menu available on the Trace tab background. Trace messages are generated by individual blocks during the execution of a model and are intended to provide details about events and execution flow within the blocks.

The Animation tab provides options for controlling the simulation animation as a model runs. You can enable animation for different regions of the model, as well as adjust the animation speed, start time, and end time for each selected region.

Additional details about the log, trace, and animation facilities in Simulation Studio are provided in Chapter 10, “Model Debugging and Verification.”

Project Status Bar

The Project Status bar, located at the bottom of the GUI, displays the path name of the currently active project.