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The ISHIKAWA Procedure

Contents

OVEIVIEW . . . o oot e e e e 704
Terminology . . . . . . . . L e e e e e 705
Getting Started: ISHIKAWA Procedure . . . . . . .. ... ... ... ... ........ 707
Syntax: ISHIKAWA Procedure . . . . . . . . . . . .. .. 716
Details: ISHIKAWA Procedure . . . . . . . ... ... ... .. 716
Summary of Operations . . . . . . . . . . . ... e 717
Operations . . . . . . v . v it e e e e 720
Adding Atrows . . ... 720

Labeling Arrows . . . . . . . .. 724

Moving ATTOWS . . . .« o o i e e e 727

Deleting AITowS . . . . . . ..o e e 733

Resizing Arrows . . . . . . . L 736

Swapping AITOWS . . . .« o vt e e e 738

Balancing Arrows . . . . . . ..o 741

Notepads . . . . . . . o e e e 748

Managing Complexity . . . . . . ... .. L 750

Z00ming AITOWS . . . . . . v v it e e e e e 752

Isolating Arrows . . . . . . . .. e e e 753

Merging Diagrams . . . . . .. ... Lo 755

Creating Graphics Output Using SAS/GRAPH Software . . . . . ... ... 758

Creating Bitmap Graphics Output . . . . . . .. .. ... ... ... .... 761

Modifying Fonts . . . . . . ... ... 763

Modifying Box Colors . . . . . . . . . ... .. 764

Modifying Arrow Colors and Line Styles . . . . .. ... ... ... .... 765

Modifying Text Colors . . . . . . . . . . . . . . 772

Modifying Arrow Heads . . . . . . . . ... ... L 774

Modifying Environmental Attributes . . . . . . . .. ... L. 775

Saving an Ishikawa Diagram for Future Editing . . . . . .. ... ... ... 776

Reading an Existing Ishikawa Diagram . . . . . .. .. ... ... ... .. 777

Displaying Multiple Ishikawa Diagrams . . . . . . ... ... .. ... ... 778

Inputand Output Data Sets . . . . . . . . . . . . . e 781
Examples: ISHIKAWA Procedure . . . . . . ... .. ... ... ... ... ........ 783
Example 9.1: Quality of Air Travel Service . . ... ... ... ....... 783

Example 9.2: Integrated Circuit Failures . . . . . . ... ... ... ..... 784

Example 9.3: Photographic Development Process . . . . . . ... ... ... 785

References . . . . . . . . e 785




704 4 Chapter 9: The ISHIKAWA Procedure

Overview: ISHIKAWA Procedure

The Ishikawa diagram, also known as a cause-and-effect diagram or fishbone diagram, is one of the seven
basic tools for quality improvement in Japanese industry.! It is used to display the factors that affect a
particular quality characteristic or problem. For example, the Ishikawa diagram in Figure 9.1 shows factors
affecting the quality of air travel service.

Figure 9.1 Ishikawa Diagram
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In this example, the factors are organized into three categories of service (Pre-flight, In-flight, and Post-flight),
which are represented as branches. The factors affecting each of these areas are represented as stems.

An Ishikawa diagram is typically the result of a brainstorming session to improve a product, process, or
service. The main goal is represented by a main arrow or trunk, and primary factors are represented as
sub-arrows or branches. Secondary factors are then added as stems, tertiary factors as leaves, and so on.

Creating the diagram stimulates discussion and often leads to an increased understanding of a complex
problem. Japanese QC Circle members often post Ishikawa diagrams in a display area where they will be
accessible to managers and other groups; refer to Rodriguez (1991). In the United States, Ishikawa diagrams
are often included in presentations by plant personnel to management or customers.

Traditionally, Ishikawa diagrams have been prepared by hand on paper or chalk boards. This limits the
amount of detail that can be added and makes it awkward to update the diagram as an understanding of
the process evolves. Manual preparation also restricts the collection and display of data on the diagram, as
advocated by Ishikawa (1982).

The ISHIKAWA procedure was designed to overcome these limitations by providing a highly interactive
graphics environment (referred to in this section as the ISHIKAWA environment) for creating and modifying
Ishikawa diagrams.

IThe Ishikawa diagram is named after its developer, Kaoru Ishikawa (1915-1989), a leader in Japanese quality control; see
Karabatsos (1989), Kume (1985), and Sarazen (1990).
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In the ISHIKAWA environment, you can do the following:

e add and delete arrows with a mouse. You can also swap, copy, and so forth.
e highlight special problems or critical paths with line styles and color
e display additional data for each of the arrows in a popup notepad

e display portions of the diagram in separate windows for increasing or isolating detail. You can also
divide sections of the diagram into separate Ishikawa diagrams.

e merge multiple Ishikawa diagrams into a single, master diagram
e display any number of arrows and up to ten levels of detail
o foliate and defoliate diagrams dynamically
e save diagrams for future editing
e save diagrams in graphics catalogs or export them to host clipboards or graphics files
e customize graphical features such as fonts, arrow types, and box styles
e obtain online help at any time
If you are using the ISHIKAWA procedure for the first time, the tutorial at the end of this chapter demonstrates

some of the basic operations used in the ISHIKAWA procedure. A summary of these operations (and others)
can be found in the section “Summary of Operations” on page 717.

For a detailed discussion of each of the operations, see “Details: ISHIKAWA Procedure” on page 716. This
chapter includes many tools not presented in the tutorial.

Terminology

This section introduces basic operations used in the ISHIKAWA environment and defines terms used to
describe the ISHIKAWA procedure. Some details depend on your host, which is the specific system of
computing hardware and software you use. For example, all hosts present the ISHIKAWA environment in a
system of windows on the host’s display, but the appearance of your windows may differ from the figures
in this book. You can find more information in the SAS companion for your host and in your host system
documentation.

Using a Mouse

On most hosts you can use a mouse to point to objects on the display. A mouse is a physical device that
controls the location of a cursor, which is a small, movable symbol on the display. Due to the precision
required, you must use a mouse to perform tasks in the ISHIKAWA environment.

Text is placed relative to the fext cursor and not the mouse cursor ( \_). The mouse cursor is always visible,
while the text cursor is displayed only when text can be entered (for example, when an arrow is being added).

The mouse also has buttons that work like keys on the keyboard. On most hosts, you select an object by
pointing to it with the mouse and clicking the left button on the mouse. To click, press the button down and
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release it quickly without moving the mouse. To double click, click twice quickly without moving the mouse.
To drag, move the mouse while holding down the left mouse button.

Popup menus appear to pop up on the display when you press a button—usually the right mouse button.
Popup menus are convenient to use, since they always appear at the cursor location. Selecting an item from
the popup menu, however, is host specific.

For details about using the mouse on your system, consult the SAS companion for your host.

Using Context-Sensitive Operations

Basic operations such as add, edit, delete, and move are invoked by activating the mouse near various
hotspots along the arrows rather than selecting tools from a tools palette. The hotspots are the following
context-sensitive areas in the Ishikawa diagram:

e arrow heads, tails, lines, and labels

e window background
Given such evident features, and a rigidly defined structure, the hotspots are not highlighted.
The hotspot areas are illustrated in Figure 9.2.

Figure 9.2 Context-Sensitive Locations (Hotspots)
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The dotted, circular region at the right end of the arrow is the arrow head hotspot. Arrows attach to other
arrows at the head of the arrow. The dotted, circular region at the left end of the arrow is the arrow tail hotspot.
The region that encompasses the arrow line is also hot. Every arrow in the diagram has these hotspots.

The window background is any area inside the window and outside the dotted lines. You use the window
background to cancel pending operations (such as adds and moves) and to control global or environment-
specific operations (such as decreasing detail and tagging arrows).

When you activate the mouse, the ISHIKAWA environment uses the mouse event (click, double click, drag,
or popup) and the hotspot type (head, tail, line, label, or background) to infer the intended operation. The
ISHIKAWA environment responds differently depending upon which hotspot you select and how you select
it. This is often referred to as context-sensitive behavior.
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Context sensitivity allows the ISHIKAWA environment to operate without modes. In a modeless environment
like the ISHIKAWA environment, context-sensitive operations reduce the amount of mouse travel (the time
and distance spent moving the cursor from the drawing area to the tools palette and back). For example, you
do not go to a tools palette to change from add mode to delete mode. This allows you to focus on the diagram
rather than on the diagramming tool.

In the ISHIKAWA environment, the primary operations such as add, edit, delete, and move are all operations
associated with a specific hotspot and the mouse button. Secondary operations such as zoom, copy, highlight,
and so forth operate from context-sensitive popup menus (typically activated using the right mouse button.)
Other, less frequently used operations are available from the command bar.

The relationship between these context-sensitive areas, the mouse actions, and the basic ISHIKAWA
tools is introduced in the tutorial that follows. A comprehensive discussion of each operation
is given in “Details: ISHIKAWA Procedure” on page 716. In addition, the tables in the section
“Summary of Operations” on page 717 provide a good overview of how to function inside the ISHIKAWA
environment.

Using the Command Bar

In addition to the editing tools, the ISHIKAWA environment provides a number of file management, printing,
and help facilities. These facilities are located on the pull-down menu associated with the window. The
appearance and location of the command bar are host specific. On most hosts, you choose these operations
by pulling down a menu from a menu bar using the mouse button. For more details about using the command
bar on your system, consult the SAS companion for your host.

Getting Started: ISHIKAWA Procedure

NOTE: See Airline Data in the SAS/QC Sample Library.

The following example is used throughout the ISHIKAWA chapters. Later examples illustrate how to add to
and modify this diagram. If you are not familiar with the ISHIKAWA procedure, you may want to complete
this tutorial before proceeding to “Details: ISHIKAWA Procedure” on page 716. In this tutorial you will
learn to create and save a simple Ishikawa diagram.

A task force is studying ways to improve the quality of passenger service for a major airline. After a
preliminary discussion, the team concludes that three major areas should be considered: pre-flight service,
in-flight service, and post-flight service. This result is to be displayed with the preliminary Ishikawa diagram
in Figure 9.3.
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Figure 9.3 Preliminary Ishikawa Diagram
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1. To begin using the ISHIKAWA environment, submit the following SAS statements:
proc ishikawa;
run;

An initial menu appears on your display, as shown in Figure 9.4.

Figure 9.4 Initial Menu

lzhikawa Procedure |

Edit an Existing Ishikawa Diagram

Help

Quit




Getting Started: ISHIKAWA Procedure 4 709

2. Select Create a New Ishikawa Diagram to open a window containing a template for a new Ishikawa
diagram, as shown in Figure 9.5.

Figure 9.5 Starting a New Ishikawa Diagram
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The ISHIKAWA environment guides you through the first steps of the diagramming process by prompting you
to enter the text for the central line and then the upper left branch. During each step, a message indicating the

action required is displayed in the message area for this window. Once you have completed these preliminary
steps, you can proceed in any order you want.
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3. Initially, the text cursor is positioned inside the box for the trunk. A message is displayed directing you to
enter the first line of text for the trunk. Type the word Quality, as shown in Figure 9.6.>

Figure 9.6 Labeling the Trunk
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Note that the text is placed relative to the text cursor. You can correct mistakes by using any of the keyboard
editing keys or cursor navigation keys (for instance, BACK SPACE and <-).

2You can skip this step, in future diagrams, by pressing RETURN before entering any text.
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4. Advance to the next line by pressing RETURN. Now complete the label as shown in Figure 9.7 by entering
Air Travel and Service on separate lines.

Figure 9.7 Labeling the Trunk (continued)
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5. To terminate text entry, press RETURN a second time. The ISHIKAWA environment automatically moves
the cursor to the upper left branch, as shown in Figure 9.8. If you made a mistake labeling the trunk, continue
with the example. You cannot return to the trunk until you have finished the branch.

Figure 9.8 Labeling the First Branch
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6. Enter the label Pre-Flight Service. Press RETURN twice to terminate text entry for this branch.> Your
window should now look like Figure 9.9.

Figure 9.9 Completed Branch Label
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Note that when you finish entering text for the upper left branch, the other branches are deleted. These were
temporarily displayed as visual cues, and now it is up to you to decide where to add the remaining branches.

3You can skip this step, in future diagrams, by pressing RETURN before entering any text.
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7. To add the branch labeled In-Flight Service to the lower half of the diagram, position the cursor slightly
below the point where you want the branch to attach to the trunk and click the mouse button. The branch
appears with the text cursor centered inside the box, as shown in Figure 9.10. Enter the first line of text.

Figure 9.10 Adding a New Branch
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If your branch is not positioned where you want it, move the cursor to the appropriate position along the
trunk and click. Each time you click, the branch is moved to the new location.

If, on the other hand, the branch is not drawn at all, the cursor was probably too far away from the trunk to be
recognized. Move the cursor closer to the trunk and try again.

Enter the label In-Flight Service and press RETURN twice to terminate text entry.
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8. Next, add the branch Post-Flight Service to the upper half of the diagram, as shown in Figure 9.11. Position
the cursor so that it is just above the point where you want the branch to attach to the trunk and click.

Figure 9.11 Adding the Last Branch
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9. Press RETURN twice to terminate text entry.

Congratulations. You have just completed your first Ishikawa diagram using the ISHIKAWA procedure. In
the process you learned to add branches to a diagram using context-sensitive mouse clicks. Future examples
will illustrate other context sensitive areas, tools, and popup menus.

The examples that follow will, for the most part, expand on this diagram. To save the diagram, select File »
Save as » Data Set from the command bar. Use SASUSER for the library name and AIRLINE for the data
set name. Then select Save.

To leave the ISHIKAWA environment and return to the SAS Display Manager, select File » Close from the
command bar.
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Syntax: ISHIKAWA Procedure

There are only three options that can be specified in the PROC ISHIKAWA statement, since the ISHIKAWA
procedure is primarily a user-driven procedure.

DATA=SAS-data-set
identifies the name of a SAS data set that specifies an existing Ishikawa diagram. By default, the
procedure will prompt you to edit an existing Ishikawa diagram or start a new one. When you specify
the DATA= option, the procedure bypasses this initial menu. For example, the following statements
simplify editing an existing Ishikawa diagram saved in a SAS data set:

proc ishikawa data=work.airline;
run;

NEW
starts a new Ishikawa diagram. By default, the procedure will prompt you to edit an existing Ishikawa
diagram or start a new one. When you specify the NEW option, the procedure bypasses this initial
menu and starts with a new diagram. Do not specify any other options when using the NEW option.
For example, the following statements simplify starting a new Ishikawa diagram:

proc ishikawa new;
run;

NOFS
allows you to create hard copies of Ishikawa diagrams saved as SAS data sets without invoking the
interactive features of the procedure. You must specify the DATA= option when you use the NOFS
option. For example, the following statements create a hard copy of the Ishikawa diagram saved in the
SAS data set work.airline:

goptions dev=psl noprompt;
proc ishikawa data=work.airline nofs;
run;

Details: ISHIKAWA Procedure

This chapter presents detailed information about and examples of all the operations available in the
ISHIKAWA environment. Some of the examples build upon the diagram created in the tutorial.



Summary of Operations 4 717

Summary of Operations

To invoke the context-sensitive operations, apply the specified action (mouse event) to the appropriate hotspot,
using the left mouse button.

Table 9.1 Primary Operations

Operation Mouse Event  Hotspot Section
Add Click Near the intended attachment point  “Adding Arrows”
Edit Click Arrow tail “Labeling Arrows”
Move Click (to pick)  Arrow head

Click (to drop) Near the intended attachment point  “Moving Arrows”
Delete Double-click Arrow head “Deleting Arrows”
Resize Drag Arrow tail “Resizing Arrows”
Notepad Double-click Arrow tail “Notepads”

To invoke the following operations, make the specified selection from the appropriate context-sensitive popup
menu using the right mouse button.

Table 9.2 Secondary Operations

Operation  Menu Selection Section

Swap Head or tail Swap “Swapping Arrows”

Balance Head or tail Balance “Balancing Arrows”

Hide Detail  Background < Detail “Managing Complexity”

Show Detail Background > Detail “Managing Complexity”

Zoom Head or tail Zoom “Zooming Arrows”

Isolate Head or tail  Isolate “Isolating Arrows”

Print Pull-down File » Save as » Graph “Creating Graphics Output Using
SAS/GRAPH Software”

Save Pull-down File » Save as » Data Set  “Saving an Ishikawa Diagram for Future Edit-
ing”

Save Pull-down File » Save as » Image

Subset Head or tail ~ Subset “Modifying Arrow Colors and Line Styles”

Copy Head or tail  Copy “Merging Diagrams”

Refresh Background Refresh

Unsubset Background Unsubset “Modifying Arrow Colors and Line Styles”

Unbalance Background Unbalance “Balancing Arrows”

Undelete Background Undelete “Deleting Arrows”

When applied to the appropriate hotspots, the following actions (mouse events) invoke the context-sensitive
operations that are listed.
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Table 9.3 Context-Sensitive Tools
Hotspot Mouse Operation Section
Event
Arrow Head  Click Begin move “Moving Arrows”
Double-click Delete “Deleting Arrows”
Drag Resize “Resizing Arrows”
Popup menu  Subset “Modifying Arrow Colors and Line Styles”
Balance “Balancing Arrows”
Swap “Swapping Arrows”
Copy “Merging Diagrams”
Zoom “Zooming Arrows”
Isolate “Isolating Arrows”
Arrow Tail Click Edit “Labeling Arrows”
Double-click Notepad “Notepads”
Drag Resize “Resizing Arrows”
Popup menu  Subset “Modifying Arrow Colors and Line Styles”
Balance “Balancing Arrows”
Swap “Swapping Arrows”
Copy “Merging Diagrams”
Arrow Click Add new arrow or “Adding Arrows”
complete move operation “Moving Arrows”
Window Click Drop (finish) pending action
Background  Drag Drop (finish) pending action

Popup menu

Undelete
Unsubset
Unbalance
Show Detail
Hide Detail
Refresh

“Deleting Arrows”

“Modifying Arrow Colors and Line Styles’
“Balancing Arrows”

“Managing Complexity”

“Managing Complexity”

’

The File menu on the command bar can be used to control the operations in the following table.
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File » Description Section
New Start a new diagram “Getting Started: ISHIKAWA
Procedure”
Open Open an existing diagram “Reading an Existing Ishikawa
Diagram”
Close Close the current window
Merge Merge in an existing diagram “Merging Diagrams”
Save as »
Data Set Save as a SAS data set “Saving an Ishikawa Diagram for
Future Editing”
Graph Print using SAS/GRAPH software  “Creating Graphics Output Using
SAS/GRAPH Software”
Image Save as an IMAGE, catalog entry ~ "Save as an IMAGE"
Export as Bitmap »
File Copy to a bitmap file “Creating Bitmap Graphics
Output”
Customize Export options "Export as Bitmap"

The Edit menu on the command bar can be used to control the following operations.

Table 9.5 Edit Menu

Edit » Description Section
Copy Copy the diagram to host clipboard “Creating Bitmap Graphics Output”
Clear Clear the window

The View menu on the command bar can be used to control the following operations.
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Table 9.6 View Menu

View » Description Section
Ishikawa Settings »
Palettes Line and color palettes “Modifying Arrow Colors
and Line Styles”
Background Color Change window background color
Save Attributes Save window attributes: size, fonts

Balance Method »
Resize Method »

and background color
Select a balancing style
Select a resizing method

“Balancing Arrows”
“Resizing Arrows”

Primary Fonts Font dialog for first 3 levels “Modifying Fonts”
Secondary Fonts Font dialog for levels 4-10 “Modifying Fonts”
Colors Color dialog “Modifying Box Colors”
Arrows Arrow style dialog “Modifying Arrow Heads”
Other Style dialog “Modifying Environmental
Attributes”
Refresh Refresh the window

The Help menu on the command bar can be used to control the following operations.

Table 9.7 Help Menu

Help » Description
SAS System Help SAS help system
Using This Window Ishikawa specific help

Operations

This section provides details concerning the operations available in the ISHIKAWA environment. The order
in which the topics appear is the order in which the operations are typically encountered. Some of the
examples in this section build upon the diagram created in the tutorial.

Adding Arrows

You add an arrow by pointing with the mouse to the intended attachment point along an existing arrow
and clicking the mouse. You control the direction of the new arrow by offsetting the mouse cursor a small
distance away from the parent arrow on the side where the new arrow is to appear.

For example, to add upper branches, you offset the cursor slightly above the trunk. To add lower branches,
you offset the cursor slightly below the trunk. Likewise, you offset the cursor to the right of the branch to add
a right-hand stem and slightly left for a left-hand stem.

If a new arrow is not drawn as you intended (either positionally or directionally), you can easily move or
delete it. To delete a new arrow before you have entered any text, click in the background. To move a new
arrow before you have entered any text, move the cursor to a new attachment point and click.
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Once an arrow is drawn, you are immediately prompted for its label (note the hint, Edit. .., displayed on
the message line and the appearance of the text cursor at the end of the arrow). See “Labeling Arrows” on
page 724, for details on the text editing features of the ISHIKAWA environment.

A diagram can contain up to ten levels of detail, but the number of arrows is limited only by the resolution
and size of your graphics display.

Example

Continuing with the tutorial example from “Getting Started: ISHIKAWA Procedure” on page 707, suppose
that you have obtained detailed information for each of the three major service areas, which you want to
display by adding stems to the branches of the diagram you previously created. If you closed the ISHIKAWA
environment after saving the data set, SASUSER.AIRLINE, you can easily restore the diagram by submitting:

proc ishikawa data=sasuser.airline;
run;

To add a stem to the left side of the branch labeled In-Flight Service, position the cursor so that it is just
to the left of the point where you want the stem to attach. Click the mouse. The new arrow (pending text)
appears as in Figure 9.12.

Figure 9.12 Adding the Left Stem
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Type the label Meals and press RETURN twice.
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To add a stem to the right side of the same branch, position the cursor so that it is just to the right of the
attachment point. When you click the mouse, your window will appear as in Figure 9.13.

Figure 9.13 Adding the Right Stem
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Type the label Flight attendants on two lines and press RETURN to terminate text entry.
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Complete the diagram by adding the remaining stems as shown in Figure 9.14.

Figure 9.14 Stem-Level Diagram
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Experiment further by adding several of the leaves as shown in Figure 9.15. Don’t be concerned if some of
the labels collide with each other. Later, you will learn how to move and resize arrows.

Figure 9.15 Leaf-Level Diagram
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Labeling Arrows

To edit the label of an existing arrow, click on one of the following areas:

e the label
e the arrow tail (if the arrow does not have a label)

e inside the box for trunk and branch labels

Use your keyboard to enter the text.
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On hosts that support direct graphical text entry,* the following functions are supported:

e edit keys such as BACK SPACE, DELETE CHAR, DELETE LINE, and RETURN
e cursor navigation keys such as 1, |, — and <«
o the INSERT key to toggle between insert and overstrike modes

e buffers to copy, cut, or paste text into and from external sources

Text entry is terminated whenever you press RETURN on an empty line or exceed the maximum line limit
for a label. Text entry is also terminated whenever you click the mouse. This shifts focus away from the
editing operation and to the new location.

Labels are restricted to 40 characters per line. The trunk label can have up to five lines, and labels for other
levels are limited to two lines.

You can split a line of text into two lines by pressing the RETURN key anywhere inside the line. Likewise,
flow a line with the previous line of text by pressing the BACK SPACE key at the beginning of the line.

You can copy the contents of the paste buffer into a label using the PASTE command. This can be helpful
when the information for your diagram is available from another source (a flat file, for example). Use the
paste buffer to copy the information from that source to your Ishikawa diagram.

Some hosts designate the right mouse button for pasting, some use control keys (like ctrl-p), while others use
a designated function key. For more details about using paste buffers with the SAS System, consult the SAS
companion for your host.

To paste text into a label, you must first select the label. For existing arrows, select the arrow, position the
cursor where you want the text to appear, and then issue the PASTE command. For new arrows pending text
entry, simply issue the PASTE command. Any text in the paste buffer that causes the label to exceed its limits
is truncated.

When your mouse has a paste key defined, instead of adding an arrow and pasting the text in two operations,
use the right mouse button to add the arrow. This action adds a new arrow, automatically copies the label
from the paste buffer, and terminates text entry, in a single operation.

Example

In the diagram in Figure 9.16, the branch labeled In-Flight Service has been selected by clicking on the
arrow tail. The arrow is highlighted with a narrow dotted line, and the text cursor is positioned over the first
character in the label.

“4Devices such as the IBM3179 do not support the direct graphical text entry mechanism described in these examples. Instead, a
text entry window pops up whenever you select an arrow for editing. You must edit the text for the arrow from the dialog box and
close the text entry window before the diagram is updated.
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Figure 9.16 Selecting an Arrow for Editing
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To change the label so that the word Service appears on a separate line, use the — or <— key to move the
cursor to the space before the word Service, as shown in Figure 9.17.

Figure 9.17 Using Cursor Keys
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Now press RETURN to split the text into two lines, as in Figure 9.18.

Figure 9.18 Splitting Text
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Remember to delete the space preceding Service before pressing RETURN to terminate text entry.

Moving Arrows

You move an arrow by picking up the arrow and dropping it at a new location:

e To pick up an arrow, position the cursor over the arrow head and click the mouse. The arrow you
selected will be highlighted with a narrow dotted line. If the arrow is not highlighted, move the cursor
closer to the arrow head and repeat the click.

e To drop an arrow, move the cursor slightly to one side of the new attachment point and click (just as
though you are adding a new arrow).

When you move an arrow, all its descendants move with it.
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To cancel a move after picking up an arrow, click in the background area of the ISHIKAWA window.

Do not try to drop the arrow back into place by clicking on the arrow head a second time. Double-
clicking on (or near) the arrow head deletes the arrow. To move an arrow a short distance, move the cursor
away from the arrow head before clicking to drop the arrow. On some systems the cursor will change shape
when you have moved outside the context-sensitive area.

Example

As your diagrams develop, you will want to reposition arrows, either because of errors or for aesthetic reasons.
Figure 9.19 shows an example of an Ishikawa diagram that needs to be modified.

Figure 9.19 An Inelegantly Arranged Ishikawa Diagram
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The diagram lacks balance, and some of the branches are too close, resulting in collisions and clipping.

One way to improve the diagram is to move the branch for Pre-Flight Service toward the center of the trunk.
First select the arrow head for this branch, as shown in Figure 9.20.
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Then move the cursor to a point just slightly above the trunk near the desired new attachment point (Fig-

ure 9.21).

Figure 9.21 Locating the New Attachment Point

¥ SAS (O]

File Edit “iew Tools

Solutions  Window  Help

Fre-Flight Service I

In-Flight Service I

Pozt-Flight Service

Baggage

attendants

::" Ishikawa-New _ (O]

Cuality
Air Travel
Service

|Move...




730 4 Chapter 9: The ISHIKAWA Procedure

Drop the arrow in place by clicking the mouse (Figure 9.22).

Figure 9.22 Dropping an Arrow into Position
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Next, you should reflect the middle branch to the lower half of the diagram to balance the diagram and
eliminate the remaining collisions. Once you have selected the branch, position the cursor slightly below the
trunk near the desired new attachment point, as shown in Figure 9.23.



Figure 9.23 Selecting an Arrow for Reflecting
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Click the mouse to complete the reflection (Figure 9.24).

Figure 9.24 Reflecting an Arrow
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Note that the stems are reflected with the branch and that their positions (relative to the trunk) are preserved.

Finally, the stem labeled Meals is incorrectly attached to the branch labeled Pre-Flight Service and should be
moved to the branch labeled In-Flight Service. Once you have selected the stem, move the cursor slightly left
of the new attachment point, as in Figure 9.25.

Figure 9.25 Locating the New Attachment Point
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To complete the move, click the mouse (Figure 9.26).

Figure 9.26 Moving a Stem
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Apply the same principles when moving an arrow to a new level (for example, to elevate a stem to a branch)
or a new diagram (when you have multiple ISHIKAWA windows open).

Deleting Arrows

You can delete an arrow (with all its descendants) by moving the cursor over the arrow head (attachment
point) and double-clicking. If you accidentally move the cursor while double-clicking, it is possible that the
arrow will be moved instead of being deleted. In that case, double-click on the arrow head again.

You can undo a deletion by moving the cursor to a background area of the window and using the right mouse
button to select Undelete from the background popup menu. Repeat the operation when you want to undo
several deletions.
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Once an arrow has been selected for deletion, you can cancel the pending operation by moving the cursor to
a background area of the diagram and clicking the mouse.

The ISHIKAWA environment does not allow you to delete the trunk. To clear the window, select Edit »
Clear from the command bar. Then start a new diagram by selecting File » New or File » Open.

Example
In the diagram in Figure 9.27, the branch labeled Post-Flight Service has been selected for deletion (note that
the branch is highlighted).

Figure 9.27 Selecting a Branch for Deletion
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Without moving the cursor, click on the arrow head a second time to delete the branch (Figure 9.28).
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To undelete the previous deletion, move the cursor to a background area of the window and use the right
mouse button to select Undelete from the background popup menu (Figure 9.29).
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Resizing Arrows

You can resize an arrow by holding the mouse button down over the tail end of the arrow and dragging the
mouse.’ As you move the mouse, the arrow is represented by a rubberband line, and a plus sign (4) is drawn
to indicate the original position of the arrow tail. The new length is determined by the position of the cursor
when you release the mouse.

To cancel a resize operation once you have depressed the mouse button, release the button outside the
ISHIKAWA window.

All non-horizontal arrows are constrained to have the same angle. You control the angle by resizing a branch.
That is to say, when you resize a leaf, its angle does not change.

Use View » Ishikawa Settings » Resize Method to control the scope of the resizing operation.

e Local resizes only the arrow being dragged.

o Global resizes all the arrows at that level to lengths that are proportional to the arrow being dragged.
This is the default.

e Uniform resizes all arrows at that level to the length of the arrow being dragged.

When you resize an arrow, you also update the default size for all new arrows at that level.

By default, global and uniform resizing applies to all the arrows at the level of the arrow being resized. To
restrict resizing to a specific subset of arrows, you can subset them as follows:

e Move the cursor over the arrow head of an arrow to subset that arrow and all its descendants.

e Move the cursor over the arrow tail of an arrow to subset only that arrow (and not its descendants).

e Use the right mouse button to activate the popup menu.

e Select Subset.

On some hosts, shift-clicking on the arrow head or tail also subsets an arrow.

Subsetted arrows are indicated by underlined labels. Subsetting is a toggle operation, so to unsubset an arrow,
repeat the preceding steps.

To unsubset all the arrows in the diagram, do the following:

e Move the cursor to a background area of the window.
e Use the right mouse button to activate the background popup menu.

e Select Unsubset.

Be sure to remove all subsets after you have finished modifying the diagram, since remaining subsets can
alter the focus of other operations.

See “Moditying Arrow Colors and Line Styles” on page 765, for more examples of how subsets are used.

3Some devices (such as the IBM3179) require you to define a drag key. For more details about dragging on your system, consult
the SAS companion for your host.



Operations 4 737

Example
Arrows that are too long can cause clipping and collisions, as illustrated in Figure 9.30.

Figure 9.30 Before Resizing the Diagram

W SAS =] E3

Fil= Edit “iew Tool: Solution: window Help

= Ishikawa-WORK_ISHPLANE [_ O] =]
Fre-Flight Service Pozt-Flight Service

zarby gates Huick,

Convenientdeplaning

Minimum departure timez Bagg‘.age
cannechions Quick c ' SECUnty
rance boarding lekelipyy - formation
pazzes Competitive Hearby
Frequent flier Fares exits
courtesies Mo Gates accessible
overbdauag ticketed Quality

Air Travel
Service

Mechanical Flight
Prampt attendants
arrival
teals
Camfartable
zeating Prompt
departures

Entertainment

In-Flight Service

To resize the stems in the upper half of the diagram, proceed as follows:

Subset the branch for Pre-Flight Service by moving the cursor over its arrow head and selecting
Subset.

Do the same to Post-Flight Service.

Shorten one of the subsetted stems by dragging its tail to the desired length.

Remove all subsets by selecting Unsubset.
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The results are shown in Figure 9.31.

Figure 9.31 After Resizing the Diagram
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Swapping Arrows

Use the swap operation to interchange two arrows in a single operation instead of using two move operations.
Swapping has all the flexibility of the move operation; you can swap arrows that have different parents,
different levels, or arrows from different diagrams.

Like moving, the results depend upon whether you select the arrow from the arrow head or the arrow tail.
When you select the arrow head, the arrow and all its descendants are moved. When you select the arrow tail,
only the labels of the selected arrows are interchanged.
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Swapping is a two-step operation.
e Move the cursor over the arrow head (tail) of one of the arrows to be swapped and select Swap from
the context-sensitive popup menu.

e Complete the swap by using the mouse to select the comparable end (head or tail) of the second arrow.

To cancel a swap after you have selected the first arrow, click in a background area of the diagram.

Example

To swap the branch labeled Pre-Flight Service (and all its descendants) with the branch labeled Post-Flight
Service in the following diagram, move your cursor over the arrow head of the Pre-Flight Service branch and
activate the popup menu using the right mouse button. Select Swap to begin the operation (Figure 9.32).

Figure 9.32 Swapping Two Arrows
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To complete the swap, select the arrow head of the Post-Flight Service branch (Figure 9.33).

Figure 9.33 Swapping Two Arrows (continued)
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The completed diagram (Figure 9.34) shows how the swap operation simplifies interchanging two arrows.

Figure 9.34 Completing a Swap
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An alternative to swapping the arrows is to move them. However, moving arrows in this situation requires
more steps and tends to be more cumbersome than swapping.

Balancing Arrows
An Ishikawa diagram is said to be balanced if the sub-arrows attached to each arrow are equally spaced.

To balance the immediate descendants of an arrow and all its descendants, proceed as follows:

e Move the cursor over the arrow head.
e Activate the popup menu using the right mouse button.

e Select Balance.

To balance only the immediate descendants of an arrow, select Balance from the popup menu for the arrow
tail.

You can restore the arrows to their original positions by doing the following:

e Activate the background popup menu using the right mouse button.

e Select Unbalance.

The ISHIKAWA environment provides three alternative methods for balancing arrows. Select one of the
following choices from the View » Ishikawa Setting » Balance Method » menu:

e Preserve order/sides maintains the order and directions of the sub-arrows but repositions them so
they are evenly spaced.

e Preserve order/alternate sides maintains the ordering of the arrows but repositions adjacent arrows
so that they appear on opposite sides. This is the default.

e Preserve sides maintains the side on which the sub-arrows are attached then spaces each side of the
arrow independently.
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Example
Consider the unbalanced diagram in Figure 9.35.

Figure 9.35 An Unbalanced Ishikawa Diagram

W SAS =] E3
Fil= Edit “iew Tool: Solution: window Help
::'— Ishikawa-New [_ O] x|

Branch & Branch D Branch E

Trurk

Branch B Branch C

| | 7.

To balance only the stems of the branch labeled Branch A, move the cursor over the arrow head and press the
right mouse button (Figure 9.36).



Figure 9.36 Balancing a Branch
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Select Balance from the arrow head popup menu (Figure 9.37).

Figure 9.37 A Balanced Branch
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Note that since the stems are without leaves, selecting either the head or the tail has the same result.

To balance only the five major branches in the preceding diagram without affecting their stems, move the
cursor to the tail end of the trunk and select Balance from the popup menu (Figure 9.38).

Figure 9.38 Balancing Only the Branches
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To balance the entire diagram (from head to tail, so to speak), move the cursor to the head of the trunk and
select Balance from the popup menu (Figure 9.39).

Figure 9.39 Balancing the Entire Diagram
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Note that the balancing method used here not only changes the spacing of the stems but reflects them
as needed to achieve a balanced appearance. You can control this by specifying a balancing method, as
illustrated by the next example.
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Example
The diagram in Figure 9.40 displays an unbalanced branch and a copy of that branch after it was balanced
using the Preserve order/alternate sides balancing method.

Figure 9.40 Preserving Order but Alternating Sides
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Note that the stems remain in order (/-8) from tail to head, but they now alternate evenly across both sides of
the branch. This is the default method used for balancing arrows.
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Example
The diagram in Figure 9.41 displays an unbalanced branch and a copy of that branch after it was balanced
using the Preserve order/sides method.

Figure 9.41 Preserving Order and Sides
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Note that stems 4-6 remain on the left, stems /-3 and 7-8 remain on the right, and the order from tail to head
is still /-8. However, the stems are now spaced uniformly.
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Example
The diagram in Figure 9.42 displays an unbalanced branch and a copy of that branch after it was balanced
using the Preserve sides balancing method.

Figure 9.42 Preserving Sides
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Note that the stems on the left (4-6) are spaced uniformly, and the stems on the right (/-3 and 7-8) are spaced
uniformly. The two sides are spaced independently of each other.

Notepads

Ishikawa (1982) and Kume (1985) advocate the display of quantitative information with the arrows in an
Ishikawa diagram.

In the ISHIKAWA environment, you can use Notepad windows to record or display information associated
with each arrow. To open the Notepad window, move the cursor over the arrow tail and double-click
(Figure 9.43).
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Figure 9.43 Ishikawa Notepad

Izhikawa Motepad
Pre-F1ight Service

I]I(l Cancel | Helpl

Notes are limited to four lines of text with no more than 40 characters per line.

When you save your Ishikawa diagram, your notes are saved with the SAS data set.

Later, when you retrieve your diagram, all the notes are restored.

You must close the Notepad window before you continue working in the ISHIKAWA environment.

Example
As shown in Figure 9.44, double-clicking on the Prompt arrival stem reveals details about prompt arrival
times.

Figure 9.44 Using Notepads to Organize Details
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Managing Complexity

A major advantage of the ISHIKAWA environment is that you can quickly organize a highly complex diagram.

However, not everyone may be interested in seeing all the details—at least initially.

To increase the level of detail by one level, do the following:

e Move the cursor to a background area of the window, and use the right mouse button to activate the

background popup menu.

e Select > Detail. On some hosts, you can press the > key instead of using the popup menu (as long as

you are not editing text).

Each time you select > Detail from the background popup menu, the detail increases by one level.

To reverse the process and decrease the level of detail, select < Detail from the popup menu, or press the <

key.

Example

You are making an online presentation about factors that influence the quality of air travel service. The

diagram in Figure 9.45 presents too many details to be a good starting point for your audience.

Figure 9.45 Highly Detailed Ishikawa Diagram
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A better way to begin is by displaying only the trunk and branches (Figure 9.46).

Figure 9.46 Branch-Level Diagram
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Then, at the next stage of your presentation, dynamically foliate the branches with stems (Figure 9.47).

Figure 9.47 Increasing the Level of Detail
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The amount of detail is increased by one level (Figure 9.48).

Figure 9.48 Increasing the Level of Detalil
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Zooming Arrows

A second method for managing a highly detailed Ishikawa diagram is to work with a subsection of the
diagram in a separate window. The window and the sub-arrows inside it can be resized independently of the
parent window. In all other respects, the information in the two diagrams is linked dynamically. Changes in
one window (for instance, moving, adding, and editing arrows) are reflected in the other window.

To zoom an arrow, proceed as follows:

e Move the cursor over the arrow head.

e Activate the popup menu using the right mouse button.

e Select Zoom.

To return or unzoom, select File » Close.
You can have up to four windows open at one time.

To reduce the amount of window management, you can specify that zoomed diagrams are to be displayed
in the current window rather than in new windows by setting Zoom Window to Current in the View »
Ishikawa Settings » Other dialog box.
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Example
Figure 9.49 shows a branch labeled In-Flight Service after it has been zoomed into a new window.

Figure 9.49 Zooming a Branch
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Isolating Arrows

A third method for managing a highly complex Ishikawa diagram is to view the entire diagram as a collection
of smaller diagrams. Any arrow (along with its sub-arrows) can be isolated into a separate diagram in a new
window. This diagram can then be easily saved in a separate file.

To isolate a branch as a separate diagram, do the following:

e Move the cursor over the head of the arrow.
e Activate the popup menu using the right mouse button.

e Select Isolate.

You can have up to four ISHIKAWA windows open at one time.
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Example
Consider the diagram in Figure 9.50.

Figure 9.50 A Highly Detailed Diagram
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To isolate the branch labeled In-Flight Service as a separate Ishikawa diagram, move your cursor over the
head of the arrow. Use the right mouse button to activate the popup menu and select Isolate.

Figure 9.51 shows the main diagram in one window and the branch labeled In-Flight Service after it has been
isolated to another window.

Figure 9.51 Promoting a Branch into a New Diagram
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To return to the original diagram, select File » Close.

Merging Diagrams

You can combine multiple Ishikawa diagrams into a master diagram by using the merge operation. To merge
a stored diagram into the current diagram, proceed as follows:

e Select File » Merge.

e Specify the name of a SAS data set that contains a saved Ishikawa diagram.
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Another way to combine diagrams is to open separate ISHIKAWA windows for each sub-diagram then copy
them into the master diagram. To copy all or part of an Ishikawa diagram from one window to another, do
the following:

e Move the cursor over the head of the arrow.
e Activate the popup menu using the right mouse button.

e Select Copy.

e Position the cursor slightly to one side of the new attachment point and click (just as though you are
adding a new arrow).

Example
Suppose you want to create the diagram in Figure 9.52 by combining information from diagrams already
created by each of the major service areas (Pre-Flight, In-Flight, and Post-Flight) and stored in different SAS
data sets.

Figure 9.52 A Completed Master Diagram
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First, use the ISHIKAWA environment to create the trunk for the new master diagram (Figure 9.53).

Figure 9.53 Starting a Master Diagram
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Select File » Merge from the command bar to open the File Requestor dialog box (Figure 9.54).

Figure 9.54 Member Selector
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Specify the name of the data set for Pre-flight services and press Open.
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Now click on a point along the trunk where this sub-diagram is to attach (Figure 9.55).

Figure 9.55 Constructing a Master Diagram
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To complete the diagram, repeat the process for the remaining branches.

Creating Graphics Output Using SAS/GRAPH Software

One way to create a hard copy of your Ishikawa diagram is to send it to a graphics device using SAS/GRAPH
software. To do this, you should submit a GOPTIONS statement to direct the graphics output to the
appropriate location and control the output format before you invoke the ISHIKAWA environment. For
example, the following GOPTIONS statement directs the output to a PostScript device:

goptions target=psl noprompt;

If you do not specify a target device before invoking the ISHIKAWA environment, you will be prompted for
one before the graph is generated.

In the ISHIKAWA environment, when you are ready to route your output to a hard copy device, select File
» Save as » Graph. This opens a dialog box that enables you to customize various aspects of your graph
(Figure 9.56).
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Figure 9.56 Hard Copy Requestor
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To save the diagram to the default graphics catalog in the WORK library (WORK.GSEG), simply press OK
and close the dialog box. The default member name is ISHIKAWA.

To save the diagram to a different graphics catalog, select Save and then use the Member selector window to
specify a library, a SAS catalog, and a member name.

When sending a diagram directly to an output device, you can ignore the member name entirely.

To save to your own graphics catalog, select Save and then use the Save a member selection window to
specify a catalog and data set name. Simply click OK when you want to save your diagram to the default
graphics catalog (WORK.GSEG). When sending a diagram directly to an output device, you can use OK.

You must specify two SAS/GRAPH fonts for drawing the labels in the hard copy of the diagram. The
hardware fonts used in the ISHIKAWA environment cannot be used for your hard copy. The primary font
and size are used for the first three levels of text. The secondary font and size are used for the remaining
levels of text.

To change fonts, enter a valid SAS/GRAPH font name in the font field or click the button to the right of the
font field to display a font requestor dialog box. The default font is SIMPLEX.

You can specify the height of the text directly in the height field (in screen percent units), or you can click the
button to the right of the field to request an absolute height or a relative height (Figure 9.57).
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Figure 9.57 Font Height Selector
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Select Absolute when you want the font height in the output to be the same height as the font height used in
the ISHIKAWA environment even if the output window and the ISHIKAWA window differ in size. Select
Relative to maintain the same font height to window size proportion in both the ISHIKAWA window and the
output window. The numeric value entered in the height field after either choice is a screen percent unit. The
default text height is absolute.

Use the Fill Text Boxes and Draw Shadow check boxes to suppress the box fills and box shadows from the
output. They cannot be used to add these features to the hard copy if they were not present in the ISHIKAWA
window.

Use the Use background color check box to indicate whether the background color from the ISHIKAWA
environment is used in the output. This option is useful when you are sending your diagram to a color device
and you want the background in your hard copy to match that of your ISHIKAWA environment.

Use the Switch Black and White check box to interchange black and white when the diagram is sent to
the output device. This option is useful when you send your diagram from a white-on-black display to a
black-on-white hard copy device.

Click OK to generate the hard copy output or click Cancel to quit.
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Creating Bitmap Graphics Output
A second way to create a hard copy of your Ishikawa diagram is to export it as a bitmap to one of the
following:
e the host graphical clipboard
e an external bitmap file

e a SAS/GRAPH Image catalog entry

To copy the Ishikawa diagram as a bitmap to the host clipboard, select Edit » Copy. The results are host

specific. For more details about copying to the host clipboard on your system, consult the SAS companion
for your host.

To export the Ishikawa diagram to a bitmap file using SAS/GRAPH software, select File » Export as
Bitmap » File (Figure 9.58).

Figure 9.58 Export File Requestor
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The appearance of this dialog box will be host specific. For more details about the format of this dialog box
on your system, consult the SAS companion for your host.

To save the Ishikawa diagram as an IMAGE entry in a SAS catalog, select File » Save as » Image
(Figure 9.59).
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Figure 9.59 Entry Selector
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You must specify a SAS catalog in which to save the IMAGE entry as well as a name for the object.

When exporting your diagram to a bitmap or saving to a SAS/GRAPH IMAGE entry, you can have the colors
mapped so that color diagrams are saved in black on white or white on black. You do not have to make those
changes to the diagram yourself. Use File » Export as Bitmap » Customize to display the dialog box
shown in Figure 9.60.

Figure 9.60 Customize Export Dialog
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Select Black on white to convert the output to a black diagram on a white background. This is useful when
the diagram is being exported to a document.

Select White on black to convert the output to a white diagram on a black background. This is useful when
the diagram is being exported for display on a black and white terminal.
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Modifying Fonts

By default, the ISHIKAWA environment uses the same hardware font as the SAS windowing environment.
However, you have the option of specifying two different font styles/sizes.

The primary font is used for labeling arrows in the first three levels of the diagram. The secondary font
is used for labeling arrows in the remaining levels. You will typically use a smaller font in the detailed
(secondary) areas of the diagram.

To change a font, select View » Ishikawa Settings » Primary Fonts or View » Ishikawa Settings »
Secondary Fonts to display the Font Requestor window, as in Figure 9.61.

Figure 9.61 Font Requestor
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The layout of the Font requestor window is host specific. Typically, it will contain a list of available fonts and
sizes displayed in a scrollable region. Refer to your host documentation for specific information regarding
the format of this dialog box.

To change fonts, select a font from the list.

You must close the Font Requestor window before you can proceed. Click OK to apply the font or Cancel to
cancel the dialog box.

To customize your session so that these fonts are permanently associated with the ISHIKAWA environment,
select View » Save Attributes from the command bar.
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Modifying Box Colors

By default, the box fill (background) color is empty and the shadow (outline) color is the same as the arrow
color.

To modify the colors associated with trunk and branch boxes, select View » Ishikawa Settings » Colors.
A dialog box, similar to the one in Figure 9.62, is displayed.

Figure 9.62 Colors Dialog Box
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To change the fill color of all the boxes® in the Ishikawa diagram, do the following:

e Select a color from the color palette.

o Select Infill.

Once modified, the fill color is unaffected by changes in the arrow color. To return the box to an empty fill,
proceed as follows:

e Select the current infill color from the color palette (if it is not already the current color).

o Select Infill.

To change the shadow color of the boxes, select Shadow and follow the same procedure.

Click OK to close the dialog box or Cancel to cancel the changes.

% You cannot directly modify the colors of individual boxes from this dialog box.
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Modifying Arrow Colors and Line Styles

The ISHIKAWA environment provides a line style palette and a color palette that you can use to customize
the arrows in your Ishikawa diagram. Select View » Palettes to activate both palettes (Figure 9.63).”

Figure 9.63 Line Style and Color Palettes
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To specify the arrows to which color and line selections apply, subset them with the subset function. To
toggle an arrow in or out of the list of subsetted arrows, do the following:

e Use the right mouse button to display the arrow head or the arrow tail popup menu. To subset an arrow
and all its descendants, use the arrow head popup menu. Use the arrow tail popup menu to subset an
arrow without any descendants.

e Select Subset.

The labels of all subsetted arrows are underlined.

On some hosts, shift-clicking on the arrow head or tail will also subset the arrow. You can subset any
combination of arrows in the diagram.

You can change the color of all the subsetted arrows by selecting the desired color in the color palette with
the mouse. Likewise, use the line palette to control the style and width of the arrows.

7If you are working on a black-and-white terminal, you should not use the color palette.
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To unsubset all the arrows in the diagram, do the following:

e Move the cursor to a background area of the ISHIKAWA window.
e Use the right mouse button to activate the background popup menu.

e Select Unsubset from the popup menu.

To unsubset a specific arrow in the diagram, select Subset from the context-sensitive popup menu for the
arrow head or tail.

Be sure to remove all subsets once you have finished modifying the diagram, since subsets affect the focus of
many other operations.

Example
Continuing with the diagram from the previous section, subset the trunk using the arrow tail popup menu
(Figure 9.64).

Figure 9.64 Subsetting Only the Trunk
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Note that only the trunk is subsetted (as indicated by the underlined label) (Figure 9.65).
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Figure 9.65 Subsetting Only the Trunk (continued)
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When you select a line style from the line palette, only the line style of the subsetted arrow changes
(Figure 9.66).

Figure 9.66 Modified Diagram
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Alternatively, if you subset the trunk using the arrow head popup menu, all of the arrows in the diagram are
subsetted (Figure 9.67).

Figure 9.67 Subsetting the Entire Diagram
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Note that all of the labels in the diagram are now underlined (Figure 9.68).

Figure 9.68 Subsetting the Entire Diagram (continued)
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Now, when you select a new line style from the line palette, all the arrows are drawn with this line style

(Figure 9.69).



770 4 Chapter 9: The ISHIKAWA Procedure

Figure 9.69 Modified Diagram
W SAS - [O] =]
File Edit “iew Toolz Solution: window Help
:'— Ishikawa-New |_ O] x|
Fre-Flight Service Post-Flight Service
j Euits ----- ¥,
ales ----- ¥ Y
L';E ----- Boarding passes

InFlight Service

Huality
Air Travel
Service
"’
:E _____ Elight
! attendants
1
Meals ----- »
JJ .
koo Entertainment
‘
‘

arrow head popup menu (Figure 9.70).

To remove the subset from the Pre-Flight Service branch and all its descendants, select Subset from the

&
Figure 9.70 Selectively Removing Tags
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This removes the underlines from the labels in these arrows (Figure 9.71).
Figure 9.71 Selectively Removing Subsets (continued)
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You can now use the line palette to change the line style for all the arrows in the diagram with the exception

of the Pre-Flight Service branch and its descendants (Figure 9.72).
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Figure 9.72 Modified Diagram
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The same principles apply when making color changes—simply use the color palette instead of the line style
palette.

Modifying Text Colors

By default, labels have the same color as the arrow. To modify the text color independently of the arrow
color, select View » Ishhikawa Settings » Colors. The Customize Color window, similar to the one in
Figure 9.73, will open.
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Figure 9.73 Colors Dialog Box
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To change the text color of all the arrows® in the Ishikawa diagram, do the following:

e Select a color from the color palette.

o Select Text.

Once modified, the text color is unaffected by changes to the arrow color. To relink the text color to the arrow
color, do the following:

e Select the current text color from the color palette (if it is not already the current color).

o Select Text.

Click OK to close the dialog box. To cancel the changes, click Cancel.

8 You cannot directly modify the text color for individual arrows from this dialog box.
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Modifying Arrow Heads

To modify the characteristics of the arrow heads in your diagram, select View » Ishikawa Settings »
Arrows. This opens the dialog box shown in Figure 9.74.

Figure 9.74 Arrows Dialog Box
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The dialog box controls the characteristics of all arrow heads. Arrow heads cannot be modified individually.

Arrow heads can be tapered, flush, or empty. Use the sliders labeled Length and Width to control the length
and width of the arrow heads. Move the sliders to the right to increase the length/width of the arrow head and
to the left to decrease the length/width.

Removing arrow heads increases the readability of a highly detailed diagram. Use the Display slider to
control the level at which arrow heads are displayed. Move the slider to the extreme left to remove all the
arrow heads and to the extreme right to display all the arrow heads. Use the intermediate settings to select a
threshold level of detail, above which arrow heads are not displayed. By default, arrow heads are displayed
for all levels.

Click OK to close the window. To cancel the changes, click Cancel.
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You can modify other features of the ISHIKAWA environment such as zooming, mouse sensitivity, and
shadow attributes by selecting View » Ishikawa Settings » Other to open the dialog box in Figure 9.75.

Figure 9.75 Others Dialog Box
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Zoom Window controls whether the zoom operation opens a new window or draws in the current window.

Select Currentto reduce the amount of window management required.

The Shadow Type button controls the type of shadow that is drawn around the trunk and branch boxes.

Bevel 1 draws a beveled edge box with a lower-right light source.

Bevel 2 draws a beveled edge box with an upper-left light source.

Drop draws a box with a drop shadow. This is the default.

None suppresses the shadow.

The Shadow Width slider controls the shadow width if the boxes have shadows or the outline width when
boxes are displayed without shadows. Move the slider to the right to increase the shadow width and to the

left to decrease the width.

The Add Sensitivity slider controls how closely you must position the cursor to an existing arrow before
a mouse click results in an add arrow operation. Move the slider to the right to increase the size of the

context-sensitive area and to the left to reduce the size of the context-sensitive are

a.

The Select Sensitivity slider controls how closely you must position the cursor to an existing arrow before a
mouse click results in an edit, delete, move, or popup arrow operation. Operate this slider in the same manner

as the Add Sensitivity slider.
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Saving an Ishikawa Diagram for Future Editing

You must save your Ishikawa diagram as a SAS data set if you intend to edit it in the future with the
ISHIKAWA environment. The ISHIKAWA environment does not reconstruct Ishikawa diagrams by reading
graphics entries (GRSEG) from SAS catalogs.

Select File » Save As » Data Set to activate the Data Set Requestor window.

Figure 9.76 Output File Requestor
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A list of SAS librefs is displayed in the Libraries tree in the left region of the dialog box (Figure 9.76). Begin
by selecting a libref from the list. A libref refers to a permanent SAS data library located on your host system.
For example, the default SASUSER libref (on most hosts) points to a directory called SASUSER, located
under the working directory of your current SAS session. Any data sets saved with the libref SASUSER will
be saved in that directory.

To direct your SAS data sets to a different directory, select the Create new library tool icon to open the New
Library dialog box. Use this dialog box to specify the directory and assign a libref to that directory.

To select the libref SASUSER, move your cursor over that entry in the list and click. The region to the right
of the Libraries tree is used to display any existing SAS data sets in that library.

To save your diagram in an existing SAS data set, use the mouse to click on an entry in the list. The member
name field will be updated to reflect your choice. If you want to save your diagram in a new SAS data set,
move your cursor to the member name field and type the new name (in this example, SERVICE).

Select Savet o save the diagram and return to the ISHIKAWA environment or select Cancel to cancel the
save.
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Reading an Existing Ishikawa Diagram

To enter the ISHIKAWA environment and resume editing an existing diagram, you must have previously
saved the diagram as a SAS data set. The ISHIKAWA environment does not allow you to modify graphs
stored in SAS/GRAPH catalogs.

You can specify the name of this data set when you establish the ISHIKAWA environment with the following
statements:

proc ishikawa data=libref.dataset;

run;
Alternatively, the ISHIKAWA environment will prompt you for a data set after you invoke the environment
with the following statements:

proc ishikawa;

run;

When you specify a data set in the PROC statement, the ISHIKAWA environment is initialized and your
diagram is displayed up to the branch level. The message area will indicate if any additional detail is hidden.
You can edit your diagram even if some of the diagram is hidden. To add or remove detail one level at a time,
select > Detail or < Detail from the background popup menu.

When you do not specify a data set in the PROC statement, you will see the menu in Figure 9.77.

Figure 9.77 Initial Menu
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Since you are editing an existing diagram rather than starting a new diagram, select Edit an Existing
Diagram to activate the Member Selector window (Figure 9.78).
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Figure 9.78 Input Member Selector
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Use the Member Selector window to specify an input SAS data set. For information on how to specify
the SAS data set name, follow the steps outlined in “Saving an Ishikawa Diagram for Future Editing” on
page 776.

To establish the ISHIKAWA environment and display the diagram you have selected, select Open. The
diagram is displayed up to the branch level.

To quit or start a new diagram, return to the main menu by selecting Cancel.

Displaying Multiple Ishikawa Diagrams

The ISHIKAWA environment enables you to view multiple Ishikawa diagrams simultaneously for side-
by-side comparisons of different diagrams. You can also use this feature to transfer information between
diagrams, since the move and copy operations function across windows. You can have up to four ISHIKAWA
windows open at one time.

To open a window for another Ishikawa diagram, select File » Open. This will display the Member Selector
window, which you can use to specify the name of the input SAS data set for the other Ishikawa diagram.

You can also start new diagrams while displaying other Ishikawa diagrams. To open a window for a new
Ishikawa diagram, select File » New. This opens an ISHIKAWA window with a template for a new diagram.
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Example
Figure 9.79 shows an Ishikawa diagram for Quality Air Travel Service after an initial brainstorming session.

Figure 9.79 Single Ishikawa Diagram
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The current diagram and another Ishikawa diagram can be viewed simultaneously by selecting File » Open
from the command bar (Figure 9.80).
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Figure 9.80 Opening a Second Diagram
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In this situation, displaying both diagrams concurrently emphasizes the improved understanding of the
process. It also enables you to transfer information from one diagram to another (Figure 9.81).
Figure 9.81 Viewing Multiple Ishikawa Diagrams
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Input and Output Data Sets

The following is a complete list of the variables in output SAS data sets created by the ISHIKAWA environ-

ment:
Variable Type Len Description
_LEVEL_ Num 8 Level of detail
_TEXT1_ Char 40 First line of label
_TEXT2__ Char 40 Second line of label
_TEXT3_ Char 40 Third line of label
_TEXT4__ Char 40 Fourth line of label
_TEXT5__ Char 40 Fifth 1line of label
_NOTE1l_ Char 40 First line of note
_NOTE2__ Char 40 Second line of note
_NOTE3_ Char 40 Third 1line of note
_NOTE4__ Char 40 Fourth line of note
_RELPOS__ Num 8 Relative arrow position
_SIDE_ Char 1 Side arrow attaches to parent
_ANGLE_ Num 8 Angle (non-horizontal arrows)
_LWIDTH_ Num 8 Line width
_LSTYLE__ Num 8 Line style
_LCOLOR_ Char 8 Line color
_TCOLOR__ Char 8 Text color
_ICOLOR__ Char 8 Box infill color
_SCOLOR _ Char 8 Shadow color
_STYPE__ Char 1 Shadow type
_SWIDTH Num 8 Shadow width
_RELLNG__ Num 8 Relative length of an arrow
_HLEVEL Num 8 Arrow head threshold
_HSTYLE Num 8 Arrow head style
_HLNGTH__ Num 8 Arrow head length
_HWIDTH Num 8 Arrow head width
_HTEXT Num 8 Font height
_FTEXT_ Char 8 Font

Only the variables _LEVEL_ and _TEXT1_ are required in the input data set for the ISHIKAWA procedure.
Each observation in the input data set corresponds to a particular arrow in the diagram. The order of the
observations is critical because it defines the relationships of the arrows.

The trunk is always the first observation.

The remaining observations are ordered so that leaves are nested within stems, stems are nested within
branches, and branches are nested within the trunk.

The variable _LEVEL_ is numeric and indicates the level within the diagram. The trunk has a level of
0, branches have a level of 1, stems have a level of 2, and so on.

The first line of text in a label is stored as _TEXT]1_, the second as _TEXT2_, and so on.
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Example
The following is a partial listing of the SAS data set used to create the Ishikawa diagram shown in Figure 9.15:

data ishplane;
length _textl_ _text2__text3_ $ 40 _side_ $ 1;
input _level_ _textl_ & _text2_ & _text3_ & _relpos_ _side_;

datalines;
0 Quality Air Travel Service -1.00 .
1 Pre-Flight Service 0.26 T
2 Competitive fares 0.68 R
2 Convenient departure times 0.18 R
2 Quick ticketing 0.43 R
2 Frequent flier courtesies 0.81 L
1 In-Flight Service 0.61 B
2 Prompt departures 0.21 R
2 Comfortable seating 0.35 L

4

Note the structure of this data set:

The trunk (always the first observation) has a _LEVEL_ value of zero.

All subsequent observations for which _LEVEL_ is equal to one are branches that emerge from the
trunk.

Observations 4 and 5 are both leaves that emerge from the preceding stem (observation 3).

Likewise, leaves 7 and 8 emerge from the preceding stem (observation 6).

You can use this data set as a way of extracting text and notepad information from the diagram.
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Examples: ISHIKAWA Procedure

Example 9.1: Quality of Air Travel Service
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Example 9.2: Integrated Circuit Failures
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Example 9.3: Photographic Development Process
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Ishikawa diagrams

adding arrows, 720-724

aligning arrows, 741-748

arrow colors, 765-772

arrow heads, 774

arrow line style, 765-772

arrow line width, 765772
balancing arrows, 741-748

box color, modifying, 764

box shadow, 775

clipboard graphics, 761, 762

color, arrow, 765-772

color, box, 764

color, palette, 765-772

color, text, 772

context-sensitive operations, 706, 717
data collection, 748, 749

data presentation, 748, 749
deleting arrows, 733-736

detail, decreasing, 750-752

detail, increasing, 750752

Edit menu, 719

editing existing diagrams, 777, 778
editing labels, 724-727

examples, 783

examples, Integrated Circuit Failures, 784

examples, Photo Development Process, 785
examples, Quality of Air Travel Service, 783

exporting diagrams, 761, 762
File menu, 718

fonts, modifying, 763

Help menu, 720

highlighting arrows, 765-772
history, 704

hotspots, 706, 717

isolating arrows, 754, 755
labeling arrows, 724-727

line palette, 765772
managing complexity, 750758
merging diagrams, 755-758
mouse sensitivity, 775

moving arrows, 727-733, 738-748

multiple diagrams, displaying, 755-758, 778, 779

notepads, 748, 749

output, bitmaps, 761, 762

output, graphics, 758-760

output, SAS data set, 776, 781, 782
overview, 704

palettes, colors, 765772

palettes, fonts, 763

palettes, lines, 765-772

printing, bitmaps, 761, 762

printing, SAS/GRAPH output, 758-760
resizing arrows, 736-738

SAS data set, input, 777, 778, 781, 782
SAS data set, output, 776, 781, 782
saving, bitmaps, 761, 762

saving, clipboard graphics, 761, 762
saving, graphics, 758-760

saving, SAS data set, 776

subsetting arrows, 736738, 765-772
summary of operations, 717-720
swapping arrows, 738-741

syntax, 716

tagging arrows, 736738, 765-772
terminology, 705

text entry, 724-727

tutorial, 707, 708, 710-715

undo, 733-736

View menu, 719

zooming arrows, 752-754, 775
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Ishikawa diagrams
adding arrows, 720-724
aligning arrows, 741-748
balancing arrows, 741-748
data collection, 748, 749
data presentation, 748, 749
deleting arrows, 733-736
detail, decreasing, 750-752
detail, increasing, 750-752
editing existing diagrams, 777, 778
editing labels, 724-727
exporting diagrams, 761, 762
fonts, modifying, 763
highlighting arrows, 765-772
isolating arrows, 753-755
labeling arrows, 724-727
managing complexity, 750758
merging diagrams, 755-758
moving arrows, 727-733, 738-748
notepads, 748, 749
output, bitmaps, 761, 762
output, graphics, 758-760
output, SAS data set, 776, 781, 782
overview, 704
printing, bitmaps, 761, 762
printing, SAS/GRAPH output, 758-760
resizing arrows, 736-738
SAS data set, input, 777, 778, 781, 782
SAS data set, output, 776, 781, 782
saving, bitmaps, 761, 762
saving, clipboard graphics, 761, 762
saving, graphics, 758-760
saving, SAS data set, 776
subsetting arrows, 736738, 765-772
summary of operations, 717-720
swapping arrows, 738—741
tagging arrows, 736738, 765-772
terminology, 705
text entry, 724-727
undo, 733-736
zooming arrows, 752, 753, 775
ISHIKAWA procedure, 716
syntax, 716
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