Migrating Your SAS® IT Resource Management Environment from SAS 8 to SAS 9
<table>
<thead>
<tr>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Chapter 1 ▲ Migrating Your SAS IT Resource Management Environment from SAS 8 to SAS 9</strong></td>
</tr>
<tr>
<td>Introduction</td>
</tr>
<tr>
<td>Your SASUSER Library</td>
</tr>
<tr>
<td>Your Site Library/Libraries for SAS IT Resource Management</td>
</tr>
<tr>
<td>Your PDBs</td>
</tr>
<tr>
<td>MXG</td>
</tr>
<tr>
<td>Other SAS Libraries Related to SAS IT Resource Management</td>
</tr>
<tr>
<td>Remote Profiles</td>
</tr>
<tr>
<td>PDB Properties</td>
</tr>
<tr>
<td>Your List of Known PDBs</td>
</tr>
<tr>
<td>Your PGMLIB</td>
</tr>
<tr>
<td>Verifying</td>
</tr>
</tbody>
</table>
Introduction

Note: SAS IT Resource Management is the new name for IT Service Vision. You might see references in our older documentation to the former name.

You do not need to read this document if you are installing SAS IT Resource Management for the first time.

SAS IT Resource Management Release 2.7 will run only under SAS 9. △

This document explains how to migrate your SAS IT Resource Management environment that is currently running under SAS 8 to run under SAS 9.

Introductory Notes

- This document is for sites at which SAS IT Resource Management currently runs under SAS 8 but, as of Release 2.7, will run under SAS 9.

Note: If your site also has SAS IT Charge Management installed, then you must run both products on the same version of SAS. If you intend both products to be installed on SAS 9 and migrated to SAS 9, then wait to begin until you are ready to do both, so that the product releases are synchronized. △

- Supplied Software and Objects

Before you follow the instructions in this document, install SAS IT Resource Management Release 2.7 on SAS 9. This installs the supplied software and supplied objects. For more details, see the installation instructions.

- Site-Specific (Customized) Software and Objects

The two SAS versions (SAS 8 and SAS 9) have a different structure for objects. The objects that are specific to your site (your PDBs; your libraries, such as those
with custom report definitions, custom rule definitions, or custom palette
definitions; your remote profiles, and so on) need to be converted.

In this document, “convert” means to create a SAS 9 object that corresponds to
a SAS 8 object. This document describes how to do the conversions.

Note: Before you use SAS IT Resource Management 2.7 software for production
work under SAS 9, you need to convert SAS IT Resource Management objects to SAS 9.
But you can use SAS 8 objects for SAS 9 non-production work as long as you use
ACCESS=READONLY (for UNIX and Windows) or DISP=SHR (for z/OS) for the SAS 8
objects.

Convert the objects in the order in which they are presented in this document. △

Your SASUSER Library

The first time you use SAS 9, it will create a new SASUSER library, which will be
empty.

Your SAS 8 SASUSER library probably contains information that you want to
continue to use. The SAS 8 library might contain information that is related to SAS
settings. It might also contain information that is related to SAS IT Resource
Management settings, your list of known PDBs, your remote profiles, and perhaps your
custom report definitions, custom rule definitions, custom palette definitions, and so on.
Additionally, it might contain similar information about other SAS products.

Following are the instructions to copy the contents of the SAS 8 SASUSER library to
the SAS 9 SASUSER library so that the new library contains the SAS 8 contents,
structured correctly for SAS 9. In the instructions, you have two decisions to make:

Decision 1: You can copy the contents of the SAS 8 SASUSER library by using the
Program Editor window in the SAS 9 graphical user interface (GUI) or by running
the equivalent SAS batch job under SAS 9. One of these methods might be more
convenient than the other at your site.

Decision 2: You can perform an EXCLUDE copy or a SELECT copy.

[ ] The EXCLUDE copy is recommended if you are using the SAS 9 SASUSER
library for the first time. You might copy more items than you need and thus
you might need to delete some items later, but all of the items that you need
will be copied.

[ ] The SELECT copy is recommended if you have already used your SAS 9
SASUSER library. You might not copy all of the items that you need and thus
you might need to copy more items later, but you will not overwrite any items
that are already in the SAS 9 SASUSER library.

Read the instructions before acting on them, because the choices might make a
difference at your site.

1 Find the location of your SAS 8 SASUSER library and the names of the items in it.
The easiest way to do this is to bring up SAS IT Resource Management under SAS
8 in your usual way and to submit the following statements from the SAS Program
Editor window. (You can also submit these statements in a SAS 8 batch job.)

```sas
OPTIONS SOURCE NOTES;
LIBNAME SASUSER LIST;
PROC DATASETS DD=SASUSER;
QUIT;
```

In the SAS log, the location of your SASUSER library is identified by the label
Physical Name, and the items within it are listed in the Name column.
2 In a way that does not also invoke SAS IT Resource Management (or that invokes SAS IT Resource Management and then exits to SAS), invoke the SAS 9 GUI. SAS defines the SASUSER libref to point to your SAS 9 SASUSER library (and creates the library if this is your first use of SAS 9).

3 In the Program Editor window of the SAS 9 GUI, type the following code, edit the location of your SAS 8 SASUSER library, and submit the edited code. Or do the equivalent in a SAS batch job under SAS 8.

At this point, choose either the EXCLUDE copy instructions or the SELECT copy instructions.

- To perform an EXCLUDE copy (which copies everything except the items that are listed in the EXCLUDE statement):
  
  **For z/OS:**
  ```
  LIBNAME olduser
  ‘location-of-your-SAS-8-SASUSER-library’
  DISP=SHR;
  PROC COPY IN=olduser OUT=sasuser;
  EXCLUDE profile;
  RUN;
  ```
  
  **For UNIX or Windows:**
  ```
  LIBNAME olduser
  ‘location-of-your-SAS-8-SASUSER-library’
  ACCESS=READONLY;
  PROC COPY IN=olduser OUT=sasuser;
  EXCLUDE profile;
  RUN;
  ```
  
  **Note:** The profile that is being excluded is your Base SAS profile.

- If you use your SAS 9 SASUSER library with other products or applications, then some of the items that you copied might be associated with the other products and applications. Verify that those products or applications are working properly after the copy has been performed.

- To perform a SELECT copy (which copies only the items that are listed in the SELECT statement):

  **For z/OS:**
  ```
  LIBNAME olduser
  ‘location-of-your-SAS-8-SASUSER-library’
  DISP=SHR;
  PROC COPY IN=olduser OUT=sasuser;
  SELECT cpusropt cpver itsv workarea tskinfo
cpugms cpuout cpulog cpugseg cpusrc;
  RUN;
  ```

  **For UNIX or Windows:**
  ```
  LIBNAME olduser
  ‘location-of-your-SAS-8-SASUSER-library’
  ACCESS=READONLY;
  PROC COPY IN=olduser OUT=sasuser;
  SELECT cpusropt cpver itsv workarea tskinfo
cpugms cpuout cpulog cpugseg cpusrc;
  RUN;
  ```
Note: The preceding SELECT statement contains a list of the names of the items that SAS IT Resource Management might have created in the SAS 8 SASUSER library. Add to this list the names of any objects that you created (report definition folders, rule definition folders, palette definition folders, data sets, views, catalogs, and so on) in the SAS 8 SASUSER library and that you want to continue to use under SAS 9. For example, if you have report definitions in SASUSER.MYDEFS, then add MYDEFS to the list. However, do not add your Base SAS profile (PROFILE) to the list.

Some of the items that are listed in the preceding SELECT statement might not be present in your SAS 8 SASUSER library. Missing items are not a problem. You can omit them from the list or leave them in the list.

If you use your SAS 9 SASUSER library with other products or applications, then verify that those products or applications are working properly after the copy has been performed. You might need to re-copy some of the items that are associated with those products and applications.

Your Site Library/Libraries for SAS IT Resource Management

If you have made modifications to your SAS 8 SITELIB library and want to migrate those modified settings to SAS 9, then you will need to make a new SAS IT Resource Management site library (SITELIB) for use with SAS 9 and copy the contents of the SAS 8 site library to it. (If you have more than one SAS IT Resource Management site library, then you will need to do this one time for each site library.)

Note: The installation instructions include a SAS IT Resource Management appendix that refers to instructions named CPSITEUP.

- On z/OS, they are in the SAS IT Resource Management PDS named CPMISC.
- On Windows, they are in the directory named cpe/sasmisc.
- On UNIX, they are in the directory named !SASROOT/misc/cpe.

If, as a result of following those instructions, you made SITELIB refer to a SAS 9 SAS library, then you can skip this section of this document.

Following are the instructions to copy the contents of the SAS 8 site library to the SAS 9 site library so that they are structured correctly for SAS 9. You can perform the copy by using the SAS 9 GUI or by running the equivalent SAS batch job under SAS 9. Read the instructions before acting on them, because the choice of method might make a difference at your site.

1 Find the location of your SAS 8 site library. You can do this by invoking the SAS IT Resource Management GUI under SAS 8 and by using the Site Options button on the Administration tab in the UNIX/WIndows GUI, or by following this path in the z/OS GUI: from the main menu, select Options ▶ Site SAS Options ▶ Site Location. If in doubt, consult the SAS IT Resource Management administrator at your site.

Then find the location of your SAS 9 site library. You can do this by invoking the SAS IT Resource Management GUI under SAS 9 and by using the method that is described in the previous paragraph. If in doubt, consult the SAS IT Resource Management administrator at your site or consult the person who installed SAS IT Resource Management Release 2.7.

2 Only for z/OS: Run IEFBR14 or use ISPF 3.2 to allocate space for a SAS 9 site library if the installation of SAS IT Resource Management Release 2.7 did not already do this. Except for the DSN= and perhaps adding more space if the SAS 8 site library was running out of space, you can use the same amount of space and the same DCB that you used for the SAS 8 site library.
In a way that does not also invoke SAS IT Resource Management, invoke the SAS 9 GUI. Or invoke the SAS IT Resource Management GUI and exit to SAS. Or in a way that does not also invoke SAS IT Resource Management, construct a batch job that invokes SAS 9.

4 Type the following code in the SAS Program Editor window, edit the locations of your SAS 8 and SAS 9 site libraries, and submit the edited code. Or add the edited code to the SAS job, and submit the batch job.

For z/OS:

LIBNAME OLDSITE
  ’location-of-your-SAS-8-site-library-for-earlier-SAS-ITRM’
  DISP=SHR;
LIBNAME SITELIB
  ’location-of-your-SAS-9-site-library-for-SAS-ITRM-2.7’
  DISP=OLD;
PROC COPY IN=oldsite OUT=sitelib;
RUN;

For UNIX or Windows:

LIBNAME oldsite
  ’location-of-your-SAS-8-site-library-for-earlier-SAS-ITRM’
  ACCESS=READONLY;
LIBNAME sitelib
  ’location-of-your-SAS-9-site-library-for-SAS-ITRM-2.7’;
PROC COPY IN=oldsite OUT=sitelib;
RUN;

Note: You might need to edit some of the values in the SAS 9 site library, but do not do this until you finish converting the other objects. There are instructions for editing later in this document.

Your PDBs

PDBs that are created in SAS 8 can be accessed in read-only mode from SAS 9, but not in write mode. Each PDB that you want to write to from SAS 9 will need to be converted from SAS 8 format to SAS 9 format. You can use either of the following methods:

- Copy the PDB, making the new target copy a SAS 9 PDB. This will enable you to continue using the SAS 8 PDB while also having a SAS 9 PDB available for validation or testing.
- Convert the SAS 8 PDB to a SAS 9 format in place. This will save space but will not enable you to have both a SAS 8 and a SAS 9 format of the contract database available simultaneously.

You do not need to convert the demonstration PDBs. When SAS IT Resource Management 2.7 is installed, the demonstration PDBs are created in SAS 9 format.

Converting PDBs by Copying

You can copy the PDBs either by using the SAS 9 GUI with SAS IT Resource Management 2.7 or by running a SAS batch job under SAS 9 and invoking SAS IT Resource Management 2.7. Read the instructions before acting on them, because the
choice of method might make a difference at your site. (For example, on z/OS, doing this operation in a batch job is strongly recommended.)

1 Find the location of your SAS 8 PDB. To remind yourself of the PDB locations, you can invoke the SAS IT Resource Management GUI under SAS 8. Then, in the UNIX/Windows GUI, select the Manage PDBs button on the Administration tab. In the z/OS GUI, from the main menu, select PDB Admin ▶ Manage PDBs/ Switch PDB. If in doubt, consult the SAS IT Resource Management administrator at your site.

Then, plan the location of your SAS 9 PDB. If in doubt, consult the SAS IT Resource Management administrator at your site or consult the person who installed SAS IT Resource Management Release 2.7.

2 On z/OS, allocate space for each of the PDB libraries. On UNIX and Windows, create a directory for the PDB and create subdirectories for each of the PDB libraries. There is no requirement at this point for the new PDB to contain any other structure or any content.

   □ On a z/OS server host:

       Use the 3270-style GUI (from the main menu, select PDB Admin ▶ Define New PDB, and do not add tables), or run IEFBR14, or use ISPF 3.2 to allocate space for the SAS 8 PDB libraries. Except for the DSN= and perhaps adding more space if the SAS 8 site library was running out of space, you can use the same amount of space and the same DCB that you used for the SAS 8 PDB libraries. You will need to allocate nine libraries for each PDB, all of whose names start with the PDB name as a prefix. If your PDB name is MYPDB, for example, then you will need to allocate the following libraries:

       □ MYDB.DICTLIB
       □ MYDB.DETAIL
       □ MYDB.DAY
       □ MYDB.WEEK
       □ MYDB.MONTH
       □ MYDB.YEAR
       □ MYDB.ADMIN
       □ MYDB.PDBWORK
       □ MYDB.COLLECT

       A sample job to allocate a PDB is found in the CMPDBALC member of the SAS IT Resource Management CPMISC PDS. You might need to adjust the SPACE= parameters and possibly the UNIT= and BLKSIZE= parameters.

   □ On a UNIX or Windows server host:

       Create directories for the SAS 9 PDB and its libraries. You can create them by using the UNIX/Windows GUI (from the main window, select the QuickStart Wizard or the Create PDB Wizard), or by using the SAS IT Resource Management %CPSTART macro in a SAS batch job, or by using the mkdir command at the operating system prompt.

       If your PDB name is PDB, for example, then you will need to create the following directories:

       □ /my/pdb or c:\My\Pdb
       □ /my/pdb/dictlib or c:\My\Pdb\Dictlib
       □ /my/pdb/detail or c:\My\Pdb\Detail
       □ /my/pdb/day or c:\My\Pdb\Day
       □ /my/pdb/week or c:\My\Pdb\Week

   □ On a mainframe server host:

       Use the 3270-style GUI (from the main menu, select PDB Admin ▶ Define New PDB, and do not add tables), or run IEFBR14, or use ISPF 3.2 to allocate space for the SAS 8 PDB libraries. Except for the DSN= and perhaps adding more space if the SAS 8 site library was running out of space, you can use the same amount of space and the same DCB that you used for the SAS 8 PDB libraries. You will need to allocate nine libraries for each PDB, all of whose names start with the PDB name as a prefix. If your PDB name is MYPDB, for example, then you will need to allocate the following libraries:

       □ MYDB.DICTLIB
       □ MYDB.DETAIL
       □ MYDB.DAY
       □ MYDB.WEEK
       □ MYDB.MONTH
       □ MYDB.YEAR
       □ MYDB.ADMIN
       □ MYDB.PDBWORK
       □ MYDB.COLLECT

       A sample job to allocate a PDB is found in the CMPDBALC member of the SAS IT Resource Management CPMISC PDS. You might need to adjust the SPACE= parameters and possibly the UNIT= and BLKSIZE= parameters.
3 Copy the contents of the SAS 8 PDB to the SAS 9 PDB.

- **By using the GUI:**
  
  If the SAS 9 GUI is not already invoked, then invoke it. Then, invoke SAS IT Resource Management 2.7 software, using one of the SAS 9 demonstration PDBs as the active PDB.

  **If the PDB that is to be converted is on a z/OS server:**
  
  From the main menu: select PDB Admin ▶ Manage PDBs/Switch PDBs ▶ the name of the SAS 8 PDB. Then, from the Item Actions menu select Copy PDB, type or select the location of the SAS 9 PDB, and select Run. When the confirmation window appears, select OK. When the copy operation is finished, select Goback to return to the PDB Admin window. From the list of known PDBs, select the name of the SAS 8 PDB. From the Item Actions menu, select Remove PDB Entry.

  **Reminder:** The batch method of copying the PDB is preferred, because copying the PDB in a TSO session might take a very long time.

  **If the PDB that is to be converted is on a UNIX or Windows server:**
  
  On the Administration tab, select Manage PDBs. From the list of known PDBs, select the name of the SAS 8 PDB. From the File menu, select Copy. In the To field, type or select the name of the SAS 9 PDB. Then select OK. When the copy operation is finished, from the list of known PDBs, select the name of the SAS 8 PDB. From the File menu, select Remove PDB Entry.

  **Note:** The preceding z/OS and UNIX/Windows paragraphs assume that you retained the original name and location of the SAS 8 PDB and that you used a new name and location for the SAS 9 PDB. If, instead, you renamed and moved the SAS 8 PDB and you used the original name and location for the SAS 9 PDB, then you do not need to remove the original name from your list of known PDBs in SAS 9. But you might want to change the name of the SAS 8 PDB in your list of known PDBs and remote profiles in SAS 8.

- **By using a batch job:**
  
  If a batch job that invokes SAS 9 has not already been constructed, then construct one now. (On UNIX and Windows, be sure that the invocation uses your SAS 9 SASUSER library.) Then, add a call to the %CPSTART macro in order to invoke SAS IT Resource Management 2.7 software, using one of the SAS 9 demonstration PDBs as the active PDB. Add a call to the %CPDBCOPY macro in order to copy the contents of the SAS 8 PDB to the SAS 9 PDB, and add a call to the %CPSTART macro in order to activate the SAS 9 PDB.

  In the first call to the %CPSTART macro, you need to specify the **ROOT=** parameter so that it can point to the location of the SAS IT Resource Management 2.7 software. Refer to the following examples.

  **If the PDB that is to be converted is on a z/OS server:**

  ```bash
  %cpstart(mode=batch,
           root=location-of-SAS-IT-Resource-Management-2.7,
           pdb=location-of-SAS-9-demonstration-PDB,
           disp=shr);
  ```
Converting PDBs by Copying

Chapter 1

%cpdbcopy
(location-of-SAS-8-PDB,
location-of-SAS-9-PDB);

%cpstart(mode=batch,
root=location-of-SAS-IT-Resource-Management-2.7,
pdb=location-of-SAS-9-PDB,
disp=old);

Note: The root= parameter, that is specified as your "location-of-SAS-IT-Resource-Management-2.7" in the preceding code, might need to include a two-letter reference to the encoding that is installed at your site. Additional information on encodings is available in the Configuration Guide for SAS® 9.1.3 Foundation for z/OS.

If the PDB that is to be converted is on a UNIX or Windows server:

%cpstart(mode=batch,
root=location-of-SAS-IT-Resource-Management-2.7,
pdb=location-of-SAS-9-demonstration-PDB,
access=readonly);

%cpdbcopy
(location-of-SAS-8-PDB,
location-of-SAS-9-PDB);

%cpstart(mode=batch,
root=location-of-SAS-IT-Resource-Management-2.7,
pdb=location-of-SAS-9-PDB,
access=write);

If you use the SAS IT Resource Management GUI, then check that your list of known PDBs in SAS 9 has the appropriate names and locations, and update any that need to be changed. You might want to do the same for your list of known PDBs in SAS 8. Access and, if necessary, edit your list of known PDBs as described earlier. (In the “Converting PDBs by Copying” section, see step 3.) For more information about calling these macros, see the SAS IT Resource Management reference documentation.

4 Your site might have a .QS PDS or /qs directory “under” your PDB. That PDS or directory is not a SAS object (and its related PDSs and subdirectories are not SAS objects). If you want to make a copy of them “under” the SAS 9 PDB, then you can use an operating system command. Refer to the following examples.

On a z/OS server, you can use ISPF 3.3 or IEBCOPY in batch, or you can use a similar utility. (There are multiple PDSs with a .QS qualifier. Be sure to copy each of them.)

On a Windows server, you can use XCOPY or a similar command.

On a UNIX server, you can use

cp -R location-of-SAS-8-PDB/qs location-of-SAS-9-PDB/qs

Also, if you want to use the QuickStart jobs with the SAS 9 PDB, you will need to edit the xREPORT, xPROCESS, and possibly xFTPHtml files in the “location-of-SAS-9-PDB/qs/cntl” or “location-of-SAS-9-PDB qs\cntl” directory or in the “location-of-SAS-9-PDB.QS.CNTL” PDS, and then to change the PDB and ROOT references that are contained in those files.

5 Your site might have an archive “under” or associated with your PDB. An archive is used only in read-only mode and thus its archive libraries do not require
Migrating Your SAS IT Resource Management Environment from SAS 8 to SAS 9

Other SAS Libraries

Conversion. (If you need to restore data from these archive libraries later, then you will need to remember that they have their original names and locations.)

Converting PDBs in Place

You might want to convert a SAS 8 format PDB to SAS 9 by converting it in place rather than copying. We strongly recommend that you perform this operation in batch mode, especially when you are running under z/OS. Use the preceding instructions to locate the SAS 8 PDBs that need to be converted. If you are performing this operation interactively, close the SAS IT Resource Management GUI and continue to keep SAS active. If you are running a batch job, submit a CPSTART macro to activate any PDB, and then use the following statement under SAS 9:

\%cpdbconv(location-of-PDB);

This conversion is reversible, so if you have a SAS 9 PDB and want to convert it back to a SAS 8 PDB, you can do so by using the same statement under SAS 8. However, SAS IT Resource Management 2.6 must be installed, with (at least) the 82IS06 hot fix applied.

MXG

If you install a new version of MXG, then part of the installation procedure is to run a job that creates and populates a SAS library of formats for use with MXG. When you run the job under SAS 9, a SAS 9 library will be the result.

If you want to continue to use your existing SAS 8 format library until you install the next version of MXG, then you can convert the existing format library from SAS 8 to SAS 9. First, allocate space for the new library, as described in the section “Your Site Library/Libraries for SAS IT Resource Management.” Then, to copy the catalog that contains the formats, submit SAS code like this through the SAS 8 Program Editor window or a SAS 9 batch job:

LIBNAME V8LIB
  ‘location-of-SAS-8-format-library-for-MXG’
  DISP=SHR;
LIBNAME V9LIB
  ‘location-of-SAS-9-format-library-for-MXG’
  DISP=OLD;
PROC CATALOG CAT=V8LIB.FORMATS;
COPY OUT=V9LIB.FORMATS;
RUN;
QUIT;

Other SAS Libraries Related to SAS IT Resource Management

You might have other SAS 8 libraries that are related to SAS IT Resource Management, such as one or more libraries for custom report definitions, custom rule definitions, custom palette definitions, and source code for exits.

Convert each of these libraries in the same way that you converted the site library. However, you might want to use different librefs for clarity. For example, instead of oldsite you might want to use oldlib, and instead of sitelib you might want to use
newlib. And the locations that you edit are the locations of the old and new custom library, not the old and new site library.

---

**Remote Profiles**

If you use any remote profiles, edit the locations in them to refer to the SAS 9 objects. To do so, you can follow this path: on the **Administration** tab, select **Manage PDBs** ▶ **Locals** ▶ **Remote Profile**.

Then, for each profile that you use, select the profile name, then select **File** ▶ **Open**. Review the contents of all fields on all tabs, and edit the values for any software or objects whose location has changed. Then select **OK** ▶ **OK** ▶ **Close**.

*Note:* This section assumed that the original names and locations were retained for the SAS 8 objects and that new names and locations were used for the SAS 9 objects. If, instead, the SAS 8 objects were renamed and moved, and if the SAS 9 objects used the original names and locations, then you do not need to edit your SAS 9 remote profiles. But you might want to edit the SAS 8 remote profiles.

---

**PDB Properties**

If you have a PDB that has an archive, then decide whether you want the SAS 9 PDB to use the same archive as the SAS 8 PDB or to use a new archive. (Either is acceptable.) Then, edit the SAS 9 PDB’s properties that refer to the location of the archive. (If nothing was specified, then the location of the archive is probably changing, because the default location is “under the PDB” and the location of the PDB is probably changing.)

- To edit in batch, call `%CPSTART` to activate that PDB. Then, call the `%CPPDPOPT` macro to specify the values of its archive parameters.
- To edit by using the 3270-style GUI, activate that PDB and then, from the main menu, select **PDB Admin** ▶ **Set Active PDB Options** ▶ **edit the values of the archive parameter** ▶ **OK**.
- To edit by using the UNIX/Windows GUI, on the **Applications** tab, select **Manage PDBs**, activate the PDB if it is not already activated, select **Properties**, select the **Archive** tab, edit the values of the archive parameters, and select **OK** ▶ **Close**.

---

**Your List of Known PDBs**

If you use the SAS IT Resource Management GUI, then edit your list of known PDBs if you are on a client host. For instructions, see step 3 in the “Converting PDBs by Copying” section.

---

**Your PGMLIB**

*Note:* The following paragraphs describe the same operation that you perform for every new PGMLIB if you have an installed user-written table in the earlier PGMLIB. The operation is not related to the conversion from SAS 8 to SAS 9.
SAS IT Resource Management Release 2.7 includes a SAS 9 PGMLIB. If you installed a user-written table definition in your SAS 8 PGMLIB, then you might want to install that table definition in your SAS 9 PGMLIB. To do so, write a batch job that performs the following actions:
- invokes SAS 9
- calls the %CPSTART macro to start SAS IT Resource Management 2.7 and to activate a PDB that contains the table
- calls the %CPDDUTL macro to apply the INSTALL TABLE control statement.

For more information about how to use the %CPDDUTL macro and about the %CPDDUTL control statement INSTALL TABLE, see the SAS IT Resource Management macro reference documentation.

**Verifying**

Ideally, run both the SAS 8 and SAS 9 systems in parallel for two weeks and compare the results every day. If you have a very large site, then running in parallel might not be possible, but you should at least run parallel test systems before converting the production system to SAS 9.

At minimum, compare the process summary tables and reduce summary tables in the SAS 8 and SAS 9 logs.
We want your feedback.

☐ If you have comments about this book, please send them to yourturn@sas.com. Include the full title and page numbers (if applicable).

☐ If you have comments about the software, please send them to suggest@sas.com.
SAS® Publishing gives you the tools to flourish in any environment with SAS!

Whether you are new to the workforce or an experienced professional, you need to distinguish yourself in this rapidly changing and competitive job market. SAS® Publishing provides you with a wide range of resources to help you set yourself apart.

**SAS® Press Series**
Need to learn the basics? Struggling with a programming problem? You’ll find the expert answers that you need in example-rich books from the SAS Press Series. Written by experienced SAS professionals from around the world, these books deliver real-world insights on a broad range of topics for all skill levels.

[support.sas.com/saspress](http://support.sas.com/saspress)

**SAS® Documentation**
To successfully implement applications using SAS software, companies in every industry and on every continent all turn to the one source for accurate, timely, and reliable information—SAS documentation. We currently produce the following types of reference documentation: online help that is built into the software, tutorials that are integrated into the product, reference documentation delivered in HTML and PDF—free on the Web, and hard-copy books.

[support.sas.com/publishing](http://support.sas.com/publishing)

**SAS® Learning Edition 4.1**
Get a workplace advantage, perform analytics in less time, and prepare for the SAS Base Programming exam and SAS Advanced Programming exam with SAS® Learning Edition 4.1. This inexpensive, intuitive personal learning version of SAS includes Base SAS® 9.1.3, SAS/STAT®, SAS/GRAPH®, SAS/QC®, SAS/ETS®, and SAS® Enterprise Guide® 4.1. Whether you are a professor, student, or business professional, this is a great way to learn SAS.

[support.sas.com/LE](http://support.sas.com/LE)