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Overview of SAS Enterprise Guide Administration

In order for SAS Enterprise Guide to be able to access the analytical power of SAS, it
must have access to SAS data and resources. After you have installed SAS Enterprise
Guide at your organization, a large part of the process of administering the application
consists of defining the locations of SAS data and resources. These definitions enable
SAS Enterprise Guide users to access the data transparently, without having to know
anything about the actual location. These definitions are stored as metadata, so you
must determine the location and type of the metadata repository, and then make sure
that all SAS Enterprise Guide users access the repository. After you have a location to
store metadata definitions, you can create definitions for SAS resources such as servers
and libraries. Depending on which type of metadata repository you are using, you can
also define resources such as users and user groups and can select the tasks that SAS
Enterprise Guide users have access to.

Most administration tasks are performed using SAS Enterprise Guide Explorer,
which is a component of SAS Enterprise Guide. SAS Enterprise Guide Explorer can
also be used by non-administrators to view the metadata definitions. Depending on
which type of metadata repository you are using, you might also need to use SAS
Management Console in the administration process.

Figure 1.1 on page 2 illustrates how SAS Enterprise Guide uses the metadata
definitions that are created by SAS Enterprise Guide Explorer to access SAS resources
such as servers and libraries.
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Figure 1.1 Creating and Accessing Metadata Definitions

SAS Enterprise
Guide Explorer

Creates metadata definitions
for servers and libraries

Metadata Repository

Server definition Library definition

Retrieves locations of
server and library from
metadata definitions

SAS Enterprise
Guide user

Accesses server and
library identified by
metadata definitions

Library definition

Server definition #2

Server definition #3

Server

What Is SAS Enterprise Guide?

SAS Enterprise Guide is a thin-client Windows applications that provide a
point-and-click desktop interface to the SAS System (Version 8 or later). SAS

Enterprise Guide can be used to connect to various server platforms, including UNIX, z/
0OS, and Windows. SAS Enterprise Guide communicates with the SAS System to access
data, perform analysis, and generate results. From SAS Enterprise Guide you can
access and analyze many types of data, such as SAS data sets, Excel spreadsheets, and
third-party databases. You can either use a set of task dialog boxes or write your own
SAS code to perform your analysis. The application helps users to produce results

easily, regardless of their SAS knowledge.

SAS Enterprise Guide uses a distributed computing model of networked servers that

enable users to access data on multiple platforms quickly and easily.

What Is SAS Enterprise Guide Explorer?

SAS Enterprise Guide Explorer is an application for network and PC administrators
that serves as a central resource manager for SAS Enterprise Guide. The resource
definitions are stored in a metadata repository, thus enabling all users to access the



Introduction to SAS Enterprise Guide Administration /A Updates to This Guide 3

same resources. SAS Enterprise Guide and SAS Enterprise Guide Explorer can access
metadata definitions in SAS Metadata Repositories as well as SAS Enterprise Guide
repositories.

With SAS Enterprise Guide Explorer you can perform the following tasks:

O manage metadata repository definitions by specifying access information and
setting an active repository

O create metadata definitions for SAS servers and libraries

O set up virtual folders with shortcuts to multiplatform data (when using a SAS
Enterprise Guide repository)

O set up groups of users to provide high-security access to resources, or bypass groups
to provide low-security access (when using a SAS Enterprise Guide repository)

For example, you could add a SAS server that runs on UNIX, specify which users have
access to the server, and set up SAS libraries on that server. The specified users could
then access the libraries from their SAS Enterprise Guide installation.

SAS Enterprise Guide Explorer operates in either Admin or User mode. Admin mode
is available only to users who have had administration features activated, while User
mode is available to all users. In Admin mode, users can create and modify metadata
definitions and manage repositories. In User mode, users can only view metadata
definitions.

About Metadata Repositories

SAS Enterprise Guide and SAS Enterprise Guide Explorer can work with metadata
definitions in a SAS Metadata Repository or a SAS Enterprise Guide Repository.
Although you can create definitions for multiple repositories of each type, you must
choose a single repository as the active repository. The active repository is the source
and destination for resource definitions.

The type of metadata repository that you use depends on the needs and requirements
of your organization. The following table compares the two types of metadata

repositories.
Feature SAS Metadata Repository SAS Enterprise Guide
Repository

Definition sharing Metadata definitions shared Metadata definitions used by
among all SAS Business SAS Enterprise Guide only
Intelligence applications

Definitions created by SAS Servers, libraries Servers, libraries, users,

Enterprise Guide Explorer groups, binders

Other administrative SAS Management Console None

applications

Updates to This Guide

Updates to this guide are available from the SAS Institute Web site at
support.sas.com.
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Getting Help

To get started with SAS Enterprise Guide Explorer, from the SAS Enterprise Guide
Explorer main menu, click Help » SAS Enterprise Guide Explorer Help, or click the
Help button in any SAS Enterprise Guide Explorer dialog box to get help for that dialog
box.

For technical assistance, contact SAS Technical Support or visit the Web site at
support.sas.com.
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Installing

SAS Enterprise Guide

Locating Installation Media

System requirements and instructions for installing SAS Enterprise Guide are
described in the installation document that is included with the SAS Enterprise Guide
application software CD.

The SAS Enterprise Guide software is installed on Microsoft Windows platforms and
provides access to SAS services and data that are located on your network. A SAS
server can be located on Windows XP, Windows NT, z/OS, or UNIX (AIX 4.2, HP-UX
10.20, or Solaris 2.6) platforms. Specific installation procedures are provided with the
SAS Enterprise Guide software.

Using Quiet Mode to Install SAS Enterprise Guide

Understanding Quiet Mode

The quiet install program enables you to create a quiet record file, which contains
responses to all of the prompts that are encountered during installation. You can then
point to the file when you install SAS Enterprise Guide, which installs the application
without requiring any responses from the machine’s user. You can use the quiet mode
installation together with applications such as Microsoft System Management Server
(SMS) to remotely install SAS Enterprise Guide throughout your organization.

Note: The installation process also requires you to run the SAS Enterprise Guide
System Requirements Wizard on every machine on which SAS Enterprise Guide will be
installed. This wizard verifies that all system software components are at the required
level, makes updates as necessary, and performs any required reboots. The System
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Requirements Wizard can also be run in quiet mode, which lets you include this step in
a remote installation plan.
In addition, you must verify the following conditions on each machine on which you
are installing SAS Enterprise Guide:
0 Each machine must have enough free disk space. Refer to the SAS Enterprise
Guide installation documentation for specific information about the amount of disk
space that is required.

0 Each machine must not have a hardware password enabled. A hardware password

prevents the reboots that are required when the System Requirements Wizard
runs.

A

Recording an Installation

When you record an installation, you are recording all your dialog box settings in a
quiet record file. As you proceed through the dialog boxes, read all of the available
online Help before continuing.

To record an installation:

1 Determine the location of the source SAS Enterprise Guide image (that is, the
image from which you want to install). Make this location the current directory.
Start the install recording wizard by entering the setup.exe record command.
On the first page of the wizard, select a language for the remainder of the wizard.
4 On the second page of the wizard, specify the location of the quiet record file. The

default location is the current path, and the default filename is quiet.ini. If you

specify the filename and location of an existing quiet record file, the file will be
overwritten with no warning.
5 On the next page of the wizard, edit the information that will be stored in the

quiet record file. These values specify responses to prompts that are displayed in a

normal install. For example, specifying a value of Yes for AddDesktopShortcut

indicates that a desktop shortcut is automatically created for all SAS Enterprise
Guide installations.

Enterprise Guide 5etup ﬂ
Edit Quiet Record File Sas

The ddministrator Uzer Guide has information about how to edit the zettings for the guiet record
file belovs. Usze Chl-Enter to add new lines. To save the quiet recard file, click MNest.

W N

[Silent Optionz]
ReplaceRegistik epe=v'as
AddD esktopShortout=r'as
CopySASSyntasHelp="'es
CopytdminFiles="es

|+

[Language Selections]
Languagel=eng

[Default Language] |

Default=eng
| _'l_I
[ietallshield

< Back | Mewt > I Cancel |

The values that are specified in the quiet record file are as follows:
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ReplaceRegistryKeys
specifies whether the installation process updates all registry
entries that SAS Enterprise Guide uses without prompting the
user to check for potential conflicts. Specify Yes (the default) to
automatically make all registry changes or No to require the user
to verify changes.

AddDesktopShortcut
specifies whether to create a shortcut on the user’s desktop for
SAS Enterprise Guide. Specify Yes (the default) to create the
shortcut or No to not create it.

CopySASSyntaxHelp
specifies whether the help for SAS syntax elements is installed
along with SAS Enterprise Guide. Specify Yes (the default) to
install the help or No to omit installation. The SAS syntax help
requires approximately 57MB to install, so if you select Yes, you
must ensure that all users machines have enough free disk space.

CopyAdminFiles
specifies whether to allow the ability to use SAS Enterprise Guide
Explorer for administration functions. If the administration
functions are not installed, SAS Enterprise Guide Explorer can
still be used to view resource information. Specify Yes (the
default) to install the administration functions or No to omit the
installation.

Languagel
specifies which localized versions of SAS Enterprise Guide will be
installed. You must specify at least one language (identified as
Languagel, which is specified as English by default). Additional
languages are specified as Language2, Language3, and so forth.
The default value is eng (English). Other valid values are as
follows:
zho Simplified Chinese
zht Chinese Traditional
fra French
deu German
iwr Hebrew
hun Hungarian
ita Italian
jpn Japanese
kor Korean
pol Polish
rus Russian
esp Spanish
sve Swedish

Default

specifies the localized version of SAS Enterprise Guide that is
used by default whenever the application is started. The language



8

Using Quiet Mode to Install SAS Enterprise Guide A Chapter 2

Location

that you select must be a language that you have specified to be
installed. The default value is eng (English).

specifies the installation path for SAS Enterprise Guide. If you do
not specify a path, a default path of ¢: \Program
Files\SAS\Enterprise Guide 4 is used. The user is prompted
to supply an installation path. This setting does not contain a
default value.

6 On the last page of the wizard, select Finish to close the wizard and save the

quiet record file.

After you have created the quiet record file for SAS Enterprise Guide, create a quiet
record file for the System Requirements Wizard. To create this file, follow the steps in

the following section.

Performing a Quiet Installation

After you record your quiet record file, you can use it to repeat the same installation
without using or seeing the setup dialog boxes. You can also use the quiet record file
together with an application such as Microsoft Systems Management Server (SMS) to
install SAS Enterprise Guide remotely.

Before you can install SAS Enterprise Guide, you must run the System
Requirements Wizard. To run the wizard in quiet mode, follow these steps:

1 Determine the location of the System Requirements Wizard. The wizard is located
in the \SRW directory of the location of your SAS install image.

2 Enter this command:

LOCATION\SETUP.EXE -s -f2'' log_file r
‘‘QuietLog:log_file’’
‘‘LogFile:DetailedLogFile’’
‘*AutoID:UserID’’

‘ ‘AutoPwd:Password’’

‘*AutoDomain:Domain’ ’

—£2”1og_file”

QuietLog:log_file

specifies the fully qualified path to the log file that contains the
dialog box responses.

specifies the fully qualified path to the log file that contains the
dialog box responses.

LogFile:DetailedLogFile

AutolD,
AutoPwd,
AutoDomain

specifies the fully qualified path to the detailed log of the quiet
installation.

specifies the user ID, password, and domain of the user under
which the wizard runs. The ID, password, and domain must be
valid for each machine on which you run the wizard. If you do
not specify these options, the wizard will not finish running
until a user manually logs on to the machine. The user ID and
password are stored in the Windows Registry of the remote
machine between reboots and are removed from the registry
after the last reboot.

3 Check the detailed log file for any errors that prevented the System Requirements
Wizard from finishing on a machine.
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After you have run the System Requirements Wizard on all machines, you can install
the SAS Enterprise Guide application. To install SAS Enterprise Guide in quiet mode,
follow these steps:

1 Determine the location of the source SAS Enterprise Guide image, and make that
the location of the current directory.

2 Determine the name and the location of the quiet record file that you want to use.
For this example, the location is C:\quiet.ini.

Note: If you do not provide the pathname and filename for the setup response
file, then the setup program tries to use quiet.ini in the directory where setup.exe
resides. A

3 Run the setup program by using the /s quietfile: command line options to
specify quiet mode and the quiet record file that should be used for input. Here is
an example command:

m:\eg> setup /s quietfile:=’’c:\quiet.ini’’

You can also use the /f2 option to specify the location of an installation log file.
Here is an example:

m:\eg> setup /s quietfile='’'C:\quiet.ini’’ /£2’'’C:\EGInstall.log’’

You can also use the silentstatus option to display an installation status
monitor on the user’s desktop during installation.

Troubleshooting

If the quiet setup program encounters a problem during playback, then the program
terminates. When the program terminates, the status dialog box disappears and all of
the changes that were made to your system are reversed. The system is left in its
original state.

Installing SAS Servers

This section describes the configuration of a SAS server for use with SAS Enterprise
Guide. These instructions complement the normal SAS installation. For system
requirements for installing SAS on server hosts, see the installation instructions that
are included with the SAS installation CD.

1 Install the required SAS software.

Using the SAS installation procedures that are included with the software
package, install Version 8 or a later version of SAS software on the server host.
These products are required when you install SAS software:

0 Base SAS
o SAS Core
o SAS Integration Technologies.

2 Install additional SAS products.

Based on your business needs, install any additional SAS products by using the
installation procedures that are provided with the software package. The following
is a sample list of products that you can install on the server.

o SAS/ACCESS (for accessing database management system data, such as data
that is housed in Oracle or DB2)

o SAS/ETS



10

Troubleshooting the Installation A Chapter 2

o SAS/GRAPH
o SAS/QC

o SAS/MDDB
O SAS/STAT.

3 Configure the object server.

After you install SAS, you need to configure a SAS object server so that it can
communicate with SAS Enterprise Guide. The configuration procedure that you
follow is based on the host environment of the server and on whether you are
using a SAS Metadata Repository or a SAS Enterprise Guide repository.

If the server is running on a local Windows machine, you can use a COM
connection. If the server is running on a remote Windows machine, you must use
an IOM Bridge connection. If the server is running on a z/OS or UNIX platform,
you must use an IOM Bridge connection and a SAS spawner to communicate with
the server.

If you are using a SAS Metadata Repository, you can define the object server by
using SAS Management Console. From the Server Manager, start the New Server
wizard, define a SAS Application Server, and select SAS Workspace Server as the
server type. See SAS Management Console: User’s Guide for more information.

If you are using a SAS Enterprise Guide repository, you must define the object
server manually. See SAS Integration Technologies: Server Administrator’s Guide
for information on defining a COM or IOM Bridge connection and defining a SAS
Spawner.

Troubleshooting the Installation

After you install SAS Enterprise Guide, you must verify that the installation was
successful. To verify the installation, start SAS Enterprise Guide. If SAS Enterprise
Guide displays an error message that indicates that the application cannot connect to
the local repository, then contact either your local SAS representative or SAS Technical
Support before continuing. This process will identify any problem machines that are
not found by the installation wizard.
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What Is a Metadata Repository?

A metadata repository contains definitions for objects such as servers and libraries
that are used by SAS Enterprise Guide and other applications. SAS Enterprise Guide
can use metadata from a SAS Metadata Repository or from a SAS Enterprise Guide
repository. Metadata definitions in a SAS Metadata Repository can be used by many
other applications besides SAS Enterprise Guide, which lets you use a single set of
object definitions for all SAS applications in your organization.

If you use a SAS Metadata Repository, you can use SAS Enterprise Guide Explorer to
define servers and libraries. Other metadata definitions (such as users and SAS content)
are defined by SAS Management Console or other applications such as ETL Studio.

If you use a SAS Enterprise Guide repository, you can use SAS Enterprise Guide
Explorer to define servers, libraries, users, groups, and binders.

Setting up metadata repositories is an essential part of SAS Enterprise Guide
administration because SAS Enterprise Guide needs to access at least one repository,
whether the repository is stored locally or on a networked Windows server. You can use
SAS Enterprise Guide Explorer to identify which type of repository will be used to store
object definitions.

You can use SAS Enterprise Guide Explorer to create definitions for multiple
repositories of each of the supported types, and then select one repository as the active
repository. SAS Enterprise Guide then uses the active repository as the source for
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object definitions. You can change which repository is designated as the active
repository, but you cannot share object definitions between repositories.

Figure 3.1 is an example of a multi-repository configuration used with SAS
Enterprise Guide, with a SAS Metadata Repository selected as the active repository.
This specifies that SAS Enterprise Guide uses the selected SAS Metadata Repository
for object definitions.

Figure 3.1 Repository Configuration, Active SAS Metadata Repository

SAS Enterprise Guide
Repository #1

SAS Enterprise Guide

Repository #2 8
SAS Enterprise
Guide user
SAS Enterprise Guide
Repository #3
Set SAS Metadata SAS Metadata
Repository #2 as Repository #1
Active
ACTIVE
. SAS Metadata
SAS Enterprise .
Guide Explorer Repository #2 @

Figure 3.2 illustrates the same configuration with a SAS Enterprise Guide repository
selected as the active repository.
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Figure 3.2 Repository Configuration , Active SAS Enterprise Guide Repository
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After you set up the repository configuration, you can use the automatic update
feature to make changes to the configuration and have the changes automatically
applied to all machines where SAS Enterprise Guide is installed. You first use SAS
Enterprise Guide Explorer to make changes to the configuration, including defining all
repositories and designating the active repository. The new configuration information is
then saved to a file in a network location. When an SAS Enterprise Guide user starts
the application, the configuration file is automatically read and the repository changes
are applied.

Figure 3.3 shows how the changes to the repository configuration are applied to SAS
Enterprise Guide through the configuration file.
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Figure 3.3 Repository Changes Applied through Configuration File
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Setting Up SAS Metadata Repositories

SAS Metadata Repositories are metadata repositories on SAS Metadata Servers. The
metadata definitions on these servers are used not only by SAS Enterprise Guide but by
other SAS applications as well. Using SAS Metadata repositories lets SAS Enterprise
Guide users access and share libraries and servers with other applications.

A SAS Metadata Server is installed by the SAS Configuration Wizard during the
process of installing and configuring SAS software. Use SAS Management Console to
create repositories on the metadata server that will contain the SAS Enterprise Guide
object definitions. See “Creating a Metadata Profile” and “Creating a Metadata
Repository” in SAS Management Console: User’s Guide for information about creating
metadata repositories on a SAS Metadata Server.
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Setting Up SAS Enterprise Guide Metadata Repositories

About the Repository Process

Each SAS Enterprise Guide metadata repository is accessed through a metadata
repository process so that multiple SAS Enterprise Guide users can access the same
metadata repository if necessary. The repository process is located with a metadata
repository either on your local machine or on a networked Windows server.

The repository process is a multiple-user process (called sasdsdb.exe). Only one
repository process will run on each machine, and that one process will service all of the
repository users on that machine. The repository process starts on demand from the
first SAS Enterprise Guide application (SAS Enterprise Guide or SAS Enterprise Guide
Explorer) that tries to access the repository. It ends when the last such application ends.

Running the Repository Process Locally

At installation, SAS Enterprise Guide Explorer, along with a repository process for
SAS Enterprise Guide repositories, is installed on your local machine with the SAS
Enterprise Guide application. Local is a location that depends on the vantage point of
the application. You can run the SAS Enterprise Guide repository process locally on a
server or on a desktop PC, and either machine can be configured for access from other
Windows machines. Figure 3.3 illustrates the relationship between SAS Enterprise
Guide and a local repository process.
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Figure 3.4 SAS Enterprise Guide Repository Process on a Local Machine
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A default metadata repository is created in this location:
C:\Program Files\SAS\Shared Files\SAS Directory Services\SdsLocal

where €:\ is the drive on which SAS Enterprise Guide is installed on your machine.
The default objects that are defined in the default SAS Enterprise Guide repository
indicate that you are running both SAS and SAS Enterprise Guide locally. It reflects
the simplest installation of SAS Enterprise Guide.

The objects that are defined in the SdsLocal file are

Server Local

User [Unknown User]
Group General

Binders Sample

The default object definitions indicate that all users are [Unknown User], belong to
the General group, and have access to both the Local server and the Sample binder.
You can change the default settings for each object in SAS Enterprise Guide Explorer,
and you can enter new object definitions.

Running the Repository Process on a Remote Server

You can set up the SAS Enterprise Guide repository process to run on a server that is
remote from SAS Enterprise Guide. On a server you can choose to install only the SAS
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Enterprise Guide repository process, also referred to as SAS Directory Services (SDS),
without installing SAS Enterprise Guide.

To install SDS on the remote server machine, run the SAS Enterprise Guide installer
and select Install Repository Only from the main installation window.

The SAS Directory Services Setup wizard starts. Follow the prompts in the wizard to
install SDS on the remote machine.

Figure 3.5 illustrates the relationship between SAS Enterprise Guide and a remote
repository process.

Figure 3.5 SAS Enterprise Guide Repository Process on a Remote Machine
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Create Shared Access to the Repository Process

To enable multiple users who are logged on to different machines to share
information in one repository, configure the repository process as a Distributed COM
(DCOM) server. A repository process can run either on your local machine or on a
shared remote machine. Use the Windows dcomcnfg utility on the machine that will be
accessed remotely by other machines. If a user’s desktop machine does not have a
metadata repository that needs to be shared with other users who are logged on to
other machines, SAS Enterprise Guide or SAS Enterprise Guide Explorer can access
the local repository without having to set up shared access.

When you configure the repository process for DCOM access, the process must be set
to run under the authority of a user ID account on the machine or a domain user ID
that is allowed to run on the machine. The machine can be a Windows server that is
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shared by many users, or it can be any desktop machine capable of running a DCOM
server process (such Windows 2000, Windows XP, or Windows 2003 Server).

A current dcomenfg problem on some Windows machines causes the following problem
to occur. If a domain user ID is specified to run the repository server and there is a
local machine user ID that has the same name, then the repository process execution
will fail. Dcomenfg correctly sets the domain user ID to be used to run the process, but
it incorrectly gives the local user ID rather than the domain user ID the needed user
right to “Logon as a batch job.” To avoid this problem, do not enter a domain user ID
for the repository process identity that is the same user ID as a local machine user ID,
because they are unrelated accounts. Or, after you run dcomenfg, follow these steps:

1 Run the User Manager application. From the Start menu, select Programs »
Administrative Tools » User Manager

2 From the main menu select Policies » User Rights. Check the Advanced User
Rights check box.

3 Go to Logon as a batch job and set the domain user ID (not the local user ID
account) to have this right.

Because of this limitation, it is recommended that a new user ID account be added to
the machine on which the shared repository process is to run. The account needs to be
only a member of the Users group, but it also must have full-control file permission
access to the repository database that is installed as part of the SAS Enterprise Guide
or SAS Enterprise Guide Explorer setup.

If you want to keep the repository process running at all times, then you can keep a
copy of the SAS Enterprise Guide Explorer running while you access the metadata
repository. This is especially useful if you use Windows 95 or 98 machines as DCOM
servers for the metadata repository process because, on these machines, there is no way
to instantiate a DCOM server upon first request.

To configure a DCOM server process for sharing the metadata repository process
using Windows XP:

1 From the Windows taskbar on the server machine, select Start » Run
2 Type dcomenfg, and then select OK.

3 From the tree view in the Component Services window, open the Component
Services node, the Computers node, the My Computer node, and the bcoM
Config node.

Note: This window appears only if you are using Windows XP. A
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Computers

4 Under the bcoM Config node, select the SAS Directory Services Repository
node, and then select Actions » Properties

Note: If you are using Windows NT, select SAS Directory Services Repository
from the list of applications in the Distributed COM Configuration Properties
window. A

5 Select the Security tab. Select the Customize option under Launch Permissions,
and then click Edit to grant custom launch permissions.

Select Add in the Launch Permission window, and either add the group called
Everyone (you must type in the word Everyone) or add the specific groups and/or
users to whom you want to grant or deny access. If you add the group Everyone,
the Allow check box should be selected. Then click OK.
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Launch Permizzion

ﬁ Adminiztrators [0 234 \WAdminiztrators)
‘ Ewemane

€7 INTERACTIVE

€7 SrSTEM

Launch Permizzion

6 Repeat step 4 for Access Permissions. (You can set Everyone for access and launch
permissions because only users who are defined as administrators in the SAS
Enterprise Guide Explorer software will be allowed to make changes to the
repository. If you choose, however, you can restrict certain users and/or groups.)

7 From the SAS Directory Services Repository Properties window, select the
Identity tab. Enter a user ID (and domain) to be used to run the repository
process, and then click OK.

Note: Due to a current DCOM limitation, this user ID should not be the same as
the user ID for the interactive user who might run SAS Enterprise Guide on this
server. A
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SAS Directory Services Repository Properties

_omse|

8 At least the user from the previous step must have full control of the repository
database that was installed previously (Sdslocal or another name specified by the
administrator). If the Everyone group is shown, it can be removed because no
other users need to have access to this file. To ensure full control in the file
system, select the repository file (such as Sdslocal) in the My Computer directory.
Click the right mouse button to access the shortcut menu. Select Properties.
Click the security tab, and then click add. Either add a group that the user ID
(used to run the repository DCOM server) belongs to, or add the actual user ID,
then click oK. In the Permissions list, select Allow for the Full Control
permission, and then click oK.
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To control access on a FAT drive, do not make the repository database file
available for read/write access in a shared directory on a network.

9 Restart the machine so that all of the settings take effect.

10 Finally, if DCOM is not enabled on the server machine, then enable it now by
selecting Start » Run » dcomenfg. Open the Component Services and
Computers nodes, and then select the My Computer node. Select Actions »
Properties to open the My Computer Properties window. Select the befault
Properties tab. Select Enable Distributed COM on this computer. ClickOK
to close the window
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My Computer Properties
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Working with SAS Enterprise Guide Repositories

Before you add object definitions in the repository, add yourself as a user with
administrator privileges and set a password.
To work with a repository for the first time:

1 Start SAS Enterprise Guide Explorer.
2 Add yourself as a user with administrator privileges.

3 Add security by setting a password for the active repository. (Security is optional
for local repositories.) After you set a password, only users with administrator
privileges can make changes to the repository. A user can gain administrator
privileges temporarily by using the password. (This is also a way to add an
administrator if none exists.) From the pull-down menu, select Mode » Change
Password

If a password has not been specified, these fields are blank. Type the password
and verify it.
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Change administrator password

Current password: |-|

Mew pazswond:

Werfy new paszword:

aEk. Cancel

4 “Populate” the repository; that is, add servers, libraries, users, and other object

definitions. You can add the objects in the order in which they appear in this
document or in the order that works best for your situation.

Managing Repositories

Ahout Repository Management

After you create the SAS Open Metadata repositories and SAS Enterprise Guide
repositories, you must create and manage definitions for the repositories so that SAS
Enterprise Guide can access them. Managing repositories includes these tasks:

O
O
O
O

creating new repository definitions

specifying an active repository

modifying existing repository definitions

setting up automatic updating of repository information

To configure and manage repositories, select File » Manage Repositories. The
Repository Manager window opens.
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Updates Mame | Type | Machine | Add...

Repositories

|ﬁ BlAdmin SAS Metadata Repository d9581.na sas.com
Chiis's QMR SAS Metadata Repository 11702 us.saz.com Modify
Citris SAS Metadata Repository cannonballtre.sas.com

local EG Enterprize Guide Repozitory  lacalhast
TIFw2 Enterprise Guide Aepositony TJFW2 Delete

Set aclive

Cloze
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The Repository Manager window contains a list of all the SAS Metadata repositories
and SAS Enterprise Guide repositories that have been defined for SAS Enterprise

Guide Explorer. The active repository is identified by the active repository icon (@ ).
The following sections provide information about specific management tasks that you
can perform in this window.

Define a Repository

To use a SAS Metadata Repository or a SAS Enterprise Guide repository, you must
create a definition for the repository in the Repository Manager. To define a repository,
follow these steps:

1 Select Repositories from the selection pane, then click aAdd. The Add Repository
Definition window opens.

Audd Repository Definition 0] =]

545 Metadata Repositary |_

(v (!
1234 mycorp. com a561

1234\sasadm oo
[ Browse.. |

—

2 Specify the name and description for the definition, then use the drop-down list in
the Type field to specify the type of repository that you are defining. The
remaining fields in the window might become active or inactive or might change
names, depending on which type of repository you select (SAS Metadata repository
or SAS Enterprise Guide repository).

For example, if you are defining a remote SAS Metadata repository, then you
must specify the machine ID and port, the user ID and password for logging on to
the machine, and the SAS metadata repository name. However, if you are defining
a remote SAS Enterprise Guide repository, only the machine name is needed.
Refer to the online help for the window for detailed information about the fields.
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If you select SAS Metadata Repository in the Type field, then you must specify
the SAS metadata repository name. After you specify the machine and user
information, click Browse to view a list of defined repositories on the selected
machine.

3 Click save to create the repository definition and return to the Repository
Manager window.

Specify an Active Repository

You can specify one repository as an active repository. The active repository serves as
the source for all resource definitions (such as servers and libraries).

To specify an active repository, select Repositories from the selection pane, select a
repository from the list of defined repositories, and click set Active. The selected

repository is identified by the active repository icon (@ ).

Modify a Repository

After a repository has been defined in the Repository Manager, you can modify the
properties of the repository. To modify a repository, follow these steps:

1 Select Repositories from the selection pane, then select the repository that you
want to change and click Modify. The Modify Repository window opens.

M odify Repository

d9581.na.zas. com

49581 Ysazadm oo

Fomdain | Bewse |

_ Ces | _ Carcel|

2 In the Modify Repository window you can change repository options for the
selected repository type. You cannot use this window to change the repository type.
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3 Make any needed changes to the repository options, and then click save to accept
the changes and return to the Repository Manager window.

Delete a Repository

You can use the Repository Manager to delete a repository definition. Select
Repositories from the selection pane, then select the repository that you want to
remove and click Delete.

Specify the Channel Source

You can use the Repository Manager to specify the channels that are used by the
Publish to Channel feature in SAS Enterprise Guide. You need to specify the channel
source only if you are using this feature. To specify the channel source, follow these
steps:

1 Select Channels from the selection pane.

2 If the active repository is a SAS Metadata Repository, the Repository Manager
window indicates that the channel metadata is obtained from the active SAS
Metadata Repository.

If the active repository is a SAS Enterprise Guide repository, the channel

metadata is obtained from an LDAP server. Use the LDAP Configuration fields to
specify information about the server and LDAP directory structure.

-loix

Repasitaries Channels
Channels
Updates —Chanrel Metadata

Use LDAP configuration below

—LOAP Canfiguration
Save |
Fart:

Machine:

|Idap.mycorp.c:om |385|

User: Password:

|cn=m}lpidb,o=h‘1y Corp,c=U5 |
Bind root:

|c:n=M_l,l C.o=My Corp,c=l15

3 Click Save to save the specified LDAP information.

Configure Repository Updates

Whenever you make changes to the repository configuration, such as changing the
location of a defined repository or adding a new repository, you must provide the
changed information to SAS Enterprise Guide users so that they can find the changed
repositories. To avoid having to update SAS Enterprise Guide users manually, you can
store the repository configuration information in a shared location and enable SAS
Enterprise Guide to automatically apply configuration updates.

To set up automatic updating, follow these steps:
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1 Select File » Manage Repositories.
2 In the Repository Manager window, select Updates from the selection pane.

71 Repository Manager

Repasitories
Charnelz

hnetworkhupdates\BEMG

3 In the Location of update file field, specify a network location that all SAS
Enterprise Guide users can access. When you activate automatic updating, SAS
Enterprise Guide checks this location for automatic updates to the repository
configuration information.

Select Update configuration automatically if you want SAS Enterprise
Guide Explorer to receive updates to the configuration information. Usually, the
information in SAS Enterprise Guide Explorer and the information in the
configuration file are the same, but you might want to select this option for testing
purposes.

Click check for updates now to test whether SAS Enterprise Guide Explorer
can locate the update information in the specified location.

4 Click close.

5 Copy the SDSUpdate.xml file from the work directory that you specified when you
first configured the repositories (see “Create a Shared Repository Deployment” on
page 29) to the network location that you specified in the Repository Manager
window.

6 Copy the SDSControl.xml file from the work directory to the network location that
you specified in the Repository Manager window. If you change the location of the
configuration update file, then you must copy the changed SDSControl file to all
machines where SAS Enterprise Guide is installed.

7 Select Tools » Options. This opens the Options window. Select Repository and
Server under the Administration options.
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8 Specify the location of the configuration update file that you specified in the
Repository Manager window. Select Automatically update repository
configuration. Click Load Configuration to apply the current configuration
file. Click ok to close the window.

9 Include the EGOptions.xml file in the SAS Enterprise Guide installation package
to automatically apply the option to all machines where SAS Enterprise Guide is
installed. If you already have SAS Enterprise Guide installed, you can distribute
the EGOptions.xml file to the machines where SAS Enterprise Guide is installed
in order to change the default SAS Enterprise Guide options.
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Create a Shared Repository Deployment

After you define the SAS Metadata repositories and SAS Enterprise Guide
repositories, you can configure the deployment so that it is shared by SAS Enterprise
Guide users. Whenever you make changes to the repository configuration, such as
changing the location of a defined repository or adding a new repository, you must
provide the changed information to SAS Enterprise Guide users so that they can find
the changed repositories. By storing the repository configuration information in a
shared location and enabling SAS Enterprise Guide to automatically apply configuration
updates, you can avoid having to update SAS Enterprise Guide users manually.

To configure repository deployment in SAS Enterprise Guide Explorer, follow these

steps:

1 Select Tools » Repository Deployment Wizard

The Repository Configuration Deployment Wizard starts. The first page lists the
tasks that the wizard will perform. Click Next to continue.

2 The next page of the wizard lists the name and type of the active repository. To
change the active repository or define a new repository, click Configure

Repositories. Click Next to continue.
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3 The next page enables you to test the connection to all of the defined repositories.
When you click Begin Test, the application attempts to establish a connection to
each of the defined repositories. The Status column indicates whether the
connection was successful. When you have finished the test, click Next to continue.

"-1 Repository Configuration Deplopyment Wizard

Step 2

Werify the configuration by connecting to each repositary. You may
chooze all repositories or only those that are active.

LD&P Repositony
SA5 Metadata Reposgitory
Enterprize Guide Repositary

4 The next page enables you to specify the location of the shared configuration
update file. By using automatic updating, you can make changes to the repository
configuration in SAS Enterprise Guide Explorer, and those changes will
automatically be sent to all SAS Enterprise Guide users.

Y% Repository Configuration Deployment Wizard

Step 3
Specify location for shared update file.

U:hoznet, 21, awb\UpdateshE Goonfig

| —

If you specified the location of the configuration update file on the Updates area
in the Repository Manager window, then the value that you specified is already
listed in this field. If you did not already specify the location, then enter a network
location that all SAS Enterprise Guide users can access.
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5 Click Next to continue.

6 Specify the location where SAS Enterprise Guide Explorer stores the repository
configuration files.

"-1 Repository Configuration Deplopyment Wizard

Step 4
Specify location to write the generated configuration files.

C:AControlReposContol

e

The SDSUpdate.xml file contains the configuration information that is read by
SAS Enterprise Guide to provide automatic updating. When the configuration is
complete, you should move this file to the location that you specified in step 3. The
SDSControl.xml file is distributed with the SAS Enterprise Guide installation
package in your organization. This file specifies the location of the automatic
update file.

Specify a location on your local drive for these files. When the configuration
process is complete, copy the files to the appropriate location.

7 Click Next to continue.

8 Specify whether you want to view the Read Me file. Then click Finish to create
the repository configuration files.
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"-1 Repository Configuration Deplopyment Wizard

Finish
Create the configuration files and optionally display the Readke file.

9 Copy the SDSUpdate.xml file from the work directory that you specified when you
first configured the repositories (see “Create a Shared Repository Deployment” on
page 29) to the network location that you specified in the Repository Manager
window.

10 Copy the SDSControl.xml file from the work directory to network location for the
SAS Enterprise Guide installation image. If you change the location of the
configuration update file, you must copy the changed SDSControl file to all
machines where SAS Enterprise Guide is installed.
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Preparing a Setup Image for Users in a Networked Environment

Setting up SAS Enterprise Guide includes giving users access to a setup image of
SAS Enterprise Guide. Users must access the setup image in order to install the SAS
Enterprise Guide software on their local machines. In a networked environment, you
create a setup image on a server. Note that the setup procedure includes pointing users
to the correct metadata repository server process.

In a networked environment you can create several repositories for different groups of
users. This is the most complex way to use repositories, and it is also the most powerful.
If you create several repositories, then you will need to configure a different setup image
for each group of users so that each group will access the correct repository at startup.
This is appropriate if the groups do not have access to the same Windows servers.

To create a setup image for users in a networked environment:

1 If you have not already done so, choose a location for the setup image. The
location should be on a server that your users can access. Using Windows Explorer
or another file manager, copy the installation files (from the installation CD or
from another location) to the chosen location.

2 Create a customized set of defaults for SAS Enterprise Guide installations, which
are automatically applied when users install SAS Enterprise Guide. The defaults
are read from the EGOptions.xml file (if present) and the options.ini file when the
installation is performed. If you do not create an EGOptions.xml file, SAS
Enterprise Guide will use the default values that are set by SAS.

To create the EGOptions.xml file, open the Enterprise Guide Options window by
selecting Tools » Options
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Customize Dptions
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Specify the default values for SAS Enterprise Guide installations by selecting
each category and setting the displayed options. Move the mouse pointer to an
option in order to display a brief description of that option at the bottom of the
window.

3 After you set the default values, click save or save As. In the Save window,
specify a filename of EGOptions.xml. After you create the file, copy it to the
location for the setup image.

4 Make sure that the repository information for this set of users is in a location
where users can access it. (It does not need to be in the same location as the
installation files.)

5 Copy the SDSControl.xml file from the work directory to the SAS Enterprise
Guide setup directory and to the <SHAREDFILES>\SAS Directory Services
location. This file contains the central repository information.

6 Copy the SAS Enterprise Guide application setup directory to a network drive that
users can access in order to run SETUP.EXE, which is the program that installs a
copy of the setup image on their local machines. Add the SDSControl.xml file to
the directory where SETUP.EXE resides. You can provide a link from a Web site to
the directory for easy access.
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Viewing the Objects

You view objects in SAS Enterprise Guide Explorer in much the same way as you
view objects in the Windows Explorer. Click once on a category of objects in the left side

of the window (Servers, Binders, Users, and so on) to display its contents on the right
side.
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Double-click a category name to expand that category.

If you are accessing objects that reside on SAS servers, then you might be prompted
to enter a user ID and password. In SAS Enterprise Guide Explorer, when you create a
server object, you can configure it to require users to enter a user ID and password.

You can customize your session further by selecting view from the pull-down menu.
From the menu you can activate options for displaying different views of the icons, sizes
of the icons, and information about the objects.

Adding Objects

To add a new object to a SAS Enterprise Guide repository, select File » New and
then select the object type you want to create. The new object wizard that starts guides
you through the process of creating the object you have selected. from each page in the
wizard, you can use the Back button or pull-down menu to return to an earlier page,
You can also click Help to access information on the current wizard page.

The types of objects you can add depends on the type of repository you are using. If
you are using a SAS Metadata Repository, you can use SAS Enterprise Guide Explorer
to add servers and libraries. However, you can also server and library definitions
created in SAS Management Console. If you are using a SAS Enterprise Guide
repository, you can add server, library, group, user, and binder definitions.

Managing Servers

About SAS Servers

SAS servers are networked computers on which SAS is installed. SAS servers enable
multiple clients to access and use SAS data libraries (and members of the libraries)
concurrently. A SAS server for SAS Enterprise Guide can be running in a Windows,
z/OS, or UNIX operating environment. SAS Enterprise Guide Explorer defines which
servers to use with the client platform.

If you are using a SAS Enterprise Guide repository, clients are SAS Enterprise Guide
sessions on networked Windows workstations that request services from SAS servers.



Managing Metadata Objects Using SAS Enterprise Guide Explorer /A Adding SAS Servers 37

The services might include SAS processing, data access, and data manipulation. The
client is used to submit SAS processing either locally or to a remote SAS server.

You add SAS servers in SAS Enterprise Guide Explorer so that networked SAS
Enterprise Guide users can execute SAS and access their data. If you add a SAS server
that uses the TCP/IP protocol, then you need the following information:

O server type
IP address/host name
protocol

m
m
O port address
m

user IDs and passwords (optional)
If you are using a SAS Metadata Repository, then servers that you define in SAS
Enterprise Guide Explorer are accessible by any other application that uses the SAS

Metadata Repository. You can create server definitions with SAS Enterprise Guide
Explorer or SAS Management Console.

Adding SAS Servers

Note: To add a SAS server, select File » New » Server and follow the prompts on
each page of the Server Wizard. Depending on the options you select in the wizard, the
number of pages in the wizard and the page on which a specific option appears may
change.

Use the following information when completing the wizard:

0 On page 1 of the wizard, you must specify a name for the server. The name cannot
contain any of these characters:

\/iE2 s |

You can also enter a description when you specify a name for the server. The
descrption will appear when a user attempts to log on to the server.

0 On page 2 of the wizard, you must select the operating system of the server. The
operating system you select will affect some of the optiobs available in the wizard
(such as connection protocol and file navigation).

0 On page 3 of the wizard, you must select a connection protocol and specify a host
name and port number. You should only select COM for the connection type if the
server is running on your local Windows machine. Select IOM Bridge for all other
server types.

Enter a DNS name or IP address in the Host Name field and specify the port
used to connect to the server.

0 On page 4 of the wizard, you specify how users will log on to the server. If you are
using a SAS Metadata Repository, you can specify that the user will be prompted
for logon information or that the server will use logon information that is stored
on the SAS Metadata Server. You must also specify an authentication domain to
use with the logon information. You can either select from the authentication
domains that are already defined in the SAS Metadata Server or define a new
domain. If you are using a SAS Enterprise Guide repository, you can specify that
the user will be prompted for logon information or provide a user ID and password
to be used each time he or she logs on to the server.

0 If you are defining a connection to a z/OS server, page 7 of the wizard lets you
specify the search patterns that will help users locate z/OS libraries. SAS
Enterprise Guide Explorer creates a filing cabinet for each pattern that you enter
and creates folders for each data set that is a part of that pattern. If your site has
a large number of z/OS libraries, then users can use the bound library filing
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cabinets to quickly navigate to the specific data set that they are interested in.
Because you are creating a navigational aid for users, you should choose patterns
that will help users navigate to data sets quickly.

For example, assume that you need access to the following data sets on a z/
OS server:

o SRV.MFG.PRODL1 ... SRVMFG.PROD20
o SRV.DEV.INV1 ... SRV.DEV.INV5
o SRV.TEST.DEV1
Specifying a pattern of SRV.*.* would result in a bound library that was too

broad and contained too many sublevels to allow for rapid navigation. A more
efficient solution would be to specify three bound library patterns:

o SRVMFG.*
o SRV.DEV.*
o SRV.TEST.*

Bound libraries must be specified as a fully qualified name, with the last
member specified as a wildcard character (¥).

A

After you complete the Server Wizard, the new server should now appear in the list
of servers in the viewer.

Updating Server Properties

Server properties include information such as names, protocols, and preferences. To
update this information:

1 Locate the server in the SAS Enterprise Guide Explorer viewer whose properties
you want to change. You can only edit server properties if you are not connected to
the server. To disconnect from a server, select the server and select Disconnect
from the pop-up menu.

2 Select the server in the viewer and select Properties from the pop-up menu.

3 Select the item in the selection pane that corresponds to the information that you
want to update. See “Adding SAS Servers” on page 37 for information about each
field.

Managing Libraries

About Libraries

Libraries are collections of files that are stored on a server and accessed from SAS
Enterprise Guide. Libraries give SAS Enterprise Guide users convenient access to their
data on servers. When you add a library through SAS Enterprise Guide Explorer, you
make it available to all the networked SAS Enterprise Guide installations that have
access to a specific metadata repository.

If you are using a SAS Metadata Repository, the library is also available to all other
applications that use the repository. You can use SAS Enterprise Guide Explorer or
SAS Management Console to create library definitions.

Note: Before you add a library, you must first add the server on which the library
resides. A



Managing Metadata Objects Using SAS Enterprise Guide Explorer /\ Adding a Library 39

To define a library:

1 Define the library’s path on the server platform.

2 Specify the SAS engine that is identified with the library.

3 Enter any associated options that you can specify in a LIBNAME statement.
LIBNAME options work like the commands in an AUTOEXEC.BAT file. The
LIBNAME options are stored on the client and then executed when a SAS
Enterprise Guide application connects to the specified SAS server. See SAS

Language Reference: Dictionary for more information about SAS libraries,
LIBNAME statements, and LIBNAME options.

Adding a Library

To add a library, select File » New » Library and follow the prompts on each page of
the Library Wizard. Depending on the options you select in the wizard, the number of
pages in the wizard and the page on which a specific option appears may change.

Use the following information when completing the wizard:

0 On page 1 of the wizard, you must specify a name for the library. The name can be
up to 8 characters long and must not be duplicated on any server on which you are
creating the library. The wizard automatically enters the name in uppercase
characters.

o If your active repository is a SAS Metadata Repository, you must select how the
library is assigned on page 2 of the wizard. You must choose to assign the library
by using one of the following:

SAS Enterprise  specifies that SAS Enterprise Guide uses the metadata
Guide supplied in the wizard to assign the library by using the native
engine. No table or column metadata is used.

SAS Server specifies that the library is assigned in an autoexec statement
or through a metaautoinit statement. SAS Enterprise Guide
does not use the metadata that you specify for the library, but
assumes that the library is already assigned.

Metadata if Show only tables with metadata definitions is

Library Engine checked, then only tables that have metadata definitions
appear when the library is selected. If the check box is not
selected, then all tables in the library will appear (even if you
deny ReadMetadata permission for a table). Permissions are
enforced if a user tries to open a restricted table.

0 On page 4 of the wizard, you must specify an engine for the library. Choose the
SAS engine with which the data was created. For more information about engines,
refer to the SAS documentation for your operating environment. See also the
chapter that corresponds to your database management system in SAS/ACCESS
Software for Relational Databases: Reference.

0 Also on page 4 of the wizard, you may have to specify the physical path where the
library resides on the server. Depending on the value of the Engine field, Path
may not be selectable. You can use the following wildcards in the Path field:

<userid> substitutes a Windows user ID. For example, if a user logs on
as ebeacon, then \\librarypath\<userid> becomes
\\librarypath\ebeacon.

<sample> substitutes the SAS Enterprise Guide sample directory. For
example, if you installed by using the default directories,
<sample>\data becomes C:\Program Files\SAS\Enterprise
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Guide 3.0\Sample\data. If, however, another user installed
in D:\EC, then <sample>\data becomes D: \EC\Sample\data.

<serveruser> substitutes the server logon user ID.
<serverpassword> substitutes the server logon password.
<libraryuser> substitutes the library logon user ID.
<librarypassword> substitutes the library logon password.

Note: These wildcards may not work with client applications other than SAS
Enterprise Guide and Addon for Microsoft Office. A

0 On page 5 or 6 of the wizard (depending on the value of the Engine field), you can
specify library options and values. If wildcards are valid in the pPath field, then
you can also use them in the options field. Avoid using prompting options such as
DBPROMPT=YES. For additional options, refer to the chapter that corresponds to
your database management system in SAS/ACCESS Software for Relational
Databases: Reference.

0 Page 6 or 7 of the server lets you test the library definition on each server. If the
library name or libref is not unique on all servers, the conflict is listed in the
Status column.

After you complete the wizard, the library is created and then is displayed in the
viewer under the client libraries for the specified servers.

Creating the EGTASK Library

By default, SAS Enterprise Guide stores output data in the SASUSER, WORK, or
EGTASK library on the SAS server. You can select Tools » Options » Output Library
to change the default output library. For example, you might want all output to go to a
central library that all users can access. In addition, SASUSER is a temporary location
on z/OS and some UNIX systems, so output needs to be directed to a different location
in order to be saved permanently.

To define the EGTASK library if you are using a SAS Metadata Repository, you can
follow either one of these strategies:

0 Use SAS Management Console to define the EGTASK library. Select Data Library
Manager and then select New Library. Choose Pre-assigned Library as the
library type to ensure that the library is assigned whenever the server starts.
Make sure the library is defined on all servers that will be used with SAS
Enterprise Guide.

0 Use SAS Enterprise Guide Explorer to add the LIBNAME statement for EGTASK
to all server definitions used by SAS Enterprise Guide. Include the statement in
the SAS startup statements field in the New Server wizard (for new servers) or
in the Properties window (for servers that have already been defined).

To define the EGTASK library if you are using a SAS Enterprise Guide repository:

1 Select File » New » Library . Enter EGTASK in the Name field on page 1

2 Enter EGTASK in the LIBREF field on page 2. Select the Assign at Server
Startup check box. This value ensures that EGTASK is created and available
every time the server is started.

3 On page 3 of the wizard, select a server on which users run tasks. If more than
one server is used to run tasks, then you must go through the library definition
process separately for each server that needs to have EGTASK available.

4 On page 4, select BASE in the Engine field. In the Path field, type or select a
location that is not protected and is available to all users.
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5 Select the defaults for the remaining options and complete the wizard to create the
definition.

Updating Library Properties

Properties for libraries include information such as names, pathnames, and
LIBNAME options. To view or update this information:

1 Select a server, and then locate the library whose properties you want to change.
You can change properties for unassigned libraries only. If the library that you
want to change is assigned, then click the right mouse button and select Unassign
from the shortcut menu.

2 Select the library and then select Properties from the pop-up menu.

3 Select the item in the selection pane that corresponds to the information that you
want to update. See “Adding a Library” on page 39 for information about each field.

Unassigning Libraries

You can assign and unassign libraries dynamically during an SAS Enterprise Guide
Explorer session. To unassign an assigned library, right-click the library name and
select Unassign from the shortcut menu. The color of the library icon changes from
yellow to white to indicate that the library is not assigned. While the library is
disconnected, its icon is also white in any open dialog boxes to indicate that the library
is selectable but currently unassigned.

To assign the library, right-click the library icon and select Assign from the shortcut
menu. The library icon changes back to yellow.

Note: Do not manually assign and unassign libraries on z/OS servers. When a
library on an z/OS server is assigned, it locks out all other potential users. 2

Managing Binders

Abhout Binders

Binders are a type of virtual folder that provide users with transparent access to
data and, at the same time, enable users and work groups to easily share information
across an enterprisewide network of servers on multiple platforms.

Users access binders through SAS Enterprise Guide. You can control user access to
binders through groups, or you can grant all SAS Enterprise Guide users access to
binders. You can insert shortcuts to data so that users can easily access information
without having to know its exact location.

Binders are not available if you are using a SAS Metadata Repository.

To create a binder, select File » New » Binder and follow the prompts on each page
of the Binder Wizard. On page 2 of the wizard, you must select the folder location of the
binder. You can choose one of the following:

Server specifies a file or directory on a server. When an SAS Enterprise
Guide user opens a file from a binder that maps to a location on a
server, a copy of the file is sent to the client machine so that other
users can still access the file. After the SAS Enterprise Guide user
saves and closes the file, the file is updated on the server.
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File System specifies a folder in the Windows file system.Binders that map to
native files contain files and directories that users can access by
using Windows native file protocols. The files and directories can
reside on local drives or on any file server in the Windows network;
they do not reside on servers that you administer through SAS
Enterprise Guide Explorer.

Note: Because others can share native files on Window servers,
be aware that when users open files in native binders, they are
granted direct access to those files. Therefore, they might lock out
other users. The files in native folders are not copied to client
machines as they are in files on a server location. A

No Folder creates an empty binder that you can later populate with shortcuts,
files, and other binders.

Deleting a Binder

Note: A binder merely points to items that reside on servers. Therefore, the original
items are not deleted when you delete the binder. However, any shortcuts in the binder
are deleted when you delete a binder. A

To delete a binder, select the binder in the viewer, then select belete from the
shortcut menu.

Managing Groups

About Groups

A group is a collection of SAS Enterprise Guide users who are granted access to the
same set of resources, such as SAS servers, libraries, and binders. If you will be adding
groups, it is best to add at least one group first, and then add the users that belong to
that group. Then, as you add each user, you assign the user to one or more existing
groups.

If you are using a SAS Metadata Repository, you must use SAS Management Console
to view and manage groups. If you are using a SAS Enterprise Guide repository, you
can view and manage groups in SAS Enterprise Guide Explorer.

Compared with user profiles, groups provide a lower maintenance approach to
resource access management, because updating information for a group is easier than
updating information for individual users. Groups and users are useful for
high-security environments where you need strict control of user access to resources. If,
however, you are granting your users universal access to servers and binders, then you
do not need to add groups.

Adding a Group

To add a group, select File » New » Group and follow the prompts in the Group
Wizard. The wizard lets you select the group members as well as the servers, binders,
and tasks that the group members can access.
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Deleting a Group

To delete a group, select the group in the viewer, then select Delete from the
shortcut menu.

Note: Deleting the group does not delete the users who are its members. To delete
specific users, see “Deleting a User” on page 44. A

Updating Group Properties

Access group properties to update information for groups and set defaults.

To change the properties for a group, select the group in the viewer and select
Properties from the shortcut menu. Select the item in the selection pane that
corresponds to the information you want to update.

Managing Users

About Users

Users are individuals with unique ID and password combinations. In a networked
environment, you can create groups of users to control access to servers, libraries, and
binders. If you will be adding groups, it is best to add at least one group first, and then
add the users who belong to that group. For information about groups, see “Managing
Groups” on page 42.

If you are using a SAS Metadata Repository, you must use SAS Management Console
to view and manage users. If you are using a SAS Enterprise Guide repository, you can
view and manage users in SAS Enterprise Guide Explorer.

Note: If you are an administrator in a networked environment, you must first add
yourself as a user with administrator privileges, and then assign yourself to a group. A

For example, suppose that you have a new user who just installed the SAS
Enterprise Guide software on his local machine. Suppose that he wants to access an
administered library on a UNIX machine that you added earlier by using SAS
Enterprise Guide Explorer. As you add the new user, you can assign the user to a group
that already has access to the UNIX server and the administered library.

You will need to gather this information before adding each user:

O name

o user ID (for the PC)

0 phone number (optional)

O office location (optional)

o

e-mail address (optional).

Adding a User

To add a user, select File » New » User and follow the prompts in the User Wizard.
The wizard lets you specify the user’s name, ID, identifying information, and group
membership.
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On page 2 of the wizard, you can select whether to grant the user administrator
privileges. Granting these privileges gives the user write access to the SAS Enterprise
Guide repository.

Deleting a User

To delete a user, select the user in the viewer, then select belete from the shortcut
menu. The user is automatically deleted from any groups that included the user.

Note: You cannot delete users whose names are in brackets []. A

Updating User Properties

User properties include user IDs, group memberships, and privileges. To change the
properties for a user, select the user in the viewer and select Properties from the
shortcut menu. Select the item in the selection pane that corresponds to the
information you want to update.

Managing Security Settings

About Security Settings

If you are using a SAS Metadata Repository, you can specify security settings for SAS
resources such as SAS folders, stored processes, and projects. Security settings are
permission rules that specify which users or groups of users that are defined in the SAS
Metadata Repository can access SAS resources. You can choose to grant read or write
permission to a specific SAS resource or specify that the security settings for a resource
be inherited from the parent of the resource.

Specifying Security Settings

You can specify security settings only if you are using a SAS Metadata Repository. To
specify the security settings for an object:
1 In the SAS Enterprise Guide Explorer object tree, select the object for which you
want to specify security settings. Security settings can be applied to SAS folders,
stored processes, and projects.

2 Right-click and select Properties. The Properties window appears.

3 Select security from the list to display the current security settings. You can
specify that the security settings for the object should be inherited, or you can
explicitly define the settings.

4 To inherit the security settings, select Use inherited security settings.

If security settings have been explicitly defined for any parent of the current
object, the window specifies the settings that are in effect and identifies the object
from which the settings are inherited.
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& Project Properties

If security settings have not been defined for any parent objects, the default
security settings for the metadata repository are used. You must use the
Authorization Manager in SAS Management Console to view or modify these
default settings.

5 To explicitly define security settings, clear the Use inherited security
settings check box. The window displays a list of the users and groups that have
been defined on the metadata server by SAS Management Console. Use the
drop-down list to display only the available users or the available groups.

Select the users and groups for which you want to define security settings, and
use the arrows to move them to the Selected Users and Groups list.

Select a user or group in the Selected list and use the Access check boxes to
specify the security settings for the user or group. The available security settings
are as follows:

Read specifies that the user or group can view the resource and view
the metadata for the selected resource. This option corresponds
to the ReadMetadata permission in SAS Management Console.

Write specifies that the user or group can modify the resource and
the metadata for the resource. This option corresponds to the
WriteMetadata permission in SAS Management Console.
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CAUTION:
If you clear the “Use inherited security settings” check box, you must grant write
access to at least one user or group. If you do not grant this access, an administrator
must change the security settings to allow access. A

6 Click oK to close the Properties window and apply the security settings.



Ly

CHAPTER

Administering SAS Enterprise
Guide Tasks

Administering Tasks 47

Importing Task Definitions 47
Enabling Tasks for User Groups 49
Enabling Task Administration 50

Administering Tasks

SAS Enterprise Guide Explorer enables you to specify which tasks are available to
each SAS Enterprise Guide user group. You can use this capability to disable certain
tasks for user groups that do not need to run those tasks. You can also increase users’
efficiency by enabling only those tasks that they need to use. Task administration
applies only to tasks that are supplied with SAS Enterprise Guide.

The task administration process consists of three steps:

1 Importing task definitions
2 Selecting tasks to enable for each user group
3 Turning on task administration.

Importing Task Definitions

Task definitions are entries in an XML file that contain the information that SAS
Enterprise Guide Explorer needs in order to work with each task. You can administer
only tasks whose definitions you have imported into SAS Enterprise Guide Explorer.

You must be working with a SAS Enterprise Guide repository in order to administer
tasks. This function is not supported with SAS Metadata repositories.

To import task definitions:

1 Select Tools » Task Import Wizard

The first page of the wizard provides a brief introduction to the wizard and
identifies the currently active SAS Enterprise Guide repository and repository
machine.

Click to continue.

2 The Location page (page 2) allows you to specify the location of the file that
contains the SAS Enterprise Guide task definitions. Select A11 known locations
on this computer to search all common locations. Select From this file and
specify a filename to import task definitions from a specific file. By default, task
definitions are contained in the AddInRegistry.xml file that is stored in the SAS
Enterprise Guide directory.
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Click Next to continue.

3 The Search page (page 3) displays the number of task definitions that were found
and the number that are identical or similar to task definitions that have already
been imported.

FE: Task Import Wizard

3of7 Flease wait while task data is extracted.

-

Click Next to continue.

4 The Adding Tasks page (page 4) lists the tasks in the selected file or location that
do not match tasks that are already in the repository.

FE: Task Import Wizard

407 These tasks were notfound in the repository. Select any that
u wouwish to add.
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Generalized Linear Model:

Select the tasks whose definitions you want to add to the repository (or click
Select All to select all of the listed tasks), and click Next to continue.

5 The Existing Tasks page (page 5) lists the tasks that already exist in the repository.
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Select the tasks whose definitions you want to update (or click select All to

select all of the listed tasks), and click Next to continue.

6 The Locale page (page 6) lets you specify the locale for the imported tasks. The
available locales are those that were selected when SAS Enterprise Guide was

installed.

Select the locale from the pull-down list, then click Next to continue.
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7 The Finish page (page 7) lists the number of tasks that will be added and updated
in the repository.

Click Finish to import the task definitions.

Enabling Tasks for User Groups

After you import the task definitions, you must determine which tasks each user

group should have access to. To successfully implement task administration, every SAS
Enterprise Guide user must be assigned to a group, and you must enable a set of tasks
for every group. A user who is not assigned to a group will not have access to any SAS
Enterprise Guide tasks.

To enable tasks for user groups:

1 Ensure that all users have been assigned to a user group.

2 Select a group whose tasks you want to enable. To open the Properties window for
the group, select File » Properties

3 In the Properties window, select the Tasks item.
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f¢ Group Properties

General
Users
Servers
Bind

AR A Forecast Modeling
Bar
Basic Forecasting

Box Chart

EBubble

c Chart

Canonical Correlation

Create Format

4 The Available Tasks box lists the SAS Enterprise Guide tasks whose definitions
are contained in the repository. Select the tasks that you want the members of the
user group to have access to, and click the arrow control to move the selected tasks
to the Sselected Tasks list.

£+ Group Properties

General

Users

Servers

Binders - -
Append Table Basic Forecasting
Area Cluster Analyzis
AR IMA Forecast Modeling Correlations
Bar
Box Chart
EBubble
c Chart
Canonical Correlation
COF Plots

Contour
Create Format
Create Map Feature T able

5 Click OK to close the Properties window.

6 Repeat this selection process for all user groups. If you do not enable a set of tasks
for a user group, then by default all tasks will be turned off for the members of
that group.

Enabling Task Administration

After you import the task definitions and enable tasks for all user groups, you must
enable task administration in order for the settings to take effect.
To enable task administration:

1 Select Tools » Options

The Options window opens.
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B Options

2 Select Enable task administration and click OK to close the window.

The task settings for each user group will take effect whenever a user starts a SAS
Enterprise Guide session. If users have already started an SAS Enterprise Guide
session when task administration is enabled, then the task settings will not take effect
until they start a new session.



52



53

APPENDIX

1

Recommended Reading

Recommended Reading 53

Recommended Reading

Here is the recommended reading list for this title:

0O Getting Started with SAS Enterprise Guide
SAS Integration Technologies: Administrator’s Guide
SAS Learning Edition
SAS Management Console: User’s Guide
SAS Metadata Server: Setup and Administration Guide
SAS Open Metadata Architecture: Best Practices Guide

Oo o oo o

For a complete list of SAS publications, see the current SAS Publishing Catalog. To
order the most current publications or to receive a free copy of the catalog, contact a
SAS representative at

SAS Publishing Sales

SAS Campus Drive

Cary, NC 27513

Telephone: (800) 727-3228*
Fax: (919) 677-8166
E-mail: sasbook@sas.com

Web address: support.sas.com/pubs
* For other SAS Institute business, call (919) 677-8000.

Customers outside the United States should contact their local SAS office.
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binder
a virtual folder that can be mapped to a folder or directory on a server or to a folder
in a Windows file system. Binders enable multiple users and work groups to easily
access and share data across a network of servers on multiple platforms. Binders can

contain Enterprise Guide projects, source-code files, SAS data files, and other types
of data files.

COM (Component Object Model)
an object-oriented programming model that defines how software components
interact within a single process or between processes. For example, COM includes
standard rules of communication that enable a user-interface object to be dragged
and dropped from one application window to another.

database library
a collection of one or more database management system files that are recognized by
SAS and that are referenced and stored as a unit. Each file is a member of the library.

DCOM (Distributed Component Object Model)
an extension to the Component Object Model (COM) that enables components to
request services from components that are on other computers in a network.

engine
a component of SAS software that reads from or writes to a file. Each engine enables
SAS to access files that are in a particular file format.

LDAP (Lightweight Directory Access Protocol)
a set of protocols that are used for accessing directories or folders. LDAP is based on
the X.500 standard, but it is simpler and, unlike X.500, it supports TCP/IP.

LDIF (LDAP Data Interchange Format)
a file format that is widely used for building a database of directories that are stored
on multiple servers, for adding large numbers of directories to a directory database,
and for synchronizing the contents of those directories. The servers on which the
directories are stored must support the LDAP protocol.

libref (library reference)
a name that is temporarily associated with a SAS library. The complete name of a
SAS file consists of two words, separated by a period. The libref, which is the first
word, indicates the library. The second word is the name of the specific SAS file. For
example, in VLIB.NEWBDAY, the libref VLIB tells SAS which library contains the
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file NEWBDAY. You assign a libref with a LIBNAME statement or with an operating
system command.

metadata repository
a collection of related metadata objects, such as the metadata for a set of tables and
columns that are maintained by an application. A SAS Metadata Repository is an
example.

metadata server
a server that provides metadata management services to one or more client
applications. A SAS Metadata Server is an example.

object spawner
a program that instantiates object servers that are using an IOM bridge connection.
The object spawner listens for incoming client requests for IOM services. When the
spawner receives a request from a new client, it launches an instance of an IOM
server to fulfill the request. Depending on which incoming TCP/IP port the request
was made on, the spawner either invokes the administrator interface or processes a
request for a Universal Unique Identifier (UUID).

repository
a location in which data, metadata, or programs are stored, organized, and
maintained, and which is accessible to users either directly or through a network.
See also metadata repository, SAS Metadata Repository.

SAS client
a SAS session that requests access to remote data by means of a SAS server.

SAS Metadata Repository
a repository that is used by the SAS Metadata Server to store and retrieve metadata.
See also SAS Metadata Server.

SAS Metadata Server
a multi-user server that enables users to read metadata from or write metadata to
one or more SAS Metadata Repositories. The SAS Metadata Server uses the
Integrated Object Model (IOM), which is provided with SAS Integration Technologies,
to communicate with clients and with other servers.

schema
a map or model of the overall data structure of a database. A schema consists of
schema records that are organized in a hierarchical tree structure. Schema records
contain schema items.

server
a computer system that provides data or services to multiple users on a network.
The term ’server’ sometimes refers to the computer system’s hardware and software,
but it often refers only to the software that provides the data or services. In a
network, users might log on to a file server (to store and retrieve data files), a print
server (to use centrally located printers), or a database server (to query or update
databases). In a client/server implementation, a server is a program that waits for
and fulfills requests from client programs for data or services. The client programs
might be running on the same computer or on other computers.

tasks
in Enterprise Guide, operations that correspond to SAS procedures and SAS
functions that analyze, manipulate, or display data. From the Task List you can
select the analysis and reporting tasks that you want to run on your data.
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A

active repository
administering tasks
See task administration
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adding
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C
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configuring
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D

defining repositories

E

EGTASK library [40]
Enterprise Clients E
installing
Enterprise Guide
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Enterprise Guide Administrator
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populating
remote process
running locally
security
setting up

shared access

shared deployment
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working with
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Help E

importing
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deleting
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metadata repositories
See repositories
MVS servers

N
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networked environment
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setup image for users
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object definitions
object server
configuring
objects

viewing
options.ini file
08/390

manually assigning/unassigning libraries

P

playing back installations E
properties
group properties
library properties
SAS server properties
user properties

R

recording installations E
remote repository process
repositories
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See also Enterprise Guide metadata repositories
See also SAS Open Metadata Repositories
configuring

configuring updates

defining

deleting

in networked environment

modifying

setting up

shared deployment

specifying active repository

SAS Directory Services (SDS)
SAS Open Metadata Repositories
configuring

configuring updates
defining

deleting

modifying

shared deployment
specifying active repository
SAS servers

adding

installing E

updating properties
SDS (SAS Directory Services)
security

Enterprise Guide repositories
servers

binders mapped to server locations

managing

MVS
SAS servers E
setup

Enterprise Guide metadata repositories
repositories
silent setup program E
setup image
shared access
shared repository deployment
silent setup program E
playing back installations E
recording installations E

troubleshooting E

T

task administration
enabling
enabling tasks for user groups @
importing task definitions
task definitions
importing
troubleshooting
installation E
silent setup program E

U

updating repositories
user groups

enabling tasks for @
user profiles
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users
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