What's New in SAS Activity-Based Management 7.2.

PART 1  Getting Started  1

Chapter 1 • The Elements  3
Activity-Based Costing  3
SAS Activity-Based Management  4
The Resource Module  4
The Activity Module  5
The Cost Object Module  7
The External Units Module  8
Parcel Express Tutorial Model  8

Chapter 2 • Guidelines for Development  11
Guidelines for Creating the Model Structure  11
Guidelines for Creating Modules  14
Guidelines for Creating Dimensions  14
Guidelines for Creating Accounts  17
Guidelines for Creating Drivers  19
Guidelines for Creating Assignments  20
Guidelines for Sharing Models, Configurations, and Data  20

Chapter 3 • The User Interface  23
Navigation Pane  24
Workspace Manager  27
Workspace Manager Tasks  30
Shortcut Keys  32
Buttons and Icons  34
Help Tips  43
Using the JAWS Graphics Labeler  45
Create Shortcut Dialog Box  45
New Folder Dialog Box  46
About SAS Activity-Based Management Dialog Box  46
SAS Activity-Based Management System Information Window  47

Chapter 4 • User Capabilities and Groups  49
Overview  49
Capabilities  49
Group Permissions  50
Giving Read or Read/Write Permission to Members of a Group  50
Changing Owners  51
Select User Dialog Box  52

Chapter 5 • The Workflow  53
The Work Flow  54
Working in SAS Activity-Based Management  55
Log On Dialog Box  58
## Contents

**Chapter 28 • How To**
- Create a Driver ........................................... 317
- Specify the Default Driver .............................. 320
- Create an Assignment ................................. 321
- Associate a Driver Using an Account's Item Properties ........................................... 323
- Associate a Driver Using a Module's Grid ........................................... 324
- Show Only the Source Accounts for a Driver ........................................... 325
- Show Only the Destination Accounts for a Driver ........................................... 325
- Show the Source Accounts and the Destination Accounts for a Driver ........................................... 325

**PART 10 Using Formulas with Drivers and Calculated Attributes** 327

**Chapter 29 • Formulas** ........................................... 329
- Formula ........................................... 330
- Functions ........................................... 331
- Formula Context ........................................... 332
- Enhanced Formula Capabilities ........................................... 337
- Using Numeric Attributes in a Formula ........................................... 340
- Troubleshooting Formulas ........................................... 341
- Operator Precedence ........................................... 343
- Formula Builder Dialog Box ........................................... 343

**Chapter 30 • Boolean Functions** ........................................... 347
- Introduction ........................................... 347
- HasAttribute function ........................................... 347
- if function ........................................... 348
- IsChildOf function ........................................... 348
- IsClose function ........................................... 349
- IsNull function ........................................... 350
- Match function ........................................... 350

**Chapter 31 • Numeric Functions** ........................................... 353
- abs function ........................................... 353
- degrees function ........................................... 353
- exp function ........................................... 354
- max function ........................................... 354
- min function ........................................... 354
- pi function ........................................... 354
- power function ........................................... 355
- quotient function ........................................... 355
- radians function ........................................... 355
- round function ........................................... 355
- sign function ........................................... 356
- sqrt function ........................................... 356
- trunc function ........................................... 356

**Chapter 32 • String Functions** ........................................... 357
- & function (string concatenation) ........................................... 357
- find function ........................................... 357
- left function ........................................... 358
- len function ........................................... 358
- mid function ........................................... 358
PART 14 Generating Cubes 437

Chapter 39 • Working with Generation 439

Cubes 439
Generate Cubes 442
Incremental Cube Generation 443
Include Numeric Attributes in a Cube 446
Display the Internal Name of a Cube 447
Delete a Cube or Fact Table 448
Manage Cube Permissions 448

PART 15 OLAP Analysis 451

Chapter 40 • Using the Analysis Workspace 453

Analysis Workspace 453
OLAP Mode 455
OLAP Views 456
OLAP Analyzer View 457
Save OLAP View As Dialog Box 459
Change Cube Context Dialog Box 460
SAS OLAP Restrictions 461

Chapter 41 • How To 463

Using the SAS OLAP Analyzer 463
Create an OLAP View 464
Change the Appearance of an OLAP Window 464
Open an OLAP View 464
Open an OLAP View with an OLAP View Already Open 465

PART 16 Querying Contributions 467

Chapter 42 • Contributions Workspace 469
## Part 17 Importing and Exporting

### Chapter 43 • Model Data
- Importing Model Data ................................................. 479
- Using the Import Wizard to Import from a Database .................. 481
- Using the Import Data Wizard to Import an XML File .............. 489
- Exporting Model Data .................................................. 492
- Archive a Model to an XML File with the Export Wizard ........... 493

### Chapter 44 • Survey Data
- Exporting Survey Data .................................................. 497
- Importing Survey Data .................................................. 502

### Chapter 45 • Cube Configurations
- Import Cube Configurations .......................................... 507
- Export Cube Configurations .......................................... 507

### Chapter 46 • Column Layouts
- Import a Column Layout .............................................. 509
- Export a Column Layout ............................................... 509

### Chapter 47 • Export Module Views to Excel
- Export Module Views to Excel ........................................ 511

### Chapter 48 • OLAP Views
- Import OLAP Views ..................................................... 521
- Export OLAP Views .................................................... 522
- Export to Excel ......................................................... 522

### Chapter 49 • Reports
- Export a Report .......................................................... 525

### Chapter 50 • Easy API
- Using Easy API .......................................................... 527

### Chapter 51 • Publish Information Maps
- Overview ................................................................. 533
- Create Information Maps (Register Metadata) ....................... 533
- Register Metadata / Metadata Server Options ....................... 535

### Chapter 52 • Publish Behaviors to SAS Profitability Management
- Overview ................................................................. 539
- Publish Behaviors to SAS Profitability Management ............... 539

### Chapter 53 • Publish Performance Measures to SAS Strategy Management
- Overview ................................................................. 543
- Steps for Integrating with SAS Strategy Management .............. 543
### Contents

**Performance Measures View** .................................................. 552  
**Publish Performance Measures Dialog Box** ........................... 553

**PART 18 Reporting Model Data**  555

**Chapter 54 • About Reports** .................................................. 557  
Reports ....................................................................................... 558  
Reports Mode ............................................................................ 560  
Reports Workspace .................................................................... 560  
Report Page ................................................................................. 562  
Report Templates ....................................................................... 565  
Publish Report Dialog Box ......................................................... 565  
Insert New Published Report Dialog Box .................................... 565  
Report Configuration Dialog Box .............................................. 566

**Chapter 55 • Correlation Reports** ........................................... 567  
What is a Correlation Report ....................................................... 567  
Create a Correlation Report ....................................................... 571  
Report Output ............................................................................ 573  
Export a Report .......................................................................... 578

**Chapter 56 • How To** .............................................................. 581  
Create a Report .......................................................................... 581  
Open a Report ........................................................................... 585  
Open a Report with a Report Already Open ................................. 585  
Change a Report Configuration .................................................. 585  
Save a Report Configuration ...................................................... 586  
Export a Report .......................................................................... 586  
Publish a Report ......................................................................... 591  
Delete a Report Configuration .................................................... 592

**PART 19 Customizing the Interface**  593

**Chapter 57 • User Options** .................................................... 595  
Customizing the Interface: User Options .................................... 595  
Cause Background Colors to Be Printed ..................................... 599  
Hide or Show the Status Bar ....................................................... 599  
Retrieve More Rows from the Server .......................................... 599  
User Options Dialog Box .......................................................... 599

**PART 20 Properties Reference**  603

**Chapter 58 • Property Relationship Diagrams** ....................... 605  
Cost Flowing Into and Out of an Account (Non-Reciprocal) ......... 606  
Cost Flowing Into and Out of an Account (Reciprocal) ............... 609  
Assignment Properties .............................................................. 610  
Account Driver Properties ......................................................... 611  
Combined Account Cost Properties ......................................... 613  
Cost (Economic World) .............................................................. 615
Has Attributes (HasAttr) ......................................................... 659
Cost (Cost) ................................................................. 641
Formula (Formula) .......................................................... 658
Driver Quantity Variable (DQV) ........................................ 654
Incoming Cost ............................................................. 632
Has idle Cost (HasIdlCost) .................................................. 660
Types of Costs .................................................................. 618
How to Read these Diagrams ............................................. 616
Properties ........................................................................ 623
Chapter 59 • Properties in Calculation ................................. 623
Properties ........................................................................ 623
Assignment and Account Driver Properties ......................... 626
Outgoing Cost .................................................................. 630
Incoming Cost .................................................................. 632
Chapter 60 • Properties Listed Alphabetically ..................... 635
Allocated Cost (AllocCost) .................................................. 637
Assigned Cost (AsgnCost) ................................................... 638
Assigned Idle Cost (AsgnIdlCost) ....................................... 639
Assigned Idle Quantity (AsgnIdlQty) ................................... 640
Assigned Non Reciprocal Cost (AsgnNRecipCost) ............... 640
Assigned Reciprocal Cost (AsgnRecipCost) ....................... 640
Calculate Error (CalcError) .............................................. 641
Cost (Cost) ................................................................ 641
Dimension Level Name (DimLevelName) ............................ 642
Dimension Level Number (DimLevelNum) .......................... 642
Dimension Member Name (DimMemName) ......................... 643
Dimension Member Reference (DimMemRef) ....................... 643
Dimension Name (DimName) ............................................. 644
Display Name (Display Name) ............................................ 645
Display Reference (Display Reference) ............................... 645
Drivable Cost (DrvblCost) .................................................. 646
Driven Cost (DrvCost) ...................................................... 647
Driven Cost (DrvnCost) ...................................................... 647
Driven Quantity (DrvnQty) ................................................ 647
Driver Allocated Cost (DrvAllocCost) .................................. 648
Driver Cost (DrvCost) ...................................................... 648
Driver Driven Cost (DrvDrvCost) ....................................... 649
Driver Driven Quantity (DrvDrvQty) ................................... 650
Driver Formula (DrvFormula) ............................................. 650
Driver Idle Cost (DrvIdlCost) ............................................ 651
Driver Name (DrvName) .................................................... 651
Driver Percentage (DrvPcnt) .............................................. 652
Driver Quantity Basic (DrvQtyBasic) ................................. 652
Driver Quantity Calculated (DrvQtyCalc) ............................ 652
Driver Quantity Fixed (DQF) .............................................. 653
Driver Quantity Variable (DQV) ....................................... 654
Driver Rate (DrvRate) ........................................................ 654
Driver Sequence Number (DrvSeq) ................................... 655
Driver Type (DrvType) ...................................................... 655
Driver Used Cost (DrvUsedCost) ....................................... 656
Driver Weight Fixed (DWF) .............................................. 656
Driver Weight Variable (DWV) ......................................... 657
Entered Cost (EntCost) ...................................................... 657
Fixed Driver Quantity Override (FixedDQOverride) .......... 658
Formula (Formula) .......................................................... 658
Has Assignments (HasAsgn) ............................................. 659
Has Attributes (HasAttr) ................................................... 659
Has BOC (HasBOC) .......................................................... 659
Has Entered Cost (HasEntCost) ......................................... 660
Has Idle Cost (HasIdlCost) ............................................... 660
Has Notes (HasNotes) ...................................................... 661
Has Used Cost (HasUsedCost) ........................................... 661
Idle Cost (IdlCost) ......................................................... 661
Idle Driver Quantity (IdlDrvQty) ...................................... 662
Idle Driver Quantity UE (IdlQtyUE) ................................. 663
Idle Flow Method (IdleFlow) ............................................ 663
Idle Percentage (IdlPcnt) ............................................... 664
Idle Quantity (IdlQty) .................................................... 665
Intersection Name (IntsctnName) ................................. 666
Intersection Reference (IntsctnRef) .............................. 666
Is Behavior (IsBehavior) ................................................ 667
Module Type (ModType) ................................................ 667
Name (Name) .......................................................... 667
Output Quantity (OutQty) .............................................. 668
Output Quantity UE (OutQtyUE) ..................................... 668
Periodic Note (PerNote) ............................................... 669
Profit (Profit) .......................................................... 669
Received Allocated Cost (RcvAllocCost) ......................... 669
Received Assignment Cost (RcvAsgnCost) ....................... 670
Received BOC Cost (RcvBOCCost) ................................. 671
Received Cost (RcvCost) ............................................... 672
Received Driven Cost (RcvDrvCost) .............................. 673
Received Idle Cost (RcvIdlCost) .................................... 673
Received Non Reciprocal Cost (RcvNRecipCost) .............. 674
Received Reciprocal Cost (RcvRecipCost) ....................... 674
Received Used Cost (RcvUcost) ..................................... 674
Reference (Reference) .................................................. 675
Revenue (Revenue) ...................................................... 675
Rule Formula (RuleFormula) ........................................... 676
Sold Quantity (SoldQty) ............................................... 676
Total Driver Quantity (TDQ) ........................................... 677
Total Driver Quantity Basic (TDQBasic) ......................... 677
Total Driver Quantity Calculated (TDQCalc) .................... 678
Total Driver Quantity UE (TDQUE) ............................... 678
Type (Type) ........................................................... 679
Unassigned Cost (UnAsgnCost) ................................. 679
Unassigned Quantity (UnAsgnQty) .............................. 680
Unique Driver Quantities (UniqDvrQty) ......................... 680
Unit Cost (UnitCost) ..................................................... 681
Unit Of Measure (UoM) .................................................. 681
Unit Profit (UnitProfit) .................................................. 682
Unit Revenue (UnitRevenue) .......................................... 682
Use Fixed Quantities (UseFixQty) .................................. 683
Use Variable Quantities (UseVarQty) ............................. 683
Use Weighted Quantities (UseWeightedQty) .................... 684
Used Cost (UsedCost) .................................................. 684
Used Quantity (UsedQty) ............................................. 685
Use Rule Formula (UseRuleFormula) ............................. 685
User-Entered Cost Allocation (UECostAllocation) ............ 686
Variable Driver Quantity Override (VariableDQOverride) .. 687

Index ............................................................................. 689
What’s New in SAS Activity-Based Management 7.2

Overview

- “Surveys” on page xv
- “Set Attributes on Dimension Members” on page xvi
- “Select Dimension Members for Inclusion in Cubes” on page xvi
- “Incremental Cube Generation” on page xvii
- “Export Module Views to Excel” on page xvii
- “Save Queries for Account Search” on page xviii
- “Expand All/Collapse All” on page xix
- “Enhanced Public Views” on page xx
- “Select a Default Column Layout” on page xx
- “Correlation Reports” on page xxi
- “Conditional Highlighting of Module Cells” on page xxi
- “Rename Modules” on page xxi
- “Integration with SAS Strategy Management” on page xxiii
- “Choice in Exporting OLAP Views to Excel” on page xxiii
- “Independent TDQ” on page xxiv
- “Import from and Export to Microsoft Office” on page xxiv
- “Delete All Assignments” on page xxiv
- “Easy API” on page xxv

Surveys

One of the most difficult tasks in maintaining a model is keeping its data accurate and up-to-date. Now you can create Web surveys to solicit data from the people who are directly responsible for the activities and accounts in your model. Data from the surveys is written directly to staging tables that have been exported from the model.
The following table shows the types of surveys that you can create for each module and the fields that a survey taker can update for each type of survey.

*Note:* Each field name is qualified by the staging table that it is in.

<table>
<thead>
<tr>
<th>Module</th>
<th>Type of survey</th>
<th>Fields that can be updated</th>
</tr>
</thead>
<tbody>
<tr>
<td>External Unit</td>
<td>Quantity: <em>(account)</em></td>
<td>Assignment.DriverQuantityFixed</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Unit Costs</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ExternalUnit.UnitCostEntered</td>
</tr>
<tr>
<td>Resource</td>
<td>Resource Drivers</td>
<td>Assignment.DriverQuantityFixed</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Resource Costs</td>
</tr>
<tr>
<td></td>
<td></td>
<td>EnteredCostElement.EnteredCost</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Numeric Attribute</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ValueAttributeAssociation.NumericValue</td>
</tr>
<tr>
<td>Activity</td>
<td>Activity Drivers</td>
<td>Assignment.DriverQuantityFixed</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Numeric Attributes</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ValueAttributeAssociation.NumericValue</td>
</tr>
<tr>
<td>Cost Object</td>
<td>Cost Object Drivers</td>
<td>Assignment.DriverQuantityFixed</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Revenues and Sold Quantities</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Account.Revenue</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Account.SoldQuantity</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Output Quantities</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Account.OutputQuantityUE</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Numeric Attributes</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ValueAttributeAssociation.NumericValue</td>
</tr>
</tbody>
</table>

For more information, see “Surveys” in the *SAS Activity-Based Management 7.2: Data Administration Guide* available from the Help menu or from [http://support.sas.com/documentation/onlinedoc/abm/](http://support.sas.com/documentation/onlinedoc/abm/).

---

**Set Attributes on Dimension Members**

Setting an attribute on a dimension member provides a method of automatically setting the attribute on multiple accounts. Setting an attribute on a dimension member is an indirect method of setting the attribute on all the accounts that share in that dimension member. Because having attributes on accounts is particularly important for generating rule-based drivers, setting attributes on dimension members provides a method of quickly setting those attributes on many accounts.

See Chapter 20, “Attributes on Dimension Members,” on page 197.

---

**Select Dimension Members for Inclusion in Cubes**

You can now pick and chose at any level of the dimension hierarchy what dimension members to include in a generated cube. With this ability, you can create cubes that go deep into the dimension hierarchy and still remain small.
Incremental Cube Generation

Now, when you generate a cube, for every period (period and scenario association) that will be included in an existing cube, if

- the cube already contains that period, and
- the period has not been modified since the cube was last generated,

then the period is not regenerated. This means that cube generation is faster because periods that have already been generated are not regenerated.

When you generate a cube for a model that has been generated before, SAS Activity-Based Management determines whether the entire cube must be regenerated or whether only the new or modified periods need to be generated. When you generate a cube, you do not have to specify whether you want incremental generation. SAS Activity-Based Management makes the determination for you.

Also, dimensions are no longer shared between models. Previously, dimension sharing meant that when a dimension changed in one model (for example, by gaining new dimension members), then every model that shared that dimension required its cubes to be regenerated, even if the particular change did not affect the model. Now that dimensions are no longer shared, less time is needed for cube generation.

See “Incremental Cube Generation” on page 443.

*Note:* With the implementation of incremental cube generation, OLAP views that were saved in a previous release of SAS Activity-Based Management will no longer work in SAS Activity-Based Management 7.2 if you are using Microsoft Analysis Services to build the cube. This is because the saved view is an MDX query, and the period names embedded in the query are no longer correct.

Export Module Views to Excel

If you want a printable form of the hierarchical structure of a module and one that you can easily modify without affecting the underlying model, you can export the module to Excel. You can either select particular rows of a module view to export or you can export the entire module. Only those rows that are expanded when you perform the export are exported. So, what you see in the module view is what you get in the spreadsheet.

The following picture shows how to select rows in the primary pane of a partially expanded Resource module, right-click, and select Export to Excel:
Save Queries for Account Search

Queries for searching for accounts can be long, complicated, and tedious to construct. Now you can save your queries, retrieve them for subsequent use, export them, and import them.

Once a query has returned the results that you want, click Save Query on the Search Account Results dialog box to save the query. The query is saved along with your SAS Activity-Based Management user ID.
To retrieve queries for subsequent use, click **Saved Queries** on the Search for Accounts dialog box. A list of the queries saved with your user ID is displayed for selection and reuse.

Expand All/Collapse All

There is a new menu item that allows you to expand all the levels of the hierarchy of a dimension in a module view (Resource, Activity, Cost Object, External Object) so that you can see all the accounts at every level. The menu item takes the place of repeated clicking in the hierarchy to expand it.

See “Save Queries for Account Search” on page 162.
Enhanced Public Views

In previous releases, public views used an internally generated number to refer to models, dimensions, and cube configurations. Not only was it not obvious what objects were referred to by the numbers, but the numbers changed when a model was re-imported—thus invalidating any procedures that referred to those numbers.

Now, although the original public views are maintained in this release for those who want to continue using them, there is an entirely new set of public views. These new public views maintain the same columns as the old ones, but instead of using internally generated numbers, they use more meaningful identifiers as follows:

**Model**
- Model reference

  *Note:* The model reference is also used as the prefix for cube names instead of the numeric model identifier.

**Dimension**
- Dimension short reference

**Cube Configuration**
- Cube configuration reference

These identifiers do not change when a model is re-imported, so procedures that you create referencing them remain valid.

For more information, see "Public Views" and "Information Maps" in the *SAS Activity-Based Management 7.2: Data Administration Guide* available from the Help menu or at [http://support.sas.com/documentation/onlinedoc/abm/](http://support.sas.com/documentation/onlinedoc/abm/).

Select a Default Column Layout

Although you can customize, name, and save column layouts, in previous releases every model always opened with the same default column layout. Now you can select a
different default layout for every model. The layout that you select is the layout that is used each time that you open the model. A single column layout contains a column specification for all the modules—External Unit, Resource, Activity, Cost Object—and also the Dimension view.

To select a default column layout for a model, open the Model Properties dialog, and select a layout from the drop-down list for the Default column layout option, as shown in the following picture.

**Correlation Reports**

A correlation report shows the correlation over multiple periods between the demand for products and services and the cost of producing them. A correlation report provides an answer to the question of how reliably can one predict cost given an increase or decrease in demand. For every account with outgoing assignments or with a sold quantity not equal to zero, a correlation report shows the strength of correlation between that account’s demand and its cost.

The report can help in the following ways to validate a model across multiple periods:

- ascertain whether changes to driver quantities reliably affect costs when adjusting sales and process mixes
- identify weak correlations that require changing the unit of measure used to drive costs or redefining the flow of money through the model
- provide a foundation for reliable predictive models for forecasting and simulation.

Conditional Highlighting of Module Cells

With using conditional highlighting of cells, you can change the text and background color of the cells in a column that satisfy conditions that you specify. For example, you can highlight in red all the Cost cells that contain a negative value. Or you can highlight text cells with a particular content.

See “Conditionally Highlight Cells in a Column” on page 239.

Rename Modules

Instead of using the standard names for modules—Resource, Activity, Cost Object, External Unit—you can rename the modules in your model. This is particularly useful for those who are using SAS Activity-Based Management to model something other than costs—for example, greenhouse gases.

To rename modules, select Model ➔ Properties and click the Module Alias tab.
Note: Module names can be up to 64 characters and can contain the following characters: alphanumerics, underscores, and embedded blanks.

Note: The aliases are preserved during model export and import; however, the aliases do not appear in cubes or reports and are not substituted elsewhere in the user interface such as in menu items.

Integration with SAS Strategy Management

SAS Activity-Based Management 7.2 supports a simpler interface with SAS Strategy Management. When you publish performance measures, SAS Activity-Based Management creates tables and registers them in metadata so that you can import them directly into SAS Strategy Management 5.3.


Choice in Exporting OLAP Views to Excel

When exporting an OLAP view to Excel, you can choose either of two options:

**Dimensions Flattened**

The Excel table has more columns and fewer rows. The table has a single row of column headers, with one level per column.

**Dimensions not Flattened**

The Excel table has fewer columns and more rows. Each dimension has its own row.
Independent TDQ

The property TDQ (total driver quantity) is now decoupled from OutputQty so that TDQ always defaults to UsedQty. Consequently, a change in OutputQtyUE affects UnitCost, but it does not affect TDQ. So, changing OutputQtyUE does not affect DriverRate (which depends on TDQ) and, thus, does not affect cost flows. The effect is to allow you to change UnitCost without affecting the overall cost flow.

See “Independent TDQ” on page 303.

Import from and Export to Microsoft Office

When importing from or exporting to Microsoft Access or Microsoft Excel, SAS Activity-Based Management uses Microsoft Office drivers on the client. This now allows you to import from or export to client installations of Microsoft Office, even if your SAS Activity-Based Management server is on a UNIX system where the Microsoft Office drivers would not work.

For more information, see Chapter 15, “Connecting to a Database,” in SAS Activity-Based Management: Data Administration Guide.

Delete All Assignments

The following menu items now delete all assignments, whether visible or not, for a selected account, not only for those assignments that are visible in an Assignments pane:

- **Delete All Assignments Left**
- **Delete All Assignments Right**
- **Delete All Assignments Left and Right Shift+F7**
This represents a change in behavior from the previous version, in which only those assignments that were visible were deleted.

*Note:* A Left or Right Assignments pane does not have to be open in order to delete all the assignments for a selected account.

---

**Easy API**

Using Easy API, you can do in batch many of the same operations that you can do inside SAS Activity-Based Management. With Easy API, you can

- Import and export model data
- Calculate a model
- Generate a cube
- Export report data
- Copy model data from one period/scenario to another
- Import and export cube configurations

In addition, you can use Easy API to run SAS stored processes, an external SAS Enterprise Guide project, or any other executable that you want to invoke. So, for example, you can use Easy API to export model data, invoke a stored process to update the exported data, and finally import the updated data back into your model.

For more information, see "Using the API" in the *SAS Activity-Based Management 7.2: Data Administration Guide* available from the Help menu or at [http://support.sas.com/documentation/onlinedoc/abm/](http://support.sas.com/documentation/onlinedoc/abm/).
Part 1

Getting Started

Chapter 1
  The Elements ................................................................. 3

Chapter 2
  Guidelines for Development ............................................ 11

Chapter 3
  The User Interface ......................................................... 23

Chapter 4
  User Capabilities and Groups ......................................... 49

Chapter 5
  The Workflow ............................................................... 53
Activity-Based Costing

Activity-based costing is the basic tool of activity-based management. Two critical limitations of traditional cost accounting systems are the following:

- the inability to report individual product, customer, service, or process costs with a reasonable level of accuracy
- the inability to provide useful feedback to management for the purpose of operational control

When managers of complex organizations make important decisions using traditional cost accounting systems, inaccurate and/or inappropriate cost information and profitability information cause incorrect decisions. These decisions often affect such areas as pricing, product mix, resource allocations, and budgeting.

Activity-based costing more accurately tracks costs than traditional methods because activity-based costing assumes the following:

- Activities cause expenditure of resources.
- Cost objects (the results of activities or products and services produced) create the demand for activities.
Using SAS Activity-Based Management, one or more models can be built to apply direct and indirect organizational costs to specific activities and processes. As a result, managers are able to see actual cost assignments and their bottom-line impacts from an operational perspective. Managers get a true understanding of the cause-and-effect relationships that link resources and processes to outputs. Therefore, business planners can easily forecast resource requirements, create budgets, and optimize capacity usage.

SAS Activity-Based Management

By applying direct and indirect business costs to activities, SAS Activity-Based Management enables managers to get a true understanding of the costs and profits that are associated with a product, customer, service, or business process. SAS Activity-Based Management supports ongoing profitability analysis, cost-management initiatives, shared services management, planning and budgeting efforts, and capacity optimization.

An activity-based management system identifies activities, associates resources (expenditures) with those activities, and flows the cost of activities to cost objects.

With SAS Activity-Based Management, you can analyze business trends, and you can make the results of your analyses available to business professionals throughout your organization. You do not need to know how to program or how to use database tools.

SAS Activity-Based Management guides you through the steps for Web-enabled data analysis and reporting from a model. With access over the Internet to interactive views of a model, to interactive analysis capabilities, and to customizable reports, decision-makers can complete the following tasks:

• learn the true costs of producing and delivering products or services
• identify areas in which profits could be increased
• examine processes and act to improve them

The Resource Module

Overview

The Resource module contains information about resources, such as salaries, materials, and depreciation. Resources are the costs that are consumed by activities such as planning, introducing new line items, advertising, or promoting products. To understand and manage resources, you should focus on activities and on how they consume resources.

Guidelines for Creating the Structural Dimensions

The typical structural dimensions in the Resource module are General Ledger and Organization. These dimensions are denoted as General Ledger x Organization.

Before you create the structural dimensions, consider the following typical dimensions, suggested dimension level names, and example dimension members.
**General Ledger Dimension**

The General Ledger dimension typically contains information about expense categories and individual expenses. The information for this dimension can be found in your organization's general ledger or other transactional financial system.

The General Ledger categorizes expenses into a hierarchy, an example of which is shown in the following example:

```
1xx Wages, Salaries, and Benefits
  10x Salaries and Wages
    101 Wages - Hourly
    102 Wages - Salary Non-Exempt
    103 Wages - Salary
    104 Overtime Premium
    105 Shift Differential
    106 Management Bonus
```

The lowest level of detail shown (items 101-106) is generally captured in the General Ledger for such purposes as taxes, expense analysis, reconciliation, and internal control. Although this low level of detail is necessary for financial accounting, it is usually too detailed for a SAS Activity-Based Management model. This level of detail is cost classification, whereas the level of detail for a model should be cost behavior.

To obtain the level of detail of cost behavior, the lowest level of detail in the General Ledger that should be used in a SAS Activity-Based Management model is the next higher level in the example (10x Salaries and Wages). For example:

<table>
<thead>
<tr>
<th>Dimension Level Name</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>GL Account Group</td>
<td>Wages, Salaries, and Benefits</td>
</tr>
<tr>
<td>GL Account</td>
<td>Salaries and Wages</td>
</tr>
</tbody>
</table>

If the most detailed level of the General Ledger must be in a model, you can use entered cost elements to store these costs.

**Organization Dimension**

The Organization dimension that was created in the Activity module can be reused here.

**See Also**

- “Measures and Dimensions” on page 123
- “Modules, Module Rollups, Accounts, and Rollup Accounts” on page 146

---

**The Activity Module**

**Overview**

The Activity module contains information about activities. Activities are tasks performed within an organization, such as entering the details of a customer order, operating a machine, or loading a pallet.

Activities can receive costs from resource accounts or from other activity accounts.
Guidelines for Creating the Structural Dimensions

The typical structural dimensions in the Activity module are Activities and Organization. These dimensions are denoted as Activities x Organization.

Before you create the structural dimensions, consider the following suggested dimension level names and example dimension members.

**Activities Dimension**

The Activities dimension typically contains information about business processes and individual activities.

A business process is a group of activities with a common outcome or output. Because activities are the building blocks of business processes, activities and business processes can be incorporated into a single structural dimension. The business processes can be created as the upper (more summary) dimension members, and the activities can be created as the lower (more detailed) dimension members. For example:

<table>
<thead>
<tr>
<th>Dimension Level Name</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Macro Process</td>
<td>Receive Packages</td>
</tr>
<tr>
<td></td>
<td>Collect by Region</td>
</tr>
<tr>
<td></td>
<td>Collect by Region</td>
</tr>
<tr>
<td></td>
<td>Unload Trucks</td>
</tr>
<tr>
<td>Process</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Activity</td>
<td></td>
</tr>
</tbody>
</table>

**Organization Dimension**

The Organization dimension typically contains information about the organization’s structure. The information for this dimension can be found in your organization’s Organizational Chart.

Each department manager is responsible for the expenses incurred by his/her department. The activity-based management model that is most useful to business users preserves the departments. Preserving each department enables each department manager to examine the activities performed in the department, the costs of those activities, and how the resources for which each manager is responsible affect the activities that he/she manages.

For example:

<table>
<thead>
<tr>
<th>Dimension Level Name</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Facility</td>
<td>North Carolina</td>
</tr>
<tr>
<td></td>
<td>Manufacturing</td>
</tr>
<tr>
<td></td>
<td>Inspection</td>
</tr>
<tr>
<td>Function</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Department</td>
<td></td>
</tr>
</tbody>
</table>

See Also

“Measures and Dimensions” on page 123
The Cost Object Module

Overview

The Cost Object module contains information about products and services. Additionally, products and services can be organized by customers, channels, regions, and so on. Cost objects can receive costs from resources, activities, other cost objects, or any combination of these three.

Guidelines for Creating the Structural Dimensions

The typical structural dimensions in the Cost Object module are Products, Customers, and Channels. These dimensions are denoted as Product x Customer x Channel. (For public organizations, the typical structural dimensions are Service and Region.) If your organization is complex, you might need to create other dimensions.

Before you create the structural dimensions, consider the following suggested dimension level names (so that business users can examine data at various levels).

**Products Dimension**
The Products dimension typically contains information about product categories and individual products. For example:

<table>
<thead>
<tr>
<th>Dimension Level Name</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Product Line</td>
<td>Shoes</td>
</tr>
<tr>
<td>Product Group</td>
<td>Summer Sandals</td>
</tr>
<tr>
<td>Product</td>
<td>Leather Weave</td>
</tr>
<tr>
<td>SKU (if needed)</td>
<td>Tan576830</td>
</tr>
</tbody>
</table>

**Customers Dimension**
The Customers dimension typically contains information about customer categories and individual customers. For example:

<table>
<thead>
<tr>
<th>Dimension Level Name</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Customer Group</td>
<td>Retail</td>
</tr>
<tr>
<td>Customer Category</td>
<td>Discount</td>
</tr>
<tr>
<td>Specific Customer</td>
<td>Big Mart</td>
</tr>
<tr>
<td>Location (if needed)</td>
<td>Phoenix</td>
</tr>
</tbody>
</table>

**Channels Dimension**
The Channels dimension typically contains information about distribution channel categories and individual channels. For example:
The External Units Module

The External Units module contains information about external unit cost elements. An external unit is an item, such as a part purchased from a supplier, whose cost is maintained outside of a SAS Activity-Based Management model, but needs to be accounted for in the model.

Like the other modules, the External Units module can contain multiple dimensions. For example, if you obtain parts from several suppliers, you can create the dimensions Supplier and Part. Then, based on the availability and cost of a part, you can enter cost information for the supplier from whom you bought the part.

Suppose that your organization is a municipality that supplies garbage-collection services to residents. You can create an external unit named Tons of Garbage that has a unit cost that is the cost per ton your organization is charged to dispose of the garbage. You can enter the number of tons of garbage collected to calculate the total charge. Also, if your organization supplies bins or carts in which residents place their garbage, you can create an external unit for the cost of each bin or cart.

See Also

- “Measures and Dimensions” on page 123
- “Modules, Module Rollups, Accounts, and Rollup Accounts” on page 146

Parcel Express Tutorial Model

You can import an already-completed model for the Parcel Express Tutorial by doing the following:

1. Select File ⇒ Import ⇒ Model Data.
2. Select XML or ZIP File as the type of data you want to import, and click Next.
3. Browse to, and select the following file: `<install director>\Activity-Based Management Solution\Client\Samples\Models\Native \ParcelExpressTutorial.xml`
4. Name the tutorial. You can name it anything you want. Click **Next**, review your choices, then click **Finish**.

The tutorial model is imported. You must calculate the model to view calculated data.
Guidelines for Creating the Model Structure

**Anticipate the Needs of Users**

Before you build a model, define the goals of the model. Each organization has different goals that affect how a model is designed. There is no single correct way to design a model.

Before you build the model, consider the following questions:

- What are the required outputs, such as reports or cubes?

The people in your organization might need to answer questions such as, What does this product or service cost? and Why does it cost that?
The type and details of analysis that users perform after the model is built depend on the structure that you define.

- **How well do you know your organization?**
  
  Know your organization well before starting to build a model. Consider your organization's systems, products or services, and customers.

- **What types of information do the people in your organization need?**
  
  Ensure that the model accommodates the needs and goals of the organization. Include only that information that supports the needs and goals.

- **What level of detail is important to your organization?**
  
  If you include too much detail, you might complicate the analysis without adding useful information. A detailed model requires more maintenance in the future. If you include too little detail, you might fail to reveal opportunities for improvement. Include enough detail to generate any required reports.

Building a model is an iterative process. Few people build a model with all of the necessary information the first time. A model often requires several iterations to determine the best balance between too much information and not enough information.

Communicate often with those people who will use the information provided by the model. Are you including the information that meets their needs? Is the amount of detail enough? Do these people need to analyze the data in ways you have not accommodated in the model?

The best method to design a model is to create a paper model before attempting to build the model in SAS Activity-Based Management.

**Create a Paper Model**

A paper model helps you focus on the model structure before entering data into the model. Sketch the model structure on paper, and note the important levels in the organizational hierarchy. Then, review the paper model with other people in your organization to determine whether you are approaching their needs correctly.

Your paper model might look something like the following:
After you determine that the paper model meets the needs of the people in your organization, you should start collecting the data that is needed by the model.

**Collect Data**

A review of the paper model will identify the data that you need to collect. The quality and the integrity of the model depend on identifying the data and collecting the data.

There are many different ways to collect data. Most organizations use a combination of techniques and methods, such as the following:

- conducting interviews with people
- distributing questionnaires to people
- analyzing historical records and reports
- gathering a panel of experts or focus groups
- observing people and work flow

**Guidelines for Designing a Model**

A well-designed model is based on a good understanding of your organization's resources, activities, and cost objects. When you create a model, goals are defined. Each organization has different goals that affect how a model is designed. There is no single correct way to design a model.

Here are some guidelines for creating a model that runs efficiently and that provides useful information:

- Define the goals.
  What are the goals and the scope?
- Decide what types of information are needed.
  What types of information do managers need? Make sure that the model accommodates the needs and goals of the organization.
- Design the model structure before entering data into the model.
  Note the important levels in the organizational hierarchy.
- Decide how much detail to include.
  What level of detail is important to your organization? If you include too much detail, you might complicate the analysis without adding useful information. A detailed model requires more maintenance in the future. If you include too little detail, you might fail to reveal opportunities for improvement. Include enough detail to generate any required reports.
- Combine similar accounts.
  If your organization's General Ledger lists the details of travel expenses, such as airfare, hotel, or entertainment, you might want to combine these accounts into one travel account. Are the particular costs incurred together, or are multiple costs caused by the same factor? If so, you might want to combine such items. Also, if some accounts have small costs, you might want to combine the small accounts into larger accounts that represent more general categories.
- Group related accounts.
Group accounts into rollup accounts if the accounts have similar functionality or if the accounts are linked to similar activities.

- Gather costs.
  Consider the relationship between the time period that you use for gathering costs and the time period that you use for gathering resource values and activity driver values.

- Collect driver data.
  When you collect driver data to assign activity costs to cost objects, ensure that the data is current, available, and accurate. Ask individuals in your organization to verify the data’s accuracy.

- Minimize the use of unique driver quantities.
  Unique driver quantities can use a lot of memory. They increase your processing time, and they do not provide a calculation advantage.

---

**Guidelines for Creating Modules**

Before you create the modules, consider the following:

- Start by creating the Cost Object module.
  Identify the expected result and work toward it. If your organization is in the service industry, the cost objects might not be known. In this situation, start by creating the Activity module.

- Identify the departments (or branches) of your organization.
  The structural dimensions for the Activity module and the Resource module depend on this knowledge. (More information is presented in the sections that address the Activity module and the Resource module.)

- Create the modules without calculating costs or generating cubes, but validate the model as you progress.
  Not calculating costs or generating cubes enables you to create a model quickly and helps you to identify flaws in the model design before you spend the time calculating costs and generating cubes.

---

**Guidelines for Creating Dimensions**

Before you create dimensions, consider the following points:

- Think in terms of dimensions when you begin to plan the model, such as Who do I work for? At the highest level, it’s your entire organization. This can be further refined by a geographic office (world area, country, and/or state or province), a business area (Sales or Finance), and a department (Public Sales or Accounts Payable).

  A dimension signature uniquely identifies an account in the model; the dimension signature is the intersection of two or more dimensions. So, think of what dimensions are needed to uniquely identify an account.
Dimensions help users pull apart (deconstruct) information in a model. Consider the reporting needs of the users. Identify a dimension by the fact that users need to have the information appear during OLAP analysis.

- Decide what required data translates into model structure or what data translates into attributes.

- After you have defined the structural dimensions, consider how to enhance the structure with attributes to support different aggregations of costs for different users. Attribute dimensions are for users needs for reporting. Do not put these needs into the models structural dimensions because doing so creates a burden when entering model data or when revising a model.

- For better performance and easier data entry, minimize the number of dimensions. Although a dimension intersection can include an unlimited number of dimensions, a smaller number (five or fewer) is more manageable.

- Ensure that you have a justifiable business need for every dimension or dimension level.

  If you create unnecessary dimensions and dimension levels, the resulting OLAP cubes provide too much information and not enough understanding.

- To help distinguish a dimension from a dimension member, consider the following points:

  - If part of a model is repeated in a single dimension (such as the General Ledger accounts of Rent-North Carolina, Rent-New York, and Rent-Kansas), then that part is probably a dimension. In this example, you provide more flexibility for OLAP analysis by creating two dimensions: one dimension for the office location and one dimension for the General Ledger expenses.

  - A dimension member can be identified by whether it gives or receives costs (it is part of an assignment).

**Example: Multiple Dimensions for Better Analysis**

Suppose that your organization wants to model the North America region, specifically the offices in the states of North Carolina and New York. The model must store the resource costs of personnel, operating expenses, and equipment for each of these locations.

From your perspective as model builder, you can create a single, structural dimension on the Dimensions view as shown in the following figure:
In the Resource module, the structure looks like the following figure (with example values entered):

![Resource Module Structure](image)

Using this structural dimension, after you build the entire model, the calculated costs are correct. Users can analyze the cost data in the OLAP Analyzer, as shown in the following figure of the Cube Explorer View:

![Cube Explorer View](image)

Users can examine the costs associated with New York or North Carolina (which is not expanded in the figure). However, they cannot combine the costs of individual accounts for both North Carolina and New York. For example, users cannot examine the total cost of personnel for both North Carolina and New York.

Now, suppose that you want to allow users more flexibility during OLAP analysis, so that they can combine accounts from different office locations. You can change the
previous single, structural dimension to become two dimensions, as shown in the following figure of the Dimensions view:

In the Resources module, the structure looks identical to the previous example. However, in addition to the OLAP analysis shown in the previous example, users can display the model data so that it reveals the total personnel costs for both North Carolina and New York, as shown in the following figure:

---

**Guidelines for Creating Accounts**

- Combine similar accounts.

If your organization’s general ledger lists the details of travel expenses, such as airfare, hotel, or entertainment, you might want to combine these expenses into one travel account. Are the particular costs incurred together, or are multiple costs caused by the same factor? If so, you might want to combine such costs. Also, if some
accounts have small costs, you might want to combine the small accounts into larger accounts that represent more general categories.

Combining accounts into a single account can make creating and maintaining a model easier. However, you must ensure that combining accounts does not hinder business users from reporting the information that they need.

- Group related accounts.

Group accounts into roll-up accounts if the accounts have similar functionality or are linked to similar activities. For example, the following ungrouped accounts could be grouped as shown:

<table>
<thead>
<tr>
<th>Ungrouped Accounts</th>
<th>Grouped Accounts</th>
</tr>
</thead>
<tbody>
<tr>
<td>Magazine Advertising Inserts</td>
<td>Advertising</td>
</tr>
<tr>
<td>Direct Mail Advertising</td>
<td>Print</td>
</tr>
<tr>
<td>In-Store Advertising Circulars</td>
<td>Magazine Inserts</td>
</tr>
<tr>
<td>Radio Advertising</td>
<td>Direct Mail</td>
</tr>
<tr>
<td>TV Advertising</td>
<td>In-Store Circulars</td>
</tr>
<tr>
<td>Yellow Pages Advertising</td>
<td>Radio</td>
</tr>
<tr>
<td></td>
<td>TV</td>
</tr>
<tr>
<td></td>
<td>Yellow Pages</td>
</tr>
</tbody>
</table>

Grouping accounts is similar to the advice concerning the use of multiple dimensions in Chapter 6, Dimensions. A group, and the levels within a group, provide business users with more flexibility to analyze costs at different levels. In the previous example, business users can examine the individual costs of advertising through Magazine Inserts, Direct Mail, and In-Store Circulass. Business users can also examine the total cost of these methods at the Print level, and the total cost of advertising, regardless of the method.

- In OLAP analysis, the lowest level that can be examined in a cube is the accounts; cost element costs are rolled up into accounts and cannot be examined individually. Therefore, ensure that cost information that must be available to business users is in accounts, not in cost elements.

**Guidelines for Creating Cost Object Accounts**

Before you create cost object accounts, consider the following:

- Name and organize the cost objects so that they are familiar to the business users.

**Guidelines for Creating Activity Accounts**

Before you create activity accounts, consider the following:

- Name and organize the activity accounts so that they are familiar to the business users.

- Distinguish an activity from a task and a process from an activity. A task provides too much detail and a process provides too little detail.

Follow the 5-50 rule:

If a potential activity consumes less than 5% of anyone's time, then it is probably a task. Combine tasks to create an activity or several activities. For example, the tasks
of opening correspondence, typing correspondence, and applying postage can be combined into the activity of Communicate with Customers.

However, understanding the task level is important because it clarifies the scope of an activity, it clarifies the boundaries between adjacent activities, and it helps people in your organization relate to the activity.

If a potential activity consumes more than 50% of anyone's time, then it is probably a business process (or business macro process). Divide the activity into finer detail to identify the activities that are involved in the process. For example, the process of Secure Facility can be divided into the activities of Patrol the Grounds, Monitor Automobile Traffic, and Issue Security Badges.

• An activity account must be active; it is not an arbitrary accounting bucket. The action is denoted by naming an activity account using a verb-noun phrase, such as Process Order or Enter Invoices.

• An activity account is a cost category that management is concerned about.

• Ensure that all required activity accounts are defined.

To determine your organization's activities, conduct surveys with the people in your organization.

• Create an activity account only if management needs to know details about the activity to make decisions.

• An activity account has one driver that is used for assigning costs.

Guidelines for Creating Resource Accounts

Before you create resource accounts, consider the following:

• Name and organize the resource accounts so that they are familiar to the business users. Create the references for resource accounts and cost elements so that the references match the account numbers in your organization's chart of accounts.

See Also

“Modules, Module Rollups, Accounts, and Rollup Accounts” on page 146

Guidelines for Creating Drivers

Before you create drivers, consider the following points:

• Minimize the use of unique driver quantities. Unique driver quantities can use a lot of memory. They increase processing time, and they do not provide a calculation advantage.

• Create drivers whose quantities or volumes are already being collected or cost little to measure.

• When you collect driver data, ensure that the data is current, available, and accurate. Ask individuals in your organization to verify the data's accuracy.

• In general, use fixed driver quantities for basic drivers. Use variable driver quantities for bill of costs drivers.
Guidelines for Creating Assignments

Before you create assignments, consider the following:

- You can assign costs from one account to another account, but you cannot assign costs to a roll-up account.
- Try to assign 100 percent of an account's costs to other accounts.
  
  If you do not assign 100 percent, SAS Activity-Based Management issues warnings when you calculate costs.

See Also

“Assignments” on page 263

Guidelines for Sharing Models, Configurations, and Data

Overview

After you create a model and analyze it, you will have data that helps you make business decisions (or that helps others in your organization make business decisions). You will want to share your results so that co-workers can use the business data that you have prepared. However, because much data is stored on a single server, you should establish naming conventions and other guidelines so that all users can easily find the correct information.

Workspace Manager lists items that are available for all SAS Activity-Based Management users who are using the same server.

Saving Items

Establish guidelines for when to save and when not to save column layouts, OLAP views, published reports, and report configurations.

Naming Items

Overview

To manage the lists of items that are on a SAS Activity-Based Management server, establish a naming convention. Decide whether a name should include the owner's initials. Names of items affect the sort order within folders in Workspace Manager.

Naming Import Configurations and Models

For model names and import configurations, you might want to include the following information:

- the goal for the model
• the users that can work with the model
• a short way of referring to the types of structures, dimensions, attributes, or measures that are selected when data is imported
• the period/scenario associations
• the date on which the model was imported

Naming Column Layouts
For column layout names, you might want to include the following information:
• the users or teams who use the column layout
• the models or types of models that use the column layout

Naming Report Configurations
By default, each description on the Reports workspace contains the following information:
• the description that was entered when the report configuration was saved
• the date on which the report configuration was saved

Naming OLAP Views
By default, each description on the Analysis workspace contains the following information:
• the description that was entered when the OLAP view was saved
• the date on which the OLAP view was saved
• the model name
• the type of predefined cube
• the network login of the person who saved the OLAP view

Removing Items
Your organization should encourage users to remove items that were automatically saved or that they saved and no longer need. You can establish guidelines for when to remove items.

Sharing Data with Others
For people who do not use SAS Activity-Based Management, you can export cubes to a Microsoft Excel spreadsheet, and you can export reports to popular application formats.
Chapter 3
The User Interface
Navigation Pane

Overview

The Navigation Frame allows you to navigate among the workspaces that constitute SAS Activity-Based Management:

- Workspace Manager – See “Workspace Manager” on page 27.
- Analysis – See “Analysis Workspace” on page 453.
- Reports – See “Reports Workspace” on page 560.
- Contributions – See “Contributions Workspace” on page 469.
How to Access the Navigation Pane

If the Navigation Pane is not visible, then select View ➔ Navigation Pane.

Minimize the Navigation Pane

1. Click the Auto hide icon to minimize the Navigation Pane.

   When you roll-over the minimized tab, the Navigation Pane returns, but only temporarily.
2. Click the Auto Hide icon again (the push-pin) to make the Navigation Pane stay open (or select View ⇒ Navigation Pane).

1. Click Auto hide, and the Navigation Pane is minimized.

2. Roll over the tab, and the Navigation Pane reappears (temporarily).

3. Click the push pin, and the Navigation Pane stays open.

**Partition the Navigation Pane**

Move the gripper up or down to change the relative size of the task area and the button area in the Navigation Pane.

*Note:* You cannot move the gripper up further than is necessary to fully display all the buttons in the button area.
Workspace Manager

Overview

The Workspace Manager provides a treeview of all SAS Activity-Based Management elements—from models to cube configurations to reports—and gives you access to them all.

Workspaces and Workspace Items

A workspace stores the items, such as column layouts and models, that are created in SAS Activity-Based Management. A workspace is shared by all users on the same server, and it enables your organization to define standard items once and to apply them to different models as needed.

How to Access the Workspace Manager

1. If the Navigation Pane is not visible, click View ⇒ Navigation Pane.
2. Click Workspace Manager.
Workspace Manager Layout

About the Workspace Manager Layout

Workspace Manager looks similar to Windows Explorer, and most of the commands and techniques that you use in Windows Explorer, including drag-and-drop, function identically in Workspace Manager.

Workspace Manager displays information in two panes. When you select an item in the left pane, the contents of the selected item are shown in the right pane.

The left pane has two main parts: the server area and My Shortcuts.

Server Area

The server area shows you all the items on a SAS Activity-Based Management server. The name of the workspace area is the name of the server on which the items are stored, followed by the word Workspace. For example, if the server is named ABCdata, the server area is named ABCdata Workspace. You cannot change this name.

In the server area, you see only those items for which you have permission. Also, you see the folders that have been created by all users, although you do not necessarily see the contents of each folder.
If you are a system administrator, you see every item, regardless of who owns the item, and you can interact with every item.

**Creating and Deleting Items in the Server Area**

You cannot rename or delete the top-level folders in the server area. However, if you have the necessary permissions, you can create and delete subfolders within these top-level folders.

When you delete a model, workspace items that depend on that model are not deleted. As a result, when you open a workspace item, you might see an error message about the missing model.

*Note:* You cannot change the model that is associated with an item. To avoid the error message, delete the workspace item, and then create an identical item that is based on another model.

**My Shortcuts**

*My Shortcuts* enables you to organize the items that you need for your work. You can create shortcuts to items that are in the server area. Then, use a shortcut to open and use an item.

*Note:* Even when the item that a shortcut refers to is renamed or moved, or when the folder that contains the item is renamed, the shortcut still works.

My Shortcuts holds only folders and shortcuts. Each user of SAS Activity-Based Management has a different shortcut area, so you see only the folders and shortcuts that you create. You can use these folders and shortcuts from any computer that is connected to the server on which you create the folders and shortcuts.

Items in the server area are arranged by type. By contrast, in My Shortcuts, you can arrange folders by task and project, and you can create shortcuts to many different types of items in those folders.

**Naming Guidelines for Workspace Items**

Your organization can develop naming guidelines. However, these guidelines must conform to the SAS Activity-Based Management naming conventions.

**Ownership and Permissions for Server Area Workspace Items**

When you create a server area item, SAS Activity-Based Management assigns ownership to you. You can modify the item, rename it, or move it. You can assign permissions to other users in the same group of which you are a member.

To each group established with SAS Management Console, you can assign the permission to read or to read and write to any item that you own. If you do not assign permissions to a group, users who are members of that group cannot see the item.

*Note:* To assign permissions to a group, you must be a member of that group. This security prevents sensitive company data from unintentional publication. If you need to assign permissions to a group of which you are not a member, ask the system administrator to temporarily assign you to the group.

**See Also**

- “Workspace Manager Tasks” on page 30
Workspace Manager Tasks

Overview

Use the Workspace Manager to start frequently used tasks. You can perform tasks from the Workspace Manager without first opening a model. For more on the Workspace Manager itself, see Workspace Manager.

*Note:* The availability of these features depends on your permissions.

*Note:* The **Show items owned by user** drop-down list is available only to administrators.

**See Also**

“Workspace Manager” on page 27

**How to Access the Workspace Manager**

1. If the Navigation Pane is not visible, click **View ⇒ Navigation Pane.**
2. Click **Workspace Manager.**
Create a shortcut to a workspace item

1. In Workspace Manager, select an item in the server area.
2. Select File ⇒ Create Shortcut.
   The Create Shortcut dialog box appears.

Review or change the properties of a workspace item

1. In Workspace Manager, select an item.
2. Select Edit ⇒ Item Properties.
   The Item Properties dialog box appears.

Create a folder

1. In Workspace Manager, select a folder under which to create the new folder.
2. Select Edit ⇒ New Folder.
   The New Folder dialog box appears.

Move a workspace item

1. In Workspace Manager, select an item.
2. Drag the item to a new location.

   Note: You can drag the item only to a new location that is of the same type as the item.

Open a workspace item

1. In Workspace Manager, select an item.
2. Select File ⇒ Open Workspace Item.
Publish a report that was created using SAS software

1. In Workspace Manager, select Published Reports.
2. Select File ⇒ Insert Published Report.

   The Insert New Published Report dialog box appears.

Refresh Workspace Manager

Select View ⇒ Refresh.

Delete a workspace item

1. In Workspace Manager, select an item.
2. Select Edit ⇒ Delete.

Show items that are owned by a specific user

Note: This feature is available only to administrators.

From the Show items owned by user menu, select a user.

See Also

“Workspace Manager” on page 27

Shortcut Keys

You can use the following shortcut keys to quickly perform actions.

Navigation tasks

<table>
<thead>
<tr>
<th>Shortcut key</th>
<th>Action performed</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alt+Left Arrow</td>
<td>Move backward</td>
</tr>
<tr>
<td>Alt+Right Arrow</td>
<td>Move forward</td>
</tr>
<tr>
<td>Numeric keypad plus (+)</td>
<td>Expand the hierarchy</td>
</tr>
<tr>
<td>Numeric keypad minus (-)</td>
<td>Contract the hierarchy</td>
</tr>
</tbody>
</table>
### Basic editing tasks

<table>
<thead>
<tr>
<th>Shortcut key</th>
<th>Action performed</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+X</td>
<td>Cut selected text to the Windows clipboard</td>
</tr>
<tr>
<td>Ctrl+C</td>
<td>Copy selected text to the Windows clipboard</td>
</tr>
<tr>
<td>Ctrl+V</td>
<td>Paste text from the Windows clipboard</td>
</tr>
<tr>
<td>Ctrl+Q</td>
<td>Create a new folder in Workspace Manager or on the Attributes view</td>
</tr>
<tr>
<td>F5</td>
<td>Refresh the information</td>
</tr>
</tbody>
</table>

### Modeling tasks

<table>
<thead>
<tr>
<th>Shortcut key</th>
<th>Action performed</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+A</td>
<td>Create a new item (other than an entered cost element)</td>
</tr>
<tr>
<td>Ctrl+O</td>
<td>Create a new entered cost element</td>
</tr>
<tr>
<td>Ctrl+E</td>
<td>Manage the attributes that have been added to an account</td>
</tr>
<tr>
<td>Ctrl+G</td>
<td>Go to the selected account</td>
</tr>
<tr>
<td>Alt+Enter</td>
<td>Show the item's properties</td>
</tr>
<tr>
<td>F7</td>
<td>Create assignments between the selected account and all of the accounts in the left and right assignments panes</td>
</tr>
<tr>
<td>Shift+F7</td>
<td>Delete all incoming assignments to the selected account and all outgoing assignments from the selected account.</td>
</tr>
</tbody>
</table>

Note: It is not necessary that either the incoming assignments or the outgoing assignments be visible in an Assignments pane for the assignments to be deleted. In fact, it is not even necessary that an Assignments pane be displayed.

**Notes:**

- The JAWS screen-reading program occasionally locks input fields of HTML pages, preventing you from entering data. If this happens while you are using JAWS, press Alt+N to re-enable screen input.
• The JAWS screen-reading program assigns the label graphics plus a random number to unlabeled graphics. You can assign your own label using the JAWS Graphics Labeler.

• Due to a Windows bug, the underscore is not displayed for top-level menu items. For example, in the following picture the underscore is missing for File. However, the ALT key still works, even for File.

Buttons and Icons

Resource, Activity, Cost Object, and External Unit module views

The following tables list the buttons and icons on the Resource module, Activity module, and Cost Object module and on the External Units module.

<table>
<thead>
<tr>
<th>This button</th>
<th>Does this</th>
</tr>
</thead>
<tbody>
<tr>
<td>🌋</td>
<td>Starts the New Model Wizard</td>
</tr>
<tr>
<td>📚</td>
<td>Displays the selected item's properties</td>
</tr>
<tr>
<td>✗</td>
<td>Deletes the selected item</td>
</tr>
<tr>
<td>🛡</td>
<td>Opens the Calculate Costs dialog box</td>
</tr>
<tr>
<td>🕳</td>
<td>Opens the Generate Cubes dialog box</td>
</tr>
<tr>
<td>🍎</td>
<td>Create an account</td>
</tr>
<tr>
<td>🌋</td>
<td>Opens the Search for Accounts dialog box</td>
</tr>
<tr>
<td>🍺</td>
<td>Opens the New Entered Cost Element dialog box</td>
</tr>
<tr>
<td>🏫</td>
<td>Opens the Column Layout dialog box</td>
</tr>
<tr>
<td>This button</td>
<td>Does this</td>
</tr>
<tr>
<td>-------------</td>
<td>-----------</td>
</tr>
<tr>
<td><img src="image" alt="Closes button" /></td>
<td>Closes the current model and opens the Models workspace</td>
</tr>
<tr>
<td><img src="image" alt="Refresh button" /></td>
<td>Refresh data from the server</td>
</tr>
<tr>
<td><img src="image" alt="Resource button" /></td>
<td>Opens the Resource module</td>
</tr>
<tr>
<td><img src="image" alt="Activity button" /></td>
<td>Opens the Activity module</td>
</tr>
<tr>
<td><img src="image" alt="Cost Object button" /></td>
<td>Opens the Cost Object module</td>
</tr>
<tr>
<td><img src="image" alt="External Units button" /></td>
<td>Opens the External Units module</td>
</tr>
<tr>
<td><img src="image" alt="Left pane button" /></td>
<td>Add accounts to the left pane for assignments</td>
</tr>
<tr>
<td><img src="image" alt="Right pane button" /></td>
<td>Add accounts to the right pane for assignments</td>
</tr>
<tr>
<td><img src="image" alt="Assignment view button" /></td>
<td>View left or right assignments panes.</td>
</tr>
<tr>
<td><img src="image" alt="Assignments button" /></td>
<td>The button displays all assignments for the selected account. A menu is displayed from which you can select assignments or clear accounts.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>This icon</th>
<th>Represents this</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Folder icon" /></td>
<td>A closed or open module rollup</td>
</tr>
<tr>
<td><img src="image" alt="Folder icon" /></td>
<td>A closed or open rollup account</td>
</tr>
<tr>
<td><img src="image" alt="Resource icon" /></td>
<td>A Resource account</td>
</tr>
<tr>
<td><img src="image" alt="Activity icon" /></td>
<td>An Activity account</td>
</tr>
<tr>
<td><img src="image" alt="Cost Object icon" /></td>
<td>A Cost Object account</td>
</tr>
<tr>
<td><img src="image" alt="Cost element icon" /></td>
<td>An entered cost element</td>
</tr>
<tr>
<td><img src="image" alt="Resource account icon" /></td>
<td>An assigned cost element from a Resource account</td>
</tr>
<tr>
<td><img src="image" alt="Activity account icon" /></td>
<td>An assigned cost element from an Activity account</td>
</tr>
<tr>
<td><img src="image" alt="Cost Object account icon" /></td>
<td>An assigned cost element from a Cost Object account</td>
</tr>
<tr>
<td>This icon</td>
<td>Represents this</td>
</tr>
<tr>
<td>-----------</td>
<td>----------------</td>
</tr>
<tr>
<td>![External Unit Cost Element]</td>
<td>An external unit cost element</td>
</tr>
<tr>
<td>![Internal Cost Element]</td>
<td>An internal cost element</td>
</tr>
</tbody>
</table>

**Attributes view buttons and icons**

The following tables list the buttons and icons on the Attributes view.

<table>
<thead>
<tr>
<th>This button</th>
<th>Does this</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Resource Module]</td>
<td>Opens the Resource module</td>
</tr>
<tr>
<td>![Activity Module]</td>
<td>Opens the Activity module</td>
</tr>
<tr>
<td>![Cost Object Module]</td>
<td>Opens the Cost Object module</td>
</tr>
<tr>
<td>![External Units Module]</td>
<td>Opens the External Units module</td>
</tr>
<tr>
<td>![New Attribute Dialog Box]</td>
<td>Opens the New Attribute dialog box</td>
</tr>
<tr>
<td>![Display Item's Properties]</td>
<td>Displays the selected item's properties</td>
</tr>
<tr>
<td>![Delete Item]</td>
<td>Deletes the selected item</td>
</tr>
<tr>
<td>![Close Model and Open Models Workspace]</td>
<td>Closes the current model and opens the Models workspace</td>
</tr>
<tr>
<td>![Refresh Data]</td>
<td>Refresh data from the server</td>
</tr>
<tr>
<td>![Primary and Right Assignments Panes]</td>
<td>The button displays the primary and the right assignments panes. A menu is displayed from which you can select specific panes.</td>
</tr>
<tr>
<td>![All Assignments for Selected Account]</td>
<td>The button displays all assignments for the selected account. A menu is displayed from which you can select assignments or clear accounts.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>This icon</th>
<th>Represents this</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Attributes Folder]</td>
<td>A closed or open Attributes Folder</td>
</tr>
<tr>
<td>This icon</td>
<td>Represents this</td>
</tr>
<tr>
<td>----------</td>
<td>-----------------------------------------------------</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>A closed or open Dimension attribute</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>A Tag attribute</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>A Numeric attribute</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>A closed or open dimension member attribute</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>A dimension value attribute</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>A Text attribute</td>
</tr>
</tbody>
</table>

**Drivers view buttons and icons**

The following tables list the buttons and icons on the Drivers view.

<table>
<thead>
<tr>
<th>This button</th>
<th>Does this</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Opens the Resource module</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Opens the Activity module</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Opens the Cost Object module</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Opens the External Units module</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Opens the New Driver dialog box</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Displays the selected driver's properties</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Deletes the selected driver</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Closes the current model and opens the Models workspace</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Refresh data from the server</td>
</tr>
</tbody>
</table>
This icon | Represents this
---|---
| A closed or open Drivers folder
| A driver

**Dimensions view buttons and icons**

The following tables list the buttons and icons on the Dimensions view.

<table>
<thead>
<tr>
<th>This button</th>
<th>Does this</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Opens the Resource module</td>
</tr>
<tr>
<td></td>
<td>Opens the Activity module</td>
</tr>
<tr>
<td></td>
<td>Opens the Cost Object module</td>
</tr>
<tr>
<td></td>
<td>Opens the External Units module</td>
</tr>
<tr>
<td></td>
<td>Opens the New Dimension Member dialog box</td>
</tr>
<tr>
<td></td>
<td>Displays the selected item's properties</td>
</tr>
<tr>
<td></td>
<td>Deletes the selected item</td>
</tr>
<tr>
<td></td>
<td>Closes the current model and opens the Models workspace</td>
</tr>
<tr>
<td></td>
<td>Refresh data from the server.</td>
</tr>
<tr>
<td></td>
<td>Delete selected association (of an attribute with a dimension member)</td>
</tr>
<tr>
<td></td>
<td>Delete all associations (of attributes with dimension members)</td>
</tr>
<tr>
<td></td>
<td>Add and remove columns</td>
</tr>
<tr>
<td></td>
<td>Apply attributes to accounts</td>
</tr>
</tbody>
</table>
Period and scenario associations view buttons and icons

The following tables list the buttons and icons on the Period and scenario associations view.

<table>
<thead>
<tr>
<th>This icon</th>
<th>Represents this</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>A closed or open dimension</td>
</tr>
<tr>
<td></td>
<td>A dimension member</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>This button</th>
<th>Does this</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Opens the Resource module</td>
</tr>
<tr>
<td></td>
<td>Opens the Activity module</td>
</tr>
<tr>
<td></td>
<td>Opens the Cost Object module</td>
</tr>
<tr>
<td></td>
<td>Opens the External Units module</td>
</tr>
<tr>
<td></td>
<td>Opens the Associate Periods and Scenarios dialog box</td>
</tr>
<tr>
<td></td>
<td>Opens the Period/Scenario Association Properties dialog box</td>
</tr>
<tr>
<td></td>
<td>Deletes the selected association</td>
</tr>
<tr>
<td></td>
<td>Publishes or unpublishes the selected association</td>
</tr>
<tr>
<td></td>
<td>Closes the current model and opens the Models workspace</td>
</tr>
<tr>
<td></td>
<td>Refresh data from the server</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>This icon</th>
<th>Represents this</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>The current association</td>
</tr>
</tbody>
</table>
**Performance Measures view buttons and icons**

The following tables list the buttons and icons on the Performance Measures view.

<table>
<thead>
<tr>
<th>This button</th>
<th>Does this</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="button" /></td>
<td>Opens the Resource module</td>
</tr>
<tr>
<td><img src="image" alt="button" /></td>
<td>Opens the Activity module</td>
</tr>
<tr>
<td><img src="image" alt="button" /></td>
<td>Opens the Cost Object module</td>
</tr>
<tr>
<td><img src="image" alt="button" /></td>
<td>Opens the External Units module</td>
</tr>
<tr>
<td><img src="image" alt="button" /></td>
<td>Displays the selected item's properties</td>
</tr>
<tr>
<td><img src="image" alt="button" /></td>
<td>Deletes the selected item</td>
</tr>
<tr>
<td><img src="image" alt="button" /></td>
<td>Closes the current model and opens the Models workspace</td>
</tr>
<tr>
<td><img src="image" alt="button" /></td>
<td>Refresh data from the server</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>This icon</th>
<th>Represents this</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="icon" /></td>
<td>A closed or open module rollup</td>
</tr>
<tr>
<td><img src="image" alt="icon" /></td>
<td>An External Unit account</td>
</tr>
<tr>
<td><img src="image" alt="icon" /></td>
<td>A Resource account</td>
</tr>
<tr>
<td><img src="image" alt="icon" /></td>
<td>An Activity account</td>
</tr>
<tr>
<td><img src="image" alt="icon" /></td>
<td>A Cost Object account</td>
</tr>
<tr>
<td><img src="image" alt="icon" /></td>
<td>A Numeric attribute</td>
</tr>
</tbody>
</table>

**Analysis workspace buttons and icons**

The following tables list the buttons and icons in the Analysis Workspace.
<table>
<thead>
<tr>
<th>This button</th>
<th>Does this</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>View the selected workspace item</td>
</tr>
<tr>
<td></td>
<td>Create a new folder</td>
</tr>
<tr>
<td></td>
<td>Cut</td>
</tr>
<tr>
<td></td>
<td>Copy</td>
</tr>
<tr>
<td></td>
<td>Paste</td>
</tr>
<tr>
<td></td>
<td>Deletes the selected item</td>
</tr>
<tr>
<td></td>
<td>Refresh data from the server</td>
</tr>
<tr>
<td></td>
<td>Go up one level</td>
</tr>
<tr>
<td></td>
<td>Create a new OLAP view</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>This icon</th>
<th>Represents this</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>An OLAP view</td>
</tr>
</tbody>
</table>

**OLAP Analyzer view buttons and icons**

The following tables list the SAS Activity-Based Management buttons and icons on the OLAP Analyzer view. The OLAP Analyzer view embeds the SAS OLAP Analyzer that you use to explore cubes.

*Note:* For more OLAP-specific Help information, see the SAS OLAP Analyzer Help.

<table>
<thead>
<tr>
<th>This button</th>
<th>Does this</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Create a new OLAP view</td>
</tr>
<tr>
<td></td>
<td>Saves the current OLAP view</td>
</tr>
</tbody>
</table>
The following tables list the buttons and icons on the Reports workspace.

### Reports workspace buttons and icons

<table>
<thead>
<tr>
<th>This button</th>
<th>Does this</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Folder" /></td>
<td>View the selected workspace item</td>
</tr>
<tr>
<td><img src="image" alt="New Folder" /></td>
<td>Create a new folder</td>
</tr>
<tr>
<td><img src="image" alt="Cut" /></td>
<td>Cut</td>
</tr>
<tr>
<td><img src="image" alt="Copy" /></td>
<td>Copy</td>
</tr>
<tr>
<td><img src="image" alt="Paste" /></td>
<td>Paste</td>
</tr>
<tr>
<td><img src="image" alt="Delete" /></td>
<td>Deletes the selected item</td>
</tr>
<tr>
<td><img src="image" alt="Refresh" /></td>
<td>Refresh data from the server</td>
</tr>
<tr>
<td><img src="image" alt="Up" /></td>
<td>Go up one level</td>
</tr>
</tbody>
</table>
Report view buttons

The following table lists the buttons on the Report view.

<table>
<thead>
<tr>
<th>This button</th>
<th>Does this</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Create a new report" /></td>
<td>Create a new report</td>
</tr>
<tr>
<td><img src="image" alt="Saves the report configuration" /></td>
<td>Saves the report configuration</td>
</tr>
<tr>
<td><img src="image" alt="Configure the report" /></td>
<td>Configure the report</td>
</tr>
<tr>
<td><img src="image" alt="Starts the Publish a Report Wizard" /></td>
<td>Starts the Publish a Report Wizard</td>
</tr>
<tr>
<td><img src="image" alt="Opens the Reports workspace" /></td>
<td>Opens the Reports workspace</td>
</tr>
<tr>
<td><img src="image" alt="Refresh data from the server" /></td>
<td>Refresh data from the server</td>
</tr>
</tbody>
</table>

Help Tips

Printing Help information

When you print Help information, sometimes you can choose to print either a single topic or all subtopics. To ensure that a page is formatted correctly when you print, print only the single topic that you are viewing.

If the colored background of images or shaded tables is missing when you print a topic, you can specify the background color printing option.
Using Full-Text Search

About Full-Text Search
When using the full-text search feature in Help, the following techniques can help you improve your searches for more precise results.

Boolean Operators
The AND, OR, NOT, and NEAR operators create a relationship between search terms. If an operator is not specified, AND is used. For example, “water ski boat” is equivalent to “water AND ski AND boat”.

Wildcard Expressions
Wildcard expressions enable you to search for one or more unspecified characters in conjunction with other characters. The question mark and the asterisk are wildcard characters.

<table>
<thead>
<tr>
<th>Search for...</th>
<th>Example</th>
<th>Results</th>
</tr>
</thead>
<tbody>
<tr>
<td>a single word</td>
<td>sail</td>
<td>Topics that contain the word “sail”. You also find the word's grammatical variations, such as sailor and sailing.</td>
</tr>
<tr>
<td>a phrase</td>
<td>“scuba dive” or scuba dive</td>
<td>Topics that contain the literal phrase “scuba dive” and all its grammatical variations. Without the quotation marks, this is equivalent to “scuba AND dive”, which finds topics that contain both words.</td>
</tr>
<tr>
<td>a wildcard expression</td>
<td>water* or 90?10</td>
<td>Topics that contain “water”, “waterfall”, “waterproof”, and so on. Topics that contain “90110”, “90210”, “90310”, and so on. The asterisk and the question mark cannot be used without other characters.</td>
</tr>
</tbody>
</table>

Nested Expressions
Nested expressions enable you to create complex queries. For example, ocean AND ((swim OR surf) NEAR Malibu) finds topics that contain the word ocean, along with the words swim and Malibu close together. The query also finds topics that contain ocean, along with the words surf and Malibu close together.

Here are the basic rules for using nested expressions to search Help topics:

- You can use parentheses to nest expressions. The expressions within parentheses are evaluated before the rest of the query.
• If a query does not contain a nested expression, it is evaluated from left to right. For example, scuba NOT Florida OR Bahamas finds topics that contain the word scuba without the word Florida, as well as topics that contain the word Bahamas. On the other hand, scuba NOT (Florida OR Bahamas) finds topics that contain the word scuba without either of the words Florida or Bahamas.

• You cannot nest expressions more than five levels deep.

---

Using the JAWS Graphics Labeler

If a graphic in SAS Activity-Based Management has not been assigned a label, JAWS assigns it the label graphic followed by a random number. You can use the graphics labeler to assign such graphics a more meaningful label. You can either label a graphic manually or you can use the auto-labeler.

To label a graphic manually:
1. Find the graphic that you want to label.
2. Press Insert + g to open the graphics labeler.
3. Type your label in the edit field.
4. Tab to the next edit field to enter the graphic label for your Braille display.

When you press Tab again, you see three radio buttons that indicate where you want to save your labeled graphic. Choose where you want to save it, and then press Enter to activate the label.

To label a graphic manually, make sure that All Graphics is selected in the JAWS verbosity settings.

---

Create Shortcut Dialog Box

About the Create Shortcut Dialog Box

In the Create Shortcut dialog box, you can name a shortcut and select its location in My Shortcuts.

How to Access the Create Shortcut Dialog Box

In Workspace Manager, select a workspace item in the server area and select File ⇒ Create Shortcut. The Create Shortcut dialog box appears.

Specify information

1. Type the Name of the shortcut.
   The name must follow the naming guidelines.
2. In the Create in list, select the folder in which you want to place the shortcut.
3. To create a new folder in which to place the shortcut, click New Folder.
The New Folder dialog box appears.

**TIP** You can create a shortcut by dragging an object from the server area into My Shortcuts.

---

**New Folder Dialog Box**

**About the New Folder Dialog Box**

In the New Folder dialog box, you can name a new folder in Workspace Manager.

**How to Access the New Folder Dialog Box**

Do one of the following:

- In Workspace Manager, select **Edit** ⇒ **New Folder**.
- In the Create Shortcut dialog box, click **New Folder**.

**Specify Information**

Type the folder Name.

---

**About SAS Activity-Based Management Dialog Box**

**About the Dialog Box**

In the About SAS Activity-Based Management dialog box, you can see the SAS Activity-Based Management version information, and you can access additional system information.

**How to Access About SAS Activity-Based Management Dialog Box**

Select **Help** ⇒ **About SAS Activity-Based Management**.
SAS Activity-Based Management System Information Window

About the SAS Activity-Based Management System Information Window

In the SAS Activity-Based Management System Information window, you can see information about the SAS Activity-Based Management application that is installed on your computer and information about the SAS Activity-Based Management server to which you are connected.

How to Access the SAS Activity-Based Management System Information Window

Select Help ⇒ About SAS Activity-Based Management. Then click System Info.
Overview

The abilities that you possess as a SAS Activity-Based Management user depend on:

- the capabilities that you inherit from the groups to which you belong.
- the permissions that are granted to the groups to which you belong.

Capabilities

When a SAS Activity-Based Management administrator created your SAS Activity-Based Management account, you inherited one or more of the following capabilities in virtue of belonging to a group with those capabilities.

- Create Models
- View Models
- Create Reports
- View Reports
- Create Cubes
- View Cubes
- View Contributions
- Audit
• Administer
• Take Surveys

Quite likely, most users will have inherited either Create Models capability or View Models capability. The Create Models capability provides the abilities of a Modeler in previous releases of SAS Activity-Based Management. It gives full access to a model including model creation and deletion, cube creation and viewing, etc. Plus, it gives users some other abilities not related to a particular model such as creating column layouts and setting up exchange rates.

Similarly the View Models capability provides the abilities of a Business User in previous releases of SAS Activity-Based Management. It gives users the ability to create, view, and publish reports, plus some other abilities.

If you do not know what capabilities you have inherited, ask your SAS Activity-Based Management administrator.

---

**Group Permissions**

The administrator creates groups for your organization and assigns you to one or more groups. Your abilities depend on the Read and Read/Write permissions granted to the groups to which you belong.

---

**Giving Read or Read/Write Permission to Members of a Group**

The creator of a model or other workspace item is, by default, its owner. Of course the owner has Read/Write access to the item. The owner can grant Read or Read/Write access to the item to users in a group. If you are a member of a group that has been granted access to a model or other workspace item, then you have that access as a member of the group.

The owner of a model or other item (or an administrator) grants access to the item to members of a group by selecting the item in the Workspace Manager and selecting **Edit → Item Properties**. Then, by checking either **Read** or **Read/Write**, the owner grants that access to members of the group.
Note: Only the owner of an item (or an administrator) can grant access to that item. Members of a group that have been granted Read/Write access to an item cannot grant access to other groups.

If you do not know to what groups you belong, ask your SAS Activity-Based Management administrator.

Changing Owners

The owner of a model or other workspace item (or an administrator) can transfer ownership to another user. To transfer ownership, the owner (or administrator) selects the item in the Workspace Manager and selects **Edit ⇒ Item Properties**. Then the owner (or administrator) selects a new owner from the drop-down list of users.

Note: The drop-down list of potential owners includes those users who have Create capability for the item. For example, you can transfer ownership of a model only to those users who have Create Models capability.
Select User Dialog Box

About the Select User Dialog Box

Use this dialog box to display items owned by a particular user.

*Note:* This dialog box is available only to users with Administrator capability.

How to Access the Select User Dialog Box

Select **Tools** → **Select User**.
Chapter 5
The Workflow

The Work Flow ................................................................. 54
  About the Work Flow ....................................................... 54
  Overview of the General Work Flow ................................... 54
Working in SAS Activity-Based Management ................................. 55
  Connecting to a SAS Environment ....................................... 55
  Model Availability ............................................................ 55
  Model Size and Performance .............................................. 56
  Saving Data ........................................................................ 56
  Organization of Features .................................................. 56
  Task Bars ........................................................................... 57
  Right-Click Support .......................................................... 57
  Status Bar ........................................................................... 57
  Refreshing Information ....................................................... 57
  Multiple Sessions .............................................................. 58
  Canceling a Server Task .................................................... 58
  Server Timeout ................................................................. 58
Log On Dialog Box ................................................................. 58
  About the Log On Dialog Box ............................................. 58
  How to Access the Connect Dialog Box ................................. 58
  Task .................................................................................... 58
Item Properties Dialog Box ............................................................ 59
  About the Item Properties Dialog Box .................................. 59
  How to Access the Item Properties Dialog Box ....................... 59
  Specify Information .......................................................... 59
  Set Permissions ................................................................... 59
Manage Tasks Dialog Box ............................................................. 59
  About the Manage Tasks Dialog Box .................................. 60
  How to Access the Manage Tasks Dialog Box ......................... 60
  Cancel a Task ....................................................................... 60
Operation Summaries Dialog Box ..................................................... 60
  About the Operation Summaries Dialog Box ......................... 60
  How to Access the Operation Summaries Dialog Box ............... 61
  Delete a Summary ............................................................ 61
  View Details about a Server Operation .................................. 61
  Export the Operation Summaries ......................................... 61
Audit Log Window ................................................................. 61
  About the Audit Log Window .............................................. 61
  How to Access the Audit Log Window .................................. 62
The Work Flow

About the Work Flow

By storing model data in a structure that is optimized for analytical purposes, SAS Activity-Based Management provides fast and intuitive analysis of broad trends and relationships. SAS Activity-Based Management is designed specifically for analyzing data. The following design features enable SAS Activity-Based Management to respond rapidly to complex queries that involve large amounts of data:

- Data is stored in a multidimensional data structure.
- Some of the summary calculations are performed before you request them.

Overview of the General Work Flow

Enter Business Data
1. Plan periods and scenarios. Then, set up periods and set up scenarios for each SAS Activity-Based Management server.
   On each server, all the periods and scenarios are shared across all models. Your organization should determine the period hierarchy that works best for all models. Then, set up periods and scenarios.
2. Create a model or import model data.
3. Calculate costs.
4. Generate cubes.

Analyze Business Data
- Use modules, cubes, and reports to analyze business data.

Make Business Analyses Available to Others
- Set up and save column layouts, OLAP views, published reports, and report configurations.
- (Optional) Export cubes and export reports.
Working in SAS Activity-Based Management

Connecting to a SAS Environment

Overview
When you log on to SAS Activity-Based Management, the file sassw.config (whose default installation location is C:\Program Files\SASHome) provides the URL of the file sas-environments.xml. For example:

SASENVIRONMENTURL=http://rde01011.sas.com:8080/SASLogon/sas-environment.xml

The file, sas-environment.xml, associates each entry in the SAS environment drop-down list of the Log On dialog with the URL of a SAS WIP Server (Web Infrastructure Platform). The WIP Server authenticates your logon information and provides an interface to a SAS Activity-Based Management Metadata Server. Because you, as a client user, log on to a WIP Server instead of directly to a SAS Activity-Based Management Metadata Server, the Metadata Server can be changed without affecting your client log-on procedure.

Current Credentials
Your SAS Activity-Based Management user name and password might or might not be the same as your network user name and password. If they are the same, then you can use your network login information, called your current credentials, to connect to the SAS environment.

If your current credentials are not applicable to the server, then you must supply your domain and user name.

Model Availability
Sometimes, you might not be able to perform certain tasks in a model. For example, if you attempt to edit a part of the model that someone else is editing, you will not be able to edit. However, you will always be able to view model data.

Other tasks affect model availability, regardless of what type of user you are. These tasks require that the model data be in a stable state for some amount of time. For example, if you create a report, the costs in the report should reflect a specific point in time. You do not want someone to change the costs of accounts while the report is being generated. Likewise, when SAS Activity-Based Management is calculating a model's costs, you do not want someone to change an account's cost. Allowing such a change would cause the final calculated costs to be wrong.

SAS Activity-Based Management prevents changes from being made during the following tasks:

• validating a model
• creating a report
• calculating costs
• generating cubes
• exporting data
Model Size and Performance

The number of accounts, assignments, dimensions, and dimension members within a model determine how long the model is unavailable, as well as how long it takes to perform a task. In a model that has few of these items (a small model), tasks complete faster than in a model that has numerous items (a large model).

Model size affects performance when you interact with SAS Activity-Based Management (such as when you expand a rollup account in the Resource module, the Activity module, or the Cost Object module, when you copy period/scenario association data, and when you create an account). Model size affects performance when you generate reports.

Saving Data

SAS Activity-Based Management enables multiple users to interact with a model that is located on a server. If you are unfamiliar with such an application, there are several differences from a desktop application.

• Unlike a desktop application in which you must actively save data, data is saved automatically.

Automatic saving enables all users to see the most current data immediately. (The availability of data is controlled by your user type and the status of the period/scenario association.)

Unlike a desktop application in which your changes can be canceled, changes cannot be canceled.

Because changes are saved for multiple users, your individual changes are immediately merged with other users’ changes and cannot be separated. You can cancel a dialog box or wizard, but once you click OK, your changes are saved in the model.

• Unlike a desktop application, which stores a copy of your data in memory so that you can undo your changes, SAS Activity-Based Management writes directly to the model.

This enables all users to see the most current data immediately.

You cannot undo your changes except by re-entering previous values. However, to preserve the state of the model before you make changes, you can export the model. You can then revert to the previous version by importing the model.

Organization of Features

Overview

SAS Activity-Based Management groups features by these categories:

• Workspace Manager
• Model mode
• OLAP mode
• Reports mode
Note: Each mode can display a different model and/or a different period/scenario association. When you first change to another mode, you can select a model and a period/scenario association.

Changing Modes
To change modes, use Navigation Pane.

When you change modes, a new menu appears for that mode. This new menu appears between the View menu and the Tools menu.

Mode Workspaces
Each mode contains a workspace and one or more related views. Each workspace shows you a subset of a branch of Workspace Manager.

For example, the Models workspace shows you the Models branch of Workspace. However, mode views are different from Workspace Manager. On a mode view, you cannot edit the information for an item, and you cannot reorganize the folder structure in the left pane. You can sort the items in the right pane.

Task Bars
Each workspace has a task bar that shows you the most frequently used operations that are related to the workspace.

Right-Click Support
In addition to providing the conventional methods of performing tasks (by selecting items from the menus), SAS Activity-Based Management provides right-click support, thus enabling you to alternatively perform many common tasks by right-clicking the mouse. This Help documentation only describes how to perform tasks using the menus in the SAS Activity-Based Management interface.

Status Bar
The status bar, which is at the bottom of the window, displays informational messages, such as whether the current period/scenario association is published. The status bar also displays the tasks that are currently being performed. From the status bar, you can manage server tasks.

Refreshing Information
As you work in SAS Activity-Based Management, some information is updated automatically. However, it might not be updated immediately. Whenever the refresh icon turns red, new information is available, and you can refresh the information.

Click 🔄

After the information is refreshed, the icon returns to its usual state 🔄.

Note: You might not see the new information. It could be on another view or in part of a hierarchy that is collapsed.

Users can see changes to global items, such as exchange rates and period/scenario associations, only after they restart SAS Activity-Based Management.
Multiple Sessions

You can create multiple sessions of SAS Activity-Based Management at the same time: that is, you can launch several instances of the SAS Activity-Based Management client application at one time and use them as though they are different applications. (The client application sessions can even talk to different SAS Activity-Based Management servers.) Multiple sessions enable you to easily compare multiple models or different areas of the same model.

Canceling a Server Task

You can cancel a server task that you initiate. However, after you cancel a task, the model might be in an unusable state.

You might need to cancel a server task when you realize that the task will require too much time or when you start a server task by mistake.

Note: A system administrator can cancel any task, regardless of who started it. If a system administrator cancels a task that you started, a message will notify you.

Server Timeout

For security reasons, the SAS Activity-Based Management server has a timeout. As you use SAS Activity-Based Management, save items, such as column layouts and OLAP views, often so that you do not lose any work. The timeout can be changed via Microsoft Internet Information Services (IIS) settings.

Log On Dialog Box

About the Log On Dialog Box

In the Log On dialog box, you supply security information so that you can access SAS Activity-Based Management.

How to Access the Connect Dialog Box

Start SAS Activity-Based Management. The Log on dialog box appears.

Task

Connect to a SAS Environment

1. Select an environment from the SAS environment drop-down list or specify default to select the default environment.

2. Type your domain and User ID, for example, HQ\AlexW.

3. Type your Password

4. Click Log On.
Note: If multiple languages are installed on your computer, the language that is used is determined by the location setting in Windows (select Settings ➔ Control Panel ➔ Regional and Language Options).

---

### Item Properties Dialog Box

#### About the Item Properties Dialog Box

In the Item Properties dialog box, you can review or change information about a workspace item and you can set permissions for the workspace item.

*Note:* The availability of these features depends on your permissions.

#### How to Access the Item Properties Dialog Box

In Workspace Manager, select an item and select **Edit ➔ Item Properties**. The Item Properties dialog box appears.

#### Specify Information

1. Click the **General** tab.
2. Type the Name.
   
   The name must follow the naming guidelines.

   **Tip** When you rename an item, notify other users. Otherwise, they might look for an item name that no longer exists.
3. Type the Description.

#### Set Permissions

*Note:* Permissions are not applicable to shortcuts.

1. Click the **Permissions** tab.
2. Select an Owner.
3. In the **Privileges** list, select or clear the check boxes that are next to each listed Role.

*Note:* To assign permissions to a group, you must be a member of that group. This security prevents sensitive company data from unintentional publication. If you need to assign permissions to a group of which you are not a member, ask the system administrator to temporarily assign you to the group.
Manage Tasks Dialog Box

About the Manage Tasks Dialog Box

In the Manage Tasks dialog box, you can monitor the status of tasks that are being performed on a SAS Activity-Based Management server.

Note: You can perform the following tasks without first opening a model.

How to Access the Manage Tasks Dialog Box

Do one of the following:

- Click Tasks in the status bar.
  The Tasks button is visible only during an operation that you can cancel, and only when the status bar is not hidden.
- Select Tools ⇒ Manage Tasks.

Cancel a Task

1. From the list of Tasks, select a task.
   You can select more than one task. A check mark is displayed next to the selected tasks.
2. Click End Tasks.
   There might be a delay before the operation is canceled.

Operation Summaries Dialog Box

About the Operation Summaries Dialog Box

In the Operation Summaries dialog box, you can see a list of all of the operations that you have performed on a SAS Activity-Based Management server. For example, an operation entry is added to this list whenever you calculate costs or generate a cube.

Note: The Operation Summaries dialog box displays summaries for a specific user account in a specific domain, such as LOCALMACHINE/Alex. If Alex also has an account in the domain COMPANY, and if he logs in as COMPANY/Alex, he will not see the summaries for the account LOCALMACHINE/Alex.

Note: You cannot change this information.
How to Access the Operation Summaries Dialog Box

Select Tools ⇒ Operation Summaries.

Delete a Summary

1. Select the check box next to a summary.
2. Click Delete.

View Details about a Server Operation

1. Select the check box next to a summary.
2. Click View.
   The Operation Summary window appears.
3. Click Show Details.

Export the Operation Summaries

1. Click Export.
   The Save As dialog box appears.
2. Navigate to a location.
3. Type the File name.

Audit Log Window

About the Audit Log Window

The availability of this feature depends on your permissions.

In the Audit Log window, you can see a history of the actions that have been performed on a SAS Activity-Based Management server. The history includes information such as what action was performed, the user who performed the action, and the item that was acted upon.
How to Access the Audit Log Window

Select **Tools ⇒ Audit Log**.

Sort the Information

Click a column heading.

The information in the log changes its sort order. The sort order changes from chronological to ascending to descending.

Limit the Information

From the **User**, **Name**, **Period**, and **Scenario** menus, select values to use for limiting the information.
Part 2

Models

Chapter 6
  Model Concepts ................................................................. 65

Chapter 7
  Working with Models ....................................................... 69

Chapter 8
  Naming Conventions ......................................................... 81

Chapter 9
  Windows for Models ......................................................... 89
Chapter 6
Model Concepts

Models

About Models
The basic container for activity-based management information in SAS Activity-Based Management is the model. A meaningful activity-based management model reflects the organization that it is modeling and uses terms that are familiar to the people who work at the organization. Therefore, a good understanding of your organization's resources, activities, and cost objects is required.

A model contains two types of information: the structure of the model, and the data for specific amounts of time (periods) and for specific circumstances (scenarios).

See Also
- “Create a Model” on page 69
- “Models Workspace” on page 67
- “Model Mode” on page 67
The Structure of a Model

Structural information includes the following:

• accounts to hold costs and information that pertain to resources, activities, and products
• assignment paths that assign resource expenses to activities and that assign activity costs to products
• drivers for measuring the frequency or intensity of demands that are placed on resources by activities, and that are placed on activities by products
• notes that describe structures
• descriptive words or phrases that can be added to structures for analysis purposes
• lists of components that products consist of

Data for Specific Periods of Time and for Specific Circumstances

SAS Activity-Based Management stores information for specific amounts of time and for specific circumstances. Each segment of time is a period, and each circumstance is a scenario.

The structure of a model can change between periods. This allows a model to account for situations, such as seasonal activities and product changes.

Model Properties

About Model Properties

You can customize a model by specifying model properties. These properties pertain to a model, so they affect every user of the model, not just you. Customizing a model is different from customizing the modeling interface.

Note: Model properties are different from properties (see Chapter 60, “Properties Listed Alphabetically,” on page 635.).

Some of the most significant model properties are described below.

Base Currency

A model's base currency is the currency that was selected when the model was created.

Default Driver

The default driver is the driver that SAS Activity-Based Management associates with an assignment when you first create the assignment. You can change the driver later.

Attributes in Cubes

You can specify a set of numeric attributes whose values will be included as measures in OLAP cubes. If you include these numeric attributes in a cube, you can perform more advanced analyses.

To ensure that the specified attributes contain current costs, calculate the costs before you generate any cube.

See also: “Include Numeric Attributes in a Cube” on page 446.
The Audit Log

The audit log tracks changes to a model (see “Audit Log Window” on page 61).

Model Mode

About Model Mode

In Model mode, you can perform the following tasks:

- Create a model and edit a model on the Resource module view, the Activity module view, and the Cost Object module view
- Manage external units on the External Units module view
- Manage attributes on the Attributes view
- Manage drivers on the Drivers view
- Manage dimension members on the Dimension view

Note: The availability of these features depends on your permissions.

How to Access Model Mode

Do one of the following:

- If no model is open, click Models in the Navigation Pane.
- If a model is open, click the Go to Models Workspace icon in the toolbar, or select Model ⇒ Change Model or Context to open a different model.

Printing in Model Mode

You cannot print in Model mode. However, you can use Windows techniques to capture a screenshot, paste it into another program, and print the screenshot.

Models Workspace

About the Models Workspace

Note: The availability of these features depends on your permissions.

From the Models workspace, you can open a model.
The list of Folders and the list of Models correspond to the Models branch of the server area in Workspace Manager.

How to Access the Models Workspace

Do one of the following:

- If no model is open, click **Models** in the Navigation Pane.
- If a model is open, click the **Go to Models Workspace** icon in the toolbar, or select **Model ⇒ Change Model or Context** to open a different model.

Sort information in the Models Workspace

1. Click the **Sort By** link.
   
   A menu appears.
2. Select an option. The options contain the following criteria:

<table>
<thead>
<tr>
<th>Name</th>
<th>The name of the model</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date and Time</td>
<td>The date and time which the model was created</td>
</tr>
</tbody>
</table>
# Chapter 7
## Working with Models

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a Model</td>
<td>69</td>
</tr>
<tr>
<td>Open a Model</td>
<td>75</td>
</tr>
<tr>
<td>Open a Model with a Model Already Open</td>
<td>75</td>
</tr>
<tr>
<td>Delete a model</td>
<td>75</td>
</tr>
<tr>
<td>Calculate Costs</td>
<td>76</td>
</tr>
<tr>
<td>Generate Cubes</td>
<td>76</td>
</tr>
<tr>
<td>Register Metadata for Creating Information Maps</td>
<td>76</td>
</tr>
<tr>
<td>Copy Period/Scenario Association data</td>
<td>77</td>
</tr>
<tr>
<td>Change the Properties of a Model</td>
<td>77</td>
</tr>
<tr>
<td>Review the Summary of a Model</td>
<td>77</td>
</tr>
<tr>
<td>Validate a Model</td>
<td>77</td>
</tr>
<tr>
<td>Copy a Model</td>
<td>78</td>
</tr>
</tbody>
</table>

## Create a Model

To be able to create a model, you must first understand the concepts of periods, scenarios, dimensions, and the modules.

1. Select **File ⇒ New ⇒ Model**.

   The New Model Wizard appears.
2. In the **Model Name** box, type the name. See “**Naming Conventions**” on page 81.

3. In the **Reference** field, type an eight-character string whose first character is alphabetic. Invalid characters such as spaces are not allowed. This short reference is used in public views. (See the chapter on “Public Views” in the SAS Activity-Based Management Data Administration Guide.) Also see “**Reference Conventions**” on page 86.

4. From the **Select the base currency** list, select a currency.

Notice that once you select a base currency, you cannot change it later.

Next, you will specify the initial period/scenario association. You can create additional periods, scenarios, and period/scenario associations later.

5. Click **Next**.

6. From the **Select the initial period** list, select a period.

7. To create a new period, do the following:

   a. Click **New Period**.

      The Manage Periods dialog box appears.
b. From the Period column, select a period under which to create the new period.

c. Click New.

The New Period dialog box appears.

d. Type the Name.

The name must follow the naming conventions. See “Naming Conventions” on page 81.

e. Type the Reference.

A default reference is created from the period's name. If you change the reference, the new reference must follow the reference conventions. See “Reference Conventions” on page 86.

f. Type the Start date and the End date, or select dates from the drop-down calendar.

g. Type the Description.

h. Click OK.

8. From the Select the initial scenario list, select a scenario.

9. To create a new scenario, do the following:
a. Click **New Scenario**.

The Manage Scenarios dialog box appears.

![Manage Scenarios dialog box](image)

b. From the **Scenario** column, select a scenario under which to create the new scenario.

c. Click **New**.

The New Scenario dialog box appears.

![New Scenario dialog box](image)

d. Type the **Name**.

The name must follow the naming conventions. See “Naming Conventions” on page 81.

e. Type the **Reference**.

A default reference is created from the scenario's name. If you change the reference, the new reference must follow the reference conventions. See “Reference Conventions” on page 86.

f. Type the **Description**.

g. Click **OK**.
Next, you will specify the dimensions for each module: the Resource module, the Activity module, the Cost Object module, and the External Units module. In addition, you will specify the dimension for profit analysis.

10. Click Next.

11. Select either the **Select or define the dimensions for each module** option or the **Use the default dimension selections** option.

   The default dimensions for each module are listed. These dimensions are routinely used by a variety of organizations, but they might not be appropriate for your organization or you might want additional dimensions.

   The remainder of this task assumes that you want to create additional dimensions for each of the modules. Each module (and profit analysis) will be presented in the wizard.

12. Click Next.

13. From the list of **Available dimensions** for the Resource module, select a dimension, and click **>**.

   You can select multiple dimensions, but only one dimension at a time.

14. To create a new dimension, do the following:
   
a. Click **New**.

   The New Dimension dialog box appears.
b. Type the Name.
   The name must follow the naming conventions. See “Naming Conventions” on page 81.

c. Type the Reference.
   A default reference is created from the dimension’s name. If you change the reference, the new reference must follow the reference conventions. See “Reference Conventions” on page 86.

d. Type a Short Reference. The short reference is used in public views. See the chapter on “Public Views” in the *SAS Activity-Based Management Data Administration Guide*.

The wizard presents each of the remaining modules and profit analysis so that you can specify the dimensions. Each of these pages is identical to the page previously described.

After you have defined the dimensions for profit analysis, you will review the summary of what will be created.

15. Click Next.

16. Review the summary information.

17. If you need to change any information, click Back until you reach the page that you need to change in the wizard.

   All the information that you have specified is saved. Click Next to advance through the wizard.

18. Click Finish.
The model is created and the Dimensions page appears. Next, dimensions must be created.

---

Open a Model

*Note:* If a model is not already open, open a model from the Models Workspace.

1. From the **Model** menu, select a model.
   
   If you do not see the model that you want to use, then you probably do not have permission to view it.

2. From the **Period/Scenario** menu, select a period/scenario association.

3. Click

   The model opens and the Resource Module is displayed.

---

Open a Model with a Model Already Open

If a model is already open and you want to open a different model, do one of the following:

- Select a model from the **Model** drop-down list, and select a period and scenario from the **Period/Scenario** drop-down list, and then click the arrow icon.

  ![Select model from drop-down list](image)

  If you do not see the model that you want to use, you probably do not have permission to view it.

- Click the **Go to Models Workspace** icon on the toolbar, and then select a model to open.

  ![Go to Models Workspace icon](image)

---

See Also

“Change Model or Context Dialog Box” on page 89

---

Delete a model

In the Models Workspace, click the Delete link that is next to the model.

*Note:* Depending on your permissions, Delete might not be available.
Calculate Costs

Select **Model ➔ Calculate Costs**.

The Calculate Costs dialog box appears.

**See Also**

- “Calculate Costs Dialog Box” on page 396
- “Calculating Costs” on page 395

Generate Cubes

Select **Model ➔ Generate Cubes**.

The Generate Cubes dialog box appears.

**See Also**

- “Generate Cubes” on page 442
- “Cubes” on page 439
- “Incremental Cube Generation” on page 443
- Chapter 35, “Working with Cube Configurations,” on page 377

Register Metadata for Creating Information Maps

When you create SAS Activity-Based Management model-specific information maps (account maps and assignment maps), you can use SAS Web Report Studio to generate account-based reports and assignment-based reports.

Select **Tools ➔ Metadata Server Options**.

The Metadata Server Options dialog box appears.

**See Also**

- “Register Metadata / Metadata Server Options” on page 535
- “Create Information Maps (Register Metadata)” on page 533
Copy Period/Scenario Association data

1. Select **Model ⇒ Copy Period/Scenario Data**.
   The Copy Period/Scenario Data Wizard appears.
2. Follow the directions in the wizard.

*See Also*
“Copy Period/Scenario Data” on page 118

Change the Properties of a Model

Select **Model ⇒ Properties**.
The Model Properties dialog box appears.

*See Also*
“Model Properties Dialog Box” on page 91

Review the Summary of a Model

Select **Model ⇒ Summary**.
The Model Summary window appears.

Validate a Model

When you calculate a model, SAS Activity-Based Management performs validation checks to ensure that the model is ready to be calculated. For a large model, the calculation might require hours to complete, and the calculation might be halted before completion by an error or warning message. To increase the probability that a calculation runs to completion without error, you can manually validate the model before starting a calculation.

1. Open a model.
2. Select **Model ⇒ Validate**.
   The Validate Model dialog box appears.

In addition, validation performs some checks that are not performed during calculation because they are not necessary for calculation to succeed but can provide relevant information concerning your model.
You can choose to validate the following conditions of a model:

**Overdriven source accounts do NOT exist**
Ensures that no account assigns to other accounts more than 100% of its cost.

*Note:* This validation check is only approximate. For a full validation, the model must be calculated to determine whether any account is attempting to flow more than 100% of its costs.

**Unassigned accounts do NOT exist**
Ensures that all accounts in the Resource module and in the Activity module are assigned. Accounts in the Cost Object module are typically at the end of an assignment path, so they are not assigned to other accounts.

*Note:* If the model contains rule-based drivers, then this validation is inconclusive because the assignments are not generated for those drivers until a calculation is performed. See “Rule-based Drivers” on page 281.

**Accounts with zero cost do NOT exist**
Ensures that all accounts have costs that are not zero.

**Empty attributes do NOT exist**
Ensures that all attributes that have been added to accounts have values. For numeric attributes, this ensures that the values are not zero. For text attributes, this ensures that the values are not blank.

**Negative driver quantities do NOT exist**
Ensures that an account does not have negative driver quantities.

*Note:* The existence of any of these conditions does not mean that there are errors in the model. Ensure that the messages produced by the validation are what you expect. For example, if you use negative driver quantities in a model, you should expect the validation to report this.

**See Also**

“Validate Model Dialog Box” on page 95

**Copy a Model**

Before making major changes to a model, you can make a copy of the model that you can refer to, or revert to, later on.

To copy a model:

1. Go to the Workspace Manager.
2. Select the model that you want to copy, and then select *Edit ➔ Copy* (or, right-click the model and select *Copy*).
3. Select the directory in which you want to place the model. Then select *Edit ➔ Paste* (or right-click the directory and select *Paste*). The Paste Model dialog box opens.
4. If the model that you want to copy was previously calculated and fact tables were generated, then you can include the calculated data and fact tables along with the model. If you choose to copy the fact table, then the calculated data is automatically included. Choose none, one, or both of the following options:

- Include Calculated data
- Include FACT Tables

Whereas models that you export and re-import must be recalculated and their fact tables regenerated, models that you copy do not require those steps.
Chapter 8
Naming Conventions

Naming Conventions

General naming conventions

The name of any item must conform to the following rules:

- Names cannot contain this character: |
- Any item, such as a dimension, a driver, an attribute, and so on, that might become a dimension in a cube cannot have the reserved names All or None.
• Names are case insensitive. For example, the name My Model is the same as my model and mY mODEL.

In addition to the general naming conventions, there are more restrictive naming conventions for the following items.

**Attribute naming conventions**

In addition to the general naming conventions, attribute names must conform to these rules:

• Attribute names must be unique within a parent.
• Attribute names may contain up to 64 alphanumeric characters. However, attribute names longer than 50 characters are truncated to 50 characters when a cube is generated for Microsoft Analysis Services. SAS OLAP allows all 64 characters for attribute names.
• An attribute name cannot be the name of a numeric property.
• Attribute names may contain the following characters, even though these characters are not valid in cubes:

  . , ; ' ` : ? * & % $ ! - + = ( ) [ ] { } / /

  Each of these characters is replaced with an underscore (_) when a cube is generated.

For additional considerations concerning stage attributes, see “Stage Attributes” on page 185.

**Dimension naming conventions**

In addition to the general naming conventions, dimension names must conform to these rules:

• Dimension names may contain up to 64 alphanumeric characters. However, dimension names longer than 32 characters are truncated to 32 characters when a cube is generated for Microsoft Analysis Services. SAS OLAP allows all 64 characters for dimension names.
• Dimension names must be unique within all dimensions and dimension attributes.
• Dimension names must be unique within a parent.
• Dimension names may contain these characters, even though these characters are not valid in cubes:

  . , ; ' ` : ? * & % $ ! - + = ( ) [ ] { } / /

  Each of these characters will be replaced with an underscore (_) when a cube is generated.

**Dimension level naming conventions**

In addition to the general naming conventions, dimension level names must conform to these rules:

• Dimension level names may contain up to 64 alphanumeric characters. However, dimension level names longer than 50 characters are truncated to 50 characters when a cube is generated for Microsoft Analysis Services. SAS OLAP allows all 64 characters for dimension level names.
• Dimension level names must begin with an alphabetic character.
• Dimension level names cannot contain these characters:
  / / |
• Dimension level names may contain these characters, even though these characters are not valid in cubes:
  . [ ]
Each of these characters will be replaced with an underscore (_) when a cube is generated.
• Note: Because of the mechanism used by SAS Activity-Based Management to store dimension level names, some user-specified names will cause conflicts with the underlying database (regardless of whether Microsoft SQL Server or Oracle is used). These conflicts will appear as obscure error messages when calculating a model. Dimension level names that will cause conflicts are reserved words in the Microsoft SQL query language. Some of the more common reserved words are: level, group, function, drop, and join. For example, using the name LeVeL will cause errors. To avoid dimension level name conflicts, add a descriptive prefix or suffix.

To change the name of a dimension level:
1. Open a model.
2. Select **Model** ➔ **Dimensions**.
3. Right-click a dimension and select **Item Properties**.
   The Dimension Properties window opens.
4. Type a new name, and then click **OK**.

### Dimension member naming conventions

In addition to the general naming conventions, dimension member names must conform to these rules:
• Dimension member names may contain up to 64 alphanumeric characters. However, dimension member names longer than 50 characters are truncated to 50 characters.
when a cube is generated for Microsoft Analysis Services. SAS OLAP allows all 64 characters for dimension member names.

• Dimension member names may contain the following characters, even though these characters are not valid in cubes:

  . [ ]

Dimension member names must be unique within a parent.

**Driver naming conventions**

In addition to the general naming conventions, driver names must conform to these rules:

• Driver names must be unique within all drivers.

• Driver names may contain up to 64 alphanumeric characters. However, driver names that are longer than 50 characters are truncated to 50 characters when a cube is generated.

• Driver names may contain these characters, even though these characters are not valid in cubes:

  . [ ]

Each of these characters will be replaced with an underscore (_) when a cube is generated.

**Entered cost element naming conventions**

In addition to the general naming conventions, entered cost element names must conform to these rules:

• Entered cost element names may contain up to 64 alphanumeric characters.

• Entered cost element names must be unique within the same account in the same period/scenario association.

• Entered cost element names may contain these characters, even though these characters are not valid in cubes:

  . [ ]

Each of these characters will be replaced with an underscore (_) when a cube is generated.

**External unit naming conventions**

In addition to the general naming conventions, external unit names must conform to these rules:

• External unit references must be unique within all external units.

• External unit names may contain up to 64 alphanumeric characters.

**Module naming conventions**

When renaming modules, the name must conform to these rules:

• Module names may contain up to 64 alphanumeric characters.
• Module names can contain the following characters: alphanumeric, underscores, embedded blanks.

**Period naming conventions**

In addition to the general naming conventions, period names must conform to these rules:

• Period names must be unique within all periods.

• Period names may contain up to 64 alphanumeric characters. However, period names that are longer than 50 characters are truncated to 50 characters when a cube is generated.

• Period names may contain these characters, even though these characters are not valid in cubes:

  . [ ]

Each of these characters will be replaced with an underscore (_) when a cube is generated.

**Period level naming conventions**

In addition to the general naming conventions, period level names must conform to these rules:

• Period level names must be unique within all period levels.

• Period level names may contain up to 64 alphanumeric characters. However, period level names that are longer than 50 characters are truncated to 50 characters when a cube is generated.

• Period level names may contain these characters, even though these characters are not valid in cubes:

  . [ ]

Each of these characters will be replaced with an underscore (_) when a cube is generated.

**Scenario naming conventions**

In addition to the general naming conventions, scenario names must conform to these rules:

• Scenario names must be unique within all scenarios.

• Scenario names may contain up to 64 alphanumeric characters. However, scenario names that are longer than 50 characters are truncated to 50 characters when a cube is generated.

• Scenario names may contain these characters, even though these characters are not valid in cubes:

  . [ ]

Each of these characters will be replaced with an underscore (_) when a cube is generated.
Scenario level naming conventions

In addition to the general naming conventions, scenario level names must conform to these rules:

- Scenario level names must be unique within all scenario levels.
- Scenario level names may contain up to 64 alphanumeric characters. However, scenario level names that are longer than 50 characters are truncated to 50 characters when a cube is generated.
- Scenario level names may contain these characters, even though these characters are not valid in cubes:
  
  [ ]

Each of these characters will be replaced with an underscore (_) when a cube is generated.

Stage attribute naming conventions

In addition to the general naming conventions and Attribute naming conventions, stage attribute names must conform to these rules:

- Stage names must begin with an alphabetic character (letter).
- Stage names may contain the following characters, but they are not valid in cubes and cause cube generation to fail:
  
  . , ' ` : ? * & $ ! - + = ( ) [ ] { } / /

- You can change stage names as long as they retain their order when sorted. If the sort order changes them, you will need to regenerate the fact tables for all period/scenarios in the model.

Workspace item naming conventions

In addition to the general naming conventions, workspace item names must conform to these rules:

- Workspace item names cannot contain these characters:
  
  / / or |

- Workspace item names must be unique within a folder.
- Workspace item names may contain up to 64 alphanumeric characters.

Reference Conventions

Account reference conventions

- Account references must be unique within a module for all period/scenario associations.
For additional considerations concerning stage attributes, see “Stage Attributes” on page 185.

**Attribute reference conventions**

- Attribute references must be unique within all attributes.

**External unit reference conventions**

- External unit references must be unique within all external units.

**Dimension reference conventions**

- Dimension references must be unique within all dimensions and dimension attributes.

**Dimension member reference conventions and dimension attribute reference conventions**

- Dimension member references and dimension attribute references must be unique within a dimension.

**Period reference conventions**

- Period references must be unique within all periods.

**Scenario reference conventions**

- Scenario references must be unique within all scenarios.

**Entered cost element reference conventions**

- Entered cost element references must be unique within a module for all period/scenario associations.
### Change Model or Context Dialog Box

**About the Change Model or Context Dialog Box**

Use this dialog to do any of the following:

- Open a new model, specifying its period/scenario association and column layout
- Change the period/scenario association for the currently open model
- Change the column layout of the currently open model

### Model Summary Window

**About the Model Summary Window**

How to Access the Model Summary Window

Print the Model Summary

### Model Properties Dialog Box

**About the Model Properties Dialog Box**

How to Access the Model Properties Dialog Box

General Tab

Cube Tab

Attributes in Cubes Tab

Model Dimensions Tab

Performance Measures Tab

Module Alias Tab

### Validate Model Dialog Box

**About the Validate Model Dialog Box**

How to Access the Validate Model Dialog Box

Select Validation Options
How to Access the Change Model or Context Dialog Box

Select Model ⇒ Change Model or Context.

Note: You must be in the Models Workspace for this menu item to be available.

See Also
“Models Workspace” on page 67

Model Summary Window

About the Model Summary Window

In the Model Summary window, you can see summary information about various aspects of a model for the current period/scenario association, such as total costs for each module and the number of cycles (reciprocal cost assignments) in the model.

Note: You cannot change this information.

How to Access the Model Summary Window

In Model mode, select Model ⇒ Summary.
Print the Model Summary

Click Print.

Model Properties Dialog Box

About the Model Properties Dialog Box

The availability of these features depends on your permissions.

In the Model Properties dialog box, you can review or change information about a model.

<table>
<thead>
<tr>
<th>Tab</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>General on page 92</td>
<td>Specify general options</td>
</tr>
<tr>
<td>Cube on page 93</td>
<td>Specify In or Out for each module of a Multi-stage Contributions cube</td>
</tr>
<tr>
<td>Attributes in Cubes on page 93</td>
<td>Specify the numeric attributes to be included in cubes</td>
</tr>
</tbody>
</table>
### How to Access the Model Properties Dialog Box

Open a model in Model mode and select **Model ➤ Properties**.

### General Tab

![Model Properties dialog box](image)

Click the **General** tab, and choose among the following options:

**Model Currency**
- You cannot edit Model Currency

**Column Layout Options**
- Select a **Default column layout** to be displayed when a model is opened.

**Output Quantity Options**
- Type a value in the **Default output quantity** box.

**Module Default Driver Options**
- Select a default driver for each module.
**Cube Tab**

The options that you select here are automatically selected as defaults when you create a new cube configuration for the model. You can, however, override the defaults when you create the cube configuration.

*Note:* Changing these options after a cube has been generated does not affect the generated cube. It only affects the defaults for the creation of new cube configurations.

1. Click the **Cube** tab.

2. Choose one of the following options:

   - **Define stages by each module.** Each module defines a separate stage one stage per module in the following order:
     1. External Unit
     2. Resource
     3. Activity
     4. Cost Object
   
   - **Define stages by a dimension attribute named Stages.**
     Each stage is defined by a dimension member attribute in a dimension attribute named Stages. For more information, see “Stage Attributes” on page 185 and “Add Stage Attributes to Accounts” on page 193.

3. In the **Use the cost as it flows in or out of each stage** list, select the **Cost Flow (In or Out)** for each module or stage.

   If you select **In**, then only costs flowing into accounts in the module or stage are included in the cube. If you select **Out**, then only costs flowing out of accounts in the module or stage are included in the cube.

   *Note:* The **In/Out** option only makes a difference in the case of accounts that make assignments to other accounts in the same module or stage (or in an earlier stage). If such is the case, then not all cost flowing into that account also flow out of it from the same stage or module. If such is the case, then you must decide whether you want the cube to show cost flowing into the account in that stage or module, or cost flowing out of the account from that stage or module. If, on the other hand, there are no accounts that make assignments to other accounts in the same module or stage (or in an earlier stage), then the **In/Out** option makes no difference. All cost flowing into an account in one stage or module also flows out of it from that module or stage (or, at least is accounted for as None if it remains in the account).

**Attributes in Cubes Tab**

**Overview**

Use the **Attributes in Cubes** tab of the Model Properties dialog box to work with attributes. However, the function of this tab is different for a single-stage contribution cube than for a resource contribution cube or a multi-stage contribution cube.
**Single-Stage Contribution Cube**
To include numeric attributes in a single-stage contribution cube:

1. Select the Attributes in Cubes tab.
2. Select the numeric attributes to be included in the cube.
   
   If you generate a single-stage contribution cube, then the numeric attributes that you select are included in the cube.

**Resource Contribution Cube and Multi-Stage Contribution Cube**
The numeric attributes that you select on the Attributes in Cubes tab are automatically checked for inclusion when you create a new cube configuration for the model. You can, however, decide not to include the properties when you create the cube configuration, and you can include different attributes. The attributes that you select here are only checked by default. You can reverse the decision for any particular cube configuration.

1. Click the Attributes in Cubes tab.
2. Select the numeric attributes to be checked by default in a new cube configuration.

**Model Dimensions Tab**

1. Click the Model Dimensions tab.
2. In the Dimensions used in each module list, expand a module.
   
   The dimensions that are used in the module are displayed.

**Performance Measures Tab**
You can specify how you want to publish performance measures. See “Choose the Table Format for Publishing” on page 547.

For more information about publishing to SAS Strategy Management, see the section on “Working with Other SAS Programs” in the *SAS Activity-Based Management Data Administration Guide*, available from the Help menu or from [http://support.sas.com/documentation/onlinedoc/abm/](http://support.sas.com/documentation/onlinedoc/abm/).

**See Also**
Chapter 27, “SAS Strategy Management,” in SAS Activity-Based Management: Data Administration Guide
Module Alias Tab

Instead of using the standard names for modules—Resource, Activity, Cost Object—you can rename the modules in your model. This is particularly useful for those who are using SAS Activity-Based Management to model something other than costs—for example, greenhouse gases.

To rename modules, select Model ➔ Properties and click the Module Alias tab.

Note: The aliases are preserved during model export and import; however, the aliases do not appear in cubes or reports and are not substituted elsewhere in the user interface such as menu items.

Validate Model Dialog Box

About the Validate Model Dialog Box

In the Validate Model dialog box, you can select options that control how a model is validated.

Note: The availability of these features depends on your permissions.

How to Access the Validate Model Dialog Box

Open a model in Model mode and select Model ➔ Validate.

The Validate Model dialog box appears:
Select Validation Options

1. From the list of Options, select or clear the options.

2. From the Using this period/scenario association menu, select a period/scenario association.

3. From the Errors and Warnings section, select an option.

See Also

“Validate a Model” on page 77
Chapter 10
 Periods
Periods and Scenarios

About Periods and Scenarios

SAS Activity-Based Management stores information for specific amounts of time (periods) and for specific sets of data (scenarios).

Note: The structure of a model is based on periods. Therefore, if you change the period/scenario association for a model, the model structure might change. In fact, the entire model structure might disappear if the period/scenario association contains no structure data.

Periods

About Periods

A period can represent any unit of time: a month, a quarter, a year, and so on. For example, if your organization chooses to enter data each month, then the marketing payroll cost is the amount of payroll for one month.

Period Levels

You can create a hierarchy of periods, such as FY2003 > Q1 > January. By default, each level is given a name such as Period L1. However, these names are not descriptive when you generate cubes. So, you can name a period level.

Scenarios

About Scenarios

Scenarios are used for managing different variations of data within a period. A scenario can be any set of data: actual data, budget data, aggressive plan data, conservative plan data, and so on. The default scenarios are Actual and Budget.

Some scenarios can be agreed upon and can be set up before people start to use SAS Activity-Based Management. Other scenarios can be created when they are needed. That is, not all scenarios can be anticipated by an organization. Your organization might want to develop guidelines for naming and organizing scenarios in a hierarchy so that the list of scenarios on a server does not become unmanageable.

Scenario Levels

You can create a hierarchy of scenarios, such as Budget > Aggressive. By default, each level is given a name such as Scenario L1. However, these names are not descriptive when you generate cubes. So, you can name a scenario level.

Creating Periods or Scenarios

About Creating Periods or Scenarios

When you create a period, the names must conform to certain naming conventions.
**Period Start Dates and End Dates**

When you define a period, you specify its start date and its end date. These dates are useful to people in your organization and do not affect the data.

A period must meet these criteria:

- The duration of the period must be at least one day.
- The start date can be no earlier than January 1, 1980.
- The end date can be no later than December 31, 2029.

Periods that are at the same level in the hierarchy must meet these criteria:

- The periods must be sequential, with no overlapping dates.
- Each period must be within the date range of the period that is at the next higher level.

**Setting up Periods and Scenarios**

Periods and scenarios are shared by all the models on the same server. Therefore, before people start to use SAS Activity-Based Management, your organization might want to set up a period hierarchy, and you might want to publish guidelines for defining scenarios.

On the OLAP Analyzer view, SAS Activity-Based Management automatically rolls up values for each period and scenario that is in the hierarchy above the hierarchy level that contains data. This rolled-up data is not available for reports.

**Deleting Periods or Scenarios**

If a period or scenario is used in a period/scenario association, you cannot delete the period or scenario. You must first delete the period/scenario association in each model. Then, delete the period or delete the scenario.

**Period/Scenario Associations**

**About Period/Scenario Associations**

A period/scenario association identifies a specific period, such as Q1, and a specific scenario, such as Budget. All model data must reside in a period and must pertain to a scenario. An association represents a period-scenario pair.

Depending on your permissions, the Period/Scenario menu lists in SAS Activity-Based Management may show only associations that have been published.

**Calculation Status of Associations**

The calculation status of a period/scenario association indicates whether the data in the association is complete and accurate. A calculation status can be either Not calculated or Calculated.

**Status of Associations**

A period/scenario association can be either Not published or Published.

By default, a period/scenario association is Not published. The data is not ready for the general viewer to see because the data is in the process of being entered.
When the data for a period/scenario association is entered and calculated, the association is published. This enables the general user to see and analyze the data in that period/scenario association.

*Note:* As long as a period/scenario association has a status of Published, the data within the association cannot be edited.

Typically, an association is published at the end of a reporting period, such as at the end of a fiscal quarter.

**Copying Data from One Association to Another**

You can copy data from one period/scenario association to another period/scenario association. The ability to copy data enables you to propagate association data to similar periods and/or to similar period/scenario associations.

**Periods and Scenarios in OLAP Analysis**

Periods and scenarios are dimensions and can be used by business users for OLAP analysis. Periods and scenarios can aggregate data or separate data.

For example, suppose that a model contains actual cost data for the first three months of 2005 in the following period/scenario associations: Jan 2005/ACTUAL, Feb 2005/ACTUAL, and Mar 2005/ACTUAL.

When the OLAP cubes are generated and all period/scenario associations are included in an OLAP cube, business users can analyze the data in several ways on the OLAP view. For example, business users can aggregate the costs by month and then by category, as shown in the following figure of the Cube Explorer View:

Or, business users can aggregate the costs by category and then by month, as shown in the following figure:
Using combinations of periods and scenarios, business users can achieve many of their analysis goals.

## Create a Period

1. Select **Tools ⇒ Manage Periods**.

   The Manage Periods dialog box appears.

2. From the **Period** column, select a period under which to create the new period.

3. Click **New**.

   The New Period dialog box appears.
4. Type the Name. 
   The name must follow the naming conventions. See “Naming Conventions” on page 81.

5. Type the Reference. 
   A default reference is created from the period's name. If you change the reference, 
   the new reference must follow the reference conventions. See “Reference 
   Conventions” on page 86,

6. Type the Start date and the End date, or select dates from the drop-down calendar. 
7. Type the Description.

See Also

“New Period Dialog Box” on page 105

---

Manage Period Level Names

1. Select Tools ⇒ Manage Periods.
   The Manage Periods dialog box appears.
2. From the **Period** column, select a period.
3. Click **Levels**.

   The Period Level Names dialog box appears.

4. In the **New level name** column, double-click in a row and type a name.
   
   The name must follow the naming conventions. See “Naming Conventions” on page 81.

*See Also*

“Period Level Names Dialog Box” on page 108
New Period Dialog Box

About the New Period Dialog Box

In the New Period dialog box, you can name a new period and you can specify other information about the period.

Note: The availability of these features depends on your permissions.

How to Access the New Period Dialog Box

Do one of the following:
- In the Manage Periods dialog box, click New.
- In the Associate Periods and Scenarios dialog box, click New.

Specify Information

1. Type the Name. See “Naming Conventions” on page 81.
2. Type the Reference. See “Reference Conventions” on page 86.
   A default reference is created from the period's name. If you change the reference, the new reference must follow the reference conventions.
3. Type the Start date and the End date, or select dates from the drop-down calendar.
4. (Optional) Type the Description.

See Also

“Periods and Scenarios” on page 99

Manage Periods Dialog Box

About the Manage Periods Dialog Box

The availability of this feature depends on your permissions.

In the Manage Periods dialog box, you can manage periods.

Note: You can perform the following tasks without first opening a model.

TIP If a row is highlighted, the dates for the period are outside the date range for the parent period. This situation can occur when data is imported. Correct the dates for the highlighted period.

TIP You can widen the columns by dragging the column separators.
**How to Access the Manage Periods Dialog Box**

Do one of the following:
- Select **Tools ➔ Manage Periods**.
- In the Associate Periods and Scenarios dialog box, click **New Period**.

**Create a Period**

1. From the **Period** column, select a period under which to create the new period.
2. Click **New**.
   
   The New Period dialog box appears.

**Manage period properties**

1. From the **Period** column, select a period.
2. Click **Properties**.
   
   The Period Properties dialog box appears.

**Manage Period Level Names**

1. From the **Period** column, select a period.
2. Click **Levels**.
   
   The Period Level Names dialog box appears.

**Delete a Period**

1. If the period is part of a period/scenario association, delete the period/scenario association in every model.
2. After the period/scenario association has been deleted from every model, select the period from the **Period** column.
3. Click **Delete**.

**See Also**

“Periods and Scenarios” on page 99
Period Properties Dialog Box

About the Period Properties Dialog Box

In the Period Properties dialog box, you can review or change a period's properties.

Note: The availability of these features depends on your permissions.

How to Access the Period Properties Dialog Box

In the Manage Periods dialog box, select a period and click Properties.

Specify Information

1. Type the Name.
2. Type the Reference.
3. Type the Start date and the End date, or select dates from the drop-down calendar.
4. Type the Description.
5. In the Associated models list, review the models that use the period.

See Also

“Periods and Scenarios” on page 99

Period Level Names Dialog Box

About the Period Level Names Dialog Box

In the Period Level Names dialog box, you can name period levels.

Note: The availability of these features depends on your permissions.

How to Access the Period Level Names Dialog Box

In the Manage Periods dialog box, select a period and click Levels.

Specify Information

(Optional) In the New level name column, double-click in a row and type a name.

See Also

“Manage Period Level Names” on page 104
Chapter 11

Scenarios

Create a Scenario

1. Select Tools ⇒ Manage Scenarios.

The Manage Scenarios dialog box appears.
2. From the **Scenario** column, select a scenario under which to create the new scenario.

3. Click **New**.
   
The New Scenario dialog box appears.

4. Type the **Name**.
   
The name must follow the naming conventions. See “**Naming Conventions**” on page 81.

5. Type the **Reference**.
   
   A default reference is created from the scenario's name. If you change the reference, the new reference must follow the reference conventions. See “**Reference Conventions**” on page 86.

6. Type the **Description**.

**See Also**

- “**Periods and Scenarios**” on page 99
- “**New Scenario Dialog Box**” on page 112
Manage Scenario Level Names

1. Select Tools ⇒ Manage Scenarios.
   The Manage Scenarios dialog box appears.

2. From the Scenario column, select a scenario.
3. Click Levels.
   The Scenario Level Names dialog box appears.

4. In the New level name column, double-click in a row and type a name.
   The name must follow the naming conventions. See “Naming Conventions” on page 81.
New Scenario Dialog Box

About the New Scenario Dialog Box

In the New Scenario dialog box, you can name a new scenario and you can specify other information about the scenario.

*Note:* The availability of these features depends on your permissions.

How to Access the New Scenario Dialog Box

Do one of the following:

- In the Manage Scenarios dialog box, click **New**.
- In the Associate Periods and Scenarios dialog box, click **New**.

Specify Information

1. Type the Name.
2. Type the Reference.
   
   A default reference is created from the scenario's name. If you change the reference, the new reference must follow the reference conventions.
3. (Optional) Type the Description.

See Also

“Periods and Scenarios” on page 99

Manage Scenarios Dialog Box

About the Manage Scenarios Dialog Box

In the Manage Scenarios dialog box, you can create and perform other tasks to manage scenarios.

*Note:* You can perform the following tasks without first opening a model.

*Note:* The availability of these features depends on your permissions.
How to Access the Manage Scenarios Dialog Box

Do one of the following:

- Select Tools ⇒ Manage Scenarios.
- In the Associate Periods and Scenarios dialog box, click New Scenario.

Create a Scenario

1. From the Scenario column, select a scenario under which to create the new scenario.
2. Click New.

   The New Scenario dialog box appears.

Manage Scenario Properties

1. From the Scenario column, select a scenario.
2. Click Properties.

   The Scenario Properties dialog box appears.

Manage Scenario Level Names

1. From the Scenario column, select a scenario.
2. Click Levels.

   The Scenario Level Names dialog box appears.

Delete a Scenario

1. If the scenario is part of a period/scenario association, delete the period/scenario association in every model.
2. After the period/scenario association has been deleted from every model, select the scenario from the Scenario column.
3. Click Delete.

   TIP   You can widen the columns by dragging the column separators.

See Also

“Periods and Scenarios” on page 99
Scenario Properties Dialog Box

**About the Scenario Properties Dialog Box**

In the Scenario Properties dialog box, you can review or change a scenario's properties.

*Note:* The availability of these features depends on your permissions.

**How to Access the Scenario Properties Dialog Box**

In the Manage Scenarios dialog box, select a scenario and click **Properties**.

**Specify Information**

1. Type the Name.
2. Type the Reference.
3. Type the Description.
4. In the **Associated models** list, review the models that use the scenario.

**See Also**

“Periods and Scenarios” on page 99

Scenario Level Names Dialog Box

**About the Scenario Level Names Dialog Box**

In the Scenario Level Names dialog box, you can name scenario levels.

The availability of these features depends on your permissions.

**How to Access the Scenario Level Names Dialog Box**

From the Manage Scenarios dialog box, click Levels.

**Specify information**

(Optional) In the **New level name column**, double-click in a row and type a name.

**See Also**

“Manage Scenario Level Names” on page 111
Chapter 12
Period and Scenario Associations

Period and Scenario Associations View

About the Period and Scenario Associations View

How to Access the Period and Scenario Associations View

Create a Period/Scenario Association

Review or Change the Properties of a Period/Scenario Association

Delete a Period/Scenario Association

Publish or Unpublish a Period/Scenario Association

Create a Period/Scenario Association

Change the Current Period/Scenario Association

Copy Period/Scenario Data

Publish or Unpublish a Period/Scenario Association

Associate Periods and Scenarios Dialog Box

About the Associate Periods and Scenarios Dialog Box

How to Access the Associate Periods and Scenarios Dialog Box

How to Create New Periods and Scenarios

Period/Scenario Association Properties Dialog Box

About the Period/Scenario Association Properties Dialog Box

How to Access the Period/Scenario Association Properties Dialog Box

Specify Information

---

**Period and Scenario Associations View**

**About the Period and Scenario Associations View**

The availability of this feature depends on your permissions.
On the Period and Scenario Associations view, you can manage period/scenario associations.

The period/scenario association that is open is indicated by a check in the first column.

Note: You can perform the following tasks without first opening a model.

Note: You cannot directly edit the information on the Period and Scenario Associations view.

How to Access the Period and Scenario Associations View

Open a model in Model mode and select Model ➔ Period and Scenario Associations.

Create a Period/Scenario Association

Select Edit ➔ New Association.

The Associate Periods and Scenarios dialog box appears.

Review or Change the Properties of a Period/Scenario Association

1. Select a period/scenario association.
2. Select Edit ➔ Item Properties.

The Period/Scenario Association Properties dialog box appears.

Delete a Period/Scenario Association

1. Select a period/scenario association.
2. Select Edit ➔ Delete.

Publish or Unpublish a Period/Scenario Association

1. Select a period/scenario association.
2. Select Edit ➔ Publish/Unpublish.

See Also

• “Periods and Scenarios” on page 99
• “Associate Periods and Scenarios Dialog Box” on page 119
• “Create a Period/Scenario Association” on page 116
• “Change the Current Period/Scenario Association” on page 118

Create a Period/Scenario Association

1. Select Tools ➔ Period and Scenario Associations.
The Period and scenario associations page appears.

2. Select **Edit ➔ New Association**.

The Associate Periods and Scenarios dialog box appears.

3. Select the **Period**. To create a new period, do the following:

   a. Click **New Period**.

   The Manage Periods dialog box appears. Create a new period as described in the Create a Period section.

   b. Select the **Period**.

4. Select the **Scenario**. To create a new scenario, do the following:

   a. Click **New Scenario**.

   The Manage Scenarios dialog box appears. Create the scenario as described in the Create a Scenario section.

   b. Select the **Scenario**.

5. Type **Notes** for the association.

**See Also**

- “Associate Periods and Scenarios Dialog Box” on page 119
- “Periods and Scenarios” on page 99
- “Change the Current Period/Scenario Association” on page 118
Change the Current Period/Scenario Association

The current period/scenario association is the period and scenario to which costs are assigned when you add costs to a model.

To change the current period/scenario association, select from the period/scenario drop-down list on the Resource, Activity, Cost Object, or External Unit view of an open model and click the arrow button.

The current period is indicated by a check mark on the Period and Scenario Association view.

To open the Period/Scenario Associations view, open a model in Model mode and select Model → Period and Scenario Associations.

See Also

• “Periods and Scenarios” on page 99
• “Associate Periods and Scenarios Dialog Box” on page 119
• “Period and Scenario Associations View” on page 115

Copy Period/Scenario Data

1. Open a model in Model mode.
2. Select Model → Copy Period/Scenario Data.

The Copy Period/Scenario Data dialog box appears.
3. Select a Period/scenario.

4. To copy data to an existing period/scenario association, do the following:
   a. Select the Existing period/scenario association option.
   b. From the drop-down list on the right, select a period/scenario association.

5. To copy data to a new period/scenario association, do the following:
   a. Select the New period/scenario association option.
   b. Select a Period and a Scenario.

### Publish or Unpublish a Period/Scenario Association

1. Select Model ➔ Period and Scenario Associations Page.
   The Period and scenario associations page appears.
2. Select a period/scenario association.

### Associate Periods and Scenarios Dialog Box

#### About the Associate Periods and Scenarios Dialog Box

Some features may not be available depending on your permissions.

In the Associate Periods and Scenarios dialog box, you can associate periods and scenarios.

#### How to Access the Associate Periods and Scenarios Dialog Box

Do either of the following:
• From the task list of the Period/Scenario Associations view, click **Associate Period–Scenario**.

![Period-Scenario Association Task](image)

• On the Period/Scenario Associations view, select a period/scenario association, and then select **Edit** ⇒ **New Association**.

### How to Create New Periods and Scenarios

1. Select the Period or create a new period.
2. Select the Scenario or create a new scenario.
3. (Optional) Type Notes for the association.

### See Also

- “Periods and Scenarios” on page 99
- “Create a Period/Scenario Association” on page 116
- “Change the Current Period/Scenario Association” on page 118

### Period/Scenario Association Properties Dialog Box

#### About the Period/Scenario Association Properties Dialog Box

In the Period/Scenario Association Properties dialog box, you can create a period/scenario association.

*Note:* The availability of these features depends on your permissions.

#### How to Access the Period/Scenario Association Properties Dialog Box

On the Period and scenario associations view, select an association and select **Edit** ⇒ **Item Properties**.

### Specify Information

These steps are optional.

1. Select a Status.
2. Type Notes for the association.
Part 4

Dimensions

Chapter 13
Working with Dimensions ........................................... 123

Chapter 14
Windows for Dimensions ........................................... 137
Chapter 13
Working with Dimensions

Measures and Dimensions

Measures
Data that are most likely to be summarized are stored as values, either as currency or as numbers. Measures are the values that are aggregated and analyzed. A model can have values for costs, for sales quantities, for revenue, and so on. These values form the measures. For example, a model has information about product sales: product costs, sales quantities, and revenue. If you want to evaluate the success of a particular region, you can compare that region's total revenue to the total revenue of each other region.
**Dimensions**

A dimension is a category by which data can be analyzed. For example, you might want to categorize sales figures by region, by customer, and by product. Each of these categories represents a single dimension. Common dimensions are products, time, geography, customers, promotions, and sales channels.

To further illustrate, suppose that a manager says, I need to see the data items x, y, and z grouped by a, by b, and by c. In this statement, x, y, and z represent measures, and a, b, and c represent dimensions. For example, perhaps the manager needs to see revenue, cost, and profit grouped by region, by customer, and by product.

*Note:* For information about specifications for dimensions in Microsoft Analysis Services, see the Microsoft documentation.

**Dimension Levels**

To present data in a manageable or interesting form, you can group items within a dimension. Each item is then at a specific level in a hierarchy.

By default, each dimension level is given a name, such as Level1. To make this name more meaningful during OLAP analysis, you can rename dimension levels. There is more information about dimension level naming conventions.

For example, in the Products dimension, you can start with product families (the dimension level named Family). You can divide product families first into product lines (the dimension level named Line), and then into stock keeping units (the dimension level named SKU).

![Diagram of dimension levels](image)

In this example, the Products dimension has three levels below it. The levels enable you to show the measures for each level of information.

Dimension levels are a powerful modeling tool because they enable you to ask general questions and expand a dimension in order to reveal more detail. For example, you
might first ask to see product costs for the past three fiscal years. You might notice that
the costs for 2001 are higher than the costs for other years. You might explore levels of
the Products dimension to see whether costs were high for a particular product family,
product line, or SKU. This type of exploration is known as drill-down.

When you create a model, you select the dimension levels.

**Dimension Members**

**Overview**

Dimension members are the unique elements in the dimension levels. In the previous
example, Backpacking, Frame, and Hiker are examples of dimension members.

**All, No <Dimension Name>, None, and (Data) on the Module views**

To understand what a module view is showing, add a column for the Intersection Name
property. The intersection name lists the dimension members in the dimension order
from left to right.

In the following picture, the COST OBJECT module rollup cost represents all product
costs and all customer costs. In this case, the dimension order is the Product dimension
by the Customer dimension, which is often written as Product X Customer. In an
intersection name, All represents all dimension members in that position in the
dimension order. By looking at the intersection name (IntsectName column), you see
that the Solo Light rollup account is the intersection of the Solo Light dimension
member of the Product dimension and all the dimension members of the Customer
dimension (Solo Light x All). So, the Solo Light rollup account represents all of
the product costs of Solo Light, which includes the costs for all customers and all other
costs.

As you drill down into the COST OBJECT module rollup, you see more details about its
costs. When you expand Solo Light to see its accounts, you see a No <Customer>
account, which indicates costs (which are $248,253.44) that affect the total cost of the
Solo Light product, but that are not directly assigned to any specific customer (such as
raw materials, manufacturing, and production activities). When you look at the No
<Customer> intersection name, you see that No <Customer> is the intersection of the
dimension member and no customer dimension members (Solo Light x No
<Customer>).

No <dimension> represents costs that are outside the identified intersections. For
example, suppose that you create a model that represents your department. When you
import costs from the General Ledger (which contains the costs for all departments), you
can ensure that the costs of the other departments do not affect your department by
putting the costs for the other departments in No <dimension>.

The other Solo Light account is LLCorn, a customer. This account's intersection name
indicates that the account is the intersection of the Solo Light product and the LLCorn
customer (Solo Light X LLCorn). The account's cost represents the product costs of Solo
Light and the customer costs of LLCorn.
All, No <Dimension Name>, None, and (Data) in Grid View

In OLAP grid view, every dimension has the same value for the total value in the entire cube, which is shown in the All field. The All member of the dimension is not associated with any values, and the None value is used to balance the All value with values that are associated with other members in the dimension.
**Structural Dimensions**

Structural dimensions are the building blocks of the modules in a model. For example, the typical structural dimensions of the Resource module are region, organization, and General Ledger; the Activity module might be structured according to the region or organization dimension, along with an activity dimension. The combination of dimensions that uniquely identifies a model is the dimension signature.

Structural dimensions are basically “buckets” to model the flow of costs through your organization. However, this perspective of the costs is generally too detailed for other people in your organization. These people require a higher level of detail, such as details that are provided by attribute dimensions and OLAP analysis. Be aware that how you create the structural dimensions can greatly help users manipulate the model data into a form that suits their needs.

*Note:* Structural dimensions are created when you first create a model. You cannot delete structural dimensions later, and you cannot create new structural dimensions (but you can create dimension attributes). However, you can add and delete dimension members within each structural dimension.

**Attribute Dimensions**

Attribute dimensions are dimensions that are created whenever dimension attributes are created. You cannot explicitly create an attribute dimension. The SAS Activity-Based Management OLAP tool makes no distinction between attribute dimensions and structural dimensions.

See “Dimension Attributes, Dimension Member Attributes, and Dimension Value Attributes” on page 182.

---

**Dimensions View**

**About the Dimensions View**

The availability of this feature depends on your permissions.

On the Dimensions view, you can manage a model's dimensions and the dimension member names.

*Note:* You cannot directly edit the information on the Dimensions view.
How to Access the Dimensions View

Open a model in Model mode and select Model ➔ Dimensions.

Create a Dimension Member

1. Select an item within which to create the dimension member.
2. Select Edit ➔ New Dimension Member.
   The New Dimension Member dialog box appears.
3. (Optional) Create the account that corresponds to the dimension member.

See Also
“Create a Dimension Member” on page 128

Review or Change the Properties of an Item

1. Select an item.
2. Select Edit ➔ Item Properties.
   If you selected a dimension, the Dimension Properties dialog box appears.
   If you selected a dimension member, the Dimension Member Properties dialog box appears.

Delete a Dimension Member

1. Delete the account that corresponds to the dimension member.
2. Select the dimension member.
3. Select Edit ➔ Delete.

See Also
“Measures and Dimensions” on page 123

Create a Dimension Member

1. On the Dimensions page, select a dimension or a dimension member within which to create the new dimension member.
2. Select Edit ➔ New Dimension Member.
   The New Dimension Member dialog box appears.
3. Click Add.
A new row is added to the Dimension members list. The row contains default information.

4. Click in the Name column and type the name of the new dimension member.
The name must follow the naming conventions. See “Naming Conventions” on page 81.

5. Click in the Reference column and type the reference.
A default reference is created from the dimension member's name. If you change the reference, the new reference must follow the reference conventions. See “Reference Conventions” on page 86.

6. Click in the Level Name column and select a level name.

7. Select or clear the Show this dialog box every time I create a dimension member option.

8. Click Add.

9. On a module page, create the account that corresponds to the dimension member.

See Also

- “New Dimension Member Dialog Box” on page 139
- “Measures and Dimensions” on page 123

Reordering Dimension Members

Overview

You can use the mouse, keyboard, or staging tables to change the order of dimension members.
Using the Mouse

1. Go to the Dimensions view and select the dimension member that you want to reorder.

2. Hover over the dimension member until the cursor changes to the following:

3. Drag the cursor to the dimension member after which you want to move the selected item.

4. Drop the item and the dimension members are reordered.
To reorder dimension members using the keyboard, do the following:

1. Go to the Dimensions view.
2. Use the up or down arrow keys to navigate to the dimension member that you want to reorder.
3. Press **CTRL + D** to select the dimension member.
4. Use the up or down arrow keys to navigate to the dimension member after which you want to place the dimension member.
5. Press **CTRL + R** to drop the item.

*Note:* If you drag a dimension member out of its parent, then the system assumes that you want to change the parent of the dimension member.

### Using Staging Tables

To specify the display order of dimension members using staging tables, use the `DisplayOrder` field in the `DimensionMember` table.

You might consider numbering dimension members with increments of 10 so that you can easily interpose dimension member rows that are out of order in the staging table. For example, in the following picture the dimension member, Land Distribution, is assigned `DisplayOrder=15` so that it displays immediately after AirDistribution (`DisplayOrder=10`) and before Expedite Shipping (`DisplayOrder=20`).
See the chapter on “Importing and Exporting Using Staging Tables” in the SAS Activity-Based Management Data Administration Guide available from the Help menu or from http://support.sas.com/documentation/onlinedoc/abm/.

See Also

“Changing the Parent of a Dimension Member” on page 132

---

### Changing the Parent of a Dimension Member

**Overview**

You can use the mouse or keyboard to change the parent of a dimension member by moving the dimension member to its new parent.

*Note:* You can move a dimension member to a new parent only in the same dimension.

**Using the Mouse**

1. Go to the Dimensions view and select the dimension member that you want to reparent.

   ![Open the Dimension view](image)

   ![Select the item you want to reparent](image)

2. Hover over the dimension member until the cursor changes to the following:
3. Press and hold the **ALT** key, and then click and hold **Mouse button 1**.

4. Drag the cursor to the new parent (continuing to hold down the **ALT** key).

5. Drop the item.

   You are asked to confirm that you want to re-parent the item. If you confirm, then the item is moved under the new parent.

6. The dimension member is always added at the end as the last child of the new parent. If this is not where you want it, you can reorder the dimension member under its new parent.
Note: If you drag a dimension member out of its current parent, then the system assumes that you want to change the parent of the dimension member and it is not necessary to hold the ALT key.

Using the Keyboard

To re-parent an account using the keyboard, do the following:

1. Go to the Dimensions view.
2. Use the up or down arrow keys to navigate to the dimension member that you want to re-parent.
3. Press **CTRL + D** to select the dimension member.
4. Use the up or down arrow keys to navigate to the dimension member that is to be the parent.
5. Press **CTRL + Shift + R** to drop the item.

You are asked to confirm that you want to re-parent the item. If you confirm, then the item is moved under the new parent.

Using Staging Tables

You can specify the parent of a dimension member with the ParentReference field in the DimensionMember table.

Note: However, if a model already exists, you can not change the parent of a dimension member by re-importing a table with a different value for its ParentReference field—if the values are different, the imported value is ignored.

See the chapter on “Importing and Exporting Using Staging Tables” in the *SAS Activity-Based Management Data Administration Guide* available from the Help menu or from http://support.sas.com/documentation/onlinedoc/abm/.

See Also

“Reordering Dimension Members” on page 129
Changing Dimension Level Names

To change the name of a dimension level:

1. Open a model.
2. Select **Model ➔ Dimensions**.
3. Right-click a dimension and select **Item Properties**.
   The Dimension Properties window opens.
4. Type a new name, and then click **OK**.

**See Also**

“Dimension level naming conventions” on page 82
Chapter 14
Windows for Dimensions

New Dimension Dialog Box

About the New Dimension Dialog Box
In the New Dimension dialog box, you can create a new dimension if you are creating a new model.

Note: The availability of these features depends on your permissions.
How to Access the New Dimension Dialog Box

In the New Model Wizard, when you are specifying the model's dimensions, click **New**.

![New Dimension Dialog Box](image)

Specify Information

1. Type the Name.
2. (Optional) Type the Reference.
3. (Optional) Type the Short Reference.

The Short Reference is used in information maps and public views. For information, see the chapters on "Public Views" and "Information Maps" in the *SAS Activity-Based Management Data Administration Guide* available from the Help menu or at [http://support.sas.com/documentation/onlinedoc/abm/](http://support.sas.com/documentation/onlinedoc/abm/).

See Also

“Measures and Dimensions” on page 123

---

Edit Dimension Dialog Box

About the Edit Dimension Dialog Box

The availability of this feature depends on your permissions.

In the Edit Dimension dialog box, you can edit information about a dimension if you are creating a new model.

How to Access the Edit Dimension Dialog Box

In the New Model Wizard, when you are specifying the dimensions in the model, select a dimension and click **Edit**.

Specify Information

These steps are optional.

1. Type the Name. For more information, see About dimension naming conventions.
2. Type the Reference. For more information, see About dimension reference conventions.

See Also

- “Measures and Dimensions” on page 123
- “Dimension Properties Dialog Box” on page 139

---

**Dimension Properties Dialog Box**

**About the Dimension Properties Dialog Box**

In the Dimension Properties dialog box, you can review or change information about a dimension.

**How to Access the Dimension Properties Dialog Box**

On the Dimensions view, select a dimension and select **Edit ➔ Item Properties**.

**Specify Information**

1. Type the Name. For more information, see About naming conventions.
2. Type the Reference. For more information, see About reference conventions
3. From the Use this icon menu, select an icon.
   The icon represents a dimension in the interface.
4. In the New level name column, double-click in a row and type a name.
   For more information, see About dimension level names and About naming conventions.

See Also

- “Edit Dimension Dialog Box” on page 138
- “Measures and Dimensions” on page 123

---

**New Dimension Member Dialog Box**

**About the New Dimension Member Dialog Box**

In the New Dimension Member dialog box, you can name a new dimension member and you can specify other information about the dimension member.

*Note:* The availability of these features depends on your permissions.
How to Access the New Dimension Member Dialog Box

On the Dimensions view, select an item and select Edit ⇒ New Dimension Member.

Add a Dimension Member

1. Click Add.
   A new row is added to the Dimension members list. The row contains default information.
2. (Optional) Click in the Name column and type the name.
3. (Optional) Click in the Reference column and type the reference. A default reference is created from the dimension member's name. If you change the reference, the new reference must follow the reference convention.
4. (Optional) Click in the Level Name column and select a level name.
5. (Optional) Select or clear the Show this dialog box every time I create a dimension member option.

See Also

- “Create a Dimension Member” on page 128
- “Measures and Dimensions” on page 123

Find Dimension Member Dialog Box

In the Find Dimension Member dialog box, you can quickly find dimension members when creating a new account.
How to Access the Find Dimension Member Dialog Box

Open a model in Model mode and select Edit ⇒ New Account. When the New Account Wizard opens, click Find.

Find a Dimension Member

1. Type the Member name.
2. Select the dimension from the Dimension name menu.
3. (Optional) Select Match name exactly to find only exact matches with the member name that you type.

- If you don't select Match name exactly, then you can use an asterisk (*) as a wildcard to stand for 0 or more of any characters. And, the member name that you type is implicitly appended with an asterisk so that, for example, typing Equipment matches Equipment Depreciation and Equipment Expenses (it is the same as typing Equipment*).
- If you select Match name exactly, then only exact matches are made and there are no wildcards. If you type a name with an asterisk, then it will match only a member whose name itself contains an asterisk. And, the name that you type is not implicitly appended with an asterisk wildcard.

Dimension Member Properties Dialog Box

About the Dimension Member Properties Dialog Box

The availability of these features depends on your permissions.

In the Dimension Member Properties dialog box, you can review or change information about a dimension member.

How to Access the Dimension Member Properties Dialog Box

On the Dimensions view, select a dimension member and select Edit ⇒ Item Properties.

Specify Information

1. Click the General tab.
2. Type the Name.
3. Type the Reference.

See Also

“Measures and Dimensions” on page 123
Part 5

Modules and Accounts

Chapter 15

Working with Modules and Accounts ........................................ 145

Chapter 16

Windows for Accounts .............................................................. 167
Chapter 15
Working with Modules and Accounts

Modules, Module Rollups, Accounts, and Rollup Accounts ................. 146
  About Modules, Module Rollups, Accounts, and Rollup Accounts .... 146
  Resource Module .................................................. 147
  Activity Module ................................................... 147
  Cost Object Module ............................................... 148
  External Units Module .......................................... 148
  Profit Analysis Module ......................................... 148
  Accounts and Rollup Accounts .................................. 148
  Columns .............................................................. 150
  Module Rollups ................................................... 150
  References ......................................................... 150

Resource Module, Activity Module, and Cost Object Module ............... 150
  About the Resource Module, Activity Module, and Cost Object Module 151
  How to Access the Resource Module, Activity Module, and Cost Object Module 151
    Create an account ................................................ 151
    Create an Entered Cost Element ................................ 152
    Delete an Item .................................................... 152
    Create an Assignment .......................................... 152
    Delete Assignments ............................................. 152
    Show Assignments Panes ...................................... 153
    Show Only the Source Accounts for an Account ................. 153
    Show Only the Destination Accounts for an Account .......... 153
    Show the source accounts and the destination accounts for an account 153
    Go to an Account ............................................... 153
    Manage the Attributes of an Account .......................... 154
    Edit the Column Layout ....................................... 154
    Review or Change the Properties of an Item ................... 154

External Units Module View ...................................... 154
  About the External Units Module View ................................ 154
  How to Access the External Units Module View ...................... 155
  Create an external unit ......................................... 155
  Manage the Attributes That Have Been Added to an External Unit .... 155
  Edit the Column Layout .......................................... 155
  Review or Change the Properties of an Item ...................... 155
  Delete an Item .................................................... 155

Create an Account ................................................. 156

Reorder Accounts .................................................. 159
  Overview .......................................................... 159
Modules, Module Rollups, Accounts, and Rollup Accounts

About Modules, Module Rollups, Accounts, and Rollup Accounts

A module contains a specific type of cost information in a model, such as information about resources or information about activities. A model can contain the following modules:

- “Resource Module” on page 147
- “Activity Module” on page 147
- “Cost Object Module” on page 148
- “External Units Module” on page 148
- “Profit Analysis Module” on page 148

Each module is displayed on its own view.

If a model is not a complete activity-based costing implementation, you are not required to use all of the available modules when building the model. For example, costs can be entered directly into activities in the Activity module, assignments can be made from those activities to products in the Cost Object module, and then costs can be calculated. In this example, you do not need the Resource module.
Resource Module
This module contains information about resources. Resources are the costs that are consumed by activities such as planning, introducing new line items, advertising, or promoting products. To understand and manage resources, you should focus on activities and on how activities consume resources.

Activity Module

About the Activity Module
This module contains information about activities.

Guidelines for Creating Activities
When you create activities, consider these guidelines:

- An activity is a significant portion of an organization's cost (at least 5 percent of the total cost).
- Activities have the same type of process.
- An activity has one cost driver that is used for assigning product costs.
- An activity is a cost category that management is already concerned about.
- An activity involves and action or actions; it is not just an arbitrary accounting bucket.
- Ensure that all required activities are defined.
- To determine your organization's activities, conduct surveys of people in the organization.
- Create an activity only if management needs to know details about the activity to make decisions.

Methods of Organizing Activities
Use one of the following methods to organize the Activity module:

- Hierarchically by departments
  This is usually the best method.
- By process
  If you organize activities by their process, then organize the items within a rollup account either by their order in the process or by the order in which you want to report them.

To determine which method to use, consider how you want to assign costs to activities. Decide how you want to assign activity costs to cost objects. Keep in mind that you create assignments between accounts, not between rollup accounts.

Rollup accounts enable you to view the total cost of groups of related activities. For example, you can create a rollup account that groups activities in a process or that groups activities that are performed by a single department.
**Cost Object Module**

This module contains information about products and services. Additionally, products and services can be organized by customers, channels, regions, and so on.

**External Units Module**

This module contains information about external unit cost elements.

**Profit Analysis Module**

You can not directly work with the Profit Analysis module. The system uses the dimensions of the Profit Analysis module to determine what assignments to make with the Sales Volume driver.

*Note:* The dimensions of the Profit Analysis module must be the same as the dimensions of the Cost Object module.

**Accounts and Rollup Accounts**

**About Accounts and Rollup Accounts**

An account is an intersection of dimensions that is similar to a line item in a chart of accounts. Each account contains cost elements.

In the following picture you can see that the account 2nd Day Guaranteed is the intersection of the dimension members Beaverton x Drop Box x 2nd Day Guaranteed. Those dimension members are, in turn, members of the dimensions Region x Channel x Products and Services respectively. You can notice that the display name of the account, 2nd Day Guaranteed, is the name of the last member in the intersection of the dimension members when the order of dimension members is the order of their containing dimensions—Region, Channel, Products. The order of dimensions is the order in which you define them when you create a model.
Note: An account must contain a dimension member from every dimension in a module. However, you can omit specifying a dimension member from a particular dimension by selecting instead the "None" dimension member that the system automatically generates for each dimension.

Each account contains cost elements.

A rollup account is a cluster of accounts or a cluster of other rollup accounts that are related by function, department, location, or group. The cost of a rollup account is the sum of costs for all of the accounts and rollup accounts in the immediate subordinate level. Each module contains a module rollup. A module rollup is the highest level in the module. A module rollup represents all the accounts and rollup accounts in the module.
Creating and Deleting Accounts

An account corresponds to dimension members. You must create the dimension member before you can create the account that corresponds to the dimension member.

When you delete an account, the corresponding dimension member still exists, and the dimension member will appear in any cube that you generate. To remove the dimension member from a cube, you must delete the dimension member.

*Note:* When you delete an account, the model to which it belongs can be viewed but cannot be edited while the delete is in progress.

See also

“Create an Account” on page 156

Columns

SAS Activity-Based Management displays information in each module in user-defined columns in a grid. You can add or remove columns from the grid and specify how information in the columns appears. When you are satisfied with the appearance, you can save the display configuration (called a saved column layout). At a later time, you can display the saved column layout and the columns will be displayed like they were when you saved the column layout.

*Note:* The Display Name column, which is the left-most column in the column layout, is required, so you cannot remove it, change it, or reorder it.

See Also

“Column Layouts” on page 229

Module Rollups

Each module contains a module rollup. A module rollup is the highest level in the module. A module rollup represents all the accounts and rollup accounts in the module.

References

Within each module, a reference is a unique identifier for an item, such as an account, a dimension, or a cost element.

References are similar to the account numbers or account codes in a chart of accounts and in a General Ledger; account numbers uniquely identify line items. Generally, the references for accounts and cost elements in the Resource module match the account numbers in an organization's chart of accounts.

See Also

“Reference Conventions” on page 86
Resource Module, Activity Module, and Cost Object Module

About the Resource Module, Activity Module, and Cost Object Module

The availability of this feature depends on your permissions.

On the Resource Module, Activity Module, and Cost Object Module, you can examine the cost relationships in a model.

You interact with each module (Resource, Activity, and Cost Object) in the same way. So, all three modules are presented in this topic.

See Also
“Resource, Activity, Cost Object, and External Unit module views” on page 34

How to Access the Resource Module, Activity Module, and Cost Object Module

Open a model in Model mode and select Model ⇒ <name of module>. For example: Model ⇒ Cost Object Module.

Create an account

1. If the underlying dimension member does not exist, then create the dimension member.
2. Select a rollup account or an account.
   The New Account Wizard appears.
4. Follow the directions in the wizard.

   Tip To quickly locate a dimension member, click Find in the New Account Wizard. The Find Dimension Member dialog box appears.
Create an Entered Cost Element

1. Select an account (not a rollup account).
2. Select Edit Æ New Entered Cost Element.

Either the New Entered Cost Element dialog box or a new cost element appears, depending on how you set your user option for creating an entered cost element.

Delete an Item

1. Select an item.
2. Select Edit Æ Delete.

Create an Assignment

1. Decide which assignments panes to show.
2. Select Model Æ Assignments Æ Add Accounts in Left Pane (or Add Accounts in Right Pane).

The Add Accounts for Assignment dialog box appears.
3. Select the destination account.
4. To assign the cost to an account in the right assignments pane, click the arrowhead to the left of the account. To assign the cost from an account in the left assignments pane, click the arrowhead to the right of the account.

An arrow connects the two accounts.

**TIP** To quickly create assignments to many accounts, select Model Æ Assignments Æ Assign All Left, Assign All Right, or Assign All Left and Right.

5. To hide the accounts in the left assignments pane or the right assignments pane, select Model Æ Assignments Æ Clear Left (or Clear Right).

This only hides the accounts; it does not remove them from assignments.

To show the accounts, click in the left assignments pane or the right assignments pane and select Model Æ Assignments Æ Show Left (or Show Right).

Delete Assignments

1. Decide which assignments panes to show.
2. To delete an assignment, click the arrowhead to the right (or to the left) of the source account (or of the destination account).

An arrow connects the two accounts.

**TIP** To quickly delete assignments to many accounts, select Model Æ Assignments Æ Delete All Assignments Left, Delete All Assignments Right, or Delete All Assignments Left and Right.
Show Assignments Panes

From the following list, choose which assignments panes to show.

See Also
“Assignments Panes” on page 264

Show Only the Source Accounts for an Account

1. Select Model ⇒ Assignments ⇒ Show Left Assignments Pane.
   The view is split to include an empty left assignments pane. The selected module is displayed in the primary pane on the right.
2. Expand the module hierarchy and select an account.
3. Select Model ⇒ Assignments ⇒ Show Left.
   Arrows indicate that the listed accounts are source accounts for the selected account.

Show Only the Destination Accounts for an Account

1. Select Model ⇒ Assignments ⇒ Show Right Assignments Pane.
   The view is split to include an empty right assignments pane. The selected module is displayed in the primary pane on the left.
2. Expand the module hierarchy and select an account.
3. Select Model ⇒ Assignments ⇒ Show Right.
   Arrows indicate that the listed accounts are destination accounts for the selected account.

Show the source accounts and the destination accounts for an account

1. Select Model ⇒ Assignments ⇒ Show Left and Right Assignments Pane.
   The view is split to include empty left and right assignments panes. The selected module is displayed in the primary pane in the center.
2. Expand the module hierarchy and select an account.
3. Select Model ⇒ Assignments ⇒ Show Left and Right.
   Arrows indicate the accounts that are source accounts for the selected account, as well as the accounts that are destination accounts for the selected account.

Go to an Account

1. Select an account.
2. Select Edit ⇒ Go To Account.
Manage the Attributes of an Account

1. Select an account.
2. Select Edit ➤ Manage Attributes.
   The Manage Attributes dialog box appears.

Edit the Column Layout

1. Select Model ➤ Column Layout ➤ Edit Columns.
   The Column Layout dialog box appears.
   **Tip** Alternatively, you can double-click a column heading.
2. To save the column layout, select Model ➤ Column Layout ➤ Save As.
   The Save Column Layout As dialog box appears.

Review or Change the Properties of an Item

1. Select an item.
2. Select Edit ➤ Item Properties.
   The Item Properties dialog box appears.

External Units Module View

About the External Units Module View

The availability of these features depends on your permissions.

On the External Units Module view, you can manage a model's **units** for the current period/scenario association.

You can add more columns for periods, scenarios, properties, and For example, you can show the external unit costs per unit for the past two months.
Note: You cannot directly edit the information on the External Units Module view.

How to Access the External Units Module View

Open a model in Model mode and select Model ⇒ External Units Module.

Create an external unit

1. Select an item.
2. Select Edit ⇒ New Account.
   The New Account Wizard appears.
3. Follow the directions in the wizard.

Manage the Attributes That Have Been Added to an External Unit

1. Select an account.
2. Select Edit ⇒ Manage Attributes.
   The Manage Attributes dialog box appears.

Edit the Column Layout

1. Select Model ⇒ Column Layout ⇒ Edit Columns.
   The Column Layout dialog box appears.
   TIP Alternatively, you can double-click a column heading.
2. To save the column layout, select Model ⇒ Column Layout ⇒ Save As.
   The Save Column Layout As dialog box appears.

Review or Change the Properties of an Item

1. Select an item.
2. Select Edit ⇒ Item Properties.
   The Item Properties dialog box appears.

Delete an Item

1. Select an item.
2. Select Edit ⇒ Delete.
Create an Account

Provide Minimal Information

This task describes the minimal amount of information needed to create an account.

1. If the underlying dimension member does not exist, then create the dimension member.

2. Open a model in Model mode, and select Model ⇒ <name of module>. For example, Model ⇒ Resource Module.

3. Select a roll-up account or an account.


The New Account Wizard appears.

5. From the list of Dimensions, select at least two dimensions.

6. From the Create accounts using drop-down list, select a value.

   The effect of each value follows:

   Selecting leaf dimension members only creates accounts only for the intersections of the lowest dimension members in each dimension, as shown:
Selecting **all intersections** creates accounts for the intersections of all the dimension members in each dimension, as shown:

Create accounts using: **all intersections**

Selecting **parent dimension members only** creates accounts only for the intersections of the highest dimension members, as shown:
Note: The name shown in the list of Accounts is displayed in a module in the Display Name column. The display name uniquely identifies an item and is created by SAS Activity-Based Management; you cannot change the display name. However, you can change the account name. You will have the opportunity to change the account name in the next step of the wizard.

At this point, you have specified the minimal information needed to create an account using default information.

7. If you do not want to change an account name, change an account reference, or create cost elements, click Finish.

Provide Optional Information

8. Click Next (assuming that you did not click Finish in step 7).

9. To change the name of an account, click in the Name column and type a new name. The name must follow the naming conventions. See “Naming Conventions” on page 81.
10. To change the reference of an account, click in the **Reference** column and type a new reference.

   The reference must follow the reference conventions. See “Reference Conventions” on page 86.

   **Note:** At this point in the New Account Wizard, you can create cost elements.

11. Click **Finish**.

**See Also**

“Accounts and Rollup Accounts” on page 148

---

**Reorder Accounts**

**Overview**

You can control the display order of accounts by reordering dimension members on the Dimensions view. The order that you establish is preserved when you export and import a model.

You can reorder accounts using the mouse, keyboard, or staging tables.

**Using the Mouse**

1. Go to the Dimensions view and select the dimension member that you want to reorder.

   ![Open the Dimension view](image)

2. Hover over the dimension member until the cursor changes to the following:

   ![Select the item you want to move](image)
3. Drag the cursor to the dimension member after which you want to move the selected item.

4. Drop the item and the dimension members are reordered.

Note: If you drag a dimension member out of its parent, then the system assumes that you want to change the parent of the dimension member. For more information on re-parenting, see Changing the Parent of a Dimension Member.

When you open the appropriate assignments pane, you can notice that the accounts are reordered.
And the new order is reflected in cubes:

<table>
<thead>
<tr>
<th>Display Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>COST OBJECT (PRIMARY Pane)</td>
</tr>
<tr>
<td>USA</td>
</tr>
<tr>
<td>Oregon</td>
</tr>
<tr>
<td>Beaverton</td>
</tr>
<tr>
<td>No &lt;Channel&gt;</td>
</tr>
<tr>
<td>Commercial Pick-up</td>
</tr>
<tr>
<td>Drop Box</td>
</tr>
<tr>
<td>Walk In</td>
</tr>
<tr>
<td>Eugene</td>
</tr>
<tr>
<td>No &lt;Channel&gt;</td>
</tr>
<tr>
<td>Commercial Pick-up</td>
</tr>
<tr>
<td>Drop Box</td>
</tr>
<tr>
<td>Walk In</td>
</tr>
</tbody>
</table>

Using the Keyboard

To reorder an account using the keyboard, do the following:

1. Go to the Dimensions view.
2. Use the up or down arrow keys to navigate to the dimension member that you want
to reorder.
3. Press **CTRL + D** to select the dimension member.
4. Use the up or down arrow keys to navigate to the dimension member after which you
want to place the dimension member.
5. Press **CTRL + R** to drop the item.

The item is moved to the new position.

See Also

“Changing the Parent of a Dimension Member” on page 132

Using Staging Tables

To specify the display order of dimension members using staging tables, use the
DisplayOrder field in the DimensionMember table.

See the chapter on “Importing and Exporting Using Staging Tables” in the *SAS Activity-
Based Management Data Administration Guide* available from the Help menu or from
http://support.sas.com/documentation/onlinedoc/abm/.
Search for Accounts

To search for accounts, open a model in Model mode and do either of the following:

- Select **Edit ⊳ Search Accounts**.
- Click the Search Accounts icon.

Note: If a network user from a different domain (than that of the SAS Activity-Based Management client machine) logs in to the client machine to search for accounts, then that user must be granted WRITE access to the [ClientInstallpath]/bin folder for the operation to succeed.

See Also

- “Search for Accounts Dialog Box” on page 167
- “Search Account Results Dialog Box” on page 168
- “Save Queries for Account Search” on page 162

Save Queries for Account Search

Queries for searching for accounts can be long, complicated, and tedious to construct. Now you can save your queries, retrieve them for subsequent use, export them, and import them.

Save a Query

Once a query has returned the results that you want, click **Save Query** on the Search Account Results dialog box to save the query.

A saved query is not associated with a particular model or a particular user but rather with the machine on which it is saved. Any SAS Activity-Based Management user who uses that machine can see all the queries saved on that machine. In order to use the queries on another machine, you can export the queries and import them on the other machine.
Retrieve Queries

To retrieve a query for subsequent use, click Saved Queries on the Search for Accounts dialog box. All those queries that have been saved on that machine are displayed for selection and reuse.

![Retrieve queries](image)

Export Account Search Queries

In order to use the queries on another machine, you can export the queries and import them on the other machine. When you export, all the queries saved on the machine are exported regardless of which users saved them. The exported queries may be imported by any user.

To export your queries:

1. Go to the Workspace Manager.

![Workspace Manager](image)

2. Select Files ➔ Export ➔ Account Queries.

The Export Saved Search Account Queries dialog box opens.

3. Specify the name of the Registry file to which the queries are to be saved and click Export.

Note:

- It is not necessary to specify the file extension because it is added automatically. The default extension is .reg.
- If you do not type a path before the file name, then the file is saved in <installation directory>\SASActivityBasedManagementClient\7.2\bin.
• You can click the Browse button to browse to the directory in which you want to save the export file. Again, it is not necessary to specify the file extension because it is added automatically. The default extension is .reg.

Import Account Search Queries

When you import queries on a machine, any SAS Activity-Based Management user who uses that machine can see all the imported queries. When you import saved queries, the imported queries replace any queries that were previously saved on that machine.

To import queries:

1. Go to the Workspace Manager.

2. Select \textit{Files} \rightarrow \textit{Import} \rightarrow \textit{Account Queries}.

   The Import Saved Search Account Queries dialog box opens.

3. Specify the name of, or browse to the file to be imported and click \textit{Import}.

   \textit{Note}: When you import saved queries, the imported queries replace any queries that were previously saved on that machine.

See Also

• “Search for Accounts Dialog Box” on page 167
• “Search Account Results Dialog Box” on page 168

Go to an Account

You can quickly go to an account that is displayed in the left assignments pane or the right assignments pane.

1. Select an account in the left assignments pane or the right assignments pane.
2. Select **Edit \(\Rightarrow\) Go To Account**.

The selected account is displayed in the primary pane. You can display the source accounts and the destination accounts for the selected account.

**See Also**

“Assignments Panes” on page 264

---

**Expand All Levels**

To expand all dimension levels to see the accounts at every level, do either of the following:

- Select a module name (Resource, Activity, Cost Object, External Unit), a dimension, or a dimension member. Then, select **View \(\Rightarrow\) Expand \(\Rightarrow\) All Levels** from the menu bar.

- Right-click a module, dimension, or dimension member, and select **Expand \(\Rightarrow\) All Levels** from the pop-up menu.
Collapse All

To collapse all dimension levels so that no accounts are visible, do either of the following:

• Select a module name, dimension, or dimension member that is fully or partially expanded, and then select View ⇒ Collapse ⇒ All Levels from the menu bar.

• Right-click a module, dimension, or dimension member that is fully or partially expanded, and then select Collapse ⇒ All Levels from the pop-up menu.

Note:

• You can only Expand All one at a time on a view. If an Expand All in process, you can not do another Expand All until the first one has finished.

• If you change models during an Expand All function, the expansion is canceled.

• If you select Expand ⇒ All Levels and there are more rows than are specified in the Maximum number of rows user option, then a message box appears that allows you to cancel the operation.
Chapter 16
Windows for Accounts

Search for Accounts Dialog Box

About the Search for Accounts Dialog Box
In the Search for Accounts dialog box, you can specify criteria to build and update a query to search for accounts. This is useful when you build a model.

How to Access the Search for Accounts Dialog Box
Open a model in Model mode and select Edit ➤ Search Accounts or click the Search Accounts icon.

Build a Query to Search for Accounts
1. Select a Property or Attribute.
2. Select an Operator and specify a Value (numeric, Boolean, text, enumerated values, sets) to add criteria to your query.
3. Click Add to add the line to your query. The combined search criteria display in the Query box.
4. Repeat Steps 1 through 3 as necessary to build your query.

Search Account Results Dialog Box

About the Search Account Results Dialog Box

How to Access the Search Account Results Dialog Box

Sort the Search Results

Revise the Query Criteria

Perform an Action on Accounts

167
5. Filter the search results by selecting options in the Search for and Search in fields. You can select the * as wildcard check box and limit the result count in multiples of 50.

6. Click Search. The Search Account Results dialog box appears. You can update an existing query to search for accounts.

**Update Your Query to Search for Accounts**

1. Select the line in the Query box that you want to change and modify the criteria as necessary.

2. Click Update to display the updated search criteria in the Query box.

3. To remove a single line from the query, select the line in the Query box that you want to delete and click Remove. To remove all the lines of the query, click Remove All.

**See Also**

- “Search Account Results Dialog Box” on page 168
- “Save Queries for Account Search” on page 162
- “Find Property or Attribute Dialog Box” on page 223

---

**Search Account Results Dialog Box**

**About the Search Account Results Dialog Box**

In the Search Account Results dialog box, you can see the results of the query that you built in the Search for Accounts dialog box. The final search criteria are displayed in the non-editable Query box.

**How to Access the Search Account Results Dialog Box**

From the Search for Accounts dialog box, click Search.

**Sort the Search Results**

To sort the results by column, click the column heading.

**Revise the Query Criteria**

To revise the search criteria, click Revise Query. The Search for Accounts dialog box opens.
Perform an Action on Accounts

Overview
Select one or more accounts from the list of search results, and click Actions to perform any of the following actions:

- “Go to an Account” on page 169
- “Add Accounts” on page 169
- “Delete Accounts” on page 169
- “Add Attributes and Values” on page 169
- “Remove Attributes” on page 170
- “Mark Accounts as Profitability Management Behaviors” on page 171
- “Unmark Accounts as Profitability Management Behaviors” on page 171
- “Delete Assignments” on page 171

Go to an Account
1. Select an account from the list of results.
2. Click Actions ⇦ Go to Account to go to the selected account.

Add Accounts
1. Select one or more accounts from the list of results.
2. Click one of the following:
   - Actions ⇦ Add Accounts in Left Pane
   - Actions ⇦ Add Accounts in Right Pane

   Note: These actions are disabled on the Actions menu if the appropriate pane is not already open.

Delete Accounts
1. Select one or more accounts from the list of results.
2. Click Actions ⇦ Delete Accounts to delete the selected accounts. You are asked to confirm the deletion before the actual deletion takes place.

   Note: When you delete an account, the model to which it belongs can be viewed but cannot be edited while the delete is in progress.

Add Attributes and Values
1. Select one or more accounts from the list of results.
2. Click Actions ⇦ Add Attributes and Values. The Add Attributes and Values dialog box opens.
3. Select each attribute that you want to add to the selected accounts, and then click Add.

4. Enter a new value in the **Value** column if you want to change the value of the attribute.

   *Note:* The value that is displayed in the **Value** column is the default value for an attribute - not its current value even if the account already has that attribute. An existing attribute is reset to its default value unless you specify a new value.

   *Note:* You cannot change Boolean attributes or calculated attributes. A calculated attribute retains its formula. If you want to change the formula of a calculated attribute, you must go to the Attributes view and change the formula from there.

5. Click **OK**. The attributes (along with their values) are added to the selected accounts.

   *Note:* This method of adding attributes to accounts is an efficient method for adding stage attributes to multiple accounts to create multi-stage contribution cubes.

**Remove Attributes**

1. Select one or more accounts from the list of results.

2. Click Actions ⇒ Remove Attributes.

   The Remove Attributes dialog box opens, showing all the attributes from all selected accounts.
3. Select each attribute that you want to remove from the selected accounts, and click Remove.

If you have selected multiple accounts, and an attribute that you select for removal belongs to more than one of the selected accounts, then the attribute is removed from all of those accounts.

4. Click OK. The attributes are removed from the selected accounts.

**Mark Accounts as Profitability Management Behaviors**
1. Select one or more accounts from the list of results.

2. Click Actions ⇒ Mark Accounts as Behaviors. A message is displayed if the action is successful.

   Note: Rollup accounts and external unit accounts cannot be marked as behaviors.

Once you have marked accounts as behaviors, you can publish them to SAS Profitability Management.

**Unmark Accounts as Profitability Management Behaviors**
1. Select one or more accounts from the list of results.

2. Click Actions ⇒ Unmark Accounts as Behaviors. A message is displayed if the action is successful.

**Delete Assignments**
1. Select one or more accounts from the list of results.

2. Click one of the following:

   Actions ⇒ Delete Incoming Assignments to delete assignments coming into the selected accounts.

   Actions ⇒ Delete Outgoing Assignments to delete assignments going out of the selected accounts.

   Actions ⇒ Delete Incoming and Outgoing Assignments to delete both sorts of assignments.

   Note: These options are not available for rollup accounts. For external unit accounts, deleting incoming assignments is not available (because external unit accounts do not have incoming assignments). You are asked to confirm the deletion before the actual deletion takes place.

**See Also**

- “Search for Accounts Dialog Box” on page 167
- “Save Queries for Account Search” on page 162
- “Find Property or Attribute Dialog Box” on page 223
Chapter 17
Working with Cost Elements

Cost Elements

Overview
The cost of an account is the sum of its cost elements. There are four types of cost elements:

- entered cost elements
- assigned cost elements
- internal unit cost elements
- external unit cost elements

Entered Cost Elements

An entered cost element is the cost that you specified. You can specify entered cost elements either interactively or by importing costs. You can set an option that controls how an entered cost element is specified.
**Assigned Cost Elements**

An assigned cost element is the cost that is flowed from one account to another account.

**Internal Unit Cost Elements**

An internal unit cost element is a unit (for example, a part that is produced within an organization) whose cost is already represented in the model. This cost flows from one account to another account's bill of costs.

**External Unit Cost Elements**

An external unit cost element is a unit (for example, a part that is purchased from a supplier) whose cost is maintained outside of a SAS Activity-Based Management model, but which needs to be accounted for in the model.

In SAS Activity-Based Management, external unit cost elements are treated like accounts. When an external unit cost element's cost is flowed to an account, the flowed cost is listed as an external unit cost element. External unit cost elements always contribute costs, but they do not receive costs.

**See Also**

“Types of Costs” on page 618

---

**Create Cost Elements When Creating an Account**

1. On the second page of the New Account Wizard, click **Add Cost Element**.

   A new entered cost element with default information appears.

<table>
<thead>
<tr>
<th>Name</th>
<th>Reference</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>Northeast x Salaries_1021</td>
<td>Northeast x Salaries_1021</td>
<td></td>
</tr>
<tr>
<td>Salaries_1021-1</td>
<td>Salaries_1021_1021-1</td>
<td></td>
</tr>
</tbody>
</table>

2. To change the name of the cost element, click in the **Name** column and type a new name.

   The name must follow the naming conventions. See “Naming Conventions” on page 81.

3. To change the reference of the cost element, click in the **Reference** column and type a new reference.

   The reference must follow the reference conventions. See “Reference Conventions” on page 86.

4. To enter the cost of the cost element, click in the **Cost** column and type a cost.
Create an Entered Cost Element on a Module Page

1. In a module, select an account (not a roll-up account).
2. Select Edit ➜ New Entered Cost Element.
   The New Entered Cost Element dialog box appears.

3. Click Add Cost Element.
   A new row is added to the Entered cost elements list. The new row contains default information.
4. Click in the Name column and type the name.
   The name must follow the naming conventions. See “Naming Conventions” on page 81.
5. Click in the Reference column and type the reference.
   A default reference is created from the cost elements name. If you change the reference, the new reference must follow the reference conventions. See “Reference Conventions” on page 86.
6. Click in the Cost column and type the cost.
7. To delete a cost element, do the following:
   a. From the list of Entered cost elements, select an element.
   b. Click Delete Cost Element.
New Entered Cost Element Dialog Box

About the New Entered Cost Element Dialog Box
In the New Entered Cost Element dialog box, you can create one or more entered cost elements.

How to Access the New Entered Cost Element Dialog Box
On the Resource module, the Activity module, or the Cost Object module, select an account and select Edit ⇒ New Entered Cost Element.

Add a Cost Element
1. Click Add Cost Element.
   A new row is added to the Entered cost elements list. The new row contains default information.
2. (Optional) Click in the Name column and type the name.
3. (Optional) Click in the Reference column and type the reference.
4. (Optional) Click in the Cost column and type the cost.
5. (Optional) Select or clear the Show this dialog box every time I create an entered cost element option.

Delete a Cost Element
1. From the list of Entered cost elements, select an element.
2. Click Delete Cost Element.

See Also
- “Cost Elements” on page 175
- “Create Cost Elements When Creating an Account” on page 176
- “Create an Entered Cost Element on a Module Page” on page 177
Part 7

Attributes

Chapter 18
Types of Attributes .................................................... 181

Chapter 19
How To ................................................................. 187

Chapter 20
Attributes on Dimension Members ............................... 197

Chapter 21
Windows for Attributes ............................................... 217
Chapter 18
Types of Attributes

Introduction

About Attributes

An attribute is a label that is added to an account. Each attribute is a characteristic that is used for analysis or for a calculated value, such as in a formula for a calculated attribute or calculated driver. An attribute conveys information about the item to which the attribute is added.

You create an attribute on the Attributes view. You add and delete (manage) the attributes that have been added to an account on the Resource module, the Activity module, and the Cost Object module.

Attribute Folders

An attribute folder organizes attributes. Generally, an attribute folder can contain any type of attribute, and it can contain multiple types of attributes, because the folder itself has no type. However, a dimension attribute folder can contain only dimension member...
attributes or other dimension value attributes. In addition, dimension member attributes must be contained in a dimension attribute folder.

You cannot explicitly create a dimension attribute folder. When you explicitly create a new dimension attribute, SAS Activity-Based Management automatically creates a dimension attribute folder in which dimension member attributes are contained. If you create a new dimension attribute when a dimension attribute folder is selected, the new dimension attribute is automatically created as a dimension member attribute. You cannot change this attribute type.

---

**Dimension Attributes, Dimension Member Attributes, and Dimension Value Attributes**

A dimension attribute is a type of dimension and is included in and displayed in cubes. When you create a dimension attribute on the Attributes view, it is automatically displayed on the Dimensions view, as shown:

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Region</td>
<td>Dimension</td>
</tr>
<tr>
<td>General Ledger</td>
<td>Dimension</td>
</tr>
<tr>
<td>Activities</td>
<td>Dimension</td>
</tr>
<tr>
<td>Channel</td>
<td>Dimension</td>
</tr>
<tr>
<td>Products and Services</td>
<td>Dimension</td>
</tr>
<tr>
<td>Materials</td>
<td>Dimension</td>
</tr>
<tr>
<td>Vendors</td>
<td>Dimension Member</td>
</tr>
<tr>
<td>Jans Sports</td>
<td>Dimension Member</td>
</tr>
<tr>
<td>Sue Sports</td>
<td>Dimension Member</td>
</tr>
<tr>
<td>Midwest</td>
<td>Dimension Member</td>
</tr>
<tr>
<td>Pacific Northwest</td>
<td>Dimension Member</td>
</tr>
<tr>
<td>Northeast</td>
<td>Dimension Member</td>
</tr>
<tr>
<td>Southeast</td>
<td>Dimension Member</td>
</tr>
<tr>
<td>West Coast</td>
<td>Dimension Member</td>
</tr>
</tbody>
</table>

The leaf node of a dimension attribute is called a dimension value attribute. It is the dimension value attribute that applies to an account. Whereas a dimension member attribute contains a dimension value attribute, a dimension value attribute cannot contain other attributes.

If you attempt to create another attribute within a dimension value attribute, the dimension value attribute automatically becomes a dimension member attribute. For example, you can see in the following that if you create an Ohio attribute inside the Midwest attribute, then the Midwest attribute automatically becomes a dimension member attribute:

Dimension value attributes can facilitate data entry because a drop-down list of possible attribute values is displayed in the interface. For example, from the previous picture, the following drop-down list is displayed when a user sets the value of the Vendors attribute:
Dimension attributes, dimension member attributes, and dimension value attributes provide business users with roll-up values for OLAP analysis that differ from the values available from the structural dimensions. Using dimension attributes, you enhance a model by classifying or organizing information in ways that will help business users analyze model results.

For example, dimension attributes are commonly used to indicate which resources are fixed or variable and which activities are value-added or non-value-added. Other typical dimension attributes include core, sustaining, and discretionary; strategic and non-strategic; and primary and secondary.

### Numeric Attributes

A numeric attribute stores a number. What the number represents is determined by the unit of measure. The unit of measure is text that provides meaning to the unit. For example, the unit of measure could be cases, pounds, kilograms, and so on. Without a unit of measure, a numeric attribute has little meaning. Alternatively, the name of the numeric attribute can indicate the unit of measure, as in Miles Shipped or Number of Pallets.

A numeric attribute can serve purposes such as:

- A numeric attribute can track a models financial measures or non-financial measures.
- A numeric attribute can track activity performance over time.
- A numeric attribute can be a performance measure for special reporting purposes.

The data that a numeric attribute contains can be used in calculated drivers and in calculated attributes.

### See Also

- “Using Numeric Attributes in a Formula” on page 340
- “Properties That Can Be in Formulas” on page 361
Calculated Attributes

Overview

A calculated attribute stores a number that is calculated from numeric properties of a model and/or from other calculated attributes, based on a formula that you define. (Examples of calculated attributes)

Property values and attribute values are derived from the item to which the attribute is attached. For example, the value of a calculated numeric attribute that is based on the property Cost depends on the item to which the attribute is attached, because each item has a different cost.

Unlike the formula for a calculated driver, which remains the same for all periods, the formula for a calculated attribute can change with each period.

Example: Average Cost of Processing a Customer Order

The following example illustrates how calculated attributes can be used in a model. Equations often include numeric properties and numeric attributes.

Suppose that a company provides order-processing services to other companies. To determine the average cost of processing an order, the cost (the property Cost) is divided by the number of orders processed (the user-defined numeric attribute Orders Processed), as follows:

Cost/Orders Processed

Example: Average Number of Cases Loaded per Employee

Suppose that a company loads goods onto trucks for shipping. Management wants to determine how many cases are loaded per full-time employee. The number of cases loaded (the user-defined numeric attribute Cases Loaded) is divided by the number of full-time employees who are loading cases (the user-defined numeric attribute FTE), as follows:

Cases Loaded/FTE

See Also

- Chapter 29, “Formulas,” on page 329
- “Using Numeric Attributes in a Formula” on page 340
- “Properties That Can Be in Formulas” on page 361

Tag Attributes

A tag attribute is either added to an account or it is not. A tag attribute does not store a value.
You can use the HasAttribute function in the formula for a calculated driver, rule-based driver or calculated attribute to test whether an account has a particular tag attribute or not.

*Note:* In previous releases of SAS Activity-Based Management, tag attributes were called Boolean attributes.

The maximum length of a text attribute is 2048 characters.

---

**Text Attributes**

A text attribute stores alphabetic and numeric characters. A text attribute provides information about the item to which the attribute is added. For example, a text attribute named Cost Analysis can indicate whether a resource account is a fixed cost or a variable cost. Or, a text attribute named Life Cycle can indicate where a cost object account belongs in a life cycle: analysis, start-up, entry, build, mature, decline, or withdrawal.

The maximum length of a text attribute is 2048 characters.

---

**Stage Attributes**

**Overview**

Stages are used for creating the Multi-stage Contributions cube. To define stages, you create a dimension value attribute for each stage, and then you assign these attributes to accounts. You must create these dimension value attributes within a dimension attribute named Stages. You can give a dimension value attribute any name, but the name must conform to the Stages attribute naming conventions.

For more information, see Adding Stage Attributes to Accounts.

*Note:*

- All the accounts for a given stage must belong to the same module (resource, activity, cost object, or external units).
- Stage names and references must begin with an alphabetic character (letter).

Previous releases of SAS Activity-Based Management allowed stage names and references to begin with a numeric character. In SAS Activity-Based Management 7.2, this is not allowed. If you have a stage name or reference that begins with a numeric character, then you must change it to begin with an alphabetic character. For models using renamed stages, update cube configurations to re-select the dimensions that are included in the cube and regenerate any multi-stage contributions cubes. (Regenerating cubes is not necessary if you are using Microsoft Analysis Services for cubes.)

- The stage name is used to define a dimension name in cubes. The stage name is concatenated with a user-defined dimension name to form the actual dimension in the cube.
- A Stages attribute example is Stage2 Activity, where Stage2 is the stage name and Activity is the user-defined dimension. If 2 is used in place of Stage2, then the generated cube dimension name becomes 2 Activity.
To see the stages in the Multi-stage Contributions cube, you must specify the properties for the cube. This is true regardless of which method you use for creating the Stages attributes.

**Guidelines for Adding the Stages Attributes to Accounts**

Follow these guidelines when you add Stages attributes to accounts:

- Add only one Stages attribute (or one member of a Stages attribute) to an account.
- Do not skip an account that you need for analysis.
  
  For example, suppose that an IT Salaries account is assigned to an IT Help Desk account, and that the IT Help Desk account is subsequently assigned to a Design Products account. Ensure that a different Stages attribute is added to each account. Do not skip the IT Help Desk account.

- Do not add Stages attributes to accounts that you do not need for analysis.
  
  Every account that has a Stages attribute is included in the Multi-stage Contributions cube. The cube can be generated more quickly if unnecessary accounts are omitted.

- To avoid performance problems, do not exceed six to eight stages.

**See Also**

“Add Stage Attributes to Accounts” on page 193
Create an Attribute

1. Open a model in Model mode, and select **Model ➔ Attributes Page**.
   The Attributes page appears.
2. Select the folder in which the attribute is to go.
   A dimension attribute can go in the **ATTRIBUTES** folder or in an existing dimension attribute.
   Other attributes can go in the **ATTRIBUTES** folder or in another attribute folder.
3. Select **Edit ➔ New Attribute**.
   The New Attribute dialog box appears.
4. Type the **Name**.
   The name must follow the naming conventions. See “Naming Conventions” on page 81.

5. Type the **Reference**.
   An attribute reference is required only for dimension attributes and is used in public views. See the chapter on “Public Views” in the *SAS Activity-Based Management Data Administration Guide*. A reference must follow the reference conventions. See “Reference Conventions” on page 86.

6. Select the **Attribute type**.
   
   *Note:* If you select **Dimension** when either **ATTRIBUTES** or an existing dimension attribute is selected, you will create a dimension attribute folder, not a dimension attribute.

   **For a numeric attribute only:**

7. Type the **Unit of measure**.

8. Click the **Advanced** tab.
9. From the Using this period/scenario association drop-down list, select a period/scenario association.

10. Type the Default value.

11. If this is a calculated attribute, perform the following steps:
   a. Select the Calculated option.
   b. Click Formula Builder.

      The Formula Builder dialog box appears.
TIP You can also modify the formula in the Formula box.

c. Select an item from the list of Numeric properties, from the list of Operators, or from the list of Attributes.

d. Click Insert.

   The item is added to the formula.

   TIP You can also type the formula.

e. Continue to insert items until you have built the entire formula.

f. To remove the last item that you inserted, click Undo.

g. To delete the entire formula, click Clear.

h. Click Validate Formula.

   If no errors are displayed, the syntax of the formula is valid.

See Also

- Chapter 18, “Types of Attributes,” on page 181
- “Add an Attribute to an Account” on page 191
- “Specify an Attribute's Value” on page 192
- “Show the Accounts To Which an Attribute Has Been Added” on page 194
- “Remove an Attribute from an Account” on page 194

Create an Attribute Folder

1. Open a model in Model mode, and select Model ⇒ Attributes Page.
The Attributes page appears.
2. Select an attribute folder (other than a dimension attribute folder) within which to create the new folder.
   The New Attribute Folder dialog box appears.

```
New Attribute Folder

Name: [Input field]
Reference: [Input field]

OK  Cancel  Help
```

4. Type the Name.
   The name must follow the naming conventions. See “Naming Conventions” on page 81.
5. Type the Reference.
   A default reference is created from the name. If you change the reference, the new reference must follow the reference conventions. See “Reference Conventions” on page 86.

---

**Add an Attribute to an Account**

1. On a module page, select an account, and select Edit ⇒ Manage Attributes.
   The Manage Attributes dialog box appears.
2. From the **Attribute hierarchy** list, select an attribute.
3. Click **Add >**.
   The attribute is added to the **Account's attributes** list.

**See Also**

“Specify an Attribute's Value” on page 192

---

**Specify an Attribute's Value**

1. On a module page, select an account, and select **Edit → Manage Attributes**.
   The Manage Attributes dialog box appears.
2. From the **Account's attributes** list, select an attribute.
3. Set the **Value**.
   The type of value that you can specify depends on the type of attribute.

**See Also**

“Show the Accounts To Which an Attribute Has Been Added” on page 194
Add Stage Attributes to Accounts

Overview

Adding stage attributes to accounts requires two steps:
1. Create stage attributes
2. Add stage attributes to accounts

To Create Stage Attributes:

1. In Model mode, select Model ⇒ Attributes view. The Attributes view opens.
2. On the Attributes view, select Edit ⇒ New Attribute (or click the New Attribute button). The New Attribute dialog box opens.
3. In the New Attribute dialog box, specify Stages as the name of the new attribute and select Dimension as its Attribute Type, then click OK.
4. On the Attributes view, select the Stages dimension (that you created in Step 3) and select Edit ⇒ New Attribute (or click the New Attribute button). The New Attribute dialog opens again.
5. From the New Attribute dialog box, name the new attribute (which represents a stage) and select Dimension Member as the Attribute Type.
6. Repeat steps 4 and 5 for as many times as you want stages - one dimension member attribute per stage. Your attributes might resemble the following:

<table>
<thead>
<tr>
<th>Name</th>
<th>Reference</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>ATTRIBUTES</td>
<td>ATTRIBUTES</td>
<td>Dimension</td>
</tr>
<tr>
<td>Stages</td>
<td>stages</td>
<td>Dimension</td>
</tr>
<tr>
<td>stage1</td>
<td>stage1</td>
<td>Dimension Member</td>
</tr>
<tr>
<td>stage2</td>
<td>stage2</td>
<td>Dimension Member</td>
</tr>
<tr>
<td>stage3</td>
<td>stage3</td>
<td>Dimension Member</td>
</tr>
</tbody>
</table>

Note: The dimension attribute must be named Stages. The name of each dimension member attribute (for example, stage1, stage2) is arbitrary, but the name and reference must be the same.

To Add Stage Attributes to Accounts, Do One of the Following:

• Add attributes from the Manage Attributes dialog box.
• Search for accounts and add attributes to accounts that are found.

Note: All of the accounts for a stage must belong to the same module (Resource, Activity, Cost Object, or External Unit). The following picture shows adding the stage1 attribute to accounts that are found as a result of searching for accounts.
Show the Accounts To Which an Attribute Has Been Added

You can divide the Attributes page to see the accounts to which an attribute has been added.

1. Select Model ⇒ Attributes Page.
   
   The Attributes page appears.

2. Select Model ⇒ Assignments ⇒ Show Right Assignments Pane.
   
   The right assignments pane is displayed.

3. Select an attribute.

4. Select Model ⇒ Assignments ⇒ Show Right.

   If the attribute has been added to any accounts, then those accounts are displayed.

Remove an Attribute from an Account

1. On a module page, select a account, and select Edit ⇒ Manage Attributes.

   The Manage Attributes dialog box appears.

2. From the Account's attributes list, select an attribute.
3. Click **Remove**.

   The attribute is removed from the **Attribute hierarchy** list.
Chapter 20
Attributes on Dimension Members

General Description

Introduction

Setting an attribute on a dimension member sets the attribute on multiple accounts automatically.

Setting an attribute on a dimension member is an indirect method of setting the attribute on all the accounts whose dimension signature includes that dimension member. One reason that it is important to be able easily to set attributes on accounts is because having attributes on accounts is particularly important for generating rule-based drivers. Setting attributes on dimension members provides a method of quickly setting those attributes on many accounts.

To understand how setting an attribute on a dimension member works, first remember that an account is an intersection of dimension members. An account is defined by that intersection, which is called its dimension signature (or alternatively, its dimension identifier). For example, in the following picture you can see that the account 2nd Day Guaranteed is the intersection of the dimension members Beaverton x Drop Box x 2nd Day Guaranteed. Those dimension members are, in turn, members of the dimensions Region x Channel x Products and Services, respectively.

Note: The display name of the account, 2nd Day Guaranteed, is the name of the last member in the intersection of the dimension members when the order of dimension members is the order of their containing dimensions—Region, Channel, Products. The order of dimensions is the order in which you define them when you create a model.
Now, if you set an attribute on the dimension member Beaverton, you would automatically set the attribute on the 2nd Day Guaranteed account because its dimension signature is Beaverton x Drop Box x 2nd Day Guaranteed. And, in fact, you would automatically set the attribute on all the accounts whose dimension signature includes Beaverton.

An Example

Let's look at an example.

1. Create an attribute:

   You can use any existing attribute, but for this example suppose that you create a numeric attribute named AttributeOnDimensionMember with a default value of 100, as shown in the following picture.

2. Go to the model's Dimension view, and select the period in which the attribute is to be applied.

3. Select a dimension member, and select Manage Attributes to attach the attribute to the dimension member.
For this example, attach the attribute, AttributeOnDimensionMember, to the Beaverton dimension member in the Region dimension.

In fact, there are two ways in which to attach an attribute to a dimension member. And, you can modify the columns in the Dimension view to display attributes. For more information, see “Attach an Attribute to a Dimension Member” on page 207.

4. Select **Model ⇔ Apply Attributes On Accounts** to apply attributes-on-dimension-members to accounts.

See “Apply Attributes-on-Dimension-Members to Accounts” on page 214.

5. The result is that the attribute, AttributeOnDimensionMember, is applied to every account whose dimension signature includes Beaverton, as shown in the following picture.
You can see that the attribute with its default value is now on every account with the dimension member of Beaverton, but it is not on accounts with the dimension member Eugene. And, note, moreover, that the preceding picture shows only the Cost Object module. As a result of applying dimension attributes to accounts, other modules that have accounts whose dimension signature includes Beaverton would also have attributes applied to those accounts. In short, an attribute that you initially assigned to a dimension member is now on multiple accounts.

Frequently Asked Questions

FAQ

- “What type of attributes can you attach to dimension members?” on page 201
- “Where precisely can you attach the attributes?” on page 201
- “Attribute associations are periodic” on page 203
- “How are attribute values inherited from dimension members?” on page 204
- “What are the default values for such attributes?” on page 204
- “System-generated versus user-entered attribute values” on page 205
- “What happens when a dimension member is re-parented?” on page 205
What type of attributes can you attach to dimension members?

You can attach any type of attribute to a dimension member, including dimension attributes and calculated attributes.

<table>
<thead>
<tr>
<th>Name</th>
<th>Reference</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text attribute</td>
<td>Text attribute</td>
<td>Text</td>
</tr>
<tr>
<td>Tag attribute</td>
<td>Tag attribute</td>
<td>Tag</td>
</tr>
<tr>
<td>Numeric attribute</td>
<td>Numeric attribute</td>
<td>Numeric</td>
</tr>
<tr>
<td>Calculated numeric attribute</td>
<td>Calculated numeric attribute</td>
<td>Numeric</td>
</tr>
<tr>
<td>Dimension attribute</td>
<td>Dimension attribute</td>
<td>Dimension</td>
</tr>
</tbody>
</table>

So, you can attach any of the following types of attributes to a dimension member:

- Text
- Tag (Boolean)
- Numeric (including calculated numeric)
- Dimension

Where precisely can you attach the attributes?

- You can attach an attribute to any dimension member.
- You can not attach an attribute to a dimension.

For example, in the following picture, you can attach an attribute to (among others) the dimension members Personnel Intensive Activities (Level1) and Resolve Customer Complaints (Level2), but you can not attach an attribute to the Activities dimension.

- You can not attach an attribute to a dimension attribute.

You can attach an attribute only to a structural dimension. Thus, for example, in the Parcel Express Tutorial model, you can not attach an attribute to the FixedVariable dimension attribute.
Do not be confused by terminology. A dimension attribute is called "dimension attribute" because it is like an ordinary (structural) dimension in that it is an element of an OLAP cube. Inside an OLAP cube there is no distinction between dimension attributes and structural dimensions. They are both dimensions of a measure. However, whereas you cannot attach an attribute to a dimension attribute, you can attach a dimension attribute to a dimension member. For example, in the following picture, the dimension attribute Fixed_Variable is attached to the following dimension members:

- Personnel Intensive Activities (with a value of Variable)
- Air Distribution (with a value of Variable)
- Land Distribution (with a value of Fixed)

The picture also shows the result of applying the attribute Fixed_Variable to accounts. You can see that the attribute is applied to four different accounts in the Beaverton region. (It would also be applied to the appropriate accounts in the Eugene region, but those accounts are not shown.)

- You can attach a particular attribute to the dimension members of only one dimension in a model.

For example, in the following picture, if you have attached a particular attribute to the Beaverton dimension member (which is in the Region dimension), then you can
not attach the same attribute to the Drop Box dimension member because it is in the Channel dimension.

The reason for this restriction is to avoid conflicting attribute assignments. Suppose that you could attach the same attribute to dimension members in different dimensions. Take, for example, our previous example of the 2nd Day Guaranteed account whose dimension signature is Beaverton x Drop Box x 2nd Day Guaranteed. Suppose that the attribute AttributeOnDimensionMember has the value 100 when it is attached to the Beaverton dimension member. And, suppose that the same attribute has the value 99 when it is attached to the Drop Box dimension member. Then, when you apply attributes to accounts, the 2nd Day Guaranteed account will get the AttributeOnDimensionMember attribute from both the Beaverton dimension member and the Drop Box dimension member. But, in that case, what is its value? Is it 100 (from Beaverton) or 99 (from Drop Box)?

Attribute associations are periodic
When you attach an attribute to a dimension member, you attach it in a particular period. Consequently, a dimension member can have a particular attribute in one period but not in another. And, it can have one value in a particular period and a different value in another period.
**How are attribute values inherited from dimension members?**

When an attribute on a dimension member is applied to an account, and when there are additional attributes on dimension members in the same dimension hierarchy, then the first dimension member found up the hierarchy from the account is used.

For example, in the following picture the value of the attribute AttributeOnDimensionMember is 5 on the account, Portland x Drop Box x 2nd Day Guaranteed. It is 5 because there is no attribute on the Portland dimension member, so the account inherits the value 5 from the attribute AttributeOnDimensionMember on the parent dimension member, Oregon. The value of the attribute, AttributeOnDimensionMember, is 10 on the accounts that inherit from the Beaverton dimension member. The value is 15 on the accounts that inherit from the Eugene dimension member.

**What are the default values for such attributes?**

Because attributes on dimension members are ordinary attributes, once they have been applied to accounts, they have the same default values as ordinary attributes:

- For attributes with a user-defined default value for the active period/scenario, the attribute is initialized with the user-defined default value.
- Numeric attributes that do not have a user-defined default value are initialized with zero. Calculated numeric attributes are initialized with the result of their formula.
- Text attributes are initialized with an empty string.
- Tag attributes and dimension attributes do not have a value, so they are not initialized with a default value.

Despite the existence of default values, an error occurs during calculation if an attribute is referenced in a formula and both of the following conditions are true:

- the attribute has no user-defined default value, and
• the attribute is not attached to the account whose formula is being evaluated (for the period being calculated).

If either of the preceding conditions is false, then no error occurs during calculation. That is, no error occurs if either of the following conditions is true (the negations, respectively, of the preceding conditions):

• the attribute has a user-defined default value (even if it is not attached to the account whose formula is being evaluated), or

• the attribute is attached to the account whose formula is being evaluated (even if it has no user-defined default value).

System-generated versus user-entered attribute values
When an attribute on a dimension member is applied to an account, the account receives the attribute with its default value, if one is defined for that period/scenario. The following question then arises:

• What happens if you edit the attribute on that account to modify the value, and subsequently you re-apply the attributes on dimension members to accounts? Does the attribute on the account once again receive its default value, or does it retain its modified value?

• The answer is that it retains its modified value.

SAS Activity-Based Management distinguishes between system-generated attribute values and user-entered attribute values:

• A system-generated attribute value is the value that an attribute on an account receives when the attribute is applied to the account in virtue of having been attached to a dimension member.

• A user-entered attribute value is the value that an attribute on an account receives when you, the user, modifies the attribute value.

  Note: An attribute value is considered to be user-entered even if you overwrite the attribute value with exactly the same value. It is sufficient to type into the attribute value field, no matter what you type.

Once an attribute value is marked as user-entered, the only way in which it can be returned to system-generated (if you want to return to using its default value) is by doing the following:

1. Remove the attribute from the dimension member. (That is, remove the association between the attribute and the dimension member—this does not mean deleting the attribute itself.)

2. Re-attach the attribute to the dimension member with the default value desired.

3. Re-apply attributes on dimension members to accounts (or perform a calculation, which automatically re-applies attributes on dimension members).

  Note: Tag attributes and dimension attributes do not have a value, so the question of their default value does not arise.

What happens when a dimension member is re-parented?
When you re-parent a dimension member, accounts that have that dimension member in their signature can no longer inherit attributes from the old parent of that dimension member (assuming that the old parent is another dimension member). They now inherit attributes from the new parent (assuming, again, that the new parent is another dimension member).
Note: The new inheritance and the termination of the old inheritance does not take place until either:

- You apply attributes on dimension members to accounts.
- You calculate the model (which automatically applies attributes on dimension members to accounts).

For example, in the following picture, Portland is moved out from under Oregon to be directly under USA. This means that accounts whose dimension signature includes Portland no longer can inherit from any attributes on the Oregon dimension member.

---

**Importing and exporting attributes on dimensions**

When you export a model, the associations of attributes with dimension members are exported. If you subsequently import the same model, then dimension members have the same attributes that they had when the model was exported.

However, if before exporting the model you either apply attributes on dimension members to accounts or calculate the model (which automatically applies attributes on dimension members to accounts), then

- System-generated attribute values are not exported to an XML export file. However, user-entered attribute values are exported to an XML export file.

  If you subsequently import that XML file, then in order to regenerate attribute associations, you must either apply attributes on dimension members to accounts or you must calculate the model.

- Both system-generated attribute values and user-entered attribute values are exported to a staging-table export file in a database.
If you subsequently import that staging-table, then it is not necessary to regenerate attribute associations. Both system-generated attribute values and user-entered attribute values, having been stored in the staging table, are restored in the model.

**See Also**

- “Attach an Attribute to a Dimension Member” on page 207
- “Remove Attributes from Dimension Members” on page 212
- “Apply Attributes-on-Dimension-Members to Accounts” on page 214

---

### Attach an Attribute to a Dimension Member

**Introduction**

Attaching attributes to dimension members is done in two stages:

- “Define the Attribute Columns to be Displayed in the Dimensions View” on page 207
- “Attach Attributes to Dimension Members” on page 210

**Define the Attribute Columns to be Displayed in the Dimensions View**

1. Select **Model ➔ Dimensions** to open the Dimensions view of the model for which you want to apply attributes.

2. Select **Model ➔ Column Layout ➔ Edit Columns** to open the Column Layout dialog box.

   **Note:** You can also double-click the column header.

   ![Double-click to edit](image)

   ![Drop down to select](image)

   The Column Layout dialog opens, showing the layout for the Dimensions view.
3. Select and add the attributes that you want to display in the column layout so that you can attach them to dimension members.

For each attribute that you select, specify the following:

**Column Name**

The column name is the name that is displayed in the Dimensions view to identify an attribute on a dimension member. It is an arbitrary name that you can assign to enable you to recognize an attribute. It might identify the period and scenario in which the attribute is assigned so that you can distinguish different instances of the same attribute applied to different periods and scenarios.

**Period/Scenario**

The period and scenario in which this attribute is applied when it is applied to an account. Attributes on dimension members are periodic. They can have different values in different periods and scenarios.

**Format**

Click the format icon to open the Format Column dialog to format the column display of the attribute.
**Note**: The following fields of the Column Layout dialog are not modifiable. They are for information only:

**Field Name**

The Field Name is the name of the attribute that you assigned to it when you created it.

**Type**

- Tag attribute (Boolean)
- Dimension attribute
- Numeric attribute
- Text attribute

These fields are not modifiable

4. Click **Save As** if you want to save the column layout.
5. Click **OK**.

The Column Layout dialog closes and returns to the Dimensions view, with the attribute columns displayed that you just defined.

**Note:** The attributes are not yet attached to any dimension members. You have only determined what attribute columns to display.

---

**Attach Attributes to Dimension Members**

There are two ways to attach an attribute to a dimension member:

- Attach attributes using the Dimensions view
- Attach attributes using the Manage Attributes dialog

**Attach attributes using the Dimensions view**

After defining the attribute columns to be displayed in the Dimensions view, type the attribute value (or select the value for a dimension attribute) in the column cell for a dimension member.
**Attach an Attribute to a Dimension Member**

The period to which the value that you type applies is the period specified for this column in the Column Layout dialog, as shown for example in the following picture:

**Note:** You can use the Dimensions view for attaching the following types of attributes:

- Text
- Numeric (non-calculated)
- Dimension

You can not use this method for attaching the following types of attributes:

- Calculated numeric (because you don't enter its value—it is calculated)
- Tag (because it does not have a value that you can type)

**Attach attributes using the Manage Attributes dialog**

To use the Manage Attributes dialog:

1. Select **Model ⇒ Dimensions** to open the Dimensions view of the model for which you want to apply attributes.

2. Select a period/scenario association. The period/scenario that you select is the period/scenario in which any attribute that you add will apply.

3. Select a dimension member, right-click, and select **Manage Attributes**.

The Manage Attributes dialog opens.
4. Select the attributes that you want to attach to the dimension member.
5. Click OK.

See Also

“Remove Attributes from Dimension Members” on page 212

Remove Attributes from Dimension Members

There are three ways in which you can remove the association of attributes with dimension members:

• Remove a particular attribute from a dimension member
• Remove all attributes from a dimension member
• Remove attributes using the Manage Attributes dialog

Remove a particular attribute from a dimension member

To remove a particular attribute from a dimension member:
1. Select Model ➔ Dimensions to open the Dimensions view.
2. Right-click on the cell where the column for the attribute to be deleted intersects the row of the dimension member from which the attribute is to be removed (see the following picture), and select Delete Attribute Association.
Remove all attributes from a dimension member

To remove all attributes from a dimension member:

1. Select **Model ➔ Dimensions** to open the Dimensions view.
2. Right-click on the dimension member from which you want to remove all attributes, and select **Delete All Attribute Associations**.

Remove attributes using the Manage Attributes dialog

To use the Manage Attributes dialog:

1. Select **Model ➔ Dimensions** to open the Dimensions view.
2. Select a dimension member, right-click, and select **Manage Attributes**.
   
   The Manage Attributes dialog opens.
3. Select the attribute that you want to remove from the dimension member, and then click Remove.

4. Click OK to close the Manage Attributes dialog.

---

### Apply Attributes-on-Dimension-Members to Accounts

After attaching attributes to dimension members, you can apply the attributes to individual accounts. For each attribute on a dimension member, the attribute is added to every account whose dimension signature includes that dimension member.

**Note:** It is not necessary to perform this action because it is done automatically whenever you calculate a model. However, you can do it before performing a calculation if you want to see attributes applied to accounts.

1. Select **Model ➔ Apply Attributes to Accounts** from the Dimensions view.

The Apply Attributes to Accounts dialog opens.

2. Select the period/scenario associations whose attributes on dimension members you want to apply to accounts.
3. Click **OK**.

### See Also

- “Attributes on Dimension Members” on page 197
- “Attach an Attribute to a Dimension Member” on page 207
# Chapter 21

## Windows for Attributes

<table>
<thead>
<tr>
<th>Attributes View</th>
<th>218</th>
</tr>
</thead>
<tbody>
<tr>
<td>About the Attributes View</td>
<td>218</td>
</tr>
<tr>
<td>How to Access the Attributes View</td>
<td>218</td>
</tr>
<tr>
<td>Create an Attribute Folder</td>
<td>218</td>
</tr>
<tr>
<td>Create a Dimension Attribute</td>
<td>219</td>
</tr>
<tr>
<td>Create an Attribute</td>
<td>219</td>
</tr>
<tr>
<td>Delete an Attribute</td>
<td>219</td>
</tr>
<tr>
<td>Review or Change the Properties of an Item</td>
<td>219</td>
</tr>
<tr>
<td>Show the Accounts to Which an Attribute Has Been Added</td>
<td>219</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>New Attribute Dialog Box</th>
<th>219</th>
</tr>
</thead>
<tbody>
<tr>
<td>About the New Attribute Dialog Box</td>
<td>220</td>
</tr>
<tr>
<td>How to Access the New Attribute Dialog Box</td>
<td>220</td>
</tr>
<tr>
<td>Specify Information</td>
<td>220</td>
</tr>
<tr>
<td>Specify Advanced Information for a Numeric Attribute</td>
<td>220</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Manage Attributes Dialog Box</th>
<th>220</th>
</tr>
</thead>
<tbody>
<tr>
<td>About the Manage Attributes Dialog Box</td>
<td>221</td>
</tr>
<tr>
<td>How to Access the Manage Attributes Dialog Box</td>
<td>221</td>
</tr>
<tr>
<td>Add an Attribute</td>
<td>221</td>
</tr>
<tr>
<td>Remove an Attribute</td>
<td>221</td>
</tr>
<tr>
<td>Specify an Attribute's Value</td>
<td>221</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Attribute Properties Dialog Box</th>
<th>221</th>
</tr>
</thead>
<tbody>
<tr>
<td>About the Attribute Properties Dialog Box</td>
<td>222</td>
</tr>
<tr>
<td>How to Access the Attribute Properties Dialog Box</td>
<td>222</td>
</tr>
<tr>
<td>Specify Information</td>
<td>222</td>
</tr>
<tr>
<td>Specify Advanced Information for a Numeric Attribute</td>
<td>222</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Find Property or Attribute Dialog Box</th>
<th>223</th>
</tr>
</thead>
<tbody>
<tr>
<td>How to Access the Find Property or Attribute Dialog Box</td>
<td>223</td>
</tr>
<tr>
<td>Find a Property or Attribute</td>
<td>223</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Item Properties and Attributes Dialog Box</th>
<th>223</th>
</tr>
</thead>
<tbody>
<tr>
<td>About the Item Properties and Attributes Dialog Box</td>
<td>223</td>
</tr>
<tr>
<td>How to Access the Item Properties and Attributes Dialog Box</td>
<td>223</td>
</tr>
<tr>
<td>Review Information</td>
<td>223</td>
</tr>
<tr>
<td>Review or Change Properties and Attributes</td>
<td>224</td>
</tr>
<tr>
<td>Specify Measures to Use with SAS Strategy Management</td>
<td>224</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Search for Properties and Attributes Dialog Box</th>
<th>224</th>
</tr>
</thead>
<tbody>
<tr>
<td>About the Search for Properties and Attributes Dialog Box</td>
<td>225</td>
</tr>
<tr>
<td>How to Access the Search for Properties and Attributes Dialog Box</td>
<td>225</td>
</tr>
<tr>
<td>Select an Item</td>
<td>225</td>
</tr>
</tbody>
</table>
Attributes View

About the Attributes View

The availability of this feature depends on your permissions.

On the Attributes view, you can manage a model’s attributes.

<table>
<thead>
<tr>
<th>Name</th>
<th>Reference</th>
<th>Type</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Average Time to Expire</td>
<td>Average Time to Exp</td>
<td>Numeric</td>
<td>Hours</td>
</tr>
<tr>
<td>Completed Expedite Requests</td>
<td>Completed Expedite R</td>
<td>Numeric</td>
<td>Completed Requests</td>
</tr>
<tr>
<td>Cost per Inspection</td>
<td>Cost per Inspection</td>
<td>Numeric</td>
<td>Dollars</td>
</tr>
<tr>
<td>Fixed Variable</td>
<td>FV</td>
<td>Dimension</td>
<td></td>
</tr>
<tr>
<td>Inspections Passed</td>
<td>LP</td>
<td>Numeric</td>
<td>Units Passed</td>
</tr>
<tr>
<td>Number of Inspections</td>
<td>Num of Ins</td>
<td>Numeric</td>
<td>Inspections</td>
</tr>
<tr>
<td>Percent of Inspections Passed</td>
<td>Percent of Inspections</td>
<td>Numeric</td>
<td>Percentage</td>
</tr>
</tbody>
</table>

Note: You cannot directly edit the information on the Attributes view.

How to Access the Attributes View

Open a model in Model mode and select Model ➔ Attributes View.

Create an Attribute Folder

1. Select an attribute folder (other than a dimension attribute folder) within which to create the new folder.

2. Select Edit ➔ New Folder.

The New Attribute Folder dialog box appears.

Note: To create a dimension attribute, follow these directions.
Create a Dimension Attribute

1. Select ATTRIBUTES or an existing dimension attribute.
2. Select Edit ⇒ New Attribute.
   The New Attribute dialog box appears.

Create an Attribute

1. Select an attribute folder within which to create the new attribute.
2. Select Edit ⇒ New Attribute.
   The New Attribute dialog box appears.

Delete an Attribute

1. Select an attribute.
2. Select Edit ⇒ Delete.

Review or Change the Properties of an Item

1. Select an item.
2. Select Edit ⇒ Item Properties.
   If you selected an attribute folder, the Edit Attribute Folder dialog box appears.
   If you selected an attribute, the Attribute Properties dialog box appears.

Show the Accounts to Which an Attribute Has Been Added

1. Select Model ⇒ Assignments ⇒ Show Right Assignments Pane.
   The right assignments pane is displayed.
2. Select an attribute.
3. Select Model ⇒ Assignments ⇒ Show Right.
   If the attribute has been added to any accounts, then those accounts are displayed.
New Attribute Dialog Box

About the New Attribute Dialog Box

In the New Attribute dialog box, you can name a new attribute and you can specify other information about the attribute. You can create a dimension attribute folder.

Note: The availability of these features depends on your permissions.

How to Access the New Attribute Dialog Box

On the Attributes view, select either an attribute folder or ATTRIBUTES and select Edit ⇒ New Attribute.

Specify Information

1. Type the Name.
2. Type the Reference.
   
   A default reference is created from the name. If you change the reference, the new reference must follow the reference conventions. (See “Reference Conventions” on page 86.)
3. Select the Attribute type.
   
   Note: If you select Dimension when either ATTRIBUTES or an existing dimension attribute is selected, you will create a dimension attribute folder, not a dimension attribute.

If you selected the Numeric type, then perform the following steps:

1. (Optional) Type the Unit of measure.
2. Specify the advanced information.

Specify Advanced Information for a Numeric Attribute

1. Click the Advanced tab.
2. From the Using this period/scenario association menu, select a period/scenario association.
3. (Optional) Type the Default value.
4. If this is a calculated attribute, then perform the following steps:
   a. Select the Calculated option.
   b. Click Formula Builder.
      The Formula Builder dialog box appears.

TIP You can also modify the formula in the Formula dialog box.
Manage Attributes Dialog Box

About the Manage Attributes Dialog Box

The availability of these features depends on your permissions.

In the Manage Attributes dialog box, you can manage the attributes that have been added to an account.

How to Access the Manage Attributes Dialog Box

On the Resource module view, the Activity module view, the Cost Object module view, or the External Units module view, select an account and select Edit ⇒ Manage Attributes.

See Also

“Attributes View” on page 218

Add an Attribute

1. From the Attribute hierarchy list, select an attribute.
2. Click Add >.
   The attribute moves to the Account's attributes list.

Remove an Attribute

1. From the Account's attributes list, select an attribute.
2. Click < Remove.
   The attribute moves to the Attribute hierarchy list.

Specify an Attribute's Value

1. From the Account's attributes list, select an attribute.
2. Set the Value.
   The type of value that you can specify depends on the type of attribute.
Attribute Properties Dialog Box

About the Attribute Properties Dialog Box

In the Attribute Properties dialog box, you can review or change information about an attribute.

The availability of these features depends on your permissions.

How to Access the Attribute Properties Dialog Box

On the Attributes view, select an attribute, and select Edit ➔ Item Properties.

See Also

“Attributes View” on page 218

Specify Information

1. Click the General tab.
2. Type the Name. See “Naming Conventions” on page 81.
3. Type the Reference. See “Reference Conventions” on page 86.
   Note: The Attribute type is read-only.
4. If the Attribute type is Numeric, perform the following steps:
   a. (Optional) Type the Unit of Measure.
   b. Specify the advanced information.

Specify Advanced Information for a Numeric Attribute

1. Click the Advanced tab.
2. From the Using this period/scenario association menu, select a period/scenario association.
3. Type the Default value.
4. If this attribute is a calculated attribute, perform the following steps:
   a. Select the Calculated option.
   b. Click Formula Builder.
      The Formula Builder dialog box appears.
      TIP You can also modify the formula in the Formula box.

See Also

• “Numeric Attributes” on page 183
• “Calculated Attributes” on page 184
Find Property or Attribute Dialog Box

In the Find Property or Attribute dialog box, you can quickly find properties or attributes to search for accounts when building an account search query.

How to Access the Find Property or Attribute Dialog Box

In the Search for Accounts dialog box, click Find.

Find a Property or Attribute

1. In the Show menu, specify whether you want to find Properties, Attributes, or Both.
2. To quickly move through the list, type a phrase in the Search box.
   As you type the text, the item that most closely matches the text is selected.
3. Select an item from the list.
   The description of the item is displayed below the list.
   Note: Some items, such as attributes, might not have a description.

See Also

• “Search for Accounts Dialog Box” on page 167
• “Search Account Results Dialog Box” on page 168

Item Properties and Attributes Dialog Box

About the Item Properties and Attributes Dialog Box

The availability of these features depends on your permissions.

In the Item Properties and Attributes dialog box, you can see the properties and attributes of an item that you have selected on any Model mode view, except the Drivers view.

How to Access the Item Properties and Attributes Dialog Box

On any Model mode view, except the Drivers view, select an item and then select Edit ⇒ Item Properties.

Review Information

To review information, do the following:

• Click the General tab.
The **General** tab displays information about the selected item, such as Display name, Dimensional identifier, Display reference, and Type.

**Review or Change Properties and Attributes**

1. Click the **Properties** tab or the **Attributes** tab.
   
   The **Attributes** tab is displayed only if the item has attributes.

2. To search for a property, click **Search**.
   
   The Search for Properties and Attributes dialog box appears.

   **Note:** If the property that you are searching for is found, that property is selected in the Item Properties and Attributes dialog box. If no property is selected, then the item does not contain that property.

3. If an item in the Name list can be edited, type or select a Value.

**Specify Measures to Use with SAS Strategy Management**

You can specify SAS Activity-Based Management model properties and attributes that you want to publish as performance measures. See General steps for integrating with SAS Strategy Management for more information.

1. Click the **Performance Measures** tab.

   The **Performance Measures** tab displays a list of performance measures (numeric properties and attributes) that are available for publishing to SAS Strategy Management.

2. Type a name for the set of selected properties and attributes in the **Publish name** field.

   **Note:** The **Publish name** field cannot contain more than 32 characters long. By default the **Publish name** is the selected item's Display reference. (You can change the **Publish name** without changing the Display reference.) A **Publish name** of more than 32 characters can result in the following error messages when publishing to SAS Strategy Management: No hierarchy found with code ... or No member found with code .... The reason is that the name is truncated to 32 characters during publishing. These messages can also result if names do not match exactly, including matching for case.

3. Select the check box next to the numeric properties and attributes that you want to publish as performance measures to SAS Strategy Management.

   **Note:** Only numeric properties and attributes can be published to SAS Strategy Management.
Search for Properties and Attributes Dialog Box

About the Search for Properties and Attributes Dialog Box

In the Search for Properties and Attributes dialog box, you can find data to display when you add a column, or you can find a property when you review the properties of an item or when you review the attributes of an item.

How to Access the Search for Properties and Attributes Dialog Box

Do one of the following:

- In the Column Layout dialog box, click Search.
- In the Item Properties dialog box, click Search.

Select an Item

1. From the Show menu, select the items to display.
2. To quickly move through the list, type a phrase in the Search box.
   As you type the text, the item that most closely matches the text is selected.
3. Select an item from the list.
   The description of the item is displayed below the list.

   Note: Some items, such as attributes, might not have a description.

Attribute Folder Properties Dialog Box

About the Attribute Folder Properties Dialog Box

The availability of this feature depends on your permissions.

In the Attribute Folder Properties dialog box, you can review or change information about an attribute folder.

How to Access the Attribute Folder Properties Dialog Box

On the Attributes view, select a folder, and select Edit ⇒ Item Properties.

Specify Information

1. Click the General tab.
2. Type the Name. See “Naming Conventions” on page 81.
New Attribute Folder Dialog Box

About the New Attribute Folder Dialog Box
In the New Attribute Folder dialog box, you can name a new folder and you can specify
the folder's reference.

Note: The availability of these features depends on your permissions.

How to Access the New Attribute Folder Dialog Box
On the Attributes view, select an item and select Edit ⇒ New Folder.

See Also
“Attributes View” on page 218

Specify Information

1. Type the Name.
2. Type the Reference.
   A default reference is created from the name. If you change the reference, the new
   reference must follow the reference conventions.
Part 8

Column Layouts

Chapter 22
Working with Column Layouts ........................................ 229

Chapter 23
Windows for Column Layouts ........................................ 245

Chapter 24
Adding Properties to a Column Layout ............................... 251
Chapter 22
Working with Column Layouts

Column Layouts ................................................................. 229
   About Column Layouts .................................................. 230
   Showing Multiple Period/Scenario Associations ................... 231
   Saving a Column Layout ................................................ 231
   Importing and Exporting a Column Layout ......................... 231
   Predefined Column Layouts ............................................. 231
   Default Column Layout ................................................ 232

Add a Column ................................................................. 232

Remove a Column ............................................................ 234

Order Columns ............................................................... 234

Format a Column ............................................................ 234
   Overview ......................................................................... 234
   How to Format ................................................................ 235
   Color, Style, and Alignment ............................................. 236
   Currency Type ................................................................ 236
   Number Type .................................................................. 237
   Percentage Type .......................................................... 237
   Text Type ....................................................................... 237
   Checkbox Type ................................................................ 237
   Available Format Types ................................................ 237
   Negative Numbers ........................................................ 237
   Precision ....................................................................... 238
   Currency Formatting ...................................................... 238
   Displaying the Currency Symbol ..................................... 238

Conditionally Highlight Cells in a Column .......................... 239
   Overview ......................................................................... 239
   Highlight Additional Cells .............................................. 240
   Remove Highlighting ...................................................... 241
   Save the Highlighting ..................................................... 242
   Conditions ..................................................................... 242

Select the Period to which the Column Refers ..................... 243

Save a Column Layout ........................................................ 243

Apply a Saved Column Layout ............................................ 243

Copy a Column Layout to another Module ........................... 244
Column Layouts

About Column Layouts

SAS Activity-Based Management displays information in user-defined columns in a grid. You can specify how information in the columns appears. When you are satisfied with the appearance, you can save the display configuration as a saved column layout. At a later time, you can display the saved column layout and the columns will be displayed like they were when you saved the column layout. You can import a column layout and export a column layout.

Note: Adding or removing columns from the grid provides a view of tables. It does not affect the data in the tables. Select Model ⇒ Column Layout ⇒ Edit Columns to add or remove columns. Or, double-click the column header to open the Column Layout dialog box.

Note: The Display Name column, which is the left-most column in the column layout, is always required, so you cannot remove it, change it, or reorder it.

In addition, SAS Activity-Based Management provides several predefined column layouts, which can be applied to a model.

Each column in a grid in SAS Activity-Based Management displays a property. A property refers to any model item that holds the values that were entered by a user or that were calculated by SAS Activity-Based Management.

A column layout is a collection of displayed columns, column formats, and the column order. You can customize column layouts on the following views to display various information, such as properties, attributes, periods, and scenarios:

- the Resource module
- the Activity module
- the Cost Object module
- the External Units module

Note: The Display Name column, which is the left-most column in the column layout, is required, so you cannot remove it, change it, or reorder it.

When you save a customized column layout, you assign a name to the layout so that you can retrieve it later. If a model is open, the column layout is applied to that model. If you select a column layout from Workspace Manager when a model is not open, the original
model that was saved with the column layout is opened. The selected column layout is applied to that model, and the Resource module is opened.

Each named column layout has four different aspects, one for each module. For example, instead of creating different named column layouts for each module, such as My Favorite for Resource module or My Favorite for Activity module, you can create one column layout named My Favorites that changes based on which module is displayed.

All column layouts that have been saved by all users on the same server are listed in Workspace Manager. Therefore, your organization might want to set up guidelines for saving and naming column layouts.

Showing Multiple Period/Scenario Associations

By default, a new column displays values for a model's current period/scenario association. When you want to compare measures across period/scenario associations, create columns that have different period/scenario associations.

Saving a Column Layout

SAS Activity-Based Management stores your saved column layouts in the Column Layouts folder in Workspace Manager. When you save a column layout, the following information is saved:

- the description
- the column headings
- the information that is displayed in each column, and the period/scenario association to which the information pertains
- the format for each column, and the order of the columns from left to right
- the model
- the column widths
- the open module

The following information is not saved:

- the number of assignments panes that are visible

Importing and Exporting a Column Layout

SAS Activity-Based Management enables you to work with column layouts that have already been created. You can import a column layout or export a column layout and apply it to a model.

Predefined Column Layouts

SAS Activity-Based Management provides several predefined column layouts (including the Default column layout) that are designed for common business uses. These predefined column layouts are located in the Column Layouts ⇒ System folder in Workspace Manager.

Note: Predefined column layouts cannot be modified.
Default Column Layout

The default column layout is the column layout that is shown to all users by default, before any columns are added or removed and before any columns are formatted. The columns that are included are Display Name, Display Reference, and Cost.

After changing the default column layout, do not save the column layout. If you save changes to the default column layout, the default column layout is changed for all users. Instead, save your changes to the default column layout in a separate column layout.

Note: The column Display Name is the system-generated name for an item, not the name that you choose or that you can edit. To display the name that you can edit, add to the grid a column to display the property Name.

See Also

• “Add a Column” on page 232
• “Format a Column” on page 234

Add a Column

1. On a module page, select Model ➔ Column Layout ➔ Edit Columns.

   Tip Alternatively, you can double-click a column heading.

   The Column Layout dialog box appears.

2. Select the Module to which this column layout applies.

3. From the list of Displayed columns, select the pane from the appropriate tab (Left, Primary, or Right) to which you want to add the column.

4. From the list of Properties, Attributes, and Dimensions, select an item.

5. To search for an item, do the following:
a. Click Search.

The Search for Properties and Attributes dialog box appears.

b. From the Show drop-down list, select the items to display.

c. To rapidly move through the list of items, type a phrase in the Search box.

As you type text, the item that most closely matches the text is selected.

d. Select an item from the list.

The Description of the item is displayed.

*Note:* Some items, such as attributes, might not have a description.

e. Click OK.

6. Click Add >.

7. To rename the column, click the Column Name of the new row, and type a new name.

This text is displayed in the column heading of the column layout.

8. To select a different period/scenario association, click in the Period/Scenario column, and select a period/scenario association.

*Note:* If your column layout has too many column headings to be able to view in a window all at once, you can use the scroll wheel of the mouse to scroll the column headings.
Remove a Column

1. On a module page, select Model ⇒ Column Layout ⇒ Edit Columns.
   The Column Layout dialog box appears.
2. Select the Module to which this column layout applies.
3. From the list of Displayed columns, select the pane from the appropriate tab (Left, Primary, or Right) from which you want to remove the column.
4. Select a row (which represents a column in the view).
5. Click < Remove.
   The row (column) is removed from the list of Displayed columns.

Order Columns

1. On a module page, select Model ⇒ Column Layout ⇒ Edit Columns.
   The Column Layout dialog box appears.
2. Select the Module to which this column layout applies.
3. From the list of Displayed columns, select the pane from the appropriate tab (Left, Primary, or Right) that you want to order.
4. Select a row (which represents a column in the view).
5. To move the row up, click Move Up.
   The column will be moved to the left.
6. To move the row down, click Move Down.
   The column will be moved to the right.

TIP You can drag columns on the following pages: the Resource module page, the Activity module page, the Cost Object module page, and the External Units module page.

Format a Column

Overview

When you add a column to the following views, SAS Activity-Based Management assigns default formatting to the columns:

- Resource module
- Activity module
How to Format

1. On the Resource module page, the Activity module page, the Cost Object module page, or the External Units module page, select Model ⇒ Column Layout ⇒ Edit Columns.

   The Column Layout dialog box appears.

2. In a row that represents the column that you want to format, click .

   The Format Column dialog box appears.
3. In the **Type and Size** section, select the **Type** of data.

4. For **Display values using this currency**, select or clear an option.

5. From the **When viewing negative numbers use** drop-down list, select or clear an option.

6. Specify the precision:
   - Select or clear the **Override default precision** option.
   - Set a value for the number of **decimal places**.

7. To quickly set the width of a column so that the column is wide enough to display all data, select the **Size column to text** option.

8. In the **Font settings** section, select or clear options for **Alignment**, **Style**, and **Color**.

### Color, Style, and Alignment

To highlight important information, you can specify the foreground color and the background color for a column. Also, you can specify the font style, such as bold or italic, and the alignment of data within a column, such as right-aligned or left-aligned.

To ensure that columns are not too wide or too narrow for their contents, you can specify that column widths should change according to the width of each column's contents.

### Currency Type

The Currency type displays column values as currency. A column can display either the model's base currency or a currency that was specified in an exchange rates table. You can select any available currency, including the currencies that are not specified in an exchange rates table. If you select a currency that does not have an exchange rate, all of the column values are displayed as zeros.
**Number Type**

The Number type displays column values as numbers.

**Percentage Type**

The Percentage type displays column values by multiplying each value by 100 and then appending the percentage symbol (%).

*Note:* The Percentage type pertains only to individual column values. The percentage that each column value contributes to the total of all the column values is not calculated.

**Text Type**

The Text type displays column values as text.

**Checkbox Type**

The Checkbox type displays column values as check boxes. Each cell is either checked or not checked.

**Available Format Types**

The format types that are available for a specific column depend on the data in the column. For example, a column that contains text cannot be formatted to display as percentages or as numbers because the underlying data is not numeric. The following table lists the format types for underlying data:

<table>
<thead>
<tr>
<th>Underlying data</th>
<th>Available format types</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Text</td>
</tr>
<tr>
<td>Cost or rate</td>
<td>Currency (default)</td>
</tr>
<tr>
<td></td>
<td>Number</td>
</tr>
<tr>
<td>Number or quantity</td>
<td>Number (default)</td>
</tr>
<tr>
<td></td>
<td>Currency</td>
</tr>
<tr>
<td></td>
<td>Percentage</td>
</tr>
<tr>
<td>Percentage</td>
<td>Percentage (default)</td>
</tr>
<tr>
<td></td>
<td>Number</td>
</tr>
<tr>
<td>Boolean</td>
<td>Checkbox</td>
</tr>
</tbody>
</table>

**Negative Numbers**

You can specify how negative numbers are displayed. The default appearance for negative numbers is based on your Windows regional settings.
**Precision**

Precision is the number of decimal places that are displayed for numbers in a column. Your user options affect precision.

**Tip** Before you add new columns, set the default precision in your user options. Then, set the precision for any column in which you want the precision to be different from the default precision.

**Note:** For the following properties, if you select the Percentage type, each column value can have only two decimal places:
- Driver Percentage
- Idle Percentage

**Currency Formatting**

The number of decimal places that you specify in your options overrides the No. of digits after decimal setting in Windows Regional Options.

<table>
<thead>
<tr>
<th>Change this</th>
<th>in this dialog box.</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Positive currency format</td>
<td>Customize Regional Options</td>
<td>1,1 F</td>
</tr>
<tr>
<td>Negative currency format</td>
<td>Customize Regional Options</td>
<td>-1,1 F</td>
</tr>
<tr>
<td>Decimal symbol</td>
<td>Customize Regional Options</td>
<td>,</td>
</tr>
<tr>
<td>No. of digits after decimal</td>
<td>Customize Regional Options</td>
<td>2</td>
</tr>
<tr>
<td>Digit grouping symbol</td>
<td>Customize Regional Options</td>
<td>a space</td>
</tr>
<tr>
<td>Digit grouping</td>
<td>Customize Regional Options</td>
<td>123 456 789</td>
</tr>
</tbody>
</table>

**Displaying the Currency Symbol**

You can add columns on the Resource module view, the Activity module view, and the Cost Object module view to display different currencies in the same display.

You can choose to display the currency symbol as part of the number formatting, or in column headings. If you choose to display the currency symbol in column headings, then you can choose to display the currency symbol, the currency code, both, or neither. You might want to display only the currency code if your computer's fonts do not support currency symbols.
Conditionally Highlight Cells in a Column

Overview

With conditional highlighting of cells, you can change the text and background color of the cells in a column that satisfy conditions that you specify. For example, you can highlight in red all the Cost cells that contain a negative value. Or, you can highlight text cells with a particular content.

To conditionally highlight cells in a column:
1. Open the Column Layout dialog. See “Column Layout Dialog Box” on page 245.
2. Select a column whose cells you want to highlight.
3. Click the Conditions icon.
4. Specify a condition that determines which cells are to be highlighted. For allowable conditions, see “Conditions” on page 242.
5. Specify the highlighting that is to be applied to each cell whose data satisfies the condition specified. You can specify:
   • Background color
   • Text color
6. Click Add to select additional cells for highlighting. For each set of additional cells selected, you can specify different highlighting. See “Highlight Additional Cells” on page 240.
Highlight Additional Cells

For each column, you can select more than one set of cells for highlighting. For each set of cells selected, you can specify different highlighting.

To select more than one set of cells in a column for highlighting, do the following:

1. From the Column Layout dialog box, click the Conditions icon.

The Conditional Formatting dialog opens.

2. Specify a condition that determines which cells are to be highlighted.

3. Specify the highlighting that is to be applied to each cell whose data satisfies the condition specified.

4. Click Add to select additional cells for highlighting. For each set of additional cells selected, you can specify different highlighting.

The following picture shows highlighting cells in the Profit column as follows:

<table>
<thead>
<tr>
<th>Cells</th>
<th>Condition</th>
<th>Highlighting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set 1</td>
<td>is less than 0</td>
<td>Background: red</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Text: white</td>
</tr>
</tbody>
</table>
Cells | Condition | Highlighting
---|---|---
Set 2 | is greater than 500,000 | Background: green
 |  | Text: black

Remove Highlighting

To remove the highlighting from cells:
1. On the Conditional Formatting window, click **Delete**.
2. Select the condition to be deleted.
3. Click **OK**.
Save the Highlighting

To save the conditional highlighting specifications, select **Save** or **Save As** from the Column Layout dialog.

The conditional highlighting specifications are saved along with the column layout. They persist with the column layout if the column layout is exported and subsequently imported.

Conditions

The conditions that you can specify to select cells for highlighting depend on the type of column selected. The conditions are as follow:

**Numeric Columns**

You can select cells in a numeric data column by using the following conditions:

- is equal to
- is not equal to
- is between
- is greater than
- is greater than or equal to
- is less than
- is less than or equal to

**Text Columns**

You can select cells in a text data column by using the following conditions:

- is equal to
- is not equal to

**Boolean Property Columns**

You can select cells in a Boolean property column (such as HasAttribute) by using the following conditions:

- is checked
Tag Attribute Columns
You can select cells in a tag attribute column by using the following condition:
• is checked

Select the Period to which the Column Refers

From the Period/Scenario drop-down menu, select the period/scenario association to which the data in the column refers.

Note: <<Current>> refers to the period/scenario association currently displayed in the module view or dimensions view to which the column layout is being applied.

Save a Column Layout
Select Model ➔ Column Layout ➔ Save.
The Save Column Layout As dialog box appears.

Apply a Saved Column Layout

Note: You can apply a saved column layout to the following views: the Resource module, the Activity module, Cost Object module, External Units module, and the Dimensions view.

1. From the Column Layout drop-down list, select a column layout.
2. Click 🔄.

---

**Copy a Column Layout to another Module**

1. On the page to which you want to copy a column layout (the Resource module page, the Activity module page, the Cost Object module page, or the External Units module page), select Model ⇒ Column Layout ⇒ Edit Columns.

   The Column Layout dialog box appears.

2. Click Copy From.

   The Copy Columns dialog box appears.

3. Select the module to copy From.

4. Select the assignments panes to copy from.
Chapter 23
Windows for Column Layouts

Column Layout Dialog Box

About the Column Layout Dialog Box

In the Column Layout dialog box, you can customize a column layout by managing the columns in the view and by formatting columns.

Rows represent columns in a column layout. The rows, from top to bottom, represent the column layout's columns, from left to right.
Note: The **Display Name** column, which is the left-most column in the column layout, is not displayed in this dialog box. The Display Name column is required, so you cannot remove it, change it, or reorder it.

**Icons**

Icons indicate whether each item in the column is a property, an attribute, or a dimension:

<table>
<thead>
<tr>
<th>This icon</th>
<th>Represents this</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Property Icon" /></td>
<td>Property</td>
</tr>
<tr>
<td><img src="image" alt="Attribute Icon" /></td>
<td>Attribute</td>
</tr>
<tr>
<td><img src="image" alt="Dimension Icon" /></td>
<td>Dimension</td>
</tr>
</tbody>
</table>

**How to Access the Column Layout Dialog Box**

- In the Resource module, Activity module, Cost Object module, External Units module, or Dimensions view, select **Model ➔ Column Layout ➔ Edit Columns**, or double-click the column header.
See Also

- Chapter 22, “Working with Column Layouts,” on page 229
- Chapter 23, “Windows for Column Layouts,” on page 245
- Chapter 24, “Adding Properties to a Column Layout,” on page 251

Format Column Dialog Box

In the Format Column dialog box, you can format the information in the columns in the Resource, Activity, Cost Object, and External Units modules, and in the Dimensions view.

How to Access the Format Column Dialog Box

In the Column Layout dialog box, select a row and click the <button> button.

The Format Column dialog box appears:

![Format Column Dialog Box](image_url)

See Also

“Column Layout Dialog Box” on page 245

Specify the Format

These steps are optional.

1. In the Type and Size section, select the Type of data.
   
   For more information, see About types.
2. For **Display values using this currency**, select or clear an option.
3. From the **When viewing negative numbers use** menu, select or clear an option.
4. Specify the **precision**:
   a. Select or clear the **Override default precision** option.
   b. Set a value for the number of decimal places.

1. To quickly set the width of a column so that the column is wide enough to display all data, select the **Size column to text** option.
2. In the Font settings section, select or clear options for Alignment, Style, and Color.

**See Also**

“Format a Column” on page 234

---

### Save Column Layout As Dialog Box

**About the Save Column Layout As Dialog Box**

In the Save Column Layout As dialog box, you can name a column layout.

**How to Access the Save Column Layout As Dialog Box**

Do one of the following:

- On the Resource module view, the Activity module view, the Cost Object module view, or the External Units module view, select **Model ➔ Column Layout ➔ Save As**.
- In the Column Layout dialog box, click **Save As**.

**Specify Information**

1. Select the **New column layout** option.
2. In the box on the right, type the name of the new column layout.
3. (Optional) Type the Description.

**Replace an Existing Column Layout**

1. Select the **Existing column layout** option.
2. From the menu on the right, select a column layout.
Copy Columns Dialog Box

About the Copy Columns Dialog Box

In the Copy Columns dialog box, you can copy a column layout from one module to another.

How to Access the Copy Columns Dialog Box

In the Column Layout dialog box, click Copy From.

Specify What to Copy

1. Select the module to copy from.
2. Select the assignments panes to copy from.
Chapter 24
Adding Properties to a Column Layout

Overview

This chapter discusses adding properties to column layouts for assignments panes.

Note: With the ability to add attributes to dimension members, you can also add properties to column layouts for the Dimensions view (see Chapter 20, “Attributes on Dimension Members,” on page 197). But, in this chapter, we are concerned only with adding properties to column layouts for assignments panes.

Assignments panes provide a window into accounts. The primary assignments pane shows all the accounts in the module to which the pane is attached. The left and right assignments panes provide a restricted (filtered) view of accounts:

• The left assignments pane shows accounts making assignments to the primary pane.
• The right assignments pane shows accounts receiving assignments from the primary pane.

The primary assignments pane shows accounts in one module only. Given the existence of intra-modular assignments (assignments within the same module), the right and left assignments panes can show accounts in more than one module.

Properties fall into the following categories:

assignment properties
refer to a particular assignment between accounts. Assignments are displayed in the narrow area between assignments panes, as shown in the following picture:
In a column layout, given that you cannot add properties in between assignments panes, the following question arises: if you attach an assignment property to one assignments pane, does it refer to an assignment to the left of that pane or to the right of it? The answer, as we shall see in more detail shortly, is to the left.

**Outgoing properties**
refer to costs flowing out of an account, across assignment paths, into one or more destination accounts. Outgoing properties are relational. They attach to an account, but they refer to cost flows to other accounts.

**Incoming properties**
refer to costs flowing into an account, across an assignment path, from one or more source accounts. Incoming properties are also relational. They refer to cost flows from other accounts.

**Account properties**
refer to accounts apart from any flow into or out of the account.

**Driver properties**
refer to drivers apart from any particular assignment between accounts.

### Assignment Properties

An assignment property describes a flow between accounts. Driver Quantity Fixed (DQF), for example for a percentage driver, specifies the percentage of an account’s cost that flows to each of its destination accounts. The DQF for one destination account can be, say, 60%, and 30% for a different destination account, and 10% for another.

Given that you attach properties only to assignments panes and not to the flow between panes, it makes most sense to attach assignment properties to the right assignments pane. The following picture shows why. Notice that in the right assignments pane, you can clearly see to which assignment path each DQF of 23,000 and 50,000, respectively, applies. By contrast, in the primary pane, you can see the DQF of 15,000, but to which incoming assignment does it apply? When there is more than one incoming assignment (in this case there are three), you cannot tell from the primary assignments panes to which assignment it applies. And the situation is even worse in the left assignments pane because you can’t see any of the incoming assignments. So, in short, attach assignment properties to the right assignments pane.
The following table lists assignment properties. The second column shows the properties whose value you can set in an assignments pane.

**Table 24.1 Assignment Properties**

<table>
<thead>
<tr>
<th>Property</th>
<th>Set By User?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Driver Allocated Cost</td>
<td>Yes</td>
</tr>
<tr>
<td>Driver Cost</td>
<td></td>
</tr>
<tr>
<td>Driver Driven Cost</td>
<td></td>
</tr>
<tr>
<td>Driver Driven Quantity</td>
<td></td>
</tr>
<tr>
<td>Driver Idle Cost</td>
<td></td>
</tr>
<tr>
<td>Driver Percentage</td>
<td></td>
</tr>
<tr>
<td>Driver Quantity Basic</td>
<td></td>
</tr>
<tr>
<td>Driver Quantity Calculated</td>
<td></td>
</tr>
<tr>
<td>Driver Quantity Fixed (DQF)</td>
<td>Yes</td>
</tr>
<tr>
<td>Driver Quantity Variable (DQV)</td>
<td>Yes</td>
</tr>
<tr>
<td>Driver Used Cost</td>
<td></td>
</tr>
<tr>
<td>Driver Weight Fixed (DWF)</td>
<td>Yes</td>
</tr>
<tr>
<td>Driver Weight Variable (DWV)</td>
<td>Yes</td>
</tr>
<tr>
<td>Idle Driver Quantity</td>
<td></td>
</tr>
<tr>
<td>Idle Driver Quantity UE</td>
<td>Yes</td>
</tr>
</tbody>
</table>

**Outgoing Properties**

An *outgoing property* refers to a cost flow going out of accounts across assignment paths to destination accounts. The following picture shows the DrvnCost property attached to
the left, primary, and right assignments panes. In every case, regardless of which pane the property is attached to, it shows something going out of an account to destination accounts.

The following table lists outgoing properties. The second column lists the properties whose value you can set in an assignments pane. With two exceptions, you can not set outgoing properties.

Table 24.2 Outgoing Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Set By User?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allocated Cost</td>
<td></td>
</tr>
<tr>
<td>Assigned Cost</td>
<td></td>
</tr>
<tr>
<td>Assigned Idle Cost</td>
<td></td>
</tr>
<tr>
<td>Assigned Idle Quantity</td>
<td></td>
</tr>
<tr>
<td>Assigned Non-Reciprocal Cost</td>
<td></td>
</tr>
<tr>
<td>Assigned Reciprocal Cost</td>
<td></td>
</tr>
<tr>
<td>Calculate Error</td>
<td></td>
</tr>
<tr>
<td>Drivable Cost</td>
<td></td>
</tr>
<tr>
<td>Driven Cost</td>
<td></td>
</tr>
<tr>
<td>Driven Quantity</td>
<td></td>
</tr>
<tr>
<td>Driver Rate</td>
<td></td>
</tr>
<tr>
<td>Has Idle Cost</td>
<td></td>
</tr>
<tr>
<td>Has Used Cost</td>
<td></td>
</tr>
<tr>
<td>Idle Cost</td>
<td></td>
</tr>
<tr>
<td>Idle Percentage</td>
<td></td>
</tr>
<tr>
<td>Idle Quantity</td>
<td></td>
</tr>
<tr>
<td>Total Driver Quantity (TDQ)</td>
<td></td>
</tr>
<tr>
<td>Total Driver Quantity Basic (TDQBasic)</td>
<td></td>
</tr>
<tr>
<td>Total Driver Quantity Calculated (TDQCalc)</td>
<td></td>
</tr>
</tbody>
</table>
Incoming Properties

An incoming property refers to cost flows coming into accounts, across assignment paths, from source accounts. The following picture shows Received Cost attached to the left, primary, and right assignments panes. In every case, regardless of which pane the property is attached to, the property shows costs flowing into an account from source accounts.

The following table lists incoming properties. Sold Quantity is the only incoming property whose value is not calculated automatically by the system.

Table 24.3  Incoming Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Set By User?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Has Assignments</td>
<td></td>
</tr>
<tr>
<td>Has BOC</td>
<td></td>
</tr>
<tr>
<td>Received Allocated Cost</td>
<td></td>
</tr>
<tr>
<td>Received Assignment Cost</td>
<td></td>
</tr>
<tr>
<td>Received BOC Cost</td>
<td></td>
</tr>
<tr>
<td>Received Cost</td>
<td></td>
</tr>
<tr>
<td>Received Driven Cost</td>
<td></td>
</tr>
</tbody>
</table>
Driver Properties

*Driver properties* are properties of a driver that are independent of any particular assignment. For example, Driver Name is the same for a given driver in all its assignment paths.

The following picture shows two driver properties (DrvName and DrvSeq) attached to all three assignments panes.

The following table lists driver properties. You can set driver properties only in driver dialogs, not in assignments panes.

### Table 24.4  Driver Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Set By User?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Received Idle Cost</td>
<td></td>
</tr>
<tr>
<td>Received Non-Reciprocal Cost</td>
<td></td>
</tr>
<tr>
<td>Received Reciprocal Cost</td>
<td></td>
</tr>
<tr>
<td>Received Used Cost</td>
<td></td>
</tr>
<tr>
<td>Sold Quantity</td>
<td>Yes</td>
</tr>
</tbody>
</table>
Account Properties

Accounts properties are properties of an account considered by itself, apart from any flow into or out of the account. For example, Entered Cost is an account property and not an outgoing property because it may or may not flow out of the account to which it is attached. The following picture shows the account property (EntCost) attached to all three assignments panes.

The following table lists account properties.

Table 24.5  Account Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Set By User?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost</td>
<td></td>
</tr>
<tr>
<td>Entered Cost</td>
<td>Yes</td>
</tr>
<tr>
<td>Has Attributes</td>
<td></td>
</tr>
<tr>
<td>Has Entered Cost</td>
<td></td>
</tr>
<tr>
<td>Has Notes</td>
<td></td>
</tr>
<tr>
<td>Is Behavior</td>
<td></td>
</tr>
<tr>
<td>Profit</td>
<td></td>
</tr>
<tr>
<td>Output Quantity</td>
<td></td>
</tr>
<tr>
<td>Output Quantity UE</td>
<td>Yes</td>
</tr>
<tr>
<td>Revenue</td>
<td>Yes</td>
</tr>
<tr>
<td>Unit Profit</td>
<td></td>
</tr>
<tr>
<td>Unit Revenue</td>
<td></td>
</tr>
</tbody>
</table>
Summary

In thinking about properties, you might find useful the following rule of thumb: if a property is prefixed with “Driver”, then it is either an assignment property or a driver property. If it is prefixed with “Received”, then it is an incoming property. And, if it is prefixed with neither “Driver” nor “Received”, then it is either an outgoing property or an account property.

The following table lists the properties in alphabetical order and specifies the type of property for each one.

**Table 24.6 Property Type**

<table>
<thead>
<tr>
<th>Property</th>
<th>Outgoing</th>
<th>Incoming</th>
<th>Assignment</th>
<th>Account</th>
<th>Driver</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allocated Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Assigned Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Assigned Idle Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Assigned Idle Quantity</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Assigned Non-Reciprocal Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Assigned Reciprocal Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Calculate Error</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Drivable Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Driven Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Driven Quantity</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Driver Allocated Cost</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Driver Cost</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Driver Driven Cost</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Driver Driven Quantity</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Driver Formula</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Driver Idle Cost</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Driver Name</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Driver Percentage</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Driver Quantity Basic</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Property</td>
<td>Outgoing</td>
<td>Incoming</td>
<td>Assignment</td>
<td>Account</td>
<td>Driver</td>
</tr>
<tr>
<td>---------------------------------------------------</td>
<td>----------</td>
<td>----------</td>
<td>------------</td>
<td>---------</td>
<td>--------</td>
</tr>
<tr>
<td>Driver Quantity Calculated</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Driver Quantity Fixed (DQF)</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Driver Quantity Variable (DQV)</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Driver Rate</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Driver Sequence Number</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Driver Type</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Driver Used Cost</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Driver Weight Fixed (DWF)</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Driver Weight Variable (DWV)</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Entered Cost</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Has Assignments</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Has Attributes</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Has BOC</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Has Entered Cost</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Has Idle Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Has Notes</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Has Used Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Idle Cost</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Idle Driver Quantity</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Idle Driver Quantity UE</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Idle Flow Method</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Idle Percentage</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Idle Quantity</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Output Quantity</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Output Quantity UE</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Profit</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Received Allocated Cost</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Received Assignment Cost</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Received BOC Cost</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Property</td>
<td>Outgoing</td>
<td>Incoming</td>
<td>Assignment</td>
<td>Account</td>
<td>Driver</td>
</tr>
<tr>
<td>--------------------------------------</td>
<td>----------</td>
<td>----------</td>
<td>------------</td>
<td>---------</td>
<td>--------</td>
</tr>
<tr>
<td>Received Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Received Driven Cost</td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Received Idle Cost</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Received Non-Reciprocal Cost</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Received Reciprocal Cost</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Received Used Cost</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Revenue</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Sold Quantity</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Total Driver Quantity (TDQ)</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Total Driver Quantity Basic (TDQB)</td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Total Driver Quantity Calculated (TDQ)</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Total Driver Quantity UE (TDQUE)</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Unassigned Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Unassigned Quantity</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Unique Driver Quantities</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Unit Cost</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Unit Profit</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Unit Revenue</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Use Fixed Quantities</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Use Rule Formula</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Use Variable Quantities</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Use Weighted Quantities</td>
<td></td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>Used Cost</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Used Quantity</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Part 9

Drivers

Chapter 25
Assignments ................................................................. 263

Chapter 26
Types of Drivers ........................................................... 269

Chapter 27
Driving Costs ............................................................... 291

Chapter 28
How To ................................................................. 317
Assignments

Overview

Assignments are a way to distribute costs between accounts. Costs that are assigned between accounts that are in the same module are called inner-module assignments. Costs that are assigned between accounts that are in different modules are called cross-module assignments.

When you assign the cost from one account to another account, the cost is said to flow from the first account to the second account. The first account is called a source account because it is the source of costs for the second account. The second account is called the destination account because it is the destination to which the first account's cost flows.

The manner in which the cost flows is controlled by a driver. A single source account can flow its costs to any number of destination accounts, but each source account can have only one driver.

Before creating an assignment, you must select accounts to add to the assignment.

Assignment Paths

As you create assignments between accounts on the Resource module, the Activity module, and the Cost Object module, you create a sequence of accounts through which costs flow. This sequence is called the assignment path. For example, suppose that costs
are assigned first from account A to account B. Then costs are assigned from account B to account C. This process creates an assignment path from account A to account C.

Assignments Panes

You can divide the Resource module, the Activity module, and the Cost Object module into up to three panes. This capability enables you to easily create assignments or to see the assignments between accounts.

For example:

- **One pane**
  The primary pane shows you one module at a time. The primary pane always displays the hierarchy of the module that you are viewing. The left and right panes display accounts only, not module hierarchy.

- **Two panes**
  The primary pane and the left or right pane show you assignments from one module to another module, as well as assignments that are in the same module.

- **Three panes**
  The left pane, the primary pane, and the right pane show you assignments that flow the costs from resources, through activities, to cost objects.

In both the two-pane view and the three-pane view, costs flow from the left to the right. The space between the panes is called the splitter bar. Within the splitter bar, lines and arrows indicate the assignments between accounts.

1. Select **Left and Right Assignments Panes** from the View Assignments Panes icon.

2. Select **Show Left and Right** from the Show Assignments icon.
If there are no assigned costs, you see nothing additional when you show assignments.

**T I P** You can also divide the Attributes view to see the accounts to which an attribute has been assigned.

### Assignments and Modules

The following table shows which modules are available for creating assignments:

<table>
<thead>
<tr>
<th>These modules are available in the left pane</th>
<th>when this module is in the primary pane</th>
<th>these modules are available in the right pane.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource</td>
<td>Resource</td>
<td>Resource</td>
</tr>
<tr>
<td>External Units</td>
<td>Activity</td>
<td>Activity</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Cost Object</td>
</tr>
<tr>
<td>Resource</td>
<td></td>
<td>Activity</td>
</tr>
<tr>
<td>Activity</td>
<td></td>
<td>Cost Object</td>
</tr>
<tr>
<td>External Units</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Resource</td>
<td>Cost Object</td>
<td>Cost Object</td>
</tr>
<tr>
<td>Activity</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost Object</td>
<td>External Units</td>
<td>Resource</td>
</tr>
<tr>
<td>External Units</td>
<td></td>
<td>Activity</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Cost Object</td>
</tr>
</tbody>
</table>

### Assignment Guidelines

The following guidelines will help you create assignments:

- You can assign costs from one account to another account, but you cannot assign costs to a rollup account.
• Try to assign 100 percent of an account's costs to other accounts.

If you do not assign all costs, SAS Activity-Based Management issues warnings when you calculate costs.

See Also

“Associating a Driver with an Account” on page 266

Associating a Driver with an Account

You associate a driver with an account by setting the account's Driver Name property.

Add Accounts for Assignments Dialog Box

Overview

In the Add Accounts for Assignments dialog box, you can select accounts to display in an assignments pane in preparation for creating an assignment.

Note: Some functionality is not available depending upon your permissions

How to Access the Add Accounts for Assignments Dialog Box

Do one of the following:
On the Resource module view, the Activity module view, or the Cost Object module view, open the left or right assignments pane and select Model → Assignments → Add Accounts in Left Pane (or Add Accounts in Right Pane).

Click an Add accounts for assignment button on the toolbar.

Add an Account

1. From Show accounts from this module, select an option.
2. From the list, select an account.
   
   You can select multiple accounts by using standard Windows selection techniques.
   
   If you select a rollup account, all accounts within that rollup account are added.
   
   Note: You cannot select the module rollup and add all accounts within it.
3. Click Add Accounts.
   
   The accounts are added to the grid.

Note: You can leave this dialog box open to add more accounts individually.

See Also

“Assignments” on page 263
Chapter 26
Types of Drivers

Overview ................................................................. 270
Basic Drivers ............................................................ 270
Bill of Costs Drivers .................................................... 271
Overview ................................................................. 271
Overview ................................................................. 271
Discrete-Manufacturing Environments ............................. 271
Process-Manufacturing Environments ......................... 271
Variable Quantities ................................................... 272
Fixed Quantities ....................................................... 272
Variable quantities and fixed quantities ....................... 273
Creating a Bill of Costs .............................................. 273
Calculated Drivers ...................................................... 273
Overview ................................................................. 273
Examples of Calculated Drivers ..................................... 274
Example: Shipping a Product ...................................... 274
Example: Delivering a Product to Customers .................. 274
Example: Storage Costs for an Inventory of Finished Goods
Example: Carrying Costs of an Inventory of Finished Goods
Example: Processing Customer Orders ....................... 275
Evenly Assigned Drivers .............................................. 276
Overview ................................................................. 276
Evenly Assigned Quantities .................................... 276
Percentage Drivers .................................................... 276
Overview ................................................................. 276
Example of a Percentage Driver: Time Spent on Tasks .... 277
Sales Volume Drivers .................................................. 277
Weighted Drivers ....................................................... 279
Overview ................................................................. 279
Specify the Weights for a Weighted Driver .................... 280
Example: Processing Customer Orders ....................... 281
Example: Supporting Products .................................... 281
Rule-based Drivers ...................................................... 281
About Rule-based Drivers ....................................... 281
Sample Rule-based Drivers ....................................... 282
Two More Rule-Based Drivers .................................... 285
Additional Rule Formulas ....................................... 287
Limitations ............................................................... 288
Overview

A driver controls how costs flow from one account to another account by instructing how costs flow from an account. A driver attempts to accurately measure an account’s consumption or to assign costs to an account. For example, a driver can be the number of full-time employees (FTEs), the percent of supplies used, or the number of boxes packaged.

Drivers for the open model are listed on the Drivers view.

When you create a driver, you can select from several types of drivers:

- “Basic Drivers” on page 270
- “Bill of Costs Drivers” on page 271
- “Calculated Drivers” on page 273
- “Evenly Assigned Drivers” on page 276
- “Percentage Drivers” on page 276
- “Sales Volume Drivers” on page 277
- “Weighted Drivers” on page 279
- “Rule-based Drivers” on page 281

See Also

- “Comparing Driver Types” on page 289
- “Fixed Driver Quantities, Variable Driver Quantities, and Weighted Driver Quantities” on page 293

Basic Drivers

A basic driver (named Basic) includes only one factor that represents the relationship between accounts. For example, a basic driver can be the number of hours a machine is running or the number of full-time equivalents that are required for producing a product.

See Also

“Fixed Driver Quantities, Variable Driver Quantities, and Weighted Driver Quantities” on page 293
Bill of Costs Drivers

Overview

A bill of costs driver (named Bill of Cost) represents an account that is a bill of costs.

Note: Every driver from an External Unit account is considered a BOC driver regardless of whether it is an explicit BOC driver or a Calculated driver. From any other account only an explicit BOC driver is considered a BOC driver. Apart from External Unit accounts, a Calculated driver from any other account is not considered a BOC driver.

Overview

A bill of costs (BOC) driver provides an easy way to add material costs and internal costs directly to accounts.

Use a bill of costs driver for these circumstances:

• External Unit Cost Elements need to be included in a model.

  Not all costs that are assigned through a model come from the General Ledger. For example, material costs (the cost of purchased components) can be additional product cost information, which often comes from a Materials Requirements Planning (MRP) system.

• Internal cost elements in a model that are associated with product families need to be tracked.

If you create an assignment from an external unit, the bill of costs driver is automatically specified. If you create an assignment from an internal unit, you must specify the driver.

A bill of costs driver quantity can include variable quantities, fixed quantities, or both.

Discrete-Manufacturing Environments

In a discrete-manufacturing environment, a bill of materials is a familiar concept. Usually, each product has a bill of materials that lists all the product's components and their costs. In the simplest case, a bill of materials is a list of the products components, the number of units of each component that the product includes, and the unit cost for each component. Because bills of materials exist in many environments, bills of costs correspond to them to some degree.

In discrete-manufacturing environments, products that are components of other products are called internal unit cost elements. These products can each have its own bill of costs.

Process-Manufacturing Environments

In a process-manufacturing environment, an activity might have a bill of costs. A bill of costs for an activity lists all materials that were added during that activity in the process. Because material costs are added to the specific activities that consume them, you can trace the cost of finished products more accurately.
Variable Quantities

A bill of costs quantity can include variable quantities, fixed quantities, or both. For variable quantities, the cost that flows to an account from the bill of costs depends on the output quantity: the unit cost of the bill of costs is multiplied by the driver quantity (the property Driver Quantity Variable; column DQV) and by the output quantity (either the property Output Quantity or the property Output Quantity UE; column OutQtyUE).

For example, suppose that a company manufactures bicycles. The rubber tires are purchased from another company for $5 each. (This value was specified when the external unit was created.) Because each bicycle requires two tires, the unit cost of the bill of costs is $10. If the company produces 100 bicycles, the total cost is $1,000 (100.00 x $5.00 x 2.00).

(Note that all other cost elements have been removed to better illustrate the bill of costs.)

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Cost</th>
<th>OutQtyUE</th>
<th>DQF</th>
<th>DQV</th>
</tr>
</thead>
<tbody>
<tr>
<td>COST OBJECT (PRI)</td>
<td>$1,000.00</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>North America</td>
<td>$1,000.00</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Bicycle</td>
<td>$1,000.00</td>
<td>100.00</td>
<td>0.00</td>
<td>2.00</td>
</tr>
<tr>
<td>Tire</td>
<td>$1,000.00</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

\[ $1000.00 = 100.00 \times $5.00 \times 2.00 \]

Fixed Quantities

For fixed quantities, the cost that flows to an account from the bill of costs does not depend on the output quantity: the unit cost of the bill of costs is multiplied by the driver quantity (the property Driver Quantity Fixed; column DQF).

For example, suppose that the bicycle manufacturer that was mentioned previously buys a drum of grease at the beginning of each year. The unit cost of the bill of costs is the current price of the drum of grease, regardless of how many bicycles are produced.
Variable quantities and fixed quantities

You can use both variable quantities and fixed quantities in a single bill of costs.

Creating a Bill of Costs

You create a bill of costs between accounts when you use the bill of costs driver to create an assignment between the accounts.

If you create an assignment from an external unit, the bill of costs driver is automatically specified. If you create an assignment from an internal unit, you must specify the driver.

Calculated Drivers

Overview

A calculated driver (named Calculated) includes a formula the evaluation of which determines Driver Quantity Calculated (DrvQtyCalc) for an assignment. The formula for a calculated driver is not periodic; the formula remains the same for all periods.

By default, if a name in the formula of a calculated driver is not found belonging to the destination account, then it is assumed to belong to the source account. In more detail,
the order of precedence for resolving references (for example “Foo”) in the formula of a calculated driver is the following:

1. Assignment path
2. Destination account
3. Source account
4. Dimension reference
5. Attribute reference

The following properties are not valid for use in the formula of a calculated driver and, therefore, do not appear in the Formula Builder drop-down list:

- DriverQuantityBasic
- IdleDriverQuantity

The reason is that in an assignment these quantities depend on DrvQtyCalc. Consequently, a vicious circle would be created if the formula were to make DrvQtyCalc depend on these quantities. That is, DrvQtyCalc could not be determined without first determining these quantities, and these quantities could not be determined without first determining DrvQtyCalc.

**Examples of Calculated Drivers**

The following examples illustrate how calculated drivers can be used in a model. These equations often include numeric properties and numeric attributes.

**Note:** You can use cost properties in the driver formula for a calculated driver, but you will need to use driver sequencing to ensure that the properties are non-zero. If you use the default sequence of 1, then all cost values will be zero except for Entered Cost.

**Example: Shipping a Product**

Suppose that a company wants to calculate the shipping cost for products that are shipped on pallets. The shipping vendor's cost is based on how many pallets are shipped, not on how many units are produced. To determine the shipping cost, the output quantity (the property OutputQuantity) is divided by the number of products that a pallet can hold (the user-defined numeric attribute UnitsPerPallet), as follows:

\[ \text{OutputQuantity/UnitsPerPallet} \]

If the physical dimensions of the product change, then the number of units that a pallet can hold will change. The value of UnitsPerPallet can be changed accordingly. Also, the value of UnitsPerPallet can be different for each product, but the same equation can be used for multiple products.

**Example: Delivering a Product to Customers**

Suppose that a company wants to calculate the cost of product delivery. To determine the delivery cost, the number of deliveries to each customer per month is multiplied by the average delivery time. Both of these attributes are user-defined numeric attributes.

\[ \text{DeliveriesPerMonth*AvgTimePerDelivery} \]
A customer who prefers more deliveries per month might pay a different delivery cost than a customer who prefers fewer deliveries. Likewise, a customer who is farther away from the company might pay a different delivery charge than a customer who is closer.

**Example: Storage Costs for an Inventory of Finished Goods**

Suppose that a company wants to calculate the cost of storing slow-moving products. To determine the storage cost, the output quantity (the property `OutputQuantity`) is divided by the speed at which a product sells (the user-defined numeric attribute `InventoryTurns`). The result of that calculation is multiplied by the volume of storage space that a product requires (the numeric attribute `CuFtPerUnit`), as follows:

\[
\frac{\text{OutputQuantity}}{\text{InventoryTurns}} \times \text{CuFtPerUnit}
\]

Dividing `OutputQuantity` by `InventoryTurns` yields the average inventory level in units. In order to use `CuFtPerUnit`, the Resource module in the model must include costs, such as utilities or rent, that are based on per-cubic-foot values.

**Example: Carrying Costs of an Inventory of Finished Goods**

Suppose that a company wants to add costs to a model to calculate the financial carrying cost of inventory. The previous equation could be altered to calculate the financial carrying cost of the inventory, not the physical storage cost:

\[
\frac{\text{OutputQuantity}}{\text{InventoryTurns}} \times \text{Cost}
\]

**Example: Processing Customer Orders**

Suppose that a company processes orders for other companies. The number of orders that are processed is only part of the important data. The company might need to consider the complexity of each customer's order.

To determine the cost of processing an order, the number of orders that are processed (the user-defined numeric attribute `NumberOfOrdersProcessed`) is multiplied by the complexity of each order (the user-defined numeric attribute `OrderComplexityByCustomer`), as follows:

\[
\text{NumberOfOrdersProcessed} \times \text{OrderComplexityByCustomer}
\]

For `OrderComplexityByCustomer`, a different value could be assigned to each customer, and the same equation could be used for all customers.

**See Also**

- Chapter 29, “Formulas,” on page 329
- “Using Numeric Attributes in a Formula” on page 340
- “Properties That Can Be in Formulas” on page 361
Evenly Assigned Drivers

Overview

An evenly assigned driver (named Evenly Assigned) assigns equal percentages of an account’s costs to each account that receives costs. For example, if you use an evenly assigned driver to assign an account’s cost to two accounts, then each account automatically receives 50 percent of the cost.

The evenly assigned driver is often used as a first approximation of the costs that flow between accounts when actual driver quantities are not known. When actual driver quantities are known, replace this driver with a driver that is more accurate.

Note: The types of driver quantities are preset for the evenly assigned driver; you cannot change them.

Evenly Assigned Quantities

If you choose to distribute idle quantities with evenly assigned quantities, the idle quantities are divided evenly among the destination accounts. For example, each of the destination account’s idle quantity is 1.00, which is half of the source account’s idle quantity of 2.00.

<table>
<thead>
<tr>
<th>InstructionName</th>
<th>DrvQty</th>
<th>IdlQty</th>
<th>DrvIdlCost</th>
</tr>
</thead>
<tbody>
<tr>
<td>North America x Front Fender</td>
<td>5.00</td>
<td>1.00</td>
<td>$100.00</td>
</tr>
<tr>
<td>North America x Rear Fender</td>
<td>3.00</td>
<td>1.00</td>
<td>$100.00</td>
</tr>
</tbody>
</table>

After calculating the costs, the driver idle cost (the column DrvIdlCost) for both the Front Fender and the Rear Fender is $100.00 (1.00 x $100.00).

Percentage Drivers

Overview

A percentage driver (named Percentage) assigns a specified percentage of an account’s costs to each account that receives costs. The percentage driver tracks the total percentage and issues a warning if costs exceed 100 percent or if less than 100 percent of costs are used.

The percentage driver is often used as a first approximation of the costs that flow between accounts when actual driver quantities are not known. Unlike an evenly assigned driver that allocates the same percentage to each account that receives costs, a percentage driver enables you to assign a percentage to each account. When actual driver quantities are known, replace this driver with a driver that is more accurate. Or, if determining the actual driver quantities is not practical, ensure that the percentages are reasonably accurate. (Example of a percentage driver)

Note: The types of driver quantities are preset for the percentage driver; you cannot change them.
Example of a Percentage Driver: Time Spent on Tasks

The following example illustrates how a percentage driver can be used in a model. These equations often include numeric properties and numeric attributes.

Suppose that an organization decides that it's not practical to determine the actual number of hours that clerical personnel spend on various tasks per year. The cost to determine the actual number of hours outweighs the benefit. To approximate the annual number of hours, management asks the clerical personnel to record their actual hours for one week. From these recordings, a percentage is assigned to each task. For this organization, a percentage is reasonably accurate and acceptable.

Sales Volume Drivers

A Sales Volume driver generates a cost flow whose magnitude is determined by the quantity of an item sold. To use a Sales Volume driver you must do two things:

1. Attach a Sales Volume driver to an account. The account is the source of a cost associated with selling an item. Usually such accounts are in the Cost Object module.

*Note:* For a Sales Volume driver to work, the dimensions of an account to which it is attached must be the same as the dimensions in the Profit Analysis module. The Sales Volume driver is generally attached to Cost Object accounts. This means that the dimensions of the Cost Object module must be the same as the dimensions of the Profit Analysis module. However, there is no restriction against attaching the Sales Volume driver to an account in any other module. If you do, then the dimensions of that module must be the same as the dimensions of the Profit Analysis module for the Sales Volume driver to work.

2. Assign a value to the Sold Quantity (SoldQty) property of one or more accounts (presumably a Cost Object account) that are the final destination of the item before sale.

During calculation, then, the system does two things:

1. It generates an assignment between each account to which a Sales Volume driver is attached and every appropriate destination account.

*Note:* A destination account is appropriate if its Sold Quantity (SoldQty) is non-zero and if its intersection dimension members are the same as the intersection dimension members of the source account (where None matches any intersection dimension member). The intersection dimension members for the destination account are determined by the dimensions of the Profit Analysis module.

The following picture shows an example in which the Sales Volume driver is attached to the following source account:

Beaverton x Drop Box x No <Products and Services>

During calculation, the system generates assignments to the following destination accounts that have a non-zero value for SoldQty:

Beaverton x Drop Box x 2nd Day Guaranteed
Beaverton x Drop Box x Overnight Express
Beaverton x Drop Box x Standard Ground
You can see that the "None" intersection (No <Products and Services>) in the source account matches the intersection in three destination accounts. None acts like a wildcard whether it appears in a source account or in a destination account.

2. It calculates the Driver Quantity Calculated (DrvQtyCalc) for the driver. DrvQtyCalc is equal to the SoldQty on the destination account. The system then uses the value of DrvQtyCalc to calculate the magnitude of the cost flow.

The Sales volume driver is a kind of rule-based driver (see “Rule-based Drivers” on page 281.) If you attach a Sales volume driver to an account, then calculation automatically makes an assignment to every possible destination account for which the following rule is true:

1. The destination account has a non-zero value for its SoldQuantity property.
2. The dimension signature (the intersection of its dimension members) of the destination account is the same as the dimension signature of the source account (to which the Sales volume driver is attached).

Note: The null dimension counts as a wildcard—it matches any dimension.

For example, consider the following picture.

You can see that the following pairs of dimension signatures match:

- **Eugene x No <Channel> x 2nd Day Guaranteed** for the source account matches **Eugene x Drop Box x 2nd Day Guaranteed** for the destination account.
• Eugene x No <Channel> x Overnight Express for the source account matches Eugene x Walk In x Overnight Express for the destination account.

• Eugene x No <Channel> x Standard Ground for the source account matches Eugene x Commercial Pick-Up x Standard Ground for the destination account.

As you can see, the null dimension, No <Channel>, matches each of the following dimensions: Drop Box, Walk In, and Commercial Pick-Up.

3. The structural dimensions of the module in which the Sales volume driver is attached are the same as the structural dimensions of the Profitability module.

In practice, the Sales volume driver is always attached to accounts in the Cost Object module, and the structural dimensions of the Cost Object module are the same as the Profitability module.

In fact, because the Sales volume driver is a kind of rule-based driver, you can make the same assignments with an appropriately defined rule-based driver as you can with the Sales volume driver. To do so, you would do the following for the rule-based driver:

• Use a calculated driver whose formula is SoldQuantity. That is, instead of using the general formula DrvQtyCalc = (DQF x DWF) + (DQV x DWV x Dest. TDQ), the calculated driver uses the formula DrvQtyCalc = SoldQuantity.

• The driver’s rule formula is the following:

\[
\text{Destination.Region.DimMemName} = \text{Source.Region.DimMemName} \\
\text{AND \ Destination.Prod_Serv.DimMemName} = \text{Source.Prod_Serv.DimMemName} \\
\text{AND \ SoldQuantity} > 0
\]

Note: Notice that the formula uses the dimension reference rather than the dimension name. Also note that by leaving out a condition for Prod_Serv, the channel "None" matches every channel.

---

**Weighted Drivers**

**Overview**

A weighted driver (named Weighted) contains two factors that represent the relationship between accounts. The first factor measures volume (or frequency), and the second factor measures intensity (or complexity). The two factors are multiplied to produce a calculated value that is used for distributing costs. This calculated value, based on weight, is necessary because if the cost of a source account is merely passed to each destination account, the cost incurred by the complexity of each destination account is not considered. Therefore, the cost of each destination account is not accurate. To compensate for the intensity or complexity of each destination account, a relative weight is specified for each destination account.

For example, in the following figure, the cost ($100) for the activity Process Orders is equally assigned to the cost objects Simple Product and Complex Product. But, this cost is not accurate because of the difference in complexity between the products.
Suppose that Complex Product is four times more complex than Simple Product. To consider the different complexities, assign a weighted driver to Process Orders. Then, specify the driver weight of 1 to Simple Product and 4 to Complex Product. After calculating, the costs for the products are significantly different and more accurate.

Specify the driver weights using the properties Driver Weight Fixed and Driver Weight Variable, depending on whether the driver supports fixed quantities, variable quantities, or both. (Examples of weighted drivers)

**Specify the Weights for a Weighted Driver**

1. Open the module that contains the destination accounts for the source account that uses a weighted driver.
2. For a weighted driver that uses fixed driver quantities, add a column to contain the property Driver Weight Fixed.
3. For a weighted driver that uses variable driver quantities, add a column to contain the property Driver Weight Variable.
4. Click in the Driver Weight Fixed (DWF) column or the Driver Weight Variable (DWV) column for a destination account, and type a value.

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Cost</th>
<th>DWF</th>
<th>DWV</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACTIVITY (PRIMARY PANE)</td>
<td>$9,000.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Stamping Parts</td>
<td>$7,333.33</td>
<td>1.00</td>
<td>2.50</td>
</tr>
<tr>
<td>Chroming Parts</td>
<td>$1,000.00</td>
<td>3.00</td>
<td>5.00</td>
</tr>
<tr>
<td>Attaching Bumper</td>
<td>$666.67</td>
<td>2.00</td>
<td>4.00</td>
</tr>
</tbody>
</table>

If you are prevented from entering these values, verify that the following are correct:

- The source account's driver is a weighted driver.
- The weighted driver allows fixed driver quantities, variable driver quantities, or both.
Example: Processing Customer Orders

The following examples illustrate how weighted drivers can be used in a model. These equations often include numeric properties and numeric attributes.

Suppose that a company sells products with varying numbers of options. Some products offer no options and some products offer many options. The cost of processing customer orders is equal to the number of orders that are processed (frequency), multiplied by the average number of lines per order (complexity, which is the number of options for each product). The products that offer the most options have greater weights than the products that offer fewer (or no) options.

Example: Supporting Products

Suppose that a company sells products of varying complexity. Some products are simple and yield customer telephone calls that require little time. Some products are complex and yield customer calls that require significant time. Each product is assigned a weight based on the amount of time needed for an average customer call.

See Also

“Fixed Driver Quantities, Variable Driver Quantities, and Weighted Driver Quantities” on page 293

Rule-based Drivers

About Rule-based Drivers

Rule-based drivers allow you to generate cost assignments automatically. A rule-based driver is an ordinary driver with an associated rule formula. The formula determines for which destination accounts an assignment is automatically generated from every source account to which the driver is attached.

Creating and using rule-based drivers is a four-step process:

1. **Attach a formula to a driver.**

   To attach a formula, on the Driver Properties dialog select **Use Rule Formula** and click **Formula Builder**.

   - Any sort of driver (Calculated, Bill of Cost, Percentage, etc.) except for Sales Volume can have a formula (referred to as a rule formula).
   - Use the Formula Builder to build a rule formula. The following is a sample formula:

     ```
     Module="CostObject" AND Destination.HasAttribute("SuppHours") AND SuppHours > 5
     ```

     This sample formula returns true for every destination account in the CostObject module that has an attribute "SuppHours" whose value is greater than 5.

2. **Attach the driver to one or more source accounts.**
The source accounts can be in any module including External Units. (However, Idle Flow is not supported from an External Unit.)

3. **Calculate the model.**

   During calculation every source account that has a rule-based driver (a driver with an associated rule formula) attached to it starts the following process:

   - Every destination account that is downstream of the source account is evaluated for the rule formula. (A destination account is downstream of a source account if it is in the same module as the source account or if it is in a later module when the modules are considered in the following order: External Units, Resource, Activity, Cost Object).

   - If the rule formula tests true for the destination account, then an assignment is made between the source account being considered and that destination account.

   - If the rule formula tests false for the destination account and there is currently an assignment between the source account being considered and that destination account, then the assignment is deleted.

   - If the rule formula tests false for the destination account and there is currently no assignment between the source account being considered and that destination account, then no assignment is made.

4. **Clean up the assignments made.**

   This step is optional and is recommended only for rapid prototyping.

   - Manually delete any assignments that were created that you don't want.

   - Manually create any additional assignments that you do want between a source account with a rule-based driver and a destination account for which the rule formula tested false.

   **Note:** If you do this sort of manual clean-up, then you should be aware of the fact that running a subsequent calculation will restore the assignments that you deleted and delete the additional assignments that you made. You can avoid this in either of two ways:

     - Selecting Disable Driver Rules during calculation to disable all rule-based drivers.
     - Deselecting Use Rule Formula in the Driver Properties dialog box to disable the rule formula for an individual driver.

**Sample Rule-based Drivers**

Suppose we have a model with the following dimensions:
Suppose also that we have a numeric attribute named SuppHours:

<table>
<thead>
<tr>
<th>Name</th>
<th>Reference</th>
<th>Type</th>
<th>UoM</th>
</tr>
</thead>
<tbody>
<tr>
<td>SuppHours</td>
<td>SuppHours</td>
<td>Numeric</td>
<td>hours</td>
</tr>
</tbody>
</table>

The attribute is attached to two Cost Object accounts:

<table>
<thead>
<tr>
<th>Display Name</th>
<th>SuppHours</th>
</tr>
</thead>
<tbody>
<tr>
<td>LOGO COST OBJECT (PRIMARY PANE)</td>
<td></td>
</tr>
<tr>
<td>LOGO No &lt;Customers&gt;</td>
<td></td>
</tr>
<tr>
<td>LOGO Retail</td>
<td></td>
</tr>
<tr>
<td>LOGO Sears</td>
<td></td>
</tr>
<tr>
<td>LOGO No &lt;Products&gt;</td>
<td></td>
</tr>
<tr>
<td>LOGO Recreation</td>
<td></td>
</tr>
<tr>
<td>LOGO Bike</td>
<td>5.00</td>
</tr>
<tr>
<td>LOGO Lawn &amp; Garden</td>
<td></td>
</tr>
<tr>
<td>LOGO Kmart</td>
<td></td>
</tr>
<tr>
<td>LOGO No &lt;Products&gt;</td>
<td></td>
</tr>
<tr>
<td>LOGO Recreation</td>
<td></td>
</tr>
<tr>
<td>LOGO Bike</td>
<td>15.00</td>
</tr>
<tr>
<td>LOGO Lawn &amp; Garden</td>
<td></td>
</tr>
<tr>
<td>LOGO Wholesale</td>
<td></td>
</tr>
</tbody>
</table>

Suppose, finally, that we have defined three rule-based drivers with the rule formulas shown in the following table:

<table>
<thead>
<tr>
<th>Driver Name</th>
<th>Driver Type</th>
<th>Rule Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>CustSupp</td>
<td>Basic</td>
<td>SuppHours&lt;&gt;0</td>
</tr>
</tbody>
</table>
Notice that a rule-based driver can be of any type (Calculated, Bill of Cost, Percentage, etc.) except for Sales Volume. So, a calculated rule-based driver has two formulas: a rule formula to determine assignments and a driver formula to determine the calculation for each assignment. The following picture shows drivers in our sample model:

The following picture shows the two assignments that are generated by the driver CustSupp whose rule formula is: SuppHours<>0:

- Kmart x Bike (for which account SuppHours=15)
- Sears x Bike (for which account SuppHours=5)

The following picture shows the two assignments that are generated by the driver Stock, whose rule formula is: Cust.DimMemRef="None" AND Prod.DimMemRef<>"None"

- No <Customers> x Mower
- No <Customers> x Bike

*Note:* It is important to note that even though the column for the intersection name shows "No <Customers>" in the following picture, you must use the internal name "None" in your formulas.
The following picture shows the three assignments that are generated by the driver Sell whose rule formula is:

\[
\text{Prod.DimMemRef}=\text{"None" AND Cust.DimMemRef}=\text{"None"}
\]

- Sears x No <Products>
- Kmart x No <Products>
- Passthru x No <Products>

Note: Again, note that the formula uses "None" for the null intersection even though the column heading in the assignments pane shows "No <Prod>".

Two More Rule-Based Drivers

Now let's introduce two more rule-based drivers to create assignments from Cost Object accounts to other Cost Object accounts:

<table>
<thead>
<tr>
<th>Driver Name</th>
<th>Driver Formula</th>
</tr>
</thead>
</table>

The following picture shows three of the assignments that are generated by the driver Product, whose rule formula is the following:

\[
\]
And, the following picture shows three more assignments that are generated by the driver Product:

The following picture shows two of the assignments that are generated by the driver Customer, whose rule formula is the following:

\[
\text{Prod. DimMemRef} \neq \text{"None"}
\]
\[
\text{AND} \quad \text{Cust. DimMemRef} \neq \text{"None"}
\]
\[
\text{AND} \quad \text{Source.Prod.DimMemRef} = \text{"None"}
\]
\[
\text{AND} \quad \text{Source.Cust.DimMemRef} = \text{Destination.Cust.DimMemRef}
\]

The following picture shows two more assignments that are generated by the driver Customer, whose rule formula is the following:

\[
\text{Prod. DimMemRef} \neq \text{"None"}
\]
\[
\text{AND} \quad \text{Cust. DimMemRef} \neq \text{"None"}
\]
\[
\text{AND} \quad \text{Source.Prod.DimMemRef} = \text{"None"}
\]
\[
\text{AND} \quad \text{Source.Cust.DimMemRef} = \text{Destination.Cust.DimMemRef}
\]
And, the following picture shows the last two assignments that are generated by the driver Customer, whose rule formula is the following:

\[
\text{Prod.DimMemRef} \neq \text{"None"} \\
\text{AND Cust.DimMemRef} \neq \text{"None"} \\
\text{AND Source.Prod.DimMemRef} = \text{"None"} \\
\text{AND Source.Cust.DimMemRef} = \text{Destination.Cust.DimMemRef}
\]

### Additional Rule Formulas

The following are some examples of formulas that you can use in a rule-based driver. For a full list of functions, see Functions.

<table>
<thead>
<tr>
<th>Rule Formula</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Match( Name, &quot;*Salary&quot; )</td>
<td>The name of the destination account matches &quot;*Salary&quot; e.g., &quot;Wages &amp; Salary&quot;.</td>
</tr>
<tr>
<td>TDQ &gt; 0 and TDQ &lt;= 100</td>
<td>The TDQ of the destination account is between 0 and 100.</td>
</tr>
<tr>
<td>Cost &gt; 0 and Source.Cost &lt; 0</td>
<td>The cost of the destination account is greater than 0 and the cost of the source account is less than 0.</td>
</tr>
</tbody>
</table>
Rule Formula: 
\[(\text{NumberOfCalls} > 0) \quad \text{OR} \quad (\text{NumberOfReturns} > 0)\]

Explanation:
The value of the attribute, \(\text{NumberOfCalls}\), on the destination account is greater than 0, or the value of the attribute \(\text{NumberOfReturns}\), also on the destination account, is greater than 0.

If \(\text{not IsNull(SoldQuantity)}\), \(\text{SoldQuantity, OutputQuantity}\) > 0

Explanation:
The condition is evaluated as follows:
1. If \(\text{SoldQuantity}\) is not null, then \(\text{SoldQuantity}\) is returned.
2. If \(\text{SoldQuantity}\) is null, then \(\text{OutputQuantity}\) is returned.
3. If whichever quantity is returned (\(\text{SoldQuantity}\) or \(\text{OutputQuantity}\)) is greater than 0, then the condition is true and an assignment is made.

Limitations

- Properties on the source account related to outgoing assignments will be accessible but are not recommended for use in rule formulas. In all cases these will be zero because the outgoing assignments haven't been created yet. These properties are: \(\text{TotalDriverQuantity, IdleQuantity, AssignedIdleQuantity, OutputQuantity, UsedQuantity, TotalDriverQuantityCalculated, TotalDriverQuantityBasic, DrivenQuantity, DrivableCost, IdleCost, AssignedIdleCost, UsedCost, AllocatedCost, DrivenCost, UnassignedCost, AssignedCost, AssignedReciprocalCost, AssignedNonReciprocalCost}\).

- A syntax error occurs if a rule formula uses an assignment property since they do not exist in the context of a rule evaluation. These properties are: \(\text{AllocatedCost, Cost, DrivenCost, DriverQuantityCalculated, DriverQuantityFixed, DriverQuantityVariable, DriverRate, DriverWeightFixed, DriverWeightVariable, IdleCost, IdleDriverQuantityUE, UsedCost}\).

- If the Use Rule Formula checkbox is checked for a driver but no rule formula is defined, then all outgoing assignments are deleted from accounts that use that driver. If you want to retain existing assignments make sure the Use Rule Formula checkbox is unchecked when the rule formula is empty.

- No warning is issued if your formula refers to dimensions that exist but in an order that does not exist. For example, not warning is issued if your formula attempts to assign from an Activity module account to a Resource module account. Such an assignment does not exist because assignments cannot go in a backwards direction (e.g., from Activity module to Resource module).

- Assignments are not generated when you define a rule formula or when you import a model with rule-based drivers. Assignments are generated only when you calculate a model.

Recommendations

Please be aware of the following considerations and recommendations in using rule-based drivers:
Do Not Create Unnecessary Assignments

The ease of creating assignments with rule-based drivers can lead to generating millions of unnecessary assignments. Unnecessary assignments both use up memory and increase calculate time. The more accounts there are that use rules-based drivers the more work there is for calculation to do beyond flowing costs.

One way to avoid unnecessary assignments is to include a check in the rule formula to eliminate assignments with zero cost flow. For example, suppose you have a calculated driver that uses the attribute NumberOfCalls to calculate cost. You could include in a rule formula the condition NumberOfCalls > 0 to avoid making assignments with zero cost flow.

Numeric Functions Are Faster Than String Functions

Formulas that use string concatenation and functions that return strings are slower to evaluate than numeric or boolean expressions. Plan accordingly when using them in rule formulas or in calculated attributes that are referenced by rule formulas.

Be Wary of Creating Reciprocal Assignments

Remember that rule-based drivers can result in the creation of assignments from accounts in one module to destination accounts in the same module. As a result you can end up with unintended reciprocal costs. You can avoid reciprocal costs by specifying the destination module with the condition Module.DimMemRef=. For example:

- "Module".DimMemRef="ExternalUnit"
- "Module".DimMemRef="Resource"
- "Module".DimMemRef="Activity"
- "Module".DimMemRef="CostObject"

See Also

- “Enhanced Formula Capabilities” on page 337
- “Formula” on page 330
- “Formula Context” on page 332
- “Functions” on page 331
- “Troubleshooting Formulas” on page 341
- “Using Numeric Attributes in a Formula” on page 340

Comparing Driver Types

The following table shows for each driver what properties it uses for calculating DrvQtyCalc for an assignment path and what formula it uses for the calculation:

<table>
<thead>
<tr>
<th>Type of Driver</th>
<th>Properties Used</th>
<th>How DrvQtyCalc is Calculated</th>
</tr>
</thead>
<tbody>
<tr>
<td>Evenly assigned</td>
<td>DQF</td>
<td>DrvQtyCalc = DQF=1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>where DQF is automatically assigned a value of 1 for every assignment path of the driver. DQF is not changeable by a user for this driver.</td>
</tr>
<tr>
<td>Type of Driver</td>
<td>Properties Used</td>
<td>How DrvQtyCalc is Calculated</td>
</tr>
<tr>
<td>---------------</td>
<td>----------------</td>
<td>-------------------------------</td>
</tr>
<tr>
<td>Percentage</td>
<td>DQF</td>
<td>DrvQtyCalc = DQF</td>
</tr>
<tr>
<td>Basic</td>
<td>DQF</td>
<td>DrvQtyCalc = DQF + (DQV x Dest.TDQ)</td>
</tr>
<tr>
<td></td>
<td>DQV</td>
<td></td>
</tr>
<tr>
<td>Weighted</td>
<td>DQF, DWF</td>
<td>DrvQtyCalc = (DQF x DWF) + (DQV x DWV x Dest.TDQ)</td>
</tr>
<tr>
<td></td>
<td>DQV, DWV</td>
<td></td>
</tr>
<tr>
<td>BOC</td>
<td>DQF, DWF</td>
<td>DrvQtyCalc = (DQF x DWF) + (DQV x DWV x Dest.TDQ)</td>
</tr>
<tr>
<td></td>
<td>DQV, DWV</td>
<td></td>
</tr>
<tr>
<td>Sales volume</td>
<td>SoldQty</td>
<td>DrvQtyCalc = SoldQty</td>
</tr>
<tr>
<td>Calculated</td>
<td>See Chapter 33, “Properties That Can Be In Formulas,” on page 361.</td>
<td>DrvQtyCalc = the value of the driver formula</td>
</tr>
</tbody>
</table>
# User-Entered Cost Allocation
User-Entered Cost Allocation

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fixed Driver Quantities, Variable Driver Quantities, and Weighted Driver Quantities</td>
<td>292</td>
</tr>
<tr>
<td>Overview</td>
<td>293</td>
</tr>
<tr>
<td>Fixed Driver Quantities</td>
<td>293</td>
</tr>
<tr>
<td>Variable Driver Quantities</td>
<td>293</td>
</tr>
<tr>
<td>Variable Driver Quantities and Fixed Driver Quantities</td>
<td>295</td>
</tr>
<tr>
<td>Weighted Driver Quantities</td>
<td>296</td>
</tr>
<tr>
<td>Unique and Non-Unique (Shared) Driver Quantities</td>
<td>296</td>
</tr>
<tr>
<td>Unique Driver Quantities</td>
<td>296</td>
</tr>
<tr>
<td>Non-Unique (Shared) Driver Quantities</td>
<td>297</td>
</tr>
<tr>
<td>Changing Driver Quantities between Unique and Non-Unique</td>
<td>297</td>
</tr>
<tr>
<td>Driver Sequencing</td>
<td>298</td>
</tr>
<tr>
<td>Overview</td>
<td>298</td>
</tr>
<tr>
<td>Misconceptions about Driver Sequencing</td>
<td>301</td>
</tr>
<tr>
<td>Idle Quantities</td>
<td>301</td>
</tr>
<tr>
<td>Overview</td>
<td>301</td>
</tr>
<tr>
<td>User-Entered Quantities</td>
<td>302</td>
</tr>
<tr>
<td>User Proportion Quantities</td>
<td>302</td>
</tr>
<tr>
<td>Use Driver Quantities</td>
<td>302</td>
</tr>
<tr>
<td>Evenly Assigned Quantities</td>
<td>303</td>
</tr>
<tr>
<td>Independent TDQ</td>
<td>303</td>
</tr>
<tr>
<td>Introduction</td>
<td>303</td>
</tr>
<tr>
<td>The Problem</td>
<td>304</td>
</tr>
<tr>
<td>Starting with 7.2</td>
<td>304</td>
</tr>
<tr>
<td>Does Anything Else Change?</td>
<td>305</td>
</tr>
<tr>
<td>Does the Change Affect Existing Models?</td>
<td>305</td>
</tr>
<tr>
<td>One Further Effect</td>
<td>306</td>
</tr>
<tr>
<td>Reciprocal Costing</td>
<td>307</td>
</tr>
<tr>
<td>Overview</td>
<td>307</td>
</tr>
<tr>
<td>Creating Reciprocal Costs</td>
<td>307</td>
</tr>
<tr>
<td>Reciprocal Costing Guidelines</td>
<td>307</td>
</tr>
<tr>
<td>Reciprocal Costs Calculation</td>
<td>307</td>
</tr>
<tr>
<td>Drivers View</td>
<td>308</td>
</tr>
<tr>
<td>About the Drivers View</td>
<td>308</td>
</tr>
<tr>
<td>How to Access the Drivers View</td>
<td>308</td>
</tr>
<tr>
<td>Create a Driver</td>
<td>308</td>
</tr>
<tr>
<td>Review or Change the Properties of a Driver</td>
<td>309</td>
</tr>
</tbody>
</table>
User-Entered Cost Allocation

User-entered cost allocation enables you to assign a specific cost to an assignment path by setting the Driver Allocated Cost (DrvAllocCost) property.

Some organizations allocate a specific cost to an account or department at the start of a budgetary period. This cost is then depleted during the budgetary period. This type of allocation is used in more traditional costing methodologies, but it is generally not part of the activity-based costing methodology. However, if the people within your organization are more familiar with this method of allocating costs, you can employ user-entered cost allocation to simulate this use.
Fixed Driver Quantities, Variable Driver Quantities, and Weighted Driver Quantities

Overview

You can specify the types of driver quantities that a driver will accept as input. This helps prevent inappropriate data from being entered into a model.

For example, if you create a driver that accepts only fixed quantities, SAS Activity-Based Management prevents variable quantities and weighted quantities from being assigned as follows:

- In the interface, variable quantities and weighted quantities cannot be entered.
- When you import model data, variable quantities and weighted quantities are reported as warnings and are ignored.

Fixed Driver Quantities

For fixed driver quantities, the cost that flows to a destination account from a source account does not depend on any property of the destination account. In other words, it does not depend on demand. The cost is “pushed” by a quantity supplied: the source account’s unit cost is multiplied by the fixed driver quantity (represented by the property DQF).

For example, suppose that $100.00 in the resource account Salary flows into two activity accounts, Take Orders and Process Orders. The costs that flow through a basic, fixed-quantity driver are shown in the following figure:

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Cost</th>
<th>IntsectName</th>
<th>Cost</th>
<th>DQF</th>
</tr>
</thead>
<tbody>
<tr>
<td>RESOURCE (PR)</td>
<td>$100.00</td>
<td>New York x Take Orders</td>
<td>$66.67</td>
<td>2.00</td>
</tr>
<tr>
<td>New York</td>
<td>$100.00</td>
<td>New York x Process Orders</td>
<td>$33.33</td>
<td>1.00</td>
</tr>
<tr>
<td>Salary</td>
<td>$100.00</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The driver quantity for Salary is 3.00: 2.00 for Take Orders and 1.00 for Process Orders.

The unit cost that flows from Salary is calculated by dividing the total cost of Salary by the driver quantity of Salary: $100.00/3.00 = $33.33.

So, the cost for each account is calculated as follows:

<table>
<thead>
<tr>
<th>Account</th>
<th>UnitCost x DQF</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>Take Orders</td>
<td>$33.33 X 2.00</td>
<td>$66.67</td>
</tr>
<tr>
<td>Process Orders</td>
<td>$33.33 X 1.00</td>
<td>$33.33</td>
</tr>
</tbody>
</table>

Note: All values are rounded.

Variable Driver Quantities

For variable driver quantities, the cost that flows to a destination account from a source account depends on the destination account’s total driver quantity. In other words, the
cost is determined by demand. It is “pulled” by the quantity required at the final destination account: the source account’s unit cost is multiplied by the variable driver quantity (DQV) and by the Destination.TDQ.

For example, suppose that $100.00 in the resource account Salary flows into two activity accounts, Take Orders and Process Orders. The costs that flow through a basic, variable-quantity driver are shown in the following figure:

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Cost</th>
<th>InactivName</th>
<th>Cost</th>
<th>DQF</th>
<th>DQV</th>
<th>TDQ</th>
</tr>
</thead>
<tbody>
<tr>
<td>RESOURCE PHH</td>
<td>$100.00</td>
<td>New York x Take Orders</td>
<td>$76.92</td>
<td>10.00</td>
<td>10.00</td>
<td>10.00</td>
</tr>
<tr>
<td>New York</td>
<td>$100.00</td>
<td>New York x Process Orders</td>
<td>$23.08</td>
<td>3.00</td>
<td>10.00</td>
<td>10.00</td>
</tr>
<tr>
<td>Salary</td>
<td>$100.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The driver quantity (DrvQtyCalc) for Salary is 130.00, which is calculated as follows:

<table>
<thead>
<tr>
<th>Account</th>
<th>DQV x Dest.TDQ</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>Take Orders</td>
<td>10.00 x 10.00</td>
<td>100.00</td>
</tr>
<tr>
<td>Process Orders</td>
<td>3.00 x 10.00</td>
<td>30.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>130.00</td>
</tr>
</tbody>
</table>

The unit cost that flows from Salary is calculated by dividing the total cost of Salary by the driver quantity of Salary: $100.00/130.00 = $0.7692.

So, the cost for each account is calculated as follows:

<table>
<thead>
<tr>
<th>Account</th>
<th>Unit Cost x DQV x Dest.TDQ</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>Take Orders</td>
<td>$100.00 x 10.00 x 10.00</td>
<td>$76.92</td>
</tr>
<tr>
<td>Process Orders</td>
<td>$100.00 x 3.00 x 10.00</td>
<td>$23.08</td>
</tr>
</tbody>
</table>

Note: All values are rounded.

As for Dest.TDQ (the quantity “demanded”), it is determined by two other quantities:

**TDQCalc**

For an account that uses a variable quantity driver, if at least one of its destination accounts assigns costs using a fixed quantity driver, then the DQF for that assignment makes for a non-zero TDQCalc for that destination account, and hence for a non-zero TDQ. And, this is the Dest.TDQ for the account that uses the variable quantity driver.

**SoldQty**

You can determine the quantity demanded for a product by specifying SoldQty for some destination account of a source account that uses a variable quantity driver.
Variable Driver Quantities and Fixed Driver Quantities

You can use both variable quantities and fixed quantities in a single driver.

For example, suppose that $100.00 in the resource account Salary flows into two activity accounts, Take Orders and Process Orders. The costs that flow through a basic, fixed-quantity and variable-quantity driver are shown in the following figure:

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Cost</th>
<th>Instructions Name</th>
<th>Cost</th>
<th>DQF</th>
<th>DQV</th>
<th>TDD</th>
</tr>
</thead>
<tbody>
<tr>
<td>RESouce FRI</td>
<td>$100.00</td>
<td>New York x Take Orders</td>
<td>$75.69</td>
<td>2.00</td>
<td>10.00</td>
<td>10.00</td>
</tr>
<tr>
<td>New York</td>
<td>$100.00</td>
<td>New York x Process Orders</td>
<td>$23.31</td>
<td>1.00</td>
<td>3.00</td>
<td>10.00</td>
</tr>
<tr>
<td>Salary</td>
<td>$100.00</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The driver quantity (DrvQtyCalc) for Salary is 133.00, which is calculated as follows:

<table>
<thead>
<tr>
<th>Account</th>
<th>(DQF)</th>
<th>(DQV x Dest.TDQ)</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>Take Orders</td>
<td>2.00</td>
<td>10.00 x 10.00</td>
<td>102.00</td>
</tr>
<tr>
<td>Process Orders</td>
<td>1.00</td>
<td>3.00 x 10.00</td>
<td>31.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>133.00</td>
</tr>
</tbody>
</table>

The unit cost that flows from Salary is calculated by dividing the total cost of Salary by the driver quantity of Salary: $100.00/133.00 = $0.7519.

So, the cost for each account is calculated as follows:
Weighted Driver Quantities

Weighted driver quantities are used with a weighted driver.

See Also

- “Weighted Drivers” on page 279
- “Driver Weight Fixed (DWF)” on page 656
- “Driver Weight Variable (DWV)” on page 657
- “Examples of Calculation” on page 399

Unique and Non-Unique (Shared) Driver Quantities

Unique Driver Quantities

Driver quantities determine the amount of a cost to distribute from a source account to destination accounts. A driver quantity can be unique or non-unique.

A unique driver quantity is a quantity for a destination account that can differ for every assignment to that destination account through the same driver. For each account that receives costs, you must specify the driver quantity.

Unique Driver Quantities

Each instance of the driver can have its own unique quantities.
Non-Unique (Shared) Driver Quantities

A non-unique driver quantity is a quantity for a destination account that is identical for every assignment to that destination account through the same driver. You specify the driver quantity once for the destination account, and that driver quantity is applied to all assignments. If you determine that you must put the same driver quantity on multiple destination accounts using the same driver, then that driver probably needs to be non-unique.

Non-Unique Driver Quantities

Every instance of the driver to the same account must have the same quantities. The quantities cannot be unique to the instance.

Changing Driver Quantities between Unique and Non-Unique

You can change a driver quantity from unique to non-unique, or vice versa, at any time, even after driver quantities have been calculated. If you change a non-unique driver quantity to a unique driver quantity, the driver quantity is copied to each destination account. If you change a unique driver quantity to a non-unique driver quantity, the first driver quantity that is encountered is copied to each destination account.

Suppose that the activities Take Orders and Process Orders flow costs to the cost objects Simple Product and Complex Product, as shown in the following figure:

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Cost</th>
<th>Driver Name</th>
<th>InscnmName</th>
<th>DQF</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACTIVITY (PRIMARY PA)</td>
<td>$100.00</td>
<td>Take Orders</td>
<td>No &lt; Customers&gt; x Simple Product</td>
<td>7.00</td>
</tr>
<tr>
<td>New York</td>
<td>$100.00</td>
<td></td>
<td>No &lt; Customers&gt; x Complex Product</td>
<td>10.00</td>
</tr>
<tr>
<td>Take Orders</td>
<td>$78.34</td>
<td>Basic Non-Unique</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Process Orders</td>
<td>$23.96</td>
<td>Basic Unique</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Cost</th>
<th>Driver Name</th>
<th>InscnmName</th>
<th>DQF</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACTIVITY (PRIMARY PA)</td>
<td>$100.00</td>
<td>Take Orders</td>
<td>No &lt; Customers&gt; x Simple Product</td>
<td>1.00</td>
</tr>
<tr>
<td>New York</td>
<td>$100.00</td>
<td></td>
<td>No &lt; Customers&gt; x Complex Product</td>
<td>2.00</td>
</tr>
<tr>
<td>Take Orders</td>
<td>$78.34</td>
<td>Basic Non-Unique</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Process Orders</td>
<td>$23.96</td>
<td>Basic Unique</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The driver for Take Orders is a basic, non-unique driver (named Basic Non-Unique). The driver for Process Orders is a basic, unique driver (named Basic Unique). Even though both activities flow costs to the same cost objects, the driver quantities for each cost object are different (the column DQF).

Now, suppose that the driver Basic Unique for the activity Process Orders is changed to the driver Basic Non-Unique. Because the driver quantities are now non-unique, the
driver quantities specified for the cost objects in the assignment to Take Orders are copied to the assignment to activity Process Orders. This is shown in the following figure:

In the previous example, a non-unique driver might be the best type because the number of orders processed for each product is probably the same number of orders taken for each product.

### Driver Sequencing

#### Overview

Driver sequencing allows you define multiple calculation passes through assignments such that the driver quantity (DQF or DQV) of a sequenced driver (in a subsequent pass) is based on a cost resulting from drivers that execute in a previous pass.

To create a sequenced driver:

1. Click the **Advanced** tab of the Driver Properties dialog and select **Use this sequence number**.
2. Select a sequence number greater than 1.
   
   By default, non-sequenced drivers have a sequence number of 1.
3. Select **Replace fixed quantity with** or **Replace variable quantity with** (or both) and select a cost from the drop down list.
   
   The cost that you select is used as the Driver Quantify Fixed (DQF) or Driver Quantity Variable (DQV) for the driver.
In the following example there are two workers and a manager. The two workers contribute a fixed portion (DQF) of their salary using a Basic driver to two activities, Activity 1 and Activity 2, as shown in the following table. By using a sequenced driver for the manager, you can base the manager’s cost contribution to the two activities on the relative contributions of the two people that the manager manages.

<table>
<thead>
<tr>
<th></th>
<th>DQF Activity 1</th>
<th>DQF Activity 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Worker 1</td>
<td>1</td>
<td>5</td>
</tr>
<tr>
<td>Worker 2</td>
<td>1</td>
<td>2</td>
</tr>
<tr>
<td>Manager</td>
<td>to be determined</td>
<td>to be determined</td>
</tr>
</tbody>
</table>

As the following picture shows, the driver quantities that are used for Driver 2 (the driver that executes in sequence 2 for the manager) are based on costs from the drivers that execute in sequence 1.
The following picture perhaps shows more clearly the processing sequence in the example under consideration. In a first pass, all drivers of sequence 1 are calculated. In this first pass the Manager's costs for Activity 1 and Activity 2 are calculated as $0. In a second pass, the Manager's costs are calculated based on the costs resulting from the first pass.

The following table summarizes the values shown in the preceding picture:

<table>
<thead>
<tr>
<th>Src. Cost (Salary)</th>
<th>DQF Activity 1</th>
<th>DQF Activity 2</th>
<th>Dst.Cost Activity 1</th>
<th>Dst.Cost Activity 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Worker 1</td>
<td>$1200</td>
<td>1</td>
<td>5</td>
<td>$200</td>
</tr>
<tr>
<td>Worker 2</td>
<td>$1200</td>
<td>1</td>
<td>2</td>
<td>$400</td>
</tr>
<tr>
<td>Manager</td>
<td>$1600</td>
<td>200+400=600</td>
<td>1000+800=1800</td>
<td>$400</td>
</tr>
</tbody>
</table>

Note: These overwritten values remain, even when you remove driver sequencing for the driver. To change the driver quantities, you must manually change them. Because of this potentially extensive impact on model data, SAS recommends that you define
a new driver for use with driver sequencing. You should not use an existing driver to experiment with driver sequencing.

**Misconceptions about Driver Sequencing**

The following list presents common misconceptions about driver sequencing:

- Every driver needs a sequence number.
  
  Specify a sequence number for a driver only when the driver quantities on the destination accounts need to be replaced. This replacement is the only function of driver sequencing.

- Every driver in an assignment path needs a sequence number.
  
  Do not specify a driver sequence in an attempt to indicate the calculation sequence between accounts in an assignment path. For example in the following picture specifying a sequence is unnecessary. The driver between Account A and Account B will automatically run before the driver between Account B and Account C.

![Account A ➔ Account B ➔ Account C](sequence-1-sequence-2)

- A sequenced driver is not paired with any particular previous driver. The cost that replaces the DQF or DQV for a sequenced driver is the cost for an account at the time the sequenced driver runs, regardless of what drivers have contributed to that cost. For example in the following picture, the DQF for Driver 3 is not just the cost resulting from Driver 2 - it is the cost resulting both from Driver 1 and Driver 2. More generally, the cost of a driver in a sequence is the cost resulting from all drivers in a previous sequence.

![Account A ➔ Driver 1, sequence 1 ➔ Driver 2, sequence 2 ➔ Driver 3, sequence 3 ➔ Account B](sequence-diagram)

---

**Idle Quantities**

**Overview**

Idle quantities are unused resources or unused time in a model. For example, if a machine can run for 10 hours a day, but is used for only eight hours a day, the idle quantity for that machine is two hours. You can assign the idle quantity to the destination accounts, as follows:
The 10 hours that the machine can run is specified in the user-entered total driver quantity (the column TDQUE). The eight hours that the machine is used is specified in the fixed-driver quantities (the column DQF; five hours for the Front Fender and three hours for the Rear Fender). The two hours of idle quantity is calculated by SAS Activity-Based Management (the column IdlQty; 10 TDQUE on the source account minus 8 DQF on the destination accounts).

You can specify how idle quantities are distributed for a driver. If you do not activate this feature, idle quantities are not displayed in an account’s hierarchy, and idle quantities are not used when an account’s cost is calculated.

To specify how idle quantities are distributed in an assignment, you can select one of the choices described below. The effect of each choice on the previous example is shown, based on the hourly cost of the machine (a press, in this example), which is $100.00.

**User-Entered Quantities**

If you choose to distribute idle quantities using user-entered quantities, you specify the idle quantities to be assigned to the idle components (the property idle quantity user-entered; the column IdlQtyUE). For example, you enter two hours for the Rear Fender.

<table>
<thead>
<tr>
<th>IntctnName</th>
<th>DQF</th>
<th>IdlQtyUE</th>
<th>IdlDrvQty</th>
<th>DrvldlCost</th>
</tr>
</thead>
<tbody>
<tr>
<td>North America x Front Fender</td>
<td>5.00</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>North America x Rear Fender</td>
<td>3.00</td>
<td>2.00</td>
<td>2.00</td>
<td>$200.00</td>
</tr>
</tbody>
</table>

The system-generated value for the idle driver quantity (the column IdlDrvQty) corresponds to your entry. After calculating the costs, the driver idle cost (the column DrvldlCost) is $200.00 (2.00 x $100.00).

**User Proportion Quantities**

If you choose to distribute idle quantities using user-proportioned quantities, you specify the proportions for the idle quantities (the property idle quantity user-entered; the column IdlQtyUE). For example, you enter 1 for the Front Fender and 3 for the Rear Fender.

<table>
<thead>
<tr>
<th>IntctnName</th>
<th>DQF</th>
<th>IdlQtyUE</th>
<th>IdlDrvQty</th>
<th>DrvldlCost</th>
</tr>
</thead>
<tbody>
<tr>
<td>North America x Front Fender</td>
<td>5.00</td>
<td>1.00</td>
<td>0.50</td>
<td>$50.00</td>
</tr>
<tr>
<td>North America x Rear Fender</td>
<td>3.00</td>
<td>3.00</td>
<td>1.50</td>
<td>$150.00</td>
</tr>
</tbody>
</table>

The total user-entered idle quantities is 4.00: 1.00 + 3.00. After calculating the costs, the idle driver quantity (the column IdlDrvQty) for the Front Fender is 0.50 (1/4 x 2.00), and the idle driver quantity for the Rear Fender is 1.50 (3/4 x 2.00).

Therefore, the driver idle cost (the column DrvldlCost) for the Front Fender is $50.00 (0.50 x $100.00). The driver idle cost for the Rear Fender is $150.00 (1.50 x $100.00).
Use Driver Quantities

If you choose to distribute idle quantities with driver quantities, the ratio of the driver quantities is used for assigning the idle quantities. For example, the ratio of the driver quantity for the Front Fender is 5/8 (5.00/(5.00+3.00)). The ratio of the driver quantity for the Rear Fender is 3/8 (3.00/(5.00+3.00)).

<table>
<thead>
<tr>
<th>IntsctnName</th>
<th>DQF</th>
<th>IdlQtyUE</th>
<th>IdlDrvQty</th>
<th>DrvIdlCost</th>
</tr>
</thead>
<tbody>
<tr>
<td>North America x Front Fender</td>
<td>5.00</td>
<td></td>
<td>1.25</td>
<td>$125.00</td>
</tr>
<tr>
<td>North America x Rear Fender</td>
<td>3.00</td>
<td></td>
<td>0.75</td>
<td>$75.00</td>
</tr>
</tbody>
</table>

After calculating the costs, the idle driver quantity (the column IdlDrvQty) for the Front Fender is 1.25 (5/8 x 2.00), and the idle driver quantity for the Rear Fender is 0.75 (3/8 x 2.00).

<table>
<thead>
<tr>
<th>IntsctnName</th>
<th>DQF</th>
<th>IdlQtyUE</th>
<th>IdlDrvQty</th>
<th>DrvIdlCost</th>
</tr>
</thead>
<tbody>
<tr>
<td>North America x Front Fender</td>
<td>5.00</td>
<td>1.00</td>
<td></td>
<td>$100.00</td>
</tr>
<tr>
<td>North America x Rear Fender</td>
<td>3.00</td>
<td>1.00</td>
<td></td>
<td>$100.00</td>
</tr>
</tbody>
</table>

Therefore, the driver idle cost (column DrvIdlCost) for the Front Fender is $125.00 (1.25 x $100.00). The driver idle cost for the Rear Fender is $75.00 (0.75 x $100.00).

Evenly Assigned Quantities

If you choose to distribute idle quantities with evenly assigned quantities, the idle quantities are divided evenly among the destination accounts. For example, each of the destination account’s idle quantity is 1.00, which is half of the source account’s idle quantity of 2.00.

See Also

“Idle Flow” on page 414

Independent TDQ

Introduction

The following picture shows the relationships that existed among several properties before the current release of SAS Activity-Based Management:
TDQ defaulted to OutQty unless overridden by TDQUE.

OutQty defaulted to UsedQty unless overridden by OutQtyUE.

DriverRate is based on TDQ.

DriverRate is a key value that is used to determine the costs that flow out along assignment paths.

UnitCost is based on OutQty.

**The Problem**

If a modeler wants to use a unit cost that is not the same as UnitCost as calculated by the system (UnitCost=Cost/OutQty), the desired way is to specify OutQtyUE. Because OutQtyUE overrides OutQty, it follows that UnitCost=Cost/OutQtyUE.

However, because TDQ defaulted to OutQty, and OutQty defaulted to UsedQty unless overridden by OutQty was overridden by OutQtyUE. But, if OutQty was overridden by OutQtyUE so that TDQ equalled OutQtyUE, then it followed that Driver Rate equalled UnitCost. That is, if TDQ=OutQtyUE, then Driver Rate (which is Cost/TDQ) equals Cost/OutQtyUE (which is UnitCost).

Moreover, because the DriverRate determines the costs that flow out along assignment paths, the outgoing costs are more or less than the incoming costs, which is not the intended effect of specifying OutQtyUE.

**Starting with 7.2**

The solution, starting with 7.2, is to decouple TDQ from OutQty so that TDQ always defaults to UsedQty, as shown in the following picture. Now, a change in OutQtyUE affects UnitCost, but it does not affect TDQ or DriverRate.
Does Anything Else Change?

The measure TDQ is now added to fact tables, as are the following measures:

<table>
<thead>
<tr>
<th>Measure</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total Driver Quantity (TDQ)</td>
<td>TDQ</td>
</tr>
<tr>
<td>Driver Rate</td>
<td>Cost / TDQ</td>
</tr>
<tr>
<td>Revenue Rate</td>
<td>Revenue / TDQ</td>
</tr>
<tr>
<td>Profit Rate</td>
<td>Profit / TDQ</td>
</tr>
</tbody>
</table>

Does the Change Affect Existing Models?

One Case Where it Does

There is one case in which the change makes a difference. If you examine the previous pictures, you can see that there is only one case in which cost flow would be different in the current release than it was in previous releases. This is the case in which for a particular assignment:

- OutQtyUE is specified
- TDQUE is null

In previous releases, TDQ=OutQtyUE (unless TDQ is overridden by TDQUE). In the current release, TDQ=UsedQty (unless overridden by TDQUE).

The migration of models from previous releases (and the importing of models from previous releases using XML) ensures that there is no change in cost flow by doing the following for any account that uses OutQtyUE but not TDQUE:

- Migration copies the value of OutQtyUE into TDQUE. Because TDQUE overrides TDQ, this gives TDQ the value of OutQtyUE, just as it would have received in previous releases.

You do not need to make any adjustments for any model that you define using SAS Activity-Based Management 7.2.
If You Import from Staging Tables

If you have a model from a previous release stored in staging tables that you plan to import into SAS Activity-Based Management 7.2, and if that model has an account that uses OutQtyUE but not TDQUE, then to ensure that there is no difference between cost flows in 7.2 and previous releases, you must manually adjust values in the Account staging table and the External Unit staging table. Copy OutQtyUE to TDQUE when TDQUE is null. If an OutQtyUE column does not exist, then nothing needs to be done.

The reason that you must do this manually is because staging tables contain no version identification. The import process is unable to distinguish models from earlier releases for which this must be done, and models from the current release for which this should not be done.

You do not need to make any adjustments for any model that you define using SAS Activity-Based Management 7.2.

Important Notice

If you have a model from a previous release such as described above (where the value of OutQtyUE gets copied into TDQUE), and you want to make certain further changes to the model, then you must make a corresponding change to TDQUE. In previous releases of SAS Activity-Based Management, you generally specified OutQtyUE to represent the demand factor for variable quantity drivers. Now, you generally specify SoldQty instead. So, if now you want to modify the demand factor for a variable quantity driver by modifying SoldQty for the driver’s destination accounts, then you must also zero out TDQUE for the source account. If you do not zero out TDQUE, then it will override the value that you specify for SoldQty, and your change to SoldQty will have no effect.

One Further Effect

If, as described here, the following was true in a model from a previous release:

- TDQUE is not specified
- OutQtyUE is null
- OutQtyUE < TDQCalc

And, if that model is brought into SAS Activity-Based Management such that the adjustment described above is made (OutQtyUE is copied to TDQUE when TDQUE is null), then the following occurs: TDQUE < TDQCalc.

That is, if (OutQtyUE < TDQCalc) and (OutQtyUE=TDQUE) then (TDQUE < TDQCalc)

But, when TDQUE < TDQCalc, it means that there is a negative IdleQty, which doesn't make sense. If this happens, then you must change the model to eliminate the error.
Reciprocal Costing

Overview

Reciprocal costing is a technique that enables costs to be shared between two or more accounts in the same module. With reciprocal costing, part of an account’s cost flows to another account, and part of that account’s cost flows back to the original account.

You create reciprocal costs by creating an assignment from an account or from an internal bill of costs.

*Note:* In the Model Summary window, reciprocal cost assignments are referred to as cycles.

For example, suppose that part of the cost of the Information Technology (IT) department is based on how much time IT personnel spend maintaining the computers in the Human Resources (HR) department. Part of the cost of the HR department is based on how much time HR personnel spend hiring IT workers. These two activities are reciprocal accounts because they share costs.

Creating Reciprocal Costs

You create reciprocal costs by creating an assignment from an account or from an internal bill of costs.

Reciprocal Costing Guidelines

When you use an internal bill of costs to create a reciprocal cost, consider the following points:

- You can attach more than one reciprocal internal bill of costs within the same module.
- You must attach an internal bill of costs to a third account so that costs can flow out of the reciprocal cost assignment. Otherwise, the two accounts in the reciprocal cost assignment create a continuous loop.

Reciprocal Costs Calculation

Reciprocal costs are calculated using simultaneous equations. This means that the costs that are shared between accounts A and B are calculated at the same time, as shown below:
Drivers View

About the Drivers View

On the Drivers view, you can manage a model's drivers, the types of drivers, and the driver quantities.

Note: You cannot directly edit the information on the Drivers view.

How to Access the Drivers View

Open a model in Model mode and select Model ➔ Drivers.

Create a Driver

1. Select DRIVERS.
2. Select Edit ➔ New Driver.

The New Driver dialog box appears.

The calculations:

<table>
<thead>
<tr>
<th>R1</th>
<th>R2</th>
<th>The results:</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.50</td>
<td>2500</td>
<td>R1 = $1,794.87</td>
</tr>
<tr>
<td>$1,500</td>
<td>2500</td>
<td>R2 = $2,948.72</td>
</tr>
<tr>
<td>25%</td>
<td>10%</td>
<td>A1 = $897.44</td>
</tr>
<tr>
<td>50%</td>
<td>90%</td>
<td>A2 = $3,102.56</td>
</tr>
</tbody>
</table>

The equations:

\[
\begin{align*}
R1 &= 1500 + 0.10B \\
R2 &= 2500 + 0.25A \\
A1 &= 0.5A \\
A2 &= 0.25A - 0.5B \\
\end{align*}
\]

The results:

<table>
<thead>
<tr>
<th>R1</th>
<th>R2</th>
<th>A1</th>
<th>A2</th>
</tr>
</thead>
<tbody>
<tr>
<td>$1,794.87</td>
<td>$2,948.72</td>
<td>$897.44</td>
<td>$3,102.56</td>
</tr>
</tbody>
</table>
**Review or Change the Properties of a Driver**

1. Select a driver.
2. Select Edit ➔ Item Properties.
   
   The Driver Properties dialog box appears.

---

**New Driver Dialog Box**

**About the New Driver Dialog Box**

In the New Driver dialog box, you can name a new driver and you can specify other information about the driver.

*Note:* The availability of these features depends on your permissions.

**How to Access the New Driver Dialog Box**

On the Drivers view, select Edit ➔ New Driver.

**Specify General information**

The General tab contains the following options.
Name
See “Naming Conventions” on page 81.

Driver type
See “Types of Drivers” on page 270.

This driver's quantities are unique
See “Unique and Non-Unique (Shared) Driver Quantities” on page 296.

Allow fixed driver quantities for this driver
See “Fixed Driver Quantities, Variable Driver Quantities, and Weighted Driver Quantities” on page 293.

Allow variable driver quantities for this driver
See “Fixed Driver Quantities, Variable Driver Quantities, and Weighted Driver Quantities” on page 293.

Allow weighted driver quantities for this driver
See “Weighted Drivers” on page 279.

Formula Builder
Click Formula Builder to define a formula for a calculated driver. See “Calculated Drivers” on page 273.

For information on formulas, see “Formula Builder Dialog Box” on page 343.

Use Rule Formula
Select Use Rule Formula if you want the driver to be a rule-based driver. See “Rule-based Drivers” on page 281. Then click Formula Builder to create the formula that determines assignments.
The Formula Builder dialog box appears. See “Formula Builder Dialog Box” on page 343.

Note: If you create a formula for the rule and run calculate to create assignments, then you can subsequently uncheck Use Rule Formula to cause calculate not to create assignments based on the rule formula. The rule formula is retained, but calculation ignores it. This allows you to run calculation once to create the assignments, and then remove some of those assignments or add additional ones. If you have done this, then you do not want calculate to restore the assignments that you removed or remove the assignments that you added. You can also turn off all rule formulae by selecting Disable Driver Rules during calculate.

Specify Advanced Information

The Advanced tab contains the following options.

Assign idle quantities using this method
Select this option to choose one of the following methods for flowing idle quantities:
• User Entered
• User Proportion
• Use Driver Quantities
• Evenly Assign

See “Idle Quantities” on page 301.

The following options apply to Driver Sequencing. See “Driver Sequencing” on page 298.

Use this sequence number.
Specify a number in the box on the right.

Replace fixed quantity with
If you select this option, then choose a numeric property from the menu on the right.

Note: This option is only available for Basic, Bill of Costs, and Weighted drivers.
Replace variable quantity with
If you select this option, then choose a numeric property from the menu on the right.

*Note:* This option is only available for Basic, Bill of Costs, and Weighted drivers.

The following option applies to **User Cost Allocation**. See “**User-Entered Cost Allocation**” on page 292.

**Allow user-entered cost allocation**
If you allow user-entered cost allocation, then you can assign a specific cost to an assignment by setting the Driver Allocated Cost (DrvAllocCost) property. See “**Driver Allocated Cost (DrvAllocCost)**” on page 648.

---

**Driver Properties Dialog Box**

**About the Driver Properties Dialog Box**

The availability of these features depends on your permissions.

In the Driver Properties dialog box, you can review or change the properties of a driver.

**How to Access the Driver Properties Dialog Box.**

On the Drivers view, select a driver and select **Edit ⇒ Item Properties**.

**Specify General Information**

The **General** tab contains the following options.
Name
See “Naming Conventions” on page 81.

Driver type
See “Types of Drivers” on page 270.

This driver's quantities are unique
See “Unique and Non-Unique (Shared) Driver Quantities” on page 296.

Allow fixed driver quantities for this driver
See “Fixed Driver Quantities, Variable Driver Quantities, and Weighted Driver Quantities” on page 293.

Allow variable driver quantities for this driver
See “Fixed Driver Quantities, Variable Driver Quantities, and Weighted Driver Quantities” on page 293.

Allow weighted driver quantities for this driver
See “Weighted Drivers” on page 279.

Formula Builder
Click Formula Builder to define a formula for a calculated driver. See “Calculated Drivers” on page 273.

For information on formulas, see “Formula Builder Dialog Box” on page 343.

Use Rule Formula
Select Use Rule Formula if you want the driver to be a rule-based driver. See “Rule-based Drivers” on page 281. Then click Formula Builder to create the formula that determines assignments.
The Formula Builder dialog box appears. See “Formula Builder Dialog Box” on page 343.

Note: If you create a formula for the rule and run calculate to create assignments, then you can subsequently uncheck Use Rule Formula to cause calculate not to create assignments based on the rule formula. The rule formula is retained, but calculation ignores it. This allows you to run calculation once to create the assignments, and then remove some of those assignments or add additional ones. If you have done this, then you do not want calculate to restore the assignments that you removed or remove the assignments that you added. You can also turn off all rule formulæ by selecting Disable Driver Rules during calculate.

Specify Advanced Information

The Advanced tab contains the following options.

Note: The available options depend on the type of driver that is being edited.

The following option applies to Idle Cost Assignment.

Assign idle quantities using this method
Select this option to choose one of the following methods for flowing idle quantities:

- User Entered
- User Proportion
- Use Driver Quantities
- Evenly Assign

See “Idle Quantities” on page 301.

The following options apply to Driver Sequencing. See “Driver Sequencing” on page 298.

Use this sequence number.
Specify a number in the box on the right.

Replace fixed quantity with
If you select this option, then choose a numeric property from the menu on the right.

Note: This option is only available for Basic, Bill of Costs, and Weighted drivers.
Replace variable quantity with
If you select this option, then choose a numeric property from the menu on the right.

Note: This option is only available for Basic, Bill of Costs, and Weighted drivers.

The following option applies to User Cost Allocation. See “User-Entered Cost Allocation” on page 292.

Allow user-entered cost allocation
If you allow user-entered cost allocation, then you can assign a specific cost to an assignment by setting the Driver Allocated Cost (DrvAllocCost) property. See “Driver Allocated Cost (DrvAllocCost)” on page 648.
Chapter 28
How To

Create a Driver

Open the New Driver Dialog
1. Open a model in Model mode, and select Model ⇒ Drivers.
   The Drivers page appears.
2. Select Edit ⇒ New Driver.

   Or, right-click the DRIVERS folder and select DRIVERS.

   The New Driver dialog box appears.
Specify General Information

The General tab contains the following options.

Name
See “Naming Conventions” on page 81.

Driver type
See “Types of Drivers” on page 270.

This driver's quantities are unique
See “Unique and Non-Unique (Shared) Driver Quantities” on page 296.
Allow fixed driver quantities for this driver
See “Fixed Driver Quantities, Variable Driver Quantities, and Weighted Driver Quantities” on page 293.

Allow variable driver quantities for this driver
See “Fixed Driver Quantities, Variable Driver Quantities, and Weighted Driver Quantities” on page 293.

Allow weighted driver quantities for this driver
See “Weighted Drivers” on page 279.

Formula Builder
Click Formula Builder to define a formula for a calculated driver. See “Calculated Drivers” on page 273.

For information on formulas, see “Formula Builder Dialog Box” on page 343.

Use Rule Formula
Select Use Rule Formula if you want the driver to be a rule-based driver. See “Rule-based Drivers” on page 281. Then click Formula Builder to create the formula that determines assignments.

The Formula Builder dialog box appears. See “Formula Builder Dialog Box” on page 343.

Note: If you create a formula for the rule and run calculate to create assignments, then you can subsequently uncheck Use Rule Formula to cause calculate not to create assignments based on the rule formula. The rule formula is retained, but calculation ignores it. This allows you to run calculation once to create the assignments, and then remove some of those assignments or add additional ones. If you have done this, then you do not want calculate to restore the assignments that you removed or remove the assignments that you added. You can also turn off all rule formulae by selecting Disable Driver Rules during calculate.

Specify Advanced Information

The Advanced tab contains the following options.

Note: The available options depend on the type of driver that is being edited.

The following option applies to Idle Cost Assignment.
Assign idle quantities using this method
Select this option to choose one of the following methods for flowing idle quantities:

- User Entered
- User Proportion
- Use Driver Quantities
- Evenly Assign

See “Idle Quantities” on page 301.

The following options apply to Driver Sequencing. See “Driver Sequencing” on page 298.

Use this sequence number.
Specify a number in the box on the right.

Replace fixed quantity with
If you select this option, then choose a numeric property from the menu on the right.

Note: This option is only available for Basic, Bill of Costs, and Weighted drivers.

Replace variable quantity with
If you select this option, then choose a numeric property from the menu on the right.

Note: This option is only available for Basic, Bill of Costs, and Weighted drivers.

The following option applies to User Cost Allocation. See “User-Entered Cost Allocation” on page 292.

Allow user-entered cost allocation
If you allow user-entered cost allocation, then you can assign a specific cost to an assignment by setting the Driver Allocated Cost (DrvAllocCost) property. See “Driver Allocated Cost (DrvAllocCost)” on page 648.

Specify the Default Driver

1. Select Model ⇒ Properties.
   The Model Properties dialog box appears.
2. Click the General tab.

3. In the Module Default Driver Options section, select a default driver for each module.

The drivers that are available for the External Units module include all drivers of type Bill of Cost.

**Note:** If you delete a driver that is used, all accounts using the driver are flagged as using the module’s default driver. If there is no default driver, then the account is flagged as having no driver (i.e. undefined). If you delete the default driver, then the default driver is set to “undefined”.

---

### Create an Assignment

1. Decide which assignments panes to show by selecting either:
   - **Model ⇄ Assignments ⇄ Show Left Assignments Pane**
   - **Model ⇄ Assignments ⇄ Show Right Assignments Pane**
   - **Model ⇄ Assignments ⇄ Show Left and Right Assignments Pane**

2. Select either:
   - **Model ⇄ Assignments ⇄ Add Accounts in Left Pane**
   - **Model ⇄ Assignments ⇄ Add Accounts in Right Pane**

The Add Accounts for Assignments dialog box appears.
3. From **Show accounts from this module**, select an option.

4. From the list of accounts, select an account.
   
   You can select multiple accounts by using standard Microsoft Windows selection techniques.
   
   If you select a roll-up account, all accounts within that roll-up account are added.
   
   **Note:** You cannot select the module roll-up and add all accounts within it.

5. Click **Add Accounts**.
   
   The accounts are added to the grid.
   
   **Note:** You can leave this dialog box open to add more accounts individually.

6. Click **Close**.

7. Select the destination account.

8. To assign the cost to an account in the right assignments pane, click the arrowhead to the left of the account.
   
   An arrow connects the two accounts.

   To assign the cost from an account in the left assignments pane, click the arrowhead to the right of the account.
T I P  
To quickly create assignments to many accounts, select Model ⇒ Assignments ⇒ Assign All Left, Assign All Right, or Assign All Left and Right.

## Associate a Driver Using an Account's Item Properties

1. In the Resource module, Activity module, or Cost Object module, select an account.
2. Select Edit ⇒ Item Properties.

   The Item Properties dialog box appears.

3. Click the Properties tab.
4. From the Properties list, locate the Driver Name property.
5. Click in the Value column and select a driver.
1. In the Resource module, Activity module, or Cost Object module, add a column to display the **Driver Name** property.

2. Click in the **DrvName** column and select a driver.
Show Only the Source Accounts for a Driver

1. Select Model ⇒ Assignments ⇒ Show Left Assignments Pane.
   The view is split to include an empty left assignments pane. The selected module is displayed in the primary pane on the right.
2. Expand the module hierarchy and select an account.
3. Select Model ⇒ Assignments ⇒ Show Left.
   Arrows indicate the accounts that contribute costs to the selected account.

Show Only the Destination Accounts for a Driver

1. Select Model ⇒ Assignments ⇒ Show Right Assignments Pane.
   The view is split to include an empty right assignments pane. The selected module is displayed in the primary pane on the left.
2. Expand the module hierarchy and select an account.
3. Select Model ⇒ Assignments ⇒ Show Right.
   Arrows indicate the accounts that receive costs from the selected account.

Show the Source Accounts and the Destination Accounts for a Driver

1. Select Model ⇒ Assignments ⇒ Show Left and Right Assignments Panes.
   The view is split to include empty left and right assignments panes. The selected module is displayed in the primary pane in the center.
2. Expand the module hierarchy and select an account.
3. Select Model ⇒ Assignments ⇒ Show Left and Right.
   Arrows indicate the accounts that contribute costs to the selected account, as well as to the accounts that receive costs from the selected account.
Part 10

Using Formulas with Drivers and Calculated Attributes

Chapter 29
Formulas ................................................................. 329

Chapter 30
Boolean Functions ....................................................... 347

Chapter 31
Numeric Functions ....................................................... 353

Chapter 32
String Functions .......................................................... 357

Chapter 33
Properties That Can Be In Formulas .............................. 361
Chapter 29
Formulas

Formula ................................................................. 330
Overview ............................................................ 330
Using attributes in a formula .................................... 330
Source account and destination accounts ....................... 330
Property names in formulas ........................................ 331
Properties for a source account and a destination account 331
Testing formulas ..................................................... 331
Using attribute names .............................................. 331

Functions ............................................................. 331

Formula Context ..................................................... 332
Overview ............................................................ 332
Qualifying Properties .............................................. 333
An Example ......................................................... 335

Enhanced Formula Capabilities ................................... 337
Overview ............................................................ 337
New Features ......................................................... 338
New Functions ....................................................... 338
Changed Functionality ............................................ 339
Limitations ............................................................ 339

Using Numeric Attributes in a Formula ......................... 340
Overview ............................................................ 340
Using a Calculated Numeric Attribute ......................... 340
Using a Calculated Attribute in the Driver Formula of a Calculated Driver 341
Determining the Value of a Numeric Attribute ............... 341

Troubleshooting Formulas ......................................... 341
Using Cost in a Formula ........................................... 341
Troubleshooting String Expressions ............................ 342

Operator Precedence ................................................ 343

Formula Builder Dialog Box ....................................... 343
Overview ............................................................ 344
How to Access the Formula Builder Dialog Box ............. 344
Components .......................................................... 345
Define a formula ...................................................... 346
A formula consists of expressions made up of the following elements that are evaluated in a context:

- strings and the string concatenation operator &
- Boolean operators: NOT, AND, OR
- numbers and numerical operators +, -, *, /, **, %, (, )
- relational operators <, <=, =, >=, >, <>
- functions
- system-defined properties
- user-defined attributes
- user-defined dimensions and dimension members
- user-defined dimension attributes and dimension member attributes
- system-defined dimensions: Module, Period, Scenario

Note: See “Operator Precedence” on page 343.

Use the Formula Builder dialog box to create a formula for use with a:

- calculated driver (See “Calculated Drivers” on page 273.)
- rule-based driver (See “Rule-based Drivers” on page 281.)
- calculated attribute (See “Calculated Attributes” on page 184.)

Using attributes in a formula

To include user-defined attributes, you must create these attributes before you define a formula.

If you use an attribute in a calculated driver formula, you must add that attribute to all destination accounts of the assignment before running any calculations. When you add the attribute, enter the appropriate values for both the numeric attribute and the driver quantity. The numeric attribute and the driver quantity must contain values; they cannot be blank. You can add the attribute either before defining the calculated driver, or after. The numeric attribute must be added before you run a calculation. Otherwise, you might encounter errors, or costs might be calculated as zero.

Source account and destination accounts

A formula can use the numeric properties and numeric attributes of a source account or a destination account. In the SAS Activity-Based Management interface, the list of numeric properties includes the keywords [Source] and [Destination]. When you select either of the keywords to include in a formula, you see the notation Source. or Destination., followed by a property or attribute. For example, Source.Cost or Destination.UnitCost.
Note: By default in the formula for a calculated driver and for a rule-based driver, properties and attributes refer to destination accounts.

**Property names in formulas**

The property names in formulas are the same as the property names that you see elsewhere in SAS Activity-Based Management, except that the spaces are removed. For example, the property Allocated Cost is `AllocatedCost` in a formula.

Occasionally, the property name that is used in a formula contains an abbreviation, such as `DimLevelName` for the property Dimension Level Name, or `TDQ` for the property Total Driver Quantity.

**Properties for a source account and a destination account**

You can access the values of properties for a source account or a destination account. To access the properties for a source account, use the keyword `[Source]`, a period (`.`), and a property name. For example, `Source.Cost`. To access the properties for a destination account, use the keyword `[Destination]`. Both of the keywords are available when you define a formula.

**Testing formulas**

Testing a formula validates the operators and ensures that there are no spaces in the formula. However, numeric properties and numeric attributes are not validated. Testing does not guarantee that the formula is valid or that the formula will yield the intended value.

During calculation, if a formula references an item that does not exist, a warning is displayed. If you use an invalid formula, SAS Activity-Based Management halts the calculation as soon as it encounters the invalid formula. Subsequent values in the model are not calculated.

**Using attribute names**

To ensure that SAS Activity-Based Management correctly interprets any special characters or spaces in a numeric attribute name, enclose the name in double quotation marks (`"`). You do not need to use quotation marks for names of numeric properties.

For example, in the following formula, `OutputQuantity` does not require quotation marks because it is a system-defined numeric property. But, `Units Per Pallet` requires quotation marks because that name contains spaces.

`OutputQuantity/"Units Per Pallet"`

**Functions**

A function is an expression that takes zero or multiple values as input and returns a single value. You can use functions as part of a formula that is used in a:

- calculated driver (See “Calculated Drivers” on page 273.)
- rule-based driver (See “Rule-based Drivers” on page 281.)
SAS Activity-Based Management makes available the following functions:

<table>
<thead>
<tr>
<th>Boolean functions</th>
<th>Numeric functions</th>
<th>String functions</th>
</tr>
</thead>
<tbody>
<tr>
<td>HasAttribute</td>
<td>abs</td>
<td>&amp;</td>
</tr>
<tr>
<td>if</td>
<td>degrees</td>
<td>find</td>
</tr>
<tr>
<td>IsChildOf</td>
<td>exp</td>
<td>left</td>
</tr>
<tr>
<td>IsClose</td>
<td>max</td>
<td>len</td>
</tr>
<tr>
<td>IsNull</td>
<td>min</td>
<td>mid</td>
</tr>
<tr>
<td>Match</td>
<td>pi</td>
<td>right</td>
</tr>
<tr>
<td></td>
<td>power</td>
<td>str</td>
</tr>
<tr>
<td></td>
<td>quotient</td>
<td>trim</td>
</tr>
<tr>
<td></td>
<td>radians</td>
<td>value</td>
</tr>
<tr>
<td></td>
<td>round</td>
<td></td>
</tr>
<tr>
<td></td>
<td>sign</td>
<td></td>
</tr>
<tr>
<td></td>
<td>sqrt</td>
<td></td>
</tr>
<tr>
<td></td>
<td>trunc</td>
<td></td>
</tr>
</tbody>
</table>

When including a function in a formula, it is important to remember that every function is evaluated in a context.

*Note:* Function parsing was developed using ANTLR2 software.

### See Also

- “Enhanced Formula Capabilities” on page 337
- “Formula” on page 330
- “Formula Context” on page 332
- “Troubleshooting Formulas” on page 341
- “Using Numeric Attributes in a Formula” on page 340

### Formula Context

#### Overview

A formula consists of expressions made up of the following elements:

- strings and the string concatenation operator &
• Boolean operators: NOT, AND, OR
• numbers and numerical operators +, -, *, /***, %, (, )
• relational operators <, <=, =, >=, > <>
• functions
• system-defined properties
• user-defined attributes
• user-defined dimensions and dimension members
• user-defined dimension attributes and dimension member attributes
• system-defined dimensions: Module, Period, Scenario

Note: See “Operator Precedence” on page 343.

Some expressions are not dependent on context. For example the string ABC and the number 2010 refer to the same thing regardless of context. Other expressions, such as attributes and properties depend on context. The property Cost, for example, only has a value relative to an account or an assignment. Hence, you should be aware of the following principles concerning formulas:

calculated driver
The formula for a calculated driver is calculated in the context of an assignment from each source account to which the driver is attached and each destination account, in turn, from that source account.

By default, properties and attributes in the formula refer to the destination account.

rule-based driver
The formula for a rule-based driver is calculated in the context of an assignment from each source account to which the driver is attached and each potential destination account, in turn, from that source account.

By default, properties and attributes in the formula refer to the destination account.

calculated attribute
The formula for a calculated attribute is evaluated in the context of an account.

Qualifying Properties
When you include a property in a formula, you can qualify the name of the property to specify unambiguously which property you are referring to. Although qualifiers may not be necessary in a particular case, you are always allowed to use up to two levels of qualifiers:

```plaintext
Source Dimension Reference Property
Destination
```

For example: Source.Product.OutputQuantity

Following are some examples:
Example
Products.DimMemRef
Source.Products.DimMemRef
Destination.Products.DimMemRef

Explanation
In this example, "Products" is a dimension reference. When unqualified with either Source or Destination, Destination is assumed.

When you create a dimension member you must specify its reference.

When the dimension member is displayed in an assignments pane, its column header is labelled DimMemRef to distinguish it from the column for an account reference.

Example
Products.DrivableCost
Source.Products.DrivableCost
Destination.Products.DrivableCost

Explanation
In this example, "Products" is a dimension reference. When unqualified with either Source or Destination, Destination is assumed.
Example

Module.DimMemRef

Destination.Module.DimMemRef

Source.Module.DimMemRef

Explanation

Possible values for Module.DimMemRef are:

- "ExternalUnit"
- "Resource"
- "Activity"
- "CostObject"

You can use Module.DimMemRef in expressions such as Module.DimMemRef="CostObject".

Example

Period.2009

Explanation

Quotation marks are not required around the name of the period.

Example

Scenario.Budget

Explanation

Quotation marks are not required around the name of the scenario.

An Example

Let's consider an extended example using the Parcel Express Tutorial. The tutorial model has the following module dimensions:

- **Resource**
  - Region
  - General Ledger
- **Activity**
  - Region
  - Activities
- **Cost Object**
  - Region
  - Channel
  - Products and Services
- **External Unit**
- **Profitability**

The dimensions have the following dimension members.
Now let’s consider an assignment, shown in the picture below, from the following source account in the Activity module:

<table>
<thead>
<tr>
<th>Region Dimension Member</th>
<th>Activity Dimension Member, Level 1</th>
<th>Activity Dimension Member, Level 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton</td>
<td>Personnel Intensive Activities</td>
<td>Expedite Package Shipments</td>
</tr>
</tbody>
</table>

To the following destination account in the Cost Object module:

<table>
<thead>
<tr>
<th>Region Dimension Member</th>
<th>Channel Dimension Member</th>
<th>Products and Services Dimension Member</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton</td>
<td>None</td>
<td>2nd Day Guaranteed</td>
</tr>
</tbody>
</table>

Now let’s assume that the destination account is the context account for this example. As the picture below shows, the following expressions that might appear in a formula have the value shown in the following table:

<table>
<thead>
<tr>
<th>Formula Expression</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Destination.Region.DimMemRef</td>
<td>Beaverton</td>
</tr>
<tr>
<td>Destination.Prod_Serv.DimMemRef</td>
<td>2nd Day Guaranteed</td>
</tr>
<tr>
<td>Destination.Chnnl.DimMemRef</td>
<td>None</td>
</tr>
</tbody>
</table>
Enhanced Formula Capabilities

Overview

Significant new capabilities have been added to SAS Activity-Based Management for creating the formula (rule formula) of a rule-based driver. You can use these same enhanced capabilities to create the driver formula for a calculated driver or the formula for a calculated attribute. These enhanced capabilities include:

<table>
<thead>
<tr>
<th>Formula Expression</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source.Region.DimMemRef</td>
<td>Beaverton</td>
</tr>
<tr>
<td>Source.Act.DimMemRef</td>
<td>Expedite Package Shipments</td>
</tr>
</tbody>
</table>

**Note:** It is very important to note that you refer to a null intersection with the constant None. The destination account is the intersection of the following dimension members:

<table>
<thead>
<tr>
<th>Region Dimension Member</th>
<th>Channel Dimension Member</th>
<th>Products and Services Dimension Member</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton</td>
<td>None</td>
<td>2nd Day Guaranteed</td>
</tr>
</tbody>
</table>

Even though the column for the intersection name shows No <Channel> for display purposes, you should use the internal name None in your formulas.
New Features

- String support
  - String (text) values are fully supported inside formulas, including the string values of text attributes.
  - You can use the following string properties of an account in any formula: Reference, Name, and DriverName.
  - You can use the following string properties of an account’s intersection dimension members in any formula: Reference (or DimMemRef), Name (or DimMemName), Level, and LevelNumber.

- Access to properties
  - You can access the properties of an account’s intersection dimension members as well as the properties of attribute dimension members.
  - You can reference the system-defined dimensions Period, Scenario, and Module in any formula.

- Functionality for calculated drivers
  - The driver formulas for Calculated Drivers can access cost and revenue properties on accounts.
    
    **Note:** If cost properties are used, you should use driver sequencing or the cost properties will be zero.
  - You can use calculated drivers in the External Units module.

New Functions

**Boolean**

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>HasAttribute(s)</td>
<td>Determines if an attribute is associated with an account</td>
</tr>
<tr>
<td></td>
<td><em>Note:</em> You can use the new HasAttribute() function with Tag (Boolean) attributes as well as with Text and Numeric attributes.</td>
</tr>
<tr>
<td>IsChildOf(s)</td>
<td>Determines if a dimension member is a child of (self, immediate child, or descendent) of a given dimension member</td>
</tr>
<tr>
<td>Match(s1,&quot;s2&quot;)</td>
<td>Determines if string s1 matches a wildcard pattern s2.</td>
</tr>
<tr>
<td>isClose(n1,n2,digits)</td>
<td>Determines if two numbers are close, to accommodate floating point round-off issues</td>
</tr>
</tbody>
</table>
### String

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left(s,n)</td>
<td>Returns the leftmost characters of a string</td>
</tr>
<tr>
<td>Mid(s,pos,len)</td>
<td>Returns a substring of a source string</td>
</tr>
<tr>
<td>Right(s,len)</td>
<td>Returns the rightmost characters of a string</td>
</tr>
<tr>
<td>Str(s,size,dec)</td>
<td>Converts a number to a string</td>
</tr>
<tr>
<td>Trim(s)</td>
<td>Trims leading and trailing spaces</td>
</tr>
</tbody>
</table>

### Numeric

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Find(s1,s2)</td>
<td>Returns the position of string s1 within string s2.</td>
</tr>
<tr>
<td>Len(s)</td>
<td>Returns the length of a string</td>
</tr>
</tbody>
</table>

For a full list of functions, see Functions.

### Changed Functionality

Expressions with Null values evaluate to false in comparison (<, <=, =, >=, >, <>), and Null for all other operators. Note that "Null=Null" is false so the IsNull() function should be used when it is important to determine whether a value (or expression) is Null or not. Null values occur when:

- an attribute is not attached to any account and does not have a default value
- for some properties such as TDQUE and OutputQuantityUE.

### Limitations

1. Default values and formulas are not supported for Text attributes.
2. The following properties are not valid for use in the formula of a calculated driver and, therefore, do not appear in the Formula Builder drop-down list:
   - DriverQuantityBasic
   - IdleDriverQuantity

The reason is that in an assignment these quantities depend on DrvQtyCalc. Consequently, a vicious circle would be created if the formula were to make DrvQtyCalc depend on these quantities. That is, DrvQtyCalc could not be determined without first determining these quantities, and these quantities could not be determined without first determining DrvQtyCalc.
Using Numeric Attributes in a Formula

Overview

You can use both calculated numeric attributes and ordinary numeric attributes in a formula. All that you need to do is to refer to the attribute by its reference just as you would any property.

Note: If an attribute reference contains spaces or special characters, then you must enclose it in quotation marks.

Using a Calculated Numeric Attribute

In order to use a calculated attribute in a formula it is not necessary to attach the attribute to an account. It is sufficient that you refer to the attribute for the attribute's formula to be evaluated during calculation. This allows you to use calculated attributes to define common sub-expressions that are used by other formulas. This avoids cut-and-paste errors and allows for quick revisions without having to update multiple formulas. It also allows for the reusability of calculated attributes to define sub-expressions that can be reused by different drivers.

Example

Suppose you have the following three calculated drivers each with its driver formula as shown in the following table:

<table>
<thead>
<tr>
<th>Calculated Driver</th>
<th>Driver Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drvr1</td>
<td>(A / B) * (B / C)</td>
</tr>
<tr>
<td>Drvr2</td>
<td>(A / B) * 2</td>
</tr>
<tr>
<td>Drvr3</td>
<td>(B / C) * 3</td>
</tr>
</tbody>
</table>

Now, suppose you define the following calculated numeric attributes:

<table>
<thead>
<tr>
<th>Calculated Attribute</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rate1</td>
<td>(A / B)</td>
</tr>
<tr>
<td>Rate2</td>
<td>(B / C)</td>
</tr>
</tbody>
</table>

then you can modify the driver formula for each of the three calculated drivers to use a calculated attribute as shown in the following table:

<table>
<thead>
<tr>
<th>Calculated Driver</th>
<th>Driver Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drvr1</td>
<td>Rate1 * Rate2</td>
</tr>
<tr>
<td>Drvr2</td>
<td>Rate1 * 2</td>
</tr>
</tbody>
</table>
### Calculated Driver

| Drvr3  | Rate2 * 3 |

**Note:** The cascading evaluation of attribute formulas is fully supported. For example, suppose calculated attribute CA1 uses calculated attribute CA2, which in turn uses calculated attribute CA3, etc. There is no restriction on the depth of references, but it will be more difficult to troubleshoot with increasing depth. However, cyclic reference is not supported. For example, CA1 → CA2 → CA3 → CA1 is a cyclic reference (back to C1) and an error is reported when cyclic reference is encountered.

Of course, whenever a calculated attribute is attached to an account its calculated value is written to the model by the calculation. Even for sub-expression use, where you wouldn't normally attach the calculated attribute to an account, it can still be useful to attach it to one account when debugging complex formulas. When it is working you can then remove it from the account.

---

### Using a Calculated Attribute in the Driver Formula of a Calculated Driver

In the driver formula for a calculated driver you can use only properties that represent a quantity. Consequently, if such a formula contains a calculated attribute, then that calculated attribute should also use only properties that represent a quantity.

---

### Determining the Value of a Numeric Attribute

During calculation, when the system encounters a numeric attribute in a formula it uses the following precedence of rules for determining the attribute value. As soon as the system is able to determine the attribute value according to a rule it uses that value as the final calculation and does not consult any subsequent rule.

1. If it is a calculated attribute, then evaluate its formula and use the resulting value.
2. If the attribute is attached to the account, use the value of the attribute for that account.
3. If the attribute has a default value for the current period/scenario, then use the default value.
4. Use null as the attribute value.

---

### Troubleshooting Formulas

#### Using Cost in a Formula

This section explains why using cost properties in a formula (driver formula for a calculated driver, rule formula for a rule-based driver, or formula for a calculated attribute) can make it difficult to troubleshoot problems, describes some troubleshooting techniques, and provides guidelines for their use.

Whenever cost is used to determine flow, driver sequencing is required. When you use Cost in a formula, the actual value used comes from the previous sequence. So if a driver
uses sequence 3, then it takes Cost from the destination account after sequence 2 is evaluated. In the case where there is a single Cost property, the value is written to DQCalc and it is easy to determine what the value that was used.

More complicated formulas become more difficult. For instance, using a formula of "Cost / NumCalls" means that you would have to multiply DQCalc * NumCalls to determine the value of Cost that was evaluated in sequence 2 and used in sequence 3.

An even more complicated situation is where the formula uses a calculated attribute that in turn uses Cost. A common way to troubleshoot a calculated attribute is to attach it to an account, calculate through the sequence in question, and look at its value. This works well, but when Cost (or any cost property) is used in the attribute formula, a final evaluation is made before it is committed to the database to ensure that it uses the proper cost value. To see how this is significant you must understand how calculation orders its work:

Sequence Loop
1. Clear calculated attribute values
2. Create rule-based assignments (using rule formulas)
3. Consumption (eval DQCalc, using driver formulas)
4. Cost flow
End Loop

Clear calculated attribute values
Eval calculated attributes

In the steps above, calculated attributes can get evaluated during 2. Create rule-based assignments as a result of evaluating rule formulas and during 3. Consumption as a result of evaluating driver formulas. Notice that this occurs before 4. Cost flow. Numeric attributes need a final evaluation so that any use of cost properties is in sync with the final cost values. So the cost values used in calculated attributes could be different from those used by rule formulas or driver formulas. This could easily cause confusion when troubleshooting the actual values used. To find out what values are used, stop calculation on the sequence step before they are actually used by a rule formula or driver formula to see what their value is.

To avoid confusion consider the following guidelines
1. If all you need is to use a cost property for DQF or DQV, then use FixedDQOverride or VariableDQOverride respectively. This keeps it simple.
2. If you need a more complicated driver formula or rule formula that uses cost properties, avoid using calculated attributes that have cost properties in their formulas (directly or indirectly).
3. If you must use cost properties in the formula for a calculated attribute, keep their use to a minimum.

**Troubleshooting String Expressions**

A typical way to troubleshoot formulas is to put the formula in a calculated numeric attribute and attach the attribute to an account. This works as long as the formula has a numeric result. But for string expressions this is not an option because calculated text attributes do not exist in SAS Activity-Based Management. So, how can you troubleshoot string expressions when you aren’t getting the results you want?

A technique is to use the if(condition,then,else) function in a numeric formula, as in the following example:

```
If( Attr1 & Attr2 = "ABCD", 1, 0 )
```
This concatenates two attributes to see if they are a specific value and if they are returns a value of 1, and 0 if they aren't.

You aren't limited to concatenation—you can use any string expression and compare its results to something. For instance, you could use something like the following:

\[
\text{If( HasAttribute(Attr2) and len(Attr2) > 2, 1, 0) }
\]

---

**Operator Precedence**

The following table shows the priority given to operators when the system evaluates a formula. Priority goes from top to bottom of the table, and from left to right in a given row.

So, for example, NOT x+y is evaluated as (NOT x)+y rather than NOT(x+ y) because NOT takes priority over +.

And, for example, x*y/z is evaluated as (x*y)/z rather than x*(y/z) because multiplication takes priority over division.

Note: It is a good idea to use parentheses. Notice that parentheses have the highest priority and, thus, remove all ambiguity in a formula.

<table>
<thead>
<tr>
<th>Priority</th>
<th>Operator</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>(x)</td>
<td>parentheses</td>
</tr>
<tr>
<td>2</td>
<td>x**y</td>
<td>exponent</td>
</tr>
<tr>
<td>3</td>
<td>NOT x</td>
<td>unary boolean operator</td>
</tr>
<tr>
<td>4</td>
<td>+x, -x</td>
<td>unary numeric operators</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(positive, negative)</td>
</tr>
<tr>
<td>5</td>
<td>x*y, x/y, x%y</td>
<td>binary numeric operators</td>
</tr>
<tr>
<td></td>
<td></td>
<td>multiply, divide, percent</td>
</tr>
<tr>
<td>6</td>
<td>x+y, x-y, x&amp;y;</td>
<td>binary operators: plus, minus, string concatenation</td>
</tr>
<tr>
<td>7</td>
<td>x&lt;y, x&lt;=y, x&gt;=y, x&gt;y</td>
<td>numeric or string comparison</td>
</tr>
<tr>
<td>8</td>
<td>x=y, x&lt;&gt;y</td>
<td>numeric or string comparison</td>
</tr>
<tr>
<td>9</td>
<td>x AND y</td>
<td>boolean AND</td>
</tr>
<tr>
<td>10</td>
<td>x OR y</td>
<td>boolean OR</td>
</tr>
</tbody>
</table>
Formula Builder Dialog Box

Overview

In the Formula Builder dialog box, you can create a formula for a:

- calculated driver (See “Calculated Drivers” on page 273.)
- rule-based driver (See “Rule-based Drivers” on page 281.)
- calculated attribute (See “Calculated Attributes” on page 184.)

See Also

- Chapter 29, “Formulas,” on page 329
- Chapter 30, “Boolean Functions,” on page 347
- Chapter 31, “Numeric Functions,” on page 353
- Chapter 32, “String Functions,” on page 357
- Chapter 33, “Properties That Can Be In Formulas,” on page 361

How to Access the Formula Builder Dialog Box

To create a formula for a calculated driver
In the New Driver dialog box, click Formula Builder.

To create a formula for a rule-based driver
In the New Driver dialog box, select Use Rule Formula and click Formula Builder.

To create a calculated attribute
In the New Attribute dialog box, click Formula Builder.
**Components**

**Context**

Use the keywords Source or Destination to specify whether a property or attribute applies to a source or destination account. For example, Source.Cost or Destination.UnitCost.

*Note:* By default in the formula for a calculated driver, properties and attributes refer to destination accounts.

*Note:* By default in the formula for a rule-based driver, properties and attributes refer to destination accounts.

**Operators and Functions**

For a list of functions, see “Functions” on page 331.

**Analysis**

This tab contains a list of system-defined properties and user-defined attributes.

To ensure that SAS Activity-Based Management correctly interprets any special characters or spaces in a numeric attribute name, enclose the name in double quotation marks (" "). You do not need to use quotation marks for names of numeric properties.

For example, in the following formula, OutputQuantity does not require quotation marks because it is a system-defined numeric property. But, Units Per Pallet requires quotation marks because that name contains spaces.

```
OutputQuantity/"Units Per Pallet"
```

*Note:* The names of the properties shown in the Formula Builder dialog box are different from the names of the properties in other parts of the interface. See: About Property names in formulas.
Dimensions

This tab contains a list of dimensions, dimension members, and dimension attributes.

Define a formula

1. Select an item from the available components.
2. Click Insert.
   
   The item is added to the formula.

   **TIP** You can also modify the formula directly in the formula box.

   ![You can edit the formula directly]

3. Continue to insert items until you have built the formula.

   **Note:** The formula can be at most 16383 characters long.

4. To remove the last item that you inserted, click Undo.
5. To delete the entire formula, click Clear.
6. (Optional) Click Test.

   If no errors are displayed, the syntax of the formula is valid.
Chapter 30
Boolean Functions

Introduction
A Boolean function, named after the English logician/mathematician George Boole, returns either a TRUE or a FALSE.

Note: Null values are considered to be false when evaluating a formula for a rule-based driver.

The following are Boolean functions:
- HasAttribute
- if
- IsChildOf
- IsClose
- IsNull
- Match

HasAttribute function
Returns true if an account or external unit has an attribute attached to it for the attribute reference passed, and false otherwise. You can use the new HasAttribute() function with Tag (Boolean) attributes as well as with Text and Numeric attributes.
Syntax

HasAttribute( string )

where string is an attribute reference.

Examples

HasAttribute( "Quality" )
Destination.HasAttribute( "Quality" )
Source.HasAttribute( "Quality" )

Further explanation

If an attribute association does not exist but the attribute has a default value, false is returned. This works only for the numeric, text and tag value attributes—not for dimension attributes.

This function must be evaluated in the context of an account. Appropriate "Source." or "Destination." prefixes may be needed to select the correct account.

Note: When used in the assignment rule for a rule-based driver, the attribute is assumed to refer to the destination account unless Source is specified.

if function

The if function returns one value if a test evaluates to TRUE and a different value if the test evaluates to FALSE.

Syntax

if( test , true_value , false_value )

test is a value or expression that evaluates to TRUE or FALSE.

ture_value is the value that is returned when test is TRUE.

false_value is the value that is returned when test is FALSE.

Examples

if( not IsNull(SoldQuantity), SoldQuantity, OutputQuantity )

IsChildOf function

Returns true if the dimension member is a child of (self, immediate child, or descendent) of a given dimension member.

Syntax

dimension.reference.IsChildOf(dim-member-reference)

Examples

Customer.IsChildOf(Retail)
Source.Dept.IsChildOf(Sales)
Source.Dept.IsChildOf( "Sales" & "and Marketing" )
Product.IsChildOf(Source.Chnnl.Reference)
Product.IsChildOf(trim(Source.Chnnl.Reference))

Note: The dim-member-reference does not have to be the immediate child of the dimension.reference. For example, suppose you have the following hierarchy:
In this case, the formula `Products.IsChildOf(ProductLineB)` tests true for Product3 and Product4.

**Further explanation**

If the account's intersection dimension member reference matches the string passed, true is returned. For instance, if the intersection has member Region.Raleigh and the formula has "Region.IsChildOf(Raleigh)" then a true is returned. `IsChildOf()` must evaluate in the context of a dimension member. To accomplish that, use compound references as shown in the examples to select a dimension member on an account's or external unit's intersection. If an integer is passed then it is taken as-is without converting it to a number. This special case allows for syntax such as Period.2009 instead of requiring Period."2009".

**Note:** When used in the assignment rule for a rule-based driver, the dim-member-reference is assumed to refer to the destination account unless Source is specified.

---

**IsClose function**

Returns true or false depending on whether the leading significant digits match.

**Syntax**

```
IsClose( number1, number2 [, digits] )
```

**Examples**

- `IsClose( 0, 0 ) → true`
- `IsClose( 0, 1e-4 ) → false`
- `IsClose( 0, 1e-9 ) → true`
- `IsClose( 0, 1e-4, 3 ) → true`
- `IsClose( 123.4567, 123.4568, 6 ) → true`
- `IsClose( 0.0001234567, 0.0001234568, 6 ) → true`
- `IsClose( 1.234567e-5, 1.234568e-5, 6 ) → true (same as previous example)`
- `IsClose( 1, 1.00000001 ) → false`
- `IsClose( 1, 1.000000001 ) → true`
- `IsClose( 1, 0.999999999 ) → true`

**Note:** In the last example the digits don’t really match, but the number is just as far from 1 as in the previous example, so it is also considered close.
Further explanation
This function can be used when floating point round-off occurs. The number of digits to compare is determined by the digits parameter, which defaults to 8 if not passed.

IsNull function

Returns true or false depending on whether the leading significant digits match.

Syntax
IsNull( expression )

Examples
IsNull(SoldQuantity)

Further explanation
Null values are considered to be false when evaluating a formula for a rule-based driver.

Match function

Returns true when a string matches a given pattern. All comparisons are case insensitive.

Syntax
Match( string, "pattern" )

Examples
Match( Product.Reference, "*or*" )  
matches or, ord, facilitator, but not asteroid
Match( Product.DimMemRef, "abc*" ) 
matches abc, abcd, but not asteroid, a, ab or bc
Match( Product.Reference, "*xyz" )  
matches xyz, wxyz, but not asteroid, x, y, z, or yz
Match( Product.DimMemRef, "*bil*ion" ) 
matches billion, abillion, but not billions
Match( Product.Reference, "????DEF" ) 
matches abcDEF, ABCDEF, but not DEF, aDEF, abDEF
Match( Product.DimMemRef, "*bike*" )  
matches *bike*, *Bike*, but not *bikes*

Further explanation
Special characters:

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>*</td>
<td>matches zero or more characters</td>
</tr>
<tr>
<td>?</td>
<td>matches any single character</td>
</tr>
</tbody>
</table>
used as an escape character to allow matching a literal `*`, `?`, or `\` in the string. The escape character says that the immediately following character in the pattern (`*, ?, or `\`) is being used as itself and not as a special character. So, for example, `Match(Product, Name\?)` matches `Name?` and does not match either `Name` or `Names`.

*Note:* When used in the assignment rule for a rule-based driver, properties are assumed to refer to the destination account unless Source is specified.
Chapter 31
Numeric Functions

abs function

The abs function returns the absolute value of a number.

Syntax

```plaintext
abs(x)
```

where `x` is the number.

degrees function

The degrees function converts radians into degrees.

Syntax

```plaintext
degrees(x)
```

where `x` is the radians.
Examples
    \text{degrees}(1.57079633) = 90

exp function

The exp function returns \( e \) raised to the power of the number. The constant \( e \) equals 2.71828182845904, the base of the natural logarithm.

Syntax
    \text{exp}(x)

where \( x \) is the number.

Examples
    \text{exp}(2) = 7.389056099

max function

The max function returns the larger number of two numbers, or the greater of two strings.

Note: One string is greater than another if it comes after the other in UTF-16 sorting sequence (more simply stated, if it comes later in alphabetical order).

Syntax
    \text{max}(x, y)

where \( x \) and \( y \) are two numbers or two strings.

min function

The min function returns the smaller number of two numbers, or the smaller of two strings.

Syntax
    \text{min}(x, y)

where \( x \) and \( y \) are two numbers or two strings.

pi function

The pi function returns the number 3.14159265358979, the mathematical constant \( \pi \), and is accurate to 15 digits.

Syntax
    \text{pi}()

There are no parameters.
Examples
\[ \pi() = 3.14159265358979 \]

---

**power function**

The power function returns the result of a number raised to a power.

**Syntax**

```
power(x, y)
```

- \( x \) raised to the power of \( y \)

**Examples**

```
power(3, 2) = 9
```

---

**quotient function**

The quotient function returns the integer portion of a division. Use this function when you want to discard the remainder of a division.

**Syntax**

```
quotient(x, y)
```

**Examples**

```
quotient(17, 3) = 5
```

---

**radians function**

The radians function converts degrees to radians.

**Syntax**

```
radians(x)
```

- \( x \) is the degrees.

**Examples**

```
radians(90) = 1.57079633
```

---

**round function**

The round function returns a number that has been rounded to a specified number of decimal places.

**Syntax**

```
round(x, y)
```

- \( x \) is the number.

- \( y \) is the number of decimal places. \( y \) can be any of the following:

- \( 0 \) - rounding to the nearest integer.
- \( 1 \) - rounding to one decimal place.
- \( 2 \) - rounding to two decimal places.
- \( 3 \) - rounding to three decimal places.
- etc.

**Examples**

```
round(1.2345, 2) = 1.23
```
Greater than zero | x is rounded to the specified number of decimal places.
---|---
Zero | x is rounded to the nearest integer.
Less than zero | x is rounded to the left of the decimal point.

**sign function**

The sign function returns a number that indicates the sign of a number.

**Syntax**

```
sign(x)
```

* x is the number.

**Return values**

<table>
<thead>
<tr>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>indicates that the number is positive.</td>
</tr>
<tr>
<td>0</td>
<td>indicates that the number is zero.</td>
</tr>
<tr>
<td>-1</td>
<td>indicates that the number is negative.</td>
</tr>
</tbody>
</table>

**sqrt function**

The sqrt function returns the positive square root of a number.

**Syntax**

```
sqrt(x)
```

* x is the positive number. A negative number produces an error message.

**trunc function**

The trunc function truncates a number to an integer by removing the fractional part of the number.

**Syntax**

```
trunc(x)
```

* x is the number to truncate.

**Examples**

```
trunc(5.46) = 5
```
Chapter 32
String Functions

& function (string concatenation)

Returns the concatenation of two strings.

**Syntax**
```
string & string
```

**Examples**
```
"Las Vegas" & "," & "Nevada"
Product.DimMemRef & " & " & Source.DimMemRef
```

find function

Returns the position of `find_string` in `within_string`, starting at `pos` (`pos` starts at 1).

**Syntax**
```
find( find_string, within_string, pos )
```

**Examples**
```
find(Source.DimMemRef, "x")
```

**Further explanation**
If `find_string` isn’t found in `within_string`, a Null is returned.
If \( pos \) is less than 1 or larger than the length of \( \text{within\_string} \), a Null is returned.

If \( \text{find\_string} \) is an empty string, then 1 is returned.

All comparisons are case sensitive.

*Note:* Null values are considered to be false when evaluating a formula for a rule-based driver.

---

**left function**

Returns a string with the leftmost length characters of string.

**Syntax**

\[
\text{left( string, length )}
\]

**Examples**

\[
\text{left(Source.Name, 5)} \\
\text{left(Source.Name, find(Source.Name, " and")-1)}
\]

**Further explanation**

If \( \text{length} \) is greater than the length of \( \text{string} \), then \( \text{string} \) is returned.

---

**len function**

Returns the number of characters in a string.

**Syntax**

\[
\text{len( string )}
\]

**Examples**

\[
\text{len(Source.Channel.Reference)}
\]

---

**mid function**

Returns a substring starting at \( \text{pos} \) with a length of \( \text{length} \) (\( \text{pos} \) starts at 1).

**Syntax**

\[
\text{mid( string, pos [, length] )}
\]

**Examples**

\[
\text{mid(Source.Channel.Reference, 3)} \\
\text{mid(Channel.Reference, find(Channel.Reference, " and"), len(Channel.Reference)-find(Channel.Reference)-1)}
\]

**Further explanation**

If \( \text{length} \) is not included then all characters starting from \( \text{pos} \) to the end of the string are returned.
**right function**

Returns a string with the rightmost length characters of string.

**Syntax**

```
right( string, length )
```

**Examples**

- `right(Source.Channel.Reference,3)`
- `right(Channel.Reference, find(Channel.Reference, " and"), len(Channel.Reference)-find(Channel.Reference)-1)`

**Further explanation**

If `length` is greater than the length of `string`, then `string` is returned.

**str function**

Converts a number to a string.

**Syntax**

```
str( number [, size [, dec] ] )
```

**Examples**

- `str(Destination.Cost)`
- `str(len(Source.IdleQuantity))`

**Further explanation**

The default parameter values are `size=16` (includes the decimal point when `dec > 0`) and `dec=6` for the number of digits past the decimal. If `size` is passed but `dec` is not, then `dec` defaults to a value of zero instead. If the `number` is larger than the `size` passed then more space will be created for it, so the string returned may be longer than the size passed. Passing a size of "1" removes all leading spaces from the number.

**trim function**

Returns the string with all spaces removed except for single spaces between words.

**Syntax**

```
trim( string )
```

**Examples**

- `trim(Destination.Name)`

**value function**

Converts a string to a number.
Syntax
   value( string )

Examples
   value(Destination.DimLevel)

Further explanation
   If a non-numeric character is encountered the conversion stops. An empty string evaluates to zero.
Properties That Can Be in Formulas

The following table identifies all the properties that can be used in formulas. The Assignment column applies to assigned, internal and external cost elements.

<table>
<thead>
<tr>
<th>Property</th>
<th>Type</th>
<th>Account</th>
<th>Ext Unit</th>
<th>Assignment</th>
<th>Dim Member</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>[Value Attributes]</td>
<td>Num or Char</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
<td>Text and Tag attributes can be used in addition to numeric attributes.</td>
</tr>
<tr>
<td>AllocatedCost</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>AssignedCost</td>
<td>Num</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>AssignedIdleCost</td>
<td>Num</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>AssignedIdleQuantity</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td>Valid property for assignment, but not accessible from formula because of circular reference.</td>
</tr>
<tr>
<td>AssignedNonReciprocalCost</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>AssignedReciprocalCost</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost</td>
<td>Num</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DimLevelName</td>
<td>Char</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DimLevelNumber</td>
<td>Num</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DimMemName</td>
<td>Char</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td>Synonym of Name for Dim Member in an intersection</td>
</tr>
<tr>
<td>DimMemRef</td>
<td>Char</td>
<td></td>
<td></td>
<td>✓</td>
<td></td>
<td>Synonym of Reference for Dim Member in an intersection</td>
</tr>
<tr>
<td>Property</td>
<td>Type</td>
<td>User Accessible</td>
<td>Formula Accessible</td>
<td>Notes</td>
<td></td>
<td></td>
</tr>
<tr>
<td>---------------------------</td>
<td>---------</td>
<td>----------------</td>
<td>-------------------</td>
<td>----------------------------------------------------------------------</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DrivableCost</td>
<td>Num</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>DrivenCost</td>
<td>Num</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DrivenQuantity</td>
<td>Num</td>
<td>✓</td>
<td>✓</td>
<td>Valid property for assignment, but not accessible from formula because of circular reference.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DriverName</td>
<td>Char</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>DriverQuantityCalculated</td>
<td>Num</td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>DriverQuantityFixed</td>
<td>Num</td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>DriverQuantityVariable</td>
<td>Num</td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>DriverRate</td>
<td>Num</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DriverWeightFixed</td>
<td>Num</td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>DriverWeightVariable</td>
<td>Num</td>
<td></td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>EnteredCost</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>IdleCost</td>
<td>Num</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>IdleDriverQuantityUE</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td>Was &quot;IdleDriverQuantity_UE&quot; in 6.4</td>
<td></td>
<td></td>
</tr>
<tr>
<td>IdleQuantity</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Char</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>OutputQuantity</td>
<td>Num</td>
<td>✓</td>
<td>✓</td>
<td>Unavailable as Source property from assignment</td>
<td></td>
<td></td>
</tr>
<tr>
<td>OutputQuantityUE</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Profit</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ReceivedAllocatedCost</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ReceivedAssignmentCost</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ReceivedBOCCost</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ReceivedCost</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ReceivedDrivenCost</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ReceivedNonReciprocalCost</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ReceivedReciprocalCost</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Reference</td>
<td>Char</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Revenue</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SoldQuantity</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Property</td>
<td>Type</td>
<td>Available</td>
<td>Used</td>
<td>Source Property</td>
<td>Notes</td>
<td></td>
</tr>
<tr>
<td>-----------------------</td>
<td>------</td>
<td>-----------</td>
<td>------</td>
<td>-----------------</td>
<td>----------------------------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td>TDQ</td>
<td>Num</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>Unavailable as Source property from assignment</td>
<td></td>
</tr>
<tr>
<td>TDQBasic</td>
<td>Num</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>Unavailable as Source property from assignment</td>
<td></td>
</tr>
<tr>
<td>TDQCalculated</td>
<td>Num</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>Unavailable as Source property from assignment</td>
<td></td>
</tr>
<tr>
<td>TDQUE</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>UnassignedCost</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>UnitCost</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>UnitProfit</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>UnitRevenue</td>
<td>Num</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>UsedCost</td>
<td>Num</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>UsedQuantity</td>
<td>Num</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Part 11

Currencies

Chapter 34

*Working with Currencies* ........................................ 367
Currencies

Overview

A currency represents a unique monetary system that is identified by a name and by a three-letter code (currency code).

You can display a model's costs in more than one currency simultaneously. However, you must first define the currencies and their exchange rates. SAS Activity-Based Management can display a model's costs in whatever currency you select, using the exchange rate that is associated with each currency.
When you create a model, you can select the base currency that you want to use for calculating the model costs. SAS Activity-Based Management saves the base currency with the model.

Note: Once you set a model's base currency, you cannot change it later.

**Windows Currency Settings**

The Windows Regional Options for your computer let you set your locale, which affects only the display of currency on your computer. A locale is a group of language settings that you want to use on your computer. You can accept the default values for the selected locale's number of digits after the decimal, or you can select a different value from a list for that locale.

Note: The base currency determines the currency symbol. Windows Regional Options do not affect the currency symbol.

**Exchange Rates**

An exchange rate is a multiplier that is used to convert values from one currency to another. You enter exchange rates in an exchange rates table. Because exchange rates tables are shared by all the models on the same SAS Activity-Based Management server, you can compare costs between models.

When you enter an exchange rate in an exchange rates table, the exchange rate's corresponding multiplier is automatically entered. After entering an exchange rate, you can change it.

You can easily add all the euro exchange rates at once. After adding the default euro exchange rates, you can change them. If a period is before 1999, the euro currency is not available.

Exchange rates can vary from one period/scenario association to another period/scenario association. To add exchange rates quickly, you can copy an exchange rates table from one period/scenario association to another period/scenario association.

The display precision that you see in an exchange rates table is determined by the Rates value in the Options dialog box.

**Selecting Currencies for an Exchange Rates Table**

A currency is not the same as a locale. A locale can support multiple currencies. For example, you can use Windows to set the locale to French (France). In SAS Activity-Based Management, you can format a unit cost column for francs with a currency of France (F) and add a column and format it with a currency of euro.

All currencies are available for you to specify in an exchange rates table. You add the currencies that you want to use.

---

**Set up Multiple Currencies**

You can follow these steps to set up currencies for all the models on a SAS Activity-Based Management server.

1. Add currencies.
2. Set up exchange rates.

3. (Optional) Add columns and change the column formats to one of the added currencies.

---

**Add a Currency**

1. Select **Tools ⇒ Manage Exchange Rates**.

   The Manage Exchange Rates dialog box appears.

2. Click the **Add/remove currency** link.

   The Add/Remove Currencies dialog box appears.

3. In the **Available currencies** list, select one or more currencies.
To select more than one currency, use standard Microsoft Windows selection techniques.

4. Click >.
   The currency is added to the **Selected currencies** list.

   *Note:* To add all currencies, click >>.

---

## Copy an Exchange Rates Table

1. Select **Tools ➔ Manage Exchange Rates.**
   The Manage Exchange Rates dialog box appears.

2. Click the **Copy rate table from** link.
   The Copy Rates From dialog box appears.

   ![Copy Rates From](image)

3. Select the **Period/Scenario** association that has the exchange rates table that you want to copy.

---

## Manage Exchange Rates Dialog Box

### About the Manage Exchange Rates Dialog Box

The availability of this feature depends on your permissions.

In the Manage Exchange Rates dialog box, you can set up exchange rates between currencies.
Note: You can perform the following tasks without first opening a model.

**How to Access the Manage Exchange Rates Dialog Box**

Select **Tools ➔ Manage Exchange Rates**.

**Add or Remove a Currency**

Click the **Add/remove currency** link.
The Add/Remove Currencies dialog box appears.

**See Also**

“Add/Remove Currencies Dialog Box” on page 371

**Set up an Exchange Rates Table**

1. Select a Period.
2. Select a Scenario.
3. (Optional) Click the **Add/remove currency** link.
The Add/Remove Currencies dialog box appears.
4. In the Rate table, click on the intersection between two currencies, and type an exchange rate.
5. Repeat step 4 for each exchange rate.
6. (Optional) Add euro exchange rates.

**Add Euro Exchange Rates**

1. Click the **Save changes** link.
   Before you can add euro exchange rates, you must save any changes to the exchange rates table.
2. Add the currency named euro:
   a. Click the **Add/remove currency** link.
The Add/Remove Currencies dialog box appears.
   b. Select the currency named euro.
   c. Select the **Show Euro member currencies** option.

**Copy an Exchange Rates Table**

Click the **Copy rate table** from link.
The Copy Rates From dialog box appears.
Add/Remove Currencies Dialog Box

About the Add/Remove Currencies Dialog Box

The availability of these features depends on your permissions.

In the Add/Remove Currencies dialog box, you can manage currencies before you define exchange rates.

How to Access the Add/Remove Currencies Dialog Box

In the Manage Exchange Rates dialog box, click the Add/remove currency link.

See Also
“Manage Exchange Rates Dialog Box” on page 370

Add a Currency

1. In the Available currencies list, select one or more currencies.
   To select more than one currency, use standard Windows selection techniques.
2. Click >.
   The currency moves from the Available currencies list to the Selected currencies list.
   Note: To add all currencies, click >>.

Remove a Currency

1. In the Selected currencies list, select one or more currencies.
   To select more than one currency, use standard Windows selection techniques.
2. Click <.
   The currency moves from the Selected currencies list to the Available currencies list.
   Note: To remove all currencies, click <<.

Copy Rates From Dialog Box

About the Copy Rates From Dialog Box

The availability of this feature depends on your permissions.

In the Copy Rates From dialog box, you can copy an exchange rates table from one period/scenario association to another period/scenario association.
How to Access the Copy Rates From Dialog Box

In the Manage Exchange Rates dialog box, select **Copy rate table from**.

See Also

“Manage Exchange Rates Dialog Box” on page 370

Select an Exchange Rates Table

Select the Period/Scenario association that has the exchange rates table that you want to copy.
Part 12

Cube Configurations

Chapter 35

Working with Cube Configurations ................. 377
Create a Cube Configuration

A cube configuration holds the options that you select for generating cubes and fact tables. After creating a cube configuration, you use it to generate cubes. Creating a cube configuration is preliminary to generating cubes—you don't generate cubes until later.

1. Go to the Workspace Manager or to the Resource, Activity, or Cost Object module for a model.

2. Select File ⇒ New ⇒ Cube Configuration.

   The New Cube Configuration wizard opens.

3. Depending on the type of cube that you want to generate, complete the steps in the following table:
<table>
<thead>
<tr>
<th>Type of Contributions Cube</th>
<th>Steps to Create the Cube Configuration</th>
</tr>
</thead>
</table>
| Single-stage              | • Step 1: “Cube Configuration: Select a Model and General Options” on page 378  
|                           | • Step 2: “Cube Configuration: Cube Options” on page 383                     
|                           | • Step 3: “Cube Configuration: Finish” on page 386                          |
| Resource                  | • Step 1: “Cube Configuration: Select a Model and General Options” on page 378  
|                           | • Step 2: “Cube Configuration: Cube Options” on page 383                     
|                           | • Step 3: “Cube Configuration: Select Numeric Attributes” on page 385        
|                           | • Step 4: “Cube Configuration: Finish” on page 386                          |
| 6.3 Compatible Multi-Stage | • Step 1: “Cube Configuration: Select a Model and General Options” on page 378  
|                           | • Step 2: “Cube Configuration: Cube Options” on page 383                     
|                           | • Step 3: “Cube Configuration: Options for a 6.3-Compatible, Multi-Stage Contribution Cube” on page 382  
|                           | • Step 4: “Cube Configuration: Select Numeric Attributes” on page 385        
|                           | • Step 5: “Cube Configuration: Finish” on page 386                          |
| Custom Multi-Stage        | • Step 1: “Cube Configuration: Select a Model and General Options” on page 378  
|                           | • Step 2: “Cube Configuration: Cube Options” on page 383                     
|                           | • Step 3: “Cube Configuration: Options for a Custom, Multi-Stage Contribution Cube” on page 380  
|                           | • Step 4: “Cube Configuration: Select Numeric Attributes” on page 385        
|                           | • Step 5: “Cube Configuration: Finish” on page 386                          |

**See Also**

“Generate Cubes” on page 442

---

**Cube Configuration: Select a Model and General Options**

In this step of creating a cube configuration you select the model, name the cube configuration, and select other options for cube generation.

**Select a Model and Name the Cube Configuration**
Model name
Select the model whose cube and/or fact table is to be generated. A model can have more than one cube configuration because different cubes can be generated from the same model.

Cube configuration name
You will use the cube configuration later to generate cubes. In this step of the wizard, you assign a name that describes the cube to be generated.

Cube configuration reference
The cube configuration reference is used in public views as an unchangeable identifier for the configuration.

Select the Type of Cube and Whether to Generate a Cube and Fact Table, or Fact Table Only

Cube and Fact Table or Fact Table only
You can choose to generate both a cube and fact table, or only a fact table. You can use the fact table to generate a customized cube in another application, such as SAS OLAP Cube Studio or Microsoft SQL Server Analysis Services.

Type
Single-Stage Contribution
Analyzes the cost contributions from one assignment level back.

Multi-Stage contribution
Analyzes the cost contributions to or from accounts that have stages attributes.

Resource Contribution
Analyzes the costs contributions from original accounts where costs were entered for final accounts that do not assign costs to other accounts.

Select Either a Custom or a 6.3-Compatible Cube
Create custom cube and fact table
This option applies only to multi-stage contribution cubes. A custom cube allows you to select what to include in it. By making different selections, you can generate different multi-stage contribution cubes from the same model. A cube configuration remembers your selections for a particular cube and for a particular model. Note: You can copy an existing cube configuration and change only the model with which the cube configuration is associated. See Copy a Cube Configuration to a Different Model.

Suppress zero cost
Suppress items that have no associated costs to save generation time and reduce cube size.

Create 6.3 compatible cube and fact table
For single-stage contribution cubes and for resource contribution cubes, you can only choose this option. These cubes are generated exactly as they were in the 6.3 release.

If you select this option for a multi-stage contribution cube, then you are not presented as many choices for what to include in the cube. SAS Activity-Based Management makes the choices for you and the cube is generated exactly as it was in the 6.3 release.

Note: You can have only one 6.3-compatible cube configuration of a given type (e.g., resource contribution) per model. This is because you can have only one 6.3-compatible cube of a given type per model. If you create a second cube configuration for a 6.3-compatible cube, then the first cube configuration is deactivated (detached from the model). You are issued an informational message when this happens.

See Also

• “Create a Cube Configuration” on page 377
• Chapter 39, “Working with Generation,” on page 439

Cube Configuration: Options for a Custom, Multi-Stage Contribution Cube

The following dialog box appears only for a custom multi-stage contribution cube.
Modules and Stages

Modules
Each module defines a single stage (one stage per module) in the following order:

1. External Units
2. Resource
3. Activity
4. Cost Object

Stages
Each stage is defined by a dimension member attribute in a dimension attribute that is named Stages. For more information, see Stage attributes and Adding Stage Attributes to Accounts.

Select All
Check this box to select all dimensions in a module or stage for inclusion in the cube. Selecting this check box turns on the Include flag for each individual dimension.

Include
Check this box to include the selected dimension in the cube.

Cost Flow
Select whether to include cost flows into or out of the selected module or stage.

With some models, it makes a difference in generating a cube whether you select to show costs flowing into a module/stage or out of a module/stage. It makes a difference in case the model has assignments from accounts in a module/stage to accounts within the same module/stage. You cannot choose to show both assignments because that would result in double-counting final costs.

If a model has no cost assignments from accounts within a module/stage to accounts within the same module/stage, then the choice of showing cost flows into or out of a
module/stage makes no difference (every cost into a module/stage is also a cost out of the module/stage). By defining multiple stages such that there are no assignments within a single stage, you avoid having to make the choice of showing cost flows in or out.

**Include to Level**
For dimensions with multiple levels, specify how many levels you want included in the cube for drill down. The default is to include up to and including level 2 of a dimension.

**Filter Members**
Click this button to select the dimension members to be included in the generated cube. You can select dimension members in any level of the dimension hierarchy up to and including the level specified in Include to Level. See “Select Dimension Members for Inclusion in Cubes” on page 388.

**See Also**

- “Create a Cube Configuration” on page 377
- Chapter 39, “Working with Generation,” on page 439

---

**Cube Configuration: Options for a 6.3-Compatible, Multi-Stage Contribution Cube**

The following dialog box appears only for a 6.3 compatible multi-stage contribution cube.

![Edit Cube Configuration - Modules and Stages](image)

**Modules and Stages**

**Modules**
Each module defines a single stage (one stage per module) in the following order:

1. External Units
2. Resource
3. Activity

<table>
<thead>
<tr>
<th>Include</th>
<th>Modules or Stages</th>
<th>Cost Flow</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>External Unit</td>
<td>Out</td>
</tr>
<tr>
<td></td>
<td>Resource</td>
<td>In</td>
</tr>
<tr>
<td></td>
<td>Activity</td>
<td>In</td>
</tr>
<tr>
<td></td>
<td>Cost Object</td>
<td>Out</td>
</tr>
</tbody>
</table>

---

**Include**

- **Modules**
- **Stages**
4 Cost Object

**Stages**
Each stage is defined by a dimension member attribute in a dimension attribute that is named Stages. For more information, see Stage attributes and Add Stage Attributes to Accounts.

**Include**
Check this box to include the module or stages in the cube.

**Cost Flow**
Select whether to include cost flows into or out of the selected module or stage.

**See Also**
- “Create a Cube Configuration” on page 377
- Chapter 39, “Working with Generation,” on page 439

---

**Cube Configuration: Cube Options**

**Overview**
Your options for creating a cube depend on whether you are using:
- SAS OLAP
- Microsoft SQL Server Analysis Services

**Cube Options for SAS OLAP**

*Note:* The following picture is only an example. By default you do not have to specify any options to generate a cube. Indeed, you should not specify any options unless you have experience with SAS programming.

![Cube Options](image)

Parameters for options statement:

```
OPTION MEMSIZE=2G; OPTION REALMEMSIZE=1331M;
```

PROC OLAP options:

```
INDEXSORTSIZE=32 MAXTHREADS=2
```

Metadata server cube folder path:

```
/Products/SAS Activity Based Management/Cubes/
```
Parameters for options statement
By default you do not have to specify any options for cube generation. However, if you want to override the default SAS system options, you can specify them here. The following are some sample options:

```plaintext
OPTION NOSYNTAXCHECK;
OPTION SORTPGM=SAS;
OPTION MEMSIZE=2G;
OPTION REALMEMSIZE=1331M;
OPTION SUMSIZE=1331M;
OPTION BUFSIZE=64K;
OPTION IBUFSIZE=32767;
OPTION UBFSIZE=64K;
OPTION SORTSIZE=512M;
OPTION CPUCOUNT=2;
OPTION NOOVP;
```

For all system options, see SAS System Options in the SAS 9.2 Language Reference: Dictionary.

PROC OLAP options
SAS Activity-Based Management uses the SAS OLAP procedure to generate cubes. By default you do not have to specify any PROC OLAP options for cube generation. However, if you want to override the default OLAP options, you can specify them here. The following are two sample options:

```plaintext
INDEXSORTSIZE=32 MAXTHREADS=2
```

For all PROC OLAP options, see The OLAP Procedure in the SAS OLAP Server: User's Guide (http://support.sas.com/documentation/ondlinedoc/olap/index.html) The following two options can possibly save disk storage space by reducing cube size: COMPACT_NWAY and NONUPDATEABLE.

### Cube Options

#### Specify cube options

Parameters for options statement:

PROC OLAP options:

```plaintext
COMPACT_NWAY NONUPDATEABLE
```

Metadata server cube folder path:

`/Products/SAS Activity Based Management/Cubes/`

### COMPACT_NWAY
specifies that the cube build will include an additional summarization step that is designed to decrease the size of the NWAY aggregation and improve viewing performance. The amount of improvement depends on the nature of the data. The cubes that improve the most are those that have the largest

### NONUPDATEABLE
specifies that the dimension(s) should be built with the minimum amount of disk space to represent the members available when the cube is created. By default,
new dimensions are built to allow for new members to be added in future updates. NONUPDATEABLE is valid only when the cube is first created.

Note: The following options are not supported: DRILLTHROUGH_TABLE=, WORKPATH=, DESCRIPTION=, IGNORE_MISSING_DIMKEYS=.

Metadata server cube folder path
If you want to override the default location for the generated cube, you can specify a path on the SAS Metadata Server.

By default, the path is: /Products/SAS Activity Based Management/ Cubes/. However, the default path could have been changed during installation. In either case you can override the path here.

Note: The folder that you specify must already exist when cube generation is started and you must have write access to the folder for cube generation to be successful.

Cube Options for Microsoft SQL Server Analysis Services

Cube Options

Specify cube options

Pre-Aggregation Design Options

- **Apply Aggregation Percentage**
  - Pre-aggregation Percentage: 20

- **Process cube**

Pre-aggregation Percentage

Pre-aggregating numeric data results in faster performance when you work with a cube in the OLAP analyzer. But, for large models pre-aggregating data can take a long time which increases cube-generation time. So, the more pre-aggregation you do, the faster you can navigate a cube, but the longer it takes to generate it. This option allows you to trade generation time for execution speed.

Process cube

Processing a cube causes processing of all the measure groups within the cube and the constituent dimensions that are currently in an unprocessed state. When you process a cube, an SQL query is issued to retrieve values from the fact table to populate each member in the cube with appropriate measure values. For any specific path to a node in the cube, there is a value or a calculable value. Processing a cube creates machine-readable files that store relevant fact data. If there are aggregations created, they are stored in aggregation data files.
Cube Configuration: Select Numeric Attributes

Select the numeric attributes to be included in the generated cube.

Note: This dialog box applies only to resource contribution cubes and multi-stage contribution cubes. It does not appear for a single-stage contribution cube. For instructions on including numeric attributes in a single-stage contribution cube, see Include Numeric Attributes in a Cube.

Note: You can select the numeric attributes that are to be checked by default in a new cube configuration by doing the following:

1. In model mode, select Model → Properties.
2. Select the Attributes in Cube tab.
3. Select the attributes that are to be checked by default in a new cube configuration for that model.

Attributes that you select in Model Properties are automatically checked in a new cube configuration to be included in the generated cube. However, you can uncheck the attributes in the cube configuration and select others.

See Also

- “Create a Cube Configuration” on page 377
- “Include Numeric Attributes in a Cube” on page 446
- Chapter 39, “Working with Generation,” on page 439

Cube Configuration: Finish

Review your selections; then click Finish.
The cube configuration is created. You can use it to generate cubes.

See Also

- “Create a Cube Configuration” on page 377
- Chapter 39, “Working with Generation,” on page 439

Copy a Cube Configuration to a Different Model

A cube configuration is associated with one and only one model. You can copy a cube configuration, preserving all its specifications except the model with which it is associated. By doing this, you create a new cube configuration with all the specifications of the old one except for the model with which it is associated.

To make a copy of a cube configuration that is associated with a different model, do the following:

1. From the Navigation Pane, go to the Workspace Manager.
2. Select Cube Configurations.
3. Select Copy To Model from the pop up menu.
   The Copy To Model dialog box opens.
4. Select the new model to which the cube configuration is to be assigned.
   Note: The new model must have the same dimensions as the old one.
5. Specify the name of the new cube configuration.
6. Click OK.

A new cube configuration is created with all the attributes of the old one, but associated with a different model.
Select Dimension Members for Inclusion in Cubes

Overview

Before SAS Activity-Based Management 7.2, in generating a cube you could limit the size of cubes by choosing which dimensions to include and, for those dimensions, up to what level to include dimension members. That is, for each dimension you could specify how deep to go, but you could not choose at any depth what dimension members to include.

The following picture shows selecting the Dept dimension, and choosing to include all dimension members up to and including level 4.

**Before:** Include all dimension members up to and including a specified level

<table>
<thead>
<tr>
<th>Select All</th>
<th>Modules/Stages and Dimensions</th>
<th>Include</th>
<th>Cost Flow</th>
<th>Include to Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>✔️</td>
<td>✔️ Activity</td>
<td>✔️</td>
<td>Custom</td>
<td>Level 4 (4 of 5)</td>
</tr>
</tbody>
</table>

Now, not only can you choose what dimensions to include and up to what level to include its dimensions members. But, you can also choose at any level what dimension members to include. This ability allows you to create cubes that go deep into the dimension hierarchy and yet remain small.

The following picture shows the same hierarchy as the previous picture, and it shows selecting dimension members at an even deeper level than the previous picture, and yet creating a small cube because it contains fewer dimension members.
Selecting Dimension Members

To select the dimension members to include in a generated cube, do the following:

1. Go to the Workspace Manager or to the Resource, Activity, or Cost Object module for a model.

2. Select **File ➔ New ➔ Cube Configuration** or open an existing cube configuration.

3. For Step 1 of the Cube Configuration wizard, specify the following:
   - Model name
   - Cube configuration name
   - Cube configuration reference
   - Specify **Multi-Stage contribution** as the type of cube to generate.
   - Specify **Create custom cube and fact table**.

   Click **OK** to proceed to Step 2 of the Cube Configuration wizard.


   Click **OK** to proceed to Step 3 of the Cube Configuration wizard.

5. For Step 3 of the Cube Configuration wizard:
   a. Select a dimension member
   b. Select **Include** to include this dimension member in the generated cube.
   c. For **Include to Level**, select the level of the dimension hierarchy through which you want to include dimension members.
   d. Click **Filter Members**.
The Filter Dimension Members dialog opens.

6. In the Filter Dimension Members dialog, select the dimension members that you want to include in the cube.

   *Note:* If you want to go deeper (or shallower) in the dimension hierarchy, use the Include to Level drop-down list to select a level. When you leave this dialog, the level is reflected in the previous Modules, Stages, Dimensions, and Levels window.

7. Click **OK**.

   The Filter Dimension Member dialog closes, and a "Yes" in the Filter Members column indicates that not every dimension member is selected for inclusion in the cube.
Note: Although dimension members that you deselect are not included in a cube, their costs are included in the None category.
Part 13

Calculating Costs

Chapter 36
  Calculation ................................................................. 395

Chapter 37
  Examples of Calculation ................................................... 399

Chapter 38
  Detailed Example of Calculation ....................................... 417
Chapter 36
Calculation

Calculating Costs

Overview
As you begin entering data from the paper model into the model in SAS Activity-Based Management, you should notice how the costs are conforming to expectations. At any time during the development of a model, you can assign the cost of each account according to the account's driver.

You can enter costs interactively. However, interactively entering data can be tedious and prone to errors. Importing data from an existing data source can minimize tedium and error. For example, if the costs from the general ledger are available, and if you have built the model so that the models resource account references match the general ledgers account numbers, it is more efficient to add costs to the model by importing them.

After you calculate costs, you might want to republish your data to SAS Strategy Management because your costs are not automatically updated.

Changing the Model Structure after Calculating Costs
After you have calculated costs for an entire model, any of the following actions can invalidate some of the model costs:

- Adding, deleting, or changing the cost of an entered cost element
- Adding, deleting, or changing the cost of an external unit cost element in a bill of costs
- Changing the cost of an account that is used as an internal unit cost element in a bill of costs
- Changing an accounts driver, driver quantities, attribute quantities, or output quantities
• Adding or deleting a rollup account, an account, or a cost element
• Creating new assignments or deleting existing ones

In all of these cases, costs are updated if you calculate costs. However, it might not be necessary to calculate costs for a minor change.

**Period/Scenario Association**

When you calculate costs, you can choose a specific period/scenario association, or you can choose all period/scenario associations.

**Errors**

You should choose to report all errors at least once while you are calculating costs and generating cubes. Fix any problems that are reported. If you determine that the remaining errors are insignificant, you can choose to not report all errors. Then, you can limit the number of errors that are reported. If you limit the number of errors, performance might improve when costs are calculated and when cubes are generated.

**See Also**

Chapter 37, “Examples of Calculation,” on page 399

---

**Calculate Costs Dialog Box**

*Note:* The availability of these features depends on your permissions.

1. Open a model in Model mode, and select **Model ➔ Calculate Costs**.

   The Calculate Costs dialog box opens:
2. Select one or more period/scenario associations.

   *Note:* If there is an error calculating one period/scenario, then no others are calculated.

3. Select or clear the Stop calculating after sequence number option. If applicable, specify the sequence number.

   For more information, see Driver sequencing.

4. Select **Force Calculate** to perform calculations even if a flag says that calculations are up to date.

   To speed processing, SAS Activity-Based Management skips calculating if it thinks that calculations are up to date. Use this option to force calculation even if the system thinks that calculations are up to date.

5. Select **Disable Driver Rules** if you want calculation to ignore the rule formula attached to any rule-based driver.

   You can choose this option to disable driver rules to speed up calculation if you have previously done a calculation that has already created the driver assignments for rule-based drivers.

   If you do not select this option to disable driver rules, then calculation evaluates for which potential destination accounts the driver's formula tests true and creates an assignment from the source account to each such destination account. And, calculation evaluates for which potential destination accounts the driver's formula tests false and deletes the assignment to that account if the assignment exists. This means that if you have previously allowed calculation to create assignments and subsequently you removed some of those assignments from the source account or created additional assignments to other destination accounts, then those manually created assignments will be undone and you will have to do them over again.

   *Note:* You can also turn off the formula for individual drivers by deselecting Use Rule Formula in the Driver Properties dialog box.

6. Select the number of error and warning messages to be displayed.
7. Click **OK**.
Introduction

This chapter shows both the demand flow and cost flow for several examples of assignments. Demand flow is the calculation of the quantities involved in assignments. Demand flow is always calculated before cost flow. That is, before costs can be calculated, it is necessary to calculate the quantities of things involved. Whereas cost flows from left to right (for example, from the Resource module to the Activities module to the Cost Object module) demand flows from right to left (that is, before calculating how much cost flows to a destination account, it is necessary to know how much output is required at the destination). This should become clear in the course of the examples.

- “Using a Non-Weighted Driver with Variable Driver Quantities” on page 400
Using a Non-Weighted Driver with Variable Driver Quantities

**Step A—User Enters Driver Quantities and Sold Quantity**

For this example, the user enters the value of DQV and SoldQty.

The problem: calculate how much is spent for cars and trucks respectively, given the following information:

- 50 cars were sold, and 5 trucks were sold
  - SoldQty(cars)=50
  - SoldQty(trucks)=5
- Each car has 4 wheels, and each truck has 8 wheels
  - DQV(cars)=4
  - DQV(trucks)=8
- Each wheel (regardless of car or truck) has 5 lug nuts
  - DQV=5
- Each lug nut costs $.05 per nut
  - UnitCost=.05

The following picture summarizes the information. You can also see that TDQ(cars)=50 and TDQ(trucks)=5.

In this case, TDQ=SoldQty for cars and trucks respectively. This is explained as follows. In the following picture, we reproduce the picture shown in “Account Driver Properties” on page 611. Because there is no further outgoing flow of costs from either cars or trucks, it follows that their TDQCalc=0. So, given that UsedQty = TDQCalc + SoldQty,
it follows that UsedQty = SoldQty. Furthermore, because TDQ = IdleQuantity + Used Quantity, and because there is no Idle Quantity, it follows that TDQ=SoldQty.

**Step B—DQCalc for Each Path from Wheels to Cars and Trucks Respectively**

DQCalc is calculated according to the formula $DQCalc = DQV \times DWV \times Dest.TDQ$. Because the driver from Wheels to Cars and Trucks is not weighted, $DQV$ in the formula has the value of 1.

*Note:* In the SAS Activity-Based Management user interface, DQCalc is abbreviated as DrvQtyCalc. We use the shorter abbreviation here to save space.

![Diagram showing DQCalc calculation](image)

**Step C—TDQCalc and TDQ for Wheels**

TDQCalc for Wheels is the number of wheels for cars plus the number of wheels for trucks, $TDQCalc = DQCalc(\text{cars}) + DQCalc(\text{trucks})$. And, in this case, because Wheels itself has no SoldQty, its TDQ=TDQCalc, as shown in the following picture:
Step D—DQCalc for the Path from Lug Nuts to Wheels

Because the driver from Lug Nuts to Wheels also is not weighted, DQCalc is calculated according to the following formula:

\[ DQCalc = DQV \times DWV \times Dest.TDQ \]

where \( DWV = 1 \)

See the following picture:
**Step E—TDQCalc and TDQ for Lug Nuts**

Given the calculation of TDQCalc (and therefore also TDQ), we now know how many lug nuts are needed for both cars and trucks.

1. \[ \text{DQCalc} = \text{DOV} \times \text{DWV} \times \text{Dest.TDQ} \]
   \[ \text{DQCalc(cars)} = 4 \times 1 \times 50 = 200 \]
   \[ \text{DQCalc(trucks)} = 8 \times 1 \times 5 = 40 \]

2. \[ \text{TDQCalc} = \text{DQCalc}(1) + \text{DQCalc}(2) + \ldots + \text{DQCalc}(n) \]
   \[ \text{TDQCalc} = 200 + 40 = 240 \]

3. \[ \text{TDQ} = \text{TDQCalc} \]
   \[ \text{TDQ} = 240 \]

4. \[ \text{DQCalc} = \text{DOV} \times \text{DWV} \times \text{Dest.TDQ} \]
   \[ \text{DQCalc} = 5 \times 1 \times 240 = 1200 \]

5. \[ \text{TDQCalc} = \text{DQCalc}(1) + \text{DQCalc}(2) + \ldots + \text{DQCalc}(n) \]
   \[ \text{TDQCalc} = 1200 \]

6. \[ \text{TDQ} = \text{TDQCalc} \]
   \[ \text{TDQ} = 1200 \]

**Step F—Cost and DrvblCost for Lug Nuts**

And, knowing how many lug nuts are needed in total, we can calculate the cost according to the formula

\[ \text{Cost} = \text{UnitCost} \times \text{TDQ} \]

as shown in the following picture. Because

\[ \text{DrvblCost} = \text{Cost} - \text{Allocated Cost} \]

and, because there is no Allocated Cost in this example, it follows that:

\[ \text{DrvblCost} = \text{Cost} \]
Step G—DrvDrvCost for Each Path from Wheels to Cars and Trucks Respectively

Knowing the total cost, $60, we distribute the cost for cars and trucks respectively according to the formula

\[ \text{DrvDrvCost} = \text{DrvblCost} \times \frac{\text{DQCalc}}{\text{TDQCalc}} \]

See the following picture:
**Step H—Cost for Cars and Trucks Respectively**

The cost for a given account is the sum of costs driven to that account by all the drivers into it. Because, for this example, there is only one driver into each of the Cars and Trucks accounts, the cost is the DrvDrvnCost for that driver, as shown in the following picture:
As discussed in Chapter 24, “Adding Properties to a Column Layout,” on page 251, it is interesting to review the preceding cost flow and to classify the properties involved according to whether they are:

- outgoing properties
- assignment properties
- incoming properties
- account properties
- driver properties.

The following picture uses arrows in its annotation to classify the properties. In the picture, you can note the following:

- Cost, in the destination accounts Cars and Trucks, is an account property rather than an incoming property. Cost flows into and out of accounts, but when it is in an account—especially when it is at its final destination—is not going anywhere, it is just there.

- TDQ is always an outgoing property, even in the Cost Object accounts Cars and Trucks. For example, TDQ=240 for Wheels is also an outgoing property even though the Wheels account is the destination of the Lug Nuts account to its left. That is why when the Lug Nuts account wants to reference the TDQ of Wheels, it must do so by qualifying the property with “Dest” in the formula DQCalc=DQVxDWVxDest.TDQ.
Without the qualifier “Dest”, the Lug Nuts account would be referring to its own TDQ.

- The picture does not show incoming properties such as Received Cost or Received Driven Cost.

Using a Weighted Driver with Variable Driver Quantities

**Step A—User Enters Driver Quantities and Sold Quantity**

Now we show an alternative method for distributing the cost of lug nuts to cars and trucks. Instead of creating an account for Wheels and having a separate driver from the Wheels account to each of the Cars and Trucks accounts, we now have a single driver from Lug Nuts with different weights for Cars and Trucks.

Driver weights are used when, in addition to driver quantities, some special characteristics need to be considered to distribute costs. For example, complexity of the product, length of the order (and so forth). In this example, the weight captures how
many wheels are required for each of Cars and Trucks respectively, as shown in the following picture:

**Step B—DQCalc for Each Path from Lug Nuts to Cars and Trucks Respectively**

As before, we calculate DQCalc according to the formula

\[ DQCalc = DQV \times DWV \times Dest.TDQ \]

This time, however, there is a weight to be included in the calculation, as shown in the following picture:

1. \[ DQCalc = DQV \times DWV \times Dest.TDQ \]
2. \[ DQCalc(\text{cars}) = 5 \times 4 \times 50 = 1000 \]
3. \[ DQCalc(\text{trucks}) = 5 \times 8 \times 5 = 200 \]

**Step C—TDQCalc for Lug Nuts**

As shown in the following picture, TDQCalc for Lug Nuts is the sum of DQCalc for cars plus DQCalc for trucks.
Step D—TDQ for Lug Nuts

TDQ equals TDQCalc. So, now we know how many lug nuts are needed in total for both cars and trucks.

Step E—Cost and DrvblCost for Lug Nuts

Cost equals the total number of lug nuts times the unit cost for each lug nut:
Cost = UnitCost x TDQ = 0.05 x 1200 = 60

Because

DrvblCost = Cost - Allocated Cost

and, because there is no Allocated Cost in this example, it follows that

DrvblCost = Cost

Step F—DrvDrvnCost for Each Path from Lug Nuts to Cars and Trucks Respectively

Knowing the total driveable cost, $60, we can distribute the cost to cars and trucks respectively according to the formula

DrvDrvnCost = DrvblCost x DQCalc/TDQCalc

as shown in the following picture:
Step G—Cost for Cars and Trucks Respectively

The cost for a given account is the sum of costs driven to that account by all the drivers into it. Because, for this example, there is only one driver going into each of the Cars and Trucks accounts, the cost is the DrvDrvnCost for that driver, as shown in the following picture:
Using a Weighted Driver with Fixed Driver Quantities

For this example, we show the properties in a single picture. The problem for this example is to distribute the cost of support calls for two products: cars (a less complex product requiring less time to support) and trucks (a more complex product requiring more time to support). The data given for the problem is the following:

- $320 was spent on support calls for both cars and trucks combined.
- Whereas each support call for a car takes 3 minutes (DWF=3), each support call for a truck requires 10 minutes (DWF=10).

The following picture shows the calculation of the cost driven to each product (DriverCost) using the following formulas:

- \[ DQ\text{Calc} = (DQF \times DWF) + (DQV \times DWV \times Dest.TDQ) \]
- \[ TDQ\text{Calc} = DQ\text{Calc}(1) + DQ\text{Calc}(2) + \ldots + DQ\text{Calc}(n) \]
- \[ DriverCost = Cost \times \frac{DQ\text{Calc}}{TDQ\text{Calc}} \]
Using a Weighted Driver with Fixed and Variable Driver Quantities

For this example, we again show the properties in a single picture for the cost flow of a driver with two assignment paths, each using a different weight.

Once again, the picture shows the calculation of the cost driven to each product (DriverCost) using the following formulas:

- \( \text{DQCalc} = (DQF \times DWF) + (DQV \times DWV \times \text{Dest.TDQ}) \)
- \( \text{TDQCalc} = \text{DQCalc}(1) + \text{DQCalc}(2) + \ldots + \text{DQCalc}(n) \)
- \( \text{DriverCost} = \text{Cost} \times (\text{DQCalc}/\text{TDQCalc}) \)

For example:

- \( \text{DQCalc}(\text{cars}) = (20 \times 3) + (0 \times 1 \times 0) = 60 \)
- \( \text{DQCalc}(\text{trucks}) = (0 \times 10) + (0 \times 1 \times 0) = 100 \)

DriverCost(\text{cars}) = \$200 \times (60/100) = \$120 \)

DriverCost(\text{trucks}) = \$200 \times (100/100) = \$200 \)

DQCalc = (DQF \times DWF) + (DQV \times DWV \times \text{Dest.TDQ})

DQCalc(\text{A1}) = (3*2) + (3*2*2) = 18

DQCalc(\text{A2}) = (2*1) + (2*1*100) = 202

DriverCost(\text{A1}) = 100 \times (18/220) = 8.18

DriverCost(\text{A2}) = 100 \times (202/220) = 91.82
Idle Flow

The following picture shows the four different methods of flowing an Idle Quantity from a source account to destination accounts. The four different methods are:

**User Entered**
The idle quantity is distributed as specified by the value of IdleQtyUE for each assignment path. Any idle quantity that is not distributed is assigned to the property Unassigned.

**User Proportion**
The idle quantity is distributed in the relative proportion of the IdleQtyUE of each assignment path.

**Driver Quantity**
The idle quantity is distributed in the relative proportion of the DQF of each assignment path.

**Evenly Assigned**
The idle quantity is distributed equally among the destination accounts.

*Note:* IdleQty = TDQUE - UsedQuantity
### User Entered

<table>
<thead>
<tr>
<th>TDQUE</th>
<th>UsedQty</th>
<th>IdleQty</th>
<th>IdleQtyUE</th>
<th>IdleDrvQty</th>
<th>A1</th>
</tr>
</thead>
<tbody>
<tr>
<td>100</td>
<td>80</td>
<td>20</td>
<td>5</td>
<td>5</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>IdleQtyUE</td>
<td>IdleDrvQty</td>
<td>A2</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>5</td>
<td>5</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>IdleQtyUE</td>
<td>IdleDrvQty</td>
<td>A3</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>5</td>
<td>Unassigned=5</td>
<td>5</td>
</tr>
</tbody>
</table>

### User Proportion

<table>
<thead>
<tr>
<th>TDQUE</th>
<th>UsedQty</th>
<th>IdleQty</th>
<th>IdleQtyUE</th>
<th>IdleDrvQty</th>
<th>A1</th>
</tr>
</thead>
<tbody>
<tr>
<td>100</td>
<td>80</td>
<td>20</td>
<td>50</td>
<td>20 x 50/225</td>
<td>4.49</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>IdleQtyUE</td>
<td>IdleDrvQty</td>
<td>A2</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>100</td>
<td>20 x 100/225</td>
<td>8.89</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>IdleQtyUE</td>
<td>IdleDrvQty</td>
<td>A3</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>75</td>
<td>20 x 75/225</td>
<td>6.67</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>50+100+75=225</td>
<td>Unassigned=0</td>
<td></td>
</tr>
</tbody>
</table>

### Driver Quantity

<table>
<thead>
<tr>
<th>TDQUE</th>
<th>UsedQty</th>
<th>IdleQty</th>
<th>DQF</th>
<th>IdleDrvQty</th>
<th>A1</th>
</tr>
</thead>
<tbody>
<tr>
<td>100</td>
<td>80</td>
<td>20</td>
<td>10</td>
<td>20 x 10/60</td>
<td>3.33</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>DQF</td>
<td>A2</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>20</td>
<td>6.67</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>20 x 20/60</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>30</td>
<td>Unassigned=0</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>10+20+30=60</td>
<td></td>
</tr>
</tbody>
</table>

### Evenly Assigned

<table>
<thead>
<tr>
<th>TDQUE</th>
<th>UsedQty</th>
<th>IdleQty</th>
<th>DQF</th>
<th>IdleDrvQty</th>
<th>A1</th>
</tr>
</thead>
<tbody>
<tr>
<td>100</td>
<td>80</td>
<td>20</td>
<td>20/3</td>
<td>8.66</td>
<td>A2</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>DQF</td>
<td>A3</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>20/3</td>
<td>8.66</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Unassigned=0</td>
<td></td>
</tr>
</tbody>
</table>

**See Also**

“Idle Quantities” on page 301
Chapter 38
Detailed Example of Calculation

Introduction

This chapter describes what the system does to calculate the cost flows between accounts for the following simple example:

- **Introduction**: This chapter describes what the system does to calculate the cost flows between accounts for the following simple example:

- **Step 1–User Enters Driver Quantities (DQF, DQV, DWF, DWV, DrvAllocCost)**

- **Step 2–DrvQtyCalc for Paths to Cost Object Accounts**

- **Step 3–TDQCalc for Activity Accounts**

- **Step 4–TDQ for Activity Accounts**

- **Step 5–DrvQtyCalc for Paths to the Activity Accounts**

- **Step 6–TDQCalc for Resource Account**

- **Step 7–TDQ for Resource Account**

- **Step 8–AllocCost for Resource Account**

- **Step 9–DrvblCost for Resource Account**

- **Step 10–DrvRate for Resource Account**

- **Step 11–DrvDrvnCost for Paths to Activity Accounts**

- **Step 12–DrvCost for Paths to Activity Accounts**

- **Step 13–DrvblCost for Activity Accounts**

- **Step 14–DrvRate for Outgoing Drivers from Activity Accounts**

- **Step 15–DrvDrvnCost for Paths to Cost Object Accounts**

- **Step 16–DrvCost for Paths to Cost Object Accounts**

- **Step 17–Cost for Cost Object Accounts**
The description can help you to further understand that some system properties describe quantities flowing along an assignment path, while other system properties describe costs coming into or flowing out of an account. Although this example does not include all the properties available in a model, it does include those that are most frequently used in assignments.

To summarize the calculation process for this example:

- **Resource_account** assigns costs to **Activity_account1** and **Activity_account2** using a weighted driver.

  The weighted driver allows both fixed driver quantities (DQF and DWF) and variable driver quantities (DQV and DWV).

  The driver also allows user-entered cost allocation (DrvAllocCost).

- **Activity_account1** assigns costs to **CO_account1** and **CO_account2** using a basic driver.

  This basic driver allows both fixed driver quantities (DQF) and variable driver quantities (DQV) — but not DWF and DWV because it is not a weighted driver.

- **Activity_account2** also assigns costs to **CO_account1** and **CO_account2** but using a percentage driver.

The following is a schematic drawing which we will use in the rest of this chapter in discussing the calculation process.
To anticipate, the process by which the system determines the cost flow from Resource_account to Activity_account1 and Activity_account2 is the following:

1. User Enters Driver Quantities (DQF, DQV, DWF, DWV, DrvAllocCost)

   The subsequent calculations are all performed by the system.

2. DrvQtyCalc for Paths to Cost Object Accounts

3. TDQCalc for Activity Accounts

4. TDQ for Activity Accounts

5. DrvQtyCalc for Paths to the Activity Accounts

6. TDQCalc for Resource Account

7. TDQ for Resource Account

8. AllocCost for Resource Account

9. DrvblCost for Resource Account

10. DrvRate for Resource Account

11. DrvDrvnCost for Paths to Activity Accounts

12. DrvCost for Paths to Activity Accounts

13. DrvblCost for Activity Accounts

14. DrvRate for Outgoing Drivers from Activity Accounts

15. DrvDrvnCost for Paths to Cost Object Accounts

16. DrvCost for Paths to Cost Object Accounts

17. Cost for Cost Object Accounts
Step 1–User Enters Driver Quantities (DQF, DQV, DWF, DWV, DrvAllocCost)

The following are user-entered driver quantities:

- DQF (Driver Quantity Fixed)
- DQV (Driver Quantity Variable)
- DWF (Driver Weight Fixed)
- DWV (Driver Weight Variable)
- DrvAllocCost (Driver Allocated Cost)
Step 2–DrvQtyCalc for Paths to Cost Object Accounts

DrvQtyCalc=(DQF x DWF) + (DQV x DWV x Dest.TDQ):

DrvQtyCalc from Activity_account1 to CO_account1 = (1 x 1) + (5 x 1 x 0) = 1
DrvQtyCalc from Activity_account1 to CO_account2 = (1 x 1) + (10 x 1 x 0) = 1
DrvQtyCalc from Activity_account2 to CO_account1 = (60 x 1) + (0 x 1 x 0) = 60
DrvQtyCalc from Activity_account2 to CO_account2 = (40 x 1) + (0 x 1 x 0) = 40

Note: TDQ=0 for CO_account1 and for CO_account2 because there are no costs flowing out of these Cost Object accounts.

Note: A Percentage driver does not allow variable driver quantities. So, its DQV is null, and for calculations a null is counted as zero (DQV=0).

Note: Both the Percentage driver and the Basic driver are non-weighted drivers. For non-weighted drivers, DWF=1 and DWV=1.
Step 3–TDQCalc for Activity Accounts

TDQCalc is the sum of all DrvQtyCalc:

TDQCalc for Activity_account1 = 1 + 1 = 2

TDQCalc for Activity_account2 = 60 + 40 = 100
Step 4—TDQ for Activity Accounts

TDQ for Activity_account1 = DQF to CO_account1 + DQF to CO_account2:
TDQ for Activity_account1 = 1 + 1 = 2

TDQ for Activity_account2 = DQF to CO_account1 + DQF to CO_account2:
TDQ for Activity_account2 = 60 + 40 = 100
Step 5–DrvQtyCalc for Paths to the Activity Accounts

Driven Quantity Calculation (DrvQtyCalc) formula:

$$\text{DrvQtyCalc} = (\text{DQF} \times \text{DWF}) + (\text{DQV} \times \text{DWV} \times \text{Dest.TDQ})$$

Example calculations:

- For Activity_account1:
  
  $$\text{DrvQtyCalc} = (3 \times 2) + (3 \times 2 \times 2) = 18$$

- For Activity_account2:
  
  $$\text{DrvQtyCalc} = (2 \times 1) + (2 \times 1 \times 100) = 202$$
Step 6–TDQCalc for Resource Account

TDQCalc is the sum of DrvQtyCalc for all outgoing assignment paths:

\[ \text{TDQCalc} = (\text{DrvQtyCalc for Activity_account1}) + (\text{DrvQtyCalc for Activity_account2}) \]

\[ \text{TDQCalc} = 18 + 202 = 220 \]
Step 7–TDQ for Resource Account

TDQ = TDQCalc:
TDQ = 220
Step 8–AllocCost for Resource Account

Source Allocated Cost = Sum of DrvAllocCost for all outgoing assignment paths:

DrvAllocCost of assignment path from Resource_account to Activity_account1 = 12
DrvAllocCost of assignment path from Resource_account to Activity_account2 = 16

Source Allocated Cost = 12 + 16 = 28
Step 9–DrvblCost for Resource Account

Drivable Cost = Cost - Allocated Cost:

Drivable Cost = 100 - 28 = 72
Step 10–DrvRate for Resource Account

DriverRate = DrivableCost / TDQ:

DriverRate = 72 / 220 = 0.33 (rounded up)
Step 11–DrvDrvnCost for Paths to Activity Accounts

DrvDrvnCost for Resource_account to Activity_account1:

\[
\text{DrvDrvnCost} = \text{DrvblCost} \times \left( \frac{\text{DrvQtyCalc}}{\text{TDQCalc}} \right)
\]

\[
\text{DrvDrvnCost} = 72 \times \left( \frac{18}{220} \right) = 5.89
\]

DrvDrvnCost for Resource_account to Activity_account2:

\[
\text{DrvDrvnCost} = \text{DrvblCost} \times \left( \frac{\text{DrvQtyCalc}}{\text{TDQCalc}} \right)
\]

\[
\text{DrvDrvnCost} = 72 \times \left( \frac{202}{220} \right) = 66.11
\]
Driver Cost for assignment path from Resource_account to Activity_account1:

DriverCost = Driver Driven Cost + DrvAllocCost:

DriverCost = 5.89 + 12 = 17.89

So, Cost=17.89 for Activity_account1

Driver Cost for assignment path from Resource_account to Activity_account2:

DriverCost = Driver Driven Cost + DrvAllocCost:

DriverCost = 66.11 + 16 = 82.11

So, Cost=82.11 for Activity_account2
Step 13–DrivableCost for Activity Accounts

DrivableCost = Cost - Allocated Cost:

DrivableCost for Activity_account1 = 17.89 - 0 = 17.89
DrivableCost for Activity_account2 = 82.11 - 0 = 82.11
DriverRate = DrivableCost / TDQ:

DriverRate for Activity_account1 = 17.89 / 2 = 8.95 (rounded up)

DriverRate for Activity_account2 = 82.11 / 100 = .82 (rounded down)
Step 15–DrvDrvnCost for Paths to Cost Object Accounts

Driver Driven Cost = DrvblCost * (DrvQtyCalc / TDQCalc):

Driver Driven Cost for Activity_account1 ⇒ CO_account1 = 17.89 x (1/2) = 8.95
Driver Driven Cost for Activity_account1 ⇒ CO_account2 = 17.89 x (1/2) = 8.95
Driver Driven Cost for Activity_account2 ⇒ CO_account1 = 82.11 x (60/100) = 49.27
Driver Driven Cost for Activity_account2 ⇒ CO_account2 = 82.11 x (40/100) = 32.84
Step 16–DrvCost for Paths to Cost Object Accounts

DriverCost for assignment path from Activity_account1 to CO_account1:

DriverCost = 8.95 + 0 = 8.95

DriverCost for assignment path from Activity_account1 to CO_account2:

DriverCost = 8.95 + 0 = 8.95

DriverCost for assignment path from Activity_account2 to CO_account1:

DriverCost = 49.27 + 0 = 49.27

DriverCost for assignment path from Activity_account2 to CO_account2:

DriverCost = 32.84 + 0 = 32.84
Step 17–Cost for Cost Object Accounts

Cost for destination account = Sum of individual DriverCosts:

Cost for CO_account1 = 8.95 + 49.27 = 58.21
Cost for CO_account2 = 8.95 + 32.84 = 41.79
Part 14

Generating Cubes

Chapter 39

*Working with Generation* ........................................... 439
Chapter 39
Working with Generation

Cubes

Overview
A cube is the basic unit of analysis: it represents a particular domain of inquiry in online analytical processing (OLAP). A cube contains a subset of model data, such as single-stage contribution, multi-stage contribution, or resource contribution. Each cube combines multiple dimensions and the measures that the dimensions contain into one unit. SAS Activity-Based Management cubes are standard OLAP cubes.

You use SAS Activity-Based Management to connect to the cubes on a SAS Activity-Based Management server and to interact with these cubes. After generating cubes, you can then manipulate these cubes on the OLAP Analyzer view to interactively analyze data.

In an analysis grid, a cube's dimensions determine the columns and rows. The measures are the data in the cells of the rows and columns.
A cube in which costs are indexed by two dimensions (for example, customer and product) is a two-dimensional cube. A cube in which costs are indexed by three dimensions (for example, region, customer, and product) is a three-dimensional cube.

It does not matter how many dimensions a cube has; the storage unit is still a cube, and the cube represents $n$ dimensions of data. A cube enables you to perform multidimensional data analysis. You extract useful knowledge from an $n$-dimensional cube, and you represent the knowledge so that it can be easily understood.

In a cube, measures are aggregated within a single dimension and for all combinations of dimension members from different dimensions. These aggregations enable you to analyze measures by dimension members in different dimensions simultaneously. For example, you can analyze quarterly costs for products within a region.

Fact Tables

Each cube is based on a fact table, which stores model data for the cube. When you generate a cube, the fact table is generated first. Then, the cube is created from the fact table.

To make your data analysis capabilities more flexible, you can choose to generate a fact table without generating the associated cube. You can use the fact table to generate a customized cube in another application, such as SAS OLAP Cube Studio or Microsoft Analysis Services.

Note: When you generate a fact table, SAS Activity-Based Management determines whether any model data has changed since the last time the model was calculated. If any model data has changed, the period/scenario association is calculated to ensure that the model data is correct. You can force the costs to be calculated.

Generating Cubes

Overview

After you calculate costs, you can generate cubes to analyze a model on the OLAP Analyzer view.

When SAS Activity-Based Management generates cubes, it performs calculations that pre-aggregate numeric data to give you faster performance when you work on the OLAP view. For large models, pre-aggregating data for cubes can take many hours to complete.

The following factors are listed in order, from those that take more time to generate a cube, to those that take less time:

- the number of stages
- the number of dimensions
- the length of assignment paths
  
  Assignment paths should contain fewer than 10 items.
- the number of accounts and the number of assignment paths

Note: Whenever you generate cubes, cubes that were generated previously are no longer available for viewing.
**OLAP Analyzer View Performance**

If the SAS Activity-Based Management server does not finish pre-aggregating data during cube generation, some data might be aggregated while you are using the OLAP Analyzer view. This can result in poor performance. Therefore, you might want to increase the server's default time limit (about 10 hours) for pre-aggregating data. To increase the default time limit, contact your regional SAS Technical Support for assistance.

**Predefined Cubes**

SAS Activity-Based Management provides the following predefined cubes:

**Resource Contribution cube**
Use the Resource Contribution cube to analyze costs contributions from original accounts where costs were entered to final accounts that do not assign costs to other accounts.

**Single-stage Contribution cube**
Use the Single-stage Contribution cube to analyze the cost contributions from one assignment level back.

**Multi-stage Contribution cube**
Use the Multi-stage Contribution cube to analyze cost contributions to or from accounts that are tagged with stages attributes.

*Note:* You do not need to add stages attributes to accounts; you can use each module as a stage.

**Resource Contribution Cube**

The Resource Contribution cube enables you to analyze resource costs that contribute to a product, customer, service cost, and so on. Or, use this cube to analyze the products, customers, service costs, and so on, that receive costs from resources.

The Resource Contribution cube enables you to study cost contributions from original accounts where costs were entered to final accounts that do not assign costs to other accounts. Generally, these cost contributions are from resource accounts to cost object accounts, but where the original or final accounts reside does not matter.

*Note:* The Resource Contribution cube contains only the costs of the first account in an assignment path and the costs of the last account. It does not contain the intermediate accounts and their costs.

**Single-stage Contribution Cube**

The Single-stage Contribution cube enables you to answer questions such as:

- Which activity costs contribute to product, customer, service cost, and so on?
- When costs are assigned within the Cost Object module, which sub-assembly costs contribute to product costs?
- What are the costs of resources that contribute to activities?
The Single-stage Contribution cube enables you to analyze the cost contributions from one assignment level back. Where costs originate or end does not matter. Typically, cost is contributed from:

- Activities to cost objects
- Resources to activities

*Note:* You do not need to add stages attributes to accounts; you can use each module as a stage.

**Multi-stage Contribution Cube**

The Multi-stage Contribution cube enables you to address issues and answer questions such as:

- Product A is not profitable. I want to trace the costs back through activities and then to resources that contribute costs to this product.
- What are the costs for Product B that originate in salary resources and are assigned through the Inspection activity to this product?

The Multi-stage Contribution cube enables you to analyze cost contributions into and out of stages defined in a model. You can define each module as a stage or you can use stages attributes. The SAS OLAP Analyzer Cube Explorer View enables you to visually trace cost contributions through all the stages.

**Using the Cubes with Other Software**

**Cognos PowerPlay**

To open SAS Activity-Based Management cubes with Cognos PowerPlay, see the Cognos online document titled *OLAP Server Connection Guide*. The chapter “Connect to Microsoft SQL Server OLAP Services” describes the procedure and concepts in detail.

The SAS Activity-Based Management Administrator can give you the model ID for each model. Instructions are in the “SAS Activity-Based Management Installation Checklist.”

If you require additional help after reviewing the Cognos documentation, please contact your regional SAS Technical Support.

**Microsoft Excel**

You can export a cube to Microsoft Excel and then modify, print, or save the data.

---

**Generate Cubes**

1. Open the model for which you want to generate cubes.
2. Select Model ⇒ Generate Cubes. The Generate Cubes dialog box opens.
3. Select the cube configurations to use. Each cube configuration generates a single cube.

   See “Create a Cube Configuration” on page 377.

4. Select **Force Cube Generate** to cause a cube to be generated even if the system thinks that it is up-to-date and doesn’t need to be regenerated. See “Incremental Cube Generation” on page 443.

5. Select either a period/scenario association or **Select All**.

6. Select how many error and warning messages to display.

7. Click **Count Rows** to count the number of rows in the cube to be generated. This gives you an idea of how long it will take to generate the cube. (It is not required to count the rows before generating.)

---

**Incremental Cube Generation**

Now, when you generate a cube, for every period/scenario association that is to be included in an existing cube, if

- the cube already contains that period/scenario association, and
- the period/scenario association has not been modified since the cube was last generated

then the period/scenario association is not regenerated. This means that cube generation is faster because periods that have already been generated are not regenerated.

In order to support incremental cube generation, SAS Activity-Based Management provides a new **Periodic data only** option in the Import Wizard that allows you to import only the periods that have changed in a model (for example, the new periods).
If you select **Periodic data only**, then only those staging tables that contain periodic data are displayed in the Import Wizard for you to select for importing.

Staging tables are distinguished by whether they contain periodic or structural data. Periodic data is model data that is stored separately for each period/scenario association. Structural data is model data that is independent of any period/scenario association. It is data that is common to all period/scenario associations.

The following table lists staging tables that contain periodic data and those that contain structural data:

<table>
<thead>
<tr>
<th>Periodic data</th>
<th>Structural data</th>
</tr>
</thead>
<tbody>
<tr>
<td>Account</td>
<td>Dimension</td>
</tr>
<tr>
<td>Assignment</td>
<td>DimensionMember</td>
</tr>
<tr>
<td>CurrencyRate</td>
<td>DimensionLevel</td>
</tr>
<tr>
<td>Dimension</td>
<td></td>
</tr>
<tr>
<td>Driver</td>
<td></td>
</tr>
<tr>
<td>ExternalCostElement</td>
<td></td>
</tr>
<tr>
<td>ExternalUnit</td>
<td></td>
</tr>
<tr>
<td>Model</td>
<td></td>
</tr>
<tr>
<td>MultiStageContribution</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td></td>
</tr>
<tr>
<td>AssignmentMainUnit</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td></td>
</tr>
</tbody>
</table>

If you select **Periodic data only**, then only those staging tables that contain periodic data are displayed in the Import Wizard for you to select for importing.

Staging tables are distinguished by whether they contain periodic or structural data. Periodic data is model data that is stored separately for each period/scenario association. Structural data is model data that is independent of any period/scenario association. It is data that is common to all period/scenario associations.

The following table lists staging tables that contain periodic data and those that contain structural data:
When you generate a cube for a model that has been generated before, SAS Activity-Based Management determines whether the entire cube must be regenerated or whether only the new or modified periods need to be generated. You do not have to specify, when you generate a cube, whether you want incremental generation or not. SAS Activity-Based Management makes the determination for you.

**Note:** If you are using Microsoft Analysis Services for cubes, then incremental cube generation is available only if you are using either Microsoft SQL Server Enterprise or Microsoft SQL Server Developer. Incremental cube generation is not available with Microsoft SQL Server Standard.

**Note:** If you are using SAS OLAP for cubes, then incremental cube generation is not available under certain circumstances because SAS OLAP does not allow deleting or updating a Period/Scenario inside a cube. For example, if you have generated a cube containing a Period/Scenario which you subsequently modify inside the model, then when you regenerate the same cube, adding a new Period/Scenario, the entire cube must be regenerated because the previously generated Period/Scenario can neither be deleted nor updated. When you generate a cube using SAS OLAP, SAS Activity-Based Management determines whether it can use incremental cube generation or whether it must regenerate the entire cube.

**Note:** Cubes in SAS OLAP that are generated using either the NO_NWAY option or the NONUPDATEABLE option are not eligible for incremental generation. See “Cube Options for SAS OLAP” on page 383. Also see The OLAP Procedure in the SAS OLAP Server: User's Guide for more information:: [http://support.sas.com/documentation/onlinedoc/olap/index.html](http://support.sas.com/documentation/onlinedoc/olap/index.html).

**Note:** With the implementation of incremental cube generation, OLAP views that were saved in a previous release of SAS Activity-Based Management will no longer work in SAS Activity-Based Management 7.2 if you are using Microsoft Analysis Services to build the cube. This is because the saved view is an MDX query, and the period names embedded in the query are no longer correct.
Include Numeric Attributes in a Cube

The method for including numeric attributes in a single-stage contribution cube is different from the method for including them in a resource contribution cube or a multi-stage contribution cube.

**Single-Stage Contribution Cube**

To include numeric attributes in a single-stage contribution cube:

1. In model mode, select **Model > Properties**.
2. Select the **Attributes in Cubes** tab.
3. Select the numeric attributes to be included in the cube.

   If you generate a single-stage contribution cube, then the numeric attributes that you select are included in the cube.

**Resource Contribution Cube and Multi-Stage Contribution Cube**

To include numeric attributes in a resource contribution cube or multi-stage contribution cube:

1. Go to the Numeric Attributes dialog of the Cube Configuration wizard.

   ![Edit Cube Configuration - Numeric Attributes](insert_image)

   - Select the numeric attributes to be included in the cube.

   If you generate either a resource contribution cube or a multi-stage contribution cube, then the numeric attributes that you select are included in the cube.

   You can select the numeric attributes that are to be checked by default in a new cube configuration by doing the following:

   1. In model mode, select **Model > Properties**.
   2. Select the **Attributes in Cube** tab.
   3. Select the numeric attributes that are to be checked by default in a new cube configuration for that model.
Attributes that you select in Model Properties are automatically checked in a new cube configuration to be included in the generated cube. However, you can uncheck the attributes in the cube configuration and select others before generating the cube.

See Also

“Cube Configuration: Select Numeric Attributes” on page 385

Display the Internal Name of a Cube

Instead of using SAS Activity-Based Management to view a generated cube, you can use SAS Enterprise Guide, SAS Web Report Studio, or SAS OLAP Cube Studio. Or you can use a third party tool other than SAS to view a cube and its fact table. Fact tables are stored in the database and cubes are stored in the OLAP server. To open a fact table or cube you need to know its internal name.

Note: Using a program other than SAS Activity-Based Management to modify a cube that has been generated by SAS Activity-Based Management can affect display of the cube inside of SAS Activity-Based Management.

To display the internal name of a fact table or cube:
1. Open the model for whose fact tables or cubes you want to display the internal name.
2. Select Model ⇒ Manage Cubes and Permission .
   The Manage Cubes and Permissions dialog box opens.
3. Select the fact table or cube whose internal name you want to display.
   Note: You can select only one row at a time.
4. Click Internal names. A dialog box opens displaying the internal names.
Delete a Cube or Fact Table

1. Open the model whose cubes or fact tables you want to delete.
2. Select Model ⇒ Manage Cubes and Permissions.
   The Manage Cubes and Permissions dialog box opens.
3. Select the cube or fact table that you want to delete.
   Note: You can delete only one cube or fact table at a time.
4. Click Delete.

Manage Cube Permissions

After creating a cube, you can change its owner, and add or remove Read access to it.

To manage cube permissions:
1. Open the model for whose cubes you want to manage permissions.
2. Select Model ⇒ Manage Cubes and Permissions.
   The Manage Cubes and Permissions dialog box opens.
3. Select the cube whose permissions you want to change.
   
   Note: You can change only one cube at a time.

4. Click Permissions. The Permissions dialog box opens.

5. You can add or remove Read access to groups. All members of the group inherit the permissions that you select for that group.
Part 15

OLAP Analysis

Chapter 40
Using the Analysis Workspace ........................................ 453

Chapter 41
How To ................................................................. 463
Chapter 40
Using the Analysis Workspace

Analysis Workspace ......................................................... 453
  About the Analysis Workspace ...................................... 454
  How to Access the Analysis workspace .............................. 454
  Open an OLAP view ...................................................... 454
  Delete an OLAP view .................................................... 455
  Sort information ......................................................... 455

OLAP Mode ................................................................. 455
  About OLAP Mode ....................................................... 455
  How to Access OLAP Mode ............................................. 455
  Open an OLAP View ..................................................... 455
  Open a Model and a Cube .............................................. 456

OLAP Views ................................................................. 456
  About OLAP Views ....................................................... 456
  Saving a View ............................................................ 456
  Cube Availability ....................................................... 457

OLAP Analyzer View ...................................................... 457
  About the OLAP Analyzer View ...................................... 457
  Working in the OLAP Analyzer View ................................. 458
  How to Access the OLAP Analyzer View ............................ 458
  Save an OLAP view ...................................................... 459
  Change the Appearance of an OLAP Window ....................... 459
  Show or Hide the Cube View Manager ............................... 459
  Open the View Editor ................................................. 459
  Open the MDX Editor ................................................... 459
  Export a Cube ............................................................ 459
  Print an OLAP View ..................................................... 459

Save OLAP View As Dialog Box ........................................ 459
  About the Save OLAP View As Dialog Box ......................... 460
  How to Access the Save OLAP View As Dialog Box .............. 460
  Save an OLAP View ..................................................... 460

Change Cube Context Dialog Box ..................................... 460
  About the Change Cube Context Dialog Box ....................... 460
  How to Access the Change Cube Context Dialog Box ............ 460

SAS OLAP Restrictions .................................................... 461
Analysis Workspace

About the Analysis Workspace

In the Analysis workspace, you can open an OLAP view.

*Note:* The availability of these features depends on your permissions.

The list of Folders and the list of OLAP Views correspond to the OLAP branch of the server area in Workspace Manager.

How to Access the Analysis workspace

Do one of the following:

- If no OLAP view is open, click **Analysis** in the Navigation Pane.
- If an OLAP view is open, click the **Go to Analysis Workspace** icon in the toolbar.

Open an OLAP view

1. From the list of Folders on the left, select a folder.
2. From the list of OLAP Views on the right, double-click a view.

*Note:* The JAWS screen-reading program occasionally locks input fields of HTML pages, preventing you from entering data. If this happens while you are using JAWS, press Alt+N to re-enable screen input.
Delete an OLAP view

Select the OLAP view and click Delete on your keyboard.

Note: Depending on your permissions, Delete might not be available to you.

Sort information

1. Click the Sort By link.
   A menu appears.
2. Select an option. The options contain the following criteria:

<table>
<thead>
<tr>
<th>Name</th>
<th>The name of the OLAP view</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cube</td>
<td>The name of the cube that the OLAP view uses</td>
</tr>
<tr>
<td>Model</td>
<td>The name of the model that the OLAP view uses</td>
</tr>
<tr>
<td>Date and Time</td>
<td>The date and time which the OLAP view was created</td>
</tr>
</tbody>
</table>

See Also

“OLAP Mode” on page 455

OLAP Mode

About OLAP Mode

In OLAP mode, you can use cubes on the OLAP view to analyze data.
If no OLAP view is selected when you enter OLAP mode, the OLAP view is displayed.

How to Access OLAP Mode

Click Analysis in the Navigation Pane.

Open an OLAP View

1. From the Cube View menu, select a saved OLAP view.
Note: If an OLAP view is not already open, open an OLAP view from the Analysis workspace.

2. Click 🔄

Open a Model and a Cube

1. From the Model menu, select a model.
2. From the Cube menu, select a predefined cube.
3. Click 🔄

See Also

• “Analysis Workspace” on page 453
• “Change the Appearance of an OLAP Window” on page 464
• “Open an OLAP View” on page 464
• “Open an OLAP View with an OLAP View Already Open” on page 465

OLAP Views

About OLAP Views

OLAP is a technology that is used to create decision-support software. OLAP enables users to quickly analyze data that has been summarized into multidimensional views and hierarchies. By summarizing predicted queries into multidimensional views and hierarchies before run time, SAS Activity-Based Management's OLAP tool provides the benefit of increased performance over traditional database access tools. Most of the resource-intensive calculation that is required to summarize the data is done before a query is submitted.

An OLAP view is a collection of information, such as a cube and model, that controls how a cube is displayed in the Analysis Workspace.

Saving a View

To save an OLAP view, do the following:
1. Go to the Analysis workspace.
2. Open an OLAP view.
3. Click Save the current OLAP view, or Save to a new OLAP view.

Once an OLAP view has been saved, open it from the Analysis workspace.
When you save an OLAP view, all of the following are saved:

- the cube
- the model
- the OLAP view's layout
- the OLAP view's contents

During analysis, changes that you make to a grid view, a chart view, and the Cube Explorer View are retained during a session, even when you return to the OLAP view after viewing other tabs. However, your changes are lost when you close SAS Activity-Based Management or when you close a grid view, a chart view, or the Cube Explorer View.

If you want these changes to be available later, save the OLAP view. However, the window positions and window states are not saved.

**Cube Availability**

When you try to display a cube in an OLAP view, the following situations might cause the cube to be unavailable:

- Another user is currently regenerating the cube.
- The cube on which a saved OLAP view is based has been deleted.

**OLAP Analyzer View**

**About the OLAP Analyzer View**

The OLAP Analyzer view embeds the SAS OLAP Analyzer. With the OLAP analyzer you can study measures at dimension intersections by creating an OLAP view. You can analyze dimensions and measures in Grid View, Chart View, and Cube Explorer View.
Note: Press F1 for help while working in the OLAP Analyzer.

The predefined cube that you choose determines which dimensions and measures are available to you, as well as what kinds of analyses you can perform.

Note: Models are not displayed in the Model menu until you generate the model's cubes.

**Working in the OLAP Analyzer View**

You can view data in one or two windows, depending on your needs.

The OLAP buttons that are available to you depend on which window is selected and on what type of information is displayed in the window.

**How to Access the OLAP Analyzer View**

1. Click Analysis in the Navigation Pane.
2. Double-click to open an OLAP view in the SAS OLAP Analyzer.
See Also

“Analysis Workspace” on page 453

Save an OLAP view

Select Analysis ⇒ Chart Type ⇒ "type of chart".

Change the Appearance of an OLAP Window

Display a chart
Select Analysis ⇒ Chart Type ⇒ "type of chart".

Display a Cube Explorer view
Select Analysis ⇒ Cube View ⇒ New ⇒ Cube Explorer.

Swap rows and columns
Select Analysis ⇒ Pivot.
Both the table view and the graph view are updated.

Show or Hide the Cube View Manager

Select Analysis ⇒ View Manager.
A check indicates that View Manager is displayed.

Open the View Editor

Select Edit View ⇒ Edit with View Editor.
The View Editor allows you to create OLAP views by dragging and dropping dimensions and measures into the view.

Open the MDX Editor

Select Edit ⇒ Edit with MDX Editor.
The Edit MDX Statement dialog box appears.

Export a Cube

Select Analysis ⇒ Export To Excel.
Microsoft Excel opens and displays the exported data.

Print an OLAP View

From the Print menu, select Print Preview or Print.

See Also

“SAS OLAP Restrictions” on page 461
Save OLAP View As Dialog Box

**About the Save OLAP View As Dialog Box**

In the Save OLAP View As dialog box, you can save a customized OLAP view.

**How to Access the Save OLAP View As Dialog Box**

Open an OLAP view and select Analysis ⇒ Save View As.

**Save an OLAP View**

1. Type the Name.
2. (Optional) Type the Description.

Change Cube Context Dialog Box

**About the Change Cube Context Dialog Box**

Use this dialog to select a different cube to view for the currently open model, or select a different cube of a different model.

**How to Access the Change Cube Context Dialog Box**

Select Analysis ⇒ Change cube context.

*Note:* You must be in the Analysis Workspace with a cube view currently open for this menu item to be available.
SAS OLAP Restrictions

The following restrictions exist in the 9.2 SAS OLAP Server which is used to displayed reports:

• Most OLAP names can be up to 32 characters in length except for aggregation names that can be up to 256 characters. When SAS processes a name it will be uppercased.

• Level names must be unique within a cube.

• Measure names must be unique within a cube.

• Number of dimensions: Maximum 128 (Minimum 1).

• Number of levels per dimension: Maximum 19.

• Number of levels per cube: Maximum 256.

• Number of measures per cube: Maximum 1024.

• Maximum length of a unique name is 32767 characters.

• Size of the MDX string is unlimited, but extremely long strings can affect performance.
Using the SAS OLAP Analyzer

SAS Activity-Based Management uses the SAS OLAP Analyzer to view cubes. With the SAS OLAP Analyzer, you can analyze dimensions and measures in a grid view, a chart view, and a Cube Explorer View. The predefined cube that you choose determines which dimensions and measures are available to you, as well as what types of analyses you can perform. You can view data in one or two windows, depending on your needs. The OLAP toolbar buttons that are available to you depend on which window is selected and on what type of information is displayed in the window.

Note: Models are not displayed in the Model drop-down list of the OLAP Analyzer until you generate the model's cubes.

The SAS OLAP Analyzer is usually part of SAS Enterprise Guide, which you might not have installed on your system. (Even if you don't have SAS Enterprise Guide, you do have the SAS OLAP Analyzer as part of SAS Activity-Based Management.) The help for SAS OLAP Analyzer includes help for SAS Enterprise Guide.

You can open the Help for SAS OLAP Analyzer from the Help menu of SAS Activity-Based Management.

See Also

• “OLAP Analyzer View” on page 457
• “SAS OLAP Restrictions” on page 461
Create an OLAP View

1. Select File $\Rightarrow$ New $\Rightarrow$ OLAP View.
   The New OLAP View Wizard appears.

   ![New OLAP View Wizard](image)

2. From the Select the model you want to use drop-down list, select a model.
3. From the Select the cube you want to base the view on drop-down list, select a cube.
   The list contains only those cubes that have been generated.

Change the Appearance of an OLAP Window

1. Open an OLAP view on the Analysis workspace.
2. First, click a window’s title bar.
   a. To display a grid, select OLAP $\Rightarrow$ Grid.
   b. To display a chart, select OLAP $\Rightarrow$ Chart $\Rightarrow$ <type of chart>.
   c. To display a Decomposition Tree, select OLAP $\Rightarrow$ Decomposition Tree.
   d. To display a perspective view, select OLAP $\Rightarrow$ Perspective.

Open an OLAP View

If you start OLAP mode without an OLAP view open, you can open an OLAP view from the Analysis workspace. The list of Folders and OLAP Views corresponds to the OLAP branch of the server area in Workspace Manager.

1. From the list of Folders, select a folder.
2. From the list of OLAP Views, click a view.

Open an OLAP View with an OLAP View Already Open

If an OLAP view is already open in the Analysis workspace and you want to open a different view, do one of the following:

- Select an OLAP view from the Cube View down-down list.

- Click the Go to Analysis Workspace button and select another OLAP view.
Part 16

Querying Contributions

Chapter 42

Contributions Workspace ................................. 469
Chapter 42
Contributions Workspace

Contributions Workspace ............................................................... 469
  How to Access the Contributions Workspace .................................. 469
  Some Things to Know ................................................................. 470
Query Contributions from Resource to Cost Object .......................... 471
Query Contributions Via the Activity Module .................................. 472
Query Contributions from Resource to Activity Module ...................... 473
Drill Down to a Lower Level ......................................................... 474
Get the PROC ABC Statement ....................................................... 475

Contributions Workspace

The ability to query contributions provides the fastest and easiest method available to view cost flows throughout a model. You can now query contributions without even having to generate a cube. And, the queries are extremely fast because there is no cube to navigate. The Contributions view allows you to do "queries on the fly."

How to Access the Contributions Workspace

1. Open the Contributions view by doing one of the following:
   • Click Contributions in the Navigation Pane.

      Note: The Contributions icon appears only if the Contributions Server has been installed.

      Then, click New Query.

      • Select File ⇒ New ⇒ Contribution Query.

2. Select the model you want to query.

      Note: The model must have been calculated.

3. Select the period/scenario association to use.

Some Things to Know

- Select a module (Resource, Activity, Cost Object, External Unit) to expand it. Expanding a module does not select anything in it. Select checkboxes to select dimensions in the module.

![Select to expand]

- You can choose only one module, but you can select multiple dimensions in a module.

![Select checkboxes]

Note: Only one module is active at a time. Do not be misled by the fact that checkboxes remain selected when a module is collapsed. If a module is collapsed, then it is not active.

- You can select no more than 10 dimensions, but you can select any number of levels within a dimension (for purposes of the Contributions view, we count Drivers as a dimension). The following picture should make clear how dimensions are counted. In this picture 4 dimensions are selected and 6 dimension levels:
You must select at least one source level and at least one destination level.

Sample Queries:

- “Query Contributions from Resource to Cost Object” on page 471
- “Query Contributions Via the Activity Module” on page 472
- “Query Contributions from Resource to Activity Module” on page 473
- “Drill Down to a Lower Level” on page 474
- “Get the PROC ABC Statement” on page 475

Query Contributions from Resource to Cost Object

The following query use the Parcel Express Tutorial model. The query shows, by region, the contributions of wages, operating expenses, and equipment expenses to each of the three products by region and channel.

1. For Source Module, click Resource and select:
   - Region \( \Rightarrow \) Level3
   - General Ledger \( \Rightarrow \) Level1

2. For Destination Module, click Cost Object and select:
   - Region \( \Rightarrow \) Level3
   - Channel \( \Rightarrow \) Level1
   - Products and Services \( \Rightarrow \) Level1
3. Click Get Results. The resulting table shows the contributions of wages, operating expenses, and equipment expenses to each of the three products by region and channel. (The following picture shows the table split in pieces, with one piece on top of the other, to fit better on the screen.)

**Query Contributions Via the Activity Module**

The following query uses the Parcel Express Tutorial model. The query shows the general ledger contributions by activity to each of the three products by channel.

1. For Source Module, click Resource and select:
   - Region \( \Rightarrow \) Level3
   - General Ledger \( \Rightarrow \) Level1

2. For Via Module, click Activity and select:
   - Activities \( \Rightarrow \) Level2

3. For Destination Module, click Cost Object and select:
   - Channel \( \Rightarrow \) Level1
   - Products and Services \( \Rightarrow \) Level1
4. Click **Get Results**. The resulting table shows the general ledger contributions by activity (activities in the via column are shown in yellow) to each of the three products by channel. (Because it is large, only part of the table is shown.)

---

**Query Contributions from Resource to Activity Module**

The destination module need not be a cost object. The following query use the Parcel Express Tutorial model. The query shows the contributions, by region, of general ledger items to activities.

1. For Source Module, click **Resource** and select:
   - **Region** ⇒ **Level3**
   - **General Ledger** ⇒ **Level1**

2. For Destination Module, click **Activity** and select:
   - **Activities** ⇒ **Level2**
3. Click **Get Results**. The resulting table shows the contributions, by region, of general ledger items to activities.

<table>
<thead>
<tr>
<th>Source Module/Stage</th>
<th>Destination Module/Stage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource</td>
<td>Activity</td>
</tr>
<tr>
<td>Region</td>
<td>Level1</td>
</tr>
<tr>
<td>General Ledger</td>
<td>Level1</td>
</tr>
<tr>
<td>Activity</td>
<td>Level3</td>
</tr>
<tr>
<td>Cost Object</td>
<td>Level2</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Activity</th>
<th>Resource</th>
<th>Drivers</th>
<th>Cost Object</th>
<th>External</th>
</tr>
</thead>
<tbody>
<tr>
<td>Region</td>
<td>Level1</td>
<td>Level2</td>
<td>Level3</td>
<td></td>
</tr>
<tr>
<td>General Ledger</td>
<td>Level1</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Activity</td>
<td>Level3</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost Object</td>
<td>Level2</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Drill Down to a Lower Level

The table generated by a query is not static. If you have selected a dimension level to display that has additional levels under it, you can click the generated table to display the next level of detail. Here is an example which uses the Parcel Express Tutorial model.

1. For Source Module, click **Activity** and select:
   - Region \ Level3
   - Activities \ Level

2. For Destination Module, click **Cost Object** and select:
   - Products and Services \ Level1

3. Click **Get Results**. The resulting table shows the contributions, by region, of activities to products and services. Note that the Activities column is highlighted.

```
<table>
<thead>
<tr>
<th>Source Module/Stage</th>
<th>Destination Module/Stage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource</td>
<td>Activity</td>
</tr>
<tr>
<td>Region</td>
<td>Level1</td>
</tr>
<tr>
<td>General Ledger</td>
<td>Level1</td>
</tr>
<tr>
<td>Activity</td>
<td>Level3</td>
</tr>
<tr>
<td>Cost Object</td>
<td>Level2</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Activity</th>
<th>Resource</th>
<th>Drivers</th>
<th>Cost Object</th>
<th>External</th>
</tr>
</thead>
<tbody>
<tr>
<td>Region</td>
<td>Level1</td>
<td>Level2</td>
<td>Level3</td>
<td></td>
</tr>
<tr>
<td>General Ledger</td>
<td>Level1</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Activity</td>
<td>Level3</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost Object</td>
<td>Level2</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
```

Activities column is highlighted.
4. Click **1:Local Processing** in the Activities column to drill down to Level2. What you saw initially in the Activities column was at Level1. By clicking, you drill down to see the Level2 activities. Notice that the entire table is replaced by the Level2 activities. Also notice that the rollup account **1:Local Processing** is displayed.

5. Click **Drill Up** to return to the previous table.

---

**Get the PROC ABC Statement**

SAS Activity-Based Management has externalized, in the form of the ABC procedure, the processing that it uses internally to calculate a model and query a cube. The ABC procedure allows you to create SAS programs to query model data outside of SAS Activity-Based Management.

The easiest method to create a program that uses the ABC procedure is to use the Contributions tab to perform a query. Then click **Gen Proc Stmt** to copy, to the clipboard, the PROC ABC statement that the Contributions tab used for the query. To get the PROC ABC statement:

1. Perform a query.
2. Click **Gen Proc Stmt**.
3. Paste into the SAS editor (or any ASCII editor). You can modify the program in any way that you like before running it.

You see something similar to the following:

Note that you must click **Get Results** before clicking **Gen Proc Stmt**. Changing the query options after performing a query does not change what statement is copied to the clipboard until you click **Get Results** again to perform a different query.
Part 17

Importing and Exporting

Chapter 43
Model Data ................................................................. 479

Chapter 44
Survey Data ................................................................. 497

Chapter 45
Cube Configurations ..................................................... 507

Chapter 46
Column Layouts ........................................................... 509

Chapter 47
Export Module Views to Excel ....................................... 511

Chapter 48
OLAP Views ................................................................. 521

Chapter 49
Reports ........................................................................ 525

Chapter 50
Easy API ........................................................................ 527

Chapter 51
Publish Information Maps .............................................. 533

Chapter 52
Publish Behaviors to SAS Profitability Management .......... 539

Chapter 53
Publish Performance Measures to SAS Strategy Management . 543
Chapter 43
Model Data

Importing Model Data .......................................................... 479
Importing from a Database or XML File ................................. 479
Importing Survey Data ......................................................... 480

Using the Import Wizard to Import from a Database ................. 481
Importing the Model ............................................................. 481
Periodic Import ................................................................. 488

Using the Import Data Wizard to Import an XML File ........... 489

Exporting Model Data .......................................................... 492
Export to Database, XML, or ZIP File ................................ 492
Export Survey Data .............................................................. 492

Archive a Model to an XML File with the Export Wizard ...... 493

Importing Model Data

Importing from a Database or XML File

To build a model or to add data to a model in SAS Activity-Based Management, you can either add data interactively in Model mode or you can import data into a model.

Tip Because manually building a model is time-consuming and error-prone and leaves little time for analysis, importing data is the recommended method.

You can import data from the following sources:

Database
See “Using the Import Wizard to Import from a Database ” on page 481. Also, see the SAS Activity-Based Management Data Administration Guide available from the Help menu on a possibly more recent version from http://support.sas.com/documentation/onlinedoc/abm/.

XML file
The XML file must be an XML file that was exported from SAS Activity-Based Management. You should not import a manually created XML file, because it is challenging to dynamically create an XML file with the correct format for directly importing model data.

To import a model from an XML file, select File ⇒ Import ⇒ Model Data, and then select XML or ZIP file.
Oros model
Please contact SAS technical support if you want to import an Oros model into SAS Activity-Based Management.

See Also
“Using the Import Data Wizard to Import an XML File” on page 489

Importing Survey Data

To import survey data, do the following:

1. Select File ➔ Import.
2. Select Surveys.
3. Select whether to import into a new model or an existing model.

Note: When importing into an existing model, make sure that the survey data is for the correct model. If the data is from a different model, the import can corrupt the existing model.
Using the Import Wizard to Import from a Database

Importing the Model

Before Importing
Before attempting to import data from a database, see Chapter 15, “Connecting to a Database,” in SAS Activity-Based Management: Data Administration Guide, which provides information about connecting to the most common databases.

Note: You can import a model without first opening a model.

1. Create a database or a database view that matches the data schema.
   For information about the data schema, see .

2. In SAS Activity-Based Management, verify or create any required period/scenario associations.

3. Select File ⇒ Import ⇒ Model Data.
   The Import Data Wizard opens.

Step 1 – Select Database

1. Select the Database option.

Step 2 – Connect to the Database

1. Click the Browse... button on the Wizard page.
The Connection Information window opens.

For information on using this window, see Chapter 15, “Connecting to a Database,” in SAS Activity-Based Management: Data Administration Guide.

2. Click Next.

**Step 3 – Select Model**

1. If you want to import the database into a new model, do the following:
Using the Import Wizard to Import from a Database

Step 4 – Map Input Tables to Target Tables

In this step, you specify which tables to import. And, for each table that you import, you specify to what SAS Activity-Based Management table it maps.

1. To select a table to import, select the check box to the left of the table name in the Source Table column.

   **Note:** If you selected Periodic data only in the previous step, then only tables that contain periodic information are displayed for selection.

a. Select the **New model** option.

b. Type the **Model name**.

2. If you want to import the database into an existing model, do the following:

   a. Select the **Existing model** option.

   b. From the drop-down list, select a model.

   c. To append the imported data to the existing model data, select the Update all data in the model, then import new data option.

   d. Select Periodic data only to import only the staging tables that contain periodic data. See “Periodic Import” on page 488.

   e. To remove all existing data, select the Remove all data in the model, then import new data option.

3. Click **Next**.
2. To map a **Source Table**, click in the **Target Table** column to the right of the source table, and select a SAS Activity-Based Management table from the drop-down list.

Note: If you have named the source tables with the same names that are used in SAS Activity-Based Management, the wizard automatically creates the mappings and selects the tables to be imported. If you have not used the same names, then you must specify which source table maps to which SAS Activity-Based Management table.

Note: You can map multiple input tables to the same. The following picture shows the input tables Account1 and Account2 both mapped to Account.

3. Repeat steps 1 and 2 to map every table that you want to import.
4. Click Next.

**Step 5 – Specify Type of Account Keys**

In this step, you specify how accounts are identified in source tables that contain accounts. You can identify each account by a dimension signature or by reference number. You can choose to have the wizard create accounts for all valid dimension signatures, even if accounts have not been created for those intersections.

1. To identify accounts by the dimension signature, select the check box in the **Dimension Signature Required** column to the right of each source Table.

If you clear the check box, accounts will be identified by their references.

2. To have the wizard automatically create accounts for all valid dimension signatures, select the **Automatically create accounts using dimension signatures** option.

3. Click Next.

**Step 6 – Map Input Columns to Target Columns**

In this step, you specify which table columns to import. And, for each table column that you import, you specify to which table column in SAS Activity-Based Management it maps.

1. To select a table column to import, select the check box to the left of the table name in the **Source** column.

You can select as many table columns as needed, but you must import those columns that are required. Required columns are denoted by an asterisk (*).
Note: If you have named the source table columns with the same column names that are used in SAS Activity-Based Management, the wizard automatically creates the mappings and selects the columns to be imported. If you have not used the same names, then you must specify which source table column maps to which SAS Activity-Based Management table column.

2. If you chose in the previous step to identify accounts by their dimension signatures, specify the number of Dimensions that are contained in the source table.

The Dimensions option appears only when you choose to identify accounts by their dimension signatures. You must specify the number of dimensions so that the interface displays the correct column names that you must map. For each dimension in the source table, there must be two columns that can be mapped to the SAS Activity-Based Management table columns; these two columns are named DimRef<number> and DimMemberRef<number>. For example, a source table that contains two dimensions must contain columns that must be mapped to DimRef1, DimMemberRef1, DimRef2, and DimMemberRef2.

3. To map a Source table column, click in the Target Column Name column to the right of the Source table column, and select a SAS Activity-Based Management table column from the drop-down list.

The drop-down list contains the values DimRef<number> and DimMemberRef<number> only if you chose to identify accounts by their dimension signatures, which is the only situation in which these values are needed.

4. If a source table does not contain a column that you want to create in the model, and you want to assign a value to this column, do the following:
   a. Click Add.
      A new row appears.
   b. Click in the Source column, and select a column name from the drop-down list.
   c. Type a Default value.

For example, if the source table does not contain a column to map to the Period column in SAS Activity-Based Management, and you want to create a period...
named MyPeriod in the model, then add a column named <None>. Map this new column to the **Target Column Name** Period, and specify the **Default** value as MyPeriod.

5. Repeat steps 1 through 4 for every table column that you want to import.

6. Click the appropriate tab at the bottom of the grid to map the columns for another table.

7. Click **Next**.

**Step 7 – Review Your Choices**

1. Review the import summary.

2. If you need to change any information, click **Back** until you reach the step that you need to change in the wizard.

   All of the information that you have specified is saved. Click **Next** to advance through the wizard.

3. To save the import configuration so that the import can be easily run again, do the following:
   a. Select the **Save configuration as** option.
   b. Type the **Name**.
   c. Type the **Description**.

4. Select **Save without running** to save the import configuration with performing the import.

5. Click **Finish**.
Periodic Import

When you generate a cube, for every period (period and scenario association) that is to be included in an existing cube, if:

- the cube already contains that period, and
- the period has not been modified since the cube was last generated

then the period is not regenerated.

This means that cube generation is faster because periods that have already been generated are not regenerated.

In order to support incremental cube generation, SAS Activity-Based Management provides a **Periodic data only** option in the Import Wizard that allows you to import only the periods that have changed in a model—for example, the new periods.

If you select **Periodic data only**, then only those staging tables that contain periodic data are displayed in the Import Wizard for you to select for importing.
Staging tables are distinguished by whether they contain periodic or structural data. Periodic data is model data which is stored separately for each period/scenario association. Structural data is model data which is independent of any period/scenario association. It is data that is common to all period/scenario associations.

The following staging tables contain **periodic data**:

- Account
- Assignment
- CurrencyRate
- ExternalUnit
- EnteredCostElement
- PerformanceMeasure
- ValueAttributeAssociation
- ValueAttributePeridicDef
- DimensionalAttributeAssociation

The following staging tables contain **structural data**:

- Dimension
- DimensionMember
- DimensionLevel
- DimensionOrder
- Driver
- Model
- ValueAttributes
- Period
- PeriodLevel
- Scenario
- ScenarioLevel

When you generate a cube for a model that has been generated before, SAS Activity-Based Management determines whether the entire cube must be regenerated or whether only the new or modified periods need to be generated. You do not have to specify, when you generate a cube, whether you want incremental generation or not. SAS Activity-Based Management makes the determination for you.

**Note:** Cubes in SAS OLAP that are generated using either the NO_NWAY option or the NONUPDATEABLE option are not eligible for incremental generation.

---

**Using the Import Data Wizard to Import an XML File**

**Note:** You can perform this task without first opening a model.

When you import model data from an XML file, a new model is created. You can choose to give the model a new name or you can reuse the name of an existing model.
You cannot import model data from an XML file to incrementally update an existing model or to combine several models into a single model. Whatever data is contained by an existing model is removed and replaced by the model data in the imported XML file.

1. Select **File ➤ Import ➤ Model Data**.

   The Import Data Wizard appears.

2. Select the **XML File** option.

3. Click Next.

4. Type the absolute pathname to the XML file. Or, click **Browse...**.

5. Click Next.
6. If you want to import the XML file into a new model, do the following:
   a. Select the **New model** option.
   b. Type the **Model name**.
   c. Type the **Model Reference**. The Model Reference is used in public views.

7. If you want to import the XML file into an existing model, do the following:
   a. Select the **Existing model** option.
   b. From the drop-down list, select a model.

8. Click **Next**.

9. Review the import summary.

10. If you need to change any information, click **Back** until you reach the step that you need to change in the wizard.
    
    All of the information that you have specified is saved. Click **Next** to advance through the wizard.

11. To save the import configuration so that the import can be easily run again, do the following:
    a. Select the **Save configuration as** option.
b. Type the **Name**.

c. Type the **Description**.

12. Select **Save without running** to save the import configuration without performing the import.

13. Click **Finish**.

---

## Exporting Model Data

### Export to Database, XML, or ZIP File

You can export model data to a database or to an XML or ZIP file. If you want to export only a portion of the model data, you must export to a database. If you export to an XML or ZIP file, all model data is exported. If you want to export all of the model data, you can export to a database or to an XML or XZIP file.

The following table lists some of the reasons why you might export model data. For each reason, the table shows whether you would export to a database or to an XML or ZIP file:

<table>
<thead>
<tr>
<th>Reason for exporting</th>
<th>Export destination</th>
</tr>
</thead>
<tbody>
<tr>
<td>To export model data and to manipulate the data, and then to import the data back into the model or into another model</td>
<td>Database</td>
</tr>
<tr>
<td>To archive a model</td>
<td>Database</td>
</tr>
<tr>
<td></td>
<td>XML file (requires less disk space)</td>
</tr>
<tr>
<td>To export some of the items in the model, but to exclude other items</td>
<td>Database</td>
</tr>
</tbody>
</table>

To export model data to an XML file, select **File → Export → Model Data**, and select **XML or ZIP file**.

For exporting to a database, see the SAS Activity-Based Management Data Administration Guide available from the Help menu or from [http://support.sas.com/documentation/onlinedoc/abm/](http://support.sas.com/documentation/onlinedoc/abm/).

**Note:** If a network user from a different domain (than that of the SAS Activity-Based Management client machine) logs in to the client machine to export to XML, then that user must be granted WRITE access to the [ClientInstallpath]\bin folder for the operation to succeed.

### See Also

“Archive a Model to an XML File with the Export Wizard” on page 493

### Export Survey Data

To do a survey, you do not have to export everything out of your model. For complete information about surveys, see the SAS Activity-Based Management Data
Archive a Model to an XML File with the Export Wizard

Note: You can perform this task without first opening a model.

1. Verify that the model is ready.

2. Select File ➔ Export Model Data.
   The Export Wizard appears.

3. Select the Select default tables and properties to archive a model option.

4. Select the XML File option.

5. Click Next.
6. Type the absolute pathname to the XML file. Or, click Browse.

7. From the Select a model to export drop-down list, select a model.

8. From the Select period/scenario associations you want to export from list, select the check box next to one or more period/scenario associations.

9. Click Next.

10. Review the export summary.
11. If you need to change any information, click **Back** until you reach the step that you need to change in the wizard.

   All of the information that you have specified is saved. Click **Next** to advance through the wizard.

12. To save the export configuration so that the export can be easily run again, do the following:
   
   a. Select the **Save configuration as** option.

   b. Type the **Name**.

   c. Type the **Description**.

13. Select **Save without running** to save the export configuration without performing the export.

14. Click **Finish**.
Chapter 44
Survey Data

Exporting Survey Data

To create a survey, you do not have to export everything out of your model. Here are the steps to ensure you export only the required fields.

Note: Unless specified otherwise, accept all the default Export Wizard selections.

To export survey data, do the following. Also, see “Exporting Model Data to a Database” in Chapter 14 of SAS Activity-Based Management: Data Administration Guide. And, see “Using the Export Wizard” in Chapter 14 of SAS Activity-Based Management: Data Administration Guide.

1. Select File ➔ Export ➔ Survey Model Data.

2. On the Select Model window:
   a. Select the model to be exported.
   b. Select one of the following:
      - New Survey Model, and then enter a new survey model name.
      
      You will use this name to access the model while working with the survey.

      Note: You can export survey data multiple times for the same model—for example, once for each period in the model. In this case, you would use a different survey model name for each export.
• **Update Existing Survey Model**, and then select an existing survey model name.

Selecting this option overwrites the staging tables for the survey model in the database.

c. Select the Period/Scenario associations to be exported.

d. Click **Next**.

3. Select the tables to export.

*Note:* You cannot unselect the required tables.

If you plan to survey Numeric Attributes, then you also must check the following two tables:

**ValueAttribute table**

See “ValueAttribute table” in Chapter 16 of SAS Activity-Based Management: Data Administration Guide.

**ValueAttributeAssociation table**

See “ValueAttributeAssociation table” in Chapter 16 of SAS Activity-Based Management: Data Administration Guide.
4. Select common dimension columns (that is, select the columns that will always be exported for each table).

*Note:* You cannot unselect required columns.

Columns that you select are selected by default on the next Export Wizard page. You can, however, change your selection on the next page. That is, you can deselect a field that you had selected, or select a field that you had deselected.

5. Select dimension columns to export for each table.

*Note:* You can overwrite the name of the target column.
6. Filter by dimensions (that is, select those dimension members that will be exported for each table).

7. Choose the columns to export for each table.

Click **Add** to add filters to further select the columns to export. Selected columns are exported only if they pass the filter. In other words, for a column to be exported, it must both

- be selected
- pass whatever filters exist for the table
In addition to all default selections, make sure the following columns are checked:

**Account table**
- DriverName
- Name
- OutputQuantityUE
- Revenue
- SoldQuantity
- PeriodicNote (optional - only if you have Account Notes)

**Assignment table**
- Source Accounts.DriverName
- DriverQuantityFixed

**EnteredCostElement table**
- EnteredCost

**ExternalUnit table**
- UnitCostEntered
- Name
- PeriodicNote (optional - only if you have ExternalUnit Notes)

8. Verify the summary and click **Finish**.
Select **Save configuration as** to save your selections. The selections are saved in the **Survey Data Exports** folder.

Double-click a saved configuration to begin exporting using the saved options. You can modify the options while using the Export Wizard.

---

**Importing Survey Data**

To import survey data, do the following.

1. Select **File → Import → Model Data**.
2. Select **Surveys**, and then click **Next**.
3. On the Import Data – Model window, select an existing model to update with survey data. You cannot create a new model from survey data.
   a. Select an existing model to update with survey data.
      
      *Note:* You cannot create a new model from survey data.
   
   b. Select the survey data to import.
      
      *Note:* Make sure that the survey data is for the correct model. If the data is from a different model than the one from which data was exported, the import can corrupt the existing model. See Step 1 on page 497.
   
   c. Select whether you want to do periodic import.
      
      Periodic import allows you to import only the periods that have changed in a model. For information, see the section on “Incremental Cube Generation” in the SAS Activity-Based Management User’s Guide.
   
   d. Click **Next**.

4. On the Import Data – Select Tables window, select tables from the survey data being imported and map them to tables in the model being updated.

   The tables being imported correlate to the tables that were previously exported. See Step 3 on page 498.
5. On the Import Data – Options window, for each table being imported, select whether you want to identify accounts by their dimension signature.

*Note:* The import will work regardless of what you choose, so you can simply click Next.

6. On the Import Data – Map Columns window, select the columns to be imported.

The columns being imported correlate to the columns that were previously exported. See Step 4 on page 499. And see Step 5 on page 499.

7. Review your selections and click Finish.
### Importing Survey Data

#### Import Data - Summary

**Import File Type:**
- Summary

**Source:**
- connection string

**Tables:**
- WM1002.Account -> Account
- WM1002.Assignment -> Assignment
- WM1002.ExternalConf -> ExternalConf
- WM1002.ExternalUnit -> ExternalUnit
- WM1002.ValueAttribute -> ValueAttribute
- WM1002.ValueDefinition -> ValueDefinition

**Model:**
- Type: report in an existing model
- Name: SampleDataset Table
- Reference: [dataset]

[Save configuration as:][Selected/Running:]

[Back][Next][Finish][Cancel][Help]
Chapter 45
Cube Configurations

Import Cube Configurations

1. Go to the Workspace Manager.
2. Select File → Import → Cube Configurations. The Import Cube Configuration dialog box opens.
3. Select the file to import and import options:
   - Rename cube configuration being imported
     If a cube configuration exists with the same name as a cube configuration being imported, the one that you are importing is renamed. This applies to every cube configuration being imported if multiple cube configurations are imported.
   - Replace the existing cube configuration
     If a cube configuration exists with the same name as a cube configuration being imported, then the existing cube configuration is replaced with the imported one.
   - Do not import duplicate cube configurations
     If a cube configuration exists with the same name as a cube configuration that you are importing, then the duplicate cube configuration is not imported. Leave the existing one in place.
4. Click Finish.

Export Cube Configurations

1. Go to the Workspace Manager.
3. Select the cube configurations to export and export options:
Automatically check children
Select this check box to recursively select cube configurations that are inside the selected folder.

*Note:* This option applies only to subsequent folder selections. It does not select subfolders of folders that are already selected.

Include folders
Select this check box to store folder information in the exported file. As a result, folders can be recreated when you import the cube configurations.

*Note:* This option does not create folders in the export directory. It stores the folder information in the export file so that the folders can be recreated later during import.

Export to this path and XML file name
Select the path and name of the export file.

*Note:* Only one export file is created, even if you select multiple folders and cube configurations to export.

4. Click Finish.
Chapter 46

Column Layouts

---

**Import a Column Layout**

*Note:* You can perform this task without first opening a model.

1. Select **File ➔ Import ➔ Column Layouts.**
   
   The Import Column Layouts Wizard appears.

2. Follow the directions in the wizard.

---

**Export a Column Layout**

You can perform this task without first opening a model.

1. Select **File ➔ Export ➔ Column Layouts.**
   
   The Export Column Layouts Wizard appears.

2. Follow the directions in the wizard.
Chapter 47
Export Module Views to Excel

Export Module Views to Excel .......................................................... 511
Summary ......................................................................................... 511
Export the Entire Module ................................................................. 511
Only Rows that are Expanded are Exported .................................... 512
Select Particular Rows to Export .................................................... 513
Other Features ................................................................................ 515
Restrictions ..................................................................................... 518

Export Module Views to Excel

Summary

If you want a printable form of the hierarchical structure of a module, and one that you can easily modify without affecting the underlying model, you can export the module to Excel. You can either select particular rows of a module view to export, or you can export the entire module.

Note: Exported spreadsheets cannot be re-imported into SAS Activity-Based Management.

Export the Entire Module

To export the expanded rows of an entire module:

1. Select the primary pane of the module view.

2. Without selecting any rows, right-click the module name (Resource, Activities, Cost Object, External Units).

   Note: If more than one row is selected, then only the selected rows are exported.

3. Select Export to Excel.
The Export to Excel dialog box appears.

4. Specify the name of the Excel file and the name of the sheet to be created and whether you want to overwrite existing data.
   - If the Excel file does not exist, it is created with a sheet named as you specify.
     
     **Note:** You must specify a complete path and file name.
     
     **Note:** Do not name the sheet Sheet1 unless you are replacing Sheet1 of an already existing Excel file.
   - If the Excel file already exists but does not contain a sheet with the name that you specify, then a new sheet is added to the existing file.

5. Click **OK**.

**Only Rows that are Expanded are Exported**

Only rows that are expanded when you perform the export are exported. So, what you see in the module view is what you get in the spreadsheet.

It is not necessary, however, that either all the rows or all the columns are visible when you perform the export.

- Some rows that are expanded may not be visible if there are more rows than fit on the screen, such that vertical scrolling is necessary to see them.
- Some columns in the column layout may not be visible if there are more columns than fit on the screen, such that horizontal scrolling is necessary to see them.
Exporting works as though you had an infinitely large screen that is able to display, without scrolling, all the rows in the hierarchy that are expanded and all the columns in the column layout.

Note: Columns that you have added to the current column layout are exported even if you haven’t yet saved the column layout with the additional columns.

Note: If there are no accounts in the module, then the export is not performed.

Select Particular Rows to Export

If you select a subset of the rows in the primary pane of a module view and select Export to Excel, then only the selected rows are exported.

If the rows selected are contiguous and the first row selected is at the highest level of the selected rows, then the rows in the spreadsheet will exhibit the same hierarchy. For example, in the following picture, where all the rows for Drop Box and for WalkIn have been selected, their hierarchy will be reflected in the Excel spreadsheet.

The following picture shows the resulting spreadsheet.

However, if you select non-contiguous rows that are at different levels, then it may not be possible to preserve the hierarchy in the spreadsheet. For example, in the following picture Eugene will be at the same level in the Excel spreadsheet as Drop Box and
WalkIn. Because the rows selected are non-contiguous and at different levels, it is not practical for the export facility to reconstruct the larger hierarchy, of which the non-contiguous rows are a part.

The following picture shows the resulting spreadsheet. Notice that an empty row separates the discontinuous hierarchies.
Other Features

Panes are Frozen for Better Scrolling
When you export a module view, the Excel panes are frozen so that the column header does not scroll vertically. The column header is always visible. And, the account names are frozen so that they do not scroll horizontally. They are always visible when you scroll horizontally to see all the account properties. You can unfreeze the panes in Excel if you want scrolling to perform differently.

Additional Columns
When you export a module view to Microsoft Excel, SAS Activity-Based Management includes two additional columns in the spreadsheet: (Type) and (Item View Order).

(Type)
Tells what sort of data the spreadsheet row is for:

Note: The (Type) column contains the same data as the Type column in a column layout. If the module view being exported already contains a Type column, then SAS Activity-Based Management does not add an additional (Type) column to the exported spreadsheet.
(Item View Order)
Use this column to restore a sorted spreadsheet to its original display order (see “Unsorting” on page 516).

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Cost ($)</th>
<th>Type</th>
<th>Item View Order</th>
</tr>
</thead>
<tbody>
<tr>
<td>RESOURCE (PRIMARY PANE)</td>
<td>10,000.00</td>
<td>Rollup Account</td>
<td>1</td>
</tr>
<tr>
<td>Administration</td>
<td>12,000.00</td>
<td>Rollup Account</td>
<td>2</td>
</tr>
<tr>
<td>Sales Marketing</td>
<td>106,500.00</td>
<td>Rollup Account</td>
<td>3</td>
</tr>
<tr>
<td>Ads Shows</td>
<td>15,000.00</td>
<td>Account</td>
<td>4</td>
</tr>
<tr>
<td>Expenses Facilities</td>
<td>9,000.00</td>
<td>Account</td>
<td>5</td>
</tr>
<tr>
<td>Salary Trade Shows</td>
<td>31,200.00</td>
<td>Account</td>
<td>6</td>
</tr>
<tr>
<td>Salary Direct Sales</td>
<td>46,500.00</td>
<td>Account</td>
<td>7</td>
</tr>
<tr>
<td>Salary Sales Manager</td>
<td>4,000.00</td>
<td>Account</td>
<td>8</td>
</tr>
</tbody>
</table>

Sorting
In order to sort columns in the exported Excel spreadsheet, you must first ungroup the Display Name column.

To ungroup the Display Name column:
1. Select columns A through F (the Display Name column).
2. On the Home tab, select Merge & Center ⇒ Unmerge Cells.
3. Select the column that you want to sort and perform the sort.

Unsorting
To restore a sorted spreadsheet to its original display order, you can use the (Item View Order) column that SAS Activity-Based Management adds to the Excel Spreadsheet for this purpose. The column contains the number of each row in the spreadsheet’s original display order.
Decimal Places
The number of decimal places that are displayed in an exported Excel file are the number of decimal places that you specified in SAS Activity-Based Management by selecting **Tools → User Options**.

Row names
Every row in an exported Excel spreadsheet is named using the account ID. The format of the name is `<sheetname>_ID_<account ID>`. The name appears in the drop-down list located before the Excel formula bar, as shown in the following picture. If you select a name in the drop-down list, then the corresponding row is highlighted.
Checkboxes

Checkboxes in the module view are also displayed as checkboxes in the exported spreadsheet. However, the checkboxes in the exported spreadsheet only reflect what is in the module view. They cannot be edited.

Restrictions

Currency formatting

Because Microsoft Excel does not support all the currency formats that SAS Activity-Based Management supports, currency fields are formatted as numeric columns in an exported spreadsheet. The currency symbol is displayed in the column header of the exported spreadsheet instead of in each spreadsheet cell. After exporting a module view, you can use Microsoft Excel to format currency cells as you like.

The following picture shows a module view in which costs are displayed both in dollars (the base currency) and in Euros (converted from dollars).
The following picture shows the resulting exported spreadsheet. Notice that the currency symbol is displayed in the spreadsheet column header, and the formula used for conversion is displayed in the formula area.

Negative numbers
Regardless of how negative numbers are formatted in a module view, they are preceded by a minus sign (-) and displayed in black when exported to Microsoft Excel. This is because the negative number formatting in the SAS Activity-Based Management module view might not be available in Microsoft Excel depending upon Excel's national language settings. Once the Excel file has been created, you can format negative numbers in it any way that you like.
Chapter 47 • Export Module Views to Excel

Export uses this format for negative numbers.

Currency formats are used for general monetary values. Use Accounting formats to align decimal points in a column.
Chapter 48
OLAP Views

Import OLAP Views
To import OLAP views:

1. Go to the Workspace Manager.
2. Select File ⇒ Import OLAP Views. Step 1 of the Import OLAP Views dialog box opens.
3. Select the XML file (containing the views) to be imported.
4. Specify the model to associate with the views being imported.

   Note: Although a model was specified when the OLAP views were exported, you can associate the views with a different model on import.

Rename OLAP view being imported
   If an OLAP view already exists with the same name as an OLAP view being imported, the one being imported is renamed. This applies to every OLAP view being imported if multiple views are imported.

Replace the existing OLAP view
   If an OLAP view already exists with the same name as an OLAP view being imported, then the existing one is replaced with the imported one.

Do not import duplicate OLAP views
   If an OLAP view already exists with the same name as an OLAP view being imported, then don't import the duplicate view. Leave the existing one in place.

5. Click Next. Step 2 of the Import OLAP Views dialog box opens.
6. For each OLAP view being imported, select a cube from the Cube drop-down list to associate with that view.

   The Cube drop-down list shows all the cubes that have been previously generated (on the import-to machine) for the model selected in Step 1.

   If you are importing multiple views, you can choose to bypass importing individual ones.
7. Click \textbf{Finish}. The select views are imported.

\textit{See Also}

“Export OLAP Views” on page 522

\textbf{Export OLAP Views}

To export OLAP views to an XML file:

1. Go to the Workspace Manager.
2. Select \textit{File} \textasciitilde \textit{Export OLAP Views}. The Export OLAP Views dialog box opens.
3. Select one or more OLAP views to be exported. You can export any view to which you have access.

\textbf{Automatically check children}

Selecting this causes cube configurations inside a folder to be recursively selected when you select the folder.

\textit{Note:} This only applies to \textit{subsequent} folder selections. It does not select the children of folders that are \textit{already} selected.

\textbf{Include folders}

Selecting this causes folder information to be stored in the export file so that the folders can be recreated when you subsequently import the cube configurations.

\textit{Note:} This option does not create folders in the export directory. It only stores the folder information in the export file so that the folders can be recreated later during import.

\textbf{Export to this path and XML file name}

Select the path and name of the export file.

\textit{Note:} Only one export file is created even if you select multiple folders and cube configurations to be exported.

4. Click \textbf{Finish}.

\textit{See Also}

- “Import OLAP Views” on page 521
- “Export to Excel” on page 522

\textbf{Export to Excel}

To export an OLAP View to Excel, do the following:

1. Go to the \textit{Analysis} workspace.
2. Open an OLAP view.
3. Select \textit{Analysis} \textasciitilde \textit{Export to Excel}. 
4. Choose either of the following:

**Dimensions Flattened**

The Excel table has more columns and fewer rows. The table has a single row of column headers, with one level per column.

**Dimensions not Flattened**

The Excel table has fewer columns and more rows. Each dimension has its own row.

The following picture shows an example of an Excel with flattened dimensions and without flattened dimensions.

**Dimensions Flattened** (more columns)

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Level1</td>
<td>Level1</td>
<td>Level2</td>
<td>01 JAN 2000:00:00:00 - Cost</td>
</tr>
<tr>
<td>2</td>
<td>All</td>
<td>All</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>All</td>
<td>None</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>All USA</td>
<td>USA</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>All</td>
<td>USA</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>All</td>
<td>USA</td>
<td>California</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>All</td>
<td>USA</td>
<td>Oregon</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>All</td>
<td>USA</td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>None</td>
<td>All</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>None</td>
<td>None</td>
<td></td>
<td>47,114.10</td>
</tr>
<tr>
<td>11</td>
<td>None</td>
<td>USA</td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>None</td>
<td>USA</td>
<td>California</td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>None</td>
<td>USA</td>
<td>Oregon</td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>None</td>
<td>USA</td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>Equipment Expenses All</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td>Equipment Expenses None</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>17</td>
<td>Equipment Expenses USA</td>
<td>USA (direct)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>18</td>
<td>Equipment Expenses USA</td>
<td>California</td>
<td>311,000.00</td>
<td></td>
</tr>
<tr>
<td>19</td>
<td>Equipment Expenses USA</td>
<td>Oregon</td>
<td>224,000.00</td>
<td></td>
</tr>
<tr>
<td>20</td>
<td>Equipment Expenses USA</td>
<td></td>
<td>955,000.00</td>
<td></td>
</tr>
<tr>
<td>21</td>
<td>Operating Expenses All</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>22</td>
<td>Operating Expenses None</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>23</td>
<td>Operating Expenses USA</td>
<td>USA (direct)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>24</td>
<td>Operating Expenses USA</td>
<td>California</td>
<td>1,790,000.00</td>
<td></td>
</tr>
<tr>
<td>25</td>
<td>Operating Expenses USA</td>
<td>Oregon</td>
<td>956,000.00</td>
<td></td>
</tr>
<tr>
<td>26</td>
<td>Operating Expenses USA</td>
<td></td>
<td>2,754,800.00</td>
<td></td>
</tr>
<tr>
<td>27</td>
<td>Wages</td>
<td>All</td>
<td></td>
<td></td>
</tr>
<tr>
<td>28</td>
<td>Wages</td>
<td>None</td>
<td></td>
<td></td>
</tr>
<tr>
<td>29</td>
<td>Wages</td>
<td>USA</td>
<td>USA (direct)</td>
<td></td>
</tr>
<tr>
<td>30</td>
<td>Wages</td>
<td>USA</td>
<td>California</td>
<td>3,561,360.59</td>
</tr>
<tr>
<td>31</td>
<td>Wages</td>
<td>USA</td>
<td>Oregon</td>
<td>1,302,195.19</td>
</tr>
<tr>
<td>32</td>
<td>Wages</td>
<td>USA</td>
<td></td>
<td>4,063,359.77</td>
</tr>
</tbody>
</table>

**Dimensions not Flattened** (fewer columns)

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>All</td>
<td>All</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>All</td>
<td>None</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>All USA</td>
<td>USA</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>All</td>
<td>USA</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>All</td>
<td>USA</td>
<td>California</td>
</tr>
<tr>
<td>6</td>
<td>All</td>
<td>USA</td>
<td>Oregon</td>
</tr>
<tr>
<td>7</td>
<td>All</td>
<td>USA</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>None</td>
<td>All</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>None</td>
<td>None</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>None</td>
<td>USA</td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>None</td>
<td>USA</td>
<td>California</td>
</tr>
<tr>
<td>12</td>
<td>None</td>
<td>USA</td>
<td>Oregon</td>
</tr>
<tr>
<td>13</td>
<td>None</td>
<td>USA</td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>Equipment Expenses All</td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>Equipment Expenses None</td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td>Equipment Expenses USA</td>
<td>USA (direct)</td>
<td></td>
</tr>
<tr>
<td>17</td>
<td>Equipment Expenses USA</td>
<td>California</td>
<td>311,000.00</td>
</tr>
<tr>
<td>18</td>
<td>Equipment Expenses USA</td>
<td>Oregon</td>
<td>224,000.00</td>
</tr>
<tr>
<td>19</td>
<td>Equipment Expenses USA</td>
<td></td>
<td>955,000.00</td>
</tr>
<tr>
<td>20</td>
<td>Operating Expenses All</td>
<td></td>
<td></td>
</tr>
<tr>
<td>21</td>
<td>Operating Expenses None</td>
<td></td>
<td></td>
</tr>
<tr>
<td>22</td>
<td>Operating Expenses USA</td>
<td>USA (direct)</td>
<td></td>
</tr>
<tr>
<td>23</td>
<td>Operating Expenses USA</td>
<td>California</td>
<td>1,790,000.00</td>
</tr>
<tr>
<td>24</td>
<td>Operating Expenses USA</td>
<td>Oregon</td>
<td>956,000.00</td>
</tr>
<tr>
<td>25</td>
<td>Operating Expenses USA</td>
<td></td>
<td>2,754,800.00</td>
</tr>
<tr>
<td>26</td>
<td>Operating Expenses USA</td>
<td></td>
<td></td>
</tr>
<tr>
<td>27</td>
<td>Wages</td>
<td>All</td>
<td></td>
</tr>
<tr>
<td>28</td>
<td>Wages</td>
<td>None</td>
<td></td>
</tr>
<tr>
<td>29</td>
<td>Wages</td>
<td>USA</td>
<td>USA (direct)</td>
</tr>
<tr>
<td>30</td>
<td>Wages</td>
<td>USA</td>
<td>California</td>
</tr>
<tr>
<td>31</td>
<td>Wages</td>
<td>USA</td>
<td>Oregon</td>
</tr>
<tr>
<td>32</td>
<td>Wages</td>
<td>USA</td>
<td></td>
</tr>
</tbody>
</table>
Export a Report

You can export a report if you want to customize the report or if you want to use some other reporting tool. If you want to use SAS Enterprise Guide as your front end, you can use the SAS Activity-Based Management Report Data Selection add-in, instead of exporting the report to a temporary location.

   The Report Data Wizard appears.

2. Select the report type. Depending on the type you select, the choices in the subsequent wizard dialogs will change. For example, Dimensional View, Profit and Loss, and Profit Cliff wizard dialogs differ, so, when filtering your data, you must specify your view perspective (how you want to view the data).

3. Select the models (one or more) that you want to report from.

4. Select a period/scenario association (one or more).

5. Select a module. If you selected more than one model, you cannot use the Use Selection option in the wizard. The subsequent dialogs in the wizard enable you to filter your data for your report.

6. If exporting to a database, connect to the database.

*Note:* You can export data from inside SAS Enterprise Guide.
Chapter 50
Easy API

Using Easy API

Overview

Using Easy API, you can do in batch many of the same operations that you can do inside SAS Activity-Based Management. With Easy API, you can

• Import and export model data
• Calculate a model
• Generate a cube
• Export report data
• Copy model data from one period/scenario to another
• Import and export cube configurations

In addition, you can use Easy API to run SAS stored processes, an external SAS Enterprise Guide project, or any other executable that you want to invoke. So, for example, you can use Easy API to export model data, invoke a SAS stored process to update the exported data, and finally import the updated data back into your model.

Operations are run in the order specified in your EasyAPI.txt file. Whatever operations you perform, Easy API synchronizes them so that the next operation to run does not begin until the previous one has finished. For example, a SAS program to update exported tables does not run until the tables have been exported.

Invoking Easy API to perform a SAS Activity-Based Management operation involves three steps:

1. “Create an XML File” on page 528
   The XML file describes the operation to be performed.
2. “Save Easy API Commands in a Text File” on page 529
Easy API commands invoke SAS Activity-Based Management and pass an XML file to tell it what to do.

3. “Invoke Easy API” on page 530

Easy API uses the text file to run its commands.

See also

For more information on Easy API, see the section "Using the API" in the SAS Activity-Based Management Data Administration Guide available from the Help menu or at http://support.sas.com/documentation/onlinedoc/abm/.

Create an XML File

SAS Activity-Based Management uses XML internally to encode the information that it needs for performing operations. Easy API uses the same XML to invoke SAS Activity-Based Management in batch to perform those operations. Following is sample XML to generate a cube. Notice that the XML specifies the model, periods, and cube configuration to be used in generating the cube.

```xml
<CROSCOMMAND Version="2.0">
  <MODELCONTEXT ModelId="1242">
    <PeriodScenario PeriodId="13" ScenarioId="1"/>
    <PeriodScenario PeriodId="14" ScenarioId="1"/>
  </MODELCONTEXT>
  <COMMANDPARAMS MessageLimit="50" CubeAction="Generate">
    <CubeConfig Id="8J"/>
  </COMMANDPARAMS>
</CROSCOMMAND>
```

Because Easy API uses exactly the same XML to invoke SAS Activity-Based Management that SAS Activity-Based Management itself uses internally, the easiest way for you to create the XML that you need to run Easy API is to ask SAS Activity-Based Management to create it.

To ask SAS Activity-Based Management to create XML:

1. Inside SAS Activity-Based Management, select **Tools ➔ User Options**.
2. Click the **Easy API Configuration** tab.
3. Select **Save operation xml in directory path**.
4. Specify the directory path where the XML will be saved.

Now, when you perform an operation inside SAS Activity-Based Management, the XML for that operation is saved in a file in the directory that you specified.

You can modify the XML file to suit your purposes. For example, you might modify the XML file shown here to generate different periods for the same model or to generate the same periods for a different model.

For information on the XML files, see "Using the API" in the SAS Activity-Based Management Data Administration Guide available from the Help menu or at http://support.sas.com/documentation/onlinedoc/abm/.
**Save Easy API Commands in a Text File**

The following table lists the Easy API commands and tells what each command does. Notice that each command takes one parameter which is either the path and name of an XML file, or the path and name of an external program. The parameters shown are only examples given that your path is probably different.

<table>
<thead>
<tr>
<th>Command and sample argument</th>
<th>What it does</th>
</tr>
</thead>
<tbody>
<tr>
<td>Export &quot;C:\Program Files\SASHome\SASActivityBasedManagementClient\7.2\EasyAPI\your.xml&quot;</td>
<td>Export model data</td>
</tr>
<tr>
<td>Run &quot;C:\Program Files\SASHome\SASActivityBasedManagementClient\7.2\EasyAPI\your.sas&quot;</td>
<td>Execute external programs including, but not limited to, SAS stored processes. For example, you can also run SAS Enterprise Guide vbscripts using this Run command.</td>
</tr>
<tr>
<td>Import &quot;C:\Program Files\SASHome\SASActivityBasedManagementClient\7.2\EasyAPI\your.xml&quot;</td>
<td>Import model data</td>
</tr>
<tr>
<td>Calculate &quot;C:\Program Files\SASHome\SASActivityBasedManagementClient\7.2\EasyAPI\your.xml&quot;</td>
<td>Calculate and/or generate a cube. Note: The XML file that you use determines whether this command does a calculation or generates a cube.</td>
</tr>
<tr>
<td>Export Report &quot;C:\Program Files\SASHome\SASActivityBasedManagementClient\7.2\EasyAPI\your.xml&quot;</td>
<td>Export a report</td>
</tr>
<tr>
<td>Copy Period &quot;C:\Program Files\SASHome\SASActivityBasedManagementClient\7.2\EasyAPI\your.xml&quot;</td>
<td>Copy model data from one period/scenario to another</td>
</tr>
<tr>
<td>Export Cube &quot;C:\Program Files\SASHome\SASActivityBasedManagementClient\7.2\EasyAPI\your.xml&quot;</td>
<td>Export cube configurations</td>
</tr>
<tr>
<td>Import Cube &quot;C:\Program Files\SASHome\SASActivityBasedManagementClient\7.2\EasyAPI\your.xml&quot;</td>
<td>Import cube configurations</td>
</tr>
<tr>
<td>// Comment</td>
<td>You can put ’ or // in front of the command line to comment out (skip) a particular Easy API command.</td>
</tr>
</tbody>
</table>

To issue an Easy API command, put it in a text file named EasyAPI.txt residing in the following directory:

```
<installation directory>\SASActivityBasedManagementClient\7.2\EasyAPI\ 
```

For example:

```
C:\Program Files\SASHome\SASActivityBasedManagementClient\7.2\EasyAPI\ 
```

An easy way to open EasyAPI.txt is by selecting Start ➔ Programs ➔ SAS ➔ SAS Activity-Based Management 7.2 ➔ EasyAPI ➔ 2. Specify parameters from the Start menu.
The following picture shows EasyAPI.txt as it appears on installation of SAS Activity-Based Management.

Don't forget to include your login credentials in the txt file.

Invoke Easy API

To invoke Easy API, select Start ⇒ Programs ⇒ SAS ⇒ SAS Activity-Based Management 7.2 ⇒ EasyAPI ⇒ 3. Run from the Start menu.

Easy API can e-mail you the results of its operation. To receive an e-mail with operation results:
1. Inside SAS Activity-Based Management, select **Tools ⇒ User Options**.
2. Click the **Easy API Configuration** tab.
3. Specify an **SMTP server** for sending the mail.
4. Specify an **Email Id for successful operation**.
5. Specify an **Email Id for failure of operation**.

**Notes:**
- Log files named EasyAPI.log or CutomEasyAPI.log are created in the Easy API Installation folder. You can also access the Easy API operations log in the Windows Event Viewer.
- You can also invoke Easy API by running EasyAPI.exe, which is installed in `<installation directory>SASActivityBasedManagementClient \7.2\EasyAPI\`.
- By supplying a path argument to EasyAPI.exe, you can tell it to use a different txt file for Easy API commands, for example, `EasyAPI.exe "c:\MyPath \EasyAPI2.txt"`. If you don't supply a path argument, then Easy API uses EasyAPI.txt in its installation directory.
- You can use the Microsoft Windows Scheduled Tasks Wizard to schedule EasyAPI.exe to run automatically at selected intervals.
- In the EasyAPI.txt file, you can either store your password in clear text or you can encrypt it using EncryptPassword.exe located at `<installation directory>\SASActivityBasedManagementClient\7.2\EasyAPI\`. EncryptPassword.exe produces an encrypted string that you can paste into EasyAPI.txt. Easy API then decrypts the password before performing Easy API operations.
Overview

For more on information maps, see the SAS Activity-Based Management Data Administration Guide available from the Help menu or see a possibly newer version of the same publication at http://support.sas.com/documentation/onlinedoc/abm/.

Create Information Maps (Register Metadata)

Information maps are the vehicle for sharing information among SAS programs such as SAS Information Map Studio, SAS Web Report Studio, and SAS OLAP Cube Studio. For example, you can use SAS Web Report Studio to generate account-based reports and assignment-based reports.

Perform the following steps to create information maps:

1. Open the model for which you want to create information maps.
2. Select Model ⇒ Register Metadata. The Register Metadata dialog box opens.
   
   Note: The model must have been calculated.

3. If you have not already specified the folder to use on the Metadata Server to use, click Configure. The Metadata Server Options dialog box appears.
   
   Note: You can also open the Metadata Server Options dialog box by selecting Tools ⇒ Metadata Server Options.

4. Under Create information maps for reporting, select the type of map(s) that you want to create.
• **Account Map**: This option creates an information map from model-specific public database views. This information map contains account-related data that can be used by SAS Web Report Studio to create account-based reports.

• **Assignment Map**: This option creates an information map from model-specific public database views. This information map contains assignment-related data that can be used by SAS Web Report Studio to create assignment-based reports.

5. Click **Create**. Before information maps are created, specific public database views that are associated with the current model are copied to the SAS data library that you specified in the Metadata Server Options dialog box. These public database views are created during model calculation, and they are used to create information maps. Map names are automatically generated in the following formats:

- Account maps: M<InternalModelID>_<ModelName>_AccountMap
- Assignment maps: M<InternalModelID>_<ModelName>_AssignmentMap

For example, an account map for a SAS Activity-Based Management model with an internal model ID of 1079 and a model name of Parcel Express is generated as M1079_ParcelExpress_AccountMap

**Note**: Each time that you create an information map, the existing information map is deleted and replaced by the new information map.

6. Click **Details** to view the log details of the results. The Register Metadata Results dialog box appears. If the tables are successfully imported, then the information maps are created.
See Also

- “Register Metadata / Metadata Server Options” on page 535
- “Work with Information maps in SAS Information Map Studio” in Chapter 25 of SAS Activity-Based Management: Data Administration Guide
- “Use SAS Management Console to Configure for Information Maps” in Chapter 25 of SAS Activity-Based Management: Data Administration Guide
- “Change the SAS Metadata Server Connection” in Chapter 25 of SAS Activity-Based Management: Data Administration Guide

Register Metadata / Metadata Server Options

About the Register Metadata and Metadata Server Options Functions

The availability of these features depends on your permissions.
For more information on SAS Information Maps and on SAS Profitability Management, see the chapter on “Working with Other SAS Programs” in the *SAS Activity-Based Management Data Administration Guide* available from the Help menu and also from [http://support.sas.com/documentation/onlinedoc/abm/](http://support.sas.com/documentation/onlinedoc/abm/).

Register Metadata

**About Registering Metadata**

Use the Register Metadata dialog box to create information maps for a calculated model.

**How to Access the Register Metadata Dialog Box**

Select **Model ⇒ Register Metadata**.

*Note*: The model must have been calculated and must currently be open.
Metadata Server Options

About the Metadata Server Options
Use the Metadata Server Options dialog box to specify where on the Metadata Server information maps and SAS Profitability Management behaviors are stored — and to specify what programs are used to create them.

*Note:* The settings displayed in the Metadata Server Options dialog box are determined during installation of SAS Activity-Based Management. However, you can use the Metadata Server Options dialog box to change these settings after installation.

How to Access the Metadata Server Options Dialog Box
Do either of the following:

- Select **Tools ⇒ Metadata Server Options**.
- Click **Configure** on the Register Metadata window.
Overview

For more information on working with SAS Profitability Management, see the SAS Activity-Based Management Data Administration Guide available from the Help menu or see a possibly newer version of the same publication at http://support.sas.com/documentation/ondlinedoc/abm/.

Publish Behaviors to SAS Profitability Management

Select File ⇒ Publish ⇒ Behaviors. The Publish Behaviors wizard opens.

Note: Before you can publish behaviors, you must specify the SAS Profitability Management input library so that SAS Activity-Based Management knows where to store the published behaviors. And, you must have marked some accounts as behaviors.

1. Select a model and specify the name of the behavior table to be created.
Model name
Select the model whose accounts you want to mark as behaviors.

Period/Scenario associations
Select the period/scenario associations for which you want to publish the data.

Behavior table name
Specify a name for the behavior table.

Option
Create table
Creates a behavior table. If a table with the same name exists, then the operation quits with an error message, and the existing table is undisturbed.

Replace table
Replaces an existing table with the same name.

Append to table
Appends records to an existing table.

2. Map properties and attributes of the accounts being published to fields in the resulting behavior table being created.
Id is the identifying reference for the behavior

Name is the name of the behavior

Period defines the period for the costs

Unit value is the unit cost for each transaction with this source. If you select a Unit value, then you may not select a Total value.

Total value is the total source amount that will be spread. If you select a Total value, then you may not select a Unit value.

3. You can optionally set a condition that an account must satisfy to be published as a behavior. This allows you to select a subset of all the accounts that have been marked as behaviors.
4. You can further limit the number of accounts to be published by selecting dimensions. If you do not select any dimensions, then accounts (which are marked as behaviors) from all dimensions are published.

5. Review your selections, and then click **Finish**.

The published accounts are written to a behavior table in the Profitability Management input library.
Overview

For more information on working with SAS Strategy Management, see the *SAS Activity-Based Management Data Administration Guide* available from the Help menu or see a possibly newer version of the same publication at [http://support.sas.com/documentation/onlinedoc/abm/](http://support.sas.com/documentation/onlinedoc/abm/).

Steps for Integrating with SAS Strategy Management

What Is SAS Strategy Management

SAS Activity-Based Management provides reliable, fact-based data that can be used to evaluate an organization's past performance and affect future decisions. Using SAS Activity-Based Management, you can mark accounts and rollup accounts from the Resource, Activity, Cost Object, and External Units modules as items for performance review. Any property or numeric attribute of a SAS Activity-Based Management
account can be marked and published as a performance measure to be used in other reporting tools, such as SAS Strategy Management.

A performance measure, also known as a key performance indicator (KPI), can be any number that you consider significant in the context of your business and, therefore, want to track. A KPI element, or metric, is a specific, predefined measure of the success of an organization. For example, KPI elements that measure your organization's financial performance might be average annual profit per customer and average cost of sale or service. You can include this SAS Activity-Based Management information in other reporting applications, such as by integrating them with SAS Strategy Management.

**T I P** Anything that you define as a performance measure in SAS Activity-Based Management and display as a KPI element in SAS Strategy Management can also be displayed in the SAS Information Delivery Portal (dashboard, aggregation view, and table view portlets).

Integrating SAS Activity-Based Management with SAS Strategy Management provides quick insight to issues and a path toward their resolution. Both solutions are complimentary to almost any process or activity:

- Many measures that are used in SAS Strategy Management are financial in perspective and include elements of profitability and/or cost.
- Many measures that are used in SAS Strategy Management are metrics that are used as cost drivers in SAS Activity-Based Management.
- SAS Strategy Management identifies leading and lagging indicators of performance, and SAS Activity-Based Management provides insight into the cause of the values of these indicators.
- SAS Activity-Based Management provides the actionable detail behind the KPIs.

Calculating the costs of a SAS Activity-Based Management model provides a picture of an organization's behavior. The model values (numeric properties and attributes) that you specify as performance measures are calculated by SAS Activity-Based Management, and they can then be provided or published to a SAS Strategy Management scorecard. A collection of performance measures, or KPI elements, comprises a SAS Strategy Management project. (Scorecards can be arranged in a hierarchical tree by using the SAS Solutions Dimension Editor.)

**Integration Procedure**

Integrating with SAS Strategy Management is a four-step process:

1. “Select Performance Measures” on page 544
2. “Choose the Table Format for Publishing” on page 547
3. “Publish the Measures” on page 551

**Select Performance Measures**

**Add Performance Measures**

The following items can be used as performance measures:

- numeric properties (costs and quantities)
numeric attributes

To add a performance measure to an account:
1. In one of the modules, right-click an account.
2. Select Item Properties.
3. Select the performance measures to be applied to the account and click OK.
   
   **Note:** Performance measures are periodic. When you associate a performance measure with an account, it is associated only with the period/scenario association in which you attach it.

   **Note:** The Publish name of an account is the name that is used for the account in tables that are written to the database when you publish performance measures.

---

**Selecting Roll–Up Accounts**

To create a record in the metric table for ALL, select a roll-up account and mark it as a performance measure, as shown for example in the following picture:

The following picture shows a portion of the resulting metric table:
Similarly, to create a record in the metric table for NONE, select the <No> roll-up account and mark it as a performance measure, as shown for example in the following picture:

**Display Performance Measures**

To display the performance measures that have been added to accounts:

1. Select Model ➔ Performance Measures.
2. Select a period/scenario association. Performance measures are periodic.

The Performance Measures view opens to display all the performance measures that have been added to accounts.
Modify Performance Measures

You can add or remove performance measures from an account that appears in the Performance Measures view by right-clicking the account and selecting Item Properties.

However, if an account does not yet have a performance measure and, consequently, does not appear in the Performance Measures view, then the only way to add a performance measure is from a module view, as described previously.

Choose the Table Format for Publishing

Overview

Before publishing performance measures, choose options for the output tables. There are two options for publishing model data to SAS Strategy Management:

- “Create a single metric table using the Publish Name column” on page 548
- “Create a metric table for each module type using the module's dimensions ” on page 549

1. Select Model ⇒ Properties.
   
The Model Properties window opens.
2. Select the Performance Measures tab.
3. Select options for the output tables.
Create a single metric table using the Publish Name column

Selecting this option creates one hierarchy table and one metric table per SAS Activity-Based Management model. The metric table contains a single dimension column with dimension members, each of whose name is the “Publish name” of the account (see “Select Performance Measures” on page 544). Use this option to summarize SAS Activity-Based Management metrics into a single dimension in a SAS Strategy Management scorecard.

Entering the Dimension code and the Dimension name that you want to publish to SAS Strategy Management uniquely identifies the dimension for this SAS Activity-Based Management model.

The following picture shows a sample hierarchy table and metric table that result from choosing this option:
Note: Dimension names cannot contain blanks when used with SAS Strategy Management because of an ODBC restriction.

Create a metric table for each module type using the module’s dimensions

Selecting this option creates a different metric table for each module in the SAS Activity-Based Management model. The metric table contains a dimension column corresponding to each dimension in the module, with dimension members that are created from the SAS Activity-Based Management dimension members for that module. Use this option if you want to maintain the dimension detail of the SAS Activity-Based Management metrics in the SAS Strategy Management scorecard.

The following picture shows sample hierarchy tables and metric tables that result from choosing this option:
Collapsing the Metric Tables

If you choose the option to Create-a-metric-table-for-each-module-type-using-the-module's-dimensions, then you must perform some post-processing on the metric tables published by SAS Activity-Based Management before they can be used by SAS Strategy Management. The reason is that SAS Strategy Management supports a single dimension in a table, and the metric tables published by SAS Activity-Based Management contain multiple dimensions. Consequently, you must perform post-processing to collapse any metric table that you want to import into SAS Strategy Management such that the metric table contains a single dimension.

To take a very simple example, suppose that you have selected four accounts in the Cost Object module as performance measures as shown in the following picture:
Publishing performance measures with the option to create-a-metric-table-for-each-module-type-using-the-module's-dimensions creates the metric table shown in the following picture:

<table>
<thead>
<tr>
<th>Name</th>
<th>PubName</th>
<th>InsectName</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>2nd Day Guaranteed</td>
<td>2nd Day Guaranteed</td>
<td>Los Angeles x Customer Pick Up x 2nd Day Guaranteed</td>
<td>$69,682.17</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>Overnight Express</td>
<td>Los Angeles x Drop Box x Overnight Express</td>
<td>$15,053.13</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>Overnight Express</td>
<td>Los Angeles x Customer Pick Up x Overnight Express</td>
<td>$135,090.46</td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>2nd Day Guaranteed</td>
<td>Los Angeles x Drop Box x 2nd Day Guaranteed</td>
<td>$49,362.46</td>
</tr>
</tbody>
</table>

After doing post-processing to collapse the table on the CHNL (Channel) dimension, the following table (containing a single dimension) is produced that can be used with SAS Strategy Management:

<table>
<thead>
<tr>
<th>REG</th>
<th>CHNL</th>
<th>PROD_SERV</th>
<th>SCENARIO</th>
<th>PERIOD</th>
<th>STARTDATE</th>
<th>ENDDATE</th>
<th>STMTIMEPERIOD</th>
<th>MEASURE</th>
<th>VALUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Drop Box</td>
<td>Actual</td>
<td>2008 Q1</td>
<td>2008-01-01</td>
<td>2008-03-31</td>
<td>2008-03-31</td>
<td>Cost</td>
<td>64205.59375</td>
<td></td>
</tr>
</tbody>
</table>

You can notice in this example that the VALUE column contains the sum of the VALUE column of the rows that are collapsed, as shown in the following picture:

Of course, in your post-processing you do not have to use the SUM function. You can choose to collapse the rows in any way that you like.

**Publish the Measures**

**Procedure**

To publish the performance measures:

1. Select **Model ➔ Performance Measures**.

The Performance Measures view opens.
2. Select **Publish Performance Measures**.

The Publish Performance Measures window opens for selecting a period/scenario to publish.

3. Select a period/scenario association to publish, or select **All** to publish data for all period/scenario associations.

---

**Import the Measures**

For information on importing, see the chapter on SAS Strategy Management in *SAS Activity-Based Management Data Administration Guide* available from the Help menu or (a possibly newer version) from [http://support.sas.com/documentation/onlinedoc/abm/](http://support.sas.com/documentation/onlinedoc/abm/)

---

**Performance Measures View**

**About the Performance Measures View**

<table>
<thead>
<tr>
<th>Name</th>
<th>PubName</th>
<th>InstrName</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>External Unit</td>
<td>Wages</td>
<td>Beaverton x Wages</td>
<td>$1,538,600.00</td>
</tr>
<tr>
<td>Resource</td>
<td>Cost</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

On the Performance Measures view, you can work with performance measures for publishing to SAS Strategy Management. For more information, see “Working with Other Programs” in the *SAS Activity-Based Management Data Administration Guide*.  

**Note:** You cannot directly edit the information on the Performance Measures view.

**See also:**
For more information, see the chapter on “SAS Strategy Management” in the SAS Activity-Based Management Data Administration Guide available from the Help menu and from http://support.sas.com/documentation/onlinedoc/abm/.

**How to Access the Performance Measures View**
Open a model in Model mode and select Model ➤ Performance Measures.

**Tasks**

**Add or Remove Performance Measures**
You can use the Performance Measures view to add or remove performance measures from an account. However, the account must already have at least one performance measure added to it in order to appear in the Performance Measures view.

1. From the Performance Measures view, select the item whose performance measures you want to modify.
2. Select Edit ➤ Item Properties.
   
   The Item Properties and Attributes dialog box appears.

**Publish Performance Measures**
From the Performance Measures view, select Model ➤ Publish Performance Measures.

The Publish Performance Measures dialog box appears.

---

**Publish Performance Measures Dialog Box**

**About the Publish Performance Measures Dialog Box**
In the Publish Performance Measures dialog box, you select the period/scenario association to be published for use by SAS Strategy Management.

![Publish Performance Measures Dialog Box](image)

See also:
For more information, see the chapter on “SAS Strategy Management” in the SAS Activity-Based Management Data Administration Guide available from the Help menu and from http://support.sas.com/documentation/onlinedoc/abm/.
How to Access the Publish Performance Measures Dialog Box

1. Open a model.

2. Select Model ➞ Performance Measures.

   The Performance Measures view opens. See “Performance Measures View” on page 552.

3. From the Performance Measures view, select Model ➞ Publish Performance Measures.

<table>
<thead>
<tr>
<th>Name</th>
<th>PubName</th>
<th>IntName</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>External Unit</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Resource</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Wages</td>
<td></td>
<td>Revenues=Wages</td>
<td></td>
</tr>
<tr>
<td>LVCost</td>
<td></td>
<td></td>
<td>$1,638,600.00</td>
</tr>
<tr>
<td>Activity</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cost object</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Part 18

Reporting Model Data

Chapter 54
About Reports ................................................................. 557

Chapter 55
Correlation Reports ....................................................... 567

Chapter 56
How To ........................................................................ 581
556
# About Reports

Reports
- About Reports
- Model Size and Report Performance
- Report Header
- Setting up a Report
- Report Configurations
- Saving Report Data
- Adding Reports to SAS Activity-Based Management

Reports Mode
- Overview
- How to Access the Reports Mode
- Open a Report

Reports Workspace
- About the Reports Workspace
- How to Access the Reports Workspace
- Open a report configuration
- Delete a report configuration
- Change a report configuration
- Publish a report
- Sort information

Report Page
- About the Report Page
- How to Access the Report Page
- Open a Report Configuration
- Change a Report Configuration
- Save a Report Configuration
- Publish a Report
- Export a Report

Report Templates

Publish Report Dialog Box
- About the Publish Report Dialog Box
- How to Access the Publish Report Dialog Box
- Specify Information

Insert New Published Report Dialog Box
- About the Insert New Published Report Dialog Box
- How to Access the Insert New Published Report Dialog Box
- Specify Information

Report Configuration Dialog Box
Reports

About Reports

A report is created as an Adobe Portable Document Format (PDF) file.

The Report Wizard guides you through a series of steps for selecting data, running a report, and saving a report. You can then view, print, and export reports that have been created.

Model Size and Report Performance

Model size affects the performance of the reports. This is particularly true of the Multi-level Contributions report, which contains a large amount of detailed data. The time required to gather this data depends on the size of the model. Likewise, creating a report that includes data from multiple period/scenario associations requires more time than a report that includes data from a single period/scenario association.

When creating a report for a large model, consider creating a report for each module instead of a single report for all modules. Likewise, create a report for a single period/scenario association, instead of creating a report for multiple period/scenario associations.

Report Header

Each report has a header that lists pertinent information for that report. All or some of the following information can be listed in a report's header:

<table>
<thead>
<tr>
<th>Information</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Model Name</td>
<td>The model selected for the report</td>
</tr>
<tr>
<td>Module</td>
<td>One or more modules selected for the report; each module starts on a new page</td>
</tr>
<tr>
<td>Period</td>
<td>The period selected for the report</td>
</tr>
<tr>
<td>Scenario</td>
<td>The scenario selected for the report</td>
</tr>
<tr>
<td>View Perspective</td>
<td>The dimension selected for the report</td>
</tr>
<tr>
<td>Filtered</td>
<td>Indicates that one or more attributes were used to select items for the report; attributes used to select report data are listed on a report's last page</td>
</tr>
</tbody>
</table>
Setting up a Report

About Setting up a Report
To create a report, the Report Wizard guides you through a series of steps for selecting data, running a report, and saving a report. The modules, period, scenario, and dimensions that you select determine the data that is included in the report. See “Create a Report” on page 581.

Note: To create a report you do not have to generate a cube. However, to create the following reports you must have already generated the Fact table for the model:

- Resource Contributions
- Destination Furthest
- Profit and Loss (Resource Contribution)

Selecting Accounts
You can report on specific accounts within a module by using standard Windows selection techniques.

Selecting Dimensions
Certain report types require you to select dimensions to arrange and filter data. The order that you select these dimensions affects the results that you see in the report.

Report Configurations

About Report Configurations
When you open a report, you can save selections in the report to use later for a specific model. This saved information is a report configuration.

Saving a Report Configuration
Remember, you are not saving the report's data; rather, you are saving the report configuration to use later. If you want to save the report's data, you have several methods for saving report data.

All report configurations that are saved on the same server are listed in Workspace Manager. Therefore, your organization might want to set up some guidelines for saving and naming report configurations.

Selecting a Period/Scenario Association
Before running or opening a saved report configuration, select the period/scenario association for the open model. When you open a saved report configuration, if possible, it will try to use the open model and its current period and scenario.

Saving Report Data

About Saving Report Data
To save the data in a report, you can export and publish.
Exporting a Report
If you want to customize a report after running it, such as add a company logo, you can export the report.

Publishing a Report
If you want other users to see the report results with the data reflecting a specific point in time, you can publish the report. Publishing the report enables others to see the report data without the need to rerun the report. For a report that requires considerable time to run, publishing the report can save other users time.

Adding Reports to SAS Activity-Based Management
You can create a report in another application, such as SAS Enterprise Guide. However, to have the report appear in SAS Activity-Based Management, you must manually insert (publish) the report.

See Also
- “Reports Mode” on page 560
- “Reports Workspace” on page 560

Reports Mode

Overview
In Reports mode, you can open or create a report configuration.

When you enter Reports mode without a report configuration selected, the Reports page appears.

How to Access the Reports Mode
- If no report is open, click Reports in the Navigation Pane.
- If a report is already open, click the Go to Reports Workspace icon in the Reports workspace toolbar.

Open a Report
1. From the Report Configuration menu, select a configuration.
   
   Note: If a report is not already open, open a report from the Reports workspace.
2. Click
Reports Workspace

About the Reports Workspace

In the Reports workspace, you can open or create a report configuration.

Note: The availability of these features depends on your permissions.

The list of Folders and Report Configurations reflects the Reports branch of the server area in Workspace Manager.

How to Access the Reports Workspace

Do one of the following:

- Without a report open, click Reports in the Navigation Pane.
- With a report open, click the Go to Reports Workspace icon in the toolbar

Open a report configuration

1. From the list of Folders on the left, select a folder.
2. From the list of Report Configurations on the right, click a report configuration.

TIP You can also click .
Delete a report configuration

To the right of a report configuration, click the Delete link.

*Note:* If you are a member of a group that has read-only permission, then Delete is not available to you.

Change a report configuration

To the right of a report configuration, click the Configure link.

The settings that you selected the last time you used the Report Wizard for this report configuration appear.

*Note:* If you are a create-model capability, but your group permissions are read-only, then Configure is not available to you.

Publish a report

To the right of a report configuration, click the Publish link.

The Publish Report dialog box appears.

*Note:* If you have create-model capability, but your group permissions are read-only, then Publish is not available to you.

Sort information

1. Click the Sort by link.
   
   A menu appears.

2. Select an option. The sort options contain the following criteria:

<table>
<thead>
<tr>
<th>Name</th>
<th>The name of the report configuration</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date and Time</td>
<td>The date and time which the report configuration was created</td>
</tr>
</tbody>
</table>

See Also

- “Reports Mode” on page 560
- “Reports” on page 558
About the Report Page

On the Report page, you can work with report configurations and create and view reports.

When you set up reports, you first select a model and a report template. Next, the Report Wizard guides you through a series of steps for selecting data, running a report, and saving a report. You can view, print, and export reports that have been created.

Because reports are displayed in PDF format, some Adobe Acrobat facilities are available to you from the menu bar such as Acrobat Connect for web conferencing and Acrobat Buzzword for creating and reviewing documents collaboratively. These facilities are not part of SAS Activity-Based Management. For further information on them, see the documentation available from Adobe.

How to Access the Report Page

Open a report in Reports mode.

Open a Report Configuration

1. From the Report Configuration menu, select a configuration.
2. Click
**Change a Report Configuration**

1. Open a report configuration.
2. Select **Reports ➔ Configure**.

   The settings that you selected the last time you used the Report Wizard for this report configuration appear.

**Save a Report Configuration**

1. Open a report configuration.
2. Select **Reports ➔ Save Configuration**.

   The last page of the Report Wizard, in which you specify the name of the report configuration, appears.

**Publish a Report**

1. Open a report configuration.
2. Select **Reports ➔ Publish**.

   The Publish Report dialog box appears. Published reports are saved by default in this directory:

   ```
   C:/<Your_Server_Name>/Activity-Based Management Solution/Enterprise Server/SasSolutions/ABM/Reports/Published
   ```

**Export a Report**

You can export a report if you want to customize the report or if you want to use some other reporting tool. If you want to use SAS Enterprise Guide as your front end, you can use the SAS Activity-Based Management Report Data Selection add-in, instead of exporting the report to a temporary location.

1. Select **File ➔ Export ➔ Report Data**.

   The Report Data Wizard appears.

2. Select the report type. Depending on the type you select, the choices in the subsequent wizard pages will change. For example, Dimensional View, Profit and Loss, and Profit Cliff wizard pages differ, so, when filtering your data, you must specify your view perspective (how you want to view the data).

3. Select the models (one or more) that you want to report from.
4. Select a period/scenario association (one or more).
5. Select a module. If you selected more than one model, you cannot use the **Use Selection** option in the wizard. The subsequent pages in the wizard enable you to filter your results for your report.
6. If exporting to a database, connect to the database.

**Note:** You can export data from inside SAS Enterprise Guide.
Report Templates

A report template is a file that specifies the layout of a report and the fields of data in a report (but not the report's data itself). When you create a report, you choose a report template.

SAS Activity-Based Management comes with several predefined report templates that provide set formats and permit great flexibility in the amount and type of data to include in a report. For information on the following templates, see “Working with Reports” in the SAS Activity-Based Management Data Administration Guide, available from the Help menu or see a possibly more recent version at http://support.sas.com/documentation/onlinedoc/abm/.

- Destination Furthest
- Dimensional Attribute Cost
- Dimensional Attribute Unit Cost
- Dimensional View
- Driver - Cost and Rate
- Idle Capacity
- Module Hierarchy
- Multi-level Contributions
- Profit Cliff
- Resource Contributions
- Resource Contributions by Attribute
- Resource Contributions Intermediate
- Single-stage Assignment
- Single-stage Contributions
- Unassigned Costs
- Unit Cost

Publish Report Dialog Box

About the Publish Report Dialog Box

In the Publish Report dialog box, you can publish a report so that it is available to other users.

How to Access the Publish Report Dialog Box

Do one of the following:

- From the Reports workspace, click the Publish link next to a report configuration.
- On the Report view, click the Publish Report link.

Specify Information

1. Type the Name.
2. (Optional) Type the Description.
3. Select a Format.
Insert New Published Report Dialog Box

About the Insert New Published Report Dialog Box

In the Insert New Published Report dialog box, you can add to Workspace Manager a report created in Adobe Portable Document Format (PDF) or Rich Text Format (RTF).

Note: You can perform the following task without first opening a model.

How to Access the Insert New Published Report Dialog Box

In Workspace Manager, select Published Reports, and select File ➪ Insert Published Report.

Specify Information

1. Type the Report Name.
2. For Report Source, type the full path to the location in which the report is stored.
   Or, to navigate to the location, click ...
3. (Optional) Type the Description.
4. Click OK.

Report Configuration Dialog Box

About the Report Configuration Dialog Box

Use this dialog box to open a different saved report configuration.

How to Access the Report Configuration Dialog Box

Select Reports ➪ Open Saved Report Configuration.

Note: You must be in the Reports Workspace for this menu item to be available.
Chapter 55
Correlation Reports

What is a Correlation Report

Introduction
A correlation report shows the correlation over multiple periods between the demand for products and services and the cost of producing them. A correlation report provides an answer to the question of how reliably can one predict cost given an increase or decrease in demand. For every account with outgoing assignments or with a sold quantity not equal to zero, a correlation report shows the strength of correlation between that account’s demand and its cost.

The report can help in the following ways to validate a model across multiple periods:
• ascertain whether changes to driver quantities reliably affect costs when adjusting sales and process mixes
• identify weak correlations that require changing the unit of measure used to drive costs or redefining the flow of money through the model
• provide a foundation for reliable predictive models for forecasting and simulation.

To measure an account’s cost, the correlation report uses its Cost property.

To measure the demand associated with an account, the correlation report uses the account’s Used Quantity property. Although, in general, the TDQ property is a measure
of demand, it is not used because it can be overridden by TDQUE (user entered TDQ), in which case the demand might be artificially skewed by the user entered value.

Used Quantity is the sum of TDQCalc and SoldQty. TDQCalc is the total outgoing flow from an account. It can be construed as the amount of work produced by the account. Alternatively, it can be construed as the demand on the account. The relationship among the three quantities can be represented pictorially as follows.

\[
\text{UsedQty} = \text{TDQCalc} + \text{SoldQty} \\
\text{SoldQty} = \text{TDQCalc} + \Delta Q \cdot \Delta W \cdot \Delta S \cdot \\
\text{TDQCalc} = \Delta Q \cdot \Delta W \cdot \Delta S \\
\text{DTQ} = \Delta Q \cdot \Delta W \cdot \Delta S
\]

For the complete diagram, see “Account Driver Properties” on page 611.

A correlation report produces graphs that show the correlation between the Cost and Used Quantity properties on accounts over multiple periods. It also produces charts that summarize the correlation, and it produces detail lists that show information for individual accounts.


**Interpreting Correlation**

A correlation value close to +1 signifies a positive correlation and occurs when Cost increases when Used Quantity increases. If the correlation value is exactly +1, then there is perfect correlation between Cost and Used Quantity so that one can reliably predict what Cost will be given Used Quantity. As the correlation value decreases toward zero, the ability to predict Cost becomes less reliable.

A correlation value of zero means that there is no correlation between Cost and Used Quantity. Increasing or decreasing Used Quantity does not give any predictable Cost.

A correlation value close to -1 signifies a negative correlation and occurs when Cost decreases when Used Quantity increases, or Cost increases when Used Quantity decreases. Like positive correlation, an exact correlation of -1 enables one to determine
Cost accurately given Used Quantity. As the correlation value increases toward zero, the ability to predict Cost becomes less reliable.

The following table shows several examples of correlation.

<table>
<thead>
<tr>
<th>Account</th>
<th>Type of Data</th>
<th>Jan</th>
<th>Feb</th>
<th>Mar</th>
<th>Corr</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>A1</td>
<td>Cost</td>
<td>1000</td>
<td>2000</td>
<td>3000</td>
<td>+1</td>
<td>Cost and Used Quantity are going up at different rates, but the Used Quantity rate is predictable given the Cost rate.</td>
</tr>
<tr>
<td></td>
<td>Used Quantity</td>
<td>30</td>
<td>35</td>
<td>40</td>
<td></td>
<td></td>
</tr>
<tr>
<td>A2</td>
<td>Cost</td>
<td>1000</td>
<td>2000</td>
<td>1100</td>
<td>0.9868</td>
<td>Non-perfect correlation</td>
</tr>
<tr>
<td></td>
<td>Used Quantity</td>
<td>30</td>
<td>35</td>
<td>40</td>
<td></td>
<td></td>
</tr>
<tr>
<td>B</td>
<td>Cost</td>
<td>1000</td>
<td>900</td>
<td>800</td>
<td>1</td>
<td>When Used Quantity goes up, Cost goes down.</td>
</tr>
<tr>
<td></td>
<td>Used Quantity</td>
<td>30</td>
<td>50</td>
<td>70</td>
<td></td>
<td></td>
</tr>
<tr>
<td>C</td>
<td>Cost</td>
<td>1000</td>
<td>2000</td>
<td>3000</td>
<td>0</td>
<td>Even though Used Quantity goes both up and down, Cost goes consistently up.</td>
</tr>
<tr>
<td></td>
<td>Used Quantity</td>
<td>10</td>
<td>20</td>
<td>10</td>
<td></td>
<td></td>
</tr>
<tr>
<td>D</td>
<td>Cost</td>
<td>1000</td>
<td>2000</td>
<td>3000</td>
<td>N/A</td>
<td>Used Quantity is always the same (e.g., Percentage driver)</td>
</tr>
<tr>
<td></td>
<td>Used Quantity</td>
<td>100</td>
<td>100</td>
<td>100</td>
<td></td>
<td></td>
</tr>
<tr>
<td>E</td>
<td>Cost</td>
<td>1000</td>
<td>10</td>
<td>N/A</td>
<td></td>
<td>Only one period</td>
</tr>
<tr>
<td></td>
<td>Used Quantity</td>
<td>10</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Another way to interpret correlation is in relation to linear regression. When a regression line is created by plotting Cost (Y) and Used Quantity (X) for an account, correlation tells us if points are consistently close to the line. If they are not consistently close then they are not correlated. Correlation is a measure of the strength of linear dependence between two variables.

The interpretation of a correlation coefficient is context dependent. A correlation of 0.9 might be considered to be very low if one is verifying a physical law using high-quality instruments, but it might be regarded as very high in the social sciences where complicating factors impede a strict correlation.

**Undefined Correlation**

There are two cases where a correlation value cannot be calculated for an account and is marked as undefined:

- when an account exists in only one of the periods included in the report
- when the Used Quantity for an account is the same across all periods in the report.

This always occurs for accounts that use the Percentage driver. It also often occurs for accounts that use the Evenly Assigned driver—unless the number of outgoing assignments changes from one period to the next. It can also occur for other drivers if the amount of sales or work done in each period is identical.

Accounts with undefined correlation are listed in a separate section of the correlation report. You can choose to include that section by selecting **Include accounts with undefined correlation value** in creating the correlation report.
Select Options
Select display options for the report:

- Include accounts with cost greater than:
- Include accounts with undefined correlation value

Note: If an account has no outgoing assignments and has a Sold Quantity of zero (or null) then the account is not included in any correlation report because there is no demand defined for the account.

**Number of Periods**

It is possible to create a report covering only two periods; however, it is recommended that you include more. While it is technically possible to create a report for two periods, the results are unusable because the correlation values are always -1, 0 or +1.

It is recommended that you have at least 12 periods for creating a correlation report, and 36 periods are ideal.

**Factors Affecting Correlation**

Correlation is usually not perfect. Correlation is perfect when cost changes at a rate that is predictable from the rate at which demand changes. The two rates can be different, but when there is a correlation one is predictable from the other—given a change in demand, one can predict the change in cost. Another way of looking at this is that cost and demand can be plotted separately on a graph where each quantity changes over time, and then given the value of demand at any point on the graph, one can predict the value of cost at that same point.

This raises the question, what can cause demand and cost not to be correlated? The general answer is anything that causes a change to one but not the other.

**Change in Cost**

Following are a number of examples where costs can change independently of demand.

- Inflation has a broad impact on most costs. Even though the effect of inflation on some costs might be predictable on an annual basis (for example, on wages), the change is registered in a single month or quarter. This results in a lower correlation for an account when it is correlated for all periods in the year.

- Taxes can rise and fall from period to period depending on business activities and congressional action.

- Management decisions to restructure departments can reassign work to business units (accounts) that didn’t exist in the past, or change the number of people in business units, and so on. A correlation report can help identify where such changes are needed by noticing a drop in an account’s correlation after a restructuring.

- Expensive marketing campaigns that target specific products increase the cost of those products during the campaign. If the marketing costs are assigned to the products, while the product costs are assigned to product-plus-customer accounts, then the product-only account correlation will be lower than usual.

**Change in Demand**

If we consider the case where costs remain the same but demand changes, the effect on correlation is less clear. The following are some examples to consider:
An inappropriate unit of measure for a driver results in driving costs inaccurately. For example, while the number of problem reports that a technical support department handles is a readily available metric, using it to drive costs can be inaccurate given that the time to address each problem can vary from minutes to days or weeks, causing work demands that vary significantly across periods while the cost remains the same. A better unit of measure could be hours spent on different activities such as interacting directly with a customer and time spent troubleshooting the problem locally. These can also vary between periods but not as drastically as the number of support issues.

There is extra capacity available that isn’t being utilized, and extra work being done simply uses up the idle capacity.

Some work is omitted from the model. For instance, consider a quick quality check that is done on a widget at the end of a production run. Because the time to do the check is minimal, it is not worth identifying as an activity in the model. Whether omitting the quality check is good or not is impossible to determine without more knowledge of the widget and the resulting cost of not doing a lengthier check. Are there later costs that are incurred because a lengthier quality check was omitted, or is the quality check unnecessary?

The preceding examples show that a change in demand but not in costs can be a difficult situation to assess without further analysis.

Create a Correlation Report

To create a correlation report, do the following:

1. Select **New ▸ Report**.

2. Select a model, and select **Correlation** as the **Report template**. Then click **Next**.

3. Select the periods to include in the report, and then click **Next**.

   **Note:** You must select at least two periods to create a correlation report.

While it is technically possible to create a correlation report for two periods, the results are unusable because the values will always be -1, 0 or +1. It is recommended that you have at least 12 periods for creating a correlation report, and 36 periods are ideal.
4. Select the modules to include in the report, and then click Next.

5. Select dimension attributes to include in the report, and then click Next.
   - If you don’t select any dimension attributes, then all accounts are included in the report.
   - If you select one or more dimension attributes (up to four), then only accounts for which any of the selected dimension attributes is not null are included in the report.

6. Select report options, and then click Next.
Options include the ability to show only those accounts whose correlation value falls within a certain range, such as from 0 to +1.

7. Review the report summary, and then click **Finish**.

---

**Report Output**

**Overview**

Each correlation report produces the following output:

- report header
  - shows the options selected for the report.
graphs
one graph per module for which there are accounts whose correlation coefficient is calculated. See “Report Graphs” on page 574.

account summaries
one summary for each of those modules for which there is a graph. See “Account Summary” on page 575.

account details
one for each of those modules for which there is a graph. See “Account Details” on page 576.

undefined correlations.
one for each module for which there are accounts with undefined correlation. See “Undefined Correlations” on page 577.

---

Report Graphs

Each point in the graph represents an account. The Y axis represents the average cost of each account for the periods reported on. The X axis represents the correlation value—a measure of the extent to which the Cost for an account depends upon its Used Quantity during the periods in question.

One graph is produced for each module reported on.
Account Summary

Each account summary lists the accounts for which a correlation value was calculated. One account summary is produced per module. For each account, the account summary displays the following information:

- Account Name
- Account Reference
- Driver Name
- Average Cost (for the periods reported on)
- Average Used Quantity (for the periods reported on)
- Correlation Value
**Account Details**

Account details shows the Cost and Used Quantity for each account for each of the periods reported on. There is one account details per module.

Account details displays the following information:

- **Account Name**
- **Period (all periods reported on)**
- **Account Reference**
- **Scenario (all scenarios reported on)**
- **Driver Name**
- **Cost (for a particular period)**
- **Correlation Value (for all periods)**
- **UsedQuantity (for a particular period)**
### Undefined Correlations

An account has an undefined correlation value if either of the following conditions is true:

- the account exists in only one of the periods included in the report
- the account’s Used Quantity is the same across all periods in the report.

See “Undefined Correlation” on page 569.

One undefined correlation report is produced per module. These reports are produced only if you selected **Include accounts with undefined correlation value** in creating the correlation report.

#### Select Options

Select display options for the report:
- Include accounts with cost greater than:
- Include accounts with undefined correlation value
- Show summary
Export a Report

To export correlation report data, select File ⇒ Export ⇒ Report Data.

The following columns are exported for a correlation template.

<table>
<thead>
<tr>
<th>Column name</th>
<th>Data type</th>
<th>Length</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>ModelId</td>
<td>Integer</td>
<td></td>
<td>Model ID</td>
</tr>
<tr>
<td>ModelName</td>
<td>Alphanumeric</td>
<td>64</td>
<td>Model name</td>
</tr>
<tr>
<td>ModuleId</td>
<td>Integer</td>
<td></td>
<td>Module Id for ExternalUnit (0), Resource (1), Activity (2), and CostObject (3)</td>
</tr>
<tr>
<td>Module</td>
<td>Alphanumeric</td>
<td>64</td>
<td>Module name</td>
</tr>
<tr>
<td>DriverName</td>
<td>Alphanumeric</td>
<td>64</td>
<td>Driver name</td>
</tr>
<tr>
<td>AccountId</td>
<td>Integer</td>
<td></td>
<td>Account Id. Useful for joining with other tables</td>
</tr>
<tr>
<td>AccountRefnum</td>
<td>Integer</td>
<td></td>
<td>Account Reference</td>
</tr>
<tr>
<td>Column name</td>
<td>Data type</td>
<td>Length</td>
<td>Explanation</td>
</tr>
<tr>
<td>----------------</td>
<td>-----------</td>
<td>--------</td>
<td>------------------------------------------------------------</td>
</tr>
<tr>
<td>AccountName</td>
<td>Alphanumeric</td>
<td>64</td>
<td>Account Name</td>
</tr>
<tr>
<td>Correlation</td>
<td>Float</td>
<td></td>
<td>The correlation value in the range [-1,+1]</td>
</tr>
<tr>
<td>Periods</td>
<td>Integer</td>
<td></td>
<td>The number of period/scenarios the account exists in</td>
</tr>
<tr>
<td>CostMean</td>
<td>Float</td>
<td></td>
<td>The mean average of cost for account across the period/scenarios</td>
</tr>
<tr>
<td>UsedQuantityMean</td>
<td>Float</td>
<td></td>
<td>The mean average of UsedQuantity across the period/scenarios</td>
</tr>
</tbody>
</table>
Create a Report


The Report Wizard appears.

Note: To create a report you do not have to generate a cube. However, to create the following reports you must have already generated the Fact table for the model:

- Resource Contributions
- Destination Furthest
• Profit and Loss (Resource Contribution)

2. Select a Model.


   For information about what data each report template contains, see the section on “Working with Reports” in the SAS Activity-Based Managed Data Administration Guide, available from the Help menu or from http://support.sas.com/documentation/onlinedoc/abm/.

4. Click Next.

5. To use the data in the period/scenario association for a model that is open, select the Use current period/scenario association option.

   If you select this option and a model is not open, you will be prompted to select a period/scenario association at the end of the wizard.

6. To use the data in another period/scenario association, select the Use a specific period/scenario association option, and select the period/scenario association from the list.

7. Click Next.

8. To include data from all the modules and all the accounts, select the Use all modules option.

9. To limit data to a specific module, select the Select a module option, and select a module.
10. To limit data to specific accounts, select the **Use selection** check box, then select one or more accounts from the list.

11. Click **Next**.

The content of this step varies depending on the report you are creating. For some reports the list includes only dimension attributes. For other reports, the list includes structural dimensions. For any report:

- If you select no dimensions, then all accounts are included in the report.
- If you select one or more dimensions (up to four), then only accounts under any of the selected dimensions are included in the report.

12. Click **Next**.

13. To exclude accounts that contain zero costs, select the **Suppress zero costs** option.

14. To exclude cost elements, select the **Hide cost elements** option.

15. To include a single currency, select the **Single currency** option, and select the **First currency**.
16. To include a second currency, select the **Two currencies** option, and select the **Second currency**.

you will review the report summary and create the report.

17. Click **Next**.

18. Review the report summary.

19. If you need to change any information, click **Back** until you reach the page that you need to change in the wizard.

   All of the information that you have specified is saved. Click **Next** to advance through the wizard.

20. To save the report configuration so that the report can be easily run again, do the following:

   a. Select the **Save configuration as** option.

   b. Type the **Name**.

   c. Type the **Description**.

21. To rename an existing report configuration, do the following:

   a. Select the **Update existing configuration** option.

   b. Type the new **Name**.

   c. Type the **Description**.

22. Click **Finish**.

   If you selected the option to use the current period/scenario association in the second step of the Report Wizard and the model is not open, you will be prompted to select a period/scenario association now.
Open a Report

If you start Reports mode without a report already open, you can open a report from the Reports workspace.

The lists of Folders and Report Configurations correspond to the Reports branch of the server area in Workspace Manager.
1. From the list of Folders, select a folder.
2. From the list of Report Configurations, click a configuration.

Open a Report with a Report Already Open

If a report is already open and you want to open a different one, do one of the following:

- Select a report configuration from the drop-down list at the top of the Reports workspace.
- Click the Go to Reports Workspace icon in the Reports workspace toolbar, and then select a report configuration.

See Also

“Reports Workspace” on page 560

Change a Report Configuration

1. Open a report configuration.
2. Select Reports ⇒ Configure.
   The settings you selected the last time that you used the Report Wizard for this report configuration appear.
3. Move through the pages of the Report Wizard to change the report configuration.
Note: If you have Read-only permission to a model, then you do not have the ability to configure.

Save a Report Configuration

1. Open a report configuration.
2. Select Reports > Save Configuration.
   The last page of the Report Wizard appears, in which you specify the name of the report configuration.
3. Select the Save configuration as option.
4. Type the Name.
5. Type the Description.
6. Click Finish.

Export a Report

You can export report data from within SAS Activity-Based Management or from inside SAS Enterprise Guide. For information about how to use SAS Enterprise Guide, see the SAS Enterprise Guide Help.

The report data will be exported to a database.

   You do not need to start Reports mode; you can export report data in any mode.
   The Report Data Wizard appears.
2. Select a *Report template*.

For information about what data each report template contains, see the section on “Working with Reports” in the *SAS Activity-Based Managed Data Administration Guide*, available from the Help menu or from [http://support.sas.com/documentation/onlinedoc/abm/](http://support.sas.com/documentation/onlinedoc/abm/).

3. Click Next.

4. Select one or more *Models*.

5. Click Next.
6. Select one or more Period(s)/Scenario(s).
7. Click Next.

8. To include data from all the modules and all the accounts, select the Use all modules option.
9. To limit data to a specific module, select the Select a module option, and select a module.
10. To limit data to specific accounts, select the Use selection check box, then select one or more accounts from the list.
11. Click Next.
Note: The content of this step varies depending on the report you are creating. However, in each variation of content, you are selecting dimensions to include in the report.

12. If the wizard presents a list, then expand the hierarchy and select the check box next to each dimension to include in the report.

13. If the wizard presents the dimensions as shown, do the following:

a. From the left list, select a dimension.

b. Click Add >.

   The dimension moves to the right list.

   The order that you select dimensions affects the order of the results in the report.

   c. To reorder the dimensions in the right list, select a dimension and click ↑ or ↓.

   d. To remove a dimension from the right list, select the dimension and click Remove <.

Next, you will select other options for the report. The available options depend on the report.

14. Click Next.
15. Click ... (to the right of *Browse to setup a database connection*)

The Data Link Properties dialog box appears. For information about this dialog box, see the Microsoft Help.

16. Type the **Destination table name**.

17. Click **Next**.
18. Review the export summary.

19. If you need to change any information, click **Back** until you reach the page that you need to change in the wizard.

   All of the information that you have specified is saved. Click **Next** to advance through the wizard.

20. To save the export configuration so that the export can be easily run again, do the following:
   
a. Select the **Save configuration as** option.

   b. Type the **Name**.

   c. Type the **Description**.

21. To rename an existing export configuration, do the following:
   
a. Select the **Update existing configuration** option.

   b. Type the new **Name**.

   c. Type the **Description**.

22. Click **Finish**.

---

**Publish a Report**

1. Open a report in Reports mode.
2. Open a report configuration.
3. Select **Reports** ⇒ **Publish**.

The Publish a Report dialog box appears.
4. Type the Name.
   The name must follow the naming conventions. See “Naming Conventions” on page 81.

5. Type the Description.

6. Select a Format.
   
   Note: If you have Read-only permission to a model, then you do not have the ability to publish.

---

Delete a Report Configuration

1. Go to the Reports workspace.
2. Select a report configuration.
3. Click Delete.

   Note: Depending on your permissions, you may not have the ability to delete a report configuration.
Part 19

Customizing the Interface

Chapter 57
User Options .......................................................... 595
Chapter 57
User Options

Customizing the Interface: User Options

Overview
You can customize the SAS Activity-Based Management user interface to fit your needs. User interface settings change the interface for you only, not for all users. They do not change any data in a model. These settings are different from model properties.

Language Shown in the Interface
If multiple languages are installed on your computer, the language that is used is determined by your location setting in Windows (select Settings → Control Panel → Regional and Language Options).

Note: Error messages are generated by SAS Activity-Based Management and by the SAS Activity-Based Management server. Therefore, you might see error messages both in the language that you selected and in the language that is installed on the SAS Activity-Based Management server.
Default Display Precision for New Columns

Overview
You can specify the default number of decimal places that are displayed for costs, driver quantities, and rates. When you add a column on the Model view, the display precision that you set in your user options is used by default.

The display precision option does not affect current columns. It does not change the precision of the underlying data. And, it does not affect reports or cubes.

These settings are saved on each computer. Therefore, any changes that you make to the default display precision affect only columns that you add on the computer on which you changed the default display precision. The changes affect all models.

You can format an individual column to change its display precision.

Default Precision for Cost Values
For the following properties, the default display precision for cost values determines the default display precision for new columns that have the Currency type:

- Allocated Cost
- Assigned Cost
- Assigned Idle Cost
- Assigned Non-reciprocal Cost
- Assigned Reciprocal Cost
- Cost
- Drivable Cost
- Driven Cost
- Driver Allocated Cost
- Driver Cost
- Driver Driven Cost
- Driver Idle Cost
- Driver Percentage
- Driver Used Cost
- Entered Cost
- Idle Cost
- Idle Percentage
- Profit
- Received Allocated Cost
- Received Assignment Cost
- Received BOC Cost
- Received Cost
- Received Driven Cost
- Received Idle Cost
- Received Non-reciprocal Cost
- Received Reciprocal Cost
- Received Used Cost
- Revenue
- Unassigned Cost
- Used Cost
- User Entered Cost Allocation
Default Precision for Numeric Values
For the following properties, the default display precision for numeric values determines the default display precision for new columns that have the Number type:

- Assigned Idle Quantity
- Driven Quantity
- Driver Driven Quantity
- Driver Quantity Basic
- Driver Quantity Calculated
- Driver Quantity Fixed
- Driver Quantity Variable
- Driver Sequence Number
- Driver Weight Fixed
- Driver Weight Variable
- Idle Driver Quantity
- Idle Driver Quantity UE
- Idle Quantity
- Output Quantity
- Output Quantity UE
- Sold Quantity
- Total Driver Quantity
- Total Driver Quantity Basic
- Total Driver Quantity Calculated
- Total Driver Quantity UE
- Unassigned Quantity
- Used Quantity

Default Precision for Currency Rates
The default display precision for currency rates determines the default display precision for columns in the Manage Exchange Rates dialog box:

- Driver Rate
- Unit Cost
- Unit Profit
- Unit Revenue

Number of Rows Retrieved from the Server

Overview
When you expand a rollup account that contains many other accounts or cost elements, or when you show the assignments for an account in the assignments panes, a large amount of information must be retrieved from the server. This information is contained in the rows that are shown in a grid. The larger a model is, the more rows of information must be retrieved. The number of rows that must be retrieved directly affects the response time that you experience when you navigate the structure of a model.

For example, suppose that a model contains 2,000 rollup accounts at the root of the Resource module:
If you want to navigate into the accounts that are contained in Account 250, you must wait until all 2,000 rollup accounts are retrieved from the server. The response time depends on the network traffic and on the other processes that are running on the server. However, if you retrieve fewer rows, you will always save time. To improve the response time for navigating the structure of a model, you can specify how many rows to retrieve from the server. SAS Activity-Based Management will then retrieve either all rows or the specified limit, whichever is smaller. For example, if an account contains 1,200 rows and the limit is 1,500 rows, then all 1,200 rows will be retrieved. However, if the limit is 1,000 rows, then only the first 1,000 rows will be retrieved.

Note: The amount of information that is retrieved from a server does not affect your ability to edit values in a grid. It also has no effect on the costs that are shown in rollup accounts. It merely limits the number of rows that are retrieved.

**More Rows Available Indicator**

If more rows are available, the following indicator appears:

![More Rows Available...](image)

You can then retrieve more rows.

**Changing the Number of Rows to Retrieve**

You can change the number of rows to retrieve while SAS Activity-Based Management is running. When an account is expanded, the most recent value is used. For example, you could specify that 1,500 rows be retrieved the first time you expand an account. After expanding the account to 1,500 rows, you could change the value to 500. When data is retrieved from the server again, the rows will be limited to 500.

Note: A minimum of 50 rows must be set to retrieve from the server.

**Refreshing Information**

When you refresh the information that is displayed in a grid, the information for all the rows is retrieved from the server. The data is refreshed only for the rows that have already been retrieved.

**Appearance of Grids**

You can select the font size of text that is contained in grids (tables). This setting is different from the Windows Control Panel setting that specifies the font size for all fonts that are displayed on your monitor.

You can select the colors for alternating rows in grids.

**Display of Certain Dialog Boxes and Wizards**

By default, when you create an entered cost element or create a dimension member, you specify information about the item in a dialog box. The dialog box enables you to specify all the information about the item when the item is created. However, you can bypass the dialog box to quickly create numerous items. In this case, system-generated default information is used, but you can change the default information later.
Cause Background Colors to Be Printed

1. Select Help ⇒ Contents, Index, and Search > .
   The SAS Activity-Based Management Help appears.
2. Select Options ⇒ Internet Options.
   The Internet Options dialog box appears.
3. Click the Advanced tab.
4. In the Settings list, under the Printing options, select the Print background colors and images option.

Hide or Show the Status Bar

Select View ⇒ Status Bar.

Retrieve More Rows from the Server

Click the arrow in the last row:

More Rows Available...

Additional rows are displayed, up to the limit that you set as an option.

User Options Dialog Box

About the User Options Dialog Box

In the User Options dialog box, you can specify options that affect how you use SAS Activity-Based Management.

Note: You can perform the following tasks without first opening a model.
**How to Access the User Options Dialog Box**

Select **Tools** ⇒ **User Options**.

**Data Tab**

**Select the Default Display Precision for New Columns**

1. Click the **Data** tab.
2. In the Decimal Places Displayed section, select the number of decimal places for Cost values, Numeric values, and Currency rates.

**Specify the Number of Rows to Retrieve from the Server**

1. Click the **Data** tab.
2. In the Amount of Data Retrieved from the Server section, set the value for Maximum number of rows.

**Display Tab**

**Select the Grid Colors and Font Size**

1. Click the **Display** tab.
2. In the Grid Colors section, select values for First row color, Second row color, and Text color from the menus.
3. In the Grid Font Size section, select an option.

**Select Where to Display the Currency Symbol**

1. Click the **Display** tab.
2. In the Currency section, select or clear the options.
**Advanced Tab**

**Specify Whether Certain Dialog Boxes and Wizards Will Be Displayed**
1. Click the **Advanced** tab.
2. In the Settings section, under Dialog Boxes and Wizards, select the dialog boxes and wizards.

**Easy API Configuration Tab**

**Specify an SMTP server for sending emails**
If you specify an SMTP server, then Easy API sends an email to report the results of each operation. You can specify one email ID for receiving reports of a successful operation and a different email ID for receiving reports of a failed operation.
- Click the **Easy API Configuration** tab.
- Specify an SMTP server.

**Specify an email ID to receive good news**
You can specify one email ID for receiving reports of a successful Easy API operation.
- Click the **Easy API Configuration** tab.
- Specify an **Email Id for successful operation**.

**Specify an email ID to receive bad news**
You can specify a different email ID for receiving reports of a failed operation.
- Click the **Easy API Configuration** tab.
- Specify an **Email Id for failure of operation**.

**Turn on or off the saving of XML**
When SAS Activity-Based Management performs an operation, it uses XML to pass the parameters for the operation. You can ask SAS Activity-Based Management to save this XML when it performs an operation so that you can use the same XML to perform the same operation using Easy API.

To begin saving XML:
- Click the **Easy API Configuration** tab.
- Select **Save operation xml in directory path**.
- Specify the directory path where the XML is to be saved.

To stop saving XML:
- Click the **Easy API Configuration** tab.
- Unselect **Save operation xml in directory path**.
Part 20

Properties Reference

Chapter 58
Property Relationship Diagrams .................................................. 605

Chapter 59
Properties in Calculation ................................................................. 623

Chapter 60
Properties Listed Alphabetically ..................................................... 635
Chapter 58
Property Relationship Diagrams

Cost Flowing Into and Out of an Account (Non-Reciprocal) 606
  Incoming and Outgoing Cost 606
  Cost Properties on the Source Side 607
  Cost and Quantities Math on the Source Side 607
  Costs on the Destination Side 607
  Costs on an Assignment 608
  Cost and Quantity Math on an Assignment 608
  Some Cost and Quantity Math in a Nutshell 608

Cost Flowing Into and Out of an Account (Reciprocal) 609

Assignment Properties 610

Account Driver Properties 611
  Account Driver Quantities 611
  Quantities on an Assignment 611
  Cost and Quantity Math on an Assignment 611
  Quantities on the Outgoing Side 611
  Cost and Quantity Math on the Source Side 612
  Idle Cost Quantity Math on an Assignment 612
  Idle Cost Quantity Math on the Source Side 612

Combined Account Cost Properties 613

Cost (Economic World) 615

How to Read these Diagrams 616
  A Single Account 616
  X and Y Axes 616
  A Slightly Unintuitive Case 617

Types of Costs 618
There are different "assignment" methodologies that can be used to assign costs — BOC method or the Assignment method.

Costs: represent all assignment methodologies used to flow costs from an account — BOC and Assignment costs leaving an
the account point of view, "what costs am I assigning out?"

Costs: represent all assignment methodologies that are used to contribute costs to an account. As entered costs are not part of the
methodology they are not included. From the account point of view, "what Assigned Costs am I receiving in?"

Cost element  ● Internal cost element  ○ External cost element  ● Received cost element
Legend

**Received BOC Cost** = \[ \sum \text{Received internal cost (BOC) elements and received external unit cost (BOC) elements.} \]

**Received Assignment Cost** = \[ \sum \text{sum of received assigned cost elements. The received assigned cost elements can come from the Resource, Activity, or Cost Object modules.} \]

**Entered Cost** = \[ \sum \text{sum of user entered cost elements.} \]

**Received Cost** = \[ \sum \text{sum of received internal cost (BOC) elements, received external unit cost (BOC) elements, and received assigned cost elements. The received assigned cost elements can come from the Resource, Activity, or Cost Object modules.} \]

**Cost** = \[ \sum \text{sum of received internal cost (BOC) elements, received external unit cost (BOC) elements, received assigned cost elements, and user entered cost elements. The received assigned cost elements can come from the Resource, Activity, or Cost Object modules.} \]

See “How to Read these Diagrams” on page 616.

**Cost Properties on the Source Side**

Drivable Cost = (Cost - Allocated Cost)

Driver Rate = Drivable Cost/TDQ

Drivable Cost = (Used Cost + Idle Cost)

Idle Cost = (Assigned Idle Cost + Unassigned Cost)

Driven Cost = (Used Cost + Assigned Idle Cost)

Assigned Cost = (Driven Cost + Allocated Cost)

Unassigned Cost = Cost - Assigned Cost

**Cost and Quantities Math on the Source Side**

Driver Rate = Cost/TDQ (or TDQUE)

Used Cost = UsedQty*Driver Rate

IdleCost = IdleQty*Driver Rate

IdlePercentage = IdleQty/TDQ

**Costs on the Destination Side**
(Received Driven Cost + Received Allocated Cost) = (Received BOC Cost + Received Assignment Cost) = Received Cost
(Received Cost + Entered Cost) = Cost

Costs on an Assignment

Driver Driven Cost = (Driver Used Cost + Driver Idle Cost)
Driver Cost = (Driver Driven Cost + Driver Allocated Cost)

Cost and Quantity Math on an Assignment

Driver Used Cost = DriverQtyCalc * Driver Rate
Driver Idle Cost = Idle DriverQty * Driver Rate
Driver Driven Cost = (Driver Used Cost + Driver Idle Cost) or (DrvDrvnQty * Driver Rate)
Driver Cost = (Driver Driven Cost + Driver Allocated Cost)

Some Cost and Quantity Math in a Nutshell

TDQ = IF TDQUE is not null THEN TDQUE ELSE UsedQty
OutputQty = IF OutputQtyUE is not null THEN OutputQtyUE ELSE UsedQty
DrivableCost = Cost - AllocatedCost
DriverRate = IF ExternalUnit THEN UnitCostEntered ELSE DrivableCost/TDQ
UnitCost = IF ExternalUnit THEN UnitCostEntered ELSE DrivableCost/OutputQty
UnitCost = IF OutputQtyUE is not null THEN DrivableCost/OutputQtyUE ELSE DrivableCost/UsedQty
UnitRevenue = Revenue/OutputQty
UnitRevenue = IF OutputQtyUE is not null THEN Revenue/OutputQtyUE ELSE Revenue/UsedQty
UnitProfit = Profit/OutputQty
UnitProfit = IF OutputQtyUE is not null THEN Profit/OutputQtyUE ELSE Profit/UsedQty

See Also

“Types of Costs” on page 618
## Cost Flowing Into and Out of an Account (Reciprocal)

<table>
<thead>
<tr>
<th>Unassigned Cost</th>
<th>Assigned Reciprocal Cost</th>
<th>Assigned Non Reciprocal Cost</th>
<th>Allocated Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>Idle Cost</td>
<td>f(Idle$q_y$)</td>
<td>Driven Cost</td>
<td>f(Driven$q_y$ + Sold$q_y$)</td>
</tr>
<tr>
<td>Received Reciprocal Cost</td>
<td>Σ = c(e$_i$, i.e.,)</td>
<td>Received Non Reciprocal Cost</td>
<td>Σ = c(e$_j$, $</td>
</tr>
<tr>
<td>Received Driven Cost</td>
<td>Σ = c(e$_i$, i.e.,)</td>
<td>Received Allocated Cost</td>
<td>Σ = c(e$_j$, $</td>
</tr>
<tr>
<td>Entered Cost</td>
<td>Σ = c(e$_j$, $</td>
<td>$</td>
<td></td>
</tr>
</tbody>
</table>
Legend

Received Cost = \sum \text{sum of received internal cost elements and received external unit cost elements and received assigned cost elements. Note: The received assigned cost elements can come from the Resource, Activity, or Cost Object module.}

Note: The received assigned cost elements can come from the Resource, Activity, or Cost Object module.

Entered Cost = \sum \text{sum of user entered cost elements.}

Cost = \sum \text{sum of received internal cost elements and received external unit cost elements and received assigned cost elements and user entered cost elements.}

See Also

“Types of Costs” on page 618

Assignment Properties

Driver Quantity Calculated

\text{DrvQtyCalc} = \text{(DQF \times DWF)} + \text{(DQV \times DWV \times Cost.TDQ)}

Idle Driver Quantity

\text{IdlDrvQty} = f(\text{idle flow method})

Driver Driven Quantity

\text{DrvDrvnQty} = \text{IdlDrvQty + DrvQtyCalc}

Computed Assignment Quantities

Driver Driven Cost

\text{DrvDrvnCost} = \text{DrvQtyCalc \times (DrvIdleCost / TDQ)}

Driver Idle Cost

Driver Used Cost

Driver Allocated Cost (user-entered)

Computed Assignment Costs

See “How to Read these Diagrams” on page 616.
See Also

“Types of Costs” on page 618

Account Driver Properties

Account Driver Quantities

- TDQCalc = DQBasic + TDQ * Dest.TDQ
- DQBasic = DQF + DQV * Dest.TDQ
- Idle Driver Quantity = Idle Driver Quantity UE

Cost and Quantity Math on an Assignment

- Driver Used Cost = DriverQtyCalc * Driver Rate
- Driver Idle Cost = Idle DriverQty * Driver Rate
- Driver Driven Cost = (Driver Used Cost + Driver Idle Cost) or (DrvDrvnQty * Driver Rate)
- Driver Cost = (Driver Driven Cost + Driver Allocated Cost)

Quantities on the Outgoing Side

- UsedQty = (TDQCalc + SoldQty)
DrivenQty = ∑ Assigned Idle Quantity + ∑ Used Qty

IdleQty = (TDQUE – OutputQty) (TDQUE and OutputQtyUE override respective quantities)

If TDQUE > OutputQty then Positive Idle
If TDQUE < OutputQty/OutputQtyUE then Negative Idle

Cost and Quantity Math on the Source Side

Driver Rate = DrivableCost/TDQ (or DrivableCost/TDQUE)

DrivableCost = Cost - AllocatedCost

Used Cost = UsedQty*Driver Rate

IdleCost = IdleQty*Driver Rate

IdlePercentage = IdleQty/TDQ

Idle Cost Quantity Math on an Assignment

IdleDrvQty = IdleQtyUE

DrvDrvnQty = DrvQtyCalc + IdleDrvQty

DrvUsedCost = DrvQtyCalc * Driver Rate

DrvIdleCost = IdleDrvQty * Driver Rate

DrvDrvCost = DrvDrvCost = (DrvUsedCost + DrvIdleCost)

DrvCost = (DrvDrvCost + DrvAllocCost)

Idle Cost Quantity Math on the Source Side

DrvRate = DrvbleCost /TDQ

IdleQty = TDQUE-UsedQty

IdlCost = IdleQty * DriverRate

Asgn IdlCost = (sum of DrvIdleCost of destination side accounts)

UnassignedCost = (IdleCost - AsgnIdlCost) or (Cost - Assigned Cost)

AssignedCost = (DrivenCost + AllocCost)

See Also

“Types of Costs” on page 618
**Assumption:** There are different ‘assignment’ methodologies that can be used to assign costs — BOC method or the Assignment method.

**Assigned Costs:** represent all assignment methodologies used to flow costs from an account — BOC and Assignment costs leaving an account. From the account point of view, “what costs am I assigning out?”

**Received Costs:** represent all assignment methodologies that are used to contribute costs to an account. As entered costs are not part of the assignment methodology they are not included. From the account point of view, “what ‘Assigned Costs’ am I receiving in?”

- Entered cost element
- Internal cost element
- External cost element
- Received cost element
See “How to Read these Diagrams” on page 616.

See Also

“Types of Costs” on page 618
See “How to Read these Diagrams” on page 616.
See Also

“Types of Costs” on page 618

How to Read these Diagrams

A Single Account

The diagrams show costs flowing into and out of a single account. Read the chart from left to right. The diagram shows costs coming in from the left, passing through from left to right, and going out on the right.

X and Y Axes

The vertical Y-axis represents a fixed quantity of cost along the entire horizontal X-axis. So, the quantity between any two parallel horizontal lines is constant along the horizontal X-axis. The following picture should make this clear:
A Slightly Unintuitive Case

As the following picture shows:

- **Received BOC Cost** = some amount of **Received Driven Cost** plus some amount of **Received Allocated Cost**.

- **Received Assignment Cost** = some amount of **Received Driven Cost** plus some amount of **Received Allocated Cost**.
Types of Costs

The diagrams show both entered costs and cost flows from one account to another.

- An entered cost is one that you enter directly into an account. It does not come from another account.
- There are three types of cost flows from one account to another:
  - External BOC
  - Internal BOC
  - Assignment

External BOC
An External BOC assignment flows from an account in an External Unit to an account in the Resource, Activity, or Cost Object module. Assignments from an External Unit use a Bill of Cost (BOC) driver or a calculated driver.

Internal BOC
An Internal BOC assignment is an assignment that uses a Bill of Costs (BOC) driver and flows from an account in the Resource, Activity, or Cost Object module to an account that is also in the Resource, Activity, or Cost Object module.

The assignments can be either of two kinds:

- **Cross module** (Resource-to-Activity, Resource-to-Cost Object, or Activity-to-Cost Object)
- **Inner module** (Resource-to-Resource, Activity-to-Activity, or Cost Object-to-Cost Object)

The word "internal" in the expression "Internal BOC" means that the assignment does not come from an External Unit.
Assignment

An Assignment is a cost flow from an account in the Resource, Activity, or Cost Unit module to an account that is also in the Resource, Activity, or Cost Object module. It uses a driver other than a Bill of Costs (BOC) driver. That is, it uses one of the following drivers: Basic, Calculated, Evenly Assigned, Percentage, Sales Volume, or Weighted.

Note: The same word is used in both a general sense and in a specific sense.

In the general sense, an "assignment" is any cost flow from one account in any module to another account in any module.

In the specific sense, an "Assignment" (generally written with an uppercase "A"), is a cost flow from one account that is not in an External Unit to another account (that is also not in an External Unit), and it uses a non-BOC driver.

The assignments can be either of two kinds:

- **Cross module** (Resource-to-Activity, Resource-to-Cost Object, or Activity-to-Cost Object)
- **Inner module** (Resource-to-Resource, Activity-to-Activity, or Cost Object-to-Cost Object)
Cost Element Types

In a Single-stage Contribution cube you can display costs by cost element type. Here are the types available that are available:

- Assignment
- Entered Cost Element
- External Cost Element
- Internal Cost Element

The following table shows the reason for the cost for each type of cost element.

**Note:** In this case, the cost of a cost element is considered from the destination-side point of view. It is the cost resulting from some source.

<table>
<thead>
<tr>
<th>Cost element type</th>
<th>Cost results from</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assignment</td>
<td>Basic, Calculated, Evenly Assigned, Percentage, Sales Volume, or Weighted driver from an account in the Resource, Activity, or Cost Object module</td>
</tr>
<tr>
<td>Cost element type</td>
<td>Cost results from</td>
</tr>
<tr>
<td>---------------------------</td>
<td>-----------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Entered Cost Element</td>
<td>User entered cost</td>
</tr>
<tr>
<td>External Cost Element</td>
<td>Bill of Costs or Calculated driver from an external unit account</td>
</tr>
<tr>
<td>Internal Cost Element</td>
<td>Bill of Costs driver from an account in the Resource, Activity, or Cost Object module</td>
</tr>
</tbody>
</table>

**See Also**

“Cost Elements” on page 175
Chapter 59
Properties in Calculation

Properties

Introduction

Model properties that are involved in calculation fall into categories that are represented by the following diagrams:

- “Diagram 1: Cost Flowing Into and Out of an Account” on page 623
- “Diagram 2: Properties of an Assignment” on page 624
- “Diagram 3: Account Driver Properties” on page 625

This chapter begins by presenting the diagram for each category of properties. Then, in the subsequent sections, the interrelationships among the diagrams are examined in detail.

Diagram 1: Cost Flowing Into and Out of an Account

The following diagram shows costs flowing into and out of a single account. This is the same diagram as shown in “Cost Flowing Into and Out of an Account (Non-Reciprocal)” on page 606 with the addition of numbering.

- The diagram is for non-reciprocal cost flow.
- The column in the center shows the total cost in the account. Cells to the left show cost flowing into the account. Cells to the right show cost flowing out.
- The numbers in the cells show the logical sequence for the calculation of properties. The calculation of a property with a higher number depends upon the prior calculation of certain properties with lower numbers. These numbers are used later in...
this chapter to label descriptions of the individual calculations. Letters are used (for example, 2a and 2b) to indicate that either can be calculated first.

### Diagram 2: Properties of an Assignment

The following diagram shows the properties associated with an individual assignment. This is the same diagram as shown in “Assignment Properties” on page 610 with the addition of numbering.

**Note:** This diagram does not apply to assignments made with a calculated driver. In the case of a calculated driver, DrvQtyCalc is derived from a user-specified formula.

**Note:** Although the properties are prefixed with the word “Driver” (or include it, as in the case of IdlDrvQty), they are all properties of an individual assignment.

![Diagram 2: Properties of an Assignment](image-url)
Diagram 3: Account Driver Properties

The following diagram shows the properties associated with the driver for an account. For example, TDQCalc for an account is the sum of DrvQtyCalc for the individual outgoing assignments that make up the driver for that account. Assignments are to one or more destination accounts.

This diagram is the same one as in “Account Driver Properties” on page 611 with the addition of numbering.

When TDQUE is not specified, then there are no idle quantities (IdlQty=0, AsgnIdlQty=0, and UnAsgnQty=0) and, therefore, TD=UsedQty=DrivenQty. When TDQUE is not specified, the diagram reduces to the following:
Assignment and Account Driver Properties

This section examines the interrelations among the following diagrams:

- “Diagram 1: Cost Flowing Into and Out of an Account” on page 623
- “Diagram 2: Properties of an Assignment” on page 624
- “Diagram 3: Account Driver Properties” on page 625

In the following diagram, the long blue arrows denote a dependency relationship between properties. The property pointed to by the arrow depends on the property that points to it. For example, the arrow that points to 4a. TDQCalc from 2a. Driver Quantity Calculated indicates that TDQCalc (4a) depends on Driver Quantity Calculated (2a). In the table that follows the diagram, look for the row number that matches the number of the property pointed to. This row describes the dependency relationship between the two properties. For the current example, the row number is 4a and its text includes the following formula:

\[ \text{TDQCalc} = \sum \text{DrvQtyCalc} \]

Note that (2a) is the number of the cell in the diagram for the property that TDQCalc is dependent on (DrvQtyCalc). DrvQtyCalc is described by the table row numbered 2a.

The portion of the diagram that is labeled “Diagram 2. An assignment” stands for one or more assignments to different destination accounts. So, for example, TDQCalc (which is in the portion of the diagram labeled “Diagram 3”) is the sum of DrvQtyCalc (in the portion of the diagram labeled “Diagram 2”) for all outgoing assignments.
Step # | Property | Property Type | Calculation
--- | --- | --- | ---
0a. | Entered Cost | Incoming | User-entered. Entered Cost is the sum of entered cost elements for the account (a single account can have multiple entered cost elements).

0b. | Received Cost | Incoming | If we assume, for the purpose of illustration, that the account whose cost flow is being described receives all its cost from External Unit accounts, then Received Cost is the sum of received external cost elements—costs received via a BOC driver from External Unit accounts. The cost in an External Unit account is determined by its Unit Cost, which is user-entered in this module (unlike in other modules, where it is calculated).

1. | Cost | Cost in an account | Cost = Entered Cost (0a) + Received Cost (0b)
The cost in an account is the sum of its own Entered Cost (its own entered cost elements) plus its Received Cost.
<table>
<thead>
<tr>
<th>Step #</th>
<th>Property</th>
<th>Property Type</th>
<th>Calculation</th>
</tr>
</thead>
<tbody>
<tr>
<td>2a.</td>
<td>Driver Quantity Calculated</td>
<td>Assignment</td>
<td>DrvQtyCalc = (DQF x DWF)+(DQV x DWV x Dest.TDQ)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 2</td>
<td>Note: This formula does not apply to a Calculated driver—where DrvQtyCalc is determined by a user-defined formula.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>There are two kinds of quantities: fixed vs. variable. Fixed works by “push” (how much is supplied) whereas variable works by “pull” (how much is demanded). Variable requires looking forward until finding Dest.TDQ ne 0 (that is until Dest.SoldQty ne 0 or Dest.TDQUE ne 0 or Dest.TDQCln Calc ne 0). A single assignment can have both fixed and variable quantities, (it can work both by push and by pull). For more information on fixed and variable quantities, see “Fixed Driver Quantities, Variable Driver Quantities, and Weighted Driver Quantities” on page 293.</td>
</tr>
<tr>
<td>2b.</td>
<td>Idle Driver Quantity</td>
<td>Assignment</td>
<td>IdlDrvQty for an assignment is determined by its idle flow method (user-entered, user proportion, driver quantity, evenly assigned). For information, see “Idle Quantities” on page 301.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 2</td>
<td></td>
</tr>
<tr>
<td>3.</td>
<td>Driver Driven Quantity</td>
<td>Assignment</td>
<td>DrvDrvnQty = DrvQtyCalc (2a) + IdlDrvQty (2b)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 2</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Now that the system has looked at all the outgoing assignments from an account, it can calculate the quantities associated with an account’s driver.</td>
</tr>
<tr>
<td>4a.</td>
<td>TDQCalc</td>
<td>Account driver</td>
<td>TDQCalc = ∑DrvQtyCalc (2a)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 3</td>
<td>TDQCalc for a driver is the sum of DrvQtyCalc for the individual outgoing assignments of that driver.</td>
</tr>
<tr>
<td>4b.</td>
<td>Sold Quantity</td>
<td>Account driver</td>
<td>User-entered.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 3</td>
<td></td>
</tr>
<tr>
<td>5.</td>
<td>Used Quantity</td>
<td>Account driver</td>
<td>UsedQty = TDQCalc (4a) + Sold Quantity (4b)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 3</td>
<td></td>
</tr>
<tr>
<td>6.</td>
<td>Output Quantity</td>
<td>Account driver</td>
<td>Output Quantity = Used Quantity (5) unless overridden by OutQtyUE.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 3</td>
<td>In RAC modules, Output Quantity is used to determine Unit Cost according to the following formula: UnitCost = Cost/OutQty</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>In the External Unit, Unit Cost is user-entered and OutQtyUE is disallowed.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Also, UnitRevenue = Revenue / OutQty</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Also, UnitProfit = Profit / OutQty</td>
</tr>
<tr>
<td>7.</td>
<td>TDQ</td>
<td>Account driver</td>
<td>TDQ = Used Quantity (6) unless overridden by TDQUE</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 3</td>
<td></td>
</tr>
<tr>
<td>Step #</td>
<td>Property</td>
<td>Property Type</td>
<td>Calculation</td>
</tr>
<tr>
<td>--------</td>
<td>----------------</td>
<td>---------------</td>
<td>-------------</td>
</tr>
<tr>
<td>8.</td>
<td>Idle Quantity</td>
<td>Account driver</td>
<td>IdlQty = TDQ (7) – UsedQty (5)</td>
</tr>
<tr>
<td></td>
<td>Idle Percent</td>
<td>Diagram 3</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Because TDQ equals UsedQty unless overridden by TDQUE, the only way that IdlQty can be non-zero is if TDQUE is greater than UsedQty. Note: If TDQUE is less than UsedQty, then the following error message appears: “Overdriven source account. The value entered for TDQUE is less than the Driven Quantity.” IdlPcnt = 100 * IdlQty / TDQ (7)</td>
</tr>
<tr>
<td>9.</td>
<td>Assigned Idle Quantity</td>
<td>Account driver</td>
<td>AsgnIdlQty = ∑ IdlDrvQty (2b)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 3</td>
<td></td>
</tr>
<tr>
<td>10.</td>
<td>Unassigned Quantity</td>
<td>Account driver</td>
<td>UnAsgnQty = IdlQty (8) – AsgnIdlQty (9)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 3</td>
<td></td>
</tr>
<tr>
<td>11.</td>
<td>Driven Quantity</td>
<td>Account driver</td>
<td>Driven Quantity = UsedQty (5) + AsgnIdlQty (9)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 3</td>
<td></td>
</tr>
<tr>
<td>12.</td>
<td>Driver Allocated Cost</td>
<td>Assignment</td>
<td>User-entered.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 2</td>
<td></td>
</tr>
<tr>
<td>13.</td>
<td>Allocated Cost</td>
<td>Outgoing</td>
<td>AllocCost=∑ DrvAllocCost (12)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 1</td>
<td></td>
</tr>
<tr>
<td>14.</td>
<td>Drivable Cost</td>
<td>Outgoing</td>
<td>DrvblCost = Cost (1) – Allocated Cost (13)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 1</td>
<td></td>
</tr>
<tr>
<td>15.</td>
<td>Driver Rate</td>
<td>Account driver</td>
<td>Driver Rate = DrvblCost (14) / TDQ (7)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 3</td>
<td></td>
</tr>
</tbody>
</table>

Once the system has determined Driver Rate, it can calculate the costs flowing out on each outgoing assignment.
### Table

<table>
<thead>
<tr>
<th>Step #</th>
<th>Property</th>
<th>Property Type</th>
<th>Calculation</th>
</tr>
</thead>
<tbody>
<tr>
<td>16.</td>
<td>Driver Driven Cost</td>
<td>Assignment</td>
<td>Driver Driven Cost = DrvQtyCalc (2a) x Driver Rate (15)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 2</td>
<td>So, Driver Driven Cost = DrvQtyCalc (2a) x (DrvblCost/TDQ)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Also, DrvDrvnCost = DrvIdlCost (17) + DrvUsedCost (18)</td>
</tr>
<tr>
<td>17.</td>
<td>Driver Idle Cost</td>
<td>Assignment</td>
<td>DrvIdlCost = IdlDrvQty (2b) x DrvRate (15)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 2</td>
<td></td>
</tr>
<tr>
<td>18.</td>
<td>Driver Used Cost</td>
<td>Assignment</td>
<td>DrvUsedCost = DrvDrvnCost (16) – DrvIdlCost (17)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 2</td>
<td>Also, DrvUsedCost = DrvQtyCalc (2a) x DrvRate (15)</td>
</tr>
<tr>
<td>19.</td>
<td>Driver Cost</td>
<td>Assignment</td>
<td>Driver Cost = DrvAllocCost (12) + DrvDrvnCost (16)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 2</td>
<td>That is, the outgoing cost for an assignment is the sum of the cost that</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>is allocated plus the sum that is driven by the driver.</td>
</tr>
</tbody>
</table>

### Outgoing Cost

This section examines the interrelations among the following diagrams:

- “Diagram 1: Cost Flowing Into and Out of an Account” on page 623
- “Diagram 3: Account Driver Properties” on page 625
### Step # | Property | Property Type | Calculation |
---|---|---|---|
20a. | Used Cost | Outgoing | Used Cost = UsedQty (5) x DrvRate (15) |
20b. | Idle Cost | Outgoing | Idle Cost = IdlQty (8) x DrvRate (15) Also, Idle Cost = AsgnIdlCost (20c) + UnAsgnCost (22) |
20c. | Assigned Idle Cost | Outgoing | AsgnIdlCost = AsgnIdlQty (9) x DrvRate (15) Also, AsgnIdlCost = sum of DrvIdlCost (17) on outgoing assignments |
20d. | Driven Cost | Outgoing | Driven Cost = DrvnQty (11) x DrvRate (15) Also, Driven Cost = Used Cost (20a) + AsgnIdlCost (20c) |
21. | Assigned Cost | Outgoing | Assigned Cost = Allocated Cost (13) + Driven Cost (20d) |
<table>
<thead>
<tr>
<th>Step #</th>
<th>Property</th>
<th>Property Type</th>
<th>Calculation</th>
</tr>
</thead>
<tbody>
<tr>
<td>22.</td>
<td>Unassigned Cost</td>
<td>Outgoing</td>
<td>UnAsgnCost = DrvblCost (14) + AllocCost (13) – AsgnCost (21)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 1</td>
<td>Also, UnAsgnCost = Cost (1) – AsgnCost (21)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Also, UnAsgnCost = IdlCost (20b) – AsgnIdlCost (20c)</td>
</tr>
</tbody>
</table>

Next, the system looks at costs flowing into the destination account.

### Incoming Cost

This section examines the interrelations among the following diagrams:

- “Diagram 1: Cost Flowing Into and Out of an Account” on page 623
- “Diagram 2: Properties of an Assignment” on page 624

The assignment shown in this diagram stands for one or more assignments from different source accounts. For example, RcvIdlCost, in the receiving account, is the sum of DrvIdlCost in all the incoming assignments to that account.
23a. Received Idle Cost
   
   Calculation:
   \[ \text{RcvIdlCost} = \sum \text{DrvIdlCost} \]  
   
   Diagram 1

   RcvIdlCost is the sum of idle costs from individual assignments, DrvIdlCost, to the destination account.

23b. Received Used Cost
   
   Calculation:
   \[ \text{RcvUsedCost} = \sum \text{DrvUCost} \]  
   
   Diagram 1

   RcvUsedCost is the sum of used costs from individual assignments, DrvUCost, to the destination account.

23c. Received Allocated Cost
   
   Calculation:
   \[ \text{RcvAllocCost} = \sum \text{DrvAllocCost} \]  
   
   Diagram 1

   RcvAllocCost is the sum of costs allocated on individual assignments, DrvAllocCost, to the destination account.

24. Received Driven Cost
   
   Calculation:
   \[ \text{RcvDrvnCost} = \sum \text{DrvDrvnCost} \]  
   
   Diagram 1

   RcvDrvnCost is the sum of costs driven by individual assignments, DrvDrvnCost, to the destination account.

   Also, RcvDrvnCost = RcvIdlCost (23a) + RcvUsedCost (23b)
<table>
<thead>
<tr>
<th>Step #</th>
<th>Property</th>
<th>Property Type</th>
<th>Calculation</th>
</tr>
</thead>
<tbody>
<tr>
<td>25a.</td>
<td>Received BOC Cost</td>
<td>Incoming</td>
<td>RcvBOCCost is that part of RcvDrvnCost (24) that is the result of BOC drivers to the destination account.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 1</td>
<td></td>
</tr>
<tr>
<td>25b.</td>
<td>Received Assignment Cost</td>
<td>Incoming</td>
<td>RcvAsgnCost is RcvAllocCost (23c) plus that part of RcvDrvnCost (24) that is the result of non-BOC drivers to the destination account.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 1</td>
<td></td>
</tr>
<tr>
<td>26.</td>
<td>Received Cost</td>
<td>Incoming</td>
<td>Received Cost = RcvDrvnCost (24) + RcvAllocCost (23c)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Diagram 1</td>
<td>Also, Received Cost = RcvBOCCost (25a) + RcvAsgnCost (25b)</td>
</tr>
</tbody>
</table>

Now the destination account contains a cost that is equal to its Received Cost plus its own Entered Cost, and the process of examining outgoing assignments starts over until the calculation process has traversed all the accounts and all the assignments in the model.
## Properties Listed Alphabetically

<table>
<thead>
<tr>
<th>Property Name</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allocated Cost (AllocCost)</td>
<td>637</td>
</tr>
<tr>
<td>Assigned Cost (AsgnCost)</td>
<td>638</td>
</tr>
<tr>
<td>Assigned Idle Cost (AsgnIdlCost)</td>
<td>639</td>
</tr>
<tr>
<td>Assigned Idle Quantity (AsgnIdlQty)</td>
<td>640</td>
</tr>
<tr>
<td>Assigned Non Reciprocal Cost (AsgnNRecipCost)</td>
<td>640</td>
</tr>
<tr>
<td>Assigned Reciprocal Cost (AsgnRecipCost)</td>
<td>640</td>
</tr>
<tr>
<td>Calculate Error (CalcError)</td>
<td>641</td>
</tr>
<tr>
<td>Cost (Cost)</td>
<td>641</td>
</tr>
<tr>
<td>Dimension Level Name (DimLevelName)</td>
<td>642</td>
</tr>
<tr>
<td>Dimension Level Number (DimLevelNum)</td>
<td>642</td>
</tr>
<tr>
<td>Dimension Member Name (DimMemName)</td>
<td>643</td>
</tr>
<tr>
<td>Dimension Member Reference (DimMemRef)</td>
<td>643</td>
</tr>
<tr>
<td>Dimension Name (DimName)</td>
<td>644</td>
</tr>
<tr>
<td>Dimension Reference (DimRef)</td>
<td>645</td>
</tr>
<tr>
<td>Display Name (Display Name)</td>
<td>645</td>
</tr>
<tr>
<td>Display Reference (Display Reference)</td>
<td>646</td>
</tr>
<tr>
<td>Drivable Cost (DrvblCost)</td>
<td>646</td>
</tr>
<tr>
<td>Driven Cost (DrvnCost)</td>
<td>647</td>
</tr>
<tr>
<td>Driven Quantity (DrvnQty)</td>
<td>647</td>
</tr>
<tr>
<td>Driver Allocated Cost (DrvAllocCost)</td>
<td>648</td>
</tr>
<tr>
<td>Driver Cost (DrvCost)</td>
<td>648</td>
</tr>
<tr>
<td>Driver Driven Cost (DrvDrvnCost)</td>
<td>649</td>
</tr>
<tr>
<td>Driver Driven Quantity (DrvDrvnQty)</td>
<td>650</td>
</tr>
<tr>
<td>Driver Formula (DrvFormula)</td>
<td>650</td>
</tr>
<tr>
<td>Driver Idle Cost (DrvIdlCost)</td>
<td>651</td>
</tr>
<tr>
<td>Driver Name (DrvName)</td>
<td>651</td>
</tr>
<tr>
<td>Driver Percentage (DrvPct)</td>
<td>652</td>
</tr>
<tr>
<td>Driver Quantity Basic (DrvQtyBasic)</td>
<td>652</td>
</tr>
</tbody>
</table>
Driver Quantity Calculated (DrvQtyCalc) ........................................... 652
Driver Quantity Fixed (DQF) .......................................................... 653
Driver Quantity Variable (DQV) ....................................................... 654
Driver Rate (DrvRate) ........................................................................ 654
Driver Sequence Number (DrvSeq) .................................................... 655
Driver Type (DrvType) ....................................................................... 655
Driver Used Cost (DrvUsedCost) ....................................................... 656
Driver Weight Fixed (DWF) .............................................................. 656
Driver Weight Variable (DWV) .......................................................... 657
Entered Cost (EntCost) ....................................................................... 657
Fixed Driver Quantity Override (FixedDQOverride) ......................... 658
Formula (Formula) ............................................................................ 658
Has Assignments (HasAsgn) ............................................................. 659
Has Attributes (HasAttr) ................................................................. 659
Has BOC (HasBOC) ........................................................................... 659
Has Entered Cost (HasEntCost) ........................................................ 660
Has Idle Cost (HasIdlCost) ............................................................... 660
Has Notes (HasNotes) ....................................................................... 661
Has Used Cost (HasUsedCost) ......................................................... 661
Idle Cost (IdlCost) ............................................................................ 661
Idle Driver Quantity (IdlDrvQty) ....................................................... 662
Idle Driver Quantity UE (IdlQtyUE) .................................................... 663
Idle Flow Method (IdleFlow) ............................................................. 663
Idle Percentage (IdlPcnt) .................................................................. 664
Idle Quantity (IdlQty) ....................................................................... 665
Intersection Name (IntsectnName) ..................................................... 666
Intersection Reference (IntsectnRef) ................................................ 666
Is Behavior (IsBehavior) ................................................................... 667
Module Type (ModType) ................................................................... 667
Name (Name) ....................................................................................... 667
Output Quantity (OutQty) ............................................................... 668
Output Quantity UE (OutQtyUE) ....................................................... 668
Periodic Note (PerNote) ................................................................... 669
Profit (Profit) ...................................................................................... 669
Received Allocated Cost (RevAllocCost) .......................................... 669
Received Assignment Cost (RevAsgnCost) ...................................... 670
Received BOC Cost (RevBOCCost) .................................................... 671
Allocated Cost (AllocCost)

The cost that is flowing out of an account to other accounts based on the user allocation method; a direct placement of money to a specified destination account, and the remainder of the cost could be assigned using driver quantities.

The value of this property is generated by the system. You cannot change this value. It represents the sum of all user-entered allocated costs. You enter a user-entered allocated
cost by setting the value of Driver Allocated Cost (DrvAllocCost). You enable a user allocation method by checking the **Allow user-entered cost allocation** check box on the **Advanced** tab of the New Driver window. Unless you check this, Driver Allocated Cost (DrvAllocCost) is protected for the driver.

$$\text{Drivable Cost} = \text{Cost} - \text{Allocated Cost}$$

$$\text{Driver Rate} = \frac{\text{Drivable Cost}}{\text{TDQ}}$$

<table>
<thead>
<tr>
<th>Table 60.1</th>
<th>General information concerning the property</th>
</tr>
</thead>
<tbody>
<tr>
<td>System generated or user entered?</td>
<td>Calculated by system</td>
</tr>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Outgoing</td>
</tr>
</tbody>
</table>

**See Also**

- “User-Entered Cost Allocation” on page 292
- “Create a Driver” on page 317

**Assigned Cost (AsgnCost)**

The cost that is flowing out of a cost element or account to other cost elements or accounts; the cost flowing out of an account to other accounts based on the driver method.

Assigned cost is calculated according to the following formula:
Assigned Cost = Driven Cost + Allocated Cost

Table 60.2 General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Outgoing</td>
</tr>
</tbody>
</table>

See Also

- “Types of Costs” on page 618
- “Assigned Reciprocal Cost (AsgnRecipCost)” on page 640
- “Received Cost (RcvCost)” on page 672

Assigned Idle Cost (AsgnIdlCost)

The sum of costs on outgoing assignments where those costs are due to the source account's idle flow behavior.

Assigned Idle Cost is calculated according to the following formula:

\[
\text{Asgn IdlCost} = \text{(sum of DrvIdleCost of destination side accounts)}
\]

Table 60.3 General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Outgoing</td>
</tr>
</tbody>
</table>

See Also

- “Types of Costs” on page 618
- “Idle Quantities” on page 301
- “Idle Flow” on page 414
Assigned Idle Quantity (AsgnIdlQty)

The amount of an account's idle quantity that causes cost on outgoing assignments because of the account's idle flow behavior.

Table 60.4  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Outgoing</td>
</tr>
</tbody>
</table>

See Also

- “Idle Quantities” on page 301
- “Idle Flow” on page 414

Assigned Non Reciprocal Cost (AsgnNRecipCost)

The sum of costs on an account's outgoing assignments where the destination accounts are not part of the same reciprocal system as the source account.

Table 60.5  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Outgoing</td>
</tr>
</tbody>
</table>

Assigned Reciprocal Cost (AsgnRecipCost)

The assigned cost that is flowing from a reciprocal account to other reciprocal accounts. For a non-reciprocal account, this value is NULL.
Table 60.6  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Generated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Outgoing</td>
</tr>
</tbody>
</table>

See Also

- “Reciprocal Costing” on page 307
- “Cost (Cost)” on page 641
- “Received Reciprocal Cost (RevRecipCost)” on page 674

Calculate Error (CalcError)

The error status for a calculated driver or calculated attribute value.

This property rolls up in the module view and displays the highest priority error at the module level. This error information can be useful when debugging calculation errors.

Note: Although an error (for example, dividing by zero) can occur on an assignment using a calculated driver from one source account and not on another assignment from the same source account, the Calculate Error property applies to the source account and not to the particular assignment.

Table 60.7  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Generated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Outgoing</td>
</tr>
</tbody>
</table>

Cost (Cost)

The calculated cost of a cost element or account.

Cost is calculated according to the following formula:

\[
\text{Cost} = \text{EnteredCost} + \text{Received Cost}
\]

in more detail:

\[
\text{Cost} = \text{EnteredCost} + \text{ReceivedAssignmentCost} + \text{Received BOC cost}
\]
Table 60.8  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>You can change this value only for entered cost elements. All other values of this property are generated by the system. You cannot change those values.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Account</td>
</tr>
</tbody>
</table>

See Also

- Chapter 36, “Calculation,” on page 395
- “Assigned Reciprocal Cost (AsgnRecipCost)” on page 640
- “Received Cost (RcvCost)” on page 672

Dimension Level Name (DimLevelName)

The name of the level for the dimension that completes an intersection.

Table 60.9  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User specifiable. But this property is read-only in a module view.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>The maximum length is 64 alphanumeric Unicode characters</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>N/A</td>
</tr>
</tbody>
</table>

When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

See Also

- “Measures and Dimensions” on page 123
- “Dimension Level Number (DimLevelNum)” on page 642

Dimension Level Number (DimLevelNum)

The depth in the dimension hierarchy of the dimension that completes an intersection.
Table 60.10  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Generated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>4-byte integer value</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>N/A</td>
</tr>
</tbody>
</table>

See Also

- “Measures and Dimensions” on page 123
- “Dimension Level Name (DimLevelName)” on page 642

Dimension Member Name (DimMemName)

The name of the dimension member that defines an account (dimensional intersection).

Table 60.11  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User specifiable, but not in a column layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>The maximum length is 64 alphanumeric Unicode characters</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>N/A</td>
</tr>
</tbody>
</table>

When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

See Also

- “Measures and Dimensions” on page 123
- “Dimension Member Reference (DimMemRef)” on page 643

Dimension Member Reference (DimMemRef)

The reference of the dimension member that defines an account (dimensional intersection).
Table 60.12  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User specifiable, but not in a column layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>The maximum length is 64 alphanumeric Unicode characters.</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>N/A</td>
</tr>
</tbody>
</table>

When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

See Also

- “Measures and Dimensions” on page 123
- “Dimension Member Name (DimMemName)” on page 643

Dimension Name (DimName)

The name of the dimension that completes an intersection.

Table 60.13  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User specifiable, but not in a column layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>The maximum length is 64 alphanumeric Unicode characters.</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>N/A</td>
</tr>
</tbody>
</table>

When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

See Also

- “Measures and Dimensions” on page 123
- “Dimension Reference (DimRef)” on page 645
Dimension Reference (DimRef)

**Table 60.14  General information concerning the property**

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User specifiable, but not in a column layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>The maximum length is 64 alphanumeric Unicode characters</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>N/A</td>
</tr>
</tbody>
</table>

When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

**See Also**
- “Measures and Dimensions” on page 123
- “Dimension Name (DimName)” on page 644

Display Name (Display Name)

The name for the displayed item.

**Table 60.15  General information concerning the property**

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Generated by system. However, you can change Name.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>The maximum length is 64 alphanumeric Unicode characters</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>N/A</td>
</tr>
</tbody>
</table>

When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

**See Also**

“Display Reference (Display Reference)” on page 646
Display Reference (Display Reference)

The reference for the displayed item.

**Table 60.16  General information concerning the property**

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Generated by system. However, you can change Reference.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>The maximum length is 64 alphanumeric Unicode characters.</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>N/A</td>
</tr>
</tbody>
</table>

When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

**See Also**

“Display Name (Display Name)” on page 645

**Drivable Cost (DrvblCost)**

The remainder of an account’s cost that can be assigned by its driver after subtracting user-allocated costs.

You cannot change this value. It is generated by the system according to the following formula:

\[
\text{DrivableCost} = \text{Cost} - \text{AllocatedCost}
\]

Also:

\[
\text{DrivableCost} = \text{UsedCost} + \text{IdleCost}
\]

**Table 60.17  General information concerning the property**

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Outgoing</td>
</tr>
</tbody>
</table>
Driven Cost (DrvnCost)

The amount of cost that is driven by the account's driver, including both Used Cost and Assigned Idle Cost.

Driven Cost is calculated according to the following formula:

\[
\text{Driven Cost} = \text{Used Cost} + \text{Assigned Idle Cost}
\]

<table>
<thead>
<tr>
<th><strong>Table 60.18</strong></th>
<th>General information concerning the property</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>System generated or user entered?</strong></td>
<td>Calculated by system</td>
</tr>
<tr>
<td><strong>Default format in a column layout:</strong></td>
<td>Currency</td>
</tr>
<tr>
<td><strong>Data type:</strong></td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td><strong>Type of property in an assignments pane:</strong></td>
<td>Outgoing</td>
</tr>
</tbody>
</table>

See Also

- “Used Cost (UsedCost)” on page 684
- “Assigned Idle Cost (AsgnIdlCost)” on page 639

Driven Quantity (DrvnQty)

The sum of the driver quantity on an account's outgoing assignments, including both Used Quantity and Assigned Idle Quantity.

The value of this property is generated by the system. You cannot change this value. It is defined by the following formula:

\[
\text{DrivenQuantity} = \text{AssignedIdleQty} + \text{UsedQuantity}
\]

<table>
<thead>
<tr>
<th><strong>Table 60.19</strong></th>
<th>General information concerning the property</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>System generated or user entered?</strong></td>
<td>Calculated by system</td>
</tr>
<tr>
<td><strong>Default format in a column layout:</strong></td>
<td>Number</td>
</tr>
<tr>
<td><strong>Data type:</strong></td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td><strong>Type of property in an assignments pane:</strong></td>
<td>Outgoing</td>
</tr>
</tbody>
</table>
Driver Allocated Cost (DrvAllocCost)

The user-entered Allocated Cost value on an assignment path.

You enable the setting of Driver Allocated Cost by checking the Allow user-entered cost allocation check box on the Advanced tab of the New Driver window. Unless you check this, Driver Allocated Cost is protected for the driver.

Table 60.20 General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User-entered</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Assignment</td>
</tr>
</tbody>
</table>

See Also

“Create a Driver” on page 317

Driver Cost (DrvCost)

The cost that is flowing out of or flowing into an account through an assignment.

Driver Cost is calculated according to the following formula:
Driver Cost = (Driver Driven Cost + Driver Allocated Cost)

**Table 60.21  General information concerning the property**

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Assignment</td>
</tr>
</tbody>
</table>

**See Also**

- “Using a Weighted Driver with Fixed and Variable Driver Quantities” on page 413
- “Step 12–DrvCost for Paths to Activity Accounts” on page 431
- “Step 16–DrvCost for Paths to Cost Object Accounts” on page 435
- “Cost (Cost)” on page 641

**Driver Driven Cost (DrvDrvnCost)**

The assigned cost that is flowing on an assignment path, including both Used Cost and Assigned Idle Cost.

Driver Driven Cost is calculated according to the following formula:

Driver Driven Cost = (Driver Used Cost + Driver Idle Cost)

Also:

Driver Driven Cost = (DrvDrvnQty * Driver Rate)

**Table 60.22  General information concerning the property**

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Assignment</td>
</tr>
</tbody>
</table>

**See Also**

- “Cost (Cost)” on page 641
- “Step 11–DrvDrvnCost for Paths to Activity Accounts” on page 430
- “Step 15–DrvDrvnCost for Paths to Cost Object Accounts” on page 434
**Driver Driven Quantity (DrvDrvnQty)**

The assigned quantity that is flowing on an assignment path, including both Used Quantity and Assigned Idle Quantity.

Driver Driven Quantity is calculated according to the following formula:

\[
\text{DrvDrvnQty} = \text{DrvQtyCalc} + \text{IdleDrvQty}
\]

**Table 60.23  General information concerning the property**

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Assignment</td>
</tr>
</tbody>
</table>

**Driver Formula (DrvFormula)**

The formula that is attached to a source account's driver.

**Table 60.24  General information concerning the property**

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User specifiable. But you cannot change this value in the column layout for a module view. You can change it only in the Driver properties dialog.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>Large text value</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Driver</td>
</tr>
</tbody>
</table>

When you import or export model data, this value must translate into the TEXT or NTEXT data types in Microsoft SQL Server.

**See Also**

- “Calculated Drivers” on page 273
- “Formula (Formula)” on page 658
Driver Idle Cost (DrvIdlCost)

A source account's Idle Cost. The assigned idle cost that is flowing on an assignment path.

Driver Idle Cost is calculated according to the following formula:

\[ \text{Driver Idle Cost} = \text{Idle DriverQty} \times \text{Driver Rate} \]

Table 60.25 General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Assignment</td>
</tr>
</tbody>
</table>

See Also

- “Driver Cost (DrvCost)” on page 648
- “Idle Quantities” on page 301
- “Idle Flow” on page 414

Driver Name (DrvName)

Driver Name (DrvName) The name of the driver that is associated with an account.

Table 60.26 General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>You can change this value only on accounts and external units.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>The maximum length is 64 alphanumeric Unicode characters.</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Driver</td>
</tr>
</tbody>
</table>

When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.
Driver Percentage (DrvPcnt)

The percentage of the total driver quantity for an assignment.

Table 60.27  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Assignment</td>
</tr>
</tbody>
</table>

Driver Quantity Basic (DrvQtyBasic)

The sum of the fixed and variable quantities that flows from one account to another.

Driver Quantity Basic is calculated according to the following formula:

\[ DQ_{\text{Basic}} = DQ_F + DQ_V \times \text{Dest.TDQ} \]

Table 60.28  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Assignment</td>
</tr>
</tbody>
</table>

See Also

- “Comparing Driver Types” on page 289
- “Driver Quantity Calculated (DrvQtyCalc)” on page 652
- “Driver Quantity Fixed (DQF)” on page 653
- “Driver Quantity Variable (DQV)” on page 654

Driver Quantity Calculated (DrvQtyCalc)

The calculated quantity that flows from one account to another.
The value of this property is generated by the system. You cannot change this value. It is calculated according to the following formula:

\[ \text{DrvQtyCalc} = (\text{DQF} \times \text{DWF}) + (\text{DQV} \times \text{DWV} \times \text{Dest.TDQ}) \]

**Table 60.29  General information concerning the property**

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Assignment</td>
</tr>
</tbody>
</table>

**See Also**

- “Comparing Driver Types” on page 289
- Chapter 38, “Detailed Example of Calculation,” on page 417
- “Driver Quantity Basic (DrvQtyBasic)” on page 652
- “Driver Quantity Fixed (DQF)” on page 653
- “Driver Quantity Variable (DQV)” on page 654

**Driver Quantity Fixed (DQF)**

The user-entered fixed quantity that flows from one account to another.

**Table 60.30  General information concerning the property**

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>You can change this value only on assigned cost elements with a driver that allows fixed driver quantities.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Assignment</td>
</tr>
</tbody>
</table>

**See Also**

- “Fixed Driver Quantities, Variable Driver Quantities, and Weighted Driver Quantities” on page 293
- “Driver Quantity Basic (DrvQtyBasic)” on page 652
- “Driver Quantity Calculated (DrvQtyCalc)” on page 652
- “Driver Quantity Variable (DQV)” on page 654
Driver Quantity Variable (DQV)

The user-entered variable quantity that flows from one account to another.

Table 60.31 General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>You can change this value only on assigned cost elements with a driver that allows variable driver quantities.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Assignment</td>
</tr>
</tbody>
</table>

See Also

- “Fixed Driver Quantities, Variable Driver Quantities, and Weighted Driver Quantities” on page 293
- “Driver Quantity Basic (DrvQtyBasic)” on page 652
- “Driver Quantity Calculated (DrvQtyCalc)” on page 652
- “Driver Quantity Fixed (DQF)” on page 653

Driver Rate (DrvRate)

The calculated price per unit for assigned costs. The calculated cost per driver quantity unit for assignments. It is calculated according to the following formula:

\[
\text{DriverRate} = \begin{cases} 
\text{UnitCostEntered} & \text{if } \text{ExternalUnit} \\
\frac{\text{DrivableCost}}{\text{TDQ}} & \text{otherwise}
\end{cases}
\]

And:

\[
\text{DrivableCost} = \text{Cost} - \text{AllocatedCost}
\]

Table 60.32 General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Outgoing</td>
</tr>
</tbody>
</table>
Driver Sequence Number (DrvSeq)

The sequence number that is associated with a source account's driver.

Table 60.33  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User specifiable, but not in a column layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>4-byte integer value</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Driver</td>
</tr>
</tbody>
</table>

See Also

“Driver Sequencing” on page 298

Driver Type (DrvType)

The type of driver: Basic, Bill of Cost, Calculated, Evenly Assigned, Percentage, Sales Volume, or Weighted. The default driver is Basic.

Table 60.34  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User specifiable. But this property is read-only in a column-layout.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>The maximum length is 64 alphanumeric Unicode characters.</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Driver</td>
</tr>
</tbody>
</table>

When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

See Also

Chapter 26, “Types of Drivers,” on page 269
Driver Used Cost (DrvUsedCost)

The sum of costs on an account's outgoing assignments that is caused by the account's driver. This amount does not include Allocated Cost or Idle Cost.

Driver Used Cost is calculated according to the following formula:

\[ \text{Driver Used Cost} = \text{DriverQtyCalc} \times \text{Driver Rate} \]

or, the following formula if there is no SoldQuantity

\[ \text{DriverUsedCost} = \text{DrivableCost} \times \frac{\text{DQcalc}}{\text{TQCalc}} \]

Table 60.35  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Assignment</td>
</tr>
</tbody>
</table>

Driver Weight Fixed (DWF)

The numeric factor that modifies a fixed driver quantity. The default weight is 1.

Table 60.36  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>You can change this value only on assigned cost elements with a driver that allows fixed driver weights.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Assignment</td>
</tr>
</tbody>
</table>

See Also

- “Fixed Driver Quantities, Variable Driver Quantities, and Weighted Driver Quantities” on page 293
- “Driver Weight Variable (DWV)” on page 657
Driver Weight Variable (DWV)

The numeric factor that modifies a variable driver quantity. The default weight is 1.

<table>
<thead>
<tr>
<th>Table 60.37</th>
<th>General information concerning the property</th>
</tr>
</thead>
<tbody>
<tr>
<td>System generated or user entered?</td>
<td>You can change this value only on assigned cost elements with a driver that allows variable driver weights.</td>
</tr>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Assignment</td>
</tr>
</tbody>
</table>

See Also

- “Fixed Driver Quantities, Variable Driver Quantities, and Weighted Driver Quantities” on page 293
- “Driver Weight Fixed (DWF)” on page 656

Entered Cost (EntCost)

The user-entered cost for a cost element or the calculated total of all account entered cost elements for a roll-up account.

<table>
<thead>
<tr>
<th>Table 60.38</th>
<th>General information concerning the property</th>
</tr>
</thead>
<tbody>
<tr>
<td>System generated or user entered?</td>
<td>User specifiable</td>
</tr>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Account</td>
</tr>
</tbody>
</table>

See Also

- Chapter 17, “Working with Cost Elements,” on page 175
- “Cost (Cost)” on page 641
Fixed Driver Quantity Override (FixedDQOverride)

For a sequenced driver, the name of the property that replaces the Driver Quantity Fixed value after the previous sequence pass.

Table 60.39  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User specifiable, but not in a column layout.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>The maximum length is 64 alphanumeric Unicode characters.</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>N/A</td>
</tr>
</tbody>
</table>

When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

See Also

• “Driver Sequencing” on page 298
• “Variable Driver Quantity Override (VariableDQOverride)” on page 687

Formula (Formula)

The formula for a calculated driver or calculated attribute.

Table 60.40  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User specifiable, but not in column layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>This is a large text-based value.</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>N/A</td>
</tr>
</tbody>
</table>

When you import or export model data, this value must translate into the TEXT or NTEXT data types in Microsoft SQL Server.

See Also

• Chapter 29, “Formulas,” on page 329
• “Calculated Drivers” on page 273
Has Assignments (HasAsgn)

Indicates whether an account receives costs from another account.

<table>
<thead>
<tr>
<th>Table 60.41 General information concerning the property</th>
</tr>
</thead>
<tbody>
<tr>
<td>System generated or user entered?</td>
</tr>
<tr>
<td>Default format in a column layout:</td>
</tr>
<tr>
<td>Data type:</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
</tr>
</tbody>
</table>

Has Attributes (HasAttr)

Indicates whether an item has at least one attribute.

<table>
<thead>
<tr>
<th>Table 60.42 General information concerning the property</th>
</tr>
</thead>
<tbody>
<tr>
<td>System generated or user entered?</td>
</tr>
<tr>
<td>Default format in a column layout:</td>
</tr>
<tr>
<td>Data type:</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
</tr>
</tbody>
</table>

Has BOC (HasBOC)

Indicates whether an account receives at least one bill of costs from the External Unit.

<table>
<thead>
<tr>
<th>Table 60.43 General information concerning the property</th>
</tr>
</thead>
<tbody>
<tr>
<td>System generated or user entered?</td>
</tr>
<tr>
<td>Default format in a column layout:</td>
</tr>
<tr>
<td>Data type:</td>
</tr>
</tbody>
</table>
Type of property in an assignments pane: incoming

See Also

“Bill of Costs Drivers” on page 271

Has Entered Cost (HasEntCost)

Indicates whether an account has at least one user-entered cost element.

*Table 60.44  General information concerning the property*

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>System generated</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Checkbox</td>
</tr>
<tr>
<td>Data type:</td>
<td>Boolean</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Account</td>
</tr>
</tbody>
</table>

See Also

Chapter 17, “Working with Cost Elements,” on page 175

Has Idle Cost (HasIdlCost)

Indicates whether an item has a non-zero idle cost—that is, costs that don’t flow to other accounts.

*Table 60.45  General information concerning the property*

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>System generated</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Checkbox</td>
</tr>
<tr>
<td>Data type:</td>
<td>Boolean</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>outgoing</td>
</tr>
</tbody>
</table>

See Also

- “Idle Quantities” on page 301
- “Idle Flow” on page 414
Has Notes (HasNotes)

Indicates whether an item has a Periodic Note.

<table>
<thead>
<tr>
<th>Table 60.46</th>
<th>General information concerning the property</th>
</tr>
</thead>
<tbody>
<tr>
<td>System generated or user entered?</td>
<td>System generated</td>
</tr>
<tr>
<td>Default format in a column layout:</td>
<td>Checkbox</td>
</tr>
<tr>
<td>Data type:</td>
<td>Boolean</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>N/A</td>
</tr>
</tbody>
</table>

Has Used Cost (HasUsedCost)

Indicates whether an item has a non-zero used cost—that is, it flows costs to other accounts.

<table>
<thead>
<tr>
<th>Table 60.47</th>
<th>General information concerning the property</th>
</tr>
</thead>
<tbody>
<tr>
<td>System generated or user entered?</td>
<td>Calculated by system</td>
</tr>
<tr>
<td>Default format in a column layout:</td>
<td>Checkbox</td>
</tr>
<tr>
<td>Data type:</td>
<td>Boolean</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>outgoing</td>
</tr>
</tbody>
</table>

Idle Cost (IdlCost)

The idle cost is the remaining cost after all direct assignments have been made; the calculated cost that does not flow out of an account. It is the account unit cost x idle quantity (where idle quantity = user-entered total driver quantity – output quantity). Or, more succinctly:

\[
\text{Idle Cost} = \text{IdlQty} \times \text{Driver Rate}
\]

Also:

\[
\text{Idle Cost} = \text{AssignedIdleCost} + \text{UnassignedCost}
\]

Also:

\[
\text{IdleCost} = \text{IdleQty} \times \text{Driver Rate}
\]
This remaining cost can be assigned using a specific idle cost flow method (driver, percentage, user-entered, or evenly).

Table 60.48 General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Outgoing</td>
</tr>
</tbody>
</table>

See Also

- “Idle Quantities” on page 301
- “Idle Flow” on page 414
- “Cost (Cost)” on page 641
- “Idle Quantity (IdlQty)” on page 665
- “Idle Percentage (IdlPcnt)” on page 664

**Idle Driver Quantity (IdlDrvQty)**

The quantity that is due to the source account’s idle flow behavior and that causes cost on an assignment path.

Idle Driver Quantity is calculated according to the following formula:

\[
\text{Idle Driver Quantity} = \text{Idle Driver Quantity UE}
\]

Table 60.49 General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Assignment</td>
</tr>
</tbody>
</table>

See Also

- “Idle Quantities” on page 301
- “Idle Flow” on page 414
- “Idle Driver Quantity UE (IdlQtyUE)” on page 663
- “Idle Flow Method (IdleFlow)” on page 663
Idle Driver Quantity UE (IdlQtyUE)

The optional, user-entered idle driver quantity value for assigned cost elements and internal cost elements.

This value is used to drive idle costs that are based on source account's idle flow behavior.

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User specifiable</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Assignment</td>
</tr>
</tbody>
</table>

See Also

- “Idle Quantities” on page 301
- “Idle Flow” on page 414
- “Idle Driver Quantity (IdlDrvQty)” on page 662
- “Idle Flow Method (IdleFlow)” on page 663

Idle Flow Method (IdleFlow)

The method by which idle cost through a driver is calculated for a source account's outgoing assignments.

Interactively within the interface, the values can be: User Entered, User Proportion, User Driver Quantities, and Evenly Assigned. The default is User Entered. The Idle Flow Method is specified in a drop-down box on the Advanced tab of the Driver Properties window.
When you import model data, the values can be: Don’t Assign, Evenly Assigned, User Driver Quantities, User Entered, User Proportion. The default is Don’t Assign.

### Table 60.51 General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User specifiable, but not in a column layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>The maximum length is 64 alphanumeric Unicode characters.</td>
</tr>
<tr>
<td>Type of property in an assignments pane</td>
<td>Driver</td>
</tr>
</tbody>
</table>

When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

**See Also**

- “Idle Quantities” on page 301
- “Idle Flow” on page 414

### Idle Percentage (IdlPcnt)

The calculated percentage of an account’s cost that does not flow out of the account. The idle percentage is the remaining cost after all direct assignments have been made. It is 100 - (user-entered total driver quantity - calculated total driver quantity)/user-entered total driver quantity.

Idle Percentage is calculated according to the following formula:

\[
\text{IdlePercentage} = \frac{\text{IdleQty}}{\text{TDQ}}
\]
Idle Quantity (IdlQty)

The calculated amount of an account's quantity that does not flow out of the account. The idle quantity is the remaining cost after all direct assignments have been made. It is (user-entered total driver quantity – output quantity).

\[
\text{IdlQty} = \text{TDQUE} - \text{OutQty}
\]

If TDQUE > OutputQty then Positive Idle

If TDQUE < OutputQty / OutputQtyUE then Negative Idle

### See Also

- “Idle Quantities” on page 301
- “Idle Flow” on page 414
- “Idle Cost (IdlCost)” on page 661
- “Idle Quantity (IdlQty)” on page 665
Intersection Name (IntsctnName)

The concatenation of all the names of the dimensions that intersect to create an item. Each name is separated by a special character.

**Table 60.54  General information concerning the property**

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>System generated</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>The maximum length is 64 alphanumeric Unicode characters.</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>N/A</td>
</tr>
</tbody>
</table>

When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

**See Also**

“Intersection Reference (IntsctnRef)” on page 666

Intersection Reference (IntsctnRef)

The concatenation of all the references of the dimension members that intersect to create an item. Each reference is separated by a special character.

**Table 60.55  General information concerning the property**

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>System generated</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>The maximum length is 64 alphanumeric Unicode characters.</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>N/A</td>
</tr>
</tbody>
</table>

When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

**See Also**

“Intersection Name (IntsctnName)” on page 666
Is Behavior (IsBehavior)

Indicates whether an account is flagged for use with SAS Profitability Management. See “Publish Behaviors to SAS Profitability Management” on page 539.

Table 60.56  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>System generated</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Checkbox</td>
</tr>
<tr>
<td>Data type:</td>
<td>Boolean</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Account</td>
</tr>
</tbody>
</table>

Module Type (ModType)

The type of module: Resource, Activity, Cost Object, External Units, or Profitability. (The Profitability value supports the Sales Volume driver.)

Table 60.57  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Generated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>64–byte alphanumeric Unicode characters.</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>N/A</td>
</tr>
</tbody>
</table>

When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

Name (Name)

The user-entered or default name of an item.

Table 60.58  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User specifiable. You can change this value for any item except external unit cost elements, internal cost elements, and assignments, which are generated by the system.</th>
</tr>
</thead>
</table>
Default format in a column layout: Text

Data type: The maximum length is 64 alphanumeric Unicode characters.

Type of property in an assignments pane: N/A

When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

See Also
“Reference (Reference)” on page 675

Output Quantity (OutQty)

The calculated amount that is produced for an account for a period/scenario association, or the user-entered amount (Output Quantity UE). The user-entered amount overrides the calculated amount.

You cannot change this value. It is generated by the system according to the following formula:

\[
\text{OutputQty} = \begin{cases} 
\text{OutputQtyUE} & \text{if OutputQtyUE is not null} \\
\text{UsedQty} & \text{else}
\end{cases}
\]

Table 60.59  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Account</td>
</tr>
</tbody>
</table>

Output Quantity UE (OutQtyUE)

The user-entered output quantity.

Table 60.60  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User specifiable</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Account</td>
</tr>
</tbody>
</table>
See Also

“Output Quantity (OutQty)” on page 668

Periodic Note (PerNote)

The period or scenario information that is attached to an item.

Table 60.61 General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User specifiable, but not in a column layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>The maximum length is 32,000 alphanumeric Unicode characters.</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>N/A</td>
</tr>
</tbody>
</table>

See Also

“Has Notes (HasNotes)” on page 661

Profit (Profit)

The calculated difference between revenue and cost.

Table 60.62 General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Account</td>
</tr>
</tbody>
</table>

Received Allocated Cost (RcvAllocCost)

The calculated cost of all allocated cost elements within an account. The sum of all allocated costs that flows into an account.
Note: You enable allocated cost elements by checking the **Allow user-entered cost allocation** check box on the **Advanced** tab of the New Driver window.

**Table 60.63**  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Incoming</td>
</tr>
</tbody>
</table>

**Received Assignment Cost (RcvAsgnCost)**

The calculated cost of all assigned cost elements within an account.

Assignment costs result from non-BOC driver assignments. They satisfy the following two conditions:

- The contributing account is in the Resource, Activity, or Cost Object module.
- The driver is a non-BOC driver (i.e., one of the following: Basic, Calculated, Evenly Assigned, Percentage, Sales Volume, or Weighted).

The Received Assignment Cost is the sum of:

**Cross module assignments**
- From an account in one module (Resource, Activity, or Cost Object) to an account in a different module.

**Inner module assignments**
- From an account in one module (Resource, Activity, or Cost Object) to an account in the same module.
Table 60.64  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Incoming</td>
</tr>
</tbody>
</table>

Received BOC Cost (RcvBOCCost)

The calculated cost of all cost elements that use the bill of cost driver within an account. This property of an account is the sum of:

**External Unit cost elements**
Assignments, using a BOC driver, to that account from accounts in an External Unit.

All assignments from an External Unit use Bill of Costs (BOC) drivers.

**Internal cost elements**
Assignments, using a BOC driver, to that account from accounts in the Resource, Activity, or Cost Object modules. Such assignments can be either:
Cross Module

From an account in one module to an account in a different module. Inner Module

Inner Module

From an account in one module to an account in the same module.

Table 60.65  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Incoming</td>
</tr>
</tbody>
</table>

Received Cost (RcvCost)

The calculated cost that is received by an account from all assignments.

Received Cost is calculated according to the following formula:

Received Cost = (Received BOC Cost + Received Assignment Cost)

Also:
Received Cost = (Received Driven Cost + Received Allocated Cost)

**Table 60.66  General information concerning the property**

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>System generated or user entered?</td>
<td>Calculated by system</td>
</tr>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Incoming</td>
</tr>
</tbody>
</table>

**Received Driven Cost (RcvDrvCost)**

The sum of costs of assignments to an account that is specifically caused by driver quantities and by excluding allocated cost amounts.

**Table 60.67  General information concerning the property**

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>System generated or user entered?</td>
<td>Calculated by system</td>
</tr>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Incoming</td>
</tr>
</tbody>
</table>

**Received Idle Cost (RcvIdlCost)**

The cost amounts on assignments to an account that are caused by the source accounts' idle flow behaviors.

This value appears only on a cost element, not on an account.

**Table 60.68  General information concerning the property**

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>System generated or user entered?</td>
<td>Calculated by system</td>
</tr>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Incoming</td>
</tr>
</tbody>
</table>
Received Non Reciprocal Cost (RcvNRecipCost)

The calculated difference between the cost that is received by an account from all assignments and the cost that is received from all reciprocal assignments.

*Table 60.69  General information concerning the property*

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Incoming</td>
</tr>
</tbody>
</table>

See Also

“Received Reciprocal Cost (RcvRecipCost)” on page 674

Received Reciprocal Cost (RcvRecipCost)

The calculated cost that an account receives from other accounts in the same reciprocal system.

*Table 60.70  General information concerning the property*

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Incoming</td>
</tr>
</tbody>
</table>

See Also

“Received Non Reciprocal Cost (RcvNRecipCost)” on page 674

Received Used Cost (RcvUcost)

The cost amounts on assignments to an account that are caused by non-idle driver quantities (Driver Quantity Calculated).

This value appears only on a cost element, not on an account.
**Table 60.71  General information concerning the property**

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Incoming</td>
</tr>
</tbody>
</table>

**Reference (Reference)**

The user-entered or default label that uniquely identifies an item.

**Table 60.72  General information concerning the property**

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>You can change this value for any item except external unit cost elements, internal cost elements, and assignments, which are generated by the system.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>The maximum length is 64 alphanumeric Unicode characters</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>N/A</td>
</tr>
</tbody>
</table>

When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

**See Also**

“Name (Name)” on page 667

**Revenue (Revenue)**

The user-entered revenue.

**Table 60.73  General information concerning the property**

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User specifiable</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Account</td>
</tr>
</tbody>
</table>
Rule Formula (RuleFormula)

The formula that is attached to a driver and is used to generate assignments from accounts to which the driver is attached to destination accounts that satisfy the formula. For information, see “Rule-based Drivers” on page 281.

You specify this property by checking the Used Rule Formula check box on the General tab of the New Driver window or the Driver Properties window and then clicking Formula Builder.

This property is displayed on the drivers page as RuleFormula:

See Also

“Use Rule Formula (UseRuleFormula)” on page 685

Sold Quantity (SoldQty)

The user-entered number of units sold.

Table 60.74  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User specifiable</th>
</tr>
</thead>
</table>
The calculated output quantity or the user-entered total driver quantity (Total Driver Quantity UE (TDQUE)). The user-entered amount overrides the calculated amount.

You cannot change this value. It is generated by the system according to the following formula:

\[
\text{TDQ} = \begin{cases} 
\text{TDQUE} & \text{if TDQUE is not null} \\
\text{UsedQty} & \text{otherwise}
\end{cases}
\]

### Total Driver Quantity Basic (TDQBasic)

The calculated quantity of all outgoing Basic driver quantities (Driver Quantity Basic) for an account.
Table 60.76  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Outgoing</td>
</tr>
</tbody>
</table>

See Also

- “Comparing Driver Types” on page 289
- “Total Driver Quantity (TDQ)” on page 677
- “Total Driver Quantity Calculated (TDQCalc)” on page 678
- “Total Driver Quantity UE (TDQUE)” on page 678

Total Driver Quantity Calculated (TDQCalc)

The calculated quantity of all outgoing Calculated driver quantities (Driver Quantity Calculated) for an account.

Table 60.77  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Outgoing</td>
</tr>
</tbody>
</table>

See Also

- “Comparing Driver Types” on page 289
- “Total Driver Quantity (TDQ)” on page 677
- “Total Driver Quantity UE (TDQUE)” on page 678
- “Total Driver Quantity Basic (TDQBasic)” on page 677
- “Total Driver Quantity UE (TDQUE)” on page 678

Total Driver Quantity UE (TDQUE)

The user-entered total driver quantity.
Note: You can not set TDQUE for the following drivers: Percentage, Evenly Assigned. TDQUE is also not specifiable in the External Unit.

Table 60.78 General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>You cannot change this value for accounts with a driver type of Evenly Assigned, Sales Volume, or Percentage.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Outgoing</td>
</tr>
</tbody>
</table>

See Also

- “Comparing Driver Types” on page 289
- “Total Driver Quantity (TDQ)” on page 677
- “Total Driver Quantity Calculated (TDQCalc)” on page 678

Type (Type)

The type of item.

Table 60.79 General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User specifiable, but not in a column layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>4-byte integer value</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>N/A</td>
</tr>
</tbody>
</table>

Unassigned Cost (UnAsgnCost)

The calculated cost that does not flow out of an account.

Unassigned Cost is calculated according to the following formula:

Unassigned Cost = Cost - Assigned Cost

Table 60.80 General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
</table>
**Unassigned Quantity (UnAsgnQty)**

The calculated number of driver quantity units that do not cause cost on an account's outgoing assignments.

Unassigned Quantity is calculated according to the following formula:

\[
\text{UnassignedQty} = (\text{OutputQty} - \text{UsedQty} + \text{UnassignedIdleQty})
\]

**Table 60.81  General information concerning the property**

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Outgoing</td>
</tr>
</tbody>
</table>

**See Also**

- “Assigned Cost (AsgnCost)” on page 638
- “Unassigned Quantity (UnAsgnQty)” on page 680

**Unique Driver Quantities (UniqDvrQty)**

Indicates whether a driver quantity is not shared by assignments from other accounts.

**Table 60.82  General information concerning the property**

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User specifiable, but not in a column layout.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Checkbox</td>
</tr>
<tr>
<td>Data type:</td>
<td>Boolean</td>
</tr>
</tbody>
</table>
Unit Cost (UnitCost)

The calculated cost of one unit. It is calculated according to the following formula:

\[
\text{UnitCost} = \begin{cases} 
\text{UnitCostEntered} & \text{IF ExternalUnit} \\
\frac{\text{DrivableCost}}{\text{OutputQty}} & \text{ELSE}
\end{cases}
\]

And:

\[
\text{OutputQty} = \begin{cases} 
\text{OutputQtyUE is not null} & \text{THEN OutputQtyUE} \\
\text{UsedQty} & \text{ELSE}
\end{cases}
\]

So:

\[
\text{UnitCost} = \begin{cases} 
\text{IF ExternalUnit} & \text{THEN UnitCostEntered} \\
\frac{\text{DrivableCost}}{\text{UsedQty}} & \text{ELSE}
\end{cases}
\]

Remember:

\[
\text{DrivableCost} = \text{Cost} - \text{AllocatedCost}
\]

Unit Cost is used to drive Sales Volume Cost and External Bills of Cost.

Table 60.83  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Outgoing</td>
</tr>
</tbody>
</table>

Unit Of Measure (UoM)

The user-entered name for the unit of measure for the output of an account.

Table 60.84  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User specifiable, but not in a column layout.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Text</td>
</tr>
<tr>
<td>Data type:</td>
<td>The maximum length is 64 alphanumeric Unicode characters.</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>N/A</td>
</tr>
</tbody>
</table>

When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.
Unit Profit (UnitProfit)

The calculated profit for a sold unit.
You cannot change this value. It is calculated according to the following formula:

\[ \text{UnitProfit} = \frac{\text{Profit}}{\text{OutputQty}} \]
And:
\[ \text{OutputQty} = \begin{cases} \text{OutputQtyUE} & \text{if OutputQtyUE is not null} \\ \text{UsedQty} & \text{else} \end{cases} \]
So:

\[ \text{UnitProfit} = \begin{cases} \frac{\text{Profit}}{\text{OutputQtyUE}} & \text{if OutputQtyUE is not null} \\ \frac{\text{Profit}}{\text{UsedQty}} & \text{else} \end{cases} \]

Table 60.85  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Account</td>
</tr>
</tbody>
</table>

See Also

- “Unit Cost (UnitCost)” on page 681
- “Unit Revenue (UnitRevenue)” on page 682

Unit Revenue (UnitRevenue)

The calculated revenue for a sold unit.
You cannot change this value. It is calculated according to the following formula:

\[ \text{UnitRevenue} = \frac{\text{Revenue}}{\text{OutputQty}} \]
And:
\[ \text{OutputQty} = \begin{cases} \text{OutputQtyUE} & \text{if OutputQtyUE is not null} \\ \text{UsedQty} & \text{else} \end{cases} \]
So:

\[ \text{UnitRevenue} = \begin{cases} \frac{\text{Revenue}}{\text{OutputQtyUE}} & \text{if OutputQtyUE is not null} \\ \frac{\text{Revenue}}{\text{UsedQty}} & \text{else} \end{cases} \]

Table 60.86  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
</tbody>
</table>
Use Fixed Quantities (UseFixQty)

Indicates that Driver Quantity Fixed is editable on an assignment whose source account uses the fixed quantity driver.

Table 60.87  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User specifiable, but not in a column layout.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Checkbox</td>
</tr>
<tr>
<td>Data type:</td>
<td>Boolean</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Driver</td>
</tr>
</tbody>
</table>

See Also

- “Use Variable Quantities (UseVarQty)” on page 683
- “Use Weighted Quantities (UseWeightedQty)” on page 684

Use Variable Quantities (UseVarQty)

Indicates that Driver Quantity Variable is editable on an assignment whose source account uses the variable quantity driver.

Table 60.88  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User specifiable, but not in a column layout.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Checkbox</td>
</tr>
<tr>
<td>Data type:</td>
<td>Boolean</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Driver</td>
</tr>
</tbody>
</table>
See Also

- “Use Fixed Quantities (UseFixQty)” on page 683
- “Use Weighted Quantities (UseWeightedQty)” on page 684

Use Weighted Quantities (UseWeightedQty)

Indicates whether Driver Weight Fixed and/or Driver Weight Variable values are editable on an assignment whose source account uses the weighted quantity driver.

Table 60.89  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>User specifiable, but not in a column layout.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Checkbox</td>
</tr>
<tr>
<td>Data type:</td>
<td>Boolean</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Driver</td>
</tr>
</tbody>
</table>

See Also

- “Use Fixed Quantities (UseFixQty)” on page 683
- “Use Variable Quantities (UseVarQty)” on page 683

Used Cost (UsedCost)

The calculated used cost for outgoing driver quantities and sold quantities for an account.

Used Cost is calculated according to the following formula:

\[
\text{Used Cost} = \text{UsedQty} \times \text{Driver Rate}
\]

Table 60.90  General information concerning the property

<table>
<thead>
<tr>
<th>System generated or user entered?</th>
<th>Calculated by system</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default format in a column layout:</td>
<td>Currency</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Outgoing</td>
</tr>
</tbody>
</table>
**Used Quantity (UsedQty)**

The calculated amount for outgoing driver quantities and sold quantities for an account. Used Quantity is calculated according to the following formula:

\[ \text{UsedQty} = (\text{TDQCalc} + \text{SoldQty}) \]

<table>
<thead>
<tr>
<th>Table 60.91</th>
<th>General information concerning the property</th>
</tr>
</thead>
<tbody>
<tr>
<td>System generated or user entered?</td>
<td>Calculated by system</td>
</tr>
<tr>
<td>Default format in a column layout:</td>
<td>Number</td>
</tr>
<tr>
<td>Data type:</td>
<td>8-byte floating-point number</td>
</tr>
<tr>
<td>Type of property in an assignments pane:</td>
<td>Outgoing</td>
</tr>
</tbody>
</table>

**See Also**

“Used Quantity (UsedQty)” on page 685

**Use Rule Formula (UseRuleFormula)**

Indicates whether assignments using this driver are generated by a formula. For information, see “Rule-based Drivers” on page 281.

You enable this property by checking the **Use Rule Formula** check box on the **General** tab of the New Driver window or the Driver Properties window.
This property is displayed on the drivers page as **UseRuleFormula**:

<table>
<thead>
<tr>
<th>DriverName</th>
<th>RuleFormula</th>
<th>UseRuleFormula</th>
</tr>
</thead>
<tbody>
<tr>
<td>DRIVERS</td>
<td># Components Per Pack</td>
<td>SolidQuantity&gt;0</td>
</tr>
<tr>
<td></td>
<td># FitIns Per Pack</td>
<td></td>
</tr>
</tbody>
</table>

See Also

“Rule Formula (RuleFormula)” on page 676

**User-Entered Cost Allocation (UECostAllocation)**

Indicates whether user-entered allocated cost values (Driver Allocated Cost) are editable on an assignment whose source account uses a user-entered cost allocation driver.

You enable this property by checking the **Allow user-entered cost allocation** check box on the **Advanced** tab of the New Driver window.
This property is displayed on the drivers page as \texttt{UECostAllocation}:

\begin{table}[h]
\centering
\begin{tabular}{|c|c|c|c|c|c|c|c|}
\hline
\textbf{DrvName} & \textbf{DrvType} & \textbf{UniqDrvQty} & \textbf{UseFixQty} & \textbf{UseVarQty} & \textbf{UseWeightedQty} & \textbf{UECostAllocation} \\
\hline
\hline
\end{tabular}
\end{table}

\textit{Table 60.92}  General information concerning the property

\begin{itemize}
\item System generated or user entered?: User specifiable, but not in a column layout for a module view.
\item Default format in a column layout: Checkbox
\item Data type: Boolean
\item Type of property in an assignments pane: N/A
\end{itemize}

\textbf{Variable Driver Quantity Override (VariableDQOverride)}

For a sequenced driver, the name of the property that replaces the Driver Quantity Variable value after the previous sequence pass.

\begin{table}[h]
\centering
\begin{tabular}{|c|c|}
\hline
\textbf{System generated or user entered?} & User specifiable, but not in a column layout. \\
\hline
\textbf{Default format in a column layout:} & Text \\
\hline
\end{tabular}
\end{table}
### Data type

The maximum length is 64 alphanumeric Unicode characters.

<table>
<thead>
<tr>
<th>Type of property in an assignments pane</th>
<th>N/A</th>
</tr>
</thead>
</table>

When you import or export model data, this value must translate into a CHAR, NCHAR, VARCHAR, or NVARCHAR.

### See Also

- “Driver Sequencing” on page 298
- “Fixed Driver Quantity Override (FixedDQOverride)” on page 658
Index

Special Characters
& function (concatenation) 357

A
ABC Procedure 475
abs function 353
Account Map 533
accounts
expand all levels in module view 165
go to an account 164
save queries for account search 162
show source and destination accounts 325
Activity-Based Costing 3
Add Accounts for Assignments Dialog Box 266
Allocated Cost (AllocCost) 637
Analysis Workspace 453
Assigned Cost (AsgnCost) 638
Assigned Idle Cost (AsgnIdlCost) 639
Assigned Idle Quantity (AsgnIdlQty) 640
Assigned Non Reciprocal Cost (AsgnNRecipCost) 640
Assigned Reciprocal Cost (AsgnRecipCost) 640
Assignment Map 533
assignments
assignments paths 263
association a driver with an account 266
create an assignment 321
attributes, on dimension members
apply to accounts 214
attach an attribute to a dimension member 207
general description 197
remove attributes from dimension members 212
attributes, types of
calculated 184
dimension, dimension member 182
numeric 183
stage 185
tag (Boolean) 184
text 185
attributes, working with
add stage attributes to accounts 193
add to an account 191
create an attribute 187
create an attribute folder 190
remove from an account 194
show accounts with an attribute 194
specify its value 192

B
behaviors (for SAS Profitability Management) 539

C
Calculate Error (CalcError) 641
calculating costs, examples
detailed example 417
idle flow 414
using a non-weighted driver with variable driver quantities 400
using a weighted driver with fixed and variable driver quantities 413
using a weighted driver with variable driver quantities 407
using a weighted driver with fixed driver quantities 412
calculating costs (calculation) 395
independent TDQ 303
cancel a server task 58
capabilities 49
column layouts
  add a column 232
  adding properties to a column layout 251
  copy a column layout to another module 244
  format a column 235
  order columns 234
  remove a column 234
column layouts, working with
  formatting columns 234
Contributions Workspace
  drill down 474
  from Resource to Activity module 473
  from Resource to Cost Object 471
general information 469
  get the PROC ABC statement 475
  via Activity module 472
correlation report 567
Cost (Cost) 641
cost elements, creating
  on a module page 177
  when creating an account 176
cost elements, types of
  assigned 176
  entered 175
  external unit 176
  internal unit 176
cube configurations
  creating 377
general options 378
  options for a 6.3–compatible multi-stage
    contribution cube 382
  options for a custom multi-stage
    contribution cube 380
  options for SAS OLAP Analyzer 383
  options for SQL Server Analysis
    Services 385
  select numeric attributes 386
  selecting dimension members for
    inclusion in cubes 388
cubes
  delete a cube or fact table 448
  display the internal name of a cube 447
general information 439
  import periodic data only 443
  include numeric attributes in a cube 446
  incremental cube generation 443
  manage cube permissions 443
currencies
  add a currency 369
  copy an exchange rates table 370
  exchange rates 368
  introduction 367
  set up multiple currencies 368
  customizing the interface 595

D
degrees function 353
diagrams, property
  combined account cost properties 614
  cost (economic world) 615
  cost element properties 610
  non-reciprocal system 607
  quantities 611
  reciprocal system – account properties 610
  Dimension 124
  Dimension level 124
  Dimension Level Name (DimLevelName) 642
  Dimension Level Number
    (DimLevelNum) 642
  Dimension member 125
  Dimension Member Name
    (DimMemName) 643
  Dimension Member Reference
    (DimMemRef) 643
  Dimension Name (DimName) 644
  Dimension Reference (DimRef) 645
dimensions
  create a dimension member 128
dimensions and dimension members 123
  reordering dimension members 129
  Display Name (Display Name) 645
  Display Reference (Display Reference) 646
  Drivable Cost (DrvblCost) 646
  Driven Cost (DrvnCost) 647
  Driven Quantity (DrvnQty) 647
  Driver Allocated Cost (DrvAllocCost) 648
  Driver Cost (DrvCost) 648
  Driver Driven Cost (DrvDrvnCost) 649
  Driver Driven Quantity (DrvDrvnQty) 650
  Driver Formula (DrvFormula) 650
  Driver Idle Cost (DrvldCost) 651
  Driver Percentage (DrvPcnt) 652
  Driver Quantity Basic (DrvQtyBasic) 652
  Driver Quantity Calculated (DrvQtyCalc) 652
  Driver Quantity Fixed (DQF) 653
  Driver Quantity Variable (DQV) 654
  Driver Rate (DrvRate) 654
Driver Sequence Number (DrvSeq) 655
Driver Type (DrvType) 655
Driver Used Cost (DrvUsedCost) 656
Driver Weight Fixed (DWF) 656
Driver Weight Variable (DWV) 657
drivers, general information
fixed, variable, and weight driver quantities 293
guidelines for drivers 19
idle quantities 301
reciprocal costing 307
sequencing 298
unique and non-unique (shared) quantities 296
user-entered cost allocation 292
drivers, types of
basic 270
bill of costs 271
calculated 273
comparing driver types 289
evenly assigned 276
percentage 276
rule-based 281
sales volume 277
weighted 279
drivers, working with
associate a driver in a module’s grid 324
associate a driver with an account’s item properties 323
create a driver 317
create an assignment 321
show destination accounts 325
show source accounts 325
show source and destination accounts 325
specify the default driver 320
specify weights for a weighted driver 280

E
Entered Cost (EntCost) 657
exp function 354
export
column layout 509
cube configurations 507
model 493
OLAP views 522
report 586

F
fact tables
deleting 448
general information 440
find function 357
Fixed Driver Quantity Override 658
Formula 658
formulas
enhanced formula capabilities 337
formula context 332
functions 331
general information 330
numeric attributes in a formula 340
operator precedence 343
troubleshooting 341
formulas
properties that can be in formulas 361
functions 331
functions, Boolean
HasAttribute 347
if 348
IsChildOf 348
IsClose 349
IsNull 350
Match 350
functions, numeric
abs 353
degrees 353
exp 354
max 354
min 354
pi 354
power 355
quotient 355
radians 355
round 355
sign 356
sqrt 356
trunc 356
functions, string
& (concatenation) 357
find 357
left 358
len 358
mid 358
right 359
str 359
trim 359
value 359

G
guidelines
for creating accounts 17
for creating assignments 20
for creating the Activity module 5
for creating the Cost Object module 7
for creating the External Units module 8
for creating the model structure 11
for creating the modules 14
for creating the Resource module 4

H
Has Assignments (HasAsgn) 659
Has Attributes (HasAttr) 659
Has BOC (HasBOC) 659
Has Entered Cost (HasEntCost) 660
Has Idle Cost (HasIdlCost) 660
Has Notes (HasNotes) 661
Has Used Cost (HasUsedCost) 661
HasAttribute function 347

I
icons 34
Idle Cost (IdlCost) 661
Idle Driver Quantity (IdlDrvQty) 662
Idle Driver Quantity UE (IdlQtyEU) 663
Idle Flow Method (IdleFlow) 663
Idle Percentage (IdlPcnt) 664
Idle Quantity (IdlQty) 665
If function 348
import
  column layout 509
cube configurations 507
model 479, 489
OLAP views 521
information maps 533, 535
Intersection Name (IntsctnName) 666
Intersection Reference (IntsctnRef) 666
Is Behavior (IsBehavior) 667
IsChildOf function 348
IsClose function 349
IsNull function 350

J
JAWS graphics labeler 45

L
left function 358
len function 358
log on 55

M
Match function 350
max function 354
Metadata Server Options 535
mid function 358
min function 354
models
  create a model 69
importing 479
model mode 67
open a model with a model already open 75
Models Workspace 67
Module Type (ModType) 667
multiple sessions 58

N
Name (Name) 667
naming conventions
  account references 86
  attribute references 87
  attributes 82
dimension levels 82
dimension member references 87
dimension members 83
dimension references 87
dimensions 82
drivers 84
termed cost element references 87
termed cost elements 84
External Unit 84
External Unit references 87
genereal 81
modules 84
period levels 85
period references 87
periods 85
scenario levels 86
scenario references 87
scenarios 85
stages 86
Workspace items 86
Navigation Pane 24

O
OLAP
  change appearance of OLAP window 464
  create an OLAP view 464
  OLAP mode 455
  open an OLAP view with a view already open 465
  open an OLAP view without a view already open 464
  using SAS OLAP Analyzer 463
Output Quantity (OutQty) 668
Output Quantity UE(OutQtyUE) 668
owners, changing 51

P
Parcel Express tutorial 8
Periodic Note (PerNote) 669

periods
change the current period/scenario association 118
copy period/scenario data 118
create a period 103
create a period/scenario association 116
manage period level names 104
publish a period/scenario association 119

permissions
changing owners 51
group permissions 50

pi function 354
power function 355
PROC ABC 475
Profit (Profit) 669
Profitability Management overview 539
publish behaviors for 539
properties
account 257
assignment 252
driver 256
incoming 255
outgoing 253
table of property types 258

property diagrams
combined account cost properties 614
cost (economic world) 615
cost element properties 610
how to read these diagrams 616
non-reciprocal system 607
quantities 611
reciprocal system – account properties 610
types of costs 618

publish
behaviors (for SAS Profitability Management) 539
information maps 533
performance measures (for SAS Strategy Management) 553
Publish Performance Measures dialog box 553

R
radians function 355
Received Allocated Cost (RcvAllocCost) 669
Received Assignment Cost (RcvAsgnCost) 670
Received BOC Cost (RcvBOCCost) 671
Received Cost (RcvCost) 672
Received Driven Cost (RcvDrvnCost) 673
Received Idle Cost (RcvIdlCost) 673
Received Non Reciprocal Cost (RcvNRecipCost) 674
Received Reciprocal Cost (RcvRecipCost) 674
Received Used Cost (RcvUcost) 674
reciprocal costing 307
Reference (Reference) 675
refresh 57
register metadata (create information maps) 535
Register Metadata dialog box 535
reports
change a report configuration 585
create a report 581
delete a report configuration 592
export 586
open a report with a report already open 585
open a report without a report already open 585
publish 591
report templates 565
Reports mode 560
save a report configuration 586
Revenue (Revenue) 675
right function 359
round function 355
Rule Formula 676

S
SAS OLAP Analyzer
cube options for 383
general information 463
restrictions 461
SAS Profitability Management overview 539
publish behaviors for 539
SAS Strategy Management 543
performance measures 552
Publish Performance Measures dialog box 553
SASHome 55
sassw.config 55
saving data 56
scenarios
  create a scenario 109
  manage scenario level names 111
sequencing drivers 298
sessions, multiple 58
shortcut keys 32
shortcuts 29
sign function 356
Sold Quantity (SoldQty) 676
SQL Server Analysis Services 385
sqrt function 356
str function 359
Strategy Management 543
  performance measures 552
  Publish Performance Measures dialog box 553
T
TDQ, independent TDQ 303
Total Driver Quantity (TDQ) 677
Total Driver Quantity Basic (TDQBasic) 677
Total Driver Quantity Calculated
  (TDQCalc) 678
Total Driver Quantity UE (TDQUE) 678
trim function 359
trunc function 356
tutorial, Parcel Express 8
Type (Type) 679
U
Unassigned Cost (UnAsgnCost) 679
Unassigned Quantity (UnAsgnQty) 680
Unique Driver Quantities (UniqDvrQty) 680
Unit Cost (UnitCost) 681
Unit Of Measure (UoM) 681
Unit Profit (UnitProfit) 682
Unit Revenue (UnitRevenue) 682
Use Fixed Quantities (UseFixQty) 683
Use Rule Formula 685
Use Variable Quantities (UseVarQty) 683
Use Weighted Quantities
  (UseWeightedQty) 684
Used Cost (UsedCost) 684
Used Quantity (UsedQty) 685
user options 595
User-Entered Cost Allocation 686
V
value function 359
Variable Driver Quantity Override 687
W
Workspace Manager 27, 30