Getting Started with SAS® Activity-Based Management 7.2, Second Edition
## Contents

### Chapter 1 • Introduction
- Overview .......................................................... 1
- Tutorial Conventions ........................................... 2
- Terminology ...................................................... 3
- Online Help ....................................................... 3
- Technical Support ............................................... 3
- Additional Training and Tutorials ........................... 3

### Chapter 2 • Activity-Based Management
- Overview .......................................................... 5
- The ABC Model and CAM-I Methodology .................... 6
- SAS Activity-Based Management Models .................... 7
- Basic Steps to Building a Model .............................. 8
- Parcel Express .................................................. 9

### Chapter 3 • Getting Started
- Overview .......................................................... 11
- Logging On ....................................................... 11
- Navigation Pane ............................................... 12
- The Workspace Manager ...................................... 15
- Models Workspace ............................................ 16
- Reports Workspace ............................................ 20
- Analysis Workspace for OLAP Cubes ....................... 21
- Contributions .................................................. 21

### Chapter 4 • Creating a Paper Plan
- Overview .......................................................... 23
- Building by Design ............................................ 23
- The Parcel Express Tutorial Model .......................... 24

### Chapter 5 • Creating Periods and Scenarios
- Overview .......................................................... 27
- Creating a Period ............................................... 27
- Creating a Scenario ............................................ 29
- Deleting Periods and Scenarios ............................... 30

### Chapter 6 • Creating Dimensions and Dimension Members
- Overview .......................................................... 31
- Creating Dimensions with the New Model Wizard ........ 32
- Creating Dimension Members ................................. 37

### Chapter 7 • Creating Modules and Accounts
- Overview .......................................................... 41
- Building the Resource Module Structure ................... 43
- Building the Activity Module Structure ..................... 47
- Building the Cost Object Module Structure ............... 49

### Chapter 8 • Creating Attributes
- Overview .......................................................... 53
- Types of Attributes ............................................ 54
- Creating Attributes ........................................... 56
Creating a Column Layout .................................................. 59
Entering Attribute Values .................................................... 61
Applying Additional Attributes to Accounts ......................... 62

Chapter 9 • Drivers for the Model ........................................... 65
Overview .............................................................................. 65

Chapter 10 • Making Assignments ........................................ 71
Overview .............................................................................. 71
Using a Column Layout ......................................................... 72
Making Assignments from Resources to Activities ................... 74
Making Assignments from Activities to Other Activities ............ 80
Making Assignments from Activities to Cost Objects ............... 84
Adding Attributes to Cost Accounts ....................................... 88
Postscript on Using a Column Layout .................................... 90
Postscript on Generating Assignments According to a Rule ........ 92

Chapter 11 • Calculating Costs ............................................. 99
Overview .............................................................................. 99
Performing Calculations ....................................................... 99
Viewing and Verifying Calculation Results .......................... 100

Chapter 12 • Adding Bills of Costs ....................................... 103
Adding Bills of Costs .......................................................... 103
Steps for Building Bills of Costs ........................................... 103
Internal and External Units ................................................. 104
Fixed and Variable Quantities .............................................. 104
Creating External Units and Bills of Costs ............................ 105

Chapter 13 • Entering Sales and Revenue Data ....................... 111
Calculating Sales Volume .................................................... 111
Entering Revenue and Calculating Profit .............................. 120

Chapter 14 • Querying Contributions .................................. 123
Overview .............................................................................. 123
Some Key Things to Know ................................................... 124
Query Contributions from Resource to Cost Object ................. 125
Query Contributions from Resource to Activity ..................... 129
Drilling Down to a Lower Level .......................................... 130
Using the ABC Procedure ................................................... 131

Chapter 15 • Generating Reports ....................................... 133
Overview .............................................................................. 133
Report Templates .............................................................. 133
Creating a Report .............................................................. 134
Working with Reports ......................................................... 137

Chapter 16 • Generating Cubes ........................................... 139
Overview .............................................................................. 139
Types of Cubes ................................................................... 139
Overview of Cube Generation ............................................. 140
Cube Configurations ......................................................... 141
Generate Cubes ................................................................. 149
Select Cost Flow: In or Out ............................................... 150
Manage Cube Permissions .................................................. 152
Chapter 17 • Using the SAS OLAP Analyzer ................................................................. 155
  Creating OLAP Views ................................................................................. 155
  Analyzing OLAP Cubes ........................................................................... 156
  Using the Cube Explorer View ................................................................. 174

Chapter 18 • Handling Null-Intersections ......................................................... 181
  Introduction ............................................................................................... 181
  Alternative Method .................................................................................. 183
  Advantages of Using the Alternative ......................................................... 186

Chapter 19 • Finishing Up ............................................................................... 191
  Parcel Express Conclusions ..................................................................... 191
  Additional Features .................................................................................... 191
  What to Do Next ....................................................................................... 192
Contents
Chapter 1
Introduction

Overview

This tutorial is intended to familiarize you with the basic modeling concepts that are used in SAS Activity-Based Management software. To complete the model-building process, perform this tutorial from beginning to end, exactly as it is presented.

Note: You can import an already completed model for the Parcel Express Tutorial by doing the following:

1. Select File ⇒ Import ⇒ Model Data.
2. Select XML or ZIP File as the type of data you want to import, and click Next.
3. Browse to the following file:
   
   `<install directory>\SASHome\SASActivityBasedManagementClient\7.2\Samples \Models\Native\ParcelExpressTutorial.xml`, and click Next.
4. Name the tutorial. You can name it anything you want. Click Next, review your choices, and then click Finish.

   The tutorial model is imported. You must calculate the model to view calculated data.

If you are new to the discipline of activity-based management (ABM), you might benefit more from this tutorial by first learning about the concept. A number of books and articles present excellent overviews. Even without this background, you will learn some basic ABM concepts by completing this tutorial.
Even though you might know ABM, work through this tutorial to become familiar with SAS Activity-Based Management software the concepts, terminology, commands, and dialog boxes.

**Tutorial Conventions**

This section discusses the conventions that are used throughout this tutorial.

**Fonts**

<table>
<thead>
<tr>
<th>Font</th>
<th>Represents</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bold</strong></td>
<td><strong>Menu</strong> ⇒ <strong>Command</strong></td>
<td>Select <em>File</em> ⇒ <em>Save Model As.</em></td>
</tr>
<tr>
<td></td>
<td>User input</td>
<td>Type <em>Parcel Express Tutorial.</em></td>
</tr>
<tr>
<td></td>
<td>User interface elements, such as</td>
<td>Select <em>Calculate Specific Modules</em></td>
</tr>
<tr>
<td></td>
<td>menus, dialog boxes, buttons, or</td>
<td></td>
</tr>
<tr>
<td></td>
<td>list items</td>
<td></td>
</tr>
</tbody>
</table>

**Procedures**

A procedure is a task that includes a set of numbered step-by-step instructions. Some steps are followed by a comment or an explanation. A section that has the following convention indicates a procedure:

- **Begin this tutorial**
  1. Perform step one.
     
     Explanatory comments and illustrations, which explain and display results of proper completion of the preceding steps, are included between steps, when necessary.
  2. Perform step two.

**Notes and Tips**

A note indicates additional information. This is the convention for indicating a note:

*Note:* Text that is set off in this manner presents important information.

The format for a tip is similar.

**Illustrations**

Depending on your display settings and the number of times that you perform a step or procedure, the information in the windows might differ slightly from the illustrations that are presented in this tutorial. If you enter, then delete, and then recreate accounts and cost elements, the reference number might differ from the illustration. The displayed order of accounts might differ if you close and reopen the model. Consider the illustrations to be guides.
Illustrations will usually show only the pertinent portions of the window that are being discussed.

**Terminology**

This tutorial refers to both the discipline of activity-based management (ABM), and the SAS Activity-Based Management solution. References to the discipline appear in lowercase or by abbreviation. The SAS solution is always capitalized.

The discipline of activity-based management has a set of specialized terms. Some are used in this tutorial precisely because of their specialized meaning to the theory and practice of ABM. As these terms are introduced, this tutorial provides brief definitions. More complete definitions can be found in the CAMI Glossary of Activity-Based Management.

**Online Help**

The online Help is a comprehensive information system that has full-text search capabilities. It includes:

- detailed step-by-step instructions to complete specific tasks
- information about features
- reference material

**Technical Support**

If you encounter problems that you cannot solve by reading the online Help or this tutorial, try going to the SAS technical support site at http://support.sas.com.

**Additional Training and Tutorials**


Topics that are covered on the BetterManagement.com site include value-based management, profitability analysis, strategic enterprise management, activity-based costing/management, business intelligence, and performance measurement.
Chapter 2
Activity-Based Management

Overview

Activity-based management is a discipline that enables companies to manage activities and processes as a means of improving organizational performance and the value that is received by the customer. By applying direct and indirect business costs to activities, the SAS Activity-Based Management solution enables managers to get a true understanding of the costs and profits that are associated with a product, customer, service, or business process. It supports ongoing profitability analysis, cost-management initiatives, shared-services management, planning and budgeting efforts, and capacity optimization.

The basic tool of ABM is activity-based costing (ABC), which more accurately tracks costs than traditional methods. Two critical limitations of traditional cost accounting systems are:

- the inability to report individual product, service, customer, or process costs with a reasonable level of accuracy
- the inability to provide useful feedback to management for the purpose of operational control

Often, managers of complex organizations make important decisions about pricing, product and customer mix, resource allocations, and budgeting that are based on inaccurate and inappropriate cost and profitability information.

Using SAS Activity-Based Management, you build one or more models that apply direct and indirect organizational costs to specific activities and processes. As a result, managers are able to see actual cost assignments and their bottom-line impacts from an operational perspective. Managers get a true understanding of the cause-and-effect
relationships that link resources and processes to outputs. Thus, business planners can easily forecast resource requirements, create budgets, and optimize capacity usage.

The ABC Model and CAM-I Methodology

Overview

ABC assumes that activities cause expenditure of resources, and that cost objects the results of activities or products and services that are produced create the demand for activities.

The Consortium of Advanced Management, International (CAMI) develops methods to define critical business issues and to model effective strategies and solutions that resolve cost and resource management issues. SAS Activity-Based Management uses the CAMI methodology for activity-based model development.

The Cost Assignment View

An ABM system enables you to identify the activities that are performed, associate resources (expenditures) with those activities, and flow the cost of activities to cost objects. Resource drivers (typically, general ledger entries such as payroll, utilities, or materials) drive expenditures for activities. Activity drivers (such as the number of parts
or setups) drive activity consumption for cost objects. Types of cost objects are: products, services, markets, distribution channels, engineering projects, or customers.

**The Process View**

An ABM system enables you to expose the relationship between why work is done, and the results of that work. In ABM terms, cost drivers drive the reason for activities and the effort that is needed to engage in the activities. Performance measures drive the achieved results of activities the efficiency, the required completion time, and the quality of the activities that were performed.

**SAS Activity-Based Management Models**

The basic container for ABM information in SAS Activity-Based Management software is the model. A meaningful ABM model reflects the organization that it is modeling, and uses terms that are familiar to the people who work there. The structural elements of a model should be named after elements that are present in the organizational environment. For example, a company's general ledger account names, such as Wages and Depreciation, can be used to name and reference the resource accounts in the ABM model; the hierarchy of processes in a company can be applied to the activity accounts in the ABM model.

**Modules**

A model consists of three basic modules, which reflect the CAM-I definitions:

**Resource**
contains the expenses (or costs), such as salaries, materials, and depreciation, for the organization that is being modeled.

**Activity**
contains activities. Activities have accounts with cost elements. Costs might be assigned to activities from resource accounts or from other activity accounts.

**Cost Object**
contains cost objects (products, services, channels, or customers). These cost objects are assigned costs from resources, activities, other cost objects, or any combination of the three.

These modules constitute the main structure of a model. A fourth module, external units, provides support for external costs. An external unit is an item, such as a part that is purchased from a supplier, whose cost is maintained outside of a SAS Activity-Based Management model, but which needs to be accounted for in the model. You will build each of these modules with the use of dimensions.

**Dimensions**

**Overview**
A dimension is a category by which data is analyzed. For example, it might be useful to see sales figures when they are broken down by region, by customer, and by product. Each of these categories (region, customer, and product) represents a single dimension. Common dimensions are products, time, geography, customers, promotions, and sales channels.
To break down information into a manageable or useful form, you can group items within a dimension to create a hierarchical structure. Each member of the hierarchy is then at a specific level in the hierarchy. You can name a dimension level as needed. Dimension levels are a powerful modeling tool because they allow you to ask questions at a high level, and then expand a dimension to reveal more detail.

**Types of Dimensions**
There are two types of dimensions in a model: structural and attribute.

Structural dimensions are the building blocks of modules. For example, the typical structural dimensions of the resource module are region, organization, or general ledger; the activity module might be structured according to the region or organization dimension, along with an activity dimension.

Dimension attributes provide information that is useful, but not required, to uniquely identify the model structure. Using dimension attributes, you can classify or organize information in ways that will help you analyze model results. The SAS Activity-Based Management OLAP tool makes no distinction between dimension attributes and structural dimensions.

**Basic Steps to Building a Model**

The following list of steps summarizes the method that you will use in this tutorial for setting up and analyzing information in SAS Activity-Based Management models. This method is described completely in the lessons and exercises in the tutorial.

1. Create a paper plan.
   Collect resource (expenditure), activity, and cost object (products and services) information to design your model. Determine the goal of the model (what kind of information you want to get from it), and determine the appropriate dimensions, periods, and scenarios to achieve that goal.

2. Create periods and scenarios.
   Create the periods and scenarios to be used by your model. (Periods and scenarios are shared by all models on a server.)

3. Create dimensions, modules, and accounts.
   Create the dimensions and dimension members that you will use to build the modules. Build the resource, activity, and cost object modules by defining the accounts (dimension intersections) of each module.

4. Define attributes.
   Define and add attributes to the appropriate accounts.

5. Define drivers.
   Define drivers that measure the consumption of expenses and activities.

6. Make assignments.
   Select the relevant driver for each source account. Make cost assignments from source accounts to destination accounts.

7. Calculate costs.
   Calculate costs and display the results.
8. Add bills of costs.
   Define and link external unit costs to accounts.

9. Enter output, sales, and revenue data.
   Enter output quantities, determine unit costs, enter sales volumes, and calculate profit.

---

**Parcel Express**

Parcel Express is a fictitious organization that is using activity-based management to determine whether this method more clearly conveys costs and profitability information than traditional costing methods.

A later chapter outlines the main business activities of Parcel Express and the company's goals in using SAS Activity-Based Management.
Overview

The SAS Activity-Based Management solution is Web-enabled. Its server typically resides on your company’s intranet, and the client software resides on your computer. This tutorial assumes that you have installed the software on your computer, and that you are familiar with basic software usage techniques, such as using menus, dialog boxes, and other windows and Web controls.

Logging On

Log on to SAS Activity-Based Management from the Start menu.

• Log on to SAS Activity-Based Management

  1. Select Start ⇒ Programs ⇒ SAS ⇒ Activity-Based Management 7.2 ⇒ Activity-Based Management Solution.

     You see the Log On dialog box.
2. Select an environment from the **SAS environment** drop-down list or specify **default** to choose the default environment.

An “environment” is a shortcut to the URL of a SAS server program that authenticates your logon information and provides a connection to a SAS Activity-Based Management Metadata Server. Because you logon first to the SAS server program rather than directly to a Metadata Server, the Metadata Server can change without your having to modify your logon procedure.

3. Type your domain and User ID (for example, HQ\JohnD).

4. Type your **Password**.

5. Click **Log On**.

You see the SAS Activity-Based Management Workspace Manager.

*Note:* If multiple languages are installed on your computer, the language that is used is determined by your location setting in Windows (select **Settings** ➜ **Control Panel** ➜ **Regional and Language Options**).

---

**Navigation Pane**

The Navigation pane allows you to navigate among the workspaces that constitute SAS Activity-Based Management:

- Workspace Manager
- Models
- Analysis
- Reports
- Contributions
If the Navigation pane is not visible, then select View Æ Navigation pane.

Minimizing the Navigation Pane

1. Click the Auto hide icon to minimize the Navigation pane.

   When you roll over the minimized tab with the cursor, the Navigation pane is restored, but only temporarily.

2. Click the Auto Hide icon again (the push-pin) to make the Navigation pane stay open (or select View Æ Navigation Pane).
Partitioning the Navigation Pane

Move the gripper up or down to change the relative size of the task area and the button area in the Navigation pane.

Note: You cannot move the gripper up further than is necessary to fully display all the buttons in the button area.
The Workspace Manager

Overview

The following display shows the SAS Activity-Based Management Workspace Manager. The Workspace Manager provides a treeview of all SAS Activity-Based Management elements—from models to cube configurations to reports—and gives you access to them all.

Read the online Help (click 📚) for a description of the Workspace Manager. Any existing models to which you have access rights appear in the Models folder or its subfolders. You can create shortcuts to your models in the My Shortcuts folder.
**Go to the Models Workspace**

From the Workspace Manager, to go to the Models workspace:

1. On the Navigation pane of Workspace Manager, click **Models**.

   ![Navigation pane](image)

   *Note: If the Navigation pane is not visible, select **View → Navigation Pane**.

2. You see the Models workspace. If you have just started SAS Activity-Based Management, you will see the Models folder. If you have been working with a model, you will see the model page you were working on last.

---

**Models Workspace**

**Overview**

The Models workspace lists the models to which you have access rights. From this workspace, you can open, create, or delete models.
Model Mode and Module Pages

When you open a model, you usually go to the Resource module page, one page among many pages that constitute Model mode. If you change to a different mode, such as OLAP or Reports mode, and then return to Model mode, you go to the model page you were working on most recently.

You perform all of the tasks that are associated with building a model, entering data, and calculating costs in Model mode. Many of the tasks rely on the use of dialog boxes (which enable you to manage specific aspects of the model) and wizards (which guide you through certain procedures). In many cases, you will enter data directly into a column on one of the Model mode pages.

The following window shows the Resource module page of the model that you will be building in this tutorial.
When a model is open, if you want to open a model different from the currently open model, do one of the following:

- Click the **Go to Models Workspace** button on the Models Workspace Toolbar.

- Select **Model → Change Model or Context** from the menu bar.
- Go to the Workspace Manager and navigate to the Models folder.

In this tutorial, you will be directed to use the menus most of the time. Occasionally, you will be instructed to use a button or an icon. As you become more familiar with the software, you can choose the method you prefer to initiate tasks. Read the online Help for complete descriptions of toolbar buttons and icons.

**Assignments Panes**

One of the main objectives of activity-based management is to accurately assess how company costs are consumed; for example, you can see how costs flow from general
ledger accounts to activities to products and services. SAS Activity-Based Management provides you with several graphical tools to help you see and manage this flow. Among these tools are the left and right assignments panes, which allow you to view and assign costs from one module to another and within a single module.

By default, each module opens in a single-pane view, the primary pane. The primary pane contains the structure of a module, which includes the dimension intersections (accounts) and each account's cost elements. You can open the left assignments pane to see the accounts from which costs flow (sometimes called source accounts). You can open the right assignments pane to see the accounts to which costs flow (sometimes called destination accounts).

The following display shows the Activity module of the model that you will be building in this tutorial. All three panes are open.

In this display, the arrows that point from the left assignments pane to the primary pane indicate costs that are flowing into the Beaverton Inspect account in the Activity module. The arrows that point from the primary pane to the right assignments pane indicate costs that then flow from the Beaverton Inspect account into other accounts.

In this tutorial, you will use the right assignments pane to assign costs from one account to another.

**Column Layouts**

**Overview**

A column layout is a collection of displayed columns, column formats, and the column order on the module pages.

You can customize a column layout to display various information, such as properties, attributes, periods, and scenarios. When you have customized it, you can save a column layout by name so that you can retrieve it later. You see saved column layouts in the
Workspace Manager and in the Column Layout list on the Resource, Activity, Cost Object, and External Units module pages.

When you save a column layout, the following information is saved:

• description
• column headings
• information that is displayed in each column and the period/scenario association to which it applies
• format for each column and order of the columns from left to right
• model
• column widths

The following information is not saved:

• number of assignments panes that appear on the page

T I P All column layouts that are saved by all users on the same server are listed in the Workspace Manager. Therefore, your organization might want to set guidelines for saving and naming column layouts.

Properties, Attributes, and Dimensions in Column Layouts

The columns of a column layout are derived from the following model elements:

Properties
A property is a model item that holds values that are entered by a user or calculated by the software. Examples of properties include Cost, Unit Cost, Output Quantity, Sold Quantity, and Profit. The more familiar you become with SAS Activity-Based Management modeling, the more you will be able to use properties creatively to achieve your analysis goals.

Attributes
An attribute is a user-defined label or numeric value that is attached to an account. Each attribute is a particular characteristic that is used for analysis. An attribute conveys information about the item to which it is attached.

Dimensions
A dimension is a category by which data will be or is analyzed. You define the dimensions of your model when you use the New Model Wizard.

Reports Workspace

SAS Activity-Based Management allows you to use predefined report templates or to create your own reports.

• Change to the Reports workspace

From the Navigation pane, click Reports.

You see the Reports workspace.

Once you have opened a report, if you want to open a report different from the currently open one, do one of the following:
• Click the **Go to Reports Workspace** button on the Reports Workspace toolbar.

• Go to the Workspace Manager and navigate to the Reports folder.

---

**Analysis Workspace for OLAP Cubes**

A cube is the main object in OLAP, a technology that provides fast access to data in a model. A cube contains a set of data that is constructed from a subset of model data and that is organized and summarized into a multidimensional structure. SAS Activity-Based Management cubes are standard OLAP cubes.

You use SAS Activity-Based Management software to connect to and interact with the cubes on a SAS Activity-Based Management server. For each model, you can generate cubes that you can manipulate with the OLAP Analyzer to interactively analyze business data.

• Change to the Analysis workspace to access OLAP cubes.

  From the Navigation pane, click **Analysis**.

  You see the Analysis workspace.

When you have opened an OLAP view, if you want to open an OLAP view different from the currently open one, do one of the following:

• Click the **Go to Analysis Workspace** button on the Analysis Workspace Toolbar.

• Go to the Workspace Manager and navigate to the OLAP Views folder.

---

**Contributions**

The Contributions workspace allows you to query a cube on the fly without having to generate a cube. You can quickly see what input contributed to costs from accounts in
any module to accounts in any other module. The Contributions workspace provides the quickest and easiest way to explore the flow of costs throughout a model.

- Change to the Contributions workspace
  
  From the Navigation pane, click **Contributions**.

  You see the Contributions page.
Creating a Paper Plan

Overview

Activity-based management projects begin with a plan. After you have determined the analysis goals of the model and defined the dimensions that will enable that analysis, you can begin data collection. Information concerning resources (expenditures), activities (tasks), and cost objects (products and services produced) provides the basis for building an ABM model.

Building by Design

Before beginning to build a model, evaluate and make preliminary decisions about the design of the model. Just as a building contractor needs a plan before beginning to build a house, a model builder needs a plan for the structure of a model before beginning to build the model. Factors that influence a model's design include the following:

• goal of the model the operational or strategic questions the activity-based management program is intended to answer

• data already collected and its format

• data needed that is not being collected

• types of reports and OLAP cubes that will be needed

This tutorial uses a simple design and focuses on the steps for building a model. The design of the model and the effort that it takes can be simple or complex. The model builder will need to understand these factors, and other factors that are unique to each modeling situation, to arrive at a design. The model used with this tutorial is named Parcel Express. The Parcel Express Tutorial case study provides fictitious company data.
The Parcel Express Tutorial Model

Company Background

Parcel Express began operations in Beaverton, Oregon, in 1990 as a ground parcel delivery service. In 1995, with 125 employees and $1 million in sales, the company began expanding to overnight delivery and second-day delivery.

In the first quarter of 2004, total sales revenue was approximately $5.5 million. Costs for the same period were about $3.8 million, for a profit of about $1.7 million.

ABM Goals

Parcel Express hopes to use SAS Activity-Based Management to trace operating costs to individual products and services so that the overall costs and profit of each product and service can be determined and improved. Parcel Express is concerned that the current accounting system, which divides the business into about 10 product groupings, might not accurately reflect the different costs of doing business for the two express services: Overnight Express and 2nd Day Guaranteed.

Management wants to know how each product is performing. The company's competitors have dominated in the second-day delivery market, and management has recently slashed prices on that product. Sales volumes have increased as a result, but it's unclear how much profit Parcel Express is making, if any. The company would like to meet a target profit margin of at least 10% on the 2nd Day Guaranteed product, and at least 25% on all others. It is willing to adjust pricing or modify processes to reach that goal.

Model Structure

Overview

Parcel Express has assembled a SAS Activity-Based Management modeling team whose members have become familiar with ABM concepts and the structure of ABM models. Together, they have determined that the following module structure most accurately reflects the way Parcel Express conducts its operations.

Resource Module

Resources will be structured by region and general ledger account. The two main processing plants are Beaverton and Eugene, Oregon. General ledger accounts include:

- wages (salary and overtime)
- operating expenses and office supplies
- equipment depreciation

Activity Module

Activities will be structured by region and activity. The activities Parcel Express has chosen to model are:

- branch collection
• sorting and inspection
• air and land distribution
• resolution of customer complaints

The Eugene facility does not have an air distribution function, so it will have one less account than Beaverton.

**Cost Object Module**
Parcel Express needs to be able to track not only the costs of products and services, but the costs of its channels as well. Therefore, Parcel Express will organize the cost object module by channel and products and services.

The three channels are:
• drop box
• walk in
• commercial pick up

The three products and services are:
• Standard Ground
• 2nd Day Guaranteed
• Overnight Express

**External Units Module**
Each product has packaging costs that must be accounted for. Materials for packaging will be tracked as external units, including:
• envelopes
• flats
• boxes

**Data Collection**
The following data will be collected for entry into the ABM model:

**Wages**
Wage information, including salaries and overtime, will come from the general ledger system. Wages will be entered as dollar amounts, and assigned to activities according to the number of full-time employees, or FTEs (Full-Time Equivalents), who are associated with an activity.

**Operating Expenses**
Operating expenses and supply costs will come from the general ledger. These costs will be assigned to activities in dollar amounts.

**Equipment Expenses**
Equipment expenses, including depreciation, will come from the general ledger. These costs will be assigned by percentage.

**Collection and Distribution**
Branch managers will collect data from their control systems regarding the number of packages that are collected, moved to warehouses, sorted, inspected, and distributed by land and air. Accurate numbers here are critical to the success of the modeling effort. Activity accounts will assign costs by number of packages.
Complaints
The number of customer complaints will be collected by branch managers. Costs that are associated with complaint resolution will be assigned according to the number of complaints that are received.

Revenue
Revenue will come from the sales accounting system. Revenue will be associated with cost objects according to the sales quantity for each product.
Overview

A period is an interval of time in which activity-based management data is maintained. A period can represent any unit of time: a month, a quarter, a year, and so on. For example, if your organization chooses to enter data each month, the marketing payroll cost is the amount of payroll for one month. A model can hold data for different periods, but only one period at a time is active. You can create a hierarchy of periods, such as FY2008 > Q1 > January. By default, each level is given a name, such as Period L1.

You can compare model data that you have entered for different periods. For example, you can enter costs into a model on a month-by-month basis and examine the costs for March versus the costs for February.

Scenarios are generally used to manage different variations of data within a period. A scenario can be any set of data: actual, budget, aggressive plan, conservative plan, and so on. The default scenarios are Actual and Budget. You can create a hierarchy of scenarios, such as Budget > Aggressive. By default, each level is given a name, such as Scenario L1. However, these names are not descriptive when you generate cubes. So, you can rename a default scenario level.

Creating a Period

Parcel Express analyzes costs by quarters, so the model will be structured to analyze quarter-on-quarter costs. The period that you will create is 2008 Q1.

• Create a period
  1. Select Tools ⇒ Manage Periods.

You see the Manage Periods dialog box.
2. Select the 2008 period and click New.

   Note: These periods might already exist on your server.

   You see the New Period dialog box.

3. For Name, replace New Period with 2008 Q1.

4. For Reference, type 08Q1.

5. Select a Start date of January 1, 2008.

   Note: In addition to using the graphical calendar, you can simply overwrite the start or end date:


   Note: SAS Activity-Based Management enables you to enter descriptions for the items that you create. In this tutorial, you do not enter descriptions.

7. Click OK.

   You see the new period added to the list below the 2008 period.

8. Create three more periods that are named 2008 Q2, 2008 Q3, and 2008 Q4. Specify appropriate date ranges and references for each period. All period references must be unique.

   When you are done, you should see the following periods in the Manage Periods dialog box:
Creating a Scenario

Parcel Express wants to compare actual costs that it incurred on a quarterly basis. It will analyze the profit and loss trends in these costs to make decisions about resource allocation, process control, and pricing. For these purposes, the Actual default scenario is adequate.

However, so that you gain experience, assume that the company had specific profit targets that it wanted to model in SAS Activity-Based Management. You could create a scenario named Target.

• Create a scenario

1. Select Tools ⇒ Manage Scenarios

You see the Manage Scenarios dialog box.

2. Select All Scenarios and click New.

You see the New Scenario dialog box.

9. Click OK.
3. For Name, replace New Scenario with Target.
4. For Reference, type Target.
5. Click OK.
   You see the new scenario added to the list below the Actual scenario.
6. Click OK.

Deleting Periods and Scenarios

You can delete a period or scenario from the Manage Periods or Manage Scenarios dialog boxes, respectively:

1. Select Tools ⇒ Manage Periods or Tools ⇒ Manage Scenarios.
2. Select a period or scenario.
3. Click Delete.

Note: This procedure makes the period or scenario unavailable for any model. If a period/scenario association is already assigned to a model, then you first need to delete the association from every such model. To do so:

1. Open the model and select Model ⇒ Period and Scenario Associations Page.
2. Right-click a period/scenario association.
3. Select Delete.
Overview

Before creating the structure of a module, you must define the dimensions, as specified in the paper plan, that you will use to build that structure.

The following table shows the dimensions that you will create for the tutorial along with the default dimensions that are created if you do not specify dimensions.

<table>
<thead>
<tr>
<th>Module</th>
<th>Tutorial Dimensions</th>
<th>Default Dimensions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource</td>
<td>Region</td>
<td>Organization</td>
</tr>
<tr>
<td></td>
<td>General Ledger</td>
<td>General Ledger</td>
</tr>
<tr>
<td>Activity</td>
<td>Region</td>
<td>Organization</td>
</tr>
<tr>
<td></td>
<td>Activities</td>
<td>Activities</td>
</tr>
<tr>
<td>Cost Object</td>
<td>Region</td>
<td>Customer</td>
</tr>
<tr>
<td></td>
<td>Channel</td>
<td>Products and Services</td>
</tr>
<tr>
<td></td>
<td>Products and Services</td>
<td></td>
</tr>
<tr>
<td>External Unit</td>
<td>Materials</td>
<td>Materials</td>
</tr>
<tr>
<td>Profit Analysis</td>
<td>Region</td>
<td>Customer</td>
</tr>
<tr>
<td></td>
<td>Channel</td>
<td>Products and Services</td>
</tr>
<tr>
<td></td>
<td>Products and Services</td>
<td></td>
</tr>
</tbody>
</table>
Creating Dimensions with the New Model Wizard

The main purpose of the New Model Wizard is to establish the dimensions of your model. These are the dimensions that you will use to create accounts and the structure of the modules. Most important, these are the dimensions that will eventually enable you to generate meaningful cubes and to analyze the profits and losses that result from your business activities.

Now, you will create the model named Parcel Express Tutorial. The model's monetary data will be in U.S. dollars.

- **Start the New Model Wizard**
  1. Select **File** \(\rightarrow\) **New** \(\rightarrow\) **Model**.

You see Step 1 of the New Model Wizard.

The New Model Wizard contains nine steps. If you accept the default dimensions for your model, you will not perform every step. For this tutorial, you will define your own dimensions and perform every step in the New Model Wizard.

2. For the name, type **Parcel Express Tutorial**.

   **Note:** Each model name must be unique on a SAS Activity-Based Management server.

3. For the reference, type **PExpress**. This short reference is used in public views. (See the chapter on “Public Views” in the SAS Activity-Based Management 7.2: User's Guide.

4. Verify that the base currency is **US Dollar($)**.

5. Click **Next**.

You see Step 2 of the New Model Wizard.

- **Select a starting period and scenario**
  1. Expand **2008** and select the **2008 Q1** period.
2. Select the Actual scenario.

A period/scenario association identifies a specific period and scenario combination; in this case, 2008 Q1/Actual. All model data must reside in a period and must apply to a scenario. An association represents a period-scenario pair.

3. Click Next.

You see Step 3 of the New Model Wizard.

- Select the method for defining dimensions

1. Verify that the Select or define the dimensions for each module option is selected.

This option enables you to create new dimensions, rearrange dimensions, or use the default dimensions for some modules, but not others. The dimensions that you will create for the tutorial are:

<table>
<thead>
<tr>
<th>Module</th>
<th>Dimensions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource</td>
<td>Region</td>
</tr>
<tr>
<td></td>
<td>General Ledger</td>
</tr>
<tr>
<td>Activity</td>
<td>Region</td>
</tr>
<tr>
<td></td>
<td>Activities</td>
</tr>
<tr>
<td>Cost Object</td>
<td>Region</td>
</tr>
<tr>
<td></td>
<td>Channel</td>
</tr>
<tr>
<td></td>
<td>Products and Services</td>
</tr>
<tr>
<td>External Unit</td>
<td>Materials</td>
</tr>
<tr>
<td>Profit Analysis</td>
<td>Region</td>
</tr>
<tr>
<td></td>
<td>Channel</td>
</tr>
<tr>
<td></td>
<td>Products and Services</td>
</tr>
</tbody>
</table>

2. Click Next.

You see Step 4 of the New Model Wizard.

- Define the resource module dimensions

1. In the Selected dimensions list, select the Organization dimension.

Next, you will remove this dimension from the Selected dimensions list.

2. Click < Remove.
You see the **Organization** dimension move from the **Selected dimensions** list to the **Available dimensions** list.

3. Click **New**.

You see the New Dimension dialog box.

4. For **Name**, type **Region**.

5. For **Reference**, use **Region**.

6. Click **OK**.

The New Dimension dialog box closes and you see that the **Region** dimension has been added to the **Available dimensions** list.

7. Select the **Region** dimension and click **Add >**.

You see the **Region** dimension move from the **Available dimensions** list to the **Selected dimensions** list, below the **General Ledger** dimension. The order of dimensions in the list determines the hierarchy of dimensions in the module. In this case, Parcel Express wants to organize its resources by **Region**, and then by **General Ledger**. So, you will have to move **Region** above **General Ledger**.

8. Select the **Region** dimension and click **Move Up**.

9. Click **Next**.

You see Step 5 of the New Model Wizard.

Now, you will define the dimensions for the activity module by using these same techniques. Refer to the previous procedure if you need clarification on a step.

- **Define the activity module dimensions**

  1. Remove the **Organization** dimension from the **Selected dimensions** list.

  2. Move the **Region** dimension to the **Selected dimensions** list.

  3. Move **Region** above **Activities**.

The **Selected dimensions** list should appear as follows:

4. Click **Next**.

You see Step 6 of the New Model Wizard.
• Define the cost object module dimensions
  1. Remove the Customer dimension from the Selected dimensions list.
  2. Move the Region dimension to the Selected dimensions list.
  3. Create a new dimension named Channel that has a reference of Chnnl.
  4. Move the Channel dimension to the Selected dimensions list.
  5. Order the dimensions as follows:
     1. Region
     2. Channel
     3. Products and Services

   The Selected dimensions list should appear as follows:

<table>
<thead>
<tr>
<th>Selected dimensions:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Region</td>
</tr>
<tr>
<td>Channel</td>
</tr>
<tr>
<td>Products and Services</td>
</tr>
</tbody>
</table>

   6. Click Next.

   You see Step 7 of the New Model Wizard.

• Define the external units module dimensions
  1. Verify that Materials is the only dimension in the Selected dimensions list.
  2. Click Next.

   You see Step 8 of the New Model Wizard.

• Define the profit analysis dimensions
  1. Move the Region dimension to the Selected dimensions list.
  2. Move the Channel dimension to the Selected dimensions list.
  3. Order the dimensions as follows:
     1. Region
     2. Channel
     3. Products and Services

   The Selected dimensions list should appear as follows:

<table>
<thead>
<tr>
<th>Selected dimensions:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Region</td>
</tr>
<tr>
<td>Channel</td>
</tr>
<tr>
<td>Products and Services</td>
</tr>
</tbody>
</table>

   TIP: The dimensions of the Profit Analysis module must be the same as the dimensions of the Cost Object module.

  4. Click Next.

   You see Step 9 of the New Model Wizard.

• Review the summary and finish the New Model Wizard
1. Review the **Summary of Information** and dimensions in each module, as shown:

![New Model: Summary](image)

If any of the information in the summary is incorrect, click **Back** to move to the page that requires changes. After making the corrections, click **Next** to return to the summary.

2. Click **Finish**.

You see the **Dimensions** page that now has the following dimensions:

<table>
<thead>
<tr>
<th>Name</th>
<th>Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Region</td>
<td>Region</td>
</tr>
<tr>
<td>General Ledger</td>
<td>GL</td>
</tr>
<tr>
<td>Activities</td>
<td>Act</td>
</tr>
<tr>
<td>Channel</td>
<td>Channel</td>
</tr>
<tr>
<td>Products and Services</td>
<td>Prod_Serv</td>
</tr>
<tr>
<td>Materials</td>
<td>Mat</td>
</tr>
</tbody>
</table>
Note: If you select Model ⇒ Properties and click the Model Dimensions tab, you can see the dimensions as shown in the following picture:

These dimensions are the basic building blocks that you will use to construct the modules of your model. First, however, you must create the members of each dimension.

Creating Dimension Members

Dimension members are the unique elements of a dimension level. For example, the Region dimension of the Parcel Express Tutorial model will have levels that include countries, states, and cities. Beaverton and Eugene are dimension members at the same level of the Region dimension.

- Create dimension members
  1. On the Dimensions page, select Region.
  2. Select Edit ⇒ New Dimension Member (or right-click Region).
     You see the New Dimension Member dialog box.
3. Click **Add**.

4. For **Name**, type **USA**.

   **Tip** After clicking **Add**, you can simply begin typing. The focus is automatically given to the **Name** field, and you do not have to move the cursor there.

5. Click **OK**.

   You see that the **USA** dimension member has been added below **Region**.

   **Tip** When you click **OK**, you see that the **Reference** field is automatically made to be the same as the **Name** field. In this tutorial, you will not change the references of dimensions; however, for the models that you create for your company, you might want to devise a standard referencing methodology.

6. Select the **USA** dimension member.

7. Create a new dimension member under **USA** named **Oregon**.

   Note that the level is **Level2**. The reason for this is that you are adding a dimension member below a **Level1** dimension member.

8. Using the techniques that you have learned, create the following dimension members:
Creating Dimension Members

<table>
<thead>
<tr>
<th>Name</th>
<th>Reference</th>
<th>DimLevelName</th>
</tr>
</thead>
<tbody>
<tr>
<td>Region</td>
<td>Region</td>
<td></td>
</tr>
<tr>
<td>USA</td>
<td>USA</td>
<td>Level1</td>
</tr>
<tr>
<td>Oregon</td>
<td>Oregon</td>
<td>Level2</td>
</tr>
<tr>
<td>Beaverton</td>
<td>Beaverton</td>
<td>Level3</td>
</tr>
<tr>
<td>Eugene</td>
<td>Eugene</td>
<td>Level3</td>
</tr>
<tr>
<td>General Ledger</td>
<td>GL</td>
<td></td>
</tr>
<tr>
<td>Wages</td>
<td>Wages</td>
<td>Level1</td>
</tr>
<tr>
<td>Operating Expenses</td>
<td>Operating Expenses</td>
<td>Level1</td>
</tr>
<tr>
<td>Equipment Expenses</td>
<td>Equipment Expenses</td>
<td>Level1</td>
</tr>
<tr>
<td>Activities</td>
<td>Act</td>
<td></td>
</tr>
<tr>
<td>Personnel Intensive Activities</td>
<td>Personnel Intensive Activities</td>
<td>Level1</td>
</tr>
<tr>
<td>Resolve Customer Complaints</td>
<td>Resolve Customer Complaints</td>
<td>Level2</td>
</tr>
<tr>
<td>Expedite Package Shipment</td>
<td>Expedite Package Shipment</td>
<td>Level2</td>
</tr>
<tr>
<td>Local Collection</td>
<td>Local Collection</td>
<td>Level1</td>
</tr>
<tr>
<td>Move to Warehouse</td>
<td>Move to Warehouse</td>
<td>Level2</td>
</tr>
<tr>
<td>Local Processing</td>
<td>Local Processing</td>
<td>Level1</td>
</tr>
<tr>
<td>Sort</td>
<td>Sort</td>
<td>Level2</td>
</tr>
<tr>
<td>Inspect</td>
<td>Inspect</td>
<td>Level2</td>
</tr>
<tr>
<td>Regional Distribution</td>
<td>Regional Distribution</td>
<td>Level1</td>
</tr>
<tr>
<td>Air Distribution</td>
<td>Air Distribution</td>
<td>Level2</td>
</tr>
<tr>
<td>Land Distribution</td>
<td>Land Distribution</td>
<td>Level2</td>
</tr>
<tr>
<td>Channel</td>
<td>Channel</td>
<td></td>
</tr>
<tr>
<td>Drop Box</td>
<td>Drop Box</td>
<td>Level1</td>
</tr>
<tr>
<td>Walk In</td>
<td>Walk In</td>
<td>Level1</td>
</tr>
<tr>
<td>Commercial Pick Up</td>
<td>Commercial Pick Up</td>
<td>Level1</td>
</tr>
<tr>
<td>Products and Services</td>
<td>Prod_Serv</td>
<td></td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>2nd Day Guaranteed</td>
<td>Level1</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>Overnight Express</td>
<td>Level1</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>Standard Ground</td>
<td>Level1</td>
</tr>
<tr>
<td>Materials</td>
<td>Mat</td>
<td></td>
</tr>
</tbody>
</table>

Note: You will not create dimension members for the Materials dimension yet. You will add those dimension members when you create bills of costs.
Overview

An account is the basic repository of costs in a model. You create an account in SAS Activity-Based Management by defining an intersection between dimension members. For example, in the Parcel Express Tutorial model, you will create an account for tracking the costs of inspecting packages in Beaverton. You create this account by defining an intersection between Region and Activity dimension members, as shown here:

Region > USA > Oregon > Beaverton
  x
Activity > Regional Sorting > Inspect

Shorthand for the resulting account, or dimension intersection, is Beaverton x Inspect.

The costs of an account are derived from cost elements, which can either be added directly to the account or assigned from other accounts.

The following picture shows the accounts and cost elements that you will create in this chapter for each module:
In the following picture you can see that the account 2nd Day Guaranteed is the intersection of the dimension members Beaverton x Drop Box x 2nd Day Guaranteed. Those dimension members are, in turn, members of the dimensions Region x Channel x Products and Services respectively. You can notice that the display name of the account, 2nd Day Guaranteed, is the name of the last member in the intersection of the dimension members when the order of dimension members is the order of their containing dimensions—Region, Channel, Products. The order of dimensions is the order in which you define them when you create a model.
Building the Resource Module Structure

Start by creating a structure to hold the resource costs in the model.

- **Create resource accounts**
  1. To open the resource module, select **Model ⇒ Resource Module** (or click the Resource Module icon on the toolbar).
  2. Select **Edit ⇒ New Account**. (or right-click RESOURCE (PRIMARY PAN) and select **New Account**.

You see Step 1 of the New Account Wizard.

The **Dimensions** area contains the dimensions of the resource module. The **Accounts** area will contain the accounts that you create.

3. Expand **Region** to display all of its dimension members.
4. In the **Dimensions** list, select the following dimension members:
   - Beaverton
   - Eugene
   - Wages
   - Operating Expenses
   - Equipment Expenses
5. Verify that **leaf dimension members only** is selected in the Create accounts using field.

   ![New Account - Create Accounts at Dimension Intersections](image)

6. Click **Add**.

You see that the following accounts have been added to the **Accounts** list:
7. Click **Next**.

You see Step 2 of the New Account Wizard. Here, you will add the cost elements and costs of each account.

<table>
<thead>
<tr>
<th>Account Name</th>
<th>Reference</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Wages</td>
<td>BS</td>
<td>1,563,000.00</td>
</tr>
<tr>
<td>Beaverton x Operating Expenses</td>
<td>BOT</td>
<td>75,600.00</td>
</tr>
</tbody>
</table>

**TIP** The system has automatically generated a unique name and reference for each account. The names and references that you see will be different from those shown in the window. These names and references are used in reports and operational summaries, but they do not appear elsewhere on a page, unless you add columns to display them. Your company can decide whether to use the system-generated names or to use a naming and referencing methodology. If your models are extremely large, it will probably be more convenient to use system-generated account names and references.

- **Add cost elements and costs**
  1. Select the **Beaverton x Wages** account and click **Add Cost Element** twice.

You see that two cost elements have been added to the account table. The names and references of these cost elements are system-generated. In the account table, you can add costs and change the names and references of cost elements.

2. Change the names and references of the two cost elements that you added and enter their costs, as follows:

<table>
<thead>
<tr>
<th>Cost Element Name</th>
<th>Cost Element Reference</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>Salaries</td>
<td>BS</td>
<td>1,563,000.00</td>
</tr>
<tr>
<td>Overtime</td>
<td>BOT</td>
<td>75,600.00</td>
</tr>
</tbody>
</table>
The New Account window should look like the following:

![New Account window](image)

**Note:** In large models, costs might be imported from other sources, such as a database. In that case, you could create the cost elements, but leave the costs empty.

3. Using the techniques that you have learned, create cost elements and enter costs as follows:

<table>
<thead>
<tr>
<th>Account</th>
<th>Cost Element Name</th>
<th>Cost Element Reference</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x</td>
<td>Operating Expenses</td>
<td>BOE</td>
<td>228,000.00</td>
</tr>
<tr>
<td>Operating Expenses</td>
<td>Office Supplies</td>
<td>BOS</td>
<td>10,000.00</td>
</tr>
<tr>
<td>Beaverton x</td>
<td>Equipment Depreciation</td>
<td>BED</td>
<td>54,300.00</td>
</tr>
<tr>
<td>Equipment Expenses</td>
<td>Salaries</td>
<td>ES</td>
<td>1,298,000.00</td>
</tr>
<tr>
<td></td>
<td>Overtime</td>
<td>EOT</td>
<td>110,000.00</td>
</tr>
<tr>
<td>Eugene x Wages</td>
<td>Operating Expenses</td>
<td>EOE</td>
<td>263,000.00</td>
</tr>
<tr>
<td>Operating Expenses</td>
<td>Office Supplies</td>
<td>EOS</td>
<td>8,000.00</td>
</tr>
<tr>
<td>Eugene x</td>
<td>Equipment Depreciation</td>
<td>EED</td>
<td>38,000.00</td>
</tr>
</tbody>
</table>
4. Click **Next**.
You see Step 3 of the New Account Wizard. This step contains a summary of the accounts, cost elements, and costs you are about to create.

5. Click **Finish**.
You see that the accounts have been added to the resource module.

The system automatically rolls up costs from cost elements, to accounts, to higher-dimension levels.

The following picture shows some alternative arrangements of accounts that you could have adopted from the available dimensions and dimension members by not selecting the option to add **leaf dimension members only**. (The arrangement chosen for this tutorial is circled.) Notice that the icon indicates that the accounts belong to the resource module.
Building the Activity Module Structure

An activity is a task that consumes resources. Examples of activities include setting up a machine to produce a particular part, scheduling production of a certain number of products, and inspecting a batch of parts. In a model, you identify activities and calculate their costs.

Creating Activity Accounts

In the activity module, you will create activity accounts.

- Create activity accounts
  1. To open the activity module, select **Model ⇒ Activity Module** (or click the Activity Module icon on the toolbar).
  2. Select **Edit ⇒ New Account**.
     
     You see the New Account Wizard.
  3. Using the New Account Wizard, create the following accounts:
     
     *Note:* Do not create cost elements. Costs will be assigned to these accounts from other accounts.
<table>
<thead>
<tr>
<th>Dimension Intersection</th>
<th>Personnel Intensive Activities</th>
<th>Local Collection</th>
<th>Local Processing</th>
<th>Regional Distribution</th>
<th>Personnel Intensive Activities</th>
<th>Local Collection</th>
<th>Local Processing</th>
<th>Regional Distribution</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Beaverton x Resolve Customer Complaints</td>
<td>Beaverton x Expedite Package Shipments</td>
<td>Beaverton x Move to Warehouse</td>
<td>Beaverton x Air Distribution</td>
<td>Beaverton x Land Distribution</td>
<td>Eugene x Resolve Customer Complaints</td>
<td>Eugene x Expedite Package Shipments</td>
<td>Eugene x Land Distribution</td>
</tr>
<tr>
<td></td>
<td>Beaverton x Sort</td>
<td>Beaverton x Inspect</td>
<td>Oregon x Move to Warehouse</td>
<td>Oregon x Sort</td>
<td>Oregon x Inspect</td>
<td>Oregon x Air Distribution</td>
<td>Oregon x Land Distribution</td>
<td>Oregon x Inspect</td>
</tr>
</tbody>
</table>

**Note:** There is no Air Distribution from Eugene.

**Note:** A quick way to create the Activity module accounts is to add the dimensions shown in the following picture and then remove the one Eugene x Air Distribution account.

Create accounts using:

- Select these
- Remove this

After completing the steps of the New Account Wizard, you see the following activity module structure (notice that the icon indicates that the accounts belong to the activity module):
Building the Cost Object Module Structure

The cost object module will hold information about Parcel Express Tutorial's products and services. Its dimensions are Channel and Products and Services.

Omitting a Dimension from an Account

You can create accounts that omit one or more dimensions of a module. In the cost object module of the Parcel Express Tutorial model, you will create accounts that have a Channel dimension member, but no Products and Services dimension member, and vice versa. The purpose of these omissions is to track the unique costs of a channel that are unassociated with any product, and to track the unique costs of a product that are unassociated with any channel. To omit a dimension from an account, you select the No option in the New Account Wizard.

Examples of accounts that omit a dimension are:

- Drop Box x No <Products and Services>
  (tracks unique costs that are associated with the Drop Box channel)
- No <Channel> x 2nd Day Guaranteed
  (tracks unique costs that are associated with the 2nd Day Guaranteed product)

Note: You have not entered cost elements for these accounts, and no costs have been assigned yet, so cost is $0.00.
Creating Cost Object Accounts

- **Create cost object accounts**

Using the techniques that you have learned, create the following accounts in the cost object module for each regional office Beaverton and Eugene:

*Note:* Do not create cost elements. Costs will be assigned to these accounts from other accounts.

<table>
<thead>
<tr>
<th>Dimension Intersection</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drop Box x 2nd Day Guaranteed</td>
</tr>
<tr>
<td>Drop Box x Overnight Express</td>
</tr>
<tr>
<td>Drop Box x Standard Ground</td>
</tr>
<tr>
<td>Drop Box x No &lt;Products and Services&gt;</td>
</tr>
<tr>
<td>Walk In x 2nd Day Guaranteed</td>
</tr>
<tr>
<td>Walk In x Overnight Express</td>
</tr>
<tr>
<td>Walk In x Standard Ground</td>
</tr>
<tr>
<td>Walk In x No &lt;Products and Services&gt;</td>
</tr>
<tr>
<td>Commercial Pick Up x 2nd Day Guaranteed</td>
</tr>
<tr>
<td>Commercial Pick Up x Overnight Express</td>
</tr>
<tr>
<td>Commercial Pick Up x Standard Ground</td>
</tr>
<tr>
<td>Commercial Pick Up x No &lt;Products and Services&gt;</td>
</tr>
<tr>
<td>No &lt;Channel&gt; x 2nd Day Guaranteed</td>
</tr>
<tr>
<td>No &lt;Channel&gt; x Overnight Express</td>
</tr>
<tr>
<td>No &lt;Channel&gt; x Standard Ground</td>
</tr>
</tbody>
</table>

*Note:* You can create these accounts all at once by checking the leaf dimension members that are shown in the following display. This quick method, however, results in creating two meaningless accounts that you can delete afterward:

- Beaverton x No <Channel> x No <Products and Services>
- Eugene x No <Channel> x No <Products and Services>
After you have created these accounts, you see the following cost object module structure:
<table>
<thead>
<tr>
<th>Display Name</th>
<th>Display Reference</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>COST OBJECT (PRIMARY PANE)</td>
<td></td>
<td>$0.00</td>
</tr>
<tr>
<td>USA</td>
<td>USA</td>
<td>$0.00</td>
</tr>
<tr>
<td>Oregon</td>
<td>Oregon</td>
<td>$0.00</td>
</tr>
<tr>
<td>Beaverton</td>
<td>Beaverton</td>
<td>$0.00</td>
</tr>
<tr>
<td>Drop Box</td>
<td>Drop Box</td>
<td>$0.00</td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>2nd Day Guaranteed</td>
<td>$0.00</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>Overnight Express</td>
<td>$0.00</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>Standard Ground</td>
<td>$0.00</td>
</tr>
<tr>
<td>No &lt;Products and Services&gt;</td>
<td>No &lt;Prod_SERV&gt;</td>
<td>$0.00</td>
</tr>
<tr>
<td>Walk In</td>
<td>Walk In</td>
<td>$0.00</td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>2nd Day Guaranteed</td>
<td>$0.00</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>Overnight Express</td>
<td>$0.00</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>Standard Ground</td>
<td>$0.00</td>
</tr>
<tr>
<td>No &lt;Products and Services&gt;</td>
<td>No &lt;Prod_SERV&gt;</td>
<td>$0.00</td>
</tr>
<tr>
<td>Commercial Pick Up</td>
<td>Commercial Pick Up</td>
<td>$0.00</td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>2nd Day Guaranteed</td>
<td>$0.00</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>Overnight Express</td>
<td>$0.00</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>Standard Ground</td>
<td>$0.00</td>
</tr>
<tr>
<td>No &lt;Products and Services&gt;</td>
<td>No &lt;Prod_SERV&gt;</td>
<td>$0.00</td>
</tr>
<tr>
<td>No &lt;Channel&gt;</td>
<td>No &lt;Channel&gt;</td>
<td>$0.00</td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>2nd Day Guaranteed</td>
<td>$0.00</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>Overnight Express</td>
<td>$0.00</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>Standard Ground</td>
<td>$0.00</td>
</tr>
<tr>
<td>No &lt;Products and Services&gt;</td>
<td>No &lt;Prod_SERV&gt;</td>
<td>$0.00</td>
</tr>
<tr>
<td>Eugene</td>
<td>Eugene</td>
<td>$0.00</td>
</tr>
<tr>
<td>Drop Box</td>
<td>Drop Box</td>
<td>$0.00</td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>2nd Day Guaranteed</td>
<td>$0.00</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>Overnight Express</td>
<td>$0.00</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>Standard Ground</td>
<td>$0.00</td>
</tr>
<tr>
<td>No &lt;Products and Services&gt;</td>
<td>No &lt;Prod_SERV&gt;</td>
<td>$0.00</td>
</tr>
<tr>
<td>Walk In</td>
<td>Walk In</td>
<td>$0.00</td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>2nd Day Guaranteed</td>
<td>$0.00</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>Overnight Express</td>
<td>$0.00</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>Standard Ground</td>
<td>$0.00</td>
</tr>
<tr>
<td>No &lt;Products and Services&gt;</td>
<td>No &lt;Prod_SERV&gt;</td>
<td>$0.00</td>
</tr>
<tr>
<td>Commercial Pick Up</td>
<td>Commercial Pick Up</td>
<td>$0.00</td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>2nd Day Guaranteed</td>
<td>$0.00</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>Overnight Express</td>
<td>$0.00</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>Standard Ground</td>
<td>$0.00</td>
</tr>
<tr>
<td>No &lt;Products and Services&gt;</td>
<td>No &lt;Prod_SERV&gt;</td>
<td>$0.00</td>
</tr>
<tr>
<td>No &lt;Channel&gt;</td>
<td>No &lt;Channel&gt;</td>
<td>$0.00</td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>2nd Day Guaranteed</td>
<td>$0.00</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>Overnight Express</td>
<td>$0.00</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>Standard Ground</td>
<td>$0.00</td>
</tr>
<tr>
<td>No &lt;Products and Services&gt;</td>
<td>No &lt;Prod_SERV&gt;</td>
<td>$0.00</td>
</tr>
</tbody>
</table>
Overview

An attribute is a label or identification tag that is attached to an account or roll-up account. The attribute conveys information about the object to which it is attached.

Attributes have many purposes. You can use them to do the following:

• group activity-based management data to simplify report preparation and interpretation
• create different dimensions of data
• report similar cost categories across cost centers
• classify cost components as fixed or variable, value-added or non-value-added
• use them in the definition of a calculated driver
Types of Attributes

Overview

There are five attribute types:
- text
- numeric
- calculated
- dimension
- tag

Text Attributes

A text attribute describes model information. You can use text attributes to annotate a model. You can use them to provide information about a model. You will see an example in this chapter.

Note: Text attributes cannot be viewed in OLAP.

Numeric Attributes

A numeric attribute enables you to enter data that is not entered or otherwise generated in a model.

Typically, numeric attributes are measures or quantities of units that contribute to the total cost of an activity, such as number of cases, number of pounds, number of orders, or number of times an activity is performed.

You can establish numeric attributes as performance measures for special reporting purposes, such as tracking productivity (number of inputs or rejects, cycle time, and quality), or classifying information (level of complexity or number of subassemblies). Use the Default Value field under the Advanced tab to define data that is specific to that attribute.
**Calculated Numeric Attributes**

Numeric attributes can be calculated. Calculated numeric attributes are also user-defined attributes, but they rely on a formula to express their characteristics. This formula is developed by the user to capture unique business data. Calculated numeric attributes can be used in a driver definition.

**Dimension and Dimension Member Attributes**

A dimension attribute reflects a dimension, and a dimension member attribute reflects a dimension member. Dimension attributes enable you to categorize, select, and subtotal information in a report. For example, activities can be grouped by summary-level processes, such as detailed manufacturing activities rolling up to manufacturing, and detailed distribution activities rolling up to distribution. The names of these higher-level processes are defined as dimension member attributes and are attached to their respective activities. Most importantly, you can query for dimension member attributes in OLAP.

Other examples of dimension attributes include:

- value-added categories (high, medium, low) that are attached to activities
- fixed cost/variable cost that is attached to resources enables you to group activity or cost object costs by fixed and variable cost components
- cost object groupings that are used to roll up products by product family, brand, market segment, or package type, or to group customers by region, channel, or salesperson

**Tag Attributes**

A tag attribute is one that is either attached (tagged) to an account or not. You can use the HasAttribute function to test whether an account has the attribute.

*Note:* Tag attributes used to be called Boolean attributes in previous releases of SAS Activity-Based Management. Tag attributes cannot be viewed in OLAP.
Creating Attributes

You will create a text attribute, a numeric attribute, and a dimension attribute.

• **Create a text attribute**
  1. Select **Model ⇒ Attributes Page**.
  2. Select **Edit ⇒ New Attribute** (or right-click ATTRIBUTES (PRIMARY PANE) and select **New Attribute**).
    You see the New Attribute dialog box.
    
    ![New Attribute dialog box](image)
    
    3. For **Name**, type **Manager**.
    4. Select an **Attribute type** of **Text**.
    5. Click **OK**.
    You see that the Manager attribute has been added to the list.

• **Create a numeric attribute**
  1. Select **Model ⇒ Attributes Page**.
  2. Select **Edit ⇒ New Attribute**.
    You see the New Attribute dialog box.
  3. For **Name**, type **Number of Inspections**.
  4. For **Reference**, type **Num of Ins**.
  5. Select an **Attribute type** of **Numeric**.
    **Tip** You can type “n” to change the selection to Numeric in addition to using the drop-down list.
  6. For **Unit of Measure**, type **Inspections**.

To summarize:
7. Click **OK**.
   You see that the Number of Inspections attribute has been added to the list.

8. Create three more numeric attributes.

<table>
<thead>
<tr>
<th>Name</th>
<th>Reference</th>
<th>Type</th>
<th>Unit of Measure</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Inspections</td>
<td>Num of Ins</td>
<td>Numeric</td>
<td>Inspections</td>
</tr>
<tr>
<td>Inspections Passed</td>
<td>I_P</td>
<td>Numeric</td>
<td>Units Passed</td>
</tr>
<tr>
<td>Completed Expedite Requests</td>
<td>Completed Expedite Requests</td>
<td>Numeric</td>
<td>Completed Requests</td>
</tr>
<tr>
<td>Average Time to Expedite</td>
<td>Average Time to Expedite</td>
<td>Numeric</td>
<td>Hours</td>
</tr>
</tbody>
</table>

- **Create a calculated numeric attribute**

<table>
<thead>
<tr>
<th>Name</th>
<th>Reference</th>
<th>Type</th>
<th>Unit of Measure</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cost per Inspection</td>
<td>Cost per Inspection</td>
<td>Numeric</td>
<td>Dollars</td>
<td>Cost / “Num of Ins”</td>
</tr>
</tbody>
</table>

1. Select **Edit ⇒ New Attribute**.
2. For **Name**, type **Cost per Inspection**.
3. For **Reference**, type **Cost per Inspection**.
4. Select an **Attribute type** of **Numeric**.
5. Select **Dollars** for Unit of Measure.
6. Select the **Advanced** tab.
7. Verify that the period is 2008 Q1 / Actual.
8. Select the Calculated check box. This allows you to enter a formula.
9. Click Formula Builder.
   You see the Formula Builder dialog box.

10. The cost of inspection would be derived from a formula of Cost divided by the Number of Inspections. Create this formula by double-clicking each element. The formula will appear in the Formula area.
11. Click Test to verify the syntax of the formula.
12. Click OK to dismiss the message box.
13. Click OK to accept the formula.
14. Click OK to create the attribute.
15. Create a calculated numeric attribute for Percent of Inspections Passed.

<table>
<thead>
<tr>
<th>Name</th>
<th>Reference</th>
<th>Type</th>
<th>UoM</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>Percent of Inspections Passed</td>
<td>Percent of Inspections</td>
<td>Numeric</td>
<td>Calculated</td>
<td>“I_P”/“Num of Ins”</td>
</tr>
</tbody>
</table>

• Create a dimension attribute

<table>
<thead>
<tr>
<th>Name</th>
<th>Reference</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fixed_Variable</td>
<td>FV</td>
<td>Dimension</td>
</tr>
</tbody>
</table>

1. Select Edit ⊳ New Attribute.
2. For Name, type Fixed_Variable.
3. For Reference, type FV.
4. Select a Type of Dimension.
5. For Short Reference, type FV.
6. Click OK.

Notice that the attribute is created as a folder to contain its dimension member attributes which you create next.

7. Select the Fixed_Variable attribute folder.
8. Create the following two dimension member attributes:

<table>
<thead>
<tr>
<th>Name</th>
<th>Reference</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fixed</td>
<td>F</td>
<td>Dimension Member</td>
</tr>
<tr>
<td>Variable</td>
<td>V</td>
<td>Dimension Member</td>
</tr>
</tbody>
</table>

You see that the Fixed_Variable dimension and its two-dimension members have been added to the list of your model's dimensions.

---

**Creating a Column Layout**

To view the attributes in the model, add a column. For the Parcel Express Tutorial model, you will create a column layout named Cost Assignments. Initially, you will define the column layout for the activity module. Later, you will add columns to the layout for the other modules to create a cost assignment column view.

- **Add a column to show an attribute**
  1. Select Model ⇒ Activity Module.
  2. Select Model ⇒ Column Layout ⇒ Edit Columns.

    *Note*: You can also double-click the column header, as shown in the following picture, to open the Column Layout dialog box.

You see the Column Layout dialog box.
The columns that you see in the Displayed columns list refer to the layout for a specific pane in a specific module. In the illustration, you see the column layout for the Primary pane of the Activity Module. To change the column layout for a different pane or module, select that pane or module. The Inspections Passed column layout that you create in this tutorial will ultimately contain layouts for several modules and panes.

Note: A column layout is a read-only view of columns that already exist in tables in your model. Adding or removing a column from a column layout does not add or remove a column from a table; nor, for that matter, does creating a column layout create a table or add or remove columns from any table.

- Define the column layout for one panel.
  1. Verify that the Primary pane tab is selected.
  2. From the Displayed columns list, select Display Reference.
  3. Click Remove.
     You see that Display Reference has been removed from the list of Displayed columns. Removing this column from the layout will provide more screen space for columns that are relevant to making driver assignments.
  4. From the Properties, Attributes, and Dimensions list, select Inspections Passed (under the Attributes folder).
  5. Click Add.
     You see that Inspections Passed has been added to the Displayed columns list.
  6. Select Manager (under the Attributes folder), and then click Add.
     You see that Manager has been added to the Displayed columns list.

- Save the column layout
  1. Click Save As.
You see the Save Column Layout As dialog box.

2. Verify that the **New column layout** option is selected, and then type **Cost Assignments**.

3. Click **OK**.

You see that the column layout **Name** has been changed to **Cost Assignments**.

4. Click **OK**.

You see the changes that you made to the column layout. **Cost Assignments** is the active column layout, and **Inspections Passed** and **Manager** appear in the column layout list.

---

**Entering Attribute Values**

Now, you will display a column to enter attribute values.

- **Enter attribute values**

1. Expand the Activity module by right-clicking the **Activity** row and selecting **Expand All Levels**

2. In the **Inspections Passed** column for the **Beaverton x Inspect** account, type **43400**.

3. In the **Inspections Passed** column for the **Eugene x Inspect** account, type **1100**.
4. In the **Manager** column for the **Beaverton x Sort** account, type **Smith**.

5. In the **Manager** column for the **Eugene x Sort** account, type **Jones**.

### Applying Additional Attributes to Accounts

Having created the dimension attribute **Fixed_Variable** with its two dimension member attributes, **Fixed** and **Variable**, you can apply the dimension member attributes to accounts.

**Note:** You can attach attributes to accounts, but not to cost elements or to roll-up accounts.

- **Apply one attribute**

  1. Switch to the **Resources** page (remember that you can click the Resource Module icon on the toolbar).

  2. Right-click the **Beaverton x Wages** account, and then select **Manage Attributes** from the pop-up menu.

The Manage Accounts dialog box opens.

3. From the Manage Accounts dialog box, double-click **Fixed_Variable** to add it to the list of the account's attributes. (Or, select **Fixed_Variable** and click **Add**.)

4. Select **Fixed** from the drop-down list of dimension member attributes.
5. Click **OK** to apply the attribute **Fixed** to the **Wages** account.

The attribute is added to the account.

Before adding the Fixed or Variable attribute to additional accounts, let’s add the Fixed_Variable attribute column to the layout so that we can add the attributes more easily and better see the results.

• **Add a Fixed_Variable column to the column layout**

1. Right-click (or double-click) the column header, and then select **Edit Columns** from the pop-up menu. (Or, select **Model** ⇒ **Column Layout** ⇒ **Edit Columns**.)

The Column Layout dialog box opens.

2. In the Column Layout dialog box, double-click **Fixed_Variable** (under the Attributes folder). (Or, select **Fixed_Variable** and click **Add**.)

3. Click **OK** to add the Fixed_Variable column to the column layout.
Now we can more easily apply additional **Fixed** and **Variable** attributes to accounts.

- **Apply additional attributes to accounts**
  1. Select the Beaverton x Operating Expenses account.
  2. From the menu in the **Fixed_Variable** column, select **Variable**.
  3. Repeat the process to apply the following dimension member attributes to the following accounts:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Account</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fixed</td>
<td>Eugene x Wages</td>
</tr>
<tr>
<td>Variable</td>
<td>Eugene x Operating Expenses</td>
</tr>
</tbody>
</table>

Note that it is not necessary to apply the attribute to all the resource accounts, as we are not applying it to the Equipment Expenses account.

Later, when we describe "Using OLAP Cubes for Analysis," we will see that OLAP analysis allows, in this case, querying fixed-cost contributions versus variable-cost contributions. Dimension member attributes allow much of the functionality of real dimensions, without some of the overhead. In fact, they can provide a method of adding "dimensions" to a model, whereas the model itself cannot have dimensions added after the initial model definition.
Chapter 9
Drivers for the Model

Overview

An important aspect of activity-based management is the understanding of how activities in an organization consume expenses and how products consume activities. These consumptions are governed by relevant drivers, which measure the frequency or intensity of the cost demands that are placed on resources and activities. A driver specifies how costs are assigned.

This tutorial uses both system-defined and user-defined drivers.

The first step in assigning resource costs to activities and activity costs to cost objects is building a list of drivers.

The Parcel Express Tutorial model uses several system-defined drivers. Additionally, you will create the following drivers:

<table>
<thead>
<tr>
<th>User-Defined Driver</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>FTEs</td>
<td>Tracks the cost of wages from the resource module to the activity module.</td>
</tr>
<tr>
<td>Dollars</td>
<td>Tracks the cost of operating expenses from the resource module to the activity module.</td>
</tr>
<tr>
<td>Number of Customer Complaints</td>
<td>Tracks the number of customer complaints per channel.</td>
</tr>
<tr>
<td>Number of Packages</td>
<td>Tracks the number of packages that were collected, sorted, and distributed.</td>
</tr>
<tr>
<td>Number of Expedite Requests</td>
<td>Tracks the packages that are expedited regionally.</td>
</tr>
</tbody>
</table>

• Define basic drivers
  1. Select Model ⇒ Drivers Page.

You see the following list of system-defined drivers:
2. Select **Edit ⇒ New Driver**. (Or, right-click **Drivers** and select **New Driver**.) You see the New Driver dialog box.

3. For **Name**, type **FTEs**.
4. Verify that the **Driver type** is **Basic**.
5. Verify that the **This driver's quantities are unique** option is checked.
6. Verify that **Allow fixed driver quantities for this driver** is checked.
7. Click **OK**.

You see that **FTEs** has been added to the list of drivers.

8. Add the following **Basic** type of drivers:

<table>
<thead>
<tr>
<th>Driver</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dollars</td>
<td>Basic</td>
</tr>
<tr>
<td>Number of Customer Complaints</td>
<td>Basic</td>
</tr>
<tr>
<td>Number of Packages</td>
<td>Basic</td>
</tr>
</tbody>
</table>
9. Select the following options for the **Number of Packages** driver:

- This driver’s quantities are unique
- Allow fixed driver quantities for this driver
- Allow variable driver quantities for this driver
- Allow weighted driver quantities for this driver

The Number of Expedite Requests is a calculated driver. Calculated drivers expand system capability, enabling you to define cost drivers that are unique to your business. You define these calculated drivers with formulas that you create using the system-generated numeric properties and attributes that you have defined for your unique usage. The calculated driver in this tutorial will use attributes that you have just created and numeric properties generated by the system.

**Defining a calculated driver**

<table>
<thead>
<tr>
<th>Driver</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Expedite Requests</td>
<td>[“Average Time to Expedite” * “Completed Expedite Requests”] / DriverQuantityFixed</td>
</tr>
</tbody>
</table>

1. Add **Number of Expedite Requests** as a calculated driver. For **Driver type**, select **Calculated**.
2. Verify that the **This driver’s quantities are unique** option is checked.
3. Verify that **Allow fixed driver quantities for this driver** is checked.
4. Click **Formula Builder**.

You see the Formula Builder dialog box.

*Note:* In the following instructions, you can choose an element of the formula either by double-clicking the element, or by selecting it and clicking **Insert**.
5. Choose ( from the Operators list.
6. Chose Average Time to Expedite from the Attributes list.
7. Choose * from the Operators list.
8. Choose Completed Expedite Requests as the multiplier from the Attributes list.
9. Choose ) to close the set.
10. Choose / from the Operators list.
11. Choose DriverQuantityFixed from the Numeric properties list.

DriverQuantityFixed is the user-entered fixed quantity that flows from one account to another. You can change this value only on assigned cost elements with a driver that allows fixed driver quantities.

12. Click Test to verify the syntax of the formula.
13. Click OK to accept the formula.
14. Click OK to create the driver.
Review the list of drivers.

<table>
<thead>
<tr>
<th>Driver Name</th>
<th>Dry Type</th>
<th>Using</th>
<th>Use Variability</th>
<th>Use Variability</th>
<th>Use Variable</th>
<th>Use Weighted</th>
<th>Use Cost Allocation</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bill of Cost</td>
<td>Bill of Cost</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Evenly Assigned</td>
<td>Evenly Assigned</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Percentage</td>
<td>Percentage</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sales volume</td>
<td>Sales Volume</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>PFC</td>
<td>PFC</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Dollars</td>
<td>Dollars</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Number of Customer Complaints</td>
<td>Basics</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Number of Passengers</td>
<td>Basics</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Number of Expedite Requests</td>
<td>Calculated</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td><em>(Average - Time to Expedite * Completed Expedite Requests) / Driver Quantity Fixed</em></td>
</tr>
</tbody>
</table>
Overview

An assignment links source accounts to destination accounts. Costs flow along this path from resources to activities to cost objects from expenses to activities to products, services, or customers. A source account is the source of a cost assignment. A destination account receives the results of a cost assignment.
As shown, the possible assignments between accounts, as indicated by letters, are:

- A resource to resource
- B resource to cost object
- C resource to activity
- D activity to activity
- E activity to cost object
- F cost object to cost object

### Using a Column Layout

In a previous section, you created a column layout named Cost Assignments for the activity module. In the following sections, you will add columns to the layout for the other modules.

While building the model structure, you have been working in the single pane view. To make assignments, you need to open an assignments pane. When the primary pane and an assignments pane are open, you can see source accounts, destination accounts, assignments, driver names, and driver quantities. To assign resource costs to activity accounts, you will open the right assignments pane.

- **Open the right assignments pane and Column Layout dialog box**
  2. If it is not already open, open the Cost Assignments saved column layout.
  3. In the resource module, select Model ➔ Assignments ➔ Show right assignments pane.

You see the right assignments pane (to the right of the resource module primary pane). The default columns are IntsctnName, Reference, and Cost.

**TIP** You can split the assignments panes simply by clicking the Show Left and Right Assignments Panes button. It is not necessary to pull down the menu.

**TIP** You might want to hide the Navigation Pane on the left side of the window to display more data. To do this, click the X in the upper-right corner of the pane. You can make columns of the assignments panes wider or narrower by clicking on the line between two column headings and dragging the edge of the column to the width that you want.

4. Select Model ➔ Column Layout ➔ Edit Columns.

The columns that you see in the Displayed columns list refer to the layout for a specific pane in a specific module. Because you are currently viewing the resource module, you see the column layout for the primary pane of the resource module. To change the column layout for a different pane or module, select that pane or module. The Cost Assignments column layout that you create in this tutorial will ultimately contain layouts for several modules and panes.
• Define the column layout for two panes

1. Verify that the **Primary** pane tab is selected.

2. From the **Displayed columns** list, select **Display Reference**.

3. Click **Remove**.

   You see that **Display Reference** has been removed from the list of **Displayed columns**. Removing this column from the layout will provide more space for columns that are relevant to making driver assignments. Remember that removing a column from a column layout does not remove it from any table in the model; it simply changes your view of the model.

4. In **Drivers**, select **Driver Name (DrvName)**.

   **TIP** To find **Driver Name (DrvName)**, scroll down to **Driver** and expand it.

5. Click **Add**.

   You see that **Driver Name (DrvName)** has been added to the **Displayed columns** list.

6. Click the **Right** pane tab.

   You see the default columns of the right pane in the **Displayed columns** list.

7. Remove the **Reference** column from the **Displayed columns** list.

8. Add the **Driver Quantity Fixed (DQF)** property to the **Displayed columns** list.

• Save the column layout

1. Click **Save**.

2. Click **OK** to dismiss the Column Layout dialog box.

   You see the changes that you made to the Cost Assignments column layout appear in the Column Layout list.

*Note:* If your column layout has too many column headings to be able to view in a window all at once, you can use the scroll wheel of the mouse to scroll the column headings.
Making Assignments from Resources to Activities

The first assignments that you make will be inter-modular; that is, assignments from the resource module to the activity module.

- Add accounts for assignments
  1. Select Model ⇒ Assignments ⇒ Add Accounts in Right Pane.
     You see the Add Accounts for Assignments dialog box.

     ![Add Accounts for Assignments dialog box]

     2. Verify that the Activity module is selected.
     3. Expand Activity so that you can see the Beaverton and Eugene roll-up accounts.
     4. Select the Beaverton roll-up account, and then click Add Accounts.
        You see that the Beaverton activity accounts have been added to the right pane.
     5. Add the Eugene activity accounts to the right pane.
     6. Click Close.

     Note: To avoid mixing up assignments between Beaverton resources and Eugene accounts (and vice versa), consider adding only the Beaverton accounts first to the right pane. Next, make the assignments. Then, do the same for Eugene.

     Note: Clearing accounts from the right pane does not delete assignments from your model. It removes the accounts from view temporarily.

Now that the intended destination accounts are displayed, you can make assignments from resource accounts to activity accounts.

- Make assignments
  1. In the primary pane, expand Resource to display all of its accounts.

     TIP Select View ⇒ Expand to display subfolders. In this tutorial, you do not need to expand the module hierarchies to display the cost elements of each account. If the cost elements are displayed, collapse the hierarchy to hide them.
2. Select the **Wages** account under **Beaverton**.

You see that arrows appear next to each account in the right pane. These arrows indicate that you can make assignments from Beaverton Wages to any of the listed accounts. Logically, the cost of wages in Beaverton would be assigned only to Beaverton activities, not Eugene activities.

3. In the **Wages** row under **Beaverton** click on the cell in the **DrvName** column.

You see a list of available drivers, including system-defined and user-defined drivers.

4. Select **FTEs**.

5. Make assignments to all of the Beaverton accounts in the right pane by clicking the arrow next to each account.

   **Note:** You can use the hotkey F7 to create assignments between the selected account and all of the accounts in the other assignments pane.

You see that a line now connects Beaverton Wages to each of the arrows that you clicked.

6. Type the following values in the **DQF** column in the right pane (the order of accounts might be different from the order that is shown; be careful to assign values to the correct accounts):

<table>
<thead>
<tr>
<th>InstructionsName</th>
<th>Cost</th>
<th>DQF</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Air Distribution</td>
<td>$0.00</td>
<td>9.00</td>
</tr>
<tr>
<td>Beaverton x Inspect</td>
<td>$0.00</td>
<td>3.00</td>
</tr>
<tr>
<td>Beaverton x Sort</td>
<td>$0.00</td>
<td>4.00</td>
</tr>
<tr>
<td>Beaverton x Move to Warehouse</td>
<td>$0.00</td>
<td>3.00</td>
</tr>
<tr>
<td>Beaverton x Expedite Package Shipment</td>
<td>$0.00</td>
<td>2.00</td>
</tr>
<tr>
<td>Beaverton x Resolve Customer Complaints</td>
<td>$0.00</td>
<td>3.00</td>
</tr>
<tr>
<td>Beaverton x Land Distribution</td>
<td>$0.00</td>
<td>12.00</td>
</tr>
</tbody>
</table>
Note: The total cost of Beaverton Wages ($1,638,600.00) will be consumed by these seven activity accounts according to the number of FTEs that you have entered. SAS Activity-Based Management performs the math for you when you calculate costs in a later lesson.

After making the assignments, your model should look like this (the order of accounts might differ):

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Driver</th>
<th>Resource Account</th>
<th>Activity Account</th>
<th>DQF</th>
</tr>
</thead>
<tbody>
<tr>
<td>RESOURCE (PRIMARY Pane)</td>
<td></td>
<td>Beaverton x Operating Expenses</td>
<td>Beaverton x Resolve Customer Complaints</td>
<td>6,500.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Beaverton x Expedite Package Shipments</td>
<td>8,000.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Beaverton x Move to Warehouse</td>
<td>15,000.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Beaverton x Sort</td>
<td>23,000.00</td>
</tr>
<tr>
<td>Beaverton</td>
<td></td>
<td></td>
<td>Beaverton x Inspect</td>
<td>54,000.00</td>
</tr>
<tr>
<td>Oregon</td>
<td></td>
<td></td>
<td>Beaverton x Air Distribution</td>
<td>83,000.00</td>
</tr>
<tr>
<td>Beaverton</td>
<td></td>
<td>Beaverton x Land Distribution</td>
<td></td>
<td>56,500.00</td>
</tr>
</tbody>
</table>

• Make other assignments

Note: Remember that when making assignments, you must first select a driver before you can select a destination account and assign a numeric value to the account.

1. In the primary pane, select Operating Expenses for Beaverton and make the following assignments:

<table>
<thead>
<tr>
<th>Resource Account</th>
<th>Driver</th>
<th>Activity Account</th>
<th>DQF</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x</td>
<td>Dollars</td>
<td>Beaverton x Resolve Customer Complaints</td>
<td>6,500.00</td>
</tr>
<tr>
<td>Operating Expenses</td>
<td></td>
<td>Beaverton x Expedite Package Shipments</td>
<td>8,000.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Move to Warehouse</td>
<td>15,000.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Sort</td>
<td>23,000.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Inspect</td>
<td>54,000.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Air Distribution</td>
<td>83,000.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Land Distribution</td>
<td>56,500.00</td>
</tr>
</tbody>
</table>

After making the assignments, your model should look like the following (again the order of accounts might be different):
2. In the primary pane, select **Equipment Expenses** for **Beaverton** and make the following assignments:

<table>
<thead>
<tr>
<th>Resource Account</th>
<th>Driver</th>
<th>Activity Account</th>
<th>DQF</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x</td>
<td>Percentage</td>
<td>Beaverton x Resolve Customer Complaints 5</td>
<td></td>
</tr>
<tr>
<td>Equipment Expenses</td>
<td></td>
<td>Beaverton x Expedite Package Shipments 3</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Move to Warehouse 7</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Sort 20</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Inspect 25</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Air Distribution 15</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Land Distribution 15</td>
<td></td>
</tr>
</tbody>
</table>

**Note:** The total equals 100 because 100% of equipment expenses are used by Parcel Express.

After making the assignments, your model should look like the following (again the order of accounts might be different):

3. In the primary pane, select **Wages** for **Eugene** and make the following assignments:
### Resource Account | Driver | Activity Account | DQF
--- | --- | --- | ---
Eugene x Wages | FTEs | Eugene x Resolve Customer Complaints | 2
|  |  | Eugene x Expedite Package Shipments | 1
|  |  | Eugene x Move to Warehouse | 5
|  |  | Eugene x Sort | 3
|  |  | Eugene x Inspect | 2
|  |  | Eugene x Land Distribution | 12

After making the assignments, your model should look like the following:

4. In the primary pane, select **Operating Expenses** for **Eugene** and make the following assignments:
After making the assignments, you model should look like the following:

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Cost</th>
<th>Driver</th>
<th>Resource Account</th>
<th>Activity Account</th>
<th>DQF</th>
</tr>
</thead>
<tbody>
<tr>
<td>RESOURCE</td>
<td></td>
<td>Percentage</td>
<td>Eugene x</td>
<td>Resolve Customer Complaints</td>
<td>5,700.00</td>
</tr>
<tr>
<td>PRIMARY PANE</td>
<td></td>
<td></td>
<td>Operating Expenses</td>
<td>Expedite Package Shipments</td>
<td>9,000.00</td>
</tr>
<tr>
<td>USA</td>
<td>$3,647,900.00</td>
<td></td>
<td>Eugene x</td>
<td>Move to Warehouse</td>
<td>69,000.00</td>
</tr>
<tr>
<td>Oregon</td>
<td>$3,647,900.00</td>
<td></td>
<td>Eugene x</td>
<td>Sort</td>
<td>38,000.00</td>
</tr>
<tr>
<td>Beaverton</td>
<td>$1,539,900.00</td>
<td></td>
<td>Eugene x</td>
<td>Inspect</td>
<td>58,300.00</td>
</tr>
<tr>
<td>Eugene</td>
<td>$1,717,000.00</td>
<td></td>
<td>Eugene x</td>
<td>Land Distribution</td>
<td>98,000.00</td>
</tr>
<tr>
<td>Wage</td>
<td>$1,400,000.00</td>
<td>Other</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Operating Expenses</td>
<td>$300,000.00</td>
<td>Percentage</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

5. In the primary pane, select **Equipment Expenses** for Eugene and make the following assignments:

<table>
<thead>
<tr>
<th>Resource Account</th>
<th>Driver</th>
<th>Activity Account</th>
<th>DQF</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eugene x</td>
<td>Percentage</td>
<td>Eugene x</td>
<td>5</td>
</tr>
<tr>
<td>Equipment Expenses</td>
<td></td>
<td>Resolve Customer Complaints</td>
<td></td>
</tr>
<tr>
<td>Eugene x</td>
<td></td>
<td>Expedite Package Shipments</td>
<td>2</td>
</tr>
<tr>
<td>Eugene x</td>
<td></td>
<td>Move to Warehouse</td>
<td>8</td>
</tr>
<tr>
<td>Eugene x</td>
<td></td>
<td>Sort</td>
<td>20</td>
</tr>
<tr>
<td>Eugene x</td>
<td></td>
<td>Inspect</td>
<td>25</td>
</tr>
<tr>
<td>Eugene x</td>
<td></td>
<td>Land Distribution</td>
<td>40</td>
</tr>
</tbody>
</table>
After making the assignments, you model should look like the following:

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Cost</th>
<th>DrvName</th>
</tr>
</thead>
<tbody>
<tr>
<td>RESOURCE</td>
<td>$5,647,900.0</td>
<td></td>
</tr>
<tr>
<td>USA</td>
<td>$3,647,900.0</td>
<td></td>
</tr>
<tr>
<td>Oregon</td>
<td>$3,647,900.0</td>
<td></td>
</tr>
<tr>
<td>Beaverton</td>
<td>$1,250,900.0</td>
<td></td>
</tr>
<tr>
<td>Eugene</td>
<td>$1,717,000.0</td>
<td></td>
</tr>
<tr>
<td>Wages</td>
<td>$1,408,000.0</td>
<td>FTES</td>
</tr>
<tr>
<td>Operating Expenses</td>
<td>$271,000.0</td>
<td>Dollars</td>
</tr>
<tr>
<td>Equipment Expenses</td>
<td>$355,000.0</td>
<td>Percentage</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>IntraName</th>
<th>DQF</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eugene x Inspect</td>
<td>23.00</td>
</tr>
<tr>
<td>Eugene x Sort</td>
<td>20.00</td>
</tr>
<tr>
<td>Eugene x Move to Warehouse</td>
<td>3.00</td>
</tr>
<tr>
<td>Eugene x Expedite Package Shipment</td>
<td>2.00</td>
</tr>
<tr>
<td>Eugene x Resolve Customer Complaints</td>
<td>5.00</td>
</tr>
<tr>
<td>Eugene x Land Distribution</td>
<td>40.00</td>
</tr>
</tbody>
</table>

**Making Assignments from Activities to Other Activities**

The costs of some activities flow to other activities. For example, at Parcel Express, when packages are moved to a warehouse, they must then be sorted or inspected. Therefore, in the Parcel Express Tutorial model, the costs of the Move to Warehouse activity flow to the Sort and Inspect activities. These are known as intra-modular, or reciprocal assignments.

- **Modify the Cost Assignments column layout**
  1. Select Model ⇒ Activity Module (or click the Activity Module icon on the toolbar).
  2. If it is not already open, open the right assignments pane.
  3. If the Cost Assignments layout is not already selected, select it from the Column Layout list, and then click the arrow.
  4. Open the Column Layout dialog box.
  5. Modify the column layout as follows:
    - In the primary pane, remove Inspections Passed and add Driver Name (DrvName).
    - In the right pane, remove Reference and add Driver Quantity Fixed (DQF).
  6. Click Save, and then click OK.

You see that the column layout has changed.

- **Add accounts for assignments**
  1. Open the Add Accounts for Assignments dialog box.
  2. Select the Activity module.
  3. Add the following accounts to the right pane:

    **TIP** To see these accounts, expand the hierarchy in the Add Accounts for Assignments dialog box. You can add the accounts individually or select them all at once by holding down the CTRL key, and then clicking Add Accounts.
Making Assignments from Activities to Other Activities

Activity Account

Beaverton x Inspect
Beaverton x Sort
Beaverton x Air Distribution
Beaverton x Land Distribution
Eugene x Inspect
Eugene x Sort
Eugene x Land Distribution

4. Click Close.

- Make assignments

1. In the primary pane, select Move to Warehouse for Beaverton and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account (Primary Pane)</th>
<th>Driver</th>
<th>Activity Account (Right Pane)</th>
<th>DQF</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Move to Warehouse</td>
<td>Number of Packages</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Sort</td>
<td>203,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Inspect</td>
<td>50,000</td>
</tr>
</tbody>
</table>

After making the assignments, your model should look like the following:

2. In the primary pane, select Inspect for Beaverton and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account (Primary Pane)</th>
<th>Driver</th>
<th>Activity Account (Right Pane)</th>
<th>DQF</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Inspect</td>
<td>Number of Packages</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Sort</td>
<td>44,000</td>
</tr>
</tbody>
</table>

After making the assignments, your model should look like the following:
3. In the primary pane, select Sort for Beaverton and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account (Primary Pane)</th>
<th>Driver</th>
<th>Activity Account (Right Pane)</th>
<th>DQF</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Sort</td>
<td>Number of Packages</td>
<td>Beaverton x Land Distribution</td>
<td>107,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Beaverton x Air Distribution</td>
<td>140,000</td>
</tr>
</tbody>
</table>

After making the assignments, you model should look like the following:

4. In the primary pane, select Move to Warehouse for Eugene and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account (Primary Pane)</th>
<th>Driver</th>
<th>Activity Account (Right Pane)</th>
<th>DQF</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eugene x</td>
<td>Number of Packages</td>
<td>Eugene x Sort</td>
<td>117,000</td>
</tr>
<tr>
<td>Move to Warehouse</td>
<td></td>
<td>Eugene x Inspect</td>
<td>18,000</td>
</tr>
</tbody>
</table>

After making the assignments, you model should look like the following:
5. In the primary pane, select **Inspect** for **Eugene** and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account (Primary Pane)</th>
<th>Driver</th>
<th>Activity Account (Right Pane)</th>
<th>DQF</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eugene x Inspect</td>
<td>Number of Packages</td>
<td>Eugene x Sort</td>
<td>16,000</td>
</tr>
</tbody>
</table>

After making the assignments, your model should look like the following:

6. In the primary pane, select **Sort** for **Eugene** and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account (Primary Pane)</th>
<th>Driver</th>
<th>Activity Account (Right Pane)</th>
<th>DQF</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eugene x Sort</td>
<td>Number of Packages</td>
<td>Eugene x Land Distribution</td>
<td>133,000</td>
</tr>
</tbody>
</table>

After making the assignments, your model should look like the following:
Making Assignments from Activities to Cost Objects

Now, you will make more inter-modular assignments from activity accounts to cost object accounts. Remember that some cost object accounts are single-dimension accounts. These accounts hold unique costs for individual channels or products. Some Parcel Express activities, such as Resolve Customer Complaints, apply uniquely to a channel, regardless of the packages that are being processed through the channel. Similarly, some costs apply only to products, as you will see in the following procedures.

• **Add accounts for assignment**

  1. If there are accounts in the right pane, clear the accounts as follows:
     - Select the highest branch of the Activity hierarchy in the primary pane.
     - Select Model ⇨ Assignments ⇨ Clear Right.

     You see that the right pane has been cleared of accounts. This does not delete the assignments it only removes them from view.

  2. Open the Add Accounts for Assignments dialog box.

  3. Verify that the Cost Object module is selected.

  4. Add all of the Cost Object accounts to the right pane.

     Note: To avoid mixing up activities and cost objects from Beaverton and Eugene, consider first adding only the Beaverton accounts. Next, make the assignments. Then, clear the right pane. And then, add all of the Eugene accounts and make assignments. Also, note that clearing accounts from a pane does not delete assignments from your model. It removes the accounts from view temporarily.

  5. Click Close.

• **Make assignments for Beaverton**

  1. In the primary pane, select Resolve Customer Complaints for Beaverton and make the following assignments:

     | Activity Account | Driver | Cost Object Account for Beaverton | DQF |
     |------------------|--------|----------------------------------|-----|
     | Beaverton x      |        | Commercial Pick Up x             | 25  |
     | Resolve Customer Complaints | Number of Customer Complaints | No <Products and Services> | |
     |                  |        | Walk In x                        | 85  |
     |                  |        | No <Products and Services>       |     |
     |                  |        | Drop Box x                       | 15  |
     |                  |        | No <Products and Services>       |     |

     After making the assignments, your model should look like the following:
2. In the primary pane, select **Expedite Package Shipments** for Beaverton and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account</th>
<th>Driver</th>
<th>Cost Object Account for Beaverton</th>
<th>DQF</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Expedite Package Shipments</td>
<td>Number of Expedite Requests</td>
<td>No &lt;Channel&gt; x Standard Ground</td>
<td>3,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x Overnight Express</td>
<td>26,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x 2nd Day Guaranteed</td>
<td>15,000</td>
</tr>
</tbody>
</table>

After making the assignments, your model should look like the following:

3. In the primary pane, select **Inspect** for Beaverton and create the following assignments:

<table>
<thead>
<tr>
<th>Activity Account</th>
<th>Driver</th>
<th>Cost Object Account for Beaverton</th>
<th>DQF</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Inspect</td>
<td>Number of Packages</td>
<td>No &lt;Channel&gt; x Standard Ground</td>
<td>500</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x Overnight Express</td>
<td>4,500</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x 2nd Day Guaranteed</td>
<td>1,000</td>
</tr>
</tbody>
</table>

After making the assignments, your model should look like the following:

You can notice that in addition to the assignments to three Cost Activity accounts, there is an additional assignment to the **Beaverton x Sort** Activity Account.

4. In the primary pane, select **Air Distribution** for Beaverton and make the following assignments:
5. In the primary pane, select **Land Distribution** for Beaverton and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account</th>
<th>Driver</th>
<th>Cost Object Account for Beaverton</th>
<th>DQF</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Land Distribution</td>
<td>Number of Packages</td>
<td>No &lt;Channel&gt; x Standard Ground</td>
<td>67,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x Overnight Express</td>
<td>15,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x 2nd Day Guaranteed</td>
<td>25,000</td>
</tr>
</tbody>
</table>

After making the assignments, you model should look like the following:

- **Make assignments for Eugene**
  1. In the primary pane, select **Resolve Customer Complaints** for Eugene and make the following assignments:
Activity Account | Driver | Cost Object Account for Eugene | DQF
--- | --- | --- | ---
Eugene x Resolve Customer Complaints | Number of Customer Complaints | Commercial Pick Up x No <Products and Services> | 10

Walk In x No <Products and Services>
Drop Box x No <Products and Services>

After making the assignments, you model should look like the following:

2. In the primary pane, select **Expedite Package Shipments** for Eugene and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account</th>
<th>Driver</th>
<th>Cost Object Account for Eugene</th>
<th>DQF</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eugene x Expedite Package Shipments</td>
<td>Number of Expedite Requests</td>
<td>No &lt;Channel&gt; x Standard Ground</td>
<td>25,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x Overnight Express</td>
<td>1,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x 2nd Day Guaranteed</td>
<td>10,000</td>
</tr>
</tbody>
</table>

After making the assignments, you model should look like the following:

3. In the primary pane, select **Inspect** for Eugene and create the following assignments:

<table>
<thead>
<tr>
<th>Activity Account</th>
<th>Driver</th>
<th>Cost Object Account for Eugene</th>
<th>DQF</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eugene x Inspect</td>
<td>Number of Packages</td>
<td>No &lt;Channel&gt; x Standard Ground</td>
<td>1,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x Overnight Express</td>
<td>500</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x 2nd Day Guaranteed</td>
<td>500</td>
</tr>
</tbody>
</table>

After making the assignments, you model should look like the following:
You can notice that in addition to the assignments to three Cost Activity accounts, there is an additional assignment to the **Eugene x Sort** Activity Account.

4. In the primary pane, select **Land Distribution** for **Eugene** and make the following assignments:

<table>
<thead>
<tr>
<th>Activity Account</th>
<th>Driver</th>
<th>Cost Object Account for Eugene</th>
<th>DQF</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eugene x Land Distribution</td>
<td>Number of Packages</td>
<td>No &lt;Channel&gt; x Standard Ground</td>
<td>75,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x Overnight Express</td>
<td>16,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No &lt;Channel&gt; x 2nd Day Guaranteed</td>
<td>42,000</td>
</tr>
</tbody>
</table>

After making the assignments, your model should look like the following:

---

**Adding Attributes to Cost Accounts**

When you created the cost drivers for the Parcel Express Tutorial model, you built one calculated driver, named Number of Expedite Requests, that was composed of two attributes, named Average Time to Expedite and Completed Expedite Requests (See Calculated Drivers). The value of those attributes must be added to the cost accounts to which they apply.

- **Open the cost object module**
  
  Select Model ⇒ Cost Object Module.

- **Add columns for attributes in the column layout**
  
  To enter numeric values for attributes, the attributes must be added to the column layout for the cost object account:
  
  1. Make sure the current column layout is **Cost Assignments**.
2. Select **Model** ⇒ **Column Layout** ⇒ **Edit Columns**. The Column Layout window opens.

3. Make sure the **Cost Object Module** is selected.

4. Make sure the **Primary** pane tab is selected.

5. Remove **Display Reference** from the Displayed columns list.

6. Add the **Average Time to Expedite** attribute.

7. Add the **Completed Expedite Requests** attribute.

The column layout should look like the following:

8. Click **OK**. The attributes are added to the primary pane. There is no need to save the column layout.

- **Add attribute quantities**

1. Now, add the following attribute quantities for Beaverton:

<table>
<thead>
<tr>
<th>Destination Account</th>
<th>Average Time to Expedite</th>
<th>Completed Expedite Requests</th>
</tr>
</thead>
<tbody>
<tr>
<td>No &lt;Channel&gt; x Standard Ground</td>
<td>1.75</td>
<td>4,000</td>
</tr>
<tr>
<td>No &lt;Channel&gt; x Overnight Express</td>
<td>1.75</td>
<td>15,000</td>
</tr>
<tr>
<td>No &lt;Channel&gt; x 2nd Day Guaranteed</td>
<td>1.75</td>
<td>25,000</td>
</tr>
</tbody>
</table>

2. Add the following attribute quantities for Eugene:

<table>
<thead>
<tr>
<th>Destination Account</th>
<th>Average Time to Expedite</th>
<th>Completed Expedite Requests</th>
</tr>
</thead>
<tbody>
<tr>
<td>No &lt;Channel&gt; x Standard Ground</td>
<td>3</td>
<td>6,000</td>
</tr>
<tr>
<td>Destination Account</td>
<td>Average Time to Expedite</td>
<td>Completed Expedite Requests</td>
</tr>
<tr>
<td>-------------------------------------</td>
<td>--------------------------</td>
<td>-----------------------------</td>
</tr>
<tr>
<td>No &lt;Channel&gt; x</td>
<td>3</td>
<td>15,000</td>
</tr>
<tr>
<td>Overnight Express</td>
<td></td>
<td></td>
</tr>
<tr>
<td>No &lt;Channel&gt; x</td>
<td>3</td>
<td>20,000</td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The resulting attribute assignments should look like the following:

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Cost</th>
<th>Average Time to Expedite</th>
<th>Completed Expedite Requests</th>
</tr>
</thead>
<tbody>
<tr>
<td>COST OBJECT (PRIMARY PANE)</td>
<td>$0.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>USA</td>
<td>$0.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Oregon</td>
<td>$0.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Beaverton</td>
<td>$0.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Drop Box</td>
<td>$0.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Walk In</td>
<td>$0.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Commercial Pick Up</td>
<td>$0.00</td>
<td>1.75</td>
<td>25,000.00</td>
</tr>
<tr>
<td>No &lt;Channel&gt;</td>
<td>$0.00</td>
<td>1.75</td>
<td>25,000.00</td>
</tr>
<tr>
<td>No &lt;Channel&gt;</td>
<td>$0.00</td>
<td>1.75</td>
<td>15,000.00</td>
</tr>
<tr>
<td>Eugene</td>
<td>$0.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Drop Box</td>
<td>$0.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Walk In</td>
<td>$0.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Commercial Pick Up</td>
<td>$0.00</td>
<td>1.75</td>
<td>4,000.00</td>
</tr>
</tbody>
</table>

---

**Postscript on Using a Column Layout**

A saved column layout specifies the column headings for all of the following modules:

- Resource
- Activity
- Cost Object
- External Unit

For each module, you specify the column headings for that module considered as the primary pane and for its left assignments pane and its right assignments pane.

Let's look more closely at a column layout, taking the Activity Module as an example.
The following picture shows a column layout for the Activity Module displayed as a single pane.

In addition to specifying the column headings for the primary pane, you also specify the column headings for both its left assignments pane and its right assignments pane. In the case of the Activity Module, the source accounts that can appear in the left assignments pane can belong to either the Resource Module or the Activity Module itself (because you can make assignments within the Activity Module from one account to another). The destination accounts that can appear in the right assignments pane can belong to either the Activity Module itself or to the Cost Object Module. The next picture shows the Activity Module (the primary pane) displayed in the center of the screen along with its left assignments pane and its right assignments pane.

You should understand that the column headings in a column layout are the same whether the primary pane is viewed as a single pane, in the center of the screen, or in the left or right of the screen. The next two pictures show the primary pane viewed in the left of the screen and in the right of the screen, respectively.
Postscript on Generating Assignments According to a Rule

Overview

If you noticed a significant amount of repetition in the assignments that you made, you might have wondered if you could establish a general rule for making assignments and let the system generate the assignments for you in accordance with the rule. With the rule-based driver feature of SAS Activity-Based Management you can do just that.

You use rule-based drivers to generate cost assignments automatically during calculation. The feature works by allowing you to attach a formula—referred to as a rule formula—to an existing driver. When you attach the driver with its rule formula to a source account, the calculation evaluates for which potential destination accounts the rule formula tests true and creates an assignment from the source account to each such destination account.

The following picture shows some assignments in the Parcel Express Tutorial model that are candidates for generating according to a rule. Notice that the driver, Number of Expedite Requests, is attached to two different source accounts each of which assigns costs to three different destination accounts. If we can find a rule formula to pick out just those destination accounts, then with one driver and a rule we can generate six assignments.
Attaching a Formula and Generating Assignments

Before describing some rule formulas that will pick out the desired destination accounts, let's first see how to attach a rule formula to a driver. Knowing how to attach a rule formula to a driver will help to establish some context of what we are talking about when we refer to rule-based drivers.

To attach a rule formula to a driver do the following:

1. Go to the Drivers page (select Model ⇒ Drivers Page).
2. Select the driver to which you want to attach a rule formula and select Edit ⇒ Item Properties.
   The Driver Properties dialog box opens.
3. Select Use Rule Formula and then click Formula Builder.

The Formula Builder dialog box opens.
4. Either use selections and the **Insert** key to build the formula, or type the complete formula in the text field.

5. Click **OK** to close the Formula Builder, and then click **OK** to close the Driver Properties dialog box.

6. Repeat the preceding steps for each driver to which you want to attach a rule formula.

7. Attach each rule-based driver to the appropriate source accounts.

   Of course, assuming that you have already attached these drivers to source accounts while doing this tutorial, the calculation will simply recreate the assignments that you have already made (assuming that you define an appropriate rule formula). The point is that rule-based drivers give you an alternative to creating the assignments manually.

8. To generate assignments, calculate the model.

   The assignments are generated—which you can verify by viewing the appropriate assignments panes. You can also verify that the cost flows, as shown below, are the same as when you attached the drivers manually.
Selecting the Destination Accounts—First Pass

Now let's talk about what rule formula to define. Probably the easiest way to select the desired destination accounts is to add a tag attribute to each. A tag attribute is one that either you add or you don't add to an account. (In previous releases of SAS Activity-Based Management, tag attributes were called Boolean attributes.) Then you can use the HasAttribute() function in a formula to test for the presence of the attribute. As shown below, the tag attribute, Expedite Requests, is attached to the six destination accounts.

The rule formula, however, is not yet complete. Notice that if you were to apply this rule formula, it would generate assignments from a Beaverton source account not only to

So, the following rule formula selects just these destination accounts:

"Module".DimMemRef="CostObject"
AND Destination.HasAttribute("Expedite Requests")

The first condition, testing for the Cost Object module, is not necessary because the Expedite Requests attribute is attached to accounts only in the Cost Object module. However, adding the condition can speed up assignment generation because the system knows that it does not have to check other modules for potential destination accounts. The condition also helps ensure that you do not generate assignments to accounts other than those you intend. In particular, it can help prevent generating reciprocal costing where an account, directly or indirectly, assigns costs to itself.

Similarly, the “Destination” modifier is also not necessary because the system assumes by default that any unmodified account is a destination account. However, adding the modifier can make your rule formula easier to understand.

The rule formula, however, is not yet complete. Notice that if you were to apply this rule formula, it would generate assignments from a Beaverton source account not only to
Beaverton destination accounts but also to the similar Eugene destination accounts. And, it would generate assignments from a Eugene source account to Beaverton destination accounts. Clearly you want Beaverton source accounts to assign costs only to Beaverton destination accounts, and Eugene source accounts only to Eugene destination accounts. The following sections sketch two solutions to this problem.

**Selecting the Destination Accounts—Second Pass**

The first solution entails creating distinct attributes for the Beaverton and Eugene destination accounts:

- Expedite Requests Beaverton
- Expedite Requests Eugene

The following picture shows these attributes attached to the respective destination accounts:

In order to test for these attributes you also need two distinct drivers each with its own rule formula—one for Beaverton and one for Eugene. The rule formula for the Beaverton driver is the following:

```
"Module".DimMemRef="CostObject"
AND Destination.HasAttribute("Expedite Requests Beaverton")
```

And, the rule formula for the Eugene driver is the following:

```
"Module".DimMemRef="CostObject"
AND Destination.HasAttribute("Expedite Requests Eugene")
```

The following pictures show the assignments that are generated by these rule formulas from the Beaverton and Eugene source accounts:
Selecting the Destination Accounts—Third Pass

This section describes an alternative solution. Remember that you want Beaverton source accounts to assign costs only to Beaverton destination accounts, and Eugene source accounts only to Eugene destination accounts. In short, you want the source region to equal the destination region. You can accomplish this with the following condition:

Source.Region.DimMemRef=Destination.Region.DimMemRef

So, the complete rule formula to select the destination accounts is the following:

"Module".DimMemRef="CostObject"
AND Destination.HasAttribute("Expedite Requests Eugene")
AND Source.Region.DimMemRef=Destination.Region.DimMemRef

With this one rule formula you can avoid creating distinct attributes for Beaverton and Eugene and also avoid duplicating the driver. This rule formula that is attached to a single driver generates exactly the assignments desired.

An Alternative Formula for Selecting the Destination Accounts

Let's look more closely at the destination accounts to see if it is possible to define a rule that selects just those destination accounts without even having to add an attribute. The display below shows the destination accounts with the CostObject module as the primary pane. Notice that all six destination accounts have the following property in common:

The DimMemRef of their dimension member in the Chnnl dimension is None.
Therefore, the following formula selects just these destination accounts:

"Module".DimMemRef="CostObject"
AND Destination.Chnnl.DimMemRef="None"
AND Source.Region.DimMemRef=Destination.Region.DimMemRef

Notes:

• Although the assignments pane shows “No <Chnnl>” as the DimMemRef of the dimension member in the Chnnl dimension, you must use the constant “None” in your formula. “None” is the internal name. “No <Chnnl>” is a translatable label that is just for display.

• Similarly, you can use either “DimMemRef” in your formula or “Reference”. In this context “Chnnl.DimMemRef” and “Chnnl.Reference” are synonymous. The dimension in this case is Channel, and the possible dimension members are Drop Box, Walk In, Commercial Pick-Up, and None. You refer to the dimension members using the compound notation: “Channel.Drop Box”, “Channel.Walk In”, “Channel.Commercial Pick-Up”, and “Channel.None”. Channel is the dimension, and the item that follows the period is a dimension member. More generally, you can write either “Channel.DimMemRef” or “Channel.Reference” because they are synonymous. The column heading in the assignments pane uses the label “DimMemRef” to distinguish it from the Reference of an account.
Chapter 11
Calculating Costs

Overview

Typically, costs are entered in a model at the end of a defined period. These costs come from an organization's general ledger accounts and from external bills of costs. Additional cost information can come from a Material Requirements Planning (MRP) system. Production data is also entered in a model at the end of a defined period.

At any time during the development of a model, you can calculate the cost of each account according to its driver and driver quantities.

Performing Calculations

You entered Parcel Express costs and quantities for the 2004 Q1 period, so calculations will be performed for this period.

- Calculate costs
  1. Select Model ➔ Calculate Costs.
     
     You see the Calculate Costs dialog box.
2. Select the period/scenario **2008 Q1/Actual**.

*Note:* You can select to force calculations even if the flag is set that says that calculations are up to date. To speed processing, SAS Activity-Based Management skips calculating if it thinks that calculations are up to date. Use this option to force calculations anyway.

3. Click **OK**.

You see a message in the status bar, at the bottom of the window, indicating that the calculation is in progress.

Depending on the speed of your SAS Activity-Based Management server and your connection to it, the calculation might take several seconds. When the calculation is completed, you see the Operation Summary window. You should have 0 fatal errors and 0 errors.

---

**Viewing and Verifying Calculation Results**

Experienced activity-based costing users calculate a model after they create accounts, assignments, and driver quantities, or after they enter cost data, as a validation and quality assurance technique.

The following displays show the total costs for the resource, activity, and cost object modules, along with the key roll-up accounts in each module. Verify that the modules and accounts in your model match the costs.
### Viewing and Verifying Calculation Results

#### RESOURCE (PRIMARY PANES)

<table>
<thead>
<tr>
<th>Area</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>USA</td>
<td>$3,647,900.00</td>
</tr>
<tr>
<td>Oregon</td>
<td>$3,647,900.00</td>
</tr>
<tr>
<td>Beaverton</td>
<td>$1,930,900.00</td>
</tr>
<tr>
<td>Wages</td>
<td>$1,638,600.00</td>
</tr>
<tr>
<td>Operating Expenses</td>
<td>$238,000.00</td>
</tr>
<tr>
<td>Equipment Expenses</td>
<td>$54,300.00</td>
</tr>
<tr>
<td>Eugene</td>
<td>$1,717,000.00</td>
</tr>
<tr>
<td>Wages</td>
<td>$1,408,000.00</td>
</tr>
<tr>
<td>Operating Expenses</td>
<td>$271,000.00</td>
</tr>
<tr>
<td>Equipment Expenses</td>
<td>$36,000.00</td>
</tr>
</tbody>
</table>

#### ACTIVITY (PRIMARY PANES)

<table>
<thead>
<tr>
<th>Activity</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>USA</td>
<td>$3,647,900.00</td>
</tr>
<tr>
<td>Oregon</td>
<td>$3,647,900.00</td>
</tr>
<tr>
<td>Beaverton</td>
<td>$1,930,900.00</td>
</tr>
<tr>
<td>Personnel Intensive Activities</td>
<td>$218,201.72</td>
</tr>
<tr>
<td>Local Collection</td>
<td>$388,040.02</td>
</tr>
<tr>
<td>Local Processing</td>
<td>$716,731.93</td>
</tr>
<tr>
<td>Regional Distribution</td>
<td>$1,682,395.54</td>
</tr>
<tr>
<td>Eugene</td>
<td>$1,717,000.00</td>
</tr>
<tr>
<td>Personnel Intensive Activities</td>
<td>$187,783.21</td>
</tr>
<tr>
<td>Local Collection</td>
<td>$351,422.14</td>
</tr>
<tr>
<td>Local Processing</td>
<td>$743,326.79</td>
</tr>
<tr>
<td>Regional Distribution</td>
<td>$1,504,169.86</td>
</tr>
</tbody>
</table>

#### COST OBJECT (PRIMARY PANES)

<table>
<thead>
<tr>
<th>Object</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>USA</td>
<td>$3,647,900.00</td>
</tr>
<tr>
<td>Oregon</td>
<td>$3,647,900.00</td>
</tr>
<tr>
<td>Beaverton</td>
<td>$1,930,900.00</td>
</tr>
<tr>
<td>Drop Box</td>
<td>$15,468.14</td>
</tr>
<tr>
<td>Walk In</td>
<td>$37,652.80</td>
</tr>
<tr>
<td>Commercial Pick Up</td>
<td>$25,790.24</td>
</tr>
<tr>
<td>No &lt;Channel&gt;</td>
<td>$1,801,998.82</td>
</tr>
<tr>
<td>Eugene</td>
<td>$1,717,000.00</td>
</tr>
<tr>
<td>Drop Box</td>
<td>$45,519.59</td>
</tr>
<tr>
<td>Walk In</td>
<td>$58,265.07</td>
</tr>
<tr>
<td>Commercial Pick Up</td>
<td>$18,207.84</td>
</tr>
<tr>
<td>No &lt;Channel&gt;</td>
<td>$1,595,007.50</td>
</tr>
</tbody>
</table>
Adding Bills of Costs

A bill of costs provides a convenient mechanism for adding material and unit costs directly to accounts, for bidding on jobs, or for implementing activity accounting.

Use a bill of costs when either of the following is true:

- Costs outside of the general ledger need to be introduced into a model. Not all costs that are assigned through a model come from the general ledger. For example, material costs (the cost of purchased components) can be additional product cost information that often comes from a Material requirements planning (MRP) system.
- A model's unit cost elements that are associated with product families need to be tracked.

Steps for Building Bills of Costs

To build bills of costs:

1. Define a dimension in the external units module.
You did this step for the Parcel Express Tutorial model when you completed the New Model wizard. The dimension is Materials.

2. Create dimension members.
   For the Parcel Express tutorial, the Materials dimension members represent packaging materials.

3. Create accounts in the external units module.
   You will use the New Account wizard to add external units to the model.

4. Create an assignment from the external unit to an account, using the Bill of Cost driver.
   Packaging materials in the Parcel Express Tutorial model contribute to the unique costs of a product. You will make assignments from accounts in the external units module to accounts in the cost object module.

5. Enter a fixed or variable driver quantity.
   You will enter both types of quantities.

6. If you enter a variable driver quantity, you must also enter a number to quantify demand so that cost can be calculated. You can specify this number with the SoldQty property for destination accounts.
   You will enter sold quantities in a later chapter.

---

**Internal and External Units**

An external unit is a unit, such as a part purchased from a supplier, whose cost is maintained outside of a SAS Activity-Based Management model but which needs to be accounted for in the model. SAS Activity-Based Management treats external units like accounts. When an external unit's cost is flowed to an account, you see the flowed cost listed as an external unit cost element.

A difference between external units and accounts in other modules (Resource, Activity, Cost Object) is that UnitCost is entered by the user for external units whereas it is calculated by the system for other accounts.

---

**Fixed and Variable Quantities**

A bill of costs driver can include variable or fixed quantities or both.

**Fixed Quantities**

With a fixed quantity driver, the cost that flows out of an account does not depend on demand. The cost is “pushed” by the quantity supplied. To calculate cost, the driver’s unit cost is multiplied by the fixed driver quantity (DQF).

For example, assume that a company manufactures bicycles. It buys 1,000 tires from another company at the beginning of each year. The tires might be used in any model of bicycle that the manufacturer produces, or they might not be used at all if some bicycles are not produced. In this case, the driver’s unit cost does not vary with the number of
Variable Quantities

With a variable quantity driver, the cost that flows out of an account depends on the quantity demanded. The cost is “pulled” by how many are needed at their final destination. To calculate cost, the bill of cost's unit cost is multiplied by the variable driver quantity (DQV) and the total driver quantity (TDQ) of the destination account. The total driver quantity can be either a system-calculated quantity (TDQ) or a user-entered quantity (TDQUE).

Note: TDQ, as a system-calculated quantity, ultimately depends on user-entered quantities such as SoldQty and DQF.

For example, assume that the bicycle manufacturer purchases tires from another company for $5 each for each bicycle that it sells. Because each bicycle requires two tires, the unit cost is $10. If the company sells 100 bicycles (SoldQty), the total cost is $1,000 (100 x $5 x 2). The cost of tires depends on the demand for them. In other words, the cost of tires is “pulled” by how many of them must be sent to their final destination.

Creating External Units and Bills of Costs

Introduction

Parcel Express buys the following components from outside vendors:

- standard envelopes
- 2nd day flats
- overnight flats
- large boxes
- small boxes

These costs must be accounted for in the model. To account for them, you will create external units and assign them to cost object accounts, thereby creating bills of costs.

Create the Dimension Members for Materials

1. Select Model → Dimensions Page.

2. Using the techniques that you have learned, create the following Materials dimension members:
Create External Units Accounts

1. Select Model ⇒ External Units Module or click the External Units icon ( ) on the toolbar.

You see the external units module, which has no structure yet.

2. Select Edit ⇒ New Account.

You see the New Account wizard.

3. Select the following dimension members:
   - Standard Envelope
   - 2nd Day Flat
   - Overnight Flat
   - Large Box
   - Small Box

4. Click Add and then click Next.

You see Step 2 of the New Account wizard.

5. Enter the following unit costs:

<table>
<thead>
<tr>
<th>Account</th>
<th>Unit Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>Standard Envelope</td>
<td>.06</td>
</tr>
<tr>
<td>2nd Day Flat</td>
<td>.14</td>
</tr>
<tr>
<td>Overnight Flat</td>
<td>.14</td>
</tr>
<tr>
<td>Large Box</td>
<td>.95</td>
</tr>
<tr>
<td>Small Box</td>
<td>.75</td>
</tr>
</tbody>
</table>

6. Click Finish.
You see the following external unit structure:

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Display Reference</th>
<th>UnitCost</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>EXTERNAL UNITS</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Envelopes</td>
<td>EIW</td>
<td>$0.00</td>
<td>$0.00</td>
</tr>
<tr>
<td>Standard Envelopes</td>
<td>SENV</td>
<td>$0.06</td>
<td>$0.00</td>
</tr>
<tr>
<td>Flats</td>
<td>FT5</td>
<td></td>
<td>$0.00</td>
</tr>
<tr>
<td>2nd Day Flat</td>
<td>2DF</td>
<td>$0.14</td>
<td>$0.00</td>
</tr>
<tr>
<td>Overnight Flat</td>
<td>ONF</td>
<td>$0.14</td>
<td>$0.00</td>
</tr>
<tr>
<td>Boxes</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Large Box</td>
<td>LBX</td>
<td>$0.95</td>
<td>$0.00</td>
</tr>
<tr>
<td>Small Box</td>
<td>SBX</td>
<td>$0.75</td>
<td>$0.00</td>
</tr>
</tbody>
</table>

**Modify the Cost Assignments Column Layout**

1. In the external units module, show the right assignments pane.
2. If the Cost Assignments layout is not already selected, select it from the Column Layout list, and then click the arrow.
4. Modify the primary pane as follows:
   - Remove Display Reference.
   - Add Driver Name (DrvName).
5. Modify the right pane as follows:
   - Remove Reference.
   - Add Driver Quantity Fixed (DQF).
   - Add Driver Quantity Variable (DQV).
6. Click Save and then click OK.

**Add Accounts for Assignments**

1. Select Model ⇒ Assignments ⇒ Show Right Assignments Pane.
2. Open the Add Accounts for Assignments dialog box (select Model ⇒ Assignments ⇒ Add Accounts in Right Pane).
3. Add the following Cost Object accounts under Beaverton and Eugene to the right pane:
   - No <Channel> x 2nd Day Guaranteed
   - No <Channel> x Overnight Express
   - No <Channel> x Standard Ground
### Make Assignments and Calculate

1. Make assignments that have the following driver quantities:

<table>
<thead>
<tr>
<th>External Unit Account</th>
<th>Cost Object Account</th>
<th>DQF</th>
<th>DQV</th>
</tr>
</thead>
<tbody>
<tr>
<td>Standard Envelope</td>
<td>Beaverton x No &lt;Channel&gt; x Overnight Express</td>
<td>17,333</td>
<td></td>
</tr>
<tr>
<td>Standard Envelope</td>
<td>Eugene x No &lt;Channel&gt; x Overnight Express</td>
<td>8,677</td>
<td></td>
</tr>
<tr>
<td>2nd Day Flat</td>
<td>Beaverton x No &lt;Channel&gt; x 2nd Day Guaranteed</td>
<td>1.00</td>
<td></td>
</tr>
<tr>
<td>2nd Day Flat</td>
<td>Eugene x No &lt;Channel&gt; x 2nd Day Guaranteed</td>
<td>1.00</td>
<td></td>
</tr>
<tr>
<td>Overnight Flat</td>
<td>Beaverton x No &lt;Channel&gt; x Overnight Express</td>
<td>123,500</td>
<td></td>
</tr>
<tr>
<td>Overnight Flat</td>
<td>Eugene x No &lt;Channel&gt; x Overnight Express</td>
<td>6,500</td>
<td></td>
</tr>
<tr>
<td>Large Box</td>
<td>Beaverton x No &lt;Channel&gt; x Standard Ground</td>
<td>120,833</td>
<td></td>
</tr>
<tr>
<td>Large Box</td>
<td>Eugene x No &lt;Channel&gt; x Standard Ground</td>
<td>4,167</td>
<td></td>
</tr>
<tr>
<td>Small Box</td>
<td>Beaverton x No &lt;Channel&gt; x Standard Ground</td>
<td>73,950</td>
<td></td>
</tr>
<tr>
<td>Small Box</td>
<td>Eugene x No &lt;Channel&gt; x Standard Ground</td>
<td>2,550</td>
<td></td>
</tr>
</tbody>
</table>

*Note:* When you make assignments from external units, the software automatically applies the Bill of Cost driver.

2. Select **Model ➔ Assignments ➔ Show Single Pane**.

3. Calculate the model, and then close the **Operation Summary**.

*Note:* Warnings occur because costs are still unassigned.

You see the following external unit costs:
The 2nd Day Flat external unit does not have a cost yet because you assigned a variable driver quantity of 1. Until you know how many are needed, the system cannot calculate the cost of 2nd Day Flat. The next chapter describes how the cost is calculated.

Summary

The following picture shows how the Cost is derived for each external unit by multiplying its TDQ times its UnitCost. Because there is no variable cost in this case, we can simply add the two DQFs to derive the TDQ.

<table>
<thead>
<tr>
<th>Display Name</th>
<th>UnitCost</th>
<th>Cost</th>
<th>DrvName</th>
</tr>
</thead>
<tbody>
<tr>
<td>Envelopes</td>
<td>$1,560.60</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Standard Envelope</td>
<td>$0.06</td>
<td>$1,560.60</td>
<td>Bill of Cost</td>
</tr>
<tr>
<td>2nd Day Flat</td>
<td>$0.14</td>
<td>$18,200.00</td>
<td>Bill of Cost</td>
</tr>
<tr>
<td>Overnight Flat</td>
<td>$0.14</td>
<td>$18,200.00</td>
<td>Bill of Cost</td>
</tr>
<tr>
<td>Boxes</td>
<td>$176,125.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Large Box</td>
<td>$0.95</td>
<td>$118,750.00</td>
<td>Bill of Cost</td>
</tr>
<tr>
<td>Small Box</td>
<td>$0.75</td>
<td>$57,375.00</td>
<td>Bill of Cost</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>DQF (Desawton)</th>
<th>Standard Ground</th>
<th>Overnight Flat</th>
<th>Large Box</th>
<th>Small Box</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>17,333.00</td>
<td>123,500.00</td>
<td>120,833.00</td>
<td>73,590.00</td>
</tr>
<tr>
<td>DQF (Eugenia)</td>
<td>8,677.00</td>
<td>8,500.00</td>
<td>4,187.00</td>
<td>2,550.00</td>
</tr>
<tr>
<td>TDQ (Total Driver Quantity = DQF + DQF)</td>
<td>26,010.00</td>
<td>132,000.00</td>
<td>125,000.00</td>
<td>76,140.00</td>
</tr>
<tr>
<td>UnitCost</td>
<td>$0.06</td>
<td>$0.14</td>
<td>$0.95</td>
<td>$0.75</td>
</tr>
<tr>
<td>Cost (TDQ x UnitCost)</td>
<td>$1,560.60</td>
<td>$18,200.00</td>
<td>$118,750.00</td>
<td>$57,375.00</td>
</tr>
</tbody>
</table>
Chapter 13
Entering Sales and Revenue Data

Calculating Sales Volume

Some of the most critical calculations in a model rely on the number of products that are produced and sold as well as on sales revenue. From these values, you can determine unit costs and profit. SAS Activity-Based Management provides properties for the input and calculation of these values.

Modify the Cost Assignments Column Layout

1. Select Model ➔ Cost Object Module.
2. Select Model ➔ Column Layout ➔ Edit Columns. The Column Layout dialog box opens.
3. Modify the primary pane as follows:
   - Remove the Display Reference, Average Time to Expedite, and Completed Expedite Requests columns.
   - Add Driver Name (DrvName).
   - Add Sold Quantity (SoldQy).
4. Click Save and then click OK.

Assign the Sales Volume Driver

1. Expand the Cost Object module by selecting COST OBJECT (PRIMARY PANE), right-clicking, and then selecting Expand ➔ All Levels.
2. Delete the No <Channel> x No <Products and Services> accounts for both Eugene and Beaverton. (Right-click each account and select Delete.)

*Note:* You might have deleted them already when creating the cost object accounts.

3. Assign the Sales Volume driver to the following accounts for both Beaverton and Eugene:

<table>
<thead>
<tr>
<th>Cost Object Account</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drop Box x No &lt;Products and Services&gt;</td>
</tr>
<tr>
<td>Walk In x No &lt;Products and Services&gt;</td>
</tr>
<tr>
<td>Commercial Pick Up x No &lt;Products and Services&gt;</td>
</tr>
</tbody>
</table>

4. Assign the Sales Volume driver to each of the No <Channel> accounts for both Beaverton and Eugene:

<table>
<thead>
<tr>
<th>Cost Object Account</th>
</tr>
</thead>
<tbody>
<tr>
<td>No &lt;Channel&gt; x 2nd Day Guaranteed</td>
</tr>
<tr>
<td>No &lt;Channel&gt; x Overnight Express</td>
</tr>
<tr>
<td>No &lt;Channel&gt; x Standard Ground</td>
</tr>
</tbody>
</table>

The Cost Object module should look like this:
Enter the Sold Quantity

You enter sales volumes using the SoldQuantity property.

1. In the primary pane, enter the following values for SoldQuantity for the following accounts:

<table>
<thead>
<tr>
<th>Account</th>
<th>SoldQuantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Drop Box x 2nd Day Guaranteed</td>
<td>9,000</td>
</tr>
<tr>
<td>Beaverton x Drop Box x Overnight Express</td>
<td>4,000</td>
</tr>
<tr>
<td>Account</td>
<td>SoldQuantity</td>
</tr>
<tr>
<td>--------------------------------------------------</td>
<td>--------------</td>
</tr>
<tr>
<td>Beaverton x Drop Box x Standard Ground</td>
<td>21,666</td>
</tr>
<tr>
<td>Beaverton x Walk In x 2nd Day Guaranteed</td>
<td>29,840</td>
</tr>
<tr>
<td>Beaverton x Walk In x Overnight Express</td>
<td>37,330</td>
</tr>
<tr>
<td>Beaverton x Walk In x Standard Ground</td>
<td>73,300</td>
</tr>
<tr>
<td>Beaverton x Commercial Pick Up x 2nd Day Guaranteed</td>
<td>20,000</td>
</tr>
<tr>
<td>Beaverton x Commercial Pick Up x Overnight Express</td>
<td>26,000</td>
</tr>
<tr>
<td>Beaverton x Commercial Pick Up x Standard Ground</td>
<td>34,000</td>
</tr>
<tr>
<td>Eugene x Drop Box x 2nd Day Guaranteed</td>
<td>4,500</td>
</tr>
<tr>
<td>Eugene x Drop Box x Overnight Express</td>
<td>2,000</td>
</tr>
<tr>
<td>Eugene x Drop Box x Standard Ground</td>
<td>10,834</td>
</tr>
<tr>
<td>Eugene x Walk In x 2nd Day Guaranteed</td>
<td>16,000</td>
</tr>
<tr>
<td>Eugene x Walk In x Overnight Express</td>
<td>18,670</td>
</tr>
<tr>
<td>Eugene x Walk In x Standard Ground</td>
<td>36,700</td>
</tr>
<tr>
<td>Eugene x Commercial Pick Up x 2nd Day Guaranteed</td>
<td>10,000</td>
</tr>
<tr>
<td>Eugene x Commercial Pick Up x Overnight Express</td>
<td>13,000</td>
</tr>
<tr>
<td>Eugene x Commercial Pick Up x Standard Ground</td>
<td>17,000</td>
</tr>
</tbody>
</table>

2. Calculate the model, and then close the **Operation Summary**.
   
   You see that costs are now assigned to the nine accounts (for each location) that previously did not have costs.
Making Assignments with Sales Volume Drivers

It is helpful to understand that while you typically make assignments from accounts in the primary pane to accounts in the right pane, the Sales Volume driver automatically assigns costs to the right pane based on the quantity that you enter in the primary pane. You do not have to make explicit assignments. To see this, follow these steps:

1. Display the right pane by selecting Model ⇒ Assignments ⇒ Show Right Assignments Pane.

2. In the primary pane, select the Beaverton x Drop Box x No <Products and Services> account.

3. Select Model ⇒ Assignments ⇒ Show Right.

### Display Name | Cost | DryName | SoldQty
--- | --- | --- | ---
COST OBJECT (PRIMARY PANE) | $3,856,293.20 | 383,840.00
USA | $3,856,293.20 | 383,840.00
Oregon | $3,856,293.20 | 383,840.00
Beaverton | $2,127,721.43 | 255,136.00
No <Channel> | $1,998,820.25 |
2nd Day Guaranteed | $401,573.75 | Sales volume
Overnight Express | $564,408.06 | Sales volume
Standard Ground | $1,032,838.45 | Sales volume
Drop Box | $203,937.13 | 34,666.00
No <Products and Services> | $15,468.14 | Sales volume
2nd Day Guaranteed | $605,439.43 | 9,000.00
Overnight Express | $35,315.67 | 4,000.00
Standard Ground | $183,182.03 | 21,666.00
Walk In | $1,191,263.92 | 140,470.00
No <Products and Services> | $87,652.80 | Sales volume
2nd Day Guaranteed | $222,273.57 | 29,840.00
Overnight Express | $355,220.46 | 37,330.00
Standard Ground | $632,770.10 | 73,300.00
Commercial Pick Up | $652,520.38 | 80,000.00
No <Products and Services> | $25,780.24 | Sales volume
2nd Day Guaranteed | $142,941.92 | 20,000.00
Overnight Express | $225,329.11 | 26,000.00
Standard Ground | $283,249.36 | 34,000.00
Eugene | $1,728,571.77 | 128,704.00
No <Channel> | $1,605,579.27 |
2nd Day Guaranteed | $493,165.07 | Sales volume
Overnight Express | $245,887.62 | Sales volume
Standard Ground | $867,526.58 | Sales volume
Drop Box | $273,528.18 | 17,334.00
No <Products and Services> | $45,519.59 | Sales volume
2nd Day Guaranteed | $84,579.19 | 4,500.00
Overnight Express | $19,957.90 | 2,000.00
Standard Ground | $174,091.19 | 10,834.00
Walk In | $946,675.03 | 71,370.00
No <Products and Services> | $53,265.07 | Sales volume
2nd Day Guaranteed | $271,771.65 | 16,000.00
Overnight Express | $151,586.40 | 18,670.00
Standard Ground | $523,317.00 | 36,700.00
Commercial Pick Up | $503,368.56 | 40,000.00
No <Products and Services> | $18,207.84 | Sales volume
2nd Day Guaranteed | $165,245.43 | 10,000.00
Overnight Express | $100,854.85 | 13,000.00
Standard Ground | $236,268.28 | 17,000.00
You see that assignments have automatically been made to three accounts in the right pane. Notice that the three destination accounts in the right pane are all in the Cost Object module. The Sales Volume driver has generated three Cost Object-to-Cost Object assignments.

Note: You can verify that the accounts in the right pane belong to the Cost Object module by right-clicking an account in the right pane and selecting Go To Account.

You see that the destination account is in the Cost Object module.

4. In the primary pane, select the Eugene x No <Channel> x 2nd Day Guaranteed account.
5. Select Model ⇒ Assignments ⇒ Show Right.

TIP You can display assignments simply by clicking the Show Assignments icon ( ). It is not necessary to pull down the menu.

Again, you see that assignments have automatically been made to three accounts in the right pane.
Of course, you can show the assignments that have been made for any account to which the Sales Volume driver is assigned.

**Calculating Variable Costs**

If you return to the External Units module, you see that a cost has now been generated for the 2nd Day Flat account.

The reason that the cost has been calculated is that you assigned a Bill of Costs driver that uses the DQV property to the 2nd Day Flat account. To calculate the cost of an item that uses a DQV driver, you must know how many units of the item are required. Now that you have entered a Sold Quantity for the 2nd Day Guaranteed accounts (which are the final destination accounts for 2nd Day Flat), the cost of 2nd Day Flat can be calculated.

Let's look more closely at how the cost of $12,507.60 for 2nd Day Flat is calculated. Remember that you made assignments from the External Unit account, 2nd Day Flat, using a BOC driver with a Driver Quantity Variable. (See “Make Assignments and Calculate” on page 108.)

Unlike an account whose driver uses only DQF (whose cost is determined by an amount supplied) the cost of an account whose driver uses DQV is determined by an amount demanded. The cost on an assignment (DrvQtyCalc) is determined by the following formula:

\[
\text{DrvQtyCalc} = (\text{DQF} \times \text{DWF}) + (\text{DQV} \times \text{DWV} \times \text{Dest.TDQ})
\]
Notice that when DQV is non-zero, then DrvQtyCalc depends on the TDQ of the destination account (Dest.TDQ). In the case of the 2nd Day Flat account, the destination accounts are the following accounts in the Cost Object module, as you can see in the following picture:

- Eugene x Commercial Pick Up x 2nd Day Guaranteed
- Eugene x Drop Box x 2nd Day Guaranteed
- Eugene x Walk In x 2nd Day Guaranteed
- Beaverton x Commercial Pick Up x 2nd Day Guaranteed
- Beaverton x Drop Box x 2nd Day Guaranteed
- Beaverton x Walk In x 2nd Day Guaranteed

Note: You can not recreate this picture in the UI. It is created by combining multiple images in an image editor.

Note: Remember that the assignments to the final destination accounts result from your having attached the Sales Volume driver to the following two intermediary accounts:
- Eugene x No <Channel> x 2nd Day Guaranteed
- Beaverton x No <Channel> x 2nd Day Guaranteed

(See “Assign the Sales Volume Driver” on page 111.)

You can see from the picture that the TDQ of the final destination accounts results from your having assigned a Sold Quantity to those accounts, as shown in the following table. (See “Enter the Sold Quantity” on page 113.)

<table>
<thead>
<tr>
<th>Final Destination Account</th>
<th>Sold Quantity</th>
<th>Total Driver Quantity (TDQ)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eugene x Commercial Pick Up x 2nd Day Guaranteed</td>
<td>10,000</td>
<td>10,000</td>
</tr>
<tr>
<td>Eugene x Drop Box x 2nd Day Guaranteed</td>
<td>4,500</td>
<td>4,500</td>
</tr>
<tr>
<td>Eugene x Walk In x 2nd Day Guaranteed</td>
<td>16,000</td>
<td>16,000</td>
</tr>
<tr>
<td>Beaverton x Commercial Pick Up x 2nd Day Guaranteed</td>
<td>20,000</td>
<td>20,000</td>
</tr>
<tr>
<td>Beaverton x Drop Box x 2nd Day Guaranteed</td>
<td>9,000</td>
<td>9,000</td>
</tr>
<tr>
<td>Beaverton x Walk In x 2nd Day Guaranteed</td>
<td>29,840</td>
<td>29,840</td>
</tr>
</tbody>
</table>

In the following table, you can see how the cost of $12,507.60 is calculated for the 2nd Day Flat account using the following formulas:

1. DrvQtyCalc=(DQF*DWF)+(DQV*DWV*Dest.TDQ)
2. TDQ = \( \sum (\text{DrvQtyCalc}) \)
3. Cost = UnitCost \( \times \) TDQ

*Note:* The abbreviations used in the formulas are the following:

<table>
<thead>
<tr>
<th>Abbreviation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DrvQtyCalc</td>
<td>Driver Quantity Calculated</td>
</tr>
<tr>
<td>DQF</td>
<td>Driver Quantity Fixed</td>
</tr>
<tr>
<td>DWF</td>
<td>Driver Weight Fixed</td>
</tr>
<tr>
<td>DQV</td>
<td>Driver Quantity Variable</td>
</tr>
<tr>
<td>DWV</td>
<td>Driver Weight Variable</td>
</tr>
<tr>
<td>Dest</td>
<td>Destination</td>
</tr>
<tr>
<td>TDQ</td>
<td>Total Driver Quantity</td>
</tr>
</tbody>
</table>

\[
\text{DrvQtyCalc} = (\text{DQF} \times \text{DWF}) + (\text{DQV} \times \text{DWV} \times \text{Dest}. \text{TDQ})
\]

<table>
<thead>
<tr>
<th>Final Destination Account</th>
<th>DQF</th>
<th>DWF</th>
<th>DQV</th>
<th>DWV</th>
<th>Dest.TDQ</th>
<th>DrvQtyCalc</th>
</tr>
</thead>
<tbody>
<tr>
<td>Eugene x Commercial Pick Up x 2nd Day Guaranteed</td>
<td>0</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>10,000</td>
<td>10,000</td>
</tr>
<tr>
<td>Eugene x Drop Box x 2nd Day Guaranteed</td>
<td>0</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>4,500</td>
<td>4,500</td>
</tr>
<tr>
<td>Eugene x Walk In x 2nd Day Guaranteed</td>
<td>0</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>16,000</td>
<td>16,000</td>
</tr>
<tr>
<td>Beaverton x Commercial Pick Up x 2nd Day Guaranteed</td>
<td>0</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>20,000</td>
<td>20,000</td>
</tr>
<tr>
<td>Beaverton x Drop Box x 2nd Day Guaranteed</td>
<td>0</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>9,000</td>
<td>9,000</td>
</tr>
<tr>
<td>Beaverton x Walk In x 2nd Day Guaranteed</td>
<td>0</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>29,840</td>
<td>29,840</td>
</tr>
</tbody>
</table>

TDQ of 2nd Day Flat = sum of DrvQtyCalc for individual assignments

| TDQ: 89,340 |

Cost of 2nd Day Flat = UnitCost \( \times \) TDQ = 0.14 \( \times \) 89,340 = 12,507.60

| Cost: 12,507.60 |

**Sales Volume Drivers and Rule-Based Drivers**

The Sales Volume driver is a kind of rule-based driver (see "Postscript on Generating Assignments According to a Rule" on page 92.) If you attach a Sales Volume driver to an account, then calculation automatically makes an assignment to every destination account for which the following rule is true:

1. The destination account has a non-zero value for its SoldQuantity property.
2. The dimension signature (the intersection of its dimension members) of the destination account is the same as the dimension signature of the source account (to which the Sales Volume driver is attached).

*Note:* The null dimension counts as a wildcard—it matches any dimension.

For example, in the picture above you can see that the following pairs of dimension signatures match:
• Eugene x No <Channel> x 2nd Day Guaranteed for the source account matches Eugene x Drop Box x 2nd Day Guaranteed for the destination account.

• Eugene x No <Channel> x Overnight Express for the source account matches Eugene x Walk In x Overnight Express for the destination account.

• Eugene x No <Channel> x Standard Ground for the source account matches Eugene x Commercial Pick-Up x Standard Ground for the destination account.

As you can see, the null dimension, No <Channel>, matches each of the following dimensions: Drop Box, Walk In, and Commercial Pick-Up.

3. The structural dimensions of the module in which the Sales Volume driver is attached are the same as the structural dimensions of the Profitability module.

In practice, the Sales Volume driver is always attached to accounts in the Cost Object module, and the structural dimensions of the Cost Object module are the same as the Profitability module. In the Parcel Express tutorial model, the structural dimensions of both the Cost Object module and the Profitability module are:

• Region
• Channel
• Products and Services

In fact, because the Sales Volume driver is a kind of rule-based driver, you can make the same assignments with an appropriately defined rule-based driver as you can with the Sales Volume driver. To do so, you would do the following for the rule-based driver:

• Use a calculated driver whose formula is SoldQuantity. That is, instead of using the general formula $\text{DrvQtyCalc} = (DQF \times DWF) + (DQV \times DWV \times \text{Dest.TDQ})$, the calculated driver uses the formula $\text{DrvQtyCalc} = \text{SoldQuantity}$.

• The driver’s rule formula is the following:

$$\begin{align*}
\text{Dest.Region.DimMemName} &= \text{Source.Region.DimMemName} \\
\text{Dest.Chnnl.DimMemName} &= \text{Source.Chnnl.DimMemName} \\
\text{SoldQuantity} &> 0
\end{align*}$$

Note: Notice that the formula uses the dimension reference rather than the dimension name.

---

**Entering Revenue and Calculating Profit**

Profit and loss can be calculated after you enter sales data in the Revenue property.

**Create a new column layout**

1. Select Model $\Rightarrow$ Cost Object Module.
2. Select the Default column layout.
3. Select Model $\Rightarrow$ Assignments $\Rightarrow$ Show Single Pane.
4. Open the Column Layout dialog box.
5. Modify the primary pane as follows:
   - Remove the **Display Reference** column.
   - Add the **UnitCost**, **Sold Quantity**, **Revenue**, and **Profit** columns.

6. Save the new column layout with the name **Profit**.

7. Close the Column Layout dialog box.

**Enter revenue and calculate profit**

1. In the **Revenue** column, type the following values:

<table>
<thead>
<tr>
<th>Cost Object Account</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton x Drop Box x 2nd Day Guaranteed</td>
<td>72,550</td>
</tr>
<tr>
<td>Beaverton x Drop Box x Overnight Express</td>
<td>59,800</td>
</tr>
<tr>
<td>Beaverton x Drop Box x Standard Ground</td>
<td>379,166</td>
</tr>
<tr>
<td>Beaverton x Walk In x 2nd Day Guaranteed</td>
<td>321,667</td>
</tr>
<tr>
<td>Beaverton x Walk In x Overnight Express</td>
<td>558,133</td>
</tr>
<tr>
<td>Beaverton x Walk In x Standard Ground</td>
<td>123,333</td>
</tr>
<tr>
<td>Beaverton x Commercial Pick Up x 2nd Day Guaranteed</td>
<td>139,000</td>
</tr>
<tr>
<td>Beaverton x Commercial Pick Up x Overnight Express</td>
<td>388,700</td>
</tr>
<tr>
<td>Beaverton x Commercial Pick Up x Standard Ground</td>
<td>595,000</td>
</tr>
<tr>
<td>Eugene x Drop Box x 2nd Day Guaranteed</td>
<td>61,275</td>
</tr>
<tr>
<td>Eugene x Drop Box x Overnight Express</td>
<td>29,900</td>
</tr>
<tr>
<td>Eugene x Drop Box x Standard Ground</td>
<td>189,584</td>
</tr>
<tr>
<td>Eugene x Walk In x 2nd Day Guaranteed</td>
<td>215,834</td>
</tr>
<tr>
<td>Eugene x Walk In x Overnight Express</td>
<td>279,061</td>
</tr>
<tr>
<td>Eugene x Walk In x Standard Ground</td>
<td>641,667</td>
</tr>
<tr>
<td>Eugene x Commercial Pick Up x 2nd Day Guaranteed</td>
<td>69,500</td>
</tr>
<tr>
<td>Eugene x Commercial Pick Up x Overnight Express</td>
<td>194,350</td>
</tr>
<tr>
<td>Eugene x Commercial Pick Up x Standard Ground</td>
<td>297,500</td>
</tr>
</tbody>
</table>

2. Calculate the model, and then close the Operation Summary.

You see the following profit and loss information:
<table>
<thead>
<tr>
<th>Display Name</th>
<th>Cost</th>
<th>UnitCost</th>
<th>SoldQty</th>
<th>Revenue</th>
<th>Profit</th>
</tr>
</thead>
<tbody>
<tr>
<td>USA</td>
<td>$3,856,293.20</td>
<td>383,840.00</td>
<td>$4,616,020.00</td>
<td>$759,726.80</td>
<td></td>
</tr>
<tr>
<td>Oregon</td>
<td>$3,856,293.20</td>
<td>383,840.00</td>
<td>$4,616,020.00</td>
<td>$759,726.80</td>
<td></td>
</tr>
<tr>
<td>Beaverton</td>
<td>$1,277,721.43</td>
<td>265,000.00</td>
<td>$2,637,349.00</td>
<td>$509,627.57</td>
<td></td>
</tr>
<tr>
<td>No &lt;Channel&gt;</td>
<td>$1,990,620.25</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>$401,573.75</td>
<td>6.32</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Overnight Express</td>
<td>$564,408.05</td>
<td>8.38</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Standard Ground</td>
<td>$1,032,635.45</td>
<td>9.01</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Drop Box</td>
<td>$283,937.15</td>
<td>134,666.00</td>
<td>$511,516.00</td>
<td>$227,578.87</td>
<td></td>
</tr>
<tr>
<td>No &lt;Products and Service</td>
<td>$15,468.14</td>
<td>0.05</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>$65,439.43</td>
<td>7.27</td>
<td>9,000.00</td>
<td>$72,550.00</td>
<td>$7,110.57</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>$35,315.57</td>
<td>8.28</td>
<td>4,000.00</td>
<td>$59,800.00</td>
<td>$24,484.33</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>$183,182.03</td>
<td>9.45</td>
<td>21,566.00</td>
<td>$379,166.00</td>
<td>$195,983.97</td>
</tr>
<tr>
<td>Walk In</td>
<td>$1,191,263.92</td>
<td>140,470.00</td>
<td>$1,003,133.00</td>
<td>$188,190.92</td>
<td></td>
</tr>
<tr>
<td>No &lt;Products and Service</td>
<td>$77,652.30</td>
<td>0.62</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>$222,273.37</td>
<td>7.45</td>
<td>29,840.00</td>
<td>$321,667.00</td>
<td>$99,393.63</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>$396,229.46</td>
<td>9.01</td>
<td>57,330.00</td>
<td>$558,133.00</td>
<td>$221,912.54</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>$632,770.10</td>
<td>9.32</td>
<td>73,060.00</td>
<td>$123,333.00</td>
<td>$509,437.10</td>
</tr>
<tr>
<td>Commercial Pick Up</td>
<td>$652,520.38</td>
<td>80,000.00</td>
<td>$1,022,700.00</td>
<td>$470,179.62</td>
<td></td>
</tr>
<tr>
<td>No &lt;Products and Service</td>
<td>$25,700.24</td>
<td>0.32</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>$142,941.92</td>
<td>7.15</td>
<td>20,000.00</td>
<td>$139,000.00</td>
<td>$(3,941.92)</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>$226,329.11</td>
<td>8.70</td>
<td>26,000.00</td>
<td>$388,700.00</td>
<td>$162,370.89</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>$283,249.36</td>
<td>8.33</td>
<td>34,000.00</td>
<td>$595,000.00</td>
<td>$313,750.64</td>
</tr>
<tr>
<td>Eugene</td>
<td>$1,728,571.77</td>
<td>128,704.00</td>
<td>$1,578,671.00</td>
<td>$250,099.23</td>
<td></td>
</tr>
<tr>
<td>No &lt;Channel&gt;</td>
<td>$1,606,579.27</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>$493,165.07</td>
<td>15.17</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Overnight Express</td>
<td>$245,887.62</td>
<td>7.30</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Standard Ground</td>
<td>$667,750.58</td>
<td>15.44</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Drop Box</td>
<td>$278,529.18</td>
<td>17,334.00</td>
<td>$280,789.00</td>
<td>$2,230.82</td>
<td></td>
</tr>
<tr>
<td>No &lt;Products and Service</td>
<td>$15,929.59</td>
<td>2.63</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>$94,579.19</td>
<td>15.83</td>
<td>4,500.00</td>
<td>$61,275.00</td>
<td>$(523,304.19)</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>$19,957.80</td>
<td>9.93</td>
<td>2,000.00</td>
<td>$29,900.00</td>
<td>$10,042.20</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>$174,091.19</td>
<td>15.07</td>
<td>10,324.00</td>
<td>$169,584.00</td>
<td>$15,492.81</td>
</tr>
<tr>
<td>Walk In</td>
<td>$946,675.30</td>
<td>71,370.00</td>
<td>$1,136,536.00</td>
<td>$189,896.97</td>
<td></td>
</tr>
<tr>
<td>No &lt;Products and Service</td>
<td>$59,265.37</td>
<td>3.92</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>$271,771.53</td>
<td>16.99</td>
<td>16,000.00</td>
<td>$215,834.00</td>
<td>$(55,937.53)</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>$151,586.40</td>
<td>8.12</td>
<td>18,570.00</td>
<td>$279,061.00</td>
<td>$127,474.63</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>$523,107.00</td>
<td>14.26</td>
<td>36,700.00</td>
<td>$611,667.00</td>
<td>$118,350.00</td>
</tr>
<tr>
<td>Commercial Pick Up</td>
<td>$503,908.56</td>
<td>40,000.00</td>
<td>$561,350.00</td>
<td>$57,981.44</td>
<td></td>
</tr>
<tr>
<td>No &lt;Products and Service</td>
<td>$18,207.84</td>
<td>0.46</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>$166,245.43</td>
<td>15.62</td>
<td>10,000.00</td>
<td>$69,500.00</td>
<td>$(96,745.43)</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>$100,954.85</td>
<td>7.76</td>
<td>13,000.00</td>
<td>$184,350.00</td>
<td>$83,395.15</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>$236,260.20</td>
<td>13.96</td>
<td>17,000.00</td>
<td>$297,500.00</td>
<td>$61,231.72</td>
</tr>
</tbody>
</table>
Overview

The Contributions page provides the fastest and easiest method to view cost flows throughout a model. To query a model on the Contributions page, the model must have been calculated. However, a cube does not need to be generated. Queries are fast because there is no cube to navigate.

Open the Contributions Page

1. Click Contributions in the Navigation pane, and then click New Query. This option appears only if the Contributions Server has been installed.
Or, select File $\Rightarrow$ New $\Rightarrow$ Contribution Query

2. Select Parcel Express Tutorial as the model.

3. Select 2008 Q1/Actual as the association to use.


*Note:* Apache Tomcat must be running on the server.

Some Key Things to Know

- Select a module (Resource, Activity, Cost Object, External Unit) to expand it. Expanding a module does not select anything in it. Select checkboxes to select dimensions in the module.

- You can choose only one module, but you can select multiple dimensions in a module.
Note: Only one module is active at a time. Do not be misled by the fact that checkboxes remain selected when a module is collapsed. If a module is collapsed, then it is not active.

- You can select up to 10 dimensions. You can select any number of levels within a dimension (for the Contributions page, Drivers is considered a dimension). The following picture should make clear how dimensions are counted. In this picture, four dimensions are selected and six dimension levels:

You must select at least one source level and at least one destination level.

- You do not have to select anything in Via Module/Stage(s). Select nothing means that all paths from source to destination are included in calculations. Select something in Via Module/Stage(s) to restrict the paths that are included.

---

**Query Contributions from Resource to Cost Object**

To refresh your memory, here again is a picture of the model dimensions:
Query from general ledger to products and services

1. For Source Module, select **Resource**, and then select:
   - **Level1** under **General Ledger**

2. For Destination Module, select **Cost Object**, and then select:
   - **Level1** under **Products and Services**

3. Click **Get Results**. The resulting table shows the contributions of wages, operating expenses, and equipment expenses to each of the products.

Add a region to source and destination

1. For Source Module, select **Resource**, and then select:
   - **Level3** under **Region**
   - **Level1** under **General Ledger**

Add a region to source and destination
2. For Destination Module, select **Cost Object**, and then select:
   - **Level3** under **Region**
   - **Level1** under **Products and Services**

3. Click **Get Results**. The resulting table shows, by region, the contributions of wages, operating expenses, and equipment expenses to each of the products by region. (In order to fit the picture on the page, the table has been split in two and one half stacked on top of the other.)

### Table: Contributions by Region

<table>
<thead>
<tr>
<th>Region</th>
<th>Wages</th>
<th>Operating Expenses</th>
<th>Equipment Expenses</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beaverton</td>
<td>11989.56</td>
<td>361146.58</td>
<td>481772.77</td>
</tr>
<tr>
<td>Beaverton</td>
<td>6288.62</td>
<td>4991.75</td>
<td>79472.73</td>
</tr>
<tr>
<td>Beaverton</td>
<td>2735.00</td>
<td>1335.01</td>
<td>18289.75</td>
</tr>
<tr>
<td>Eugene</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
</tr>
<tr>
<td>Eugene</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
</tr>
<tr>
<td>Eugene</td>
<td>1900.00</td>
<td>11634.14</td>
<td>5466.78</td>
</tr>
</tbody>
</table>

Add channel to the destination

1. For Source Module, select **Resource**, and then select:
   - **Level3** under **Region**
   - **Level1** under **General Ledger**[MB2]

2. For Destination Module, select **Cost Object**, and then select:
   - **Level3** under **Region**
   - **Level1** under **Channel**
   - **Level1** under **Products and Services**
3. Click **Get Results**.

The resulting table shows the contributions of wages, operating expenses, and equipment expenses to each of the products by region and channel. (Again, the table is split in pieces to fit on the page.)

Because the table is long, you must scroll to see all the columns. The scroll button scrolls one column at a time.

### Add a Via module

1. For **Source Module**, select **Resource**, and then select:
   - **Level3 under Region**
   - **Level1 under General Ledger**
2. For Via Module, select **Activity**, and then select:
   - **Level2** under **Activities**

3. For Destination Module, select **Cost Object**, and then select:
   - **Level1** under **Channel**
   - **Level1** under **Products and Services**

   **Note:** We have deselected Region. This reduces the number of result columns by half. Because there are two items at **Level3** under Region (Beaverton and Eugene), the number of columns would double. If you want to see activities by region, then you can add it back.

4. Click **Get Results**.

5. The resulting table shows the general ledger contributions by activity to each of the three products by channel. (Activities in the Via column are shown in yellow.) Because it is large, only part of the table is shown.

---

**Query Contributions from Resource to Activity**

**Query from general ledger to activities**

1. For Source Module, select **Resource**, and then select:
1. For Source Module, select **Activity**, and then select:
   - **Level3** under **Region**
   - **Level1** under **General Ledger**

2. For Destination Module, select **Activity**, and then select:
   - **Level2** under **Activities**

3. Click **Get Results**. The resulting table shows the contributions, by region, of general ledger items to activities.

Drilling Down to a Lower Level

**Drill to lower-level activities**

The table generated by a query is not static. If you select a dimension level to display that has additional levels under it, you can click the generated table to display the next level of detail.

1. For Source Module, select **Activity**, and then select:
   - **Level3** under **Region**
   - **Level1** under **Activities**

2. For Destination Module, select **Cost Object**, and then select:
   - **Level1** under **Products and Services**

3. Click **Get Results**.

The resulting table shows the contributions of activities, by region, to products and services. Note that the Activities column is highlighted.
4. Click **1:Local Processing** in the Activities column to go to the next level of detail.

Initially, activities were displayed at Level1. By clicking, you drill down to Level2 activities. Notice that the entire table is replaced by the Level2 activities. Also notice that the roll-up account **1:Local Processing** is displayed.

5. Click **Drill Up** to return to the previous table.

---

**Using the ABC Procedure**

SAS Activity-Based Management has externalized, in the form of the ABC procedure, the processing that it uses internally to calculate a model and query a cube. The ABC procedure allows you to create SAS programs to query model data outside of SAS Activity-Based Management.

The easiest method to create a program that uses the ABC procedure is to use the Contributions tab to perform a query. Then click **Gen Proc Stmt** to copy, to the clipboard, the PROC ABC statement that the Contributions tab itself used for the query. For example: Assume that you have performed the query described above; click **Gen Proc Stmt** and paste the statement into the SAS editor (or any ASCII editor). You will see something similar to the following:
You can modify the program in any way that you like before running it.

Note that you must click **Get Results** before clicking **Gen ProcStmt**. Changing the query options after performing a query does not change what statement is copied to the clipboard unless you click **Get Results** again to perform a different query.
Overview

When the information has been entered into the activity-based management model, the costs have been calculated, and the data has been reviewed, the next step in analyzing the data is generating reports.

The benefits of generating reports include:

- validating the model
- producing printouts that present an overall view of the data
- analyzing costs online
- producing files for inclusion in other programs, such as spreadsheets or word processors
- focusing on a specific area of interest

Report Templates

A report template is a file that specifies the layout of a report and the fields of data in a report (but not the data itself). When you create a report, you first select a report template.

SAS Activity-Based Management has predefined report templates that provide formats and that enable great flexibility in the amount and type of information to include in a report. The following predefined templates are included:
Creating a Report

You will create a report and view the results online. The report is for the 2008 Q1/Actual period/scenario association, and includes information about resource contributions.

To create a new report, you use the Report Wizard. The Report Wizard has six steps.

• Select a model and template
  1. Click **Reports** in the Navigation Pane.

You see the Reports workspace.

2. Select **File** ⇒ **New** ⇒ **Report**.

You see Step 1 of the Report Wizard.
3. Under **Select a model and a report template**, select the **Parcel Express Tutorial** model and the **Single-stage Assignments** report template.

   *Note:* To create a report you do not have to generate a cube. However, to create the following reports you must have already generated the Fact table for the model:
   - Resource Contributions
   - Destination Furthest
   - Profit and Loss (Resource Contribution)

4. Click **Next**.
   You see Step 2 of the Report Wizard.

5. Select **2008 Q1/Actual**, and then click **Next**.
   You see Step 3 of the Report Wizard.

6. Select **Use all modules**, and then click **Next**.
   You see Step 4 of the Report Wizard.

7. Verify that no dimensions are selected.
   Certain report types require you to select dimensions to arrange and filter data. For these reports, the order that you select these dimensions affects the results that you see in the report.
   Click **Next**.
   You see Step 5 of the Report Wizard.

8. Verify that **Suppress zero costs** and **Single currency** are selected, and then click **Next**.


10. For Name, type **PX Tutorial Single-stage Assignments**.

11. Click **Finish**.
    You see the finished report in portable document format (PDF).
The data in this report reflects the current model. If you make changes to the model and reopen the report, the report data reflects the changes.

Each report has a header that lists pertinent information for that report. All or some of the following information can be listed in a report's header:

<table>
<thead>
<tr>
<th>Information</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Model Name</td>
<td>The model that is selected for the report.</td>
</tr>
<tr>
<td>Module</td>
<td>One or more modules that are selected for the report. Each module starts on a new page.</td>
</tr>
<tr>
<td>Period</td>
<td>The period that is selected for the report.</td>
</tr>
<tr>
<td>Scenario</td>
<td>The scenario that is selected for the report.</td>
</tr>
<tr>
<td>View Perspective</td>
<td>The structural dimension that is selected for the report.</td>
</tr>
<tr>
<td>Filtered</td>
<td>Indicates that one or more attributes were used to select items for the report. Attributes that are used to select report data are listed on a report's last page.</td>
</tr>
</tbody>
</table>

The data in this report reflects the current model. If you make changes to the model and reopen the report, the report data reflects the changes.

Each report has a header that lists pertinent information for that report. All or some of the following information can be listed in a report's header:

<table>
<thead>
<tr>
<th>Information</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Model Name</td>
<td>The model that is selected for the report.</td>
</tr>
<tr>
<td>Module</td>
<td>One or more modules that are selected for the report. Each module starts on a new page.</td>
</tr>
<tr>
<td>Period</td>
<td>The period that is selected for the report.</td>
</tr>
<tr>
<td>Scenario</td>
<td>The scenario that is selected for the report.</td>
</tr>
<tr>
<td>View Perspective</td>
<td>The structural dimension that is selected for the report.</td>
</tr>
<tr>
<td>Filtered</td>
<td>Indicates that one or more attributes were used to select items for the report. Attributes that are used to select report data are listed on a report's last page.</td>
</tr>
</tbody>
</table>
Working with Reports

Overview

All saved report configurations that are on the same server are listed in the Workspace Manager. Your company might want to set up guidelines for saving and naming report configurations. You can open a report configuration from the Workspace Manager or from the Reports workspace.

On the Reports workspace, you can open, publish, configure, or delete a report configuration.

Note: If a report is already open in the Reports workspace, you can return to the list of reports by clicking the Go to Reports Workspace icon in the Reports workspace toolbar.

Navigating Reports

You can navigate the pages of a report by using the standard Adobe Acrobat paging and search tools on the toolbar.

Saving Report Data

Overview

When you save a report configuration, you are saving only the parameters of the report, not the data. To save the data in a report, you must publish or export the report.

Publishing Reports

If you want other users to see the report results, along with the data that reflects a specific time period, you can publish the report. If you want to view and edit the report using SAS Web Report Studio, you must publish the report.

Publishing the report enables others to see the report data without having to rerun the report. In cases where a report requires considerable time to run, publishing the report can save time for other users.

Publish a report


You see the Publish a Report dialog box.
2. Type a **Name**.
   
   *Note:* You cannot enter a path. Published reports are stored on the SAS Activity-Based Management server.

3. Type a **Description**.

4. Select a **Format**.
   
   The available publishing formats are:
   
   • Portable Document Format (PDF)
   • Rich Text Format (RTF)

5. Click **OK**.
   
   The report is added to the Workspace Manager in the Published Reports folder.

**Exporting Reports**

If you want to manipulate a report after running it, you can export the report. Data that you export from SAS Activity-Based Management can be used by other reporting tools, such as SAS Enterprise Guide and Microsoft Excel. To export a report, select **File ➔ Export ➔ Report Data**, and follow the instructions in the Report Data Wizard.

**Importing Published Reports**

You can also import a published report created outside of SAS Activity-Based Management. For example, you can import reports published by SAS Enterprise Guide. To import a published report (for example, from Enterprise Guide), in Workspace Manager select **Published Reports**, and select **File ➔ Insert Published Report**.

**Configuring Reports**

By running the New Report Wizard, you are configuring a report.

**Reconfigure a report**

1. On the Reports workspace, select a report click **Configure Report**.
   

2. Complete the Report Wizard by selecting the new configuration settings.
Overview

A cube is the basic unit of analysis in OLAP, a technology that provides fast, interactive access to data in a model. A cube is a storage unit that combines all of a model's dimensions and the measures they contain into one unit. You use SAS Activity-Based Management to connect to and interact with the cubes on a SAS Activity-Based Management server. For each model, you can generate cubes and manipulate them on the OLAP page to interactively analyze business data.

An OLAP cube is called a cube even if it has more than the three dimensions of an ordinary geometric cube. An OLAP cube can represent any number of dimensions of data. SAS Activity-Based Management cubes are standard OLAP cubes.

Types of Cubes

**Multi-Stage Contribution Cube**

Use this type of cube to perform tasks and to answer questions such as:

- Why is product A not profitable? You want to trace the costs back through activities and then to resources that contribute costs to this product.
What are the costs for Product B that originate in salary resources and that are assigned through the Inspection activity to this product?

The multi-stage contribution cube enables you to analyze cost contributions into and out of stages that are defined in a model. The Cube Explorer view enables you to visually trace cost contributions through all the stages.

Resource Contribution Cube

Use this type of cube to analyze resource accounts that contribute costs to other accounts. Or, use this type of cube to analyze the accounts that receive costs from resources.

The resource contribution cube enables you to analyze cost contributions from original accounts (where costs were entered) to final accounts that do not assign costs to other accounts. Generally, these contributions are from resource accounts to cost object accounts, but it does not matter where the original or final accounts reside.

Single-Stage Contribution Cube

Use this type of cube to answer questions such as:

- Which activity costs contribute to product, customer, service costs, and so on?
- When costs are assigned within the cost object module, which subassembly costs contribute to product costs?
- What are the costs of resources that contribute to activities?

The single-stage contribution cube enables you to analyze cost contributions from one assignment level back. It does not matter where the costs originate or end. Typically, cost is contributed from:

- activities to cost objects
- resources to activities

Overview of Cube Generation

Generating a cube is a two-step process.

**Step 1: Create a cube configuration**

From a single model, you can generate multiple cubes. A cube configuration remembers your choices for a particular cube. If you update the model and need to regenerate the cube, you don’t have to specify the cube characteristics again. In short, one model can have multiple cube configurations, and each cube configuration contains the specifications for a single cube.

**Step 2: Generate the cube**

After a model has been calculated, you generate cubes by specifying which of the cube configurations belonging to the model are to be used, and which periods are to be included. For each cube configuration that you select, a cube is generated. If the model has not been calculated, you are asked if you want the calculation to be done so that cube generation can proceed.
Cube Configurations

For this tutorial, you will create four cube configurations:

- resource contribution cube
- 6.3-compatible multi-stage contribution cube
- custom multi-stage contribution cube
- custom, but minimal, multi-stage contribution cube

Create a resource contribution cube

1. Go to the Workspace Manager.

2. Select File ⇒ New ⇒ Cube Configuration.
   
   Step 1 of the New Cube Configuration wizard opens.
Specify the following for step 1:

- For **Model name**, select **Parcel Express Tutorial**.
- For **Cube configuration name**, type **Parcel Express Tutorial – Resource Contribution**.
- In the **Generate** section, select **Cube and Fact table**.
- For **Type**, select **Resource Contribution**.
- In the **Cube and Fact Table Information** section, select **Create SAS Activity-Based Management 6.3 compatible cube and fact table**.

*Note:* For a resource contribution cube, the only option available is to generate a 6.3 compatible cube.

For a multi-stage contribution cube, you can generate a custom cube. A custom cube is one for which you choose what goes into it. We'll look at this in a moment.

3. **Click Next.** Step 2 opens.

This step allows you to specify options for cube generation. The options available depend on whether you are using SAS OLAP or Microsoft Analysis Services to display cubes. The following picture shows the options for SAS OLAP cubes.
The following picture shows the options for Microsoft Analysis Services cubes.

For this tutorial you can accept the default options.


5. Select all numeric attributes to be included in the resource contribution cube. Since the Parcel Express Tutorial model is relatively small, you can select all of the numeric attributes.

6. Click Next. Review your options, and then click Finish.
The cube configuration is added to the Cube Configurations folder.

Create a multi-stage contribution cube

1. Select File ➔ New ➔ Cube Configuration.

Step 1 of the New Cube Configuration wizard opens.

Specify the following for step 1:

- For Model name, select Parcel Express Tutorial.
- For Cube configuration name, enter Parcel Express Tutorial – Multi-Stage Contribution.
- In the Generate section, select Cube and Fact table.
- For Type, select Multi-Stage Contribution.
- For Cube and Fact Table Information, select Create SAS Activity-Based Management 6.3 compatible cube and fact table.
Later, you will see what is involved in creating a custom cube. For now, choose a 6.3 compatible cube.

2. Click **Next**. Step 2 opens.

This step allows you to specify options for cube generation. The options available depend on whether you are using SAS OLAP or Microsoft Analysis Services to display cubes. The following picture shows the options for SAS OLAP cubes.

![Cube Options for SAS OLAP Cubes](image1.png)

The following picture shows the options for Microsoft Analysis Services cubes.

![Cube Options for Microsoft Analysis Services Cubes](image2.png)

For this tutorial you can accept the default options.

3. Click **Next**.

Step 3 opens. In this step, you select which modules or stages to include in the cube, and whether to include costs flowing into or out of the module or stage.
Click the **Modules** checkbox. This means that each module defines a separate stage in the order shown.

Selecting the **Stages** checkbox means that stages are defined by user-defined Stages attributes applied to accounts. The Parcel Express tutorial does not have any such attributes, so you select **Modules**.

• Select **Include** to include all the modules in the cube.

• Leave the defaults for Cost Flow as shown. The cost flow specifies whether to include cost flows into or out of the selected module or stage. We’ll look more closely at what this choice means later in this chapter. In the meantime, you can take the defaults.

4. Click **Next**.

Step 4 opens. In this step, you select numeric attributes to be included in the cube. Since the tutorial model is relatively small, select all of the attributes.

5. Click **Next**. Review your selections, and then click **Finish**.

The cube configuration is added to the Cube Configurations folder.

Create a custom multi-stage contribution cube

A custom cube allows you to select what goes into the cube. This allows you to create smaller cubes for particular purposes.

1. Select **File** ⇒ **New** ⇒ **Cube Configuration**. Step 1 opens.

Specify the following for step 1:

• For Model name, select **Parcel Express Tutorial**.

• For Cube configuration name, enter **Parcel Express Tutorial – Custom Cube**.

• In the Generate section, select **Cube and Fact table**.

• For Type, select **Multi-Stage Contribution**.

• In the Cube and Fact Table Information section, select **Create custom cube and fact table**.

• For Cube and Fact table name, enter **Parcel Express Tutorial Custom Cube**.

Because you can generate different multi-stage contribution cubes for the same model, you must assign a name to each cube to identify it.
2. Click **Next**.

Step 2 opens. This step allows you to specify options for cube generation. The options available depend on whether you are using SAS OLAP or Microsoft Analysis Services to display cubes.

Once again, you can accept the default options.

3. Click **Next**.

Step 3 opens. In this step, you can select not only which modules or stages to include in the cube, but also the level at which to include them.

- Click the **Modules** checkbox. This means that each module defines a separate stage in the order shown.
- Click the plus sign to expand the Resource module, and uncheck **GL (General Ledger)**. The cube will be smaller if you exclude some accounts.
- Click the plus sign to expand the Cost Object module, and under the **Include to Level** column, select **Level 3** from the drop-down list for **Region**. Selecting **Level 3** for Region includes the details for Beaverton and Eugene in the cube.
- Leave the defaults under **Cost Flow** as shown. We'll look more closely at what this choice means later in the chapter.

4. Click **Next**. Step 4 opens.

5. Select all the numeric attributes to be included in the cube.

6. Click **Next**. Review your options, and then click **Finish**.

The cube configuration is added to the Cube Configurations folder.

**Create a minimal custom multi-stage contribution cube**
The next cube configuration that you create is an interesting one because it is very small. It provides an illustration of the utility of custom multi-stage contribution cubes. Even though this one is small, it is useful because it allows you to concentrate on total costs without worrying about where they come from.

1. Select **File** → **New** → **Cube Configuration**. Step 1 opens.
   Specify the following for step 1:
   - For **Model name**, select **Parcel Express Tutorial**.
   - For **Cube configuration name**, enter **Parcel Express Tutorial – Mini Cube**.
   - In the **Generate** section, select **Cube and Fact table**.
   - For **Type**, select **Multi-Stage Contribution**.
   - In the **Cube and Fact Table Information** section, select **Custom Cube**.
     For **Cube and Fact table name** name, specify **Parcel Express Tutorial Mini Cube**.

2. Click **Next**.
   Step 2 opens. This step allows you to specify options for cube generation. The options available depend on whether you are using SAS OLAP or Microsoft Analysis Services to display cubes.
   Once again, you can accept the default options.

3. Click **Next**.
   Step 3 opens. In this step, you can select not only which modules or stages to include in the cube, but also the level at which to include them.

   ![New Cube Configuration - Modules, Dimensions, Stage Dimensions and Levels](image)

   - Click the **Modules** checkbox.

   - Uncheck the first three modules: **External Unit**, **Resource**, and **Activity**. In this cube, you want to see only final costs.

   - Click the plus sign to expand the Cost Object module, and under the **Include to Level** column, select **Level 3** from the drop-down list for Region. Selecting
Level3 for Region includes the details for Beaverton and Eugene in the cube. The default is to include up to and including Level 2.

- Leave the defaults under Cost Flow as shown.

4. Click Next. Step 4 opens.
5. Select all the numeric attributes to be included in the cube.
6. Click Next. Review your options, and then click Finish.

The cube configuration is added to the Cube Configurations folder.

---

**Generate Cubes**

Having created four cube configurations, you can use them to generate cubes.

1. If the Parcel Express Tutorial is not already open, return to model mode and open the tutorial model.
2. Select Model ⇒ Generate Cubes.

The Generate Cubes dialog opens.

3. Select the four cube configurations that you created.
4. Select the period/scenario 2008 Q1/Actual.

Note: In previous releases of SAS Activity-Based Management, you could not select a subset of periods/scenarios for inclusion.

5. Click Generate.

One cube is generated for each cube configuration that is selected.
Select Cost Flow: In or Out

With some models, it makes a difference in generating a cube whether you select to show costs flowing into a module/stage or out of a module/stage. It makes a difference in case the model has assignments from accounts within a module/stage to accounts within the same module/stage. For the Parcel Express Tutorial model in Chapter 3, Making Assignments, you made assignments from activities to activities. One such example is shown in the following picture.

Note: To display these assignments:
1. Select the Activity module.
2. Select Left and Right Assignments Panes from the View Assignments Panes icon.
3. Select the Move to Warehouse account.
4. Select Show Left and Right from the Show Assignments icon.

Tip: You can simply click the View Assignments Panes icon. It is not necessary to pull down the menu.
Tip: You can simply click the Show Assignments icon. It is not necessary to pull down the menu.

When you generate a cube, you must specify what cost assignments you want to appear in the cube for each module/stage. Sticking with the current example, you must choose assignments into the Activity module (Move to Warehouse), or out of the Activity Module (Sort and Inspect). You cannot choose both because that would result in double-counting final costs (part of Sort and Inspect costs are Move to Warehouse costs).

The following picture shows the results of showing costs flowing into the Activity module. Notice that Move to Warehouse has non-zero cost because it receives assignments from the Resource module. Inspect and Sort also have non-zero costs because they also receive assignments from the Resource module.

By contrast, the following picture shows the results of showing costs flowing out of the Activity module. Notice that Move to Warehouse now has zero cost because it has no assignments out of the Activity module into the Cost Object module; its assignments are entirely within the Activity module.
If a model has no cost assignments from accounts within a module/stage to accounts within the same module/stage, then the choice of showing cost flows into or out of a module/stage makes no difference (Every cost into a module/stage is also a cost out of the module/stage.). By defining multiple stages such that there are no assignments within a single stage, you avoid having to make the choice of showing cost flows in or out.

### Manage Cube Permissions

After generating a cube, you can change its owner and control who has permission to access it. Permission is granted by role. All users who are authorized to a role can receive permission (or be denied permission) to view a cube. Roles are created, and users are assigned to roles, in the SAS Activity-Based Management Administrator program.

**Note:** The ability to manage permissions in this way is restricted to cubes stored in Microsoft Analysis Services (MSAS).

#### Manage cube permissions

1. Select **Model ⇒ Manage Cubes and Permissions**.
   
The Manage Cubes and Permissions dialog box opens.

2. Select the cube whose permissions you want to manage.
Note: You can change only one cube at a time.

3. Click **Permissions**.

The Permissions dialog box opens.

4. You can add or remove Read access to groups. All members of the group inherit the permissions that you select for that group.
Chapter 17
Using the SAS OLAP Analyzer

Creating OLAP Views ..................................................... 155
Analyzing OLAP Cubes .................................................. 156
  Overview ................................................................. 156
  Selecting and Displaying Dimensions in Cubes .................. 157
  Displaying Dimension Attributes .................................. 163
  Summary: Rows and Columns ....................................... 165
  Saving OLAP Views .................................................... 167
  Using Measures in Cubes ............................................. 167
  Exporting Cubes ...................................................... 173
Using the Cube Explorer View ........................................ 174

Creating OLAP Views

Once you have generated cubes, you use the SAS OLAP Analyzer to view the cube.

Create an OLAP view

1. Select File ⇒ New ⇒ OLAP View.

   You see Step 1 of the New OLAP View Wizard. The New OLAP View Wizard has
   only one step.

2. Select the Parcel Express Tutorial model.


4. Click Finish.
You see the resource contributions cube for the Parcel Express Tutorial model.

The cube view will be slightly different if you generated the cube using SAS OLAP than if you generated it using Microsoft SQL Server Analysis Services. For example, if the cube was generated using Microsoft SQL Server Analysis Services, then the Product and Services row is collapsed rather than expanded. This chapter shows a cube generated by using SAS OLAP.

Analyzing OLAP Cubes

Overview

So far, the only information that the cube has provided is the costs for periods and scenarios. To perform an interactive analysis of the cube, you will select specific dimensions for analysis. You use the Data Dimensions window to select dimensions for display in OLAP cubes.
Note: If the Data Dimensions window is not visible, click the Data Dimensions tab to enlarge it.

Selecting and Displaying Dimensions in Cubes

Select dimensions

1. Select Rows from the Add To drop-down list.

2. Select Src_REGION and click the add arrow.

Note: Make sure that Rows is selected to add to rows.

3. Select Src_GENERAL_LEDGER and click the add arrow to add to Row.

4. Move All Dst_PRODUCTS_and_SERVICES from rows to columns.

   To do this, click the down-arrow next to All Dst_PRODUCTS_and_SERVICES and select Move to Columns on the menu.
5. Remove **AllPeriods** from columns.

To do this, click the down-arrow next to **AllPeriods** and select **Remove from View** on the menu.

The table view should now look like the following:

The data in the table view has been updated according to the dimensions that you have selected. To see the details, you must drill through the dimensions.

**Collapse the table**

Click the links in the table header to collapse rows or columns to produce a more compact table.

1. Click **Src_Region** in the table header.
2. Click **Src_General_Ledger** in the table header.

Your table should now look like the following.

<table>
<thead>
<tr>
<th>Level</th>
<th>All</th>
<th>None</th>
<th>2nd Day Guaranteed</th>
<th>Overnight Express</th>
<th>Standard Ground</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Cost</td>
<td>Cost</td>
<td>Cost</td>
<td>Cost</td>
<td>Cost</td>
</tr>
<tr>
<td>All Src Region</td>
<td>All Src_General_Ledger</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>All Src Region</td>
<td>All Src_General_Ledger</td>
<td></td>
<td>953,250.90</td>
<td>870,164.28</td>
<td>2,032,677.56</td>
</tr>
</tbody>
</table>

Note: If links are not active in the table header, you can make them active by clicking the down arrow next to any item in the header and selecting **Show All Drill Paths and Descriptions**.

Drill through dimensions

1. Click the down arrow next to the **All Src_General_Ledger** row in the grid.

   **Note**: Use 
   to drill down (the node that you click is replaced by its children). Use 
   to expand (the node that you click is displayed along with its children).

You see the **SrcGeneral_Ledger** dimension expand, showing the costs for each item.
2. Delete empty rows and columns by clicking the View Properties button on the toolbar. Then click Optimize Results and uncheck the following two boxes:

- Show empty rows in results
- Show empty columns in results

You see that the empty rows and columns have been removed from the grid and bar chart.

3. Drill down on the AllSrc_Region row multiple times until you see the general ledger expenses for Eugene and Beaverton.
Both the grid and bar chart show the contribution of resource accounts to each product.

4. In the Data Dimensions window, add Dst_Channel to Column.
You see that the All_Channel dimension has been added to the grid and bar chart.

The table view should look like the following, showing the cost per channel for each product and service:

<table>
<thead>
<tr>
<th>Level?</th>
<th>2nd Day Guaranteed</th>
<th>Walk In</th>
<th>Overnight Expense</th>
<th>Walk In</th>
<th>Standard Ground</th>
</tr>
</thead>
<tbody>
<tr>
<td>Measures</td>
<td>Cost</td>
<td>Drop Box</td>
<td>Cost</td>
<td>Cost</td>
<td>Cost</td>
</tr>
<tr>
<td>Level2</td>
<td>Level1</td>
<td>Equipment Expenses</td>
<td>$3,766.49</td>
<td>$1,727.42</td>
<td>$5,883.10</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Operating Expenses</td>
<td>$16,758.40</td>
<td>$7,761.18</td>
<td>$25,603.87</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wages</td>
<td>$119,536.00</td>
<td>$54,937.30</td>
<td>$186,752.70</td>
</tr>
<tr>
<td>Level3</td>
<td>Level2</td>
<td>Equipment Expenses</td>
<td>$3,735.69</td>
<td>$1,902.33</td>
<td>$4,906.12</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Operating Expenses</td>
<td>$26,827.92</td>
<td>$12,373.87</td>
<td>$43,209.07</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Wages</td>
<td>$134,272.35</td>
<td>$65,842.35</td>
<td>$230,171.88</td>
</tr>
</tbody>
</table>

A very useful navigational aid is the ability to isolate portions of a table.

5. Right-click the Commercial Pick-up column under 2nd Day Guaranteed, and then select Isolate Commercial Pick-up from the pop-up menu.

The resulting table allows you to focus your attention on the Commercial-Pickup channel.
Displaying Dimension Attributes

In addition to displaying dimensions in the rows and columns of an OLAP view, you can display dimension attributes.

Select the Fixed_Variable dimension attribute

1. Select **Src_Fixed_Variable** from the Data Dimensions window and click the add arrow to add to **Row**.

Notice that the dimension attribute, Fixed_Variable, appears in the Data Dimension window along with other cube dimensions.
2. Right-click the row header, **Level1**, and then select **Remove Src_General_Ledger** from the pop-up menu.

This step is not necessary, but we are doing it so as to isolate the Fixed_Variable attribute.

Your OLAP view should now look like the following. Notice that costs are broken down into fixed costs and variable costs (and those that are neither fixed nor variable). Dimension attributes can serve the same purpose as full-fledged dimensions.
Summary: Rows and Columns

The following picture shows for each type of cube the elements that are available in the OLAP Analyser for adding to rows or columns.
Saving OLAP Views

During the analysis, changes that you make to the Grid View, Chart View, and Cube Explorer View are retained during a session, even when you return to the OLAP page after viewing other tabs. However, when you close the session or when you close Grid View, Chart View, or Cube Explorer View, your changes are lost.

To save these changes so that they will be available later, you must save the OLAP view. When you save an OLAP view, you save the layout and contents of the view. However, the window positions and states are not saved.

**Save an OLAP view**

1. Select **Analysis ➤ Save View As**.
   You see the Save OLAP View As dialog box.

2. For **Name**, type **Parcel Express Tutorial – Resource Contributions**. Click **OK**.
3. On the toolbar, click the **Go to Analysis Workspace** icon.
   You see a link to **Parcel Express Tutorial Resource Contributions** in the OLAP Views list.

Using Measures in Cubes

A measure is a property or an attribute that you can use to analyze OLAP information. The default measure is Cost. Now, you will create a new OLAP view using different measures. You will also create a custom measure.

**Working with measures in OLAP**

1. Select **File ➤ New ➤ OLAP View** (or click **New OLAP View**).
2. Select the **Parcel Express Tutorial** model.
3. Select the **Resource Contributions** cube.

4. Click **Finish**.

   The resource contributions cube for the Parcel Express Tutorial model opens.

5. From the Data Dimensions window, add the following Measures to Columns:
   - Cost
   - Profit
   - Revenue
   - UnitCost
   - UnitProfit
   - UnitRevenue

   **Note:** If there are too many periods displayed in columns of the cube, you can remove AllPeriods from columns and then add back just the period 2008 as shown in the following picture.
6. You see that the **2nd Day Guaranteed** product is losing money, while the other two products are profitable.

<table>
<thead>
<tr>
<th>Year</th>
<th>Measures</th>
<th>Cost</th>
<th>Profit</th>
<th>Revenue</th>
<th>UnitCost</th>
<th>UnitProfit</th>
<th>UnitRevenue</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>All</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>None</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2008</td>
<td>2nd Day Guaranteed</td>
<td>953,250.96</td>
<td><strong>-73,424.96</strong></td>
<td>879,626.00</td>
<td>10.67</td>
<td>-0.82</td>
<td>9.85</td>
</tr>
<tr>
<td></td>
<td>Overnight Express</td>
<td>870,154.28</td>
<td>539,779.72</td>
<td>1,809,944.00</td>
<td>8.52</td>
<td>5.33</td>
<td>14.95</td>
</tr>
<tr>
<td></td>
<td>Standard Ground</td>
<td>2,032,877.95</td>
<td>133,372.65</td>
<td>2,226,250.00</td>
<td>10.51</td>
<td>1.00</td>
<td>11.51</td>
</tr>
</tbody>
</table>

7. Let's highlight the unprofitable product.
   a. Click the **Conditional Highlights** button.
   b. Click **Add**.

   The Add Conditional Highlight window opens.
   
   c. Select **Profit** as the item to be highlighted.
   d. Select **By range**.
   e. Select **Is less than**.
   f. Select 0.00.
g. Click the **Highlight** tab.

h. Select white as the text color.

i. Select red as the background color, and click **OK**.

The display now appears as follows. Notice that the negative profit is displayed with a red background.

<table>
<thead>
<tr>
<th>Measur</th>
<th>2008</th>
</tr>
</thead>
<tbody>
<tr>
<td>Level</td>
<td></td>
</tr>
<tr>
<td>All</td>
<td></td>
</tr>
<tr>
<td>None</td>
<td></td>
</tr>
<tr>
<td>2nd Day Guaranteed</td>
<td>353,250.96</td>
</tr>
<tr>
<td>Overnight Express</td>
<td>970,164.28</td>
</tr>
<tr>
<td>Standard Ground</td>
<td>2,023,877.90</td>
</tr>
</tbody>
</table>

8. Click the **Data Dimensions** button to return to the Data Dimensions tab.

9. Add **Dst_Channel** to **Row**.

This will enable you to see whether this trend is similar across all channels. One of management's goals was to make a profit of at least 10% on the 2nd Day Guaranteed product, and at least 25% on all other products. SAS Activity-Based Management has shown that the company's profit picture is not what management expected. Competitive pressures forced the company to lower the price of their 2nd Day Guaranteed product, but it did not know that it was losing money on all products but the Walk In product.
Now, you will create a custom measure to calculate gross margin.

**Create a custom measure**

1. Click the Customized Items and Sets button.

2. Click New ➔ Calculated Measure.

You see Step 1 of the Create New Calculated Member.

3. For Name, type GrossMargin, and then click Next.

Leave Basic Analysis selected.
4. Select **Ratio** and **Profit / Revenue**, and then click **Next**.

5. Select **Percent** for the **Format**, and then click **Next**.

   ![Screenshot of Calculated Measure](image)

   *Note:* The option **Publicly, to all users at all times** is available only for cubes in SAS OLAP Server. The option is not available for cubes in Microsoft Analysis Services.

6. Review the summary, and then click **Finish**.

   You see the profit margin of each product. Based on the stated goals of the company, the 2nd Day Guaranteed is underperforming significantly.
If you look at the Data Dimensions window, you can see that **GrossMargin** has been added to the list of available measures.

---

### Exporting Cubes

At any point during OLAP analysis, you can export the displayed data to a Microsoft Excel spreadsheet. When you export to Microsoft Excel, you are exporting only the data that is currently displayed, not the entire cube.

**Export an OLAP cube**

1. Display the OLAP data that you want to export to a Microsoft Excel spreadsheet.
2. Select Analysis ➔ Export to Excel.

You see a Microsoft Excel spreadsheet that contains the data that is currently displayed in the cube.
Using the Cube Explorer View

Now, you will analyze the model by using the Cube Explorer View to get more information about the costs that are associated with each product. The management of Parcel Express has learned that margins on the 2nd Day Guaranteed product fall well below expectations. The SAS Activity-Based Management OLAP tool will help management assess why costs for that product are higher than costs for other products.

You will create a multi-stage contributions cube view and use the Cube Explorer View to explore costs.

Create a multi-stage contributions cube view
1. Select File ⇒ New ⇒ OLAP View (or click New OLAP View).
2. Select the Parcel Express Tutorial model.
3. Select the Multi Stage Contributions cube.
4. Click Finish.

The multi-stage contributions cube for the Parcel Express Tutorial model opens.

Create a new Cube Explorer View
1. Select New View ⇒ Explorer.
2. Click Cost_Object_Products_and_Services ⇒ All ⇒ 2nd Day Guaranteed, and then click Next. You will open the Cube Explorer View at the 2nd Day Guaranteed product because that is the product whose costs you want to explore.
3. Select **Cost** and **UnitCost** as the measures to analyze, and then click **Finish** (we will skip the third step of applying filters).

*Note:* The following image has been doctored to show **Cost** and **UnitCost** together.

The Cube Explorer View opens at the 2nd Day Guaranteed product.

**Measures:** **Cost, UnitCost**

Analyse the model in Cube Explorer View
1. Right-click **2nd Day Guaranteed** and select **Change To** ⇒ **Cost_Object_Region** ⇒ **Level3**.

You see the regional costs that contribute to the 2nd Day Guaranteed product.

2. Because Eugene accounts for the larger part of costs (54.82%) of the 2nd Day Guaranteed product costs, drill down into Eugene to discover where those costs come from. Right-click Eugene and select **Change To** ⇒ **Cost_Object_Channel** ⇒ **Level1**.

You see that the **Walk In** channel contributes 52% to the costs of the 2nd Day Guaranteed product. Drill down into this channel to explore what accounts for its costs.

3. Right-click **Walk In** and select **Change To** ⇒ **Activity_Activities** ⇒ **Level2**.
The **Land Distribution** set of activities stands out as constituting 47.90% of costs.

*Note:* If the Land Distribution node is covered, you can use the mouse to slide the covering nodes away.

4. Right-click **LandDistribution** and select **Change To ⇒ Resource_General_Ledger ⇒ Level1**.
Now you can see that the overwhelming part of this cost is for wages in Eugene a full 86%.

5. To confirm the finding that it is wages in Eugene that account for the high cost of the 2nd Day Guaranteed product, drill down on Beaverton for a comparison.
   a. Right-click Beaverton and select **Change To** ⇒ **Cost_Object_Channel** ⇒ **Level1**.
   b. Right-click Walk In and select **Change To** ⇒ **Activity_Activities** ⇒ **Level2**.
   c. Right-click Land Distribution and select **Change To** ⇒ **Resource_General_Ledger** ⇒ **Level1**.
Even though Wages account for a similar percentage of costs for the 2nd Day Guaranteed product in Beaverton, UnitCost for Beaverton is a fraction of UnitCost for Eugene, and the total cost in Beaverton is half of the total cost in Eugene.

If you could put the two branches of the tree together, the picture would look like the following. The unit cost of wages in Eugene for land distribution ($7.00) is much higher than the unit cost of wages in Beaverton ($1.90). These costs play an important role in accounting for the total costs of the 2nd Day Guaranteed product.

Note: You cannot actually put these branches side-by-side in the Cube Explorer View.
Chapter 17 • Using the SAS OLAP Analyzer
Chapter 18
Handling Null-Intersections

Introduction

To create an account (an intersection of dimensions), you must specify a dimension member from each dimension in a module. The following error message appears if you omit selecting a dimension member from a particular dimension.

However, you can omit specifying a dimension member from a particular dimension by selecting instead the “No” dimension member that the system automatically generates for each dimension. The “No” dimension member signifies that there is no value for that dimension. For example, in the cost object module of the Parcel Express Tutorial, you created, for each product, an account in which the product is not associated with any particular channel. And, for each channel, you similarly created an account in which the channel is not associated with any particular product. The following display shows these accounts. You can see, for example, that the Drop Box x No <Products and Services> account has associated costs of $15,468.14. These are costs that are associated with the Drop Box channel and not associated with any particular product.
You should also notice, as shown below, that the Drop Box x No <Products and Services> account is grouped with ordinary accounts in which the Drop Box channel is associated with a particular product.

This mixing of accounts has the somewhat unintuitive results that the total for the Drop Box roll-up account, $283,937.13, does not include the costs that are associated with the Drop Box x No <Products and Services> account.

The reason for not including the full cost is that doing so would result in double counting. As shown below, the cost of the No <Products and Services> account is already spread to the individual Region x Channel x Product accounts. Rolling up the full cost would result in double counting.
This chapter describes an alternative method for organizing null intersection accounts that avoids this counterintuitive result and has an even more significant advantages that are described later.

### Alternative Method

The alternative method entails the following steps for the module that contains accounts with null intersections. In the Parcel Express Tutorial, it is the cost object module that contains null-intersection accounts.

#### Create an additional dimension and its dimension members

1. Create an additional dimension. Name this dimension Cost Object Type.

2. Inside the Cost Object Type dimension, create a dimension member for each dimension for which you want a null intersection.

   For the Parcel Express Tutorial, that means creating the following dimension members:
   
   - A dimension member for channels that are not associated with any product. Name this dimension member Region_Channel because it is to contain accounts that are the intersection of Region x Channel x No <Products and Services>.
   
   - A dimension member for products that are not associated with any channel. Name this dimension member Region_Product because it is to contain accounts that are the intersection of Region x Product x No <Channel>.

3. Inside the Cost Object Type dimension, create a dimension member to contain accounts that do not contain any null intersections.

   Name this dimension member Sales. It contains accounts that are the intersection of Region x Channel x Products and Services. These accounts represent the last stop in the model. When the final product is sold, you know the exact Product x Channel x Region intersection. All costs, even indirect product costs, are assigned to a final intersection of all dimensions.

The following display contrasts the original dimensions in the Parcel Express Tutorial with the alternative method being described in this chapter that entails an additional dimension and its dimension members.
Create accounts using the new dimension members

Create the following accounts for Beaverton and Eugene:

<table>
<thead>
<tr>
<th>Dimension Member</th>
<th>Accounts</th>
</tr>
</thead>
<tbody>
<tr>
<td>Region_Channel</td>
<td>Commercial Pick-up x No &lt;Products and Services&gt;</td>
</tr>
<tr>
<td></td>
<td>Drop Box x No &lt;Products and Services&gt;</td>
</tr>
<tr>
<td></td>
<td>Walk In x No &lt;Products and Services&gt;</td>
</tr>
<tr>
<td>Region_Product</td>
<td>No &lt;Channel&gt; x 2nd Day Guaranteed</td>
</tr>
<tr>
<td></td>
<td>No &lt;Channel&gt; x Overnight Express</td>
</tr>
<tr>
<td></td>
<td>No &lt;Channel&gt; x Standard Ground</td>
</tr>
<tr>
<td>Dimension Member</td>
<td>Accounts</td>
</tr>
<tr>
<td>------------------</td>
<td>----------</td>
</tr>
<tr>
<td>Sales</td>
<td>Commercial Pick-up x 2nd Day Guaranteed</td>
</tr>
<tr>
<td></td>
<td>Commercial Pick-up x Overnight Express</td>
</tr>
<tr>
<td></td>
<td>Commercial Pick-up x Standard Ground</td>
</tr>
<tr>
<td></td>
<td>Drop Box x 2nd Day Guaranteed</td>
</tr>
<tr>
<td></td>
<td>Drop Box x Overnight Express</td>
</tr>
<tr>
<td></td>
<td>Drop Box x Standard Ground</td>
</tr>
<tr>
<td></td>
<td>Walk In x 2nd Day Guaranteed</td>
</tr>
<tr>
<td></td>
<td>Walk In x Overnight Express</td>
</tr>
<tr>
<td></td>
<td>Walk In x Standard Ground</td>
</tr>
</tbody>
</table>

The following display shows the accounts to be created in the cost object module under Beaverton compared to the original accounts in the Parcel Express Tutorial. The same accounts are created under Eugene.

### Original Cost Object Hierarchy

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>COST OBJECT (PRIMARY PANE)</td>
<td>$3,855,293.20</td>
</tr>
<tr>
<td>USA</td>
<td>$3,855,293.20</td>
</tr>
<tr>
<td>Oregon</td>
<td>$3,855,293.20</td>
</tr>
<tr>
<td>beaverton</td>
<td>$2,127,721.43</td>
</tr>
<tr>
<td>- Drop Box</td>
<td>$283,537.13</td>
</tr>
<tr>
<td>- Standard Ground</td>
<td>$103,192.03</td>
</tr>
<tr>
<td>- 2nd Day Guaranteed</td>
<td>$65,439.43</td>
</tr>
<tr>
<td>- Overnight Express</td>
<td>$38,515.67</td>
</tr>
<tr>
<td>- No &lt;Products and Services&gt;</td>
<td>$15,468.14</td>
</tr>
<tr>
<td>- Commercial Pick-up</td>
<td>$652,520.38</td>
</tr>
<tr>
<td>- Standard Ground</td>
<td>$383,494.36</td>
</tr>
<tr>
<td>- No &lt;Products and Services&gt;</td>
<td>$25,780.24</td>
</tr>
<tr>
<td>- 2nd Day Guaranteed</td>
<td>$142,941.52</td>
</tr>
<tr>
<td>- Overnight Express</td>
<td>$228,329.11</td>
</tr>
<tr>
<td>- No &lt;Channel&gt;</td>
<td>$1,998,820.25</td>
</tr>
<tr>
<td>- 2nd Day Guaranteed</td>
<td>$401,573.75</td>
</tr>
<tr>
<td>- Overnight Express</td>
<td>$654,408.05</td>
</tr>
<tr>
<td>- Standard Ground</td>
<td>$1,033,888.46</td>
</tr>
<tr>
<td>- Walk In</td>
<td>$1,191,263.92</td>
</tr>
<tr>
<td>- 2nd Day Guaranteed</td>
<td>$222,273.37</td>
</tr>
<tr>
<td>- Overnight Express</td>
<td>$335,770.10</td>
</tr>
<tr>
<td>- Standard Ground</td>
<td>$632,770.10</td>
</tr>
<tr>
<td>- No &lt;Products and Services&gt;</td>
<td>$87,652.80</td>
</tr>
<tr>
<td>- Eugene</td>
<td>$1,728,571.77</td>
</tr>
</tbody>
</table>

### Alternative Cost Object Hierarchy

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>COST OBJECT (PRIMARY PANE)</td>
<td>$3,855,293.20</td>
</tr>
<tr>
<td>Region_Channel</td>
<td>$250,855.68</td>
</tr>
<tr>
<td>USA</td>
<td>$250,855.68</td>
</tr>
<tr>
<td>Oregon</td>
<td>$250,855.68</td>
</tr>
<tr>
<td>- Eugene</td>
<td>$125,928.30</td>
</tr>
<tr>
<td>- beaverton</td>
<td>$125,901.10</td>
</tr>
<tr>
<td>- Commercial Pick-up</td>
<td>$256,780.29</td>
</tr>
<tr>
<td>- Drop Box</td>
<td>$15,468.14</td>
</tr>
<tr>
<td>- No &lt;Products and Services&gt;</td>
<td>$87,652.80</td>
</tr>
<tr>
<td>- 2nd Day Guaranteed</td>
<td>$198,820.58</td>
</tr>
<tr>
<td>- Overnight Express</td>
<td>$564,108.06</td>
</tr>
<tr>
<td>- Standard Ground</td>
<td>$1,032,888.45</td>
</tr>
<tr>
<td>- Walk In</td>
<td>$585,293.20</td>
</tr>
<tr>
<td>- Sales</td>
<td>$585,293.20</td>
</tr>
<tr>
<td>- Oregon</td>
<td>$2,127,721.43</td>
</tr>
<tr>
<td>- beaverton</td>
<td>$263,937.13</td>
</tr>
<tr>
<td>- Commercial Pick-up</td>
<td>$652,520.36</td>
</tr>
<tr>
<td>- 2nd Day Guaranteed</td>
<td>$142,941.92</td>
</tr>
<tr>
<td>- Overnight Express</td>
<td>$335,770.10</td>
</tr>
<tr>
<td>- Standard Ground</td>
<td>$1,033,888.46</td>
</tr>
<tr>
<td>- Walk In</td>
<td>$1,191,263.39</td>
</tr>
<tr>
<td>- Eugene</td>
<td>$1,728,571.77</td>
</tr>
</tbody>
</table>
Advantages of Using the Alternative

Recall that mixing null intersection accounts with ordinary accounts has the somewhat counterintuitive effect that the cost in a roll-up account does not include the cost of null-intersection accounts.

Another aspect of this same phenomenon is the fact that mixing accounts results in the non-display of totals for null-intersection accounts. For example, in the top part of the following picture, you can see that in both the original cost object hierarchy and in the alternative cost object hierarchy, the total is displayed for products that are not associated with any channel ($1,998,820.25). However, in the bottom part of the display, you can see that in the original cost object hierarchy, there is no total that is displayed for the cost of channels that are not associated with any product. By contrast, in the alternative cost object hierarchy, in which null-intersection accounts are grouped together, you can easily see that the total cost for channels not associated with any product is $128,901.18. Thus, it is easier to trace costs that are associated with a null intersection for a specific dimension.
An even more significant advantage is that the cost flow from non-intersection accounts to other accounts is more clearly visible. For example, in the following display you can see how the cost of the Beaverton Walk In channel unrelated to any product ($87,652.80) contributes to the total cost of the Walk In channel. You can also see that product costs that are not related to any channel are also passed on to the Walk In channel. However, as you might expect, not all these costs can be attributed to the Walk In channel.
For example, to see where the $401,573.75 of costs go for the No <Channel> x 2nd Day Express account, expand the roll-up accounts for Commercial Pick-up x 2nd Day Guaranteed and Drop Box x 2nd Day Guaranteed. As you can see, the costs are distributed as follows:

<table>
<thead>
<tr>
<th>Source and Target Accounts</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Source</strong>: Region_Product x Beaverton x No &lt;Channel&gt; x 2nd Day Guaranteed</td>
<td>$136,496.86</td>
</tr>
<tr>
<td><strong>Target</strong>: Sales x Beaverton x Commercial Pick-up x 2nd Day Guaranteed</td>
<td></td>
</tr>
<tr>
<td><strong>Source</strong>: Region_Product x Beaverton x No &lt;Channel&gt; x 2nd Day Guaranteed</td>
<td>$61,423.59</td>
</tr>
<tr>
<td><strong>Target</strong>: Sales x Beaverton x Drop Box x 2nd Day Guaranteed</td>
<td></td>
</tr>
<tr>
<td><strong>Source</strong>: Region_Product x Beaverton x No &lt;Channel&gt; x 2nd Day Guaranteed</td>
<td>$203,653.31</td>
</tr>
<tr>
<td><strong>Target</strong>: Sales x Beaverton x Walk In x 2nd Day Guaranteed</td>
<td></td>
</tr>
<tr>
<td><strong>Total Cost</strong></td>
<td>$401,573.75</td>
</tr>
</tbody>
</table>

The following display shows the cost flows to the different Beaverton 2nd Day Guaranteed accounts for each of the channels.
To see in more detail where the product costs that are not associated with a particular channel flow, you can do the following:

1. Display the **Right Assignments Pane**.

2. Select the null-intersection account **No <Channel> x 2nd Day Guaranteed** for Beaverton.

3. Click **Show Right**.

4. In the right assignments pane, display the **Driver Cost (DrvCost)** column.

The resulting display is shown below. You can see that the total for Beaverton x Walk In x 2nd Day Guaranteed ($222,273.37) is the total of Walk In expenses not related to any product ($18,620.06) and 2nd Day Guaranteed expenses not related to any channel ($203,653.31). And, similarly, the total for Beaverton x Walk In ($1,191,263.92) is the total of the following roll-up accounts:

- Beaverton x Walk In x 2nd Day Guaranteed ($222,273.37)
- Beaverton x Walk In x Overnight Express ($336,496.86)
- Beaverton x Walk In x Standard Ground ($632,770.10).
Chapter 18 • Handling Null-Intersections

<table>
<thead>
<tr>
<th>Diagram Description</th>
<th>Table Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>Null-Intersection</td>
<td>Total Error</td>
</tr>
<tr>
<td>Calculation Result</td>
<td>368,630.96</td>
</tr>
<tr>
<td>Error Source</td>
<td>320,963.60</td>
</tr>
<tr>
<td>Channel A</td>
<td>368,630.96</td>
</tr>
<tr>
<td>Channel B</td>
<td>320,963.60</td>
</tr>
</tbody>
</table>

Note: The diagram illustrates the handling of null-intersections in a particular channel. The table shows the calculation of total error and the distribution of error sources between Channel A and Channel B.
Parcel Express Conclusions

Now that you have created a SAS Activity-Based Management model and you have learned the basics of model analysis, you can begin designing and implementing your own models.

Using SAS Activity-Based Management, Parcel Express was able to see how costs flowed out of resource accounts to activities, and from activities to cost objects. In modeling the flow of costs through its business processes, the company learned that the 2nd Day Guaranteed product, which managers had assumed was not performing as well as the other products, was performing far worse than expected, and was actually losing money across all channels.

An OLAP analysis of the model showed that the percentages of costs that flowed from resource and activity accounts to cost object accounts was consistent across all product categories. Therefore, pricing seemed to be the primary reason for the underperformance. Another revelation was the amount of profit that was being made on the other two products.

Management must now decide how much of a loss, if any, is acceptable for the 2nd Day Guaranteed product. How will a price change affect volume? Is the higher profit on other products enough to offset the loss on the 2nd Day Guaranteed product?

To assess the impact of changes to the pricing structure, Parcel Express can use SAS Activity-Based Management to model possible future scenarios.

Additional Features

Many SAS Activity-Based Management features are not covered in this tutorial, or they are only briefly covered. These features include:

- importing data from other information systems
- importing models from databases, XML, or Oros
• exporting models to databases or XML
• sharing models
• managing the ownership and permissions for items
• publishing period/scenario associations
• managing item properties
• selecting currencies and exchange rates
• working with internal units
• creating stage attributes
• variable quantity drivers
• assigned idle cost
• allocated cost
• creating custom report templates
• using the SAS Services API

To build effective and complete models for your organization, you will want to use some of these additional features. Because your models will be much larger than the Parcel Express Tutorial model, you might want to read about model size and performance in the online Help. You can also consult the SAS Activity-Based Management: User's Guide at http://support.sas.com/documentation/onlinedoc/abm/.

What to Do Next

If you felt comfortable using the basic tools and techniques in this tutorial to build the Parcel Express Tutorial model, use them on a simple project of your own.

SAS has a variety of products, including videotapes and training classes, that can help you learn more about activity-based costing, management, and budgeting. In addition, SAS can help you build models for your organization. If you need additional information, contact your on-site SAS support personnel.