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This tutorial is intended to familiarize you with the basic modeling concepts that are
used in SAS Activity-Based Management software. To complete the model-building
process, perform this tutorial from beginning to end, exactly as it is presented.
Note: You can import an already completed model for the Parcel Express Tutorial by
doing the following:
1

Select File > Import > Model Data.

2

Select XML or ZIP File as the type of data you want to import, and click
Next.

3

Browse to the following file:
<install director>\Activity-Based Management
Solution\Client\Samples\Models\Native\ParcelExpressTutorial.xml,
and click Next.

4

Name the tutorial. You can name it anything you want. Click Next, review
your choices, and then click Finish.

The tutorial model is imported. You must calculate the model to view calculated
data.
If you are new to the discipline of activity-based management (ABM), you might
benefit more from this tutorial by first learning about the concept. A number of books
and articles present excellent overviews. Even without this background, you will learn
some basic ABM concepts by completing this tutorial.
Even though you might know ABM, work through this tutorial to become familiar
with SAS Activity-Based Management software—the concepts, terminology, commands,
and dialog boxes.
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Tutorial Conventions
This section discusses the conventions that are used throughout this tutorial.

Fonts
Font

Represents

Bold

Menu > Command

Example
Select File > Save Model As.

User input

Type Parcel Express Tutorial.

User interface elements, such as
menus, dialog boxes, buttons, or list
items

Select Calculate Specific Modules

Procedures
A procedure is a task that includes a set of numbered step-by-step instructions. Some
steps are followed by a comment or an explanation. A section that has the following
convention indicates a procedure:

¾ Begin this tutorial
1 Perform step one.
Explanatory comments and illustrations, which explain and display results of
proper completion of the preceding steps, are included between steps, when
necessary.
2 Perform step two.

Notes and Tips
A note indicates additional information. This is the convention for indicating a note:
Note: Text that is set off in this manner presents important information.
The format for a tip is similar.

Illustrations
Depending on your display settings and the number of times that you perform a step
or procedure, the information in the windows might differ slightly from the illustrations
that are presented in this tutorial. If you enter, then delete, and then re-create accounts
and cost elements, the reference number might differ from the illustration. The
displayed order of accounts might differ if you close and reopen the model. Consider the
illustrations to be guides.

Introduction
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Illustrations will usually show only the pertinent portions of the window that are
being discussed.

Terminology
This tutorial refers to both the discipline of activity-based management (ABM), and
the SAS Activity-Based Management solution. References to the discipline appear in
lowercase or by abbreviation. The SAS solution is always capitalized.
The discipline of activity-based management has a set of specialized terms. Some are
used in this tutorial precisely because of their specialized meaning to the theory and
practice of ABM. As these terms are introduced, this tutorial provides brief definitions.
More complete definitions can be found in the CAM-I Glossary of Activity-Based
Management.

Online Help
The online Help is a comprehensive information system that has full-text search
capabilities. It includes:


detailed step-by-step instructions to complete specific tasks



information about features



reference material

Technical Support
If you encounter problems that you cannot solve by reading the online Help or this
tutorial, refer to the Worldwide Technical Support topic in the online Help.

Additional Training and Tutorials
Additional training and tutorials can be found at the SAS Web site and the companion
Web site, http://www.bettermanagement.com. BetterManagement.com offers in-depth
content about selected management concepts that are aimed at improving an
organization’s performance. The BetterManagement.com site is a comprehensive source
for performance management information.
Topics that are covered on the BetterManagement.com site include value-based
management, profitability analysis, strategic enterprise management, activity-based
costing/management, business intelligence, and performance measurement.

4
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Activity-based management is a discipline that enables companies to manage
activities and processes as a means of improving organizational performance and the
value that is received by the customer. By applying direct and indirect business costs to
activities, the SAS Activity-Based Management solution enables managers to get a true
understanding of the costs and profits that are associated with a product, customer,
service, or business process. It supports ongoing profitability analysis, cost-management
initiatives, shared-services management, planning and budgeting efforts, and capacity
optimization.
The basic tool of ABM is activity-based costing (ABC), which more accurately tracks
costs than traditional methods. Two critical limitations of traditional cost accounting
systems are:


the inability to report individual product, service, customer, or process costs with a
reasonable level of accuracy



the inability to provide useful feedback to management for the purpose of
operational control

Often, managers of complex organizations make important decisions about pricing,
product and customer mix, resource allocations, and budgeting that are based on
inaccurate and inappropriate cost and profitability information.
Using SAS Activity-Based Management, you build one or more models that apply
direct and indirect organizational costs to specific activities and processes. As a result,
managers are able to see actual cost assignments and their bottom-line impacts from an
operational perspective. Managers get a true understanding of the cause-and-effect
relationships that link resources and processes to outputs. Thus, business planners can
easily forecast resource requirements, create budgets, and optimize capacity usage.
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The ABC Model and CAM-I Methodology
ABC assumes that activities cause expenditure of resources, and that cost objects—
the results of activities or products and services that are produced—create the demand
for activities.
The Consortium of Advanced Management, International (CAM-I) develops methods
to define critical business issues and to model effective strategies and solutions that
resolve cost and resource management issues. SAS Activity-Based Management uses the
CAM-I methodology for activity-based model development.
COST ASSIGNMENT VIEW*
RESOURCES
Resource
Drivers
Resource Cost
Assignment
PROCESS VIEW
Cost
Drivers

ACTIVITIES

Performanc
e Measures

Activity Cost
Assignment
Activity
Drivers
COST
OBJECTS

The Cost Assignment View
An ABM system enables you to identify the activities that are performed, associate
resources (expenditures) with those activities, and flow the cost of activities to cost
objects. Resource drivers (typically, general ledger entries such as payroll, utilities, or
materials) drive expenditures for activities. Activity drivers (such as the number of parts
or setups) drive activity consumption for cost objects. Types of cost objects are: products,
services, markets, distribution channels, engineering projects, or customers.

The Process View
An ABM system enables you to expose the relationship between why work is done,
and the results of that work. In ABM terms, cost drivers drive the reason for activities
and the effort that is needed to engage in the activities. Performance measures drive the

Activity-Based Management
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achieved results of activities—the efficiency, the required completion time, and the
quality of the activities that were performed.

SAS Activity-Based Management Models
The basic container for ABM information in SAS Activity-Based Management
software is the model. A meaningful ABM model reflects the organization that it is
modeling, and uses terms that are familiar to the people who work there. The structural
elements of a model should be named after elements that are present in the
organizational environment. For example, a company’s general ledger account names,
such as Wages and Depreciation, can be used to name and reference the resource
accounts in the ABM model; the hierarchy of processes in a company can be applied to
the activity accounts in the ABM model.

Modules
A model consists of three basic modules, which reflect the CAM-I definitions:
Resource

contains the expenses (or costs), such as salaries, materials, and
depreciation, for the organization that is being modeled.

Activity

contains activities. Activities have accounts with cost elements.
Costs might be assigned to activities from resource accounts or from
other activity accounts.

Cost Object

contains cost objects (products, services, channels, or customers).
These cost objects are assigned costs from resources, activities, other
cost objects, or any combination of the three.

These modules constitute the main structure of a model. A fourth module, external
units, provides support for external costs. An external unit is an item, such as a part
that is purchased from a supplier, whose cost is maintained outside of a SAS ActivityBased Management model, but which needs to be accounted for in the model. You will
build each of these modules with the use of dimensions.

Dimensions
A dimension is a category by which data is analyzed. For example, it might be useful
to see sales figures when they are broken down by region, by customer, and by product.
Each of these categories (region, customer, and product) represents a single dimension.
Common dimensions are products, time, geography, customers, promotions, and sales
channels.
To break down information into a manageable or useful form, you can group items
within a dimension to create a hierarchical structure. Each member of the hierarchy is
then at a specific level in the hierarchy. You can name a dimension level as needed.
Dimension levels are a powerful modeling tool because they allow you to ask questions
at a high level, and then expand a dimension to reveal more detail.

8
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Types of Dimensions
There are two types of dimensions in a model: structural and attribute.
Structural dimensions are the building blocks of modules. For example, the typical
structural dimensions of the resource module are region, organization, or general ledger;
the activity module might be structured according to the region or organization
dimension, along with an activity dimension.
Dimension attributes provide information that is useful, but not required, to uniquely
identify the model structure. Using dimension attributes, you can classify or organize
information in ways that will help you analyze model results. The SAS Activity-Based
Management OLAP tool makes no distinction between dimension attributes and
structural dimensions.

Basic Steps to Building a Model
The following list of steps summarizes the method that you will use in this tutorial for
setting up and analyzing information in SAS Activity-Based Management models. This
method is described completely in the lessons and exercises in the tutorial.
1

Create a paper plan.
Collect resource (expenditure), activity, and cost object (products and services)
information to design your model. Determine the goal of the model (what kind of
information you want to get from it), and determine the appropriate dimensions,
periods, and scenarios to achieve that goal.

2

Create periods and scenarios.
Create the periods and scenarios to be used by your model. (Periods and scenarios
are shared by all models on a server.)

3

Create dimensions, modules, and accounts.
Create the dimensions and dimension members that you will use to build the
modules. Build the resource, activity, and cost object modules by defining the
accounts (dimension intersections) of each module.

4

Define attributes.
Define and add attributes to the appropriate accounts.

5

Define drivers.
Define drivers that measure the consumption of expenses and activities.

6

Make assignments.
Select the relevant driver for each source account. Make cost assignments from
source accounts to destination accounts.

7

Calculate costs.
Calculate costs and display the results.

Activity-Based Management
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9

Add bills of costs.
Define and link external unit costs to accounts.

9

Enter output, sales, and revenue data.
Enter output quantities, determine unit costs, enter sales volumes, and calculate
profit.

Parcel Express
Parcel Express is a fictitious organization that is using activity-based management to
determine whether this method more clearly conveys costs and profitability information
than traditional costing methods.
A later chapter outlines the main business activities of Parcel Express and the
company’s goals in using SAS Activity-Based Management.
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The SAS Activity-Based Management solution is Web-enabled. Its server typically
resides on your company’s intranet, and the client software resides on your computer.
This tutorial assumes that you have installed the software on your computer, and that
you are familiar with basic software usage techniques, such as using menus, dialog
boxes, and other windows and Web controls.

Logging In
Log in to SAS Activity-Based Management from the Start menu.

¾ Log in to SAS Activity-Based Management
1

Select Start > Programs > SAS > Activity-Based Management 6.x >
Activity-Based Management Solution.
You see the Connect dialog box. The software version number might vary.

12 The Home Page
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2 If your current network login information is not valid for the server, clear the Log
in using my current credentials option.
3 From the Server drop-down list, select a server, or type the server name.
4 If you cleared the Log in using my current credentials option:
a Type your domain and User name.
For example, HQ\JohnD.
b Type your Password.
As you type each character, an asterisk (*) appears in its place.
5 Click OK.
You see the SAS Activity-Based Management home page.

The Home Page
The following window shows the SAS Activity-Based Management home page.

Getting Started

View Models

OLAP

Reports
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Read the online Help (click
) for descriptions of the home page and Workspace
Manager. Any existing models to which you have access rights appear in the Models
folder or its subfolders. You can create shortcuts to your models in the My Shortcuts
folder.

¾ Change to Model mode
1

On the home page, click
You see a model page. If you have just started SAS Activity-Based Management,
you will see the Model home page. If you have been working with a model, you will
see the model page you were working on last.
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Model Home Page
The Model home page lists the models to which you have access rights. From this
page, you can open, create, or delete models.

Model Mode and Module Pages
When you open a model, you usually go to the Resource module page, one page among
many pages that constitute Model mode. If you change to a different mode, such as
OLAP or Reports mode, and then return to Model mode, you go to the model page you
were working on most recently.
You perform all of the tasks that are associated with building a model, entering data,
and calculating costs in Model mode. Many of the tasks rely on the use of dialog boxes
(which enable you to manage specific aspects of the model) and wizards (which guide
you through certain procedures). In many cases, you will enter data directly into a
column on one of the Model mode pages.

Getting Started
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The following window shows the Resource module page of the model that you will be
building in this tutorial.

A module’s structure comes from its dimensions.
The accounts, represented by the layered cube
icons, are intersections of dimensions.

You can close the taskbar to allow more space for the model.

status bar

In this tutorial, you will be directed to use the menus most of the time. Occasionally,
you will be instructed to use a button or an icon. As you become more familiar with the
software, you can choose whichever method you prefer to initiate tasks. Read the online
Help for complete descriptions of toolbar buttons and icons.

Assignments Panes
One of the main objectives of activity-based management is to accurately assess how
company costs are consumed; for example, how costs flow from general ledger accounts
to activities to products and services. SAS Activity-Based Management provides you
with several graphical tools to help you see and manage this flow. Among these tools are
the left and right assignments panes, which allow you to view and assign costs from one
module to another and within a single module.
By default, each module opens in a single-pane view, the primary pane. The primary
pane contains the structure of a module, which includes the dimension intersections
(accounts) and each account’s cost elements. You can open the left assignments pane to
see the accounts from which costs flow (sometimes called source accounts). You can open
the right assignments pane to see the accounts to which costs flow (sometimes called
destination accounts).

16 Column Layouts
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The following display shows the Activity module of the model that you will be building
in this tutorial. All three panes are open.

Left assignments pane

Primary

Right assignments pane

In this display, the arrows that point from the left assignments pane to the primary
pane indicate costs that are flowing into the Beaverton Inspect account in the Activity
module. The arrows that point from the primary pane to the right assignments pane
indicate costs that then flow from the Beaverton Inspect account into other accounts.
In this tutorial, you will use the right assignments pane to assign costs from one
account to another.

Column Layouts
A column layout is a collection of displayed columns, column formats, and the column
order on the module pages. You can customize a column layout to display various
information, such as properties, attributes, periods, and scenarios. When you have
customized it, you can save a column layout by name so that you can retrieve it later.
You see saved column layouts in the Workspace Manager and in the Column Layout list
on the Resource, Activity, Cost Object, and External Units module pages.
When you save a column layout, the following information is saved:


description



column headings



information that is displayed in each column and the period/scenario association
to which it applies



format for each column and order of the columns from left to right



model



column widths

The following information is not saved:


number of assignments panes that appear on the page

Getting Started
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Tip: All column layouts that are saved by all users on the same server are listed in the
Workspace Manager. Therefore, your organization might want to set guidelines for
saving and naming column layouts.

Properties, Attributes, and Dimensions in Column Layouts
The columns of a column layout are derived from the following model elements:
Properties

A property is a model item that holds values that are entered by a
user or calculated by the software. Examples of properties are: Cost,
Unit Cost, Output Quantity, Sold Quantity, and Profit. The more
familiar you become with SAS Activity-Based Management
modeling, the more you will be able to use properties creatively to
achieve your analysis goals.

Attributes

An attribute is a user-defined label or numeric value that is attached
to an account. Each attribute is a particular characteristic that is
used for analysis. An attribute conveys information about the item to
which it is attached.

Dimensions

A dimension is a category by which data will be or is analyzed. You
define the dimensions of your model when you use the New Model
Wizard.

Reports
SAS Activity-Based Management allows you to use predefined report templates or to
create your own reports.

¾ Change to the Reports page
1

From the home page, click
You see the Reports home page.

OLAP Cubes
A cube is the main object in OLAP, a technology that provides fast access to data in a
model. A cube contains a set of data that is constructed from a subset of model data and
that is organized and summarized into a multidimensional structure. SAS ActivityBased Management cubes are standard OLAP cubes.
You use SAS Activity-Based Management software to connect to and interact with the
cubes on a SAS Activity-Based Management server. For each model, you can generate
cubes that you can manipulate on the OLAP page to interactively analyze business data.

18 Contributions
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¾ Change to the OLAP page
1

From the home page, click
You see the OLAP home page.

Contributions
The Contributions page allows you to query a cube on the fly without having to
generate a cube. You can quickly see what input contributed to costs from accounts in
any module to accounts in any other module. The Contributions page provides the
quickest and easiest way to explore the flow of costs throughout a model.

¾ Change to the Contributions page
1

From the home page, click
You see the Contributions page.
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Activity-based management projects begin with a plan. After you have determined the
analysis goals of the model and defined the dimensions that will enable that analysis,
you can begin data collection. Information concerning resources (expenditures),
activities (tasks), and cost objects (products and services produced) provides the basis for
building an ABM model.

Building by Design
Before beginning to build a model, evaluate and make preliminary decisions about the
design of the model. Just as a building contractor needs a plan before beginning to build
a house, a model builder needs a plan for the structure of a model before beginning to
build the model.
Factors that influence a model’s design include the following:


goal of the model—the operational or strategic questions the activity-based
management program is intended to answer



data already collected and its format



data needed that is not being collected



types of reports and OLAP cubes that will be needed

This tutorial uses a simple design and focuses on the steps for building a model. The
design of the model and the effort that it takes can be simple or complex. The model
builder will need to understand these factors, and other factors that are unique to each
modeling situation, to arrive at a design. The model used with this tutorial is named
Parcel Express. The Parcel Express Tutorial case study provides fictitious company
data.

20 The Parcel Express Tutorial Model
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The Parcel Express Tutorial Model
Company Background
Parcel Express began operations in Beaverton, Oregon, in 1990 as a ground parcel
delivery service. In 1995, with 125 employees and $1 million in sales, the company
began expanding to overnight delivery and second-day delivery.
In the first quarter of 2004, total sales revenue was approximately $5.5 million. Costs
for the same period were about $3.8 million, for a profit of about $1.7 million.

ABM Goals
Parcel Express hopes to use SAS Activity-Based Management to trace operating costs
to individual products and services so that the overall costs and profit of each product
and service can be determined and improved. Parcel Express is concerned that the
current accounting system, which divides the business into about 10 product groupings,
might not accurately reflect the different costs of doing business for the two express
services: Overnight Express and 2nd Day Guaranteed.
Management wants to know how each product is performing. The company’s
competitors have dominated in the second-day delivery market, and management has
recently slashed prices on that product. Sales volumes have increased as a result, but
it’s unclear how much profit Parcel Express is making, if any. The company would like
to meet a target profit margin of at least 10% on the 2nd Day Guaranteed product, and
at least 25% on all others. It is willing to adjust pricing or modify processes to reach that
goal.

Model Structure
Parcel Express has assembled a SAS Activity-Based Management modeling team
whose members have become familiar with ABM concepts and the structure of ABM
models. Together, they have determined that the following module structure most
accurately reflects the way Parcel Express conducts its operations.

Resource Module
Resources will be structured by region and general ledger account. The two main
processing plants are Beaverton and Eugene, Oregon. General ledger accounts include:


wages (salary and overtime)



operating expenses and office supplies



equipment depreciation

Creating a Paper Plan
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Activity Module
Activities will be structured by region and activity. The activities Parcel Express has
chosen to model are:


branch collection



sorting and inspection



air and land distribution



resolution of customer complaints

The Eugene facility does not have an air distribution function, so it will have one less
account than Beaverton.

Cost Object Module
Parcel Express needs to be able to track not only the costs of products and services,
but the costs of its channels as well. Therefore, Parcel Express will organize the cost
object module by channel and products and services.
The three channels are:


drop box



walk in



commercial pick up

The three products and services are:


Standard Ground



2nd Day Guaranteed



Overnight Express

External Units Module
Each product has packaging costs that must be accounted for. Materials for packaging
will be tracked as external units, including:


envelopes



flats



boxes

Data Collection
The following data will be collected for entry into the ABM model:
Wages

Wage information, including salaries and overtime, will
come from the general ledger system. Wages will be
entered as dollar amounts, and assigned to activities
according to the number of full-time employees, or FTEs
(Full-Time Equivalents), who are associated with an
activity.

22 The Parcel Express Tutorial Model
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Operating Expenses

Operating expenses and supply costs will come from the
general ledger. These costs will be assigned to activities
in dollar amounts.

Equipment Expenses

Equipment expenses, including depreciation, will come
from the general ledger. These costs will be assigned by
percentage.

Collection and Distribution

Branch managers will collect data from their control
systems regarding the number of packages that are
collected, moved to warehouses, sorted, inspected, and
distributed by land and air. Accurate numbers here are
critical to the success of the modeling effort. Activity
accounts will assign costs by number of packages.

Complaints

The number of customer complaints will be collected by
branch managers. Costs that are associated with
complaint resolution will be assigned according to the
number of complaints that re received.

Revenue

Revenue will come from the sales accounting system.
Revenue will be associated with cost objects according to
the sales quantity for each product.
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A period is an interval of time in which activity-based management data is
maintained. A period can represent any unit of time: a month, a quarter, a year, and so
on. For example, if your organization chooses to enter data each month, the marketing
payroll cost is the amount of payroll for one month. A model can hold data for different
periods, but only one period at a time is active. You can create a hierarchy of periods,
such as FY2008 > Q1 > January. By default, each level is given a name, such as Period
L1.
You can compare model data that you have entered for different periods. For example,
you can enter costs into a model on a month-by-month basis and examine the costs for
March versus the costs for February.
Scenarios are generally used to manage different variations of data within a period. A
scenario can be any set of data: actual, budget, aggressive plan, conservative plan, and
so on. The default scenarios are Actual and Budget. You can create a hierarchy of
scenarios, such as Budget > Aggressive. By default, each level is given a name, such as
Scenario L1. However, these names are not descriptive when you generate cubes. So,
you can rename a default scenario level.

Creating a Period
Parcel Express analyzes costs by quarters, so the model will be structured to analyze
quarter-on-quarter costs. The period that you will create is 2008 Q1.

¾ Create a period
1

Select Tools > Manage Periods.

24 Creating a Period
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You see the Manage Periods dialog box.

2

Select the 2008 period and click New.
Note: These periods might already exist on your server.
You see the New Period dialog box.

3

For Name, replace New Period with 2008 Q1.

4

For Reference, type 08Q1.

5

Select a Start date of January 1, 2008.

6

Select an End date of March 31, 2008.

Creating Periods and Scenarios
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Note: SAS Activity-Based Management enables you to enter descriptions for the
items that you create. In this tutorial, you do not enter descriptions.
7

Click OK.
You see the new period added to the list below the 2008 period.

8

Create three more periods that are named 2008 Q2, 2008 Q3, and 2008 Q4.
Specify appropriate date ranges and references for each period. All period
references must be unique.
When you are done, you should see the following periods in the Manage Periods
dialog box:

9

Click OK.

Creating a Scenario
Parcel Express wants to compare actual costs that it incurred on a quarterly basis. It
will analyze the profit and loss trends in these costs to make decisions about resource
allocation, process control, and pricing. For these purposes, the Actual default scenario
is adequate.
However, so that you gain experience, assume that the company had specific profit
targets that it wanted to model in SAS Activity-Based Management. You could create a
scenario named Target.
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¾ Create a scenario
1 Select Tools > Manage Scenarios.
You see the Manage Scenarios dialog box.

2 Select All Scenarios and click New.
You see the New Scenario dialog box.

3 For Name, replace New Scenario with Target.
4 For Reference, type TARGET.
5 Click OK.
You see the new scenario added to the list below the Actual scenario.
6 Click OK.

Deleting Periods and Scenarios
You can delete a period or scenario from the Manage Periods or Manage Scenarios
dialog boxes, respectively:
1

Select Tools > Manage Periods or Tools > Manage Scenarios.

Creating Periods and Scenarios

2

Select a period or scenario.

3

Click Delete.
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Note: This procedure makes the period or scenario unavailable for any model. If a
period/scenario association is already assigned to a model, then you first need to delete
the association from every such model. To do so:
1

Open the model and select Model > Period and Scenario Associations Page.

2

Right-click a period/scenario association.

3

Select Delete.

28
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Before creating the structure of a module, you must define the dimensions, as
specified in the paper plan, that you will use to build that structure.
The dimensions that you will create for
the tutorial are:

By contrast, the default dimensions
are:

Module

Dimensions

Module

Resource

Region

Resource

General Ledger
Activity

Region
Region

Organization
General Ledger

Activity

Activities
Cost Object

Dimensions

Organization
Activities

Cost Object

Channel

Customer
Products and Services

Products and Services

External Unit

External Unit

Materials

Profit Analysis

Profit Analysis

Region

Materials
Customer
Products and Services

Channel
Products and Services

Creating Dimensions with the New Model Wizard
The main purpose of the New Model Wizard is to establish the dimensions of your
model. These are the dimensions that you will use to create accounts and the structure
of the modules. Most important, these are the dimensions that will eventually enable
you to generate meaningful cubes and to analyze the profits and losses that result from
your business activities.
Now, you will create the model named Parcel Express Tutorial. The model’s monetary
data will be in U.S. dollars.
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¾ Start the New Model Wizard
1 Select File > New > Model.
You see Step 1 of the New Model Wizard.

The New Model Wizard contains nine steps. If you accept the default dimensions
for your model, you will not perform every step. For this tutorial, you will define
your own dimensions and perform every step in the New Model Wizard.
2

For the name, type Parcel Express Tutorial.
Note: Each model name must be unique on a SAS Activity-Based Management
server.

3

Verify that the base currency is US Dollar($).

4

Click Next.
You see Step 2 of the New Model Wizard.

¾ Select a starting period and scenario
1

Expand 2008 and select the 2008 Q1 period.

2

Select the Actual scenario.

Creating Dimensions and Dimension Members

Creating Dimensions with the New Model Wizard 31

A period/scenario association identifies a specific period and scenario combination;
in this case, 2008 Q1/Actual. All model data must reside in a period and must
apply to a scenario. An association represents a period-scenario pair.
3

Click Next.
You see Step 3 of the New Model Wizard.

¾ Select the method for defining dimensions
1

Verify that the Select or define the dimensions for each module option is
selected.
This option enables you to create new dimensions, rearrange dimensions, or use
the default dimensions for some modules, but not others. The dimensions that you
will create for the tutorial are:
Module

Dimensions

Resource

Region
General Ledger

Activity

Region
Activities

Cost Object

Region
Channel
Products and Services

External Unit

Materials

Profit Analysis

Region
Channel
Products and Services

2 Click Next.
You see Step 4 of the New Model Wizard.

¾ Define the resource module dimensions
1 In the Selected dimensions list, select the Organization dimension.
Next, you will remove this dimension from the Selected dimensions list.
2 Click < Remove.
You see the Organization dimension move from the Selected dimensions list to
the Available dimensions list.
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3 Click New.
You see the New Dimension dialog box.

4 For Name, type Region.
5 For Reference, use Region.
6 Click OK.
The New Dimension dialog box closes and you see that the Region dimension has
been added to the Available dimensions list.
7 Select the Region dimension and click Add >.
You see the Region dimension move from the Available dimensions list to the
Selected dimensions list, below the General Ledger dimension. The order of
dimensions in the list determines the hierarchy of dimensions in the module. In
this case, Parcel Express wants to organize its resources by Region, and then by
General Ledger. So, you will have to move Region above General Ledger.
8 Select the Region dimension and click Move Up.

9

Click Next.
You see Step 5 of the New Model Wizard.

Now, you will define the dimensions for the activity module by using these same
techniques. Refer to the previous procedure if you need clarification on a step.

¾ Define the activity module dimensions
1

Move the Organization dimension to the Available dimensions list.

2

Move the Region dimension to the Selected dimensions list.

3

Move Region above Activities.
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The Selected dimensions list should appear as follows:

4

Click Next.
You see Step 6 of the New Model Wizard.

¾ Define the cost object module dimensions
1

Move the Customer dimension to the Available dimensions list.

2

Move the Region dimension to the Selected dimensions list.

3

Move Region above Products and Services.

4

Create a new dimension named Channel that has a reference of Chnnl.

5

Move the Channel dimension to the Selected dimensions list.

6

Move Channel above Products and Services.
The Selected dimensions list should appear as follows:

7

Click Next.
You see Step 7 of the New Model Wizard.

¾ Define the external units module dimensions
1

Verify that Materials is the only dimension in the Selected dimensions list.

2

Click Next.
You see Step 8 of the New Model Wizard.

¾ Define the profit analysis dimensions
1

Move the Region dimension to the Selected dimensions list.

2

Move the Channel dimension to the Selected dimensions list.
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3

Move Region above Products and Services.

4

Move Channel above Products and Services.
The Selected dimensions list should appear as follows:

5

Click Next.
You see Step 9 of the New Model Wizard.

¾ Review the summary and finish the New Model Wizard
1

Review the Summary of Information and dimensions in each module, as shown:
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If any of the information in the summary is incorrect, click Back to move to the
page that requires changes. After making the corrections, click Next to return to
the summary.
2 Click Finish.
You see the Dimensions page that now has the following dimensions:

These dimensions are the basic building blocks that you will use to construct the
modules of your model. First, however, you must create the members of each
dimension.
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Note: The order of the dimensions can vary if the dimension members are changed
or if the model is imported.

Creating Dimension Members
Dimension members are the unique elements of a dimension level. For example, the
Region dimension of the Parcel Express Tutorial model will have levels that include
countries, states, and cities. Beaverton and Eugene are dimension members at the same
level of the Region dimension.

¾ Create dimension members
1

On the Dimensions page, select Region.

2

Select Edit > New Dimension Member.
You see the New Dimension Member dialog box.

3 Click Add.
4 For Name, type USA.
Tip: You see that the Reference field is automatically set to the name that you
type. In this tutorial, you will not change the references of dimensions; however,
for the models that you create for your company, you might want to devise a
standard referencing methodology.
5 Click OK.
You see that the USA dimension member has been added below Region.
6 Select the USA dimension member.
7 Create a new dimension member under USA named Oregon.
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Note that the level is Level2. The reason for this is that you are adding a
dimension member below a Level1 dimension member.
8 Using the techniques that you have learned, create the following dimension
members:

Note: You will not create dimension members for the Materials dimension yet. You
will add those dimension members when you create bills of costs.
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The following picture shows the dimensions that you are defining along with the
hierarchy of dimension members for each module:

39

C H A P T E R

7

Creating Modules and Accounts

Building the Resource Module Structure 39
Building the Activity Module Structure 43
Creating Activity Accounts 43
Building the Cost Object Module Structure 44
Omitting a Dimension from an Account 44
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An account is the basic repository of costs in a model. You create an account in SAS
Activity-Based Management by defining an intersection between dimension members.
For example, in the Parcel Express Tutorial model, you will create an account for
tracking the costs of inspecting packages in Beaverton. You create this account by
defining an intersection between Region and Activity dimension members, as shown
here:
Region > USA > Oregon > Beaverton
x
Activity > Regional Sorting > Inspect
Shorthand for the resulting account, or dimension intersection, is Beaverton x
Inspect.
The costs of an account are derived from cost elements, which can either be added
directly to the account or assigned from other accounts.

Building the Resource Module Structure
Start by creating a structure to hold the resource costs in the model.

¾ Create resource accounts
1

To open the resource module, select Model > Resource Module.

2

Select Edit > New Account.
You see Step 1 of the New Account Wizard.
The Dimensions area contains the dimensions of the resource module. The
Accounts area will contain the accounts that you create.
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3 Expand Region to display all of its dimension members.
4 In the Dimensions list, select the following dimension members:
Beaverton
Eugene
Wages
Operating Expenses
Equipment Expenses
5 Verify that leaf dimension members only is selected in the Create accounts
using field.

6

Click Add.
You see that the following accounts have been added to the Accounts list:

7

Click Next.
You see Step 2 of the New Account Wizard. Here, you will add the cost elements
and costs of each account.
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Tip: The system has automatically generated a unique name and reference for
each account. The names and references that you see will be different from those
shown in the window. These names and references are used in reports and
operational summaries, but they do not appear elsewhere on a page, unless you
add columns to display them. Your company can decide whether to use the systemgenerated names or to use a naming and referencing methodology. If your models
are extremely large, it will probably be more convenient to use system-generated
account names and references.

¾

Add cost elements and costs

1

Select the Beaverton x Wages account and click Add Cost Element twice.
You see that two cost elements have been added to the account table. The names
and references of these cost elements are system-generated. In the account table,
you can add costs and change the names and references of cost elements.

2

Change the names and references of the two cost elements that you added and
enter their costs, as follows:
Name

Reference

Cost

Salaries

BS

1,563,000.00

Overtime

BOT

75,600.00

Note: In large models, costs might be imported from other sources, such as a
database. In that case, you could create the cost elements, but leave the costs
empty.
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Using the techniques that you have learned, create cost elements and enter costs
as follows:
Account

Cost Elements

Cost
Element
Reference

Beaverton x Operating
Expenses

Operating Expenses

BOE

228,000.00

Office Supplies

BOS

10,000.00

Beaverton x Equipment
Expenses

Equipment Depreciation

BED

54,300.00

Eugene x Wages

Salaries

ES

Overtime

EOT

110,000.00

Operating Expenses

EOE

263,000.00

Office Supplies

EOS

8,000.00

Equipment Depreciation

EED

38,000.00

Eugene x Operating Expenses
Eugene x Equipment Expenses

4

Cost

1,298,000.00

Click Next.
You see Step 3 of the New Account Wizard. This step contains a summary of the
accounts, cost elements, and costs you are about to create.

5

Click Finish.
You see that the accounts have been added to the resource module.

The system automatically rolls up costs from cost elements, to accounts, to higherdimension levels.
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Building the Activity Module Structure
An activity is a task that consumes resources. Examples of activities include setting
up a machine to produce a particular part, scheduling production of a certain number of
products, and inspecting a batch of parts. In a model, you identify activities and
calculate their costs.

Creating Activity Accounts
In the activity module, you will create activity accounts.

¾ Create activity accounts
1

To open the activity module, select Model > Activity Module.

2

Select Edit > New Account.
You see the New Account Wizard.

3

Using the New Account Wizard, create the following accounts:
Note: Do not create cost elements. Costs will be assigned to these accounts from
other accounts.
Note: After creating the accounts in Step 1 of the New Account Wizard, click
Finish. Because you are not creating cost elements, there is no need to perform
steps 2 and 3.
Dimension Intersection
Personnel Intensive Activities

Beaverton x Resolve Customer Complaints
Beaverton x Expedite Package Shipments

Local Collection

Beaverton x Move to Warehouse

Local Processing

Beaverton x Sort
Beaverton x Inspect

Regional Distribution

Beaverton x Air Distribution
Beaverton x Land Distribution

Personnel Intensive Activities

Eugene x Resolve Customer Complaints

Local Collection

Eugene x Move to Warehouse

Local Processing

Eugene x Sort

Eugene x Expedite Package Shipments

Eugene x Inspect
Regional Distribution

Eugene x Land Distribution

Note: There is no Air Distribution from Eugene.
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After completing the steps of the New Account Wizard, you see the following activity
module structure:

Note: You have not entered cost elements for these accounts, and no costs have been
assigned yet, so cost is $0.00.

Building the Cost Object Module Structure
The cost object module will hold information about Parcel Express Tutorial’s products
and services. Its dimensions are Channel and Products and Services.

Omitting a Dimension from an Account
You can create accounts that omit one or more dimensions of a module. In the cost
object module of the Parcel Express Tutorial model, you will create accounts that have a
Channel dimension member, but no Products and Services dimension member, and vice
versa. The purpose of these omissions is to track the unique costs of a channel that are
unassociated with any product, and to track the unique costs of a product that are
unassociated with any channel. To omit a dimension from an account, you select the No
option in the New Account Wizard.
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Examples of accounts that omit a dimension are:


Drop Box x No <Products and Services>
(tracks unique costs that are associated with the Drop Box channel)



No <Channel> x 2nd Day Guaranteed
(tracks unique costs that are associated with the 2nd Day Guaranteed product)

Creating Cost Object Accounts

¾ Create cost object accounts
1

Using the techniques that you have learned, create the following accounts in the
cost object module for each regional office—Beaverton and Eugene:
Note: Do not create cost elements. Costs will be assigned to these accounts from
other accounts.
Dimension Intersection
Drop Box x 2nd Day Guaranteed
Drop Box x Overnight Express
Drop Box x Standard Ground
Drop Box x No <Products and Services>
Walk In x 2nd Day Guaranteed
Walk In x Overnight Express
Walk In x Standard Ground
Walk In x No <Products and Services>
Commercial Pick Up x 2nd Day Guaranteed
Commercial Pick Up x Overnight Express
Commercial Pick Up x Standard Ground
Commercial Pick Up x No <Products and Services>
No <Channel> x 2nd Day Guaranteed
No <Channel> x Overnight Express
No <Channel> x Standard Ground
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Note: You can create these accounts all at once by checking the leaf dimension
members that are shown in the following display. This quick method, however,
results in creating two meaningless accounts that you can delete afterward:
Beaverton x No <Channel> x No <Products and Services>
Eugene x No <Channel> x No <Products and Services>
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After you have created these accounts, you see the following cost object module
structure:

48
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An attribute is a label or identification tag that is attached to an account or roll-up
account. The attribute conveys information about the object to which it is attached.
Attributes have many purposes. You can use them to do the following:


group activity-based management data to simplify report preparation and
interpretation



create different dimensions of data



report similar cost categories across cost centers



classify cost components as fixed or variable, value-added or non-value-added



use them in the definition of a calculated driver

Types of Attributes
There are five attribute types:


text



numeric



calculated



dimension



Boolean

Text Attributes
A text attribute describes model information. You can use text attributes to annotate
a model. You can use them to provide information about a model. You will see an
example in this chapter.
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Note: Text attributes cannot be viewed in OLAP.

Numeric Attributes
A numeric attribute enables you to enter data that is not entered or otherwise
generated in a model.
Typically, numeric attributes are measures or quantities of units that contribute to
the total cost of an activity, such as number of cases, number of pounds, number of
orders, or number of times an activity is performed.
You can establish numeric attributes as performance measures for special reporting
purposes, such as tracking productivity (number of inputs or rejects, cycle time, and
quality), or classifying information (level of complexity or number of subassemblies). Use
the Default Value field under the Advanced tab to define data that is specific to that
attribute.

Calculated Numeric Attributes
Numeric attributes can be calculated. Calculated numeric attributes are also userdefined attributes, but they rely on a formula to express their characteristics. This
formula is developed by the user to capture unique business data. Calculated numeric
attributes can be used in a driver definition.

Dimension and Dimension Member Attributes
A dimension attribute reflects a dimension, and a dimension member attribute
reflects a dimension member. Dimension attributes enable you to categorize, select, and
subtotal information in a report. For example, activities can be grouped by summarylevel processes, such as detailed manufacturing activities rolling up to “manufacturing,”
and detailed distribution activities rolling up to “distribution.” The names of these
higher-level processes are defined as dimension member attributes and are attached to
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their respective activities. Most importantly, you can query for dimension member
attributes in OLAP.
Other examples of dimension attributes include:


value-added categories (high, medium, low) that are attached to activities



fixed cost/variable cost that is attached to resources—enables you to group activity
or cost object costs by fixed and variable cost components



cost object groupings that are used to roll up products by product family, brand,
market segment, or package type, or to group customers by region, channel, or
salesperson

Boolean Attributes
A Boolean attribute stores a Boolean value (True or False).
Note: Boolean attributes cannot be viewed in OLAP.

Creating Attributes
You will create a text attribute, a numeric attribute, and a dimension attribute.

¾ Create a text attribute
1

Select Model > Attributes Page.

2

Select Edit > New Attribute.
You see the New Attribute dialog box.

3

For Name, type Manager.
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4

Select an Attribute type of Text.

5

Click OK.
You see that the Manager attribute has been added to the list.

¾ Create a numeric attribute
6

Select Model > Attributes Page.

7

Select Edit > New Attribute.
You see the New Attribute dialog box.

8

For Name, type Number of Inspections.

9

For Reference, type Num of Ins.

10 Select an Attribute type of Numeric.
11 For Unit of Measure, type Inspections.
To summarize:
Name

Reference

Type

Unit of Measure

Number of Inspections

Num of Ins

Numeric

Inspections

12 Click OK.
You see that the Number of Inspections attribute has been added to the list.
13 Create three more numeric attributes.
Name

Reference

Type

Unit of Measure

Inspections Passed

I_P

Numeric

Units Passed

Completed Expedite
Requests

Completed Expedite
Requests

Numeric

Completed Requests

Average Time to
Expedite

Average Time to Expedite

Numeric

Hours

¾ Create a calculated numeric attribute
Name

Reference

Type

Unit of
Measure

Formula

Cost per
Inspection

Cost per
Inspection

Numeric
Calculated

Dollars

Cost / “No. of
Inspections”

1

Select Edit > New Attribute.

2

For Name, type Cost per Inspection.

3

For Reference, type Cost per Inspection.

Creating Attributes

Creating Attributes 53

4

Select an Attribute type of Numeric.

5

Select Dollars for Unit of Measure.

6

Select the Advanced tab.

7

Verify that the period is 2008 Q1 / Actual.

8

Select the Calculated check box. This allows you to enter a formula.

9

Click Equation Editor.
You see the Equation Editor dialog box.

10 The cost of inspection would be derived from a formula of Cost divided by the
Number of Inspections. Create this formula by double-clicking each element.
The formula will appear in the Equation area.
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11 Click Test to verify the syntax of the formula.
12 Click OK to dismiss the message box.
13 Click OK to accept the formula.
14 Click OK to create the attribute.
15 Create a calculated numeric attribute for Percent of Inspections Passed.
Name

Reference

Type

UoM

Formula

Percent of
Inspections Passed

Percent of
Inspections

Numeric
Calculated

Percentage

Inspections
Passed / No. of
Inspections

¾ Create a dimension attribute folder
Name

Reference

Type

Fixed_Variable

FV

Dimension

1

Select Edit > New Attribute.

2

For Name, type Fixed_Variable.

3

For Reference, type FV.

4

Select a Type of Dimension.

5

Click OK.

6

Select the Fixed_Variable attribute.

7

Create the following two dimension attributes:
Name

Reference

Type

Fixed

F

Dimension Member

Variable

V

Dimension Member

You see that the Fixed_Variable dimension and its two-dimension members have
been added to the list of your model’s dimensions.
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Creating a Column Layout
To view the attributes in the model, add a column. For the Parcel Express Tutorial
model, you will create a column layout named Cost Assignments. Initially, you will
define the column layout for the activity module. Later, you will add columns to the
layout for the other modules to create a cost assignment column view.

¾ Add a column to show an attribute
1

Select Model > Activity Module.

2

Select Model > Column Layout > Edit Columns.
You see the Column Layout dialog box.
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Columns in the layout

Module to which the layout applies

Model data that can be displayed in
columns in the layout

Pane to which the layout applies

The columns that you see in the Displayed columns list refer to the layout for a
specific pane in a specific module. In the illustration, you see the column layout for the
Primary pane of the Activity Module. To change the column layout for a different
pane or module, select that pane or module. The Inspections Passed column layout
that you create in this tutorial will ultimately contain layouts for several modules and
panes.
Note: A column layout is a read-only view of columns that already exist in tables in
your model. Adding or removing a column from a column layout does not add or remove
a column from a table; nor, for that matter, does creating a column layout create a table
or add or remove columns from any table.

¾ Define the column layout for one panel.
1

Verify that the Primary pane tab is selected.

2

From the Displayed columns list, select Display Reference.

3

Click Remove.
You see that Display Reference has been removed from the list of Displayed
columns. Removing this column from the layout will provide more screen space
for columns that are relevant to making driver assignments.

4

From the Properties, Attributes, and Dimensions list, select Inspections
Passed (under the Attributes folder).

Creating Attributes

5

Creating a Column Layout 57

Click Add.
You see that Inspections Passed has been added to the Displayed columns
list.

6

Select Manager (under the Attributes folder), and then click Add.
You see that Manager has been added to the Displayed columns list.

¾ Save the column layout
1

Click Save As.
You see the Save Column Layout As dialog box.

2

Verify that the New column layout option is selected, and then type Cost
Assignments.

3

Click OK.
You see that the column layout Name has been changed to Cost Assignments.

4

Click OK.
You see the changes that you made to the column layout. Cost Assignments is
the active column layout, and Inspections Passed and Manager appear in the
column layout list.
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Entering Attribute Values
Now, you will display a column to enter attribute values.

¾ Enter attribute values
1

In the Inspections Passed column for the Beaverton x Inspect account, type
43400.

2

In the Inspections Passed column for the Eugene x Inspect account, type
1100.

3

In the Manager column for the Beaverton x Sort account, type Smith.

4

In the Manager column for the Eugene x Sort account, type Jones.
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Applying Additional Attributes to Accounts
Having created the dimension attribute Fixed_Variable with its two dimension
member attributes, Fixed and Variable, you can apply the dimension member attributes
to accounts.
Note: You can attach attributes to accounts, but not to cost elements or to roll-up
accounts.

¾ Apply one attribute
1

Switch to the Resources page.

2

Right-click the Beaverton x Wages account, and then select Manage Attributes
from the pop-up menu.

The Manage Accounts dialog box opens.
3

From the Manage Accounts dialog box, double-click Fixed_Variable to add it to
the list of the Account’s attributes. (Or, select Fixed_Variable and click Add.)

4

Select Fixed from the drop-down list of dimension member attributes.
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5

Click OK to apply the attribute Fixed to the Wages account.
The attribute is added to the account.

Before adding the Fixed or Variable attribute to additional accounts, let’s add the
Fixed_Variable attribute column to the layout so that we can add the attributes more
easily and better see the results.

¾ Add a Fixed_Variable column to the column layout
1

Right-click (or double-click) the column header, and then select Edit Columns
from the pop-up menu. (Or, select Model > Column Layout > Edit Columns.)
The Column Layout dialog box opens.

2

In the Column Layout dialog box, double-click Fixed_Variable (under the
Attributes folder). (Or, select Fixed_Variable and click Add.)
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Click OK to add the Fixed_Variable column to the column layout.

Now we can more easily apply additional Fixed and Variable attributes to accounts.

¾ Apply additional attributes to accounts
1

Select the Beaverton x Operating Expenses account.

2

From the menu in the Fixed_Variable column, select Variable.
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3

Repeat the process to apply the following dimension member attributes to the
following accounts:
Attribute

Account

Fixed

Eugene x Wages

Variable

Eugene x Operating Expenses

Note that it is not necessary to apply the attribute to all the resource accounts, as
we are not applying it to the Equipment Expenses account.
Later, when we describe “Using OLAP Cubes for Analysis,” we will see that OLAP
analysis allows, in this case, querying fixed-cost contributions versus variable-cost
contributions. Dimension member attributes allow much of the functionality of
real dimensions, without some of the overhead. In fact, they can provide a method
of adding “dimensions” to a model, whereas the model itself cannot have
dimensions added after the initial model definition.
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Drivers for the Model

An important aspect of activity-based management is the understanding of how
activities in an organization consume expenses and how products consume activities.
These consumptions are governed by relevant drivers, which measure the frequency or
intensity of the cost demands that are placed on resources and activities. A driver
specifies how costs are assigned.
This tutorial uses both system-defined and user-defined drivers.
The first step in assigning resource costs to activities and activity costs to cost objects
is building a list of drivers.
The Parcel Express Tutorial model uses several system-defined drivers. Additionally,
you will create the following drivers:
User-Defined Driver

Purpose

FTEs

Tracks the cost of wages from the resource module to the
activity module.

Dollars

Tracks the cost of operating expenses from the resource
module to the activity module.

Number of Customer Complaints

Tracks the number of customer complaints per channel.

Number of Packages

Tracks the number of packages that were collected, sorted,
and distributed.

Number of Expedite Requests

Tracks the packages that are expedited regionally.

¾ Define basic drivers
1

Select Model > Drivers Page.
You see the following list of system-defined drivers:
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Select Edit > New Driver.
You see the New Driver dialog box.

3

For Name, type FTEs.

4

Verify that the Driver type is Basic.

5

Verify that the This driver’s quantities are unique option is checked.

6

Verify that Allow fixed driver quantities for this driver is checked.

7

Click OK.
You see that FTEs has been added to the list of drivers.

8

Add the following Basic type of drivers:
Driver

9

Driver Type

Dollars

Basic

Number of Customer Complaints

Basic

Number of Packages

Basic

Select the following options for the Number of Packages driver:

The Number of Expedite Requests is a calculated driver. Calculated drivers expand
system capability, enabling you to define cost drivers that are unique to your business.
You define these calculated drivers with formulas that you create using the systemgenerated numeric properties and attributes that you have defined for your unique
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usage. The calculated driver in this tutorial will use attributes that you have just
created and numeric properties generated by the system.

¾ Defining a calculated driver
Driver

Formula

Number of Expedite
Requests

[“Average Time to Expedite” * “Completed Expedite
Requests”] / DriverQuantityFixed

1

Add Number of Expedite Requests as a calculated driver. For Driver type,
select Calculated.

2

Verify that the This driver’s quantities are unique option is checked.

3

Verify that Allow fixed driver quantities for this driver is checked.
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Click Equation Editor.
You see the Equation Editor dialog box.
Note: In the following instructions, you can “choose” an element of the equation
either by double-clicking the element, or by selecting it and clicking Insert.

5

Choose ( from the Operators list.

6

Chose Average Time to Expedite from the Attributes list.

7

Choose * from the Operators list.

8

Choose Completed Expedite Requests as the multiplier from the Attributes
list.

9

Choose ) to close the set.

10 Choose / from the Operators list.
11 Choose DriverQuantityFixed from the Numeric properties list.
DriverQuantityFixed is the user-entered fixed quantity that flows from one
account to another. You can change this value only on assigned cost elements with
a driver that allows fixed driver quantities.
12 Click Test to verify the syntax of the formula.
13 Click OK to accept the formula.
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14 Click OK to create the driver.

Review the list of drivers.
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An assignment links source accounts to destination accounts. Costs flow along this
path from resources to activities to cost objects—from expenses to activities to products,
services, or customers. A source account is the source of a cost assignment. A destination
account receives the results of a cost assignment.

As previously shown, the possible assignments between accounts, as indicated by
letters, are:
A

resource to resource

B

resource to cost object

C

resource to activity

D

activity to activity

E

activity to cost object

F

cost object to cost object
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Using a Column Layout
In a previous section, you created a column layout named Cost Assignments for the
activity module. In the following sections, you will add columns to the layout for the
other modules.
While building the model structure, you have been working in the single pane view.
To make assignments, you need to open an assignments pane. When the primary pane
and an assignments pane are open, you can see source accounts, destination accounts,
assignments, driver names, and driver quantities. To assign resource costs to activity
accounts, you will open the right assignments pane.

¾ Open the right assignments pane and Column Layout dialog box
1

Select Model > Resource Module.

2

If it is not already open, open the Cost Assignments saved column layout.

3

In the resource module, select Model > Assignments > Show Right
Assignments Pane.
You see the right assignments pane (to the right of the resource module primary
pane). The default columns are IntsctnName, Reference, and Cost.
Tip: You might want to hide the taskbar on the left side of the window to display
more data. To do this, click the X in the upper-right corner of the taskbar. You can
make columns wider or narrower by clicking on the line between two column
headings and dragging the edge of the column to the width that you want.

4

Select Model > Column Layout > Edit Columns.
The columns that you see in the Displayed columns list refer to the layout for a
specific pane in a specific module. Because you are currently viewing the resource
module, you see the column layout for the primary pane of the resource module. To
change the column layout for a different pane or module, select that pane or
module. The Cost Assignments column layout that you create in this tutorial will
ultimately contain layouts for several modules and panes.
Resource Module

Primary pane

¾ Define the column layout for two panes
1

Verify that the Primary pane tab is selected.

2

From the Displayed columns list, select Display Reference.
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Click Remove.
You see that Display Reference has been removed from the list of Displayed
columns. Removing this column from the layout will provide more space for
columns that are relevant to making driver assignments. Remember that
removing a column from a column layout does not remove it from any table in the
model; it simply changes your view of the model.

4

In Drivers, select Driver Name (DrvName).
Tip: To find Driver Name (DrvName), scroll down to Driver and expand it.

5

Click Add.
You see that Driver Name (DrvName) has been added to the Displayed
columns list.

6

Click the Right pane tab.
You see the default columns of the right pane in the Displayed columns list.

7

Remove the Reference column from the Displayed columns list.

8

Add the Driver Quantity Fixed (DQF) property to the Displayed columns list.

¾ Save the column layout
1

Click Save.

2

Click OK to dismiss the Column Layout dialog box.
You see the changes that you made to the Cost Assignments column layout appear
in the Column Layout list.

Making Assignments from Resources to Activities
The first assignments that you make will be inter-modular; that is, assignments from
the resource module to the activity module.

¾ Add accounts for assignments
1

Select Model > Assignments > Add Accounts in Right Pane.
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You see the Add Accounts for Assignments dialog box.

2

Verify that the Activity module is selected.

3

Expand Activity so that you can see the Beaverton and Eugene roll-up
accounts.

4

Select the Beaverton roll-up account, and then click Add Accounts.
You see that the Beaverton activity accounts have been added to the right pane.

5

Add the Eugene activity accounts to the right pane.

6

Click Close.
Note: To avoid mixing up assignments between Beaverton resources and Eugene
accounts (and vice versa), consider adding only the Beaverton accounts first to the
right pane. Next, make the assignments. Then, do the same for Eugene.
Note: Clearing accounts from the right pane does not delete assignments from your
model. It removes the accounts from view temporarily.

Now that the intended destination accounts are displayed, you can make assignments
from resource accounts to activity accounts.

¾ Make assignments
1

In the primary pane, expand Resource to display all of its accounts.
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Tip: Select View > Expand to display subfolders. In this tutorial, you do not need
to expand the module hierarchies to display the cost elements of each account. If
the cost elements are displayed, collapse the hierarchy to hide them.

2

Select the Wages account under Beaverton.
You see that arrows appear next to each account in the right pane. These arrows
indicate that you can make assignments from Beaverton Wages to any of the listed
accounts. Logically, the cost of wages in Beaverton would be assigned only to
Beaverton activities, not Eugene activities.

3

In the Wages row under Beaverton click on the cell in the DrvName column.
You see a list of available drivers, including system-defined and user-defined
drivers.

4

Select FTEs.

5

Make assignments to all of the Beaverton accounts in the right pane by clicking
the arrow next to each account.
Note: You can use the hotkey F7 to create assignments between the selected
account and all of the accounts in the other assignment pane.
You see that a line now connects Beaverton Wages to each of the arrows that you
clicked.

6

Type the following values in the DQF column in the right pane (the order of
accounts might be different from the order that is shown; be careful to assign
values to the correct accounts):
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DQF column

Note: The total cost of Beaverton Wages ($1,638,600.00) will be consumed by these
seven activity accounts according to the number of FTEs that you have entered.
SAS Activity-Based Management performs the math for you when you calculate
costs in a later lesson.

¾ Make other assignments
Note: Remember that when making assignments, you must first select a driver
before you can select a destination account and assign a numeric value to the
account.
1

In the primary pane, select Operating Expenses for Beaverton and make the
following assignments:
Resource Account

Driver

Activity Account

DQF

Beaverton x Operating
Expenses

Dollars

Beaverton x Resolve Customer
Complaints

6,500.00

Beaverton x Expedite Package
Shipments

8,000.00

Beaverton x Move to Warehouse

15,000.00

Beaverton x Sort

23,000.00

Beaverton x Inspect

54,000.00

Beaverton x Air Distribution

83,000.00

Beaverton x Land Distribution

56,500.00
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In the primary pane, select Equipment Expenses for Beaverton and make the
following assignments:
Resource Account

Driver

Activity Account

DQF

Beaverton x
Equipment Expenses

Percentage

Beaverton x Resolve Customer
Complaints

5

Beaverton x Expedite Package
Shipments

3

Beaverton x Move to Warehouse

7

Beaverton x Sort

20

Beaverton x Inspect

25

Beaverton x Air Distribution

25

Beaverton x Land Distribution

15

Note: The total equals 100 because 100% of equipment expenses are used by
Parcel Express.

3

4

In the primary pane, select Wages for Eugene and make the following
assignments:
Resource Account

Driver

Activity Account

DQF

Eugene x Wages

FTEs

Eugene x Resolve Customer
Complaints

2

Eugene x Expedite Package
Shipments

1

Eugene x Move to Warehouse

5

Eugene x Sort

3

Eugene x Inspect

2

Eugene x Land Distribution

12

In the primary pane, select Operating Expenses for Eugene and make the
following assignments:
Resource Account

Driver

Activity Account

Eugene x Operating
Expenses

Dollars

Eugene x Resolve Customer
Complaints

DQF
7,700.00

Eugene x Expedite Package
Shipments

9,000.00

Eugene x Move to Warehouse

69,000.00

Eugene x Sort

38,000.00

Eugene x Inspect

58,300.00

Eugene x Land Distribution

98,000.00

76 Making Assignments from Activities to Other Activities

5

Chapter 10

In the primary pane, select Equipment Expenses for Eugene and make the
following assignments:
Resource Account

Driver

Activity Account

DQF

Eugene x Equipment
Expenses

Percentage

Eugene x Resolve Customer
Complaints

5

Eugene x Expedite Package
Shipments

2

Eugene x Move to Warehouse

8

Eugene x Sort

20

Eugene x Inspect

25

Eugene x Land Distribution

40

Making Assignments from Activities to Other Activities
The costs of some activities flow to other activities. For example, at Parcel Express,
when packages are moved to a warehouse, they must then be sorted or inspected.
Therefore, in the Parcel Express Tutorial model, the costs of the Move to Warehouse
activity flow to the Sort and Inspect activities. These are known as intra-modular, or
reciprocal assignments.

¾ Modify the Cost Assignments column layout
1

Select Model > Activity Module.

2

If it is not already open, open the right assignments pane.

3

If the Cost Assignments layout is not already selected, select it from the
Column Layout list, and then click the arrow.

4

Open the Column Layout dialog box.

5

Modify the column layout as follows:
a In the primary pane, remove Inspections Passed and add Driver Name
(DrvName).
b In the right pane, remove Reference and add Driver Quantity Fixed
(DQF).

6

Click Save, and then click OK.
You see that the column layout has changed.

¾ Add accounts for assignments
1

Open the Add Accounts for Assignments dialog box.
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2

Select the Activity module.

3

Add the following accounts to the right pane:
Tip: To see these accounts, expand the hierarchy in the Add Accounts for
Assignments dialog box. You can add the accounts individually or select them all
at once by holding down the CTRL key, and then clicking Add Accounts.
Activity Account

Beaverton x Inspect
Beaverton x Sort
Beaverton x Air Distribution
Beaverton x Land Distribution
Eugene x Inspect
Eugene x Sort
Eugene x Land Distribution
4

Click Close.

¾ Make assignments
1

In the primary pane, select Move to Warehouse for Beaverton and make the
following assignments:
Activity Account
(Primary Pane)

Driver

Activity Account
(Right Pane)

DQF

Beaverton x Move to
Warehouse

Number of Packages

Beaverton x Sort

203,000

Beaverton x Inspect

2

50,000

In the primary pane, select Inspect for Beaverton and make the following
assignments:
Activity Account
(Primary Pane)

Driver

Activity Account
(Right Pane)

DQF

Beaverton x Inspect

Number of Packages

Beaverton x Sort

44,000
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In the primary pane, select Sort for Beaverton and make the following
assignments:
Activity Account
(Primary Pane)

Driver

Activity Account
(Right Pane)

DQF

Beaverton x Sort

Number of Packages

Beaverton x Land
Distribution

107,000

Beaverton x Air
Distribution

140,000

In the primary pane, select Move to Warehouse for Eugene and make the
following assignments:
Activity Account
(Primary Pane)

Driver

Activity Account
(Right Pane)

Eugene x Move to
Warehouse

Number of Packages

Eugene x Sort
Eugene x Inspect

5

6

DQF
117,000
18,000

In the primary pane, select Inspect for Eugene and make the following
assignments:
Activity Account
(Primary Pane)

Driver

Activity Account
(Right Pane)

DQF

Eugene x Inspect

Number of Packages

Eugene x Sort

16,000

In the primary pane, select Sort for Eugene and make the following assignments:
Activity Account
(Primary Pane)

Driver

Activity Account
(Right Pane)

DQF

Eugene x Sort

Number of Packages

Eugene x Land
Distribution

133,000

Making Assignments from Activities to Cost Objects
Now, you will make more inter-modular assignments from activity accounts to cost
object accounts. Remember that some cost object accounts are single-dimension
accounts. These accounts hold unique costs for individual channels or products. Some
Parcel Express activities, such as Resolve Customer Complaints, apply uniquely to a
channel, regardless of the packages that are being processed through the channel.
Similarly, some costs apply only to products, as you will see in the following procedures.
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¾ Add accounts for assignment
1

If there are accounts in the right pane, clear the accounts as follows:
a Select the highest branch of the Activity hierarchy in the primary pane.
b Select Model > Assignments > Clear Right.
You see that the right pane has been cleared of accounts. This does not delete the
assignments—it only removes them from view.

2

Open the Add Accounts for Assignments dialog box.

3

Verify that the Cost Object module is selected.

4

Add all of the Cost Object accounts to the right pane.
Note: To avoid mixing up activities and cost objects from Beaverton and Eugene,
consider first adding only the Beaverton accounts. Next, make the assignments.
Then, clear the right pane. And then, add all of the Eugene accounts and make
assignments. Also, note that clearing accounts from a pane does not delete
assignments from your model. It removes the accounts from view temporarily.

5

Click Close.

¾ Make assignments for Beaverton
1

2

In the primary pane, select Resolve Customer Complaints for Beaverton and
make the following assignments:
Activity Account

Driver

Cost Object Account for
Beaverton

DQF

Beaverton x Resolve
Customer Complaints

Number of Customer
Complaints

Commercial Pick Up x No
<Products and Services>

25

Walk In x No <Products and
Services>

85

Drop Box x No <Products
and Services>

15

In the primary pane, select Inspect for Beaverton and create the following
assignments:
Activity Account

Driver

Cost Object Account for
Beaverton

Beaverton x Inspect

Number of Packages

No <Channel> x Standard
Ground

DQF
500

No <Channel> x Overnight
Express

4,500

No <Channel> x 2nd Day
Guaranteed

1,000
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In the primary pane, select Air Distribution for Beaverton and make the
following assignments:
Activity Account

Driver

Cost Object Account for
Beaverton

DQF

Beaverton x Air
Distribution

Number of Packages

No <Channel> x Standard
Ground

50,000

No <Channel> x Overnight
Express

65,000

No <Channel> x 2nd Day
Guaranteed

25,000

In the primary pane, select Land Distribution for Beaverton and make the
following assignments:
Activity Account

Driver

Cost Object Account for
Beaverton

DQF

Beaverton x Land
Distribution

Number of Packages

No <Channel> x Standard
Ground

67,000

No <Channel> x Overnight
Express

15,000

No <Channel> x 2nd Day
Guaranteed

25,000

In the primary pane, select Expedite Package Shipments for Beaverton and
make the following assignments:
Activity Account

Driver

Cost Object Account for
Beaverton

DQF

Beaverton x Expedite
Package Shipments

Number of Expedite
Requests

No <Channel> x Standard
Ground

3,000

No <Channel> x Overnight
Express

26,000

No <Channel> x 2nd Day
Guaranteed

15,000
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¾ Make assignments for Eugene
1

2

3

In the primary pane, select Resolve Customer Complaints for Eugene and
make the following assignments:
Activity Account

Driver

Cost Object Account for
Eugene

DQF

Eugene x Resolve
Customer
Complaints

Number of Customer
Complaints

Commercial Pick Up x No
<Products and Services>

10

Walk In x No <Products and
Services>

32

Drop Box x No <Products
and Services>

25

In the primary pane, select Inspect for Eugene and create the following
assignments:
Activity Account

Driver

Cost Object Account for
Eugene

Eugene x Inspect

Number of Packages

No <Channel> x Standard
Ground

DQF
1,000

No <Channel> x Overnight
Express

500

No <Channel> x 2nd Day
Guaranteed

500

In the primary pane, select Land Distribution for Eugene and make the
following assignments:
Activity Account

Driver

Cost Object Account for
Eugene

DQF

Eugene x Land
Distribution

Number of Packages

No <Channel> x Standard
Ground

75,000

No <Channel> x Overnight
Express

16,000

No <Channel> x 2nd Day
Guaranteed

42,000
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In the primary pane, select Expedite Package Shipments for Eugene and
make the following assignments:
Activity Account

Driver

Cost Object Account for
Eugene

Eugene x Expedite
Package Shipments

Number of Expedite
Requests

No <Channel> x Standard
Ground

25,000

No <Channel> x Overnight
Express

1,000

No <Channel> x 2nd Day
Guaranteed

DQF

10,000

Adding Attributes to Cost Accounts
When you created the cost drivers for the Parcel Express Tutorial model, you built one
calculated driver, named Number of Expedite Requests, that was composed of two
attributes, named Average Time to Expedite and Completed Expedite Requests (See
Calculated Drivers). The value of those attributes must be added to the cost accounts to
which they apply.

¾ Open the cost object module
1

Select Model > Cost Object Module.

¾ Add columns for attributes in the column layout
To enter numeric values for attributes, the attributes must be added to the column
layout for the cost object account:
1

Make sure the current column layout is Cost Assignments.

2

Select Model > Column Layout > Edit Columns. The Column Layout window
opens.

3

Make sure the Cost Object Module is selected.

4

Make sure the Primary pane tab is selected.

5

Remove Display Reference from the Displayed columns list.

6

Add the Average Time to Expedite attribute.

7

Add the Completed Expedite Requests attribute.
The column layout should look like the following:
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Click OK. The attributes are added to the primary pane. There is no need to save
the column layout.

¾ Add attribute quantities
1

2

Now, add the following attribute quantities for Beaverton:
Destination
Account

Average Time to
Expedite

Completed Expedite
Requests

No <Channel> x
Standard Ground

1.75

4,000

No <Channel> x
Overnight Express

1.75

15,000

No <Channel> x 2nd
Day Guaranteed

1.75

25,000

Add the following attribute quantities for Eugene:
Destination
Account

Average Time to
Expedite

Completed Expedite
Requests

No <Channel> x
Standard Ground

3

6,000

No <Channel> x
Overnight Express

3

15,000

No <Channel> x 2nd
Day Guaranteed

3

20,000
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The resulting attribute assignments should look like the following:
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Performing Calculations 85
Viewing and Verifying Calculation Results 86

Typically, costs are entered in a model at the end of a defined period. These costs
come from an organization’s general ledger accounts and from external bills of costs.
Additional cost information can come from a Material Requirements Planning (MRP)
system. Production data is also entered in a model at the end of a defined period.
At any time during the development of a model, you can calculate the cost of each
account according to its driver and driver quantities.

Performing Calculations
You entered Parcel Express costs and quantities for the 2004 Q1 period, so
calculations will be performed for this period.

¾ Calculate costs
1

Select Model > Calculate Costs.
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You see the Calculate Costs dialog box.

2

Select the period/scenario 2008 Q1/Actual.
Note: You can select Force Calculate to perform calculations even if the flag is
set that says that calculations are up to date. To speed processing, SAS ActivityBased Management skips calculating if it thinks that calculations are up to date.
Use this option to force calculations anyway.

3

Click OK.
You see a message in the status bar, at the bottom of the window, indicating that
the calculation is in progress.

Depending on the speed of your SAS Activity-Based Management server and your
connection to it, the calculation might take several seconds. When the calculation
is completed, you see the Operation Summary window. You should have 0 fatal
errors, 0 errors, and 0 warnings.

Viewing and Verifying Calculation Results
Experienced activity-based costing users calculate a model after they create accounts,
assignments, and driver quantities, or after they enter cost data, as a validation and
quality assurance technique.
The following displays show the total costs for the resource, activity, and cost object
modules, along with the key roll-up accounts in each module. Verify that the modules
and accounts in your model match the costs.

Calculating Costs

Resource Module

Activity Module

Cost Object Module
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Steps for Building Bills of Costs 89
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A bill of costs provides a convenient mechanism for adding material and unit costs
directly to accounts, for bidding on jobs or for implementing activity accounting.
Use a bill of costs when either of the following is true:


Costs outside of the general ledger need to be introduced into a model. Not all
costs that are assigned through a model come from the general ledger. For
example, material costs (the cost of purchased components) can be additional
product cost information that often comes from a MRP system.



A model’s unit cost elements that are associated with product families need to be
tracked.

Steps for Building Bills of Costs
To build bills of costs:
1

Define a dimension in the external units module.
You did this step for the Parcel Express Tutorial model when you completed the
New Model Wizard. The dimension is Materials.

2

Create dimension members.
For the Parcel Express Tutorial, the Materials dimension members will represent
packaging materials.

3

Create accounts in the external units module.
You will use the New Account Wizard to add external units to the model.

4

Create an assignment from the external unit to an account, using the Bill of Cost
driver.
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Packaging materials in the Parcel Express Tutorial model contribute to the unique
costs of a product. You will make assignments from accounts in the external units
module to accounts in the cost object module.
5

Enter a fixed or variable driver quantity.
You will enter both types of quantities.

6

If you enter a variable driver quantity, you must also enter an output quantity.
You will enter output quantities in a later lesson.

Internal and External Units
An external unit is a unit, such as a part purchased from a supplier, whose cost is
maintained outside a SAS Activity-Based Management model, but which needs to be
accounted for in the model. SAS Activity-Based Management treats external units like
accounts. When an external unit’s cost is flowed to an account, you see the flowed cost
listed as an external unit cost element.

Fixed and Variable Quantities
A bill of costs quantity can include variable or fixed quantities or both.

Variable Quantities
In a variable quantity, the cost that flows to the account from the bill of costs depends
on the output quantity: the bill of costs’s unit cost is multiplied by the driver quantity
and the output quantity (either a system-calculated output quantity or a user-entered
output quantity).
For example, assume that a company manufactures bicycles. The rubber tires are
purchased from another company for $5 each. Because each bicycle requires two tires,
the unit cost of the bill of costs is $10. If the company produces 100 bicycles, the total
cost is $1,000 (100 x $5 x 2).

Fixed Quantities
In a fixed quantity, the cost that flows to the account from the bill of costs does not
depend on the output quantity: the bill of cost’s unit cost is multiplied by the driver
quantity.
For example, assume that the bicycle manufacturer that was mentioned previously
buys 1,000 tires at the beginning of each year. The tires might be used in any model of
bicycle that the manufacturer produced. In this case, the bill of costs’s unit cost does not
vary with the number of bicycles produced; it's always $5,000 (1,000 x $5).

Adding Bills of Costs
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Creating External Units and Bills of Costs
Parcel Express buys the following components from outside vendors:


standard envelopes



2nd day flats



overnight flats



large boxes



small boxes

These costs must be accounted for in the model. To account for them, you will create
external units and assign them to cost object accounts, thereby creating bills of costs.

 Create the Materials dimension members
1

Select Model > Dimensions Page.

2

Using the techniques that you have learned, create the following Materials
dimension members:

Tip: Select Edit > New Dimension Member to open the New Dimension
Member dialog box or right-click the dimension name.

 Create external units accounts
1

Select Model > External Units Module.
You see the external units module, which has no structure yet.

2

Select Edit > New Account.
You see the New Account Wizard.

3

Select the following dimension members:


Standard Envelope



2nd Day Flat



Overnight Flat
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Large Box



Small Box

Click Add, and then Next.
You see Step 2 of the New Account Wizard.

5

6

Enter the following unit costs:
Account

Unit Cost

Standard Envelope

.06

2nd Day Flat

.14

Overnight Flat

.14

Large Box

.95

Small Box

.75

Click Finish.
You see the following external unit structure:

 Modify the Cost Assignments column layout
1

In the external units module, show the right assignments pane.

2

If the Cost Assignments layout is not already selected, select it from the
Column Layout list, and then click the arrow.

3

Select Model > Column Layout > Edit Columns. The Column Layout dialog
box opens.

4

Modify the primary pane as follows:

5



Remove Display Reference.



Add Driver Name (DrvName).

Modify the right pane as follows:


Remove Reference.



Add Driver Quantity Fixed (DQF).



Add Driver Quantity Variable (DQV).

Adding Bills of Costs
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Click Save, and then OK.

 Add accounts for assignments
1

Open the Add Accounts for Assignments dialog box (Model > Assignments >
Add Accounts in Right Pane).

2

Add the following Cost Object accounts under Beaverton and Eugene to the right
pane:
Cost Object Account
No <Channel> x 2nd Day Guaranteed
No <Channel> x Overnight Express
No <Channel> x Standard Ground

 Make assignments
1

Make assignments that have the following driver quantities:
External Unit Account

Cost Object Account

Standard Envelope

Beaverton x No <Channel> x
Overnight Express

DQF

Standard Envelope

Eugene x No <Channel> x
Overnight Express

2nd Day Flat

Beaverton x No <Channel> x
2nd Day Guaranteed

1.00

2nd Day Flat

Eugene x No <Channel> x 2nd
Day Guaranteed

1.00

Overnight Flat

Beaverton x No <Channel> x
Overnight Express

Overnight Flat

Eugene x No <Channel> x
Overnight Express

Large Box

Beaverton x No <Channel> x
Standard Ground

Large Box

Eugene x No <Channel> x
Standard Ground

Small Box

Beaverton x No <Channel> x
Standard Ground

Small Box

Eugene x No <Channel> x
Standard Ground

8,677.00

123,500.00
6,500.00
120,833.00
4,167.00
73,950.00
2,550.00

Note: When you make assignments from external units, the software
automatically applies the Bill of Cost driver.
2

Select Model > Assignments > Show Single Pane.

3

Calculate the model, and then close the Operation Summary.
Note: Warnings occur because costs are still unassigned.

DQV

17,333.00
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You see the following external unit costs:

Note: The 2nd Day Flat external unit does not have a cost yet because you
assigned a variable driver quantity of 1. Until you enter an output quantity for the
2nd Day Guaranteed product, the system cannot calculate the cost of 2nd Day
Flat.
The following picture shows how the Cost is derived for each external unit by
multiplying the Total Driver Quantity times the UnitCost for each.
Note: Because there is no variable cost concerned in this case, we can simply add
the two DQFs (Driver Quantity Fixed) to derive the TDQ (Total Driver Quantity).
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Some of the most critical calculations in a model rely on the number of products that
are produced and sold, as well as sales revenue. From these values, you can determine
unit costs and profit. SAS Activity-Based Management provides properties for the input
and calculation of these values.

Entering Output Quantities
In SAS Activity-Based Management models, output quantity can be derived from a
number of user-entered quantities. In the Parcel Express Tutorial model, you will enter
data into the OutQtyUE (which stands for Output Quantity User-Entered) property and
the SoldQty (which stands for Sold Quantity) property, both of which will be used to
calculate the Cost of an account. The software uses OutQty (which stands for Output
Quantity) to calculate UnitCost also.

¾ Create a new column layout
1

Select Model > Cost Object Module.

2

Select the Default column layout.

3

Remove the Display Reference column.

4

Add the following columns to the primary pane:

5



Driver Name (DrvName)



Unit Cost (UnitCost)



Output Quantity UE (OutQtyUE)



Output Quantity (OutQty)

Click Save As and name the new column layout Unit Cost.
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¾ Enter output quantities and calculate costs
1

Expand the No <Channel> roll-up accounts for Beaverton and Eugene.

2

Delete the No <Channel> x No <Products and Services> accounts for both
Eugene and Beaverton. Right-click each account and select Delete. (Note that you
might have deleted them already when creating the cost object accounts.)

3

Assign the Sales volume driver to the following accounts for both Beaverton and
Eugene:
Cost Object Account
Drop Box x No <Products and Services>
Walk In x No <Products and Services>
Commercial Pick Up x No <Products and Services>

4

Assign the Sales volume driver to each of the No <Channel> accounts:
Cost Object Account
No <Channel> x 2nd Day Guaranteed
No <Channel> x Overnight Express
No <Channel> x Standard Ground

5

In the OutQtyUE column, enter the following quantities:
Account

Quantity
Beaverton

6

Eugene

No <Channel> x 2nd Day Guaranteed

58,840

30,500

No <Channel> x Overnight Express

67,330

33,670

No <Channel> x Standard Ground

128,966

64,534

Calculate the model, and then close the Operation Summary.
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You see the unit cost for each product. Output quantities have been generated for
these products.

If you return to the external units module, you will see that a cost has now been
generated for the 2nd Day Flat account. The reason is that you assigned cost by using
the DQV property, and this property requires an output quantity for calculation. Now
that you have entered the 2nd Day Guaranteed output quantity, the 2nd Day Flat
external unit account can be calculated.
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Let’s look more closely at how the cost of $12,507.60 for 2nd Day Flat is calculated.
Cost is calculated according to the following formula:
Cost = (DQF + DQV x Dst.TDQ) x UnitCost

In this case, DQF is zero and can be ignored. As for the Total Driver Quantity (TDQ),
in this case its value equals the Output Quantity User Entered (OutQtyUE).
Note: TDQ does not always equal OutQtyUE as we shall see shortly.

Entering Sales Volumes
You will enter sales volumes in the SoldQty property.

¾

Further modify the Cost Assignments column layout

1

In the Cost Object module, show the primary pane.
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2

If the Cost Assignments layout is not already selected, select it from the
Column Layout list, and then click the arrow.

3

Select Model > Column Layout > Edit Columns. The Column Layout dialog
box opens.

4

Modify the primary pane as follows:


Remove the Display Reference, Average Time to Expedite, and
Completed Expedite Requests columns.



Add Driver Name (DrvName).



Add Sold Quantity (SoldQty).

5

Click Save, and then OK.

¾

Enter sales volumes

1

In the primary pane, enter the following values for SoldQty for the following
accounts:
Account

SoldQty

Beaverton x Drop Box x 2nd Day Guaranteed

9,000

Beaverton x Drop Box x Overnight Express

4,000

Beaverton x Drop Box x Standard Ground

21,666

Beaverton x Walk In x 2nd Day Guaranteed

29,840

Beaverton x Walk In x Overnight Express

37,330

Beaverton x Walk In x Standard Ground

73,300

Beaverton x Commercial Pick Up x 2nd Day
Guaranteed

20,000

Beaverton x Commercial Pick Up x Overnight Express

26,000

Beaverton x Commercial Pick Up x Standard Ground

34,000

Eugene x Drop Box x 2nd Day Guaranteed

4,500

Eugene x Drop Box x Overnight Express

2,000

Eugene x Drop Box x Standard Ground

10,834

Eugene x Walk In x 2nd Day Guaranteed

16,000

Eugene x Walk In x Overnight Express

18,670

Eugene x Walk In x Standard Ground

36,700

Eugene x Commercial Pick Up x 2nd Day Guaranteed

10,000
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Account

SoldQty

Eugene x Commercial Pick Up x Overnight Express

13,000

Eugene x Commercial Pick Up x Standard Ground

17,000

Calculate the model, and then close the Operation Summary.
You see that costs are now assigned to the nine accounts (for each location) that
previously did not have costs.

Let’s take a closer look at how Cost is determined. As already mentioned, Cost is
calculated according to the following formula:
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Cost = (DQF + DQV x Dst.TDQ) x UnitCost

In the previous case, the TDQ equaled OutQtyUE. However, that is not always the
case. In general, the value of TDQ is determined by the following formula:
TDQ = TDQUE (if entered)
else OutQtyUE (if entered)
else TDQCalc + SoldQty

In the following picture, you can see how TDQ is derived for all the accounts to which
you assigned the Sales Volume driver.
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It is helpful to understand that whereas you ordinarily make assignments from
accounts in the primary pane to accounts in the right pane, the Sales volume driver
automatically assigns costs to the right pane based on the quantity that you enter in the
primary pane. You don’t have to make explicit assignments. To see this, follow these
steps:
1

Show the right pane by selecting Model > Assignments > Show Right
Assignments Pane.

2

In the primary pane, select the Beaverton x Drop Box x No <Products and
Services> account.

3

Select Model > Assignments > Show Right.
You see that assignments have automatically been made to three accounts in the
right pane.

4

In the primary pane, select the Eugene x No <Channel> x 2nd Day
Guaranteed account.

5

Select Model > Assignments > Show Right
(Or, click the Show Assignments button.)

Again, you see that assignments have automatically been made to three accounts
in the right pane.
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Of course, you can show the assignments that have been made for any account to
which the Sales Volume driver is assigned.

Entering Revenue and Calculating Profit
Profit and loss can be calculated after you enter sales data in the Revenue property.

¾

Create a new column layout

1

Select Model > Cost Object Module.

2

Select the Default column layout.

3

Select Model > Assignments > Show Single Pane.

4

Open the Column Layout dialog box.

5

Modify the primary pane as follows:


Remove the Display Reference column.



Add the UnitCost, Sold Quantity, Revenue, and Profit columns.

6

Save the new column layout with the name Profit.

7

Close the Column Layout dialog box.

¾

Enter revenue and calculate profit

1

In the Revenue column, type the following values:
Cost Object Account

Revenue

Beaverton x Drop Box x 2nd Day Guaranteed

72,550

Beaverton x Drop Box x Overnight Express

59,800

Beaverton x Drop Box x Standard Ground

379,166

Beaverton x Walk In x 2nd Day Guaranteed

321,667
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Cost Object Account

Beaverton x Walk In x Overnight Express

2

Revenue

558,133

Beaverton x Walk In x Standard Ground

123,333

Beaverton x Commercial Pick Up x 2nd Day
Guaranteed

139,000

Beaverton x Commercial Pick Up x Overnight Express

388,700

Beaverton x Commercial Pick Up x Standard Ground

595,000

Eugene x Drop Box x 2nd Day Guaranteed

61,275

Eugene x Drop Box x Overnight Express

29,900

Eugene x Drop Box x Standard Ground

189,584

Eugene x Walk In x 2nd Day Guaranteed

215,834

Eugene x Walk In x Overnight Express

279,061

Eugene x Walk In x Standard Ground

641,667

Eugene x Commercial Pick Up x 2nd Day Guaranteed

69,500

Eugene x Commercial Pick Up x Overnight Express

194,350

Eugene x Commercial Pick Up x Standard Ground

297,500

Calculate the model, and then close the Operation Summary.
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You see the following profit and loss information:
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The Contributions page provides the fastest and easiest method to view cost flows
throughout a model. To query a model on the Contributions page, the model must have
been calculated. However, a cube does not need to be generated. Queries are fast
because there is no cube to navigate.

¾
1

Open the Contributions page
Click the Contributions icon, and then click New Query. This icon appears only if
the Contributions Server has been installed.

Or, select File > New > Contribution Query.
2

Select Parcel Express Tutorial as the model.

3

Select 2008 Q1/ Actual as the association to use.

4

Click Finish. The Contributions page opens.
Note: Apache Tomcat must be running on the server.
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Some Key Things to Know


Select a module (Resource, Activity, Cost Object, External Unit) to expand it.
Expanding a module does not select anything in it. Select checkboxes to select
dimensions in the module.



You can choose only one module, but you can select multiple dimensions in a
module.

Note: Only one module is active at a time. Do not be misled by the fact that
checkboxes remain selected when a module is collapsed. If a module is collapsed,
then it is not active.


You can select up to 10 dimensions. You can select any number of levels within a
dimension (for the Contributions page, Drivers is considered a dimension). The
following picture should make clear how dimensions are counted. In this picture,
four dimensions are selected and six dimension levels:

You must select at least one source level and at least one destination level.


You do not have to select anything in Via Module/Stage(s). Select nothing means
that all paths from source to destination are included in calculations. Select
something in Via Module/Stage(s) to restrict the paths that are included.
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Query Contributions from Resource to Cost Object
To refresh your memory, here again is a picture of the model dimensions:

¾

Query from general ledger to products and services

1

For Source Module, select Resource, and then select:


2

For Destination Module, select Cost Object, and then select:


3

Level1 under General Ledger

Level1 under Products and Services

Click Get Results. The resulting table shows the contributions of wages,
operating expenses, and equipment expenses to each of the products.
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¾

Add a region to source and destination

1

For Source Module, select Resource, and then select:

2

3



Level3 under Region



Level1 under General Ledger

For Destination Module, select Cost Object, and then select:


Level3 under Region



Level1 under Products and Services

Click Get Results. The resulting table shows, by region, the contributions of
wages, operating expenses, and equipment expenses to each of the products by
region. (In order to fit the picture on the page, the table has been split in two and
one half stacked on top of the other.)

¾

Add channel to the destination

1

For Source Module, select Resource, and then select:


Level3 under Region



Level1 under General Ledger

Querying Contributions
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3
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For Destination Module, select Cost Object, and then select:


Level3 under Region



Level1 under Channel



Level1 under Products and Services

Click Get Results.
The resulting table shows the contributions of wages, operating expenses, and
equipment expenses to each of the products by region and channel. (Again, the
table is split in pieces to fit on the page.)

Because the table is long, you must scroll to see all the columns. The scroll button
scrolls one column at a time.

¾

Add a Via module

1

For Source Module, select Resource, and then select:


Level3 under Region



Level1 under General Ledger
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For Via Module, select Activity, and then select:


3
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Level2 under Activities

For Destination Module, select Cost Object, and then select:


Level1 under Channel



Level1 under Products and Services

Note: We have deselected Region. This reduces the number of result columns by
half. Because there are two items at Level3 under Region (Beaverton and
Eugene), the number of columns would double. If you want to see activities by
region, then you can add it back.

4

Click Get Results.
The resulting table shows the general ledger contributions by activity to each of
the three products by channel. (Activities in the Via column are shown in yellow.)
Because it is large, only part of the table is shown.
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Query Contributions from Resource to Activity
¾

Query from general ledger to activities

1

For Source Module, select Resource, and then select:

2



Level3 under Region



Level1 under General Ledger

For Destination Module, select Activity, and then select:


3

Level2 under Activities

Click Get Results. The resulting table shows the contributions, by region, of
general ledger items to activities.

Drilling Down to a Lower Level
¾

Drill to lower-level activities

The table generated by a query is not static. If you select a dimension level to display
that has additional levels under it, you can click the generated table to display the next
level of detail.
1

2

For Source Module, select Activity, and then select:


Level3 under Region



Level1 under Activities

For Destination Module, select Cost Object, and then select:


Level1 under Products and Services
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Click Get Results.
The resulting table shows the contributions of activities, by region, to products
and services. Note that the Activities column is highlighted.

4

Click 1:Local Processing in the Activities column to go to the next level of detail.
Initially, activities were displayed at Level1. By clicking, you drill down to Level2
activities. Notice that the entire table is replaced by the Level2 activities. Also
notice that the roll-up account 1:Local Processing is displayed.

5

Click Drill Up to return to the previous table.

Using the ABC Procedure
SAS Activity-Based Management has externalized, in the form of the ABC procedure,
the processing that it uses internally to calculate a model and query a cube. The ABC
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procedure allows you to create SAS programs to query model data outside of SAS
Activity-Based Management.
The easiest method to create a program that uses the ABC procedure is to use the
Contributions tab to perform a query. Then click Gen Proc Stmt to copy, to the
clipboard, the PROC ABC statement that the Contributions tab itself used for the query.
For example: Assume that you have performed the query described above; click Gen
Proc Stmt and paste the statement into the SAS editor (or any ASCII editor). You will
see something similar to the following:

You can modify the program in any way that you like before running it.
Note that you must click Get Results before clicking Gen Proc Stmt. Changing the
query options after performing a query does not change what statement is copied to the
clipboard unless you click Get Results again to perform a different query.
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When the information has been entered into the activity-based management model,
the costs have been calculated, and the data has been reviewed, the next step in
analyzing the data is generating reports.
The benefits of generating reports include:


validating the model



producing printouts that present an overall view of the data



analyzing costs online



producing files for inclusion in other programs, such as spreadsheets or word
processors



focusing on a specific area of interest

Report Templates
A report template is a file that specifies the layout of a report and the fields of data in
a report (but not the data itself). When you create a report, you first select a report
template.
SAS Activity-Based Management has predefined report templates that provide
formats and that enable great flexibility in the amount and type of information to
include in a report. The following predefined templates are included:


Destination Furthest



Dimensional Attribute Cost



Dimensional Attribute Unit Cost



Dimensional View



Driver—Cost and Rate



Idle Capacity
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Module Hierarchy



Multi-level Contributions



Profit and Loss



Profit Cliff



Resource Contributions



Resource Contributions by Attribute



Single-stage Assignments



Single-stage Contributions



Unassigned Costs



Unit Cost

Creating a Report
You will create a report and view the results online. The report is for the 2008
Q1/Actual period/scenario association, and includes information about resource
contributions.
To create a new report, you use the Report Wizard. The Report Wizard has six steps.

¾ Select a model and template
1

Click
You see the Reports home page.

2

Select File > New > Report.
You see Step 1 of the Report Wizard.

3

Under Select a model and a report template, select the Parcel Express
Tutorial model and the Single-stage Assignments report template.
Note: To create a report you do not have to generate a cube. However, to create the
following reports you must have already generated the Fact table for the model:

Generating Reports

x
x
x

4
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Resource Contributions
Destination Furthest
Profit and Loss (Resource Contribution)

Click Next.
You see Step 2 of the Report Wizard.

5

Select 2008 Q1/Actual, and then click Next.
You see Step 3 of the Report Wizard.

6

Select Use all modules, and then click Next.
You see Step 4 of the Report Wizard.

7

Verify that no dimensions are selected.
Certain report types require you to select dimensions to arrange and filter data.
For these reports, the order that you select these dimensions affects the results
that you see in the report.
Click Next.
You see Step 5 of the Report Wizard.

8

Verify that Suppress zero costs and Single currency are selected, and then
click Next.

9

Select Save configuration for Step 6 of the Report Wizard.

10 For Name, type PX Tutorial Single-stage Assignments.
11 Click Finish.
You see the finished report in portable document format (PDF).
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The data in this report reflects the current model. If you make changes to the model
and reopen the report, the report data reflects the changes.
Each report has a header that lists pertinent information for that report. All or some
of the following information can be listed in a report's header:
Information

Description

Model Name

The model that is selected for the report.

Module

One or more modules that are selected for the report. Each module
starts on a new page.

Period

The period that is selected for the report.

Scenario

The scenario that is selected for the report.

View Perspective

The structural dimension that is selected for the report.

Filtered

Indicates that one or more attributes were used to select items for the
report. Attributes that are used to select report data are listed on a
report's last page.

Working with Reports
All saved report configurations that are on the same server are listed in the
Workspace Manager. Your company might want to set up guidelines for saving and
naming report configurations. You can open a report configuration from the Workspace
Manager or from the Reports home page.
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On the Reports home page, you can open, publish, configure, or delete a report
configuration.

Navigating Reports
You can navigate the pages of a report by using the standard Adobe Acrobat paging
and search tools on the toolbar.

Saving Report Data
When you save a report configuration, you are saving only the parameters of the
report, not the data. To save the data in a report, you must publish or export the report.

Publishing Reports
If you want other users to see the report results, along with the data that reflects a
specific time period, you can publish the report. If you want to view and edit the report
using SAS Web Report Studio, you must publish the report.
Publishing the report enables others to see the report data without having to rerun
the report. In cases where a report requires considerable time to run, publishing the
report can save time for other users.

¾
1

Publish a report
On the Reports home page, click the Publish link that is next to the desired
report configuration.
You see the Publish a Report dialog box.

2

Type a Name.
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Note: You cannot enter a path. Published reports are stored on the SAS ActivityBased Management server.
3

Type a Description.

4

Select a Format.
The available publishing formats are:
Report Publishing Formats
Portable Document Format (PDF)
Rich Text Format (RTF)

5

Click OK.
The report is added to the Workspace Manager in the Published Reports folder.

Exporting Reports
If you want to manipulate a report after running it, you can export the report. Data
that you export from SAS Activity-Based Management can be used by other reporting
tools, such as SAS Enterprise Guide and Microsoft Excel. To export a report, select
File > Export > Report Data, and follow the instructions in the Report Data Wizard.

Importing Published Reports
You can also import a published report created outside of SAS Activity-Based
Management. For example, you can import reports published by SAS Enterprise Guide.
To import a published report (for example, from Enterprise Guide), in Workspace
Manager select Published Reports, and select File > Insert Published Report.

Configuring Reports
By running the New Report Wizard, you are configuring a report.

¾
1

Reconfigure a report
On the Reports home page, click the Configure link that is next to the saved
report configuration.
You see the Report Wizard. The Report Wizard contains a subset of steps that are
in the New Report Wizard.

2

Complete the Report Wizard by selecting the new configuration settings.

123

C H A P T E R

16 Generating Cubes
Types of Cubes 123
Multi-Stage Contribution Cube 123
Resource Contribution Cube 124
Single-Stage Contribution Cube 124
Overview of Cube Generation 124
Cube Configurations 125
Generate Cubes 131
Select Cost Flow: In or Out 128
Manage Cube Permissions 130

A cube is the basic unit of analysis in OLAP, a technology that provides fast,
interactive access to data in a model. A cube is a storage unit that combines all of a
model’s dimensions and the measures they contain into one unit. You use SAS ActivityBased Management to connect to and interact with the cubes on a SAS Activity-Based
Management server. For each model, you can generate cubes and manipulate them on
the OLAP page to interactively analyze business data.
An OLAP cube is called a cube even if it has more than the three dimensions of an
ordinary geometric cube. An OLAP cube can represent any number of dimensions of
data. SAS Activity-Based Management cubes are standard OLAP cubes.

Types of Cubes
SAS Activity-Based Management provides the following types of cubes:


multi-stage contribution



resource contribution



single-stage contribution

Each type of cube helps you to analyze data in various ways and to answer different
kinds of questions.

Multi-Stage Contribution Cube
Use this type of cube to perform tasks and to answer questions such as:


Why is product A not profitable? You want to trace the costs back through
activities and then to resources that contribute costs to this product.



What are the costs for Product B that originate in salary resources and that are
assigned through the Inspection activity to this product?
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The multi-stage contribution cube enables you to analyze cost contributions into and
out of stages that are defined in a model. The Cube Explorer view enables you to
visually trace cost contributions through all the stages.

Resource Contribution Cube
Use this type of cube to analyze resource accounts that contribute costs to other
accounts. Or, use this type of cube to analyze the accounts that receive costs from
resources.
The resource contribution cube enables you to analyze cost contributions from original
accounts (where costs were entered) to final accounts that do not assign costs to other
accounts. Generally, these contributions are from resource accounts to cost object
accounts, but it does not matter where the original or final accounts reside.

Single-Stage Contribution Cube
Use this type of cube to answer questions such as:


Which activity costs contribute to product, customer, service costs, and so on?



When costs are assigned within the cost object module, which subassembly costs
contribute to product costs?



What are the costs of resources that contribute to activities?

The single-stage contribution cube enables you to analyze cost contributions from one
assignment level back. It does not matter where the costs originate or end. Typically,
cost is contributed from:


activities to cost objects



resources to activities

Overview of Cube Generation
Generating a cube is a two-step process.
Step 1: Create a cube configuration
From a single model, you can generate multiple cubes. A cube configuration
remembers your choices for a particular cube. If you update the model and
need to regenerate the cube, you don’t have to specify the cube characteristics
again. In short, one model can have multiple cube configurations, and each
cube configuration contains the specifications for a single cube.
Step 2: Generate the cube
After a model has been calculated, you generate cubes by specifying which of
the cube configurations belonging to the model are to be used, and which
periods are to be included. For each cube configuration that you select, a cube
is generated. If the model has not been calculated, you are asked if you want
the calculation to be done so that cube generation can proceed.

Generating Cubes

Cube Configurations 125

Cube Configurations
For this tutorial, you will create four cube configurations:


resource contribution cube



6.3-compatible multi-stage contribution cube



custom multi-stage contribution cube



custom, but minimal, multi-stage contribution cube

¾

Create a resource contribution cube

1

Go to the Home page.

2

Select File > New > Cube Configuration.
Step 1 of the New Cube Configuration wizard opens.

Specify the following for step 1:


For Model name, select Parcel Express Tutorial.



For Cube configuration name, type Parcel Express Tutorial –
Resource Contribution.



In the Generate section, select Cube and Fact table.



For Type, select Resource Contribution.



In the Cube and Fact Table Information section, select Create SAS
Activity-Based Management 6.3 compatible cube and fact table.
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Note: For a resource contribution cube, the only option available is to
generate a 6.3 compatible cube.
For a multi-stage contribution cube, you can generate a custom cube. A
custom cube is one for which you choose what goes into it. We’ll look at this in
a moment.
3

Click Next. Step 2 opens.

4

Select all numeric attributes to be included in the resource contribution cube.
Since the Parcel Express Tutorial model is relatively small, you can select all of
the numeric attributes.

5

Click Next. Review your options, and then click Finish.

The cube configuration is added to the Cube Configurations folder.
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¾

Create a multi-stage contribution cube

1

Select File > New > Cube Configuration.
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Step 1 of the New Cube Configuration wizard opens.

Specify the following for step 1:


For Model name, select Parcel Express Tutorial.



For Cube configuration name, enter Parcel Express Tutorial –
Multi-Stage Contribution.



In the Generate section, select Cube and Fact table.



For Type, select Multi-Stage Contribution.



For Cube and Fact Table Information, select Create SAS ActivityBased Management 6.3 compatible cube and fact table.
Later, you will see what is involved in creating a custom cube. For now,
choose a 6.3 compatible cube.

2

Click Next.
Step 2 opens. In this step, you select which modules or stages to include in the
cube, and whether to include costs flowing into or out of the module or stage.
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Click the Modules checkbox. This means that each module defines a
separate stage in the order shown.
Selecting the Stages checkbox means that stages are defined by user-defined
“Stages” attributes applied to accounts. The Parcel Express tutorial does not
have any such attributes, so you select Modules.

3



Select Include to include all the modules in the cube.



Leave the defaults for Cost Flow as shown. The cost flow specifies whether
to include cost flows into or out of the selected module or stage. We’ll look
more closely at what this choice means later in this chapter. In the
meantime, you can take the defaults.

Click Next.
Step 3 opens. In this step, you select numeric attributes to be included in the cube.
Since the tutorial model is relatively small, select all of the attributes.

4

Click Next. Review your selections, and then click Finish.

The cube configuration is added to the Cube Configurations folder.

¾

Create a custom multi-stage contribution cube

A custom cube allows you to select what goes into the cube. This allows you to create
smaller cubes for particular purposes.
1

Select File > New > Cube Configuration. Step 1 opens.
Specify the following for step 1:


For Model name, select Parcel Express Tutorial.



For Cube configuration name, enter Parcel Express Tutorial –
Custom Cube.



In the Generate section, select Cube and Fact table.



For Type, select Multi-Stage Contribution.
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In the Cube and Fact Table Information section, select Create custom
cube and fact table.



For Cube and Fact table name, enter Parcel Express Tutorial
Custom Cube. Because you can generate different multi-stage contribution
cubes for the same model, you must assign a name to each cube to identify it.
Note: If you are generating only a fact table, then it is only the fact table
name.

2

Click Next.
Step 2 opens. In this step, you can select not only which modules or stages to
include in the cube, but also the level at which to include them.



Click the Modules checkbox. This means that each module defines a
separate stage in the order shown.



Click the plus sign to expand the Resource module, and uncheck GL (General
Ledger). The cube will be smaller if you exclude some accounts.



Click the plus sign to expand the Cost Object module, and under the Include
to Level column, select Level 3 from the drop-down list for Region. Selecting
Level3 for Region includes the details for Beaverton and Eugene in the cube.



Leave the defaults under Cost Flow as shown. We’ll look more closely at
what this choice means later in the chapter.

3

Click Next. Step 3 opens.

4

Select all the numeric attributes to be included in the cube.

5

Click Next. Review your options, and then click Finish.

The cube configuration is added to the Cube Configurations folder.
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¾

Create a minimal custom multi-stage contribution cube

The next cube configuration that you create is an interesting one because it is very
small. It provides an ideal illustration of the utility of custom multi-stage contribution
cubes. Even though this one is small, it is useful because it allows you to concentrate on
total costs without worrying about where they come from.
1

Select File > New > Cube Configuration. Step 1 opens.
Specify the following for step 1:


For Model name, select Parcel Express Tutorial.



For Cube configuration name, enter Parcel Express Tutorial –
Mini Cube.



In the Generate section, select Cube and Fact table.



For Type, select Multi-Stage Contribution.



In the Cube and Fact Table Information section, select Custom Cube.
For Cube and Fact table name name, specify Parcel Express Tutorial
Mini Cube.

2

Click Next.
Step 2 opens. In this step, you can select not only which modules or stages to
include in the cube, but also the level at which to include them.



Click the Modules checkbox.



Uncheck the first three modules: ExternalUnit, Resource, and Activity. In
this cube, you want to see only final costs.



Click the plus sign to expand the Cost Object module, and under the Include
to Level column, select Level 3 from the drop-down list for Region. Selecting
Level3 for Region includes the details for Beaverton and Eugene in the cube.



Leave the defaults under Cost Flow as shown.
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3

Click Next. Step 3 opens.

4

Select all the numeric attributes to be included in the cube.

5

Click Next. Review your options, and then click Finish.
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The cube configuration is added to the Cube Configurations folder.

Generate Cubes
Having created four cube configurations, you can use them to generate cubes.
1

If the Parcel Express Tutorial is not already open, return to model mode and open
the tutorial model.

2

Select Model > Generate Cubes.
The Generate Cubes dialog opens.

3

Select the four cube configurations that you created.

4

Select the period/scenario 2008 Q1/Actual.
Note: In previous releases of SAS Activity-Based Management, you could not
select a subset of periods/scenarios for inclusion.

5

Click Generate.

One cube is generated for each cube configuration that is selected.
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Select Cost Flow: In or Out
With some models, it makes a difference in generating a cube whether you select to
show costs flowing into a module/stage or out of a module/stage. It makes a difference in
case the model has assignments from accounts within a module/stage to accounts within
the same module/stage. For the Parcel Express Tutorial model in Chapter 3, “Making
Assignments,” you made assignments from activities to activities. One such example is
shown in the following picture.

Note: To display these assignments:
1

Select the Activity module.

2

Select Left and Right Assignment Panes from the View Assignment Panes
icon.

3

Select the Move to Warehouse account.

4

Select Show Left and Right from the Show Assignments icon.
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When you generate a cube, you must specify what cost assignments you want to
appear in the cube for each module/stage. Sticking with the current example, you must
choose assignments into the Activity module (Move to Warehouse), or out of the Activity
Module (Sort and Inspect). You can’t choose both because that would result in doublecounting final costs (part of Sort and Inspect costs are Move to Warehouse costs).
The following picture shows the results of showing costs flowing into the Activity
module. Notice that Move to Warehouse has non-zero cost because it receives
assignments from the Resource module. Inspect and Sort also have non-zero costs
because they also receive assignments from the Resource module.

By contrast, the following picture shows the results of showing costs flowing out of the
Activity module. Notice that Move to Warehouse now has zero cost because it has no
assignments out of the Activity module into the Cost Object module; its assignments are
entirely within the Activity module.

If a model has no cost assignments from accounts within a module/stage to accounts
within the same module/stage, then the choice of showing cost flows into or out of a
module/stage makes no difference (Every cost into a module/stage is also a cost out of
the module/stage.). By defining multiple stages such that there are no assignments
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within a single stage, you avoid having to make the choice of showing cost flows in or
out.

Manage Cube Permissions
After generating a cube, you can changes its owner and control who has permission to
access it. Permission is granted by role. All users who are authorized to a role can
receive permission (or be denied permission) to view a cube. Roles are created, and users
are assigned to roles, in the SAS Activity-Based Management Administrator program.
Note: The ability to manage permissions in this way is restricted to cubes stored in
Microsoft Analysis Services (MSAS).

¾

Manage cube permissions

1

Select Model > Manage Cubes and Permissions.
The Manage Cubes and Permissions dialog box opens.

2

Select the cube whose permissions you want to manage.
Note: You can change only one cube at a time.

3

Click Permissions.
The Permissions dialog box opens.
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You can change the cube owner and add or remove Read access to roles. All users
with access to a role inherit the permission that you select for that role.

136
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Once you have generated cubes, you use the SAS OLAP Analyzer to view the cube.

Creating OLAP Views
¾

Create an OLAP view

1

Select File > New > OLAP View.
You see Step 1 of the New OLAP View Wizard. The New OLAP View Wizard has
only one step.

2

Select the Parcel Express Tutorial model.

3

Select the Resource Contributions cube.

4

Click Finish.
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You see the resource contributions cube for the Parcel Express Tutorial model.

Note: You can turn on and off the display of the slicer buttons by selecting OLAP
> Slicers from the menu.

Note: You can turn on and off the display of the graph by clicking the Graph
button. Depending on the size of the SAS Activity-Based Management window,
you might have to use the More menu to see the Graph button.
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Analyzing OLAP Cubes
So far, the only information that the cube has provided is the costs for periods and
scenarios. To perform an interactive analysis of the cube, you will select specific
dimensions for analysis. You use the Cube Dimensions Tree to select dimensions for
display in OLAP cubes.
Note: If the Cube Dimensions Tree is not visible, select OLAP > View Manager and
click the Cube Dimensions Tree tab.

Selecting and Displaying Dimensions in Cubes

¾

Select dimensions

1

Select Src Region from the Cube Dimensions Tree and click the add arrow

Click the arrow

Select Src Region

2

Select Src General Ledger from the Cube Dimensions Tree and click the add
arrow to add to Row.

3

Move Dst Products and Services from rows to columns.
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To do this, right-click All_Products_and_Services and select Move Dst
Products and Services > To Columns on the menu.

4

Remove All Periods from columns.
To do this, right-click All Periods and select Remove All Period from Table on
the menu.

The table view should now look like the following:

The data in the table view has been updated according to the dimensions that you
have selected. To see the details, you must drill through the dimensions.
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¾
1
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Drill through dimensions
Click the down arrow next to the All_Products_and_Services column in the
grid.
Note: Use to drill down (the node that you click is replaced by its children).
Use to expand (the node that you click is displayed along with its children).
Click the down arrow

You see the All_Products_and_Services dimension expand, showing the costs
for each product.

You can eliminate empty rows and columns

2

Delete empty rows and columns by clicking the Preferences tab of the Cube View
Manager.
Note: If the Cube View Manager is not visible, then select OLAP > View
Manager.
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Click Preferences

3

Select Exclude empty rows from the results and Exclude empty columns
from the results.
You see that the empty rows and columns have been removed from the grid and
bar chart.

4

Drill down on the All_Region row and the All_General_Ledger row until you
see the general ledger expenses for Eugene and Beaverton.
Drill down Drill down

Both the grid and bar chart show the contribution of resource accounts to each
product.
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In the Cube Dimensions Tree, add Dst Channel to Column.

You see that the All_Channel dimension has been added to the grid and bar
chart.
6

Drill down on the added column in the grid.
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Drill down

The table view should look like the following, showing the cost per channel for
each product and service:

A very useful navigational aid is the ability to isolate portions of a table.
7

Right-click the Commercial Pick-up column, and then select Isolate
Commercial Pick-up from the pop-up menu.

The resulting table allows you to focus your attention on the Commercial-Pick up
channel.
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Don’t forget that you can click the Back button to return to a previous view. And,
don’t confuse the OLAP page back button, which returns you to a previous OLAP
view, with the ABM back button, which returns you to the previous ABM page.

Displaying Dimension Attributes
In addition to displaying dimensions in the rows and columns of an OLAP view, you
can display dimension attributes.

¾
1

Select the Fixed_Variable dimension attribute
Select SrcFixed_Variable > All from the Cube Dimensions Tree and click the
add arrow to add to Row.
Notice that the dimension attribute, Fixed_Variable, appears in the Cube
Dimension Tree along with other cube dimensions.

2

Right-click the row header, Level1, and then select Remove SrcGeneral Ledger
from Table from the pop-up menu.
This step is not necessary, but we are doing it so as to isolate the Fixed_Variable
attribute.
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Click the down arrow to drill down into the All_Fixed_Variable row.
Your OLAP view should now look like the following. Notice that costs are broken
down into fixed costs and variable costs (and those that are neither fixed nor
variable). Dimension attributes can serve the same purpose as full-fledged
dimensions.

Saving OLAP Views
During the analysis, changes that you make to the Grid View, Chart View, and Cube
Explorer View are retained during a session, even when you return to the OLAP page
after viewing other tabs. However, when you close the session or when you close Grid
View, Chart View, or Cube Explorer View, your changes are lost.
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To save these changes so that they will be available later, you must save the OLAP
view. When you save an OLAP view, you save the layout and contents of the view.
However, the window positions and states are not saved.

¾

Save an OLAP view

1

Select OLAP > Save View As.
You see the Save OLAP View As dialog box.

2

For Name, type Parcel Express Tutorial – Resource Contributions.
Click OK.

3

On the toolbar, click the OLAP Home link
You see a link to Parcel Express Tutorial – Resource Contributions in the
OLAP Views list.

Using Measures in Cubes
A measure is a property or an attribute that you can use to analyze OLAP
information. The default measure is Cost. Now, you will create a new OLAP view using
different measures. You will also create a custom measure.
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¾

Working with measures in OLAP

1

Select File > New > OLAP View (or click New OLAP View).

2

Select the Parcel Express Tutorial model.

3

Select the Resource Contributions cube.

4

Click Finish.
The resource contributions cube for the Parcel Express Tutorial model opens.

5

Select Measure > Edit Measures.

6

Select the following measures and click OK:
Cost
Profit
Revenue
UnitCost
UnitProfit
UnitRevenue

When you drill down on products and services, you see that the 2nd Day
Guaranteed product is losing money, while the other two products are profitable.
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Note: To highlight the non-profitable cells in the table, select Highlight > Add
Highlight and specify Profit Is less than 0.00.

7

Use the Cube Dimensions Tree to add Dst Channel to Row.
This will enable you to see whether this trend is similar across all channels. One
of management’s goals was to make a profit of at least 10% on the 2nd Day
Guaranteed product, and at least 25% on all other products. SAS Activity-Based
Management has shown that the company’s profit picture is not what
management expected. Competitive pressures forced the company to lower the
price of their 2nd Day Guaranteed product, but it did not know that it was losing
money on all products but the Walk In product.
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Now, you will create a custom measure to calculate gross margin.

¾

Create a custom measure

1

Select Measure > Add Measure.

You see Step 1 of the Create New Calculated Member.
2

For Name, type GrossMargin, and then click Next.

3

Select Simple calculations, and then click Next.
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4

Select Ratio and Profit / Revenue, and then click Next.

4

Select Percent % for Use format, and then click Next.
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In the next dialog box, you can select whether the calculated measure is to be
temporary, for this cube view only, or for this session. Select Available during
this session only, and then click Finish.
Note: The Global, always available option is available only for cubes in SAS
OLAP Server. The option is not available for cubes in Microsoft Analysis Services.

You see the profit margin of each product. Based on the stated goals of the company,
the 2nd Day Guaranteed is underperforming significantly.

If you select the Measure menu, you can see that GrossMargin has been added to
the list of available measures (unless you chose Temporary for the scope of the
measure, in which case GrossMargin is not added).
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Exporting Cubes
At any point during OLAP analysis, you can export the displayed data to a Microsoft
Excel spreadsheet. When you export to Microsoft Excel, you are exporting only the data
that is currently displayed, not the entire cube.

¾

Export an OLAP cube

1

Display the OLAP data that you want to export to a Microsoft Excel spreadsheet.

2

Select OLAP > Export to Excel.
You see a Microsoft Excel spreadsheet that contains the data that is currently
displayed in the cube.

Using the Cube Explorer View
Now, you will analyze the model by using the Cube Explorer View to get more
information about the costs that are associated with each product. The management of
Parcel Express has learned that margins on the 2nd Day Guaranteed product fall well
below expectations. The SAS Activity-Based Management OLAP tool will help
management assess why costs for that product are higher than costs for other products.
You will create a multi-stage contributions cube view and use the Cube Explorer View
to explore costs.

¾

Create a multi-stage contributions cube view

1

Select File > New > OLAP View (or click New OLAP View).
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2

Select the Parcel Express Tutorial model.

3

Select the Multi Stage Contributions cube.

4

Click Finish.
The multi-stage contributions cube for the Parcel Express Tutorial model opens.

¾

Create a new Cube Explorer View

1

Select Cube Explorer > New Cube Explorer View.

You see the first page of the Create New Cube Explorer View.
2

Click Cost_ObjectProducts and Services > All > 2nd Day Guaranteed, and
then click Next. You will open the Cube Explorer View at the 2nd Day
Guaranteed product because that is the product whose costs you want to explore.
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Select Cost and UnitCost as the measures to analyze, and then click Finish.
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The Cube Explorer View opens at the 2nd Day Guaranteed product.

Cost
UnitCost


1

Analyze the model in Cube Explorer View
Select Apply color shadings based on > Measure values so that large costs
will stand out by their color, and then select the colors to use if you want colors
other than the default colors.

Color is determined by measures (Cost)

Select colors

2

Right-click 2nd Day Guaranteed and select Change To > Cost_ObjectRegion
> Level3.
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You see the regional costs that contribute to the 2nd Day Guaranteed product.

3

Because Eugene accounts for the larger part of costs (54.82%) of the 2nd Day
Guaranteed product costs, drill down into Eugene to discover where those costs
come from. Right-click Eugene and select Change To > Cost_ObjectChannel >
Level1.
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You see that the Walk In channel contributes 52% to the costs of the 2nd Day
Guaranteed product. Drill down into this channel to explore what accounts for its
costs.
4

Right-click Walk In and select Change To > ActivityActivities > Level2.

The Land Distribution set of activities stands out as constituting 47.90% of
costs.
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Right-click Land Distribution and select Change To > ResourceGeneral
Ledger > Level1.

Now you can see that the overwhelming part of this cost is for wages in Eugene—a
full 86%.
6

To confirm the finding that it is wages in Eugene that account for the high cost of
the 2nd Day Guaranteed product, drill down on Beaverton for a comparison.
a Right-click Beaverton and select Change To > Cost_ObjectChannel > Level1.
b Right-click Walk In and select Change To > ActivityActivities > Level2.
c Right-click Land Distribution and select Change To > ResourceGeneral Ledger >
Level1.
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Even though Wages account for a similar percentage of costs for the 2nd Day
Guaranteed product in Beaverton, UnitCost for Beaverton is a fraction of UnitCost for
Eugene, and the total cost in Beaverton is half of the total cost in Eugene.
If you could put the two branches of the tree together, the picture would look like the
following. The unit cost of wages in Eugene for land distribution ($7.00) is much higher
than the unit cost of wages in Beaverton ($1.90). These costs play an important role in
accounting for the total costs of the 2nd Day Guaranteed product.
Note: You cannot actually put these branches side-by-side in the Cube Explorer View.
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Now that you have created a SAS Activity-Based Management model and you have
learned the basics of model analysis, you can begin designing and implementing your
own models.

Parcel Express Conclusions
Using SAS Activity-Based Management, Parcel Express was able to see how costs
flowed out of resource accounts to activities, and from activities to cost objects. In
modeling the flow of costs through its business processes, the company learned that the
2nd Day Guaranteed product, which managers had assumed was not performing as well
as the other products, was performing far worse than expected, and was actually losing
money across all channels.
An OLAP analysis of the model showed that the percentages of costs that flowed from
resource and activity accounts to cost object accounts was consistent across all product
categories. Therefore, pricing seemed to be the primary reason for the
underperformance. Another revelation was the amount of profit that was being made on
the other two products.
Management must now decide how much of a loss, if any, is acceptable for the 2nd
Day Guaranteed product. How will a price change affect volume? Is the higher profit on
other products enough to offset the loss on the 2nd Day Guaranteed product?
To assess the impact of changes to the pricing structure, Parcel Express can use SAS
Activity-Based Management to model possible future scenarios.

Additional Features
Many SAS Activity-Based Management features are not covered in this tutorial, or
they are only briefly covered. These features include:


importing data from other information systems



importing models from databases, XML, or Oros
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exporting models to databases or XML



sharing models



managing the ownership and permissions for items



publishing period/scenario associations



managing item properties



selecting currencies and exchange rates



working with internal units



creating stage attributes



variable quantity drivers



assigned idle cost



allocated cost



creating custom report templates



using the SAS Services API

To build effective and complete models for your organization, you will want to use
some of these additional features. Because your models will be much larger than the
Parcel Express Tutorial model, you might want to read about model size and
performance in the online Help. You can also consult the SAS Activity-Based
Management: User’s Guide at http://support.sas.com/documentation/onlinedoc/abm/.

What to Do Next
If you felt comfortable using the basic tools and techniques in this tutorial to build the
Parcel Express Tutorial model, use them on a simple project of your own.
SAS has a variety of products, including videotapes and training classes, that can
help you learn more about activity-based costing, management, and budgeting. In
addition, SAS can help you build models for your organization. If you need additional
information, contact your on-site SAS support personnel.

Your Turn
We welcome your feedback.
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