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This tutorial is intended to familiarize you with the basic modeling concepts that are 
used in SAS Activity-Based Management software. To complete the model-building 
process, perform this tutorial from beginning to end, exactly as it is presented. 

If you are new to the discipline of activity-based management (ABM), you might 
benefit more from this tutorial by first learning about the concept. A number of books 
and articles present excellent overviews. Even without this background, you will learn 
some basic ABM concepts by completing this tutorial. 

Even though you might know ABM, work through this tutorial to become familiar 
with SAS Activity-Based Management software—the concepts, terminology, commands, 
and dialog boxes. 

Tutorial Conventions 

This section discusses the conventions that are used throughout this tutorial. 

Fonts 

Font Represents Example 
Bold Menu > Command Select File > Save Model As. 

 User input Type Parcel Express Tutorial. 

 User interface elements, such as 
menus, dialog boxes, buttons, or list 
items 

Select Calculate Specific Modules 
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Procedures 

A procedure is a task that includes a set of numbered step-by-step instructions. Some 
steps are followed by a comment or an explanation. A section that has the following 
convention indicates a procedure: 

 

 Begin this tutorial 

1 Perform step one. 

Explanatory comments and illustrations, which explain and display results of 
proper completion of the preceding steps, are included between steps, when 
necessary. 

2 Perform step two. 

Notes and Tips 

A note indicates additional information. This is the convention for indicating a note: 

Note: Text that is set off in this manner presents important information. 

The format for a tip is similar. 

Illustrations 

Depending on your display settings and the number of times that you perform a step 
or procedure, the information in the windows might differ slightly from the illustrations 
that are presented in this tutorial. If you enter, then delete, and then re-create accounts 
and cost elements, the reference number might differ from the illustration. The 
displayed order of accounts might differ if you close and reopen the model. Consider the 
illustrations to be guides.  

Illustrations will usually show only the pertinent portions of the window that are 
being discussed. 

Terminology 

This tutorial refers to both the discipline of activity-based management (ABM), and 
the SAS Activity-Based Management solution. References to the discipline appear in 
lowercase or by abbreviation. The SAS solution is always capitalized. 

The discipline of activity-based management has a set of specialized terms. Some are 
used in this tutorial precisely because of their specialized meaning to the theory and 
practice of ABM. As these terms are introduced, this tutorial provides brief definitions. 
More complete definitions can be found in the CAM-I Glossary of Activity-Based 
Management. 
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Online Help 

The online Help is a comprehensive information system that has full-text search 
capabilities. It includes: 

 detailed step-by-step instructions to complete specific tasks 
 information about features 
 reference material 

Technical Support 

If you encounter problems that you cannot solve by reading the online Help or this 
tutorial, refer to the Worldwide Technical Support topic in the online Help. 

Additional Training and Tutorials 

Additional training and tutorials can be found at the SAS Web site and the companion 
Web site, http://www.bettermanagement.com. BetterManagement.com offers in-depth 
content about selected management concepts that are aimed at improving an 
organization’s performance. The BetterManagement.com site is a comprehensive source 
for performance management information.  

Topics that are covered on the BetterManagement.com site include value-based 
management, profitability analysis, strategic enterprise management, activity-based 
costing/management, business intelligence, and performance measurement. 
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Activity-based management is a discipline that enables companies to manage 
activities and processes as a means of improving organizational performance and the 
value that is received by the customer. By applying direct and indirect business costs to 
activities, the SAS Activity-Based Management solution enables managers to get a true 
understanding of the costs and profits that are associated with a product, customer, 
service, or business process. It supports ongoing profitability analysis, cost-management 
initiatives, shared services management, planning and budgeting efforts, and capacity 
optimization.  

The basic tool of ABM is activity-based costing (ABC), which more accurately tracks 
costs than traditional methods. Two critical limitations of traditional cost accounting 
systems are:  

 the inability to report individual product, service, customer, or process costs with a 
reasonable level of accuracy  

 the inability to provide useful feedback to management for the purpose of 
operational control 

Often, managers of complex organizations make important decisions about pricing, 
product and customer mix, resource allocations, and budgeting that are based on 
inaccurate and inappropriate cost and profitability information.  

Using SAS Activity-Based Management, you build one or more models that apply 
direct and indirect organizational costs to specific activities and processes. As a result, 
managers are able to see actual cost assignments and their bottom-line impacts from an 
operational perspective. Managers get a true understanding of the cause-and-effect 
relationships that link resources and processes to outputs. Thus, business planners can 
easily forecast resource requirements, create budgets, and optimize capacity usage.  
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The ABC Model and CAM-I Methodology  

ABC assumes that activities cause expenditure of resources, and that cost objects—
the results of activities or products and services that are produced—create the demand 
for activities.  

The Consortium of Advanced Management, International (CAM-I) develops methods 
to define critical business issues and to model effective strategies and solutions that 
resolve cost and resource management issues. SAS Activity-Based Management uses the 
CAM-I methodology for activity-based model development. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The Cost Assignment View 

An ABM system enables you to identify the activities that are performed, associate 
resources (expenditures) with those activities, and flow the cost of activities to cost 
objects. Resource drivers (typically, general ledger entries such as payroll, utilities, or 
materials) drive expenditures for activities. Activity drivers (such as the number of parts 
or setups) drive activity consumption for cost objects. Types of cost objects are: products, 
services, markets, distribution channels, engineering projects, or customers. 

The Process View 

An ABM system enables you to expose the relationship between why work is done, 
and the results of that work. In ABM terms, cost drivers drive the reason for activities 
and the effort that is needed to engage in the activities. Performance measures drive the 
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achieved results of activities—the efficiency, the required completion time, and the 
quality of the activities that were performed. 

SAS Activity-Based Management Models 

The basic container for ABM information in SAS Activity-Based Management 
software is the model. A meaningful ABM model reflects the organization that it is 
modeling, and uses terms that are familiar to the people who work there. The structural 
elements of a model should be named after elements that are present in the 
organizational environment. For example, a company’s general ledger account names, 
such as Wages and Depreciation, can be used to name and reference the resource 
accounts in the ABM model; the hierarchy of processes in a company can be applied to 
the activity accounts in the ABM model. 

Modules 

A model consists of three basic modules, which reflect the CAM-I definitions: 

Resource contains the expenses (or costs), such as salaries, materials, and 
depreciation, for the organization that is being modeled. 

Activity contains activities. Activities have accounts with cost elements. 
Costs might be assigned to activities from resource accounts or from 
other activity accounts. 

Cost Object contains cost objects (products, services, channels, or customers). 
These cost objects are assigned costs from resources, activities, other 
cost objects, or any combination of the three. 

These modules constitute the main structure of a model. A fourth module, external 
units, provides support for external costs. An external unit is an item, such as a part 
that is purchased from a supplier, whose cost is maintained outside of a SAS Activity-
Based Management model, but which needs to be accounted for in the model. You will 
build each of these modules with the use of dimensions. 

Dimensions 

A dimension is a category by which data is analyzed. For example, it might be useful 
to see sales figures when they are broken down by region, by customer, and by product. 
Each of these categories (region, customer, and product) represents a single dimension. 
Common dimensions are products, time, geography, customers, promotions, and sales 
channels.  

To break down information into a manageable or useful form, you can group items 
within a dimension to create a hierarchical structure. Each member of the hierarchy is 
then at a specific level in the hierarchy. You can name a dimension level as needed. 
Dimension levels are a powerful modeling tool because they allow you to ask questions 
at a high level, and then expand a dimension to reveal more detail. 
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Types of Dimensions 

There are two types of dimensions in a model: structural and attribute. 

Structural dimensions are the building blocks of modules. For example, the typical 
structural dimensions of the resource module are region, organization, or general ledger; 
the activity module might be structured according to the region or organization 
dimension, along with an activity dimension. 

Dimension attributes provide information that is useful, but not required, to uniquely 
identify the model structure. Using dimension attributes, you can classify or organize 
information in ways that will help you analyze model results. The SAS Activity-Based 
Management OLAP tool makes no distinction between dimension attributes and 
structural dimensions. 

Basic Steps to Building a Model 

The following list of steps summarizes the method that you will use in this tutorial for 
setting up and analyzing information in SAS Activity-Based Management models. This 
method is described completely in the lessons and exercises in the tutorial. 

1 Create a paper plan. 

Collect resource (expenditure), activity, and cost object (products and services) 
information to design your model. Determine the goal of the model (what kind of 
information you want to get from it), and determine the appropriate dimensions, 
periods, and scenarios to achieve that goal. 

2 Create periods and scenarios. 

Create the periods and scenarios to be used by your model. (Periods and scenarios 
are shared by all models on a server.) 

3 Create dimensions, modules, and accounts. 

Create the dimensions and dimension members that you will use to build the 
modules. Build the resource, activity, and cost object modules by defining the 
accounts (dimension intersections) of each module. 

4 Define attributes.  

Define and add attributes to the appropriate accounts. 

5 Define drivers. 

Define drivers that measure the consumption of expenses and activities. 

6 Make assignments. 

Select the relevant driver for each source account. Make cost assignments from 
source accounts to destination accounts. 

7 Calculate costs. 

Calculate costs and display the results. 
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8 Add bills of costs. 

Define and link external unit costs to accounts. 

9 Enter output, sales, and revenue data. 

Enter output quantities, determine unit costs, enter sales volumes, and calculate 
profit. 

Parcel Express 

Parcel Express is a fictitious organization that is using activity-based management to 
determine whether this method more clearly conveys costs and profitability information 
than traditional costing methods. 

A later chapter outlines the main business activities of Parcel Express and the 
company’s goals in using SAS Activity-Based Management. 
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The SAS Activity-Based Management solution is Web-enabled. Its server typically 
resides on your company’s intranet and the client software resides on your computer. 
This tutorial assumes that you have installed the software on your computer, and that 
you are familiar with basic software usage techniques, such as using menus, dialog 
boxes, and other windows and Web controls. 

Logging In 

You log in to SAS Activity-Based Management from the Start menu.  

 

 Log in to SAS Activity-Based Management 

1 Select Start > Programs > SAS > Activity-Based Management 6.x > 
Activity-Based Management Solution. 

You see the Connect dialog box. The software version number might vary. 
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2 If your current network login information is not valid for the server, clear the Log 
in using my current credentials option. 

3 From the Server drop-down list, select a server, or type the server name. 

4 If you cleared the Log in using my current credentials option: 

a Type your domain and User name. 

For example, HQ\JohnD. 

b Type your Password.  

As you type each character, an asterisk (*) appears in its place.  

5 Click OK. 

You see the SAS Activity-Based Management home page. 

The Home Page 

The following window shows the SAS Activity-Based Management home page.   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Read the online Help (click ) for descriptions of the home page and Workspace 
Manager. Any existing models to which you have access rights appear in the Models 
folder or its subfolders. You can create shortcuts to your models in the My Shortcuts 
folder. 
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 Change to Model mode 

1 On the home page, click  

You see a model page. If you have just started SAS Activity-Based Management, 
you will see the Model home page. If you have been working with a model, you will 
see the model page you were working on last. 

Model Home Page 

The Model home page lists the models to which you have access rights. From this 
page, you can open, create, or delete models. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Model Mode and Module Pages 

When you open a model, you usually go to the Resource module page, which is just 
one page among many pages that constitute Model mode. If you change to a different 
mode, such as OLAP or Reports mode, and then return to Model mode, you go to the 
model page you were working on last. 

You perform all of the tasks that are associated with building a model, entering data, 
and calculating costs in Model mode. Many of the tasks rely on the use of dialog boxes 
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(which enable you to manage specific aspects of the model) and wizards (which guide 
you through certain procedures). In many cases, you will enter data directly into a 
column on one of the Model mode pages. 

The following window shows the Resource module page of the model that you will be 
building in this tutorial. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this tutorial, you will be directed to use the menus most of the time. Occasionally, 
you will be instructed to use a button or an icon. As you become more familiar with the 
software, you can choose whichever method you prefer to initiate tasks. Read the online 
Help for complete descriptions of toolbar buttons and icons. 

Assignments Panes 

One of the main objectives of activity-based management is to accurately assess how 
company costs are consumed; for example, how costs flow from general ledger accounts 
to activities to products and services. SAS Activity-Based Management provides you 
with several graphical tools to help you see and manage this flow. Among these tools are 
the left and right assignments panes, which allow you to view and assign costs from one 
module to another and within a single module.  

By default, each module opens in a single-pane view, the primary pane. The primary 
pane contains the structure of a module, which includes the dimension intersections 
(accounts) and each account’s cost elements. You can open the left assignments pane to 
see the accounts from which costs flow (sometimes called source accounts). You can open 

A module’s structure comes from its dimensions. 
The accounts, represented by the layered cube 
icons, are intersections of dimensions. 

You can initiate most tasks from the menus or by using toolbar buttons and icons. 

status bar 
You can close the taskbar to allow more space for the model. 
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the right assignments pane to see the accounts to which costs flow (sometimes called 
destination accounts). 

The following display shows the Activity module of the model that you will be building 
in this tutorial. All three panes are open. 

 

 

 

 

 

 

 

 

 

 

In this display, the arrows that point from the left assignments pane to the primary 
pane indicate costs that are flowing into the Beaverton Inspect account in the Activity 
module. The arrows that point from the primary pane to the right assignments pane 
indicate costs that then flow from the Beaverton Inspect account into other accounts. 

In this tutorial, you will use the right assignments pane to assign costs from one 
account to another. 

Column Layouts 

A column layout is a collection of displayed columns, column formats, and the column 
order on the module pages. You can customize a column layout to display various 
information, such as properties, attributes, periods, and scenarios. When you have 
customized it, you can save a column layout by name so that you can retrieve it later. 
You see saved column layouts in the Workspace Manager and in the Column Layout list 
on the Resource, Activity, Cost Object, and External Units module pages. 

When you save a column layout, the following information is saved: 

 description 
 column headings 
 information that is displayed in each column and the period/scenario association 

to which it applies 
 format for each column and order of the columns from left to right 
 model 
 column widths 

Left assignments pane Primary Right assignments pane 
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The following information is not saved: 

 number of assignments panes that appear on the page 

Tip: All column layouts that are saved by all users on the same server are listed in the 
Workspace Manager. Therefore, your organization might want to set up some guidelines 
for saving and naming column layouts. 

Properties, Attributes, and Dimensions in Column Layouts 

The columns of a column layout are derived from the following model elements: 

Properties A property is a model item that holds values that are entered by a 
user or calculated by the software. Examples of properties are: Cost, 
Unit Cost, Output Quantity, Sold Quantity, and Profit. The more 
familiar you become with SAS Activity-Based Management 
modeling, the more you will be able to use properties creatively to 
achieve your analysis goals. 

Attributes An attribute is a user-defined label or numeric value that is attached 
to an account. Each attribute is a particular characteristic that is 
used for analysis. An attribute conveys information about the item to 
which it is attached. 

Dimensions A dimension is a category by which data will be or is analyzed. You 
define the dimensions of your model when you use the New Model 
Wizard. 

Reports 

SAS Activity-Based Management allows you to use predefined report templates or to 
create your own reports. 

 

 Change to Reports mode 

1 From the home page, click  

You see the Reports home page. 

OLAP Cubes 

A cube is the main object in OLAP, a technology that provides fast access to data in a 
model. A cube contains a set of data that is constructed from a subset of model data and 
that is organized and summarized into a multidimensional structure. SAS Activity-
Based Management cubes are standard OLAP cubes. 
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You use SAS Activity-Based Management software to connect to and interact with the 
cubes on a SAS Activity-Based Management server. For each model, you can generate 
cubes that you can manipulate on the OLAP page to interactively analyze business data. 

 Change to OLAP mode 

1 From the home page, click  

You see the OLAP home page. 
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Activity-based management projects begin with a plan. After you have determined the 
analysis goals of the model and defined the dimensions that will enable that analysis, 
you can begin data collection. Information concerning resources (expenditures), 
activities (tasks), and cost objects (products and services produced) provides the basis for 
building an ABM model. 

Building by Design 

Before beginning to build a model, evaluate and make preliminary decisions about the 
design of the model. Just as a building contractor needs a plan before beginning to build 
a house, a model builder needs a plan for the structure of a model before beginning to 
build the model.  

Factors that influence a model’s design include: 

 goal of the model—the operational or strategic questions the activity-based 
management program is intended to answer 

 data already collected and its format 
 data needed that is not being collected 
 types of reports and OLAP cubes that will be needed 

This tutorial uses a simple design and focuses on the steps for building a model. The 
design of the model and the effort that it takes can be simple or complex. The model 
builder will need to understand these factors, and other factors that are unique to each 
modeling situation, to arrive at a design. The model used with this tutorial is named 
Parcel Express. The Parcel Express Tutorial case study provides fictitious company 
data. 

C H A P T E R  
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The Parcel Express Tutorial Model 

Company Background 

Parcel Express began operations in Beaverton, Oregon, in 1990 as a ground parcel 
delivery service. In 1995, with 125 employees and $1 million in sales, the company 
began expanding to overnight delivery and second-day delivery.  

In the first quarter of 2004, total sales revenue was approximately $5.5 million. Costs 
for the same period were about $3.8 million, for a profit of about $1.7 million. 

ABM Goals 

Parcel Express hopes to use SAS Activity-Based Management to trace operating costs 
to individual products and services so that the overall costs and profit of each product 
and service can be determined and improved. Parcel Express is concerned that the 
current accounting system, which divides the business into about 10 product groupings, 
might not accurately reflect the different costs of doing business for the two express 
services: Overnight Express and 2nd Day Guaranteed.  

Management wants to know how each product is performing. The company’s 
competitors have dominated in the second-day delivery market, and management has 
recently slashed prices on that product. Sales volumes have increased as a result, but 
it’s unclear how much profit Parcel Express is making, if any. The company would like 
to meet a target profit margin of at least 10% on the 2nd Day Guaranteed product, and 
at least 25% on all others. It is willing to adjust pricing or modify processes to reach that 
goal. 

Model Structure 

Parcel Express has assembled a SAS Activity-Based Management modeling team 
whose members have become familiar with ABM concepts and the structure of ABM 
models. Together, they have determined that the following module structure most 
accurately reflects the way Parcel Express conducts its operations. 

Resource Module 

Resources will be structured by region and general ledger account. The two main 
processing plants are Beaverton and Eugene, Oregon. General ledger accounts include: 

 wages (salary and overtime) 
 operating expenses and office supplies 
 equipment depreciation 
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Activity Module 

Activities will be structured by region and activity. The activities Parcel Express has 
chosen to model are: 

 branch collection 
 sorting and inspection 
 air and land distribution 
 resolution of customer complaints  

The Eugene facility does not have an air distribution function, so it will have one less 
account than Beaverton. 

Cost Object Module 

Parcel Express needs to be able to track not only the costs of products and services, 
but the costs of its channels as well. Therefore, Parcel Express will organize the cost 
object module by channel and products and services. 

The three channels are: 

 drop box 
 walk in 
 commercial pick up 

The three products and services are: 

 Standard Ground 
 2nd Day Guaranteed 
 Overnight Express 

External Units Module 

Each product has packaging costs that must be accounted for. Materials for packaging 
will be tracked as external units, including: 

 envelopes 
 flats 
 boxes 

Data Collection 

The following data will be collected for entry into the ABM model: 

Wages Wage information, including salaries and overtime, will 
come from the general ledger system. Wages will be 
entered as dollar amounts, and assigned to activities 
according to the number of full-time employees, or FTEs 
(Full-Time Equivalents), who are associated with an 
activity. 
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Operating Expenses Operating expenses and supply costs will come from the 
general ledger. These costs will be assigned to activities 
in dollar amounts. 

Equipment Expenses Equipment expenses, including depreciation, will come 
from the general ledger. These costs will be assigned by 
percentage. 

Collection and Distribution Branch managers will collect data from their control 
systems regarding the number of packages that are 
collected, moved to warehouses, sorted, inspected, and 
distributed by land and air. Accurate numbers here are 
critical to the success of the modeling effort. Activity 
accounts will assign costs by number of packages. 

Complaints The number of customer complaints will be collected by 
branch managers. Costs that are associated with 
complaint resolution will be assigned according to the 
number of complaints that re received.  

Revenue Revenue will come from the sales accounting system. 
Revenue will be associated with cost objects according to 
the sales quantity for each product. 
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A period is an interval of time in which activity-based management data is 
maintained. A period can represent any unit of time: a month, a quarter, a year, and so 
on. For example, if your organization chooses to enter data each month, the marketing 
payroll cost is the amount of payroll for one month. A model can hold data for different 
periods, but only one period at a time is active. The default periods are 2002 and 2003. 
You can create a hierarchy of periods, such as FY2003 > Q1 > January. By default, each 
level is given a name, such as Period L1. 

You can compare model data that you have entered for different periods. For example, 
you can enter costs into a model on a month-by-month basis and examine the costs for 
March versus the costs for February.  

Scenarios are generally used to manage different variations of data within a period. A 
scenario can be any set of data: actual, budget, aggressive plan, conservative plan, and 
so on. The default scenarios are Actual and Budget. You can create a hierarchy of 
scenarios, such as Budget > Aggressive. By default, each level is given a name, such as 
Scenario L1. However, these names are not descriptive when you generate cubes. So, 
you can rename a default scenario level. 

Creating a Period 

Parcel Express analyzes costs by quarters, so the model will be structured to analyze 
quarter-on-quarter costs. The period that you will create is 2004 Q1.  

 

 Create a period 

1 Select Tools > Manage Periods. 
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You see the Manage Periods dialog box. 

 

 

 

 

 

 

 

 

 

 

 

2 Select the 2004 period and click New. 

Note: These periods might already exist on your server. If this is the case, create 
new periods under 2005. 

You see the New Period dialog box. 

 

 

 

 

 

 

 

 

 

3 For Name, replace New Period with 2004 Q1. 

4 For Reference, type 04Q1. 

5 Select a Start date of January 1, 2004. 

6 Select an End date of March 31, 2004. 

Note: SAS Activity-Based Management enables you to enter descriptions for the 
items that you create. In this tutorial, you will not enter descriptions. 

7 Click OK. 
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You see the new period added to the list below the 2004 period. 

8 Create three more periods that are named 2004 Q2, 2004 Q3, and 2004 Q4. 
Specify appropriate date ranges and references for each period. All period 
references must be unique. 

When you are done, you should see the following periods in the Manage Periods 
dialog box: 

 

 

 

 

 

 

9 Click OK. 

Creating a Scenario 

Parcel Express wants to compare actual costs that it incurred on a quarterly basis. It 
will analyze the profit and loss trends in these costs to make decisions about resource 
allocation, process control, and pricing. For these purposes, the Actual default scenario 
is adequate. 

However, so that you gain experience, assume that the company had specific profit 
targets that it wanted to model in SAS Activity-Based Management. You could create a 
scenario named Target. 

 

 Create a scenario 

1 Select Tools > Manage Scenarios. 

You see the Manage Scenarios dialog box. 
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2 Select All Scenarios and click New. 

You see the New Scenario dialog box. 

 

 

 

 

 

 

 

3 For Name, replace New Scenario with Target. 

4 For Reference, type TARGET. 

5 Click OK. 

You see the new scenario added to the list below the Actual scenario. 

6 Click OK. 

Deleting Periods and Scenarios 

You can delete a period or scenario from the Manage Periods or Manage Scenarios 
dialog boxes, respectively. Select the period or scenario and click Delete. You are 
prompted to confirm the deletion. 
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6 
Creating Dimensions and Dimension 
Members 
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Before creating the structure of a module, you must define the dimensions that you 
will use to build that structure. As specified in the paper plan, the dimensions that you 
will define for the Parcel Express Tutorial model are: 

Module Dimensions 
Resource Region 

General Ledger 

Activity Region 

Activities 

Cost Object Region 

Channel 

Products and Services 

External Unit Materials 

Profit Analysis Region 

Channel 

Products and Services 

Creating Dimensions with the New Model Wizard 

The main purpose of the New Model Wizard is to establish the dimensions of your 
model. These are the dimensions that you will use to create accounts and the structure 
of the modules. Most important, these are the dimensions that will eventually enable 
you to generate meaningful cubes and to analyze the profits and losses that result from 
your business activities. 

Now, you will create the model named Parcel Express Tutorial. The model’s monetary 
data will be in U.S. dollars. 
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 Start the New Model Wizard 

1 Select File > New > Model. 

You see Step 1 of the New Model Wizard.  

 

 

 

 

 

 

 

 

 

 

 

 

 

The New Model Wizard contains 10 steps. If you accept the default dimensions for 
your model, you will not perform every step. For this tutorial, you will define your 
own dimensions and perform every step in the New Model Wizard. 

2 For the name, type Parcel Express Tutorial. 

Note: Each model name must be unique on a SAS Activity-Based Management 
server. 

3 Verify that the base currency is US Dollar($). 

4 Click Next. 

You see Step 2 of the New Model Wizard. 

 

 Select a starting period and scenario 

1 Expand 2004 and select the 2004 Q1 period. 

 

 

 

 



 Creating Dimensions and Dimension Members      Creating Dimensions with the New Model Wizard 29 

 

2 Select the Actual scenario. 

A period/scenario association identifies a specific period and scenario combination; 
in this case, 2004 Q1/Actual. All model data must reside in a period and must 
apply to a scenario. An association represents a period-scenario pair. 

3 Click Next. 

You see Step 3 of the New Model Wizard. 

 

 Select the method for defining dimensions 

1 Verify that the Select or define the dimensions for each module option is 
selected. 

This option enables you to create new dimensions, rearrange dimensions, or use 
the default dimensions for some modules, but not others.  

 

 

 

 

 

 

 

 

 

 

 

 

2 Click Next. 

You see Step 4 of the New Model Wizard. 

 

 Define the resource module dimensions 

1 In the Selected dimensions list, select the Organization dimension. 

Next, you will remove this dimension from the Selected dimensions list. 

2 Click  

The dimensions that you will create for 
the tutorial are: 
 

Module Dimensions 
Resource Region 

General Ledger 

Activity Region 

Activities 

Cost Object Region 

Channel 

Products and Services 

External Unit Materials 

Profit Analysis Region 

Channel 

Products and Services 

By contrast, the default dimensions 
are: 
 

Module Dimensions 
Resource Organization 

General Ledger 

Activity Organization 

Activities 

Cost Object Customer 

Products and Services 

External Unit Materials 

Profit Analysis Customer 

Products and Services 
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You see the Organization dimension move from the Selected dimensions list to 
the Available dimensions list. 

3 Click New. 

You see the New Dimension dialog box. 

 

 

 

 

 

4 For Name, type Region. 

5 For Reference, use Region. 

6 Click OK. 

The New Dimension dialog box closes and you see that the Region dimension has 
been added to the Available dimensions list. 

7 Select the Region dimension and click  

You see the Region dimension move from the Available dimensions list to the 
Selected dimensions list, below the General Ledger dimension. The order of 
dimensions in the list determines the hierarchy of dimensions in the module. In 
this case, Parcel Express wants to organize its resources by Region, and then by 
General Ledger. So, you will have to move Region above General Ledger. 

8 Select the Region dimension and click  

 

 

 

 

9 Click Next. 

You see Step 5 of the New Model Wizard. 

Now, you will define the dimensions for the activity module by using these same 
techniques. Refer to the previous procedure if you need clarification on a step. 

 

 Define the activity module dimensions 

1 Move the Organization dimension to the Available dimensions list. 

2 Move the Region dimension to the Selected dimensions list. 
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3 Move Region above Activities. 

The Selected dimensions list should appear as follows: 

 

 

 

 

4 Click Next. 

You see Step 6 of the New Model Wizard. 

 

 Define the cost object module dimensions 

1 Move the Customer dimension to the Available dimensions list. 

2 Move the Region dimension to the Selected dimensions list. 

3 Move Region above Products and Services.  

4 Create a new dimension named Channel that has a reference of Chnnl. 

5 Move the Channel dimension to the Selected dimensions list. 

6 Move Channel above Products and Services. 

The Selected dimensions list should appear as follows: 

 

 

 

 

7 Click Next. 

You see Step 7 of the New Model Wizard. 

 

 Define the external units module dimensions 

1 Verify that Materials is the only dimension in the Selected dimensions list. 

2 Click Next. 

You see Step 8 of the New Model Wizard. 

 

 Define the profit analysis dimensions 

1 Move the Region dimension to the Selected dimensions list. 
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2 Move the Channel dimension to the Selected dimensions list. 

3 Move Region above Products and Services. 

4 Move Channel above Products and Services. 

The Selected dimensions list should appear as follows: 

 

 

 

 

5 Click Next. 

You see Step 9 of the New Model Wizard. 

 

 Review the summary and finish the New Model Wizard 

1 Review the Summary of Information and dimensions in each module, as shown: 
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If any of the information in the summary is incorrect, click Back to move to the 
page that requires changes. After making the corrections, click Next to return to 
the summary. 

2 Click Finish. 

You see the Dimensions page that now has the following dimensions: 

 

 

 

 

 

 

These dimensions are the basic building blocks that you will use to construct the 
modules of your model. First, however, you must create the members of each 
dimension. 

Note: The order of the dimensions can vary if the dimension members are changed 
or if the model is imported. 

Creating Dimension Members 

Dimension members are the unique elements of a dimension level. For example, the 
Region dimension of the Parcel Express Tutorial model will have levels that include 
countries, states, and cities. Beaverton and Eugene are dimension members at the same 
level of the Region dimension. 

 

 Create dimension members 

1 On the Dimensions page, select Region. 

2 Select Edit > New Dimension Member. 
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You see the New Dimension Member dialog box. 

 

 

 

 

 

 

 

 

 

 

 

 

3 Click Add. 

4 For Name, type USA. 

Tip: You see that the Reference field is automatically set to the name that you 
type. In this tutorial, you will not change the references of dimensions; however, 
for the models that you create for your company, you might want to devise a 
standard referencing methodology.  

5 Click OK. 

You see that the USA dimension member has been added below Region. 

6 Select the USA dimension member. 

7 Create a new dimension member under USA named Oregon. 

Note that the level is Level2. The reason for this is that you are adding a 
dimension member below a Level1 dimension member. 
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8 Using the techniques that you have learned, create the following dimension 
members: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note: You will not create dimension members for the Materials dimension yet. You 
will add those dimension members when you create bills of costs. 
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7 
Creating Modules and Accounts 
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Creating Activity Accounts   41 
Building the Cost Object Module Structure   42 

Omitting a Dimension from an Account   42 
Creating Cost Object Accounts   43 
 

An account is the basic repository of costs in a model. You create an account in SAS 
Activity-Based Management by defining an intersection between dimension members. 
For example, in the Parcel Express Tutorial model, you will create an account for 
tracking the costs of inspecting packages in Beaverton, OR. You create this account by 
defining an intersection between Region and Activity dimension members, as shown 
here: 

Region > USA > Oregon > Beaverton 

x 

Activity > Regional Sorting > Inspect 

Shorthand for the resulting account, or dimension intersection, is Beaverton x 
Inspect. 

The costs of an account are derived from cost elements, which can either be added 
directly to the account or assigned from other accounts. 

Building the Resource Module Structure 

Start by creating a structure to hold the resource costs in the model. 

 

 Create resource accounts 

1 To open the resource module, select Model > Resource Module. 

2 Select Edit > New Account. 

You see Step 1 of the New Account Wizard.  

The Dimensions area contains the dimensions of the resource module. The 
Accounts area will contain the accounts that you create. 
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3 Expand Region to display all of its dimension members. 

4 In the Dimensions list, select the following dimension members: 

Beaverton 

Eugene 

Wages 

Operating Expenses 

Equipment Expenses 

5 Verify that leaf dimension members only is selected in the Create accounts 
using field. 

 

 

 

 

 

 

 

 

 

 

 

 

 

6 Click Add. 

You see that the following accounts have been added to the Accounts list: 

 

 

 

 

 

7 Click Next. 

You see Step 2 of the New Account Wizard. Here, you will add the cost elements 
and costs of each account.  
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Tip: The system has automatically generated a unique name and reference for 
each account. The names and references that you see will be different from those 
shown in the window. These names and references are used in reports and 
operational summaries, but they do not appear elsewhere on a page, unless you 
add columns to display them. Your company can decide whether to use the system-
generated names or to use a naming and referencing methodology. If your models 
are extremely large, it will probably be more convenient to use system-generated 
account names and references. 

 Add cost elements and costs 

1 Select the Beaverton x Wages account and click Add Cost Element twice. 

You see that two cost elements have been added to the account table. The names 
and references of these cost elements are system-generated. In the account table, 
you can add costs and change the names and references of cost elements. 

2 Change the names and references of the two cost elements that you added and 
enter their costs, as follows: 

Name Reference Cost 
Salaries BS 1,563,000.00 

Overtime BOT 75,600.00 

Note: In large models, costs might be imported from other sources, such as a 
database. In that case, you could create the cost elements, but leave the costs 
empty. 
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3 Using the techniques that you have learned, create cost elements and enter costs 
as follows: 

Account Cost Elements Cost 
Element 
Reference 

Cost 

Beaverton x Operating 
Expenses 

Operating Expenses  

Office Supplies 

BOE 

BOS 

228,000.00

10,000.00 

Beaverton x Equipment 
Expenses 

Equipment Depreciation BED 54,300.00 

Eugene x Wages Salaries  

Overtime 

ES  

EOT 

1,298,000.00

110,000.00 

Eugene x Operating Expenses Operating Expenses  

Office Supplies 

EOE  

EOS 

263,000.00

8,000.00 

Eugene x Equipment Expenses Equipment Depreciation EED 38,000.00 

4 Click Next. 

You see Step 3 of the New Account Wizard. This step contains a summary of the 
accounts, cost elements, and costs you are about to create. 

5 Click Finish. 

You see that the accounts have been added to the resource module. 

 

 

 

 

 

 

 

 

 

 

 

 

 

The system automatically rolls up costs from cost elements, to accounts, to higher-
dimension levels. 
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Building the Activity Module Structure 

An activity is a task that consumes resources. Examples of activities include setting 
up a machine to produce a particular part, scheduling production of a certain number of 
products, and inspecting a batch of parts. In a model, you identify activities and 
calculate their costs.  

Creating Activity Accounts 

In the activity module, you will create activity accounts. 

 

 Create activity accounts 

1 To open the activity module, select Model > Activity Module. 

2 Select Edit > New Account. 

You see the New Account Wizard. 

3 Using the New Account Wizard, create the following accounts: 

Note: Do not create cost elements. Costs will be assigned to these accounts from 
other accounts. 

Note: After creating the accounts in Step 1 of the New Account Wizard, click 
Finish. Because you are not creating cost elements, there is no need to perform 
Steps 2 and 3. 

Dimension Intersection  
Personnel Intensive Activities Beaverton x Resolve Customer Complaints 

Beaverton x Expedite Package Shipments 

Local Collection Beaverton x Move to Warehouse 

Local Processing Beaverton x Sort  

Beaverton x Inspect 

Regional Distribution Beaverton x Air Distribution 

Beaverton x Land Distribution 

Personnel Intensive Activities Eugene x Resolve Customer Complaints 

Eugene x Expedite Package Shipments 

Local Collection Eugene x Move to Warehouse 

Local Processing Eugene x Sort  

Eugene x Inspect 

Regional Distribution Eugene x Land Distribution 

Note: There is no air distribution from Eugene. 
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After completing the steps of the New Account Wizard, you see the following activity 
module structure: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note: You have not entered cost elements for these accounts, and no costs have been 
assigned yet, so cost is $0.00. 

Building the Cost Object Module Structure 

The cost object module will hold information about Parcel Express Tutorial’s products 
and services. Its dimensions are Channel and Products and Services. 

Omitting a Dimension from an Account 

You can create accounts that omit one or more dimensions of a module. In the cost 
object module of the Parcel Express Tutorial model, you will create accounts that have a 
Channel dimension member, but no Products and Services dimension member, and vice 
versa. The purpose of these omissions is to track the unique costs of a channel that are 
unassociated with any product, and to track the unique costs of a product that are 
unassociated with any channel. To omit a dimension from an account, you select the No 
option in the New Account Wizard. 
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Examples of accounts that omit a dimension are: 

Drop Box x No <Products and Services> 
(tracks unique costs that are associated with the Drop Box channel) 
No <Channel> x 2nd Day Guaranteed 
(tracks unique costs that are associated with the 2nd Day Guaranteed product) 

Creating Cost Object Accounts 
 

 Create cost object accounts  

1 Using the techniques that you have learned, create the following accounts in the 
cost object module for each regional office—Beaverton and Eugene:  

Note: Do not create cost elements. Costs will be assigned to these accounts from 
other accounts. 

Dimension Intersection 
Drop Box x 2nd Day Guaranteed 

Drop Box x Overnight Express 

Drop Box x Standard Ground 

Drop Box x No <Products and Services> 

Walk In x 2nd Day Guaranteed 

Walk In x Overnight Express 

Walk In x Standard Ground 

Commercial Pick Up x 2nd Day Guaranteed 

Commercial Pick Up x Overnight Express 

Commercial Pick Up x No <Products and Services> 

No <Channel> x 2nd Day Guaranteed 

No <Channel> x Standard Ground 

 



44 Building the Cost Object Module Structure      Chapter 7 

Note: You can create these accounts all at once by checking the leaf dimension 
members that are shown in the following display. This quick method, however, 
results in creating two meaningless accounts that you can delete afterward: 

Beaverton x No <Channel> x No <Products and Services> 

Eugene x No <Channel> x No <Products and Services> 
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After you have created these accounts, you see the following cost object module 
structure: 
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8 
Creating Attributes 

 

 
Types of Attributes   47 

Text Attributes   47 
Numeric Attributes   48 
Calculated Numeric Attributes   48 
Dimension and Dimension Member Attributes   49 
Boolean Attributes   49 

Creating Attributes   49 
Creating a Column Layout   52 
Entering Attribute Values   55 

 

An attribute is a label or identification tag that is attached to an account or roll-up 
account. The attribute conveys information about the object to which it is attached. 

Attributes have many purposes. You can use them to do the following: 

 group activity-based management data to simplify report preparation and 
interpretation 

 create different dimensions of data 
 report similar cost categories across cost centers 
 classify cost components as fixed or variable, value-added or non-value-added 
 use them in the definition of a calculated driver 

Types of Attributes 

There are four attribute types: 

 text 
 numeric 

 calculated 
 dimension 
 Boolean 

Text Attributes 

A text attribute describes model information and enables you to categorize, select, and 
subtotal information in a report. Activities can be grouped by summary-level processes, 
such as detailed manufacturing activities rolling up to “manufacturing,” and detailed 
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distribution activities rolling up to “distribution.” The names of these higher-level 
processes are defined as text attributes and are attached to their respective activities.  

Other examples of text attributes include: 

 value-added categories (high, medium, low) that are attached to activities 
 fixed cost/variable cost that is attached to resources—enables you to group activity 

or cost object costs by fixed and variable cost components 
 cost object groupings that are used to roll up products by product family, brand, 

market segment, or package type, or to group customers by region, channel, or 
salesperson 

Numeric Attributes 

A numeric attribute enables you to enter data that is not entered or otherwise 
generated in a model. 

Typically, numeric attributes are measures or quantities of units that contribute to 
the total cost of an activity, such as number of cases, number of pounds, number of 
orders, or number of times an activity is performed. 

You can establish numeric attributes as performance measures for special reporting 
purposes, such as tracking productivity (number of inputs or rejects, cycle time, and 
quality), or classifying information (level of complexity or number of subassemblies).  
Use the Default Value field under the Advanced tab to define data that is specific to 
that attribute. 

 

 

 

 

 

 

 

 

 

 

 

 

Calculated Numeric Attributes 

Numeric attributes can be calculated. Calculated numeric attributes are also user-
defined attributes, but they rely on a formula to express their characteristics. This 



 Creating Attributes      Creating Attributes 49 

formula is developed by the user to capture unique business data. Calculated numeric 
attributes can be used in a driver definition. 

Dimension and Dimension Member Attributes 

A dimension attribute reflects a dimension, and a dimension member attribute 
reflects a dimension member. 

Boolean Attributes 

A Boolean attribute stores a Boolean value (True or False). 

Creating Attributes 

You will create a numeric attribute and a dimension attribute. 

 

 Create a numeric attribute 

1 Select Model > Attributes Page. 

2 Select Edit > New Attribute. 

You see the New Attribute dialog box. 

 

 

 

 

 

 

 

 

 

 

Name Reference Type Unit of Measure 
Number of Inspections Num of Ins Numeric Inspections 

3 For Name, type Number of Inspections. 

4 For Reference, type Num of Ins. 

5 Select an Attribute type of Numeric. 
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6 For Unit of Measure, type Inspections. 

7 Click OK. 

You see that the Number of Inspections attribute has been added to the list. 

8 Create three more numeric attributes. 

Name Reference Type Unit of Measure 
Inspections Passed I_P Numeric Units Passed 

Completed Expedite 
Requests 

Completed Expedite 
Requests 

Numeric Completed Requests 

Average Time to 
Expedite 

Average Time to Expedite Numeric Hours 

 
 

 Create a calculated numeric attribute 
 

Name Reference Type Unit of 
Measure 

Formula 

Cost per 
Inspection 

Cost per 
Inspection 

Numeric 
Calculated 

Dollars Cost / “No. of 
Inspections” 

1 Select Edit > New Attribute. 

2 For Name, type Cost per Inspection. 

3 For Reference, type Cost per Inspection 

4 Select an Attribute type of Numeric. 

5 Select Dollars for Unit of Measure. 

6 Select the Advanced tab. 
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7 Verify that the period is 2004 Q1 / Actual. 

8 Select the Calculated check box. This allows you to enter a formula. 

9 Click Equation Editor. 

You see the Equation Editor dialog box. 

 

 

 

 

 

 

 

 

 

 

 

10 The cost of inspection would be derived from a formula of cost divided by the 
number of inspections. Create this formula by double-clicking on each element. 
The formula will appear in the Equation area.  

11 Click Test to verify the syntax of the formula. 

12 Click OK to dismiss the message box. 

13 Click OK to accept the formula. 

14 Click OK to create the attribute. 

15 Create a calculated numeric attribute for Percent of Inspections Passed.  

Name Reference Type UoM Formula 
Percent of 
Inspections Passed 

Percent of 
Inspections 

Numeric 
Calculated 

Percentage Inspections 
Passed / No. of 
Inspections 

 

 Create a dimension attribute 

Name Reference Type 
Fixed_Variable FV Dimension 

1 Select Edit > New Attribute. 
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2 For Name, type Fixed_Variable. 

3 For Reference, type FV. 

4 Select a Type of Dimension. 

5 Click OK. 

6 Select the Fixed_Variable attribute. 

7 Create the following two dimension attributes: 

Name Reference Type 
Fixed F Dimension Member 

Variable V Dimension Member 

You see that the Fixed_Variable dimension and its two dimension members have 
been added to the list of your model’s dimensions. 

 

 

 

 

 

 

Creating a Column Layout  

To view the attributes in the model, add a column. For the Parcel Express Tutorial 
model, you will create a column layout named Cost Assignments. Initially, you will 
define the column layout for the activity module. Later, you will add columns to the 
layout for the other modules to create a cost assignment column view.  

 

 Add a column to show an attribute 

1 Select Model > Activity Module. 

2 Select Model > Column Layout > Edit Columns. 
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You see the Column Layout dialog box. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The columns that you see in the Displayed columns list refer to the layout for a 
specific pane in a specific module. In the illustration, you see the column layout for the 
Primary pane of the Activity Module. To change the column layout for a different 
pane or module, select that pane or module. The Inspections Passed column layout 
that you create in this tutorial will ultimately contain layouts for several modules and 
panes. 

Note: A column layout is a read-only view of columns that already exist in tables in 
your model. Adding or removing a column from a column layout does not add or remove 
a column from a table; nor, for that matter, does creating a column layout create a table 
or add or remove columns from any table. 

 

 Define the column layout for one pane1. 

1 Verify that the Primary pane tab is selected. 

2 From the Displayed columns list, select Display Reference. 

3 Click Remove. 

You see that Display Reference has been removed from the list of Displayed 
columns. Removing this column from the layout will provide more screen space 
for columns that are relevant to making driver assignments. 

Pane to which the layout applies Model data that can be displayed in 
columns in the layout 

Module to which the layout applies Columns in the layout 
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4 From the Properties, Attributes, and Dimensions list, select Inspections 
Passed (under the Attributes folder).  

5 Click Add. 

You see that Inspections Passed has been added to the Displayed columns list. 

 

 Save the column layout 

1 Click Save As. 

You see the Save Column Layout As dialog box. 

 

 

 

 

 

 

 

 

 

2 Verify that the New column layout option is selected, and then type Cost 
Assignments.  

3 Click OK. 

You see that the column layout Name has been changed to Cost Assignments. 

4 Click OK. 

You see the changes that you made to the column layout. Inspections Passed 
appears in the Column Layout list. 
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Entering Attribute Values 

Now, you will display a column to enter attribute values. 

 

 Enter attribute values 

1 In the Inspections Passed column for the Beaverton x Inspect account, type 
43400. 

2 In the Inspections Passed column for the Eugene x Inspect account, type 
1100. 
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Defining Drivers 
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An important aspect of activity-based management is the understanding of how 
activities in an organization consume expenses and how products consume activities. 
These consumptions are governed by relevant drivers, which measure the frequency or 
intensity of the cost demands that are placed on resources and activities. A driver 
specifies how costs are assigned. 

This tutorial uses both system-defined and user-defined drivers. 

Drivers for the Model 

The first step in assigning resource costs to activities and activity costs to cost objects 
is building a list of drivers. 

The Parcel Express Tutorial model uses several system-defined drivers. Additionally, 
you will create the following drivers: 

User-Defined Driver Purpose 
FTEs Tracks the cost of wages from the resource module to the 

activity module. 

Dollars Tracks the cost of operating expenses from the resource 
module to the activity module. 

Number of Customer Complaints Tracks the number of customer complaints per channel. 

Number of Packages Tracks the number of packages that were collected, sorted, 
and distributed. 

Number of Expedite Requests Tracks the packages that are expedited regionally. 

 

 Define basic drivers 

1 Select Model > Drivers Page. 

You see the following list of system-defined drivers: 

 

2 Select Edit > New Driver. 
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You see the New Driver dialog box. 

 

 

 

 

 

 

 

 

 

 

3 For Name, type FTEs. 

4 Verify that the Driver type is Basic. 

5 Verify that the This driver’s quantities are unique option is checked. 

6 Verify that Allow fixed driver quantities for this driver is checked. 

7 Click OK. 

You see that FTEs has been added to the list of drivers. 

8 Add the following Basic type of drivers: 

Driver Driver Type 
Dollars Basic 

Number of Customer Complaints Basic 

Number of Packages Basic 

9 Select the following options for the Number of Packages driver: 

 

 

 

 

Calculated Drivers 

The Number of Expedite Requests is a calculated driver. Calculated drivers expand 
system capability, enabling you to define cost drivers that are unique to your business. 
You define these calculated drivers with formulas that you create using the system-
generated numeric properties and attributes that you have defined for your unique 
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usage. The calculated driver in this tutorial will use attributes that you have just 
created and numeric properties generated by the system. 

 

 Defining a calculated driver 

Driver Formula 
Number of Expedite 
Requests 

[“Average Time to Expedite” X “Completed Expedite 
Requests”] / DriverQuantityFixed 

1 Add Number of Expedite Requests as a calculated driver. For Driver type, 
select Calculated.  

2 Verify that the This driver’s quantities are unique option is checked. 

3 Verify that Allow fixed driver quantities for this driver is checked. 

 

 

 

 

 

 

 

 

 

 

 

4 Click Equation Editor. 

You see the Equation Editor dialog box. 
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5 Select  (  from the Operators list. 

6 Select Average Time to Expedite from the Attributes list. 

7 Click Insert. 

8 Select * from the Operators list. 

9 Select Completed Expedite Requests as the multiplier from the Attributes 
list. 

10 Select  )  to close the set. 

11 Select  /  from the Operators list. 

12 Select DriverQuantityFixed from the Numeric properties list. 

13 Click Test to verify the syntax of the formula. 

14 Click OK to accept the formula. 

15 Click OK to create the driver. 

 

 

 

 

 

 

 

 

 

 

 

Review the list of drivers. 
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An assignment links source accounts to destination accounts. Costs flow along this 
path from resources to activities to cost objects—from expenses to activities to products, 
services, or customers. A source account is the source of a cost assignment. A destination 
account receives the results of a cost assignment. 

 

 

 

 

 

 

 

 

As previously shown, the possible assignments between accounts, as indicated by 
letters, are:  

A resource to resource  

B resource to cost object  

C resource to activity  

D activity to activity  

E activity to cost object  

F cost object to cost object  

C H A P T E R  
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Using a Column Layout 

In a previous section, you created a column layout named Cost Assignments for the 
activity module. In the following sections, you will add columns to the layout for the 
other modules. 

While building the model structure, you have been working in the single pane view. 
To make assignments, you need to open an assignments pane. When the primary pane 
and an assignments pane are open, you can see source accounts, destination accounts, 
assignments, driver names, and driver quantities. To assign resource costs to activity 
accounts, you will open the right assignments pane. 

 

 Open the right assignments pane and Column Layout dialog box 

1 Select Model > Resource Module. 

2 If it is not already open, open the Cost Assignments saved column layout. 

3 In the resource module, select Model > Assignments > Show Right 
Assignments Pane. 

You see the right assignments pane (to the right of the resource module primary 
pane). The default columns are IntsctnName, Reference, and Cost. 

Tip: You might want to hide the taskbar on the left side of the window to display 
more data. To do this, click the X in the upper-right corner of the taskbar. You can 
make columns wider or narrower by clicking on the line between two column 
headings and dragging the edge of the column to the width that you want. 

4 Select Model > Column Layout > Edit Columns. 

The columns that you see in the Displayed columns list refer to the layout for a 
specific pane in a specific module. Because you are currently viewing the resource 
module, you see the column layout for the primary pane of the resource module. To 
change the column layout for a different pane or module, select that pane or 
module. The Cost Assignments column layout that you create in this tutorial will 
ultimately contain layouts for several modules and panes. 

 

 

 

 

 

 

 

Resource Module 

Primary pane 
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 Define the column layout for two panes 

1 Verify that the Primary pane tab is selected. 

2 From the Displayed columns list, select Display Reference. 

3 Click Remove. 

You see that Display Reference has been removed from the list of Displayed 
columns. Removing this column from the layout will provide more space for 
columns that are relevant to making driver assignments. Remember that 
removing a column from a column layout does not remove it from any table in the 
model—it simply changes your view of the model. 

4 In Drivers, select Driver Name (DrvName).  

Tip: To find Driver Name (DrvName), scroll down to Driver and expand it. 

5 Click Add. 

You see that Driver Name (DrvName) has been added to the Displayed 
columns list. 

6 Click the Right pane tab. 

You see the default columns of the right pane in the Displayed columns list. 

7 Remove the Reference column from the Displayed columns list. 

8 Add the Driver Quantity Fixed (DQF) property to the Displayed columns list. 

 

 Save the column layout 

1 Click Save. 

2 Click OK to dismiss the Column Layout dialog box. 

You see the changes that you made to the Cost Assignments column layout appear 
in the Column Layout list. 

Making Assignments from Resources to Activities 

The first assignments that you make will be inter-modular; that is, assignments from 
the resource module to the activity module.  

 

 Add accounts for assignments 

1 Select Model > Assignments > Add Accounts in Right Pane. 
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You see the Add Accounts for Assignments dialog box. 

 

 

 

 

 

 

 

 

 

 

 

 

2 Verify that the Activity module is selected. 

3 Expand Activity so that you can see the Beaverton and Eugene roll-up 
accounts. 

4 Select the Beaverton roll-up account, and then click Add Accounts. 

You see that the Beaverton activity accounts have been added to the right pane. 

5 Add the Eugene activity accounts to the right pane. 

6 Click Close. 

Note: To avoid mixing up assignments between Beaverton resources and Eugene 
accounts (and vice versa), consider first adding only the Beaverton accounts to the 
right pane. Next, make the assignments. Then, do the same for Eugene. Also, note 
that clearing accounts from the right pane does not delete assignments from your 
model. It removes the accounts from view temporarily. 

Making Assignments 

Now that the intended destination accounts are displayed, you can make assignments 
from resource accounts to activity accounts. 

 

 Make assignments 

1 In the primary pane, expand Resource to display all of its accounts.  
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Tip: Select View > Expand to display subfolders. In this tutorial, you do not need 
to expand the module hierarchies to display the cost elements of each account. If 
the cost elements are displayed, collapse the hierarchy to hide them. 

 

 

 

 

 

 

 

2 Select the Wages account under Beaverton. 

You see that arrows appear next to each account in the right pane. These arrows 
indicate that you can make assignments from Beaverton Wages to any of the listed 
accounts. Logically, the cost of wages in Beaverton would be assigned only to 
Beaverton activities, not Eugene activities. 

3 Click the DrvName cell in the Wages row under Beaverton. 

You see a list of available drivers, including system-defined and user-defined 
drivers. 

 

 

 

 

 

4 Select FTEs. 

5 Make assignments to all of the Beaverton accounts in the right pane by clicking 
the arrow next to each account. 

You see that a line now connects Beaverton Wages to each of the arrows that you 
clicked. 
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6 Type the following values in the DQF column in the right pane (the order of 
accounts might be different from the order that is shown; be careful to assign 
values to the correct accounts): 

 

 

 

 

 

 

Note: The total cost of Beaverton Wages ($1,638,600.00) will be consumed by these 
seven activity accounts according to the number of FTEs that you have entered. 
SAS Activity-Based Management performs the math for you when you calculate 
costs in a later lesson. 

 

 Make other assignments 

Note: Remember that when making assignments, you must first select a driver 
before you can select a destination account and assign a numeric value to the 
account. 

1 In the primary pane, select Operating Expenses for Beaverton and make the 
following assignments: 

Resource Account Driver Activity Account DQF 
Beaverton x Operating 
Expenses 

Dollars Beaverton x Resolve Customer 
Complaints 

6,500.00 

  Beaverton x Expedite Package 
Shipments 

8,000.00 

  Beaverton x Move to Warehouse 15,000.00 

  Beaverton x Sort 23,000.00 

  Beaverton x Inspect 54,000.00 

  Beaverton x Air Distribution 83,000.00 

  Beaverton x Land Distribution 56,500.00 

 

DQF column 
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2 In the primary pane, select Equipment Expenses for Beaverton and make the 
following assignments: 

Resource Account Driver Activity Account DQF 
Beaverton x 
Equipment Expenses 

Percentage Beaverton x Resolve Customer 
Complaints 

5 

  Beaverton x Expedite Package 
Shipments 

3 

  Beaverton x Move to Warehouse 7 

  Beaverton x Sort 20 

  Beaverton x Inspect 25 

  Beaverton x Air Distribution 25 

  Beaverton x Land Distribution 15 

Note: The total equals 100 because 100% of equipment expenses are used by 
Parcel Express. 

 

3 In the primary pane, select Wages for Eugene and make the following 
assignments: 

Resource Account Driver Activity Account DQF 
Eugene x Wages FTEs Eugene x Resolve Customer 

Complaints 
2 

  Eugene x Expedite Package 
Shipments 

1 

  Eugene x Move to Warehouse 5 

  Eugene x Sort 3 

  Eugene x Inspect 2 

  Eugene x Land Distribution 12 

 

4 In the primary pane, select Operating Expenses for Eugene and make the 
following assignments: 

Resource Account Driver Activity Account DQF 
Eugene x Operating 
Expenses 

Dollars Eugene x Resolve Customer 
Complaints 

7,700.00 

  Eugene x Expedite Package 
Shipments 

9,000.00 

  Eugene x Move to Warehouse 69,000.00 

  Eugene x Sort 38,000.00 

  Eugene x Inspect 58,300.00 

  Eugene x Land Distribution 98,000.00 
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5 In the primary pane, select Equipment Expenses for Eugene and make the 
following assignments: 

Resource Account Driver Activity Account DQF 
Eugene x Equipment 
Expenses 

Percentage Eugene x Resolve Customer 
Complaints 

5 

  Eugene x Expedite Package 
Shipments 

2 

  Eugene x Move to Warehouse 8 

  Eugene x Sort 20 

  Eugene x Inspect 25 

  Eugene x Land Distribution 40 

Making Assignments from Activities to Other Activities 

The costs of some activities flow to other activities. For example, at Parcel Express, 
when packages are moved to a warehouse, they must then be sorted or inspected. 
Therefore, in the Parcel Express Tutorial model, the costs of the Move to Warehouse 
activity flow to the Sort and Inspect activities. These are known as intra-modular, or 
reciprocal assignments. 

 

 Modify the Cost Assignments column layout 

1 Select Model > Activity Module. 

2 If it is not already open, open the right assignments pane. 

3 If the Cost Assignments layout is not already selected, select it from the 
Column Layout list, and then click the arrow. 

 

4 Open the Column Layout dialog box. 

5 Modify the column layout as follows: 

a In the primary pane, remove Inspections Passed and add Driver Name. 

b In the right pane, remove Reference and add Driver Quantity Fixed. 

6 Click Save, and then click OK. 

You see that the column layout has changed. 

 

 Add accounts for assignments 

1 Open the Add Accounts for Assignments dialog box. 

2 Select the Activity module. 

3 Add the following accounts to the right pane: 
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Tip: To see these accounts, expand the hierarchy in the Add Accounts for 
Assignments dialog box. You can add the accounts individually or select them all 
at once by holding down the CTRL key, and then clicking Add Accounts. 

Activity Account 

Beaverton x Inspect 

Beaverton x Sort 

Beaverton x Air Distribution 

Beaverton x Land Distribution 

Eugene x Inspect 

Eugene x Sort 

Eugene x Land Distribution 

4 Click Close. 

 

 Make assignments 

1 In the primary pane, select Move to Warehouse for Beaverton and make the 
following assignments: 

Activity Account 
(Primary Pane) 

Driver Activity Account 
(Right Pane) 

DQF 

Beaverton x Move to 
Warehouse 

Number of Packages Beaverton x Sort 203,000 

  Beaverton x Inspect 50,000 

 

2 In the primary pane, select Inspect for Beaverton and make the following 
assignments: 

Activity Account 
(Primary Pane) 

Driver Activity Account 
(Right Pane) 

DQF 

Beaverton x Inspect Number of Packages Beaverton x Sort 44,000 

 

3 In the primary pane, select Sort for Beaverton and make the following 
assignments: 

Activity Account 
(Primary Pane) 

Driver Activity Account 
(Right Pane) 

DQF 

Beaverton x Sort Number of Packages Beaverton x Land 
Distribution 

107,000 

  Beaverton x Air 
Distribution 

140,000 
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4 In the primary pane, select Move to Warehouse for Eugene and make the 
following assignments: 

Activity Account 
(Primary Pane) 

Driver Activity Account 
(Right Pane) 

DQF 

Eugene x Move to 
Warehouse 

Number of Packages Eugene x Sort 117,000 

  Eugene x Inspect 18,000 

 

5 In the primary pane, select Inspect for Eugene and make the following 
assignments: 

Activity Account 
(Primary Pane) 

Driver Activity Account 
(Right Pane) 

DQF 

Eugene x Inspect Number of Packages Eugene x Sort 16,000 

 

6 In the primary pane, select Sort for Eugene and make the following assignments: 

Activity Account 
(Primary Pane) 

Driver Activity Account 
(Right Pane) 

DQF 

Eugene x Sort Number of Packages Eugene x Land 
Distribution 

133,000 

Making Assignments from Activities to Cost Objects 

Now, you will make more inter-modular assignments from activity accounts to cost 
object accounts. Remember that some cost object accounts are single-dimension 
accounts. These accounts hold unique costs for individual channels or products. Some 
Parcel Express activities, such as Resolve Customer Complaints, apply uniquely to a 
channel, regardless of the packages that are being processed through the channel. 
Similarly, some costs apply only to products, as you will see in the following procedures. 

 

 Add accounts for assignment 

1 If there are accounts in the right pane, clear the accounts as follows: 

a Select the highest branch of the Activity hierarchy in the primary pane. 

b Select Model > Assignments > Clear Right. 

You see that the right pane has been cleared of accounts. This does not delete the 
assignments—it only removes them from view. 

2 Open the Add Accounts for Assignments dialog box. 

3 Verify that the Cost Object module is selected. 

4 Add all of the Cost Object accounts to the right pane. 
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Note: To avoid mixing up activities and cost objects from Beaverton and Eugene, 
consider first adding only the Beaverton accounts. Next, make the assignments. 
Then, clear the right pane. And then, add all of the Eugene accounts and make 
assignments. Also, note that clearing accounts from a pane does not delete 
assignments from your model. It removes the accounts from view temporarily. 

5 Click Close. 

 

 Make assignments for Beaverton 

1 In the primary pane, select Resolve Customer Complaints for Beaverton and 
make the following assignments: 

Activity Account Driver Cost Object Account for 
Beaverton 

DQF 

Beaverton x Resolve 
Customer Complaints 

Number of Customer 
Complaints 

Commercial Pick Up x No 
<Products and Services> 

25 

  Walk In x No <Products and 
Services> 

85 

  Drop Box x No <Products 
and Services> 

15 

 

2 In the primary pane, select Inspect for Beaverton and create the following 
assignments: 

Activity Account Driver Cost Object Account for 
Beaverton 

DQF 

Beaverton x Inspect Number of Packages No <Channel> x Standard 
Ground 

500 

  No <Channel> x Overnight 
Express 

4,500 

  No <Channel> x 2nd Day 
Guaranteed 

1,000 

 

3 In the primary pane, select Air Distribution for Beaverton and make the 
following assignments: 

Activity Account Driver Cost Object Account for 
Beaverton 

DQF 

Beaverton x Air 
Distribution 

Number of Packages No <Channel> x Standard 
Ground 

50,000 

  No <Channel> x Overnight 
Express 

65,000 

  No <Channel> x 2nd Day 
Guaranteed 

25,000 
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4 In the primary pane, select Land Distribution for Beaverton and make the 
following assignments: 

Activity Account Driver Cost Object Account for 
Beaverton 

DQF 

Beaverton x Land 
Distribution 

Number of Packages No <Channel> x Standard 
Ground 

67,000 

  No <Channel> x Overnight 
Express 

15,000 

  No <Channel> x 2nd Day 
Guaranteed 

25,000 

 

5 In the primary pane, select Expedite Package Shipments for Beaverton and 
make the following assignments: 

Activity Account Driver Cost Object Account for 
Beaverton 

DQF 

Beaverton x Expedite 
Package Shipments 

Number of Expedite 
Requests 

No <Channel> x Standard 
Ground 

3,000 

  No <Channel> x Overnight 
Express 

26,000 

  No <Channel> x 2nd Day 
Guaranteed 

15,000 

 
 

 Make assignments for Eugene 

1 In the primary pane, select Resolve Customer Complaints for Eugene and 
make the following assignments: 

Activity Account Driver Cost Object Account for 
Eugene 

DQF 

Eugene x Resolve 
Customer 
Complaints 

Number of Customer 
Complaints 

Commercial Pick Up x No 
<Products and Services> 

10 

  Walk In x No <Products and 
Services> 

32 

  Drop Box x No <Products 
and Services> 

25 
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2 In the primary pane, select Inspect for Eugene and create the following 
assignments: 

Activity Account Driver Cost Object Account for 
Eugene 

DQF 

Eugene x Inspect Number of Packages No <Channel> x Standard 
Ground 

1,000 

  No <Channel> x Overnight 
Express 

500 

  No <Channel> x 2nd Day 
Guaranteed 

500 

 

3 In the primary pane, select Land Distribution for Eugene and make the 
following assignments: 

Activity Account Driver Cost Object Account for 
Eugene 

DQF 

Eugene x Land 
Distribution 

Number of Packages No <Channel> x Standard 
Ground 

75,000 

  No <Channel> x Overnight 
Express 

16,000 

  No <Channel> x 2nd Day 
Guaranteed 

42,000 

 

4 In the primary pane, select Expedite Package Shipments for Eugene and 
make the following assignments: 

Activity Account Driver Cost Object Account for 
Eugene 

DQF 

Eugene x Expedite 
Package Shipments 

Number of Expedite 
Requests 

No <Channel> x Standard 
Ground 

25,000 

  No <Channel> x Overnight 
Express 

1,000 

  No <Channel> x 2nd Day 
Guaranteed 

10,000 

Adding Attributes to Cost Accounts 

When you created the cost drivers for the Parcel Express Tutorial model, you built one 
calculated driver, named Number of Expedite Requests, that was composed of two 
attributes, named Average Time to Expedite and Completed Expedite Requests (See 
Calculated Drivers). The value of those attributes must be added to the cost accounts to 
which they apply. 

 

 Open the cost object module 

1 Select Model > Cost Object Module. 
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 Add columns for attributes in the column layout 

To enter numeric values for attributes, the attributes must be added to the column 
layout for the cost object account: 

1 Make sure the current column layout is Cost Assignments. 

2 Select Model > Column Layout > Edit Columns. The Column Layout window 
opens. 

3 Make sure the Cost Object Module is selected. 

4 Make sure the Primary pane tab is selected. 

5 Remove Display Reference from the Displayed columns list. 

6 Add the Average Time to Expedite attribute. 

7 Add the Completed Expedite Requests attribute. The column layout should 
look like the following: 

 

 

 

 

 

 

 

 

 

 

 

8 Click OK. The attributes are added to the primary pane. There is no need to save 
the column layout. 
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 Add attribute quantities 

1 Now, add the following attribute quantities for Beaverton: 

Destination 
Account 

Average Time to 
Expedite 

Completed Expedite 
Requests 

No <Channel> x 
Standard Ground 

1.75   4,000 

No <Channel> x 
Overnight Express 

1.75 15,000 

No <Channel> x 2nd 
Day Guaranteed 

1.75 25,000 

 

2 Add the following attribute quantities for Eugene: 

Destination 
Account 

Average Time to 
Expedite 

Completed Expedite 
Requests 

No <Channel> x 
Standard Ground 

3   6,000 

No <Channel> x 
Overnight Express 

3 15,000 

No <Channel> x 2nd 
Day Guaranteed 

3 20,000 

 

The resulting attribute assignments should look like the following: 
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Calculating Costs 
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Typically, costs are entered in a model at the end of a defined period. These costs 
come from an organization’s general ledger accounts and from external bills of costs. 
Additional cost information can come from a Material Requirements Planning (MRP) 
system. Production data is also entered in a model at the end of a defined period. 

At any time during the development of a model, you can calculate the cost of each 
account according to its driver and driver quantities. 

Calculating Costs 

You entered Parcel Express costs and quantities for the 2004 Q1 period, so 
calculations will be performed for this period.  

 

 Calculate costs 

1 Select Model > Calculate Costs and Generate Cubes. 

C H A P T E R  
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You see the Calculate Costs, Generate Fact Tables, and Generate Cubes dialog box. 
This dialog box enables you to generate cubes for analysis, but you will not do that task 
in this step. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2 Under Perform this action, verify that Calculate costs is selected, and that 
Generate fact tables and Generate cubes are not selected. 

3 Click OK. 

You see a message in the status bar, at the bottom of the window, indicating that 
the calculation is in progress. 

 

Depending on the speed of your SAS Activity-Based Management server and your 
connection to it, the calculation might take several seconds. When the calculation 
is completed, you will see the Operation Summary window. You should have 0 
fatal errors, 0 errors, and 18 to 20 warnings.  

4 Click Show Details. 

You see the details of the warnings.  
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Note: The names of your accounts will differ from those that are shown in the 
following window. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note: These warnings have occurred because the accounts that are listed have no 
cost elements or costs assigned to them. You will assign costs to these accounts in 
a later lesson. 

Interpreting the Operation Summary 

An operation summary can show fatal errors, errors, and warnings. Fatal errors are 
rare during a model calculation. If a fatal error occurred, the calculation would have 
been terminated by the server, and the results would be incomplete. Errors could result 
from data or a module structure that is incomplete, inconsistent, or invalid. Warnings 
indicate that a potential problem exists with the model, but that processing was 
completed. 

The operation summary for the Parcel Express Tutorial model indicates that some 
accounts of the cost object module have no costs. In a later lesson, you will add costs to 
these accounts based on the sales quantities of each product. 
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Viewing and Verifying Calculation Results 

Experienced activity-based costing users calculate a model after they create accounts, 
assignments, and driver quantities, or after they enter cost data, as a validation and 
quality assurance technique. 

The following displays show the total costs for the resource, activity, and cost object 
modules, along with the key roll-up accounts in each module. Verify that the modules 
and accounts in your model match the costs. 

Resource Module 

 

 

 

 

 

 

 

Activity Module 

 

 

 

 

 

 

 

 

Cost Object Module 
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Adding Bills of Costs 
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A bill of costs provides a convenient mechanism for adding material and unit costs 
directly to accounts, for bidding on jobs or for implementing activity accounting. 

Use a bill of costs when: 

 Costs outside of the general ledger need to be introduced into a model. Not all 
costs that are assigned through a model come from the general ledger. For 
example, material costs (the cost of purchased components) can be additional 
product cost information that often comes from a MRP system. 

 A model’s unit cost elements that are associated with product families need to be 
tracked. 

Steps for Building Bills of Costs 

To build bills of costs: 

1 Define a dimension in the external units module. 

You did this step for the Parcel Express Tutorial model when you completed the 
New Model Wizard. The dimension is Materials. 

2 Create dimension members. 

For the Parcel Express Tutorial, the Materials dimension members will represent 
packaging materials. 

3 Create accounts in the external units module. 

You will use the New Account Wizard to add external units to the model. 

4 Create an assignment from the external unit to an account, using the Bill 
of Cost driver. 

C H A P T E R  
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Packaging materials in the Parcel Express Tutorial model contribute to the unique 
costs of a product. You will make assignments from accounts in the external units 
module to accounts in the cost object module. 

5 Enter a fixed or variable driver quantity. 

You will enter both types of quantities. 

6 If you enter a variable driver quantity, you must also enter an output 
quantity. 

You will enter output quantities in a later lesson. 

Internal and External Units 

An external unit is a unit, such as a part purchased from a supplier, whose cost is 
maintained outside a SAS Activity-Based Management model, but which needs to be 
accounted for in the model. SAS Activity-Based Management treats external units like 
accounts. When an external unit’s cost is flowed to an account, you see the flowed cost 
listed as an external unit cost element.  

An internal unit is a unit, such as a part produced within a company, whose cost is 
already represented in the model. The cost flows from one account to another account's 
bill of costs. 

In the Parcel Express Tutorial model, you will use only external units. 

Fixed and Variable Quantities 

A bill of costs quantity can include variable or fixed quantities or both. 

Variable Quantities 

In a variable quantity, the cost that flows to the account from the bill of costs depends 
on the output quantity: the bill of costs’s unit cost is multiplied by the driver quantity 
and the output quantity (either a system-calculated output quantity or a user-entered 
output quantity). 

For example, assume that a company manufactures bicycles. The rubber tires are 
purchased from another company for $5 each. Because each bicycle requires two tires, 
the unit cost of the bill of costs is $10. If the company produces 100 bicycles, the total 
cost is $1,000 (100 x $5 x 2). 

Fixed Quantities 

In a fixed quantity, the cost that flows to the account from the bill of costs does not 
depend on the output quantity: the bill of cost’s unit cost is multiplied by the driver 
quantity. 
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For example, assume that the bicycle manufacturer that was mentioned previously 
buys 1,000 tires at the beginning of each year. The tires might be used in any model of 
bicycle that the manufacturer produced. In this case, the bill of costs’s unit cost does not 
vary with the number of bicycles produced; it's always $5,000 (1,000 x $5).  

Creating External Units and Bills of Costs 

Parcel Express buys the following components from outside vendors: 

 standard envelopes 
 2nd day flats 
 overnight flats 
 large boxes 
 small boxes 

These costs must be accounted for in the model. To account for them, you will create 
external units and assign them to cost object accounts, thereby creating bills of costs. 

 

 Create the Materials dimension members 

1 Select Model > Dimensions Page. 

2 Using the techniques that you have learned, create the following Materials 
dimension members: 

 

 

 

 

 

 

 

 

Tip: Select Edit > New Dimension Member to open the New Dimension 
Member dialog box or right-click on the dimension name. 

 

 Create external units accounts 

1 Select Model > External Units Module. 

You see the external units module, which has no structure yet. 

2 Select Edit > New Account. 
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You see the New Account Wizard. 

3 Select the following dimension members: 

 Standard Envelope 
 2nd Day Flat 
 Overnight Flat 
 Large Box 
 Small Box 

4 Click Add, and then Next. 

You see Step 2 of the New Account Wizard. 

5 Enter the following unit costs: 

Account Unit Cost 

Standard Envelope .06 

2nd Day Flat .14 

Overnight Flat .14 

Large Box .95 

Small Box .75 

6 Click Finish. 

You see the following external unit structure: 

 

 

 

 

 

 

 Modify the Cost Assignments column layout 

1 In the external units module, show the right assignments pane. 

2 If the Cost Assignments layout is not already selected, select it from the 
Column Layout list, and then click the arrow. 

 

3 Select Model > Column Layout > Edit Columns. The Column Layout dialog 
box opens. 

4 Modify the primary pane as follows: 

 Remove Display Reference. 
 Add Driver Name. 
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5 Modify the right pane as follows: 

 Remove Reference. 
 Add Driver Quantity Fixed (DQF) . 
 Add Driver Quantity Variable (DQV). 

6 Click Save, and then OK. 

 

 Add accounts for assignments 

1 Open the Add Accounts for Assignments dialog box (Model > Assignments > 
Add Accounts in Right Pane). 

2 Add the following Cost Object accounts under Beaverton and Eugene to the right 
pane: 

Cost Object Account 

No <Channel> x 2nd Day Guaranteed 

No <Channel> x Overnight Express 

No <Channel> x Standard Ground 

 

 Make assignments 

1 Make assignments that have the following driver quantities: 

External Unit Account Cost Object Account DQF DQV 
Standard Envelope Beaverton x No <Channel> x 

Overnight Express 
17,333.00  

Standard Envelope Eugene x No <Channel> x 
Overnight Express 

8,677.00  

2nd Day Flat Beaverton x No <Channel> x 
2nd Day Guaranteed 

 1.00 

2nd Day Flat Eugene x No <Channel> x 2nd 
Day Guaranteed 

 1.00 

Overnight Flat Beaverton x No <Channel> x 
Overnight Express 

123,500.00  

Overnight Flat Eugene x No <Channel> x 
Overnight Express 

6,500.00  

Large Box Beaverton x No <Channel> x 
Standard Ground 

120,833.00  

Large Box Eugene x No <Channel> x 
Standard Ground 

4,167.00  

Small Box Beaverton x No <Channel> x 
Standard Ground 

73,950.00  

Small Box Eugene x No <Channel> x 
Standard Ground 

2,550.00  

Note: When you make assignments from external units, the software 
automatically applies the Bill of Cost driver. 
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2 Select Model > Assignments > Show Single Pane. 

3 Calculate the model, and then close the Operation Summary.  

Note: Warnings occur because costs are still unassigned. 

You see the following external unit costs: 

 

 

 

 

 

 

Note: The 2nd Day Flat external unit does not have a cost yet because you 
assigned a variable driver quantity of 1. Until you enter an output quantity for the 
2nd Day Guaranteed product, the system cannot calculate the cost of 2nd Day 
Flat. 
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Some of the most critical calculations in a model rely on the number of products that 
are produced and sold, as well as sales revenue. From these values, you can determine 
unit costs and profit. SAS Activity-Based Management provides properties for the input 
and calculation of these values. 

Entering Output Quantities 

In SAS Activity-Based Management models, output quantity can be derived from a 
number of user-entered quantities. In the Parcel Express Tutorial model, you will enter 
data into the OutQtyUE (which stands for Output Quantity User-Entered) property and 
the SoldQty (which stands for Sold Quantity) property, both of which will be used to 
calculate the SoldQty of an account. The software uses OutQty (which stands for Output 
Quantity to calculate UnitCost also. 

 

 Create a new column layout 

1 Select Model > Cost Object Module. 

2 Select the Default column layout. 

3 Remove the Display Reference column. 

4 Add the following columns to the primary pane: 

 Driver Name (DrvName)  
 Unit Cost (UnitCost) 
 Output Quantity UE (OutQtyUE) 
 Output Quantity (OutQty) 

5 Click Save As and name the new column layout Unit Cost. 

C H A P T E R  
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 Enter output quantities and calculate costs 

1 Expand the No <Channel> roll-up accounts for Beaverton and Eugene. 

2 Delete the No <Channel> x No <Products and Services> accounts for both 
Eugene and Beaverton. Right-click on each account and select Delete. (Note that 
you might have deleted them already when creating the cost object accounts). 

3 Assign the Sales volume driver to the following accounts for both Beaverton and 
Eugene: 

Cost Object Account 
Drop Box x No <Products and Services> 

Walk In x No <Products and Services> 

Commercial Pick Up x No <Products and Services> 

 

4 Assign the Sales volume driver to each of the No <Channel> accounts: 

Cost Object Account 
No <Channel> x 2nd Day Guaranteed 

No <Channel> x Overnight Express 

No <Channel> x Standard Ground 

 

5 In the OutQtyUE column, enter the following quantities: 

Account Quantity 
 Beaverton Eugene 

No <Channel> x 2nd Day Guaranteed   58,840 30,500 

No <Channel> x Overnight Express   67,330 33,670 

No <Channel> x Standard Ground 128,966 64,534 

 

6 Calculate the model, and then close the Operation Summary. 

 

 

 

 

 

 

 

Note: This warning appears because no sold quantities have been entered yet.  
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Note: The numbers at the end of an account name, for example 5080 at the end of 
the first line, are automatically generated by the system and will vary. 

You see the unit cost for each product. Output quantities have been generated for 
these products.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note: If you return to the external units module, you will see that a cost has now been 
generated for the 2nd Day Flat account. The reason is that you assigned cost by using 
the DQV property, which requires an output quantity for calculation. Now that you have 
entered the 2nd Day Guaranteed output quantity, the 2nd Day Flat external unit 
account can be calculated. 
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Entering Sales Volumes 

You will enter sales volumes in the SoldQty property.  

 Further modify the Cost Assignments column layout 

1 In the Cost Object module, show the primary pane. 

2 If the Cost Assignments layout is not already selected, select it from the 
Column Layout list, and then click the arrow. 

 

3 Select Model > Column Layout > Edit Columns. The Column Layout dialog 
box opens. 

4 Modify the primary pane as follows: 

 Remove the Display Reference, Average Time to Expedite, and Completed 
Expedite Requests columns. 

 Add Driver Name (DrvName) . 
 Add Sold Quantity (SoldQty). 

5 Click Save, and then OK. 

 

 Enter sales volumes 

1 In the primary pane, enter the following values for SoldQty for the following 
accounts: 

Note: In other modules, you make assignments from the accounts in the primary 
pane to the accounts in the right pane. However, the Sales volume driver 
automatically assigns costs to the right pane based on the sales volumes (SoldQty) 
that you enter in the primary pane (without you making explicit assignments). 

Account SoldQty 

Beaverton x Drop Box x 2nd Day Guaranteed 9,000 

Beaverton x Drop Box x Overnight Express 4,000 

Beaverton x Drop Box x Standard Ground 21,666 

Beaverton x Walk In x 2nd Day Guaranteed 29,840 

Beaverton x Walk In x Overnight Express 37,330 

Beaverton x Walk In x Standard Ground 73,300 

Beaverton x Commercial Pick Up x 2nd Day 
Guaranteed 

20,000 

Beaverton x Commercial Pick Up x Overnight Express 26,000 

Beaverton x Commercial Pick Up x Standard Ground 34,000 
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Account SoldQty 

Eugene x Drop Box x 2nd Day Guaranteed 4,500 

Eugene x Drop Box x Overnight Express 2,000 

Eugene x Drop Box x Standard Ground 10,834 

Eugene x Walk In x 2nd Day Guaranteed 16,000 

Eugene x Walk In x Overnight Express 18,670 

Eugene x Walk In x Standard Ground 36,700 

Eugene x Commercial Pick Up x 2nd Day Guaranteed 10,000 

Eugene x Commercial Pick Up x Overnight Express 13,000 

Eugene x Commercial Pick Up x Standard Ground 17,000 

2 Calculate the model, and then close the Operation Summary. 
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You see that costs are now assigned to the nine accounts (for each location) that 
previously did not have costs. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3 Show the right pane by selecting Model > Assignments > Show Right 
Assignments Pane. 

4 In the primary pane, select the Beaverton x Drop Box x No <Products and 
Services> account. 

5 Select Model > Assignments > Show Right. 
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You see that assignments have automatically been made to three accounts in the 
right pane. 

 

 

 

 

 

 

Entering Revenue and Calculating Profit 

Profit and loss can be calculated after you enter sales data in the Revenue property. 

 

 Create a new column layout 

1  Select Model > Cost Object Module. 

2 Select the Default column layout. 

3 Select Model > Assignments > Show Single Pane. 

4 Open the Column Layout dialog box. 

5 Modify the primary pane as follows: 

 Remove the Display Reference column. 

 Add the UnitCost, Sold Quantity, Revenue, and Profit columns. 

6 Save the new column layout with the name Profit. 

7 Close the Column Layout dialog box. 

 

 Enter revenue and calculate profit 

1 In the Revenue column, type the following values: 

Cost Object Account Revenue 

Beaverton x Drop Box x 2nd Day Guaranteed 72,550 

Beaverton x Drop Box x Overnight Express 59,800 

Beaverton x Drop Box x Standard Ground 379,166 

Beaverton x Walk In x 2nd Day Guaranteed 321,667 

Beaverton x Walk In x Overnight Express 558,133 
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Cost Object Account Revenue 

Beaverton x Walk In x Standard Ground 123,333 

Beaverton x Commercial Pick Up x 2nd Day 
Guaranteed 

139,000 

Beaverton x Commercial Pick Up x Overnight Express 388,700 

Beaverton x Commercial Pick Up x Standard Ground 595,000 

Eugene x Drop Box x 2nd Day Guaranteed 61,275 

Eugene x Drop Box x Overnight Express 29,900 

Eugene x Drop Box x Standard Ground 189,584 

Eugene x Walk In x 2nd Day Guaranteed 215,834 

Eugene x Walk In x Overnight Express 279,061 

Eugene x Walk In x Standard Ground 641,667 

Eugene x Commercial Pick Up x 2nd Day Guaranteed 69,500 

Eugene x Commercial Pick Up x Overnight Express 194,350 

Eugene x Commercial Pick Up x Standard Ground 297,500 

2 Calculate the model, and then close the Operation Summary. 
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You see the following profit and loss information: 
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When the information has been entered into the activity-based management model, 
the costs have been calculated, and the data has been reviewed, the next step in 
analyzing the data is generating reports. 

The benefits of generating reports include: 

 validating the model 
 producing printouts that present an overall view of the data 
 analyzing costs online 
 producing files for inclusion in other programs, such as spreadsheets or word 

processors 
 focusing on a specific area of interest 

Report Templates 

A report template is a file that specifies the layout of a report and the fields of data in 
a report (but not the data itself). When you create a report, you first select a report 
template. 

SAS Activity-Based Management has predefined report templates that provide 
formats and that enable great flexibility in the amount and type of information to 
include in a report. The following predefined templates are included: 

 Destination Furthest 
 Dimensional Attribute Cost 
 Dimensional Attribute Unit Cost 
 Dimensional View 
 Driver—Cost and Rate 
 Idle Capacity 
 Module Hierarchy 

C H A P T E R  
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 Multi-level Contributions 
 Profit and Loss 
 Profit Cliff 
 Resource Contributions 
 Resource Contributions by Attribute 
 Single-stage Assignments 
 Single-stage Contributions 
 Unassigned Costs 
 Unit Cost 

Creating a Report 

You will create a report and view the results online. The report is for the 2004 
Q1/Actual period/scenario association, and includes information about resource 
contributions. 

To create a new report, you use the Report Wizard. The Report Wizard has six steps. 

 

 Select a model and template 

1 Click  

You see the Reports home page. 

2 Select File > New > Report. 

You see Step 1 of the Report Wizard. 
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3 Under Select a model and a report template, select the Parcel Express 
Tutorial model and the Single-stage Assignments report template. 

4 Click Next. 

You see Step 2 of the Report Wizard. 

5 Select 2004 Q1/Actual, and then click Next. 

You see Step 3 of the Report Wizard. 

6 Select Use all modules, and then click Next. 

You see Step 4 of the Report Wizard. 

7 Verify that no dimensions are selected, and then click Next. 

You see Step 5 of the Report Wizard. 

8 Verify that Suppress zero costs and Single currency are selected, and then 
click Next. 

9 Select Save configuration for Step 6 of the Report Wizard. 

10 For Name, type PX Tutorial Single-stage Assignments. 

11 Click Finish. 

You see the finished report in Portable Document Format (PDF). 

 

 

 

 

 

 

 

 

 

 

 

 

The data in this report reflects the current model. If you make changes to the model 
and reopen the report, the report data reflects the changes. 



100 Working with Reports      Chapter 14 

Each report has a header that lists pertinent information for that report. All or some 
of the following information can be listed in a report's header: 

Information Description 
Model Name The model that is selected for the report. 

Module One or more modules that are selected for the report. Each module 
starts on a new page. 

Period The period that is selected for the report. 

Scenario The scenario that is selected for the report. 

View Perspective The structural dimension that is selected for the report. 

Filtered Indicates that one or more attributes were used to select items for the 
report. Attributes that are used to select report data are listed on a 
report's last page. 

Working with Reports 

All saved report configurations that are on the same server are listed in the 
Workspace Manager. Your company might want to set up some guidelines for saving 
and naming report configurations. You can open a report configuration from the 
Workspace Manager or from the Reports home page. 

 

 

 

On the Reports home page, you can open, publish, configure, or delete a report 
configuration. 

Navigating Reports 

You can navigate the pages of a report by using the standard Adobe Acrobat paging 
and search tools on the toolbar.  

Saving Report Data 

When you save a report configuration, you are saving only the parameters of the 
report, not the data. To save the data in a report, you must publish or export the report. 

Publishing Reports 

If you want other users to see the report results, along with the data that reflects a 
specific time period, you can publish the report. Publishing the report enables others to 
see the report data without having to rerun the report. In cases where a report requires 
considerable time to run, publishing the report can save time for other users. 

 



 Generating Reports      Working with Reports 101 

 Publish a report 

1 On the Reports home page, click the Publish link that is next to the desired 
report configuration. 

You see the Publish a Report dialog box. 

 

 

 

 

 

 

2 Type a Name. 

Note: You cannot enter a path. Published reports are stored on the SAS Activity-
Based Management server. 

3 Type a Description. 

4 Select a Format. 

The available publishing formats are: 

Report Publishing Formats 
Portable Document Format (PDF) 

Rich Text Format (RTF) 

5 Click OK. 

The report is added to the Workspace Manager in the Published Reports folder. 

Exporting Reports 

If you want to manipulate a report after running it, you can export the report. Data 
that you export from SAS Activity-Based Management can be used by other reporting 
tools, such as SAS Enterprise Guide. To export a report, select 
File > Export > Report Data, and follow the instructions in the Report Data Wizard. 

Configuring Reports 

By running the New Report Wizard, you are configuring a report. 

 

 Reconfigure a report 

1 On the Reports home page, click the Configure link that is next to the saved 
report configuration. 
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You see the Report Wizard. The Report Wizard contains a subset of steps that are 
in the New Report Wizard. 

2 Complete the Report Wizard, selecting the new configuration settings. 
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A cube is the basic unit of analysis in OLAP, a technology that provides fast, 
interactive access to data in a model. A cube is a storage unit that combines a number of 
dimensions and the measures they contain into one unit. You use SAS Activity-Based 
Management to connect to and interact with the cubes on a SAS Activity-Based 
Management server. For each model, you can generate cubes and manipulate them on 
the OLAP page to interactively analyze business data. 

The SAS Activity-Based Management OLAP tool provides three views from which to 
analyze data: 

 Grid View 
 Chart View 
 Cube Explorer View 

You can select the view that presents the data in the most meaningful format for your 
purposes. 

Cube Overview 

A cube is a data set that is constructed from a subset of model data, and that is 
organized and summarized into a multidimensional structure. SAS Activity-Based 
Management cubes are standard OLAP cubes. 

It does not matter how many dimensions a cube has—the storage unit is still called a 
cube, which represents any number of dimensions of data.  

C H A P T E R  
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Types of Cubes 

SAS Activity-Based Management provides the following types of cubes: 

 multi-stage contributions 
 resource contributions 
 single-stage contributions 

Each type of cube helps you to analyze data in various ways and to answer different 
kinds of questions. 

Multi-Stage Contributions Cube 

Use this type of cube to perform tasks and to answer questions such as: 

 Product A is not profitable. You want to trace the costs back through activities and 
then to resources that contribute costs to this product. 

 What are the costs for Product B that originate in salary resources and that are 
assigned through the Inspection activity to this product? 

The multi-stage contributions cube enables you to analyze cost contributions into and 
out of stages that are defined in a model. The Cube Explorer view enables you to 
visually trace cost contributions through all the stages. 

Resource Contributions Cube 

Use this type of cube to analyze resource accounts that contribute costs to other 
accounts. Or, use this type of cube to analyze the accounts that receive costs from 
resources. 

The resource contributions cube enables you to analyze cost contributions from 
original accounts (where costs were entered) to final accounts that do not assign costs to 
other accounts. Generally, these contributions are from resource accounts to cost object 
accounts, but it does not matter where the original or final accounts reside. 

Single-Stage Contributions Cube 

Use this type of cube to answer questions such as: 

 Which activity costs contribute to product, customer, service costs, and so on? 
 When costs are assigned within the cost object module, which subassembly costs 

contribute to product costs? 
 What are the costs of resources that contribute to activities? 

The single-stage contributions cube enables you to analyze cost contributions from one 
assignment level back. It does not matter where the costs originate or end. Typically, 
cost is contributed from: 

 activities to cost objects 
 resources to activities 
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Generating Cubes 

Before you can use OLAP cubes to analyze model data, you must generate cube data. 
Then, you can select the type of cube that meets your analysis objectives. 

 

 Generate cubes 

1 In Model mode, select Model > Calculate Costs and Generate Cubes. 

You see the Calculate Costs, Generate Fact Tables, and Generate Cubes dialog 
box. 

2 Select Calculate costs and Generate cubes. 

3 Verify that the three types of cubes in the Generate these cubes list are all 
selected. 

4 Click OK. 

You see the Operation Summary. 

5 Close the Operation Summary and change to OLAP mode. 

Creating OLAP Views 

 Create an OLAP view 

1 Select File > New > OLAP View. 

You see Step 1 of the New OLAP View Wizard. The New OLAP View Wizard has 
only one step. 
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2 Select the Parcel Express Tutorial model. 

3 Select the Resource Contributions cube. 

4 Click Finish. 

You see the resource contributions cube for the Parcel Express Tutorial model. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note: You can turn on and off the display of the slicer buttons by selecting OLAP 
> Slicers from the menu. 

 

 

 

 

Note: You can turn on and off the display of the graph by clicking the Graph 
button. Depending on the size of the SAS Activity-Based Management window, 
you might have to use the More menu to see the Graph button. 
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Analyzing OLAP Cubes 

So far, the only information that the cube has provided is the costs for periods and 
scenarios. To perform an interactive analysis of the cube, you will select specific 
dimensions for analysis. You use the Cube Dimensions Tree to select dimensions for 
display in OLAP cubes. 

Note: If the Cube Dimensions Tree is not visible, select OLAP > View Manager and 
click the Cube Dimensions Tree tab. 

Selecting and Displaying Dimensions in Cubes 

 Select dimensions 

1 Select Src Region from the Cube Dimensions Tree and click the add arrow  

 

 

 

 

 

 

 

 

2 Select Src General Ledger from the Cube Dimensions Tree and click the add 
arrow to add to Row. 

3 Move Dst Products and Services from rows to columns. 

Click the arrow 

Select Src Region 
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To do this, right-click All_Products_and_Services and select Move Dst 
Products and Services > To Columns on the menu. 

 

 

 

 

 

 

 

 

 

4 Remove All Periods from columns.  

To do this, right-click All Periods and select Remove All Period from Table on 
the menu. 

 

 

 

 

 

 

 

 

 

 

The table view should now look like the following: 

 

 

 

 

The data in the table view has been updated according to the dimensions that you 
have selected, but to see the details, you must drill through the dimensions. 
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 Drill through dimensions 

1 Click the down arrow next to the All_Products_and_Services column in the 
grid. 

Note: Use to drill down (the node that you click is replaced by its children). Use 
 to expand (the node that you click is displayed along with its children). 

 

 

 

 

 

You see the All_Products_and_Services dimension expand, showing the costs 
for each product. 

 

 

 

 

 

2 Delete empty rows and columns by clicking the Preferences tab of the Cube View 
Manager. 

Note: If the Cube View Manager is not visible, then select OLAP > View 
Manager. 

 

 

 

 

 

 

 

 

 

 

 

3 Select Exclude empty rows from the results and Exclude empty columns 
from the results. 

Click the down arrow 

You can eliminate empty rows and columns 

Click Preferences 
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You see that the empty rows and columns have been removed from the grid and 
bar chart. 

4 Drill down on the All_Region row and the All_General_Ledger row until you 
see the general ledger expenses for Eugene and Beaverton.  

 

 

 

 

 

Both the grid and bar chart show the contribution of resource accounts to each 
product. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Drill downDrill down 
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5 In the Cube Dimensions Tree, add Dst Channel to Column. 

 

 

 

 

 

 

 

You see that the All_Channel dimension has been added to the grid and bar 
chart.  

6 Drill down on the added column in the grid. 

 

 

 

 

The table view should look like the following, showing the cost per channel for 
each product and service:  

 

 

 

 

 

 

 

Saving OLAP Views 

During the analysis, changes that you make to the Grid View, Chart View, and Cube 
Explorer View are retained during a session, even when you return to the OLAP page 
after viewing other tabs. However, when you close the session or when you close Grid 
View, Chart View, or Cube Explorer View, your changes are lost. 

To save these changes so that they will be available later, you must save the OLAP 
view. When you save an OLAP view, you save the layout and contents of the view. 
However, the window positions and states are not saved. 

 

Drill down
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 Save an OLAP view 

1 Select OLAP > Save View As. 

You see the Save OLAP View As dialog box. 

 

 

 

 

 

 

 

 

 

2 For Name, type Parcel Express Tutorial – Resource Contributions. Click 
OK. 

3 On the toolbar, click the OLAP Home link  

You see a link to Parcel Express Tutorial – Resource Contributions in the 
OLAP Views list. 

 

 

 

 

 

 

Using Measures in Cubes 

A measure is a property or an attribute that you can use to analyze OLAP 
information. The default measure is Cost. Now, you will create a new OLAP view using 
different measures. You will also create a custom measure. 

 

 Working with measures in OLAP 

1 Select File > New > OLAP View (or click New OLAP View). 

2 Select the Parcel Express Tutorial model. 
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3 Select the Resource Contributions cube. 

4 Click Finish. The resource contributions cube for the Parcel Express Tutorial 
model opens. 

5 Select Measure > Edit Measures. 

6 Select the following measures and click OK: 

Cost 
Profit 
Revenue 
UnitCost 
UnitProfit 
UnitRevenue 
 

 

 

 

 

 

 

 

 

 

 

 

When you drill down on products and services, you see that the 2nd Day 
Guaranteed product is losing money, while the other two products are profitable. 
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Note: To highlight the non-profitable cells in the table, select Highlight > Add 
Highlight and specify Profit Is less than 0.00. 

 

 

 

 

 

 

 

 

 

7 Use the Cube Dimensions Tree to add Dst Channel to Row.  

This will enable you to see whether this trend is similar across all channels. One 
of management’s goals was to make a profit of at least 10% on the 2nd Day 
Guaranteed product, and at least 25% on all other products. SAS Activity-Based 
Management has shown that the company’s profit picture is not what 
management expected. Competitive pressures forced the company to lower the 
price of their 2nd Day Guaranteed product, but it did not know that it was losing 
money on all products but the Walk In product.  

 

 

 

 

 

 

 

Now, you will create a custom measure to calculate gross margin. 

 

 Create a custom measure 

1 Select Measure > Add Measure. 
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You see Step 1 of the Create New Calculated Member. 

2 For Name, type GrossMargin, and then click Next. 

 

 

 

 

 

 

 

 

 

3 Select Simple calculations, and then click Next. 
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4 Select Ratio and Profit / Revenue, and then click Next. 

 

 

 

 

 

 

 

 

 

 

 

 

5 Select Percent % for Use format, and then click Finish. 

 

 

 

 

 

 

 

 

 

 

 

6 In the next dialog box, you can select whether the calculated measure is to be 
temporary, for this cube view only, or for this session. Select Available during 
this session only, and then click Next. 

You see the profit margin of each product. Based on the stated goals of the company, 
the 2nd Day Guaranteed is significantly underperforming. 
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If you select the Measure menu, you can see that GrossMargin has been added to 
the list of available measures (unless you chose Temporary for the scope of the 
measure, in which case GrossMargin is not added). 

 

 

 

 

 

 

Exporting Cubes 

At any point during OLAP analysis, you can export the displayed data to a Microsoft 
Excel spreadsheet. When you export to Microsoft Excel, you are exporting only the data 
that is currently displayed, not the entire cube. 

 

 Export an OLAP cube 

1 Display the OLAP data that you want to export to a Microsoft Excel spreadsheet. 

2 Select OLAP > Export to Excel. 

You see a Microsoft Excel spreadsheet that contains the data that is currently 
displayed in the cube. 
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Using the Cube Explorer View 

Now, you will analyze the model by using the Cube Explorer View to get more 
information about the costs that are associated with each product. The management of 
Parcel Express has learned that margins on the 2nd Day Guaranteed product fall well 
below expectations. The SAS Activity-Based Management OLAP tool will help 
management assess why costs for that product are higher than costs for other products. 

You will create a multi-stage contributions cube and use the Cube Explorer View to 
explore costs. 

 

 Create a multi-stage contributions cube 

1 Select File > New > OLAP View (or click New OLAP View). 

2 Select the Parcel Express Tutorial model. 

3 Select the Multi Stage Contributions cube. 

 

 

 

 

4 Click Finish. The multi-stage contributions cube for the Parcel Express Tutorial 
model opens. 

 

 Create a new Cube Explorer View 

1 Select Cube Explorer > New Cube Explorer View. 

 

 

 

 

 

 

You see the first page of the Create New Cube Explorer View. 

2 Click Cost_ObjectProducts and Services > All > 2nd Day Guaranteed, and 
then click Next. You will open the Cube Explorer View at the 2nd Day 
Guaranteed product because that is the product whose costs you want to explore. 



 Using OLAP Cubes for Analysis      Using the Cube Explorer View 119 

 

 

 

 

 

 

 

 

 

 

 

 

 

3 Select Cost and UnitCost as the measures to analyze, and then click Finish. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The Cube Explorer View opens at the 2nd Day Guaranteed product. 
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 Analyze the model in Cube Explorer View 

1 Select Apply color shadings based on > Measure values so that large costs 
will stand out by their color, and then select the colors to use if you want colors 
other than the default colors. 

 

 

 

 

 

 

 

 

 

2 Right-click 2nd Day Guaranteed and select Change To > Cost_ObjectRegion 
> Level3. 

 

 

 

 

 

 

 

 

 

 

 

You see the regional costs that contribute to the 2nd Day Guaranteed product. 

Cost 
UnitCost 

Select colors 

Color is determined by measures (Cost) 
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3 Because Eugene accounts for the larger part of costs (54.82%) of the 2nd Day 
Guaranteed product costs, drill down into Eugene to discover where those costs 
come from. Right-click Eugene and select Change To > Cost_ObjectChannel > 
Level1. 

 

 

 

 

 

 

 

 

 

 

 

 

You see that the Walk In channel contributes 52% to the costs of the 2nd Day 
Guaranteed product. Drill down into this channel to explore what accounts for its 
costs. 

4 Right-click Walk In and select Change To > ActivityActivities > Level2. 
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The Land Distribution set of activities stands out as constituting 47.90% of 
costs. 

5 Right-click Land Distribution and select Change To > ResourceGeneral 
Ledger > Level1. 
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Now you can see that the overwhelming part of this cost is for wages in Eugene—a 
full 86%. 

6 To confirm the finding that it is wages in Eugene that account for the high cost of 
the 2nd Day Guaranteed product, drill down on Beaverton for a comparison. 

a Right-click Beaverton and select Change To > Cost_ObjectChannel > Level1. 

b Right-click Walk In and select Change To > ActivityActivities > Level2. 

c Right-click Land Distribution and select Change To > ResourceGeneral Ledger > 
Level1. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Even though Wages account for a similar percentage of costs for the 2nd Day 
Guaranteed product in Beaverton, UnitCost for Beaverton is a fraction of UnitCost for 
Eugene, and the total cost in Beaverton is half of the total cost in Eugene. 

If you could put the two branches of the tree together, the picture would look like the 
following. The unit cost of wages in Eugene for land distribution ($7.00) is much higher 
than the unit cost of wages in Beaverton ($1.90). These costs play an important role in 
accounting for the total costs of the 2nd Day Guaranteed product. 



124 Using the Cube Explorer View      Chapter 15 

 

 

 



 125 

16 
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Now that you have created a SAS Activity-Based Management model and you have 
learned the basics of model analysis, you can begin designing and implementing your 
own models.  

Parcel Express Conclusions 

Using SAS Activity-Based Management, Parcel Express was able to see how costs 
flowed out of resource accounts to activities, and from activities to cost objects. In 
modeling the flow of costs through its business processes, the company learned that the 
2nd Day Guaranteed product, which managers had assumed was not performing as well 
as the other products, was performing far worse than expected, and was actually losing 
money across all channels.  

An OLAP analysis of the model showed that the percentages of costs that flowed from 
resource and activity accounts to cost object accounts was consistent across all product 
categories. Therefore, pricing seemed to be the primary reason for the 
underperformance. Another revelation was the amount of profit that was being made on 
the other two products. 

Management must now decide how much of a loss, if any, is acceptable for the 2nd 
Day Guaranteed product. How will a price change affect volume? Is the higher profit on 
other products enough to offset the loss on the 2nd Day Guaranteed product?  

To assess the impact of changes to the pricing structure, Parcel Express can use SAS 
Activity-Based Management to model possible future scenarios. 

Additional Features 

Many SAS Activity-Based Management features are not covered in this tutorial or are 
only briefly covered. These features include: 

 importing data from other information systems 
 importing models from databases, XML, or Oros 

C H A P T E R  
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 exporting models to databases or XML 
 sharing models 
 managing the ownership and permissions for items 
 publishing period/scenario associations 
 managing item properties 
 selecting currencies and exchange rates 
 working with internal units 
 creating stage attributes 
 variable quantity drivers 
 assigned idle cost 
 allocated cost 
 creating custom report templates 
 using the SAS Services API 

To build effective and complete models for your organization, you will want to use 
some of these additional features. Because your models will be much larger than the 
Parcel Express Tutorial model, you might want to read about model size and 
performance in the online Help. You can also consult the SAS Activity-Based 
Management: User’s Guide at http://support.sas.com/documentation/onlinedoc/abm/. 

What to Do Next 

If you felt comfortable using the basic tools and techniques in this tutorial to build the 
Parcel Express Tutorial model, use them on a simple project of your own. 

SAS has a variety of products, including videotapes and training classes, that can 
help you learn more about activity-based costing, management, and budgeting. In 
addition, SAS can help you build models for your organization. If you need additional 
information, contact your on-site SAS support personnel. 
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Your Turn

If you have comments or suggestions about Getting Started with SAS® Activity-Based
Management 6.3, please send them to us on a photocopy of this page, or send us
electronic mail.

For comments about this book, please return the photocopy to

SAS Publishing
SAS Campus Drive
Cary, NC 27513
E-mail: yourturn@sas.com

For suggestions about the software, please return the photocopy to

SAS Institute Inc.
Technical Support Division
SAS Campus Drive
Cary, NC 27513
E-mail: suggest@sas.com
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