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What Is the SAS Add-In for Microsoft Office?

The SAS Add-In for Microsoft Office extends the functionality of Microsoft Excel,
Microsoft Word, and Microsoft PowerPoint by enabling you to access SAS analytics and
SAS reporting functionality without any SAS programming experience. The SAS add-in
is designed for users who are familiar with these Microsoft Office programs but who
might be new to SAS.

The SAS add-in includes approximately 80 SAS tasks that enable you to perform a
variety of analyses. Examples of analyses that you can perform include linear and
nonlinear regressions, multivariate analyses, time series analyses, one-way frequencies,
and summary statistics. The SAS add-in enables you to refresh these analyses so that
your results include the most up-to-date information. You can also easily share the
results with others at your site.

When the SAS add-in is installed on your computer, a SAS menu and the SAS
Analysis Tools toolbar are automatically integrated into Excel, Word, and PowerPoint.
(In Excel, the SAS Data Tools toolbar is also available.) The menu and toolbars enable
you to access the SAS analytics and reporting functionality directly from these
Microsoft Office programs without having to open a separate SAS interface.

Benefits to Using the SAS Add-In for Microsoft Office

Most of the SAS add-in functionality is identical in Excel, Word, and PowerPoint; for
example, you can run analyses and reports in all three applications.

The SAS add-in extends the functionality in Excel, Word, and PowerPoint by
enabling you to complete the following tasks:

0O Access SAS data sources as the input data for your analysis. You can view any
SAS data source or any data source available from your SAS server (including
databases such as Oracle, Teradata, and DB2).

0O Perform more sophisticated analysis and computations than what is available in
Microsoft Excel. For example, one of the sophisticated analyses that SAS provides
is the Canonical Correlation task. This task enables you to examine the
relationship between a linear combination of a set of X variables and a linear
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combination of a set of Y variables. You might run a canonical correlation analysis
to determine the degree of correspondence between a set of job characteristics and
a set of measures of employee satisfaction. This extends the correlation analysis
that is available in Excel. You can run these sophisticated analyses and
computations in Excel, Word, or PowerPoint.

Run custom analyses that were developed by others at your company. Using the
SAS add-in, you can also access programs, which are called SAS Stored Processes.
These programs are customized SAS code that is developed by business analysts or
your IT department. Running these programs enables you to quickly generate a
custom report without writing any SAS code.

Refresh the content in the Excel worksheet, Word document, or PowerPoint
presentation on demand or automatically at a specified time. Scheduling when the
content is refreshed enables you to have the most up-to-date data and reports
when you need it.

Publish the results to a central location. By publishing a document, you can share
it with others without having to e-mail it. If you publish the document to a
metadata repository, then you can perform an impact analysis on the document.
Impact analysis enables you to see where a data source came from and the items
that are dependent on this source. This analysis enables you to know how
changing a data source might affect other documents.

Additional functionality is available in Excel. In Microsoft Excel, you can also
complete the following tasks:

O Access and view data sources that exceed the 65,536 record limitation in Excel. The

SAS add-in does its processing on the server, which enables it to by-pass the
record limitation in Excel.

Copy data to a SAS server. You can copy an Excel data source or a SAS data
source to the SAS server. After a data source is copied to a SAS server, it becomes
a SAS data set. This enables you to share Excel data with Word and PowerPoint
users at your site. This functionality also enables Excel users to update
information in a SAS data source and upload it to the SAS server.

Send the results from an analysis that you ran in Excel to a Word document or
PowerPoint presentation. For example, you ran analysis of your company’s sales
for this year, and now you need to give a presentation of the results. Using this
functionality in Excel, you can select which results to include in a PowerPoint
presentation. This saves you time because you only need to run the analysis once.

This book explores some of the basic tasks that you can perform in Excel.

How to Use the SAS Add-In for Microsoft Office

When you open Microsoft Excel, Microsoft Word, or Microsoft PowerPoint, you should
see a SAS menu item and the SAS Analysis Tools toolbar. (In Excel, the SAS Data Tools
toolbar is also available.). You access the SAS add-in from the menu or from these
toolbars.

Note: If you do not see a SAS menu item or the toolbars, then you might not have
the SAS add-in installed. For help, contact the SAS administrator at your site. A
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Display 1.1 Location of SAS Menu in Microsoft Excel
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You can perform a variety of tasks using the SAS add-in. The following process
briefly explains how you would run a SAS analysis:

1 Open Microsoft Excel, Microsoft Word, or Microsoft PowerPoint.
2 Select the analysis that you want to perform.
Note: After you select the analysis, you are prompted to login to the SAS server if

you have not previously logged in during the current session. You must be
connected to a SAS server to run an analysis or to access a SAS data source. A

3 Select the data source that you want to use in the analysis. In Excel, you can use
data in an existing Excel worksheet or in a SAS data source. If you select a SAS
data source, you can choose to filter and sort the data before the analysis.

4 Select the options in the analysis that you want to use and then run the analysis.
5 Specify the location of the output. For example in Excel, you can choose to include
the results in the existing worksheet, in a new worksheet, or in a new workbook.

The results automatically open in Excel, Word, or PowerPoint in the location that
you chose.

Accessibility Features of the SAS Add-In for Microsoft Office

The SAS Add-In for Microsoft Office includes accessibility and compatibility features
that improve usability of the product for users with disabilities. These features are
related to accessibility standards for electronic information technology adopted by the
U.S. Government under Section 508 of the U.S. Rehabilitation Act of 1973, as amended.
For more information about the accessibility of the SAS Add-In for Microsoft, see the
online Help.

If you have questions or concerns about the accessibility of SAS products, send e-mail
to accessibility@sas.com.
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Ahout the Scenario in This Book

This book is intended for Microsoft Excel users. Each topic in this book builds on the
previous topic, so you must work through the chapters in sequence.

For the purpose of the scenario in this book, you are a data analyst for a company
that sells men’s and women’s shoes worldwide. You have been asked to analyze the
company’s global sales for 2006. The data is saved as a SAS data source. Your company
recently purchased the SAS Add-In for Microsoft Office, so you can now access SAS
data sources from Excel. You are an experienced Excel user, but are new to SAS.

The next three chapters provide step-by-step instructions for analyzing a data source
and creating an Excel workbook that can be shared with others at your site. During the
first part of the scenario, you will open in an Excel worksheet the SAS data source that
contains your company’s 2006 sales data. Then you will run four SAS tasks to analyze
the data. Running these SAS tasks will enable you to answer the following questions:

0 Which product had the highest sales in 2006? Which product had the lowest sales?

0 What are the average total sales, average total inventory, and average returns for
each product?

O Is there a correlation between the total sales and inventory and returns for each
product?

0 Which parameters (inventory, returns, and number of stores) determine the total
sales for a product?

After answering these questions, you are asked to analyze the sales for the product
line with the lowest sales. During this second part of the scenario, you will open the
SAS data source into a PivotTable report to answer the following questions:

o0 Which regions have sales less than $10,000?
0 Which region has the lowest sales? What are the sales and inventory costs for
each subsidiary in that region?

By the end of this scenario, you will have an Excel worksheet that you can publish to
a common repository, so it can be viewed by other SAS add-in users at your site.
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Prerequisites for This Scenario

By the time that you are ready to perform the tasks in this book, administrators at
your site should have installed and configured all necessary components of the SAS
Enterprise Intelligence Platform. You must also have the following:

0 The 21AMOO03 hotfix for the SAS Add-In 2.1 for Microsoft Office. This hotfix was
released in the summer of 2006. Your site administrator can install this hotfix
from http://www.sas.com/techsup/download/hotfix/amo21.html.

Note: You need this hotfix only to perform the steps in Chapter 5, “Analyzing a
SAS Data Source in a PivotTable Report,” on page 37. You can perform the rest of
the steps in this book without the hotfix. A

O Microsoft Office 2000, Microsoft Office XP, or Microsoft Office 2003 installed on
your desktop.

O Permissions to access the SAS Metadata Server. Your site administrator sets these
permissions. Contact your site administrator for the name and location of the SAS
Metadata Server.

0 A metadata configuration file to specify which SAS Metadata Server you will
connect to by default. This file enables you to access SAS data sources on remote
servers. For more information about setting up a metadata configuration file, see
the online Help for the SAS add-in.

O Access to the SHOES data source that is available in the SASHELP library. This
is the data source that you will be using during the analysis. The SASHELP

library ships with the SAS Add-In for Microsoft Office. If you do not have access to
this SAS library, contact your site administrator.

How to Get Help for the SAS Add-In for Microsoft Office

Use any of the following methods to get Help for the SAS Add-In for Microsoft Office:
O From the menu bar, select SAS » SAS Add-In for Microsoft Office Help.
0 Press F1 in most application windows and dialog boxes.
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About the Tasks That You Will Perform

To open and view the data that you will be using in the analysis, you will perform
the following main tasks:

1 You will select the data source to open.

Note: In this scenario, you are accessing a SAS data source from the SAS server.
However, you can use the SAS add-in to access data from a database, such as
Oracle, Teradata, and DB2. In Excel, you can also use Excel worksheets as the
data source. A

2 For the data source, you will select the following:
O the variables to include in the output
0 how to sort the data
O the output location for the data

Open the Sales Data in an Excel Worksheet

To open the SHOES data source (which is available in the SASHELP library) in
Excel, complete the following steps:

1 Select Start » Programs » Microsoft Office » Microsoft Excel.
Microsoft Excel opens. In the menu bar, you should see a SAS menu item. You
access the SAS add-in from this menu.

Note: If you do not see a SAS menu item, then you might not have the SAS
add-in installed. For help, contact the SAS administrator at your site. A

Display 3.1 Location of SAS Menu in Microsoft Excel
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2 Select SAS » Open Data Source » Into Worksheet. The Open Data Source
window opens.

Click

4 From the Look in drop-down list, select SASHELP. The Open Data Source window
now displays the contents of the SASHELP library.

to select the SAS server that you want to use.

7. Open Data Source
SASHELF
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Note: The location of the SASHELP library is dependent on how SAS was
installed at your site. If you cannot find the SASHELP library, contact the SAS
administrator at your site. A
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5 In the SASHELP library, select the SHOES data source. The variables in the
SHOES data source automatically appear in the Variables pane.

7. Open Data Source
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7 On the variables tab, select the variables that you want to include in the final
output. You can also specify the order of the variables.

Click to move all the variables from the Available list box to the
Selected list box. Select the variables so they appear in the following order:

£ Modify Data Source - SASHELP.SHOES

Char Fegion

Char Product

Char Subsidiary

Mum Murnber of Stores

Currency Total Sales
Currency Total Inventory
Currency Total A eturns

Click the sort tab to continue.
8 On the sort tab, you can specify the order of the rows in the output.
Use the drop-down lists to specify the following sort order:

£ Modify Data Source - SASHELP.SHOES

[Fegon ]

Product

Click the output Location tab to continue.
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9 On the output Location tab, you can select the location for the final output.

By default, the data source is opened in a new worksheet. In the Named box,
delete SASHELP.SHOES and type Worldwide Shoe Sales.

£ Modify Data Source - SASHELP.SHOES

worldwide Shoe S ales

Region Product Subsidiary Stares | Sales Inventory  Returns
1|Africa Boot Algiers iy §21 297 §73.737 §710
2| Aftica Boot Kinshasa 16 13921 70736 §553
3| Africa Boot Caira 20 54 846 518 965 F229
4| Africa Boot Luanda =] $5 081 351 672 325
a|Africa Boot Khartoum 24 §19282 $105370 $700
| Africa Boot Addis Ahaba 12 §29761  §191 821 §7E9
7 |Africa Boot Mairobi 25 §16 2582 §RE 017 fa44
G| Africa Boot Johannesburg 14 58,365 3011 F483
9| Africa Men's Casual Algiers 4 F53 206 0 F100 982 0 F22M

10| Aftica Men's Casual Addis Ababa 4 67 242 $118036 | §2.284
11| Aftica Men's Casual Luanda 3 $52893 $149864  §17M1
12| Aftica Men's Casual Khartoum 1 58 244 16 230 478
13| Africa Men's Casual Cairo 25 §360209 51063251 §9.424
14 |Africa Men's Dress Algiers 13 $123743 0 3428575 | 3621
16 |Africa Men's Dress khartoum 3 $18 053 561,132 1077
16| Aftica Men's Dress Mairohbi 1 58 587 §20 877 §3E3
17 |Africa Men's Dress Addis Ababa 7 §76793 0 $136273  §2.433
18 |Aftica Men's Dress Kinshasa 5 a7 531 595 563 §1 /90
19| Africa Men's Dress Cairo 5 54 051 345 962 a7
20| Africa Men's Dress Luanda 2 F2o a32 a7 247 705
21| Africa Sandal Kinshasa 10 $16662  §104 438 3611
22| Africa Sandal Luanda 9 §11.145 $195900 §R57
23| Aftica Sandal Mairobi 19 §16 289 47 406 §1,175
24| Africa Sandal Khartoum 18 G20 427 331825 0§12
2A|Africa Sandal Algiers 25 F29. 195 534 447 0 §1 630
26 | Africa Sandal Cairo 9 $10 532 $A0 430 $a95
Africa Sandal Johannesburg 13 17 337 $53,003 $809
Addis Ababa 52819 5204 284 §1 851

Aftica Sandal
Worldwide Shoe Sales 3

Tip: By default, the SAS add-in displays the variable names in the first row of
the Excel worksheet. If a variable name has a label, a red triangle appears in the
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upper right corner of the cell that contains the variable name. To view the label,
place your mouse over the triangle. In this example, the Stores, Sales, Inventory,
and Returns variables have labels.

As you scroll through the data, you will see the following:

0 Ten regions are represented: Africa, Asia, Canada, Central America/Caribbean,
Eastern Europe, Middle East, Pacific, South America, United States, and Western
Europe.

0 There are eight product types: Boot, Men’s Casual, Men’s Dress, Sandal, Slipper,
Sport Shoe, Women’s Casual, and Women’s Dress.

0 For each Region, the data is divided into product and subsidiary.

0 For each subsidiary, the data contains the number of stores that sell each product,
the total sales, total inventory, and total returns for the product.

Save the Workhook

To save the workbook, complete the following steps:
1 Select File » Save As. The Save As dialog box opens.

2 From the save in drop-down list, select ¢:\Program Files\SAS\Add-In for
Microsoft Office.

3 Type shoe Sales 2006 in the File name box.

Save As 7] %]
Save in: I[:l Add-In for Microsoft Office j -~ | @ x ﬁ + Tools =

hotfix
Shoe Sales 200545

Hiskary

&

My Dacuments

N File pame:  [Shoe Sales 2006)ds -
Py Metwark,

Places Save as bype: IMichsnFt Excel Warkbook (*.xls) j Caniel I
&)

4 Click save to save the workbook.

You are now ready to analyze the data source. For the next steps, see Chapter 4,
“Running SAS Tasks to Analyze the Data,” on page 13.
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About the Tasks That You Will Perform

These tasks assume that you have the SHOES data source open in a Microsoft Excel
worksheet. For these steps, see Chapter 3, “Opening a SAS Data Source in Microsoft
Excel,” on page 7.

To analyze the data, you will perform the following main tasks:

1 You will create a bar chart to compare the sales of each product and to determine
which products have the highest and lowest sales.

2 You will use summary statistics to determine the average total sales, average total
inventory, and average returns for each product.

3 You will determine if there is any correlation between the total sales and total
inventory and total returns for each product.

4 You will use a linear regression to determine if the parameter estimates for
inventory, returns, and number of stores should be included in a linear regression
model of sales.
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Compare Sales for Each Product

To create a bar chart that shows the sales for each product, complete the following
steps:
1 From the Active Data drop-down list on the SAS Data Analysis toolbar, verify
that SASHELP.SHOES is the active data source that you opened in the previous
chapter.

Note: In the Active Data drop-down list, the name of the SAS server appears
before the name of the data source. The name of the server depends on the SAS
server at your site. A

- Active Data: 1545Main SASHELP.SHOES = | Analyze Data | | Reports SAS Favaites~ vl [w) /] .'_.Jg =8

e

Tip: In Excel, data sources that are open are at the top of the list and have an
exclamation point (!) before the name. The current selection is the active data
source by default. Therefore, depending on where your cursor is in a worksheet,
you might have a different active data source.

2 Select SAS » Analyze Data from the main menu. The Analyze Data window opens.

[Hper

Cancel |

X
w16 g
(=g Mame  ~ | Tupe | D escription
(23 ANDvA (23 ANOvA Folder
{53 Capabilty [ Capabilty Folder
{23 Control Chatts [E5 Cortrol Charts Folder
% g:tsiribe [ Data Folder
B9 Gragh % gescr:ibe Eo:jer
. rapl older
% mo;:l.el S.conng @I Model Scoring Falder
ultivariate T

{Eg Pareto [E Multivariate Folder
{85 Fiegression [T Pareta Folder
{2 Survival Analysis [E3 Regression Fuolder
{B5) Time Series B Survival Analysis Folder
[E Time Series Folder

| |

|

Tip: You can also open the Analyze Data window by clicking in the

SAS Data Analysis toolbar.
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3 In the left pane, select Graph. The list of available graph tasks appears in the
right pane.

EA Analpze Data x|

w16 g
B3 545 Tasks Mame ~ | Type | D escription
{2 ANDV& m Area Plat Task Gererate a Area Plat for & zet of data.
{23 Capabilty il Bar Chart Task Generate a Bar Chart for a set of data.
% gontlol Charts h,} Bar Chart 'Wizard ‘Wizard Generate a Bar Chart for a set of data.
@ Data " Ped BarLine Chart Task Generate a Bar-Line Chart for a set of data
=y I'il ® [t Box Plot Task Generate a Box Plot for a set of data.
Sl . [ Bubbie Plot Task Generate a Bubble Plot for a set of data.
(38 Model Scoring
[E5) Multivariate Contour Plot Task Gererate a Contour Plot for a set of data
B9 Pareta & Create kap Feature Table Task Create a feature table for a map data zet
-{B5) Regressian &5 Donut Chart Task Gererate a Donut Chart for a set of data
(B3] Survival Analysis [l Imteractive Graphics Task Evaluate the data in different graphs
{B5) Time Series | Line Plat Task Generate a Line Plot for a et of data
% Line Plot Wizard Wizard Generate a Line Plot for a et of data
¥ tap Graph Task Generate a Map Graph for a set of data
W Fie Chart Task Generate a Pie Chart for a set of data
€ Fie Chart ‘wizard ‘izard Generate a Pie Chart for a set of data
4( Fadar Chart Task Generate a Fadar Chart for a set of data
| Scatter Plat Tazk Gererate a Scatter Plot for a set of data
Qf Surface Plot Taszk Generate a Surface Plot for a set of data
4] | |
[Hper | Cancel |

|

4 Select Bar Chart Wizard and click open. The Bar Chart Wizard opens.

5 In step 1 of the wizard, you can verify that you have selected the data source that

you want to use, but you cannot change the data source after you have opened a
SAS task.
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For this example, you should have the SHOES data source as the active data.
Click Next to continue.

Bar Chart for _TEMP_SHOES

1otd  Werity Data

6 In step 2 of the wizard, you can assign variables from the data to roles. You can
also specify whether to create a horizontal bar chart. By default, the Bar Chart
Wizard creates vertical bar charts.

In the second step, specify the following options:
0 From the Bars drop-down list, select Product.
0 From the Bar height drop-down list, select Sales.
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Bar Chart for _TEMP_SHOES

2 ofd Assignwariahles to roles

APeict )
- =

[N e
min e e

Click Next to continue.
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7 In step 3 of the wizard, you can specify the appearance of the chart.
In the third step, specify the following options:
0 Clear the 3D chart check box.

O Select the pata labels check box, and then select Sum from the drop-down
list.

Bar Chart for _TEMP_SHOES

3ot4 Specify appearance
[

barsthesame) 1]
I8

5| Legend: —FI

——

Click Next to continue.

8 In step 4 of the wizard, you can customize the title and footnote for the chart. The
Bar Chart Wizard provides a default title and footnote.
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In the Graph box, delete Bar Chart and type Total Sales for Each Product.

Bar Chart for _TEMP_SHOES

4 of4 Prowide atitle and footnote

T otal Sales for Each Product

Generated by SA5 [5_SASSERVERMAME, &5SSCPL] on ZSYSFUNCIDATE(,
EURDFDER.] at ZSYSFUMCITIME(). TIMEAMPME.)

Click Finish. The Choose Location dialog box opens.

9 From the Choose Location dialog box, select New worksheet and in the Named box,
type Total Sales for Each Product.

Chooze Location

r———

Total Sales for Each Praduct
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Click ok.The results open in a new worksheet called Total Sales for Each

Product.

A | B | ¢ | o | E | F | & | H [ 1 [ J [ K
| 1 | Total Sales for Each Product
2
% Total Sales
| 5 |
[ 6 38,000,000 §7.933,707
7 ]
g
R $7 000,000 —
10 1 §6,175 634 $6,226, 475
11 —
K 6,000,000 §5.507 243
13
(94| $5.000,000 —
15 I 54,137 951
16 400,000
17
16 1
| 12|  $3,000,000 —
| 20 | | $2,350 543
21
(22 $2 000,000
=l 7
| 24 | §1,000,000 — $558 435 $651 467
| 25 -
e 50—
| 27 | Boat hen's hen's Sandal  Slipper Sport Women's Women's
| 28 | Casual Dress Shoe Casual  Dress —
29

Product

30
W 4 b wfy Sheetl £ Worldwide Shoe Sales h Total Sales for Each Product 4 Sheet2 # 4]
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The bar chart shows the following:
o0 Men’s Casual shoes had the highest sales with $7,933,707.
O Sport Shoes had the lowest sales with $651,467.

Determine Average Sales, Inventory, and Returns for Each Product

To create an analysis that shows the average sales, inventory, and returns for each

product, complete the following steps:

1 From the Active Data drop-down list on the SAS Data Analysis toolbar, verify

that SASHELP.SHOES is the active data source.

- Active Data: 1545Main SASHELP.SHOES » = Analyze Data | | Reports SAS Favorites - | 1 [ A

B 7

2 Select SAS » Analyze Data from the main menu. The Analyze Data window opens.



Running SAS Tasks to Analyze the Data /A Determine Average Sales, Inventory, and Returns for Each Product 21

3 In the left pane, select Describe. The list of tasks in this category appears in the
right pane.

EA Analpze Data x|
w16 g
B3 545 Tasks Mame ~ | Type | D escription
{1 ANDV& [20 Characterize D ata Wizard  Wizard Compute data characteristics
% Eapab:htﬁyh il Distribution Analysis Task Perfarm a Distribution Analysis
ontrol Charts List D ata Task Create list data
{51 Dala One*w/ay Frequencies Task Generate simple frequency counts on data
B3 Gragh = Z Summary Statistics Task Generate summary statistics for a set of data
B9 Madel Scoring Zi: Summary Statistics Wizard  Wizard Generate summary statistics for a set of data
[E5) Multivariate [E summary Tables Task Create a tabular surnmary of the data
B9 Pareta ﬁ Summary Tables Wizard wizard Create a tabular summary of the data
-{B5) Regressian 5 Table Analysis Task Perform table analysiz
{EG) Survival Analysis
-[Z8 Time Seres
4] | -l
[ e | Cancel |
A

4 Select summary Statistics Wizard and click Open. The Summary Statistics
Wizard opens.

5 In step 1 of the wizard, you can verify that you have selected the data source that
you want to use, but you cannot change the data source after you have opened a
SAS task.



22 Determine Average Sales, Inventory, and Returns for Each Product A Chapter 4

For this example, you should have the SHOES data source as the active data.
Summary Statistics for _TEMP_SHOES

1otd  Werity Data

Click Next to continue.
6 In step 2 of the wizard, you can assign variables from the data to roles.

Select the following variables in the Available variables pane and drag and
drop them to the following roles:

Variables Role

Sales, Inventory, Returns ~ Summary statistics of (Analysis variable)

Product For each value of (Classification variable)
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Summary Statistics for _TEMP_SHOES

2 ofd Assignwariahles to roles

D

=

Sas.
-
-
.
-
=
—
-
=
-

[Optional)
Dirop vanables here,

Click Next to continue.

7 In step 3 of the wizard, you can specify the statistics and the results to include in
the output. By default, the Summary Statistics task calculates the mean, standard
deviation, minimum, maximum, and number of observations for each classification
variable. However, you want to include the range of values and remove the
number of observations from the output.

To specify the statistics to include in the output, complete the following steps:
a Click Edit. The Edit Statistics dialog box opens.
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b On the Basic tab, select the Range check box, and clear the Number of
observations check box.

Edit Statistics

ST BF WEGHLE

i S i R

l
l

EO

[ ok ]| coed | ben |

¢ Click OK to return to step 3 of the Summary Statistics Wizard.

The statistics that are listed in the Summary Statistics Wizard should now be
the following:

Summary Statistics for _TEMP_SHOES

3ot4 Specify statistics and results

e

[ B B

Click Next to continue.
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8 In step 4 of the wizard, you can customize the title and footnote for the output.
In the Analysis box, delete Summary Statistics Results and type Summary
Statistics for Each Product.

Summary Statistics for _TEMP_SHOES

4 of4 Prowide title and footnote

Summary Statistics for Each Product

Generated by SA5 (5_SASSERVERNAME, &5YSSCPL) on %STSFUNCIDATE(), EJRDFDEY,)
at ZSYSFUNCITIMED, TIMEAMPME,)

Click Finish. The Choose Location dialog box opens.
9 In the Choose Location dialog box, select New worksheet, and click OK.

Chooze Location

r———

Summary Statistics

The results open in a new worksheet called Summary Statistics.
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& [ B ] C [ D [ E [ F [ G [ H s
| 1| Summary Statistics for Each Product Il
2
3 |Product “ariahle  |Label Mean Std Dy Minirnurm Maximurm Range
| 4 |Boat Sales Total Sales 4520275 45705.28307 1179 286497 285318
| 5 | Inventory | Total Inventory 187012.9038| 172214.3691 374 882080 881706
5 Returns | Total Returns 1896.576923| 1652972277 50 2160 9050
| 7 |Men's Casual Sales Taotal Sales 176304.6| 2245599038 9244 1298717 1289473
| 8 | Inventory | Total Inventory 379672.2869| 504518.0812 2176 2881005 28785829
9 Returns  |Total Returns £911.888880| 9505.673749 478 57362 56884
| 10 |Men's Dress Sales Taotal Sales 110144.86| 126085.4346 3033 7E7798 754765
| 11 | Inventory [ Total Inventory 280146.8| 318693.6945 538 18347553 1847021
12 Returns  |Tatal Returns 3281.98| 3160150704 52 16833 16781
| 13 |Sandal Sales Taotal Sales 17723.18367 | 31555.64156 325 200156 199331
| 14 | Inventory | Total Inventory 55564, 79552 |  101080.6854 960 624163 623203
15 Returns | Total Returns V78.9795818| 1341.493547 10 8365 8355
| 16 | Slipper Sales Total Sales 118766.0385| 127423.85M1 3019 700513 B97494
| 17 | Inventory | Taotal Inventory 427526.5385| 4514527593 10234 2520085 25059551
18 Returns | Total Returns 4037 3076592 4029.218309 127 21247 21120
| 19 | Sport Shoe Sales Tatal Sales 12773.86275| 17910.53844 449 101922 101473
| 20 | Inventory [ Total Inventaory 65151.01961| 793441466 485 370365 369933
21 Returns | Total Returns 493.7058824 | B94.7706469 10 4204 4194
| 22 WWomen's Casual |Sales Taotal Sales 91952 46657 | 1058629157 5389 502636 497247
| 23 | Inventory | Taotal Inventory 215481.1333| 2514227633 G972 1110412 1103440
24 Returns  |Taotal Returns 2915866667 | 3561.211659 185 17445 17263
| 258 WWomen's Dress  |Sales Total Sales 122087.7451| 138840.1593 4659 7a6347 751658
| 26 | Inventory | Taotal Inventory 3I7EEZ5.0784| 44763 5925 19899 2503387 2483488
27 Returns  |Taotal Returns IFE7NTBA7 | M7 352121 210 19378 19168
28
29 Generated by SAS (SASMain, NET SRV) on O7DEC2008 at 10:57 A |
|<qn< v nfi_Sheetl £ Worldwide Shoe Sales b, Summary Statistics f Total Sales for Each Produc | 4 | | LLH

The output shows the mean, standard deviation, minimum value, maximum value
and range of the total sales, total inventory, and total returns for each product. After
analyzing the data, you note the following:

0 For each product, the average total cost of the inventory exceeds the average total
sales. For example, for Boots, the average total inventory is $187,012.90, but the
average total sales is only $45,202.75.

0 The ranges for all products is rather large. For example, for Boots, the average
total sales ranges from $1,179 to $286,497. This large range implies that sales for
boots vary across stores worldwide.

Determine Correlation between Sales, Inventory, and Returns

In the previous analysis, you saw that total inventory exceed sales for all products.
Therefore, you want to analyze whether there is any correlation between total inventory
and sales. You also decide to analyze the correlation between total returns and sales.

To determine if there is a correlation between these items, complete the following
steps:

1 From the Active Data drop-down list on the SAS Data Analysis toolbar, verify
that SASHELP.SHOES is the active data source.

Active Data: 1545k ain SASHELFP SHOES ~ 2 Analyze Data | | Reports 545 Favorites ~ i'sl Eﬂ | ] _'_Jg ;_'

e

2 Select SAS » Analyze Data from the main menu. The Analyze Data window opens.
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3 In the left pane, select Multivariate. The list of tasks in this category appears in
the right pane.

EA Analpze Data x|
NS
B3 545 Tasks Mame ~ | Type | D escription

{ﬁ ANDV& | Canomical Comelation Task Performi a canonical correlation analysiz

{ﬁ Capability [+ Cluster Analysiz Task Perfarm a cluster analysis

% gontlol Chats |+ Comelations Task Perfarm a comelation

@__‘H Data b [ Factar Analysis Task, Perform a factor analysis

escribe 5 po o .

5 Graph i Frincipal Components Task Performn a principal components analysis

(38 Model Scoring

[T Pareto

(28 Regression

[T Survival Analysiz

-[Z8 Time Seres

4] | |
[Hper | Cancel |
A

4 Select correlations and click open. The Correlations task opens.
5 In the Task Roles panel, you can assign variables from the data to roles.

Select the following variables in the variables to assign pane and drag and
drop them to the following roles:

Variables Role

Sales Analysis variable

Inventory, Returns Correlate with
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In the selection pane, select Results to continue.

6 In the Results panel, you can specify whether to include any plots in the output
and what statistics to include in the output. You can also view a summary of the
correlations for the task.
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For this analysis, select the Create a scatter plot for each correlation
pair check box.

Correlations for _TEMP_SHOES

Task Roles
Options

Rl

Output D ata
Titles

1 q

HGTS FEr fE)

In the selection pane, select Titles to continue.
7 In the Titles panel, you can customize the title and footnote for the output.
To create a customize title for the analysis, complete the following steps:

a In the Section area, select Analysis Titles.

b In the Text for section: Analysis Titles area, clear the Use default
text check box.

¢ Delete the default text and type Correlation of Sales to Inventory and
Returns.
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Correlations for _TEMP_SHOES

Task Roles
Options
Results
Output D ata

Correlation of Sales to lrwentory and Retumns

Click Run. The Choose Location dialog box opens.
8 In the Choose Location dialog box, select New worksheet, and click OK.

Chooze Location

r———

Correlations

The results open in a new worksheet called Correlations.
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A [ B | ¢© D] E [ F [ G [ H =
| 1| Carrelation of Sales to Inventory and Returns [~
2
ER [2 With “ariables: [Invertory Returns |
| 4 | |1 “ariables: |Sa|es |
| 5
= Simple Statistics
| 7| “ariable il tean Std Dev Sum|  Minimum| Maximum]|Label
| 8 | Irveritory 395| 250825.9 3515146268 22105051 374 2881005(Tatal Inventory
| 9 | Returns 395| 296732 4611.742654 1172092 10 57362 [Tatal Returns |
| 10 | Sales 395| 85700.17 1291072339 33551566 324] 1298717 [Tatal Sales
Il
Pearson Correlation Coefficients, M=
325
| 12 | Prob = |r] under HO: Rho=0
| 13 | Sales
| 14 | Irventory 0.95444
| 15 | Total Inventary 1.6575E-208
| 16 | Returns 0.56434
| 17 | Total Returns 5.6761E-229
18
1 19 | Generated by SAZ (SASMain, NET_SRY) on O7DEC2006 at 11:00 Ahd
| 20 |
| 21 |
| 22 | Correlations Plots
| 23 |
| 24 | Scatter plot of Sales by Inventory
| 25 |
% Total Sales -
M4 M)y Sheetl Worldwide Shoe Sales Correlations Summary Statistics Total Sales F | 4 | I _»IH

The output shows the correlation statistics for the correlation between sales and
inventory and sales and returns. The analysis shows the following:

0 The correlation between sales and inventory is 0.95444. This implies a strong
positive correlation between sales and inventory.

0 The correlation between sales and returns is 0.96434. This implies a strong
positive correlation between sales and returns.

0 The scatter plots also reflect this strong positive correlation. The scatter plots also
show a few outliers as sales reach $1,400,000.

Perform a Linear Regression Analysis

In the previous analysis, you saw that total inventory and returns were strongly
correlated to sales. You now want to perform a linear regression analysis on the data.
You want to determine what model you can use to determine total sales for each product.

To run a linear regression analysis, complete the following steps:

1 From the Active Data drop-down list on the SAS Data Analysis toolbar, verify
that SASHELP.SHOES is the active data source.

Aetive Data: 1545Main S45HELP.SHOES = | Analyze Data | | Reports SAS Favaites~ &) ) ] i ¢ 2 .

Select SAS » Analyze Data from the main menu. The Analyze Data window opens.

In the left pane, select Regression. The list of tasks in this category appears in
the right pane.

Select Linear and click open. The Linear task opens.
In the Task Roles panel, you can assign variables from the data to roles.

Select the following variables in the variables to assign pane and drag and
drop them to the following roles:
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Variables

Role

Sales
Inventory, Returns

Product

Dependent variable
Explanatory variables

Group analysis by

In the selection pane, select Titles to continue.
6 In the Titles panel, you can customize the title and footnote for the output.
To create a customize title for the analysis, complete the following steps:

a In the Section area, select Linear Regression.
b In the Text for section:

default text check box.

¢ Delete the default text and type Linear Regression Results for Each

Product.

Linear Regression area, clear the Use
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Linear for _TEMP_SHOES

Task Roles
todel
Statistics
Plats

Predoted | Linear Regression

Plats Linear Regression Results for Each Product

Residual -
Influence Fredictions

Predictions ~ Footriote

Click Run. The Choose Location dialog box opens.

7 In the Choose Location dialog box, select New worksheet and in the Named box,
type Linear Regression.

Chooze Location

r———

Linear Fegression

Click ok. The results open in a new worksheet called Linear Regression.
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[}

& B | C | ] | E F | &
| 1| Linear Regression Results for Each Product
2
E Model: Linear_Regression_Model
| 4 | Dependent Variable: Sales Total Sales
o
E Product=Boot
| 7 |
[ 5 | [Mumber of Observations Read | 52]
EN |Numher of Observations Used | 52|
10
Il Analysis of Variance
Surn aof] Mean
12 |Source DF Squares Sguare F “alue Pr=F
13 |Model 2 1.00852E+11| 50445914055 437 52| 5.54E-52
14 |Error 43 5545789755 11522018941
15 |Caorrected Total a1 1.06538E+11
16
| 17 | Root MSE 10734 |R-Square 0.9470
| 18 | Dependent Mean 45203 |Adj B-Sy 0.94458
| 19 | Coeff War 2374649
20
2 Parameter Estimates
Farameter Standard
22 |Wariable Label DOF Estimate Error|  t%alue Pr= |t
23 |Intercept Intercept 1| -5581.097245| 2273.8045854 -245] 0.017943
24 |Inventary Total Inventary 1]  0.098486575| 0.024550315 4.00| 0.000217
25 |Returns Tatal Returns 1 17.08522479| 2 565154556 6.64| 2.35E-058
26
Z Generated by SAS (SASMain, NET_SRY) on O7DEC2006 at 11:02 Al
M 4 ¢ Ky Sheetl worldwide Shoe Sales Linear Regression 4 Correlations Summary Stati: [ 4 | |

Bla

Before running this analysis, you assumed a significance level of 0.05. Therefore, any
parameter estimates that have a p-value less then 0.05 should be included in the
model, and any parameter estimates that have a p-value greater than 0.05 should not
be included in the model.

The following analysis of the Boot product shows you how to analyze the results for
each product.

O You can use the Pr>|t| column in the Parameter Estimates table to determine if
an input is statistically significant and should be included in the model.

The total inventory and total returns have a p-value less than 0.05, so these
inputs can be included in the model.

A B [ C [ D [ E [ F T 6 [
| 6 | Product=Boot
= [
| 8 | |Numher of Observations Read | 52|
ER [Nurmber of Observations Used | 52|
10
11 Analysis of Wariance
Sum of] MWean
12 |Source DF Squares Sruare F “alue Pr=F
13 |Model 2 1.005852E+11] 50445214088 437.82| 5.54E-32
14 |Errar 43 5645789755 1152201991
15 |Corrected Total a1 1.06535E+11
16
E Root MSE 10734 |R-Square 0.9470
| 15 | Dependent Mean 45203 |Adj R-Sq 0.9445
| 19 | Coeff var 23.74649
20
21 Parameter Estimates 7~ N
Farameter Standard x
22 [Wariahle Lahel DF Estimate Errar]  t %alu Pr = |t|
23 |Intercept Intercept 1] -5581.097245| 2275.804554 244 0.017943
24 |Inventory Total Inventary 1|  0.0954565975| 0.024650315 4.00y 0.000217
25 |Returns Tatal Returns 1] 17.05522475| 2.565134556 G.64 N\ 36E-05
26 -
ﬁ» mfy Sheetl £ Worldwide Shoe Sales 3 Linear Regression 4 Correlations A Summary Statist | <| | LIJJ
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0 After you have determined that an input is statistically significant, you can use
the value in the Parameter Estimate column to determine the impact that these
inputs have.

The impact that each of these inputs have on total sales is the following:

o For each $1.00 spent on inventory, total sales increase by $0.10.

o For each $1.00 of returns, total sales increase by $17.07. While at first this result
was confusing, you remembered that some of your stores charge a 20% re-stocking
fee on all returns. This means that your company still makes some money off of
returned items.

A | B | C | D | E | F | 6 |t
| B | Product=Buoot
2 [
| 8 | [Murnber of Observations Read | 52|
| 9| [Mumber of Observations Used | 52|
10
11 Analysis of Wariance
Sum af] Mean
12 |Source DF Squares Square F “alue Pr=F
13 [Model 2 1.00892E+11| 50445914088 437.82| 5.54E-32
14 |Error 49 5645759755 1152201991
15 |Carrected Total a1 1.065635E+11
16
|17 | Roat MSE 10734 |R-Square 0.9470
| 18 | Dependent Mean 45203 | Adj R-5q 0.9448
|19 | Coeff War 23.74649
0
21 Parareter Estimates 7~
/ Pararneter] Standard
22 [Variahle Lahel DF Estimate\ Error]  t %alue Pr = |t]
23 |Intercept Intercept 1] -5581.007245] Jo78 B04854 -2.45| 0.017943
24 |Inventory Total Inventary 1]\ 0.098486978] 024650315 4.00| 0.000217
25 |Returns Total Returns 1] \17.06522479)/2 6RG164656 5.64| 2.35E-08
26 =
[ « v nl Shestl £ Worldwide Shoe Sales}, Linear Regression { Cornelations £ Summar Statist |4 | LI.IJ

You can perform the same analysis on the other products.

Save the Workhook

To save the workbook, select File » Save.

You have now finished your initial analysis of your company’s 2006 sales data. You
can now use a PivotTable report to analyze a specific product line. For more information,
see Chapter 5, “Analyzing a SAS Data Source in a PivotTable Report,” on page 37.
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About the Tasks That You Will Perform

During the first part of the scenario, you saw that sports shoes had the lowest sales.
After your initial report, your managers asked you to identify the regions that had sport
shoe sales less than $10,000, and to perform a more in-depth analysis into the region
with the lowest sales. Because you are in Microsoft Excel, you can perform this analysis
using a PivotTable report.

To analyze the Sport Shoe product line, you will perform the following main tasks:

1 You will select the data source to open.

Note: In this scenario, you are accessing a SAS data source from the SAS server.
However, you can use the SAS add-in to access data from a database, such as

Oracle, Teradata, and DB2. In Excel, you can also use Excel worksheets as the
data source. A

2 For the data source, you will select the following:
O the variables to include in the output
O a filter that will subset the data
O the output location for the PivotTable report
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Open the Sales Data into a PivotTable Report

To open the SHOES data source (which is available from the SASHELP library) into
a PivotTable report, complete the following steps:

1 Select SAS » Open Data Source » Into PivotTable. The Open into PivotTable
window opens.

x
Lookin | (2) SASHELP Fle B X E -
] accew EECiTiwe FE4EISMBRP FSIETY Wariables
F=]ACCBwWMT Elomvr EEJEIsmMKeN E=3Fee
My Documents  E-gACCPED FEdoLass EEdEISMEIL FEdFEE
=] AD0MSG EdcLumss B Ersmkmx EdrLe
F=]ansMsE EECNTAINER EE3EISHENA, EEirse
= AFMSG B4 coLumn EdEIsMELs EEdFst
S EdcoMpany EEIsMsE E3rTe
- =] 455CMER FEdcsFoEFs Elesoen 5 [cTm
= =] 45500wWA EEJCTHEME Eleisoesz Edals
My Network | E-dAUTHLIB FEdDESKaCT FEJEIS0R)2 FEdGN
Places =] Ly EdDESKFD EdEisop)4 Elcn
F=dBYCHELP ElpESkoE, EiEisoes iGN
W =] B/ G EdoFTDICT EdEisoels G
5 - F=]EvHELF ElorLoG Eleisoe7 EqHTI
emers e
P evMsE 0P M_LOG Eieisope EEqHTI
=] CimiDay ElovNaTTR ElEisrG Elime
[% =1 CITIMON Eieis EieisTooLs EEime
Information Maps =4 CITIOTR E3risico EJETLMSGS B uan
]
'm File: narne: Il j |—ID pen
DOLAP Servers | Files of ype: |4n'5A5 Data Sources = Cancel | |
a

2 From the SASHELP library, select the SHOES data source. The variables in the

SHOES data source appear in the Variables pane.

3 Click open. The Modify Data Source window opens.
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4 On the variables tab, you select the variables that you want to include in the
final output. You can also specify the order of the variables.

Click to move all the variables from the Available list box to the
Selected list box. Select the variables so they appear in the following order:

£ Modify Data Source - SASHELP.SHOES

Char Fegion
Char Product
Char Subsidiary
Mum Murnber of Stores

Currency Total Sales
Currency Total Inventory
Currency Total A eturns

Click the Filter tab to continue.

5 On the Filter tab, you can specify the condition that you want to use to subset
the data. On this tab, you will specify two conditions and join them by an AND
operator to create a filter.

Use the drop-down lists and the text box to create the following filter:

% Modify Data Source - SASHELP.SHOES

N | [T TR - | I ) | (TR
B | [T B =

==

Click the output Location tab to continue.
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6 On the output Location tab, you can select the location for the final output.

By default, the SAS add-in opens the PivotTable report in a new worksheet. In
the Named box, delete SASHELP.SHOES and type Sport Shoe Sales Less Than

10,000.

£ Modify Data Source - SASHELP.SHOES

Click ok. The PivotTable report opens in a new worksheet.

A

Sport Shoe Sales Less Than 10,000

Dirop Page Fields Here
[

Drop Column Fields Here

alaH spjei4 moy doig

Drop Data ltems Here

Sports Shoe

Drag items to the PivatTable report

o [ Product
[ Subsidiary
[ Stares

] 5ales

g Inventary
[E] Returns

- |Row Area
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Create a PivotTable Report for the Sport Shoe Product Line

To create a PivotTable report that analyzes the actual and predicted sales for the
Sport Shoe product line, complete the following steps:

1

From the PivotTable Field List, drag and drop Region to the area marked Drop

Row Fields Here.

A

8 [ ¢ |

D |

E

Region -

Africa

Asia

Canada

Central America/Caribbean
iddle East

Pacific

South America

Western Europe

Grand Total

10 T T ey R —

From the PivotTable Field List, drag and drop Product to the area marked Drop

‘wWorldwide Shoe Sales

Linear Regre=zion Correlations

Sponts|4]

FivolT able Field List

Drag items to the PivotTable report

EI Region
[E] Product

ﬂJ;I I Add To | |R0w Area

Column Fields Here.

A

[ 8 [ ¢ |

Product |

Region ~|Sport Shoe [Grand Total

Africa

Asia

Canada

Central America/Caribbean
Middle East

Pacific

South America

Western Europe

Grand Total

O P T —

Worldwide Shoe Sales

Linear Regression Correlations

Sponts|4]

"=| PivolT able Field List

Drag items to the PivotTable report

E|Inventory
[E] Returns
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3 From the PivotTable Field List, drag and drop Sales in the area marked Drop
Data Items Here.

A | B | C [ o [ E [ F [ 6 [ H = PivotTableFieldList -

; I Drag ikems to the PivotTable repart
3 |Sum of Sales Product - - [£| Region

4 |Region w|Sport Shoe |Grand Total EI Product
iAfr!ca 22150 22150 ;---E|Subsid\ary
| B |Asia 2092 2092 i 5 stores
| 7 |Canada 12343 12343 :
| B |Central America/Carinbhean 8767 5767 =]
| 9 |Middle East 4007 4007 o[ Inventary
| 10 |Pacific 13958 13958 EI Returns
| 11 |South America 33061 33061

12 |Y¥Western Europe 24510 24510,

13 | Grand Total 120908 120908
| 14 |
|15 |
| 16 |
|17 |
| 18 |
| 19 |
| 20 |
| 21 |
| 22 |
| 23 |
| 24 |
125 |
| 26 |

Pr I

28

a0 J;I | Add To I ‘Rnw Area |v|
I« 4 v w|f  Worldwide Shoe Sales Linear Regressian Cerrelations b, Sports|| 4] | o

The results show that three regions (Asia, Middle East, and Central America/
Caribbean) have total sport shoe sales under $10,000. Asia has the lowest sales, so you
want to drill-down on the data in the Asia region to investigate further.

Drilling Down on the Data for Asia in the PivotTable Report

To drill-down on the data for the Asia region, complete the following steps:

1 In the Region column, right-click in the Asia cell. From the pop-up menu, select
Group and Show Detail » Show Detail. The Show Detail dialog box opens.

2 Select subsidiary and click OK.

Show Detail x|

Zhoose the field containing the
detail you wank o show;

Product -

Inventory
Returns

=
O, I Zancel |
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The Asia row now shows the sales for the Seoul and Tokyo subsidiaries.
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3 In the Subsidiary column, right-click on the seoul cell. From the pop-up menu,
select Group and Show Detail » Show Detail. The Show Detail dialog box opens.

4 Select Inventory and click OK.

Show Detail

Zhoose the field containing the
detail you wank o show;

2=

Product
Stares
Sales

Inventory
Returns

O, I Zancel

=

I

The Seoul row now shows the inventory cost for the Seoul subsidiary.
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5 Right-click on the Tokyo cell. From the pop-up menu, select Group and Show
Detail » Show Detail.

The Tokyo row now shows the inventory cost for the Tokyo subsidiary.
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The results suggest the following:

o0 While the sales for the Seoul subsidiary were $937, the cost of inventory was only
$455. This suggests that the profit for sport shoes was good. It could also suggest
that demand for sport shoes exceeded the inventory that the Seoul subsidiary had
in the warehouse.

o While the sport shoe sales for the Tokyo subsidiary were $1,155, the cost of
inventory was $15,602. This suggests that the Tokyo subsidiary was not profitable
in selling sport shoes. Then you remember that a low-price competitor recently
entered the Tokyo market. The demand for sport shoes declined unexpectedly, and
consequently, the Tokyo subsidiary has leftover inventory in the warehouse.

Before ordering sport shoes for either of these subsidiaries, your company will
probably want to perform an in-depth market analysis into the trends in each of these
markets.

Save the Workhook

To save the workbook, select File » Save.
You have now finished analyzing the sports shoe sales in a PivotTable report. This
completes the second part of the scenario.
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Working with Published Documents

What Is a Published Document?

After you have completed an analysis, you might want to share the results with
others at your site. Published documents are Excel, Word, or PowerPoint documents
that are saved to a common repository.

Publishing your documents to a common repository has the following benefits:

0 The workbooks, documents, and presentations in this repository can be opened by
others at your site.

0 When you publish the workbook, document, or presentation to the metadata
repository, information about all the data sources is saved to the repository.
Storing this metadata in the repository enables you to perform an impact analysis
on a document. Impact analysis enables you to see where a data source came from
and the items that depend on this source. This analysis enables you to know how
changing a data source might affect other documents.

Note: To publish a document, your site administrator must have installed SAS Web
Report Studio on the same metadata server. If you cannot publish documents, contact
your site administrator. A
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Publish the Sales Workhook
To publish the Shoe Sales 2006 workbook, complete the following steps:
1 Select SAS » Tools » Publish from the main menu.

Note: If you have any data sources that cannot be tracked in your document, then
the Verify Document for Impact Analysis dialog box opens. Click OK to continue. A

The Publish window opens.

i% Publish

FE

[i{BIF Tre=
@ Integration Techhologies

Shoe Sales 2006.xls ]
Microsoft Excel Workbook [* 1) |—

2 Select the location where you want to publish your document and click save. The
Properties dialog box for the published document opens.

Shoe Sales 2006_xl: Properties
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3 On the security tab, specify the security settings for the published document. By
default, the Use inherited security settings check box is selected and the
published document has the same settings as the parent directory.

For more information about how to set the security settings for a document or
folder, click Help in this window.

4 Click oK to publish the document.

Open the Published Workbhook

After a document has been published to a metadata repository, others at your site
can view this document.
For example, to open the Shoe Sales 2006 workbook, complete the following steps:

1 Select SAS » Reports. The Reports window opens.

Tip: You can also open the Reports window by clicking in the SAS

Data Analysis toolbar.
2 Select shoe sales 2006.xls.
3 Click open.

Working with Favorites

What Is a Favorite?

If you are going to be accessing a published document frequently, then you might
want to add it to your list of favorites. In the SAS Add-In for Microsoft Office, a favorite
is a task, stored process, or published document that is saved to the SAS Favorites
folder so that you can quickly access it later.

Add a Favorite for the Sales Workhook

To add the Shoe Sales 2006 workbook to your list of favorites, complete these steps:
1 Select SAS » Reports. The Reports window opens.
2 Select shoe sales 2006.xls.

¥
3 In the toolbar, click %I

Add to SAS Favorites x|

. The Add to SAS Favorites window opens.

Mame: |Shne Sales 2008 Ll

Create in: [,T_fj My 545 Favontes ﬂl
“[=5] Graph

Mew Folder |
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4 Select the folder where you want to save this workbook and click OK.

Run the Favorite for the Sales Workhook

To open the Shoe Sales 2006 workbook that you added to your list of favorites, select
SAS » SAS Favorites » Shoe Sales 2006.

Tip: You can also access your favorites by clicking the down arrow next to SAs
Favorites in the SAS Data Analysis toolbar.

‘ Active Data: | Active Selection ~ |2 Analyze Data | | Repartd SAS Favorites = [ R =T

-

The Shoe Sales 2006 workbook opens in Excel.

Sending Results to Microsoft Word or Microsoft PowerPoint

About Sending Results from Excel

After you performed your initial analysis of the company’s 2006 sales data in Excel,
your managers asked you to create a short presentation for the yearly sales meeting.
This presentation should include the following:

O the total sales for each product
O the average sales, inventory, and returns for each product

From Excel, you can select the results from the Shoe Sales 2006 workbook to send to
Word or to PowerPoint. When you select the SAS content to send, the current results
for that analysis are automatically displayed in Word or PowerPoint. To make sure that
the most up-to-date results are displayed in Word or PowerPoint, you should refresh the
analysis after the results are sent to these applications.

Note: You can send only SAS content from Excel to Word or PowerPoint. Any
formatting or text changes that you made to the SAS content are not sent. Only the
results are re-opened in Word or PowerPoint.

You cannot send a SAS data source or data in an Excel worksheet. Word and
PowerPoint are unable to open and read an Excel data source. Additionally, you cannot
send a PivotTable report to Word or PowerPoint. A

Send Results from the Sales Workbhook to Microsoft PowerPoint

To send SAS content from the Shoe Sales 2006 workbook to Microsoft PowerPoint,
complete the following steps:

1 Select SAS » Tools » Send To » Microsoft PowerPoint. The Send to Microsoft
PowerPoint window opens and displays all the analyses in the Shoe Sales 2006
workbook.

Tip: You can use the view drop-down list to the view the analyses for a
particular workbook or worksheet. The list of analyses in the SAS Content box
changes based on the workbook or worksheet that you selected. For each analysis,
the estimated time to send this analysis and the worksheet where this analysis is
stored is listed. By default, all of the analyses are selected.

2 In the sAs cContent box, clear the Linear and Correlations check boxes.
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3 Select Bar chart and click . . This moves the results from the Bar Chart task
up one position.
The Send to Microsoft PowerPoint window should appear similar to the
following:

& Send To Microsoft PowerPoint

Workbook [Shoe Sales 2006.xls) |_

O 4 Linear 4 zeconds Linear Regression
O« Comelations 3 seconds Corelations

i1l Bar Chart A zeconds Total Sales for Each Fr..
Z Summary Statistics 2 zeconds Summary Statistics

All rezultz in one PowerPaint prezentation |_

e | v |

4 Click send.

The current results automatically open in PowerPoint. You can now use the
functionality in PowerPoint to customize these slides and create your presentation.
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Refresh Your Results in PowerPoint

To make sure that the most up-to-date results are displayed in Word or PowerPoint,
you should refresh the analysis after the results are opened in Word or PowerPoint. You
also might want to refresh your results if the data source for the analysis has been
updated or modified since you last ran the analysis.

To refresh your results in PowerPoint, complete the following steps:

1 Select SAS » Refresh Multiple. The Refresh Multiple window opens.



Next Steps: A Quick Look at Additional Features /\ Refresh Your Results in PowerPoint 51

|EZ1 Hefresh Multiple

(T Ear Chart C dz 1
Z Summary Statistics 2 geconds

2 Click Refresh.

The SAS add-in refreshes all of the analyses in your presentation.

Tip: You can also use the Refresh Multiple window to select which analysis to
refresh. For each analysis, the estimated time to run this analysis and the slide
number of this content is listed. By default, all of the analyses are refreshed.
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Recommended Reading

Here is the recommended reading list for this title:
O the online Help for the SAS Add-In 2.1 for Microsoft Office

0 SAS offers instructor-led training and self-paced e-learning courses to help you get
started with the SAS add-in, learn how the SAS add-in works with the other
products in the SAS Enterprise Intelligence Platform, and learn how to run stored
processes in the SAS add-in. For more information about the courses available, see
support.sas.com/training.

For a complete list of SAS publications, see the current SAS Publishing Catalog. To
order the most current publications or to receive a free copy of the catalog, contact a
SAS representative at

SAS Publishing Sales

SAS Campus Drive

Cary, NC 27513

Telephone: (800) 727-3228*

Fax: (919) 677-8166

E-mail: sasbook@sas.com

Web address: support.sas.com/pubs

* For other SAS Institute business, call (919) 677-8000.

Customers outside the United States should contact their local SAS office.
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active data source
an Excel data source or a SAS data source that you specify to run all tasks on.
Specifying an active data source enables you to perform multiple analyses on the
same data source without having to specify that data source each time you run a
task. See also SAS data source, task.

analysis
a statistical calculation that is generated by either a task or a stored process. See
also task, stored process.

default metadata server
the metadata server that you will be automatically connected to when you start
Microsoft Excel, Microsoft Word, or Microsoft PowerPoint. See also metadata,
metadata server.

default server
the SAS server that will automatically be used to execute any tasks that use a
Microsoft Excel worksheet or local data as the data source, unless an active data
source that exists on a different server has been specified. See also active data source.

execution server
the server where the data is refreshed or the analysis is run.

favorite
in the SAS Add-In for Microsoft Office, a task or stored process that is saved to the
My SAS Favorites folder so that you can quickly access it later.

filter
a program or section of a program that processes or forwards only the subset of a
data source that meets specific criteria.

impact analysis
a search that enables you to track data sources and stored processes to see where
they are used. For example, you can use a tool like SAS Data Integration Studio to
determine what Microsoft Office documents are using a particular data source. This
helps you to understand what items will be impacted if you delete or rename that
data source.

label
text that describes the contents of a column in a Microsoft Excel file or of a variable
in a SAS data set.
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metadata
a description or definition of data or information.

metadata configuration file
a file that enables users to specify which SAS metadata server they want to connect
to by default. The connection to the metadata server enables users to access and run
stored processes and to access SAS data sources on remote computers.

metadata repository
a collection of related metadata objects, such as the metadata for a set of tables and
columns that are maintained by an application.

metadata server
a server that stores information about servers, users, and stored processes and that
provides this information to one or more client applications.

observation
a row in a SAS data set. All of the data values in an observation are associated with
a single entity such as a customer or a state. Each observation contains either one
data value or a missing-value indicator for each variable.

PivotTable
an interactive table that analyzes and summarizes data in Microsoft Excel. You can
rotate the rows and columns in the table to see different views of the data.

published document
a Microsoft Office document that is saved to a central repository. This workbook,
document, or presentation can be opened with the appropriate Microsoft Office
application.

SAS data source
a data file that contains SAS data. See also active data source.

SAS library
a collection of one or more files that are recognized by SAS and that are referenced
and stored as a unit. Each file is a member of the library.

stored process
a SAS program that is stored on a server and which can be executed as requested by
client applications. Stored processes are often used to create reports.

task
a program that generates and executes SAS programming code that performs a
particular type of statistical analysis on the active data source that you have
specified. A wizard prompts you for the information that is required in order to
execute the task. See also analysis, active data source.

variable
a column in a SAS data set or in a SAS data view. The data values for each variable
describe a single characteristic for all observations.
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