SAS® Information Map Studio 3.1: Creating Your First Information Map
# Contents

<table>
<thead>
<tr>
<th>Chapter 1  △  About This Book</th>
<th>1</th>
</tr>
</thead>
<tbody>
<tr>
<td>How to Use This Book</td>
<td>1</td>
</tr>
<tr>
<td>Intended Audience</td>
<td>1</td>
</tr>
<tr>
<td>Online Help for Data Library Manager</td>
<td>1</td>
</tr>
<tr>
<td>Online Help for SAS Information Map Studio</td>
<td>2</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 2  △  Before You Begin</th>
<th>3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prerequisite Software and Resources</td>
<td>3</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 3  △  Overview of SAS Information Maps</th>
<th>5</th>
</tr>
</thead>
<tbody>
<tr>
<td>What Is a SAS Information Map?</td>
<td>5</td>
</tr>
<tr>
<td>Why Are SAS Information Maps Important?</td>
<td>5</td>
</tr>
<tr>
<td>Where Can SAS Information Maps Be Used?</td>
<td>6</td>
</tr>
<tr>
<td>What Is SAS Information Map Studio?</td>
<td>6</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 4  △  Creating a Metadata Profile</th>
<th>7</th>
</tr>
</thead>
<tbody>
<tr>
<td>What Is a Metadata Profile?</td>
<td>7</td>
</tr>
<tr>
<td>Create a Metadata Profile</td>
<td>7</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 5  △  Setting Up Your Data Sources</th>
<th>13</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using Data Library Manager in SAS Management Console</td>
<td>13</td>
</tr>
<tr>
<td>Define a SAS Library</td>
<td>13</td>
</tr>
<tr>
<td>Register Tables</td>
<td>19</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 6  △  Creating a SAS Information Map</th>
<th>23</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start SAS Information Map Studio</td>
<td>23</td>
</tr>
<tr>
<td>Set Application Options</td>
<td>25</td>
</tr>
<tr>
<td>Insert Data Sources</td>
<td>25</td>
</tr>
<tr>
<td>Create a Relationship</td>
<td>27</td>
</tr>
<tr>
<td>Create Folders</td>
<td>29</td>
</tr>
<tr>
<td>Creating Data Items</td>
<td>30</td>
</tr>
<tr>
<td>Creating Filters</td>
<td>45</td>
</tr>
<tr>
<td>Save the Information Map</td>
<td>54</td>
</tr>
<tr>
<td>Test the Information Map</td>
<td>55</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 7  △  Advanced Topics</th>
<th>59</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assign a Prefilter</td>
<td>59</td>
</tr>
<tr>
<td>Designate a Required Table</td>
<td>61</td>
</tr>
<tr>
<td>Test the Prefilter and Required Table Assignments</td>
<td>63</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Glossary</th>
<th>65</th>
</tr>
</thead>
</table>

| Index                      | 69 |
How to Use This Book

This book provides step-by-step instructions for creating a simple relational information map. You will be guided through Data Library Manager in SAS Management Console to register your data in a SAS Metadata Repository and then through SAS Information Map Studio to create the information map.

The scenarios in the book use data that is provided with Base SAS software, so you can follow the instructions and create a working information map. Each topic builds on the previous topic so you must work through the chapters in sequence.

Intended Audience

This book is for information architects who will be creating information maps. The book assumes that the reader has a basic understanding of SAS business intelligence software.

Online Help for Data Library Manager

The Data Library Manager Help describes all of the dialog boxes in Data Library Manager, and it describes the main tasks that you can perform with the software.

Use either of the following methods to get Help for Data Library Manager:

- In the navigation pane (the left pane) of the SAS Management Console main window, select Data Library Manager. Then, from the menu bar, select Help ➤ Help on Data Library Manager.
- Click Help (when available) in the application dialog boxes.
Online Help for SAS Information Map Studio

The SAS Information Map Studio Help describes all of the windows and dialog boxes in SAS Information Map Studio, and it describes the main tasks that you can perform with the software.

Use any of the following methods to get Help for SAS Information Map Studio:

- From the SAS Information Map Studio menu bar, select Help ➤ SAS Information Map Studio.
- Click Help (when available) in the application windows and dialog boxes.
- Press F1 in most application windows and dialog boxes.
Before You Begin

Prerequisite Software and Resources

If you want to create the information map that is documented in this book, you must install SAS Information Map Studio 3.1. The following software and resources must also be available to you:

- a SAS 9.1.3 Metadata Server, with the following resources:
  - a foundation SAS Metadata Repository on the metadata server.
  - in the foundation metadata repository, a SAS application server definition. The application server definition must contain a logical SAS Workspace Server.

- SAS Management Console 9.1.

   Note: SAS Management Console is required only for the purposes of registering your data sources in the metadata repository; it is not required for creating an information map. If you do not have access to this software, then contact your metadata administrator for assistance with the steps in Chapter 5, “Setting Up Your Data Sources,” on page 13.

- SAS 9.1.3 Service Pack 4, which must be applied to all of the machines that are used by the previously listed software and resources.
What Is a SAS Information Map?

A SAS Information Map is business metadata about your data. Information maps are user-friendly metadata definitions of data sources and enable your business users to query data in order to meet specific business needs. Metadata is information about the structure and content of data. Note that an information map does not contain any physical data.

An information map contains data items and filters. A data item can refer to a physical data field or a calculation. A filter contains criteria for subsetting data. Data items and filters are used for building queries.

Depending on the data source, an information map might have many data items and filters. Folders can be used to organize the data items and filters in order to make it easy for business users to locate information within the information map.

Why Are SAS Information Maps Important?

Information maps provide a business metadata layer that enables business users to ask questions and get answers for themselves. This frees IT resources from ad hoc reporting requests and reduces the need to provide training in programming and database structures.

Information maps enable business users to easily access enterprise-wide data by providing the following benefits:

- Users are shielded from the complexities of the physical data.
- Data storage is transparent to users, regardless of whether the data is relational or multidimensional or whether the data is in a SAS data set or in a third-party database management system.
- Business formulas and calculations are predefined, which makes them usable on a consistent basis.
- Users can easily query data for answers to business questions without having to know query languages.
Where Can SAS Information Maps Be Used?

The following software can use information maps:
- Base SAS software
- SAS AppDev Studio (custom applications developed with)
- SAS Add-In for Microsoft Office
- SAS Enterprise Guide
- SAS Information Delivery Portal
- SAS Marketing Automation
- SAS Web OLAP Viewer for Java
- SAS Web Report Studio

What Is SAS Information Map Studio?

SAS Information Map Studio provides a graphical user interface that enables you to create and manage information maps. It enables you to define how the data items are presented so that they are most relevant to your business user. SAS Information Map Studio also enables you to set various properties to control query generation, query execution, and data access.
What Is a Metadata Profile?

A metadata profile defines the connection between a SAS Metadata Server and a SAS BI client application such as SAS Information Map Studio or SAS Management Console. Before you can start SAS Information Map Studio or SAS Management Console, you must first create a metadata profile. You can create more than one metadata profile to connect to different metadata servers or metadata repositories, although only one profile can be active at a time.

Create a Metadata Profile

If you already have a metadata profile for the metadata server and foundation repository that you will be using for this example, then you can skip this chapter and proceed to the next chapter. If you do not have an existing metadata profile for the metadata server and repository that you want to use, then you must create one by completing the following steps:

1. Select Start ► Programs ► SAS ► SAS Information Map Studio 3.1 from your Windows desktop.
2. In the Open a Metadata Profile dialog box, select Create a new metadata profile, and then click OK to start the Metadata Profile Wizard.
3 The first page of the wizard explains the function of the wizard.

4 On the Metadata Profile page, specify a name for the profile.

Click Next to continue.
On the Connection Information page, specify the following values, which are required to connect to the machine where the metadata server resides:

a. In the **Machine** box, specify the fully qualified name of the machine that the metadata server runs on.
b. In the **Port** box, specify the port number that is specified in the startsrv.bat file that is used to start the metadata server.
c. In the **User ID** box, specify the user ID that you use to log on to the metadata server. If your metadata server runs in a Windows environment, then you must fully qualify the user ID by using the domain or machine name that you specified when your login object was created in the metadata repository. Use the following format when you specify your value:
   
   Windows-domain-name\user-ID

   **Note:** In the metadata repository, you must have at least one login definition that contains a user ID that corresponds to the user ID that you specify here.

   For information about login definitions, see the User Manager Help in SAS Management Console.

d. In the **Password** box, specify the password for the user ID that you just entered.
e. (Optional) In the **Authentication Domain** box, specify an authentication domain to associate with the above user ID and password. If you do not specify an authentication domain, then the user ID and password that you provide are associated with the DefaultAuth authentication domain.
f. (Optional) To save the user ID and an encrypted version of your password in the metadata profile, select the **Save user ID and password in this profile** check box. If this option is not selected, the client application will prompt you for a user ID and password each time the metadata profile is accessed.

Click **Next** to continue.
6 On the Repository Selection page, select the foundation metadata repository that you want to access with this metadata profile.

![Repository Selection](image1.png)

Click **Next** to continue.

7 The Finish page lists all of the information that you specified in the wizard.

![Finish](image2.png)

If you need to make any corrections, click **Back** to return to the appropriate page. When all of the information is correct, click **Finish** to create the profile.
8 At this point, the Log On dialog box is displayed.

Click **cancel** because you do not need to start the application yet.

9 In the Open a Metadata Profile dialog box, click **cancel**.
Using Data Library Manager in SAS Management Console

In order for a SAS BI client application like SAS Information Map Studio to access a data table, the table’s metadata must be defined to a SAS Metadata Repository. Data Library Manager in SAS Management Console can be used to create metadata definitions for data libraries and their associated tables. The definitions are stored in the SAS Metadata Repository and are then available for applications to use.

The information that is specified for each library definition corresponds to options in the LIBNAME statement. For information about the correlation between the options that are specified in Data Library Manager and those that are specified in the LIBNAME statement, see the Data Library Manager Help.

Note: SAS Management Console is required only for the purposes of registering your data sources in the metadata repository—it is not required for creating an information map. If you do not have access to this software, then contact your metadata administrator for assistance with the steps in this chapter.

Define a SAS Library

To define a SAS library for this example, complete the following steps:


2. When you start SAS Management Console, the application either uses the default metadata profile (if you specified a default profile during a previous session) or displays the Open a Metadata Profile dialog box to enable you to choose a profile.
To choose a profile, select **Open an existing metadata profile** in the Open a Metadata Profile dialog box, and then select the metadata profile name from the drop-down list.

3 If you saved your user ID and password in the metadata profile, then the SAS Management Console main window will be displayed and you can proceed to the next step.

   If you did not save your user ID and password, then you will be prompted to specify your user ID and password in order to log on to the metadata server and display the SAS Management Console main window.

4 In the navigation pane (the left pane) of the SAS Management Console main window, expand **Data Library Manager**.
5 Select the **SAS Libraries** folder, and then select **Actions ▶ New Library** from the menu bar to start the New Library Wizard.

![New Library Wizard](image)

6 On the first page of the wizard, select the type of library that you will be working with. Selecting a library type is equivalent to specifying an engine in the SAS LIBNAME statement. Because you are working with SAS tables in this example, select **SAS Base Engine Library** from the **SAS Libraries** folder.

Click **Next** to continue.
7 On the next page, specify a name and description for the library. The name that you specify on this page is the name that will be used to identify the library in SAS Management Console—it is not the libref that is specified in a LIBNAME statement.

Click **Next** to continue.

8 On the next page, enter the following values for the library’s properties:

   a In the **Libref** box, specify the one- to eight-character libref for the SAS library. Specify **SAMPDATA** as the libref for the library that you are defining for this example.

   b In the **Engine** box, specify **BASE** as the SAS engine to use when accessing SAS tables in this library.

   c In the **Path Specification** box, specify the location of your tables on the SAS Workspace Server that is defined in the SAS application server that you will use. Any paths that have already been specified for other libraries are listed in the **Available items** list. Use the arrow controls to move a path from the **Available items** list to the **Selected items** list. For this example, the tables that you will use are, by default, located in C:\Program Files\SAS\SAS 9.1\core\sample. (The tables might be located in a different directory, depending on where SAS is installed on your workspace server machine.)
If the path for these tables is not in the Available items list, click New to display the New Path Specification dialog box, and specify the path.

Click OK.

Note: Use the Browse button in the New Path Specification dialog box only if the workspace server is running on your local machine. The Browse button in the New Path Specification dialog box cannot be used to browse remote machines.

If your workspace server is located on a remote machine, then type the pathname in the Path box.

Click Next in the wizard page to continue.
The next page lists all of the SAS application servers that have already been defined by using Server Manager in SAS Management Console. Select the SAS application server that you want to use to access the Sample Employee Data library and its tables.

Click **Next** to continue.

The last page of the wizard lists all of the information that you specified in the wizard.

If you need to make any corrections, click **Back** to return to the appropriate page. When all of the information is correct, click **Finish** to define the library.
Register Tables

After you define your library, you can begin registering tables. The Import Tables wizard in Data Library Manager guides you through the process of registering a table. To register the tables that are used in this example, complete the following steps:

1. In the navigation pane of SAS Management Console, expand Data Library Manager and then expand the SAS Libraries folder.

2. Select the Sample Employee Data library that you just defined, and then select Actions ▶ Import Tables from the menu bar to start the Import Tables wizard.

3. On the Connect to SAS page of the wizard, select the SAS application server that you specified when you defined the Sample Employee Data library.
Click **Next** to continue.

4. On the Select a SAS Library page, verify the values that are displayed. If all of the values are correct, then click **Next** to continue. Otherwise, click **Edit** to edit the information about the library.

5. On the Define Tables page, while pressing the CTRL key, select **EMPINFO** and **SALARY** in the **Select Tables** list.

Click **Next** to continue.
6 On the Wizard Finish page, verify that the wizard lists the EMPINFO and SALARY tables in the list of tables that will be defined.

If you need to make any corrections, click **Back** to return to the appropriate page. When all of the information is correct, click **Finish** to finish registering the tables.
Start SAS Information Map Studio

To start SAS Information Map Studio, complete the following steps:

1. Select Start ➤ Programs ➤ SAS ➤ SAS Information Map Studio 3.1 on your Windows desktop.

2. In the Open a Metadata Profile dialog box, select Open an existing metadata profile and then from the drop-down list, select the metadata profile that you want to use for this example.
3  Click **OK** to open the Log On dialog box.
4  In the Log On dialog box, enter the following values:
   a  In the **User ID** box, specify the user ID that you used for the metadata profile. If you saved your user ID in the metadata profile, then this box will be prepopulated with the saved value.
   b  In the **Password** box, specify the password for the user ID that you just entered. If you saved your password in the metadata profile, then this box will be prepopulated with the saved value.
   c  (Optional) If you did not save your user ID and password when you created the metadata profile, you are given another opportunity to save it when you log on. To save the user ID and password, select the **Save user ID and password in this profile** check box.

5  Click **OK** to log on and display the SAS Information Map Studio main window.
Set Application Options

SAS Information Map Studio enables you to set application usage preferences in the Options dialog box. The types of options that you can set include those that pertain to data items, tables, and relationships. The following instructions take you through the steps for changing a table option. For this example, set an option to display both column names and column labels in the application (the default setting is to display only column names).

1. From the SAS Information Map Studio menu bar, select Tools ▸ Options to open the Options dialog box.
2. In the Options dialog box, select the Tables tab.
3. Select Show column name and label (if available).
4. Click OK to apply the settings.

Insert Data Sources

The first step to creating an information map is to insert data sources. To insert the tables that you registered for this example, complete the following steps:

1. From the SAS Information Map Studio menu bar, select Insert ▸ Table to open the Insert Table dialog box.
2. In the Insert Table dialog box, expand the Sample Employee Data library to view the tables in the library.
3 While pressing the CTRL key, select the EMPINFO and SALARY tables to preview them in the Physical Data Previewer pane.

4 Click OK to insert the tables as data sources.
Create a Relationship

In order to use your data sources together in a query, you must create a relationship between them. A relationship specifies how two tables are joined in a query. For this example, the join keys that you use are the IDNUM columns in both the EMPINFO and SALARY tables. To create a relationship that specifies an inner join between the two tables, complete the following steps:

1. In the SAS Information Map main window, select the Relationships tab.
2. (Optional) Use your mouse to enlarge the tables so that you can see all of the columns.
3. From the menu bar, select Insert ► Relationship to open the Relationship Properties dialog box.

4. In the Relationship Properties dialog box, select one to one from the Cardinality drop-down list.

   Note: The cardinality setting does not enforce the cardinality between tables. Its purpose is to provide descriptive information about the relationship.

5. To create a join condition for the relationship, select IDNUM from both of the Join keys drop-down lists.
6 Click **Add** to add the join condition.

7 Click **OK**. Note that a line is displayed on the **Relationships** tab to represent the relationship.
Create Folders

Before you create the data items and filters for this example, create some folders that will help you to organize the items. To create the folders, complete the following steps:

1. In the SAS Information Map Studio main window, select the **Presentation** tab.
2. In the **Information Map** pane, select the information map icon. (The information map name is **untitled** at this point.)
3. From the menu bar, select **Insert ▶ Folder** to create a folder.
4. When the folder is first created, it is given a default name of **Folder**, but you can enter a new name for it. For this folder, enter the name **Employee Information**.
5 Repeat steps 2 through 4 two additional times to create two more folders. For the second and third folders, enter the names **Salary Statistics** and **Seniority**.

---

**Creating Data Items**

**What Are Data Items?**

Data items are the building blocks that your users use to build reports. You can create two types of data items:

- **Measures** are data items whose values are aggregated (unless otherwise specified) and which can be used in computations or analytical expressions. For example, if you want a data item that you can use for calculating sales totals, then you would create a measure data item from a sales column in your table. Typically, the values for measure data items are numeric.

- **Categories** are data items whose distinct values are used to group measure data items. For example, if you want to group your sales data by geographical location, then you would create a category data item from a column that contains geographical region names.

For this example, you will create both measures and categories. Some of the data items are created directly from the columns that they reference, and others are based on calculated expressions that you create.
Create Data Items from Table Columns

Create the Data Items

To create data items directly from the table columns, complete the following steps:

1. In the SAS Information Map Studio main window, select the Presentation tab.
2. Complete the following steps to create five data items that will be located in the Employee Information folder:
   a. In the Information Map pane, select the Employee Information folder so that the data items are created directly in that folder.
   b. In the Physical Data pane, expand the EMPINFO table.
   c. Select the NAME column. Then, while pressing the CTRL key, select the following columns: IDNUM, JOBCODE, DEPTCODE, and LOCATION.
   d. Click to create the data items.
   e. (Optional) Expand the Employee Information folder to see the newly created data items.

Note: The name of the data item that was created from the IDNUM column is Identification Number, which is the same as the column’s label. The column label was used for the data item name because an option in the Options dialog box is set (by default) to name data items by using column labels (when labels are available).

3. Complete the following steps to create four data items that will be located in the Salary Statistics folder:
   a. In the Information Map pane, select the Salary Statistics folder so that the data items are created directly in that folder.
b In the **Physical Data** pane, expand the **SALARY** table.

c Select the **SALARY** column.

d Click four times to create four data items from the same column.

e (Optional) Expand the **Salary Statistics** folder to see the newly created data items.

---

4. Complete the following steps to create one data item that will be located in the **Seniority** folder:

a In the **Information Map** pane, select the **Seniority** folder so that the data item is created directly in that folder.

b In the **Physical Data** pane, expand the **EMPINFO** table.

c Select the **HDATE** column.

d Click to create the data item.

e (Optional) Expand the **Seniority** folder to see the newly created data item.
Rename the Data Items

You should rename a data item if its default name does not follow a standard format or does not clearly convey its purpose. Some of the data items that you just created should be renamed. To rename these data items, complete the following steps:

1. In the SAS Information Map Studio main window, select the **Presentation** tab.
2. In the **Information Map** pane, select the **Jobcode** data item in the **Employee Information** folder, and then select **Edit ▶ Rename** from the menu bar.
3. Enter **Job Code** to replace **Jobcode**.
Repeat the preceding steps to rename the following data items:

<table>
<thead>
<tr>
<th>Folder Name</th>
<th>Original Data Item Name</th>
<th>New Data Item Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Employee Information</td>
<td>Deptcode</td>
<td>Department</td>
</tr>
<tr>
<td>Salary Statistics</td>
<td>Salary</td>
<td>Average Salary</td>
</tr>
<tr>
<td>Salary Statistics</td>
<td>Salary1</td>
<td>Minimum Salary</td>
</tr>
<tr>
<td>Salary Statistics</td>
<td>Salary2</td>
<td>Maximum Salary</td>
</tr>
<tr>
<td>Salary Statistics</td>
<td>Salary3</td>
<td>Sum of Salaries</td>
</tr>
</tbody>
</table>

Change the Classification

By default, the Identification Number data item was created as a measure data item because it was created from a numeric column. Because this data item is used for grouping values and is not one that should be aggregated, you need to reclassify it as a category data item. To change the classification for this data item, complete the following steps:

1. In the SAS Information Map Studio main window, select the **Presentation** tab.
2. In the **Information Map** pane, select the **Identification Number** data item in the **Employee Information** folder, and then select **Edit ▶ Properties ▶ Data Item (Identification Number)** from the menu bar to open the Data Item Properties dialog box.
3. In the Data Item Properties dialog box, select the **Classifications/Formats** tab.
4. In the **Classifications and aggregations** section, select the **Category** radio button.
5 Click OK. Note that in the Information Map pane, the icon for the data item has changed to a category icon.
Change Aggregation and Formatting Options

By default, the data items in the Salary Statistics folder were created to enable each data item to be associated with multiple aggregate functions. Because you want to use each of the data items to produce a unique aggregation, you need to limit each data item to the function that will aggregate data in the desired manner. You also want to change the number of decimal places that are displayed when the aggregated values are displayed in a report.

To change the aggregation and formatting options for these data items, complete the following steps:

1. In the SAS Information Map Studio main window, select the Presentation tab.
2. In the Information Map pane, select the Average Salary data item in the Salary Statistics folder, and then select Edit ➤ Properties ➤ Data Item (Average Salary) from the menu bar to open the Data Item Properties dialog box.
3. In the Data Item Properties dialog box, select the Classifications/Formats tab.
4. Below the Aggregations list, click Clear All to deselect all of the aggregate functions.
5. From the Aggregations list, select AVG(argument) to specify that you want this data item to average salary values.
6. In the Formatting section, enter 2 in the Valid decimal range box to specify the number of digits that are displayed after the decimal point.
7. Click OK.
Repeat the preceding steps to change the aggregate functions for the following data items:

Table 6.1 Data Items to Modify

<table>
<thead>
<tr>
<th>Data Item Name</th>
<th>Aggregate Function</th>
<th>Number of Decimal Places</th>
</tr>
</thead>
<tbody>
<tr>
<td>Minimum Salary</td>
<td>MIN</td>
<td>2</td>
</tr>
<tr>
<td>Maximum Salary</td>
<td>MAX</td>
<td>2</td>
</tr>
<tr>
<td>Sum of Salaries</td>
<td>SUM(argument)</td>
<td>2</td>
</tr>
</tbody>
</table>

Change the Value-Generation Method

Each data item has a value-generation method. The value-generation method enables you to build either a static or dynamic list of values for a data item. In SAS Information Map Studio, these lists can be used when you build filters and prompts. By default, no list is generated for a data item. For this information map, you want to enable users to generate a static list for the Department data item and a dynamic list for the Location data item. To change the value-generation method for the data items, complete the following steps:

1. In the SAS Information Map Studio main window, select the Presentation tab.
2. In the Information Map pane, select the Department data item in the Employee Information folder, and then select Edit ➤ Properties ➤ Data Item (Department) from the menu bar to open the Data Item Properties dialog box.
3. In the Data Item Properties dialog box, select the Permissions/Value Generation tab.
4. In the Value-generation method section, select Use a custom list of values that you create for the data item.
5 Click **Run Query** to open the List of Values Returned for the Data Item dialog box.

6 In the message dialog box, click **Yes**.

7 In the List of Values Returned for the Data Item dialog box, up to 1,000 unique values can be displayed. For this example, 24 rows are returned. Click **Add to Custom List** to add these values to your list.

8 In the Data Item Properties dialog box, click **OK**.

9 In the **Information Map** pane, select the **Location** data item in the **Employee Information** folder, and then select **Edit > Properties > Data Item (Location)** from the menu bar to open the Data Item Properties dialog box.
10 In the Data Item Properties dialog box, select the Permissions/Value Generation tab.

11 In the Value-generation method section, select Dynamically generate a list that contains all of the data item’s values.

12 Click OK.

Create a Data Item with a Calculated Expression

For this example, you want to create a measure data item that enables your users to calculate the number of years that an employee has been with the company. Because none of the table columns provide this information, you need to create a data item with an expression that will calculate the value. Note that to the information map consumer, this data item looks no different from the data items that you created directly from the table columns. Any complex calculations that you create here are transparent to the consumer.

To create this data item, complete the following steps:

1 In the SAS Information Map Studio main window, select the Presentation tab.

2 In the Information Map pane, select the Seniority folder so that the data item is created directly in that folder.

3 From the SAS Information Map Studio menu bar, select Insert ▶ Data Item to open the Data Item Properties dialog box.
4 To enter values for each of the data item properties, complete the following steps:

a In the Data Item Properties dialog box, enter **Number of Years Employed** in the **Data item name** box.

b Select the **Definition** tab, and enter **The number of years that the employee has been employed by the company.** in the **Description** box.

c Click **Edit** to open the Expression Editor dialog box. This dialog box enables you to create the expression that performs the calculation.

d To determine the number of years that an employee has been employed, you need to subtract the hire date for the employee from today’s date and then divide the difference by 365 (note that this calculation does not take leap years into consideration). To create an expression that performs this calculation, complete the following steps:

i In the Expression Editor dialog box, select the **Functions** tab.

ii In the **Categories** pane on the tab, select the **Date and Time** folder.

iii In the **Functions** pane on the tab, select **TODAY()**, and then click **Add to Expression** to add it to the **Expression Text** box.
iv Click in the operator toolbar to add the subtraction operator to the expression.

v Select the Data Sources tab.

vi Expand the Physical Data tree and then expand the EMPINFO table.

vii Select the HDATE column, and then click Add to Expression to add it to the Expression Text box.
In the **Expression Text** box, select `TODAY() - <<EMPINFO.HDATE>>`, and then click in the operator toolbar to enclose the expression in parentheses.

Deselect the expression, and then click in the operator toolbar to add the division operator to the expression.

In the **Expression Text** box, type 365.
xi Click **Validate Expression** to check the expression for errors.

xii Click **OK** in the message dialog box and then in the Expression Editor dialog box.

e In the Data Item Properties dialog box, select the **Classifications/Formats** tab.

f In the **Classifications and aggregations** section, ensure that **Category** is selected. You want to keep the classification of category because you do not want this data item to be aggregated. You want to be able to use this data item to display individual values or to group other data item values.

g By default, the format type of this data item is **Date/Time** because the expression contains a date function as well as a date column. But you are calculating years of service, so you want a numeric value to be displayed. In the **Formatting** section, select **Numeric** from the **Format type** drop-down list.
h. Select **COMMA** in the list of format names.

i. Click **OK** to create the data item.
Creating Filters

What Is a Filter?

A filter contains the criteria for subsetting a result set. It functions in the same way as a WHERE or a HAVING clause in an SQL statement. You can assign static values to filters, or you can create prompted filters, which enable information map consumers to specify filter values at run time. Information map consumers can choose to use a filter when they build a report. Or, you can apply mandatory filters (prefilters) to selected tables and users to pre-screen data for reports.

For this example, you will create two filters: one filter that enables your users to display results for a specific company location, and a second filter that enables your users to select the departments that they want reports for. The latter filter also uses a prompt, which enables your users to select departments from a list.

Create a Filter

To create a filter that enables your users to generate reports on employees at the company’s Cary location, complete the following steps:

1. In the SAS Information Map Studio main window, select the Presentation tab.
2. In the Information Map pane, select the information map icon so that the filter is created directly in the root of the information map.
3. From the SAS Information Map Studio menu bar, select Insert ▶ Filter to open the New Filter dialog box.
4. In the Filter name box, enter Cary Employees.
5. In the Description box, enter Employees who work in Cary, North Carolina.
6. In the Data item box, select Location from the drop-down list. Note that by default, Condition is set to Is equal to after you select the data item.
7. In the Value(s) section, select Select value(s) from a list from the drop-down list.
8 In the list of values, select Cary. Note that the list contains a dynamically generated list of values because you specified a value-generation method of Dynamically generate a list that contains all of the data item’s values for the Location data item.

9 Click OK to create the filter.
Create a Prompted Filter

To create a filter that enables your users to select the departments that they want reports for, complete the following steps:

1. In the SAS Information Map Studio main window, select the Presentation tab.
2. In the Information Map pane, select the information map icon so that the filter is created directly in the root of the information map.
3. From the SAS Information Map Studio menu bar, select Insert ▶ Filter to open the New Filter dialog box.
4. In the Filter name box, enter Which department?
5. In the Description box, enter Filters on the department(s) that the user selects.
6. In the Data item box, select Department from the drop-down list. Note that by default, Condition is set to Is equal to after you select the data item.
7 In the **Value(s)** section, select **Prompt user for value(s)** from the drop-down list. Note that no existing prompts are available for this filter to use, so you must create a new prompt.

8 Click **Create Prompt** to open the Prompt Properties dialog box.
To create the prompt, complete the following steps:

a. In the Prompt Properties dialog box, enter **Department Prompt** in the **Prompt name** box.
b. On the **Definition** tab, enter **Prompt the user to select a department code.** in the **Description** box.
c. In the **Prompt text** box, enter **Please select one or more departments:**

d. Select the **Prompt Value Generation** tab.
e From the **Prompt type** drop-down list, select **Prompt the user, using a custom list of values**.

f In the **Query for values** section, click **Get Values** to open the Valid Values for Prompt dialog box.

g In the Valid Values for Prompt dialog box, click to select all of the values.
h) Click OK. Note that the **Values list** table on the **Prompt Value Generation** tab now contains the list of values that you just selected.

i) In the **Default** column of the **Values list** table, select **APP** as the default value for the prompt.

j) At the bottom of the **Prompt Value Generation** tab, select the **Multiple values** radio button to enable users to select multiple values for this prompt.
k Click **OK** to create the prompt and to return to the New Filter dialog box.

10 Click **OK** to create the filter.
Creating a SAS Information Map

Create a Prompted Filter
Save the Information Map

An information map is stored in a metadata repository. To save the information map that you just created, complete the following steps:

1. From the SAS Information Map Studio menu bar, select File ➤ Save As to open the Save As dialog box.

2. In the Save As dialog box, drill down through the following folder path in the foundation metadata repository: BIP Tree ➤ ReportStudio ➤ Maps.

   Note: If you intend to use this information map in SAS Web Report Studio, then you must save the information map in the folder that your SAS Web Report Studio administrator has set up for information maps. This example assumes that your SAS Web Report Studio installation uses the BIP Tree/ReportStudio/Maps folder for information maps.

3. After you open the Maps folder, click 🗂️ to create a new subfolder.
4. In the New Folder dialog box, enter a folder name.

5. Click OK to create the folder.
6 In the Save As dialog box, enter **Employee Statistics Sample** in the Name box.

7 In the Description box, enter **My first information map**.

8 Click **Save** to save the information map.

---

**Test the Information Map**

Before you allow your users to use an information map, you should first test it to ensure that you can create queries with it. To test this information map, complete the following steps:

1 From the SAS Information Map Studio menu bar, select **Tools ➤ Test** to open the Test the Information Map dialog box.

2 In the Test the Information Map dialog box, select the Name data item in the Available items list. Then, while pressing the CTRL key, select the following data items and filter: Department, Location, Number of Years Employed, and Which department?

3 Click ➔ to populate the Selected items table.
4 In the Test the Information Map dialog box, click Run Test to run a test query using the selected items.

5 In the Prompt Value Specification dialog box, deselect APP, and then select the EDU and SAM departments from the Values list box. Note that the text that is displayed in the Prompts box is the text that you entered in the Prompt text box in the Prompt Properties dialog box.

6 Click OK, and the Results dialog box is displayed with the results of the test query. The result set should contain 47 rows.
7 (Optional) You can display the SQL code that is generated for the test by clicking View Query to open the View Query dialog box.

8 Click Close to close the View Query dialog box.
9 Click Close to close the Results dialog box.
10 Click Close to close the Test the Information Map dialog box.
Assign a Prefilter

If you want a filter to pre-screen and subset data before any other filters are applied, then assign the filter as a prefilter. SAS Information Map Studio supports the following two types of prefilters:

- authorization-based. Authorization-based prefilters apply to specific users and groups.
- general. General prefilters apply to all users.

For the information map that you just created, you want to prefilter data so that the reports that are generated from the information map show only information about employees who are located at the company's Cary location. To assign this general prefilter, complete the following steps:

1. If the Employee Statistics Sample information map is not open, then open it by completing the following steps:
   a. From the SAS Information Map Studio menu bar, select File ➤ Open to open the Open from Repository dialog box.
b Drill down to the folder that contains the Employee Statistics Sample information map, and select the information map name in the list that is displayed.

c Click **Open** to open the information map.

2 From the menu bar, select **Edit ► Properties ► Information Map (Employee Statistics Sample)** to open the Information Map Properties dialog box.

3 In the Information Map Properties dialog box, select the **General Prefilters** tab.

4 In the **Selected filters** pane, select the EMPINFO table.
5 In the Available filters pane, select the Cary Employees filter, and then click . Note that only one filter is in the Available filters pane. Prompted filters cannot be used as prefilters, so the prompted filter that you created is not displayed.

6 Click OK.

Designate a Required Table

If you want a table (and any associated prefilters) to be used in every query that is generated from a given information map, then designate the table as required for the information map. For this information map, designate the EMPINFO table as required by completing the following steps:

1 Open the Employee Statistics Sample information map.

2 From the menu bar, select Edit ▶ Properties ▶ Information Map (Employee Statistics Sample) to open the Information Map Properties dialog box.

3 In the Information Map Properties dialog box, select the Required Tables tab.
4 In the Available tables pane, select the EMPINFO table, and then click OK.

5 Click OK. Note that in the Physical Data pane on the Presentation tab, the EMPINFO table is denoted with an asterisk (*) to indicate that it is a required table.
6 From the SAS Information Map Studio menu bar, select File ➤ Save As, and save the updated information map with the name **Employee Statistics Sample with Advanced Features**.

### Test the Prefilter and Required Table Assignments

To ensure that the prefilter and required table assignments are working as specified, test the information map again by completing the following steps:

1. From the SAS Information Map Studio menu bar, select **Tools ➤ Test** to open the Test the Information Map dialog box.
2. In the Test the Information Map dialog box, select the **Name, Department, Location**, **Number of Years Employed**, and **Which department?** items from the **Available items** list if they are not already selected.
3. Click ![to populate the Selected items table.](image)
4. Click **Run Test** to run a test query using the selected items.
5 In the Prompt Value Specification dialog box, deselect **APP**, and then select the **EDU** and **SAM** departments from the **Values** list box.

6 Click **OK**, and the Results dialog box is displayed with the results of the test query. The result set should contain 41 rows. Note that even though you did not select the Cary Employees filter for the test, the result set contains rows of only Cary employees. The assigned prefilter pre-screened the non-Cary information.
Glossary

aggregate function
a function that summarizes data and produces a statistic such as a sum, an average, a minimum, or a maximum.

aggregation
the act or process of grouping data, using an operation that produces a statistic such as a sum, average, minimum, or maximum. The term aggregation can also refer to the grouped data that results from such an operation. See also aggregate function.

authentication domain
a set of computing resources that use the same authentication process. An individual uses the same user ID and password for all of the resources in a particular authentication domain. Authentication domains provide logical groupings for resources and logins in a metadata repository. For example, when an application needs to locate credentials that enable a particular user to access a particular server, the application searches the metadata for logins that are associated with the authentication domain in which the target server is registered.

business data
a collective term for data items in an information map. See also data item.

cardinality
in a join, a property that describes whether one row or many rows in one table are associated with one row or many rows in the other table.

category
a data item whose distinct values are used to group measure data items, using an applied aggregate function.

classification
an attribute of data items that determines how they will be processed in a query. Data items can be classified as either categories or measures.

data element
a general term that can include physical data (such as table columns, OLAP hierarchies, and OLAP measures) as well as data items. See also data item.
data item
in an information map, an item that represents either physical data (a table column, an OLAP hierarchy, or an OLAP measure) or a calculation. Data items are used for building queries. Data items are usually customized in order to present the physical data in a form that is relevant and meaningful to a business user.

data source
the physical data (cube or table), as it is defined in a SAS Metadata Repository, that an information map consumer can query through an information map. The metadata for the physical data provides SAS Information Map Studio with the information that it needs in order to access the physical data.

engine
a component of SAS software that reads from or writes to a file. Each engine enables SAS to access files that are in a particular file format.

expression
a combination of data elements, literals, functions, and mathematical operators. An expression can be used to derive a value or to specify a condition that determines whether or how data is processed.

filter
in an information map, criteria that subset data. When a query is generated from an information map, the filter is converted to a query-language statement (for example, an SQL WHERE clause).

format
a pattern that SAS uses to determine how the values of a variable or data item should be written or displayed. SAS provides a set of standard formats and also enables you to define your own formats.

foundation repository
in the SAS Open Metadata Architecture, a metadata repository that is used to specify metadata for global resources that can be shared by other repositories. For example, a foundation repository is used to store metadata that defines users and groups on the metadata server. Only one foundation repository should be defined on a metadata server.

information map
a collection of data items and filters that describes and presents data in a form that is relevant and meaningful to a business user. A user of a query and reporting application such as SAS Web Report Studio can easily build a business report by using the parts of an information map as the building blocks for queries.

inner join
a join between two tables that returns all of the rows in one table that have one or more matching rows in the other table.

join
(1) the act of combining data from two or more tables in order to produce a single result set. (2) a specification that describes how you want data from two or more tables to be combined. The specification can be in the form of Structured Query Language (SQL) programming code, or it can be done interactively through a software user interface.

join condition
a combination of join keys and a comparison operator.

join key
one or more columns that are used to associate two tables in a join.
label
(1) for a table column, the value of its description property in the metadata repository.
SAS Information Map Studio imports this value and displays it as the table column's label. (2) an attribute for certain XML elements in an information map XML file.

libref (library reference)
a short name for the full physical name of a SAS library. In the context of the SAS
Metadata Repository, a libref is associated with a SAS library when the library is
defined in the metadata repository.

login
a combination of a user ID, a password, and an authentication domain. Each login
provides access to a particular set of computing resources. In a SAS metadata
environment, each login can belong to only one individual or group. However, each
individual or group can own multiple logins.

measure
a data item whose values are aggregated (unless otherwise specified) and which can
be used in computations or analytical expressions. Typically, these values are
numeric.

metadata
data about data. For example, metadata typically describes resources that are shared
by multiple applications within an organization. These resources can include
software, servers, data sources, network connections, and so on. Metadata can also
be used to define application users and to manage users' access to resources.
Maintaining metadata in a central location is more efficient than specifying and
maintaining the same information separately for each application.

metadata profile
a client-side definition of where a metadata server is located. The definition includes
a machine name, a port number, and a metadata repository name. In addition, the
metadata profile can contain a user's login information and instructions for
connecting to the metadata server automatically.

metadata repository
a collection of related metadata objects, such as the metadata for a set of tables and
columns that are maintained by an application. A SAS Metadata Repository is an
example.

metadata server
a server that provides metadata management services to one or more client
applications. A SAS Metadata Server is an example.

physical data
data values that are stored on any kind of physical data-storage media, such as disk
or tape.

port
in a network that uses the TCP/IP protocol, an endpoint of a logical connection
between a client and a server. Each port is represented by a unique number.

prefilter
in an information map, a mandatory filter that pre-screens and subsets the data in
its associated table before any other part of a query is run. The two types of prefilters
are authorization-based prefilters and general prefilters. An authorization-based
prefilter applies to a specific user or group, and a general prefilter applies to all users.

prompt
a parameter that enables a user to enter a value at run time.
prompted filter
a filter that is associated with a prompt, which enables the user of an information map to specify filtering criteria when a query is executed.

query
a set of instructions that requests particular information from one or more data sources.

register
to save metadata about an object to a metadata repository. For example, if you register a table, you save metadata about that table to a metadata repository.

relationship
the association, between tables in an information map, that generates a database join in a query.

required table
a table that must be used in any query that is generated from an information map.

result set
the set of rows or records that a server or other application returns in response to a query.

SAS application server
a server that provides SAS services to a client. In the SAS Open Metadata Architecture, the metadata for a SAS application server specifies one or more server components that provide SAS services to a client.

SAS Information Map
See information map.

SAS library
a collection of one or more files that are recognized by SAS and that are referenced and stored as a unit. SAS libraries can be defined in a SAS Metadata Repository to provide centralized definitions for SAS applications.

SAS Metadata Repository
a repository that is used by the SAS Metadata Server to store and retrieve metadata. See also SAS Metadata Server.

SAS Metadata Server
a multi-user server that enables users to read metadata from or write metadata to one or more SAS Metadata Repositories.

SAS Workspace Server
a SAS application server that provides access to Foundation SAS features such as the SAS programming language and SAS libraries.

SQL (Structured Query Language)
a standardized, high-level query language that is used in relational database management systems to create and manipulate database management system objects.

table
a two-dimensional representation of data, in which the data values are arranged in rows and columns.
### Index

**A**
- aggregation options 36
- application options 25
- authorization-based prefilters 59

**C**
- calculated expressions
  - creating data items with category data items 30
  - changing to measure data items 34
  - classifications
  - changing columns
  - creating data items from 31

**D**
- data items 5, 30
  - aggregation options of categories 36
  - classifications of 34
  - creating 30
  - creating from table columns 31
  - creating with calculated expressions 39
  - formatting options of 36
  - measures 30
  - renaming 35
  - value-generation methods of 37

**F**
- filters 5, 45
  - assigning general prefilters 45
  - creating 45
  - creating prompted filters 47
  - folders 3
  - creating formatting options 36

**G**
- general prefilters 59

**H**
- Help
  - Data Library Manager 1
  - SAS Information Map Studio 2

**I**
- information maps 5
  - importance of 5
  - saving 54
  - software that uses testing 55, 63

**L**
- LIBNAME statement 13
- libraries
  - defining in metadata repository 13
  - logging on 24
    - using 13
    - using metadata repository defining libraries in 13
    - registering data sources in 13
    - saving information maps in 54

**N**
- New Library Wizard 15

**O**
- online help
  - Data Library Manager 1
  - SAS Information Map Studio 2
- options, application 25

**P**
- prefilters, general
  - assigning 59
  - prerequisite software and resources 3
  - prompted filters 47
  - prompts
    - creating 48

**Q**
- queries
  - designating a required table for testing 55, 63
  - view SQL code for 57

**R**
- relationships
  - creating 27
  - renaming data items 33
  - required tables 61
S

SAS Information Map Studio
logging on 24
online help 3
options 25
starting 23

SAS Management Console
logging on 14
using Data Library Manager in 13
saving information maps 54
software prerequisite 3

using information maps 8

SQL
view query code 57
starting SAS Information Map Studio 23

T

tables
assigning a general prefilter to 61
creating data items from columns 31
creating relationship between 27
designating a required table 61
inserting 25
registering in metadata repository 19
testing information maps 55 63

V

value-generation methods 37
Your Turn

If you have comments or suggestions about *SAS Information Map Studio 3.1: Creating Your First Information Map*, please send them to us on a photocopy of this page, or send us electronic mail.

For comments about this book, please return the photocopy to

SAS Publishing
SAS Campus Drive
Cary, NC 27513
E-mail: yourturn@sas.com

For suggestions about the software, please return the photocopy to

SAS Institute Inc.
Technical Support Division
SAS Campus Drive
Cary, NC 27513
E-mail: suggest@sas.com
Whether you are new to the workforce or an experienced professional, you need to distinguish yourself in this rapidly changing and competitive job market. SAS Publishing provides you with a wide range of resources—including publications, online training and software—to help you set yourself apart.

Expand Your Knowledge with Books from SAS Publishing
SAS Press offers user-friendly books for all skill levels, covering such topics as univariate and multivariate statistics, linear models, mixed models, fixed effects regression and more. View our complete catalog and get free access to the latest reference documentation by visiting us online.

SAS Self-Paced e-Learning Puts Training at Your Fingertips
You are in complete control of your learning environment with SAS Self-Paced e-Learning! Gain immediate 24/7 access to SAS training directly from your desktop, using only a standard Web browser. If you do not have SAS installed, you can use SAS Learning Edition for all Base SAS e-learning.

Build Your SAS Skills with SAS Learning Edition
SAS skills are in demand, and hands-on knowledge is vital. SAS users at all levels, from novice to advanced, will appreciate this inexpensive, intuitive and easy-to-use personal learning version of SAS. With SAS Learning Edition, you have a unique opportunity to gain SAS software experience and propel your career in new and exciting directions.