
Copyright © 2004, SAS Institute Inc., Cary, NC, USA
ISBN 1-59047-202-0
All rights reserved. Produced in the United States of America. No part of this publication may be reproduced, stored in a retrieval system, or transmitted, in any form or by any means, electronic, mechanical, photocopying, or otherwise, without the prior written permission of the publisher, SAS Institute Inc.

U.S. Government Restricted Rights Notice. Use, duplication, or disclosure of this software and related documentation by the U.S. government is subject to the Agreement with SAS Institute and the restrictions set forth in FAR 52.227–19 Commercial Computer Software-Restricted Rights (June 1987).

1st printing, January 2004

SAS Publishing provides a complete selection of books and electronic products to help customers use SAS software to its fullest potential. For more information about our e-books, e-learning products, CDs, and hard-copy books, visit the SAS Publishing Web site at support.sas.com/pubs or call 1-800-727-3228.

SAS® and all other SAS Institute Inc. product or service names are registered trademarks or trademarks of SAS Institute Inc. in the USA and other countries. ® indicates USA registration.

Other brand and product names are registered trademarks or trademarks of their respective companies.
CHAPTER 1

How to Use This Document

Using This Document


The SAS/ACCESS Interface to PeopleSoft software enables you to extract, browse, and search PeopleSoft metadata. It also enables you to use the PeopleSoft metadata to query the PeopleSoft database and build SAS views of PeopleSoft tables. You can save these views as permanent SAS views, SAS data files, or SAS source code.

Audience

This document is intended for applications programmers and other users who are comfortable with their own operating environment and are reasonably familiar with either SAS or with PeopleSoft. It is assumed that users are completely unfamiliar with using both of the systems together. The glossary provides definitions of terms that might be new to a user who is unfamiliar with either system.

This document provides tutorial instruction for a novice user of the SAS/ACCESS Interface to PeopleSoft. After you have mastered the tutorial, you can use this document for reference.
Introduction

This chapter provides a brief introduction to the SAS/ACCESS Interface to PeopleSoft. For more detailed information, consult the references that are listed in “Recommended Reading” on page 33 or contact your SAS Support Consultant.

Product Overview

Currently, you can use SAS to access your PeopleSoft data, but the SAS/ACCESS Interface to PeopleSoft provides the advantage of a faster and easier method for you to access your PeopleSoft data from SAS. The SAS/ACCESS Interface to PeopleSoft allows you to extract metadata from PeopleSoft. You can use the extracted PeopleSoft metadata to query PeopleSoft records. These queries enable you to more easily locate and use your PeopleSoft data in SAS. You can browse the extracted metadata, search the metadata to locate records that contain specific values, and query the metadata to build SAS views of PeopleSoft tables. You can also save these views as permanent SAS views, SAS data files, or SAS source code.

The SAS/ACCESS Interface to PeopleSoft uses a SAS libname engine to read the tables in the PeopleSoft database and then writes the PeopleSoft metadata to SAS data files. To use the interface to extract PeopleSoft metadata, you must have read privileges to the metadata tables in the PeopleSoft database. To build queries and create SAS views, data files, and source code in the SAS/ACCESS Interface to PeopleSoft, you must have read privileges to the application data tables in the PeopleSoft database.

Note: For more information on the interaction between your PeopleSoft database and the SAS/ACCESS Interface to PeopleSoft, see Chapter 7, “Administration,” on page 31.

Figure 2.1 on page 3 illustrates how the interface extracts the metadata from your PeopleSoft database and enables you to use that metadata to access your PeopleSoft data.
After you extract the metadata, the Metadata Explorer, shown in Display 2.1 on page 4, displays a hierarchy of PeopleSoft access groups that were defined in PeopleSoft, which are displayed as folders in the hierarchy. PeopleSoft access groups provide a way for records to be logically organized to control security. The access groups in the hierarchy show the records that the current user can view and query.

The Metadata Explorer is the main interface in the SAS/ACCESS Interface to PeopleSoft. You can use it to browse all of the extracted access group metadata or a subset of metadata that matches a user-defined set of search criteria. The Metadata Explorer also enables you to query the PeopleSoft records and to save the queries, query results, and query source code.
Getting Started with SAS/ACCESS Interface to PeopleSoft

This section provides a brief tutorial on how to use the SAS/ACCESS Interface to PeopleSoft. For more detailed information, consult the additional chapters that are listed in Chapter 1, “How to Use This Document,” on page 1 or contact your SAS Support Consultant.

To get started with the SAS/ACCESS Interface to PeopleSoft:

1. Open a SAS session.
2. Enter `psaccess` in the command line to start the SAS/ACCESS Interface to PeopleSoft. The interface searches for the following required libraries:

   Metadata Database Source identifies where your source PeopleSoft data is stored. The default name for this metadata source library is `ps_dbms`, but you can use a different name, if desired. The metadata source library must use the appropriate SAS/ACCESS libname engine for your PeopleSoft application.

   Metadata SAS Target identifies where the PeopleSoft metadata that you extract is saved. The default name for this metadata target library is `ps_meta`, but you can use a different name, if desired.

   If the interface is unable to find either of these libraries, the Administration tab on the Profile Settings window is automatically displayed. You can use this window to define the required libraries.

3. Use the Administration tab on the Profile Settings window to define the Metadata Database Source and Metadata SAS Target libraries.
a Use the **Library** list box in the Metadata Database Source panel to select the library that is associated with your metadata source database, or use the **New Library** button to define a new library, and then select it from the **Library** list. The default name for the metadata source library is **ps_dbms**, but you can use any name to reference your metadata target library.

b Use the **Library** list box in the Metadata SAS Target panel to select the library that is associated with your metadata target location, or use the **New Library** button to define a new library, and then select it from the **Library** list. The default name for the metadata target library is **ps_meta**, but you can use any name to reference your metadata target library.

4 After you define the appropriate metadata source library and metadata target library, click the **Extract Metadata** button on the Administration tab to start the Metadata Extract wizard.

5 Use the windows in the Metadata Extract wizard to verify the metadata source library and metadata target library.

6 After you review the extract settings and make any necessary changes, click the **Finish** button to begin the extraction process.

7 When the extraction process is complete, the interface automatically prompts you to review the log messages for any errors that occurred during the extraction.

8 Click the **OK** button on the Profile Settings window. The Metadata Explorer window displays the extracted PeopleSoft access groups.

---

**Browsing and Querying Using the PeopleSoft Metadata**

The Metadata Explorer window either displays a hierarchy of all of the PeopleSoft access groups that are extracted from your PeopleSoft database or displays a hierarchy of records that are selected from a metadata search. The icon at the top of the hierarchy identifies whether you are viewing access groups or search results. The Metadata Explorer window enables you to browse the hierarchy to view and query the PeopleSoft records. You can then save the queries that you build as SAS source code, SAS views, or SAS data files.

To browse and query using the PeopleSoft metadata:

1 Display the desired hierarchy in the Metadata Explorer window by doing one of the following:
   - To view the access group hierarchy, select **View** ➤ **Access Groups**
   - To view search results, click the **Select** button on the Search Metadata window, or select **View** ➤ **Search Results**

   **Note:** You must perform a metadata search before you can display search results in the Metadata Explorer.

2 Use the left panel of the Metadata Explorer to browse through the PeopleSoft access groups or search results. Each group is represented as a folder icon, and there might be several subgroups within an access group. You can expand and collapse the subgroups and records that are contained in the PeopleSoft access...
groups. When you click a group in the left panel of the Metadata Explorer, the right panel of the window displays the next level of groups or the names of the records within the selected access group or subgroup. An exclamation point icon identifies orphan records that are not associated with an access group in the PeopleSoft application.

3 To display a list of all the fields that are within that record in the right panel of the window, click a PeopleSoft record in the left panel of the Metadata Explorer.

4 To view metadata such as field names, descriptions, and lengths for the selected record, click the Fields tab in the right panel of the Metadata Explorer window.

5 To display the data that is contained in the selected record, click the Results tab in the right panel of the Metadata Explorer window. The number of rows that are shown on the Results tab is determined by the Results Observation Limit that is defined in your profile settings.

6 To view the SQL code that is used to query the PeopleSoft record and generate the view of the PeopleSoft record, click the SQL tab. You can modify the SQL code as needed. The Results tab automatically updates or refreshes to reflect any changes that are made to the SQL code.

7 To save the current view as a permanent SAS view or data file or to save the SQL query as SAS source code, select one of the following save options from the main interface menu:

<table>
<thead>
<tr>
<th>File</th>
<th>Save As View</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td>Save As Data File</td>
</tr>
<tr>
<td>File</td>
<td>Save As Source</td>
</tr>
</tbody>
</table>

For more detailed information on browsing, querying, and saving PeopleSoft records using the Metadata Explorer, see Chapter 3, “Accessing and Using the PeopleSoft Metadata in the Metadata Explorer,” on page 9.

---

**Searching the Extracted PeopleSoft Metadata**

After you extract the PeopleSoft metadata, you can use the Metadata Search window to search the metadata and build a list of records that match your search criteria. Then you can select specific records from that list and use the Metadata Explorer to build and save queries using the search results.

To search the extracted metadata:

1 To display the Search Metadata window, select the following from the main interface menu:

| Tools   | Search Metadata |

2 Enter the desired search string or keywords into the **Find What** field on the Search String tab.

3 Select the Options tab and identify the specific search criteria, such as the elements to include in the search, the maximum number of records to include in the search, and whether you want the search to be case-sensitive.
4 Click the **Search** button to complete the search. All of the records and fields that meet the identified search criteria are displayed in the list of search results at the bottom of the Search Metadata window.

5 Locate and click each of the records or fields that you want to browse and query. You can select multiple records.

**Display 2.2** Metadata Search Window with Multiple Records Selected

---

6 To browse and query the selected fields or records in the Metadata Explorer window, click the **Select** button.

7 To close the Search Metadata window, click the **Cancel** button.

8 To clear the search criteria and the search results so that you can perform another search, click the **Reset** button.

For more detailed information on performing metadata searches, see Chapter 4, “Searching PeopleSoft Metadata,” on page 15.
Using the Metadata Explorer

After you extract your PeopleSoft metadata, you can use the Metadata Explorer to browse or view the metadata and the fields that are associated with the PeopleSoft records in PeopleSoft. You can also use the Metadata Explorer to query the records in PeopleSoft and generate views that are based on these queries. You can then save these views as permanent SAS data files or SAS views, and you can save the code that was used to query PeopleSoft as SAS source code.

Note: You must extract the PeopleSoft metadata before you can use the Metadata Explorer window to browse the PeopleSoft metadata or to access the PeopleSoft data. Before you extract the PeopleSoft metadata, both the left panel and the right panel of the Metadata Explorer are blank.

Browsing PeopleSoft Records

When you open the Metadata Explorer after you extract the PeopleSoft metadata, the left panel of the window displays a hierarchy of PeopleSoft access groups. If you perform a metadata search, you can display a similar hierarchy in the left panel to view only selected records from the metadata search. The icon at the top of the hierarchy identifies whether you are viewing access groups or search results. Select the following from the main interface menu to toggle between the access groups view and the search results view:

- View ➤ Access Groups
- View ➤ Search Results

Note: The search results view is not available until after you have completed a metadata search.
You can use the left panel of the Metadata Explorer to browse or view the hierarchy of access groups or search results. The left panel of the Metadata Explorer enables you to expand and collapse the subgroups and records that are displayed in the hierarchy. Each access group or set of search results is represented as a folder icon, and there might be several subgroups within that folder.

To browse PeopleSoft records in the Metadata Explorer:

1. Display the desired hierarchy in the left panel of the Metadata Explorer by selecting one of the following from the main interface menu:

   ![View Search Results]

   ![View Access Groups]

2. Click the desired folder in the left panel of the Metadata Explorer to view the associated subgroups or the record names in the right panel of the window.

   **Display 3.1  Metadata Explorer, Browsing Subgroups**

3. Click a PeopleSoft record in the left panel of the Metadata Explorer to display the Fields, Results, and SQL tabs that enable you to view more detailed information about the selected record.

4. Click the Fields tab to view a list of fields that are associated with the selected record.
Display 3.2  Metadata Explorer, Fields Tab

The Fields tab displays the following information:

Field  displays the field name as it is defined in the PeopleSoft application.

Description  displays the field description as it is defined in the PeopleSoft application.

Key Field  identifies whether the field is indexed.

Data Type  identifies whether the field has a character, date, or numeric format.

Field Length  identifies the length of the field as it is defined in the PeopleSoft application.

Decimal Position  identifies the number of decimal positions in the field as it is defined in the PeopleSoft application.

Translate Field  identifies whether the field is associated with a PeopleSoft translate field. PeopleSoft translate fields apply a specific set of formatting instructions to field data. They are similar to SAS formats.

5  Click the Results tab to view the data that is contained in the fields that are listed on the Fields tab. This view of the PeopleSoft data is created by a query that the Metadata Explorer automatically generates. This query extracts this data from the PeopleSoft database and displays a view of that data on the Results tab. The number of rows that are shown on the Results tab is determined by the Results Observation Limit defined in your profile settings.
Display 3.3  Metadata Explorer, Results Tab

![Metadata Explorer, Results Tab](image)

**Note:** Displaying a large number of rows might result in a significant delay and might reduce system performance because the results on this tab update or refresh each time the tab is displayed. The default Results Row Limit is **100** records. For more information on setting the Results Row Limit, see “Updating Effective Date and Record Limit Defaults” on page 24.

6 Click the SQL tab to view the automatically generated SQL query that produced the view of the PeopleSoft data that was displayed on the Results tab.

Display 3.4  Metadata Explorer, SQL Tab

![Metadata Explorer, SQL Tab](image)

For detailed information about modifying or saving this query, see “Querying PeopleSoft Records” on page 13 and “Saving PeopleSoft Data and Queries” on page 13.
Querying PeopleSoft Records

When you click a record in the left panel of the Metadata Explorer, the Metadata Explorer automatically queries the tables that are associated with that record in the PeopleSoft database. The automatically generated SQL query creates a temporary view of the PeopleSoft data and displays that view on the Results tab. You can use the Metadata Explorer and the extracted metadata to modify this query and create custom views of the records in your PeopleSoft database. You can query any of the records that are within the extracted access groups. You can also query selected records from a metadata search.

To query PeopleSoft records:

1. Display the desired hierarchy in the left panel of the Metadata Explorer by selecting one of the following from the main interface menu:
   - View ➤ Search Results
   - View ➤ Access Groups

2. Use the left panel of the Metadata Explorer to browse the folders. You can expand and collapse the folders and subgroups as needed to locate the record that you want to query.

3. Select the record that you want to query. The right panel of the Metadata Explorer displays the Fields, Results, and SQL tabs.

4. Click the Results tab to display the view that is created by the automatically generated SQL query. This view is a temporary view of the data in the record. To save a permanent view, see “Saving PeopleSoft Data and Queries” on page 13.

5. Click the SQL tab to display the code for the automatically generated SQL query.

6. Modify the select statement in the SQL query as needed to create the desired view of the selected record.

7. After modifying the SQL select statement, click the Results tab to display the updated view of the selected record. The Results tab automatically refreshes to display any changes that were made in the SQL query.

8. To save the SQL code, see “Saving PeopleSoft Data and Queries” on page 13.

Saving PeopleSoft Data and Queries

The Metadata Explorer automatically generates SQL queries that enable you to display a temporary view of the data in that record. You might want to save one of these temporary views so that you can use the PeopleSoft data later in SAS. The Metadata Explorer enables you to save a temporary view as a permanent SAS view or SAS data file. If you create custom views of that record by modifying the automatically generated SQL query, you might want to save your custom query. The Metadata Explorer enables you to save your query as SAS source code. These save options are available on the main interface menu. They can also be accessed by selecting the record, and then clicking the right mouse button.
To save your PeopleSoft data and queries:

1. Select the desired record in the Metadata Explorer.

2. To save a record as a permanent data file, select the following from the main interface menu:
   
   File ➤ Save As Data File

3. To save the current view of the record as a permanent SAS view, select the following from the main interface menu:
   
   File ➤ Save as View

4. To save the automatically generated query or your own custom query as SAS source code, select the following from the main interface menu:
   
   File ➤ Save As Source

5. When the Save As window opens, specify the desired filename, file type, and location.

   Note: When you save views and data files, the filename is referred to as the Member Name and the file type is referred to as the Member Type.
Searching Your Extracted PeopleSoft Metadata

The SAS/ACCESS Interface to PeopleSoft enables you to search the record, field, and description metadata that is extracted from the PeopleSoft application and query the records that meet your search criteria. First, you specify a set of search criteria and build a list of records that match the criteria. You can then select records from the list of search results and display them in the Metadata Explorer, which enables you to browse and query the records and save the queries as SAS views, data files, or source code.

*Note:* If you want to save the records that meet your search criteria, see “Browsing and Saving Your Search Results” on page 19.

The Metadata Search window enables you to specify your search criteria and search the PeopleSoft records, fields, and descriptions. Descriptions include field and table descriptions, long field names, and short field names. When defining your search criteria, you can define:

- the text string or keywords to search for in the extracted metadata
- the elements to include in the search
- whether you want to search names, descriptions, or both
- whether you want the search to be case-sensitive
- the number of matches to display in the search results.

To perform a metadata search:

1. Open the Metadata Explorer window, and select the following from the main interface menu:
   - Tools ➤ Search Metadata
Display 4.1  Metadata Search Window, Search String Tab

The Metadata Search window is displayed.

2 Enter a search string or keyword in the **Find What** field of the Search String tab.
3 Click the Options tab.

Display 4.2  Metadata Search Window, Options Tab
4 In the Elements panel, select the appropriate element(s):

- **Records**: enables you to specify that you want to search metadata that is associated with the records in the PeopleSoft database.
- **Fields**: enables you to specify that you want to search metadata that is associated with the fields in the PeopleSoft database.

  *Note*: You can select both elements to search all of the metadata that is associated with the fields and the records in the PeopleSoft database.

5 In the Search Criteria panel, specify the criteria that you want to use in the search:

- **Name**: enables you to include the names of the selected elements in your search.
- **Description**: enables you to include the descriptions of the selected elements in your search. If you selected to search fields, this option includes long and short field names in the search.
- **Case Sensitive**: enables you to specify whether you want your search to be case-sensitive. When selected, this check box indicates that the search will be case-sensitive.

6 In the Number of Matches panel, specify how many search results you want to display:

- **Set Max. Number**: enables you to specify that you want to return a limited number of search results. Select this option and then enter the maximum number of search results that you want to display.
- **Unlimited**: enables you to indicate that you do not want to limit the number of search results that are displayed. This is the default value for the Number of Matches panel.

  *Note*: The maximum number of matches that are specified here overrides the Search Results Limit that is defined in your profile settings. Setting a limit is recommended because displaying a large number of rows might result in a significant delay. The default Search Results Limit is 100 records.

7 Click one of the following buttons:

- **Search**: enables you to complete the search based on the criteria that you defined and then display the search results.
- **Cancel**: enables you to close the Search Metadata window and return to the Metadata Explorer window.
- **Help**: enables you to display the SAS help for the Search Metadata window.
- **Reset**: enables you to clear the search criteria and the search results in order to perform a new search.

When the search is complete, the Search Results list displays the records and fields that meet your search criteria.
Display 4.3  Metadata Search Window with Search Results

This list of search results contains the following columns:

- **Record Name**  displays the name of the record that is associated with the search result.
- **Name**  displays the name of the field or record in the Search Results list.
- **Description**  displays the short description that is associated with the search result.
- **Long Description**  displays the long description that is associated with the search result. This column is displayed only if you include fields in your search.
- **Type**  identifies whether the search result is a field or a record.

*Note:* The order of the columns displayed in the Search Results list is determined by the type of elements that you include in your search. △

To query one or more of the records that are included in the search results, use the left mouse button to highlight the desired records, then click the [Select] button. The selected search results are then displayed in the left panel of the Metadata Explorer window. See “Browsing and Saving Your Search Results” on page 19 for more information on building queries against your search results.

If you have already performed a search, you can either replace your previous search results or add your new search results to the hierarchy in the left panel of the Metadata Explorer. To add your new results to the left panel, select **No** when you are prompted to replace the old search results. To replace the old search results with your new search results, select **Yes** when you are prompted to replace the old search results.
Browsing and Saving Your Search Results

After you have searched the extracted PeopleSoft metadata and performed the search, the Search Results list on the Metadata Search window displays the records that match your search criteria. From this list of Search Results, you can select records to display in the Metadata Explorer, which will enable you to browse the records that met your search criteria, identify the records that you want to work with in SAS, and save the records in SAS format.

The Metadata Explorer generates a temporary SQL view of the selected record. The view is displayed in the Results tab of the Metadata Explorer window. The Fields tab shows the fields in the selected record, and the SQL tab shows the code that is used to generate the view. You can use these tabs in the right panel of the Metadata Explorer to identify the records that you want to save in a SAS format. Once you have generated the data view you want to save, you can save the view as a permanent SAS data file or SAS view, or you can save SQL that is used to generate the views as SAS source code.

To browse and save your search results:

1. If you have not already done so, display the search results in the Metadata Explorer window. To do this, highlight the records in the Search Results list on the Metadata Search window, then click the Select button. The Metadata Explorer window displays the results of your search. If you have saved the results of more than one search rather than replacing your old search results with the new ones, the Metadata Explorer window displays a hierarchy of search results.

Display 4.4  Search Results in Metadata Explorer

2. Use the left panel of the Metadata Explorer window to expand and collapse the Search Results and locate the record that you want to browse and query.

3. To browse a record, select the record in the Search Results hierarchy, and then click the Results tab to view the fields and data in the record.
4 To query a record, select the record in the Search Results hierarchy, and then click
the SQL tab to view the SQL code that is used to build the current view of the
record. You can change the SQL code as needed to modify the existing query or
build a new query. Then click the Results tab to display a new view that is based
on the revised query.

5 To save the default view or one of the modified views that you created by
modifying the existing query or building a new query, select one of the following
from the main interface menu:

File ▶ Save As View

File ▶ Save As Data File

Then specify the desired location, Member Name, and Member Type, and click the
Save button.

6 To save the source for the query that you built or modified, select the following
from the main interface menu:

File ▶ Save As Source

Then specify the desired filename and location and click Save.
CHAPTER 5

Updating Your Profile Settings

Using Profile Settings

The SAS/ACCESS Interface to PeopleSoft enables you to define a personal profile that saves settings for SAS libraries, file formats you want to use when saving files, record limits, and defaults for handling record limits and PeopleSoft effective dates. Each time you use the interface you can change the profile settings for the current session or you can use the default profile.

When you open the SAS/ACCESS Interface to PeopleSoft for the first time, the interface searches for the following:

- psquerytree data file
- metadata source library
- metadata target library.

If you have extracted the PeopleSoft metadata, the psquerytree data file is saved in the metadata target library. If you have not defined the metadata target library or the metadata source library, the interface automatically prompts you to update your profile settings.

Updating SAS Libraries and Default File Settings

The personal profile enables you to define the file format that you want to use when saving PeopleSoft data. You can save PeopleSoft data as permanent SAS data files or SAS views, and you can also save the SQL that is used to generate views of the PeopleSoft data as SAS source code. The personal profile also enables you to assign the following default SAS libraries for these saved files:

- metadata source library, which is the location of the database where your PeopleSoft data is stored
- metadata target library, which is the location in which the extracted metadata is saved
- data file library, which is where you save PeopleSoft data as SAS data files
- view library, which is where you save PeopleSoft data as SAS views.
To update your personal profile with SAS library assignments and default library settings:

1. Select the following from the main interface menu:
   
   Tools ▶ Profile Settings
   
   The Administration tab in the Personal Profile Settings window is displayed.

   **Display 5.1** Profile Settings Window, Administration Tab

   ![Profile Settings Window, Administration Tab](image)

2. Use the Library list box in the Metadata Database Source panel to select the library that is associated with your metadata source database, or use the New Library button to define a new library. The default metadata source library is `ps_dbms`, but you can use any name to reference your metadata target library.

3. Use the Library list box in the Metadata SAS Target panel to select the library that is associated with your metadata target location, or use the New Library button to define a new library. The default metadata target library is `ps_meta`, but you can use any name to reference your metadata target library.

4. Click the Output tab.
5 Use the **Library** list box in the Save As Data File panel to select the library in which you want to save PeopleSoft data as SAS data files, or use the **New Library** button to define a new library. The default library is **sasuser**, but you can use any library.

6 Use the **Library** list box in the Save As View panel to select the library in which you want to save PeopleSoft data as SAS data files, or use the **New Library** button to define a new library. The default library is **sasuser**, but you can use any library.

7 Use the **Type** list box in the Save Source panel to select the file type or format that you want to use when saving your queries as SAS source. You can save the SAS source for your queries as SAS views or SAS data files. The default value is **View**.

8 Select the **Save View with embedded ‘‘USING’’ database library statement** check box to store a LIBNAME statement that contains all the information that is required to connect to a DBMS in your SAS view. Then identify the library, engine, and options to use when connecting to the database. When the SQL view is read, PROC SQL will use the embedded LIBNAME statement to assign the library. After you process the view, PROC SQL de-assigns the library.

9 Select the **Use ‘‘USING’’ database library on all queries** check box to apply the LIBNAME statement as previously defined in all of your queries against the PeopleSoft database.

10 Define or update the effective date handling options and record limit defaults using the instructions that are provided in the next section or proceed to the next step.
Updating Effective Date and Record Limit Defaults

The personal profile enables you to define how you want to handle PeopleSoft effective dates and effective sequencing options. It also enables you to set record limit defaults that determine how many records or rows are displayed in the Metadata Explorer and the search results list.

The effective date in PeopleSoft applications is used to date information. You can use the effective date to predate information in order to add historical data; it can also be used to postdate information in order to enter data before it is effective. Effective sequencing in PeopleSoft applications enables users to enter more than one row with the same effective date. Each of these rows is assigned an effective sequence number. In the SAS/ACCESS Interface to PeopleSoft, the effective sequence number is used only if you are using PeopleSoft effective dates. The personal profile enables you to control how the interface uses these PeopleSoft features when you query the PeopleSoft database.

To update your personal profile with effective date options and record limit defaults:

1. Select the Effective Dates tab on the Profile Settings window.
Display 5.3  Profile Settings Window, Effective Dates Tab

2 Define the effective date defaults:

- To specify that you do not want to use PeopleSoft effective dates when you query the PeopleSoft database, select the **No Effective Date** check box.

- To specify that you do want to use PeopleSoft effective dates when you query the PeopleSoft database, select one of the following options:
  
  **Effective Date** enables you to specify how PeopleSoft effective dates will be used when you query the PeopleSoft database. If you select this option, then use the drop-down list to select the date definition.

  **First Effective Date** enables you to search for the record with the earliest effective date when you query the PeopleSoft database.

  **Last Effective Date** enables you to search for the record with the most recent effective date when you query the PeopleSoft database.

3 If you are using PeopleSoft effective dates, define the **Effective Sequence** option:

  **First** enables you to search for the record with first effective sequence number when you query the PeopleSoft database.

  **Last** enables you to search for the record with last effective sequence number when you query the PeopleSoft database.

  **All** enables you to search all of the records with an effective sequence number when you query the PeopleSoft database.
4 To update the libraries and file management settings, return to the instructions that are provided in the previous section.

5 When your changes are complete, click one of the following buttons:

- **OK** enables you to save the changes that you have made to the current profile and returns you to the Metadata Explorer window.

- **Apply** enables you to save the changes that you have made to the current profile.

- **Cancel** enables you to close the Profile Settings window and return to the Metadata Explorer window without saving any changes.

- **Reset** enables you to discard all changes that you have defined on the Profile Settings window and display the default profile settings.

6 Select the Miscellaneous tab.

**Display 5.4** Profile Settings Window, Miscellaneous Tab

7 Define the Search Results Limit defaults.

- To specify that you want to display all of the results that match your search criteria, select the **Unlimited** option. This is the default option.

- To specify that you want to limit the number of search results that are displayed, select the **Set Max. Number** option, and then enter the maximum number of search results that you want to display. The default number is **100** records.

8 Define the **Results Row Limit** by entering the maximum number of rows that you want to display in the Results tab of the Metadata Explorer.
CHAPTER 6

Extracting PeopleSoft Metadata

Extracting Metadata from PeopleSoft

The Metadata Extract wizard in the SAS/ACCESS Interface to PeopleSoft enables you to extract metadata from PeopleSoft. You can then use the extracted metadata to create queries for saving PeopleSoft data to SAS data files or SAS views. You can also save these queries as SAS source files.

Extracting the PeopleSoft metadata is a required step in using the SAS/ACCESS Interface to PeopleSoft. When you first access or open the SAS/ACCESS Interface to PeopleSoft, if you have not already performed the metadata extract procedure, you will automatically be prompted to define the required libraries and extract the metadata. The following sections in this chapter provide instructions for assigning the libraries and completing the metadata extraction.

Defining Required Libraries

Before you can use the Metadata Extract wizard to extract the PeopleSoft metadata, you must define the following required libraries:

- **Metadata Source Library**
  - Identifies the location of your PeopleSoft database, which stores the source data. The default metadata source library is `ps_dbms`, but you can use any name when you define your metadata source library.

- **Metadata SAS Target Library**
  - Identifies the location in which the extracted PeopleSoft metadata will be saved. The Metadata Extract wizard writes the extracted PeopleSoft metadata to the PSQUERYTREE, PSFIELDS, and PSTABLES data files, which are saved to this metadata target library. The default metadata target library is `ps_meta`, but you can use any name when you define your metadata target library.

You can define these libraries before you begin using the SAS/ACCESS Interface to PeopleSoft or when you update your profile settings. For more information on how to define these libraries in your profile settings, see “Updating SAS Libraries and Default File Settings” on page 21.
When you first start or open the SAS/ACCESS Interface to PeopleSoft, the application searches for the metadata target library and the extracted PeopleSoft metadata, which is written to the PSQUERYTREE data file in the metadata target library. If this data set is not found, the SAS/ACCESS Interface to PeopleSoft prompts you to use the Metadata Extract wizard. For more information on the Metadata Extract wizard, see “Using the Metadata Extract Wizard” on page 28.

---

**Using the Metadata Extract Wizard**

1. Display the Source window in the Metadata Extract wizard by selecting the following from the main interface menu:

   ![Tools ➤ Extract Metadata]

2. Verify that the library that you have defined as the metadata target library is identified correctly. If it is not identified correctly in the list box, use the list box to select the appropriate library.

3. Click the **Next** button to display the Preview window.
Review the extract settings—the metadata source and target libraries. If you need to make changes to these settings, use the Back button to return to the Source window, then use the Next button to return to the Preview window. When the extract settings are correct, click the Finish button to begin the extraction process.

Note: Each time you extract the PeopleSoft metadata using these extract settings, the existing metadata is overwritten. Extracting the PeopleSoft metadata into SAS data files might require significant time and computer resources.

When the extraction process is complete, the Metadata Explorer displays the extracted PeopleSoft access groups. For more information on the Metadata Explorer, see “Using the Metadata Explorer” on page 9.
PeopleSoft Database Administration

Rather than using PeopleSoft security or PeopleSoft user names and passwords, the SAS/ACCESS Interface to PeopleSoft uses a SAS libname engine to directly access and read data from the PeopleSoft database. Therefore, the users of the interface must have the appropriate database access privileges to perform certain tasks within the SAS/ACCESS Interface to PeopleSoft.

Table 7.1 on page 31 identifies the required access privileges that are associated with each of these tasks.

**Table 7.1 Database Access Privileges for PeopleSoft Users**

<table>
<thead>
<tr>
<th>To...</th>
<th>User must have read access to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extract PeopleSoft metadata from the PeopleSoft database</td>
<td>PeopleSoft metadata records and database tables</td>
</tr>
<tr>
<td>Build queries and create and save SAS views, data files, or source code</td>
<td>PeopleSoft application data records and database tables</td>
</tr>
</tbody>
</table>

Because the SAS/ACCESS Interface to PeopleSoft uses a SAS DBMS libname engine to access the PeopleSoft database, you must specify the appropriate libname engine parameters when you define your metadata database library. If you submit a LIBNAME statement to assign the metadata database library, your LIBNAME statement might look like the following:

```
LIBNAME ps_dbms oracle user=myaccount password=mypassword
   schema=sysadmin path=ora_server;
```

For more information on the SAS/ACCESS libname engine, see the *SAS/ACCESS Software for Relational Databases: Reference.*
SAS Naming Conventions and Support for PeopleSoft Names

Some of the names in the PeopleSoft records do not conform to SAS naming conventions. When the SAS/ACCESS Interface to PeopleSoft generates SQL queries, it uses the PROC SQL DQUOTE=ANSI option to ensure that PeopleSoft names are supported in the interface. The DQUOTE=ANSI option allows the SQL column names to be surrounded by double quotation marks. These double quotation marks enable you to use special characters or blanks that are not otherwise allowed in SAS names when you specify a data set or variable. This syntax is especially useful for expressing database column and table names that contain special characters (such as @, #, and %) that are not allowed in SAS names.

The following is an example of the syntax that is used in the SQL queries that are generated by the SAS/ACCESS Interface to PeopleSoft:

```sql
PROC SQL DQUOTE=ANSI;
  Create view sasuser.accounts as
    Select '"ACCOUNT #"',
         '"LASTNAME"',
         '"FIRSTNAME"',
    from ps_dbms.ps_emp_account;
```

For more detailed information on SAS naming conventions, see the SAS Language Reference: Dictionary. For more information about the DQUOTE=ANSI option, see the SAS/ACCESS Software for Relational Databases: Reference.

You can use the VALIDVARNAME= system option to control how SAS processes a PeopleSoft name that does not conform to SAS naming conventions. This option controls the type of SAS variable names that you can use and create during a SAS session.

If the VALIDVARNAME option is set to V7, then a SAS libname engine converts all of the database column names into valid SAS names by replacing any special characters with an underscore. For example, in the SQL view that is created in the previous code example, the column name that does not conform to SAS naming conventions is converted to a SAS column name: `ACCOUNT #` is converted to `ACCOUNT_`.

If the VALIDVARNAME option is set to ANY, then the SAS libname engine creates a SAS name that is identical to the database column name. For example, in the SQL view created in the previous code example, the columns are converted to the following SAS column names: `ACCOUNT`, `LASTNAME`, and `FIRSTNAME`.

For more information on the VALIDVARNAME option, see the SAS Language Reference: Dictionary or the SAS/ACCESS Software for Relational Databases: Reference.
Recommended Reading

Here is the recommended reading list for this title:

- Doing More with SAS/ASSIST
- Getting Started with the SAS System
- SAS/AF Procedure Guide
- SAS/FSP Procedures Guide
- SAS Language Reference: Concepts
- SAS Language Reference: Dictionary
- SAS Macro Language: Reference
- SAS/Warehouse Administrator Metadata API Reference
- SAS/Warehouse Administrator User’s Guide
- Step-by-Step Programming with Base SAS Software
- Getting Started with SAS/ASSIST
- SAS Companion that is specific to your operating environment.

For a complete list of SAS publications, see the current SAS Publishing Catalog. To order the most current publications or to receive a free copy of the catalog, contact a SAS representative at:

SAS Publishing Sales
SAS Campus Drive
Cary, NC 27513
Telephone: (800) 727-3228*
Fax: (919) 677-8166
E-mail: sasbook@sas.com
Web address: support.sas.com/pubs

* For other SAS Institute business, call (919) 677-8000.

Customers outside the United States should contact their local SAS office.
Glossary

access group
a set of PeopleSoft records that are grouped in order to provide a logical organization for security. In the SAS/ACCESS Interface to PeopleSoft, the Metadata Explorer shows the access groups that the current user has the right to access and query.

access ID
the database logon ID that PeopleSoft applications use when connecting to the database. The access ID is different from the user ID that PeopleSoft users log on with. PeopleSoft applications use the access ID to sign the user off and back on. This simplifies the task of establishing security profiles for PeopleSoft databases.

database
an organized collection of related data. A database usually contains named files, named objects, or other named entities such as tables, views, and indexes.

database management system (DBMS)
a software application that enables you to create and manipulate data that is stored in the form of databases.

effective date
an attribute that can be assigned to PeopleSoft information, such as rates, salaries, and employee data, and which can be used to date that information. The effective date determines when information becomes active in the PeopleSoft system. For example, you can use the effective date to predate information in order to add historical data or to postdate information in order to enter data before the data is in effect. If you use the effective date, then you also need to specify an effective sequence. See also effective sequence.
**effective sequence**
a function in PeopleSoft that enables you to enter multiple rows of information, such as salary changes and promotions, that have the same effective date. An effective sequence number, which determines the order in which the information is processed in PeopleSoft, is assigned to each of these rows. In the SAS/ACCESS Interface to PeopleSoft, you can define an effective sequence only if you are using PeopleSoft effective dates in your queries against your PeopleSoft data. See also effective date.

**engine**
a component of SAS software that reads from or writes to a file. Each engine enables SAS to access files that are in a particular format. There are several types of engines. See also library engine and view engine.

**field**
a term in PeopleSoft that describes what is typically referred to as a column in SAS.

**library engine**
an engine that accesses groups of files and puts them into the correct form for processing by SAS utility windows and procedures. A library engine also determines the fundamental processing characteristics of the library, presents lists of files for the library directory, and supports view engines.

**metadata**
a description or definition of data or information.

**Metadata Explorer**
the main interface in the SAS/ACCESS Interface to PeopleSoft. You can use the Metadata Explorer to browse either all of the extracted access group metadata, or a subset of metadata that matches a set of search criteria. The Metadata Explorer also enables you to query the PeopleSoft records and to save the queries and the query results.

**metadata source library**
a SAS library in which your PeopleSoft data is stored. The default name for this library is `ps_dbms`, but you can use a different name. You must assign this library in order to use the SAS/ACCESS Interface to PeopleSoft. This library is also referred to as the metadata database source.
metadata target library
a SAS library in which the PeopleSoft metadata that you extract is stored. The default name for this library is **ps_meta**, but you can use a different name. You must assign this library in order to use the SAS/ACCESS Interface to PeopleSoft. This library is also referred to as the metadata SAS target.

orphan record
a record that is not associated with an access group in a PeopleSoft application. The Metadata Explorer identifies these records with an exclamation point icon. See also access group.

personal profile
the profile settings that are defined and used by the current user of the SAS/ACCESS Interface to PeopleSoft. See also profile settings.

profile settings
information about data libraries, as well as various options that a user can specify in order to customize the behavior of a software application. The SAS/ACCESS Interface to PeopleSoft saves profile settings in the PROFILE catalog of the SASUSER library. See also personal profile.

query
a set of instructions that requests particular information from one or more data sources.

record
a term in PeopleSoft that describes what is typically referred to as a table in SAS.

SAS data file
a SAS data set that contains both data values and descriptor information that is associated with the data. The descriptor information includes information such as the data types and lengths of the variables, as well as which engine was used to create the data.

SAS data library
one or more SAS files which are accessed by the same library engine and which are referenced and stored as a unit.

SAS data view
a type of SAS data set that retrieves data values from other files. A SAS data view contains only descriptor information such as the data types and lengths of the variables (columns), plus other information that is required for retrieving data values from other SAS data sets or from files that are stored in other software vendors’ file formats. Both PROC SQL views and SAS/ACCESS views are considered SAS data views.
SAS source code
PROC SQL code that is saved in SAS format. You can save the SQL queries that are built in the SAS/ACCESS Interface to PeopleSoft as SAS source code.

Structured Query Language (SQL)
the standardized, high-level query language that is used in relational database management systems to create and manipulate database management system objects. SAS implements SQL through the SQL procedure.

table
a named object that contains a specific number of fields (or columns) and any number of unordered rows.

view
See SAS data view.

view engine
an engine that enables SAS to process SAS data views. A view engine performs in a transparent manner.
Index

A
access groups
   description 3
   viewing in Metadata Explorer 8
access privileges 31

B
browsing
   records 5, 9
   search results 5, 19

D
database administration 31
   date information 24
   default file settings 21

effective date 24
   effective sequencing 24
   extracting metadata 2, 5, 27
   defining required libraries 4, 27
   Metadata Extract wizard 28

F
file settings 21

L
libname engine 31
   libraries
      defining required libraries 4, 27
      list of required libraries 4
      updating SAS libraries 28
      updating SAS libraries and default file settings 31

M
metadata
   extracting 2, 5, 27
   saving extracted metadata 4
   searching extracted metadata 6, 15
   Metadata Database Source library 4
   Metadata Explorer 9
   automatically generated query
      browsing records 5, 9
      querying records 5, 13
      record limit 24
   saving PeopleSoft data and queries 13
   viewing access groups 9
   viewing search results 5, 27
   Metadata Extract wizard 5, 27, 28
   Metadata SAS Target library 4, 27
   Metadata Search window 6, 15
   Metadata Source library 27

N
naming conventions 32

P
PeopleSoft 2
   database administration 31
   getting started with 4
   overview 2
   profile settings 21
      effective date and record limit defaults 24
      SAS libraries and default file settings 21

Q
querying records 5, 13
   automatically generated query 11, 13
   saving queries 13
   searching extracted metadata 6, 15
   saving search results 19
   search criteria 15
   viewing results 5, 9
   sequencing 24
   source data
      storing 4

R
record limit defaults 24

S
SAS/ACCESS libname engine 31
   SAS libraries
      assigning to saved files 21
      updating 21, 28
      saving
         extracted metadata 4
         PeopleSoft data and queries 13
         search results 19
      searches
         browsing results 5, 19
         extracted metadata 5, 15
         list of results 17
         list of results, record limit 24
         Metadata Search window 6, 15
         number of matches 17
         performing a search 15
         querying results 5, 15
         saving results 19
         search criteria 15
         viewing results 5, 2
         sequencing 24

T
tutorial 4

V
VALIDVARNAME= system option 32
Your Turn

If you have comments or suggestions about *SAS/ACCESS® 9.1 Interface to PeopleSoft: User’s Guide*, please send them to us on a photocopy of this page, or send us electronic mail.

For comments about this book, please return the photocopy to

SAS Publishing  
SAS Campus Drive  
Cary, NC 27513  
E-mail: yourturn@sas.com

For suggestions about the software, please return the photocopy to

SAS Institute Inc.  
Technical Support Division  
SAS Campus Drive  
Cary, NC 27513  
E-mail: suggest@sas.com