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JMP® Genomics 3.1 for SAS® 9.1.3 

Required Verification and Configuration Steps 
Once you have successfully completed the installation of the SAS® 9.1.3 Foundation and JMP® 
Genomics 3.1 as described in the Roadmap, continue with the verification, customization and 
configuration instructions as described in this document. 

Verification 
After you follow Steps 1 -4 in the Road Map for JMP Genomics 3.1 for SAS 9.1.3, launch JMP 
Genomics. Verify that the splash screen says JMP Genomics 3.1.  

When JMP 7 is started for the first time, you will need to use the SAS Installation Data (SID) file 
name jmp70_xxxxxx.txt (in which xxxxxx is your JMP Genomics Software Order). You should 
have received this file attached to an e-mail. The jmp70_xxxxxx.txt file should be saved in the 
C:\Program Files\SAS\JMP7 directory. 

If you did not receive this file, please contact the SAS Contracts Department. In the U.S and Puerto 
Rico, call (800) 727-0025, and press option 3. For Contracts support outside the U.S. and Puerto 
Rico, please refer to http://support.sas.com/adminservices/contact.html for e-mail 
contact information. 

Note:  When you open JMP Genomics for the first time, you may be prompted to merge menus. 
Click No whenever you are prompted to merge menus! Attempting to merge customized 
menus from prior versions of JMP or JMP Genomics is strongly discouraged. See 
Customizing JMP Genomics Menus on page 8 of this document for more information and 
instructions. 

Verify that the Genomics menu item is present on the top tool bar, as shown in Figure 1. 
 

 

Figure 1: The JMP Genomics menu bar 

Verify that all of the Genomics submenus are present under the main genomics menu, as shown in 
Figure 2. 
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Figure 2: The JMP Genomics submenus. 
 

If the Genomics menu is missing or you do not see all of the submenus shown in Figure 2, you must 
activate the new menus. 

Select Edit > Customize > Revert to Factory Defaults, as shown in Figure 3.  
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Figure 3: Activation of new menus. 
 

If the shortcut icons on the desktop do not display properly after you install JMP Genomics 3.1, right-
click anywhere in the desktop and select Refresh.  

Set Preferences 
To upload external data files correctly using analytical processes, JMP Genomics requires that certain 
preferences are set. These preferences should automatically set when you open JMP Genomics 3.1 for 
the first time.  

However, some users, particularly beta-testers for JMP 7 or JMP Genomics 3.1, may need to reset 
these preferences. You may set these preferences upon opening JMP Genomics for the first time (or if 
one or more of these preferences is changed accidentally) by selecting File > Set Genomics 
Preferences. 

Please note that there will be no visible sign that the preferences have been reset. You should 
therefore complete the following steps to verify that the preferences have been reset: 

1. Select File > Preferences. 

The Preference Settings window opens, as shown in Figure 4.  

2. Verify that the Save Text files as Unicode box is not checked. The unchecked box should 
appear as shown in Figure 5.  

You may choose to select or deselect additional preferences by checking or unchecking the 
appropriate box(es). 
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Figure 4: The General tab of the Preference Settings window has been set correctly. 
 

 

Figure 5: The unchecked Save Text files as Unicode box 
 

3. Click on the Text Data Files icon on the left-hand side of the window.  

4. In Import Settings, verify that the Comma box is not checked.  

5. In Export Settings, verify that the Tab option End of Field box is selected. 
 

 

Figure 6: The Text Data Files tab of the Preference Settings window has been set correctly. 
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Generate Dialogs 
JMP Genomics requires the generation of JSL dialogs from XML specifications. Both the JSL dialogs 
and the XML specifications are stored in the ProcessLibrary folder. The dialogs should automatically 
be generated when JMP Genomics 3.1 is opened for the first time.  

However, some users, particularly beta-testers for JMP 7 and JMP Genomics 3.1 and users who may 
have accidentally deleted one or more JSL dialogs will need to regenerate the dialogs. To do this, 
select Genomics > Generate Dialogs from XML. 

Upgrade SAS 9.1.3 with Service Pack 4 (including JRE 1.4.2_09) 
If you installed JMP Genomics 3.1 by upgrading JMP Genomics 2.x, please verify whether you have 
upgraded to SAS 9.1.3 with Service Pack 4 (SP4). Launch SAS. Select Help > About SAS 9. If you do 
not have SP4 installed with your SAS 9.1.3, please install Service Pack 4 for SAS Foundation for your 
operating system from  

http://ftp.sas.com/techsup/download/hotfix/e9_sbcs_prod_list.html#e9h004 

SP4 on Windows requires JRE Version 1.4.2_09. This JRE is included in your SAS 9.1.3 SP4 and 
should be installed on your machine. You can easily check the status of the JRE as follows: 

1. Start SAS 9. 

2. From a Program Editor, submit the following code: 

Proc JavaInfo; Run; 

3. Check the SAS Log for the value of java.version and java.vm.version. 

Apply Hot Fixes for Genetics Processes 
To run the most up-to-date versions of the SAS/Genetics procedures for the Genetics processes, 
download and install the latest SAS/Genetics Hot Fix from this location: 

http://ftp.sas.com/techsup/download/hotfix/e9_win_sbcs.html#gn 

This link is also available from your main JMP Genomics menu by selecting Help > JMP Genomics 
Web Links.  

Install PROC GLIMMIX for Marker-Trait Association and Radial Basis Machine 
Processes 
To run the Marker-Trait Association and Radial Basis Machine processes in JMP Genomics, you must 
first install SAS/STAT PROC GLIMMIX from 
http://support.sas.com/rnd/app/da/glimmix.html. This link is available from your main 
JMP Genomics menu by clicking Help > JMP Genomics Web Links.  

Install PROC GLMSELECT for General Linear Model Selection Process 
To run the General Linear Model Selection process, you must first install SAS/STAT PROC 
GLMSELECT from http://support.sas.com/rnd/app/da/glmselect.html. This link is 
available from your main JMP Genomics menu by clicking Help > JMP Genomics Web Links.  

Getting Started 
The main components of JMP Genomics are now operational. See the configuration steps below to set 
up the optional processes and to optimize memory settings. Additional information is available from 
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the JMP Genomics User Guide and the JMP Genomics User Guide Supplement which are available 
from the main JMP Genomics Help menu (Help > Books > JMP Genomics User Guide). 

Note:  This guide is in .pdf format, so you will need Acrobat Reader to open it. Reader can be 
downloaded free of charge at the Adobe website: www.adobe.com. 

Read and follow the guidelines in Chapter 1 of the JMP Genomics User Guide, then proceed to other 
chapters and the supplement according to your interests. Updates will be made available periodically. 
Please check http://www.jmp.com/software/genomics/index.shtml for updates to the 
User’s Guide. 

Optional Configuration Steps 

Microsoft Windows 

Increase Memory Limits and Eliminate Error Messages in Triplicate 
If you are running Windows OS, you might want to edit your SASV9.cfg file to increase memory 
limits and prevent SAS ERROR messages from appearing in triplicate. The typical location for this file 
in is: C:\Program Files\SAS\SAS 9.1\nls\en\SASV9.cfg.  

The operating system may use additional amounts of memory. The memory used by SAS includes 
virtual memory and is therefore not limited to RAM. If MEMSIZE is set to a value that is too low and 
could cause performance problems, the value of MEMSIZE is determined by SAS. 

MEMSIZE Parameter 
For the Windows OS, the operating system will most likely use virtual memory. The memory used by 
SAS includes virtual memory and is therefore not limited to RAM. If MEMSIZE is set to a value that is 
too low, it could cause performance problems. The value of MEMSIZE can be specified by SAS. 

For optimal performance, use the default value of ‘0’ for MEMSIZE 

SASV9.cfg File 
For the Windows OS, you may wish to edit the SASV9.cfg file. 

To edit the SASV9.cfg file, follow these steps: 

1. Close all SAS and JMP Genomics sessions.  

2. Use a text editor to open the SASV9.cfg file. 

3. Add the following lines to this file: 

-MEMSIZE 0  
-MVARSIZE MAX  
-MSYMTABMAX MAX  
-NOOVP  

If any of these options already exist, you may replace them with the new values.  

4. Save the SASV9.cfg file. 

All subsequent invocations of SAS will use these changes. 
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SORTSIZE parameter 
The SORTSIZE parameter specifies the amount of machine memory available to SAS for sorting large 
data files.  

1. Close all SAS and JMP Genomics sessions.  

2. Use a text editor to open the SASV9.cfg file. 

3. Add the following line to this file: 

-SORTSIZE X 

in which X indicates the amount of memory to be assigned to SAS for sorting large data files. 

A SORTSIZE value set at ‘0’ assigns all available memory to SAS. This option is not recommended 
since it will affect the performance of other applications.  

One recommended approach is to specify half the available memory on your machine. For example, if 
your machine has 1GB of memory, type  

–SORTSIZE 512m 

Save the SASV9.cfg file. All subsequent invocations of SAS will use these changes. 

Set Web Access via a Proxy Server for KEGG Pathway Search and Color 
Processes 

A proxy server is a server that sits between a Web browser and an external server on the Web to filter 
requests, improve performance, and share connections. If your computer accesses the Internet 
through a proxy server, you need to specify your proxy server name and port number to enable the 
system to search KEGG Pathways data through the Web. If your computer does not access the 
Internet through a proxy server, skip this configuration step.  

To specify the proxy server, select Genomics > Annotation Analysis > Configure Proxy 
Settings. The Configure Proxy Settings window opens, as shown in Figure 7. 

 

Figure 7: The Configure Proxy Settings window 
 

1. Type the proxy server name (in the form servername.domain.com) in the Proxy Server 
Name field.  

2. Type the proxy port number (commonly 80) in the Proxy Port Number field.  
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3. Click the Choose button to select the Output Folder.  

4. Click the Run button. A SAS Message displays when Configure Proxy Settings is completed. 

If you are not sure what values to specify, you may be able to find this information in your Web 
browser settings.  

For example, in Internet Explorer, select Tools > Internet Options > Connections tab > LAN 
Settings button > Use a proxy server check box > Advanced button.  

The Proxy Settings window opens and displays your HTTP proxy name and port number. Your IT 
Administrator may also be able to provide the values. 

Install Affymetrix GeneChip Bioconductor Expresso Process 
To run the Affymetrix GeneChip Bioconductor Expresso process in JMP Genomics, you must first 
install R and the Affy package from http://www.bioconductor.org/.  

Note: You must also install the packages specific to your Affymetrix chip. 

Customizing JMP Genomics Menus 
The menu customization system has changed considerably in JMP Genomics 3.1, so merging menu 
customizations from a prior JMP Genomics version is not easily accomplished and is strongly 
discouraged. When asked if you would like to merge menus from an earlier version of JMP Genomics, 
click No.  

If you accidentally select Yes to merge your menus from a previous version and encounter an error 
message, complete the following steps to reset the menus: 

1. Close JMP Genomics (from the Windows Task Manager if necessary). 

2. Relaunch JMP Genomics. 

3. When prompted to merge menus, select No. 

4. Select Edit > Customize > Revert to Factory Defaults to restore the factory menus. 

If you had customized menus in previous version of JMP or JMP Genomics, and would like to 
replicate the customization in JMP Genomics 3.1, complete the following steps: 

1. Select Edit > Customize > Menus and Toolbars. A menu tree browser appears in the left 
of your JMP Genomics window, as shown in Figure 8. 

 

Figure 8: The menu tree browser 

2. Click on the plus signs to open menu subsections, and right-click to insert or modify items as 
needed to complete your customization. 

3. Click Apply to save your changes.  
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