SAS® Visual Analytics 6.2
Getting Started with Exploration and Reporting
# Contents

*Using This Book* .......................................................... v

*Accessibility Features of SAS Visual Analytics* ...................... vii

**Chapter 1 • Introduction** .............................................. 1
  About Exploration ...................................................... 1
  About Reporting ........................................................ 2

**Chapter 2 • Basic Tasks** ................................................ 3
  Introduction .............................................................. 3
  Explore a Data Source .................................................. 3
  Share an Exploration .................................................... 4
  Create a Report .......................................................... 6
  View a Report ............................................................. 7

**Chapter 3 • Specific Tasks** ............................................. 9
  Introduction .............................................................. 9
  Cheat Sheet for Explorations ......................................... 10
  Cheat Sheet for Reports ................................................ 12
  About the Availability of Actions ..................................... 16

**Chapter 4 • Quick Reference** .......................................... 17
  Data Sources ............................................................ 17
  Anatomy of a Report .................................................... 18
  Gallery ................................................................. 18
  The Home Page .......................................................... 31
  The Explorer ............................................................. 32
  The Designer ............................................................. 33
  The Viewers ............................................................. 35
  Where to Find Additional Documentation .......................... 36
Using This Book

Audience

This book covers the basics of how to explore data and build reports using SAS Visual Analytics. The emphasis is on introductory instructions, how-to hints, and quick reference information.

Requirements

Prerequisites

If you choose to perform the tasks in this book, you need the following software, information, and privileges:

- a link to a working deployment of SAS Visual Analytics 6.2
- a supported web browser (see the SAS support site for supported versions)
- a supported version of the Adobe Flash Player (see the SAS support site for supported versions)
- an account that can log on to the working deployment
- the ReadMetadata and Read permissions for at least one LASR table (without the necessary permissions, you cannot select a data source or access data)
- data exploration and reporting capabilities (without the necessary capabilities, you cannot see certain user interface elements)
System Requirements

Detailed system requirements, including support for additional web browsers, are available on the SAS support site.
Accessibility Features of SAS Visual Analytics

For information about the accessibility of SAS Visual Analytics, see the SAS Visual Analytics: User’s Guide.

Please contact accessibility@sas.com if you need this document in an alternative digital format.
Introduction

About Exploration

Data exploration involves getting to know a data source and then using it to inform your decisions. In exploration, the emphasis is on discovery and ad hoc visualization. Exploration is driven by predefined questions, curiosity, logic, intuition, creativity, and experimentation.

The SAS Visual Analytics Explorer (the explorer) is well suited to the task.

- The explorer provides fast, highly visual responses so that you can use an iterative approach to exploring the data.
- The explorer's clean interface and natural interactions minimize distractions so that you can keep your concentration on the data.
- The explorer supports a range of visualization and discovery activities so that you can adapt your tactics as insights emerge.
- The explorer includes advanced analytical tools (such as forecasting, correlations, and fit lines) to further guide and refine the exploration process.
About Reporting

In reporting, the emphasis is on clear, compelling, and widespread communication. Reporting encompasses design, data selection, interactions by viewers (such as brushing and filtering), and viewing (in web and native mobile device formats).

Like the explorer, the reporting interfaces are intuitive and responsive, even for extremely large data sources. Here are the interfaces that you use for reporting:

- The SAS Visual Analytics Designer (the designer) is for creating and enhancing reports and dashboards.
- The SAS Visual Analytics Viewer (the viewer) is for viewing and interacting with reports in a web browser.
- SAS Mobile BI is for viewing and interacting with reports on mobile devices.
Basic Tasks

Introduction
This chapter provides step-by-step instructions to guide you through basic tasks. The purpose is to provide a brief, hands-on orientation to a few of the many possible workflows for exploration and reporting.

Explore a Data Source
To explore a data source:

1. In a web browser, open the SAS Visual Analytics home page (at your equivalent of http://<serverName>:<portNumber>/SASVisualAnalyticsHub).

2. In the Create Content area, click Explore Data.
3. In the SAS Visual Analytics Explorer window, click **Select a Data Source**.

   **TIP** Each data exploration is saved in its own project, which is called an exploration.

4. In the Open Data Source window, select a data source. Click **Open**.

5. Drag any data item from the left pane onto the center of the screen. The explorer assigns the data item to a role and displays an initial chart as the new exploration’s first visualization.

   **TIP** An exploration contains all of the visualizations, filters, and data settings from an explorer session.

6. Extend, enhance, and refine the exploration (as little or as much as you like). For ideas, see “Cheat Sheet for Explorations” on page 10.

   **TIP** In exploration and reporting, access to data is always Read-Only, so feel free to experiment—you will not break anything.

7. To save the exploration, select **File ▶ Save** from the main menu. In the Save As window, select **My Folder**, and enter a name. Click **Save**.

8. In the upper left corner of the explorer, click **Home**.

9. On the home page, notice that the new exploration is in the **Recent** list in the **My Content** area.

---

**Share an Exploration**

Although the primary purpose of exploration is ad hoc visualization, you might want to share your findings. For that reason, exploration is never a dead end.
One way to share the contents of an exploration is to export some or all of its visualizations as a report.

To export an exploration as a report:

1. On the SAS Visual Analytics home page, double-click an exploration to open it.
2. Select **File ➤ Export ➤ Exploration as Report** from the explorer’s main menu.
3. If your exploration contains more than one visualization, use the Export as Report window to select the visualizations that you want to export. Click **OK**.

   **TIP** A few types of content (animated bubble plot, treemap that displays additional levels, and correlation data from a scatter plot or heat map) cannot be exported. To share such content, export it as a PDF or save it as an image.

4. In the Save As window, select a shared folder, and accept the default name. Click **Save**.
5. In the upper left corner of the explorer, click **Home**.
6. In the **My Content** area of the home page, notice that the new report is not in the **Recent** list. Only objects that you create or open are in the **Recent** list. If you want to navigate to the new report, click **Browse**.

The preceding steps export content to SAS metadata as a report. Here are some other ways to share the contents of an exploration:

**Table 2.1 Additional Methods for Sharing Exploration Content**

<table>
<thead>
<tr>
<th>Task</th>
<th>How to Initiate</th>
</tr>
</thead>
<tbody>
<tr>
<td>E-mail a saved exploration as a link</td>
<td>From the explorer’s main menu, select <strong>File ➤ E-mail</strong>.</td>
</tr>
<tr>
<td>Export as a PDF</td>
<td>From the explorer’s main menu, select <strong>File ➤ Export ➤ Exploration as PDF</strong>.</td>
</tr>
<tr>
<td>Save as an image</td>
<td>In a visualization’s toolbar, click ![icon], and select <strong>Export Image</strong>.</td>
</tr>
</tbody>
</table>
Create a Report


2. Drag a **Bar Chart** from the left pane onto the center of the screen.

3. To add data:
   a. On the **Data** tab (in the left pane), click **Select a data source**. In the Add Data Source window, select a data source, and click **Add**.
   b. Drag a category 📊 from the **Data** tab onto the **Category** label (at the bottom of the bar chart).

   **TIP** A category has alphanumeric or date values that can be used as discrete groupings (for example, the values in a product category might include shoes and belts).

   c. Drag a measure 💰 from the **Data** tab onto the bar chart.

   **TIP** A measure has numeric values that can be used as numbers (for example, the values in a sales measure might specify the quantity of units sold).

4. Extend, enhance, and refine the report (as little or as much as you like). For ideas, see “Cheat Sheet for Reports” on page 12.

   **TIP** If your session times out due to inactivity, any unsaved changes are lost. It is a good idea to save your work frequently.
5 To save the report, select **File ▶ Save** from the main menu. In the Save As window, select **My Folder**, and enter a name. Click **Save**.

6 In the upper left corner of the designer, click **Home**.

7 On the home page, notice that the new report is in the **My Content** area.

---

**View a Report**

To open a report in the web viewer, right-click on the report on the home page, and then click **View** in the pop-up window.

To open a report in a mobile viewer, launch the SAS Mobile BI app, connect to a server, navigate to the report, and open it. Instructions vary by device. See the “Viewing Reports on a Mobile Device” chapter in *SAS Visual Analytics: User’s Guide*, and videos on the [SAS support site](https://support.sas.com/).

**TIP** The SAS Mobile BI app for iPad is available in the iTunes App Store. The Android app is available from Google Play.
Specific Tasks

Introduction ................................................................. 9
Cheat Sheet for Explorations ........................................... 10
Cheat Sheet for Reports .................................................. 12
About the Availability of Actions ..................................... 16

Introduction

This chapter highlights core functionality in the explorer and designer. For most tasks, there are multiple ways to begin. Here, one way to initiate each task is documented. If you ever get stuck or have questions, some of the text right inside the interface might help.

**TIP** For comprehensive instructions, access the *SAS Visual Analytics: User's Guide* from the Help menu or the SAS support site.
## Cheat Sheet for Explorations

<table>
<thead>
<tr>
<th>Task</th>
<th>How to Initiate in the Explorer</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add variables to a visualization.</td>
<td>Drag the data items onto the visualization in the center of the screen (from the Data pane on the left).</td>
</tr>
<tr>
<td>Switch to a different visualization type.</td>
<td>From the main menu, select Visualization ➤ type.</td>
</tr>
<tr>
<td>Subset data for the entire exploration.</td>
<td>Right-click on a data item, and select Add as Global Filter.</td>
</tr>
<tr>
<td>Subset data for one visualization.</td>
<td>Select the visualization, right-click on a data item, and select Add as Local Filter.</td>
</tr>
<tr>
<td>Subset data in a chart by inclusion or exclusion.</td>
<td>Select a data value (for example, a bar in a bar chart), right-click, and select either Include Only Selection or Exclude Selection. (For a line chart, Show markers must be selected on the Properties tab.)</td>
</tr>
<tr>
<td>Sort elements within a chart or table.</td>
<td>Right-click on a data item in a chart axis or table, and select Sort.</td>
</tr>
<tr>
<td>View a visualization’s data.</td>
<td>Right-click on the visualization, and select Show Table View.</td>
</tr>
<tr>
<td>Use a different aggregation method.</td>
<td>Right-click on a measure in a chart axis or table, and select Aggregation.</td>
</tr>
<tr>
<td>Use a distinct count as a measure.</td>
<td>In the Data pane, right-click on a category (or date), and select Derive Distinct Count.</td>
</tr>
<tr>
<td>Derive percentage of total as a measure.</td>
<td>In the Data pane, right-click on a measure, and select Derive Percent of Total.</td>
</tr>
<tr>
<td>Apply a correlation and fit line.</td>
<td>Right-click on a scatter plot or heat map, and select Fit Line ➤ type. (For a scatter plot, there must be at least two measures and no grouping categories. For a heat map, both the X and Y axes must be measures.)</td>
</tr>
<tr>
<td>Task</td>
<td>How to Initiate in the Explorer</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Predict future values.</td>
<td>In a line chart where a date or time data item is assigned to the category role (and no other category roles are used), right-click, and select <strong>Show Forecast</strong>.</td>
</tr>
<tr>
<td>Create multiple visualizations.</td>
<td>From the main menu, select <strong>Visualization ▶ New</strong>.</td>
</tr>
<tr>
<td>Organize your visualizations.</td>
<td>From the main menu, select <strong>View ▶ Manage Visualizations</strong>.</td>
</tr>
<tr>
<td>See how selected data in one visualization corresponds to other visualizations.</td>
<td>From the main menu, select <strong>View ▶ Data Brushing</strong>. (Not all visualizations support cross-visualization highlighting.)</td>
</tr>
<tr>
<td>Create a data item from an expression.</td>
<td>From the main menu, select <strong>Data ▶ New Calculated Item</strong>. (Calculations use unaggregated data.)</td>
</tr>
<tr>
<td>Create an aggregated measure from an expression.</td>
<td>From the main menu, select <strong>Data ▶ New Aggregated Measure</strong>.</td>
</tr>
<tr>
<td>Set up drill-down functionality.</td>
<td>From the main menu, select <strong>Data ▶ New Hierarchy</strong>.</td>
</tr>
<tr>
<td>Display a geographic map with a bubble plot overlay.</td>
<td>Drag a geographic data item 🌍 onto an empty visualization.</td>
</tr>
<tr>
<td>Set up a geographic data item.</td>
<td>In the <strong>Data</strong> pane, right-click on a data item that contains geographic information, select <strong>Geography</strong>, and assign a geographic role.</td>
</tr>
<tr>
<td>Delete an exploration.</td>
<td>Click <strong>Home</strong>, and then click <strong>Manage</strong> (next to My Content or Other Content).</td>
</tr>
<tr>
<td>Explore a different data source.</td>
<td>From the main menu, select <strong>File ▶ New Exploration</strong>.</td>
</tr>
<tr>
<td>Change the data source for the current exploration.</td>
<td>From the main menu, select <strong>Data ▶ Change Data Source</strong>.</td>
</tr>
<tr>
<td>Add or view exploration-level comments.</td>
<td>From the main menu, select <strong>File ▶ Exploration Comments</strong>.</td>
</tr>
<tr>
<td>Task</td>
<td>How to Initiate in the Explorer</td>
</tr>
<tr>
<td>------</td>
<td>--------------------------------</td>
</tr>
<tr>
<td>Add or view comments for the selected visualization.</td>
<td>From the main menu, select <strong>Visualization Comment</strong>. The <strong>Comments</strong> tab is in the right pane.</td>
</tr>
</tbody>
</table>

### Cheat Sheet for Reports

<table>
<thead>
<tr>
<th>Data Task</th>
<th>How to Initiate in the Designer</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add another data source.</td>
<td>On the <strong>Data</strong> tab, click <img src="image" alt="button" />.</td>
</tr>
<tr>
<td>Insert a data display object (such as a table, graph, or gauge).</td>
<td>Drag the object (from the <strong>Objects</strong> tab) onto the report in the center of the screen.</td>
</tr>
<tr>
<td>Use a distinct count as a measure.</td>
<td>On the <strong>Data</strong> tab, right-click on a category (or date) data item, and select <strong>Derive Distinct Count</strong>.</td>
</tr>
<tr>
<td>Change a measure’s format.</td>
<td>On the <strong>Data</strong> tab, select the measure, and then click the triangle at the end of the <strong>Format</strong> row (below the list of data items).</td>
</tr>
<tr>
<td>Create a data item from an expression.</td>
<td>On the <strong>Data</strong> tab, click <img src="image" alt="button" />, and select <strong>New Calculated Item</strong>. (Calculations use unaggregated data.)</td>
</tr>
<tr>
<td>Set up drill-down functionality.</td>
<td>On the <strong>Data</strong> tab, click <img src="image" alt="button" />, and select <strong>New Hierarchy</strong>.</td>
</tr>
<tr>
<td>Hide a data item.</td>
<td>On the <strong>Data</strong> tab, click <img src="image" alt="button" />, and select <strong>Show or Hide Items</strong>.</td>
</tr>
<tr>
<td>Exclude a subset of data.</td>
<td>Right-click on a data item, and select <strong>New Data Item Filter</strong>.</td>
</tr>
<tr>
<td>Incorporate a stored process.</td>
<td>From the main menu, select <strong>Insert Other Stored Process</strong>.</td>
</tr>
<tr>
<td>Get basic statistics about all measures.</td>
<td>On the <strong>Data</strong> tab, click <img src="image" alt="button" />, and select <strong>Measure Details</strong>.</td>
</tr>
<tr>
<td>Data Task</td>
<td>How to Initiate in the Designer</td>
</tr>
<tr>
<td>-----------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Get additional statistics about a measure.</td>
<td>On the <strong>Data</strong> tab, click 🛠️, select <strong>Measure Details</strong>, and select the measure (in the Measure Details window).</td>
</tr>
<tr>
<td>Change the data source for the current report.</td>
<td>On the <strong>Data</strong> tab, click 🛠️, and select <strong>Change Data Source</strong>.</td>
</tr>
<tr>
<td>Show multiple aggregations (or multiple formats) for a data item.</td>
<td>Right-click on the data item, select <strong>Duplicate Data Item</strong>, and then change the aggregation (or format) of the new data item.</td>
</tr>
<tr>
<td>Reuse an existing visualization or report object in a separate report.</td>
<td>From the main menu, select <strong>View ▶ Imports</strong>. The <strong>Imports</strong> tab is in the left pane.</td>
</tr>
<tr>
<td>Set up a geographic data item.</td>
<td>On the <strong>Data</strong> tab, right-click on an item that contains geographic information, select <strong>Geography</strong>, and assign measures that contain location information. (For example, you might assign Region_Latitude and Region_Longitude as the respective measures for a Region category.) You can also assign predefined geographic roles, such as Countries or US ZIP codes, instead of using the custom geographic roles.</td>
</tr>
<tr>
<td>Display a geographic map with a bubble plot overlay or with colored regions.</td>
<td>From the <strong>Other</strong> list on the <strong>Objects</strong> tab, drag <strong>Geo Bubble Map</strong> or <strong>Geo Region Map</strong> onto a report in the center of the screen. From the <strong>Data</strong> tab, drag a geographic data item onto the map.</td>
</tr>
<tr>
<td>Delete a report.</td>
<td>Click <strong>Home</strong>, and then click <strong>Manage</strong> (next to <strong>My Content</strong> or <strong>Other Content</strong>).</td>
</tr>
<tr>
<td>Derive the percentage of total for a measure.</td>
<td>On the <strong>Data</strong> tab, right-click on a measure (with a current default target aggregation of Sum or Count), and select <strong>Derive Percent of Total</strong>. A new aggregated measure is created.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Presentation Task</th>
<th>How to Initiate in the Designer</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit a report's description.</td>
<td>At the top of the <strong>Properties</strong> tab, select the report from the drop-down list.</td>
</tr>
<tr>
<td>Presentation Task</td>
<td>How to Initiate in the Designer</td>
</tr>
<tr>
<td>-----------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Format a chart’s title.</td>
<td>Select the chart, and then make changes on its <strong>Properties</strong> tab.</td>
</tr>
<tr>
<td>Add a trend line to a list table.</td>
<td>In a table, right-click on a column, and select <strong>Add Sparkline</strong>. (The data source must include a date data item.)</td>
</tr>
<tr>
<td>Change a bar chart’s orientation.</td>
<td>Select the bar chart, and then change <strong>Direction</strong> on its <strong>Properties</strong> tab.</td>
</tr>
<tr>
<td>Change a chart’s colors or styles.</td>
<td>Select the chart, and then make changes on its <strong>Styles</strong> tab.</td>
</tr>
<tr>
<td>Set up report-level conditional highlighting.</td>
<td>On the <strong>Display Rules</strong> tab, select the report, and then click <strong>New</strong>.</td>
</tr>
<tr>
<td>Set up object-level conditional highlighting.</td>
<td>On the <strong>Display Rules</strong> tab, select a report object.</td>
</tr>
<tr>
<td>Create a reusable pattern of gauge intervals</td>
<td>From the main menu, select <strong>View ▶ Shared Rules</strong>. The <strong>Shared Rules</strong> tab is in the left pane. Click [ ].</td>
</tr>
<tr>
<td>and colors.</td>
<td></td>
</tr>
<tr>
<td>Apply a shared display rule to a new gauge.</td>
<td>From the main menu, select <strong>View ▶ Shared Rules</strong>. The <strong>Shared Rules</strong> tab is in the left pane. Drag the rule onto the gauge.</td>
</tr>
<tr>
<td>Add a new section (tab) to a report.</td>
<td>At the top of the canvas, click [ ].</td>
</tr>
<tr>
<td>Create a scrollable area.</td>
<td>From the main menu, select <strong>Insert ▶ Other ▶ Vertical Container</strong> (or <strong>Horizontal Container</strong>).</td>
</tr>
<tr>
<td>Use a different canvas size.</td>
<td>At the top of the canvas, click [ ], [ ], or [ ].</td>
</tr>
<tr>
<td>Change your default canvas size.</td>
<td>From the main menu, select <strong>File ▶ Preferences</strong>.</td>
</tr>
<tr>
<td>Overlap one report object on top of another.</td>
<td>On a section’s <strong>Properties</strong> tab, select <strong>Precision</strong> from the <strong>Layout</strong> drop-down list.</td>
</tr>
<tr>
<td>Presentation Task</td>
<td>How to Initiate in the Designer</td>
</tr>
<tr>
<td>-------------------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Set up view-time filters (prompts).</td>
<td>From the <strong>Objects</strong> tab, drag a control object onto the drop zone at the top of a report or section. Then, drag a category data item onto the control object.</td>
</tr>
<tr>
<td>Set up view-time interactions (where an action on one object affects other objects).</td>
<td>From the main menu, select <strong>View ▶ Interactions</strong>. The <strong>Interactions</strong> tab is in the right pane. Click <strong>New ▶ Interaction</strong>. (Not all objects support interactions.)</td>
</tr>
<tr>
<td>Add or view comments.</td>
<td>From the main menu, select <strong>View ▶ Comments</strong>. The <strong>Comments</strong> tab is in the right pane. (Only report-level comments are supported.)</td>
</tr>
<tr>
<td>Display totals for list tables.</td>
<td>On the <strong>Properties</strong> tab, select <strong>Show totals</strong>.</td>
</tr>
<tr>
<td>Display totals and subtotals for crosstabs.</td>
<td>On the <strong>Properties</strong> tab, make selections to show subtotals and totals for columns and rows.</td>
</tr>
<tr>
<td>Create basic and advanced filters.</td>
<td>From the main menu, select <strong>View ▶ Filters</strong>. The <strong>Filters</strong> tab is in the right pane. Select a data item or <strong>Advanced</strong> from the drop-down list, and then click <strong>Add Filter</strong> and select values.</td>
</tr>
<tr>
<td>Create links to reports, sections, or external URLs.</td>
<td>From the main menu, select <strong>View ▶ Interactions</strong>. The <strong>Interactions</strong> tab is in the right pane. Click <strong>New</strong>, and then select the type of link that you want to create.</td>
</tr>
<tr>
<td>Rank values.</td>
<td>From the main menu, select <strong>View ▶ Ranks</strong>. The <strong>Ranks</strong> tab is in the right pane.</td>
</tr>
<tr>
<td>E-mail reports.</td>
<td>Select <strong>File ▶ E-mail</strong>.</td>
</tr>
</tbody>
</table>

**TIP** In general, data-related tasks are initiated from the leftmost panes, and presentation-related tasks are initiated from the rightmost pane.
About the Availability of Actions

The following factors affect the availability of actions:

- Your capabilities (for example, if you do not have export capabilities, the export options in the explorer’s File menu are not available to you).

- The interface that you are using (for example, text styling properties are available only in the designer).

- The currently selected object (for example, list tables do not have ranges).

- Whether data has been defined (for example, you must add a data source before you can define filters).

- Whether a data item is already in use (for example, you cannot change a data item’s role while it is incorporated in a bar chart as a category).
Quick Reference

Data Sources ........................................................................................................................................ 17
Anatomy of a Report ................................................................................................................................ 18
Gallery ....................................................................................................................................................... 18
The Home Page ........................................................................................................................................ 31
The Explorer ............................................................................................................................................... 32
The Designer ............................................................................................................................................. 33
The Viewers ............................................................................................................................................... 35
Where to Find Additional Documentation .............................................................................................. 36

Data Sources

Each exploration can have only one data source.

Each report (and each section within a report) can have multiple data sources.

Data that is used for explorations and reports must be loaded into memory on the SAS LASR Analytic Server. In addition to loading SAS data sets, an administrator can load other data that is accessible to a SAS/ACCESS engine and import local Excel or delimited (CSV) files.
TIP An administrator can perform ETL and aggregation functions before loading data. For more information, see the data preparation chapters in the SAS Visual Analytics: User's Guide.

Anatomy of a Report

A report’s content can include the following types of objects:

- Objects that display data or results, including tables, graphs, geo maps, gauges, and stored processes.
- Objects that provide static content, including images (for example, a logo) and text (for example, a link to a web page).
- Objects that enable viewers to interact with a report (these objects are called controls).

A report’s structure is provided by sections and containers:

- Sections separate content onto different tabs or pages. Designers and viewers can see the contents of only one section at a time.
- Vertical and horizontal containers group objects within a section. A container has a scrollable space, enabling the container to hold more content than what fits on the screen. Designers and viewers can scroll in the report to see additional content.

Gallery

This is an illustrated guide to displaying data and results. Many of the features are available in two contexts:

- as visualizations (the building blocks of explorations) in the explorer
- as report objects (the building blocks of reports) in the designer and viewers
Any differences in availability are driven by the purpose of each interface. Explorations emphasize discovery. Reports and dashboards emphasize presentation.

**TIP** Use the following images for orientation. Actual appearance and functionality are affected by the underlying data, any styles that you apply, and the interface that you are using. (Some of the following images are from the explorer, others are from the designer).

**Table 4.1  Displaying Data and Results**

A table (also known as a list table) is a two-dimensional representation of data. Values are arranged in unlabeled rows and labeled columns. A table cannot use a hierarchy.

In the designer, tables contain aggregated data (unless the **Show detail** data property is selected). You can add sparklines to a column (if the data source contains a date data item). In the explorer, tables contain raw data.

**Availability:**

- ✔ Supported in the explorer.
- ✔ Supported in the designer and viewers.
A crosstab (also known as a crosstabulation table) shows an aggregate metric for the intersections of two or more categories. In a crosstab, categories are typically displayed in both the columns and the rows. Each cell value represents the aggregated measure from the intersection of the categories in the cell’s row and column. A crosstab uses less space than a traditional table and is easier to read because data is grouped both horizontally and vertically. A crosstab can use a hierarchy.

**Availability:**

- ✔ Supported in the explorer.
- ✔ Supported in the designer and viewers.

A bar chart consists of vertical or horizontal bars that represent quantitative data. Use bar charts to compare data that is aggregated by the distinct values of a category.

You can apply grouping and create lattices.

**Availability:**

- ✔ Supported in the explorer.
- ✔ Supported in the designer and viewers.
A line chart shows the relationship of one variable to another, often as movements or trends in the data over a period of time. Line charts summarize source data, and typically are used to show how values change over time. You can apply grouping and create lattices.

In the explorer, line charts support time series. From a time series, you can generate a forecast analysis that enables you to predict future values for the series and visualize the probability range for those values.

**Availability:**
- ✓ Supported in the explorer.
- ✓ Supported in the designer and viewers.

A scatter plot is a two-dimensional plot that shows the joint variation of two data items. Each marker (represented by symbols such as dots, squares, or plus signs) represents an observation. The marker position indicates the value for each observation. Use a scatter plot to examine the relationship between numeric data items. You can apply grouping. (In the designer, grouping is called "color.")

In the explorer, you can apply statistical analysis with correlation and fit lines. When you apply more than two measures to a scatter plot, a scatter plot matrix compares each pairing of measures.

**Availability:**
- ✓ Supported in the explorer.
- ✓ Supported in the designer and viewers.
A bubble plot displays the relationships among at least three measures. Two measures are represented by the plot axes, and the third measure is represented by the size of the plot markers. Each bubble represents an observation. A bubble plot is useful for data sets with dozens to hundreds of values. You can apply grouping and create lattices.

In the explorer, you can use color to represent an additional measure and animate the bubbles to display changes in the data over time.

**Availability:**
- ✔ Supported in the explorer.
- ✔ Supported in the designer and viewers.

A geo bubble map is a bubble plot that is overlaid on a geographic map. Each bubble is located at a geographic location or at the center of a geographical region. A geo bubble map requires a data item that contains geographical information and is assigned to a geography role.

**Availability:**
- ✔ Supported in the explorer (in a geo map visualization, click ▼, and then select Map Style ▶ Bubbles).
- ✔ Supported in the designer and viewers.
A geo region map (also known as a choropleth map) is a two-dimensional map that uses colors to represent different categories or levels of magnitude. You can fill geographical boundaries (for example, a country or a state) on a map with color, based on measure values that are aggregated to the level defined by a geographical boundary. A geo region map requires a data item that contains geographical information and is assigned to a geography role.

**Availability:**

- ✔ Supported in the explorer (in a geo map visualization, click ➔, and then select Map Style ➔ Regions).
- ✔ Supported in the designer and viewers.

A histogram displays the distribution of values for a single measure.

In the explorer, you can select the bar orientation. You can select whether the values are displayed as a percentage or as a count.

To add a histogram to a report, create it in the explorer, and export it as a report object.

**Availability:**

- ✔ Supported in the explorer.
- ☒ Limited support in the designer and viewers.
A box plot displays the distribution of values for a single measure using a box and whiskers. The size and location of the box indicate the range of values that are between the 25th and 75th percentile. Additional statistical information is represented by other visual features.

In the explorer, you can create lattices and specify whether the average (mean) value and outliers are displayed for each box.

To add a box plot to a report, create it in the explorer, and export it as a report object.

**Availability:**
- ✔️ Supported in the explorer.
- ☰ Limited support in the designer and viewers.

A heat map displays the distribution of values for two data items using a grid of colored cells. If you do not assign a measure to the color data role, then a cell’s color represents the frequency of each intersection of values. If you assign a measure to the color data role, then a cell’s color represents the measure value of each intersection of values.

To add a heat map to a report, create it in the explorer, and export it as a report object.

**Availability:**
- ✔️ Supported in the explorer.
- ☰ Limited support in the designer and viewers.
A treemap displays your data as a set of rectangles (called tiles). Each tile represents a category or a hierarchy node. The color of each tile represents the value of the first measure. The size of each tile represents the value of the second measure. For example, a sales data treemap might have tile sizes that represent the number of orders and tile colors that are derived from color gradients that represent sales.

**Availability:**

✔ Supported in the explorer.
✔ Supported in the designer and viewers.

---

A correlation matrix displays the degree of correlation between measures as a series of colored rectangles. The color of each rectangle indicates the strength of the correlation.

**Availability:**

✔ Supported in the explorer.
кси Limited support in the designer and viewers.
A decision tree displays a series of nodes as a tree, where the top node is the target data item and each branch represents a split in the values of a predictor data item. A split enables you to see which value of the predictor data item corresponds to a different distribution of the value in the target data item.

**Availability:**
- ✔ Supported in the explorer.
- ☐ Not supported in the designer or viewers.

A targeted bar chart is a bar chart that has pointers to target values. In this example, the pointers appear above each bar.

**Availability:**
- ☐ Not supported in the explorer.
- ✔ Supported in the designer and viewers.
A waterfall chart (also known as a progressive bar chart) shows how the initial value of a measure increases or decreases during a series of operations or transactions. The first bar begins at the initial value, and each subsequent bar begins where the previous bar ends. The length and direction of a bar indicate the magnitude and type (positive or negative, for example) of the operation or transaction. The resulting chart is a stepped cascade that shows how the operations or transactions lead to the final value of the measure.

**Availability:**
- ☐ Not supported in the explorer.
- ✔ Supported in the designer and viewers.

A pie chart is a circular chart that is divided into slices by radial lines. Each slice represents the relative contribution of each part to the whole.

**Availability:**
- ☐ Not supported in the explorer.
- ✔ Supported in the designer and viewers.

A time series plot shows an ordered sequence of values that are observed at equally spaced time intervals. A time series plot requires a date or date time category data item that is continuous.

**Availability:**
- ✔ Supported in the explorer as a line chart.
- ✔ Supported in the designer and viewers.
A dual axis bar chart is a variation of the bar chart that has two measures. A measure is on each axis.

**Availability:**
- Not supported in the explorer.
- Supported in the designer and viewers.

A dual axis line chart is a variation of the line chart that has two measures. A measure is on each axis.

**Availability:**
- Not supported in the explorer.
- Supported in the designer and viewers.

A dual axis bar-line chart is a variation of the bar chart that has two measures. A measure is on each axis, and the bar chart is overlaid by a line chart.

**Availability:**
- Not supported in the explorer.
- Supported in the designer and viewers.
A dual axis time series plot is a variation of the time series plot that has two measures. A measure is on each axis.

**Availability:**
- Not supported in the explorer.
- ✓ Supported in the designer and viewers.

A bullet gauge is a dashboard indicator (also known as a key performance indicator (KPI) chart) that compares an actual value to a target value in intervals. This example displays three bullet gauges. The actual value is indicated by an inset bar.

**Availability:**
- Not supported in the explorer.
- ✓ Supported in the designer and viewers.

A slider gauge is a dashboard indicator (also known as a KPI chart) that compares an actual value to a target value in intervals. This example displays three slider gauges. The actual value is indicated by an arrow.

**Availability:**
- Not supported in the explorer.
- ✓ Supported in the designer and viewers.

A thermometer gauge is a dashboard indicator (also known as a KPI chart) that compares an actual value to a target value in intervals. This example displays three thermometer gauges. The actual value is indicated by a bar.

**Availability:**
- Not supported in the explorer.
- ✓ Supported in the designer and viewers.
A dial gauge is an arc-shaped dashboard indicator (also known as a KPI chart) that compares an actual value to a target value and compares them in intervals. The actual value is indicated by an arrow that points outward from the inner circle.

**Availability:**

○ Not supported in the explorer.

✔ Supported in the designer and viewers.

A speedometer gauge is a circular dashboard indicator (also known as a KPI chart) that compares an actual value to a target value and compares them in intervals. The actual value is indicated by the larger pointer.

**Availability:**

○ Not supported in the explorer.

✔ Supported in the designer and viewers.
The Home Page

1. The menu bar offers common tasks and search functionality.
2. The **Create Content** area has icons for creating new explorations and reports.
3. The **My Content** area provides several ways to navigate to certain types of content.
4. The **Other Content** area displays predefined lists of content.
5. The **Common Actions** pane is an alternate initiation point for certain actions.
6. The **Links** pane lists an introductory video and any pages that you have bookmarked.
7. The **SAS Resources** pane has links to the SAS website and social media.
The application bar provides access to the home page and recent explorations.

The menu bar offers common tasks, such as creating a new exploration.

The toolbar enables you to manage your explorations and visualizations.

The data pane enables you to manage the data that is used in your visualizations.

The data properties table enables you to set data item properties.
6. The workspace displays one or more visualizations.

7. The right pane’s tabs enable you to set properties and data roles, subset data, and use comments.

8. The dock contains any minimized visualizations.

---

The Designer

---
The application bar provides access to the home page and recent objects.

The menu bar offers common tasks for the current report or section.

The toolbar enables you to manage your reports and expand the workspace.

The **Objects** tab enables you to add new report objects.

The **Imports** tab enables you to import and reuse content from other reports.

The **Data** tab enables you to select data. You can add, refresh, or remove a data source using the icons above the list of data items. Using the local menu, you can change the data source, define a hierarchy, define a calculated item, define an aggregated measure, show or hide data items, and sort or group data items. You can access the details for the measures in the data. You can right-click on a data item to manage it or any data item filters. The data items table on the **Data** tab provides information about a selected data item, including the name, role, format, and aggregation. If you modify any of these data item properties, all report objects that use that data item are affected.

The **Shared Rules** tab enables you to create and manage display rules that are used by multiple gauges (for example, a display rule can designate range intervals and colors).

To access additional tabs or to display icons instead of tab names, click after the last tab name.

The canvas is the workspace for building a report. There is an area at the top of the canvas where you can drop filter controls and then categories to create section prompts. You can change a report's canvas size.

The right pane’s tabs enable you to work with details about a report and its report objects. To access additional tabs or to display icons instead of tab names, click after the last tab name.
The Viewers

Here is an example of a report in the web viewer:
The mobile viewers are native to each device. For example, here is a screen capture from the SAS Mobile BI app for iPad:

![Screen capture from SAS Mobile BI app for iPad](image)

**Where to Find Additional Documentation**

The most current technical resources for SAS Visual Analytics are available on the SAS support site.

Your experience with SAS software should be as smooth as possible. Please submit your feedback.