## Contents

### Chapter 1 • Quick Start for Installation

- Overview .......................................................... 1
- Preinstallation Steps ............................................. 2
- Installing the SAS PC Files Server from the SAS Downloads Site .................................................. 4
- Installing the SAS PC Files Server from the SAS Deployment Wizard ............................................. 6
- Uninstalling an Existing SAS PC Files Server ....................................................................................... 15

### Chapter 2 • Examples Using the SAS PC Files Server

- Importing and Exporting Microsoft Office Files When SAS 9.4 and the SAS PC Files Server Are on the Same Machine ................................................................. 19
- Importing and Exporting Microsoft Office Files When SAS and the SAS PC Files Server Are on Different Machines .............................................................. 26

### Chapter 3 • SAS PC Files Server Administration

- Overview .............................................................. 31
- SAS PC Files Server Configuration ............................................. 33
- SAS PC Files Server Upgrades ............................................ 35
- SAS PC Files Server Operating Modes .......................................... 36
- SAS PC Files Server Authentication ........................................... 40
- SAS PC Files Server Autostart .................................................. 42
- Local Security Policy Configuration ......................................... 43
- Constraints .................................................................... 44

### Recommended Reading ....................................................................................................................... 45

### Index .............................................................................................................................................. 47
Chapter 1
Quick Start for Installation

Overview

The SAS PC Files Server is available for installation in SAS 9.4 on Microsoft Windows. It communicates with the SAS LIBNAME engine, PCFILES, running on Windows, Linux, or UNIX. For an overview, see “SAS PC Files Server” on page 31.

This chapter covers installations for SAS 9.4 (TS1M0) plus its three maintenance releases (TS1M1, TS1M2, TS1M3). There are multiple ways to install the SAS PC Files Server:

• As an individual SAS product installation from SAS Downloads on the support.sas.com site.

• As one SAS product among others using the SAS Deployment Wizard or as a product added on to a current SAS deployment.

The SAS PC Files Server requires a license for SAS 9.4 versions of SAS/ACCESS Interface to PC Files and Base SAS software.
Preinstallation Steps

Before you can install the SAS 9.4 PC Files Server, you need to determine your versions of Microsoft Office and SAS in order to know which SAS PC Files Server to download. You also need to know whether a SAS PC Files Server is already installed on the same Windows machine.

Which version of Microsoft Office do you have?

Microsoft Office is a suite of products that includes Microsoft Access and Microsoft Excel. When the term Microsoft Office is used in this document, it refers to both products.

Open one of the products (such as Microsoft Excel) and do the following:

- click the File tab and then Help or Account (depending on your version of Office) in the list on the side of the application.
- The version of Excel is shown in About Microsoft Excel. Notice whether it is a 32-bit or 64-bit version of Excel.

If you click the About Excel icon and its System Info button, you can also see which version of Microsoft Windows you have.

Which version of SAS do you have?

If you have SAS 9.4 installed on a Microsoft Windows system, do the following.

- In your operating environment, open SAS:
  - On Microsoft Windows, select Start ⇒ All Programs ⇒ SAS.
  - On Linux or UNIX, open SAS interactively in your site-specific way.
- After SAS is open, select Help ⇒ About.
  - In the Software Information field of the dialog box, note which version of SAS you have. For example, SAS(R) Proprietary 9.4 (TS1M1) indicates that this is the first release of SAS 9.4, software maintenance one. You will need this (TS1M1) information later in the SAS PC Files Server installation.
  - This document covers only SAS 9.4 installations. For SAS 9.3 installations, see the SAS Notes listed in “Recommended Reading” on page 45.

Which SAS PC Files Server do you download?

The installation process configures the SAS PC Files Server to match the bit architecture of Microsoft Office or of the Microsoft Access Database Engine (ACE) ODBC driver, if the ACE ODBC driver is installed. If you have the 32-bit version of Microsoft Office, then the 32-bit version of PC Files Server is configured. The two are “bit-compatible,” in that they are both 32-bit. The Microsoft ACE ODBC driver must be bit-compatible with the SAS PC Files Server (32 or 64).
For more information, see the Chapter 3, “SAS PC Files Server Administration,” on page 31.

Table 1.1  Determining Which SAS PC Files Server to Download

<table>
<thead>
<tr>
<th>SAS Details</th>
<th>Versions of Microsoft Office</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>64-bit Office and SAS on 64-bit Windows</td>
<td>2010, 2013</td>
<td>Stop. You do not need to install SAS PC Files Server for the PCFILES LIBNAME engine. Instead, you can use the Access or Excel LIBNAME engine.¹</td>
</tr>
<tr>
<td>64-bit Office and SAS on a UNIX or Linux machine</td>
<td>2010, 2013</td>
<td>install the 64-bit SAS PC Files Server</td>
</tr>
</tbody>
</table>

¹The SAS LIBNAME engines for Microsoft Access and Microsoft Excel are described in “SAS LIBNAME Statement Syntax for PC Files” in SAS/ACCESS Interface to PC Files: Reference.

Preparing for the Installation

Caveats about the Different Versions of the SAS PC Files Server
Before you begin the installation, it is important that you review the following caveats and verify that you do not have another version of the SAS PC Files Server on the same Microsoft Windows machine.

- Before you install the SAS PC Files Server, you must know which version of SAS 9.4 you have: TS1M0, TS1M1, TS1M2 or TS1M3.
- The SAS 9.4 versions of the SAS PC Files Server are not backward compatible with earlier releases of SAS 9.3 or SAS 9.2.
- You cannot install a SAS 9.4 version of the SAS PC Files Server on the same Microsoft Windows machine that has a SAS 9.2 or SAS 9.3 version.
- SAS 9.4 is not supported on certain earlier Windows releases, such as Microsoft Windows XP, Microsoft Windows 2003, or Microsoft Windows Vista. Therefore, a SAS 9.4 version of the SAS PC Files Server cannot be installed on these systems.
If you have questions, please contact SAS Technical Support: http://support.sas.com/techsup/contact.

**Check First for an Existing SAS PC Files Server**

1. From the Microsoft Windows Start menu, select the Control Panel.

2. If you are using a Windows 7 or Windows 2008 machine, change the View by option in the upper right to Large icons or Small icons so that you can access all of the tools.

3. Click Administrative Tools.


5. In the Services window, scroll down to SAS PC Files Server (in alphabetic order under “S”).

6. If you do not see SAS PC Files Server, close the Services window, and go to “Installing the SAS PC Files Server from the SAS Downloads Site” on page 4.

   If you see SAS PC Files Server, you must remove this current SAS PC Files Server before you install a new SAS 9.4 version. For more information, see “Uninstalling an Existing SAS PC Files Server” on page 15.

---

**Installing the SAS PC Files Server from the SAS Downloads Site**

When you install the SAS 9.4 PC Files Server as an individual product, your installation begins on the SAS Downloads site and is continued by using the SAS Deployment Wizard. In the section, the steps are presented as the “quick view” without showing you each screen. To see a step-by-step graphical approach, including windows described in the steps below, see “Installing the SAS PC Files Server from the SAS Deployment Wizard” on page 6.

*Note:* You might be required to have Administrator rights on your system in order to stop and start servers and to install or remove the SAS PC Files Server. Be aware that each time you stop and restart the server, all users’ sessions are closed. Closing these sessions could result in a loss of data.

The SAS PC Files Server can be downloaded from one of the following:

- SAS 9.4 PC Files Server Release 9.4 - July 2015 [TS1M3]
- SAS 9.4 PC Files Server Release 9.4 - AUG 2014 [TS1M2]
- SAS 9.4 PC Files Server Release 9.4 - DEC 2013 [TS1M1]
- SAS 9.4 PC Files Server Release 9.4 - AUG 2013 [TS1M0]

Review Table 1.1 on page 3 to see whether you need to download the SAS PC Files Server and if so, which one.

Proceed as follows:

- If you have the 32-bit version of Microsoft Office, select Windows.
- If you use the SAS PC Files Server in conjunction with a Linux or UNIX system and you have 64-bit Microsoft Office, select Microsoft Windows for x64.
If you have 64-bit Office and SAS on 64-bit Windows or you have 32-bit Office and SAS on 32-bit Windows, do not install the SAS PC Files Server. You can specify DBMS=EXCEL or DBMS=ACCESS because the SAS PC Files Server is not needed for you to access your PC data.

Follow these steps to install the SAS PC Files Server:

1. From the SAS PC Files Server Download page, select your release. The SAS PC Files Server System Dependencies page appears.

2. Click the Request Downloads button. The login page for your SAS Profile might appear, depending on your version of SAS 9.4. As needed, log on or follow the instructions to create a profile, and then log on. Review the legal agreement and click I Accept.

3. The Download Area for SAS PC Files Server for Windows page appears. Review the Readme file for system requirements and resources.

4. Click the Download button to download your ZIP file.
   - If your site enables you to download and extract a ZIP file from the Web, select Open and proceed to the next step.
   - If your site requires you to save a ZIP file and then extract it, select Save to automatically save the ZIP file to your Windows Downloads directory, or select Save as to create an empty subdirectory in your root or home directory.

5. Unzip one of the files below to extract the files:
   - TS1M3: pcfilesrv__94170__win__en__web__1 for 32-bit
   - TS1M3: pcfilesrv__94170__wx6__en__web__1 for 64-bit
   - TS1M2: pcfilesrv__94160__win__en__web__1
   - TS1M1: pcfilesrv__94150__win__en__web__1
   - TS1M0: pcfilesrv__94140__win__en__web__1

   (Or unzip the _wx6_ version of the file.) If you do not specify a directory and just download the file, it prompts you for a directory name.

6. Double-click setup.exe. Depending on your settings, you might need to right-click setup.exe and select Run as administrator.

7. Running setup.exe moves the installation into the SAS Deployment Wizard. Note that not all of the windows that are described in the following steps might appear, because of your previous SAS products’ installation. For example, you might have already set your language to English when you installed SAS/ACCESS. (As noted previously, to see each windows in the SAS Deployment Window, go to “Installing the SAS PC Files Server from the SAS Downloads Site” on page 6.)

8. The Choose Language dialog box appears. Select your language and click Next.

9. The Select Products to Install window appears. Select the check box for SAS PC Files Server and click Next.

10. The Select Regional Setting window appears. Select your language and region and click Next.

11. The Select SAS PC Files Server System Service Option dialog box appears. Click the check box if you want the server to start automatically as a Windows Service when Microsoft Windows starts. (Most users will want to do this.) Click Next.

12. If you have a previous SAS 9.4 version of the SAS PC Files Server installed, you are notified.
If you have stopped the server before beginning this installation, SAS overwrites the current server and continues to install of the newer version of the SAS PC Files Server. It prompts you about whether to continue. Select **Yes** or **No**.

13. The Checking System window appears. Click **Next**.

14. The Deployment Summary window appears and lists the products and components in your installation. Click **Start**.

15. The Deployment in Progress window appears. Click **Next**.

16. The Deployment Complete window appears. Click **Next** and then **Finish** in the Download Complete window. The SAS 9.4 PC Files Server is now installed.

17. A Deployment Summary for the installation appears in your web browser. Check the summary to make sure that everything installed as expected.

**See Also**

“Installing the SAS PC Files Server from the SAS Deployment Wizard” on page 6

---

**Installing the SAS PC Files Server from the SAS Deployment Wizard**

You can install the SAS PC Files Server as part of a larger SAS order, such as when you install Base SAS and SAS/ACCESS interface to PC Files. The steps are described and shown below.

**Using the Software Order Email (SOE)**

When you receive your licensed SAS software, you receive a Software Order Email (SOE) that describes how to install your order and links to tools that you use to do so.

For a video overview about the SAS 9.4 installation and configuration process, go to [http://support.sas.com/sas94-install-videos](http://support.sas.com/sas94-install-videos).

1. Download the SAS Download Manager:

   The SAS Download Manager is the application that you use to download your software. Follow the link in your Software Order Email to install and download your SAS Download Manager.

   The SAS Download Manager prompts you through a series of windows and dialog boxes that ask you to launch the Manager, to insert the order number listed in your SOE, and to log on to the SAS Installer. You then review the software for your order and the SAS Download Manager downloads your software to the SAS Software Depot, which is a repository for your SAS software media. If you do not have a SAS Software Depot, it creates one for you.

   After the SAS Download Manager downloads the SAS software, return to the Software Order Email for additional instructions.

2. In the Software Order Email, follow the steps to begin your SAS installation. The instructions vary depending on your operating environment. Because you are installing the SAS PC Files Server on Microsoft Windows, you execute this file: `setup.exe`. Instructions for doing so are described in “Using the SAS Deployment Wizard” on page 7.
**Using the SAS Deployment Wizard**

The SAS Deployment Wizard is an application that guides you through the installation of your SAS software. For example, the following installation is for Base SAS 9.4, SAS/ACCESS 9.4 to PC Files, and the SAS 9.4 PC Files on a 64-bit Microsoft Windows. This particular user plans to access Microsoft Excel and Microsoft Access files from a Linux machine and therefore downloads the 64-version of SAS PC Files Server.

To install and configure your SAS 9.4 software interactively, follow these steps:

1. Log on to the machine with a user ID using the SAS Installer account that you created when you installed and ran the SAS Download Manager. Or use an account where you are a member of the Windows Administrators group.

2. Temporarily disable all anti-virus, anti-malware, anti-spyware, and firewall software. These types of programs can interfere with the deployment process and block files as they are being copied and extracted.

3. Start Windows Explorer and navigate to the highest-level directory in your SAS Software Depot. Right-click setup.exe and select **Run as Administrator**.

4. Choose Language: From the drop-down list, select the language that you want the SAS Deployment Wizard to use when it displays text, and click **OK**.
5. Select Deployment Task: Select **Install SAS Software** and click **Next**.

6. Select Products to Install: This window shows a list of SAS products and components. Be sure to select the box for SAS PC Files Server. You can use the scroll bar on the right to see all the products. Click **Next**.
7. Select SAS Foundation Products. Notice that Base SAS is already selected. Click **Next**.

8. Specify SAS Installation Data File. From your software order, the SAS installation data file is displayed by default. Click **Next**.
9. Select Language Support: Click Clear All. (English remains selected as the default language in this example.) Add any additional languages that you want SAS to support and click Next.

10. Select SAS PC Files Server System Service Option. Select the box if you want the SAS PC Files Server to start automatically when Windows starts.
11. Specify SAS PC Files Server Port. The default port value is displayed. Do not change this value unless your administrator has told you to do so. Click Next.

12. Checking System: Wait while the SAS Deployment Wizard checks your system. When it is finished, click Next.

13. Review Required Updates: If you already have a SAS 9.4 version of SAS PC Files Server on your Windows machine, you are prompted whether you want to install a newer version over the current version. If you have stopped the older server first,
then you can continue to install the newer SAS PC Files Server. (To stop the server, see step 1 of “Uninstall an Existing SAS 9.4 PC Files Server” on page 15.)

14. Deployment Summary: Lists the SAS products and components that are to be installed. Click **Start** to begin the software installation.
15. Deployment in Progress: Checks off each product or component as it is installed.

16. Deployment Complete: Lists all of the products and components that are installed. Click Next.
17. Additional Resources: Provides SAS websites for additional information and support. Click **Finish** to complete the software installation and to close the SAS Deployment Wizard.

---

**Uninstalling an Existing SAS PC Files Server**

Be aware that each time you stop and restart the server, all users’ sessions are closed. Closing these sessions could result in a loss of data.

**Update an Existing SAS 9.4 PC Files Server**

If you have a SAS 9.4 version of the SAS PC Files Server installed on your Microsoft Windows machine, you can update the server rather than uninstall it.

1. Stop the current SAS 9.4 server first, as described in step 1 in “Uninstall an Existing SAS 9.4 PC Files Server” on page 15.

2. Continue with the process as described, starting step 13 in “Installing the SAS PC Files Server from the SAS Downloads Site” on page 4.

**Uninstall an Existing SAS 9.4 PC Files Server**

You must stop the current SAS 9.4 PC Files Server before you uninstall it, as follows:

1. To stop the current SAS PC Files Server:
   
   - From the Microsoft Windows **Start** menu, select **Control Panel** ⇒ **Administrative Tools** ⇒ **Services** ⇒ **SAS PC Files Server** in the Services window.
   - Right-click **SAS PC Files Server** and click **Stop**. Minimize the Services window.
Note: It is recommended that you stop all BI Servers (such as the object spawner, SAS Stored Process Server, and so on) if they are running on the same machine.

2. To uninstall the SAS 9.4 PC Files Server:
   From the Microsoft Windows Start menu, select the Control Panel.

3. In the upper right corner, select either View by: Large icons or View by: Small icons to see all of the categories.

4. Double-click Programs and Features and then SAS 9.4.

5. In the Choose Language dialog box, select English or another language and click OK.

6. In the Select SAS Products to Uninstall window, click the Clear All button.
   Scroll down to make sure that all of the product check boxes are deselected. Otherwise, certain SAS products could be uninstalled along with the SAS PC Files Server.

7. Select the check box next to the SAS PC Files Server only and click Next.

8. The SAS Deployment Manager appears. In the Checking System window, note the list of SAS products that will be uninstalled. Click Next.

9. The Summary window displays the SAS 9.4 PC Files Server that is to be uninstalled. Click Start to uninstall the server.

10. The Deployment Complete: Uninstall window appears. Click Next.

11. The SAS Resources window appears. Click Next and then Finish.

Uninstall an Existing SAS 9.3 PC Files Server
You must stop the current SAS 9.3 PC Files Server before you uninstall it, as follows:

1. To stop the current SAS PC Files Server:
   • From the Microsoft Windows Start menu, select Control Panel ⇒ Administrative Tools ⇒ Services ⇒ SAS PC Files Server in the Services window.
   • Right-click SAS PC Files Server and click Stop. Minimize the Services window.

   Note: It is recommended that you stop all BI Servers (such as the object spawner, SAS Stored Process Server, and so on) if they are running on the same machine.

2. To uninstall the SAS 9.3 PC Files Server:
   From the Microsoft Windows Start menu, select Settings ⇒ Control Panel.

3. In the upper right corner, select either View by: Large icons or View by: Small icons to see all of the categories.


5. Select English or another language and click OK.

6. In the Select SAS Products to Uninstall window, click the Clear All button.

7. Make sure that all of the product check boxes are deselected. Otherwise, certain SAS products could be uninstalled along with the SAS PC Files Server.

8. Select the check box next to the SAS PC Files Server only and click Next.
9. You see the Tooling Initialization Complete window. The top bar should have 1/1. If it does not finish, contact SAS Technical Support and click **Cancel**.

10. In Tooling Initialization Complete window, select **Next**.

11. A **stage 1 uninstall** button appears.

12. Click **Start**. The SAS PC Files Server will be uninstalled.

13. Click **This Program Uninstalled Correctly**.

14. Reboot your machine.

15. After the machine has rebooted, you are done. You can now install the latest version of SAS PC Files Server.

---

**Uninstall an Existing SAS 9.2 PC Files Server**

1. From the Microsoft Windows Start menu, select **Control Panel** ⇒ **Programs and Features** ⇒ **Add/Remove Programs**.

2. Double-click **SAS PC Files Server** and **Uninstall**.
Chapter 2
Examples Using the SAS PC Files Server

Importing and Exporting Microsoft Office Files When SAS 9.4 and the SAS PC Files Server Are on the Same Machine

19
Import a Microsoft Excel File into SAS ........................................ 19
Export a SAS Data Set to a Microsoft Excel File ............................ 21
Use a SAS LIBNAME Statement for a Microsoft Excel File ............... 22
Import a Microsoft Access Table into SAS .................................. 23
Export a SAS Data Set to a Microsoft Access Table ....................... 24
Use the SAS LIBNAME Statement for a Microsoft Access Database ... 25

Importing and Exporting Microsoft Office Files When SAS and the SAS PC Files Server Are on Different Machines

26
Import a Microsoft Excel File into SAS ....................................... 26
Export a SAS Data Set to a Microsoft Excel File ............................ 27
Use the SAS LIBNAME Statement for a Microsoft Excel File ............... 27
Import a Microsoft Access Table into SAS .................................. 28
Export to a SAS Data Set to a Microsoft Access Table ....................... 28
Use the SAS LIBNAME Statement for a Microsoft Access Database on a Secured Server ........................................ 28

Importing and Exporting Microsoft Office Files When SAS 9.4 and the SAS PC Files Server Are on the Same Machine

The following examples show how to use the SAS PC Files Server to read and write Microsoft Excel and Microsoft Access files. You can omit the SERVER= statement if you have 32-bit Microsoft Office and are using the SAS PC Files Server on the same Windows 64-bit machine that is also running SAS 9.4.

Import a Microsoft Excel File into SAS

In the following examples, the Microsoft Excel workbook, Demo, is used. It contains several worksheets, including one named Invoice:
Using the PC Files Server for Excel data (EXCELCS) and the IMPORT procedure, you read the Invoice worksheet into SAS and create a SAS data set named WORK.SASINVOICES.

```sas
PROC IMPORT DATAFILE="mydrive:\proc_demo\demo.xlsx"
   DBMS=EXCELCS
   OUT=WORK.SASINVOICES REPLACE;
   SHEET='Invoice';
RUN;

PROC PRINT DATA=WORK.SASINVOICES;
RUN;
```
Log 2.1  Log for Importing the XLSX File

```sas
/* To import a Microsoft Excel file into SAS */
PROC IMPORT DATAFILE="mydrive:\proc_demo\demo.xlsx"
   DBMS=EXCELCS
   OUT=WORK.SASINVOICES REPLACE;
   SHEET='Invoice';
RUN;

NOTE: WORK.SASINVOICES data set was successfully created.
NOTE: The data set WORK.SASINVOICES has 17 observations and 8 variables.
NOTE: PROCEDURE IMPORT used (Total process time):
   real time           1.96 seconds
   cpu time            0.12 seconds

PROC PRINT DATA=WORK.SASINVOICES;
RUN;

NOTE: There were 17 observations read from the data set WORK.SASINVOICES.
NOTE: PROCEDURE PRINT used (Total process time):
   real time           0.02 seconds
   cpu time            0.03 seconds
```

Figure 2.2  WORK.SASINVOICES Data Set

<table>
<thead>
<tr>
<th>Obs</th>
<th>Invoice_ID</th>
<th>Billed_To</th>
<th>Amount_Billed_in_Local_Currency</th>
<th>Country</th>
<th>Amount_Billed_in_US_Dollars</th>
<th>Billed_By</th>
<th>Billed_On</th>
<th>Paid_On</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>11270</td>
<td>39045213</td>
<td>8736600640.0</td>
<td>Brazil</td>
<td>3675486666.21</td>
<td>2319188</td>
<td>05OCT2004</td>
<td>19OCT2004</td>
</tr>
<tr>
<td>2</td>
<td>11273</td>
<td>19783482</td>
<td>252148.5</td>
<td>USA</td>
<td>252148.5</td>
<td>2319188</td>
<td>05OCT2004</td>
<td>11NOV2004</td>
</tr>
<tr>
<td>3</td>
<td>11276</td>
<td>14321742</td>
<td>1934460.0</td>
<td>USA</td>
<td>1934460.0</td>
<td>135673</td>
<td>15OCT2004</td>
<td>05OCT2004</td>
</tr>
<tr>
<td>4</td>
<td>11270</td>
<td>14600029</td>
<td>1400625.0</td>
<td>USA</td>
<td>1400625.0</td>
<td>2319188</td>
<td>05OCT2004</td>
<td>15OCT2004</td>
</tr>
<tr>
<td>5</td>
<td>11280</td>
<td>39045213</td>
<td>8736600640.0</td>
<td>Brazil</td>
<td>3675486666.21</td>
<td>423286</td>
<td>07OCT2004</td>
<td>20OCT2004</td>
</tr>
<tr>
<td>6</td>
<td>11222</td>
<td>19783482</td>
<td>252148.5</td>
<td>USA</td>
<td>252148.5</td>
<td>457322</td>
<td>07OCT2004</td>
<td>25OCT2004</td>
</tr>
<tr>
<td>7</td>
<td>11265</td>
<td>38753919</td>
<td>2234301.3</td>
<td>Argentina</td>
<td>772847.85</td>
<td>2319188</td>
<td>10OCT2004</td>
<td>30NOV2004</td>
</tr>
<tr>
<td>8</td>
<td>11279</td>
<td>15431247</td>
<td>252148.5</td>
<td>USA</td>
<td>252148.5</td>
<td>457322</td>
<td>11OCT2004</td>
<td>04NOV2004</td>
</tr>
<tr>
<td>9</td>
<td>12468</td>
<td>14890029</td>
<td>1400825.0</td>
<td>USA</td>
<td>1400825.0</td>
<td>115673</td>
<td>2DECE2004</td>
<td>02JAN2005</td>
</tr>
<tr>
<td>10</td>
<td>12418</td>
<td>15431247</td>
<td>252148.5</td>
<td>USA</td>
<td>252148.5</td>
<td>423286</td>
<td>2DECE2004</td>
<td>02JAN2005</td>
</tr>
</tbody>
</table>

Export a SAS Data Set to a Microsoft Excel File

In this example, you use the EXPORT procedure to write SAS data from WORK.SASINVOICES and you create a new XLSB file workbook named Demo2. An XLSB (binary format) file can be read from and written to faster than other Excel file formats. That makes them especially useful for very large worksheets. The new Demo2 workbook contains one worksheet named YourInvoices.

```sas
PROC EXPORT DATA=WORK.SASINVOICES
   OUTFILE='mydrive:\PROC_demo\demo2.xlsb'
   DBMS=EXCELCS REPLACE;
   SHEET='YourInvoices';
RUN;
```
EXCELCS can also create and update Excel 2007, Excel 2010, and later files.

When you create a new Microsoft Excel file, use an .xlsb extension. If you name the new file with an .xlsx extension, no error occurs. However, the file is still in the .xlsb format because of how the Microsoft ACE driver works. You would not be able to open the file using the Excel application until you rename with an .xlsb extension.

Use a SAS LIBNAME Statement for a Microsoft Excel File

You can specify a LIBNAME statement with a DATA step to assign a libref to the Microsoft Excel workbook, Demo. You specify the PCFILES engine in order to connect to the workbook. You can then specify a worksheet (Orders) from that workbook as the source for the temporary SAS data set, TEMP1.

The file extension varies depending on the type of Excel file (XLS, XLSX, or XLSB). You must specify the file extension. Otherwise, you receive an error that your Excel file cannot be found.

LIBNAME TEST PCFILES PATH='mydrive:proc_demo\demo.xlsx';
DATA TEMP1;
SET TEST.ORDERS;
RUN;
LIBNAME TEST CLEAR;
For the following examples, you use data from the Microsoft Access table, Customers, which is one of the tables in the AnnualFiles.accdb database. You could use either an .mdb database table or an .accdb database table in these examples.

In this example, you import data from the Customers table into SAS to create the SAS data set WORK.SASCUSTOMERS.
PROC IMPORT DBMS=ACCESSCS DATATABLE='Customers'
   OUT=WORK.SASCUSTOMERS REPLACE;
   DATABASE='mydrive:\yourAccessdirectory\AnnualFiles.accdb';
RUN;

PROC PRINT DATA=WORK.SASCUSTOMERS (OBS=8);
RUN;

Figure 2.6 First Eight Rows of the WORK.SASCUSTOMERS Data Set

Export a SAS Data Set to a Microsoft Access Table

In this example, you export data from the SAS data set WORK.SASCUSTOMERS to create a table in the AnnualFiles database. You could use either an .mdb database table or an .accdb database table in these examples.

The data set option DROP= is used to remove the column STATE from the SAS data set, and therefore it does not appear in the new Microsoft Access table, Customers_by_Zip.

PROC EXPORT DATA=WORK.SASCUSTOMERS (DROP=STATE)
   OUTTABLE='Customers_by_Zip'
   DBMS=ACCESSCS REPLACE;
   DATABASE='mydrive:\yourAccessdirectory\AnnualFiles.accdb';
RUN;

Figure 2.7 First Eight Rows of the WORK.SASCUSTOMERS Data Set
For more information about using the IMPORT and EXPORT procedures with Microsoft Access and Excel files, see “File Format-Specific Reference for the IMPORT and EXPORT Procedures” in *SAS/ACCESS Interface to PC Files: Reference*.

**Use the SAS LIBNAME Statement for a Microsoft Access Database**

In this example, you assign the libref TEST to the AnnualFiles database. You then create a temporary SAS data set, TEMP1, from the Customers table in the database. Notice that this LIBNAME statement specifies the PCFILES engine. After running this simple test, you remove the TEST libref’s association with the database.

```
LIBNAME TEST PCFILES path='mydrive:\yourAccessdirectory\AnnualFiles.accdb';

DATA TEMP1;
  SET TEST.CUSTOMERS;
RUN;

LIBNAME TEST CLEAR;
```
Importing and Exporting Microsoft Office Files
When SAS and the SAS PC Files Server Are on Different Machines

If the SAS PC Files Server and SAS are not running on the same Microsoft Windows machine, you must specify additional LIBNAME statement options or additional connection statements for the IMPORT and EXPORT procedures in order to access Microsoft Office files. The same applies if you are running SAS 9.4 on UNIX or Linux and want to access Microsoft Office files located on Windows. The additional options or statements provide information so that the data access can be completed.

Import a Microsoft Excel File into SAS

In this example, the Microsoft Excel workbook, Demo, has several worksheets, including one named Invoice. Using the PC Files Server for Excel data (EXCELCS) and the IMPORT procedure, you read the Invoice worksheet into SAS and create a SAS data set named WORK.SASINVOICES. The default value for PORT= is 9621.

The SERVER= statement identifies the PC that is running the PC Files Server, and in this example, the Microsoft Excel data resides on a different Windows machine.

```sas
PROC IMPORT DATAFILE='mydrive:\proc_demo\demo.xlsx'
   DBMS=EXCELCS
   OUT=WORK.SASINVOICES REPLACE;
   PORT=9621;
   SERVER='PCfilesServer';
   SHEET='Invoice';
RUN;

PROC PRINT DATA=WORK.SASCUSTOMERS (OBS=8);
RUN;
```

For the output from this example, see Figure 2.2 on page 21.
Export a SAS Data Set to a Microsoft Excel File

In this example, you use the EXPORT procedure to write SAS data from WORK.SASINVOICES and you create a new XLSB file (workbook) named Demo2. An XLSB (binary format) file can be read from and written to faster than other Excel file formats. That makes them especially useful for very large worksheets. The new Demo2 workbook contains one worksheet named YourInvoices:

```sas
PROC EXPORT DATA=WORK.SASINVOICES
   OUTFILE='mydrive:\PROC_demo\demo2.xlsb'
   DBMS=EXCELCS REPLACE;
   SHEET='YourInvoices';
   PORT=9621;
   SERVER='PCFilesServer';
RUN;
```

For the output from this example, see Figure 2.3 on page 22.

EXCELCS can also create and update Excel 2007, Excel 2010, and later files.

When you create a new Microsoft Excel file, use an .xlsb extension. If you name the new file with an .xlsx extension, no error occurs. However, the file is still in the .xlsb format because of how the Microsoft ACE driver works. You would not be able to open it using the Excel application until you rename the file with an .xlsb extension.

For more information about using the IMPORT and EXPORT procedures with Microsoft Access and Excel files, see “File Format-Specific Reference for the IMPORT and EXPORT Procedures” in SAS/ACCESS Interface to PC Files: Reference.

Use the SAS LIBNAME Statement for a Microsoft Excel File

You can specify a LIBNAME statement with a DATA step to assign a libref to the Microsoft Excel workbook, Demo. You can then specify a worksheet (Orders) from that workbook as the source for the temporary SAS data set, TEMP1. Notice that this LIBNAME statement specifies the PCFILES engine. You identify the Windows machine on which the SAS PC Files Server is running and specify the default port number.

When using the following example, note that the file extension varies depending on the type of Excel file (XLS, XLSX, or XLSB). You must specify the file extension. Otherwise, you receive an error that your Excel file cannot be found.

```sas
LIBNAME TEST PCFILES PATH='mydrive:\PROC_demo\demo2.xlsx'
   SERVER='yourExcelserver' PORT=9621;

DATA TEMP1;
   SET TEST.ORDERS;
RUN;

LIBNAME TEST CLEAR;
```

For more examples and information, see “Assigning a Libref to a Microsoft Excel Workbook” in SAS/ACCESS Interface to PC Files: Reference.
Import a Microsoft Access Table into SAS

In this example, you import data from the Microsoft Access table, Customers, to create the SAS data set WORK.SASCUSTOMERS. Customers is the name of one of the tables in the AnnualFiles.accdb database. You could use either an .mdb database or an .accdb database in these examples. You identify the Windows machine on which the SAS PC Files Server is running and specify the default port number.

To improve performance for reading data, set the read buffer to 25 or higher using the DBDSOPTS= statement.

PROC IMPORT DATATABLE='Customers'
   DBMS=ACCESSCS
   OUT=SASCUSTOMERS REPLACE;
   DATABASE='mydrive:\yourAccessdirectory\AnnualFiles.accdb';
   SERVER="yourPCFServer.com";
   PORT=9621;
   DBDSOPTS='READBUFF=30';
RUN;

Export to a SAS Data Set to a Microsoft Access Table

In this example, you export data from the SAS data set WORK.SASCUSTOMERS to create a new table, Customers_2, which is located on same Windows machine as the SAS PC Files Server.

PROC EXPORT DATA=WORK.SASCUSTOMERS
   OUTTABLE='Customers_2'
   DBMS=ACCESSCS REPLACE ;
   DATABASE='mydrive:\yourAccessdirectory\AnnualFiles.accdb';
   SERVER="myPCFServer.com";
   PORT=9621;
   DBDSOPTS='INSERTBUFF=15';
RUN;

Note that the SAS PC Files Server does not support the INSERTBUFF= data set option with a value higher than 1 for writing data to Microsoft Excel. It ignores this option when writing data to Excel.

Use the SAS LIBNAME Statement for a Microsoft Access Database on a Secured Server

In this example, you assign the libref TEST to the AnnualFiles.accdb database. You then create a temporary SAS data set, TEMP1, from the Customers table in the database. Notice that this LIBNAME statement specifies the PCFILES engine.

Because the SAS PC Files Server is secured, you must specify a domain name and User ID, as well as the server’s password.

LIBNAME TEST PCFILES PATH='mydrive:\yourAccessdirectory\AnnualFiles.accdb'
   PORT=9621 SERVER='D1234' SERVERUSER='mydomain\suzanj' SERVERPASS='AbCd_987';

DATA TEMP1;
SET TEST.CUSTOMERS;
RUN;

LIBNAME TEST CLEAR;

For more examples and information, see “Assigning a Libref to a Microsoft Access Database” in SAS/ACCESS Interface to PC Files: Reference.
Overview

SAS PC Files Server

SAS PC Files Server is an application that receives client requests to access data files that are specific to Microsoft Office, such as Microsoft Excel and Microsoft Access. It runs on both 32- and 64-bit Windows as either a 32-bit application or a 64-bit application.
To access data from Microsoft Office products, SAS/ACCESS Interface to PC Files must be installed on the client that is running SAS. The server must be installed and running on the Microsoft Windows machine where the Microsoft Office products’ data resides.

*Figure 3.1  SAS PC Files Server Interaction*

WOW64 (Windows 32-bit on Windows 64-bit) is a subsystem of the Microsoft Windows operating environment that is capable of running 32-bit applications on 64-bit Windows. WOW64 is included in all 64-bit versions of Windows.
SAS PC Files Server Configuration

Overview

The behavior of the SAS PC Files Server is determined during installation and configuration. The installation process configures the SAS PC Files Server to match the bit architecture of Microsoft Office. The following are included in the configuration:

- operation as either a 32-bit application or a 64-bit application
- the port number that is used for TCP/IP server connections
- the number of concurrent connections that the SAS PC Files Server supports
- whether the data is encrypted between SAS/ACCESS Interface to PC Files and the SAS PC Files Server.

SAS PC Files Server Versions (32-Bit versus 64-Bit)

The version of SAS PC Files Server is automatically determined by any existing Microsoft Access Database Engine (ACE). The ACE driver is an ODBC driver that accesses the supported PC file types for use in SAS. Starting with Microsoft Office 2010, the ACE driver is supplied in either a 32-bit or 64-bit version. If Microsoft Office is installed on the same machine as the SAS PC Files Server, you can check your version of Office to see what your version of the ACE driver is.

To check whether your version of Microsoft Office is 32-bit or 64-bit, open one of the products (such as Microsoft Excel) and do the following:

- For Office 2010, click the File tab and then Help.
  - For Office 2013, click the File tab and then Account.

  - The version of Excel is shown in About Microsoft Excel. Notice whether it is a 32-bit or 64-bit version of Excel.

  - If you click the About Excel icon and its System Info button, you can also see which version of Microsoft Windows you have.

(For releases before Microsoft Office 2010, the ACE driver is 32-bit.)

The installation process configures the SAS PC Files Server to match the bit architecture of Microsoft Office or of the ACE driver if the ACE driver is installed. If you have the 32-bit version of Microsoft Office, then the 32-bit version of the SAS PC Files Server is configured. The two are “bit-compatible” in that they are both 32-bit.

Note: The SAS PC Files Server must be bit-compatible with the Microsoft ACE driver (32 or 64).

If you install the SAS PC Files Server on a machine that does not already have Microsoft Office or the ACE driver, then the 64-bit version of the ACE driver is installed, followed by the 64-bit version of the SAS PC Files Server. The ACE driver defaults to 64-bit.

Only one version of the ACE driver can be installed on a given system. You cannot install both the 32- and the 64-bit ACE drivers. The same constraint applies to the SAS PC Files Server. For more information, see “Resolving Bitness Errors.”
If you need to force the installation of a particular SAS PC Files Server (32- or 64-bit), you must first manually install the appropriate ACE driver. For an example, see “Using the Wizards and the SAS PC Files Server on Windows X64 with 32-Bit Microsoft Office” in SAS/ACCESS Interface to PC Files: Reference.

Resolving Bitness Errors

CLI and ODBC errors can occur when you use the SAS PC Files Server to import from and export to Microsoft Excel files. When you are importing or exporting Excel files using the SAS PC Files Server, you might receive the following error:

```
ERROR: CLI error trying to establish connection: [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified.
```

Either of the following can cause this problem:

- The wrong SAS PC Files Server has been installed. The most common cause is that the 64-bit version of the SAS PC Files Server is installed on a machine that is running the 32-bit version of Microsoft Office.
- No Microsoft ACE driver is installed on the system.

To circumvent the problem, first check the bit architecture of the SAS PC Files Server and Microsoft Office. To determine your versions of the server and Office, see “Preinstallation Steps” on page 2. If they do not match, uninstall your PC Files Server and re-install a version that has the same bit architecture. For instructions, see Chapter 1, “Quick Start for Installation,” on page 1.

Port Number Selection Dialog Box

The default port number that is used for TCP/IP server connections is 9621. The SAS LIBNAME statement, PROC IMPORT, and PROC EXPORT use this value by default to connect to PC files. If you change the port number on the SAS PC Files Server, users accessing that server must add the PORT=number option to their LIBNAME statements.

The SAS PC Files Server port number must be unique on a given Windows machine. You cannot run multiple servers of any kind that use the same port number on a single machine. However, you can use the same server port number on different machines.

The Port Number or Service Name is saved in the Microsoft Windows registry, and it is used each time that the SAS PC Files Server is run.
Maximum Connections

**Max Connections** specifies the number of concurrent connections that the SAS PC Files Server can support. The default value is 10. Configure the number of connections based on the load that you expect from your SAS clients.

Each command that uses the SAS PC Files Server uses one connection. There can be multiple users from different SAS sessions accessing the server concurrently. Consider all the connections when setting the **Max Connections** value. To reset this value, use the SAS PC Files Server desktop application window. For more information, see “Desktop Application (Server Mode)” on page 37.

The number of **Max Connections** is saved in the Microsoft Windows registry, and it is used each time the SAS PC Files Server is run.

Data Encryption

Select **Data Encryption** to encrypt data that is transferred between SAS/ACCESS Interface to PC Files on the client and the SAS PC Files Server. This option is set on the SAS PC Files Server desktop application window. For more information, see “Desktop Application (Server Mode)” on page 37.

The state of the **Data Encryption** is saved in the Microsoft Windows registry, and it is used each time the SAS PC Files Server is run.

SAS PC Files Server Upgrades

When you upgrade the SAS PC Files Server, such as for a maintenance release or new release, you must stop all SAS services and applications before you upgrade.
To stop the service from the Windows Start menu, select Control Panel ⇒ Administrative Tools ⇒ Services. Right-click the SAS PC Files Server and click Stop. (Or you could right-click the Properties item to access that window and stop the server.)

Install the latest SAS 9.4 maintenance release and SAS PC Files Server, and then resume the Microsoft Windows Service or run the server as a desktop application. For more information, see Chapter 1, “Quick Start for Installation,” on page 1.

SAS PC Files Server Operating Modes

**Microsoft Windows Service**

**Overview**

The SAS PC Files Server can run in two modes: Service Mode as a Microsoft Windows Service or Server Mode as a desktop application (available prior to SAS/ACCESS 9.2). Only one instance of the SAS PC Files Server can be running on a single machine at any given time.

SAS PC Files Server can be manually set to run as a Microsoft Windows Service.

From the Windows Start menu, select Control Panel ⇒ Administrative Tools ⇒ Services.

![Microsoft Services Window](image3.3)

Locate SAS PC Files Server and right-click the server. Select Properties.
Service Options
Most of the property values in the SAS PC Files Server window are generated during the server’s installation and configuration, though you can modify the description. The path and filename cannot be changed.

The Start-up type displays the start-up type of the Windows service.

- **Automatic** specifies that SAS PC Files Server starts automatically when the system starts. This value can be set from the Windows Services Start-Up Selection dialog box.
- **Manual** specifies that a user or a dependent service can start the SAS PC Files Server.
- **Disabled** prevents the system, a user, or any dependent device from starting the SAS PC Files Server.

Service status shows you whether the Windows service has been started, stopped, or paused, and also enables you to resume the service after it has been stopped or paused.

Desktop Application (Server Mode)

Overview
The SAS PC Files Server can run in two modes: Server Mode as a desktop application (available prior to SAS/ACCESS 9.2) or Service Mode as a Microsoft Windows Service. Only one instance of the SAS PC Files Server can be running on a single machine at any given time.

The desktop application (server mode) enables you to set certain options and to reset certain default values, including security options and whether the SAS PC Files Server
starts automatically when you invoke SAS. Changing the settings affects how the SAS PC Files Server runs in Windows service mode. Therefore, you must stop the current SAS PC Files Server running as a Windows Service before you can reset any options.

From the Windows Start menu, select Control Panel ⇒ Administrative Tools ⇒ Services. Right-click the SAS PC Files Server and click Stop.

**CAUTION:**

Closing these sessions could result in a loss of data. The reason is that each time you stop or restart the SAS PC Files Server, all users’ sessions are closed.

**Desktop Application Window**

To start the SAS PC Files Server as a desktop application (in server mode), do the following: From the Windows Start menu, select All Programs ⇒ SAS ⇒ SAS PC Files Server. The SAS PC Files Server desktop application window appears.
**Details from the Desktop Application Window**

- **Server Name:** Names the Windows machine where the SAS PC Files Server is running.

- **Service/Port:** A communications end point at which a server listens for a request for service from the client application. The default port is 9621. The SAS PC Files Server must use the same port number that SAS/ACCESS to PC Files uses. You can change the port number to meet your specific needs.

- **Max Connections:** The maximum number of concurrent connections that this server supports.
• **Data Encryption**: Encrypts data during transfer.

• **Authentication Required**: Requires users to provide credentials before connecting to SAS PC Files Server. These credentials can be in the form of a user ID and password or integrated windows authentication (SSPI).

• **Allow Integrated Windows Authentication (SSPI)**: Windows 64-bit users can process credentials between Windows PCs without having to explicitly give a user ID and password.

  *Note*: This option is available only when **Authentication Required** is selected.

• **Change Options**: Displays a dialog box that enables you to change the default port number and maximum number of connections. You can choose to set **Data Encryption** and **Authentication Required**. A note states that the SAS PC Files Server must be restarted in order for the changes to take effect.

• **Restart Server**: Restarts the server including all setting changes.

• **Shutdown Server**: Stops the server and closes the application window.

• **Host Name**: Lists host names of active server connections.

• **DSN / File Access**: Displays file access requests of active server connections.

• **User ID**: Displays the user ID of active server connections.

• **Current Client Connections**: Displays the total number of active connections.

  *Note*: When a single user opens multiple connections, this displays the most current information.

• **Peak Client Connections**: The greatest number of active connections during the current server session.

---

### SAS PC Files Server Authentication

#### Overview of Authentication (Security Enforcement)

Authentication enables SAS PC Files Server system administrators to secure the server and enforce security. You can configure SAS PC Files Server so that a user ID and a password are required to connect to a server and access files. You can also configure the SAS PC Files Server on specific hosts to require a user ID and password.

All the commands that allow server access support user authentication. The credentials that are supplied to the SAS PC Files Server are verified against the Microsoft Windows login database. These are the same credentials that are required to interactively log on to a PC.

*Note*: If the client PC is on a domain, the credentials are compared to the domain data, instead of to the local data.

SERVERUSER=, SERVERPASS=, and SSPI= options are available in the SAS LIBNAME statement and in the IMPORT and EXPORT procedures. Use these options to supply credentials to the SAS PC Files Server. For more information, see “SAS LIBNAME Statement Syntax for PC Files” in *SAS/ACCESS Interface to PC Files: Reference*. 
Access to SAS PC Files Server

When you run SAS, the version of Microsoft Windows must be bit-compatible (32 or 64) as both the ACE driver and the SAS PC Files Server, as described “SAS PC Files Server Versions (32-Bit versus 64-Bit)” on page 33. That is, you must run SAS on a 32-bit Windows machine that has a 32-bit ACE driver to run with a 32-bit SAS PC Files Server.

If there is a conflict, SAS cannot directly access PC files using the SAS/ACCESS engines for Microsoft Excel or Microsoft Access. Instead, SAS must use the SAS PC Files Server to bridge the gap in the number of bits (from 32-bit to 64-bit) using the PCFILES LIBNAME engine.

Access to the server is granted only if the credentials that are supplied are valid on the target PC. When connecting from a UNIX workstation to the PC, the UNIX credentials (User ID and password) can be different from the credentials that are used to access the PC files.

Access to Individual Files

After the SAS PC Files Server is secured, server administrators can enable native Microsoft Windows security at the file level. When a server connection is established, access to individual files is secured using the credentials specified by the user. File access is administered as if the client is logged on to that PC.

System Administrator Tasks

To enforce a security policy, the system administrator should ensure that the following configurations and settings are implemented:

• Local security policy is configured. For more information, see “Local Security Policy Configuration” on page 43.

• Server authentication is configured using the SAS PC Files Server desktop application. From the Windows Start menu, select All Programs ⇒ SAS ⇒ SAS PC Files Server. Select Authentication Required. Doing so requires users to provide credentials before connecting to the SAS PC Files Server. These can be as a user ID and password or as Integrated Windows Authentication (SSPI).

• Set the PC-to-PC Connections option to Allow Integrated Windows Authentication (SSPI). This option is for clients on PCs running Windows connecting to the SAS PC Files Server. Credentials are exchanged between the server and the client. The client PC does not have to explicitly set credentials.

This option is available only when Authentication Required is selected.

• Access to the server requires a user ID and password using the SERVERUSER= and SERVERPASS= options. For the Windows environment, you can also use the SSPI= option.

Security Model for Microsoft Windows

The enhanced Microsoft Windows Security Model began with Microsoft Windows Vista and applies to Windows 7 and later. This security model is designed to make it more difficult for viruses and malware to install themselves on the PC. When you are logged in as “Administrator” or as part of the “Administrators Group,” certain privileges are
temporarily not available to the operating environment. The privileges are returned when needed and are confirmed by a dialog box that asks users for permission to continue. This guarantees that the user is aware of potential security risks.

When starting the SAS PC Files Server on Windows 7 or later, you must manually enable permissions. The confirmation is not required when running the server as a Microsoft Windows Service or if the Windows security features have been disabled for Windows 7 and later.

SAS PC Files Server Autostart

The Autostart feature provides a convenient way to use a SAS PC Files Server for the current SAS session without having to actually run it on a local machine. The SAS PC Files Server Autostart includes the following features:

• Starts SAS PC Files Server in the background as needed and stops the server when finished.
• Does not require the server setup or options.
• Communicates with the SAS client using a named pipe.
• Does not transfer data over the network. This eliminates the need for data encryption.
• Runs independent of network settings and any other instances of SAS PC Files Server.
• Always runs with the credentials of the SAS client. This eliminates the need for authentication.
• Autostart instances of SAS PC Files Server are independent and use their own communication mechanisms. This eliminates the possibility that an auto-started server might interfere with other servers.

Here are the requirements for using the SAS PC Files Server Autostart feature:

• Run SAS on a machine running Microsoft Windows.
• Install the SAS PC Files Server on the same machine.
• Use an engine that is related to SAS PC Files Server (such as PCFILES) to access either local files or files that are accessible with the \host-name\folder\filename specification.
• Omit the SERVER= and PORT= options.
• Avoid using the SERVERUSER=, SERVERPASS=, or SSPI= options.

In the following code that uses the SAS LIBNAME statement and IMPORT procedure, Autostart is triggered by the “missing” SERVER= and PORT= statements.

LIBNAME DB PCFILES PATH='C:\AnnualFiles.accdb';
PROC IMPORT DBMS=ACCESSCS OUT=DB.SASCUSTOMERS
   DATATABLE='Customers' REPLACE;
RUN;
Local Security Policy Configuration

Overview

For server user authentication to work, the SAS PC Files Server must be able to create user-specific subprocesses with the credentials that are specified. Windows allows this only if certain Windows Security settings are set on the PC that is running the server. When running the server exclusively as a Windows service, use the default account of SYSTEM. Changes might not be needed if all of the required privileges are set in the SYSTEM account.

Configure User Accounts

The user account that is running the server must be in the Administrators group. To access the Administrators Group:

1. From the Windows Start menu, select Control Panel ⇒ User Accounts ⇒ Manage User Accounts.
2. Select the user account running the server.
   - If you are on a domain, it appears as the domain name in the Domain column. Select the domain-level user account.
3. Select Properties ⇒ Group Membership ⇒ Other.
4. From the pull-down list, select Administrators.
5. Click OK to close the Group Membership tab.
6. If prompted to log off, click Cancel.
7. Enable the following User Rights for the Administrators Group:
   - Act as part of the operating system.
   - Adjust memory quotas for a process.
   - Replace a process level token.
   To verify or update these: from the Windows Start menu, select Control Panel ⇒ Administrative Tools ⇒ Local Security Policy.
8. In the Security Settings pane, open Local Policies ⇒ User Rights Assignment.
9. In the Policy column, open the user right to be changed (as listed in step 7) and add Administrators to each one.
   - Ensure there is an "s" at the end of Administrators. Administrator (singular) is a specific user account.
10. Repeat the sequence for each of the user rights listed in step 7. Verify that the Administrators group has been added to each of the three user rights, as indicated previously.
11. Add the Authenticated Users group to the Log on as batch job user right.

Note: Make sure that each user ID has this Log on as batch job privilege on the Windows server where the SAS PC Files Server is located. Otherwise, users
might receive an error that the server is unable to authenticate their credentials, even though their user IDs and passwords are correctly specified for that Windows server.

12. Log off and log back on in order for the changes to take effect.

Constraints

- You cannot mix 32-bit and 64-bit ACE drivers on the same machine. A 64-bit ACE driver is available starting with Microsoft Office 2010.

- You cannot mix 32- and 64-bit SAS PC Files Servers on the same machine.

- The ACE driver must be bit-compatible with the SAS PC Files Server. That is, they must both be 32-bits or both 64-bits. The installer enforces this at installation, but the two could get out of sync if the ACE driver were ever replaced.

- If SAS on Windows has the same number of bits as the installed ACE driver, then PC files can be accessed directly using the SAS/ACCESS engines for Microsoft Excel and Microsoft Access. Therefore, no SAS PC Files Server would be required.

- If SAS on Windows does not have the same number of bits as the installed ACE driver, the SAS PC Files Server must be used to bridge the gap in bits. The Autostart feature simplifies this when running SAS on Windows.

- The server can run in server mode (desktop application) or in service mode. However, only one instance of the server can be running on a single PC at any given time.

- Service names and port numbers must be unique on a given PC.

- To modify the settings to follow the constraints:
  1. Stop the server.
  2. Make necessary changes.
  3. Restart the server.

- Each time you stop or restart the server, all users' sessions are closed. Closing these sessions might result in loss of data.

- Although you can change server configuration only in server mode (desktop application), the updated values also apply when running in service mode.
Recommended Reading

Here is the recommended reading list for this title:

• *SAS/ACCESS Interface to PC Files: Reference*
• *SAS Language Reference: Concepts*
• *SAS Statements: Reference*
• *The Little SAS Book*

The following SAS usage notes are recommended for SAS 9.3 users:

• Usage Note: **43802 Installing the SAS 9.3 PC Files Server and using it to convert 32–bit MS Office Files to 64–bit files**
• Usage Note: **47237 Installing the SAS 9.3 TS1M2 version of the SAS PC Files Server on top of the SAS 9.3 TS1M1 version of the SAS PC Files Server**

For a complete list of SAS publications, go to sas.com/store/books. If you have questions about which titles you need, please contact a SAS Representative:

**SAS Books**
SAS Campus Drive
Cary, NC 27513-2414
Phone: 1-800-727-0025
Fax: 1-919-677-4444
Email: sasbook@sas.com
Web address: sas.com/store/books
# Index

<table>
<thead>
<tr>
<th>A</th>
<th>access</th>
<th>SAS PC Files Server examples 19</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>SAS PC Files Server 41</td>
<td>Microsoft Excel files</td>
</tr>
<tr>
<td></td>
<td>administration</td>
<td>SAS PC Files Server examples 19</td>
</tr>
<tr>
<td></td>
<td>SAS PC Files Server 41</td>
<td></td>
</tr>
<tr>
<td></td>
<td>authentication</td>
<td></td>
</tr>
<tr>
<td></td>
<td>SAS PC Files Server 40</td>
<td></td>
</tr>
<tr>
<td></td>
<td>autostart</td>
<td></td>
</tr>
<tr>
<td></td>
<td>SAS PC Files Server 42</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>C</td>
<td>configuration</td>
<td>SAS PC Files Server 33</td>
</tr>
<tr>
<td></td>
<td>SAS PC Files Server 33</td>
<td></td>
</tr>
<tr>
<td></td>
<td>constraints</td>
<td></td>
</tr>
<tr>
<td></td>
<td>SAS PC Files Server 44</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>D</td>
<td>desktop applications</td>
<td>SAS PC Files Server 4</td>
</tr>
<tr>
<td></td>
<td>running SAS PC Files Server as 37</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>E</td>
<td>encryption</td>
<td>SAS PC Files Server 35</td>
</tr>
<tr>
<td></td>
<td>SAS PC Files Server 35</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Exporting Microsoft Office files</td>
<td>application modes (32-bit versus 64-bit)</td>
</tr>
<tr>
<td></td>
<td>on different machines 26</td>
<td>33</td>
</tr>
<tr>
<td></td>
<td>on the same machine 19</td>
<td>authentication 40</td>
</tr>
<tr>
<td></td>
<td></td>
<td>autostart 42</td>
</tr>
<tr>
<td></td>
<td></td>
<td>bitness 33</td>
</tr>
<tr>
<td></td>
<td></td>
<td>check for existing server 4</td>
</tr>
<tr>
<td></td>
<td></td>
<td>configuration 33</td>
</tr>
<tr>
<td></td>
<td></td>
<td>constraints 44</td>
</tr>
<tr>
<td></td>
<td></td>
<td>data encryption 35</td>
</tr>
<tr>
<td></td>
<td></td>
<td>examples 19</td>
</tr>
<tr>
<td></td>
<td></td>
<td>installation 1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>installation preparation 3</td>
</tr>
<tr>
<td></td>
<td></td>
<td>installation steps 4</td>
</tr>
<tr>
<td></td>
<td></td>
<td>LIBNAME statement examples 19, 26</td>
</tr>
<tr>
<td></td>
<td></td>
<td>maintenance upgrade 35</td>
</tr>
<tr>
<td></td>
<td></td>
<td>maximum connections 35</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Microsoft Office version 2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>operating modes 36</td>
</tr>
<tr>
<td></td>
<td></td>
<td>port number 34</td>
</tr>
<tr>
<td></td>
<td></td>
<td>preinstallation 2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>running as desktop application 37</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

---

**Note:** The table above represents the index entries extracted from the document. Each entry corresponds to a specific topic or feature related to SAS PC Files Server. The numbers next to the entries indicate page numbers where the information can be found.
running as Windows service 36
SAS Deployment Wizard 7
SAS Download Manager 6
SAS version 2
security 40
security model for Windows 41
server administration 31
service name 34
Software Order Email 6
user accounts configuration 43
which version to download 2
security
data encryption, SAS PC Files Server 35
policy, SAS PC Files Server 43
SAS PC Files Server 40
user accounts, SAS PC Files Server 43
user authentication, SAS PC Files Server 43
service name
SAS PC Files Server 34
Software Order Email
SAS PC Files Server 6

U
Uninstalling
SAS 9.2 PC Files Server 17
SAS 9.3 PC Files Server 16
SAS 9.4 PC Files Server 15
Upgrading
SAS 9.4 PC Files Server 15
SAS PC Files Server 35
Gain Greater Insight into Your SAS® Software with SAS Books.

Discover all that you need on your journey to knowledge and empowerment.