## Contents

*About These Tutorials* ................................................................. v

### Chapter 1 • SAS Model Manager Tutorials .................................................. 1
  About SAS Model Manager ............................................................. 1
  About SAS Model Manager Tutorials ................................................. 2
  Install and Register the Tutorial Files ............................................. 3
  Prepare for Using SAS Workflow ...................................................... 18

### Chapter 2 • Tutorial 1: Create a Life Cycle Template ................................... 25
  Overview of Life Cycle Templates and Roles ....................................... 25
  Create Groups for Use with the SAS Model Manager Tutorial .................. 26
  Create a Life Cycle Template .......................................................... 29
  Upload the Life Cycle Template ....................................................... 38

### Chapter 3 • Tutorial 2: Performing Basic SAS Model Manager Tasks ............... 41
  Overview of SAS Model Manager Basics ........................................... 42
  Prerequisites .................................................................................. 42
  Organize the Model Hierarchy .......................................................... 43
  Import Models .............................................................................. 51
  Create Model Comparison Reports .................................................... 57
  Using the Annotations View ............................................................ 62
  Scoring Models ............................................................................ 65
  Declare a Champion Model ............................................................... 70
  Query for the Remaining Project Tasks to Complete ............................ 72

### Chapter 4 • Tutorial 3: Importing Models, Scheduling Scoring Tasks, and Creating Reports ................................................................. 75
  Overview of Importing Models, Scheduling Scoring Tasks, and Creating Reports ... 76
  Prerequisites ................................................................................ 76
  Organize the Model Hierarchy .......................................................... 77
  Import Models .............................................................................. 85
  Create Model Comparison and Summary Reports ................................... 91
  Scoring Models ............................................................................ 99
  Declare a Champion Model ............................................................... 105

### Chapter 5 • Tutorial 4: Publishing Models .................................................. 109
  Overview of Publishing Models .......................................................... 109
  Prerequisites ................................................................................ 110
  Publish Models ........................................................................... 110
  Publish Models to a Database ............................................................ 116
  Update Life Cycle or Workflow .......................................................... 126

### Chapter 6 • Tutorial 5: Creating Performance Monitoring Reports and Using Dashboard Reports ................................................................. 129
  Overview of Performance Monitoring Reports ...................................... 129
  Prerequisites ................................................................................ 130
  Create the Champion Model Performance Data Sets for a Classification Project ... 130
  Create the Challenger Model Performance Data Sets ............................... 135
  Create the Champion Model Performance Data Sets for a Prediction Project .... 140
Chapter 7 • Tutorial 6: Creating Basel II Reports .................................................. 165
  Overview of Basel II Reports ................................................................. 165
  Prerequisites ......................................................................................... 166
  Organize the Model Hierarchy ............................................................... 167
  Import Models ....................................................................................... 171
  Create Basel II Reports ....................................................................... 174

Chapter 8 • Tutorial 7: Using Advanced Reporting ......................................... 181
  Overview of Advanced Reporting .......................................................... 181
  Prerequisites ......................................................................................... 182
  Create a Simple Ad Hoc Report ............................................................ 182
  Create an Ad Hoc Score Range Report .................................................. 183
  Install a User-defined Score Range Report ............................................ 185
  Combining Multiple Reports ................................................................ 187

Chapter 9 • Tutorial 8: Using Advanced SAS Model Manager Features .......... 191
  Overview of Using Advanced Features .................................................. 191
  Example Scope ..................................................................................... 191
  Prerequisites ......................................................................................... 192
  Organize the Model Hierarchy ............................................................... 192
  Create and Upload a Model Template .................................................. 195
  Import a Model ..................................................................................... 199
  Create an Ad Hoc Variable Importance Report ...................................... 203

Chapter 10 • Tutorial 9: Retraining Models .................................................... 207
  Overview of Retraining Models .............................................................. 207
  Prerequisites ......................................................................................... 208
  Define a Model Retrain Task ................................................................. 208
  Execute a Model Retrain Task ............................................................... 214
  Viewing Retrained Models and Model Comparison Reports .................. 215

Chapter 11 • Tutorial 10: Using Workflow Console ........................................... 221
  Overview of Workflow Console ............................................................. 221
  Prerequisites ......................................................................................... 222
  Organize the Model Hierarchy ............................................................... 223
  Working with Workflow Activities ....................................................... 226
  Using Model Management Components with a Workflow Activity ......... 230
  Managing the Workflow Process .......................................................... 247

Chapter 12 • Tutorial 11: Scoring a SAS Model Manager Model Using SAS
  Data Integration Studio ........................................................................ 257
  Overview of Using Published Models in SAS Data Integration Studio ..... 257
  Prerequisites ......................................................................................... 258
  Publish a Project Champion Model from SAS Model Manager .......... 258
  Score a Model Using a SAS Data Integration Studio Job .................... 259
  Declare and Publish a New Champion Model in SAS Model Manager ... 263
  Update the Job to Use the Latest Champion Model ................................ 263
About These Tutorials

Audience

SAS Model Manager is designed for the following users:

• those who are responsible for developing analytical models
• those who are responsible for modeling project management
• those who are responsible for model validation and performance testing
• scoring officers
• analysts
• SAS administrators and SAS Model Manager administrators

Conventions Used in This Document

The following typographical conventions are used for all text in this document except for syntax:

bold
identifies an item in the SAS Model Manager window, a menu item, or a computer path name.

bold monospace
identifies text that you enter in a SAS Model Manager window.

italics
identifies a book title or a value that is supplied by the user.

monospace
identifies SAS code.
About SAS Model Manager

SAS Model Manager is a flexible model repository and model management environment for predictive and analytical models. A centralized repository and procedural templates make it easy to manage models and metadata across organizational areas and throughout a model's life cycle. Accountability metrics and validation of analytical steps, from creation to deployment in real time or batch scoring systems, continue until a model is retired. Storing the models in a secure, centralized repository enables you to easily manage life cycle milestones, such as development, test, production, and retirement. The following figure illustrates the model management process that you use in SAS Model Manager:
The goal of a modeling project is to identify a champion model that a scoring application uses to predict an outcome. SAS Model Manager provides tools to evaluate candidate models, declare a project champion model, and inform your scoring officer that a predictive or analytical model is ready for validation or production. You can perform scoring tests for champion and challenger model assessment as well as publish and share the model life cycle and performance data over established reporting channels. You can also run comparative performance benchmarks for the models in your production environment.

**About SAS Model Manager Tutorials**

The tutorials for SAS Model Manager cover basic and advanced tasks that are related to model management within an enterprise computing environment. Tutorial folders are created by extracting files from the tutorial ZIP file. You use these data files to become familiar with the following basic tasks that are involved in model management:
• define user groups for assigning and approving life cycle tasks
• define and create the components of the model hierarchy
• import models
• run model reports
• monitor event logging
• register models
• select a champion model and challenger models
• update life cycle milestones or workflow process activities
• run model scoring code in SAS Model Manager
• publish models
• retrain models

Install and Register the Tutorial Files

About Installing and Registering the Tutorial Files

You can either define a data library and register the tables in the SAS Metadata Repository using SAS Management Console, or you can use the Edit Start-up Code feature of SAS Model Manager to make tables from the local SAS Workspace Server or network drive available. The tutorials are designed to use the SAS Metadata Repository, but you can also use the Edit Start-up Code feature. For more information, see “Using Tables from a Local or Network Drive” on page 15.

Before you use tables in the SAS Metadata Repository, the tutorial data sets and models must be installed and registered using SAS Management Console by an administrator who has Write access to the SAS Application Server. A valid SASApp user ID and password are required to install and register the tutorial files.

Some tutorials require files other than data sets and models, such as score code and templates. These files do not need to be registered in the SAS Metadata Repository. The drive where you extract the tutorial ZIP file must be accessible to the SAS Metadata Repository and to tutorial users. Tutorial users can also extract tutorial ZIP files to their local computers in order to access the other files.

Download the Tutorial Files

The ZIP file SMM121Tutorial.zip contains the tutorials’ data sets, models, and score code, and it is available from http://support.sas.com/documentation/onlinedoc/modelmgr/. Before you begin any of the tutorials, extract the tutorial files to a computer that is accessible to the SAS Metadata Server and to the SAS Model Manager users. Follow the steps for using WinZip to extract the files. If you are using a different extraction program, follow that program’s instructions for extracting the files.

1. Create a folder on your local computer to store the tutorial files. The instructions refer to this folder as <drive>.

3. Open Windows Explorer to `<drive>`. Right-click `SMM121Tutorial.zip` and select Open with WinZip.

4. Click the arrow on the Unzip button to open the Unzip from WinZip File Folder window.
   
   Note: If you are using a previous release of Windows, from the WinZip window, click the Extract button. The Extract dialog box appears.

5. Select `<drive>` from the Unzip from WinZip File Folder window.

   Note: If you are using a previous release of Windows, in the Extract to box, select `<drive>` and click Extract.

   You can find the files for each tutorial in the respective tutorial folder (for example, `<drive>`\SMM121Tutorial\Tutorial2 or `<drive>`\SMM121Tutorial\Tutorial3).

**UNIX Specifics**

To complete the tutorials in a UNIX environment, first locate the CPORT files. Files that you use to import the data sets into UNIX are located in the SMM121_UNIX_cport_files.zip file that is available from [http://support.sas.com/documentation/onlinedoc/modelmgr/](http://support.sas.com/documentation/onlinedoc/modelmgr/). Instructions, as well as the sample code for performing an import, are provided in the Readme.txt file.

---

**Prepare Tutorial 2 Data Sets and Models**

**The Required Tutorial Files**

Tutorial 2 requires the following files and folders in the `<drive>`\SMM121Tutorial\Tutorial2\Samples folder:

- `delinquency_project_input.sas7bdat`
- `delinquency_project_output.sas7bdat`
- `delinquency_scoring_input.sas7bdat`
- `delinquency_scoring_output.sas7bdat`
- `delinquency_test.sas7bdat`
- `delinquency_train.sas7bdat`

- The `model1` folder contains these model files:
  - `modelin1.sas7bdat`
  - `modelout1.sas7bdat`
  - `om.sas7bdat`
  - `result1.sas7bdat`
  - `score1.sas`
  - `target1.sas7bdat`

- The `model2` folder contains these model files:
  - `modelin2.sas7bdat`
  - `modelout2.sas7bdat`
  - `ot.sas7bdat`
• result2.sas7bdat
• score2.sas
• target2.sas7bdat

• The model3 folder contains these model files:
  • modelin3.sas7bdat
  • modelout3.sas7bdat
  • result3.sas7bdat
  • score3.sas7bdat
  • target3.sas7bdat

Register the Tutorial 2 Files in SAS Management Console
You can either define a data library and register the tables in SAS Management Console, or use the Edit Start-up Code feature of SAS Model Manager to use tables from the local SAS Workspace Server or network drive. For more information, see “Using Tables from a Local or Network Drive” on page 15.

To use SAS Management Console to define a data library and register the tables, follow these steps:

1. Start and log on to SAS Management Console as a SAS Administrator with the role Metadata Server: Operation or Metadata Server: Unrestricted.
2. Open the New Library Wizard to define the data library. Expand Environment Management ➤ Data Library Manager on the Plug-ins tab. Right-click Libraries and select New Library from the pop-up menu.
3. In the New Library Wizard, create a SAS library.
   b. Specify MM Tutorial-2 in the Name field and click Browse. In the Select a Location dialog box, double-click Model Manager and then click the New folder icon. Create the folder Tutorial2 and make Tutorial2 the active folder. Click OK. Click Next.
   c. Select SASApp from the Available servers box and click to move the server name to the Selected servers list. Click Next.
   d. Specify smm12t2 for the libref and click New.
   e. Specify the server folder that you previously created, <drive>\SMM121Tutorial\Tutorial2\Samples, for the path specification and click OK twice.
      Note: If prompted, you must enter the user ID and password of a SAS Model Manager administrator for server authentication.
   f. Click Next.
   g. Click Finish. Verify that the library MM Tutorial-2 is a library in the Libraries folder.
4. Register the data tables in the metadata repository.
   a. Right-click MM Tutorial-2 under the Libraries folder, select Register Tables from the pop-up menu, and click Next.
b. If prompted, specify a user ID and password that has access to the metadata server and click **OK**.

c. Click **Select All Tables**, click **Next**, and click **Finish**.

5. Verify that table metadata was created and close SAS Management Console. Right-click **MM Tutorial-2** and select **Properties**.

Verify the tutorial name and location.
Click the **Assign** tab. Verify that the appropriate server is in the **Selected servers** list.

Click the **Options** tab. Verify the libref, the engine, and the path specification in the **Selected items** box.
Prepare Tutorial 3 Data Sets and Models

The Required Tutorial 3 Files
The SAS data sets and models that are required for this tutorial are on your local computer after you extract them from the ZIP file SMM121Tutorial.zip. If you have not extracted the tutorial files, see “Install and Register the Tutorial Files” on page 3.

This tutorial requires the following files and folders in the `<drive>\SMM121Tutorial\Tutorial3\Samples` folder:

- hmeq_project_input.sas7bdat
- hmeq_project_output.sas7bdat
- hmeq_score_input.sas7bdat
- hmeq_score_output.sas7bdat
- hmeq_test.sas7bdat
- hmeq_train.sas7bdat
- \HMEQ_STAT_Item\HMEQItem.spk
- \Neural\Neural.xml
- \Reg1\miningResult.spk
- \Reg1\Interval\miningResult.spk
- \Tree1\miningResult.spk
Register the Tutorial 3 Files in SAS Management Console

You can either define a data library and register the tables in SAS Management Console, or use the Edit Start-up Code feature of SAS Model Manager to use tables from the local SAS Workspace Server or network drive. For more information, see “Using Tables from a Local or Network Drive” on page 15.

To use SAS Management Console to define a data library and register the tables, follow these steps:

1. Open SAS Management Console and log on to the SAS Metadata Server. Your user ID must be authorized to modify libraries in the metadata server.

2. Open the New Library Wizard to define the data library. Expand Environment Management ⇒ Data Library Manager on the Plug-ins tab. Right-click Libraries and select New Library from the pop-up menu.

3. In the New Library Wizard, create a SAS library.
   b. Select SAS BASE Library and click Next.
   c. Specify MM Tutorial-3 in the Name field and click Next.
   d. (Optional) If more than one server exists, select a server. Click Next.
   e. Specify smm12t3 for the libref and click New.
   f. Specify the server folder that you previously created, <drive>\SMM121Tutorial\Tutorial3\Samples, for the path specification and click OK twice.
   g. Click Next and Finish.

4. Register the data tables in the metadata repository.
   a. Right-click MM Tutorial-3 under the Libraries node, select Register Tables from the pop-up menu, and click Next.
   b. If prompted, specify the metadata server, test the server connection, and click OK. Click Next.
   c. Click Select All Tables, click Next, and click Finish.

5. Verify that table metadata was created and close SAS Management Console. Select MM Tutorial-3 under the Libraries node and examine the right pane.

Prepare Tutorial 5 Data Sets and Models

The Required Tutorial 5 Files

The SAS data sets that are required for this tutorial are on your local computer after you extract them from the ZIP file SMM121Tutorial.zip. If you have not extracted the tutorial files, see “Install and Register the Tutorial Files” on page 3.

This tutorial requires the following files and folders in the <drive>\SMM121Tutorial\Tutorial5\Samples folder:

- hmeq_2011q2.sas7bdat
- hmeq_2011q3.sas7bdat
- hmeq_2011q4.sas7bdat
- hmeq_2012q1.sas7bdat
Register the Tutorial 5 Files in SAS Management Console

You can either define a data library and register the tables in SAS Management Console, or use the Edit Start-up Code feature of SAS Model Manager to use tables from the local SAS Workspace Server or network drive. For more information, see “Using Tables from a Local or Network Drive” on page 15.

To use SAS Management Console to define a data library and register the tables, follow these steps:

1. Open SAS Management Console and log on to the SAS Metadata Server. Your user ID must be authorized to modify libraries in the metadata server.

2. Open the New Library Wizard to define the data library. Click Environment Management ➔ Data Library Manager on the Plug-ins tab. Right-click Libraries and select New Library from the pop-up menu.

3. In the New Library Wizard, create a SAS library.
   b. Specify MM Tutorial-5 in the Name box.
   c. From the Location box, click Browse. Navigate to the Model Manager folder. Click the New folder icon and enter Tutorial5. Click the dialog box edges, click Tutorial5, and click OK.
   d. (Optional) If more than one server exists, select a server in the Available servers list and click to move the server name to the Selected servers list.
   e. Specify smm12t5 for the libref and click New.
   f. Specify the server folder that you previously created, <drive>\SMM121Tutorial\Tutorial5\Samples, for the path specification and click OK twice.
   g. Click Next and Finish.

4. Register the data tables in the metadata repository.
   a. Right-click MM Tutorial-5 under the Libraries node, select Register Tables from the pop-up menu, and click Next.
   b. If prompted, specify the user ID and password to the metadata server and click OK. Then click Next.
   c. Click Select All Tables and click Next.
   d. Click Finish.

5. Verify that table metadata was created. Select MM Tutorial-5 under the Libraries node and examine the right pane.

Prepare Tutorial 6 Data Sets and Models

The Required Tutorial 6 Files

The SAS data sets that are required for this tutorial are on your local computer after you extract them from the ZIP file SMM121Tutorial.zip. If you have not extracted the tutorial files, see “Install and Register the Tutorial Files” on page 3.
This tutorial requires the following files and folders in the `<drive>\SMM121Tutorial\Tutorial6\Samples` folder:

**LGD data sets:**
- `\LGD\lgd_model_est.sas7bdat`
- `\LGD\lgd_model_input.sas7bdat`
- `\LGD\lgd_model_output.sas7bdat`
- `\LGD\lgd_model_target.sas7bdat`
- `\LGD\lgd_proj_input.sas7bdat`
- `\LGD\lgd_proj_output.sas7bdat`
- `\LGD\lgd_score_input.sas7bdat`
- `\LGD\lgd_score_output.sas7bdat`

**PD data sets:**
- `\PD\hmeq_project_input.sas7bdat`
- `\PD\hmeq_project_output.sas7bdat`
- `\PD\hmeq_test.sas7bdat`
- `\PD\hmeq_train.sas7bdat`
- `\PD\pd_scoring_input.sas7bdat`
- `\PD\pd_scoring_output.sas7bdat`

**Register the Tutorial 6 PD Files in SAS Management Console**

You can either define a data library and register the tables in SAS Management Console, or use the Edit Start-up Code feature of SAS Model Manager to use tables from the local SAS Workspace Server or network drive. For more information, see “Using Tables from a Local or Network Drive” on page 15.

To use SAS Management Console to define a data library and register the tables, follow these steps:

1. Open SAS Management Console and log on to the SAS Metadata Server. Your user ID must be authorized to modify libraries in the metadata server.
2. Open the New Library Wizard to define the data library. Click Environment Management ⇒ Data Library Manager on the Plug-ins tab. Right-click Libraries and select New Library from the pop-up menu.
3. In the New Library Wizard, create a SAS library.
      Select SAS BASE Library and click Next.
   b. Specify `SMMT6PD` in the Name box.
   c. From the Location box, click Browse. Navigate to the Model Manager folder. Click the New folder icon and enter `Tutorial6`. Double-click the `Tutorial6` folder and click the New folder icon and enter `PD`. Click the dialog box edges, click PD, and click OK.
   d. (Optional) If more than one server exists, select a server in the Available servers list and click ➔ to move the server name to the Selected servers list.
   e. Specify `smmt6pd` for the libref and click New.
f. Specify the server folder that you previously created, \\
   `<drive>\SMM121Tutorial\Tutorial6\Samples\PD`, for the path \\
   specification and click **OK** twice.

   *Note:* If prompted, you must enter the user ID and password of a SAS Model 
   Manager administrator for server authentication.

  g. Click **Next** and **Finish**.

4. Register the data tables in the metadata repository.

   a. Right-click **SMM6PD** under the Libraries node, select **Register Tables** from 
      the pop-up menu, and click **Next**.

   b. If prompted, specify the user ID and password to the metadata server and click 
      **OK**. Then click **Next**.

   c. Click **Select All Tables** and click **Next**.

   d. Click **Finish**.

5. Verify that table metadata was created. Select **SMM6PD** under the Libraries node 
   and examine the right pane.

---

**Register the Tutorial 6 LGD Files in SAS Management Console**

You can either define a data library and register the tables in SAS Management Console, 
or use the Edit Start-up Code feature of SAS Model Manager to use tables from the local 
SAS Workspace Server or network drive. For more information, see “Using Tables from 
a Local or Network Drive” on page 15.

To use SAS Management Console to define a data library and register the tables, follow 
these steps:

1. Open SAS Management Console and log on to the SAS Metadata Server. Your user 
   ID must be authorized to modify libraries in the metadata server.

2. Open the New Library Wizard to define the data library. Click **Environment Management 
   ➔ Data Library Manager** on the **Plug-ins** tab. Right-click **Libraries** and select 
   **New Library** from the pop-up menu.

3. In the New Library Wizard, create a SAS library.

   a. Navigate to **Resource Templates ➔ Libraries ➔ SAS Data**.
      Select **SAS BASE Library** and click **Next**.

   b. Specify **SM6LGD** in the Name box.

   c. From the Location box, click **Browse**. Navigate to the Model Manager folder. 
      Click the New folder icon and enter **Tutorial6**. Double-click the **Tutorial6** 
      folder and click the New folder icon and enter **LGD**. Click the dialog box edges, 
      click **PD**, and click **OK**.

   d. (Optional) If more than one server exists, select a server in the Available servers 
      list and click to move the server name to the Selected servers list.

   e. Specify **sm6lgd** for the libref and click **New**.

   f. Specify the server folder that you previously created, \\
      `<drive>\SMM121Tutorial\Tutorial6\Samples\LGD`, for the path 
      specification and click **OK** twice.

   *Note:* If prompted, you must enter the user ID and password of a SAS Model 
   Manager administrator for server authentication.
g. Click Next and Finish.

4. Register the data tables in the metadata repository.
   a. Right-click SMMT6LGD under the Libraries node, select Register Tables from the pop-up menu, and click Next.
   b. If prompted, specify the user ID and password to the metadata server and click OK. Then click Next.
   c. Click Select All Tables and click Next.
   d. Click Finish.

5. Verify that table metadata was created. Select SMMT6LGD under the Libraries node and examine the right pane.

**Prepare Tutorial 8 Data Sets and Models**

**The Required Tutorial 8 Files**
The SAS data sets and models that are required for this tutorial are on your local computer after you extract them from the ZIP file SMM121Tutorial.zip. If you have not extracted the tutorial files, see “Install and Register the Tutorial Files” on page 3.

This tutorial requires the following files and folders in the `<drive>\SMM121Tutorial\Tutorial8\Samples` folder:
- hmeq_project_input.sas7bdat
- hmeq_project_output.sas7bdat
- hmeq_score_input.sas7bdat
- hmeq_score_output.sas7bdat
- hmeq_test.sas7bdat
- hmeq_train.sas7bdat
- VarImportance.sas
- \Model8\importance8.sas7bdat
- \Model8\modelinput8.sas7bdat
- \Model8\modeloutput8.sas7bdat
- \Model8\nodestat8.sas7bdat
- \Model8\path8.sas7bdat
- \Model8\rules8.sas7bdat
- \Model8\score8.sas
- \Model8\target8.sas7bdat

**Register the Tutorial 8 Files in SAS Management Console**
You can either define a data library and register the tables in SAS Management Console, or use the Edit Start-up Code feature of SAS Model Manager to use tables from the local SAS Workspace Server or network drive. For more information, see “Using Tables from a Local or Network Drive” on page 15.
To use SAS Management Console to define a data library and register the tables, follow these steps:

1. Open SAS Management Console and log on to the SAS Metadata Server. Your user ID must be authorized to modify libraries in the metadata server.

2. Open the New Library Wizard to define the data library. Click Environment Management \ Data Library Manager on the Plug-ins tab. Right-click Libraries and select New Library from the pop-up menu.

3. In the New Library Wizard, create a SAS library.
   a. Navigate to Resource Templates \ Libraries \ SAS Data.
      Select SAS BASE Library and click Next.
   b. Specify MM Tutorial-8 in the Name field.
   c. From the Location box, click Browse. Navigate to the Model Manager folder.
      Click the New folder icon and enter Tutorial8. Click the dialog box edges, click Tutorial8, and click OK.
   d. (Optional) If more than one server exists, select a server in the Available servers list and click to move the server name to the Selected servers list.
   e. Specify smm12t8 for the libref and click New.
   f. Specify the server folder that you previously created, drive\SMM121Tutorial\Tutorial8\Samples, for the path specification and click OK twice.
   g. Click Next and Finish.

4. Register the data tables in the metadata repository.
   a. Right-click MM Tutorial-8 under the Libraries node, select Register Tables from the pop-up menu, and click Next.
   b. If prompted, specify the user ID and password for the server and click OK. Then click Next.
   c. Click Select All Tables, click Next, and click Finish.

5. Verify that table metadata was created and close SAS Management Console. Select MM Tutorial-8 under the Libraries node and examine the right pane.

Prepare Tutorial 11 Data Sets and Models

The Required Tutorial 11 Files
The SAS data sets and models that are required for this tutorial are on your local computer after you extract them from the ZIP file SMM121Tutorial.zip. If you have not extracted the tutorial files, see “Install and Register the Tutorial Files” on page 3.

This tutorial requires the following files and folders in the <drive>\SMM121Tutorial\Tutorial11\Samples folder:

- score_input.sas7bdat
- score_output.sas7bdat
Register the Tutorial 11 Files in SAS Management Console

You can either define a data library and register the tables in SAS Management Console, or use the Edit Start-up Code feature of SAS Model Manager to use tables from the local SAS Workspace Server or network drive. For more information, see “Using Tables from a Local or Network Drive” on page 15.

To use SAS Management Console to define a data library and register the tables, follow these steps:

1. Open SAS Management Console and log on to the SAS Metadata Server. Your user ID must be authorized to modify libraries in the metadata server.

2. Open the New Library Wizard to define the data library. Click Environment Management ➔ Data Library Manager on the Plug-ins tab. Right-click Libraries and select New Library from the pop-up menu.

3. In the New Library Wizard, create a SAS library.
   b. Specify MM Tutorial-11 in the Name box.
   c. From the Location box, click Browse. Navigate to the Model Manager folder. Click the New folder icon and enter Tutorial11. Double-click Tutorial11. Click OK.
   d. (Optional) If more than one server exists, select a server in the Available servers list and click ➔ to move the server name to the Selected servers list.
   e. Specify smm12t11 for the libref and click New.
   f. Specify the server folder that you previously created, drive\SMM121Tutorial\Tutorial11\Samples, for the path specification and click OK twice.
   g. Click Next and Finish.

4. Register the data tables in the metadata repository.
   a. Right-click MM Tutorial-11 under the Libraries node, select Register Tables from the pop-up menu, and click Next.
   b. If prompted, specify the user ID and password to the metadata server and click OK. Then click Next.
   c. Click Select All Tables and click Next.
   d. Click Finish.

5. Verify that table metadata was created. Select MM Tutorial-11 under the Libraries node and examine the right pane.

Using Tables from a Local or Network Drive

Overview

You can use tables from the local SAS Workspace Server or network drive to complete these SAS Model Manager tasks:

- Create a project
- Modify a project definition
• Create a scoring task
• Create a model retrain task
• Create reports
• Create a performance monitoring task

To use tables from the local or network drive, you must submit a LIBNAME statement to define a libref for the drive before you execute the SAS Model Manager task. You submit LIBNAME statements using the Edit Start-up Code window.

Create a Libref for a Local or Network Drive
To submit the LIBNAME statement, follow these steps:

1. Ensure that the path to the library that you want to create exists and that your SAS Model Manager user ID has access to the library.


3. Enter the LIBNAME statement. For example,

   \texttt{libname smm12t2 \textasciitilde "C:\SMM121Tutorial\Tutorial2\Samples";}

   Here are examples of the LIBNAME and librefs that you can use for each tutorial:

   \begin{tabular}{|l|l|l|}
   \hline
   Tutorial \# & Libref & Library Path Examples \\
   \hline
   Tutorial 2 & smm12t2 & C:\SMM121Tutorial\Tutorial2\Samples \\
   \hline
   Tutorial 3 & smm12t3 & C:\SMM121Tutorial\Tutorial3\Samples \\
   \hline
   Tutorial 5 & smm12t5 & C:\SMM121Tutorial\Tutorial5\Samples \\
   \hline
   Tutorial 6 & lgd pd & C:\SMM121Tutorial\Tutorial6\Samples\lgd pd \\
   \hline
   Tutorial 8 & smm12t8 & C:\SMM121Tutorial\Tutorial8\Samples \\
   \hline
   Tutorial 11 & smm12t11 & C:\SMM121Tutorial\Tutorial11\Samples \\
   \hline
   \end{tabular}

4. Click Run Now.
A message indicates whether the libref was created. Click the Log tab to see the SAS log.

5. Click OK. The LIBNAME statement is saved in the Edit Start-up Code window.

Note: If you save the code without running it by clicking OK, the code automatically runs the next time the middle-tier server starts.

If multiple LIBNAME statements are submitted for the same libref, the last LIBNAME statement defines the libref.

The librefs that you create can be viewed in the Data Sources category view. Select the SAS Libraries tab to view the list:

---

Delete a Libref

You delete a libref using the Edit Start-up Code window.

1. Select Tools ⇒ Edit Start-up Code

2. Enter the following code in the Edit Start-up Code window:

   LIBNAME libref_name CLEAR;

3. Click Run Now.

4. Click OK.
Prepare for Using SAS Workflow

Overview

SAS Workflow provides services that work together to model, automate, integrate, and streamline business processes. It provides a platform for more efficient and productive business solutions.

SAS Workflow is used by SAS solutions that benefit from business process management. SAS Workflow Studio is a desktop client application that is used to design and deploy workflow process definitions. The SAS middle tier hosts the workflow engine and the workflow services as part of the SAS Web Infrastructure Platform. The SAS Model Manager Workflow Console is used to manage the workflow processes that are associated with modeling projects and versions.

From the SAS Model Manager client application, you can view a workflow, create a new workflow for a version, and view your workflow inbox to work with activities, depending on the user permissions. The option that is selected and the user permissions determine the category view and content that are displayed when Workflow Console is launched. SAS Model Manager administrators can view the Workflow Definitions, Workflows, and Activities category views of Workflow Console. SAS Model Manager users and advanced users can view only the Activities category view. For more information about user permissions, see “Configuring Users, Groups, and Roles” in Chapter 4 of SAS Model Manager: Administrator's Guide.

To use SAS Workflow with SAS Model Manager tutorials, you must satisfy the following prerequisites:

1. SAS Workflow Engine, SAS Workflow Services, and SAS Workflow Studio must be installed and configured. For more information, see SAS Intelligence Platform: Installation and Configuration Guide.

2. If you want to receive the e-mail notifications for a tutorial workflow process, you must configure alert notifications using SAS Management Console. For more information, see “Configure Alert Notifications” on page 18.

3. Workflow process definitions must be made available using SAS Workflow Studio. For more information, see “Make the Workflow Process Definitions Available” on page 20.

Configure Alert Notifications

About Alert Notifications

To enable workflow participants to receive alert notifications from SAS Workflow when performing the tutorials, you must configure the E-mail notification type in SAS Management Console. After you have configured the alert notifications, you can then use the Notify Participant policy and other workflow notification policies for workflow process activities in SAS Workflow Studio. The notifications setting in SAS Management Console is a global setting. Preferences and notifications can also be configured for individual users.
The Send Notification By Data Object policy in SAS Workflow Studio integrates with the SAS Web Infrastructure Platform's Notification Service. Recipients are notified according to their preferences (e-mail or portlets).

**Global Alert Notifications**

To enable the e-mail notification type for all users, follow these steps:

1. Log on to SAS Management Console as a SAS administrator.
2. On the **Plug-ins** tab, navigate to **Application Management ➔ Configuration Manager ➔ SAS Application Infrastructure**.
3. Right-click **SAS Application Infrastructure** and select **Properties**.
4. Click the **Settings** tab.
5. Select **Notifications** in the left panel. Use the menus or text fields to set the property.
6. Select the **E-mail** notification type from the **Available** list and click the right-arrow to add the selected notification type.
7. Click **OK**.
8. To apply this setting and make it available, restart the SAS Web Infrastructure Platform Services and applications that use the changed property, such as SAS Model Manager Workflow Console and SAS Workflow.

**Individual User Alert Notifications**

You can use SAS Preferences Manager to override the default notification delivery type for your user account. SAS Preferences Manager is a Web application that provides a central facility for users to manage their preferences and settings. The default notification type after the deployment of SAS 9.3 is the alerts portlet.

To modify your notification delivery preference, follow these steps:

1. Enter the URL `http://host-name:port/SASPReferences` in your browser window to launch the SAS Preferences Manager. Replace the values for host-name and port based on the location of the configured SAS Web Infrastructure Platform.
2. Enter the user ID and password for the user account that you use to access SAS Web applications and SAS Model Manager.
3. Select **General ➔ Notifications**.
4. Select a format type for the E-mail notifications. The options are **HTML-formatted e-mail** and **Plain-text e-mail**.
5. Select the notification types from the **Available** list and click ➔ to add the selected notification types. The available options are the following:
   - Via e-mail
   - My alerts portlet
   - Via SMS text message
   - Via digested e-mail
   
   **TIP** To remove a notification type, select the type from the list and click ✗ to remove the selected item.
6. Click **Apply** to update the notification settings and click **OK** to save the changes.
Make the Workflow Process Definitions Available

Overview
To use SAS Workflow with tutorials, you must make the process definitions available to SAS Model Manager. After the process definitions are made available, the SAS Model Manager administrator can use Workflow Console to create workflows to be used with SAS Model Manager.

To save the tutorial workflow process definitions to the Workflow repository, follow these steps:

1. From SAS Workflow Studio, select File ⇒ Open and navigate to the location where you extracted the tutorial files (for example, C:\SMM121Tutorial\). Open the subfolder Workflow Process Definitions and select the file (for example, MMWorkflowExample1.xml).

2. Log on to the server as a SAS administrator or SAS Model Manager administrator.

3. Add the tag attribute of mmapi to the process definition file properties.

4. Upload the process definition.

5. Repeat steps 1 through 4 for each workflow process definition. There are workflow process definitions for tutorial 2, tutorial 3, tutorial 10 and some additional examples.


**Log On to the Server**

With SAS Workflow Studio, you can manage only locally stored workflow templates on your system until you have logged on to the server. After you are connected, you can access additional process templates that are stored in the SAS Content Server.

To log on to the server, follow these steps:

1. From the **Server** menu, select **Logon**.
2. In the Log On window, select the host-name from the **SAS environment** drop-down list.
3. Enter a user ID and password, and click **Log On**.

**Note:** The available host parameters are configured in the environments.xml file.

```xml
<environment name="localhost" default="false">
  <desc>SAS Environment: localhost</desc>
  <service-registry>
    http://localhost:8080/SASWIPClientAccess/remote/ServiceRegistry
  </service-registry>
  <service-registry interface-type="soap">
    http://localhost:8080/SASWIPSapServices/services/ServiceRegistry
  </service-registry>
</environment>
```

For details about this configuration, see *SAS Intelligence Platform: Web Application Administration Guide*.

---

**Add Tag Attributes to a Process Definition**

Only the process definitions in the Workflow repository that have the **mmapi** tag attribute that is specified in the file properties are available to SAS Model Manager Workflow Console. The Workflow repository is located on the SAS Content Server.

To add a tag attribute to the file properties of a process definition template in SAS Workflow Studio, follow these steps:

1. Select **File ⇒ Properties** and click **Add**.
2. Enter the tag value of **mmapi**.

  **Note:** The file properties are case sensitive. This value must be lowercase.
3. Click **OK** twice.

**Upload a Process Definition**

To upload a process, follow these steps:

1. From the **Server** menu, select the **Save to Repository** menu option. The Save to Workflow Repository window appears.

2. (Optional) Enter relevant comments to associate with the process definition.

3. Select the **Activate** option if you want to make the current version of the workflow process definition available for use in the Workflow repository by applications, such as SAS Model Manager Workflow Console.
4. Click **OK**.

**Verify That the Process Definitions Are Available in the Workflow Console**

To verify that the workflow process definitions are available in the Workflow Console, follow these steps:

1. Enter the URL `http://host-name:port/SASModelManagerWorkflow` in your Web browser.

2. Enter the user ID and password for a SAS Model Manager administrator.

3. Verify that the uploaded process definition appears in the Process Definitions category view.
Chapter 2
Tutorial 1: Create a Life Cycle Template

Overview of Life Cycle Templates and Roles

A SAS Model Manager project consists of one or more versions. A version is a time-based container for SAS Model Manager projects. For example, you might have versions for both 2011 and 2012. The 2011 version contains the champion home equity model and the 2012 version contains the resources for developing a new home equity model.

Each version has a life cycle that is associated with it to track the progress of selecting a champion model and monitoring the model's performance. The life cycle contains milestones such as development, test, and production. Associated with each milestone are tasks that you perform to complete a milestone. When you create a version, you select a life cycle template that you want to use for the version life cycle. The life cycle template for your version must be available to SAS Model Manager before you create a version.

You use the SAS Model Manager Template Editor to create a life cycle template with milestones and tasks that are specific to your modeling project. You can create a new life cycle template or start with a sample life cycle template and modify the template. SAS Model Manager provides several sample life cycle templates. After the template is complete, you can use the template in SAS Model Manager by uploading the template to the SAS Content Server. You can save a backup copy of the template to a local or network location.

In SAS Model Manager, you can view life cycle templates from the Life Cycle category view. Any user-defined template in the Life Cycle category view can be used as a life cycle when you create a version.
Any users or groups who need to update the version life cycle status must be assigned the appropriate life cycle roles using the SAS Management Console User Manager plug-in:

- Model Manager: Life Cycle Participant Usage (participant)
- Model Manager: Life Cycle Assignee Usage (assignee)
- Model Manager: Life Cycle Approval Usage (approver)

A best practice is to assign these roles only to groups and not to users. Assigning roles to groups provides flexibility when you need to add or remove users who are responsible for life cycle tasks. However, it is possible to assign these roles to users as well as groups.

When you open the SAS Model Manager Template Editor, users or groups that are assigned to the participant role appear in the Participants list. Only those users and groups in the Participants list can be considered to be assignees or approvers. When the template is selected as the life cycle for a version, only those users or groups can update the milestone and task properties.

This tutorial creates a Model Manager Tutorial Users group by using SAS Management Console. After you create the Model Manager Tutorial Users group, you create a life cycle template that can be used for the SAS Model Manager tutorials.

---

Create Groups for Use with the SAS Model Manager Tutorial

Create a SAS Model Manager Assignee Group

In this exercise, a SAS administrator creates a group in SAS Management Console for SAS Model Manager assignees. Any member of this group is able to update the status of a life cycle task if that group is specified as a value for the task Assignee property.

1. Start and log on to SAS Management Console as a SAS Administrator whose role enables you to update the metadata server user administration.
3. In the Name field, type MM Tutorial Assignees.
4. In the Display Name field, type MM Tutorial Assignees.
5. In the Description field, type A group for SAS Model Manager users who can be assigned to complete tasks.
6. Click the Members tab.
7. From the Available Identities list, select Model Manager Advanced Users, Model Manager Administrator Users, and Model Manager Users to add to this group. For each user who needs to be assigned to the group, select the user and click to move the user to the Current Members list.
8. Click the Groups and Roles tab. Ensure that the Show Roles box is checked. Select the following roles and click to move the roles to the Member of list:

- Model Manager: Life Cycle Participant Usage
**Model Manager: Life Cycle Assignee Usage**

Here is an example of the **Groups and Roles** tab.

9. Click **OK**. Here is an example of the group **MM Tutorial Assignees** listed as a group in SAS Management Console.

---

**Create a SAS Model Manager Approver Group**

In this exercise, a SAS administrator creates a group in SAS Management Console for SAS Model Manager approvers. Any member of this group is able to update the **Approved** status of a life cycle task if that group is specified as a value for the task **Approver** property.

1. Start and log on to SAS Management Console as a SAS Administrator whose role enables you to update the metadata server user administration.
2. On the **Plug-ins** tab, right-click **User Manager** and select **New Group**. The New Group Properties window appears with the **General** tab.

3. In the **Name** field, type **MM Tutorial Approvers**.

4. In the **Display Name** field, type **MM Tutorial Approvers**.

5. In the **Description** field, type **A group for SAS Model Manager users who can approve that a task is complete.**

6. Click the **Members** tab.

7. From the **Available Identities** list, select **Model Manager Advanced Users** and **Model Manager Administrator Users** to add to this group. For each user who needs to be assigned to the group, select the user and click ![arrow](image) to move the user to the **Current Members** list.

8. Click the **Groups and Roles** tab. Ensure that the **Show Roles** box is checked. Select the following roles and click ![arrow](image) to move the roles to the **Member of** list:

   - **Model Manager: Life Cycle Participant Usage**
   - **Model Manager: Life Cycle Approval Usage**

   Here is an example of the **Groups and Roles** tab.

9. Click **OK**. Here is an example of the group **MM Tutorial Approvers** listed as a group in SAS Management Console.
Create a Life Cycle Template

In this exercise, you use the SAS Model Manager Template Editor to create a user-defined life cycle template from a sample template. SAS Model Manager provides sample templates that you can use to start your user-defined template. This tutorial uses the Basic.xml template.

Start SAS Model Manager

To run SAS Model Manager, follow these steps:

1. On your client machine, start the SAS Model Manager client.
2. Log on to SAS Model Manager as a member of the Model Manager Advanced Users group or Model Manager Administrator Users group.
Create a New Life Cycle Template

This task uses the Basic.xml sample template that is provided by SAS Model Manager and modifies it to create a new life cycle template.

1. Open the SAS Model Manager Template Editor (Template Editor). Select **Tools ➤ Manage Templates** in the SAS Model Manager window.

2. In the Template Editor, open the Basic.xml sample life cycle template. Select **File ➤ Browse ➤ Browse Templates ➤ Basic.xml** and click **Open**.

3. Modify the template properties. Specify the following properties:
   - **Name**
     Replace the name with **Tutorial Life Cycle**.
   - **Description**
     Replace the description with **A life cycle for the tutorial**.
   - **Version**
     Replace the existing value with **1**.

4. Save the template to your local computer by selecting **File ➤ Save As**. In the Save dialog box, select the location on your local computer. Enter **TutorialLifeCycle.xml** as the filename and click **Save**.

5. Using a text editor, open the life cycle template XML file that you just saved. If the version attribute on the `<LifeCycleTemplate>` does not have a value of **1** enclosed in
quotation marks, replace the value with the value 1 enclosed in quotation marks. Here is the <LifecycleTemplate> element:

```xml
<LifecycleTemplate name="Tutorial Life Cycle" 
    description="A life cycle for the tutorial" version="1" 
    isDefault="True">
```

Rename the `mdlmgrexampleassignees` and `mdlmgrexampleapprovers` participants to `MM Tutorial Assignees` and `MM Tutorial Approvers`. The participants are enclosed in `<Participants>` and `</Participants>` tags. Here are the final participants in the XML file:

```xml
    <Participants>
        <Participant id="1" name="MM Tutorial Assignees"></Participant>
        <Participant id="2" name="MM Tutorial Approvers"></Participant>
    </Participants>
```

Save the file.

6. In the SAS Model Manager Template Editor, select **File** ⇒ **Open**. In the Open dialog box, select the template and click **OK**. The **Participants** list displays only `MM Tutorial Assignees` and `MM Tutorial Approvers`.

![SAS Model Manager Template Editor](image)

**Note:** After the correct participants have been added to the template, it is not necessary to save the template to a local computer. You can upload the template from the SAS Model Manager Template Editor. This tutorial saves the template periodically to a local computer to create a backup of the template.

### Add a Milestone to the User-defined Template

This exercise adds the milestone Test to the life cycle template.

1. Right-click **Tutorial Life Cycle** and select **New Milestone**. In the New Milestone window, complete the **Name** and **Type** fields and click **OK**.

   **Name**

   enter **Test**.
Type

click the Type box and select Test.

After you click OK, the Test milestone has an ID of 4.

2. Right-click Test and select Move Up. Move the Test milestone once more, which places it after Development. It now has an ID of 2.

3. Select File ➔ Save to save the template. Click OK when the Warning dialog box appears.

Here is the template at the end of this exercise:

![SAS Model Manager Template Editor](image)

### Add Tasks to the Life Cycle Template Milestones

This exercise adds tasks to each milestone.

1. Add tasks to the Development milestone.

   For each task, right-click the Development milestone and select New Task. In the New Task window, complete the Name field and Type field using the following table. Click OK. The task names are descriptive. Therefore, a description is not necessary.

<table>
<thead>
<tr>
<th>Task Name</th>
<th>Task Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Define library in SAS Management Console</td>
<td>User-defined</td>
</tr>
<tr>
<td>Register data sets</td>
<td>User-defined</td>
</tr>
<tr>
<td>Set up the project in the Project Tree</td>
<td>User-defined</td>
</tr>
<tr>
<td>Import models</td>
<td>User-defined</td>
</tr>
<tr>
<td>Create comparison reports</td>
<td>User-defined</td>
</tr>
</tbody>
</table>
The task `Select Champion` existed in the Basic.xml sample life cycle template. Rename the task and move it after the `Score models` task:

a. In the **Name** field, change the task name to **Set a champion model**.

b. In the **Task Type** field, change the task type to **Set Champion**.

c. Right-click **Set a champion model** and select **Move Down**. Repeat this until the task comes after **Score models**.

Expand the **Development** milestone. Each task has an ID in the form `milestone.task`. The first number in the ID is the milestone ID. The second number in the ID identifies the specific task.

Here is the template after adding the tasks for the **Development** milestone:

2. Add tasks to the **Test** milestone.

For each task, right-click the **Test** milestone and select **New Task**. In the New Task window, complete the **Name** field and **Type** field using the following table. Click **OK**. The task names are descriptive. Therefore, a description is not necessary.

<table>
<thead>
<tr>
<th>Task Name</th>
<th>Task Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Validate score input data</td>
<td>User-defined</td>
</tr>
<tr>
<td>Validate score output data</td>
<td>User-defined</td>
</tr>
<tr>
<td>Test scoring</td>
<td>User-defined</td>
</tr>
<tr>
<td>Sign-off</td>
<td>Sign-off</td>
</tr>
</tbody>
</table>

3. Add tasks to the **Production** milestone.

For each task listed below, right-click the **Production** milestone and select **New Task**. In the **New Task** window, complete the **Name** field and **Type** field using the
following table. Click OK. The task names are descriptive. Therefore, a description is not necessary.

<table>
<thead>
<tr>
<th>Task Name</th>
<th>Task Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Publish model</td>
<td>User-defined</td>
</tr>
<tr>
<td>Start production scoring</td>
<td>User-defined</td>
</tr>
<tr>
<td>Run monitoring reports</td>
<td>User-defined</td>
</tr>
<tr>
<td>Retrain models</td>
<td>User-defined</td>
</tr>
<tr>
<td>Sign-off</td>
<td>Sign-off</td>
</tr>
</tbody>
</table>

4. The **Declare Ready For Production** task was provided in the Basic.xml sample template. In the **Name** field, rename the task to **Declare ready for production**.

5. Select **File ➔ Save** to save the template. Click **OK** if the Warning dialog box appears.

Here is the template after all milestone tasks have been defined:

**Add Task Dependencies**

**About Dependencies**

Your model development process might require an order to complete some tasks. To each task, you can assign dependencies that indicate that one or more tasks must be
completed before another one can be marked complete. You specify dependencies in the Dependencies property for a task.

This exercise assigns dependencies to milestone tasks.

**Add Dependencies for the Development Milestone Tasks**

1. Select the Import models task. Click the Dependencies property value field and then click the ellipsis button. Select the box for Set up the project in the Project Tree. Click OK. The Import models task now has a dependency on task 1.3, Set up project in the Project Tree.

2. Select the Create comparison reports task. Click the Dependencies property and then click the ellipsis button. Select the box for Import models. Click OK. The Create comparison reports task now has a dependency on task 1.4, Import models.

3. Select the Score models task. Click the Dependencies property and then click the ellipsis button. Select the box for Import models. Click OK. The Score models task now has a dependency on task 1.4, Import models.

4. Select the Set a champion model task. Click the Dependencies property and then click the ellipsis button. Select the box for Create comparison reports and Score models. Click OK. The Set a champion model task now has a dependency on task 1.5, Create comparison reports and task 1.6, Score models.

5. Select the Sign-off task. Click the Dependencies property and then click the ellipsis button. Select the box for Set a champion model. Click OK. The Sign-off task now has a dependency on task 1.7, Set a champion model.

6. Here is the template after the Development milestone task dependencies have been assigned:

   ![Life Cycle Template](image)

**Add Dependencies for the Test Milestone Tasks**

1. Select the Test scoring task. Click the Dependencies property value field and then click the ellipsis button. Select the box for Validate score input data and Validate score output data. Click OK. The Test scoring task now has a dependency on task 2.1, Validate score input data, and task 2.2, Validate score output data.

2. Select the Sign-off task. Click the Dependencies property and then click the ellipsis button. Select the box for Test scoring. Click OK. The Sign-off task now has a dependency on task 2.3, Test scoring.
Add Dependencies for the Production Milestone Tasks

1. Select the Declare ready for production task. Click the Dependencies property value field and then click the ellipsis button. Select the box for Sign-off for ID 2.4. Click OK.

2. Select the Publish model task. Click the Dependencies property value field and then click the ellipsis button. Select the box for Declare ready for production. Click OK. The Publish model task now has a dependency on task 3.1, Declare ready for production.

3. Select the Start production scoring task. Click the Dependencies property value field and then click the ellipsis button. Select the box for Publish model. Click OK. The Start production scoring task now has a dependency on task 3.2, Publish model.

4. Select the Run monitoring reports task. Click the Dependencies property and then click the ellipsis button. Select the box for Start production scoring. Click OK. The Run monitoring reports task now has a dependency on task 3.3, Start production scoring.

5. Select the Retrain models task. Click the Dependencies property and then click the ellipsis button. Select the box for Run monitoring reports. Click OK. The Retrain models task now has a dependency on task 3.4, Run monitoring reports.

6. Select the Sign-off task. Click the Dependencies property and then click the ellipsis button. Select the box for Retrain models. Click OK. The Sign-off task now has a dependency on task 3.5, Retrain models.

7. Here is the template after all dependencies have been assigned:

8. To save the template to your local computer, select File ➤ Save.
**Complete Task Properties**

**Complete the Development Task Properties**

In this exercise, you complete the Development task properties.

Select each task and enter property values using the values in the following table.

To assign property values for the Assignees and Approvers properties, click the ellipsis button to open the Select Participants window. Select the box for the assignee or approver and click **OK**.

<table>
<thead>
<tr>
<th>Task</th>
<th>Assignees Property</th>
<th>Approvers Property</th>
<th>Weight Property</th>
<th>Duration Property</th>
</tr>
</thead>
<tbody>
<tr>
<td>Define library in SAS Management Console</td>
<td>MM Tutorial Assignees</td>
<td>MM Tutorial Approvers</td>
<td>10</td>
<td>1</td>
</tr>
<tr>
<td>Register data sets</td>
<td>MM Tutorial Assignees</td>
<td>MM Tutorial Approvers</td>
<td>10</td>
<td>1</td>
</tr>
<tr>
<td>Set up the project in the Project Tree</td>
<td>MM Tutorial Assignees</td>
<td>MM Tutorial Approvers</td>
<td>10</td>
<td>1</td>
</tr>
<tr>
<td>Import models</td>
<td>MM Tutorial Assignees</td>
<td>MM Tutorial Approvers</td>
<td>10</td>
<td>1</td>
</tr>
<tr>
<td>Create comparison reports</td>
<td>MM Tutorial Assignees</td>
<td>MM Tutorial Approvers</td>
<td>10</td>
<td>2</td>
</tr>
<tr>
<td>Score models</td>
<td>MM Tutorial Assignees</td>
<td>MM Tutorial Approvers</td>
<td>10</td>
<td>2</td>
</tr>
<tr>
<td>Set a champion model</td>
<td>MM Tutorial Assignees</td>
<td>MM Tutorial Approvers</td>
<td>30</td>
<td>4</td>
</tr>
<tr>
<td>Sign-off</td>
<td>MM Tutorial Assignees</td>
<td>MM Tutorial Approvers</td>
<td>10</td>
<td>1</td>
</tr>
</tbody>
</table>

Save the template.

**Complete the Test Task Properties**

In this exercise, you complete the Test task properties.

Select each task and enter property values using the values in the following table.

To assign property values for the Assignees and Approvers properties, click the ellipsis button to open the Select Participants window. Select the box for the assignee or approver and click **OK**.
In this exercise, you complete the Production task properties.

Select each task and enter property values using the values in the following table.

To assign property values for the Assignees and Approvers properties, click the ellipsis button to open the Select Participants window. Select the box for the assignee or approver and click OK.

<table>
<thead>
<tr>
<th>Task</th>
<th>Assignees Property</th>
<th>Approvers Property</th>
<th>Weight Property</th>
<th>Duration Property</th>
</tr>
</thead>
<tbody>
<tr>
<td>Declare ready for production</td>
<td>MM Tutorial Assignees</td>
<td>MM Tutorial Approvers</td>
<td>10</td>
<td>1</td>
</tr>
<tr>
<td>Publish model</td>
<td>MM Tutorial Assignees</td>
<td>MM Tutorial Approvers</td>
<td>15</td>
<td>1</td>
</tr>
<tr>
<td>Start production scoring</td>
<td>MM Tutorial Assignees</td>
<td>MM Tutorial Approvers</td>
<td>20</td>
<td>2</td>
</tr>
<tr>
<td>Run monitoring reports</td>
<td>MM Tutorial Assignees</td>
<td>MM Tutorial Approvers</td>
<td>25</td>
<td>1</td>
</tr>
<tr>
<td>Retrain models</td>
<td>MM Tutorial Assignees</td>
<td>MM Tutorial Approvers</td>
<td>15</td>
<td>3</td>
</tr>
<tr>
<td>Sign-off</td>
<td>MM Tutorial Assignees</td>
<td>MM Tutorial Approvers</td>
<td>15</td>
<td>1</td>
</tr>
</tbody>
</table>

Save the template.

**Upload the Life Cycle Template**

In this exercise, you upload the new life cycle template to the SAS Content Server. Only SAS Model Manager administrators can upload templates to the SAS Content Server.
1. Log on as a SAS Model Manager administrator.
2. From the SAS Model Manager windows, select **Tools ➔ Manage Templates**.
3. In the SAS Model Manager Template Editor, select **File ➔ Open**. In the Open window, select TutorialLifeCycle.xml and click **OK**.
4. Select **File ➔ Upload File**. Verify the filename in the Upload File window and click **OK**. A message box appears when the file was uploaded successfully.
5. You can now view this life cycle template in the Browse Templates window and in the Life Cycle perspective.

   To view the template in the Browse Templates window, select **File ➔ Browse ➔ Browse Templates ➔ TutorialLifeCycle.xml** and click **Open**.

   To view the template in the Life Cycle perspective, in the SAS Model Manager window, select the Life Cycle perspective button.

   **Tutorial Life Cycle** can now be specified as a life cycle template, as shown in the New Version window, when you create a version in subsequent tutorials:
Chapter 3
Tutorial 2: Performing Basic SAS Model Manager Tasks

Overview of SAS Model Manager Basics .................................................... 42
Prerequisites ................................................................. 42
  Tutorial 2 Models and Data Sets ...................................................... 42
  Verify Your User ID as a Member of Model Manager User Groups ....... 42
Organize the Model Hierarchy .............................................................. 43
  Create a Folder ................................................................................. 44
  Create a New Project ......................................................................... 44
  Define the Project Properties .......................................................... 45
  Create a Version ................................................................................. 47
  Create a Workflow (Optional) ........................................................... 48
  Update the Life Cycle (Optional) ....................................................... 49
  Update the Workflow Process (Optional) ........................................... 50
Import Models ................................................................. 51
  About Tutorial 2 Models .................................................................. 51
  Import SAS Code Models ................................................................. 52
  Set Model Properties ........................................................................ 54
  Map Model Variables to Project Variables ......................................... 54
  Update the Life Cycle (Optional) ....................................................... 55
  Update the Workflow Process (Optional) ........................................... 56
Create Model Comparison Reports ...................................................... 57
  Create a Model Profile Report .......................................................... 57
  Create a Delta Report ......................................................................... 58
  Create a Dynamic Lift Report ........................................................... 59
  View a Model Comparison Report .................................................... 60
  Update the Life Cycle (Optional) ....................................................... 60
  Update the Workflow Process (Optional) ........................................... 61
Using the Annotations View ................................................................. 62
  View History ...................................................................................... 62
  View Notes ....................................................................................... 63
  View the Summary Information ........................................................ 64
Scoring Models ................................................................. 65
  Create a Scoring Task ....................................................................... 66
  Execute a Scoring Task ..................................................................... 67
  Update the Life Cycle (Optional) ....................................................... 68
  Update the Workflow Process (Optional) ........................................... 69
Declare a Champion Model .............................................................. 70
  Set the Champion Model .................................................................. 70
  Update the Life Cycle (Optional) ....................................................... 70
Overview of SAS Model Manager Basics

After an administrator has defined your user ID in SAS Management Console and you have a life cycle template, you are ready to work in SAS Model Manager. This tutorial guides you through a simple modeling project process.

To enable you to track the progress of the modeling project, each task has instructions to update the version life cycle status.

Prerequisites

Tutorial 2 Models and Data Sets

The exercises in this tutorial require that the Tutorial 2 data sets and models from SMM121Tutorial.zip be extracted and registered in SAS Management Console. If they have not been extracted and registered, see “Prepare Tutorial 2 Data Sets and Models” on page 4 to extract and register the files. You must have access from the SAS Model Manager client to the tutorial files.

Verify Your User ID as a Member of Model Manager User Groups

This exercise ensures that your user ID is a member of the MM Tutorial Assignees group and the Model Manager Advanced Users group.

1. Open SAS Management Console and log on to the SAS Metadata Server.
2. On the Plug-ins tab, select User Manager.
3. In the right pane, double-click the MM Tutorial Assignees group and click the Members tab.
4. Review the Current Members list, and locate your user ID or a group that your user ID is a member of. If your user ID or group is not a member of the MM Tutorial Assignees group, ask your administrator to add you to this group. Close the properties window.
5. Find and double-click your user ID in the right pane of SAS Management Console.
6. Click the Groups and Roles tab. Review the Member of pane and locate the group Model Manager Advanced Users. If your user ID is not a member of this group, ask your administrator to add you to this group. Close the properties window.

See Also

“Create Groups for Use with the SAS Model Manager Tutorial” on page 26
Organize the Model Hierarchy

In this exercise, you learn to use the Project Tree to create a modeling project.
Create a Folder

To provide an organizational folder to manage your modeling projects, follow these steps:

2. Specify values for the following folder properties and click OK.
   - Name
     enter Tutorial2 for the folder name.
   - Description
     enter an optional folder description.

The new folder appears in the Project Tree.

Create a New Project

To create a project and define the model function, follow these steps:

2. Specify the following general and project properties and click Next:
   - Name
     enter Delinquency for the project name.
   - Description
     enter an optional description.
   - Model Function
     select Classification.
3. Specify the project input variables:
   a. Below the Project Input Variables table, click Import Variables. The Import Variables from Table window appears.
   b. On the SAS Metadata Repository tab, click the Look in box and navigate to the path Shared Data ⇒ Model Manager ⇒ Tutorial2.
   c. Select DELINQUENCY_PROJECT_INPUT and click OK.
4. Specify the project output variables:
   a. Below the Project Output Variables table, click Import Variables. The Import Variables from Table window appears.
   b. Select DELINQUENCY_PROJECT_OUTPUT, click OK, and click Finish.
Here is the New Project wizard Step 2 of 2 after the project variables have been set.

![New Project wizard](image)

5. Examine the **Tutorial2** folder to verify that it contains the **Delinquency** project.

- **Tutorial2**
  - **Delinquency**
    - Model Retrain
    - Performance Monitor
    - inputvar.xml
    - outputvar.xml

**Define the Project Properties**

To define the properties that SAS Model Manager uses to create reports and score models, follow these steps:

1. Select the **Delinquency** project in the **Tutorial2** folder and expand **Specific Properties** on the **Properties** tab.
2. Enter values for these properties:
   - **Default Test Table**
     Click the property value field and click **Browse**. In the Select Table window, select the table **DELINQUENCY_TEST** from the SAS Metadata Repository tab.
Default Scoring Task Input Table
Click the property value field and click Browse. In the Select Table window, select the table `DELINQUENCY_SCORING_INPUT` from the SAS Metadata Repository tab.

Default Scoring Task Output Table
Click the property value field and click Browse. In the Select Table window, select the table `DELINQUENCY_SCORING_OUTPUT` from the SAS Metadata Repository tab.

Default Train Table
Click the property value field and click Browse. In the Select Table window, select the table `DELINQUENCY_TRAIN` from the SAS Metadata Repository tab.

Training Target Variable
Enter `bad`.

Target Event Value
Enter `1`.

Class Target Level
Click the property value field and select `Binary`.

Output Event Probability Variable
Click the property value field and select `POSTERIOR`.

![Image of SAS Model Manager interface](sas-model-manager.png)
Create a Version

Create a version for the project. The version folder contains life cycle information, auxiliary version documents, candidate model files, model comparison reports, resource files, scoring tasks, and model performance reports. To create a new version, follow these steps:


2. Specify the following version properties and click OK.

   **Name**
   Enter 2012 for the version name.

   **Life Cycle Template**
   select the user-defined template Tutorial Life Cycle.

   *Note*: If you are using a workflow process to track the progress of your project or version, you can select any life cycle template. You can then skip all tasks to update the life cycle.

3. Examine the Delinquency project to verify that it contains one version called 2012. Select Life Cycle. Verify that the Name property is Tutorial Life Cycle.

![Repository Tree](image)

*Note*: If you want to use a workflow process to track the progress of your version, send a request to a SAS Model Manager administrator and ask the administrator to create a workflow to use for the tutorials. Include the name and UUID of the version with which you want the workflow to be associated.
Create a Workflow (Optional)

**Overview**
A workflow is a copy of a workflow process definition. Only a SAS Model Manager administrator can create a new workflow. Each workflow consists of activities. Activities can contain properties and comments so that you can share information with other users, or make notes. The status that you select when completing an activity determines the next activity in the workflow process.

**Prerequisites**
The exercises in this tutorial require that you have made the workflow process definition available to SAS Model Manager. For more information, see “Prepare for Using SAS Workflow” on page 18.

**Create a New Workflow**
1. Log on to SAS Model Manager as a member of the **Model Manager Administrator Users** group.

2. From the SAS Model Manager main window, right-click a version and select **New Workflow**. Workflow Console is launched in a Web browser and displays the New Workflow window.

   **Note:** If you are already logged on to Workflow Console, from the Workflow Definitions category view, select a process definition and click ![New Workflow](click).

3. Select the workflow definition that is associated with this tutorial (if you accessed the New Workflow window from the SAS Model Manager main window).

4. Enter a name for the workflow.

5. The UUID of the selected version is already populated.

   **Note:** If the UUID is not already populated, you can copy the UUID system property value for a version from the Properties view in the SAS Model Manager main...
window. The field label and other characters that precede the UUID value must be removed.

6. (Optional) Enter a description for the workflow.

7. Click OK. A message appears, indicating that the workflow has been successfully created.

![Image of successful workflow creation message]

8. Click Close. The new workflow is now available in the Workflows category view.

9. To view the new workflow, click Workflows. The Workflows category view appears. Select the workflow to view information that is associated with the new workflow.

![Image of workflow view]

The workflow process definitions that have been provided for the tutorials already have participants assigned. For information about how to assign additional participants to a workflow, see “Working with Workflow Participants” in Chapter 21 of *SAS Model Manager: User's Guide*. You can also see Chapter 11, “Tutorial 10: Using Workflow Console,” on page 221 to learn how to manage workflows and work with activities.

**Update the Life Cycle (Optional)**

To complete the milestone task of adding data sources and setting up the project in the Project Tree, follow these steps:

1. In the Delinquency project, expand 2012 → Life Cycle → Development.

2. Select the Define library in SAS Management Console task and examine the task properties. The To Be Completed By property, assigned in the life cycle template, determines which users or user groups from the Participants list are responsible for
this milestone task. Because you are a member of the MM Tutorial Assignees group, you are authorized to update the task status.

3. Click the Status box and select Completed.

4. Select the Register data sets task and examine the task properties. Click the Status box and select Completed.

5. Select the Set up project in the Project Tree task. Click the Status box and select Completed.

6. Select all of the tasks whose status you updated and examine the properties. Verify that the value of the Date Completed property is today and that the value of the Completed By property is your user ID.

7. Select the Life Cycle node to examine its properties. The value for Date Modified is today's date. The Development property displays a bar chart that shows the percentage of completed tasks for this milestone.

**Update the Workflow Process (Optional)**

To complete the activities in the associated workflow process, follow these steps:

1. Select Tools ⇒ My Workflow Inbox or click 🏷️ from the SAS Model Manager main window to view the workflow process activities in your workflow inbox. Workflow Console is launched in a Web browser, and displays the Activities category view.

   *Note:* The list displays only the activities for which you are the actual owner or are assigned as a potential owner, and that have the state of Started.

2. From the Activities category view, select an activity name, and click 🏷️.

   *Note:* You can select an activity name and click 🏷️ to release an activity that you had previously claimed.
3. (Optional) Enter a property value or change an existing property value in the Properties pane.

4. (Optional) Add a comment to the activity using the Comments pane.

5. Select a status value to complete the activity. The workflow process continues to the next activity.

6. Repeat steps 2 through 5 for the activities that you completed during this tutorial.

Note: A workflow can be configured to display the activities that are associated with a milestone or task on the Workflow Milestones tab and in the Workflow Milestones report for a version in the SAS Model Manager client application. From the Workflow Milestones tab you can view the status of milestones or tasks that are associated with activities in the workflow.

Note: For more information, see Chapter 11, “Tutorial 10: Using Workflow Console,” on page 221.

---

**Import Models**

In this exercise you import models into SAS Model Manager, set model properties, and map the model variables.

**About Tutorial 2 Models**

The imported models are SAS code models. SAS code models are models that were not created and exported from SAS Enterprise Miner. SAS code models consist of the SAS code and the model component files (metadata) that is used to process a model in SAS Model Manager.

The SAS code for the first model is the LOGISTICS procedure, whereas the SAS code for the second and third models consists of DATA step fragments. To import a SAS code file, at least three component files are required: the model score code, the model input file, and the model output file. For prediction or classification models, you also must prepare model target files.
Note: This document imports two models that use the LOGISTICS procedure. In Tutorial 2, the model is a SAS code model, which is made up of individual model component files. In Tutorial 3, the model component files were created by the LOGISTICS procedure and bundled as a model package file (.spk). SAS code models and model package files use different model import methods.

Import SAS Code Models

1. Expand the 2012 version in the Delinquency project and right-click Models. Then select Import from ⇒ Local Files. The Local Files window appears.

2. Import Model 1.
   a. In the left pane, expand the Desktop folder and select <drive>:\Tutorial2\Samples\model1.
   b. In the Choose a model template box, select Classification.
   c. Type Model 1 in the Name box. For each filename in the Object column, click the filename and drag it to the corresponding option box. This action maps the tutorial model component filenames to the SAS Model Manager model component filenames.

<table>
<thead>
<tr>
<th>Object</th>
<th>Option</th>
</tr>
</thead>
<tbody>
<tr>
<td>modelin1.sas7bdat</td>
<td>modelinput.sas7bdat</td>
</tr>
<tr>
<td>modelout1.sas7bdat</td>
<td>modeloutput.sas7bdat</td>
</tr>
<tr>
<td>om.sas7bdat</td>
<td>outmodel.sas7bdat</td>
</tr>
<tr>
<td>score1.sas</td>
<td>score.sas</td>
</tr>
<tr>
<td>target1.sas7bdat</td>
<td>target.sas7bdat</td>
</tr>
</tbody>
</table>

Here is the Local Files window after the files have been mapped.
d. Click OK.

3. Import Model 2.
   
   a. Open the Local Files window. In the left pane, expand the Desktop folder and select \<drive>\Tutorial2\Samples\model2.
   
   b. In the Choose a model template box, select Classification.
   
   c. Type Model 2 in the Name box. For each filename in the Object column, click the filename and drag it to the corresponding option box. This action maps the tutorial model component filenames to the SAS Model Manager model component filenames.

<table>
<thead>
<tr>
<th>Object</th>
<th>Option</th>
</tr>
</thead>
<tbody>
<tr>
<td>modelin2.sas7bdat</td>
<td>modelinput.sas7bdat</td>
</tr>
<tr>
<td>modelout2.sas7bdat</td>
<td>modeloutput.sas7bdat</td>
</tr>
<tr>
<td>ot.sas7bdat</td>
<td>outmodel.sas7bdat</td>
</tr>
<tr>
<td>score2.sas</td>
<td>score.sas</td>
</tr>
<tr>
<td>target2.sas7bdat</td>
<td>target.sas7bdat</td>
</tr>
</tbody>
</table>

   d. Click OK.
4. Import Model 3.
   a. Open the Local Files window. In the left pane, expand the Desktop folder and select `{drive}:\Tutorial2\Samples\model3`.
   b. Type Model 3 in the Name box. For each filename in the Object column, click the filename and drag it to the corresponding option box. This action maps the tutorial model component filenames to the SAS Model Manager model component filenames.

<table>
<thead>
<tr>
<th>Object</th>
<th>Option</th>
</tr>
</thead>
<tbody>
<tr>
<td>modelin3.sas7bdat</td>
<td>modelinput.sas7bdat</td>
</tr>
<tr>
<td>modelout3.sas7bdat</td>
<td>modeloutput.sas7bdat</td>
</tr>
<tr>
<td>score3.sas</td>
<td>score.sas</td>
</tr>
<tr>
<td>target3.sas7bdat</td>
<td>target.sas7bdat</td>
</tr>
</tbody>
</table>

c. Click OK.

5. Examine the Models folder to verify that it contains the three models. Right-click the folder and select Expand All to examine the model files.

## Set Model Properties

Set the properties for the model. SAS Model Manager requires that the Score Code Type be set to DATA step if the score code is a DATA step fragment, or be set to SAS Program if the score code is a SAS procedure. Follow these steps.

1. Select Model 1. Click the Description field and enter first model for tutorial 2.
2. Select Model 2. Click the Score Code Type box and select DATA step.
3. Select Model 3. Click the Score Code Type box and select DATA step.

## Map Model Variables to Project Variables

When the names of the model output variable are not identical to the names of the project output variables, you must map the variables. To map model output variables to project output variables, follow these steps:

1. Map model variables for the first model. Right-click Model 1 in the Models folder and then select Set Model Output Mapping. Ensure that the following model variables are mapped to their respective project variables. To map a model variable to a project variable, click in the box in the Model Variables column, select a variable, and click OK.

<table>
<thead>
<tr>
<th>Project Variables</th>
<th>Model Variables</th>
</tr>
</thead>
<tbody>
<tr>
<td>POSTERIOR</td>
<td>P_1</td>
</tr>
<tr>
<td>PREDICTION</td>
<td>I_BAD</td>
</tr>
</tbody>
</table>
2. Map model variables for the second model. Select **Model 2** in the **Models** folder and then click the **Model Mapping** tab in the right pane. Click **Edit**. Ensure that the following model variables are mapped to their respective project variables. To map a model variable to a project variable, click the box in the **Model Variables** column and select a variable. Click **OK** when you are finished.

<table>
<thead>
<tr>
<th>Project Variables</th>
<th>Model Variables</th>
</tr>
</thead>
<tbody>
<tr>
<td>POSTERIOR</td>
<td>PROB2</td>
</tr>
<tr>
<td>PREDICTION</td>
<td>PREDICTION</td>
</tr>
</tbody>
</table>

3. Map model variables for the third model. Select **Model 3** in the **Models** folder and then click the **Model Mapping** tab in the right pane. Click **Edit**. Ensure that the following model variables are mapped to their respective project variables. To map a model variable to a project variable, click the box in the **Model Variables** column and select a variable. Click **OK** when you are finished.

<table>
<thead>
<tr>
<th>Project Variables</th>
<th>Model Variables</th>
</tr>
</thead>
<tbody>
<tr>
<td>POSTERIOR</td>
<td>P_BAD1</td>
</tr>
<tr>
<td>PREDICTION</td>
<td>PREDICTION</td>
</tr>
</tbody>
</table>

**Update the Life Cycle (Optional)**

To update the Development milestone, follow these steps:

1. In the **Delinquency** project, expand **2012 → Life Cycle → Development**.

2. Select the **Import models** task. Click the **Status** box and select **Completed**.

3. Select the **Development** milestone to refresh the property values. Select **Import models**. The **Date Completed** and **Completed By** fields have been updated with today's date and your user ID.

4. Click the **Life Cycle** node to examine its properties. The value for **Date Modified** is today's date. The **Develop** property displays a bar chart that shows the percentage of completed tasks for this milestone.
Update the Workflow Process (Optional)

To complete the activities in the associated workflow process, follow these steps:

1. Select **Tools ▶ My Workflow Inbox** or click 🗄 from the SAS Model Manager main window to view the workflow process activities in your workflow inbox. Workflow Console is launched in a Web browser, and displays the Activities category view.
   
   *Note:* The list displays only the activities for which you are the actual owner or are assigned as a potential owner, and that have the state of **Started**.

2. From the Activities category view, select an activity name, and click 🖏.
   
   *Note:* You can select an activity name and click 🖏 to release an activity that you had previously claimed.

3. (Optional) Enter a property value or change an existing property value in the Properties pane.

4. (Optional) Add a comment to the activity using the Comments pane.

5. Select a status value to complete the activity. The workflow process continues to the next activity.

6. Repeat steps 2 through 5 for the activities that you completed during this tutorial.

   *Note:* A workflow can be configured to display the activities that are associated with a milestone or task on the **Workflow Milestones** tab and in the Workflow Milestones report for a version in the SAS Model Manager client application. From the **Workflow Milestones** tab you can view the status of milestones or tasks that are associated with activities in the workflow.
Create Model Comparison Reports

In this exercise, you create several model comparison reports that are used in the selection and approval of a champion model. After you create the reports, you view the reports in the Reports folder. The reports enable you to evaluate candidate models in a version or across versions by assessing the structure, performance, and resilience of your models.

Create a Model Profile Report

The Model Profile report creates three tables to display the profile data that is associated with the model input variables, output variables, and target variables. To create this report, follow these steps:


2. In the New Report window, use the specified values for these fields and click OK:

   **Type**
   - select Model Profile Report.

   **Format**
   - select PDF. PDF is the default value, and it might already be the value for Format.

   **Style**
   - select Seaside. SAS default is the default style for the SAS format that is selected. For example, the default style for the HTML format is HTMLBLUE.

   **Select Models**
   - select the box for Model 1.

   **Report Properties**
   - replace the default report name with the report name profile_model1 in the Name field.

Here is the New Report window at this point in the process. Click OK when you are finished.
3. When the information dialog box confirms that the report was created successfully, click **Close**.

**Create a Delta Report**

The Delta report compares the profile data for two models and notes the differences. To create this report, follow these steps:

1. Expand the 2012 version in the **Delinquency** project and right-click the **Reports** folder. Then select **Reports ➪ New Report**. The New Report window appears.

2. In the New Report window, use the specified values for these fields and click **OK**:
   - **Type** select Delta Report.
   - **Format** select HTML.
   - **Style** select SAS default. **SAS default** is the default style for the SAS format that is selected. For example, the default style for the HTML format is HTMLBLUE.
   - **Select Models** select the boxes for **Model 1** and **Model 2**.
   - **Report Properties** replace the default report name with the report name **delta_mod1mod2** in the **Name** field.

Here is the New Report window at this point in the process. Click **OK** when you are finished.
3. When the information dialog box confirms that the report was created successfully, click Close.

**Create a Dynamic Lift Report**

The Dynamic Lift report provides visual summaries of the performance of one or more models for predicting a binary outcome variable performance. To create this report, follow these steps:


2. In the New Report window, specify the following options and click OK:

   **Type**
   select Dynamic Lift Report.

   **Format**
   select PDF.

   **Style**
   select Seaside. SAS default is the default style for the SAS format that is selected.

   **Select Models**
   select the boxes for Model 1 and Model 3.

   **Report Properties**
   replace the default report name with the report name lift_mod1mod3 in the Name field.
Here is the New Report Wizard at this point in the process. Click OK when you are finished.

![New Report Wizard](Image)

3. When the information dialog box confirms that the report was created successfully, click Close.

**View a Model Comparison Report**

To view a model comparison report, follow these steps:

1. Expand the version folder 2012 and the Reports folder.
2. Right-click the report name and select View Report.

*Note:* If user credentials are required, then specify a user ID and password that have permission to access the SAS Content Server.

3. Use the PDF viewer to distribute or print a copy of the report.
4. Close the PDF Viewer.

For a detailed description of the model comparison reports, see the *SAS Model Manager: User's Guide*.

**Update the Life Cycle (Optional)**

To update the Development milestone, follow these steps:
1. In the Delinquency project, expand 2012 Life Cycle Development.
2. Select the Create comparison reports task. Select the Status box and select Completed.
3. Select Create comparison reports. The Completed Date and Completed By fields have been updated with today's date and your user ID.
4. Click the Life Cycle node to examine its properties. The value for Date Modified is today's date. The Development property displays a bar chart that shows the percentage of completed tasks for this milestone.

**Update the Workflow Process (Optional)**

To complete the activities in the associated workflow process, follow these steps:

1. Select Tools My Workflow Inbox or click from the SAS Model Manager main window to view the workflow process activities in your workflow inbox. Workflow Console is launched in a Web browser, and displays the Activities category view.

   *Note:* The list displays only the activities for which you are the actual owner or are assigned as a potential owner, and that have the state of Started.

2. From the Activities category view, select an activity name, and click .

   *Note:* You can select an activity name and click to release an activity that you had previously claimed.

3. (Optional) Enter a property value or change an existing property value in the Properties pane.

4. (Optional) Add a comment to the activity using the Comments pane.

5. Select a status value to complete the activity. The workflow process continues to the next activity.
6. Repeat steps 2 through 5 for the activities that you completed during this tutorial.

Note: A workflow can be configured to display the activities that are associated with a milestone or task on the **Workflow Milestones** tab and in the Workflow Milestones report for a version in the SAS Model Manager client application. From the **Workflow Milestones** tab you can view the status of milestones or tasks that are associated with activities in the workflow.

Note: For more information, see Chapter 11, “Tutorial 10: Using Workflow Console,” on page 221.

**Using the Annotations View**

In this exercise, you use the **Annotations** view to examine the time-stamped event log, add text information to a model component, and examine the synopsis of the project and model reports. The Annotations view is the lower left pane of the SAS Model Manager window.

**View History**

To view the event log for the different components of a project, follow these steps:

1. Select the **Delinquency** project.

2. In the **Annotations** view, click the **History** tab. This tab displays a time-stamped entry each time you create, modify, import, publish, export, or delete a component. SAS Model Manager records the following information:

   - The date and time that the action occurred
   - The user ID that performed the action
   - The action that was performed
Here is an example of the History in the Annotations view:

View Notes

To create persistent annotations that are associated with the different components of a project, follow these steps:

1. Expand the 2012 version in the Delinquency project and select the Models folder.
2. In the Annotations view, click the Notes tab.
3. In the Add Notes field, enter Add first note for tutorial 2 models and click Add Notes.

Here is the Delinquency project note in the Annotations view:
View the Summary Information

The Summary contains information about the components that are contained in the selected folder.

To view summary information, follow these steps:

1. In the Project Tree, click the **Tutorial2** folder.

2. In the **Annotations** view, click the **Summary** tab.

3. Examine the information on this tab. SAS Model Manager includes general property information about the components that are part of this folder, aging information, number of reports, target information, and input information about the project.
Here is the Summary information for Tutorial2:

<table>
<thead>
<tr>
<th>Repository</th>
<th>Project Tree</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Tutorial2</td>
</tr>
<tr>
<td></td>
<td>Delinquency</td>
</tr>
<tr>
<td></td>
<td>2012</td>
</tr>
<tr>
<td></td>
<td>Documents</td>
</tr>
<tr>
<td></td>
<td>Life Cycle</td>
</tr>
<tr>
<td></td>
<td>Models</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Annotations - Tutorial2</th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>General Properties</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Number of Models</td>
<td>3</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Number of Versions</td>
<td>1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Number of Scoring Tasks</td>
<td>0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Nodes that are not currently in production</td>
<td>3</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Production Models Aging Report</th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1 - 90 days</td>
<td>0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>91 - 180 days</td>
<td>0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>181 - 270 days</td>
<td>0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>271 - 365 days</td>
<td>0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>366 - 730 days</td>
<td>0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>&gt; 730 days</td>
<td>0</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Summary of Reports</th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Reports</td>
<td>3</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Model Target Variable Report</th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>EAD</td>
<td>3</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Model Input Variable Report</th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>AGE</td>
<td>3</td>
<td></td>
<td></td>
</tr>
<tr>
<td>NUMCARDS</td>
<td>2</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The information on the Summary tab dynamically reflects the contents of the selected node and its subnodes in the Project Tree. If you select MMRoot, you see summary information for all nodes in the Project Tree. If you select a project, the summary information reflects the project and all nodes within that project.

**Scoring Models**

In this exercise, you create a scoring task that is used to run the score code of a model and produce scoring results. You use the results to determine the scoring accuracy and to analyze the model performance. The scoring task uses data from a scoring task input table, and then generates the results in a scoring task output table.
Create a Scoring Task


2. Specify the following options and click Next:

   **Name**
   - enter M1 for the scoring task name.

   **Description**
   - enter test1.

   **Model**
   - select Model 1. This model controls the available values for the input and output tables.

   **Scoring task type**
   - select Test.

   **Tip:** A best practice is to start all scoring tasks with Test selected. When a scoring task is run as type Test, the results are not overwritten. You can change the type to Production after you are satisfied with the scoring task results and when the model is ready for production.

3. Verify that the output variables are mapped to the model variables. The variable mapping is as follows:

<table>
<thead>
<tr>
<th>Output Variable</th>
<th>Model Variable</th>
</tr>
</thead>
<tbody>
<tr>
<td>AGE</td>
<td>AGE</td>
</tr>
<tr>
<td>CUSTKEY</td>
<td>CUSTKEY</td>
</tr>
<tr>
<td>EVERDEFAULT</td>
<td>EVERDEFAULT</td>
</tr>
<tr>
<td>GENDER</td>
<td>GENDER</td>
</tr>
</tbody>
</table>
Select the **M1** scoring task to examine its properties. The value for **Date Modified** is today’s date. To change the scoring task name or model input and output tables, you must create a new scoring task.

### Execute a Scoring Task

1. Verify that you have mapped the model output variables to the scoring task output variables. For more information, see “Map Model Variables to Project Variables” on page 54.

2. Validate the input variables. Expand the **Scoring Tasks** folder, select the **M1** scoring task and click the ![toolbar button](image). Examine the results of **Quick Check**, and then click **OK**.

3. Right-click the **M1** scoring task and select **Execute**.

4. When the information dialog box confirms that the report was created successfully, click **Close**. To view the results, click the **Results** tab and click **Result Set**.

If the scoring task was not successful, then review the **Log** tab for error messages.

5. Click the **Graph** tab to graph the results.
a. Click **Graph Wizard**, select **Histogram**, and then click **Next**.

b. In the upper right corner, click **Use default assignments** and then click **Next**.

c. Click the **Column name box** and select **AGE**.

d. Click the **Operator** box and select **Greater than**.

e. In the **Value** field, enter **50**. Click **Next**.

f. In the **Title** field of the Chart Titles page, type **M1 Age**. Click **Next** and then click **Finish**.

Here is the histogram on the **Results** tab:

6. Expand the M1 scoring task to verify that four content files were saved and that the value for **Date Modified** is today's date.

Here is the **Scoring Tasks** folder and the files for the M1 scoring task:

---

**Update the Life Cycle (Optional)**

To update the Development milestone, follow these steps:

1. In the Delinquency project, expand **2012 ⇒ Life Cycle ⇒ Development**.

2. Select the **Score models** task. Click the **Status** box and select **Completed**.

3. Select **Score models**. The **Completed Date** and **Completed By** fields have been updated with today's date and your user ID.
4. Click the Life Cycle node to examine its properties. The value for Modification Date is today's date. The Development property displays a bar chart that shows the percentage of completed tasks for this milestone.

![Life Cycle node in SAS Model Manager](image)

**Update the Workflow Process (Optional)**

To complete the activities in the associated workflow process, follow these steps:

1. Select **Tools ⇒ My Workflow Inbox** or click from the SAS Model Manager main window to view the workflow process activities in your workflow inbox. Workflow Console is launched in a Web browser, and displays the Activities category view.

   *Note:* The list displays only the activities for which you are the actual owner or are assigned as a potential owner, and that have the state of Started.

2. From the Activities category view, select an activity name, and click .

   *Note:* You can select an activity name and click to release an activity that you had previously claimed.

3. (Optional) Enter a property value or change an existing property value in the Properties pane.

4. (Optional) Add a comment to the activity using the Comments pane.

5. Select a status value to complete the activity. The workflow process continues to the next activity.

![Workflow Console](image)

6. Repeat steps 2 through 5 for the activities that you completed during this tutorial.
Note: A workflow can be configured to display the activities that are associated with a milestone or task on the Workflow Milestones tab and in the Workflow Milestones report for a version in the SAS Model Manager client application. From the Workflow Milestones tab you can view the status of milestones or tasks that are associated with activities in the workflow.

Note: For more information, see Chapter 11, “Tutorial 10: Using Workflow Console,” on page 221.

Declare a Champion Model

In this exercise you declare a champion model.

Set the Champion Model

To set a champion model, follow these steps:

1. Expand the Models folder in the 2012 version. Right-click Model 1, select Set as Champion, and click Yes to confirm.
2. Verify that the ✓ icon appears next to the champion model and the version.
3. Select the version folder to examine its properties. The value for Date Modified is today’s date. The value for the Champion Model ID is the champion model’s UUID.

   Tip: To document the reasons or assumptions for your selection of the champion model, use the version Notes tab. SAS Model Manager automatically annotates the History tab. For more information, see “Using the Annotations View” on page 62.

Update the Life Cycle (Optional)

To update the Development milestone, follow these steps:

1. In the Delinquency project, expand 2012 ⊳ Life Cycle ⊳ Development.
2. Select the Set a champion model task. Click the Status box and select Completed.
3. Select the Sign-off task to indicate that all of the Development milestone tasks are complete. Click the Status box and select Completed.
4. Select the **Set a champion model** and **Sign-off** tasks. The **Date Completed** and **Completed By** fields have been updated with today's date and your user ID.

5. Expand the **Test** milestone. Select the **Validate score input data** task. Click the **Status** box and select **Completed**.

   **Note:** The **Set a champion model** task must have been completed before you can complete this task.

6. Click the **Life Cycle** node to examine its properties. The value for **Date Modified** is today's date. The **Development** and **Test** properties display a bar chart that shows the percentage of completed tasks for this milestone.

---

**Update the Workflow Process (Optional)**

To complete the activities in the associated workflow process, follow these steps:

1. Select **Tools ⇒ My Workflow Inbox** or click 📬 from the SAS Model Manager main window to view the workflow process activities in your workflow inbox. Workflow Console is launched in a Web browser, and displays the Activities category view.

   **Note:** The list displays only the activities for which you are the actual owner or are assigned as a potential owner, and that have the state of **Started**.

2. From the Activities category view, select an activity name, and click 📩.

   **Note:** You can select an activity name and click 📩 to release an activity that you had previously claimed.

3. (Optional) Enter a property value or change an existing property value in the Properties pane.

4. (Optional) Add a comment to the activity using the Comments pane.
5. Select a status value to complete the activity. The workflow process continues to the next activity.

6. Repeat steps 2 through 5 for the activities that you completed during this tutorial.

*Note:* A workflow can be configured to display the activities that are associated with a milestone or task on the Workflow Milestones tab and in the Workflow Milestones report for a version in the SAS Model Manager client application. From the Workflow Milestones tab you can view the status of milestones or tasks that are associated with activities in the workflow.

*Note:* For more information, see Chapter 11, “Tutorial 10: Using Workflow Console,” on page 221.

---

**Query for the Remaining Project Tasks to Complete**

In this example, you search for the status of life cycle tasks by using the Query utility.

To search for the status of life cycle tasks, follow these steps:

1. Right-click the **Tutorial2** folder and select **Query**. The Query window appears.
2. Click the **Life Cycle** tab. Select the **User** box, select **MM Tutorial Assignees**, and then click **Find**.
3. Examine the status of the associated milestones and click **OK**. The search results display tasks in the **Assignee** list that are assigned to the user and tasks in the **Approver** list that the user is assigned to approve. The **Assignee** query results return only the tasks that have a status of **Started** or **Not Started**. Results that have a status of **Complete** or **Approved** are omitted.
Query for the Remaining Project Tasks to Complete

Specify values to use for the query.

<table>
<thead>
<tr>
<th>Model</th>
<th>Component</th>
<th>Life Cycle</th>
</tr>
</thead>
</table>

User: [Field]

Assignee:

Name | Project | Version | Milestone | Status | Path |
-----|---------|---------|-----------|--------|------|
[Values] | [Values] | [Values] | [Values] | [Values] | [Values] |

Approver:

Name | Project | Version | Milestone | Status | Path |
-----|---------|---------|-----------|--------|------|
[Values] | [Values] | [Values] | [Values] | [Values] | [Values] |
Chapter 4
Tutorial 3: Importing Models, Scheduling Scoring Tasks, and Creating Reports

Overview of Importing Models, Scheduling Scoring Tasks, and Creating Reports .................................................. 76

Prerequisites .................................................................................................................................................. 76
  Tutorial 3 Models and Data Sets ........................................................................................................... 76
  Verify Your User ID as a Member of SAS Model Manager User Groups ........................................... 76

Organize the Model Hierarchy .................................. 77
  Create a Folder ......................................................... 77
  Create a New Project ................................................ 77
  Define the Project Properties ...................................... 79
  Create a Version .................................................... 80
  Create a Workflow (Optional) ..................................... 81
  Update the Life Cycle (Optional) ............................... 83
  Update the Workflow Process (Optional) ............... 84

Import Models ......................................................... 85
  Import Models from a SAS Metadata Repository .............................................................................. 85
  Import PMML Models ............................................. 86
  Import Model Package Files .................................... 87
  Map Model Variables to Project Variables .................. 88
  Update the Model Life Cycle (Optional) .................... 89
  Update the Workflow Process (Optional) ............... 90

Create Model Comparison and Summary Reports .................. 91
  Create a Model Profile Report .................................. 91
  Create a Delta Report ............................................ 92
  Create a Dynamic Lift Report .................................. 93
  Create an Interval Target Variable Report ................. 94
  Training Summary Data Set Report (Optional) .......... 95
  View a Model Comparison and Summary Reports ..... 97
  Update the Life Cycle (Optional) ............................... 98
  Update the Workflow Process (Optional) ............... 98

Scoring Models ......................................................... 99
  Create a Scoring Task ............................................ 99
  Schedule a Scoring Task ........................................ 100
  View and Graph Scoring Results ............................... 102
  Update the Life Cycle (Optional) ............................... 103
  Update the Workflow Process (Optional) ............... 104

Declare a Champion Model ........................................ 105
  Set the Champion Model ....................................... 105
  Set the Challenger Model .................................... 106
Overview of Importing Models, Scheduling Scoring Tasks, and Creating Reports

SAS Model Manager provides several methods to import SAS models into a project version. You can import your models into a project version from the SAS Metadata Repository, SAS Enterprise Miner or SAS/STAT model package files, SAS code, R models, and PMML models. SAS macros are also available so that you can use SAS code to import or register SAS models into your project version.

SAS Model Manager provides several model comparison reports that are used in the selection and approval of a champion model. After you create the reports, you view the reports in the Reports folder. The reports enable you to evaluate candidate models in a version or across versions by assessing the structure, performance, and resilience of your models.

Instead of executing a scoring task from the SAS Model Manager Project Tree, you can schedule a scoring task to run on a particular date and time. You can also schedule how often you want the scoring task to run. Advanced settings enable you to set the scheduling server, the batch server to run the scoring task, and the location of the scoring job definition in the SAS Metadata Repository.

The tutorial provides examples and step-by-step directions for performing these tasks.

Prerequisites

Tutorial 3 Models and Data Sets

The exercises in this tutorial require that the Tutorial 3 data sets and models from SMM121Tutorial.zip be extracted and registered in SAS Management Console. If they have not been extracted and registered, see “Prepare Tutorial 3 Data Sets and Models” on page 8 to extract and register the files.

Importing models requires that you know where the SAS Model Manager administrator installed the Tutorial 3 models. If you do not know the location of the models, contact your SAS Model Manager administrator.

Verify Your User ID as a Member of SAS Model Manager User Groups

This exercise ensures that your user ID is a member of the MM Tutorial Assignees group and the Model Manager Advanced Users group.

1. Open SAS Management Console and log on to the SAS Metadata Server.
2. On the Plug-ins tab, select User Manager.
3. In the right pane, double-click the MM Tutorial Assignees group and click the Members tab.
4. Review the Current Members list, and locate your user ID or a group that your user ID is a member of. If your user ID or group is not a member of the MM Tutorial Assignees group, ask your administrator to add you to this group. Close the properties window.

5. Find and double-click your user ID in the right pane of SAS Management Console.

6. Click the Groups and Roles tab. Review the Member of pane and locate the group Model Manager Advanced Users. If your user ID is not a member of this group, ask your administrator to add you to this group. Close the properties window.


---

Organize the Model Hierarchy

In this exercise, you create an organizational folder, a project, and a version for the modeling project.

Create a Folder

To provide an organizational folder to manage your modeling projects, follow these steps:

1. Right-click the MMRoot node in the Project Tree and select New ⇒ New Folder. The New Folder dialog box appears.
2. Specify the following folder properties and click OK:
   - Name
     enter Tutorial3.
   - Description
     enter an optional folder description.

The new folder appears in the Project Tree.

Create a New Project

To create a project that is associated with the classification model function, follow these steps:

2. Specify the following project properties and click Next:
   - Name
     enter Loan for the project name.
   - Description
     enter an optional description.
   - Model Function
     select Classification.
3. In Step 2 of the New Project Wizard, specify the project variables:
a. Click the **Import Variables** button for the **Project Input Variables** table. Double-click **Shared Data** \( \rightarrow \) **Model Manager** \( \rightarrow \) **Tutorial3**. Select HMEQ_PROJECT_INPUT and click OK.

b. For the **Loan** classification project, click the **Import Variables** button for the **Project Output Variables** table. Select HMEQ_PROJECT_OUTPUT and click OK.

c. Click **Finish**.

4. Examine the **Tutorial3** folder to verify that it contains the projects.

To create a project that is associated with the prediction model function, follow these steps:

1. Right-click the **Tutorial3** folder and select \( \Rightarrow \) **New** \( \Rightarrow \) **New Project**. The New Project Wizard appears.

2. Specify the following project properties and click **Next**.

   **Name**
   
   enter **HMEQ-Interval** for the project name.

   **Description**
   
   enter an optional description.

   **Model Function**
   
   select **Prediction**.

3. In Step 2 of the New Project Wizard, specify the project variables:

   a. Click the **Import Variables** button for the **Project Input Variables** table. Double-click **Shared Data** \( \rightarrow \) **Model Manager** \( \rightarrow \) **Tutorial3**. Select HMEQ_PROJECT_INPUT and click OK.

   b. For the **HMEQ-Interval** prediction project, click the **Add** button for the **Project Output Variables** table. Enter the following project variable properties and click OK.

      **Name**
      
      enter **P_DEBTINC**

      **Description**
      
      enter an optional description.

      **Type**
      
      select **N**.

      **Measurement**
      
      enter **INTERVAL**.

      **Measurement**
      
      enter **8**.

   c. Click **Finish**.

4. Examine the **Tutorial3** folder to verify that it contains the projects.
**Define the Project Properties**

To define the properties that SAS Model Manager uses to create reports and score models, follow these steps:

1. Select the project in the **Tutorial3** folder and expand **Specific Properties** in the right pane.

2. Specify the default data tables and model variables for the project:

   - **Default Test Table**
     select HMEQ_TEST.

   - **Default Train Table**
     select HMEQ_TRAIN.

   - **Training Target Variable**
     enter BAD for the Loan project that has a model function type of classification.
     enter DEBTINC for the HMEQ-Interval project that has a model function type of prediction.

   - **Target Event Value**
     enter 1 for the Loan project that has a model function type of classification.

   - **Class Target Level**
     select Binary for the Loan project that has a model function type of classification.
     select Interval for the HMEQ-Interval project that has a model function type of prediction.

   - **Output Event Probability Variable**
     select score for the Loan project that has a model function type of classification.

   - **Output Prediction Variable**
     select P_DEBTINC for the HMEQ-Interval project that has a model function type of prediction.

Here is an example of the Loan project properties:
Create a Version

Create a version for the project. The version folder contains life cycle information, auxiliary version documents, candidate model files, model comparison reports, resource files, scoring tasks, and model performance reports.

To create a new version, follow these steps:

1. Right-click the Loan project and select New ➔ New Version. The New Version dialog box appears.

2. Specify the following version properties and click OK.
   
   **Name**   
   enter 2012.

   **Life Cycle Template**   
   select the user-defined template **Tutorial Life Cycle** that you created in the first tutorial. For more information, see “Create a Life Cycle Template” on page 29.

   **Note:** If you are using a workflow process to track the progress of your project or version, you can select any life cycle template. You can then skip all tasks to update the life cycle.

3. Examine the Loan project to verify that it contains one version called 2012. Select Life Cycle. Verify that the Name property is Tutorial Life Cycle.
4. Repeat steps 1 through 3 for the HMEQ-Interval project.

Note: To use a workflow process to track the progress of your version, send a request to a SAS Model Manager administrator to create a workflow to use for the tutorials. Include the name and UUID of the version with which you want the workflow to be associated.

Create a Workflow (Optional)

Overview
A workflow is a copy of a workflow process definition. Only a SAS Model Manager administrator can create a new workflow. Each workflow consists of activities. Activities can contain properties and comments so that you can share information with other users, or make notes. The status that you select when completing an activity determines the next activity in the workflow process.

Prerequisites
The exercises in this tutorial require that you have made the workflow process definition available to SAS Model Manager. For more information, see “Prepare for Using SAS Workflow” on page 18.

Create a New Workflow
1. Log on to SAS Model Manager as a member of the Model Manager Administrator Users group.

2. From the SAS Model Manager main window, right-click a version and select New Workflow. Workflow Console is launched in a Web browser and displays the New Workflow window.

Note: If you are already logged on to Workflow Console, from the Workflow Definitions category view, select a process definition and click .
3. Select the workflow definition that is associated with this tutorial (if you accessed the New Workflow window from the SAS Model Manager main window).

4. Enter a name for the workflow.

5. The UUID of the selected version is already populated.

   Note: If the UUID is not already populated, you can copy the UUID system property value for a version from the Properties view in the SAS Model Manager main window. The field label and other characters that precede the UUID value must be removed.

6. (Optional) Enter a description for the workflow.

7. Click OK. A message appears, indicating that the workflow has been successfully created.

8. Click Close. The new workflow is now available in the Workflows category view.

9. To view the new workflow, click Workflows. The Workflows category view appears. Select the workflow to view information that is associated with the new workflow.
The workflow process definitions that have been provided for the tutorials already have participants assigned. For information about how to assign additional participants to a workflow, see “Working with Workflow Participants” in Chapter 21 of *SAS Model Manager: User's Guide*. You can also see Chapter 11, “Tutorial 10: Using Workflow Console,” on page 221 to learn how to manage workflows and work with activities.

**Update the Life Cycle (Optional)**

To complete the milestone task of adding data sources and setting up the project in the Project Tree, follow these steps:

1. In the *Loan* project, expand 2012 ⇨ Life Cycle ⇨ Development.
2. Select the Define library in SAS Management Console task and examine the task properties. The To Be Completed By property, assigned in the life cycle template, determines which users or user groups from the Participants list are responsible for this milestone task. Because you are a member of the MM Tutorial Assignees group, you are authorized to update the task status.
3. Click the Status field and select Completed.
4. Select the Register data sets task and examine the task properties. Click the Status field and select Completed.
5. Select the Set up project in the Project Tree task. Click the Status box and select Completed.
6. Select all of the tasks whose status you updated and examine the properties. Verify that the value of the Date Completed property is today and that the value of the Completed By property is your user ID.
7. Select the Life Cycle node to examine its properties. The value for Date Modified is today's date. The Development property displays a bar chart that shows the percentage of completed tasks for this milestone.
8. (Optional) Repeat steps 1 through 7 for the HMEQ-Interval project.

**Update the Workflow Process (Optional)**

To complete the activities in the associated workflow process, follow these steps:

1. Select **Tools ⇒ My Workflow Inbox** or click [click here](#) from the SAS Model Manager main window to view the workflow process activities in your workflow inbox. Workflow Console is launched in a Web browser, and displays the Activities category view.

   *Note:* The list displays only the activities for which you are the actual owner or are assigned as a potential owner, and that have the state of **Started**.

2. From the Activities category view, select an activity name, and click [click here](#).

   *Note:* You can select an activity name and click [click here](#) to release an activity that you had previously claimed.

3. (Optional) Enter a property value or change an existing property value in the Properties pane.

4. (Optional) Add a comment to the activity using the Comments pane.

5. Select a status value to complete the activity. The workflow process continues to the next activity.

6. Repeat steps 2 through 5 for the activities that you completed during this tutorial.

   *Note:* A workflow can be configured to display the activities that are associated with a milestone or task on the **Workflow Milestones** tab and in the Workflow
Milestones report for a version in the SAS Model Manager client application. From the **Workflow Milestones** tab you can view the status of milestones or tasks that are associated with activities in the workflow.

**Note:** For more information, see Chapter 11, “Tutorial 10: Using Workflow Console,” on page 221.

---

**Import Models**

In this exercise you import models into SAS Model Manager from the SAS Metadata Repository, a PMML model file, and a SAS model package file. Then you map the model variables. Before you import the model, verify that the model type is identical to the value of the project **Model Function** property, classification, or prediction. For more information, see “Create a New Project” on page 77.

**Import Models from a SAS Metadata Repository**

If your SAS Enterprise Miner 5.3 (or later) model files are registered in the SAS Metadata Repository, then you can use SAS Model Manager to import the files.

To import a model that is registered with SAS Enterprise Miner, follow these steps to understand the process:

1. Expand the **2012** version in the **Loan** project and right-click the **Models** folder. Then select **Import from ⇒ SAS Metadata Repository**. The SAS Metadata Repository dialog box appears.

2. Navigate to the location of the folder that contains the SAS Enterprise Miner models. Select a model from the folder.
3. Click OK. After SAS Model Manager processes the request to import the model, the new model appears in the Models folder of your project's version.

**Import PMML Models**

PMML (Predictive Modeling Markup Language) is an XML-based standard for representing data mining results. PMML is designed to enable the sharing and deployment of data mining results between vendor applications and across data management systems. You can use SAS Model Manager to import PMML 3.1 (or later) models that are produced by another software application, such as SAS Enterprise Miner. PMML 4.0 (or later) is supported by SAS Model Manager for creating DATA step score code when importing models. This enables a PMML model to be included in scoring tasks, reporting, and performance monitoring.

To import a PMML model, follow these steps:

1. Expand the 2012 version in the Loan project and right-click the Models folder. Then select Import From ⇒ PMML Model File. The PMML Model File dialog box appears.

2. In the PMML model name field, enter Neural.

3. Navigate to the location of the folder that contains the PMML files. For this example, use `<drive>:\Tutorial3\Samples\Neural` that was installed by the SAS Model Manager administrator. For more information, see “Prepare Tutorial 3 Data Sets and Models” on page 8.

4. Select the Neural.xml file and click OK.
5. Examine the Models folder to verify that it contains the models. Right-click the folder and select Expand All to examine the model file.

**Import Model Package Files**

SAS Enterprise Miner and SAS/STAT linear model package files, or SPK files, contain complete model information. You can import SAS Enterprise Miner and SAS/STAT models even if they are not registered in the SAS Metadata Repository. For information about how to create a package file, see the *SAS Model Manager: User's Guide*.

To import a model that was saved as a SAS package file, follow these steps:

1. Expand the 2012 version in the Loan project and right-click the Models folder. Then select Import From ⇒ SAS Model Package File. The SAS Model Package File dialog box appears.

2. In the Model Name field, enter Reg 1.

3. Navigate to the location of the folder that contains the SAS model package files. For this example, use `<drive>:\Tutorial3\Samples\Reg1` that was installed by the SAS Model Manager administrator. For more information, see “Prepare Tutorial 3 Data Sets and Models” on page 8.

4. Select the `miningResult.spk` file and click OK.
5. Repeat steps 2 through 4 to import a second package file that is located in `<drive:>`\Tutorial3\Samples\Tree1. Name the model Tree 1.

6. (Optional) Repeat steps 2 through 4 to import a third package file that is located in `<drive:>`\Tutorial3\Samples\HMEQ_STAT_Item. Name the model HMEQ_STAT_Item.

7. Repeat steps 2 through 4 in the 2012 version of the HMEQ-Interval project to import a prediction model with an interval target. The package file is located in `<drive:>`\Tutorial3\Samples\Reg1_Interval. Name the model Reg1_Interval.

8. Examine the Models folder to verify that it contains the models. Right-click the folder and select Expand All to examine the model files.

**Map Model Variables to Project Variables**

When the names for the model output variable are not identical to the names for the project output variables, you must map the variables.

To map model output variables to project output variables, follow these steps:

1. Map model variables for the first model. Select Neural in the Models folder, click the Model Mapping tab in the right pane, and click Edit. Set the following mapping and click OK:

<table>
<thead>
<tr>
<th>Project Variables</th>
<th>Model Variables</th>
</tr>
</thead>
<tbody>
<tr>
<td>score</td>
<td>P_BAD1</td>
</tr>
</tbody>
</table>

2. Map model variables for the second model. Select Reg 1 in the Models folder, click the Model Mapping tab in the right pane, and click Edit. Set the following mapping and click OK:

<table>
<thead>
<tr>
<th>Project Variables</th>
<th>Model Variables</th>
</tr>
</thead>
<tbody>
<tr>
<td>score</td>
<td>EM_EVENTPROBABILITY</td>
</tr>
</tbody>
</table>
3. Map model variables for the third model. Right-click Tree 1 in the Models folder, and select Set Model Output Mapping. Set the following mapping and click OK:

<table>
<thead>
<tr>
<th>Project Variables</th>
<th>Model Variables</th>
</tr>
</thead>
<tbody>
<tr>
<td>score</td>
<td>EM_EVENTPROBABILITY</td>
</tr>
</tbody>
</table>

4. Map model variables for the fourth model. Select HMEQ_STAT_Item in the Models folder, click the Model Mapping tab in the right pane, and click Edit. Set the following mapping and click OK:

<table>
<thead>
<tr>
<th>Project Variables</th>
<th>Model Variables</th>
</tr>
</thead>
<tbody>
<tr>
<td>score</td>
<td>P_BAD1</td>
</tr>
</tbody>
</table>

5. Map model variables for the fifth model. Right-click Reg1_Interval in the Models folder of the 2012 version in the HMEQ-Interval project, and select Set Model Output Mapping. Set the following mapping and click OK:

<table>
<thead>
<tr>
<th>Project Variables</th>
<th>Model Variables</th>
</tr>
</thead>
<tbody>
<tr>
<td>P_DEBTINC</td>
<td>P_DEBTINC</td>
</tr>
</tbody>
</table>

**Update the Model Life Cycle (Optional)**

To complete the milestone task for adding the models, follow these steps:

1. In the Loan project, expand 2012 $\Rightarrow$ Life Cycle $\Rightarrow$ Develop.

2. Select the Import models task. Select the Status box and select Completed. The Date Completed and Completed By fields have been updated with today's date and your user ID.

3. Click the Life Cycle node to examine its properties. The value for Date Modified is today's date. The Development property displays a bar chart that shows the percentage of completed tasks for this milestone.
4. (Optional) Repeat steps 1 through 3 for the HMEQ-Interval project.

**Update the Workflow Process (Optional)**

To complete the activities in the associated workflow process, follow these steps:

1. Select **Tools ⇒ My Workflow Inbox** or click ![from the SAS Model Manager main window to view the workflow process activities in your workflow inbox. Workflow Console is launched in a Web browser, and displays the Activities category view.

   *Note:* The list displays only the activities for which you are the actual owner or are assigned as a potential owner, and that have the state of **Started**.

2. From the Activities category view, select an activity name, and click ![.

   *Note:* You can select an activity name and click ![ to release an activity that you had previously claimed.

3. (Optional) Enter a property value or change an existing property value in the Properties pane.

4. (Optional) Add a comment to the activity using the Comments pane.

5. Select a status value to complete the activity. The workflow process continues to the next activity.

6. Repeat steps 2 through 5 for the activities that you completed during this tutorial.

   *Note:* A workflow can be configured to display the activities that are associated with a milestone or task on the **Workflow Milestones** tab and in the Workflow Milestones report for a version in the SAS Model Manager client application.
From the Workflow Milestones tab you can view the status of milestones or tasks that are associated with activities in the workflow.

Note: For more information, see Chapter 11, “Tutorial 10: Using Workflow Console,” on page 221.

Create Model Comparison and Summary Reports

In this exercise, you create several model comparison reports that are used in the selection and approval of a champion model. The Model Profile report can be created for any type of model. The Interval Target Variable report can be created only for a prediction model. After you create the reports, you view them in the Reports folder. The reports enable you to evaluate candidate models in a version or across versions by assessing the structure, performance, and resilience of your models.

Create a Model Profile Report

The Model Profile report creates three tables to display the profile data that is associated with the model input variables, output variables, and target variables. To create this report, follow these steps:

2. In the New Report window, use the specified values for these fields and click OK:
   - **Type**: select Model Profile Report.
   - **Format**: select PDF. PDF is the default value, and it might already be the value for Format.
   - **Style**: select Seaside. SAS default is the default style for the selected SAS format.
   - **Select Models**: select the box for Tree 1.
   - **Report Properties**: replace the default report name with the report name profile_tree1 in the Name field.
Here is the New Report window at this point in the process. Click OK when you are finished.

![New Report Window]

3. When the information dialog box confirms that the report was created successfully, click Close.

**Create a Delta Report**

The Delta report compares the profile data for two models and notes the differences. To create this report, follow these steps:


2. In the New Report window, use the specified values for these fields and click OK:

   - **Type**
     - select Delta Report.

   - **Format**
     - select HTML.

   - **Style**
     - select SAS default. SAS default is the default style for the selected SAS format. For example, the default SAS style for the HTML format is HTMLBLUE.

   - **Select Models**
     - select the boxes for Reg 1 and Tree 1.
Report Properties
replace the default report name with the report name `delta_reg1tree1` in the Name field.

Here is the New Report window at this point in the process. Click OK when you are finished.

3. When the information dialog box confirms that the report was created successfully, click Close.

Create a Dynamic Lift Report

The Dynamic Lift report provides visual summaries of the performance of one or more models for predicting a binary outcome variable performance. To create this report, follow these steps:


2. In the New Report window, specify the following options and click OK:

   - **Type**
     select Dynamic Lift Report.

   - **Format**
     select HTML.

   - **Style**
     select Seaside. SAS default is the default style for the selected SAS format.

   - **Select Models**
     select the boxes for Reg 1 and Tree 1.
Report Properties

replace the default report name with the report name \texttt{lift\_reg1tree1} in the Name field.

Here is the New Report Wizard at this point in the process. Click \textbf{OK} when you are finished.

3. When the information dialog box confirms that the report was created successfully, click \textbf{Close}.

\textbf{Create an Interval Target Variable Report}

The Interval Target Variable report creates two plots for you to view the actual versus predicted values for a model and the actual versus residual values for a model. This report can be created only for prediction models.

\textit{Note:} This report is created based on the sample data of the default test table. By default, the sample size is 1000 and the sample seed is 12345. When the sample size is less than or equal to 5000, the chart that is created in the report is a scatter plot. When the sample size is greater than 5000, the chart that is created in the report is a heat map. If you are using your own data sets and want to create an Interval Target Variable Report that contains a heat map, contact your SAS Administrator to request that the \textbf{Sample size for models with an interval target} configuration setting be changed to greater than 5000.

To create this report, follow these steps:


2. In the New Report window, specify the following options and click \textbf{OK}:
Type
select Interval Target Variable Report.

Format
select PDF.

Style
select Seaside. SAS default is the default style for the selected SAS format.

Select Models
select the box for Reg1_Interval.

Report Properties
replace the default report name with the report name reg1_interval in the Name field.

Here is the New Report Wizard at this point in the process. Click OK when you are finished.

3. When the information dialog box confirms that the report was created successfully, click Close.

Training Summary Data Set Report (Optional)

About
A Training Summary Data Set report creates frequency and distribution charts that summarize the train table variables. Using the default train table, SAS Model Manager generates data sets in the Resources folder that contain numeric and character variable summaries, and variable distributions. These data sets are used to create the summary
report. Before you can create the report, you must generate the training summary data sets.

In this exercise, you generate the training summary data sets and create a Training Summary Data Set report.

**Generate Training Summary Data Sets**

To generate the training summary data sets, follow these steps:


2. Select the 2012 version in the Loan project and verify that the Default Train Table property contains the train table for the report.

3. Right-click the 2012 version and select Generate Training Summary Data Set. The Generate Training Summary Data Set window appears.

4. Click Select All to select all variables. To only select a few variables for the report, select the box that is next to each variable in the Select column.

5. Click OK. SAS Model Manager creates data sets in the Resources folder.

**Create a Training Summary Data Set Report**

To generate a Training Summary Data Set report for a version, follow these steps:


2. In the New Report window, specify the following options and click OK:
Type
select **Training Summary Data Set Report**.

Format
select **HTML**.

Style
select **Seaside**. **SAS default** is the default style for the SAS format that is selected.

Select Models
Not applicable.

Report Properties
replace the default report name with the report name **TrainingSummaryDataSet_Loan2012** in the **Name** field.

Here is the New Report Wizard at this point in the process. Click **OK** when you are finished.

3. When the information dialog box confirms that the report was created successfully, click **Close**.

**View a Model Comparison and Summary Reports**

To view a model comparison report, follow these steps:

1. Expand the version folder **2012** and the **Reports** folder.
2. Right-click the report name and select **View Report**.

*Note:* If user credentials are required, then specify a user ID and password that have permission to access the SAS Content Server.
3. Use the PDF or HTML viewer to distribute or print a copy of the report.
4. Close the PDF or HTML viewer.

For a detailed description of the model comparison reports, see the *SAS Model Manager: User's Guide*.

**Update the Life Cycle (Optional)**

To update the Development milestone, follow these steps:

1. In the Loan project, expand 2012 ↦ Life Cycle ↦ Development.
2. Select the Create comparison reports task. Select the Status box and select Completed.
3. Select Create comparison reports. The Completed Date and Completed By fields have been updated with today's date and your user ID.
4. Click the Life Cycle node to examine its properties. The value for Date Modified is today's date. The Development property displays a bar chart that shows the percentage of completed tasks for this milestone.
5. (Optional) Repeat steps 1 through 4 for the HMEQ-Interval project.

**Update the Workflow Process (Optional)**

To complete the activities in the associated workflow process, follow these steps:

1. Select Tools ⇒ My Workflow Inbox or click from the SAS Model Manager main window to view the workflow process activities in your workflow inbox. Workflow Console is launched in a Web browser, and displays the Activities category view.

   *Note:* The list displays only the activities for which you are the actual owner or are assigned as a potential owner, and that have the state of Started.

2. From the Activities category view, select an activity name, and click .
Note: You can select an activity name and click to release an activity that you had previously claimed.

3. (Optional) Enter a property value or change an existing property value in the Properties pane.

4. (Optional) Add a comment to the activity using the Comments pane.

5. Select a status value to complete the activity. The workflow process continues to the next activity.

6. Repeat steps 2 through 5 for the activities that you completed during this tutorial.

Note: A workflow can be configured to display the activities that are associated with a milestone or task on the Workflow Milestones tab and in the Workflow Milestones report for a version in the SAS Model Manager client application. From the Workflow Milestones tab you can view the status of milestones or tasks that are associated with activities in the workflow.

Note: For more information, see Chapter 11, “Tutorial 10: Using Workflow Console,” on page 221.

Scoring Models

In this exercise, you create a scoring task that is used to run the score code of a model and produce scoring results. Then you schedule the scoring task to run on a particular date and time. You can also schedule how often you want the scoring task to run. You use the results to determine the scoring accuracy and to analyze the model performance. The scoring task uses data from a scoring task input table, and then generates the results in a scoring task output table.

Create a Scoring Task


2. Specify the following options:
Name
   enter Tree1 for the scoring task name.

Description
   enter test1.

Model
   select Tree 1. This model controls the available values for the input and output tables.

Scoring task type
   select Test.

   A best practice is to start all scoring tasks with Test selected. When a scoring task is run as type Test, the results are not overwritten. You can change the type to Production after you are satisfied with the scoring task results and when the model is ready for production.

3. To select the scoring input table, click Browse. In the Select Table window, select HMEQ_SCORE_INPUT from the SAS Metadata Repository tab.

4. To select the scoring output table, click Browse. In the Select Table window, select HMEQ_SCORE_OUTPUT from the SAS Metadata Repository tab.

5. Verify that the output variables are mapped to the model variables and click Finish.

6. Select the Tree1 scoring task to examine its properties. The value for Date Modified is today's date. To change the scoring task name or model input and output tables, you must create a new scoring task.

Schedule a Scoring Task

1. Validate the input variables. Expand the Scoring Tasks folder, select the Tree1 scoring task and click the toolbar button. Examine the results of Quick Check, and then click OK.
2. Right-click the **Tree1** scoring task and select **New Schedule**. The New Schedule window appears.

![New Schedule window](image)

3. To set how often to run the scoring task, select a time interval from the **Recurrence** list box. The default is None.

4. To set the time to run the job, select an hour from the **Hour** list box and select a minute from the **Minute** list box. Note the time that you used for this tutorial. It is recommended to schedule it 5 minutes out, so that you have time to complete the next couple of steps.

5. To set the start date, click the calendar and select a start date. The default is today’s date. Instead of using the calendar, you can select a month from the **Month** list box, select a day from the **Day** list box, and select a year from the **Year** list box.

6. (Optional) Click **Advanced**. Select the server that schedules the job from the **Scheduling server** list box. Select the batch server that runs the job from the **Batch server** list box. Click **Browse** to select a location for the scoring job definition in the SAS Metadata Repository. Click **OK**.

![Advanced settings](image)

7. Click **OK**. A dialog box message confirms that the schedule was created. Click **Close**.
View and Graph Scoring Results

To view the scoring task results, follow these steps:

1. Expand the Scoring Tasks folder, select the Tree1 scoring task.
2. Select the Job History tab to verify that the scheduled job for the Tree1 scoring task has completed.

   Note: If the scheduled time has passed, and the scheduled job is not shown as completed on the Job History tab, a SAS Model Manager administrator can refresh the content. To refresh, right-click the Tree1 scoring task, and select Update Job History.

Here is an example of two jobs that were executed for the same scoring task. The first completed successfully with warnings, and the second job completed successfully.

<table>
<thead>
<tr>
<th>Tree1</th>
<th>Properties</th>
<th>Model Input Variables</th>
<th>Input Table</th>
<th>Model Output Variables</th>
<th>Output Table</th>
<th>Pre-code</th>
<th>Post-code</th>
<th>SAS Code</th>
<th>Results</th>
<th>Graph</th>
<th>Job History</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Job Name</td>
<td>Job Status</td>
<td>Execution Status</td>
<td>Date Started</td>
<td>Date Completed</td>
<td>Log</td>
<td>Output</td>
<td>SAS Code</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Tree1</td>
<td>Completed</td>
<td></td>
<td></td>
<td>Sep 19, 2012 3:35:13 PM</td>
<td>Sep 19, 2012 3:35:16 PM</td>
<td>1.2</td>
<td>1.2</td>
<td>1.2</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Tree1</td>
<td>Completed</td>
<td></td>
<td></td>
<td>Sep 19, 2012 3:29:39 PM</td>
<td>Sep 19, 2012 3:30:48 PM</td>
<td>1.1</td>
<td>1.1</td>
<td>1.1</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

If the job completed with warnings or errors, view the taskCode.log file in the Tree1 scoring task folder before executing or scheduling the scoring task again.

   Note: To delete a schedule for a scoring task, right-click the scoring task and select Delete Schedule. To modify a schedule for a scoring task, you must delete the existing schedule and create a new schedule.

3. To view the results, click the Results tab and click Result Set.

If the scoring task was not successful, then review the Log tab for error messages.

4. Click the Graph tab to graph the results.
a. Click **Graph Wizard**, select **Histogram**, and then click **Next**.

b. Select **X** from the **Role** column for the **DEBTINC** variable and then click **Next**.

c. Click the **Column name box** and select **DEBTINC**.

d. Click the **Operator** box and select **Less than**.

e. In the **Value** field, enter 50. Click **Next**.

f. In the **Title** field of the Chart Titles page, type **Tree 1 Debt Income**. Click **Next** and then click **Finish**.

Here is the histogram on the **Results** tab:

![Histogram of Tree 1 Debt Income](image)

5. Expand the **Tree1** scoring task to verify that four content files were saved and that the value for **Date Modified** is today's date.

Here is the **Scoring Tasks** folder and the files for the **Tree1** scoring task:

![Scoring Tasks folder](image)

**Update the Life Cycle (Optional)**

To update the Development milestone, follow these steps:

1. In the **Loan** project, expand **2012 → Life Cycle → Development**.

2. Select the **Score models** task. Click the **Status** box and select **Completed**.
3. Select Score models. The Completed Date and Completed By fields have been updated with today's date and your user ID.

4. Click the Life Cycle node to examine its properties. The value for Modification Date is today's date. The Development property displays a bar chart that shows the percentage of completed tasks for this milestone.

5. (Optional) Repeat steps 1 through 4 for the HMEQ-Interval project.

**Update the Workflow Process (Optional)**

To complete the activities in the associated workflow process, follow these steps:

1. Select Tools ⇒ My Workflow Inbox or click  from the SAS Model Manager main window to view the workflow process activities in your workflow inbox. Workflow Console is launched in a Web browser, and displays the Activities category view.

   *Note:* The list displays only the activities for which you are the actual owner or are assigned as a potential owner, and that have the state of Started.

2. From the Activities category view, select an activity name, and click  .

   *Note:* You can select an activity name and click  to release an activity that you had previously claimed.

3. (Optional) Enter a property value or change an existing property value in the Properties pane.

4. (Optional) Add a comment to the activity using the Comments pane.

5. Select a status value to complete the activity. The workflow process continues to the next activity.
6. Repeat steps 2 through 5 for the activities that you completed during this tutorial.

Note: A workflow can be configured to display the activities that are associated with a milestone or task on the Workflow Milestones tab and in the Workflow Milestones report for a version in the SAS Model Manager client application. From the Workflow Milestones tab you can view the status of milestones or tasks that are associated with activities in the workflow.

Note: For more information, see Chapter 11, “Tutorial 10: Using Workflow Console,” on page 221.

---

**Declare a Champion Model**

In this exercise, you declare a champion model for each project.

**Set the Champion Model**

To assign a champion model, follow these steps:

1. Expand the Models folder in the 2012 version of the Loan project. Right-click Tree 1, select Set as Champion, and click Yes to confirm.

2. Expand the Models folder in the 2012 version of the HMEQ-Interval project. Right-click Reg1_Interval, select Set as Champion, and click Yes to confirm.

3. If there are model input variables that are not defined as project input variables, you are prompted to add the input variables. Click Yes to confirm. The model input variables are copied to the project input variables.

4. If project output variables are not defined, then the Select Project Output Variables window appears for you to select the output variables. After you select the output variables, click OK.

5. If the project output variable has not been mapped to the model output variable, the Set Model Output Mapping window appears. For each project variable, click the Model Variables field and select the model output variable. Click OK.

6. Verify that the ✓ icon appears next to the champion model and next to the 2012 version for each project.
Set the Challenger Model

You can set a challenger model after the champion model has been set. To set a challenger model, follow these steps:

1. Expand the Models folder in the 2012 version. Right-click Reg 1, select Flag as Challenger, and click Yes to confirm.

2. If there are model input variables that are not defined as project input variables, you are prompted to add the input variables. Click Yes to confirm. The model input variables are copied to the project input variables.

3. If the project output variable has not been mapped to the model output variable, the Set Model Output Mapping window appears. For each project variable, click the Model Variables field and select the model output variable. Click OK.

4. Verify that the icon appears next to the version folder.

Update the Life Cycle (Optional)

To update the life cycle milestones, follow these steps:

1. In the Loan project, expand 2012 \Life Cycle \Development.

2. Select the Set a champion model task. Click the Status box and select Completed.

3. Select the Sign-off task. Click the Status box and select Completed.

4. Click the Life Cycle node to examine its properties. The value for Date Modified is today's date. The Development property displays a bar chart that shows the percentage of completed tasks for this milestone.
**Update the Workflow Process (Optional)**

To complete the activities in the associated workflow process, follow these steps:

1. Select **Tools ⇒ My Workflow Inbox** or click 🔄 from the SAS Model Manager main window to view the workflow process activities in your workflow inbox. Workflow Console is launched in a Web browser, and displays the Activities category view.

   *Note:* The list displays only the activities for which you are the actual owner or are assigned as a potential owner, and that have the state of **Started**.

2. From the Activities category view, select an activity name, and click 🔄.

   *Note:* You can select an activity name and click 🔄 to release an activity that you had previously claimed.

3. (Optional) Enter a property value or change an existing property value in the Properties pane.

4. (Optional) Add a comment to the activity using the Comments pane.

5. Select a status value to complete the activity. The workflow process continues to the next activity.

6. Repeat steps 2 through 5 for the activities that you completed during this tutorial.

   *Note:* A workflow can be configured to display the activities that are associated with a milestone or task on the **Workflow Milestones** tab and in the Workflow Milestones report for a version in the SAS Model Manager client application. From the **Workflow Milestones** tab you can view the status of milestones or tasks that are associated with activities in the workflow.

   *Note:* For more information, see Chapter 11, “Tutorial 10: Using Workflow Console,” on page 221.
Overview of Publishing Models

SAS Model Manager provides a comprehensive publishing environment for model delivery that supports sharing model and performance data. SAS Model Manager publishes models to different channels, and to the SAS Metadata Repository. SAS Model Manager can also publish classification, prediction, and segmentation (cluster) models to a database, if the model has a score code type of SAS DATA step. SAS Model Manager cannot publish PMML models to a database. Application software, such as SAS Data Integration Studio or SAS Enterprise Guide, enables you to access models through the SAS Metadata Server and to submit on-demand and batch scoring jobs.

SAS Model Manager publishes models to defined publication channels. Authorized users who subscribe to a channel can choose to receive e-mail notifications when updated models are ready to deploy to testing or production scoring servers, and are published to a publication channel. From a publication channel, you can extract and validate the scoring logic, deploy models to a production environment, and monitor the performance of your models.

The tutorial provides examples and step-by-step directions for performing these tasks.
Prerequisites

Models Used in Tutorial 3

The exercises in this tutorial depend on some of the properties of the specific models that were added in Chapter 4, “Tutorial 3: Importing Models, Scheduling Scoring Tasks, and Creating Reports,” on page 75. Use the projects, versions, or models that are specified here. This tutorial is designed to follow Tutorial 3.

Prepare a Database for Use with SAS Model Manager

To publish a model to a database from the SAS Model Manager, the Database Administrator (DBA) needs to prepare the database. The SQL scripts for Teradata that are required for this tutorial are on your local computer after you extract them from the ZIP file SMM121Tutorial.zip. If you have not extracted the tutorial files, see “Install and Register the Tutorial Files” on page 3.

Note: Contact your system administrator if you do not have the appropriate permissions to the installation and configuration directories on the SAS Model Manager server.

Note: For more information, see “Preparing a Database for Use with SAS Model Manager” in Chapter 8 of SAS In-Database Products: Administrator's Guide.

Publish Models

In this exercise, you use the comprehensive publishing environment for model delivery to share models. Model delivery most often includes model score code and its associated input and output metadata. You publish a model and the champion model for a project to the SAS Metadata Repository and publish a model to a publish channel. In the next exercise you publish a champion or challenger model to a database. Application software, such as SAS Data Integration Studio or SAS Enterprise Guide, can access the MiningResult object through the SAS Metadata Server and submit on-demand or batch scoring jobs.

Publish a Model to the SAS Metadata Repository

SAS Model Manager uses the SAS Folder view to publish the model to any folder that is accessible to the user. You can publish a model to folders in the SAS Foundation repository or to folders in custom repositories that are created in SAS Management Console to reflect the structure of your business organization.

Note: SAS Model Manager cannot publish R models.

To publish a model to a SAS Metadata Repository, follow these steps:

1. Expand Loan ➔ 2012 ➔ Models and right-click the Tree 1 model. Then select Publish Model. The SAS Metadata Repository dialog box appears.

2. Navigate to the folder where you want to store the model.
3. Enter **Tree 1** as the name and click **Save**. If a MiningResult object exists in the same folder and has the same name or model UUID, then you are prompted to decide whether to overwrite the metadata for this stored object.

**CAUTION:**

Do not overwrite an existing MiningResult object unless you are certain that the model is from the same project in SAS Model Manager.

*Note:* If you change the score code for the model, then publish the model again to ensure that your score application uses the current scoring code.

4. In the Publish Model message box, click **Close**.

---

**Verify the Published Model**

**View Publish History**

After you have published a model to the SAS Metadata Repository, to a SAS channel, or to a database, you can view the publish history in the version, project, **MMRoot** node details pane. To view the publish history, select the **2012** version in the **Loan** project, and select the Publish History tab. Select an item from the list to view the publish details.
To view a Published Model in the SAS Metadata Repository, follow these steps:

1. Open SAS Management Console and log on to the SAS Metadata Server using the same user ID that you use to log on to SAS Model Manager.

2. Click the Folders tab and expand the folders to locate the model that you exported. When you select the folder, the right pane lists the MiningResult objects for the exported models.

3. Right-click the Tree 1 MiningResult object and select Properties from the pop-up menu. The Properties window appears.

View a Published Model in the SAS Metadata Repository

To verify that SAS Model Manager successfully created the MiningResult object in the SAS Metadata Repository for a published model, use SAS Management Console. To view the contents of the published model or project, you can use SAS Data Integration Studio. You can also use SAS Management Console to export the MiningResult object to a SAS package.

To view a MiningResult object in the metadata repository, follow these steps:

1. Open SAS Management Console and log on to the SAS Metadata Server using the same user ID that you use to log on to SAS Model Manager.

2. Click the Folders tab and expand the folders to locate the model that you exported. When you select the folder, the right pane lists the MiningResult objects for the exported models.

3. Right-click the Tree 1 MiningResult object and select Properties from the pop-up menu. The Properties window appears.
4. Examine the **Keywords** box on the **General** tab to verify that the MiningResult object contains the universal unique identifier (UUID) of the exported model. The UUID is a system property that SAS Model Manager automatically assigns to each model. To view a system property in SAS Model Manager, click the + icon beside the **System Properties** heading to expand the section.

![T I P](image)

You can use the UUID to conduct filtered searches and query the published models. For more information, see the *SAS Model Manager: User's Guide*.

5. Examine the metadata on the **Advanced** tab to determine when the MiningResult object was created or most recently updated.

6. Click **OK**.

---

**Publish the Champion Model to the SAS Metadata Repository**

To publish the champion model, you must have already assigned the champion model for the project. SAS Model Manager examines the project and always publishes the champion model for the project. When the champion model for a project changes and you publish the model again at the project level, the scoring application automatically uses the latest score code.

To publish the champion model for a project, follow these steps:

1. Verify that the project has a default version assigned. Select the **Loan** project folder to examine its properties. The **Default Version** property contains the name of the default version.
2. Right-click the Loan project and select Publish Model to SAS Metadata Repository from the pop-up menu. Click Yes for the information message that the project is unlocked. The SAS Metadata Repository dialog box appears.

3. Navigate to the folder where you want to store the model.

![SAS Metadata Repository dialog box]

4. Select the folder and click OK. If a MiningResult object that is in the repository has the same name or UUID, then you are prompted to decide whether to overwrite the metadata for this stored object.

**CAUTION:**
Do not overwrite an existing MiningResult object unless you are certain that the model is from the same project in SAS Model Manager.

5. In the information message box, click Close.

6. To view the publish history, select the Loan project, and select the Publish History tab. Select an item from the list to view the publish details.

---

**Publish Models to a SAS Channel**

SAS Model Manager uses SAS Publishing Framework to publish models to defined channels. SAS Model Manager creates a SAS Package file (SPK) for the model in a publication channel. Authorized users who subscribe to the channel can choose to receive e-mail notifications when updated models are ready to deploy to testing or production scoring servers and when the SPK file is published to a publication channel. Then you can extract and validate the scoring logic, deploy champion models to a production environment, and monitor the performance of your models.

To publish a model to a channel, follow these steps:

1. Expand Loan and right-click the Models folder. Then select Publish to a SAS Channel. The Publish to a SAS Channel window appears.

   **TIP** You can publish models from the organization, project, version, or Models folder in the Project Tree.

2. Select a publication channel from the Channel list.
Note: The channel values for **Description**, **Subject**, and **Subscribers** are defined in the SAS Metadata Repository with SAS Management Console.

3. Select **Tree 1** as the model to publish in the **Select Entries to Publish** table. SAS Model Manager lists all of the models in the version folder. To view the entire folder name, expand the ID column heading. Click **Next**.

4. Specify an optional subject line for the e-mail message in the **Message Subject** box. For this example, enter **Publish champion model**. By default, SAS Model Manager uses the value that is defined in the publication channel. If you omit the subject line, then the name of the published model is used.

5. In the **Notes** box include information about the model that might be useful to other users who are involved with the project. For this example, enter **Loan project for 2012**.
6. Click **Finish**. The information dialog box appears and provides information about whether SAS Model Manager successfully published the model. Click **Details** to display a log of the publication process and any messages.

7. Click **Close**.

8. To view the publish history, select the 2012 version in the **Loan** project, and select the **Publish History** tab. Select an item from the list to view the publish details.

The SAS package that is sent to the publication channel contains the model input, model output, SAS code, and its properties. You can submit a SAS DATA step program that calls the SAS Publish API (Application Programming Interface) to extract and deploy the model to a testing or scoring server. SAS Model Manager also provides a SAS macro program, called MM_GetModels, that extracts the SAS code and metadata to score the model. Typically, extracted files are placed on a local drive of the scoring server that is used to deploy the published model. For more information, see the *SAS Model Manager: User’s Guide*.

## Publish Models to a Database

### Overview

SAS Model Manager enables you to publish the project champion model and challenger models that are associated with the **DATA Step** score code type to a configured database. Publishing PMML models to a database is not supported. SAS Model Manager uses the SAS Scoring Accelerator and SAS/ACCESS interface to the database to publish models to the database. The Scoring Accelerator takes the models from SAS Model Manager and translates them into scoring files or functions that can be deployed inside the database. After the scoring functions are published using the SAS/ACCESS interface to the database, the functions extend the database’s SQL language and can be used in
SQL statements such as other database functions. After the scoring files are published, they are used by the SAS Embedded Process to run the scoring model.

The SAS administrator can enable the **Publish Scoring Options** setting in SAS Management Console to indicate that the metadata tables be populated in the target database when publishing a scoring function. If this setting is enabled and the scoring function publish method is chosen, the scoring metadata tables in the database are populated with information about the project and pointers to the scoring function. This feature enables users to review descriptions and definitions of the published model. The audit logs track the history of the model's usage and any changes that are made to the scoring project.

For more information, see “Publishing Models to a Database” in Chapter 12 of *SAS Model Manager: User's Guide*.

This tutorial shows you the tasks that are involved in publishing a project champion model or challenger model to a database. It contains examples and step-by-step directions about preparing a database for use with SAS Model Manager and publishing a model.

**Note:** The examples that are used in this tutorial use the Teradata database type for publishing a model to a database. You can also use this tutorial to publish a model to a DB2, Greenplum, Oracle, or Netezza database.

### Publish a Model Using the SAS Embedded Process Publish Method

In this exercise, you publish a project's champion model to a database using the SAS Embedded Process publish method.

To publish a model to a database, follow these steps:

1. Verify that you have set the project champion model. For more information, see “Set the Champion Model” on page 105.

2. Right-click the **Loan** project and select **Publish Models to a Database** from the pop-up menu. The Publish Models to a Database window appears.

3. Select a database type and select the **SAS Embedded Process** for the publish method. The type of database and the publish method that you choose determine which database settings and options are required. The default publish method is SAS Embedded Process.
Operating Environment Information

The Netezza database type for the SAS Embedded Process publish method is not supported in the second maintenance release of SAS 9.3. When the SAS Embedded process publish method is supported for Netezza, the SAS Administrator can enable Netezza support for SAS Model Manager so that the Netezza database type appears. For more information, see the SAS Model Manager: Administrator’s Guide.

4. Select the check box next to the Tree 1 champion model in the list.

5. Enter a publish name for the champion model that you selected to publish or accept the default value. The SAS Embedded Process publish method uses only the publish name to publish the model files to the database.

Here are the naming convention requirements:

- The user-defined value is case insensitive. The maximum length of alphanumeric characters is determined by the database type and publish method that is selected. No spaces are allowed. An underscore is the only special character that can be included in the publish name.

- The recommended maximum length of the publish name for the SAS Embedded Process publish method is 30 alphanumeric characters for all database types. The database types that are currently supported by SAS Model Manager are Terdata, Oracle, Greenplum, and DB2.

Note: The publish name for each model is reserved by default for subsequent use of the publishing models for a project.

6. Enter a value for the database settings that appear for the selected database type and publish method.

Here are the available database settings according to the database type:

<table>
<thead>
<tr>
<th>Database Settings</th>
<th>Database Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Database server</td>
<td>• Teradata</td>
</tr>
<tr>
<td></td>
<td>• Oracle</td>
</tr>
<tr>
<td></td>
<td>• Netezza</td>
</tr>
<tr>
<td></td>
<td>• Greenplum</td>
</tr>
<tr>
<td></td>
<td>• DB2</td>
</tr>
<tr>
<td>Database</td>
<td>• Teradata</td>
</tr>
<tr>
<td></td>
<td>• Oracle</td>
</tr>
<tr>
<td></td>
<td>• Netezza</td>
</tr>
<tr>
<td></td>
<td>• Greenplum</td>
</tr>
<tr>
<td></td>
<td>• DB2</td>
</tr>
<tr>
<td>User ID</td>
<td>• Teradata</td>
</tr>
<tr>
<td></td>
<td>• Oracle</td>
</tr>
<tr>
<td></td>
<td>• Netezza</td>
</tr>
<tr>
<td></td>
<td>• Greenplum</td>
</tr>
<tr>
<td></td>
<td>• DB2</td>
</tr>
</tbody>
</table>
7. Click **More Options**. The `<Database-type>` Options window appears.

Select the check box for the desired validation options that appear for the selected database type:

- **Validate scoring results**
- **Keep scoring files if validation fails**
- **Display detailed log messages**
- **Use model input**
**Note:** By default, the **Validate scoring results** and **Use model input** options are selected.

8. Enter a numeric value for **Sample Size**. The default value for sample size is 100 if the value is null or zero. The maximum number of digits that are allowed is 8.

9. Click **OK**. A message is displayed to indicate whether the models were published to the database successfully or not.

**Note:** The value of the publish name is validated against the target database, when the option **Replace scoring files that have the same publish name** is not selected for the SAS Embedded Process publish method. If the publish name is not unique, an error message is displayed.

10. Click **Close** to complete the publishing process. The SAS code, scoring results log, and output for the SAS Embedded Process are placed in the **Publish Results** \(<\text{publish-model-name}>\) folder in the project file list, and the **ModelNameForEP** user-defined project property is populated.

<table>
<thead>
<tr>
<th>User-Defined Properties</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>BusinessContext</td>
<td></td>
</tr>
<tr>
<td>DbmsTable</td>
<td></td>
</tr>
<tr>
<td>ModelNameForEP</td>
<td>Tree1_Tut4</td>
</tr>
</tbody>
</table>

11. The actions that are performed during the publishing process are displayed in the history. To view the history of the project, select the project name and then click the **History** tab in the **Annotations - Loan** pane.

12. To view the publish history, select the **Loan** project, and select the **Publish History** tab. Select an item from the list to view the publish details.

**Note:** After you have completed the publishing process, you can view the log file. The **Publish Results** folder in the Project Tree contains a folder for each model that was published. The publish name is used to create a folder for each model that is published. That folder contains the ScoringResults.log file. The time that the process
started, details about who initiated the process, and the time when the project was published are recorded. Error messages are also recorded in the log file. The log file provides an audit trail of all relevant actions in the publishing process.

Publish a Model Using the Scoring Function Publish Method

In this exercise, you publish a project’s champion model to a database using the scoring function publish method.

To publish a model, follow these steps:

1. Verify that you have set the project champion model in Tutorial 3. For more information, see “Set the Champion Model” on page 105.

2. (Optional) Select the Loan project folder and enter a value for the DbmsTable user-defined property. This value is the scoring input table that the DBA might have created in the database to be used with a scoring application.

   Note: If you plan to use scoring application or SQL code to score this project, you must first set the DbmsTable property to the name of input table in your database that you want to use for scoring the champion or challenger model.

   When you publish a scoring function, the information that is associated with the input table in the database is updated to contain the value of the DbmsTable property. The scoring application or SQL code can then query the database for the input table name to use as the scoring input table.

3. Right-click the Loan project in the Project Tree and select Publish Models ⇦ to a Database. The Publish Models to a Database window appears.
4. Select a database type and select the **scoring function** for the publish method. The type of database and the publish method that you choose determine which database settings and options are required.

5. Select the check box next to the **Reg 1** challenger model in the list.

   **TIP** If you have not published the champion model yet, select the champion model **Tree 1** as well.

6. Enter a publish name for each model that you selected to publish. The scoring function publish method has a system-generated **prefix** and a **publish name**. These are used to publish the model scoring function. The publish name is a user-defined value that can be modified.

   Here are the naming convention requirements:

   - The user-defined value is case insensitive. The maximum length of alphanumeric characters is determined by the database type and publish method that is selected. No spaces are allowed. An underscore is the only special character that can be included in the publish name.

   - The recommended maximum lengths of the publish names for the scoring function publish method are the following:
UNIX Specifics

The publish name (user-defined) portion of the function name in an AIX environment has a maximum length of 16 alphanumeric characters for Teradata.

Note: The publish name for each model is reserved by default for subsequent use of the publishing models for a project.

7. Enter a value for the database settings that appear for the selected database type and publish method.

Here are the available database settings according to the database type:

<table>
<thead>
<tr>
<th>Database Settings</th>
<th>Database Type</th>
</tr>
</thead>
</table>
| **Database server** | • Teradata  
                      • Netezza 
                      • Greenplum 
                      • DB2 |
| **Database**       | • Teradata 
                      • Netezza 
                      • Greenplum 
                      • DB2 |
| **User ID**        | • Teradata 
                      • Netezza 
                      • Greenplum 
                      • DB2 |
| **Password**       | • Teradata 
                      • Netezza 
                      • Greenplum 
                      • DB2 |
| **Server user ID** | DB2            |
| **Compile database** | Netezza |
| **Jazlib database** | Netezza |
| **Schema**         | • Greenplum 
                      • DB2 |
| **Initial wait time** (in seconds) | DB2 |
| **FTP time out** (in seconds) | DB2 |
8. Click **More Options**. The `<Database-type>` Options window appears.

Select the check box for the desired validation options that appear for the selected database type:

- **Validate scoring results**
- **Keep scoring function if validation fails**
- **Display detailed log messages**
- **Use model input**
- **Protected mode** (Teradata scoring function option) or **Fenced mode** (DB2 and Netezza scoring function option)

**Note:** By default, the **Validate scoring results** and **Use model input** options are selected for both publish methods. The **Protected mode** or the **Fenced mode** options are selected by default for the scoring function publish method.

9. Enter a numeric value for **Sample Size**. The default value for sample size is 100 if the value is null or zero. The maximum number of digits that are allowed is 8.
10. Click OK. A message is displayed to indicate whether the models were published to the database successfully or not.

11. Click Close to complete the publishing process.

The SAS score code (for example, Y120924043_Reg_1_Loan.sas), the scoring results log, and output for the scoring function are placed in the Publish Results \(<\text{prefix_publish-model-name_project-name}\>\) folder in the project file list, and the ScoringFunctionName and ScoringFunctionPrefix user-defined project properties are populated.

12. The actions that are performed during the publishing process are displayed in the history. To view the history of the project, select the project name and then click the History tab in the Annotations - Loan pane.

13. To view the publish history, select the Loan project, and select the Publish History tab. Select an item from the list to view the publish details.
Note: After you have completed the publishing process, you can view the log file. The Publish Results folder in the Project Tree contains a folder for each model that was published. The publish name is used to create a folder for each model that is published. That folder contains the ScoringResults.log file. The time that the process started, details about who initiated the process, and the time when the project was published are recorded. Error messages are also recorded in the log file. The log file provides an audit trail of all relevant actions in the publishing process.

Update Life Cycle or Workflow

Update the Life Cycle (Optional)

To update the life cycle milestones, follow these steps:

1. In the Loan project, expand 2012 ⇒ Life Cycle ⇒ Test.
2. Select each milestone task for Test. Click the Status box and select Completed.
   
   **Note:** Although this task is not part of this exercise, dependencies in the life cycle require you to mark this task complete.
3. Expand the Production milestone. Select the Declare ready for production task. Click the Status box and select Completed.
4. Select the Publish model task. Click the Status box and select Completed.
5. Select the Start production scoring task. Click the Status box and select Completed.
6. Click the Life Cycle node to examine its properties. The value for Date Modified is today's date. The Test and Production properties display bar charts that show the percentage of completed tasks for these milestones.
Update the Workflow Process (Optional)

To complete the activities in the associated workflow process, follow these steps:

1. Select **Tools ⇒ My Workflow Inbox** or click 🔄 from the SAS Model Manager main window to view the workflow process activities in your workflow inbox. Workflow Console is launched in a Web browser, and displays the Activities category view.

   *Note:* The list displays only the activities for which you are the actual owner or are assigned as a potential owner, and that have the state of **Started**.

2. From the Activities category view, select an activity name, and click 🔄.

   *Note:* You can select an activity name and click 🔄 to release an activity that you had previously claimed.

3. (Optional) Enter a property value or change an existing property value in the Properties pane.

4. (Optional) Add a comment to the activity using the Comments pane.

5. Select a status value to complete the activity. The workflow process continues to the next activity.

6. Repeat steps 2 through 5 for the activities that you completed during this tutorial.

   *Note:* A workflow can be configured to display the activities that are associated with a milestone or task on the **Workflow Milestones** tab and in the Workflow Milestones report for a version in the SAS Model Manager client application. From the **Workflow Milestones** tab you can view the status of milestones or tasks that are associated with activities in the workflow.
Note: For more information, see Chapter 11, “Tutorial 10: Using Workflow Console,” on page 221.
Overview of Performance Monitoring Reports

SAS Model Manager performance monitoring reports enable you to monitor and evaluate model performance. Model performance can sometimes be improved by tuning or refitting the model, or by using a new champion model.
To create performance monitoring reports, you create a performance task by using the Define Performance Task wizard. Then, you execute the performance task. The output from executing a performance task includes several charts, including Characteristic, Stability, Lift, Gini (ROC and Trend), Kolmogorov-Smirnov (KS), and Mean Squared Error (MSE) charts. The New Report wizard enables you to create a Monitoring report and a Champion and Challenger Performance report that uses the performance data as input. You can view these charts in SAS Model Manager or you can create monitoring reports in PDF, HTML, RTF, or Excel output formats.

Prerequisites

The exercises in this tutorial depend on some of the properties of the specific models that were added in Chapter 4, “Tutorial 3: Importing Models, Scheduling Scoring Tasks, and Creating Reports,” on page 75.

The performance data sets from SMM121Tutorial.zip must be extracted and registered in SAS Management Console. If the data sets have not been extracted and registered, see “Prepare Tutorial 5 Data Sets and Models” on page 9 to extract and register the files.

The `<drive>`\Tutorial5\Samples folder contains these performance data sets that are used in this tutorial:

- hmeq_2011q2.sas7bdat
- hmeq_2011q3.sas7bdat
- hmeq_2011q4.sas7bdat
- hmeq_2012q1.sas7bdat

Create the Champion Model Performance Data Sets for a Classification Project

In this exercise, you run the Define Performance Task wizard for the Loan classification modeling project to create performance monitoring task for the champion model, Tree 1. The performance monitoring task uses the information that you supply in the Define Performance Task wizard to create SAS programs. You then execute the SAS programs to create the performance monitoring data sets.

Ensure the Project and Model Properties Are Set

The Define Performance Task wizard requires that specific project properties be set before you can run the wizard.

1. Expand the Tutorial3 folder.
2. Select the Loan project and ensure that the following project properties are set:

<table>
<thead>
<tr>
<th>Project Property</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Training Target Variable</td>
<td>BAD</td>
</tr>
<tr>
<td>Target Event Value</td>
<td>1</td>
</tr>
<tr>
<td>Project Property</td>
<td>Value</td>
</tr>
<tr>
<td>-----------------------------------------------</td>
<td>-------</td>
</tr>
<tr>
<td>Class Target Level</td>
<td>Binary</td>
</tr>
<tr>
<td>Output Event Probability Variable</td>
<td>score</td>
</tr>
</tbody>
</table>

3. Expand the 2012 version and Models folder. Select the champion model and verify that the value of the Score Code Type property is set to DATA step.

**Run the Define Performance Task Wizard**

To run the Define Performance Task wizard, follow these steps:

1. Expand the Tutorial3 organizational folder, right-click Loan, and select Define Performance Task from the pop-up menu. The Define Performance Task wizard appears.

2. In the Output Variables for Stability Analysis table, select the box for the score variable.

3. In the Input Variables for Characteristic Analysis table, click Select All. Click Next.

4. On the Warning and Alert Conditions page, accept the default alert and warning conditions by clicking Next. The Data and Model Specifications page appears.
5. Accept the default process method of **Standard configuration** with the **Run scoring task** option selected.

Here are the available data processing method options:

- To run a standard environment, select **Standard configuration**. When this data processing method is selected you can select **Run scoring task** to run the scoring task code in the performance monitor job. If **Run scoring task** is not selected, then the performance data source must contain the project output variables and model scoring results.

- To run the performance monitoring task in a High Performance Analytic environment, select **High performance configuration**. When this option is selected, the **Run scoring task** check box is not available. The performance data source must contain the project output variables and model scoring results.

  **Note:** To use the high performance configuration, you must license the High Performance Analytics server product. Teradata and Greenplum currently support the High-Performance Analytics configuration.

6. Click **Browse** to select a **Performance data source**. Navigate to the location of the **Tutorial5** library folder and select **HMEQ_2011Q2**. Click **OK**.

7. Click **Validate** to validate the performance data set. Click **Close** when the successful validation message is displayed.

8. Click the calendar button to select a **Data collection date** and select **June 30, 2011** using the calendar. Click **OK**.

  **Note:** The date can be any date within the second quarter of 2011.
9. In the **Date label** box, enter **2011Q2**.

   *Note:* The label is used to identify the performance data in the performance monitoring charts. When you view the charts by using the Performance node in the Project Tree, SAS Model Manager uses the label **baseline** for the first set of performance data that is created for a champion model. SAS Model Manager does not use the text that you entered in the **Date label** box.

10. Select the **Tree 1** champion model from the **Models** list. If challenger models have been flagged, the challenger modes are listed in the **Models** table.

11. Click **Next**. The **Optional E-mail Notifications** page of the wizard appears.

12. Click **Add**. The Add Contact dialog box appears.

   Enter your e-mail address, and click **OK**.

13. Click **Finish**. The wizard creates the SAS code that can be run to create the performance monitoring data sets.

14. Execute the SAS program. Under the **Loan** project, right-click **PerformanceMonitor** and select **Execute**. SAS Model Manager executes the
performance monitoring program. When the program execution is complete, an information message indicates whether the program ran successfully. Click Close.

15. Expand **PerformanceMonitor**. Here you can see the SAS program that created the performance monitoring data sets and the resulting SAS log. Click both files to see the file contents in the **Content** pane.

16. Expand the **Resources** folder under the default version **2012**. The **Resources** folder contains the data sets that are created by executing the performance task. When a performance task is executed the first time for a given champion model, the performance task creates the initial data sets that are used for plotting the model performance charts. In executing subsequent performance tasks that use new performance data for the given champion model, SAS Model Manager appends the resulting data sets to the existing data sets. All of the data in the model performance data sets for a given champion model is used to plot the model performance charts.

Click on any file to see the contents of that file in the **Content** pane.

17. Select **Performance**. The Performance node displays the champion model performance data as a graph and as a data set.

*Note:* To view at least one line segment in Characteristic and Stability graphs, SAS Model Manager requires performance data sets from three performance task executions, at a minimum.
18. Define a performance task and execute the SAS program for the remaining three Tutorial 5 performance data sources. Complete steps 1 through 14 for each performance data source.

On the Define Performance Task wizard, page 1, select all input and output variables if they are not already selected.

On page 2, use the default alert and warning conditions. No changes are necessary.

On page 3, use these values for the **Performance data source**, **Data collection date**, and **Date label** boxes:

<table>
<thead>
<tr>
<th>Performance data source</th>
<th>Data collection date</th>
<th>Date label</th>
</tr>
</thead>
<tbody>
<tr>
<td>HMEQ_2011Q3</td>
<td>September 30, 2011</td>
<td>2011Q3</td>
</tr>
<tr>
<td>HMEQ_2011Q4</td>
<td>December 31, 2011</td>
<td>2011Q4</td>
</tr>
<tr>
<td>HMEQ_2012Q1</td>
<td>March 31, 2012</td>
<td>2012Q1</td>
</tr>
</tbody>
</table>

---

**Create the Challenger Model Performance Data Sets**

In this exercise, you run the Define Performance Task wizard to create a performance monitoring task for the challenger model, **Reg 1**. The performance monitoring task uses the information that you supply in the Define Performance Task wizard to create SAS programs. You then execute the SAS programs to create the performance monitoring data sets that are then used to create the Champion and Challenger Performance report.

**Ensure the Project and Model Properties Are Set**

The Define Performance Task wizard requires that specific project properties be set before you can run the wizard.

*Note:* You can skip these steps if you already performed them when creating the performance data sets for the champion model.

1. Expand the **Tutorial3** folder.
2. Select the **Loan** project and ensure that the following project properties are set:

<table>
<thead>
<tr>
<th>Project Property</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Training Target Variable</td>
<td>BAD</td>
</tr>
<tr>
<td>Target Event Value</td>
<td>1</td>
</tr>
<tr>
<td>Class Target Level</td>
<td>Binary</td>
</tr>
<tr>
<td>Output Event Probability Variable</td>
<td>score</td>
</tr>
</tbody>
</table>

3. Expand the **2012** version and **Models** folder. Select the champion model and verify that the value of the **Score Code Type** property is set to **DATA step**.
Run the Define Performance Task Wizard

To run the Define Performance Task wizard, follow these steps:

1. Expand the Tutorial3 organizational folder, right-click Loan, and select Define Performance Task from the pop-up menu. The Define Performance Task wizard appears.

2. In the Output Variables for Stability Analysis table, select the box for the score variable.

3. In the Input Variables for Characteristic Analysis table, click Select All. Click Next.

4. On the Warning and Alert Conditions page, accept the default alert and warning conditions by clicking Next. The Data and Model Specifications page appears.
The performance data options are populated with the values from the last performance task that was defined for the champion model.

5. Accept the default process method of Standard configuration with the Run scoring task option selected.

Here are the available data processing method options:

- To run a standard environment, select Standard configuration. When this data processing method is selected, you can select Run scoring task to run the scoring task code in the performance monitor job. If Run scoring task is not selected, then the performance data source must contain the project output variables and model scoring results.

- To run the performance monitoring task in a High Performance Analytic environment, select High performance configuration. When this option is selected, the Run scoring task check box is not available. The performance data source must contain the project output variables and model scoring results.

Note: To use the high performance configuration, you must license the High Performance Analytics server product. Teradata and Greenplum currently support the High-Performance Analytics configuration.

6. Click Browse to select a Performance data source. Navigate to the location of the Tutorial5 library folder and select HMEQ_2011Q2. Click OK.

7. Click Validate to validate the performance data set. Click Close when the successful validation message is displayed.

8. Click the calendar button to select a Data collection date and select June 30, 2011, using the calendar. Click OK.
Note: The date can be any date within the second quarter of 2011, but must be the same as the date used when creating a performance task for the champion model.

9. In the Date label box, enter 2011Q2.

Note: The label is used to identify the performance data in the performance monitoring charts. When you view the charts by using the Performance node in the Project Tree, SAS Model Manager uses the label baseline for the first set of performance data that is created for a champion model. SAS Model Manager does not use the text that you entered in the Date label box. The date label should be the same as the date label that was used when creating a performance task for the champion model.

10. Select the Reg 1 challenger model from the Models list.

11. Click Next. The Optional E-mail Notifications page of the wizard appears.
12. Click **Add**. The Add Contact dialog box appears.

Enter your e-mail address, and click **OK**.

13. Click **Finish**. The wizard creates the SAS code that can be run to create the performance monitoring data sets.

14. Execute the SAS program. Under the **Loan** project, right-click **PerformanceMonitor** and select **Execute**. SAS Model Manager executes the performance monitoring program. When the program execution is complete, an information message indicates whether the program ran successfully. Click **Close**.

15. Define a performance task and execute the SAS program for the remaining three Tutorial 5 performance data sources. Complete steps 1 through 14 for each performance data source.

In the Define Performance Task wizard, page 1, select all input and output variables if they are not already selected.

On page 2, use the default alert and warning conditions. No changes are necessary.

On page 3, use these values for the **Performance data source**, **Data collection date**, and **Date label** boxes:
Create the Champion Model Performance Data Sets for a Prediction Project

In this exercise, you run the Define Performance Task wizard for the HMEQ-Interval prediction modeling project to create a performance monitoring task for the champion model, Reg1_Interval. The performance monitoring task uses the information that you supply in the Define Performance Task wizard to create SAS programs. You then execute the SAS programs to create the performance monitoring data sets.

Ensure the Project and Model Properties Are Set

The Define Performance Task wizard requires that specific project properties be set before you can run the wizard.

1. Expand the Tutorial3 folder.

2. Select the HMEQ-Interval project and ensure that the following project properties are set:

<table>
<thead>
<tr>
<th>Project Property</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Training Target Variable</td>
<td>DEBTINC</td>
</tr>
<tr>
<td>Class Target Level</td>
<td>Interval</td>
</tr>
<tr>
<td>Output Prediction Variable</td>
<td>P_DEBTINC</td>
</tr>
</tbody>
</table>

3. Expand the 2012 version and Models folder. Select the champion model and verify that the value of the Score Code Type property is set to DATA step.

Run the Define Performance Task Wizard

To run the Define Performance Task wizard, follow these steps:

1. Expand the Tutorial3 organizational folder, right-click HMEQ-Interval, and select Define Performance Task from the pop-up menu. The Define Performance Task wizard appears.
2. In the **Output Variables for Stability Analysis** table, select the box for the **P_DEBTINC** variable.

3. In the **Input Variables for Characteristic Analysis** table, click **Select All**. Click **Next**.

4. On the **Warning and Alert Conditions** page, accept the default alert and warning conditions by clicking **Next**. The **Data and Model Specifications** page appears.
5. Accept the default process method of **Standard configuration** with the **Run scoring task** option selected.

Here are the available data processing method options:

- To run a standard environment, select **Standard configuration**. When this data processing method is selected, you can select **Run scoring task** to run the scoring task code in the performance monitor job. If **Run scoring task** is not selected, then the performance data source must contain the project output variables and model scoring results.

- To run the performance monitoring task in a High Performance Analytic environment, select **High performance configuration**. When this option is selected, the **Run scoring task** check box is not available. The performance data source must contain the project output variables and model scoring results.

  *Note:* To use the high performance configuration, the High Performance Analytics server product must be licensed. Teradata and Greenplum currently support the High-Performance Analytics configuration.

6. Click **Browse** to select a **Performance data source**. Navigate to the location of the **Tutorial5** library folder and select **HMEQ_2011Q2**. Click **OK**.

7. Click **Validate** to validate the performance data set. Click **Close** when the successful validation message is displayed.

8. Click the calendar button to select a **Data collection date** and select **June 30, 2011**, using the calendar. Click **OK**.

  *Note:* The date can be any date within the second quarter of 2011.
9. In the **Date label** box, enter **2011Q2**.

   *Note:* The label is used to identify the performance data in the performance monitoring charts. When you view the charts by using the Performance node in the Project Tree, SAS Model Manager uses the label **baseline** for the first set of performance data that is created for a champion model. SAS Model Manager does not use the text that you entered in the **Date label** box.

10. Select the **Reg1_Interval** champion model from the **Models** list. If challenger models have been flagged, the challenger models are listed in the **Models** table.

11. Click **Next**. The **Optional E-mail Notifications** page of the wizard appears.

![](image1.png)

12. Click **Add**. The Add Contact dialog box appears.

![](image2.png)

   Enter your e-mail address, and click **OK**.

13. Click **Finish**. The wizard creates the SAS code that can be run to create the performance monitoring data sets.

14. Execute the SAS program. Under the **HMEQ-Interval** project, right-click **PerformanceMonitor** and select **Execute**. SAS Model Manager executes the
performance monitoring program. When the program execution is complete, an
information message indicates whether the program ran successfully. Click Close.

15. Expand PerformanceMonitor. Here you can see the SAS program that created the
performance monitoring data sets and the resulting SAS log. Click both files to see
the file contents in the Content pane.

16. Expand the Resources folder under the default version 2012. The Resources folder
contains the data sets that are created by executing the performance task. When a
performance task is executed the first time for a given champion model, the
performance task creates the initial data sets that are used for plotting the model
performance charts. In executing subsequent performance tasks that use new
performance data for the given champion model, SAS Model Manager appends the
resulting data sets to the existing data sets. All of the data in the model performance
data sets for a given champion model is used to plot the model performance charts.

Click on any file to see the contents of that file in the Content pane.

17. Select Performance. The Performance node displays the champion model
performance data as a graph and as a data set.

Note: Before you can view at least one line segment in Characteristic and Stability
graphs, SAS Model Manager requires performance data sets from three
performance task executions, at a minimum.

18. Define a performance task and execute the SAS program for the remaining three
Tutorial 5 performance data sources. Complete steps 1 through 14 for each
performance data source.

On the Define Performance Task wizard, page 1, select all input and output variables
if they are not already selected.

On page 2, use the default alert and warning conditions. No changes are necessary.

On page 3, use these values for the Performance data source, Data collection date,
and Date label boxes:
View Performance Charts

View the Training Distribution Chart

To demonstrate the Variable Distribution chart features, follow these steps:

1. In the SAS Model Manager Project Tree, expand **Tutorial3**, expand **Loan**, and expand **2012**.

2. Select the **Performance** node to display the Performance charts.

3. On the **Variable Distribution** tab, click the **Select variable** box and select **MORTDUE**. The training distribution data and charts display the data for the MORTDUE variable.
4. Click on a bar to highlight the corresponding entry in the table. If necessary, move the scroll bar to locate the highlighted entry in the table.

5. In the table, click the highlighted row and drag the mouse to select multiple rows. The associated bars in the chart are highlighted as you select the associated rows.

---

**View the Characteristic and Stability Charts**

To demonstrate the Characteristic and Stability chart features, follow these steps:

1. Select the **Characteristic and Stability** tab.
2. Select table entries to highlight the corresponding chart points.

View the Lift Chart

To demonstrate the Lift chart features, follow these steps:

Note: This chart is not displayed for prediction models with an interval target.

1. Select the Lift tab.
2. To change the chart to show markers, follow these steps:
   a. Right-click the chart and select **Graph Properties**.
   b. In the Properties window, select **Line** from the left-side menu.
   c. Click the **Markers** tab, and select the **Show Markers** check box.
   d. Click **Apply** to save the changes, and then click **OK** to close the window.

3. Move the pointer along one lift marker. You should see a pop-up box when the pointer is resting on a data point or is close to a data point.
To chart the cumulative captured response:

a. Right-click the chart area.

b. Select Data Options. The Data Options Dialog window appears.

c. Click the Roles tab if it is not already displayed. Select Y from the Roles drop-down list.

d. Select the variable cuCapturedResp from the Available Variables list box and click the right-arrow to move it to the Assigned Variables list box.

e. Select the cuLift variable and click the left-arrow to remove it from the Assigned Variables list box. The only variable in the Assigned Variables box should be cuCapturedResp.

f. Click OK.
**View the Gini (ROC and Trend) Charts**

To view the ROC and Gini charts, select the **GINI (ROC and Trend)** tab.

*Note:* This chart is not displayed for prediction models with an interval target.

**View the Kolmogorov-Smirnov (KS) Chart**

To view the KS chart from the SAS Model Manager user interface, follow these steps:
Note: This chart is not displayed for prediction models with an interval target.

1. Select the KS tab.

2. Select a different time point from the drop-down list of the Time Interval field.

View the Mean Squared Error (MSE) Chart

To view the MSE chart from the SAS Model Manager user interface, follow these steps:

Note: This chart is displayed only for prediction models with an interval target.

1. In the SAS Model Manager Project Tree, expand Tutorial3, expand HMEQ-Interval, and expand 2012.

2. Select the Performance node to display the Performance charts.

3. Select the MSE tab.
Creating Output Formats for Performance Monitoring Reports

Create Monitoring Reports

In this exercise, you use the New Report wizard to create the monitoring reports in PDF and HTML output formats.

1. In the Project Tree, expand Tutorial3, the Loan project, and the version 2012.
2. Right-click Reports and select Reports ⇒ New Report.
   a. Select Monitoring Report from the Type drop-down list.
   b. Select PDF from the Format drop-down list. The default value is PDF.
   c. Select Seaside from the Style drop-down list. The default value is SAS default.
   d. In the Name box of General Properties, enter PDF_PerfMonitoring.
e. Click OK. An information message indicates whether the report creation was successful. Click Close to close the message box.

f. View the PDF performance monitoring report. Expand the Reports folder. Right-click PDF_PerfMonitoring and select Reports Æ View Report. Scroll through the report or click a link in the table of contents to view various parts of the report.

3. Create the same report in HTML.
   Right-click Reports and select Reports Æ New Report.
   a. Click the Type box and select Monitoring Report.
   b. Select HTML from the Format drop-down list. The default value is PDF.
   c. Select Seaside from the Style drop-down list. The default value is SAS default.
   d. In the Name box of the General Properties, enter HTML_PerfMonitoring.
e. Click **OK**. An information message indicates whether the report creation was successful. Click **Close** to close the message box.

f. View the HTML performance monitoring report. Expand the **Reports** folder. Right-click **HTML_PerfMonitoring** and select **Reports** ⇒ **View Report**. All charts and data appear on a single HTML page. Scroll through the report to view various parts of the report.

---

**Create Champion and Challenger Performance Reports**

In this exercise, you use the New Report wizard to create champion and challenger performance reports in PDF and HTML output formats.

1. In the Project Tree, expand **Tutorial3**, the **Loan** project, and the version **2012**.

2. Right-click **Reports** and select **Reports** ⇒ **New Report**.
   a. Select **Champion and Challenger Performance Report** from the **Type** drop-down list.
   b. Select **PDF** from the **Format** drop-down list. The default value is **PDF**.
   c. Select **Seaside** from the **Style** drop-down list. The default value is **SAS default**.
   d. In the **Name** box of **General Properties**, enter **PDF_ChampionChallengerPerf**.
e. Click OK. An information message indicates whether the report creation was successful. Click Close to close the message box.

f. View the PDF performance monitoring report. Expand the Reports folder. Right-click PDF_ChampionChallengerPerf and select Reports ⇒ View Report. Scroll through the report or click a link in the table of contents to view various parts of the report.

3. Create the same report in HTML.

   Right-click Reports and select Reports ⇒ New Report.

   a. Click the Type box and select Champion and Challenger Performance Report.

   b. Select HTML from the Format drop-down list. The default value is PDF.

   c. Select Seaside from the Style drop-down list. The default value is SAS default.

   d. In the Name box of the General Properties, enter HTML_ChampionChallengerPerf.
e. Click OK. An information message indicates whether the report creation was successful. Click Close to close the message box.

f. View the HTML performance monitoring report. Expand the Reports folder. Right-click HTML_ChampionChallengerPerf and select Reports to View Report. All charts and data appear on a single HTML page. Scroll through the report to view various parts of the report.

Using Dashboard Reports

Overview

The SAS Model Manager Dashboard can provide reports that show the overall state of all projects that are being monitored. The dashboard reports are produced from existing performance monitoring data sets. For each project, a user can define dashboard report indicators that are then used to create the dashboard reports. You view the dashboard reports through the SAS Model Manager Tools menu. These reports are generated in HTML by SAS Model Manager.

Note: The dashboard reports can be defined and generated only by SAS Model Manager administrators and advanced users.

In this exercise, you create a dashboard report definition, generate the dashboard reports, and view the dashboard reports.

Prerequisites

Models Used in Tutorial 3

The exercises in this tutorial depend on some of the properties of the specific models that were added in Tutorial 3. Use the projects, versions, or models that are specified here.
This tutorial is designed to follow Chapter 4, “Tutorial 3: Importing Models, Scheduling Scoring Tasks, and Creating Reports,” on page 75.

**The Required Tutorial Files**

The exercises in this tutorial depend on the performance task data sets that were created using the tutorial files in “Create the Champion Model Performance Data Sets for a Classification Project” on page 130.

**Prepare to Use Dashboard Reports**

The dashboard report directory is configured during the installation of SAS Model Manager. The default directory is `\SASConfigDir\Lev\AppData\SASModelManager12.1\Dashboard`.

To configure a different directory to store the SAS Model Manager dashboard reports, follow these steps:

1. Connect to the SAS Workspace Server.
2. Create a new directory (for example, `C:\Dashboard`).
   
   **Note:** The directory must be located on a SAS Workspace Server or a network drive that is accessible by the SAS Workspace Server. Do not include special characters or spaces in the name of the directory.
3. Grant user permissions for the new directory. For example, perform the following tasks:
   
   - Grant Full Control permission to users who need to create subdirectories, write content, or delete content. This type of user includes a user who you add (using SAS Management Console) to the Model Manager Administrator Users group or a user who is a SAS administrator. This type of user includes users that are in Model Manager Administrator Users group or a user who is a SAS administrator that you added using SAS Management Console.
   
   - Grant Read, Write, and Execute permissions to users who need to create performance indicators and execute dashboard reports. This type of user includes users that are in Model Manager Advanced Users group that you added using SAS Management Console.
   
   - Grant Read and Execute permissions to users who need only to view the dashboard reports. This type of user includes users that are in Model Manager Users group that you added using SAS Management Console.

**UNIX Specifics**

In a UNIX environment, all SAS Model Manager users must be part of a group that has the appropriate group permissions. For more information, see “Creating Operating System Accounts in UNIX Environments” in Chapter 3 of *SAS Model Manager: Administrator's Guide* and “Configuring Users, Groups, and Roles” in Chapter 4 of *SAS Model Manager: Administrator's Guide*.

**Note:**

4. From SAS Management Console, expand the Application Management node on the Plug-ins tab.
5. Select and expand Configuration Manager ➔ SAS Application Infrastructure.
6. Right-click Model Manager JavaSvcs 12.1 and select Properties.
7. (optional) Click the Settings tab and then select Report Options. Use this setting to specify the styles that are available when a user generates dashboard reports, and to
enable the indicator override option for defining dashboard report indicators. When
the indicator override configuration is enabled, indicators with conditions are
available when you add dashboard report indicators using the SAS Model Manager
Client.

8. Click the Advanced tab to modify the application dashboard directory. Change the
property value for App.DashboardDir to the directory path that was configured.

9. Click OK.

Create a Dashboard Report Definition

To create a dashboard report definition, follow these steps:

1. You must have at least one project that contains performance data before you
continue to the next step. For more information, see “Create the Champion Model
Performance Data Sets for a Classification Project” on page 130.

2. Right-click the project folder in the Project Tree, and select Dashboard Report
Definition ➔ New from the pop-up menu. The New Dashboard Report Definition
window appears.

*Note:* If a dashboard report definition already exists for a project, you can select
Edit from the pop-up menu. If you want to delete an existing dashboard report
definition, you can select Delete from the pop-up menu.

3. Click Add. The Add Indicator window appears.

*Note:* If you want to copy indicators from an existing project, click Copy Indicators
instead of Add, follow the prompts, and then skip to step 5.
a. Select a template from the Template drop-down list.

   Note: Click Detail to view information about the selected indicator template.

b. Enter values for the Normal, Warning, and Alert range definitions.

   **Table 6.1 Example Performance Indicator Values**

<table>
<thead>
<tr>
<th>Indicator Name</th>
<th>Category</th>
<th>Normal</th>
<th>Warning</th>
<th>Alert</th>
</tr>
</thead>
<tbody>
<tr>
<td>CHAR_P1</td>
<td>Characteristic</td>
<td>0 – 1</td>
<td>1 – 2</td>
<td>2 – 3</td>
</tr>
<tr>
<td>GINIDECAY</td>
<td>Model Assessment</td>
<td>0 – 0.2</td>
<td>0.2 – 0.4</td>
<td>0.4 – 0.6</td>
</tr>
<tr>
<td>STAB_P1</td>
<td>Stability</td>
<td>0 – 1</td>
<td>1 – 2</td>
<td>2 – 3</td>
</tr>
</tbody>
</table>

c. Click OK. The New Dashboard Report Definition window appears with information about the new indicator.
4. Repeat step 3 for each indicator that you want to add. To edit an existing indicator, select the indicator, and click **Edit**.

5. Select one category indicator for each category, and then select one indicator as the project indicator.

   **Note:** The indicator that you select as a project indicator must also be a category indicator.

6. Click **Next**. The New Dashboard Report Definition window appears with information about setting up e-mail notifications.
7. Select a value from the Project status drop-down list, enter a value for E-mail address, and click Add. Repeat this step for each recipient who you want to send an e-mail notification about a status. If you want an individual recipient to receive an e-mail notification for each status, you must repeat this step for each status. To delete an e-mail notification, select a project status, and click Delete.

8. Click Next. The New Dashboard Report Definition window appears with information about setting report types.

9. By default, all of the report types are selected. To change report types, follow these steps:
   a. To add a report type, select a value from the Report type drop-down list, and click Add.
   b. To delete a report type, select a value from the Report Description list, and click Delete.

10. Click Finish. An informational message is displayed indicating that the dashboard report definition were created successfully.
Note: You must define dashboard report indicators for all projects that you want to include in your dashboard reports.

**Generate Dashboard Reports**

To generate the dashboard reports, follow these steps:

*Note:* Before you generate dashboard reports, you must have at least one project that contains performance data. That project must have at least one dashboard report indicator that has been defined.

1. Select **Tools ⇒ Generate Dashboard Reports** from the menu. The Generate Dashboard Reports window appears.

2. Select a style for the report from the **Style** drop-down list.

3. Select a report option:
   - Create reports and data tables for projects that have new performance monitoring data
   - Update the style for all reports, using the existing data tables
   - Update all reports and data tables for projects whose performance monitoring data or report indicator definitions have changed

4. (Optional) Select one or more project types that you want to exclude from the dashboard reports.

5. Click **OK**. You can view the progress of the dashboard reports in the status bar. A message appears that indicates whether the report was created successfully. The message also displays the location of the dashboard reports on the SAS Workspace Server. Here is an example: C:\SAS\Config\Lev1\AppData\SASModelManager12.1\Dashboard.
SAS Model Manager administrators can configure a different location for the dashboard reports directory. If you set up notifications when you defined the dashboard indicators, the recipients receive e-mail notifications for the configured statuses.

For more information about executing dashboard reports, see the *SAS Model Manager: User's Guide*.

**View the Dashboard Reports**

To view the dashboard reports, follow these steps:

1. Select **Tools ⇒ View Dashboard Reports**

   A web page displays a table with dashboard reports for each project that has a dashboard definition.

   **All projects**

   ![All projects table](image)

   **History Status**

   ![History Status table](image)

2. Select a **Project Name** or status link to view the associated dashboard reports. The **Project Reports Index** appears in a new window. If you select a status, only the dashboard reports for that time frame are displayed.

   **Note:** You can also view the report by opening the index.html file directly in the Workspace Server dashboard reports location (for example, `c:\SAS\Config\Lev1\AppData\SASModelManager12.1\Dashboard\report`).
3. Select a link from the **Report** column to view the report details.

### KPI Detail Report

**2012Q1**

<table>
<thead>
<tr>
<th>Category</th>
<th>Category Status</th>
<th>Category Indicator</th>
<th>Indicator</th>
<th>Indicator Status</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Characteristic</td>
<td></td>
<td></td>
<td>Number of predictors with deviation index exceeding 0.1</td>
<td></td>
<td>4.9009</td>
</tr>
<tr>
<td>Model Assessment</td>
<td></td>
<td></td>
<td>Omnindex decay</td>
<td></td>
<td>0.4302</td>
</tr>
<tr>
<td>Stability</td>
<td></td>
<td></td>
<td>Number of outputs with deviation index exceeding 0.1</td>
<td></td>
<td>1.9009</td>
</tr>
</tbody>
</table>

*Note:* To return to the Project Reports Index, select the browser’s back button. To return to the All Projects dashboard, select the first tab in the browser window.

For more information about dashboard reports, see the *SAS Model Manager: User’s Guide.*
Chapter 7

Tutorial 6: Creating Basel II Reports

Overview of Basel II Reports

Basel II reports in SAS Model Manager provide several statistical measures and tests to validate stability, performance, and calibration using Loss Given Default (LGD) and Probability of Default (PD) models.

Model stability measures
The model stability measures track the change in distribution of the modeling data and the scoring data.

Model performance measures
The model performance measures report this information:

- The model’s ability to discriminate between accounts that have defaulted and those that have not defaulted. The score difference between the accounts that default and those that do not helps determine the cut-off score, which is used to predict whether a credit exposure is a default.

- The relationship between the actual default probability and the predicted probability. This information is used to understand a model’s performance over a period of time.
Model calibration measures
The model calibration measures check the accuracy of the LGD and PD models by comparing the correct quantification of the risk components with the available standards.


The tutorial provides examples and step-by-step directions for importing LGD and PD models and creating Basel II reports.

---

**Prerequisites**

The exercises in this tutorial require that the Tutorial 6 data sets and models from SMM121Tutorial.zip be extracted and registered in SAS Management Console. If they have not been extracted and registered, see “Prepare Tutorial 6 Data Sets and Models” on page 10 to extract and register the files.

Importing models requires that you know where the SAS Model Manager administrator installed the Tutorial 6 models. If you do not know the location of the models, contact your SAS Model Manager administrator.

The data sets for the traffic light benchmarks and validation grade default thresholds that are used to create the Basel II reports are located in the directory `\<server-name>\<install-directory>\Program Files\SASHome\SASFoundation\9.3\mmcore\sashelp`. This tutorial uses the default thresholds in the data sets that are located in the sashelp directory. It is not recommended to directly modify the data sets in the sashelp directory. Use one of the following methods if you want to change the default values before creating the Basel II reports.

- Copy the data sets from the sashelp directory to the location of the input table that is used when creating the Basel II reports. Examples of the input table directory location are `C:\SMM121Tutorial\Tutorial6\Samples\LGD` and `C:\SMM121Tutorial\Tutorial6\Samples\PD`.

Here are the default Basel II data sets and index that are located in the sashelp directory:

- traffic_light_benchmarks.sas7bdat
- validation_grade.sas7bdat
- validation_grade.sas7bndx

- Assign the MMBASEL library reference (libref) using SAS Management Console, or create a libref for a local or network drive using the SAS start-up code feature of SAS Model Manager. The library name must also be MMBASEL if you use SAS Management Console to define the library. Copy the data sets and index from the sashelp directory to the new MMBASEL library location.

- The search order for the data sets is the following:
  1. The library where the input table is located.
  2. The MMBASEL library, if it exists.
  3. The sashelp directory located on the server that SAS was installed.

For more information about modifying the default thresholds in the data sets for the Basel II reports, see the SAS Model Manager product documentation page on [support.sas.com](http://support.sas.com).
Organize the Model Hierarchy

In this exercise, you create an organizational folder, a project, and a version for the modeling project.

Create a Folder

To provide an organizational folder to manage your modeling projects, follow these steps:

1. Right-click the MMRoot node in the Project Tree and select New ➡ New Folder. The New Folder dialog box appears.
2. Specify the following folder properties and click OK.
   - Name: enter Tutorial6.
   - Description: enter an optional folder description. For example, enter Basel II Reports Tutorial.

The new folder appears in the Project Tree.

Create a New Project

To create a project that is associated with the classification model function, follow these steps:

2. Specify the following project properties and click Next:
   - Name: enter PD for the project name.
   - Description: enter an optional description.
   - Model Function: select Classification.
3. In Step 2 of the New Project Wizard, specify the project variables:
   a. Click the Import Variables button for the Project Input Variables table. Double-click Shared Data ➡ Model Manager ➡ Tutorial6 ➡ PD. Select HMEQ_PROJECT_INPUT and click OK.
   b. For the PD classification project, click the Import Variables button for the Project Output Variables table. Select HMEQ_PROJECT_OUTPUT and click OK.
   c. Click Finish.
4. Examine the Tutorial6 folder to verify that it contains the project.
To create a project that is associated with the prediction model function, follow these steps:

1. Right-click the Tutorial6 folder and select \**New** \*New Project. The New Project Wizard appears.

2. Specify the following project properties and click Next.
   
   **Name**
   enter LGD-Interval for the project name.

   **Description**
   enter an optional description.

   **Model Function**
   select Prediction.

3. In Step 2 of the New Project Wizard, specify the project variables:
   
   a. Click the Import Variables button for the Project Input Variables table.
      Double-click Shared Data \*Model Manager \*Tutorial6 \*LGD. Select LGD_PROJ_INPUT and click OK.

   b. Click the Import Variables button for the Project Output Variables table.
      Double-click Shared Data \*Model Manager \*Tutorial6 \*LGD. Select LGD_PROJ_OUTPUT and click OK.

   c. Click Finish.

4. Examine the Tutorial6 folder to verify that it contains the project.

**Define the Project Properties**

To define the properties that SAS Model Manager uses to create reports and score models, follow these steps:

1. Select the PD project in the Tutorial6 folder and expand Specific Properties in the right pane.

   Specify the default data tables and model variables for the PD project:

   **Default Test Table**
   select HMEQ_TEST.

   **Default Scoring Task Input Table**
   select PD_SCORE_INPUT.

   **Default Scoring Task Output Table**
   select PD_SCORE_OUTPUT.

   **Default Train Table**
   select HMEQ_TRAIN.

   **Training Target Variable**
   enter BAD for the PD project that has a model function type of classification.

   **Target Event Value**
   enter 1 for the PD project that has a model function type of classification.

   **Class Target Level**
   select Binary for the PD project that has a model function type of classification.

   **Output Event Probability Variable**
   select score for the PD project that has a model function type of classification.
Here is an example of the PD project properties:

2. Select the LGD-Interval project in the Tutorial6 folder and expand Specific Properties in the right pane.

Specify the default data tables and model variables for the LGD-Interval project:

**Default Scoring Task Input Table**
- select LGD_SCORE_INPUT.

**Default Scoring Task Output Table**
- select LGD_SCORE_OUTPUT.

**Training Target Variable**
- enter lgd for the LGD-Interval project that has a model function type of prediction.

**Class Target Level**
- select Interval for the LGD-Interval project that has a model function type of prediction.

**Output Prediction Variable**
- select p_lgd for the LGD-Interval project that has a model function type of prediction.

Here is an example of the LGD-Interval project properties:
Create a Version

Create a version for each project. The version folder contains life cycle information, auxiliary version documents, candidate model files, reports, resource files, scoring tasks, and model performance reports.

To create a new version, follow these steps:

1. Right-click the PD project and select New ➔ New Version. The New Version dialog box appears.
2. Specify the following version properties and click OK.
   - **Name**: enter 2012.
   - **Life Cycle Template**: select the user-defined template Tutorial Life Cycle that you created in the first tutorial. For more information, see “Create a Life Cycle Template” on page 29.
   - **Note**: If you are using a workflow process to track the progress of your version, you can select any life cycle template. You can then skip all tasks to update the life cycle.
3. Examine the PD project to verify that it contains one version called 2012. Select Life Cycle. Verify that the Name property is Tutorial Life Cycle.
4. Repeat steps 1 through 3 for the LGD-Interval project.

Note: To use a workflow process to track the progress of your version, send a request to a SAS Model Manager administrator to create a workflow to use for the tutorials. Include the name and UUID of the version with which you want the workflow to be associated.

---

Import Models

In this exercise you import models into SAS Model Manager from a SAS model package file, and you also import a SAS code model from local files. Then you map the model variables. SAS code models consist of the SAS code and the model component files (metadata) that are used to process a model in SAS Model Manager. To import a SAS code model, at least three component files are required: the model score code, the model input file, and the model output file. For prediction or classification models, you also must prepare model target files.

Import Model Package Files

SAS Enterprise Miner and SAS/STAT linear model package files, or SPK files, contain complete model information. You can import SAS Enterprise Miner and SAS/STAT models even if they are not registered in the SAS Metadata Repository. For information about how to create a package file, see the SAS Model Manager: User's Guide.

To import a model that was saved as a package file, follow these steps:

1. Expand the 2012 version in the PD project and right-click the Models folder. Then select Import From ⇒ SAS Model Package File. The SAS Model Package File dialog box appears.

2. In the Model Name field, enter HMEQ Scorecard.

3. Navigate to the location of the folder that contains the SAS package files. For this example, use <drive:\Tutorial6\Samples\PD that was installed by the SAS
Model Manager administrator. For more information, see “Prepare Tutorial 6 Data Sets and Models” on page 10.

4. Select the `hmeq_scorecard.spk` file and click **OK**.

![Image of SAS Model Package File]

5. Examine the **Models** folder to verify that it contains the models. Right-click the folder and select **Expand All** to examine the model files.

**Import SAS Code Models**

1. Expand the **2012** version in the **LGD-Interval** project and right-click **Models**. Then select **Import from ➪ Local Files**. The Local Files window appears.

2. Import an LGD model.
   a. In the left pane, expand the **Desktop** folder and select `<drive>:\Tutorial6\Samples\LGD`.
   b. In the **Choose a model template** box, select **Prediction**.
   c. Type **LGD** in the **Name** box. For each filename in the Object column, click the filename and drag it to the corresponding option box. This action maps the tutorial model component filenames to the SAS Model Manager model component filenames.

<table>
<thead>
<tr>
<th>Object</th>
<th>Option</th>
</tr>
</thead>
<tbody>
<tr>
<td>lgd_model_input.sas7bdat</td>
<td>modelinput.sas7bdat</td>
</tr>
<tr>
<td>lgd_model_output.sas7bdat</td>
<td>modeloutput.sas7bdat</td>
</tr>
<tr>
<td>lgd_model_est.sas7bdat</td>
<td>outest.sas7bdat</td>
</tr>
<tr>
<td>lgd_score.sas</td>
<td>score.sas</td>
</tr>
<tr>
<td>lgd_model_target.sas7bdat</td>
<td>target.sas7bdat</td>
</tr>
<tr>
<td>lgd_training.sas</td>
<td>Training.sas</td>
</tr>
</tbody>
</table>

*Note:* This file is needed only if you want to retrain the model.
Here is the Local Files window after the files have been mapped.

3. Examine the Models folder to verify that it contains the model. Right-click the folder and select **Expand All** to examine the model files.

**Map Model Variables to Project Variables**

When the names for the model output variable are not identical to the names for the project output variables, you must map the variables.

To map model output variables to project output variables, follow these steps:

1. Map model variables for the first model. Select **HMEQ Scorecard** in the Models folder, click the **Model Mapping** tab in the right pane, and click **Edit**. Set the following mapping and click **OK**:

<table>
<thead>
<tr>
<th>Project Variables</th>
<th>Model Variables</th>
</tr>
</thead>
<tbody>
<tr>
<td>score</td>
<td>P_BAD1</td>
</tr>
</tbody>
</table>

2. Map model variables for the LGD model. Right-click **LGD** in the Models folder of the **2012** version in the **LGD-Interval** project, and select **Set Model Output Mapping**. Set the following mapping and click **OK**:
Create Basel II Reports

In this exercise, you create the Basel II reports that are used to validate models. The Probability of Default (PD) report can be created for a classification model. The Loss Given Default (LGD) report can be created only for a prediction model. After you create the reports, you view them in the Reports folder. The reports enable you to validate candidate models in a version or across versions.

Create a Probability of Default (PD) Report

To create a PD report, follow these steps:

1. Expand the 2012 version folder in the PD project.
3. Select Probability of Default Model Validation Report from the Type box.
4. For the type of output that you want to create, accept the default value of PDF in the Format box. The other format that is available is RTF.

5. Select the HMEQ Scorecard model from the Select Models list.

6. Complete the Report Properties:
   - Enter a report name if you do not want to use the default value for the Name property. For example, enter Tutorial-6 PD.
   - (Optional) Enter a report description.
   - For the Input Table property, click the Browse button and select the PD_SCORE_INPUT table from the SAS Metadata Repository tab or from the SAS Libraries tab. The table can contain only input variables or it can contain input and output variables.
   - If the input table contains only input variables, set Run Scoring Task to Yes. If the input table contains input and output variables, set Run Scoring Task to No. For this exercise set Run Scoring Task to Yes, since the PD_SCORE_INPUT table contains only input variables.
   - The Time Period Variable specifies the variable from the input table whose value is a number that represents the development period. This value is numeric. The time period for PD reports begins with 1. Accept the default value of period.
• (Optional) In the **Time Label Variable** field, enter the variable from the input table that is used for time period labels. When you specify the time label variable, the report appendix shows the mapping of the time period to the time label. Enter a value of `timelabel` to include the appendix in the report.

• **Scorecard Bin Variable** is the variable from the input table that contains the scorecard bins. If the scoring job for the PD report is run outside SAS Model Manager, the scorecard bin variable must be a variable in the input table. If scoring is done within SAS Model Manager, do not include the variable in the input table. Accept the default value of `scorecard_bin`.

• **Scorecard Points Variable** is the variable that contains the scorecard points. If the scoring job for the PD report is run outside SAS Model Manager, the scorecard points variable must be a variable in the input table. If scoring is done within SAS Model Manager, do not include the variable in the input table. Accept the default of `scorecard_points`.

• **Cut-off Value** is the maximum value that can be used to derive the predicted event and to further compute accuracy, sensitivity, specificity, precision, and error rate. Accept the default of 100.

---

**Note:** The variable names that you specify can be user-defined variables. A variable mapping feature maps the user-defined variables to required variables.
7. Click OK. A dialog box message confirms that the report was created successfully.

Create a Loss Given Default (LGD) Report

To create an LGD report, follow these steps:

1. Expand the 2012 version folder in the LGD-Interval project.
3. Select Loss Given Default Report from the Type box.

4. For the type of output that you want to create, accept the default value of PDF in the Format box. The other format option that is available is RTF.

5. Select the LGD model from the Select Models list.

6. Complete the Report Properties:
   - Enter a report name if you do not want to use the default value for the Name property. For example, enter Tutorial-6 LGD.
   - (Optional) Enter a report description.
   - For the Input Table property, click the Browse button and select the LGD_SCORE_INPUT table from the SAS Metadata Repository tab or from the SAS Libraries tab that is used for scoring during the creation of the LGD report. The table can contain only input variables or it can contain input and output variables.
• If the input table that is specified in the **Input Table** property contains only input variables, set **Run Scoring Task** to **Yes**. If the input table contains input and output variables, set **Run Scoring Task** to **No**. For this exercise set **Run Scoring Task** to **Yes**, since the **LGD_SCORE_INPUT** table only contains input variables.

• The **Time Period Variable** specifies the variable from the input table whose value is a number that represents the development period. This value is numeric. Accept the default value of **period**.

• (Optional) In the **Time Label Variable** field, enter the variable from the input table that is used for time period labels. When you specify the time label variable, the report appendix shows the mapping of the time period to the time label. Enter a value of **timelabel** to include the appendix in the report.

• **Actual Variable** is the actual LGD variable. Accept the default value of **lgd**.

• **Predicted Variable** is the project scoring output variable. If the scoring for the LGD report is performed outside SAS Model Manager, the input data set must include this variable. If the scoring for the LGD report is done by SAS Model Manager, the input data set should not include this variable. Accept the default value of **p_lgd**.

• **Pool Variable** is the variable from the input table that is used to identify a two-character pool identifier. Accept the default of **pool_id**.
The variable names that you specify can be user-defined variables. A variable mapping feature maps the user-defined variables to required variables.

7. Click **OK**. A dialog box message confirms that the report was created successfully.

### View Basel II Reports

To view a Basel II report, follow these steps:

1. Expand the version folder **2012** and the **Reports** folder.
2. Right-click the report name and select **View Report**.

   *Note:* If user credentials are required, then specify a user ID and password that have permission to access the SAS Content Server.

3. Use the PDF or RTF viewer to distribute or print a copy of the report.
4. Close the PDF or RTF viewer.

Overview of Advanced Reporting

The advanced reporting capability of SAS Model Manager enables you to create three different types of reports.

- User-defined reports enable your company to add enterprise-specific reports to the existing list of reports that are available via the New Report dialog box.
- Ad hoc reports enable you to create one-of-a-kind reports as you need them.
- Aggregated reports enable you to combine multiple reports that you can distribute to company stakeholders.

To make it easy to create these reports, SAS Model Manager provides a number of SAS macro variables and SAS macro programs. These macros can be used to gain access to model-specific information as well as to more general folder and user information.

This tutorial shows you the basic tasks that are involved in creating new SAS Model Manager reports. It contains examples and step-by-step directions about setting up and running ad hoc and user-defined reports. It also shows you how to combine multiple reports by creating an aggregated report.
Prerequisites

Models Used in Tutorial 2

The exercises in this tutorial depend on some of the properties of the specific models that were added in Tutorial 2. Use the projects, versions, or models that are specified here. This tutorial is designed to follow Chapter 3, “Tutorial 2: Performing Basic SAS Model Manager Tasks,” on page 41.

The Required Tutorial Files

The SAS programs that are required for this tutorial are on your local computer after you extract them from the ZIP file SMM121Tutorial.zip. If you have not extracted the tutorial files, see “Install and Register the Tutorial Files” on page 3.

This tutorial requires the following files in the <drive>/Tutorial7/Samples folder:

- RptVars.sas
- ScoreRange.sas
- ScoreRangeMacro.sas
- ScoreRangeTemplate.xml

Create a Simple Ad Hoc Report

In this exercise, you create a PDF file to display the macro variables that are available in the SAS Model Manager reporting environment:

1. In the <drive>/Tutorial7/Samples folder, open the tutorial example report RptVars.sas in a text editor.
2. Copy the code from RptVars.sas.
3. Log on to SAS Model Manager.
4. Open the Create Ad Hoc Report window:
   a. Expand the Tutorial2 folder, the Delinquency project, and the 2012 version.
   b. Right-click the Reports folder and select Reports ⇄ Create Ad Hoc Report.
5. In the Create Ad Hoc Report window, select Model 1 in the Select Models table.
6. In the SAS Editor, paste the code that you copied in Step 2.
7. In the Name field of the Report Properties table, enter RptVars.
8. Click OK. SAS Model Manager creates the report. Click Close in the information message. SAS Model Manager then highlights and expands the Reports folder.

9. To view the report, expand the new report RptVars, right-click RptVars.pdf, and select Open.

Here is page 2 of the PDF report output:

Create an Ad Hoc Score Range Report

In this exercise, you create an ad hoc report to categorically display score ranges in an HTML report. To create output in HTML from an ad hoc report, ensure that the report code is enclosed by a SAS Model Manager formatting macro. To do this, follow these steps:

1. In the <drive>/Tutorial7/Samples folder, open the example report ScoreRange.sas and copy the code.

2. If necessary, log on to SAS Model Manager.

3. In the Project Tree, expand the Tutorial2 folder, the Delinquency project, and the 2012 version.
4. Right-click the **Reports** folder and select **Reports ➤ Create Ad Hoc Report**.

5. In the Create Ad Hoc Report window, select **Model 1** in the **Select Models** table.

6. In the **SAS Editor**, paste the code that you copied in Step 1.

7. Modify the Score Range code to format the report in HTML, and set the report style.

   The ScoreRange.sas program uses the SAS Model Manager formatting macros, which enable user reports to be formatted in PDF, HTML, RTF, and Excel. A beginning formatting macro code precedes the report code. The ending formatting macro must be the last line of code in the report program.

   a. Add the arguments `reportFormat=html` and `reportStyle=Seaside` to the `%MM_ExportReportsBegin` macro argument list. Here is the modified macro:

   ```sas
   %MM_ExportReportsBegin(reportFormat=html, reportStyle=Seaside, fileName=ScoreRange);
   ```

   b. Add the argument `reportFormat=html` to the `%MM_ExportReportsEnd` macro argument list. Here is the modified macro:

   ```sas
   %MM_ExportReportsEnd(reportFormat=html);
   ```

8. In the **Name** field of the **Report Properties** table, enter **ScoreRange**.

9. Click **OK**. SAS Model Manager runs the report and creates the **ScoreRange** folder under the **Reports** folder.

10. To view the **ScoreRange** report, expand the **ScoreRange** folder, right-click **ScoreRange.html**, and select **Open**.

    Here is the output from the FREQ procedure as a table and as a graph:

    **Display 8.1 The Score Range Report Table**

    **Credit Score Range**

    **The FREQ Procedure**

    | score          | Frequency | Percent | Cumulative Frequency | Cumulative Percent |
    |----------------|-----------|---------|---------------------|--------------------|
    | 400 and Below  | 1419      | 14.19   | 1419                | 14.13              |
    | 401 - 450      | 322       | 3.22    | 1741                | 17.41              |
    | 451 - 500      | 249       | 2.49    | 1980                | 19.90              |
    | 501 - 550      | 206       | 2.06    | 2186                | 21.95              |
    | 551 - 600      | 181       | 1.81    | 2367                | 23.57              |
    | 601 - 650      | 213       | 2.13    | 2570                | 25.70              |
    | 651 - 700      | 340       | 3.40    | 2910                | 29.10              |
    | 701 - 750      | 344       | 3.44    | 3254                | 32.54              |
    | 751 - 800      | 777       | 7.77    | 4031                | 42.31              |
    | 801 and Above  | 5969      | 59.69   | 10060               | 100.00             |
Install a User-defined Score Range Report

In this exercise, you upload the Score Range report to SAS Content Server. After the template is uploaded, you can run the Score Range report from the New Reports wizard. This exercise has two parts. In the first exercise, you upload the report files to the SAS Content Server. In the second exercise, you create a Score Range report from the New Reports wizard. To upload a report XML file or SAS file, you must have a user ID that is in the Model Manager Administrator Users group.

Install a User-defined Report

To upload the Score Range report to the New Reports wizard, follow these steps:

1. From the SAS Model Manager window, select Tools ⇒ Manage Templates. The SAS Model Manager Template Editor appears.

2. Select File ⇒ Open and navigate to <drive>Tutorial7\Samples. In the Files of type box, select SAS files (*.sas). Select ScoreRange.sas and click OK. The template opens in the Template Editor.

3. Select File ⇒ Upload File, verify the file information in the Upload File window, and click OK. When a confirmation message appears, click Close.

4. Select File ⇒ Open and navigate to <drive>Tutorial7\Samples. In the Files of type box, select SAS files (*.sas). Select ScoreRangeMacro.sas and click OK. The template opens in the Template Editor.

5. Select File ⇒ Upload File, verify the file information in the Upload File window, and click OK. When a confirmation message appears, click Close.

6. Select File ⇒ Open and navigate to <drive>Tutorial7\Samples and select ScoreRangeTemplate.xml. Click OK. The template opens in the Template Editor.
7. Select File ➔ Upload File, verify the file information in the Upload File window, and click OK. When a confirmation message appears, click Close.

Run the New User-defined Report

To execute the installed score range report, follow these steps:

1. Log on to SAS Model Manager.
2. Expand the Tutorial2 folder, the Delinquency project, and the 2012 version.
4. In the Type box, select Score Range Report.
5. In the Format box, select HTML.
6. In the Style box, select Seaside.
7. In the Select Model table, select Model 1.
8. If a ScoreRange report exists in the Reports folder from the previous exercise, you can name the report using the default filename or ScoreRange2 in the Name box of the General Properties table.
9. Click OK.

10. Click Close in the information message.

11. To view the new report, expand the new score range report, right-click ScoreRange.html, and select Open. To view the report output, see Display 8.1 on page 184 and Display 8.2 on page 185.

For more information about this task, see the SAS Model Manager: User's Guide.

---

Combining Multiple Reports

**About Combining Multiple Reports**

You can combine multiple reports from the Reports node to create a single, aggregated report. SAS Model Manager administrators and advanced users can create an aggregated report in two steps. First, you open the Define Aggregated Report window from an organizational folder, a project, or a version. Using reports that reside in the Reports folder, you select those that you want in your aggregated report to create an aggregated report definition. Next, you generate the aggregated report using the aggregated report definition. The format of the report can be PDF, HTML, or RTF. Aggregated reports are stored in the Documents folder within the node from which you selected the Define Aggregated Report pop-up menu option.

The reports that are selected are rerun to create the aggregated report. If the data set content that the selected reports use has changed since the last time you ran the report, the results might be different from the original reports. Ad hoc reports, LGD reports, and PD reports cannot be added to an aggregated report.

In this exercise, you combine multiple reports to create an aggregated report.
Create an Aggregated Report

To create an aggregated report, you must have two or more existing reports in the Reports node in the 2012 version. You first create an aggregated report definition, and then generate the report.

To create an aggregated report, follow these steps:


   Note: The Define Aggregated Report pop-up menu item is available only to SAS Model Manager administrators and advanced users.

2. In the Name field, enter Tutorial–7 Aggregated Report for the name of the report.

3. (Optional) In the Description field, enter a description for the report.

4. Accept the default value of PDF in the Format list box. The other available output formats are HTML and RTF.

5. Expand the Reports node of the 2012 version in the Available items box. Select the Delta, Dynamic Lift, and Model Profile reports that you created in Tutorial 2 from the Available items box, and click the single right arrow. The reports appear in the Selected items box.

   Note: To add all reports in the Reports node, click the double right arrow. To remove reports from the Selected items box, select the report and click the single left arrow to remove one report, or click the double right arrow to remove all reports.
6. (Optional) To order the reports, select a report, and use the up and down arrows.

7. When all of the reports are in the **Selected items** box and in the correct order, click **OK**. An object for the aggregated report definition and an **Output** node appear in the **Documents** folder within the **2012** version.

8. Expand the **Documents** folder.

9. Right-click the aggregated report definition name and select **Generate Aggregated Report**. A message appears to indicate whether the report was generated. If it was successful, click **Close**. If it was not successful, click **Details** to view the SAS log.

10. To view the report, expand the **Output** folder for the aggregated report, right-click the report, and select **Open**. If prompted, enter your user ID and password.

**Edit an Aggregated Report (Optional)**

To edit an aggregated report, follow these steps:

1. Expand the **Documents** folder in the **2012** version. Right-click the aggregated report and select **Edit Aggregated Report**. The Edit Aggregated Report window appears.
2. Modify the report definition:
   a. In the Name field, modify the name.
   b. In the Description field, enter a description for the report.
   c. Click the Format list box and select an output format. The default is PDF.
   d. To add reports to the report definition, select the report in the Available items box and click the single right arrow.
   e. To remove reports from the report definition, select the report from the Selected items box and click the single left arrow.
   f. To order the reports, select a report and use the up and down arrows.
   g. Click OK.

3. Right-click the aggregated report name and select Generate Aggregated Report. A message appears to indicate whether the report was generated. If it was successful, click Close. If it was not successful, click Details to view the SAS log.

4. To view the modified report, expand the Output folder for the aggregated report, right-click the report, and select Open. If prompted, enter your user ID and password.

Note: To delete an aggregated report, right-click the report node in the Documents folder, and select Delete. Click Yes to confirm. The aggregated report definition and Output folder are deleted.
Overview of Using Advanced Features

This tutorial is designed to enable a user who is already familiar with the administrative and the basic functions of SAS Model Manager to perform the following tasks:

• create a new model template using the SAS Model Manager Template Editor
• upload the new model template to the SAS Content Server
• import a model that is described by the template
• generate a report on the model

The tutorial contains examples and step-by-step directions for performing these tasks.

Example Scope

The model used in this tutorial is based on the ARBORETUM procedure, which is a SAS Enterprise Miner procedure.
Prerequisites

The exercises in this tutorial require that the Tutorial 8 data sets and models from SMM121Tutorial.zip be extracted and registered in SAS Management Console. If they have not been extracted and registered, see “Prepare Tutorial 8 Data Sets and Models” on page 13 to extract and register the files.

The <drive>Tutorial8\Samples\Model8 folder contains these model template files that are used in this tutorial:

- importance8.sas7bdat
- modelinput8.sas7bdat
- modeloutput8.sas7bdat
- nodestat8.sas7bdat
- path8.sas7bdat
- rules8.sas7bdat
- score8.sas
- target8.sas7bdat

Organize the Model Hierarchy

In this exercise, you use the Project Tree to create a modeling project.

Create a Folder

To provide an organizational folder to manage your modeling projects, follow these steps:

1. Right-click the MMRoot node in the Project Tree and select New ➔ New Folder. The New Folder dialog box appears.
2. Specify the following folder properties and click OK:
   - Name: enter Tutorial8.
   - Description: enter an optional folder description.

Create a New Project

To create a project and define the model function, follow these steps:

2. Specify the following project properties and click Next:
Name
   enter HmeqVars.

Description
   enter an optional description.

Model Function
   select Classification.

3. Below the Project Input Variables table, click Import Variables and navigate to
   the Tutorial8 folder in the SAS Metadata Repository. Select
   HMEQ_PROJECT_INPUT and click OK.

4. Below the Project Output Variables table, click Import Variables and navigate to
   the Tutorial8 folder in the SAS Metadata Repository. Select
   HMEQ_PROJECT_OUTPUT and click OK.

5. Click Finish.

**Define the Project Properties**

To define the properties that SAS Model Manager uses to create reports and model
scores, follow these steps:

1. Select the HmeqVars project in the Tutorial8 folder and expand Specific
   Properties in the right pane.

2. Specify the default data tables and model variables for the project:
   
   **Default Test Table**
   select HMEQ_TEST.

   **Default Scoring Task Input Table**
   select HMEQ_SCORE_INPUT.

   **Default Scoring Task Output Table**
   select HMEQ_SCORE_OUTPUT.

   **Default Train Table**
   select HMEQ_TRAIN.

   **Training Target Variable**
   enter bad.

   **Training Event Value**
   enter 1.

   **Class Target Level**
   select Binary.

   **Output Event Probability Variable**
   select score.
Create a Version

Create the version for the project. The version folder contains life cycle information, auxiliary version documents, candidate model files, model comparison reports, resource files, scoring tasks, and model performance reports. To create a new version, follow these steps:

1. Right-click the `HmeqVars` project and select **New**  ➔ **New Version**. The New Version dialog box appears.

2. Specify the following version properties and click **OK**.
   
   **Name**
   enter **2012**.

   **Life Cycle Template**
   select the user-defined template **Tutorial Life Cycle** that you created in the first tutorial. For more information, see “Create a Life Cycle Template” on page 29. If **Tutorial Life Cycle** is not a selection in the list, select any life cycle template.

3. Examine the `HmeqVars` project to verify that it contains one version, **2012**.
Create and Upload a Model Template

In this exercise, you create a new model template using the SAS Model Manager Template Editor. For information about creating a model template, see the *SAS Model Manager: User's Guide*.

To create a model template, follow these steps:

1. Open the SAS Model Manager Template Editor. Select **Tools ➜ Manage Templates**.

2. Open an empty model template in the template editor. Select **File ➜ New Model Template**. An empty, untitled model template opens.

3. Specify the model template properties.
   a. In the **Name** field, replace **Untitled Template** with **ProcArborModelTemplate**.
   b. Click the **Type** box and select **Classification Model**.
   c. In the **Tool** field, enter **SAS Enterprise Miner**.
   d. In the **Display Name** field, enter **Proc Arbor Model**.
   e. Click the **Score Code Type** box and select **DATA step**.

Here is the template editor after this step has been completed:
4. Add the model component files and the model component file properties.

The following table lists the model component files that comprise the model, and the properties for each file. For each model component file, add an entry under FileList. Then, select the file under FileList and enter the properties for that file. A value of none indicates that you do not need to set a value for that property.

To add the model component files, right-click FileList and select New File Item. In the Name field, enter the name from the table and click OK.

Here is the template after adding the file score.code as a model component file:

<table>
<thead>
<tr>
<th>Filename</th>
<th>Description</th>
<th>Required</th>
<th>Report</th>
<th>Type</th>
<th>Fileref</th>
</tr>
</thead>
<tbody>
<tr>
<td>score.sas</td>
<td>Score code for Proc Arbor model</td>
<td>select the box</td>
<td>select the box</td>
<td>text</td>
<td>ScoreCod</td>
</tr>
<tr>
<td>modelinput.sas7bdat</td>
<td>Model input table</td>
<td>none</td>
<td>select the box</td>
<td>binary</td>
<td>none</td>
</tr>
<tr>
<td>modeloutput.sas7bdat</td>
<td>Model output table</td>
<td>none</td>
<td>select the box</td>
<td>binary</td>
<td>none</td>
</tr>
</tbody>
</table>
5. Add a system property.
   a. In the left pane, right-click System and select New Property. In the Name field, enter Modeler and click OK.
   b. Select Modeler and enter the following property values:

   **Description**
   
   The model creator.

   **Display Name**
   
   Modeler

   Default values are used for all other property values. Here is the template after the system property has been added:

   ![System Property Template](image)

6. Add user properties.

   The following table lists user properties for the model template and the properties of each user property. For each user property, add an entry under User. Then, select the property under User and enter the properties for the user property. A value of none indicates that you do not need to set a value for that property.

   To add a user property, right-click User and select New Property. In the Name field, enter the name from the table and click OK.

   Here is the template after the user property Citi1 has been added:
Table 9.2  ProcArborModelTemplate User Properties and User Property Properties

<table>
<thead>
<tr>
<th>Filename</th>
<th>Description</th>
<th>Type</th>
<th>Edit</th>
<th>Required</th>
<th>Initial Value</th>
<th>Display Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Citi1</td>
<td>none</td>
<td>String</td>
<td>select the box</td>
<td>none</td>
<td>none</td>
<td>Citi1</td>
</tr>
<tr>
<td>Citi2</td>
<td>none</td>
<td>String</td>
<td>select the box</td>
<td>none</td>
<td>none</td>
<td>Citi2</td>
</tr>
<tr>
<td>Citi3</td>
<td>none</td>
<td>String</td>
<td>select the box</td>
<td>none</td>
<td>none</td>
<td>Citi3</td>
</tr>
<tr>
<td>Citi4</td>
<td>none</td>
<td>String</td>
<td>select the box</td>
<td>none</td>
<td>none</td>
<td>Citi4</td>
</tr>
<tr>
<td>Citi5</td>
<td>none</td>
<td>String</td>
<td>select the box</td>
<td>none</td>
<td>none</td>
<td>Citi5</td>
</tr>
</tbody>
</table>

7. Save the template. Saving the template creates a backup of the template. Select File ➔ Save As and enter ProcArborModelTemplate2.xml in the File name field. Click OK.

Here is the model template after all files and properties have been added to the template:
8. Select File ➤ Upload File to upload the template to the SAS Content Server. In the Upload File window, verify the information and click OK.

Note: If the template filename already exists and is reserved by SAS Model Manager, you receive an error message indicating to enter a unique filename for the template.

9. Select File ➤ Exit to close the SAS Model Manager Template Editor.

---

**Import a Model**

**Import a Model**

In this exercise, you import a model using the user model template:

1. Log on to SAS Model Manager.

2. In the 2012 version of the HmeqVars project, right-click Models and select Import from ➤ Local Files.

3. From the Choose a model template box, select ProcArborModelTemplate. The custom properties and files appear in the right pane.

4. In the Name field, enter ProcArbor.

5. In the left pane, expand Desktop to <drive>:\Tutorial8\Samples\Model8. The Local Files dialog box displays the template in the right pane and the files to import in the left pane:
6. From the left pane, drag the following files to the corresponding fields in the model template:

<table>
<thead>
<tr>
<th>Filename</th>
<th>Template Field Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>importance8.sas7bdat</td>
<td>importance.sas7bdat</td>
</tr>
<tr>
<td>modelinput8.sas7bdat</td>
<td>modelinput.sas7bdat</td>
</tr>
<tr>
<td>modeloutput8.sas7bdat</td>
<td>modeloutput.sas7bdat</td>
</tr>
<tr>
<td>nodestat8.sas7bdat</td>
<td>nodestat.sas7bdat</td>
</tr>
<tr>
<td>path8.sas7bdat</td>
<td>path.sas7bdat</td>
</tr>
<tr>
<td>rules8.sas7bdat</td>
<td>rules.sas7bdat</td>
</tr>
<tr>
<td>score8.sas</td>
<td>score.sas</td>
</tr>
<tr>
<td>target8.sas7bdat</td>
<td>target.sas7bdat</td>
</tr>
</tbody>
</table>

Here is the Local Files dialog box after the files have been assigned:
7. Click OK. The ProcArbor model appears under the Models folder.

Verify Model Properties

Verify some model properties:

1. In the Project Tree, expand the Models folder and select ProcArbor.
2. In the Properties View, verify BAD as the value of the Target Variable property.
3. Verify that the Score Code Type property is DATA step.

Here is the ProcArbor model in the SAS Model Manager window:
Map Model Output Variables to Project Output Variables

Because the project output variable name is not the same as the model output variable name, the output variables must be mapped. To map the variables, follow these steps:

1. Right-click the model name, **ProcArbor**.
2. Select the **Set Model Output Mapping** option to open the Set Model Output Mapping window.
3. Click the **Model Variables** column for score, select **P_BAD1**, and click **OK**.
Create an Ad Hoc Variable Importance Report

In this exercise, you create a report that is based on the model's PROC ARBORETUM importance data.

1. In the <drive>:Tutorial8/Samples folder, open the example report VarImportance.sas in a text editor and copy the code.

2. In the Project Tree, expand the Tutorial8 folder and the project HmeqVars.


4. In the Create Ad Hoc Report dialog box, check the box for ProcArbor in the Select Models table.

5. In the SAS Editor, paste the code that you copied in Step 1.

6. In the Name field, enter VariableImportance and click OK. After the report is created successfully, click Close to close the information message.
7. View the report output.
   a. Expand the new report, **VariableImportance**.
   b. Right-click **ProcArbor.html** and select **Open**.
   c. If prompted, enter your user ID and password.
Here is the Variable Importance report:

**Variable Importance**

<table>
<thead>
<tr>
<th>NAME</th>
<th>RELATIVE IMPORTANCE</th>
</tr>
</thead>
<tbody>
<tr>
<td>CLAGE</td>
<td>0.40</td>
</tr>
<tr>
<td>DELING</td>
<td>1.00</td>
</tr>
<tr>
<td>JOB</td>
<td>0.38</td>
</tr>
<tr>
<td>LOAN</td>
<td>0.60</td>
</tr>
<tr>
<td>VALUE</td>
<td>0.80</td>
</tr>
</tbody>
</table>
Overview of Retraining Models

Using SAS Model Manager, you can retrain models to respond to data and market changes. Retraining models enables you to update models and to improve model performance. When you define a model retrain task, you can select multiple models to be retrained at the same time. The definition of the model retrain task includes the destination version and training data source. The destination version is an existing version or new version that is associated with the selected project and that stores the retrained model information. The training data source contains new data for retraining the selected models.

The model retrain task enables you to specify a location to store comparison reports and retrain results. When you select the models to include in the comparison report, you can use the training data source or select a different data source to compare the performance of the new models. The model retrain task also enables you to specify the report options, including the name, format, and style of the comparison report. When you define e-mail notifications for a model retrain task, they are sent after you execute a model retrain task.

By default, the champion model for the selected project is retrained if a model is not selected. After you execute a model retrain task, if the Register new trained model option was selected, SAS Model Manager registers the new models to the destination version. The comparison report is stored in the Model Retrain folder, as well as in the report folder on the SAS Workspace Server that was specified when the model retrain task was defined.

Note: Only models that are created by using SAS Enterprise Miner, R models, or SAS/STAT linear models can be retrained.

In this tutorial, you perform the following tasks:

- define a model retrain task
execute the model retrain task

view the new retrained models and comparison report

---

### Prerequisites

The exercises in this tutorial depend on some of the properties of the specific project, version, and models that were added in Chapter 4, “Tutorial 3: Importing Models, Scheduling Scoring Tasks, and Creating Reports,” on page 75 and Chapter 6, “Tutorial 5: Creating Performance Monitoring Reports and Using Dashboard Reports,” on page 129. The folder path in the Project Tree is MMRoot → Tutorial3 → Loan → 2012.

Before you define a model retrain task, complete the following tasks:

- If you want to retrain the project champion model, ensure that the champion model is set.
- Verify that the training data set that is used in Tutorial 3 has been registered in the SAS Metadata Repository using SAS Management Console, so that you use the same data set as the training data source.
- Verify that the appropriate project and model properties are set.

Here is a list of properties:

**Classification Project Properties**
- Training Target Variable: BAD
- Target Event Value: 1
- Class Target Level: Binary
- Output Event Probability Variable: score

**Prediction Project Properties**
- Training Target Variable: DEBTINC
- Class Target Level: Interval
- Output Prediction Variable: P_DEBTINC

**Model Properties**
- Score Code Type: DATA step
- Verify that all of the project output variables are mapped to the corresponding model output variables.

---

### Define a Model Retrain Task

To define a model retrain task, follow these steps:

1. Right-click the Loan project name and select Define Model Retrain Task. The Define Model Retrain Task wizard appears.
2. Select the **Reg 1** model to be retrained.

   *Note:* To select all models, you can select the **Select All** check box. If you do not select a model, the champion model in the default version for the selected project is retrained.

3. Select **2012** as the destination version for new models.

   *Note:* If you do not select a destination version, the default location is used for the destination of the new retrained models.

(Optional) To create a new version to store the retrained models, follow these steps:

a. From the Select Models for Retrain page of the wizard, click **New**. The New Version window appears.
b. Enter a name of the new version and select a life cycle template. Entering a description of the new version is optional.

c. Click **OK**. You are then returned to the Define Model Retrain Task wizard.

4. Click **Browse** to select a value for the **Training data source** field.

![Select Table](image)

Select the **HMEQ_TRAIN** data set that is located in the `\Shared Data\Model Manager\Tutorial3\` directory of the SAS Metadata Repository. Click **OK**. You are then returned to the Define Model Retrain Task wizard.

5. Click **...** to select a value for the **Report folder**. This value is the location of the folder to store the comparison report.

**Note:** By default, the report is stored in the SAS session’s working folder on the SAS Workspace Server. You can also create subfolders in which to store the report. The length of the directory path for the retrain report folder must be equal to or less than 100 bytes. Here is an example: `\myserver.com\c:\Users\mmanalyst\Documents\My SAS Files\9.3\Model Retrain\Reports`
6. Click to select a value for the **Results folder**. This value is the location of the retrain results folder to store the model training results.

*Note:* This setting is for informational purposes only. The data sets and files that are created during model retraining are stored in this location. By default, the training results are stored in the SAS session’s working folder on the SAS Workspace Server. You can also create subfolders in which to store the results. The length of the directory path for the retrain result folder must be equal to or less than 100 bytes. Here is an example: `\\myserver.com\c:\Users\mmanalyst\Documents\My SAS Files\9.3\Model Retrain \Results`
7. Select **Register new trained model** to register the new models. If this option is not selected, the new models are not registered in the destination version in the Project Tree, and they are not saved to the model repository on the SAS Content Server.

8. (Optional) Select **Trace On** to print trace information to the SAS log file.

9. Click **Next**. The **Select Models for Comparison** page appears.

10. Select the **Reg 1** and **HMEQ_STAT_Item** models to compare them to the retrained model.

    **Note:** To select all models, you can click **Select All**. If you do not select a model, the champion model for the project is used to perform the comparison.
11. Select a comparison data source. Take one of the following steps:
   - Select **Use training data source** if you want to use `HMEQ_TRAIN` as the comparison data source. For this example the default values are used. However, you can either use the whole training data source to compare or you can partition it into two parts, based on partition percent and random seed. The percentage that is specified is the percentage of data that is used for model comparison; the other part of the data is used for training. The random seed value is used to generate the training data, based on the random sampling method.
   - Click **Browse** to select a value for the **Comparison data source** field to select a performance data set.

12. To specify the report options, follow these steps.
   a. Enter a report name. Here is an example: **HMEQ Model Comparison**.
   b. Select the **HTML** format for the report output. The default is **RTF**. The other available formats are **PDF**, **HTML**, and **Excel**.
   c. Select a style for the report. The default selection is **SAS default**. The other available styles are **Seaside**, **Meadow**, and **Harvest**.  
      
      *Note:* SAS Model Manager administrators can configure the report formats and styles that are available using SAS Management Console.

13. Click **Next**. The **Set E-Mail Notifications** page appears.
14. (Optional) To send the training results by e-mail, enter an e-mail address or multiple e-mail addresses that are separated by a comma or blank, and then click Add. To delete a recipient, select the recipient’s e-mail address and click Delete.

15. Click Finish. The SAS code is generated and placed in the Model Retrain folder of the associated project.

---

**Execute a Model Retrain Task**

The prerequisites for retraining a model must be completed and a model retrain task must be defined before you can execute a model retrain task.

To execute a model retrain task, follow these steps:

1. Expand the project folder.

2. Right-click the Model Retrain folder, and then select Execute from the pop-up menu.

   *Note:* The model retrain task is executed as a background process. You can view the progress of the model retrain task in the status bar at the bottom of the SAS Model Manager application window.

3. When the model retrain task has finished executing, a message appears. Click Close.
Note: In the previous exercise, you chose to register the retrained model. The retrained model is now available in the Models folder of the selected destination version in the Project Tree. If the model retrain task does not execute successfully, click Details, or look for error messages in the SAS log (ModelRetrain.log). You can find the SAS log and the retrained model comparison report in the new report folder that is located in the Model Retrain folder.

Viewing Retrained Models and Model Comparison Reports

After a model retrain task is executed, the new retrained models are available in the Models folder within the destination version. In addition, the retrained model comparison report is available in the new report folder that is located in the Model Retrain folder for the associated project.

View Retrained Models

To view retrained models, follow these steps:

1. Expand the destination version node 2012 to see the new retrained model in the Models folder.
2. Expand the new retrained model folder to view its contents.
View Model Comparison Reports for Retrained Models

To view a model comparison report, follow these steps:

1. Expand the report folder that you specified when you defined the model retrain task (for example, HMEQ Model Comparison_YYYY-MM-DDTMM:SS). The report folder is located in the Model Retrain folder for the associated project.

*Note:* The name of the report folder also contains a timestamp in the format of _YYYY-MM-DDTMM:SS that is supplied by the system when the report is created.
2. Right-click the report output file, and select **Open** from the pop-up menu. Specify user credentials when you are prompted. The report appears in your browser window. Here is an example of a lift chart that is part of the model comparison report.

**Lift Chart**
Note:

You can also view the model retrain report in the following ways:

• Navigate to the report folder location on the SAS Workspace Server that you specified when defining the model retrain task. Here is an example: `\myserver.com\c:\Users\mmanalyst\Documents\My SAS Files\9.3\Model Retrain\Reports`

• Open the SPK file that was sent in the e-mail notification. This action is available only if you set a notification when you defined the model retrain task.

Overview of Workflow Console

The SAS Model Manager Workflow Console is an interface to SAS Workflow that you can use to track the progress of models in a project’s version. A SAS Model Manager administrator or a SAS administrator uses SAS Workflow Studio to define process definitions and to make them available to SAS Model Manager for use. Process definitions contain the set of activities, participants, policies, statuses, and data objects that comprise a business task. After the workflow process definitions are made available, the SAS Model Manager administrator uses Workflow Console to create workflows to be used with SAS Model Manager. A workflow is a copy of a workflow process definition. Each workflow consists of activities. Activities can contain properties and
comments so that you can share information with other users, or make notes. The status
that you select when completing an activity determines the next activity in the workflow
process.

From the SAS Model Manager client application, you can launch the Workflow Console
to create a new workflow or view the workflow for a version, manage all workflows, and
view your workflow inbox to work with activities. The option that is selected and the
user permissions determine the category views and content that are displayed when
Workflow Console is launched. SAS Model Manager administrators can view the
Workflow Definitions, Workflows, and Activities category views. Other SAS Model
Manager users can view only the Activities category view. For more information about
user permissions, see “Configuring Users, Groups, and Roles” in Chapter 4 of SAS
Model Manager: Administrator's Guide.

See Also

• “Configuring SAS Workflow for Use with SAS Model Manager” in Chapter 3 of
SAS Model Manager: Administrator's Guide

Prerequisites

**Tutorial 3 Models and Data Sets**

The exercises in this tutorial require that the Tutorial 3 data sets and models from
SMM121Tutorial.zip be extracted and registered in SAS Management Console. If they
have not been extracted and registered, see “Prepare Tutorial 3 Data Sets and Models”
on page 8 to extract and register the files.

Importing models requires that you know where the SAS Model Manager administrator
installed the Tutorial 3 models. If you do not know the location of the models, contact
your SAS Model Manager administrator.

**Verify Your User ID as a Member of SAS Model Manager User Groups**

This exercise ensures that your user ID is a member of the MM Tutorial Assignees
group and the Model Manager Advanced Users group.

1. Open SAS Management Console and log on to the SAS Metadata Server.
2. On the Plug-ins tab, select User Manager.
3. In the right pane, double-click the MM Tutorial Assignees group and click the
Members tab.
4. Review the Current Members list, and locate your user ID or a group that your user
ID is a member of. If your user ID or group is not a member of the MM Tutorial
Assignees group, ask your administrator to add you to this group. Close the
properties window.
5. Find and double-click your user ID in the right pane of SAS Management Console.
6. Click the **Groups and Roles** tab. Review the **Member of** pane and locate the group **Model Manager Advanced Users**. If your user ID is not a member of this group, ask your administrator to add you to this group. Close the properties window.


---

### Organize the Model Hierarchy

In this exercise, you create a version and a new workflow for the modeling project.

**Create a Version**

Create a new version in the **Loan** project in the **Tutorial3** organizational folder. The version folder contains life cycle information, auxiliary version documents, candidate model files, reports, resource files, scoring tasks, and model performance reports.

*Note:* If you did not complete Tutorial 3, you must create an organization folder and complete the project setup tasks for the **Loan** project in Tutorial 3 before performing the tasks in this tutorial. For more information, see “Organize the Model Hierarchy” on page 77.

To create a new version, follow these steps:

1. Right-click the **Loan** project and select **New** → **New Version**. The New Version dialog box appears.

2. Specify the following version properties and click **OK**.

   - **Name**: enter 2013.
   - **Description**: enter **Version for Tutorial 10**.
   - **Life Cycle Template**: select the Life Cycle template **Basic**.

*Note:* When using a workflow process to track the progress of your version, you can select any life cycle template. You can then skip all tasks to update the life cycle.

3. Examine the **Loan** project to verify that it contains a version called **2013**. Select and expand the **2013** version.
Create a Workflow

Overview
A workflow is a copy of a workflow process definition. Only a SAS Model Manager administrator can create a new workflow. Each workflow consists of activities. Activities can contain properties and comments so that you can share information with other users, or make notes. The status that you select when completing an activity determines the next activity in the workflow process.

Prerequisites
The exercises in this tutorial require that you have made the workflow process definition available to SAS Model Manager. For more information, see “Prepare for Using SAS Workflow” on page 18.

Create a New Workflow
1. Log on to SAS Model Manager as a member of the Model Manager Administrator Users group.

2. From the SAS Model Manager main window, right-click the 2013 version and select New Workflow. Workflow Console is launched in a Web browser and displays the New Workflow window.

Note: If you are already logged on to Workflow Console, from the Workflow Definitions category view, select a workflow definition and click .
3. Select the workflow definition that is associated with this tutorial (if you accessed the New Workflow window from the SAS Model Manager main window).

4. Enter a name for the workflow.

5. The UUID of the selected version is already populated.

   *Note:* If the UUID is not already populated, you can copy the UUID system property value for a version from the Properties details view in the SAS Model Manager main window. The field label and other characters that precede the UUID value must be removed.

6. (Optional) Enter a description for the workflow.

7. Click **OK**. A message appears, indicating that the workflow has been successfully created.

8. Click **Close**. The new workflow is now available in the Workflows category view.

9. To view the new workflow, click **Workflows**. The Workflows category view appears. Select the workflow to view information that is associated with the new workflow.
The workflow process definitions that have been provided for the tutorials already have participants assigned. The **Model Manager Administrator Users** group is assigned to the business administrator workflow participant role, and the **Model Manager Advanced Users** group is assigned to the potential owner workflow participant role. For information about how to assign additional participants to a workflow, see “Working with Workflow Participants” in Chapter 21 of *SAS Model Manager: User's Guide*. You can also perform the exercise, “Managing the Workflow Process” on page 247 to learn how to manage workflows.

### Working with Workflow Activities

The Activities category view of Workflow Console displays the activities that you have been assigned as potential owner, business administrator, or that you became the actual owner of by claiming the activity, and that have a state of **Started**. In this exercise, you claim activities, specify properties, perform model management tasks, add comments, and complete activities.

To complete an activity, follow these steps:

1. Log on to SAS Model Manager as a member of the **Model Manager Advanced Users** group or **Model Manager Administrator Users** group.
2. Select **Tools ➞ My Workflow Inbox** or click 🔄. Workflow Console is launched in a Web browser and displays the Activities category view.
This is an example of the view for an advanced user.

3. Select an activity and click to claim an activity.

   Note: You can select an activity name and click to release an activity that you had previously claimed. Only a SAS administrator or SAS Model Manager administrator can release an activity that has been claimed by another participant. For more information, see “Releasing an Activity” in Chapter 21 of SAS Model Manager: User’s Guide.

4. (Optional) Click on a property value in the Properties pane of the Activities category view, and then enter a value or change the existing value.

   Note: Not all activities have user-defined properties.

   To save the changes to the properties, click .

   If you do not want to save the changes to the properties, click .

5. (Optional) Click New Topic to add a comment or click Reply to add to an existing comment using the Comments pane.

   Example of the New Topic window:
Example of the Reply window:

Click **Save**. The comments now appear in the **Comments** pane.

For information, see “Working with Comments” in Chapter 21 of *SAS Model Manager: User's Guide*.

6. Double-click an activity to view the activity details. From the activity details view you can perform the model management tasks that are associated with the activity. If the workflow is not associated with a version, or the activity is not configured to use a model management component, you can modify the activity properties.

**Note:** If you did not claim the activity from the Activities category view, select the **Claim** check box in the activity status bar.
This is an example of an activity that has not been claimed, contains properties, and does not have a model management task associated with it.

The following actions can be performed from the activity status bar.

- Select the information button to view the description of the activity. The description window can contain a brief description of the activity or special instructions.
- If you have no other actions to perform for the activity, you can select a status to complete the activity, and click **Update and Close**. The workflow process continues to the next activity.
- Click **Close** if you want to return to the Activities category view without updating the status of the activity.

7. If a model management component is associated with the activity, see the exercise “Using Model Management Components with a Workflow Activity” on page 230 for the tasks that can be performed.

8. (Optional) If you did not select a status to complete the activity, select a status value from the Activities category view to complete the activity. The workflow process continues to the next activity. Here is an example of the **Set up project** activity that has only one status to choose from.

9. Repeat steps 3 through 7 until the workflow process has been completed.

**Note:** From the Activities category view you can also view the dashboard reports for all projects. Click **to view the dashboard reports in a browser window.**

For more information, see “Working with Workflow Activities” in Chapter 21 of *SAS Model Manager: User's Guide.*
Using Model Management Components with a Workflow Activity

About Using Model Management Components in a Workflow Activity

SAS Model Manager enables you to integrate SAS Workflow with some of the model management tasks that are normally performed in the SAS Model Manager client. Workflow process definitions can be configured to use model management components with the workflow activities. When the workflow process definition is activated for use, the model management components are available through the object view for the associated activity in the SAS Model Manager Workflow Console.

In this exercise, you perform the model management tasks that are a part of the workflow. The steps in this exercise follow the workflow that was created in the previous exercise using the workflow process definition that was provided for Tutorial 10 in the SMM121Tutorial.zip file.

Import Models

If the Import Models component is associated with an activity, you can import models into the model repository. You can import models from the SAS Metadata Repository, a SAS package file (.spk), or a PMML file (.xml) into the version that is associated with the workflow. In this exercise you import models from the SAS package files into the 2013 version.

To import a model, follow these steps:

1. Select the SAS package file import method from the Import drop-down list.
2. Navigate to the location where the tutorials were extracted and look in the \\SMM121Tutorial\Tutorial3\Samples directory.
   - When importing a model from a SAS package file or from a PMML File, select **Open**.
   - When importing a model from SAS Metadata Repository, you select the file and specify a name in the same window.

   ![Image of Select File dialog]

   ![Image of Import Model from SAS Metadata Repository dialog]

   For this exercise, open the **Tree1** folder and select the **miningResult.spk** file to import. When importing a PMML model, you select an XML file.

3. Enter a name for the model and click **OK**.

4. Click **Close** in the success message.

5. Repeat steps 1 through 4 for the SAS package file located in the **Reg1** folder, and the PMML XML file located in **Neural** folder.
6. Select a model from the list, and click to view the information for a model.

7. Select Variables from the left menu and click the Model Mapping tab.
Map the model output variables to the project output variables.

Here are the model output variable mappings for the models that were imported:

**Neural**

<table>
<thead>
<tr>
<th>Project Variables</th>
<th>Model Variables</th>
</tr>
</thead>
<tbody>
<tr>
<td>score</td>
<td>P_BAD1</td>
</tr>
</tbody>
</table>

**Reg 1**

<table>
<thead>
<tr>
<th>Project Variables</th>
<th>Model Variables</th>
</tr>
</thead>
<tbody>
<tr>
<td>score</td>
<td>EM_EVENTPROBABILITY</td>
</tr>
</tbody>
</table>

**Tree 1**

<table>
<thead>
<tr>
<th>Project Variables</th>
<th>Model Variables</th>
</tr>
</thead>
<tbody>
<tr>
<td>score</td>
<td>EM_EVENTPROBABILITY</td>
</tr>
</tbody>
</table>

For more information about importing models using SAS Model Manager, see Chapter 7, "Importing Models,” in SAS Model Manager: User's Guide.

**Compare Models**

If the View Models component is associated with an activity, you can view a list of the models. You can also view model information such as properties, model variables, score code, model files, notes, and history. By default, the Model Viewer component is available from both the Import Models and also the Set Champion and Challenger components. The Model Viewer enables you to modify properties, map model output
variables, edit score code, and add notes for the selected model. You can also view the input variables, output variables, model files, and history of actions for the selected model.

The generic model viewer component can also be configured for an activity. This component displays a list of the models in the model repository that are associated with the version for which workflow process was created.

For this exercise, perform the following steps for each model:

1. Select a model from the list, and click . The Model Viewer window appears.

2. Select Variables from the left menu and click the Model Mapping tab. Verify that the model output variables are mapped.
3. (Optional) Select **Score Code** from the left menu to view the score code for the model.

4. (Optional) Select **Model Files** from the left menu to view the files that are in the model folder.
5. (Optional) Select Notes from the left menu to add or view notes that are associated with the model.

6. (Optional) Select History from the left menu to view the history of tasks that have been performed for the model.
If the Reports Viewer component is associated with an activity, you can view reports that were created using the New Report wizard in the SAS Model Manager client application.

To view the reports, you must first create the reports for the 2013 version. You can follow the exercise “Create Model Comparison and Summary Reports” on page 91 in tutorial 3 to create the Delta, Dynamic Lift, and Model Profile reports. In this exercise you view reports for the 2013 version. Some reports such as the Delta report and Dynamic Lift report enable you to select models from the version that contains the current project champion model.

To view a report, follow these steps:

1. Select a type of report from the left navigation menu.
2. Right-click a report from the list and select Open to view the report.
Note: You can also view the SAS code and SAS log if the report is not displayed.

3. (Optional) To view the SAS code or SAS log for a report, select a report from the list and click on the icon in the Code or Log column.

For more information, see Chapter 9, “Validating Models Using Reports,” in SAS Model Manager: User’s Guide.

**Select a Champion or Challenger Models**

If the Set Champion and Challenger component is associated with an activity, you can set a project champion model and challenger models.

This is an example of the project champion that already exists in another version.

For this exercise, select the Tree 1 model in the 2013 version and click to flag it as a challenger. Click Yes for the confirmation message.

Here are the actions that you can perform using this component:

- Select a model from the list, and click to set the model as the project champion model.

  Note: You might receive warning messages indicating that you must complete required tasks before you can continue.

Here are the possible scenarios in which a message might appear:

- If there are model input variables that are not defined as project input variables, you are prompted to add the input variables. Click Yes to confirm. The model input variables are copied to the project input variables.

- If project output variables are not defined, the Select Project Output Variables window appears for you to select the output variables. After you select the output variables, click OK.

- The Set Model Output Mapping window appears if you have not mapped the model output variables to the project output variables.
Select a model from the list, and click to flag a model as a challenger to the project champion model.

Note: You might receive warning messages indicating that you must complete required tasks before you can continue.

Here are the possible scenarios in which a message might appear:

- If there are model input variables that are not defined as project input variables, you are prompted to add the input variables. Click Yes to confirm. The model input variables are copied to the project input variables.

- The Set Model Output Mapping window appears if you have not mapped the model output variables to the project output variables.

- Select a model from the list, and click to clear a flagged challenger or champion model.

- Select a model from the list and click to view the model information.


Attach Documents

If the Add Documents component is associated with an activity, you can add, view, or delete attachments. The attachments are stored in the Documents folder that is located within a project or version in the model repository.

For this exercise, follow these steps:

1. Click to select a file to attach to the specified Attach location. The default location is the <version>/Documents folder. An example is 2013/Documents. The Select file to upload window appears.
2. Navigate to the location of the file, select the file, and click **Open**. The file appears in the list of documents.

3. Select the item in the list for the file that you attached in the previous step and click or double-click the selected file to view the contents of the file.

4. (Optional) Select an item from the list and click to delete the attachment.

### Publish Models

You can publish champion and challenger models from the model repository to the SAS Metadata Repository or to a database. In this exercise, you publish a model to the SAS Metadata Repository and to a database.

To publish models to the SAS Metadata Repository, follow these steps:

1. Select **SAS Metadata Repository** for the publish destination.

2. Select the champion model **Tree 1** in the **2012** version and the challenger model **Reg 1** in the **2012** version from the **Models** list.
3. Accept the default or specify a publish name for the challenger model. The champion model publish name is set as the project name.

   Note: The default format of the publish name is configured by the SAS administrator. You cannot modify the publish name for a champion model.

4. Select the location in the SAS Metadata Repository to publish the models.

   Click **OK**. The selected location appears in the **Location** box.
5. Click **Publish**. Click **Close** for the confirmation success message.

To publish models to a database, follow these steps:

1. Select the type of database for the publish destination.

2. Select a publish method.

3. Select the models that you want to publish from the **Models** list.

   **Note:** You can publish both the project champion model and its challenger models.

4. If you selected the **SAS Embedded Process** publish method, select the **Replace scoring files that have the same publish name** publish option.

5. Specify a publish name for each model.
Note: The default format of the publish name is configured by the SAS administrator.

6. Specify the settings to connect to the database, and click More Options to specify the processing options that should be used when publishing the models.

Select Display detailed log messages and click Save. You are returned to the Publish window.

7. Click Publish. After the models are published to the database, you receive a success confirmation message. Click Close.

For more information about publishing models using SAS Model Manager, see Chapter 12, “Publishing Models,” in *SAS Model Manager: User’s Guide*.

**View Performance Results**

If the Model Performance Viewer component is associated with an activity, you can view the performance of the project champion model through a series of charts. The
performance charts are generated using performance tasks in the SAS Model Manager client application.

To view the performance reports you must set a model in the 2013 version as the project champion model. Then you must define and execute the performance tasks for the 2013 version in the SAS Model Manager client.

For this exercise, perform the following steps:

1. Open the **M7: View Performance Reports** activity window. The performance charts are currently not available because the project champion model is not located in the version that is associated with this workflow.

2. Select the **Review** status and click **Update and Close**. The workflow process continues to the next activity.

3. Open the **M8: Administrative Review** activity and select **Claim**. The Utility model management component appears in the activity window.

   **Note:** The Utility component consists of all the model management components. You can associate the Utility component with an activity so that you can perform administrative tasks or review all of the content that is available for a workflow without having to complete multiple activities. To switch between the model management tasks select a link from the object window navigation bar.
4. Select **Set Champion and Challenger** from the object window navigation bar.

5. Select the **Tree 1** model from the **2013** version models list and click **✓** to set the model as the project champion model. Click **Yes** in both of the warning messages.
6. You must now define and execute the performance tasks in the SAS Model Manager client for the new project champion model. Follow the exercise “Create the Champion Model Performance Data Sets for a Classification Project” on page 130 in tutorial 5 to define and execute the performance tasks.

7. Return to the browser window where the SAS Model Manager Workflow Console is available and click \( \text{M8: Administrative Review} \) in the activity object window.

8. Select \textit{Performance} from the object window navigation bar.

9. Select a type of report from the left navigation menu to view the performance charts. You can select the check boxes in the upper right corner to show markers in the chart and to display the table of data.

Here is an example of the Gini charts.

For more information, see Chapter 14, “What is Performance Monitoring?,” in \textit{SAS Model Manager: User’s Guide}. 

Managing the Workflow Process

Overview

SAS Model Manager Workflow Console can be used to manage workflow processes. A SAS Model Manager administrator can create new workflows, view workflow process definitions, and interact with activities that are associated with a workflow. If the SAS Model Manager administrator is assigned to the workflow role of business administrator, the administrator can influence the progress of an activity by actions such as assigning an activity, or releasing the activity that is claimed by another user.

In this exercise, you create a workflow, work with participants, customize category views, and terminate workflow processes.

Prerequisites

The exercises in this tutorial require that you have made the workflow process definitions available to SAS Model Manager. For more information, see “Prepare for Using SAS Workflow” on page 18.

Manage Workflows

To manage workflows, follow these steps:

1. Log on to SAS Model Manager as a member of the Model Manager Administrator Users group.

2. Select Tools ⇒ Manage Workflow. Workflow Console is launched in a Web browser and displays the Workflow Definitions category view.

3. Select a workflow definition (for example, MM Workflow Example 2) and click [ ]. The New Workflow window appears.

Note: The workflow process definitions that have been provided for the tutorials already have participants assigned.
4. Enter a name for the workflow (for example, **MM Tutorial 10 Demo 1**).

5. For this tutorial, leave the UUID field blank. You can also copy the UUID system property value for a version from the Properties view in the SAS Model Manager main window.

   *Note:* The field label and other characters that precede the UUID value must be removed.

6. Enter a description for the workflow (for example, **Workflow for tutorial 10**).

7. Click **OK**. A message appears, indicating that the workflow has been successfully created.

   *Note:* If you left the UUID field blank, you receive a warning message. Click **Yes**, to continue.

**Display 11.3**  New Workflow – No UUID Specified
8. Click Close. The new workflow is now available in the Workflows category view.

9. Repeat steps 3 through 8 to create additional workflows and then continue to the next step.

10. To view the new workflows, click . The Workflows category view appears. Select the workflow to view information that is associated with the new workflow.

---

**Modify a Workflow**

**About Modifying Workflows**
In this exercise, you modify the properties associated with a workflow, add comments to a workflow, and assign participants to activities.

**Modify Workflow Properties**
To modify the properties that are associated with a workflow, follow these steps:

1. From the Workflows category view, select a workflow that you created in the previous exercise.

2. In the Properties pane, click in the cell for a property and specify or modify a value.
Here is an example:

![Properties](image)

<table>
<thead>
<tr>
<th>Property</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Created by</td>
<td>mdlmgradmin</td>
</tr>
<tr>
<td>Description</td>
<td>Workflow for tutorial 1</td>
</tr>
<tr>
<td>Workflow name</td>
<td>MM Tutorial 10 Demo 1</td>
</tr>
</tbody>
</table>

3. Click ![Click](image) to save the properties.

*Note:* You can click ![Close](image) to discard the changes and revert back to the previous value.

**Add Comments**

To add comments to the selected workflow, follow these steps:

1. In the Comments pane, click **New Topic**. The New Topic window appears.

![New Topic](image)

2. Enter a title and comment for the new topic.

*Note:* For information about adding attachments, see “Working with Comments” in Chapter 21 of *SAS Model Manager: User's Guide*.
3. Click **Save**. The new topic appears in the comments pane.

**Assign Participants**

To assign an additional participant to an activity, follow these steps:

1. Double-click a workflow to view the Workflow details view, which contains a list of activities that are associated with the workflow.
2. Select the Retrain Models activity and click in the Participants pane. The Assign a Participant window appears.

3. Select one of the identity types: user, group, or role. The SAS Model Manager user groups that were created by default during installation and configuration were assigned to each activity when the sample workflow process definition was created.

4. Enter part of the user, group, or role name. For example, you can enter the user name sasdemo or part of a user name that exists on the SAS Metadata Server. Then click .

Note: If you do not enter part of the name, all of the names for the selected identity type are displayed. In addition, if you manually enter a name value and do not click the search button, the name is verified against the SAS identity participant list when you click OK.
Select a name and click **OK**.

5. Select a workflow role for the participant.

Here are the workflow roles that you can assign to participants for a workflow activity:

- **Business administrator**: a participant who can influence the progress of an activity by actions such as adding comments, assigning an activity, or releasing the activity claimed by another user.

- **Potential owner**: a participant who can claim an activity in a workflow process and who becomes the actual owner of an activity.

Click **OK**. A message appears, indicating whether the participant was successfully assigned to the activity. For example, the user **sasdemo** was assigned the workflow role of **potential owner**.

6. Click **Close**. Here is an example of the properties and participants that are associated with the **Retrain Models** activity.
Terminate a Workflow Process

When you terminate a workflow process, all activities that have not yet been completed in the workflow process are changed to a state of Terminated. After you terminate a workflow process, it cannot be restarted.

To terminate a workflow process, follow these steps:

1. From the Workflows category view, select one of the workflows that you created in the exercise “Manage Workflows” on page 247, and click .

   Note: In order to continue with this tutorial, you need to keep at least one workflow active.

2. Click Yes to terminate the workflow process.

3. Click Close to return to the Workflows category view.

Search List Content

You can search the list in a category view to display only particular workflow definitions, workflows, or activities. For example, suppose you want to see only workflows in the Workflows category view that contain the text Demo.

To search the content that appears in the list, follow these steps:

1. On the search bar, specify the search criteria of Demo in the Search box. Here is an example of the list with the search criteria applied.
2. To save the search, click **Save Search**. The Save Search window appears.

3. In the Save Search window, specify a name for the search and an optional description. Click **OK**.

   **Note:** The search name and description can be modified in the Manage Saved Searches window. The rule cannot be modified for an existing search. If you want to change the rule, you must create a search that has the same name to replace the existing search. For more information, see “Searching List Content” in Chapter 21 of *SAS Model Manager: User's Guide*. 
Overview of Using Published Models in SAS Data Integration Studio

The SAS Model Manager publish feature enables you to publish models to the SAS Metadata Repositories, making them available for other SAS products such as SAS Data Integration Studio and SAS Enterprise Guide. SAS Model Manager offers two publish methods:

- Publish a model
- Publish a project champion model

When you publish a SAS Model Manager project champion model to the metadata repository, the result is a mining results object that contains the champion model of the project’s default version. In order for the mining results object in the SAS Metadata Repository to be updated with the new champion model, two conditions must be met: the champion model in the project’s default version is changed and the model is published from the project level again to the same SAS metadata folder.

To illustrate an application that can use a published SAS Model Manager project champion model, this tutorial uses SAS Data Integration Studio to connect metadata objects (including a mining results object) to create a scoring job.
Prerequisites

The exercises in this tutorial depend on some of the properties of the specific models that were added in Tutorial 3. Use the projects, versions, or models that are specified here. This tutorial is designed to follow Chapter 4, “Tutorial 3: Importing Models, Scheduling Scoring Tasks, and Creating Reports,” on page 75.

The scoring input and output tables from SMM121Tutorial.zip must be extracted and registered in SAS Management Console. If the data sets have not been extracted and registered, see “Prepare Tutorial 11 Data Sets and Models” on page 14 to extract and register the files. The users must also have Write and Modify permissions to the <server-name\drive\SMM121Tutorial\Tutorial11\Samples directory.

This exercise requires SAS Data Integration Studio. Use the SAS Deployment Wizard to install the SAS Data Integration Studio client.

Publish a Project Champion Model from SAS Model Manager

In this exercise, you publish a project champion model from SAS Model Manager in order for that model to be accessed and scored by SAS Data Integration Studio. When you publish from the project level, you publish the project champion model.

Note: This task requires that you use a user ID that is a member of the SAS Model Manager Advanced Users group or the SAS Model Manager Administrator Users group.

Note: If you create user-defined properties at the project level, these properties are published with the champion model. User-defined properties might be helpful for scoring applications that search mining result objects for specific name-value pairs. Each user-defined project property is stored in the SAS Metadata Repository as an Extension metadata object, which is a name-value pair.

1. In the Project Tree, expand the Tutorial3 folder.
2. Right-click the Loan project and select Publish Model to the SAS Metadata Repository. Click Yes for the information message that the project is unlocked. The SAS Metadata Repository dialog box appears.
3. Navigate to the folder where you want to store the model. For example, double-click Shared Data Model Manager and then select the Tutorial3 folder. Click OK. An information message indicates whether the champion model was successfully published. Click Close.
Score a Model Using a SAS Data Integration Studio Job

In this exercise, you create a SAS Data Integration Studio scoring job by using the Loan mining result from the SAS Metadata Repository. After you create the job, you run the job and view the output.

Open the SAS Data Integration Studio Desktop

To log on to SAS Data Integration Studio:
1. Launch SAS Data Integration Studio.
2. If prompted, create a SAS Metadata Profile for the SAS Metadata server.
3. Log on with the profile for SAS Metadata server.

Create a New Job

To create a new job, follow these steps:
1. Use the New Job Wizard to add the job:
   a. From the SAS Data Integration Studio window, right-click My Folder. Then select New ⇒ Job. The New Job dialog box appears.
   b. In the Name box, enter Tutorial11 and click OK.
      Note: If prompted to choose a default application server, select SASApp, click Test Connection, and click OK in the confirmation message. Then click OK in the Default Application Server window.
   c. Click the Inventory tab, expand Table, and find the tables SCORE_INPUT and SCORE_OUTPUT that have the folder location for the Tutorial11 data sets. Here is an example: /Shared Data/Model Manager/Tutorial11.
   d. Click and drag SCORE_INPUT to the Diagram tab. Click and drag SCORE_OUTPUT to the Diagram tab. Position the SCORE_INPUT node farthest to the left. Position the SCORE_OUTPUT node farthest to the right. These nodes are the beginning and ending nodes in the diagram. Leave enough space between them for two additional diagram nodes to occupy.
e. Click the Transformations tab and expand Access. Select and drag Table Loader to the Diagram tab. Place the Table Loader node before the HMEQ SCORE_OUTPUT node.

f. From the Transformations tab, expand Data. Select and drag Model Scoring to the Diagram tab. Place the Model Scoring node between the HMEQ SCORE_INPUT node and the Table Loader node. Here is the Diagram tab:

g. Double-click the Model Scoring node. The Model Scoring Properties window appears. Click the Models tab, expand Mining Results, and select Loan. The UUID in the Key box is the UUID of the Loan project in SAS Model Manager.

2. Click the Target Table Columns tab. Expand OutputTable, select score, and click . Click OK.

3. Drag the output handle from the SCORE_INPUT node to the Model Scoring node. The half-filled circle on the Model Scoring node is changed to a check mark to indicate that the node requirements have been met.

4. Drag the output handle from the Model Scoring node to the Table Loader node.

5. Drag the output handle from the Table Loader node to the SCORE_OUTPUT node. The half-filled circle on the Table Loader node is changed to a check mark to indicate that the node requirements have been met. Here is the diagram:

6. Save the job. Click File ➤ Save.
Run the SAS Data Integration Studio Scoring Job

To run the job and view the output, follow these steps:

1. On the **Diagram** tab, click **Run**. The Tutorial11 job runs. Here is the job status:

![Job Status Table](image)

2. To view the output, right-click the **SCORE_OUTPUT** node and select **Open**. Here is the output:
Verify the Model Code Used in the Job

To verify that you have used the correct model, view the model code that was used in the SAS Data Integration Studio job.

Click the Code tab and scroll down through the lines until you find the following comment block:

```
*------------------------------------------------------------*;
* TOOL: Score Node;                                     *
* TYPE: ASSESS;                                          *
* NODE: Score;                                           *
*------------------------------------------------------------*;
*------------------------------------------------------------*;
* EM SCORE CODE;                                         *
* VERSION: 7.1;                                          *
```
Declare and Publish a New Champion Model in SAS Model Manager

In this exercise, you declare a different model as the champion model after an initial project champion model has been published to the SAS Metadata Repository. You then publish the new project champion model to the metadata repository.

To declare and publish a new champion model, do the following:

1. In the SAS Model Manager Project Tree, expand the Tutorial3 folder, the Loan project, the 2012 version, and the Models folder.
2. Right-click the Reg 1 model and select Set as Champion.
3. When prompted to confirm the change, click Yes.
4. Right-click the Loan project and select Publish Models to the SAS Metadata Repository. Click Yes in the message window. The SAS Metadata Repository window appears.
5. Double-click Shared Data Model Manager, select Tutorial3, and click OK. Click Yes in the confirmation message box to replace the champion model.

An information message indicates whether the champion model was successfully published. Click Close to close the message box.

For more information about this task, see the SAS Model Manager: User's Guide.

Update the Job to Use the Latest Champion Model

This exercise demonstrates the steps to update the SAS Data Integration Studio job after you change the champion model in SAS Model Manager. After you publish the Loan
To update the job, follow these steps:

1. Close and reopen Tutorial11.
   a. Click the Tutorial11 window and select **File ➞ Close**.
   b. Click the **Folders** tab and expand **My Folder**. Double-click **Tutorial11** to reopen the job. When the job reopens, it uses the new score code from the Mining Result object and regenerates the code that is associated with the job.

2. In the **Tutorial11** diagram, right-click the **Model Scoring** node and select **Properties**. The Model Scoring Properties window appears. Click the **Models** tab. The **Loan** mining result is highlighted. The **Algorithm** box shows that the model is a **Regression** model.

3. Click the **Model Attributes** tab. A message box might appear that warns of potential table changes if you change the mining result. Click **Yes**.

4. Click **View Source Code**. Scroll to the top of the window. Compare the text in the comment tags to the Reg 1 model code in SAS Model Manager. They are the same, as shown in the displays below.

To view the model code in SAS Model Manager, follow these steps:

a. Log on to SAS Model Manager and expand the following Project Tree nodes:
   - **Tutorial3** folder
   - **Loan** project
   - **2012** version
   - **Models** folder
   - **Reg 1** model

b. In the **Reg 1** model, select **score.sas**. The model code appears in the **Content** view.

Here is the Reg 1 score code in SAS Model Manager.
Here is the Reg 1 score code in SAS Data Integration Studio.

```bash
---
\* TOOL: Score Node;\n\* TYPE: ASSESS;\n\* NODE: Score;\n---
\* KM SCORE CODE;\n\* VERSION: 7.1;\n\* GENERATED BY: xdimpro.exe;\n\* CREATED: 19JAN2011-14:19:11;\n---
\* TOOL: Input Data Source;\n\* TYPE: SAMPLE;\n\* NODE: Ids;\n---
\* TOOL: Regression;\n\* TYPE: MODEL;\n\* NODE: Reg;\n---
*** begin scoring code for regression;***
```

5. Click **Cancel** to close the View Source Code window.

6. Identify the variables to be used in the transform output. Click the **Target Table Columns** tab. If **score** and **customer_id** are not in the **Selected** list, follow these steps:
   a. From the **Available** list, select **score** and click **to move the score variable to the Selected list.**
b. From the Available list, expand SCORE_INPUT, select customer_id, and click to move the customer_id variable to the Selected list.

7. Click the Mappings tab. Right-click the space between the two lists of variables and select Map All. Here is the Mappings tab:

Click OK.

8. Double-click the Table Loader node and click the Mappings tab.

9. Right-click the space between the two lists of variables and select Map All. Click OK.


11. To view the output, right-click the SCORE_OUTPUT node and select Open. Here is a partial view of the output:
<table>
<thead>
<tr>
<th>#</th>
<th>customer_id</th>
<th>score</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>118-296-340</td>
<td>0.0891795...</td>
</tr>
<tr>
<td>2</td>
<td>126-291-396</td>
<td>0.0891795...</td>
</tr>
<tr>
<td>3</td>
<td>154-253-305</td>
<td>0.0891795...</td>
</tr>
<tr>
<td>4</td>
<td>107-281-352</td>
<td>0.0891795...</td>
</tr>
<tr>
<td>5</td>
<td>184-207-395</td>
<td>0.0891795...</td>
</tr>
<tr>
<td>6</td>
<td>129-227-368</td>
<td>0.1158766...</td>
</tr>
<tr>
<td>7</td>
<td>197-222-368</td>
<td>0.0891795...</td>
</tr>
<tr>
<td>8</td>
<td>141-255-328</td>
<td>0.1078593...</td>
</tr>
<tr>
<td>9</td>
<td>147-204-363</td>
<td>0.0891795...</td>
</tr>
<tr>
<td>10</td>
<td>158-258-337</td>
<td>0.0891795...</td>
</tr>
<tr>
<td>11</td>
<td>172-250-392</td>
<td>0.0891795...</td>
</tr>
<tr>
<td>12</td>
<td>192-258-329</td>
<td>0.0891795...</td>
</tr>
<tr>
<td>13</td>
<td>139-247-367</td>
<td>0.0891795...</td>
</tr>
<tr>
<td>14</td>
<td>117-216-386</td>
<td>0.0891795...</td>
</tr>
<tr>
<td>15</td>
<td>130-293-389</td>
<td>0.0891795...</td>
</tr>
<tr>
<td>16</td>
<td>156-205-313</td>
<td>0.0891795...</td>
</tr>
<tr>
<td>17</td>
<td>151-243-317</td>
<td>0.0891795...</td>
</tr>
<tr>
<td>18</td>
<td>166-240-312</td>
<td>0.0891795...</td>
</tr>
<tr>
<td>19</td>
<td>145-220-357</td>
<td>0.0891795...</td>
</tr>
<tr>
<td>20</td>
<td>173-244-305</td>
<td>0.0490147...</td>
</tr>
<tr>
<td>21</td>
<td>152-234-302</td>
<td>0.0891795...</td>
</tr>
<tr>
<td>22</td>
<td>171-293-344</td>
<td>0.0891795...</td>
</tr>
<tr>
<td>23</td>
<td>194-271-310</td>
<td>0.0891795...</td>
</tr>
<tr>
<td>24</td>
<td>117-227-361</td>
<td>0.0891795...</td>
</tr>
<tr>
<td>25</td>
<td>142-207-335</td>
<td>0.0891795...</td>
</tr>
<tr>
<td>26</td>
<td>170-219-315</td>
<td>0.1256677...</td>
</tr>
<tr>
<td>27</td>
<td>156-227-332</td>
<td>0.0319573...</td>
</tr>
<tr>
<td>28</td>
<td>156-204-343</td>
<td>0.0891795...</td>
</tr>
<tr>
<td>29</td>
<td>191-252-372</td>
<td>0.0891795...</td>
</tr>
<tr>
<td>30</td>
<td>190-257-319</td>
<td>0.0891795...</td>
</tr>
</tbody>
</table>