SAS Information Map Studio 4.2
Getting Started with SAS Information Maps
# Contents

*About This Book* .......................... v

## Chapter 1 • Introduction to SAS Information Map Studio ............................ 1
   What Is SAS Information Map Studio? ........................................... 1
   How Does SAS Information Map Studio Work? ................................... 3
   Accessibility Features of SAS Information Map Studio 4.2 ..................... 4

## Chapter 2 • Learning by Example: Creating a SAS Information Map ................. 7
   About the Scenario in This Book .................................................. 7
   How to Get Help ................................................................. 8

## Chapter 3 • Preparing to Create a SAS Information Map ............................. 9
   About the Tasks That You Will Perform ......................................... 9
   Create a Connection Profile ..................................................... 9
   Define a SAS Library ............................................................ 11
   Define Tables ................................................................. 14
   Set SAS Information Map Studio Preferences .................................. 16

## Chapter 4 • Creating a SAS Information Map ....................................... 17
   About the Tasks That You Will Perform ......................................... 17
   Add Data Sources ............................................................... 18
   Create a Relationship ........................................................... 18
   Create Folders ................................................................. 20
   Creating Data Items .................................................................. 21
   Creating Filters ........................................................................ 33
   Save the Information Map ......................................................... 37
   Run a Test Query ................................................................. 38

## Chapter 5 • Next Steps: A Quick Look at Additional Features ...................... 41
   Assign a Prefilter ................................................................. 41
   Designate a Required Table ....................................................... 43
   Test the Prefilter and Required Table Assignments ............................. 45
   Set Up Cascading Prompts Via a Filter .......................................... 46
   Test the Cascading Prompts ....................................................... 49
   Manage Columns ................................................................. 50
   Replace Resources ............................................................... 52

*Glossary* .................................................................................. 55

*Index* ..................................................................................... 61
About This Book

**Audience**

This book is for information architects who are responsible for facilitating business reporting in an organization. The book assumes that you have a basic understanding of SAS business intelligence software.

**Prerequisites**

To create the information map in this book, you must install SAS Information Map Studio 4.2 and have the following software and resources:

- a SAS 9.2 Metadata Server that has a SAS Application Server defined. The application server definition must contain a logical SAS Workspace Server.
- SAS Management Console 9.2.
  
  *Note:* SAS Management Console is required only for defining the tables that you need; it is not required for creating an information map. If you do not have access to this software, contact your metadata administrator for help with the steps in “Define a SAS Library” on page 11 and “Define Tables” on page 14.
- Base SAS 9.2 sample data sets EMPINFO and SALARY.
Chapter 1
Introduction to SAS Information Map Studio

What Is SAS Information Map Studio?

Overview
SAS Information Map Studio provides a graphical user interface that enables you to perform the following tasks:
- create and manage SAS Information Maps
- define how the items in an information map are presented so that they are most relevant to your business user
- run test queries and preview query results
- set various properties and permissions on an information map to control query generation, query execution, and data access

What Is a SAS Information Map?

Overview
A SAS Information Map is a business metadata layer that is applied on top of the data sources in your data warehouse. (Metadata is information about the structure and content of data. An information map does not contain any physical data.) Information maps provide business users with a user-friendly way to query data and get results for themselves.

An information map contains data items and filters, which are used to build queries. A data item can refer to a data field or a calculation. Filters contain criteria for subsetting the data that is returned for a query. Folders can be used to organize the data items and filters so that business users can easily locate information within the information map.
Benefits of SAS Information Maps
An information map provides business users with easy access to enterprise-wide data.

- Information maps shield users from the complexities of data.
- Information maps make data storage transparent to users. It does not matter whether the data is relational or multidimensional, or whether the data is in a SAS data set or in a third-party database system.
- Information maps predefine business formulas and calculations, which makes them usable on a consistent basis.
- Information maps enable users to easily query data for answers to business questions without knowing query languages or being aware of the data model.

What Software Products Use SAS Information Maps?
An information map can be used by these SAS software products:

- Base SAS software
- SAS AppDev Studio (custom applications developed with)
- SAS Add-In for Microsoft Office
- SAS Enterprise Guide
- SAS Information Delivery Portal
- SAS Marketing Automation
- SAS Web OLAP Viewer for Java
- SAS Web Report Studio
- SAS BI Dashboard

The SAS Information Map Studio User Interface
The SAS Information Map Studio main window consists of these parts:

1 The Relationships tab displays relational data sources (tables), their columns, and the relationships between data sources. You can create and modify the relationships
between data sources. You can also add or remove data sources. This tab is displayed only for relational information maps.

2 The **Design** tab displays the currently open information map and its resources. You can modify the information map and change its resource selections.

3 The menu bar contains the menus for performing tasks in SAS Information Map Studio.

4 The toolbar contains buttons that enable you to quickly access many of the options that are available on the menu bar.

5 The **Resources** pane provides access to existing information maps and to resources that you need for creating new information maps. Click [ ] to hide this pane and [ ] to show this pane.

6 The status bar displays the name of the connection profile that you used to log on to the metadata server, your identity, and the machine name and port number for the metadata server.

7 The **Properties** pane displays the properties of items that you select in the **Resources** pane, on the **Design** tab, or on the **Relationships** tab. You can use the **Properties** pane to modify certain properties. If you select multiple data items, then you can modify all of them at the same time. Click [ ] to hide this pane and [ ] to show this pane.

---

**How Does SAS Information Map Studio Work?**

Before you create an information map, make sure that you analyze the information needs of your organization. Those needs become the requirements for your information map.

The first step in creating an information map is adding the data sources, which are references to one or more tables or a single cube (you cannot use both tables and cubes in the same information map). Using the data sources, you can create data items and filters for the information map.

After the information map is created, you can test it in SAS Information Map Studio to ensure that it generates the queries that you expect. The information map can then be saved and used in select SAS software products (see “What Software Products Use SAS Information Maps?” on page 2). These products use the information map to query the data that is stored in the referenced tables or cube. The resulting set of data can be displayed to your end user in different ways (for example, as a report, a graph, or a data table).
Figure 1.1  The Life Cycle of a Relational SAS Information Map

1 The information map in this diagram is created from the columns that the information map's data source references.

2 An SQL query is generated from the information map.

3 The SQL query is executed to produce a result set.

### Accessibility Features of SAS Information Map Studio 4.2

SAS Information Map Studio 4.2 includes accessibility and compatibility features that improve usability of the product for users with disabilities, with exceptions noted in the online Help for the product. These features are related to accessibility standards for electronic information technology that were adopted by the U.S. Government under Section 508 of the U.S. Rehabilitation Act of 1973, as amended.

If you have questions or concerns about the accessibility of SAS products, send e-mail to accessibility@sas.com.

Note:
- For Windows-based assistive technologies to interoperate with SAS Information Map Studio, the Java Access Bridge (JAB) from Sun Microsystems must be installed and configured in the SAS Information Map Studio installation directory. For information about downloading and installing this software, see the SAS Intelligence Platform: Desktop Application Administration Guide.
• If you run SAS Information Map Studio on a Citrix server, contact your assistive technology vendor if you have questions about operating assistive technology via a remote server.
Chapter 2

Learning by Example: Creating a SAS Information Map

About the Scenario in This Book

The scenario in this book uses data that is provided with Base SAS software; you can follow the instructions to create a working information map. Each topic builds on the previous topic, so you must work through the chapters in sequence.

Note: Although the applications that are used in this book provide different methods for performing tasks (for example, via toolbars, pop-up menus, and drag-and-drop operations), the book documents only one method for each task.

For the purpose of this scenario, you are the information architect for your company's human resources department. Your department has been asked to generate salary and seniority reports on employees at your company. Your company already licenses SAS Management Console and has recently licensed SAS Information Map Studio.

The chapters in this book provide step-by-step instructions for creating a simple relational information map. You are guided through Data Library Manager in SAS Management Console to register your data in a SAS Metadata Repository, and then you are guided through SAS Information Map Studio to create the information map. You will be able to answer the following types of questions:

• What is the total salary expenditure for an individual or group?
• What is the average salary for a group?
• Which employee earns the most or the least in a group?
• How long has an employee been with the company?
How to Get Help

SAS Management Console: Data Library Manager

The Data Library Manager Help describes the dialog boxes in Data Library Manager and the main tasks that you can perform with the software.

Use either of these methods to get Help for Data Library Manager:

- In the left pane of the SAS Management Console main window, select Data Library Manager. Then, from the menu bar, select Help ⇒ Help on Data Library Manager.
- Click Help in the application dialog boxes.

SAS Information Map Studio

The SAS Information Map Studio Help describes the windows and dialog boxes in SAS Information Map Studio and the main tasks that you can perform with the software.

Use any of these methods to get Help for SAS Information Map Studio:

- From the SAS Information Map Studio menu bar, select Help ⇒ SAS Information Map Studio.
- Click Help in the application windows and dialog boxes.
- Press F1 in most application windows and dialog boxes.
Chapter 3
Preparing to Create a SAS Information Map

About the Tasks That You Will Perform

To prepare to create a SAS Information Map, you will perform these main tasks:

1. Create a connection profile so you can launch and use SAS Information Map Studio and SAS Management Console.

2. Define a SAS library that contains the tables that your information map references for data.

3. Define the tables that your information map references for data.

4. Set application preferences for SAS Information Map Studio.

Create a Connection Profile

Before you can start SAS Information Map Studio or SAS Management Console, you must create a connection profile. A connection profile defines the connection between a SAS Metadata Server and a SAS business intelligence client application such as SAS Information Map Studio or SAS Management Console.

If you already have a connection profile for the metadata server that you want to use for this scenario, proceed to the next section. If you do not have an existing connection profile, complete these steps:


   *Note:* If the Connection Profile dialog box is not automatically opened, select File ⇒ Connection Profile from the SAS Management Console menu bar.
2. In the Connection Profile dialog box, select **Create a new connection profile**, and then click **OK** to start the New Connection Profile wizard.

![Connection Profile dialog box](image)

3. The first page of the wizard explains the function of the wizard. Click **Next**.

4. On the Connection Profile page, specify a name for the profile (for example, **My Server**) and click **Next**.

5. On the Connection Information page, specify the following values, which are required in order to connect to the metadata server. If you do not know what values to specify, contact your metadata administrator.
   a. In the **Machine** field, specify the fully qualified name of the computer that the metadata server runs on.
   b. In the **Port** field, specify the port number for the metadata server.
   c. If your site supports Integrated Windows authentication, select the **Use Integrated Windows authentication** check box and click **Next**. If your site does not support this feature, proceed to step d.
   d. In the **User ID** field, specify the user ID that you use to log on to the metadata server. If your metadata server runs in a Windows environment, you must fully qualify the user ID by using the domain or machine name that you specified when your login was defined. Use the following format when you specify your value:

   \( Windows\text{-domain-name}\text{\user-ID} \)

   **Note:** For the metadata server, you must have at least one login definition that contains a user ID that corresponds to the user ID that you specify here. For information about login definitions, see the **SAS Management Console: Guide to Users and Permissions**.

   e. In the **Password** field, specify the password for the user ID.
   f. (Optional) In the **Authentication Domain** field, specify an authentication domain to associate with the user ID and password. If you do not specify an authentication domain, then the user ID and password that you provide are associated with the DefaultAuth authentication domain.
   g. (Optional) If your site does not support Integrated Windows authentication, then you can save the user ID and an encrypted version of your password in the connection profile by selecting the **Save user ID and password in this profile** check box. If you do not select this option, the client application will prompt you for a user ID and password each time the connection profile is accessed.
6. The confirmation page lists all of the information that you specified in the wizard. If you need to make any corrections, click Back. When all of the information is correct, click Finish to create the profile and enter SAS Management Console.

Define a SAS Library

In order for SAS Information Map Studio to access a data table, the table's metadata must be defined in a SAS Metadata Repository. You can use Data Library Manager in SAS Management Console to create metadata definitions for data libraries and their associated tables. The definitions are then stored in the SAS Metadata Repository and available for applications to use.

The information that is specified for each library definition corresponds to options in a SAS LIBNAME statement. For information about the correlation between the options that are specified in Data Library Manager and those that are specified in the LIBNAME statement, see the Data Library Manager Help.

Note: SAS Management Console is required only for the purpose of registering your data in the metadata repository—it is not required for creating an information map. If you do not have access to this software, contact your metadata administrator for help with the steps in this chapter.

To define a SAS library for this scenario:

1. Start SAS Management Console if you haven't already done so.
b. When you start SAS Management Console, the application either uses the default connection profile (if you specified a default profile during a previous session), or it displays the Connection Profile dialog box.

To choose a profile in the Connection Profile dialog box, select **Open an existing connection profile**. From the drop-down list, select the connection profile that you want to use for this scenario, and click **OK**.

c. If you saved your user ID and password in the connection profile, or if you are using Integrated Windows authentication, then the SAS Management Console main window will be displayed and you can proceed to the next step. Otherwise, you will be prompted to specify your user ID and password in order to log on to the metadata server and display the SAS Management Console main window.

2. Select the **Plug-ins** tab in the SAS Management Console main window and expand **Data Library Manager**.

3. Select the **Libraries** folder, and then select **Actions  New Library** from the menu bar to start the New Library Wizard.

![SAS Management Console](image)

4. Select the library type that you will be working with. Selecting a library type is equivalent to specifying an engine in a LIBNAME statement. Because you are working with SAS tables in this scenario, select **SAS BASE Library** from the SAS **Data** folder and click **Next**.

5. On the next page, enter **Sample Employee Data** in the **Name** field. The name that you enter is used to identify the library in SAS Management Console—it is not the libref that is specified in the LIBNAME statement.

6. Specify a description (optional) and a SAS folder location for the library. Click **Next**.

7. The next page lists the SAS Application Servers that have already been defined by using Server Manager in SAS Management Console. Use the arrow button to select the application server that you want to use to access the Sample Employee Data library and its tables. Click **Next**.

8. On the next page, enter the following values for the library's properties:

a. In the **Libref** field, specify a one- to eight-character libref for the SAS library. For example, you can enter **SAMPDATA**.

b. In the **Engine** field, make sure that **BASE** is selected as the SAS engine to use when accessing SAS tables in this library.
c. In the **Path Specification** section, specify the location of your tables on the SAS Workspace Server that is associated with the application server that you will use. Any paths that have already been specified for other libraries are listed in the **Available items** list. Use the arrow button to move a path from the **Available items** list to the **Selected items** list. For this scenario, the tables that you use are, by default, located in `C:\Program Files\SAS\SASFoundation\9.2\core\sample`. (The tables might be located in a different directory, depending on where SAS is installed on your workspace server machine.)

![New Library Wizard](image)

If the path for these tables is not in the **Available items** list, click **New** to display the New Path Specification dialog box, and then specify the path. Click **OK**, and then click **Next**.

9. The last page of the wizard lists all of the information that you specified in the wizard. To make any corrections, click **Back**. When all of the information is correct, click **Finish** to define the library.
After you define the library, it is added to the bottom of the list of libraries in the Libraries folder. To sort the libraries in alphabetical order, you must refresh the window.

### Define Tables

After you define your library, you can register or define its tables. The Register Tables wizard in Data Library Manager guides you through registering a table.

To register the tables that are used in this scenario:

1. In the left pane of SAS Management Console, expand Data Library Manager, and then expand Libraries.

2. Select the Sample Employee Data library that you just defined, and then select Actions ➔ Register Tables from the menu bar to start the Register Tables wizard.

3. On the Select a SAS Library page, verify the values that are displayed. If all of the values are correct, click Next. Otherwise, click Edit to edit the information about the library.
4. On the Define Tables and Select Folder Location page, press the CTRL key and select EMPINFO and SALARY in the Select Tables list. The Location field specifies the location where the tables will be stored, which, by default, is the location that you specified for the library. Click Next to accept the table selections and the location for the tables.

5. On the confirmation page, verify that the wizard lists the EMPINFO and SALARY tables. To make any corrections, click Back. When all of the information is correct, click Finish to register the tables.
Set SAS Information Map Studio Preferences

SAS Information Map Studio enables you to set application usage preferences in the Options dialog box. For example, you can set preferences for data items, data sources, and relationships. For this scenario, specify an option to display both column names and column labels in the application. (The default setting displays only column names.)

To specify the option:

1. Start SAS Information Map Studio.
   a. Select Start ⇒ Programs ⇒ SAS ⇒ SAS Information Map Studio 4.2 from your Windows desktop.
   b. When you start SAS Information Map Studio, the application either uses the default connection profile (if you specified a default profile during a previous session), or it displays the Connection Profile dialog box.
      To choose a profile in the Connection Profile dialog box, select Open an existing connection profile. From the drop-down list, select the connection profile that you want to use for this scenario, and click OK.
   c. If you saved your user ID and password in the connection profile, or if you are using Integrated Windows authentication, then the SAS Information Map Studio main window will be displayed and you can proceed to the next section. Otherwise, you will be prompted to specify your user ID and password in order to log on to the metadata server and display the SAS Information Map Studio main window.

2. From the SAS Information Map Studio menu bar, select Tools ⇒ Options.

3. In the Options dialog box, select the Tables tab.

4. Select Show column name and label (if available).

5. Click OK to apply the settings.
About the Tasks That You Will Perform

To create a SAS Information Map, you will perform these main tasks:

1. Add data sources for the information map to use.
2. Create a relationship between the data sources in order to use them together in a query.
3. Create folders to help organize the items in the information map.
4. Create and customize data items.
5. Create filters that can be used to subset data and learn how to create and use a prompt with a filter.
6. Save the information map.
7. Run a test query.
Add Data Sources

The first step in creating an information map is to add data sources. Data sources are references to tables or cubes that are accessed through a SAS Application Server.

To add as data sources the tables that you defined in chapter 3:

1. Make sure that you have started SAS Information Map Studio and are using the connection profile that you created in chapter 3.
2. On the toolbar, click to open a new information map.
3. In the SAS Information Map Studio main window, select the tab in the Resources pane.
4. In the Show drop-down list, select Tables.
5. Make sure that the SAS Application Server node that your tables are associated with is expanded.
6. Expand the Sample Employee Data library node that contains the tables that you want to add as data sources.
7. Select the EMPINFO and SALARY tables and drag them to the Selected Resources pane to add them as data sources.

Create a Relationship

In order to use your data sources together in a query, you must create a relationship between them. A relationship specifies how two data sources are joined in a query. For this scenario, use the IDNUM columns in EMPINFO and SALARY as your join keys.

To create a relationship that specifies an inner join between the two data sources:

1. In the SAS Information Map main window, select the Relationships tab.
2. (Optional) Use your mouse pointer to enlarge the data source boxes on the tab.
3. From the menu bar, select Insert ⇒ Relationship.
4. In the Relationship Properties dialog box, the two data sources are automatically selected in the Table 1 and Table 2 drop-down lists.

   *Note:* Because you are creating an inner join, do not select the Outer join check boxes.

5. From the Cardinality drop-down list, select one to one.

   *Note:* The cardinality setting does not enforce the cardinality between data sources; it provides descriptive information about the relationship.

6. To create a join condition for the relationship, select IDNUM from both Join keys drop-down lists and make sure that = is selected in the Operator drop-down list.

7. Click Add to add the join condition.

8. Click OK. A line and the appropriate cardinality and join type indicators are displayed on the Relationships tab.
Create Folders

Before you create the data items and filters for this scenario, create three folders to help you organize the items:

1. In the SAS Information Map Studio main window, select the **Design** tab.
2. In the **Information Map Contents** pane, select the information map icon. (The information map name is **untitled**.)
3. On the toolbar, click the clear icon to create a folder.
4. When the folder is created, it is given a default name of **Folder**, but you can enter a new name for it. For this folder, enter the name **Employee Information**.
5. Repeat steps 2 and 3 two additional times. For the second and third folders, enter the names **Salary Statistics** and **Seniority**.
Creating Data Items

What Are Data Items?

Data items are the building blocks that your end users use to build reports. You can create two types of data items:

- **Measure data items** are data items whose values are aggregated by default and which can be used in computations or analytical expressions. For example, if you want a data item to calculate salary totals, you would create a measure data item from a salary column in your data source. Typically, the values for measure data items are numeric.

- **Category data items** are data items whose distinct values are used to aggregate the values of measure data items. For example, if you want to aggregate your salary data by geographical location, you would create a category data item from a column that contains geographical region names.

For this scenario, you create both measure and category data items. Some of the data items are created directly from the columns that they reference, and others are based on expressions that you create.

Create Data Items from Columns

Create the Data Items

To create data items directly from the columns:

1. In the SAS Information Map Studio main window, select the Design tab.
2. Create five data items that will be located in the Employee Information folder:
   a. In the Information Map Contents pane, select the Employee Information folder so that the data items are created directly in that folder.
   b. In the Selected Resources pane, expand EMPINFO.
   c. Press the CTRL key and select NAME, IDNUM, JOBCODE, DEPTCODE, and LOCATION. (Make sure that EMPINFO is not selected).
   d. Click to create the data items.
Note: The name of the data item that was created from the IDNUM column is Identification Number, which is the same as the column's label. The column label was used for the data item name because an option in the Options dialog box is set (by default) to use column labels for the data item names (when labels are available).

3. Create four data items that will be located in the Salary Statistics folder:
   a. In the Information Map Contents pane, select the Salary Statistics folder so that the data items are created directly in that folder.
   b. In the Selected Resources pane, expand SALARY.
   c. Select the SALARY column.
   d. Click $ four times to create four data items from the same column.
4. Create one data item that will be located in the Seniority folder:

   a. In the **Information Map Contents** pane, select the **Seniority** folder so that the data item is created directly in that folder.

   b. In the **Selected Resources** pane, expand **EMPINFO**.

   c. Select the **HDATE** column.

   d. Click ➕ to create the data item.
Rename the Data Items

You can rename a data item if its default name does not follow a standard format or does not clearly convey its purpose.

To rename data items:

1. In the SAS Information Map Studio main window, select the **Design** tab.
2. In the **Information Map Contents** pane, right-click the **Jobcode** data item in the **Employee Information** folder, and then select **Rename** from the pop-up menu.
3. Enter **Job Code**.
4. Use the preceding steps to rename the following data items:

<table>
<thead>
<tr>
<th>Folder Name</th>
<th>Original Data Item Name</th>
<th>New Data Item Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Employee Information</td>
<td>Deptcode</td>
<td>Department</td>
</tr>
<tr>
<td>Salary Statistics</td>
<td>Salary</td>
<td>Average Salary</td>
</tr>
<tr>
<td>Salary Statistics</td>
<td>Salary2</td>
<td>Minimum Salary</td>
</tr>
<tr>
<td>Salary Statistics</td>
<td>Salary3</td>
<td>Maximum Salary</td>
</tr>
<tr>
<td>Salary Statistics</td>
<td>Salary4</td>
<td>Sum of Salaries</td>
</tr>
</tbody>
</table>
Change the Classification

By default, the Identification Number data item was created as a measure data item because it was created from a numeric column. Because this data item is used for grouping values and should not be aggregated, you need to reclassify it as a category data item.

To change the classification for this data item:

1. In the SAS Information Map Studio main window, select the Design tab.

2. In the Information Map Contents pane, right-click the Identification Number data item in the Employee Information folder, and then select Properties from the pop-up menu.

3. In the Data Item Properties dialog box, select the Classifications, Aggregations, Formats tab.

4. In the Classifications and Aggregations section, select the Category radio button.

5. Click OK. In the Information Map Contents pane, the icon for the data item has changed to a category icon (カテゴリー).
Change the Method of Aggregation

By default, the data items in the Salary Statistics folder were created so that end users could select from multiple methods of aggregation. You've decided to use each of the data items to produce a unique aggregation, so you are going to limit each data item to a single method of aggregation.

To change the method of aggregation for these data items:

1. In the SAS Information Map Studio main window, select the Design tab.
2. In the Information Map Contents pane, right-click the Average Salary data item in the Salary Statistics folder, and then select Properties from the pop-up menu.
3. In the Data Item Properties dialog box, select the Classifications, Aggregations, Formats tab.
4. Below the Aggregate functions list, click Clear All to deselect all of the aggregate functions.
5. From the Aggregate functions list, select AVG(argument) to specify that you want this data item to average salary values.
6. Click OK.
7. Use the preceding steps to change the aggregate functions for the following data items:

<table>
<thead>
<tr>
<th>Data Item Name</th>
<th>Aggregate Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Minimum Salary</td>
<td>MIN</td>
</tr>
<tr>
<td>Maximum Salary</td>
<td>MAX</td>
</tr>
<tr>
<td>Sum of Salaries</td>
<td>SUM(argument)</td>
</tr>
</tbody>
</table>
Change Formatting Options

You want to change the number of decimal places that are displayed for the salary data items when aggregated values are displayed in a report. To change this data item property, you decide to use the multi-edit feature of SAS Information Map Studio:

1. In the SAS Information Map Studio main window, select the Design tab.
2. In the Information Map Contents pane, press the CTRL key and select Average Salary, Minimum Salary, Maximum Salary, and Sum of Salaries.
3. In the Properties pane of the main window, click DOLLAR12.0 in the Format row of the properties table.

The Data Item Properties dialog box opens.

4. Make sure that the Selected Data Items list on the left side of the dialog box contains all four of the data items that you selected.
5. In the Formats section of the Classifications, Aggregations, Formats tab, enter 2 in the field next to Valid decimal range.

<table>
<thead>
<tr>
<th>Formats</th>
</tr>
</thead>
<tbody>
<tr>
<td>Format type:</td>
</tr>
<tr>
<td>Numeric</td>
</tr>
<tr>
<td>Format name:</td>
</tr>
<tr>
<td>DOLLAR</td>
</tr>
<tr>
<td>DOLLARX</td>
</tr>
<tr>
<td>E</td>
</tr>
<tr>
<td>EURO</td>
</tr>
<tr>
<td>EUROX</td>
</tr>
<tr>
<td>F</td>
</tr>
<tr>
<td>FRACT</td>
</tr>
</tbody>
</table>

6. Click OK to update all four of the data items.

**Change the Value-Generation Method**
Each data item has a value-generation method that enables you to build either a static or dynamic list of values for a data item. You can use these lists in filters. By default, no list is generated for a data item. For this information map, you want to enable users to generate a dynamic list for the Location data item.

To change the value-generation method for this data item:
1. In the SAS Information Map Studio main window, select the Design tab.
2. In the Information Map Contents pane, right-click the Location data item in the Employee Information folder, and then select Properties from the pop-up menu.
3. In the Data Item Properties dialog box, select the Value-Generation Method tab.
4. On the Value-Generation Method tab, select User selects values from a dynamic list.

5. Click OK.

**Create a Calculated Data Item**
For this scenario, you want to create a measure data item that enables your users to calculate the number of years that an employee has been with the company. Because none of the columns provide this information, you need to create a data item with an expression that calculates the value.
Creating Data Items

To create this data item:

1. In the SAS Information Map Studio main window, select the Design tab.
2. In the Information Map Contents pane, select the Seniority folder so that the data item is created directly in that folder.
3. On the toolbar, click to open the Data Item Properties dialog box.
4. In the Data item name field on the Definition tab, enter Number of Years Employed.
5. In the Description field, enter The number of years that the employee has been employed by the company.

6. Click Edit to open the Expression Editor dialog box. This dialog box enables you to create the expression that performs the calculation.

7. To determine the number of years that an employee has been employed by the company, subtract the hire date for the employee from today's date and then divide the difference by 365\(^1\).

   To create an expression that performs this calculation:

   a. In the Expression Editor dialog box, select the Functions tab.
   b. In the Categories pane on the tab, select the Date and Time folder.
   c. In the Functions pane on the tab, select TODAY() and click Add to Expression.

\(^{1}\) This calculation does not consider leap years.
d. Click on the operator toolbar to add the subtraction operator to the expression.

e. Select the Data Sources tab.

f. Expand Physical Data, and then expand EMPINFO.

g. Select the HDATE column, and then click Add to Expression.

h. In the Expression Text box, select TODAY() - <<EMPINFO.HDATE>>, and then click on the operator toolbar to enclose the expression in parentheses.

i. Deselect the expression, and then click on the operator toolbar to add the division operator to the expression.

j. In the Expression Text box, enter 365.

k. Click Validate Expression to check the expression for errors.
1. Click OK in the message dialog box and the Expression Editor dialog box.

8. In the Data Item Properties dialog box, select the **Classifications, Aggregations, Formats** tab.

9. In the **Classifications and Aggregations** section, make sure that **Category** is selected. You want to keep the classification of category because you do not want this data item to be aggregated. You want to use this data item to display individual values or to group other data item values.

10. By default, the format type of this data item is **Date/Time** because the expression contains a date function as well as a date column. But you are calculating years of service, so you want a numeric value to be displayed. In the **Formats** section, select **Numeric** from the **Format type** drop-down list.

11. Select **COMMA** in the **Format name** list.
12. Click **OK** to create the data item.
Creating Filters

What Is a Filter?

A filter contains the criteria for subsetting a result set. The filter functions in the same way as a WHERE clause or a HAVING clause in an SQL statement. You can assign static values to filters, or you can create prompted filters, which enable information map end users to specify filter values at run time. End users can select a filter when they build a query, or you can apply mandatory filters (prefilters) to selected relational data sources and users to prescreen data for queries.

For this scenario, you create two filters: one filter that enables your users to generate reports for a specific company location, and a second filter that enables your users to select the departments that they want reports for. The second filter also uses a prompt, which enables your users to interactively select departments from a list.

Create a Filter

To create a filter that enables your users to generate reports on employees at the company's Cary location:

1. In the SAS Information Map Studio main window, select the Design tab.

2. In the Information Map Contents pane, select the information map icon so that the filter is created directly in the root of the information map.

3. On the toolbar, click to open the New Filter dialog box.

4. In the Filter name field on the Definition tab, enter Cary Employees.

5. In the Description field, enter Employees who work in Cary, North Carolina.

6. In the Data item drop-down list, select Location. By default, Condition is set to Is equal to after you select the data item.

7. In the Value(s) section, select Select value(s) from a list from the drop-down list and the application will display a dynamically generated list of values for the Location data item.

   Note: Select value(s) from a list is available from this drop-down list because for the Location data item, you specified a value-generation method of User selects values from a dynamic list.

8. On the Browse tab in the Available section, select Cary and click .
9. Click **OK** to create the filter.

---

**Create a Prompted Filter**

To create a filter that will prompt your end users to select the departments that they want reports for:

1. In the SAS Information Map Studio main window, select the **Design** tab.

2. In the **Information Map Contents** pane, select the information map icon so that the filter is created directly in the root of the information map.
3. On the toolbar, click 🔄 to open the New Filter dialog box.

4. In the **Filter name** field on the **Definition** tab, enter *Which department?*

5. In the **Description** field, enter *Filters on the departments that the user selects.*

6. From the **Data item** drop-down list, select **Department**. By default, **Condition** is set to *Is equal to* after you select the data item.

7. In the **Value(s)** section, select **Prompt user for value(s)** from the drop-down list.

![Filter dialog box]

8. No existing prompts are available for this filter to use, so you must create a new prompt. Click **New** to open the New Prompt dialog box.

9. To create the prompt, complete these steps:
   
   *Note:* Accept the default settings for any fields that are not mentioned.

   a. In the **Name** field on the **General** tab, enter **Department Prompt**.

   b. In the **Displayed text** field, enter *Please select one or more departments:*

   c. All prompts that are used for filters are required to have values, so the **Requires a non-blank value** check box is selected by default and cannot be cleared.

   d. Select the **Prompt Type and Values** tab.

   e. In the **Prompt type** drop-down list, **Text** is preselected for you because the associated filter is based on character values.

   f. From the **Method for populating prompt** drop-down list, select **User selects values from a dynamic list**.

   g. From the **Number of values** drop-down list, select **Multiple values**.

   h. Click the **Specify** button that is next to the **Default values** field.
i. In the Default Value dialog box, select EDU from the Available values list, and then click [ ] to add it as the default value.

j. Click OK to return to the New Prompt dialog box.

k. Click OK to create the prompt and return to the New Filter dialog box.
10. Click **OK** to create the filter.

**Information Map Contents**

- **untitled**
  - Employee Information
    - Name
    - Identification Number
    - Job Code
    - Department
    - Location
  - Salary Statistics
    - Average Salary
    - Minimum Salary
    - Maximum Salary
    - Sum of Salaries
  - Seniority
    - Hire Date
    - Number of Years Employed
    - Cary Employees
  - Which department?

---

**Save the Information Map**

To save the information map that you just created:

1. From the menu bar, select **File ↦ Save As**.
2. In the Save an Information Map dialog box, open the My Folder folder. If you do not have a folder named My Folder, then select a folder that you have permission to save to.

*Note:* If you intend to use this information map in SAS Web Report Studio, then consult with your SAS Web Report Studio administrator to determine whether you need to save the information map to a particular folder.

After you open My Folder, click to create a new subfolder. Enter Sample Information Maps as the name of the folder.

3. Open the Sample Information Maps folder.

4. In the Name field, enter Employee Statistics Sample.

5. Click Save.

---

**Run a Test Query**

Before you make an information map available to your users, test it to verify that it works as intended.

To run a test query:

1. On the toolbar, click ☑.

2. In the Test the Information Map dialog box, select the Name data item in the Available items list. Then, press the CTRL key and select Department, Location, Number of Years Employed, and Which department?

3. Click ☑ to populate the Selected items list.
4. Accept the default settings for any fields that are not mentioned.

5. Click **Run Test** to run a test query that uses the selected items.

6. In the Prompt Value Specification dialog box, select **SAM** in the **Available** list, and then click **OK**. **EDU** is preselected because you chose it as your default value when you created the prompt.

   **Note:** The label that is displayed for the prompt is the text that you entered in the **Displayed text** field in the New Prompt dialog box. It is prefaced by an asterisk (*) because this prompt requires a value.
7. Click **OK**. The Results dialog box is displayed with the results of the test query. The result set should contain 47 rows.

![Results dialog box]

8. (Optional) You can display the SQL code that is generated for the test by clicking **View SQL** to open the View Query dialog box.

![View Query dialog box]

9. Click **Close** in the View Query dialog box (if you viewed the SQL) and the Results dialog box.

10. Click **Cancel** in the Prompt Value Specification dialog box.

11. Click **Close** in the Test the Information Map dialog box.
Chapter 5

Next Steps: A Quick Look at Additional Features

Assign a Prefilter

If you want a filter to prescreen and subset data before your end user's query is run, then assign the filter as a prefilter. SAS Information Map Studio supports two types of prefilters:

- authorization-based prefilters, which apply to specific users and groups
- general prefilters, which apply to all users

For the information map that you just created, you want to prefilter data so that the reports that are generated from the information map show information about employees who are located at the company's Cary location only.

To assign this general prefilter:

1. If the Employee Statistics Sample information map is not open, select **File ➔ Open** from the SAS Information Map Studio menu bar.
2. In the SAS Information Map Studio main window, select the **Design** tab.
3. In the **Information Map Contents** pane, right-click **Employee Statistics Sample**, and then select **Properties** from the pop-up menu.
4. In the Information Map Properties dialog box, select the **General Prefilters** tab.
5. In the **Selected filters** pane, select **EMPINFO**.
6. In the **Available filters** pane, select **Cary Employees**, and then click ✅.
Note: Prompted filters cannot be used as prefilters, so the prompted filter that you created is not displayed.

7. Now that this filter has been assigned as a general prefilter, you probably do not want end users to select it as a regular filter in their queries.

To hide the filter from end users:

a. Make sure that **Cary Employees** is still selected in the **Available filters** pane. Click **Edit**.

b. On the **Definition** tab in the Edit Filter dialog box, select **Hide from user**.
8. Click OK to close the Information Map Properties dialog box.
9. From the SAS Information Map Studio menu bar, select File → Save As and save the updated information map with the name Employee Statistics Sample with Advanced Features.

Designate a Required Table

If you want a data source (and any associated prefilters) to be used in every query that is generated from a given information map, then designate the data source as required. To designate EMPINFO as required for this information map:

1. Open the Employee Statistics Sample with Advanced Features information map.
2. In the SAS Information Map Studio main window, select the Design tab.
3. In the Information Map Contents pane, right-click Employee Statistics Sample with Advanced Features, and then select Properties from the pop-up menu.
4. In the Information Map Properties dialog box, select the Required Tables tab.
5. In the Available tables pane, select EMPINFO, and then click ➔.
6. Click **OK**. In the **Selected Resources** pane on the **Design** tab, the **EMPINFO** data source is denoted with an asterisk (*) to indicate that it is required.

7. Save the information map.
Test the Prefilter and Required Table Assignments

To ensure that the prefilter and required table assignments are working as expected, test the information map again:

1. On the toolbar, click the toolbar button.

2. In the Test the Information Map dialog box, select Name, Department, Location, Number of Years Employed, and Which department? from the Available items list if they are not already selected.

   Note: The Cary Employees filter is not in the Available items list because you selected Hide from user in the Edit Filter dialog box. The test facility simulates an end-user environment, so it has hidden the filter from you (the end user).

3. Click to populate the Selected items list.

4. Click Run Test to run a test query that uses the selected items.

5. In the Prompt Value Specification dialog box, add SAM to the Selected list box. (EDU should already be selected because it is the default value.)

6. Click OK. The Results dialog box is displayed with the results of the test query. The result set should contain 41 rows. Even though you did not select the Cary Employees filter for the test, the result set contains rows of Cary employees only. The assigned prefilter eliminated the non-Cary information.

<table>
<thead>
<tr>
<th>Name</th>
<th>Department</th>
<th>Location</th>
<th>Number of Years Employed</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ansho, Robert G.</td>
<td>SAM</td>
<td>Cary</td>
<td>16</td>
</tr>
<tr>
<td>Blumberg, William L.</td>
<td>SAM</td>
<td>Cary</td>
<td>17</td>
</tr>
<tr>
<td>Brackel, Leandra N.</td>
<td>SAM</td>
<td>Cary</td>
<td>18</td>
</tr>
<tr>
<td>Braysho, Kathleen</td>
<td>SAM</td>
<td>Cary</td>
<td>22</td>
</tr>
<tr>
<td>Casey, Chantal I.</td>
<td>SAM</td>
<td>Cary</td>
<td>16</td>
</tr>
<tr>
<td>Celley, Henry W.</td>
<td>EDU</td>
<td>Cary</td>
<td>16</td>
</tr>
<tr>
<td>Chasnovitz, Leonard V.</td>
<td>SAM</td>
<td>Cary</td>
<td>17</td>
</tr>
<tr>
<td>Cheng, Lain</td>
<td>SAM</td>
<td>Cary</td>
<td>17</td>
</tr>
<tr>
<td>Cetola, Eric A.</td>
<td>SAM</td>
<td>Cary</td>
<td>19</td>
</tr>
<tr>
<td>Collela, Alfred S.</td>
<td>SAM</td>
<td>Cary</td>
<td>17</td>
</tr>
<tr>
<td>Edson, Guy T.</td>
<td>SAM</td>
<td>Cary</td>
<td>17</td>
</tr>
<tr>
<td>Fluendger, Saul D.</td>
<td>SAM</td>
<td>Cary</td>
<td>17</td>
</tr>
<tr>
<td>Green, Frederick N.</td>
<td>SAM</td>
<td>Cary</td>
<td>17</td>
</tr>
<tr>
<td>Hayden, Priscilla L.</td>
<td>SAM</td>
<td>Cary</td>
<td>18</td>
</tr>
<tr>
<td>Honor, Dorothy T.</td>
<td>EDU</td>
<td>Cary</td>
<td>10</td>
</tr>
</tbody>
</table>
Set Up Cascading Prompts Via a Filter

SAS provides multiple methods for setting up cascading prompts (a sequence of dependent prompts). You can define such a cascade in SAS Information Map Studio by selecting the option to establish dependencies for the prompts in a compound filter. When dependencies are established in a filter, each prompt in the filter is dependent on every filter rule (whether it contains a prompt or not) that precedes it in the filter expression.

In this scenario, your end users are complaining that the existing department prompt (in the Employee Statistics Sample information map) forces them to scroll through a long list of departments—they want to choose from the departments that exist at their respective locations only. So you want to create a filter that will enable a user to first select a location and then select from departments at that location.

You will modify the prompted filter that you created earlier and add to the filter an additional rule that includes a location prompt. This location prompt will be the prompt at the top of the cascade. The existing department prompt will be the dependent prompt.

Note: This scenario defines a two-prompt cascade, but you can cascade more than two prompts.

1. Open the Employee Statistics Sample information map.
2. In the SAS Information Map Studio main window, select the Design tab.
3. In the Information Map Contents pane, right-click Which department?, and then select Properties from the pop-up menu to open the Edit Filter dialog box.
4. In the Data item drop-down list on the Definition tab, change the selection from Department to Location.
5. In the Value(s) section, click New to open the New Prompt dialog box.
6. To create the prompt, complete these steps:
   Note: Accept the default settings for any fields that are not mentioned.
   a. In the Name field on the General tab, enter Location Prompt.
   b. In the Displayed text field, enter Please select a location:
   c. Select the Prompt Type and Values tab.
   d. In the Prompt type drop-down list, Text is preselected for you because the associated filter is based on character values.
   e. From the Method for populating prompt drop-down list, select User selects values from a dynamic list.
      Note: You can use any method to obtain values for the prompt in the first filter rule of a compound filter (that is, you can select any value for the Method for populating prompt field for that prompt). But each (subsequent) dependent prompt must be a dynamic prompt (that is, the value for the Method for populating prompt field must be User selects values from a dynamic list). Otherwise, the cascade will not execute correctly.
   f. In the Data source section, make sure that Use the current information map is selected. You cannot cascade prompts that use tables or other information maps as their respective data sources.
g. Click the **Specify** button that is next to the **Default value** field.

h. In the Default Value dialog box, select **Cary** and click **OK** to add it as the default value.

![Prompt Type and Values](image)

i. Click **OK** to create the prompt and return to the Edit Filter dialog box.
j. Click **Add** to add this new filter rule to the filter expression. The new rule should be automatically selected in the **Filter combinations** table.

k. The order of dependency is based on the order of the rules in the filter expression, so arrange the filter rules in the order that you want the prompts to be processed. Click **to make the new rule the first rule in the filter expression.**

l. Select **Establish dependencies between prompts.**

m. Click **OK** to update the filter.

n. Save the information map with the name **Employee Statistics Sample with Cascading Prompts.**
Test the Cascading Prompts

To ensure that the updated filter is working as expected, test the information map again:

1. On the toolbar, click 🔄.

2. In the Test the Information Map dialog box, select Department, Average Salary, and Which department? from the Available items list.

3. Click ➔ to populate the Selected items list.

4. Click Run Test to run a test query that uses the selected items.

5. In the Prompt Value Specification dialog box, the location prompt is populated with the default value of Cary. The department prompt is also populated with departments that are in the Cary location. Change the value of the Please select a location drop-down list to Austin. As soon as you select the new location, the available values for the department prompt will change to the departments at the Austin location only.

6. Select TX0 and TXR in the Available list, and then click ➔.

7. Click OK. The Results dialog box is displayed with the results of the test query. The result set should contain two rows.
Manage Columns

Sometimes a table will contain many miscellaneous columns that your information map does not need to reference. To avoid cluttering your Selected Resources pane with these extraneous columns, you can omit them from the data source so that they are ignored by the application. For this scenario, you have decided that the EMPINFO data source references a few extraneous columns.

To omit the extraneous columns:
1. Open the Employee Statistics Sample information map.
2. In the SAS Information Map Studio main window, select the Design tab.
3. In the Selected Resources pane, right-click the EMPINFO data source, and then select Properties from the pop-up menu.
4. In the Table Properties dialog box, select the Columns tab.
5. Select Specify columns to omit. In the Keep these columns list box, all of the columns for EMPINFO are displayed.
6. The extraneous columns are ADDR1, ADDR2, DIVISION, STATUS, and EDLEV. Select these columns and then click .

Note: You are not allowed to omit columns that are being used by data items, filters, or relationships, so those items are not selectable.
7. Click **OK**. The columns that you omitted are no longer displayed in the **Selected Resources** pane.
Replace Resources

An information map references many external resources such as servers, libraries, tables, and cubes. Over time, the metadata that is registered for an external resource might be changed (for example, deleted or moved) so that the information map can no longer access or locate the resource. Or, you might need to reference a different resource (for example, your information map references the resources in a development environment and must now reference the resources in a production environment). The Resource Replacement dialog box provides a way for you to repair or update references to resources without re-creating the information map.

In this scenario, your administrator has used SAS Management Console to rename the EMPINFO table to EMPLOYEE. When you reopen the Employee Statistics Sample information map, you see that the EMPINFO data source is marked with a red x. The data source is trying to find the table named EMPINFO, but that table no longer exists because it has been renamed.

To replace the EMPINFO table with the EMPLOYEE table for the EMPINFO data source:

1. From the menu bar, select Tools ➤ Resource Replacement.
2. In the Resource Replacement dialog box, select the Tables tab.

Note: The SALARY data source is not displayed because it uses a resolved table. To display SALARY, clear the Display only unresolved resources check box.
3. For the EMPINFO data source, click the cell in the **Replacement Table** column of the resources table.

4. From the drop-down list, select **EMPLOYEE**. After you make the selection, the resources table is cleared because all resources were resolved when you replaced EMPINFO with EMPLOYEE.

5. Click **OK**. In the **Selected Resources** pane, the EMPINFO data source is no longer marked with a red x.

![Resource Replacement](image)

**Note:** The resource replacement feature replaces the table that is associated with the data source, but it does not change the name of the data source. So, the **Selected Resources** pane still displays EMPINFO and not EMPLOYEE. If you want to update the name of the data source, you can use the **Rename** option in the pop-up menu for the data source.

6. Save the information map.
aggregate function
a function that summarizes data and produces a statistic such as a sum, an average, a minimum, or a maximum.

aggregation
the act or process of grouping data, using an operation that produces a statistic such as a sum, average, minimum, or maximum. The term aggregation can also refer to the grouped data that results from such an operation. See also aggregate function.

authentication domain
a SAS internal category that pairs logins with the servers for which they are valid. For example, an Oracle server and the SAS copies of Oracle credentials might all be classified as belonging to an OracleAuth authentication domain.

calculated data item
a data item that has a customized expression.

cardinality
in a join, a property that describes whether one row or many rows in one table are associated with one row or many rows in the other table.

cascading prompts
a sequence of dependent prompts. See also dependent prompt.

category
a classification of data items. Category data items are used to group measure data items, using an applied aggregate function. For example, a category data item that contains the names of countries could be used to group a measure data item that contains population values.

classification
an attribute of data items that determines how they will be processed in a query. Data items can be classified as either categories or measures.

connection profile
a client-side definition of where a metadata server is located. The definition includes a computer name and a port number. In addition, the connection profile can also contain user connection information.
data element
a general term that can include data (such as table columns, OLAP hierarchies, and OLAP measures) as well as data items. See also data item.

data item
in an information map, an item that represents either data (a table column, an OLAP hierarchy, or an OLAP measure) or a calculation. Data items are used for building queries. Data items are usually customized in order to present the data in a form that is relevant and meaningful to a business user.

data source
a table or cube that an information map retrieves data from. A table can be added as a data source multiple times as long as each instance is given a unique data source name.

dependent prompt
a prompt whose values depend on the values of another prompt. For example, you have a prompt whose values are the names of the divisions in your organization. You also have a prompt whose values are the names of the departments in those divisions. If you want the end user to see only the departments for the selected division, then you would set the department prompt to be dependent on the division prompt. After you select a value for the division prompt, the department prompt is then populated with only the names of the departments from that division.

engine
a component of SAS software that reads from or writes to a file. Each engine enables SAS to access files that are in a particular file format.

expression
a combination of data elements, literals, functions, and mathematical operators. An expression can be used to derive a value or to specify a condition that determines whether or how data is processed.

filter
in an information map, criteria (rules) that subset data. When a query is generated from an information map, the filter is converted to a query-language statement (for example, an SQL WHERE clause).

format
a pattern that SAS uses to determine how the values of a variable or data item should be written or displayed. SAS provides a set of standard formats and also enables you to define your own formats.

identity
a user, group, or role definition.

information architect
a person in an organization who is responsible for facilitating business reporting in the enterprise.

information map
a collection of data items and filters that provides a user-friendly view of a data source. When you use an information map to query data for business needs, you do not have to understand the structure of the underlying data source or know how to program in a query language.
inner join
a join between two tables that returns all of the rows in one table that have one or more matching rows in the other table.

join
(1) the act of combining data from two or more tables in order to produce a single result set. (2) a specification that describes how you want data from two or more tables to be combined. The specification can be in the form of Structured Query Language (SQL) programming code, or it can be done interactively through a software user interface.

join condition
a combination of join keys and a comparison operator.

join key
one or more columns that are used to associate two tables in a join.

label
an alternate name for an object. The label is often longer and more descriptive than the name of the object.

libref
a short name for the full physical name of a SAS library. In the context of the SAS Metadata Repository, a libref is associated with a SAS library when the library is defined in the metadata repository.

login
a SAS copy of information about an external account. Each login includes a user ID and belongs to one SAS user or group. Most logins do not include a password.

measure
a classification of data items. The values of measure data items are aggregated (unless otherwise specified) and can be used in computations or analytical expressions. For example, a measure data item could contain age values that are grouped by gender and then averaged.

metadata
data about data. For example, metadata typically describes resources that are shared by multiple applications within an organization. These resources can include software, servers, data sources, network connections, and so on. Metadata can also be used to define application users and to manage users' access to resources. Maintaining metadata in a central location is more efficient than specifying and maintaining the same information separately for each application.

metadata repository
a collection of related metadata objects, such as the metadata for a set of tables and columns that are maintained by an application. A SAS Metadata Repository is an example.

metadata server
a server that provides metadata management services to one or more client applications. A SAS Metadata Server is an example.

outer join
a join between two tables that returns all of the rows in one table, as well as part or all of the rows in the other table. A left or right outer join returns all of the rows in
one table (the table on the left or right side of the SQL statement, respectively), as well as the matching rows in the other table. A full outer join returns all of the rows in both of the tables.

**port**
in a network that uses the TCP/IP protocol, an endpoint of a logical connection between a client and a server. Each port is represented by a unique number.

**prefilter**
in an information map, a mandatory filter that pre-screens and subsets the data in its associated table before any other part of a query is run. The two types of prefilters are authorization-based prefilters and general prefilters. An authorization-based prefilter applies to a specific user or group, and a general prefilter applies to all users.

**prompt**
a parameter that enables a user to specify one or more values, which can be used by consumers such as applications, stored processes, and reports.

**prompted filter**
a filter that is associated with a prompt, which enables the user of an information map to specify filtering criteria when a query is executed.

**query**
a set of instructions that requests particular information from one or more data sources.

**register**
to save metadata about an object to a metadata repository. For example, if you register a table, you save metadata about that table to a metadata repository.

**relationship**
the association, between tables in an information map, that generates a database join in a query.

**required table**
a relational data source that must be used in any query that is generated from an information map.

**resource**
an object that is external to an information map and that the information map uses or references. Some examples of resources are tables, columns, cubes, servers, stored processes, and user-defined formats.

**result set**
the set of rows or records that a server or other application returns in response to a query.

**rule**
in an information map filter, a criterion that is used for subsetting data. A simple filter contains a single rule, and a compound filter contains multiple rules.

**SAS Application Server**
in the SAS Intelligence Platform, a logical entity that represents the SAS server tier. This logical entity contains specific servers (for example, a SAS Workspace Server and a SAS Stored Process Server) that execute SAS code. A SAS Application Server has relationships with other metadata objects. For example, a SAS library can be
assigned to a SAS Application Server. When a client application needs to access that library, the client submits code to the SAS Application Server to which the library is assigned.

SAS Information Map
See information map.

SAS library
a collection of one or more files that are recognized by SAS and that are referenced and stored as a unit. SAS libraries can be defined in a SAS Metadata Repository to provide centralized definitions for SAS applications.

SAS Metadata Repository
a repository that is used by the SAS Metadata Server to store and retrieve metadata. See also SAS Metadata Server.

SAS Metadata Server
a multi-user server that enables users to read metadata from or write metadata to one or more SAS Metadata Repositories.

SAS Workspace Server
a SAS server that provides access to Foundation SAS features such as the SAS programming language and SAS libraries.

SQL
See Structured Query Language.

Structured Query Language
a standardized, high-level query language that is used in relational database management systems to create and manipulate database management system objects. Short form: SQL.

table
a two-dimensional representation of data in which the data values are arranged in rows and columns.
A
accessibility features 4
aggregation options 26
application options 16

C
calculated data items 28
cardinality, specifying for relationships 19
cascading prompts 46
category data items 21
classifications of data items
  changing 25
  definition of 21
columns, managing (hiding) 50
connection profiles 9

data items
  aggregation methods for 26
categories 21
classifications, changing 25
columns, creating from 21
creating 21
definition of 1, 21
editing multiple 27
expressions, creating from 28
formatting options of 27
measures 21
renaming 24
value-generation methods of 28

Data Library Manager
  defining libraries 11
  defining tables 14
  online help 8

data sources
  adding 18
  creating relationships between 18
designating as required 43

defining
  libraries 11
  tables 14

E
Expression Editor 29
expressions, using in data items 28

F
filters
  assigning general prefilters 41
  creating 33
definition of 1, 33
hiding 42
prompted 34
folders, creating in information maps 20
formatting options 27

H
Help
  Data Library Manager 8
  SAS Information Map Studio 8
hiding
  columns 50
  filters 42

I
information maps
  benefits of 2
definition of 1
life cycle of 3
saving 37
software that uses 2
testing 38, 45, 49
J
joins 18
testing 38, 45, 49
viewing SQL code of 40

L
LIBNAME statement 11
libraries, defining (registering) 11

M
measure data items 21

O
online help
Data Library Manager 8
SAS Information Map Studio 8
options, SAS Information Map Studio 16

P
preferences, SAS Information Map Studio 16
prefilters
assigning 41
definition of 41
prompted filters 34
prompts
cascading 46
creating 35, 46

Q
queries
designating a required data source for 43
relationships 18
renaming data items 24
required tables 43
resources
replacing 52

S
SAS Information Map Studio
online help 8
options 16
overview 1
user interface 2
SAS Management Console, using Data Library Manager in 11
saving information maps 37
SQL, viewing 40

T
tables
See also data sources
defining (registering) 14
replacing 52
testing information maps 38, 45, 49

V
value-generation methods 28