SAS® 9.4 ODS Graphics
Getting Started with Business and Statistical Graphics
Gain Greater Insight into Your SAS® Software with SAS Books.

Discover all that you need on your journey to knowledge and empowerment.

support.sas.com/bookstore
for additional books and resources.
# Contents

**Chapter 1 • Introduction to ODS Graphics**

- What is ODS Graphics? ................................................. 1
- SAS/GRAPH Output versus ODS Graphics ...................... 2
- The Suite of ODS Graphics Software ............................. 3
- Benefits of Using ODS Graphics Software ...................... 4
- Overview of ODS Destinations ..................................... 6
- Components of a Graph .............................................. 7

**Chapter 2 • Using the ODS GRAPHICS Statement**

- About the ODS GRAPHICS Statement ......................... 11
- Using ODS Graphics Functionality to Create Graphs ......... 13
- Using the ODS GRAPHICS Statement to Set Graphics Options 15
- Where to Go from Here ............................................. 16

**Chapter 3 • Using the ODS Graphics Procedures**

- About the ODS Graphics Procedures ........................... 17
- Basic Structure of a Typical Procedure ......................... 19
- Examples of Using the Procedures ............................... 22
- Where to Go from Here ............................................. 26

**Chapter 4 • Using the Graph Template Language**

- About the Graph Template Language .......................... 29
- Basic Structure of a Simple Single-Cell Graph Template .... 31
- Example of Creating a Multi-Cell Graph Template ............ 32
- Where to Go from Here ............................................. 35

**Chapter 5 • Using the ODS Graphics Designer**

- About the ODS Graphics Designer ............................. 37
- About the Designer’s Graphical Interface ..................... 38
- Example of Using the Designer ................................... 40
- Using SGD Files with the SGDESIGN Procedure ............. 47
- Using SGD Files with the Graph Template Language ......... 49
- Where to Go from Here ............................................. 49
# Contents

**Chapter 6 • Using the ODS Graphics Editor**
- About the ODS Graphics Editor .................................................. 51
- About the Editor’s Graphical Interface ....................................... 52
- Example of Using the Editor ................................................. 54
- Where to Go from Here .................................................. 60

**Chapter 7 • Changing the Appearance of Graphs**
- Understanding ODS Styles ...................................................... 61
- Recommended Styles for Statistical Work .................................. 64
- Working with Styles ............................................................. 66
- Using Attribute Mapping ....................................................... 72
- Adding Annotations to Graphs ....................................... 72

**Chapter 8 • Understanding ODS Graphics Software Interactions**
- Scenarios for ODS Graphics Software Interactions ................... 75
- Example of Producing an Annotated ODS Graphics Designer Graph for Publication .................................................. 79

**Appendix 1 • Usage Summaries**
- Summary of Ways to Create ODS Graphs ............................... 87
- Summary of Ways to Modify and Customize ODS Graphs ........ 88
- Summary of Using ODS Graphics Software ......................... 89

**Glossary** ........................................................................ 91
**Index** ........................................................................... 99
Introduction to ODS Graphics

What is ODS Graphics?

SAS ODS Graphics, sometimes called SAS ODS Statistical Graphics, is SAS functionality that can be used to create a wide variety of graphs. Many SAS procedures use ODS Graphics functionality to produce graphs as automatically as they produce tables. In addition, SAS provides a rich suite of ODS Graphics software that facilitates the creation of custom, stand-alone graphs. This suite consists of applications, procedures, and a template language that enable you to create effective and attractive graphs. Whether you are a novice SAS user or an expert SAS statistical user, you can create graphs ranging from simple scatter plots and bar charts to complex multi-page classification panels.

ODS Graphics is an extension of the SAS Output Delivery System (ODS). ODS manages procedure output and enables you to display the output in a variety of forms, such as HTML, RTF, PDF, and others. Many familiar features of ODS for tabular output
apply equally to graphs. For example, if you specify an ODS destination and style for a procedure, both the tables and graphs created by the procedure are integrated in the ODS output destination. Both outputs have the same style and share other features that were specified in the ODS destination statement.

ODS Graphics produce template-based graphs that use Graph Template Language (GTL) syntax. GTL is a comprehensive language for defining statistical graphics and provides the power and flexibility to create many types of complex graphs. The appearance and layout of these graphs are controlled by ODS style and graph templates.

See Also

*SAS Output Delivery System: User's Guide*

---

**SAS/GRAPH Output versus ODS Graphics**

SAS produces graphics using two very distinct systems. SAS/GRAPH produces graphics using a device-based system. Base SAS produces graphics through the Output Delivery System (ODS) using a template-based system.

device-based graphics (SAS/GRAPH output)

output that is produced by SAS/GRAPH, which uses devices to generate output. Devices determine the type of output. Examples of device drivers are SVG, PNG, GIF, ACTIVEX, and SASPRTC. Device drivers supplied by SAS are stored in the SASHELP.DEVICES catalog. Most procedures that produce device-based graphics also produce GRSEG catalog entries in addition to any image files, vector files, or displayed output that are produced. SAS/GRAPH procedures that produce device-based graphics and GRSEG catalog entries include the GCHART, GPLOT, GMAP, GBARLINE, GCONTOUR, and G3D procedures. The device-based procedures that do not produce GRSEG catalog entries are the GAREABAR, GKPI, and GTILE procedures. For device-based graphics, you can use the GOPTIONS statement to control the graphical environment. For example, you can specify which device is used to generate SAS/GRAPH output by specifying the DEVICE= option in the
GOPTIONS statement. For more information about device-based graphics, see SAS/GRAPH: Reference.

template-based graphics (ODS Graphics) output that is produced from a compiled ODS template of type STATGRAPH. Templates supplied by SAS are stored in SASHELP.TMPLMST. Device drivers and most SAS/GRAPH global statements (such as AXIS, LEGEND, PATTERN, and SYMBOL) have no effect on template-based graphics. The Base SAS procedures that produce template-based graphics are the SG PLOT, SGPANEL, SG SCATTER, SG DESIGN, and SG RENDER procedures. Many SAS/STAT, SAS/ETS, and SAS/QC procedures also produce template-based graphics automatically by default. Template-based graphics are always produced as image files and never as GRSEG catalog entries. For template-based graphics, you must use the ODS GRAPHICS statement to control the graphical environment. For example, you can specify the type of image file (SVG, PNG, GIF, and so on) that is produced by specifying the OUTPUTFMT= option in the ODS GRAPHICS statement. Template-based graphics are referred to as ODS Graphics.

The Suite of ODS Graphics Software

ODS Graphics software is a set of SAS features that enable you to create and edit statistical graphs. ODS Graphics software consists of the following.

<table>
<thead>
<tr>
<th>Software</th>
<th>Description</th>
<th>Level of Complexity</th>
</tr>
</thead>
<tbody>
<tr>
<td>ODS GRAPHICS statement</td>
<td>Adds graphics capabilities to many SAS analytical and Base procedures.</td>
<td>Low</td>
</tr>
<tr>
<td>SAS ODS Graphics Designer</td>
<td>Provides a graphical, interactive interface that enables you to create and design custom graphs.</td>
<td>Low</td>
</tr>
</tbody>
</table>
SAS ODS Graphics Editor

Provides a graphical, interactive editor that enables you to modify the elements of a graph or to add new features, such as titles, arrows, and text boxes.

High

SAS ODS Graphics procedures

Provide a simple, concise syntax for creating effective statistical graphs. You can create a wide variety of charts and plots with only a few lines of code.

Medium

SAS Graph Template Language

Provides a comprehensive language for creating complex, customized statistical graphics.

High

See Also

- Chapter 2, “Using the ODS GRAPHICS Statement ,” on page 11
- Chapter 3, “Using the ODS Graphics Procedures ,” on page 17
- Chapter 4, “Using the Graph Template Language ,” on page 29
- Chapter 5, “Using the ODS Graphics Designer,” on page 37
- Chapter 6, “Using the ODS Graphics Editor,” on page 51

Benefits of Using ODS Graphics Software

ODS Graphics software provides the following benefits:

- You can generate graphical output for your analytical procedures with virtually no effort on your part. Many SAS procedures use ODS Graphics functionality to produce graphs as automatically as they produce tables.
- ODS Graphics software facilitates the production of commonly used statistical graphs independent of SAS analytical procedures. These graphs can be used for preliminary exploration of data and the construction of specialized displays for
analyses. These situations require general-purpose graphical tools for the creation of stand-alone plots.

- Regardless of your level of proficiency with SAS, you can use ODS Graphics software to develop a wide variety of graphs ranging from simple plots to complex multi-cell layouts.

- Although ODS Graphics software was initially designed to facilitate the production of statistical graphs, its capabilities are also well suited for the production of non-statistical, business graphs.

- The software components complement each other and can be used together. For example, the SGRENDER procedure produces output from templates that are created with the Graph Template Language. The procedure can also produce output from ODS Graphics Editor files. For more information, see Chapter 8, “Understanding ODS Graphics Software Interactions,” on page 75.

- Because ODS Graphics is an extension of the Output Delivery System (ODS), many familiar features of ODS for tabular output apply equally to graphs. In addition, graphical output has a consistent appearance. For example, the automatic output from statistical procedures can be combined with custom graphs from the ODS Graphics procedures to create a cohesive-looking report.

- ODS Graphics software was designed with the principles of effective graphics in mind, including these features:
  - a variety of plot and chart types to handle many data situations
  - multi-cell graph layout capabilities that help eliminate the clutter that is often found in single-celled displays
  - attractive styles that emphasize the data and minimize the supporting items in the graph
Overview of ODS Destinations

The Output Delivery System (ODS) manages all output created by procedures and enables you to display the output in a variety of forms, such as HTML, PDF, RTF, and others. ODS destinations are useful in many ways. For example, you might specify the RTF destination and then copy and paste graph output from the viewer into a Microsoft Word document or a Microsoft PowerPoint slide.

Here is the basic syntax for the statement:

**ODS destination <option(s)>;**

The ODS statement is global and can be used anywhere in your program. You can use the statements to open and close an ODS destination. For example:

```sas
ods listing;
  . . . SAS statements . . .
ods listing close;
```

For creation of ODS graphs, a valid ODS destination must be open. On Windows and UNIX operating systems, HTML is the default destination.

You can use ODS destination statement options to specify where you want your output to be displayed and where you want your image files to be stored.

For example, the ODS HTML statement below specifies the following:

- the name of the HTML output file
- the folder where image files are stored
- the style to be used

```sas
ods html file="BoxPlot-Body.html"
gpath="C:\myfiles\images" style=journal;
  . . . SAS statements . . .
```

In summary, ODS destination statements provide many options for controlling your output. When used with the ODS GRAPHICS statement, these ODS features enable you to customize even more aspects of your graphical output.
See Also

- *Getting Started with the SAS Output Delivery System*
- “Understanding ODS Destinations” in Chapter 2 of *SAS Output Delivery System: User's Guide*
- Chapter 2, “Using the ODS GRAPHICS Statement,” on page 11

---

**Components of a Graph**

In general, a graph is made up of the following parts:

- titles and footnotes
- one or more cells that contain a composite of one or more plots
- legends, which can reside inside or outside a cell

The following figure shows the different parts of a graph:
Figure 1.1 Components of a Graph

1 Graph

a visual representation of data. The graph can contain titles, footnotes, legends, and one or more cells that have one or more plots.

2 Cell

a distinct rectangular subregion of a graph that can contain plots, text, and legends.

3 Title

descriptive text that is displayed above any cell or plot areas in the graph.

4 Plot

a visual representation of data such as a scatter plot, a series line, a bar chart, or a histogram. Multiple plots can be overlaid in a cell.
5 Legend

refers collectively to the legend border, one or more legend entries (where each entry has a symbol and a corresponding label) and an optional legend title.

6 Axis

refers collectively to the axis line, the major and minor tick marks, the major tick mark values, and the axis label. Each cell has a set of axes that are shared by all the plots in the cell. In multi-cell graphs, the columns and rows of cells can share common axes if the cells have the same data type.

7 Footnote

descriptive text that is displayed below any cell or plot areas in the graph.
Using the ODS GRAPHICS Statement

About the ODS GRAPHICS Statement .......................................................... 11
Using ODS Graphics Functionality to Create Graphs .................. 13
Using the ODS GRAPHICS Statement to Set Graphics Options .......................................................... 15
Where to Go from Here ............................................................................. 16

About the ODS GRAPHICS Statement

The ODS GRAPHICS statement enables many SAS procedures to produce graphs as automatically as they produce tables. The statement enables or disables ODS graphics processing and sets graphics environment options.

Here is the basic syntax for the statement:

**ODS GRAPHICS < OFF | ON> </ option(s)>**;

The statement affects ODS graphical output only. (ODS graphs are template-based graphs that are created using Graph Template Language syntax. For more information, see “SAS/GRAPH Output versus ODS Graphics” on page 2.)

The statement can be used with any SAS procedure that supports ODS Graphics functionality. Like other ODS statements, the ODS GRAPHICS statement is global and can be used anywhere in your SAS program. The statement remains in effect until you explicitly change it or until you close the SAS session.
By default, the ODS GRAPHICS statement is set to ON for SAS procedures on the Windows and UNIX operating systems.

You can disable ODS Graphics output in the SAS preferences dialog box.

In SAS, you can access this dialog box by selecting **Tools ★ Options ★ Preferences**.

You can also disable ODS Graphics for the current SAS session by issuing the following statement.

```
ods graphics off;
```

**TIP** You should consider disabling ODS Graphics if your goal is solely to produce computational or tabular results. Producing ODS Graphics uses additional resources.
Using ODS Graphics Functionality to Create Graphs

By default, ODS Graphics are enabled for many SAS procedures. However, you might need to request particular plots using procedure options. For procedures that support ODS Graphics, these options are described in the “Syntax” section of the procedure chapter of the respective procedure guide. You typically request graphs with the PLOTS= option in the procedure statement.

The following example uses the FREQ procedure to provide a frequency distribution of cars based on the number of engine cylinders. In this example, you do not need to specify the ODS GRAPHICS statement. ODS Graphics functionality is enabled by default for the FREQ procedure. However, this example specifies the PLOTS= option in the TABLES statement in order to produce graphical output.

```sas
   title1 "Distribution of Cylinders";
   proc freq data=sashelp.cars;
      tables Cylinders / plots=freqplot;
   run;
   title1;
```

**Note:** The PLOTS= FREQPLOT option is described in the “Syntax” section of the FREQ procedure in *Base SAS Procedures Guide: Statistical Procedures*. 
Display 2.1  PROC FREQ Output Table

Distribution of Cylinders

The FREQ Procedure

<table>
<thead>
<tr>
<th>Cylinders</th>
<th>Frequency</th>
<th>Percent</th>
<th>Cumulative Frequency</th>
<th>Cumulative Percent</th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td>1</td>
<td>0.23</td>
<td>1</td>
<td>0.23</td>
</tr>
<tr>
<td>4</td>
<td>136</td>
<td>31.92</td>
<td>137</td>
<td>32.16</td>
</tr>
<tr>
<td>5</td>
<td>7</td>
<td>1.64</td>
<td>144</td>
<td>33.80</td>
</tr>
<tr>
<td>6</td>
<td>190</td>
<td>44.60</td>
<td>334</td>
<td>78.40</td>
</tr>
<tr>
<td>8</td>
<td>87</td>
<td>20.42</td>
<td>421</td>
<td>98.83</td>
</tr>
<tr>
<td>10</td>
<td>2</td>
<td>0.47</td>
<td>423</td>
<td>99.30</td>
</tr>
<tr>
<td>12</td>
<td>3</td>
<td>0.70</td>
<td>426</td>
<td>100.00</td>
</tr>
</tbody>
</table>

Frequency Missing = 2

Display 2.2  PROC FREQ Output Graph
Using the ODS GRAPHICS Statement to Set Graphics Options

You can use the ODS GRAPHICS statement options to control many aspects of your graphics. The settings that you specify remain in effect for all graphics in the SAS session until you change or reset these settings with another ODS GRAPHICS statement.

For example, if you create a graph for a paper or presentation, you can specify the size of the graph as it will appear in the document rather than resize the graph after it has been produced. You can use options in the ODS GRAPHICS statement to control the size of the output image. The following example specifies a width of four inches and no border around the graph.

```sas
ods graphics / width=4in border=off;
title1 "Cholesterol Levels for Age > 60";
proc sgpanel data=sashelp.heart( where=(AgeAtStart > 60)) ;
  panelby sex / novarname;
  loess x=weight y=cholesterol / clm;
run;
title1;
```

**Note:** The height does not need to be specified in this example. The default aspect ratio of the graph is maintained when only the WIDTH= option is specified.
Where to Go from Here

For more information about the ODS GRAPHICS statement, see “ODS GRAPHICS Statement” in SAS 9.4 Output Delivery System: Procedures Guide.

For an introduction to ODS, see Getting Started with the SAS Output Delivery System.
The ODS Graphics procedures produce plots for exploratory data analysis and for customized statistical displays. These procedures can produce a variety of single- and multi-cell plots and charts, including density, dot, needle, series, bar, histograms, box, and others. They can also compute and display loess fits, polynomial fits, penalized B-spline fits, reference lines, bands, and ellipses. Options are available for specifying colors, marker symbols, and other attributes of plot features.

These procedures use the Graph Template Language (GTL) to define the layout and details of a graph. Because SAS provides a default template for every graph produced by the procedures, you do not need to know anything about templates to create graphs.
with these procedures. You can create effective graphs with a minimal amount of learning and effort.

These are the ODS Graphics procedures:

**SGPLOT**
- creates single-cell plots with a variety of plot and chart types and overlays.

**SGPANEL**
- creates classification panels for one or more classification variables. Each graph cell in the panel can contain either a simple plot or multiple, overlaid plots. This procedure can create most of the plots that the SGPLOT procedure creates. For this reason, the two procedures have a similar syntax.

**SGSCATTER**
- creates scatter plots and scatter plot matrices with optional fits and ellipses.

**SGDESIGN**
- creates graphical output based on a graph file that has been created by using the ODS Graphics Designer application.

**SGRENDER**
- produces graphs from graph templates that are written in the GTL. You can also render a graph from a SAS ODS Graphics Editor (SGE) file.

The procedures have two facilities that enable you to modify graph output:

- The SG annotation feature enables you to add shapes, images, and other annotations to graph output.

- SG attribute maps enable you to control the visual attributes that are applied to specific data values in your graphs. For example, if an ODS Graphics procedure creates a graph that plots items sold in different countries, you can specify the display attributes for the sales data of each country. Attribute maps enable you to ensure that particular visual attributes are applied to data values in particular groups.
Basic Structure of a Typical Procedure

In general, an ODS Graphics procedure contains a procedure statement and one or more plot statements. The procedure statement typically specifies a data set. A procedure can have optional statements, such as axis statements and ODS statements. This section shows typical syntax for the SGPLOT, SGPANEL, and SGSCATTER procedures. (The SGDESIGN procedure is discussed in “Using SGD Files with the SGDESIGN Procedure” on page 47. The SGRENDER procedure is shown in Chapter 4, “Using the Graph Template Language ,” on page 29.)

The SGPLOT Procedure

Here is a simple SGPLOT procedure. The procedure requires a procedure statement and at least one plot statement. Both statements accept options that provide more control over the appearance or behavior of the output. In this example, the GROUP= option is used to group the data and make it easier to interpret.

```plaintext
proc sgplot data=sashelp.class;  /* procedure statement */
   scatter x=height y=weight /
      group=sex;                   /* plot statement with a group option */
run;
```
The SGPANEL Procedure

Here is a typical SGPANEL procedure, which creates a panel of graph cells for the values of one or more classification variables. The procedure requires a procedure statement, a classification statement (PANELBY), and at least one plot statement.

```plaintext
proc sgpanel data=sashelp.class;         /* procedure statement */
   panelby sex;                           /* classification statement */
      scatter x=height y=weight;         /* plot statement */
run;
```
The SGSCATTER Procedure

Here is a typical SGSCATTER procedure, which creates a paneled graph of scatter plots for multiple combinations of variables, depending on the layout statement that you use. The procedure requires a procedure statement and one of these three statements:

- **PLOT** creates a paneled graph of scatter plots where each graph cell has its own independent set of axes.
- **COMPARE** creates a shared axis panel, also called an MxN matrix.
- **MATRIX** creates a scatter plot matrix.

This example plots the values of two combinations of Y and X variables and produces a separate cell for each combination. That is, each Y*X pair is plotted on a separate set of axes.

```sas
proc sgscatter data=sashelp.cars; /* procedure statement */
  plot mpg_highway*weight msrp*horsepower; /* plot statement */
run;
```
Examples of Using the Procedures

SGPLOT Examples

Example Fit Plot

If you calculate a custom fit for your data, you might use a series plot to render the fit. The following PROC SGPLOT example combines a scatter and a series plot, and uses the SASHELP.CLASSFIT data set.
Display 3.4  Example Output for the FIT Plot

```
proc sgplot data=sashelp.classfit noautolegend;
  scatter x=height y=weight;
  series x=height y=predict;
run;
```

The NOAUTOLEGEND option in the SGPLOT statement disables the legend that is generated automatically for the graph. Without this statement, the graph would have an unnecessary legend, as seen below.
Example Bar Chart

The following horizontal bar chart shows cumulative product orders for a clothing store.
In the SGPLOT procedure, the HBAR statement specifies the plot to be displayed, which in this case is a horizontal bar chart. In addition, the statement specifies the response variable (the number of items) to be displayed on the horizontal axis. The response variable is optional. If you do not provide a response variable, then the chart shows the frequency count on the horizontal axis. The statement also specifies the statistic for the horizontal axis. The STAT= option enables you to specify the sum, the mean, or the frequency for the response variable.

```sas
proc sgplot data=sashelp.orsales subpixel;
  format Quantity comma7.;
  hbar Product_Category / response=Quantity stat=sum;
run;
```

Note also that the SGPLOT procedure supports the FORMAT statement, along with several other global SAS statements.

**SGPANEL Example**

The following example shows a panel of regression curves.
The COLUMNS= option in the PANELBY statement specifies that the panel has three columns of graph cells. The example uses the REG statement to create the regression curve. The CLI option creates individual predicted value confidence limits. The CLM option creates mean value confidence limits.

```sas
proc sgpanel data=sashelp.iris;
  title "Scatter plot for Fisher iris data";
  panelby species / columns=3;
  reg x=sepallength y=sepalwidth / cli clm;
run;

Where to Go from Here

For more information and to learn about the syntax for the ODS Graphics procedures, see SAS ODS Graphics: Procedures Guide.
For information about individual procedures in that book, see the following chapters:

- Chapter 6, “SGPANEL Procedure” in *SAS ODS Graphics: Procedures Guide*
- Chapter 9, “SGSCATTER Procedure” in *SAS ODS Graphics: Procedures Guide*

The recommended reading list from SAS Press includes the following titles:

- *Statistical Graphics Procedures by Example: Effective Graphs Using SAS*
- *Statistical Graphics in SAS: An Introduction to the Graph Template Language and the Statistical Graphics Procedures*

For a complete list of SAS publications, go to [support.sas.com/bookstore](http://support.sas.com/bookstore). If you have questions, please send e-mail to sasbook@sas.com.
About the Graph Template Language

For situations that require highly customized displays that are not available with the ODS Graphics procedures, you can write your own graph templates. You write templates using the Graph Template Language (GTL). A graph template is a program that specifies the layout and details of a graph. You can then apply the template to your data and render graphs using the SGRENDER procedure.

The GTL is a powerful language that includes statements for specifying the following graphics items:

- plot layouts, such as lattices and overlays
- plot types, such as scatter plots and histograms
- text elements, such as titles, footnotes, and insets

The GTL also provides support for built-in computations (such as histogram binning and loess smoothing) and the evaluation of expressions. The GTL supports dynamic
variable assignment, conditional logic, and some functions. Options are available for specifying colors, marker symbols, and other attributes of plot features.

In addition, the GTL has two features that enable you to customize a graph:

- The GTL supports data-set-driven annotations, which enable you to add text, lines, shapes, and images to a graph from annotation instructions that are stored in a data set.
  
  Draw statements also enable you to draw visual elements anywhere within the graph.
- Discrete and range attribute maps enable you to map visual attributes to input data values.

Statistical procedures use the GTL to generate graphs automatically in the process of an analysis. SAS provides a default template for every graph produced by statistical procedures. SAS analytical users can use the GTL to create sophisticated custom graphs using terminology familiar to statisticians and analysts. However, with its robust capabilities and flexibility, the GTL requires an investment of time in order to learn how to best use it.

Here are two common uses for the GTL:

- create highly customized displays by writing your own graph templates and applying them directly to data with the SGRENDER procedure.
- modify the default SAS templates to make changes that are permanently in effect each time a particular statistical procedure is executed.

The default graph templates provided by SAS are usually long and complex because they specify a complete description of how the graph is to be produced. You can edit graph templates to make simple modifications such as changing titles and axis labels or adding footnotes. Advanced users can make more substantive changes. This information is covered in Chapter 30, “Modifying Predefined Templates,” in \textit{SAS Graph Template Language: User's Guide}. 

\textit{Page 30 Chapter 4 / Using the Graph Template Language}
Basic Structure of a Simple Single-Cell Graph Template

Graphs are constructed from two underlying components: a data object supplied by a procedure at run time and a compiled template that is designed to work with this data object. Together, the data object and the template form an output object that ODS displays in one or more output destinations.

All graph GTL programs use the TEMPLATE procedure to define a STATGRAPH template. Here is a short GTL program.

```gtl
proc template;                             /* procedure statement */
define statgraph customGraphs.scatter;     /* graph definition statement */
begingraph;                              /* container statement */
    layout overlay;                        /* layout block statement */
        scatterplot X=height Y=weight;     /* plot statement */
    endlayout;                             /* close the layout block */
endgraph;                                /* close the container block */
end;                                       /* close the graph definition */
run;
```

Here are the noteworthy features of this program:

- The DEFINE STATGRAPH statement is required to open a definition block that defines and names the graph template. The END statement closes the template definition.

- A BEGINGRAPH statement block is required to define the outermost container for the graph. It must contain at least one LAYOUT block. The ENDDGRAPH statement closes the container block.

- The LAYOUT statement block is required for specifying the layout structure of the graph. To generate a plot, the layout block must contain at least one plot statement. The ENDLAYOUT statement closes the layout block.

The TEMPLATE procedure must be run to compile the template and save it in the template store.
The template can be executed using the SGRENDER procedure. The procedure uses
the DATA= option to specify the data source and the TEMPLATE= option to specify the
template to use for rendering the graph.

Here is an example SGRENDER procedure:

```sas
proc sgrender data= sashelp.class template= customGraphs.scatter;
  run;
```

**Note:** In this example, the data set must contain the variables that are specified in the
plot statement of the template.

**Display 4.1  Scatter Plot Output for the SGRENDER Procedure**

---

**Example of Creating a Multi-Cell Graph Template**

This example creates a two-celled graph that shows linear and loess regression fits.
The template uses a LATTICE layout with two columns.
Here is the code for the output display.

proc template;
define statgraph mygraph;
dynamic XVAR YVAR;
begin graph / designwidth=480px designheight=320px;
layout lattice / columns=2;
layout overlayequated / equatetype=square;
entry "Linear Regression Fit" /
   valign=top textattrs=(weight=bold);
scatterplot x=XVAR y=YVAR / markerattrs=(color=red)
   datatransparency=.7;
regressionplot x=XVAR y=YVAR;
endlayout;
layout overlayequated / equatetype=square;
entry "Loess Fit" /
   valign=top textattrs=(weight=bold);
scatterplot x=XVAR y=YVAR / markerattrs=(color=red)
   datatransparency=.7;
loessplot x=XVAR y=YVAR;
endlayout;
endgraph;
end;
run;

proc sgrender data=sashelp.iris template=mygraph;
  dynamic xvar="SepalLength" yvar="SepalWidth";
run;

Here is a brief description of the code.

- The DYNAMIC statement creates dynamic variables named XVAR and YVAR. This feature enables you to specify different names for the X and Y data values when you render the graph.
  
  ```
  dynamic XVAR YVAR;
  ```

- The DESIGNWIDTH= and DESIGNHEIGHT= options in the BEGINGRAPH statement control the graph size.

  ```
  begingraph / designwidth=480px designheight=320px;
  ```

- The LAYOUT statement begins the outer LAYOUT block and specifies a lattice with two columns.

  ```
  layout lattice / columns=2;
  ```

- The outer LAYOUT block contains two nested LAYOUT blocks, one for each overlay cell in the lattice. Each cell contains a scatter plot and a fit plot. The main distinction between the two cells is the type of fit plot. The first cell contains a regression plot and the second cell contains a loess plot.

  An ENTRY statement specifies the text for each cell title. The title for the first cell is "Linear Regression Fit." In the second LAYOUT block, the title is "Loess Fit."

  The MARKERATTRS= option in the SCATTERPLOT statement specifies a red color for the scatter plot markers. In addition, 70% transparency is assigned to the scatter plot to increase the visibility of the fit plot.

  ```
  layout overlayequated / equatetype=square;
  entry "Linear Regression Fit" /
    valign=top textattrs=(weight=bold);
  scatterplot x=XVAR y=YVAR / markerattrs=(color=red) datatransparency=.7;
  regressionplot x=XVAR y=YVAR;
  endlayout;

  layout overlayequated / equatetype=square;
  entry "Loess Fit" /
    valign=top textattrs=(weight=bold);
  ```
The SGRENDER procedure specifies the library and data set to use for the graph. The DYNAMIC statement specifies which columns to use for the X and Y variables of the graph, respectively.

```sas
scatterplot x=XVAR y=YVAR / markerattrs=(color=red) datatransparency=.7;
loessplot x=XVAR y=YVAR;
endlayout;
```

- The SGRENDER procedure specifies the library and data set to use for the graph. The DYNAMIC statement specifies which columns to use for the X and Y variables of the graph, respectively.

```sas
proc sgrender data=sashelp.iris template=mygraph;
dynamic xvar="SepalLength" yvar="SepalWidth";
run;
```

---

**Where to Go from Here**

For more information about the GTL and the SGRENDER procedure, see these documents:

- Chapter 3, “Getting Started with the Graph Template Language,” in *SAS Graph Template Language: User's Guide*
- *SAS Graph Template Language: User's Guide*
- *SAS Graph Template Language: Reference*
- Chapter 8, “SGRENDER Procedure” in *SAS ODS Graphics: Procedures Guide*

The recommended reading list from SAS Press includes the following title: *Statistical Graphics in SAS: An Introduction to the Graph Template Language and the Statistical Graphics Procedures*

For a complete list of SAS publications, go to [support.sas.com/bookstore](https://support.sas.com/bookstore). If you have questions, please send e-mail to [sasbook@sas.com](mailto:sasbook@sas.com).
Using the ODS Graphics Designer

About the ODS Graphics Designer ................................................................. 37
About the Designer’s Graphical Interface ..................................................... 38
Example of Using the Designer ................................................................. 40
   About This Example .............................................................................. 40
   Step One: Create the First Cell and Assign Data .................................... 41
   Step Two: Add a Second Cell, Adjust Cell Height, and Use a Common Axis .............................................................................. 45
   Step Three: Customize the Title and Footnote .................................... 46
   Step Four: Save the Graph ...................................................................... 46
Using SGD Files with the SGDESIGN Procedure ........................................... 47
Using SGD Files with the Graph Template Language ...................................... 49
Where to Go from Here .............................................................................. 49

About the ODS Graphics Designer

The ODS Graphics Designer is an interactive graphical application that you can use to create and design custom graphs. The designer creates graphs that are based on the Graph Template Language (GTL). Using point-and-click interaction, you can create simple or complex graphical views of data for analysis without having to know the details of templates and the GTL.
The ODS Graphics Designer enables you to design sophisticated graphs by using a wide array of plot types. You can design multi-cell graphs, classification panels, and scatter plot matrices. Your graphs can have titles, footnotes, legends, and other graphics elements. You can save the results as an image for inclusion in a report or as an ODS Graphics Designer file (SGD) that you can later edit.

About the Designer’s Graphical Interface

The ODS Graphics Designer user interface consists of several main components, as shown in the following display:

*Figure 5.1 ODS Graphics Designer Graphical Interface*

1. Main menu bar
contains menus that you can use to perform these tasks:

- open, save, print, and edit SGD files
- open the Graph Gallery or view the code for a graph
- insert titles, footnotes, and legends
- add rows and columns to the graph
- apply a different style to a graph, customize styles, and define new styles
- set properties for graphs, plots, axes, legends, and other graph elements
- set display and usage preferences for the designer

**Note:** In addition to the main menu, the designer has pop-up menus that you can open by right-clicking various parts of a graph.

2 Elements pane

contains plots, lines, and insets that you can insert into a graph. To insert an element, click and drag the element to the graph. The elements on this pane are available only when a graph is open.

3 Toolbar

contains icons that you can click to perform common tasks such as saving files and inserting titles or footnotes. The icons on this toolbar are available only when a graph is open.

4 Work area

contains one or more graphs that you create and design in the designer. In addition to the graphs, you can display the Graph Gallery, a collection of predefined graphs.
Example of Using the Designer

About This Example

In this example, you create a paneled graph with two cells, each containing different types of plots. The graph shows the horsepower distribution for automobiles. The example uses the SASHELP.CARS data.

Display 5.1 Two-Cell Graph Example

There are several ways to create and customize this graph. The following steps show one way to create the graph.
Step One: Create the First Cell and Assign Data

1. Start the ODS Graphics Designer. In the SAS windowing environment, select **Tools** ▶ **ODS Graphics Designer**. The designer opens and displays the Graph Gallery.

2. On the **Basic** tab of the Graph Gallery, double-click the **Histogram** icon.

The Assign Data dialog box appears. When you create a graph from the Graph Gallery, placeholder data is assigned to the graph’s plot. The Assign Data dialog box enables you to easily change the data that is associated with the plot.

3. In the Assign Data dialog box, complete these steps:
   - Select **SASHELP** from the **Library** list box, if it’s not already selected.
   - Select **CARS** from the **Data Set** list box.
   - Select **HORSEPOWER** from the **Analysis** list box.
4 Click **OK**.

5 From the **Plot Layers** panel of the **Elements** pane, click and drag the **Normal** icon to the graph.
The Assign Data dialog box appears.

6 In the Assign Data dialog box, do not change the default selections.
Click **OK**. A normal curve is added to your graph.

Here are the results of your graph so far.
Step Two: Add a Second Cell, Adjust Cell Height, and Use a Common Axis

1. Right-click anywhere within the plot area and select **Add a Row**. A new row cell is added below the histogram.

2. From the **Plot Layers** panel, click and drag the **Box(H)** icon to the new cell. The Assign Data dialog box appears.

3. In the Assign Data dialog box, complete these steps:
   - If they are not already selected, select **SASHELP** from the **Library** list box and **CARS** from the **Data Set** list box.
   - Select **HORSEPOWER** from the **Analysis** list box.

4. Click **OK**.

5. Specify that both cells share a common X axis.
   - Right-click the bottom axis label and select **Common Column Axis**.
Here are the results of your changes.

### Step Three: Customize the Title and Footnote

1. Double-click the placeholder title. The placeholder text is highlighted:

   Type in your title...

2. In the text box, enter **Distribution of Horsepower**.

3. In the bottom left corner of the graph, double-click the placeholder footnote. The placeholder text is highlighted.

4. In the text box, enter **Data: 2012**.

### Step Four: Save the Graph

Save this graph so that you can later return to it. The next section references this example.
1. Select File ➤ Save As.

2. Save the file to the desired location. Specify the name that you want for the file. For example, you might enter horsepower. The file type SGD Files (*.sgd) is selected by default.

3. Click Save.

---

Using SGD Files with the SGDESIGN Procedure

You do not need to know programming details to use the designer. However, with some knowledge of ODS Graphics procedure syntax, you can use the SGDESIGN procedure to produce graphical output from an SGD file. The procedure enables you to run one or more graphs in batch mode and render the graphs to an ODS destination using any of the supported ODS options.

Here is the basic syntax for the procedure:

```
PROC SGDESIGN SGD= "SGD-file-specification" < option(s)>;
   DYNAMIC dynamic-var–1="assigned-value–1"
   <dynamic-var–n="assigned-value–n">;
```

If the SGD file has been defined with shared variables, then you can substitute a different value for a variable by using the DYNAMIC statement. For more information about creating SGD files with shared variables, see Chapter 20, “Using Shared Variables in Graphs,” in SAS ODS Graphics Designer: User's Guide.

The following example uses the SGD file that was created in the previous example. (See “Example of Using the Designer” on page 40.)

```
proc sgdesign sgd="C:\SGDFiles\horsepower.sgd";
run;
```

Note the following about the procedure:

- In the SGD= option of the procedure statement, substitute the path to your SGD file.
The example does not need to specify the SASHELP.CARS data set. By default, the SGDESIGN procedure uses the data set that is defined in the SGD file.

Display 5.2  PROC SGDESIGN Output for the Horsepower Distribution Graph

Data: 2004

Note: Graphs that are output to the default ODS destination in SAS might look different from those that were created using the designer's default style. In SAS, HTML is the default ODS destination, and HTMLBlue is the default style. The default style for the ODS Graphics Designer is Listing (although you can change that in the Preferences). See “Changing the Style That Is Applied to ODS Graphs” on page 66 for details about specifying a style for a graph either in the SAS program or in the designer.

For another example that uses the SGDESIGN procedure, see “Example of Producing an Annotated ODS Graphics Designer Graph for Publication” on page 79.
Using SGD Files with the Graph Template Language

You do not need to know about the Graph Template Language (GTL) in order to use the designer. However, if you do know details of the GTL, you can use the code that is generated for an SGD file to design custom templates.

Here are the main steps:

1. In ODS Graphics Designer, select the graph to make it active. Then select View ➤ Code. A window appears and displays the code for the graph.

2. To copy the code, select the portion of the code that you want, and then select Edit ➤ Copy.

   **TIP** To select the entire code, select Edit ➤ Select All.

You can now paste the code into SAS and customize the graph template using the GTL.

3. To save the code as a SAS program, select File ➤ Save As. Then specify the location and filename for the code.

4. Select View ➤ Code again to close the code window, or click ✕ in the window.

Where to Go from Here


For more information about the SGDESIGN procedure, see Chapter 5, “SGDESIGN Procedure” in SAS ODS Graphics: Procedures Guide.
About the ODS Graphics Editor

If you want to make immediate changes to a particular graph, such as change the title or add a text inset or an image, you can use the ODS Graphics Editor. The editor is an interactive graphical application used to edit and annotate graphs that are created by any SAS procedure that supports ODS Graphics. The graphic must be an ODS Graphics Editor file (SGE), which is created in SAS by using the SGE = ON option in the ODS destination statement.

You can customize titles, footnotes, and labels. You can annotate data points, add text, and change graph element properties such as fonts, colors, markers, and line styles.
After you have modified your graph, you can save it in one of several formats or as an SGE file that you can later reopen and edit.

You can also use the SGRENDER procedure (in the ODS Graphics procedures) to produce graphical output from the SGE file. The procedure enables you to run one or more graphs in batch mode and render the graphs to any ODS destination using any of the supported ODS options.

You can launch the editor from a SAS session. You can also download a stand-alone version of the ODS Graphics Editor that runs independently of SAS. When you edit a graph from the Results window in SAS, changes that you make do not affect the original graph in the Results Viewer window.

See Also


About the Editor’s Graphical Interface

The ODS Graphics Editor user interface consists of several main components, as shown in the following display:
1 Main menu bar

contains menus that you can use to perform these tasks:

- open, save, and print SGE files
- copy and paste items, and change the view (zoom and toolbars)
- insert titles, footnotes, and annotations
- arrange, group, and order annotations
- move titles and footnotes up or down
- apply a different style to a graph, and set graph properties

**Note:** In addition to the main menu, the editor has context menus that you can access by right-clicking various parts of a graph.
2 Graph toolbar

provides an easy way to select graph objects or to insert items into a graph. For more information, see “About the Graph Toolbar” in Chapter 2 of SAS ODS Graphics Editor: User's Guide.

3 Work area

contains the graph that you want to edit or annotate.

4 Formatting toolbar

provides formatting tools that enable you to change the font, size, color, and other attributes of text elements and annotations.

Note: This toolbar is active only if you have selected text or annotation objects in your graph. The text element that you select might be a title, footnote, an axis label, or a legend.

See Also


Example of Using the Editor

About This Example

This example shows how you might edit and annotate a graph that was created with the SGPLOT procedure. These tasks use some of the toolbar functions previously described. At the completion of the tasks in this example, the resulting graph is displayed:
Step One: Create and Open an Editable Graph

1. In SAS, execute the following code. The SGE = ON option in the ODS destination statement creates an editable graph.

```sas
ods html sge = on; /* enable editable graph creation */
proc sgplot data=sashelp.class; /* procedure statement */
   scatter x=height y=weight /* plot statement with a group option*/
      / group=sex;
run;
ods html sge = off; /* disable editable graph creation */
```

The SAS Results Viewer displays a scatter plot, shown here.
Your program also created an ODS Graphics Editor (SGE) file that you can edit.

2 Locate this SGE file by selecting **View ▶ Results** from the main menu.

3 Click the expansion icon in the SAS Results window to show the SGE file just created with the SGPLOT procedure.

4 Double-click the SGE file, which is identified by the icon.

The ODS Graphics Editor opens and displays the graph for editing. You are now ready to edit the graph using the various interactive tools built into the editor.

**See Also**
- For more information about the SGPLOT procedure, see Chapter 3, “Using the ODS Graphics Procedures,” on page 17.
Step Two: Add and Format a Title

1 To add a title, in the ODS Graphics Editor select **Insert ▶ Title**. Alternatively, click the **Title** icon in the **Graph** toolbar.

   The **Insert Title** text box is displayed at the top of the graph.

2 Enter the text *Study of Weight and Height* in the text box.

3 Format the title that you just created.

   a In the **Formatting** toolbar at the top of the window, select the **Arial Rounded MT Bold** font from the font drop-down list.

   **Note:** If the **Formatting** toolbar is dimmed, select the title to make the toolbar available.

   b Select the text. Click **B** to undo the text boldface, and **I** to italicize the text.

   c Press Enter to preserve your formatting selections.

Step Three: Modify the Axis Labels

1 Double-click the **Height** X-axis label.

2 Move your cursor to the end of the text and type *(IN)*.

3 Press Enter to preserve the new text.

4 Double-click the **Weight** Y-axis label.

5 Move your cursor to the end of the text and type *(LBS)*.

6 Press Enter to preserve the new text.
Step Four: Add and Rotate a Text Annotation

1 Click the \texttt{ } in the \texttt{Graph} toolbar.

2 Click the area of the graph where you want to position your text (for example the lower right quadrant of the graph). A text box appears.

3 Enter \textit{My annotation text} in the box. The width of the text box determines the maximum width of the text line. If a line exceeds the width of the text box, then the text wraps to the next line. If needed, drag one of the circles on the border of the text box to the right or left to widen the text box.

4 To rotate the text annotation, follow these steps:
   a Position your cursor in the circle above the text box. The cursor changes to a rotated arrow. 
   b Click and drag the rotated arrow to the left or right. You can rotate the entire box anywhere within a 360 degree radius.

5 Click anywhere in the graph outside the text box to preserve the text.

Step Five: Change the Style and Print the Graph

By default, graph SGE files use the active ODS destination style that is specified in the SAS program. If no style is specified, then the default style is used for the ODS destination.

1 Change the graph’s style in order to make the graph more suitable for printing with a black-and-white printer.
Select **Format ➤ Style ➤ Journal** from the main menu.

**Note:** When you apply the Journal style, all of the graphics elements change to shades of gray. However, if you had specified a different color for an element, the color would not change. When you explicitly set a color or other attribute, the specified attribute overrides the style setting.

2 Print your edited and annotated SGE file.
   
   a Select **File ➤ Print** from the main menu bar.
   
   b Select print options from the Print window.
   
   c Click **OK**.

   **Note:** You can also print PNG files from the ODS Graphics Editor. Or you can include a PNG file in a PDF document and then print the PDF document.

**See Also**
See “Changing the Style That Is Applied to ODS Graphs” on page 66 for details about specifying a style for a graph either in the SAS program or in the editor.

**Step Six: Save the Graph**
Save the graph as an SGE file for further editing.

1 Select **File ➤ Save As** from the main menu.

2 Select the directory where you want the graph to be saved. The default location is the current directory for the SAS program that generated the SGE file.

3 Select **SGE** for the type of file to save. If you save the file in PNG format, then the graph is saved as a flat image. The graph in this format cannot be edited, though it can be annotated.
Where to Go from Here

This chapter has given you a general overview of the ODS Graphics Editor, and walked you through an example of creating and editing a SAS SGE file. You can obtain more information in the following places:

- For an example that shows how to edit and annotate a graph that was created in the ODS Graphics Designer, see “Example of Producing an Annotated ODS Graphics Designer Graph for Publication” on page 79.
- For more examples and to learn all the details about using the ODS Graphics Editor, see SAS ODS Graphics Editor: User’s Guide.
- For more information about editable graphs in particular, see “Creating Editable Graphics” in Chapter 2 of SAS ODS Graphics Editor: User’s Guide.
- For more information about annotating graphs, see Chapter 9, “Annotation Overview,” in SAS ODS Graphics Editor: User’s Guide.
- For more information about the ODS Graphics procedures, see SAS ODS Graphics: Procedures Guide.
Changing the Appearance of Graphs

Understanding ODS Styles ................................................................. 61
About Styles and Style Elements ......................................................... 61
About the Default Styles ................................................................. 63

Recommended Styles for Statistical Work ........................................... 64

Working with Styles ................................................................. 66
Changing the Style That Is Applied to ODS Graphs ................................. 66
Editing a Style ................................................................................. 68
Changing the Appearance of Individual Graphics
Elements in a Graph ........................................................................... 69

Using Attribute Mapping .................................................................. 72

Adding Annotations to Graphs .............................................................. 72

Understanding ODS Styles

About Styles and Style Elements

ODS graphs derive their general default appearance from the current ODS style. An ODS style is a collection of style elements that provides specific visual attributes for your SAS output.

Style elements are used to associate groups of appearance attributes (fonts, fill colors, line styles, marker symbols, and so on) with graphical elements (text, bars, lines,
markers, and so on). Each graphical element of a plot derives its visual attributes from a specific style element in the active style. For example, a density plot uses the GraphFit style element for its visual attributes. The GraphFit style element has attributes for color, line style, line thickness, and so on. The appearance of these attributes varies depending on the graph style that is applied to the graph.

Note: For examples of graph output with different styles applied, see “Recommended Styles for Statistical Work” on page 64.

The ODS system contains many style elements. The following table shows information for just two of the style elements:

<table>
<thead>
<tr>
<th>Style Element</th>
<th>Portion of Graph Affected</th>
<th>Recognized Attributes</th>
</tr>
</thead>
<tbody>
<tr>
<td>GraphFit</td>
<td>Primary fit lines such as a normal density curve</td>
<td>ContrastColor, Color, MarkerSize, MarkerSymbol, LineStyle, LineThickness</td>
</tr>
</tbody>
</table>
The easiest way to change a graph’s appearance is to change the style that the graph uses. For more information, see “Changing the Style That Is Applied to ODS Graphs” on page 66.

See Also

About the Default Styles

Every ODS output destination has an associated default style. These default styles are different for each destination. Therefore, your output might look different depending on which destination you use. For example, the default style for the PRINTER destination is “Printer” while the default style for the RTF destination is “RTF.”

Note: The default style for the HTML and HTML5 destinations is HTMLBlue.

For a table that lists the default styles for ODS destinations, see “Working with Styles ” in Chapter 14 of SAS 9.4 Output Delivery System: Procedures Guide.

You can display a list of the available styles by submitting the following PROC TEMPLATE statements in SAS:

```sas
proc template;
   list styles;
run;
```
Recommended Styles for Statistical Work

SAS styles have been designed to address the needs of different situations while ensuring the principles of effective graphics. The following table contains a subset of the styles shipped with SAS that are particularly suitable for statistical graphics.

Table 7.1 Recommended ODS Styles

<table>
<thead>
<tr>
<th>Style</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>LISTING</td>
<td><img src="image" alt="Listing Style" /></td>
</tr>
<tr>
<td>- white background</td>
<td></td>
</tr>
<tr>
<td>- white wall</td>
<td></td>
</tr>
<tr>
<td>- sans-serif fonts</td>
<td></td>
</tr>
<tr>
<td>- color used for lines, markers, and filled areas</td>
<td></td>
</tr>
<tr>
<td>- other colors the same as DEFAULT style</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>DEFAULT</th>
<th><img src="image" alt="Default Style" /></th>
</tr>
</thead>
<tbody>
<tr>
<td>- gray background</td>
<td></td>
</tr>
<tr>
<td>- white wall</td>
<td></td>
</tr>
<tr>
<td>- sans-serif fonts</td>
<td></td>
</tr>
<tr>
<td>Style</td>
<td>Example</td>
</tr>
<tr>
<td>---------------</td>
<td>---------</td>
</tr>
<tr>
<td><strong>STATISTICAL</strong></td>
<td><img src="image" alt="Statistical Style" /></td>
</tr>
<tr>
<td>- white background</td>
<td><img src="image" alt="Statistical Style" /></td>
</tr>
<tr>
<td>- white wall</td>
<td><img src="image" alt="Statistical Style" /></td>
</tr>
<tr>
<td>- sans-serif fonts</td>
<td><img src="image" alt="Statistical Style" /></td>
</tr>
<tr>
<td>- contrasting color scheme of blues, reds, greens for markers, lines, and filled areas</td>
<td><img src="image" alt="Statistical Style" /></td>
</tr>
<tr>
<td><strong>HTMLBLUE</strong></td>
<td><img src="image" alt="HTMLBlue Style" /></td>
</tr>
<tr>
<td>- white background</td>
<td><img src="image" alt="HTMLBlue Style" /></td>
</tr>
<tr>
<td>- white wall</td>
<td><img src="image" alt="HTMLBlue Style" /></td>
</tr>
<tr>
<td>- sans-serif fonts</td>
<td><img src="image" alt="HTMLBlue Style" /></td>
</tr>
<tr>
<td>- table colors match the graph colors</td>
<td><img src="image" alt="HTMLBlue Style" /></td>
</tr>
<tr>
<td>- group distinctions based on color rather than marker or line styles</td>
<td><img src="image" alt="HTMLBlue Style" /></td>
</tr>
<tr>
<td>- a lighter color scheme for HTML content</td>
<td><img src="image" alt="HTMLBlue Style" /></td>
</tr>
<tr>
<td><strong>ANALYSIS</strong></td>
<td><img src="image" alt="Analysis Style" /></td>
</tr>
<tr>
<td>- light tan background</td>
<td><img src="image" alt="Analysis Style" /></td>
</tr>
<tr>
<td>- white wall</td>
<td><img src="image" alt="Analysis Style" /></td>
</tr>
<tr>
<td>- sans-serif fonts</td>
<td><img src="image" alt="Analysis Style" /></td>
</tr>
<tr>
<td>- muted color scheme of tans, greens, yellows, oranges and browns for lines, markers, and filled areas</td>
<td><img src="image" alt="Analysis Style" /></td>
</tr>
</tbody>
</table>
### Working with Styles

#### Changing the Style That Is Applied to ODS Graphs

**Changing the Style in Your Program**

When you use the ODS Graphics procedures or the Graph Template Language, you can easily change a graph's appearance by changing the style for an ODS destination. Changing the current style requires only the use of the `STYLE=` option in an ODS destination statement. The ODS destination statement is global and can be used...
anywhere in your SAS program. The statement remains in effect until you explicitly change it or start a new SAS session.

Note: The style that a destination uses is applied to tabular output as well as graphical output.

In the following example, the ODS destination statement specifies HTML as the destination and HTMLBlue as the style.

```sas
ods html style=htmlblue;
title "Model Height By Weight";
proc sgplot data=sashelp.class;
   reg x=height y=weight / clm cli;
run;
title;
```

Here is the output for the example:

**Display 7.1**  HTML Output Using the HTMLBlue Style

Changing the Style in the ODS Graphics Designer or the ODS Graphics Editor

In the ODS Graphics Designer and the ODS Graphics Editor, you can use the menus to change the style for a particular graph.
The default style for graphs created in the ODS Graphics Designer is Listing. You can change this default in the designer’s preferences.

By default, ODS Graphics Editor files use the active ODS destination style that is specified in the SAS program.

Editing a Style

ODS styles are produced from compiled STYLE templates written in PROC TEMPLATE style syntax.

You can use the following software to edit style templates:

- TEMPLATE procedure
  
  You can modify the ODS style template for a style to make persistent changes to that style. Using the TEMPLATE procedure, you can modify the default SAS style templates as well as custom styles that have been created at your site.
  
  For more information about the TEMPLATE procedure, see SAS 9.4 Output Delivery System: Procedures Guide.

- ODS Graphics Designer
  
  The ODS Graphics Designer has an interactive graphical interface for designing and modifying custom styles without the need to understand PROC TEMPLATE syntax. This interface, called the Graph Style Editor, makes it easy to design styles that you can apply to your ODS Graphics Designer graphs.
  
  In the Graph Style Editor, you cannot change the predefined SAS ODS styles. However, you can edit a SAS style, customize style elements and attributes, and save your changes using a new style name. You can then apply the custom style to your ODS Graphics Designer graphs as appropriate. You can also export these custom styles for use with graphs that are generated outside of the designer. For complete instructions about creating custom styles, see Chapter 14, “Customizing Graph Styles,” in SAS ODS Graphics Designer: User's Guide.
Changing the Appearance of Individual Graphics Elements in a Graph

Overview of Changing Graphics Elements

ODS Graphics software enables you to control the appearance of different parts of a graph without changing the overall style. For example, you can change the visual attributes of lines, bars, markers, text, and so on. These changes are limited to the current graph.

In general, there are two ways to change the appearance of a graphics element:

- You can specify a different style element for the graphics element. For example, a density curve uses the default GraphFit style element for its visual attributes. You might instead specify the GraphFit2 style element.

- You can change one or more attributes of a style element. For example, you might explicitly change the color of a density curve to red.

It is recommended that you specify style elements rather than explicit attributes whenever possible. The attributes of a style element are chosen to provide consistency and appropriate emphasis based on display principles for statistical graphics. When you specify a particular attribute, you override the style element. You might create a graph that is inconsistent with the style. If you later change the style for the graph, your override remains in effect and could clash with the new style.

Note: For some charts, you also have the option to specify one of several skins for fills. This option provides an easy way to enhance the appearance of the fills. The option is supported in the Graph Template Language, in the ODS Graphics procedures, and in the ODS Graphics Designer.

The following sections describe the options for changing the appearance of graphics elements in the ODS Graphics software.

Changing Graphics Elements in Your Program

The ODS Graphics software gives you the following options for changing the appearance of graphics elements in your program:
ODS Graphics procedures

Many ODS Graphics procedure statements have options and suboptions that control the appearance of different parts of a graph. Typically, you can specify a style element, a hardcoded attribute value, or a combination of both. The following example specifies a style element for a density curve in a graph.

```sas
proc sgplot data=sashelp.class noautolegend;
density height / lineattrs=graphfit2;
run;
```

The following displays show the default and the modified appearance when the HTMLBlue style is used.

<table>
<thead>
<tr>
<th>Default Line Attributes</th>
<th>GRAPHFIT2 Line Attributes</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Default Line Attributes" /></td>
<td><img src="image2" alt="GRAPHFIT2 Line Attributes" /></td>
</tr>
</tbody>
</table>

The following example specifies a style element and a hardcoded attribute value. This example changes the line to a dash-dash-dot pattern (---).

```sas
density height / lineattrs=graphfit2 (pattern=dashdashdot);
```

Graph Template Language

The Graph Template Language uses similar syntax to specify a style element, a hardcoded attribute value, or a combination of both. The following example specifies the marker color for a scatter plot.

```sas
scatterplot x=XVAR y=YVAR / markerattrs=(color=red);
```

This example was taken from “Example of Creating a Multi-Cell Graph Template” on page 32.
Changing Graphics Elements in ODS Graphics Designer and ODS Graphics Editor

ODS Graphics Designer gives you numerous options for changing the appearance of graphics elements in an SGD file.

For example, to change the properties of a graph title, right-click the title and select Title Properties from the pop-up menu. The following display shows the properties for a graph title.

*Display 7.2  GraphTitleText Style Element in the Text Properties Dialog Box*

You can specify the style element, and you can change specific element attributes (color, font size, and so on) of the title.

The ODS Graphics Editor similarly enables you to change the visual attributes of a graphics element. However, in the editor, you cannot specify a style element. You can specify only the attributes of the graphics element.
Using Attribute Mapping

The attribute mapping feature enables you to control the visual attributes that are applied to specific data values or range of values in your graphs. For example, if a procedure creates a graph that plots items sold in different countries, you can specify the display attributes for the sales data of each country.

Attribute mapping is available with the ODS Graphics procedures and the Graph Template Language.

When using the ODS Graphics procedures, attribute maps apply only to group data. Attribute maps enable you to ensure that particular visual attributes are applied to data values in particular groups.

The Graph Template Language supports both discrete and range attribute maps.

- Discrete attribute maps enable you to map discrete values to specific visual attributes (for example, color). This feature could be used to represent a data value with a specific visual attribute, regardless of the order of the values in the data. For example, when using gender as a grouping category for plots, you could set an attribute map for marker symbols.

- Range attribute maps enable you to control color assignment based on data value ranges, regardless of the current data range for a plot. This feature can be used to represent values that are not actually in the data. For example, for temperature data, you could set blue for 0 and red for 100, even if the values 0 and 100 are not in the data.

Adding Annotations to Graphs

Another way to modify the appearance of a graph is to add annotations to data points or other elements of a graph. Annotations include lines and arrows, images, text, round and rectangular shapes, and so on.
You can annotate a graph using the following software:

- ODS Graphics Editor, which provides a point-and-click method for easily adding annotations to a graph.
- ODS Graphics procedures, which provide an annotation facility that enables you to add shapes, images, and other annotations to graph output.
- Graph Template Language, which provides two types of annotation: code-driven (DRAW* statements) and data-driven (same annotation facility as ODS Graphics procedures).
Scenarios for ODS Graphics Software Interactions

The ODS Graphics procedures and applications all use the Graph Template Language (GTL) for their graph definitions. The ODS Graphics software components complement each other, and can often be used together.

Here are some tasks that you can perform using different combinations of ODS Graphics software.

- Produce a graph as part of your statistical analysis and specify the style and size of the graph.

Here are the high-level steps:
1. Enable ODS Graphics in your statistical procedure.

2. In your program, specify the ODS destination and options that you want, such as the style.

3. Use the ODS GRAPHICS statement options to control various aspects of the graph output, such as the size.

- Produce a graph that was created in the Graph Template Language (GTL).
  
  Here are the high-level steps:
  
  1. Create a graph template using the GTL.
  2. Render the compiled template using the SGRENDER procedure.

- Produce in batch mode a graph that was created in the ODS Graphics Designer.
  
  Here are the high-level steps:
  
  1. Create the graph using the ODS Graphics Designer.
  2. Render the graph using the SGDESIGN procedure as part of a batch. In your program, you can specify the ODS destination and any supported ODS options. If the SGD file has been defined with dynamic variables, then you can substitute a different value for a variable by using the DYNAMIC statement.

  **TIP** You can also export the graph template from the ODS Graphics Designer. You can then save the code as a SAS program to be run in batch mode.

- Annotate a graph that was generated for your analysis.
  
  Here are the high-level steps:
  
  1. Make sure that ODS Graphics is enabled for your procedure.
  2. In your program, specify the SGE= ON option in the ODS destination statement.
  3. Annotate the graph using the ODS Graphics Editor.
4 Do either of the following:

- Save the SGE file in the format that you want.
- Render the SGE file using the SGRENDER procedure. In your program, you can specify the ODS destination and options that you want. You can also use the ODS GRAPHICS statement options to control various aspects of the graph output.

- Produce an annotated ODS Graphics Designer graph for publication.

Here are the high-level steps:

1 Create the graph using the ODS Graphics Designer.

2 Produce an editable graph using the SGDESIGN procedure. In your program, specify the SGE= ON option in the ODS destination statement.

3 Annotate the graph using the ODS Graphics Editor.

4 Do either of the following:

- Save the file in the PNG format.
- Save the file in the SGE format, and then render the SGE file using the SGRENDER procedure. In your program, you can specify the ODS destination and options that you want. You can also use the ODS GRAPHICS statement options to control various aspects of the graph output.

For a step-by-step example of this scenario, see “Example of Producing an Annotated ODS Graphics Designer Graph for Publication” on page 79.

- Customize the template for a graph that was created in the ODS Graphics Designer.

Here are the high-level steps:

1 Create the graph using the ODS Graphics Designer.

2 Export the graph template from the designer.

3 Paste the code into SAS and customize the graph template using the GTL.
4 Render the compiled template using the SGRENDER procedure.

- Customize the template for a graph that was created using the ODS Graphics procedures.

Here are the high-level steps:

1. Create a graph using the SG PLOT or the SGSCATTER procedure. In the procedure statement, specify the TMPLOUT= option. This option writes the template code for your graph to a file.

2. In SAS, customize the exported template using the GTL.

3. Render the compiled template using the SGRENDER procedure.

- Produce graphs in batch mode using a custom style that was created in the ODS Graphics Designer.

Here are the high-level steps:

1. Create a custom style using the ODS Graphics Designer.

2. Export the style.

3. Execute the exported code in SAS to compile the style and save it in the style template store.

4. Apply the style to your procedures by specifying the style in the ODS destination statement.
Example of Producing an Annotated ODS Graphics Designer Graph for Publication

About This Example

In this example, an environmental engineering company wants to graph its stock closing values for the past few months. The company plans to include the graph in an online color presentation. Here are the high-level steps:

1. Create the graph using the ODS Graphics Designer.

2. Produce an editable graph using the SGDESIGN procedure with an ODS destination statement.

3. Modify the graph using the ODS Graphics Editor and save it as a PNG file. Modifications include the following:
   - changing the graph style and the color of the title
   - adding the company logo to the graph

Note: Within these high-level steps, the exact steps can vary. For example, some of the formatting that occurs in the ODS Graphics Editor could be done in the ODS Graphics Designer instead. The instructions here provide one way to create the final graph.
**Data Used for This Example**

The company wants to include in a presentation its stock closing values for the months July 2010 through June 2011. Here is the data set that is used.

```sas
data companyStock;
  informat day date7.;
  input day close;
  format day worddate3.;
  format close dollar4.;
datalines;
30Jul10  80
31Aug10  84
30Sep10  82
29Oct10  77
30Nov10  85
24Dec10  85
31Jan11  87
```
28Feb11 90
31Mar11 93
29Apr11 95
31May11 99
30Jun11 102
;
run;

Create the Graph Using the ODS Graphics Designer

Step One: Create the Graph and Assign Data

1 In SAS, create the data set that you need for this example. Execute the code found in “Data Used for This Example” on page 80.

2 Select Tools ▶ ODS Graphics Designer. The designer opens and displays the Graph Gallery.

3 On the Basic tab of the Graph Gallery, double-click the Series Plot icon.

The Assign Data dialog box appears.
4 In the Assign Data dialog box, complete these steps:
   - Select WORK from the Library drop-down list.
   - Select COMPANYSSTOCK from the Data Set drop-down list.
   - Select DAY from the X drop-down list.
   - Select CLOSE from the Y drop-down list.

5 Click OK.

Step Two: Customize the Title, Footnote, and Axis Labels
1 Double-click the placeholder title. The placeholder text is highlighted:
   
   ![Type in your title...]

2 In the text box, enter Stock Closing Prices.

3 In the bottom left corner of the graph, double-click the placeholder footnote. The placeholder text is highlighted.

4 In the text box, enter Years: 2010–2011.

5 Right-click the X axis label and select Axis Properties. The Cell Properties dialog box appears and displays the Axes tab.

6 In the Label text box, enter Month.

7 From the Axis list box, select Y.

8 In the Label text box, the word close is lower case. Capitalize Close.

9 Click OK.

Step Three: Resize and Save the Graph
1 To resize the graph:
   a Right-click the graph and select Graph Properties. The Graph Properties dialog box appears.
In the **Width** list box, specify 480. The width and height are measured in pixels. Clicking an arrow changes the value by 10 pixels.

To resize the height proportionally, make sure that the **Keep Aspect Ratio** check box is selected.

Click **OK**.

---

1. To save the graph:
   - Select **File** ➤ **Save As**.
   - Save the file to the desired location. Specify the name that you want for the file. For example, you might enter `companystock`. The file type **SGD Files (*.sgd)** is selected by default.
Click **Save**.

Here is the graph output.

*Display 8.2  Stock Closing Example in ODS Graphics Designer*

![Graph of Stock Closing Prices]

**Generate an Editable Graph**

In this step, you generate a graph that can be edited in the ODS Graphics Editor. To do this, use the SGDESIGN procedure with an ODS destination statement.

In SAS, execute the SGDESIGN procedure and reference the SGD file that you created for the example. Here is sample code:

```sas
ods listing sge=on;
proc sgdesign sgd="C:\SGDFiles\companystock.sgd";
run;
```

Note the following:
To create an editable graph, specify the SGE= ON option in an ODS destination statement.

For the SGD= value, specify the path and name of the SGD file that you created for the example.

The example does not need to specify the WORK.COMPANYSTOCK data set. By default, the SGDESIGN procedure uses the data set that is defined in the SGD file. That data set remains available as long as the SAS session is open.

Annotate the Graph Using the ODS Graphics Editor

Step One: Open the Graph in the ODS Graphics Editor

1. Click the expansion icon in the SAS Results window to expand the list of graphs that you created.

2. Double-click the SGE file, which is identified by the icon.

   The ODS Graphics Editor opens and displays the graph for editing.

Note: You cannot edit an ODS graph on z/OS systems.

Step Two: Change the Graph Style and the Title Color

1. With your graph displayed, select Format ▶ Style ▶ Analysis from the main menu. The style of the graph changes.

2. Double-click the title and select the text.

3. Select the green color from the color drop-down list in the Graph toolbar.

Step Three: Add an Image to the Graph

In this step, you add an image, such as a logo, to a graph. For the company stock example, the image is a company logo. You can substitute any small image that you have at your site.

1. Click from the Graph toolbar, or select Insert ▶ Image from the main menu.
2 From the Image dialog box that is displayed, select and open the image that you want to insert.

   The image appears in the center of the graph.

3 Click and drag the image to the bottom right corner of the graph.

4 If you need to resize the image, select the image and drag one of the circles that appear around the image.

   You can maintain the ratio of width to length. To do this, position your cursor on a corner circle, press Shift, and drag the corner circle.

**Step Four: Save the Graph**

1 Select **File ➤ Save As** from the menu.

2 Select the directory where you want the graph to be saved.

3 Select save options as follows:

   - Select the PNG file type. This option saves the graph as a flat image. The graph in this format cannot be edited, though it can be annotated.

     **TIP** If you might later want to reopen and edit the file, save it first in SGE format.

   - Set the resolution to 100 DPI (default). Changing the DPI changes the size of the image.

4 Enter the name of the graph in the **File name** field.

5 Click **Save**.
Appendix 1

Usage Summaries

Summary of Ways to Create ODS Graphs ........................................ 87
Summary of Ways to Modify and Customize ODS Graphs ........... 88
Summary of Using ODS Graphics Software ................................. 89

Summary of Ways to Create ODS Graphs

You can use the following ODS Graphics software to create graphs.

<table>
<thead>
<tr>
<th>Software</th>
<th>Features</th>
</tr>
</thead>
<tbody>
<tr>
<td>ODS GRAPHICS statement</td>
<td>Statistical procedures that support ODS Graphics can produce graphs as automatically as they produce tables.</td>
</tr>
<tr>
<td>Graph Template Language (GTL)</td>
<td>The GTL is very powerful but takes time to learn. After you define the graph using GTL and compile the graph template, you can produce the graph using the SGRENDER procedure.</td>
</tr>
</tbody>
</table>
The procedures provide a simple syntax for creating effective and attractive graphics. You can create single-cell plots and bar charts, multi-page classification panels, and scatter plot matrices.

The SGDESIGN produces output from a graph that was created in the ODS Graphics Designer.

The SGRENDER produces output from templates that are created with the GTL. The procedure also renders graphs from ODS Graphics Editor files.

The designer provides an easy point-and-click interface for creating and designing graphs. The Graph Gallery provides commonly used graphs. You can export the code that is generated for use outside of the designer.

You can use the following ODS Graphics software to modify and customize graphs.

<table>
<thead>
<tr>
<th>Software</th>
<th>Features</th>
</tr>
</thead>
<tbody>
<tr>
<td>ODS Graphics Editor</td>
<td>The editor provides an easy point-and-click interface for editing and annotating graphs.</td>
</tr>
<tr>
<td>ODS Graphics Designer</td>
<td>The designer provides an easy point-and-click interface for designing graphs. You can modify individual graphs to change their appearance.</td>
</tr>
<tr>
<td>Graph Template Language (GTL)</td>
<td>You can modify the ODS graph template for a plot to make changes that persist. The GTL is very powerful but takes time to learn. After you define the graph using GTL and compile the graph template, you can produce the graph using the SGRENDER procedure.</td>
</tr>
</tbody>
</table>
You can modify individual graphs to change their appearance using a simple procedure syntax.

You can change the appearance by applying a different ODS style. See “Changing the Style That Is Applied to ODS Graphs” on page 66.

Summary of Using ODS Graphics Software

The following table summarizes ways in which you can use ODS Graphics software.

<table>
<thead>
<tr>
<th>Task</th>
<th>What Software Can You Use?</th>
<th>Level of Complexity</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create graphs as part of statistical analyses.</td>
<td>ODS GRAPHICS statement</td>
<td>Low</td>
</tr>
<tr>
<td>Create stand-alone graphs for exploration of data or for customized displays.</td>
<td>ODS Graphics Designer</td>
<td>Low</td>
</tr>
<tr>
<td>Change the overall appearance of graphs and tables.</td>
<td>ODS styles (STYLE= option in the ODS destination statement)</td>
<td>Low</td>
</tr>
<tr>
<td>Change the appearance of graphics elements individually.</td>
<td>ODS Graphics Designer</td>
<td>Low</td>
</tr>
<tr>
<td></td>
<td>ODS Graphics Editor</td>
<td>Low</td>
</tr>
<tr>
<td></td>
<td>ODS Graphics procedures</td>
<td>Medium</td>
</tr>
<tr>
<td></td>
<td>Graph Template Language</td>
<td>High</td>
</tr>
<tr>
<td>Task</td>
<td>What Software Can You Use?</td>
<td>Level of Complexity</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>------------------------------------------------------------------------------------------</td>
<td>---------------------</td>
</tr>
<tr>
<td>Annotate specific graphs for a presentation or paper.</td>
<td>ODS Graphics Editor</td>
<td>Low</td>
</tr>
<tr>
<td></td>
<td>ODS Graphics procedures</td>
<td>Medium</td>
</tr>
<tr>
<td></td>
<td>Graph Template Language</td>
<td>High</td>
</tr>
<tr>
<td>Create custom graph templates.</td>
<td>ODS Graphics Designer (produces a template for each graph created)</td>
<td>Low</td>
</tr>
<tr>
<td></td>
<td>Graph Template Language</td>
<td>High</td>
</tr>
<tr>
<td>Make persistent, programmatic changes in the default graphs.</td>
<td>Graph Template Language</td>
<td>High</td>
</tr>
</tbody>
</table>
**annotation**

a label, marker, or note that is not obtained from the data but is placed on a graph independently. Such annotations might or might not be linked to data values in the plot.

**axis**

a line that represents the midpoints (for a discrete axis) or the scale (for a continuous or interval axis) for graphing variable or data values. An axis typically consists of an axis line with tick marks, tick values (or midpoint values), and a label.

**block**

See statement block.

**cell**

in ODS graphics, a distinct rectangular subregion of a graph that can contain plots, text, or legends.

**classification panel**

a multi-cell graph in which the cell data is driven by the values of one or more classification variables. The number of the cells is determined by the unique values of the classification variables. Each cell of the panel has the same types of plots.

**classification variable**

a variable whose values are used to group (or classify) the observations in a data set into different groups that are meaningful for analysis.

**column**

a set of layout cells that are stacked vertically and share the same alignment.
computed plot
a plot in which input data is internally summarized or otherwise transformed to create new data that is actually rendered by the plot. Examples of computed plot statements are BARCHART, BOXPLOT, HISTOGRAM, ELLIPSE, and REGRESSIONPLOT.

define block
in the TEMPLATE procedure, a define block (beginning with a DEFINE statement and ending with an END statement) creates various types of templates, including STATGRAPH, STYLE, and TABLE.

device-based graphic
a graph created with SAS/GRAPH software for which a user-specified or default device (DEVICE= option) controls certain aspects of the graphical output.

dots per inch
a measure of the graph resolution by its dot density. Short form: DPI.

DPI
See dots per inch.

dynamic variable
a variable defined in a template with the DYNAMIC statement that can be initialized at template run time.

fill
to apply a color within a bounded area. Many plots, such as bar charts and band plots, have bounded areas that can be filled or unfilled. When filled, a color is applied. When unfilled, the areas are transparent.

footnote area
the region below the graph area where text produced appears.
**Graph Gallery**

in ODS Graphics Designer, a gallery of predefined, commonly used graphs. Users can add their own custom graphs to the gallery.

**Graph Template Language**

an extension to the Output Delivery System (ODS) that enables users to create sophisticated analytical graphs. Short form: GTL.

**graphics template**

See ODS template.

**group variable**

a variable in the input data set used to categorize chart variable values into groups. A group variable enables the data for each distinct group value to be rendered in a visually different manner. For example, a grouped scatter plot displays a distinct marker and color for each group value.

**GTL**

See Graph Template Language.

**layout**

a generic term for a rectangular container that lays out the positions and sizes of its child components.

**layout block**

a block beginning with a LAYOUT statement and ending with an ENDLAYOUT statement.

**layout grid**

a multi-cell layout arranged as a grid of cells in rows and columns.

**layout type**

a keyword indicating the functionality of the layout. For example, OVERLAY, LATTICE, and DATAPANEL are layout types.
**legend entry**
a combination of a graphical element such as a marker or line along with text describing the value or use of the graphical element. A discrete legend can have several legend entries.

**loess plot**
a curved line showing a loess fit for a set of points.

**marker**
a symbol such as a diamond, a circle, or a triangle that is used to indicate the location of, or annotate, a data point in a plot or graph.

**multi-cell layout**
a layout that supports a rectangular grid of cells, each of which can contain a graphical element, such as a plot, a legend, a nested layout, and so on.

**nested layout**
a layout block that appears within the scope of another layout block.

**ODS**
See Output Delivery System.

**ODS destination**
a designation that the Output Delivery System uses to generate a specific type of output. Types of ODS destinations include but are not limited to HTML, XML, listing, PostScript, RTF, and SAS data sets.

**ODS Graphics**
an extension to ODS that is used to create analytical graphs using the Graph Template Language.

**ODS style**
a template that specifies instructions for the presentation aspects (color, font face, font size, and so on) of your SAS output. This template determines the overall
appearance of the documents that use it. Each style definition consists of style elements.

**ODS template**
a description of how output should appear when it is formatted. ODS templates are stored as compiled entries in a template store, also known as an item store. Common template types include STATGRAPH, STYLE, CROSSTABS, TAGSET, and TABLE.

**Output Delivery System**
a component of SAS software that can produce output in a variety of formats such as markup languages (HTML, XML), PDF, listing, RTF, PostScript, other formats, and SAS data sets. Short form: ODS.

**overlay**
a plot that can be superimposed on another plot when specified within an overlay-type layout. A common overlay combination is a fit line on a scatter plot.

**overlay layout**
a type of layout that supports the superimposition of graphical components, such as plots, legends, and nested layouts.

**panel**
a graph with multiple cells.

**plot**
a visual representation of data such as a scatter plot, needle plot, or contour plot.

**plot area**
the space, bounded by the axes, where a visual representation of data, such as a scatter plot, a series line, or a histogram, is drawn.
plot type
   a plot family such as bar chart (which would include horizontal, vertical, and grouped bar charts), or a classification scheme for plots based on some useful criteria, such as whether the plots are computed or parameterized.

regression plot
   a straight or curved line showing a linear or higher order regression fit for a set of points.

required argument
   a variable or constant that must be specified in order to evaluate an expression or render a plot, legend, text, or a layout. For example, a scatter plot has two required arguments: X=column and Y=column.

rich text
   a generic term for text that can have different font characteristics (color, family, size, weight, style) on a character-by-character basis and can also be used as a superscript or subscript. All text statements in GTL support rich text.

row
   a set of layout cells that are side-by-side and share the same alignment.

scatter plot matrix
   a grid of scatter plots showing pairwise combinations of multiple numeric variables.

SGD file
   an ODS Graphics Designer file. Users can open this file in the designer and change the graph. Users can also render the graph to an ODS destination by using the SGDESIGN procedure.

SGE file
   a file created in the ODS Graphics environment that contains an editable graph. Such files have a .sge file extension and can be edited only with the ODS Graphics Editor. You can edit SGE files from the SAS Results window or by opening the SGE file from within the ODS Graphics Editor.
shared variable
a feature of ODS Graphics Designer that enables users to reuse graphs and specify different variables from the same or from a different data set.

single-cell layout
a layout type that supports only one cell. The OVERLAY, OVERLAY3D, and OVERLAYEQUATED layouts are examples of single-cell layouts.

statement block
a group of statements that has both a logical beginning and ending statement. For example, in the GTL, a LAYOUT statement along with its ENDLAYOUT statement and all contained statements are a block. Some blocks can be nested within other blocks.

style
see ODS style.

style attribute
a visual property, such as color, font properties, and line characteristics, that has a reserved name and value defined in ODS. Style attributes are collectively referenced by a style element within a style definition.

style element
a named collection of style attributes that affects specific parts of ODS output. For example, a style element might specify the color and font properties of title text or other text in a table or graph.

template definition
the TEMPLATE procedure source program that creates a template. A template definition can be generated from a compiled template. Also called the template source.

template store
an item store that contains definitions that were created by the TEMPLATE procedure. Definitions that SAS provides are in the item store Sashelp.Tmplmst. You
can store definitions that you create in any template store to which you have Write access.

**Template-based graphic**
graphical output produced by a compiled ODS template of the type STATGRAPH. That is, a graph that is produced within the ODS graphics environment rather than in the traditional device-based environment.

**Transparency**
the degree to which a graphics element (such as a marker or filled area) is opaque or transparent. Transparency is indicated with a number from 0 (completely opaque) to 1 (completely transparent).

**Unicode**
a computing industry standard for the consistent encoding, representation and handling of text expressed in most of the world's writing systems.
### A
- annotating graphs 72
- attribute mapping 72
- attribute values, hardcoding 70

### C
- cell 7
- changing graphics elements 69
- changing styles
  - See ODS styles
- components of a graph 7
- creating custom styles 68
- creating ODS graphs
  - from a SAS procedure 13
  - overview 3
  - using the Graph Template Language 29
  - with the ODS Graphics Designer 37
  - with the ODS Graphics procedures 17
- customizing graph templates 29, 49
- customizing styles 68

### D
- default ODS styles 63
- destinations
  - See ODS destinations
- dynamic variables
  - in the Graph Template Language 32
  - in the SGDESIGN procedure 47
  - in the SGRENDER procedure 32

### E
- editable graph
  - creating 55
  - example of annotating 85
  - SGE file 86
- editing styles
  - in ODS Graphics Designer 68
  - with the TEMPLATE procedure 68
- example
  - annotating an SGD graph for publication 79
  - changing styles in a program 66
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>generating an editable graph</td>
<td>84</td>
</tr>
<tr>
<td>graph template</td>
<td>32</td>
</tr>
<tr>
<td>SGDESIGN procedure</td>
<td>47, 84</td>
</tr>
<tr>
<td>SGPANEL procedure</td>
<td>25</td>
</tr>
<tr>
<td>SGPLOT procedure</td>
<td>22</td>
</tr>
<tr>
<td>SGRENDER procedure</td>
<td>31, 32</td>
</tr>
<tr>
<td>SGSCATTER procedure</td>
<td>21</td>
</tr>
<tr>
<td>using multiple ODS Graphics software components</td>
<td>75</td>
</tr>
<tr>
<td>using ODS Graphics Designer</td>
<td>40</td>
</tr>
<tr>
<td>using ODS Graphics Editor</td>
<td>54</td>
</tr>
<tr>
<td>using ODS Graphics functionality</td>
<td>13</td>
</tr>
<tr>
<td>using SGD file with SGDESIGN procedure</td>
<td>47</td>
</tr>
<tr>
<td>structure</td>
<td>31</td>
</tr>
<tr>
<td>using an ODS Graphics Designer template</td>
<td>49</td>
</tr>
<tr>
<td>graph templates</td>
<td>29</td>
</tr>
<tr>
<td>exporting from ODS Graphics Designer</td>
<td>49</td>
</tr>
<tr>
<td>graphic environment</td>
<td></td>
</tr>
<tr>
<td>setting graphics options</td>
<td>11</td>
</tr>
<tr>
<td>graphics elements, appearance</td>
<td>69</td>
</tr>
<tr>
<td>changing in Graph Template Language</td>
<td>69</td>
</tr>
<tr>
<td>changing in ODS Graphics Designer</td>
<td>71</td>
</tr>
<tr>
<td>changing in ODS Graphics Editor</td>
<td>71</td>
</tr>
<tr>
<td>changing in ODS Graphics procedures</td>
<td>69</td>
</tr>
<tr>
<td>graphs</td>
<td></td>
</tr>
<tr>
<td>See ODS Graphics GTL</td>
<td></td>
</tr>
<tr>
<td>See Graph Template Language (GTL)</td>
<td></td>
</tr>
<tr>
<td>image</td>
<td></td>
</tr>
<tr>
<td>adding to graphs</td>
<td>72</td>
</tr>
<tr>
<td>attribute mapping</td>
<td>72</td>
</tr>
<tr>
<td>changing the appearance of graphics elements</td>
<td>69</td>
</tr>
<tr>
<td>changing the style</td>
<td>66</td>
</tr>
<tr>
<td>dynamic variables</td>
<td>32</td>
</tr>
<tr>
<td>example</td>
<td>32</td>
</tr>
<tr>
<td>specifying attribute values</td>
<td>70</td>
</tr>
</tbody>
</table>
Index 101

L

listing ODS styles 63

M

modifying custom styles 68

O

ODS destinations
  default styles 63
  overview 6
ODS Graphics
  annotating graphs 72
  attribute mapping 72
  benefits of using 4
  changing the appearance of individual elements 69
  creating graphs 3
  creating graphs from a SAS procedure 13
  example using 13
  functionality 13
  introduction 1
  procedures 17
  software interactions 75
  software suite 3
  software summary 89
ODS Graphics Designer 37
  adding cells to a graph 40
  changing the appearance of graphics elements 71
  changing the graph style 67
  editing styles 68
  example of using 40
  exporting a graph template 49
  Graph Gallery 41
  graphical interface (GUI) 38
  plot layers 42
  plot types 38
  SGD file 37
  shared variables 47
  titles and footnotes 46
  using a common axis 45
ODS Graphics Editor 51
  adding an image to a graph 85
  annotating graphs 72
  changing the appearance of graphics elements 71
  changing the graph style 67
  creating an editable graph 55
  editing a graph 85
  editing functions 52
  example of using 54
  graphical interface (GUI) 52
  rendering output with
    SGRENDER procedure 51
    SGE file 51
ODS Graphics procedures
  annotating graphs 72
  attribute mapping 72
  changing the appearance of graphics elements 71
  changing the style 66
  SGDESIGN 18
  SGPANEL 18
SGPLOT 18
SGRENDER 18
SGSCATTER 18
ODS GRAPHICS statement 11
setting graphics options 15
ODS styles 61, 66
changing in a program 66
changing in ODS Graphics
   Designer 67
changing in ODS Graphics
   Editor 67
changing the appearance of
   graphics elements 69
defaults 63
ing a program 66
listing available 63
recommended for statistics 64
style elements 61
TEMPLATE procedure 68
understanding 61

PROC TEMPLATE
   editing a style template 68
   graph templates 31
   procedure structure 19

R
recommendations
   statistical styles 64

S
scenarios
   annotating a graph from an
      analytic procedure 76
   annotating an ODS Graphics
      Designer graph 77
   annotating an SGD graph for
      publication 79
   customize the template for an
      ODS Graphics procedure
      graph 78
   customizing the template for
      an ODS Graphics Designer
      graph 77
   producing a graph from a
      custom style 78
   producing a GTL graph 76
   producing a statistical graph
      75
   producing an ODS Graphics
      Designer graph (batch
      mode) 76

P
plot area 7
plot layers 42
PROC SGDESIGN 18, 47
PROC SGPANEL 18, 20, 25
PROC SGPLOT 18, 19, 22, 70
PROC SGRENDER 18
   used with Graph Template
   Language templates 31
   used with ODS Graphics
   Editor output 51
PROC SGSCATTER 18, 21
setting graphics options 15  
SG annotation 72  
SG attribute maps 72  
SGD file 46  
using 47  
with Graph Template  
Language (GTL) 49  
with SGDESIGN procedure 47  
SGDESIGN procedure 18  
example using SGD file 47  
generating an editable graph 84  
syntax 47  
using SGD files with 47  
SGE file 59  
locating 56  
saving 86  
SGPANEL procedure 18  
example 25  
structure 20  
SGPLOT procedure 18  
example 22, 70  
specifying attribute values 70  
structure 19  
SGRENDER procedure 18  
used with Graph Template  
Language templates 31  
used with ODS Graphics  
Editor output 51  
SGSCATTER procedure 18  
structure 21  
software  
ODS Graphics scenarios 75  
ODS Graphics suite 3  
summary 89  
statistical  
ODS styles 64  
Style Editor  
ODS Graphics Designer 68  
styles  
See ODS styles  
summary  
of using ODS Graphics  
software 89  
of ways to create ODS graphs 87  
of ways to modify and customize ODS graphs 88  
T  
TEMPLATE procedure  
editing styles 68  
templates  
graph templates 31  
templates  
graph 29, 31, 49  
graph example 32  
style 68  
U  
using  
multiple ODS Graphics  
software components 75  
using ODS Graphics software  
summary 89