# Contents

*About This Book* ......................................................... v
*What's New in SAS Theme Designer 4.6 for Flex* ...................... vii
*Accessibility* ............................................................ ix

# Chapter 1 • Overview of the SAS Theme Designer 4.6 for Flex

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>What Is the SAS Theme Designer 4.6 for Flex?</td>
<td>1</td>
</tr>
<tr>
<td>Benefits of Using the SAS Theme Designer 4.6 for Flex</td>
<td>2</td>
</tr>
<tr>
<td>How to Access the SAS Theme Designer 4.6 for Flex</td>
<td>2</td>
</tr>
<tr>
<td>Who Can Use the SAS Theme Designer 4.6 for Flex?</td>
<td>3</td>
</tr>
<tr>
<td>Prerequisite for Logon Access to the SAS Theme Designer 4.6 for Flex</td>
<td>3</td>
</tr>
</tbody>
</table>

# Chapter 2 • Selected Tasks in the SAS Theme Designer 4.6 for Flex

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>About This Chapter</td>
<td>5</td>
</tr>
<tr>
<td>Create and Deploy a Custom Theme</td>
<td>6</td>
</tr>
<tr>
<td>Theme Dependencies</td>
<td>9</td>
</tr>
<tr>
<td>Base Themes</td>
<td>9</td>
</tr>
<tr>
<td>User Interface Components</td>
<td>10</td>
</tr>
<tr>
<td>Replace the Logo</td>
<td>11</td>
</tr>
<tr>
<td>Deploy a Custom Theme</td>
<td>12</td>
</tr>
<tr>
<td>Delete a Custom Theme</td>
<td>13</td>
</tr>
<tr>
<td>Undeploy a Custom Theme</td>
<td>13</td>
</tr>
<tr>
<td>Disable All Custom Themes</td>
<td>14</td>
</tr>
<tr>
<td>Change the Default Theme for Users</td>
<td>15</td>
</tr>
<tr>
<td>Modify a Theme</td>
<td>15</td>
</tr>
<tr>
<td>Export a Custom Theme</td>
<td>16</td>
</tr>
<tr>
<td>Import a Custom Theme</td>
<td>17</td>
</tr>
<tr>
<td>Apply a Theme for Flex Applications Used by the Administrator</td>
<td>17</td>
</tr>
<tr>
<td>Accessing SAS Theme Designer for Flex from the SAS Visual Analytics Home Page</td>
<td>18</td>
</tr>
<tr>
<td>Creating Report Themes from Imported Custom Themes</td>
<td>18</td>
</tr>
</tbody>
</table>

# Chapter 3 • Reference for the SAS Theme Designer 4.6 for Flex

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>About SAS Application Themes for Flex</td>
<td>21</td>
</tr>
<tr>
<td>About the Predefined Base Themes</td>
<td>22</td>
</tr>
<tr>
<td>Inheritance of Styles among Components</td>
<td>22</td>
</tr>
<tr>
<td>Report Themes for SAS Visual Analytics</td>
<td>23</td>
</tr>
<tr>
<td>Limitations of SAS Theme Designer 4.6 for Flex</td>
<td>23</td>
</tr>
<tr>
<td>Where to Find More Information</td>
<td>23</td>
</tr>
</tbody>
</table>

# Glossary

# Index
About This Book

Audience

The intended audience for this document is an administrator or visual designer who wants to change the appearance of SAS web applications that are deployed with the Adobe Flash player at their site.
What’s New in SAS Theme Designer 4.6 for Flex

Overview

There are no new additions or changes for SAS Theme Designer 4.6 for Flex.
For information about the accessibility of this product, see Accessibility Features of SAS Theme Designer for Flex 4.6 at support.sas.com.
What's New in SAS Theme Designer 4.6 for Flex
Chapter 1
Overview of the SAS Theme Designer 4.6 for Flex

What Is the SAS Theme Designer 4.6 for Flex? ............................................. 1
Benefits of Using the SAS Theme Designer 4.6 for Flex .......................... 2
How to Access the SAS Theme Designer 4.6 for Flex ............................. 2
Who Can Use the SAS Theme Designer 4.6 for Flex? ......................... 2
Prerequisite for Logon Access to the SAS Theme Designer 4.6 for Flex .... 3
Migrate and Update Custom Themes Automatically ............................. 3

What Is the SAS Theme Designer 4.6 for Flex?

The SAS Theme Designer 4.6 for Flex enables you to easily customize the appearance of SAS web applications that are displayed with the Adobe Flash Player. The SAS Theme Designer 4.6 for Flex is, itself, a Flex web application. You use SAS Theme Designer 4.6 for Flex to create and deploy simple, visually appealing, customized themes.

A theme defines the overall look and feel of an application. It is designed using colors and graphics that are applied to common user interface components and layout containers. A well-designed theme can create a strong visual identity across a product or set of products. SAS recognizes that you might not want to view your SAS applications in the default corporate theme. You might instead want to apply your own branding and customization to help the SAS applications fit in with the rest of your software environment. SAS also recognizes that users at your site often use more than one SAS application in their daily work. Having a consistent look and feel ensures that the user’s transition from one application to the next is as seamless as possible.

The SAS Theme Designer 4.6 for Flex affects only applications that use release 2.4 (or later) of SAS Application Themes for Flex. The work that you do in the SAS Theme Designer 4.6 for Flex has no effect on web applications that are not Flex applications (for example, SAS Web Report Studio 4.6).

See Also

- SAS Intelligence Platform: Middle-Tier Administration Guide
- SAS Intelligence Platform: Web Application Administration Guide
Benefits of Using the SAS Theme Designer 4.6 for Flex

The SAS Theme Designer 4.6 for Flex enables you to customize the SAS product line to meet your branding needs and to ensure a unified look across all eligible applications.

SAS Theme Designer 4.6 for Flex includes the following key features:

- A complete graphical user interface (GUI). All tasks can be done with simple point-and-click actions. You do not have to modify configuration files manually or edit the XML content.
- The implementation and deployment of custom themes are entirely within the designer’s control. You do not need to redeploy applications or restart web application servers. With a single click, you can make a new or updated custom theme available to all users in all eligible applications.
- A site can implement multiple custom themes. All deployed themes are available to all end users in all eligible applications.
- You can change the default theme. This is a single setting that applies to all eligible applications and affects all users (except those users who have specified a personal default theme).
- Custom themes that you create in the SAS Theme Designer 4.6 for Flex are retained and available after deployment-related activities such as software upgrades.
- Custom themes that were designed with previous versions of the application are easily migrated and updated.
- Custom themes can be easily exported or imported between environments.

How to Access the SAS Theme Designer 4.6 for Flex

The SAS Theme Designer 4.6 for Flex is a web application, so you access it from within a web browser. The address for the SAS Theme Designer 4.6 for Flex is: http://machine:port/SASThemeDesignerForFlex.

Note: If your site has configured web authentication, you cannot sign in using a SAS internal account (such as sasadm@saspw). If your site is using SAS authentication, you can sign in with an internal account.

Who Can Use the SAS Theme Designer 4.6 for Flex?

Anyone who can sign in to SAS Theme Designer 4.6 for Flex can perform all of the tasks that this application offers. However, creating custom themes is a highly specialized and infrequent task that should be performed only by an experienced
administrator or designated visual designer. To be able to access this application, you must be assigned the Customize Themes capability, which is part of the Theme Designer for Flex: Administration role.

---

**Prerequisite for Logon Access to the SAS Theme Designer 4.6 for Flex**

SAS Theme Designer 4.6 for Flex includes a predefined role known as Theme Designer for Flex: Administration. In SAS Management Console, you can view this role, and assign groups or users to this role.

By default, the SAS Administrators group belongs to this role as the default set of authorized users. These users can access SAS Theme Designer 4.6 for Flex and use the application to design, manage, and deploy custom themes. Other users who are assigned to this role have a similar capability to access the application, design, and manage themes. If a user who does not belong to this role, attempts to sign in to this application, then all logon attempts to the application are rejected and an error message is displayed.

In addition to the SAS Administrators group, if other users need access to SAS Theme Designer 4.6 for Flex, add these users to the Theme Designer for Flex: Administration role in SAS Management Console.

You should exercise caution in giving users access to SAS Theme Designer 4.6 for Flex, because any changes made to deployment of themes can have a global impact on your users.

To view the Theme Designer for Flex: Administration role, go to SAS Management Console and navigate to **Environment Management ➔ User Manager**. In the panel on the right, double-click **Theme Designer for Flex: Administration**.

---

**See Also**

*SAS Intelligence Platform: System Administration Guide*

---

**Migrate and Update Custom Themes Automatically**

SAS Theme Designer 4.6 for Flex is designed to easily migrate and update custom themes that were created with earlier versions of the application. All custom themes that were created and deployed with earlier versions of this application are automatically updated when you first sign in to SAS Theme Designer 4.6 for Flex after a migration. If you have custom themes that were created with earlier versions of SAS Theme Designer for Flex and were not deployed, you can manually deploy them by using SAS Theme Designer 4.6 for Flex. At the time of deployment, these custom themes are automatically updated and then deployed.
Chapter 2
Selected Tasks in the SAS Theme Designer 4.6 for Flex

<table>
<thead>
<tr>
<th>Task</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>About This Chapter</td>
<td>5</td>
</tr>
<tr>
<td>Create and Deploy a Custom Theme</td>
<td>6</td>
</tr>
<tr>
<td>Theme Dependencies</td>
<td>9</td>
</tr>
<tr>
<td>Base Themes</td>
<td>9</td>
</tr>
<tr>
<td>User Interface Components</td>
<td>10</td>
</tr>
<tr>
<td>Replace the Logo</td>
<td>11</td>
</tr>
<tr>
<td>Deploy a Custom Theme</td>
<td>12</td>
</tr>
<tr>
<td>Delete a Custom Theme</td>
<td>13</td>
</tr>
<tr>
<td>Undeploy a Custom Theme</td>
<td>13</td>
</tr>
<tr>
<td>Disable All Custom Themes</td>
<td>14</td>
</tr>
<tr>
<td>Change the Default Theme for Users</td>
<td>15</td>
</tr>
<tr>
<td>Modify a Theme</td>
<td>15</td>
</tr>
<tr>
<td>Export a Custom Theme</td>
<td>16</td>
</tr>
<tr>
<td>Import a Custom Theme</td>
<td>17</td>
</tr>
<tr>
<td>Apply a Theme for Flex Applications Used by the Administrator</td>
<td>17</td>
</tr>
<tr>
<td>Accessing SAS Theme Designer for Flex from the SAS Visual Analytics Home Page</td>
<td>18</td>
</tr>
<tr>
<td>Creating Report Themes from Imported Custom Themes</td>
<td>18</td>
</tr>
</tbody>
</table>

About This Chapter

This chapter discusses the functionality and features of SAS Theme Designer 4.6 for Flex. The simple user interface and instant preview feature facilitates an iterative and exploratory design process. This chapter describes how to create, deploy, and manage custom themes.
Create and Deploy a Custom Theme

You can use predefined base themes to create custom themes in SAS Theme Designer for Flex. The following steps show you how to create and deploy a custom theme.

1. Sign in to SAS Theme Designer 4.6 for Flex. The address for the application is: http://machine:port/SASThemeDesignerForFlex.

2. When prompted by the application to choose a task, click the **Create a Theme** button on the initial screen.

3. In the **New Theme** dialog box, select one of the predefined base themes. In the display below, the **SAS Light** base theme is selected. Click **OK**. The new theme is generated and ready to customize. The initial look and feel of the theme is determined by the predefined base theme that you selected. In the right pane, different components of the theme are displayed. The right pane provides an automatic, instant preview as you work. The left pane contains the **User Interface Components** that you can modify for your custom theme. See “**User Interface Components**” on page 10 for more information.

The following display shows a custom theme that is created from the SAS Light base theme.
Note: After you create and deploy a custom theme, you can use that theme as a basis for future themes. Such dependent relationships among themes are dynamic. For example, if you change Theme A, that change affects all themes that are based on Theme A (except for any design elements that are explicitly specified in the dependent themes).

4. Select the components that you want to change from the User Interface Components panel. The impact of each change is instantly shown in the right pane.

All of the design elements are listed in the User Interface Components pane. The sample application on the right contains examples of all of the available components. Changes that you make to certain user interface components affect other components. For example, if you change the color for Button, the colors for Tabs and Accordion change.

One place to begin changing your custom theme is the Global Settings menu on the User Interface Components. You can change text color, hover and selection colors, and the font type that is applied to the custom theme.

The following display shows Global Settings changes. The text color is changed to purple, the selection color is changed to blue, and the hover color is changed to red. The font type has been changed to Raavi.

Another change that you can make is to the Application Banner for your theme. Open the Application Banner component. In the Logo group box, click Browse.
Locate and select the image that you want to use from your local hard drive. In the display below, the Application Banner has been changed. The image file *MyLogo.jpg* has been loaded into the theme.

5. To save you work at any time, select **File ➤ Save** from the main menu.  
   **T I P** To revert the settings for a particular interface component (undoing all of your unsaved changes to that component in the current session), select the component in the **User Interface Components** pane. Then click **Reset to Defaults** in the lower left pane. The settings that were initially loaded for this session are then reapplied.

6. When you are ready to deploy the new theme, select **File ➤ Save and deploy** from the main menu.

The Save As window appears. The default theme name is **New Custom Theme**.

In the Save As window, enter a name for the custom theme. Click **OK**. The theme is saved and deployed.
A confirmation message is then displayed.

![Save and Deploy]

**Note:** Most special characters are not allowed in the theme name. The theme name can include alphabetic letters, digits, an underscore, and spaces.

The theme is now available for use with other functions in your current session of SAS Theme Designer for Flex and with other applications that might use Flex themes. For example, you can undeploy the theme if needed. From the **Tools** menu, select **Undeploy**. The Undeploy window appears. In the display below, the custom theme named *MyTheme* is now available for selection. Select the theme that you want to undeploy and click **OK**.

![Undeploy]

### Theme Dependencies

At run time, both the target theme and its base theme must be available. Each custom theme contains only information about how it differs from its base theme. The base theme is deployed simultaneously with the custom theme; both themes must be available to the consuming applications. If you have additional layers of nesting (for example, a custom theme that depends on another custom theme that in turn depends on a base theme), then all dependent themes must be available. If you deploy a theme, whose base theme is not deployed, the application automatically deploys the base theme. You cannot deploy a theme for only a particular application or for only a particular set of users. All deployed themes are available to all eligible applications and to all users.

### Base Themes

Here are the predefined base themes that are available for you to choose from:

**SAS Blue Steel**

The SAS Blue Steel theme enables you to modify the **Application banner** and **Splash screen** components. You can replace the banner logo with a customized logo. In release 3.5 and later, you can customize the two splash screens.

**SAS Corporate**

The SAS Corporate theme is the default theme for SAS Theme Designer for Flex. Colors for this theme are based on a navy blue palette. The SAS Corporate theme
enables you to modify the **Application banner** and **Splash screen** components. You can replace the banner logo with a customized logo. In release 3.5 and later, you can customize the two splash screens.

**SAS Dark**

The **SAS Dark** theme is implemented in a minimal way, without custom graphical skins. The **SAS Dark** theme is based on darker, charcoal gray tones, and should be used if a company’s theme contains a dark palette. The SAS Dark theme can be customized extensively. The full range of components on the **User Interface Components** panel are available for customization.

**SAS High Contrast**

The **SAS High Contrast** theme improves the accessibility of the text and interface for visually impaired users. The **SAS High Contrast** theme uses a black background, with white outlines, text, and icons. A currently selected (active) item is aqua color and previously selected items are purple. The full range of components on the **User Interface Components** panel are available for customization.

**SAS Light**

The **SAS Light** theme is implemented in a minimal way, without custom graphical skins. The **SAS Light** theme uses shades of light gray, beige, and white for its color palette. It should be used if a company’s theme contains an overall light palette. The SAS Light theme can be customized extensively. The full range of components on the **User Interface Components** panel are available for customization.

---

**User Interface Components**

In SAS Theme Designer 4.6 for Flex, the **User Interface Components** pane contains the settings that enable you to modify and customize a theme. The right pane of the theme immediately displays the changes that you make. This enables you to see the results immediately, as you develop the theme. Here are the different settings that you can change:

**Global Settings**

This includes settings that apply to the overall theme that you are creating or editing. The settings include color selections for text, selection, and hover. The **Font** setting enables you to select a font style that applies to the overall theme.

The list of available fonts is dependent on the fonts that are installed on your system. If a custom theme is assigned a new font, and that theme is then used on another system that does not have that font, the default font for the theme is displayed. For example: A custom theme is assigned the **Calibri** font. The theme is saved and deployed. On a different system, the **Calibri** font is not installed. The custom theme displays the default font, **Arial** on that machine.

**Accordion**

This includes settings that apply to the **Accordion** box and header in a theme. The settings include color selections for the background and header for the theme.

**Application Banner**

This includes settings that apply to the **Application Banner** in a theme. You can replace the SAS logo with a custom logo and background images. The settings include image selections for the logo and image or color selections for the background.
Application Frame
This setting applies to the background for a theme. You can apply a background image or select a background color and text color.

Button
This setting applies to the buttons and some tabs for a theme. You can apply fill and text colors for buttons.

Graphs
This setting applies to the Graphs pane for a theme. You can apply various styles and colors for a graph.

Icon Button
This setting applies a hover outline color for icon buttons.

Link Button
This setting applies text color that is displayed when a button is selected.

List
This setting applies background and text colors for the list item in the theme.

Menu
This setting applies background and text colors for menu items in the theme.

OLAP Table
This setting applies background and text colors for the OLAP table item in the theme.

Pane
This setting applies background, border, and text colors for the pane item in the theme.

Splash Screen
This setting applies initial loading and transition screen images for the theme.

Table
This setting applies background, text, and header colors for the table item in the theme.

Tabs
This setting applies various colors to the tab button and tab container items in the theme.

Toolbar
This setting applies background, color to the toolbar item in the theme.

Window Shade
This setting applies color to the header, header text, and container for the window shade item in the theme.

---

Replace the Logo

To replace the SAS logo (on the right edge of the application banner) with a different image, follow these steps:

1. In the list for the User Interface Components pane, select Application banner.
2. In the Logo group box, click Browse. Locate and select the image that you want to use from your local hard drive. In the display below, the Application Banner has been changed. The image file MyLogo.jpg has been loaded into the theme.
3. Save and deploy the custom theme. The theme is now available for use with other functions in the **File** and **Tool** menus.

---

**Deploy a Custom Theme**

As an alternative to the one-step save-and-deploy feature, you can deploy a custom theme that has already been saved. The result is identical to the one-step approach.

1. From the main menu of the SAS Theme Designer 4.6 for Flex, select **Tools** ➔ **Deploy**.

2. In the Deploy Theme window, select the theme. Note that the predefined themes are not listed because they are always deployed.

   ![Deploy Theme Window]

   Click **OK**. A confirmation window is displayed.

   ![Confirmation Window]

   The theme is now available for use with other functions in the **File** and **Tool** menus.

   **TIP** Deploying a theme makes the most-recently saved version of the theme available to end users. If you modify a custom theme, be sure to save the changes before deploying the theme.
Delete a Custom Theme

To permanently delete a custom theme from the system:

1. From the main menu of the SAS Theme Designer 4.6 for Flex, select **Tools ➜ Delete**.

2. In the Delete Themes window, select the theme.

   ![Delete Themes window](image)

   **TIP**  The predefined themes are not listed because you cannot delete those themes. To avoid unintended results, use caution in deleting themes. Consider theme dependencies. If you delete a theme that serves as a default theme (either globally or for an individual user), the SAS Blue Steel theme is then used as the default.

   Click **OK**. A second window is displayed. Select **Delete**.

   ![Delete Selected Themes window](image)

   A confirmation window is displayed.

   ![Delete Themes window](image)

   The change takes effect when a user refreshes or relaunches an eligible application.

   **Note:** If you want to make a theme unavailable for selection by an end user in the application preferences area, you do not have to delete the theme. You can instead undeploy the theme.

Undeploy a Custom Theme

If you want to remove a custom theme from the list of themes that is offered to end users in the application preferences area, you can undeploy that theme.

1. From the main menu of the SAS Theme Designer 4.6 for Flex, select **Tools ➜ Undeploy**.
2. In the Undeploy Theme window, select the theme.

![Undeploy Theme Window]

**TIP** The predefined themes are not listed because you cannot undeploy those themes. To avoid unintended results, use caution in undeploying themes. Consider theme dependencies. If you undeploy a theme that serves as a default theme (either globally or for an individual user), the SAS Blue Steel theme is then used as the default.

Click **OK**. A second window appears. Select **Undeploy**.

![Undeploy Selected Themes Window]

A confirmation window is displayed.

![Undeploy Confirmation Window]

The change takes effect when a user relaunches an eligible application. Note that undeploying a theme does not delete the theme. It just makes the theme unavailable for selection by a user in the application preferences area.

---

**Disable All Custom Themes**

In the initial configuration, custom themes are disabled (because no custom themes exist). When you create your first custom theme, custom themes are automatically enabled.

In the unusual circumstance in which you need to disable all custom themes, globally, complete the following steps:

1. From the main menu of the SAS Theme Designer 4.6 for Flex, select **Tools ⇒ Disable Custom Themes**.

2. In the confirmation message box, click **OK**. A confirmation window is displayed.

![Disable Custom Themes Confirmation Window]
When custom themes are disabled, no custom theme information is loaded into eligible applications. The change takes effect when a user relaunches or refreshes an eligible application.

---

**Change the Default Theme for Users**

In the initial configuration, the SAS Corporate theme is the default theme. A user can select a different, personal default theme from the preferences area in any eligible application. For that user, the personal default theme selection overrides the default theme. For that user, all applications are displayed using the selected personal default theme.

An administrator can set a theme other than the SAS Corporate theme as the default theme. This change affects only those users who have not already selected a personal default theme. This change does not make other themes unavailable or prevent a user from selecting a different, personal default theme.

To change the default theme for users:

1. From the main menu of the SAS Theme Designer 4.6 for Flex, select **Tools** ⇒ **Set Default Theme**. The Default Themes window is displayed.

2. Select the theme that you want to be the default theme. Click **OK**. A confirmation window is displayed.

The change takes effect when a user relaunches or refreshes an eligible application. The change does not affect users who have already specified a personal default theme.

---

**Modify a Theme**

When you open SAS Theme Designer 4.6 for Flex, you can choose to create a new custom theme or to modify an existing custom theme. To modify an existing custom theme, click the **Modify a Theme** button on the initial screen.
The Open Theme window appears. Select the custom theme that you want to modify and select OK.

The custom theme is then loaded and you can now make changes to the theme.

---

**Export a Custom Theme**

SAS Theme Designer 4.6 for Flex enables you to export a theme. You can export a custom theme from SAS Theme Designer 4.6 for Flex to a specific folder.

To export a custom theme, follow these steps:

1. From the main menu of the SAS Theme Designer 4.6 for Flex, select **Tools** ⇒ **Export Theme**.

2. Select the theme that you want to export. Click **OK**. A second window is displayed. Select **Yes**.
3. Navigate to the folder where you want the theme to be exported.

4. If desired, modify the filename for the theme, and click **OK**.

   The theme is exported and saved with a .tdf file extension.

   **Note:** For locales other than English, the default, export file name is translated to a default filename specific to that locale.

---

**Import a Custom Theme**

SAS Theme Designer 4.6 for Flex enables you to import a custom theme. You can import a custom theme from a specific folder to SAS Theme Designer 4.6 for Flex.

To import a custom theme, follow these steps:

1. From the main menu of the SAS Theme Designer 4.6 for Flex, select **Tools** ⇒ **Import Theme**.

2. In the dialog box that is displayed, select the TDF theme file that you want to import from your local hard drive. Click **Open**.

3. The theme is imported and is available within SAS Theme Designer 4.6 for Flex.

   **Note:** If a theme with the same name already exists within SAS Theme Designer 4.6 for Flex, it cannot be imported. Any valid theme that is in the correct format can be imported, including themes that were exported without a .tdf extension.

---

**Apply a Theme for Flex Applications Used by the Administrator**

SAS Theme Designer for Flex supports the selection of a different theme within the application. It supports the display of this theme for all Flex applications that are used by the administrator. As an administrator, you might be using several Flex applications in the SAS environment. As an administrator, you can select a different theme from within SAS Theme Designer for Flex, and this change is applied to all Flex applications that you use.

To apply a different theme to all of the Flex applications that you use, follow these steps:

1. From the main menu of SAS Theme Designer 4.6 for Flex, select **File** ⇒ **Preferences**.

2. In the Global Preferences dialog box, select the theme from the drop-down menu for **Theme**, and click **OK**.

   The selected theme is applied to SAS Theme Designer for Flex and all other Flex applications that you use.
Accessing SAS Theme Designer for Flex from the SAS Visual Analytics Home Page

Beginning in release 6.2 of SAS Visual Analytics, you can access SAS Theme Designer for Flex while working on the SAS Visual Analytics home page. This provides the opportunity to create and modify themes that are used in SAS Visual Analytics. When you create a theme in SAS Theme Designer for Flex, an application theme is created. Beginning in release 6.2 of SAS Visual Analytics, a report theme is also automatically generated for use in SAS Visual Analytics. Here are the steps to access the SAS Theme Designer for Flex from the SAS Visual Analytics home page:

2. On the Common Actions panel, select the option Customize Themes. This opens the SAS Theme Designer for Flex. You can now create and modify custom themes for use in SAS Visual Analytics. Once you deploy the theme, it is available for use in SAS Visual Analytics.

   Note: The Customize Themes function is also available for selection from the More Actions drop-down menu on the SAS Visual Analytics home page.
3. Once you have finished your modifications to a theme, you can return to the SAS Visual Analytics home page by selecting the Home button. This button is now available on the top left banner.

Creating Report Themes from Imported Custom Themes

When a custom application theme is created in SAS Theme Designer 4.6 for Flex, a coordinating custom report theme is automatically created. For custom application themes that are imported from previous releases of SAS Theme Designer for Flex, coordinating report themes are also now automatically created.

In order to create the report theme, custom application themes from previous releases must be exported and then imported. Custom application themes created with a release prior to release 4.1 can be exported for use in one of two scenarios:

1. A custom application theme that is created in SAS Theme Designer 3.5 for Flex is exported from one server and is then imported to SAS Theme Designer 4.6 for Flex on a different server.
2. A server is being updated (in place) from release 3.5 to 4.6 on the same machine. Custom application themes are exported as 3.5 themes and then imported and deployed as 4.6 themes.

With either scenario, the custom application theme is exported, imported, and deployed. To promote custom application themes that were created in previous releases, follow these steps:

1. In the previous release of SAS Theme Designer for Flex, export all custom themes using the Export Theme function. SAS Theme Designer for Flex creates a
single .tdf file that contains all exported themes. You can choose a specific folder to save the file. See “Export a Custom Theme” on page 16 for additional details.

2. If you are exporting and importing themes on a server that was updated (in place) from release 3.5 to 4.1 (or later release) on the same machine, then you must delete all custom themes that are available in SAS Theme Designer for Flex. You must do this after you have exported the themes. This is because the Import Theme function does not overwrite an existing theme. See “Delete a Custom Theme” on page 13 for additional details.

3. Using SAS Theme Designer 4.6 for Flex on the destination server, import the .tdf file that was generated with the Import Theme function. See “Import a Custom Theme” on page 17 for additional details.

4. You can now deploy the themes that you want to be available for use in other applications. Use the Deploy function in SAS Theme Designer 4.6 for Flex. See “Deploy a Custom Theme” on page 12 for additional details.

For each of the custom application themes that were imported and deployed, a corresponding report theme is now available for use in SAS Visual Analytics Designer. Custom application themes must be deployed for use as report themes in SAS Visual Analytics Designer.

Note: This process applies only to custom application themes that are created in previous releases. You cannot promote base themes from previous releases.
Chapter 3
Reference for the SAS Theme Designer 4.6 for Flex

About SAS Application Themes for Flex

Introduction to SAS Application Themes for Flex

Benefits of SAS Application Themes for Flex

About the Predefined Base Themes

Inheritance of Styles among Components

Report Themes for SAS Visual Analytics

Limitations of SAS Theme Designer 4.6 for Flex

Where to Find More Information

About SAS Application Themes for Flex

Introduction to SAS Application Themes for Flex

SAS applications are displayed with the Flex interface that is provided by a particular version of SAS Application Themes for Flex. At start-up time, Flex applications load Flex themes automatically. A theme consists of SWF files that include cascading style sheets (CSS) files. The theme content is downloaded to the client, and is cached by the user's web browser. As a result, during subsequent uses of the web application, the theme content loads quicker than when it is initially loaded. The SAS Corporate theme is the default theme for SAS applications that use Flex themes.

Benefits of SAS Application Themes for Flex

Flex applications require SAS Application Themes for Flex, and the themes are downloaded as SWF files to the client's web browser. Flex theme content runs within the Adobe Flash player and offers the following benefits:

- SAS Application Themes for Flex coexist with SAS Web Application Themes. For example, SAS Information Delivery Portal 4.6 uses the default web theme, but it displays SAS BI Portlets with SAS Application Themes for Flex.
- Applications that use SAS Application Themes for Flex offer more visual impact and interactivity.
- Improved visual impact and greater perceived depth are achieved through the use of skins. Skins are graphics that are applied to common user interface components in
In order to change their appearance. For example, the Corporate theme provides skins with a color palette that reflects the SAS visual identity. Skins also include some stylized graphics in the user interface.

About the Predefined Base Themes

When you choose a base theme, select the theme that is most similar to your desired color palette. You can then modify the theme as needed and save as a new, custom theme. There are five predefined base themes that override the Flex standard styles:

**SAS Blue Steel**

The SAS Blue Steel theme enables you to modify the *Application banner* and *Splash screen* components. You can replace the banner logo with a customized logo. In release 3.5 and later, you can customize the two splash screens.

**SAS Corporate**

The SAS Corporate theme is the default theme for SAS Theme Designer for Flex. Colors for this theme are based on a navy blue palette. The SAS Corporate theme enables you to modify the *Application banner* and *Splash screen* components. You can replace the banner logo with a customized logo. In release 3.5 and later, you can customize the two splash screens.

**SAS Dark**

The SAS Dark theme is implemented in a minimal way, without custom graphical skins. The SAS Dark theme is based on darker, charcoal gray tones, and should be used if a company’s theme contains a dark palette. The SAS Dark theme can be customized extensively. The full range of components on the **User Interface Components** panel are available for customization.

**SAS High Contrast**

The SAS High Contrast theme improves the accessibility of the text and interface for visually impaired users. The SAS High Contrast theme uses a black background, with white outlines, text, and icons. A currently selected (active) item is aqua color and previously selected items are purple. The full range of components on the **User Interface Components** panel are available for customization.

**SAS Light**

The SAS Light theme is implemented in a minimal way, without custom graphical skins. The SAS Light theme uses shades of light gray, beige, and white for its color palette. It should be used if a company’s theme contains an overall light palette. The SAS Light theme can be customized extensively. The full range of components on the **User Interface Components** panel are available for customization.

Inheritance of Styles among Components

Styles for certain design components in the User Interface Components panel are determined by other components and their customized styles. For example, you can customize the style for **Button** by selecting the desired background color, text, and opacity. The styles that you select for **Button** are automatically inherited by the tab headers and the accordion headers.
When you modify the color for **List**, the same color is applied to the menu and rows in a table. When elements in a list are modified, the modifications are inherited and displayed by trees, menus, and tables.

---

**Report Themes for SAS Visual Analytics**

Beginning in release 4.1 of SAS Theme Designer for Flex, custom report themes are now automatically created when a coordinating custom application theme is created in SAS Theme Designer for Flex. These custom report themes can then be used in SAS Visual Analytics reports.

---

**Limitations of SAS Theme Designer 4.6 for Flex**

When you use the SAS Theme Designer 4.6 for Flex, it is important to understand the following points:

- Not all aspects of an application’s appearance are customizable. The SAS Theme Designer 4.6 for Flex enables you to modify a rich, carefully selected subset of design elements. The intent is to offer maximum visual impact with minimal effort and minimal risk of unintended results.
- This application is not optimized for large numbers of themes or deeply nested hierarchies. It is intended for occasional, highly targeted use.
- This application does not offer manual editing of a theme or direct interaction with configuration files. For SAS Application Themes for Flex, SAS does not support direct interaction with source files. All work should be performed from within the SAS Theme Designer 4.6 for Flex.
- This application does not offer a step-by-step "undo" function.
- This application does not offer history or versioning of files.
- You cannot alter, delete, or undeploy any of the predefined themes provided by SAS.
- You cannot hide a deployed theme from anyone. All deployed themes are available to all end users in all eligible applications.
- You cannot preload a custom color palette into the SAS Theme Designer 4.6 for Flex.

---

**Where to Find More Information**

The most recent version of this document is available from the SAS Theme Designer for Flex product documentation page on the SAS support site [http://support.sas.com/documentation/onlinedoc/flexdesign](http://support.sas.com/documentation/onlinedoc/flexdesign)
Glossary

**SAS authentication**

a form of authentication in which the target SAS server is responsible for requesting or performing the authentication check. SAS servers usually meet this responsibility by asking another component (such as the server's host operating system, an LDAP provider, or the SAS Metadata Server) to perform the check. In a few cases (such as SAS internal authentication to the metadata server), the SAS server performs the check for itself. A configuration in which a SAS server trusts that another component has pre-authenticated users (for example, web authentication), is not part of SAS authentication.

**theme**

a collection of specifications (for example, colors, fonts, and font styles) and graphics that control the appearance of an application.

**web authentication**

a configuration in which users of web applications and web services are verified at the web perimeter and the metadata server trusts that verification.
# Index

| A | accessing from SAS Visual Analytics | 18 |
|   | applying a theme | 18 |
|   | administrator | 17 |

| B | base theme | 9 |
|   | SAS blue steel | 9 |
|   | SAS corporate | 9 |
|   | SAS dark | 10 |
|   | SAS high contrast | 10 |
|   | SAS light | 10 |

| C | custom report themes | 23 |
|   | custom themes | 23 |
|   | create and deploy | 6 |
|   | deleting | 13 |
|   | deploying | 12 |
|   | disabling | 14 |
|   | exporting | 16 |
|   | implementing multiple | 2 |
|   | importing | 17 |
|   | modify theme | 15 |
|   | purpose of | 1 |
|   | replace the logo | 11 |
|   | setting as the global default | 15 |
|   | undeploying | 13 |

| D | deleting themes | 13 |
|   | deploying themes | 12 |
|   | disabling custom themes | 14 |

| L | limitations of SAS Theme Designer 4.6 for Flex | 23 |

| S | SAS application themes for flex | 21 |
|   | benefits | 21 |
|   | predefined base themes | 22 |
|   | SAS Theme Designer 4.6 for Flex | 2 |
|   | benefits of using | 2 |
|   | logon prerequisites | 3 |
|   | migrate and update custom themes | 3 |
|   | what is the theme designer | 1 |
|   | who can use | 2 |
|   | scope of the SAS Theme Designer 4.6 for Flex | 1 |
|   | setting a global default theme | 15 |

| U | undeploying themes | 13 |
|   | user interface components | 22 |
|   | inheritance of styles | 22 |
Gain Greater Insight into Your SAS® Software with SAS Books.

Discover all that you need on your journey to knowledge and empowerment.

support.sas.com/bookstore for additional books and resources.

SAS and all other SAS Institute Inc. product or service names are registered trademarks or trademarks of SAS Institute Inc. in the USA and other countries. © 2015 SAS Institute Inc. All rights reserved. 201020155US.3633