SAS® Web Report Studio 4.31
User's Guide
# Contents

*About This Book* ......................................................... ix

*What's New in SAS Web Report Studio 4.31* ........................ xi

*Accessibility Features of SAS Web Report Studio* ....................... xv

## PART 1  Introduction to SAS Web Report Studio  1

**Chapter 1 • About SAS Web Report Studio** .......................... 3
- Benefits to Using SAS Web Report Studio .............................. 4
- How Does SAS Web Report Studio Work? ............................... 4
- How to Get Help for SAS Web Report Studio ............................. 5

**Chapter 2 • Managing Access to SAS Web Report Studio** .......... 7
- Access to SAS Web Report Studio Capabilities ............................ 7
- Access to Reporting Resources ............................................. 7
- Log On to SAS Web Report Studio ......................................... 8
- Log Off of SAS Web Report Studio ......................................... 9

**Chapter 3 • The SAS Web Report Studio Interface** ................. 11
- Your First Look at the SAS Web Report Studio User Interface .......... 11
- SAS Web Report Studio Menus .............................................. 13
- Overview of the Report Mode Interfaces .................................. 13
- Open Dialog Box .................................................................... 17

**Chapter 4 • Specifying Your Preferences** ............................ 25
- Overview of Specifying Preferences ......................................... 25
- Specify Preferences for Opening and Saving Reports ..................... 25
- Specify Preferences for a Data Source, Report Style, Header, and Footer .......... 26
- Specify a Preference for the Time Zone ..................................... 28

## PART 2  Introduction to Viewing and Creating Reports  31

**Chapter 5 • Viewing Reports** ........................................ 33
- Overview of Viewing Reports .................................................. 33
- Viewing Reports Created in SAS Web Report Studio .................... 34
- Viewing Stored Process Reports ............................................ 37
- Opening Data Sources Directly ............................................... 40
- Viewing Externally Created Reports ......................................... 41
- Navigating Viewed Reports .................................................... 42
- View a Summary of Applied Filters ......................................... 45
- Refreshing the Data in a Viewed Report .................................... 46
- Modifying the Data in a Viewed Report ..................................... 46

**Chapter 6 • Creating Reports** ........................................ 49
Overview of Creating Reports .......................................................... 49
Using a Quick Start Method to Create a Report ............................... 49
Use Edit Mode to Create a Report .................................................. 58
Save a Report ............................................................................. 59

PART 3 Designing Layouts 63

Chapter 7 • Designing Headers and Footers ..................................... 65
Overview of Creating a Header and a Footer for a Report Section .......... 65
About Dynamic Text in Headers and Footers ..................................... 65
Create a Header or a Footer ......................................................... 66
Remove a Header or a Footer ....................................................... 69

Chapter 8 • Adding Images and Text ............................................... 71
Overview of Using Images and Text ............................................... 71
Place an Image in a Report Section ................................................ 71
Include Text in a Report Section ................................................... 73
Format Text in Reports ................................................................ 74
Remove an Image or a Text Object ................................................ 76

Chapter 9 • Including Stored Process Output ................................... 77
Overview of Stored Processes ....................................................... 77
Insert a Stored Process .............................................................. 77
Remove a Stored Process ........................................................... 79

Chapter 10 • Positioning Objects in the Layout Grid ......................... 81
Overview of Positioning Report Objects .......................................... 81
Add Cells, Columns, and Rows to the Layout Grid ......................... 82
Align Cell Content in the Layout Grid ............................................ 82
Delete an Empty Column or Row from the Layout Grid .................. 83
Delete Objects in the Layout Grid .................................................. 83
Merge Cells in the Layout Grid ...................................................... 84
Place Objects in the Layout Grid ................................................... 84
Reposition Objects in the Layout Grid ............................................ 85

Chapter 11 • Using Synchronized Objects ....................................... 87
Overview of Synchronized Filtering, Sorting, Drilling, and Expanding .... 87
Maintain Tables, Graphs, and Geographical Maps That Are Not Synchronized . 88

PART 4 Defining Queries and Displaying Results 89

Chapter 12 • Defining Queries to Obtain Results ............................. 91
Overview of Queries Based on Data Items ....................................... 91
Using Standard Data Items in a Query .......................................... 92
Using Custom Data Items in a Query ............................................ 96
Modifying How a Data Item Is Formatted ....................................... 100
Modify How a Measure Is Aggregated ......................................... 102
Use Detail Data Instead of Grouped and Aggregated Data ............... 103
Preview or Export Query Results .................................................. 104

Chapter 13 • Subsetting Query Results ........................................... 107
<table>
<thead>
<tr>
<th>Chapter 14 • Grouping Query Results</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview of Using Group Breaks</td>
<td>125</td>
</tr>
<tr>
<td>Add Group Breaks</td>
<td>125</td>
</tr>
<tr>
<td>Remove Measure Values from Group Breaks</td>
<td>128</td>
</tr>
<tr>
<td>Remove Group Breaks</td>
<td>128</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 15 • Displaying Query Results in a Table, Graph, or Geographical Map</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview of Using Tables, Graphs, and Geographical Maps to Display Results</td>
<td>132</td>
</tr>
<tr>
<td>Using Tables to Display Query Results</td>
<td>133</td>
</tr>
<tr>
<td>Using Hyperlink Data Items</td>
<td>147</td>
</tr>
<tr>
<td>Using Graphs to Display Query Results</td>
<td>149</td>
</tr>
<tr>
<td>Using Geographical Maps to Display Query Results</td>
<td>176</td>
</tr>
<tr>
<td>Removing a Table, Graph, or Geographical Map</td>
<td>180</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>PART 5 Analyzing Results</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chapter 16 • Finding Data Items in Multidimensional Crosstabulation Tables</td>
<td>185</td>
</tr>
<tr>
<td>Overview of Finding Data Items in Multidimensional Crosstabulation Tables</td>
<td>185</td>
</tr>
<tr>
<td>Working in a Multidimensional Crosstabulation Table</td>
<td>185</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 17 • Filtering and Ranking</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>How Filtering and Ranking Can Help with Analysis</td>
<td>187</td>
</tr>
<tr>
<td>Filtering and Ranking a List Table</td>
<td>190</td>
</tr>
<tr>
<td>Filtering and Ranking a Crosstabulation Table</td>
<td>192</td>
</tr>
<tr>
<td>Filtering and Ranking a Graph</td>
<td>197</td>
</tr>
<tr>
<td>Filtering and Ranking a Geographical Map</td>
<td>200</td>
</tr>
<tr>
<td>Browsing or Searching for Filter Values</td>
<td>201</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 18 • Drilling and Expanding</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>How Drilling and Expanding Can Help with Analysis</td>
<td>207</td>
</tr>
<tr>
<td>Drill or Expand Hierarchies in a Crosstabulation Table</td>
<td>207</td>
</tr>
<tr>
<td>Drill or Expand Hierarchies in a Graph</td>
<td>208</td>
</tr>
<tr>
<td>Drill or Expand the Geographic Hierarchy in a Geographical Map</td>
<td>209</td>
</tr>
<tr>
<td>How Drilling and Expanding Affects Other Table, Graph, and Geographical Map Features</td>
<td>211</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 19 • Sorting</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>How Sorting Can Help with Analysis</td>
<td>213</td>
</tr>
<tr>
<td>Sorting Data in a List Table</td>
<td>213</td>
</tr>
<tr>
<td>Sort Data in a Crosstabulation Table</td>
<td>215</td>
</tr>
<tr>
<td>Sorting Data in a Graph</td>
<td>216</td>
</tr>
<tr>
<td>Remove All Sorting for Tables or Graphs</td>
<td>217</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 20 • Adding Total, Subtotal, and Percent of Total Calculations</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>How Totals, Subtotals, and Percent of Total Calculations Can Help with Analysis</td>
<td>219</td>
</tr>
</tbody>
</table>
Understanding the Relationship between Totals, Subtotals, and Percent of Totals .............. 220
Managing Totals and Subtotals in Tables ................................................................. 220
Managing Percent of Total Calculations in Tables .................................................. 223

Chapter 21 • Applying Conditional Highlighting ....................................................... 227
How Conditional Highlighting Can Help with Analysis ........................................... 227
Managing Conditional Highlighting for Table Values .............................................. 228
Managing Conditional Highlighting for Graph Values ............................................. 233

Chapter 22 • Displaying Information About the Data .................................................. 235
Display Data Source, Data Item, and Filter Details for a Table or a Graph ................. 235
View the Detail Data Behind the Values in a Crosstabulation Table .......................... 236
Display Field Names, Values, and Measure Information for a Region in a Geographical Map ............................................................... 238

PART 6  Managing Reports 239

Chapter 23 • Maintaining and Organizing Reports .................................................... 241
Overview of Managing Reports .................................................................................. 242
Archiving Reports ...................................................................................................... 243
Copying Reports ......................................................................................................... 246
Creating Report Templates ....................................................................................... 248
Deleting Reports and Templates ................................................................................ 249
Modifying Report Properties ..................................................................................... 250
Moving Reports ........................................................................................................... 253
Organizing Reports ..................................................................................................... 254
Rename a Report ......................................................................................................... 256
Updating Resources in a Report .................................................................................. 257
Working with Comments in a Report .......................................................................... 258

Chapter 24 • Maintaining Multi-Section Reports .......................................................... 261
Overview of Report Sections ....................................................................................... 261
Add a Section to a Report ........................................................................................... 261
Rename a Report Section ............................................................................................ 262
Copy a Report Section .................................................................................................. 263
Reorder Report Sections ............................................................................................. 264
Delete a Section from a Report ..................................................................................... 264

Chapter 25 • Sharing Reports ....................................................................................... 265
Overview of Shared Locations ..................................................................................... 265
E-mail a URL for a Report Definition Snapshot ......................................................... 265
E-mail a URL for a Report Using the File Management Window............................... 267
Publish a Report to Publication Channels ................................................................... 269
Distributing Reports ..................................................................................................... 270

Chapter 26 • Linking Reports ......................................................................................... 281
Overview of Report Linking ........................................................................................ 281
Creating a Link to a Report, a Web Page, or Another SAS Application ...................... 282
Identifying Links in Reports ......................................................................................... 288
Understanding the Run-Time Behavior of Links ........................................................ 288

Chapter 27 • Scheduling Reports .................................................................................. 291
Overview of Scheduling Reports ................................................................................ 291
Scheduling Reports, Stored Processes, and Folders .................................................. 291
View a List of Scheduled Reports .................................................. 295
Updating a Schedule .................................................................. 296

Chapter 28 • Printing and Exporting .............................................. 299
Overview of Printing and Exporting .............................................. 299
Exporting Reports and Report Data .............................................. 299
Printing Reports ........................................................................ 304

PART 7  Appendixes ................................................................. 307

Appendix 1 • Tips and Guidelines ................................................ 309
Naming Reports, Folders, and Templates ..................................... 309
Closing Dialog Boxes in SAS Web Report Studio ....................... 310
Customizing Colors .................................................................... 310
Working with Stored Process Prompts ....................................... 311
Searching for Reports and Stored Processes ............................. 311
Hiding Data Items ....................................................................... 312
Formatting Measure Data Items .................................................. 313
Creating Section Filters ............................................................... 313
Working with Conditional Highlighting ....................................... 314
Defining Prompts in Report Linking ............................................ 315
Filtering and Ranking Tables, Graphs, and Geographical Maps ... 316
Working with Text Objects, Headers, and Footers ...................... 318
Using Reports Created with a Previous Version of SAS Web Report Studio .............................................................. 319

Appendix 2 • Browsers and SAS Web Report Studio .................... 321
Browser Limitations .................................................................... 321
Using Firefox with SAS Web Report Studio .............................. 321

Appendix 3 • Data Refresh: Manual Versus Automatic .................. 323

Appendix 4 • Data Sources: Relational Versus Multidimensional .... 325

Appendix 5 • What to Do If You Are Prompted for Credentials .... 327
About the Request for Credentials .............................................. 327
Enter Credentials ...................................................................... 327
Remove Credentials .................................................................... 329
What to Do If Access Is Still Denied .......................................... 330

Appendix 6 • What to Do If Your Data Source Is Invalid ............... 331
About Invalid Data Sources and Data Items .............................. 331
When a Data Source Has Been Moved or Renamed .................... 331
When a Data Item, Filter, or Prompt Is Missing from a Report ... 331

Appendix 7 • Incomplete Tables and Graphs ................................. 333

Glossary .................................................................................... 335
Index ....................................................................................... 341
About This Book

Audience

SAS Web Report Studio is designed for the following users:

• Persons responsible for designing and creating Web-based reports for their enterprise.

• Persons responsible for analyzing report data and making decisions based on that data.

• Persons needing to explore data in support of ad hoc business questions.

You might be assigned to a specific role, which determines the tasks that you can perform. For more information, see “Access to SAS Web Report Studio Capabilities” on page 7.

SAS Web Report Studio enables you to view reports that are created by using a variety of other SAS products. This documentation focuses on tasks that you can perform on reports that were created by using SAS Web Report Studio.

Prerequisites

Here are the prerequisites for using SAS Web Report Studio:

• A user ID and password for logging on to SAS Web Report Studio.

• A supported browser installed on your desktop client.

• Access to data sources or stored processes that can be used to obtain data for reports. (These items are created in SAS applications other than SAS Web Report Studio.)

If you have questions about whether you are ready to use SAS Web Report Studio, contact your system administrator.
What's New in SAS Web Report Studio 4.31

Overview

New and enhanced features in SAS Web Report Studio 4.31 include the following:

- enhanced graph features
- new report capabilities
- enhanced productivity for users
- improved report administration
- enhanced printing capabilities

The second maintenance release of SAS Web Report Studio 4.31 contains the following changes and enhancements:

- improved tables
- new report features
- enhanced ability to send reports using e-mail
- improved exporting

Enhanced Graph Features

The following enhancements were made to graphs:

- A bubble plot has been added. This new graph type is a variation of a scatter plot in which the markers are replaced with bubbles.
- Skins are available for graphs, so that you can change the appearance.
- You can control the size of the “other” slice in a pie chart.
- You can drag and drop a second measure for a bar-line chart or a scatter plot.

New Report Capabilities

The following new capabilities are available for reports:
• For prompts, a default value is no longer required.
• Measure filters and rankings are now allowed on some synchronized objects.
• You can add row numbers to list tables using the Properties dialog box.
• Count distinct, which is a function that returns the number of distinct values for a specified column, is available in crosstabulation tables.
• The layout for the report header and footer has improved.

Enhanced Productivity for Users

The following productivity enhancements are available:
• You can copy report sections.
• Authorized users can open cubes and tables directly.
• You can now insert rows and columns between existing rows and columns in the layout grid using the vertical toolbar.
• Information map data item name changes are propagated automatically.
• The state of the left pane (either hidden or displayed) is saved between sessions.
• A new find option is available for multidimensional crosstabulation tables.
• You can now select multiple publication channels when you schedule a report.

Improved Report Administration

The following improvements have been made to report administration:
• Multiple schedules for a single report can be made by multiple users.
• Authorized users can update reports where referenced data items have been removed from an information map.
• You can pass hidden data items to a destination report for relational data.
• You can link a report to another SAS application that is passing parameters.

Enhanced Printing Capabilities

The following enhancements were made for printing:
• You can now specify that you want to print to the A3 paper size.
• Comments can be appended to printed report content.
Improved Tables

The second maintenance release of SAS Web Report Studio 4.31 contains the following table improvements:

- You can conditionally highlight rows and columns based on a category value or member.
- You can control the number of decimal places for the percent of totals.
- All members at the same level are aligned, whether or not there are child members.

New Report Features

The second maintenance release of SAS Web Report Studio 4.31 contains the following report features:

- In a report header or footer, you can associate a URL with an image. You can also display prompt values in a header or a footer.
- You can customize colors anywhere that you can change a color.
- You can display numbers and dates that are based on your browser’s regional settings.
- In graphs, you can have dual Y-axes with three or more measures.
- While viewing a report, you can switch hierarchies in the dimensions.
- You can use your current browser session to link to a non-report URL. Previously, you could only launch content in a new browser session.
- A new system option lets the Save dialog box switch to the Save As dialog box when you do not have Write Metadata permissions for the current report or folder.
- SAS Web Report Studio administrators can now create a company preferred folder as a default location for saving reports. This means that you will have Company preferred folder and My folder options, as well as other locations, when you save a report.

Enhanced Ability to Send Reports Using E-mail

The second maintenance release of SAS Web Report Studio 4.31 has enhanced your ability to e-mail reports:

- Group break values are distributed in the subject line of the e-mail message.
- You can save results and navigation automatically.
- A new system option lets you include standard text when you send the e-mail message.
• You can create a report definition snapshot, which is a customized report that is created from an original SAS Web Report Studio report and then e-mailed to a recipient. Group break information is included in a report definition snapshot.

**Improved Exporting**

The second maintenance release of SAS Web Report Studio 4.31 contains improvements to exporting:

• You can export data from individual report objects to the native XLSX output format for Microsoft Excel.

• The report name and the applied filter information are visible in exported report output.
Accessibility Features of SAS Web Report Studio

Overview

SAS Web Report Studio includes the following accessibility and compatibility features that improve usability of the product for users with disabilities. These features are related to accessibility standards for electronic information technology that were adopted by the U.S. Government under Section 508 of the U.S. Rehabilitation Act of 1973, as amended.

If you have questions or concerns about the accessibility of SAS products, send e-mail to accessibility@sas.com.

Accessibility Features of the Supported Browsers

The Web browsers that are supported for use with the SAS Foundation are also supported for use with SAS Web Report Studio. For more information, see http://support.sas.com/resources/thirdpartysupport/.

Keyboard Navigation

Standard Keyboard Navigation

SAS Web Report Studio can be navigated by using the keyboard. The following table includes some guidelines:

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard Control</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move forward through controls</td>
<td>TAB</td>
</tr>
<tr>
<td>Move backward through controls</td>
<td>SHIFT+TAB</td>
</tr>
<tr>
<td>Display drop-down list contents</td>
<td>ALT+down arrow</td>
</tr>
<tr>
<td>Display menus when they have focus</td>
<td>down arrow</td>
</tr>
</tbody>
</table>
### Task
<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard Control</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activate buttons and menu selections when they have focus</td>
<td>ENTER</td>
</tr>
<tr>
<td>Open a context menu</td>
<td>SHIFT+F10</td>
</tr>
</tbody>
</table>

### Exceptions to Standard Keyboard Navigation

In the Select Data Source dialog box, to display the contents of a subfolder, press CTRL + up/down arrow to select the subfolder and then press the right arrow key.

Web Report Studio does not follow the Microsoft Windows standard for keyboard navigation of a tabbed window. When the focus is on a tab heading, pressing the TAB key, rather than moving focus into the content of the tab, moves it to the next tab heading. Once you have cycled through the tab headings, pressing the TAB key moves the focus to the content of the tab.

### Skip Navigation

For ease of use with a screen reader, SAS Web Report Studio includes an invisible link that enables you to bypass navigation links and go directly to the unique content on the page. Navigation links that are skipped include the links for Preferences, Log Off, and Help.

When the screen reader announces that you are focused on the Skip Navigation link, press ENTER or the spacebar to activate the link.

When you select the Skip Navigation link in the Edit Report window, the page refreshes before the screen reader can focus on the focus point.

### Using SAS Web Report Studio with JAWS

#### Tables Used for Screen Layout

When tables are used for screen layout in some dialog boxes, JAWS reads the table dimensional information. To ensure that all fields are read, set your JAWS reader to read one row at a time and use the standard JAWS keystrokes for reading a table.

#### The Edit Field

When using the keyboard to navigate to the Edit field, JAWS repeats the last valid item that it was able to read before a header or a footer.
The Select Data Dialog Box

When using the **Standard** tab on the Select Data dialog box, JAWS cannot read the title of the **Available data items** list or any of the data items in the list. JAWS also cannot read the title of the **Selected data items** list or any of the data items in the list.

Navigate the Layout Grid in the Edit Tab

The **Edit** tab contains a grid for arranging objects in the body of the report section. The layout grid consists of cells into which you place report objects (tables, graphs, geographical maps, stored processes, text, and images).

Here are some keyboard shortcuts for navigating the layout grid:

- Press **ALT+Y** to move forward between the cells. When a cell has focus, press **ENTER** to select it.
- Press **ALT+Q** to navigate between report objects. When an object has focus, a pop-up context menu is available for other actions.

In general, use **TAB** and **SHIFT+TAB** to move through the controls to perform actions on the selected cells and objects.

High-Contrast and Custom Color Styles

There is intermittent support for high-contrast and custom color styles in SAS Web Report Studio.
Part 1

Introduction to SAS Web Report Studio

Chapter 1
   About SAS Web Report Studio ........................................... 3

Chapter 2
   Managing Access to SAS Web Report Studio ............................ 7

Chapter 3
   The SAS Web Report Studio Interface .................................. 11

Chapter 4
   Specifying Your Preferences .............................................. 25
Chapter 1
About SAS Web Report Studio

What Is SAS Web Report Studio?

In most organizations, many information consumers need reports from business data, but relatively few people understand the data structures necessary to build the reports. SAS Web Report Studio bypasses the need to understand complex data structures. SAS Web Report Studio provides an intuitive user interface that enables users at all technical skill levels to create, view, and explore centrally stored reports.

Easy querying
Specially prepared information maps (which are data sources in SAS Web Report Studio) provide a metadata (information) layer between the nontechnical business user and the complexities of database structure and query languages. Authorized users that might be more advanced can access tables and cubes directly. All data sources contain data items, which can refer to calculations or physical data (tables or cubes). Data items in information maps are described in common business terms that enable both casual and professional report authors to easily build queries that return consistent results. Reports can include query results from more than one data source.

Easy report design
The casual report author can use the five-step Report Wizard to design a basic report layout with one table and one graph. More advanced report authors can use the full-featured report editor to design more complex layouts, choosing from two different types of tables and eight different types of graphs. In addition, headers, footers, images, and text can be used to include corporate standards, confidentiality messages, and even hyperlinks in the report. Reports can contain multiple sections. Reports can be rendered as needed for one-time use or stored in a common repository for personal or shared access.

Easy analysis
Report authors can design reports that, by default, filter, rank, and highlight the query results based on specified conditions. These features and others are available to report viewers, who can select options from menus and toolbars to customize the
default output. Additional options that can help you analyze report data include
drilling and expanding, sorting, and creating percent of total calculations.

Other basic reporting tasks include printing, copying, moving, and exporting. Advanced
tasks include scheduling reports to run at a specified time (or times) and distributing
reports via e-mail as a PDF attachment or as an embedded HTML file.

**Benefits to Using SAS Web Report Studio**

SAS Web Report Studio provides users with the following benefits:

Empowers business users by giving them self-service access to query and reporting
capabilities

SAS Web Report Studio includes functionality designed to fit your needs by
providing easy access to accurate information. The product interface enables you to
create your own queries and generate your own reports. You can also include on-
demand analytical results without having to create sophisticated statistical models.

Improves the business value of IT and the corporate data that it manages

SAS Web Report Studio provides you with easy, self-service access to corporate
data. The risk of inconsistent results is eliminated, and business managers get
reliable information that they can trust.

Saves money on training and support costs

SAS Web Report Studio is so simple that you can quickly become self-sufficient.
Minimal IT support is required for the product, and there is no need for extensive
training. Once you start using the product, you will no longer be dependent on the IT
staff to create reports for you. Even if you and your co-workers are in different
geographic locations, you get consistent results.

**How Does SAS Web Report Studio Work?**

SAS Web Report Studio is a Web application that anyone can use to view, interact with,
create, and distribute public and private reports. Simply open an existing report and
interact with the information based on your current needs. For example, you can view,
reply to, or add comments to a report. Report authors can easily point and click to query
central sources of data. Optionally, you can add prompts and design the layout of tables,
graphs, and text using drag and drop to create a well-formatted report. All this is
accomplished by using a Web browser. You do not need to understand a programming
language. Periodic reports can be scheduled to process unattended on a recurring basis
and then optionally distributed using e-mail.

In addition, powerful SAS analytical results can be used by business professionals across
an organization through their Web browsers by leveraging SAS stored processes in SAS
Web Report Studio. *Stored processes* are SAS programs, created by business analysts
who are proficient in SAS, that contain instructions for calculating analytical results that
are rendered as part of a report or as a complete report. Stored processes typically
include queries, prompted filters, titles, images, and statistical analyses to deliver
predictive analytics to a large audience. SAS Web Report Studio combines query,
reporting, and analytical capabilities in a single Web-based tool that everyone can use to
meet a broad set of information needs.
The Report Wizard enables novice users to quickly create and distribute basic queries and reports based on either relational or multidimensional data sources in five easy steps. More advanced users can use additional layout and query capabilities that are available, including the ability to define custom calculations and complex filter combinations, multiple queries, and SAS analytical results into a single document. A gallery of predefined layout choices expedites the report creation process, and an extensive range of advanced report components enables users to create and interact with reports from their Web browsers. Reports and the application can be branded to match a corporate style.

Reports can be shared with others or kept in private folders based on security settings. Certain pages of reports can be distributed to authorized users via e-mail or a subscription channel.

How Does SAS Web Report Studio Fit into the SAS Intelligence Platform?

As an integral part of the SAS Intelligence Platform, SAS Web Report Studio leverages the analytical power of SAS by using the common SAS Open Metadata Architecture, which reduces administration tasks, and SAS Management Console, which grants access to reports and data. SAS Web Report Studio uses SAS Information Maps, which are a business view of data created by SAS Information Map Studio, so that you do not have to understand complex data structures and databases. At the same time, SAS Web Report Studio ensures that enterprise data is used consistently. SAS Web Report Studio can leverage the work of analytical SAS tools, such as SAS Enterprise Guide, which makes it easy for a wide range of users to access SAS analytical intelligence. SAS solutions, which are domain-specific applications that are built on the SAS Intelligence Platform, leverage SAS Web Report Studio for reporting.

How to Get Help for SAS Web Report Studio

There are two ways to access Help from within SAS Web Report Studio:

- Select Help ➤ Contents or Help ➤ Using this Window.
- Click Help, which is available from any SAS Web Report Studio dialog box or wizard page.

You can also find information about SAS Web Report Studio on the SAS Customer Support site at http://support.sas.com/software/products/wrs/. The product page includes information about documentation, training, samples and notes, and a link to the SAS Web Report Studio customer forum.
Access to SAS Web Report Studio Capabilities

Different users might have access to different functionality depending on their assigned roles. Roles are mapped to capabilities. A capability, also known as an application action, defines the operations a user can perform.

SAS Web Report Studio ships with three predefined roles — Report Viewing, Report Creation, and Advanced. A predefined set of capabilities is available for each role. Using SAS Management Console, a system administrator can modify these roles and specify the capabilities that meet the guidelines for your company. They can also define new roles. If you have questions about your assigned role, contact your system administrator.

For more information about the roles and capabilities that are available, see the SAS Web Report Studio information in SAS Intelligence Platform: Web Application Administration Guide.

Note: This user's guide discusses tasks that you might or might not be able to perform depending on your role.

Access to Reporting Resources

Your SAS Web Report Studio role controls which application behavior is available. Metadata security on individual objects (data, reports, folders, or even servers) controls access to those objects. For example, your role might enable you to perform the task of e-mailing reports, but you can e-mail only those reports to which you have been granted access.
Here are two examples of how data security might affect what an individual SAS Web Report Studio user can see and do:

- In a report that includes employee information, two users in the same role might not see the same output. For example, a user in the human resources department might have access to a salary column that cannot be seen by a user in the sales department who views the same report.

- In a data source that contains information about medical procedures, a user with the capability to create new reports might not have access to the data item for patient names.

If you have questions about data security, contact your system administrator.

---

**Log On to SAS Web Report Studio**

SAS Web Report Studio uses the standard log on window for SAS applications. To log on to SAS Web Report Studio, complete these steps:

1. To display the SAS Web Report Studio logon window, click on the URL that is supplied by your system administrator or paste it into the address field of your browser. For example, you might enter `http://server01.abc.com:8080/SASWebReportStudio/`:

   ![Log On Window for SAS Web Report Studio](image)

2. To log on, complete these steps:
   a. In the **User ID** field, type your user ID.
   b. In the **Password** field, type the password for the user ID that you just entered.
   c. Click **Log On**.

   The Welcome to SAS Web Report Studio window appears (see “Your First Look at the SAS Web Report Studio User Interface” on page 11).
Log Off of SAS Web Report Studio

To log off of SAS Web Report Studio, click **Log Off** in the upper right corner of the user interface.

*Note:* When you select **Log Off**, you will be logged off all environments, including the SAS OLAP server and other Web environments.

If you are prompted about unsaved changes, click **OK** to exit without saving or click **Cancel** to return to SAS Web Report Studio. In SAS Web Report Studio, select **File** ➝ **Save**. If you are saving a new report, you are prompted to complete the Save As dialog box. Click **Log Off** again to exit.

If you lose your connection to SAS Web Report Studio (for example, your session times out), then you must begin again at the point where you last saved your work. By default, if there is no activity for 30 minutes, then SAS Web Report Studio automatically logs you off and displays the logon window. Your system administrator can change the inactivity period and whether the **Log On** button is available. As a best practice, save your work frequently.

The following is an example of the message that appears when your session has timed out:

**Display 2.2 Session Timed Out Message for SAS Web Report Studio**
Chapter 3
The SAS Web Report Studio Interface

Your First Look at the SAS Web Report Studio User Interface

After you log on to SAS Web Report Studio, you see the Welcome window. Here are the main features of the Welcome window.
1 Click Log Off to exit SAS Web Report Studio.

2 Click Preferences to personalize your use of SAS Web Report Studio.

3 Select the Help menu to get help on using SAS Web Report Studio. For more information, see “How to Get Help for SAS Web Report Studio” on page 5.

4 Click New report to create a new report using the Edit tab. For more information, see “Edit Mode Interface” on page 15.

5 Click New Using Report Wizard to access the Report Wizard. The wizard guides you in defining a query; selecting a table and graph for the layout; and adding optional features such as group breaks, a header, and a footer. For more information, see “Use the Report Wizard” on page 51.

6 Click New Using Template to access the Select a Template dialog box. When you select a template, you start creating your report with a predefined layout.

7 Click Available Reports to access the Open dialog box. The Open dialog box enables you to search for reports, and it lists reports, stored processes, folders, and data sources. For more information, see “Open Dialog Box” on page 17.

Once you have viewed a data source or created a report, you will see More Reports, which lets you access the Open dialog box.

8 Click Open to access the Open dialog box. The Open dialog box enables you to search for reports, and it lists reports, stored processes, folders, and data sources. For more information, see “Open Dialog Box” on page 17.

Once you have viewed a data source or created a report, you will see a list of reports and data sources under Open. You can double-click the report or data source to open it.

9 Click New to create a new report using the Edit tab. For more information, see “Edit Mode Interface” on page 15.
Select the **File** menu to access task options, such as **Open** and **Manage Files**.

---

**SAS Web Report Studio Menus**

**About the Availability of Menus and Menu Selections**

All of the following conditions influence whether a menu or menu selection is available to use:

- **Your authorization.** For example, you must be an advanced user to schedule or distribute reports. The options that you have can also depend on settings that your system administrator has selected.

- **Your location in the SAS Web Report Studio application.** For example, some tasks are available only if you are viewing a report.

- **The type of report that you are viewing.**

- **The currently selected object.** For example, you cannot change a bar chart to a crosstabulation table.

- **Whether the section query has been defined.** For example, if the section query has not been defined, then you cannot create a section filter.

- **The type of data that is being used.** For example, you cannot use detail data if the report section is using multidimensional data.

- **Whether the report is saved.** For example, you cannot distribute a report that has not been saved.

**About the Report Menus**

The report menus contain options that apply to the entire report or to the currently displayed report section, including the objects in the section. Actions include creating a new report, adding a new section, refreshing data, and synchronizing a section. The report menus are available on the main menu bar when a report is displayed. For more information about the report menus and menu items, see the SAS Web Report Studio online Help.

---

**Overview of the Report Mode Interfaces**

Your role and the associated capabilities determine the report mode, as well as which features you can access in SAS Web Report Studio. For example, report viewers do not have the ability to access Edit mode. For more information about capabilities, see “Managing Access to SAS Web Report Studio” on page 7.

**View Mode Interface**

This is the mode that all SAS Web Report Studio users can see. View mode displays the output of a saved report. Users who are authorized to create and edit reports can also use View mode to preview new, unsaved reports.
The following figure is an example of a report displayed in View mode. The report contains query results from a multidimensional data source. The main features of this specific report and the View tab are identified.

**Figure 3.2** The View Mode Interface

1. Select the File, View, or Data menu items to access options that apply to the entire report or to the currently displayed report section, including the objects in the section.
2. Use these icons to create a new report, open an existing report, save the current report, print the current report, or export the current report.
3. Authorized users can click the Edit tab to open the viewed report in Edit mode.
4. The View tab is on top when View mode is active.
5. This icon indicates that one or more comments are associated with the report.
6. This icon indicates that the objects in this report section are synchronized.
7. This navigational box indicates the section that you are editing, as well as the total number of sections in the report. To view a different section, either enter a number in the box or select View ➔ Section and select the section that you want to open.
8. The body contains the report.
9. Use the Section Data panel to select data and to view an indicator of whether objects are synchronized. This panel can be collapsed horizontally.
10. Use the Table of Contents panel to work with both sections and group breaks. This panel can be collapsed horizontally.

In View mode, you can drag a data item from the Section Data pane and drop it onto tables and graphs.

*Note:* Some reports require that you answer prompts before their output is rendered.
**Summary: Seven Ways to Access View Mode**

There are seven ways to access View mode:

- Click **Open** in the SAS Web Report Studio Welcome window.
- Select a report name in the SAS Web Report Studio Welcome window.
- Select **File ⇒ Open** to display the Open dialog box. Select a file and then click **Open** to display it in the **View** tab.
- Select **File ⇒ Open Recent** and then select the name of an existing report, information map, table, cube, or stored process to display it in the **View** tab.
- Click **View** when editing a report to display it in View mode.
- Select an existing report, information map, table, cube, or stored process in the **File Management** window.
- Navigate to a report using a link from another report.

**Edit Mode Interface**

Authorized users can access the **Edit** tab to create new reports or to edit existing reports. Note that some options in Edit mode are not available for reports and stored processes that come from SAS Enterprise Guide. The available options in Edit mode also depend on the type of report that you are editing.

Here are some of the main features of the **Edit** tab and Edit mode.

*Figure 3.3  The Edit Mode Interface*

1. Select the **File, Edit, View, Insert, or Data** menu items to access options that apply to the entire report or to the currently displayed report section, including the objects in the section.
2. Use these icons to create a new report, open an existing report, or save the current report.
3. The **Edit** tab is on top when Edit mode is active.
4 Click View when you are ready to view the report.

5 This navigational box indicates the section that you are editing, as well as the total number of sections in the report. To view a different section, either enter a number in the box or select View ➔ Section and then select the section that you want to open. You can also use the drop-down box in the Table of Contents panel to select a section.

6 Use this horizontal toolbar to insert objects (such as tables, graphs, geographical maps, stored processes, text, and images).

7 Click Header to enter header information for the report section. For more information, see Chapter 7, “Designing Headers and Footers,” on page 65.

8 The body of the report section consists of a grid for arranging objects such as tables, graphs, and images, and two toolbars (one above the grid and one to the left of the grid). For more information, see “Overview of Positioning Report Objects” on page 81.

   The body of the report can also include stored process objects that are used to obtain data and layout information for the report section.

9 Click Footer to enter footer information for the report section. For more information, see Chapter 7, “Designing Headers and Footers,” on page 65.

10 Use the Section Data panel to select data and to specify whether objects are synchronized. This panel can be collapsed horizontally. An Options menu enables you to select data and to specify whether the objects are synchronized. You can also work with section filters. The Section Filters menu option is always available for relational data. The option is available for multidimensional data only if the filters were predefined in SAS Information Map Studio.

   After you select the data items, a context menu is available. Depending on the type of data source, you can use this menu to specify the format and data item properties. You might also be able to select or define filters and change the default format.

   For more information about defining a query that uses data items, see Chapter 12, “Defining Queries to Obtain Results,” on page 91.

11 Use this vertical toolbar to delete and align objects and to merge, split, and add cells to the layout grid.

12 Use the Table of Contents panel to work with sections and to switch between sections. Use the Options menu to add new sections and rename, delete, or reorder existing sections. This panel can be collapsed horizontally. For more information, see Chapter 3, “The SAS Web Report Studio Interface,” on page 11.

   If you select data items from a data source to define a query for the report section, then you might be able to specify group breaks for the report section. For more information, see Chapter 14, “Grouping Query Results,” on page 125.

In Edit mode, you can drag report and graph objects and drop them onto the layout grid.

**Summary: Six Ways to Access Edit Mode**

There are six ways to access Edit mode:

- Click New report in the Welcome window.
- Click New using Report Wizard in the Welcome window. After at least one data item is selected, click Finish on any wizard page to access Edit mode.
• Click **New using Template** in the Welcome window to select a report template from a gallery and display it in the **Edit** tab.

• Click **Edit** when a report is displayed in View mode.

• Select **File ⇒ Open** to display the Open dialog box. Next to the name of a report, click [ ] in the **Actions** column, and then select **Edit**.

• From the Welcome window or while editing a report, select **File ⇒ Manage Files** to access the File Management window. Navigate to the report that you want to edit. Next to the name of the report, click [ ] in the **Actions** column, and then select **Edit**.

---

**Open Dialog Box**

**Using the Open Dialog Box as a Multitask Interface**

**About the Open Dialog Box**

The Open dialog box enables you to search for and open saved reports, stored processes, information maps, tables, and cubes. For more information about searching for reports, see “View a Saved Report” on page 34.

However, the Open dialog box also enables you to create new folders and perform many other tasks on selected reports and folders.

**Note:** You must be assigned the applicable capabilities to copy, move, or delete multiple reports or folders or to open data sources. If you have questions about capabilities, contact your system administrator.

**Display 3.1**  Open Dialog Box
Searching Using the Open Dialog Box

You can search for reports, stored processes, information maps, tables, or cubes using the Open dialog box.

Note: There is also a Search for files section available in the File Management window, as shown in Display 5.1 on page 35.

Display 3.2 Open Dialog Box with the Search for Files Section Expanded

To search for files, complete these steps:

1. If the Search for files section is not visible in the Open dialog box, click ➔.

2. In the Search for field, type the text for which you want to search. For searching tips, see “Searching for Reports and Stored Processes” on page 311.

3. In the Search what drop-down list, choose whether you want to search for the text in the Name, Description, or Keywords field.

   Note: You cannot search the content of a report or a stored process.

4. In the Search where drop-down list, select a folder name.

5. (Optional) To also search for reports in folders that are contained in the folder that you are searching, select Search subfolders.

6. (Optional) To limit your search by time, select Search for Files Modified in the Date/time limits drop-down list. Specify the time frame by using the fields that are below the drop-down list.

7. Click Search. Any reports or stored processes that match your criteria are shown.

   Note: After a search, the report list also includes Path information for each located report. To clear the search results, select an option in the Location drop-down list.

The following topics contain additional information about searching:

• “View a Saved Report” on page 34.
Navigating Locations Using the Open Dialog Box

The Open dialog box enables you to navigate to find the information map, report, table, cube, or stored process that you need. For example, you might need to navigate through multiple folders to find a report. Click for the Location to see where the current folder is located in the tree structure.

Click to move up a folder level. In the following example, you are looking at the items in the Orion Star Sports folder after you have moved up one level.

Display 3.3  Open Dialog Box Showing Current Location

Working with Folders in the Open Dialog Box

You can work with folders in the Open dialog box. The icons for folders are located to the right of the Location drop-down list, as shown in Display 3.3 on page 19.

<table>
<thead>
<tr>
<th>Button</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>moves up one level</td>
</tr>
<tr>
<td></td>
<td>creates a new folder</td>
</tr>
<tr>
<td></td>
<td>refreshes the items in the current location</td>
</tr>
</tbody>
</table>

You can also create a new folder when you copy a report, move a report, or save a report. For more information about folders and shared locations, see “Overview of Shared Locations” on page 265.
Using the Actions Menu in the Open Dialog Box

To open the Actions menu, click ![Actions](image). The menu lists only those options that you are authorized to perform. For example, in the folders shown here, the actions are **Delete** and **Rename**.

Display 3.4  Actions Menu for Folders in the Open Dialog Box

Different actions are available for reports. The menu lists only those options that you are authorized to perform.
The following display shows some of the actions that might appear for reports.

**Display 3.5  Actions Menu for Reports in the Open Dialog Box**

The **Edit**, **Copy**, **Delete**, and **Move** options are also available from the File Management window.

When you are working with data sources (either information maps, tables, or cubes) in the Open dialog box, the available actions are different from the ones available for reports.
The following display shows an action that might appear for an information map.

**Display 3.6  Actions Menu for Information Maps in the Open Dialog Box**

Depending on your capabilities, you might be able to edit a table or cube from the Open dialog box.

The following display shows an action that might appear for a table.

**Display 3.7  Actions Menu for Tables in the Open Dialog Box**
Summary: Four Ways to Access the Open Dialog Box

There are four ways to access the Open dialog box:

- Click on the toolbar.
- Click Open in the Welcome window.
- Click More Reports in the Welcome window.
- Select File ➜ Open in the Welcome window or in Edit or View mode to display the Open dialog box.
Overview ofSpecifying Preferences

In SAS Web Report Studio, you can specify defaults for opening, saving, and creating reports, as well as for your time zone. The Preferences dialog box enables you to view and change your preferences only for new reports. Changes to preferences do not affect existing reports or the report that is currently open.

Specify Preferences for Opening and Saving Reports

To specify preferences for opening and saving reports, complete these steps:

1. Click Preferences in the right corner of the user interface to open the Preferences dialog box.
2. On the General tab, complete these steps:
   a. Under Open, specify the folder that is open by default when you access the Open dialog box or the File Management window. The default is Last folder used. If you choose Your Preferred folder, then select the folder.
   b. Under Save, specify the folder that you want selected by default in the Save As dialog box when you save a new report. The default is Company preferred folder, if your administrator has set this property for your company. Otherwise, the default is Last folder used. If you choose Your preferred folder, then select the folder.
c. Select one of the **Save reports as** options for new reports. By default, new reports are saved as automatically refreshed. You can change your preference for specific reports when you save them.

   *Note:* For more information, see “Data Refresh: Manual Versus Automatic” on page 323.

3. Click **OK**.

   Your preferences are used the next time you open or save a report.

   *Note:* To restore all of the options on the **General** tab to their default settings, click **Reset Defaults**.

---

**Specify Preferences for a Data Source, Report Style, Header, and Footer**

To specify a default data source, report style, header, and footer for new reports, complete these steps:

1. Click **Preferences** in the right corner of the user interface to open the Preferences dialog box.

2. On the **Report Creation** tab, complete these steps:

   a. Select **Preferred data source**. Navigate to the folder that contains your data source, and then select the information map, table, or cube that you want to use. The default is **Last data source used**.

      *Note:* You cannot select a folder.
b. From the Report style drop-down list, select the default style for creating new reports. The style that you select affects the color and font text of report objects such as tables and graphs. The four styles that are shipped with SAS Web Report Studio are Plateau (the default), Seaside, Festival, and Meadow.

Note: You can also use the Report Properties dialog box to change the style of an individual report. For more information, see “Modifying Report Properties” on page 250.

c. For the Section header and Section footer, select one or both of the following options. Header and footer preferences are used for all sections of a new report.

Banner
Select the name of the image that you want to include in the header or footer. The list contains images that have been prepared for you by your system administrator. If you do not want to include an image in the header or footer, then select None. (If your system administrator did not make any images available, then None is your only choice for Banner.)

Text
Type the static text that you want to include in the header or footer.

Note: For individual report sections, you can override header and footer preferences. For more information, see Chapter 7, “Designing Headers and Footers,” on page 65.

3. Click OK.

Your preferences are used the next time you create a new report.

Note: To restore all of the options on the Report Creation tab to their default settings, click Reset Defaults.

Display 4.2 Report Creation Tab
Specify a Preference for the Time Zone

Your time zone preference is used when SAS Web Report Studio performs an action that involves time. For example, when you save a new report, your preference is used to assign the date and time of its creation. Your preference is also used when a header or footer includes the dynamic text option called Date the data was last refreshed. The displayed refresh date and time are based on your preference.

To specify a default time zone, complete these steps:

1. Click Preferences in the right corner of the user interface to open the Preferences dialog box.

2. On the Time Zone tab, complete these steps:
   a. If the zone that you want to use is not in the Time zone drop-down list, then select the Choose from all possible time zones check box.
   b. From the Time zone drop-down list, select the time zone that you want to use. For example, you might select (GMT–8:00) Pacific Standard Time.
   c. From the Zone ID drop-down list, select one of the IDs that are available for the time zone that you specified. Each time zone has a list of associated IDs. Most of the zone IDs are in the form Area/Location, where Area is a continent, a country, or an ocean and Location is a major population area within the specific location.

      For example, if you select (GMT–10:00) Hawaii Standard Time as the time zone, then you might select (GMT–10:00) Pacific/Honolulu as the zone ID. Other zone IDs in the (GMT–10:00) Hawaii Standard Time zone include (GMT–10:00) Pacific/Johnson, (GMT–10:00) System/VHST10, and (GMT–10:00) US/Hawaii.

3. Click OK.

Your preferences are used the next time SAS Web Report Studio performs an action that involves time.

Note: Changing the time zone does not affect reports that you manually refresh.

In the following display, (GMT+08:00) Western Standard Time (Australia) is selected for the Time zone and the Zone ID drop-down list shows (GMT+08:00)
Antarctica/Casey. The two other available zone IDs are (GMT+08:00) Australia/Perth and (GMT+08:00) Australia/West.

Display 4.3 Time Zone Tab with Preferences Specified
Part 2

Introduction to Viewing and Creating Reports

Chapter 5
Viewing Reports .................................................. 33

Chapter 6
Creating Reports .................................................. 49
Overview of Viewing Reports

Overview of Viewing Reports

The output that can be displayed in View mode can be placed into these four report categories:

Saved Reports
- Saved reports are created by completing the Save As dialog box in SAS Web Report Studio.

Stored Process Reports
- When a stored process is opened directly, it is a stored process report.

Opening Data Sources Directly
- Data source reports are ad hoc reports that use either a list table or a crosstabulation table to present information from a data source.
Externally Created Reports
SAS Web Report Studio enables users to view and, in some cases, modify reports that are created by using a variety of other SAS products, including SAS Enterprise Guide and SAS Output Delivery System (ODS).

This chapter explains how to view each type of report and includes sample output.

---

Viewing Reports Created in SAS Web Report Studio

About Reports Saved in SAS Web Report Studio

Reports in SAS Web Report Studio are saved when you use the Save As dialog box. A saved report contains at least one section. Typically, that section uses at least one query method (data items from a data source or a stored process). If data items are used, then the section has at least one view element (a table, graph, or geographical map) to display the results of the query.

A report might be automatically or manually refreshed, shared or private, or read-only (which means that only the report author can make changes to it). It might also be prompted (which means that users must answer prompts before the report is rendered).

View a Saved Report

To view a saved report, you can select one of the last six viewed reports from the File menu or the Welcome window, or use the Open dialog box or the File Management window.

To use the Open dialog box or the File Management window, complete these steps:

1. Perform one of these tasks:
   - Select a report from the Welcome window, which also shows the last six viewed reports. If you are editing or viewing a report, select File ⇒ Close to display the Welcome window.
   - Select File ⇒ Open to display the Open dialog box.
   - Select File ⇒ Manage Files in the Welcome window or in either Edit or View mode.

   The Open dialog box and the File Management window contain a Search for files section that can be expanded or collapsed at the top of the window.
2. Double-click the name of a saved report to open it in View mode. Next to the name of the report, you can also click in the Actions column and then select Edit.

If you want to search for a report, complete these steps:

a. If the Search for files section is not visible, click .

b. In the Search for field, type the text for which you want to search. For searching tips, see “Searching for Reports and Stored Processes” on page 311.

c. In the Search what drop-down list, choose whether you want to search for the text in the Name, Description, or Keywords field.

   Note: You cannot search the content of a report or a stored process.

d. In the Search where drop-down list, select a folder name.

e. (Optional) To also search for reports in folders that are contained in the folder that you are searching, select Search subfolders.

f. (Optional) To limit your search by time, select Search for Files Modified in the Date/time limits drop-down list. Specify the time frame by using the fields that are below the drop-down list.

g. Click Search. Any reports or stored processes that match your criteria are shown.

   Note: After a search, the report list also includes Path information for each located report. To clear the search results, select an option in the Location drop-down list.

3. If necessary, respond to prompts and then click View Report.

Tip: If the currently displayed report section includes output from a stored process, you can select Help ➤ View Log to view a log for the stored process.

**Example Report: Product Group Revenue Contributions by Age**

The following display provides information about product group revenue and includes percentage contributions by order channel, gender, and age group. Exceptional
conditions are highlighted for product group and age group combinations for a given channel when the revenue contribution is less than 5% or greater than 8%. For example, this information could be used to decide which age groups to target for a promotional offering.

**Display 5.2  Example of a Saved Report that Contains Conditional Highlighting**

For both multidimensional and relational data, you can hide a data item from the table or graph. For example, in the company report here, the data item for *Country* is hidden. You can hide data items by right-clicking in a table or graph and selecting **Hide** from the context menu or you can use the Assign Data dialog box.
Display 5.3  Assign Data Dialog Box with a Hidden Data Item Selected

Viewing Stored Process Reports

About Stored Process Reports

A stored process is a SAS program that is stored on a server and that can be executed as requested by client applications such as SAS Web Report Studio. The embedded SAS code can contain instructions for rendering report elements as part of a larger report or for rendering a complete report that includes queries, prompted filters, titles, images, and statistical analyses. When a stored process is viewed directly in SAS Web Report Studio, it is a stored process report. Stored process reports contain only one section and are automatically refreshed. All users can run a shared stored process.

Note: Stored processes can also be included as part of a larger saved report. For more information, see Chapter 9, “Including Stored Process Output,” on page 77.

A stored process might be prompted, which means that users must answer prompts before the report is rendered. Authorized users can schedule a stored process report.

View a Stored Process Report

To view a stored process, you can select one of the last four viewed stored processes from the File menu, use the Open dialog box, or use the File Management window.

Note: Your data source administrator determines what data you are authorized to view.

To use the Open dialog box or the File Management or Welcome windows, complete these steps:

1. Perform one of these tasks:
   • Select File $\Rightarrow$ Open to display the Open dialog box.
• Select **File ➪ Manage Files** in the Welcome window or in either Edit or View mode.

The Open dialog box and the File Management window contain a **Search for files** section and a list of reports, stored processes, and folders.

**Display 5.4 File Management Window with Stored Processes Listed**

2. Double-click a stored process to view it. If you want to search for a stored process, complete steps 2a through 2g in “View a Saved Report” on page 34.

3. If necessary, respond to prompts and then click **View Report**.

4. (Optional) To view a log for the stored process, select **Help ➪ View Log**.

**Example Report: Sales Forecast for Orion USA**

The following example of a stored process report uses the predictive capabilities of SAS to give executives a glimpse into the company’s financial future. After the user enters preferences for the country, forecast variable (cost, profit, or sales), and the number of months to forecast, SAS Web Report Studio displays a line plot by month, including confidence intervals, and a supporting list table with values for the year, month, actual
sales, forecast, lower 95%, and upper 95%. The prompt window for this stored process is shown in the following display.

**Display 5.5**  Prompt Window for the Stored Process Report Shown in Display 5.6

![Prompt Window](image)

**Display 5.6**  Example of a Stored Process Report

![Sales Forecast](image)

**T I P** Some stored process reports might support chart tips, tooltips, and drilling. *Chart tips* contain data details and appear when you move the mouse over particular areas on a graph. For example, moving the mouse over the bars in a bar chart displays the data values associated with the bars. *A tooltip* is a small pop-up informational element displayed when the user positions the mouse over a chart element.

Other than changing prompt values, you cannot modify the output of a stored process from within SAS Web Report Studio. For information about how to insert a stored process into a report, see “Insert a Stored Process” on page 77. If you insert a stored process into a report, you can perform some layout design tasks that are independent of the stored process report. For example, you can add images, headers, and footers.
Opening Data Sources Directly

Note: Your data administrator determines what data sources you are authorized to view.

Data source reports are ad hoc reports that use either a list table or a crosstabulation table depending on the type of data. The following table shows the different data sources and the type of table that is used for an ad hoc report.

<table>
<thead>
<tr>
<th>Data Source</th>
<th>Associated Icon</th>
<th>Type of Table</th>
</tr>
</thead>
<tbody>
<tr>
<td>Relational information map</td>
<td>![icon]</td>
<td>A summarized list table that is based on a system default query or a default query that is set up by your data administrator</td>
</tr>
<tr>
<td>Multidimensional information map</td>
<td>![icon]</td>
<td>A crosstabulation table that is based on a system default query or a default query that is set up by your data administrator</td>
</tr>
<tr>
<td>Table</td>
<td>![icon]</td>
<td>A detailed list table including all underlying columns*</td>
</tr>
<tr>
<td>Cube</td>
<td>![icon]</td>
<td>A crosstabulation table that is based on a system default query</td>
</tr>
</tbody>
</table>

* When detail data is used, you cannot insert a crosstabulation table or any graphs except for scatter and bubble plots. To use a crosstabulation table and the other graph types, select Data ⇒ Summarization Options in Edit mode, and select the Summarize similar rows (Aggregated data) option.

To open a data source directly, complete these steps:

1. Double-click an information map, table, or cube in the Open dialog box. The ad hoc report opens in View mode.

Display 5.7 Example of a Data Source Report Based on a Multidimensional Information Map

![Example of a Data Source Report Based on a Multidimensional Information Map]
2. Select File ⇒ Save. For information about how to complete the Save As dialog box, see “Save a Report” on page 59.

TIP This is one of the quick start methods for creating a new saved report. For more information, see “About the Quick Start Methods” on page 49.

---

**Viewing Externally Created Reports**

SAS Web Report Studio enables users to view and, in some cases, modify reports that are created by using a variety of other SAS products, such as SAS Enterprise Guide. You view a shared, externally created report in the same way that you view a saved report.

There is no definitive list of default features for an externally created report because the features depend on the application that was used to create the report. Some externally created reports support the same features as a saved report. Other reports, such as those created by using SAS Enterprise Guide, cannot be modified, although report authors can use SAS Web Report Studio for very limited reporting operations, such as adding new sections. The added sections will support the standard editing features.

**Note:** Using SAS Management Console, a system administrator can add content from directories or external files, including PDF output. Contact your system administrator if you need PDF output uploaded to a location that is visible to SAS Web Report Studio.

SAS Web Report Studio supports the ability to open PDF output, including that which is generated from the SAS Output Delivery System (ODS). If the PDF output is visible to SAS Web Report Studio, then complete these steps:

1. To access the PDF output, perform one of these tasks:
   - Select File ⇒ Open to display the Open dialog box.
   - Select File ⇒ Manage Files in the Welcome window or in either Edit or View mode to display the File Management window.

   The Open dialog box and the File Management window contain a list of PDF output.
2. Double-click the PDF filename and the PDF output opens in a separate window.

SAS Web Report Studio opens PDF output in a separate window. However, certain output from ODS, which is similar to output from SAS Enterprise Guide, opens in a SAS Web Report Studio window.

Navigating Viewed Reports

About Navigation Features

A report might have these navigation features:

- Group breaks divide report sections by distinct category or hierarchy level values. A table of contents is available for navigation.
- A report might be divided into one or more sections. Each section can use a different query method and have a different layout.
- A report might include links to another report or to a Web page.

Use the Navigation Pane

The navigation pane on the left contains both the Table of Contents and Section Data panels. You can use the Table of Contents panel to work with sections and to switch between sections. You can use the Section Data panel to select data and to specify whether objects are synchronized.

To collapse the Table of Contents panel, click ⬇️.
The following display shows an example of a collapsed Table of Contents panel.

**Display 5.10**  Collapsed Table of Contents Panel

To expand the Table of Contents panel, click .

To collapse the navigation pane, which contains both the Table of Contents and the Section Data panels, click .

The following display shows an example of the collapsed navigation pane.

**Display 5.11**  Collapsed Navigation Pane
To expand the navigation pane, which contains the Table of Contents and Section Data panels, click >>.

The following display shows an example of the expanded navigation pane.

Display 5.12  Expanded Navigation Pane

If you view a different section and then return to a section that contains group breaks, SAS Web Report Studio displays the most recently viewed group break category.

**View Different Report Sections**

A report can be divided into one or more sections. Each section can use a different query method and have a different layout. To view a report section, complete either of these tasks:

- Use the navigational box in the right corner. Enter a number in the box to change sections.
- Select View ➪ Section and then select the section that you want to open.
- Use the drop-down box in the Table of Contents panel to select a section.

**Follow Links to Other Reports or to a Web Page**

Reports, stored processes, tables, graphs, geographical maps, images, or pieces of text can contain links. If linkable, text or the data cells in a table are underlined. For graphs, you must know whether the markers are linked or not. You also must know whether there is a link in a geographical map.

*Note:* The links in a stored process cannot be created in SAS Web Report Studio. The links have to be added when the stored process is created in another product, such as SAS Enterprise Guide.
When you follow a link to another report or to a Web page, the way they display is different. If the report contents open in the same browser window, there will be a link to return to the source report. However, a Web page opens in a new browser window, so there will not be a button or link to return to the source report.

For more information, see Chapter 26, “Linking Reports,” on page 281.

View a Summary of Applied Filters

You can display a summary of applied filters that are active. Filters that are based on a multidimensional report section consist of those created within a multidimensional information map. Filters that are based on a relational report section consist of those created within a relational information map and those created within a relational report section. Filters that are created for a report object pertain to that report object only.

To display a summary of applied filters that are active, complete these steps:

1. Right-click on the report object, and then select Data Source Details.

Display 5.13 Data Source Details Dialog Box with Applied Filters Listed

Note: For synchronized objects, the Applied filters text refers to the filters for the object and not the synchronized query.

2. Click OK to close the Data Source Details dialog box.
Refreshing the Data in a Viewed Report

The data in a report can be refreshed manually or automatically, depending on how the report was saved. For more information, see “Data Refresh: Manual Versus Automatic” on page 323.

Refresh the data in a viewed report when

- you want to change your prompt values. For example, you have been analyzing a report with prompted values for the Southeast region, but now you want to look at the Northeast region.
- you want an updated view of data for a report that contains a static snapshot of data.
- you suspect that the underlying data has changed since you viewed the report. Note that the values will not change if the underlying data source has not been updated.

To manually refresh the data in a report that you are viewing, select Data ⇒ Refresh. This refreshes the data in all report sections.

Modifying the Data in a Viewed Report

If you have the appropriate role, you can modify the data in a report that you are viewing. To change the data in a report, complete these steps:

1. Select either Data ⇒ Select Data or Options ⇒ Select Data to open the Select Data dialog box.
2. Add or remove data items from the Selected data items list.
3. Click OK.

Note: Modifications to the data do not change the underlying report unless you have permission to save over the original report.

Another way to change data in a report is to drag a data item from the Section Data panel and drop it onto tables and graphs.
The following display shows the **Gender** data item being dragged and then dropped on a list table.

**Display 5.14** Dragging and Dropping a Data Item from the Section Data Panel

![Screenshot of SAS Web Report Studio displaying dragging and dropping of data items](image)

**Note:** You cannot use drag and drop to hide data items. Use the Assign Data dialog box to hide data items.

For information about working with data items, see the following topics:

- “Specifying How Data Items Are Used in Tables” on page 136.
- “Specifying How Data Items Are Used in Graphs” on page 155.
Overview of Creating Reports

This chapter explains the main steps required to perform the following tasks:

• Use a quick start method to create a report.

• Build a report by making selections in the Edit tab.

Detailed steps for creating reports are explained in the following chapters:

• Chapter 9, “Including Stored Process Output,” on page 77.

• Chapter 15, “Displaying Query Results in a Table, Graph, or Geographical Map,” on page 131.

Using a Quick Start Method to Create a Report

About the Quick Start Methods

There are five quick start methods for creating a new saved report. Table 6.1 on page 50 provides an overview of the advantages and considerations for each quick start method.

Note: For more information about saved reports, see “About Reports Saved in SAS Web Report Studio” on page 34.
When reviewing the considerations, keep in mind that you can use Edit mode to make modifications until the report is exactly the way that you want it.

Table 6.1  Advantages and Considerations for Each Quick Start Method

<table>
<thead>
<tr>
<th>Quick Start Method</th>
<th>Advantages</th>
<th>Considerations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use the Report Wizard</td>
<td>The five-step Report Wizard guides you in defining a query; selecting a table and graph for the layout; and adding optional features such as group breaks, section filters, a header, and a footer. You can also select the format for displaying the data (for example, the number of decimal places that are used when displaying a number). When you click Finish, you have a complete, one-section report. Because the resulting report is based on a data source, you have full access to all the report objects (tables, graphs, geographical maps, group breaks, headers, footers, images, and text).</td>
<td>You can choose only from three graph types (bar, line, and pie).</td>
</tr>
<tr>
<td>Open a stored process as a report</td>
<td>When you include a stored process in a report, you can use Edit mode to add a header, a footer, images, and text that are independent of the stored process. The result can be a much more robust report than just the stored process report itself.</td>
<td></td>
</tr>
</tbody>
</table>
| Use a template for the layout and then add the data | When you select a template, you start creating your report with an already completed layout design. The layout can include tables, graphs, images, text, and their last saved properties; links from images* and text to Web sites and reports; a header and a footer; and positioning information. It can also include stored process objects (without the stored process selected). In addition, templates can contain multiple report sections, each with a unique design. | • You must define the query that will retrieve the data for the report.  
• You must specify any group breaks.  
• A layout design that exactly meets your needs might not be available. In this case, you can create your own template (or templates).                                                                                                                                                                                                 |
| Save a report based on a data source | When you save a report based on a data source, you create a new report simply by selecting an information map, a table, or a cube. Because the resulting report is based on a data source, you have full access to all the report objects (tables, graphs, geographical maps, group breaks, headers, footers, images, and text). | • You do not choose the data items used in the default query (which includes only standard data items).  
• You do not have any input into the default layout design.                                                                                                                                                                                                                               |
| Base the new report on an existing report | If there is an existing report that closely meets your requirements, you might only have to make minor changes to the query and the layout to create a new saved report. The existing report might have multiple report sections. | Some changes might result in the loss of some existing functionality, such as conditional highlighting. If too many adjustments need to be made, it might be easier to create a custom report.                                                                                                                                                                                                                 |

* Images can include links from group break values to prompts in a target report. However, prompt associations cannot be saved in a template because templates cannot contain group break information.
**Use the Report Wizard**

The Report Wizard guides you through five steps to create a one-section report that uses standard data items. To use the Report Wizard, complete these steps:


2. Select a `Data Source`. The default data source is determined by the selection on the `Report Creation` tab in the Preferences dialog box. You can click `Change Source` to select a different data source.

3. Select the data items that you want to use in the report. In the `Available data items` box, select one or more data items and click to move them to the `Selected data items` list box. Some users will be able to move all data items in the data source by clicking `Display 6.1

   **Step 1 in the Report Wizard**

4. Click `Next` to go to the next wizard page.

   **T I P** At this point, instead of clicking `Next`, you can click `Finish` to display the `Edit` tab. Defaults are used for any remaining unspecified required content. For example, if you are using a relational data source, a list table is automatically included. For more information about how to save the report at this point, see “Save a Report” on page 59.

5. (Optional) Select or create a category filter. For more information, see Chapter 13, “Subsetting Query Results,” on page 107.

6. (Optional) Change the format of some data items. For more information, see “Modify the Format of a Standard Data Item” on page 100.
7. Click **Next** to go to the next wizard page.

8. (Optional) Create group breaks. A *group break* is a way to divide report sections by distinct category or hierarchy level values when you are using a relational or multidimensional data source. For more information about group breaks, see “Overview of Using Group Breaks” on page 125.

   Complete these steps:
   
   a. From the first **Break by** drop-down list, select a category or hierarchy to specify the first group break.
   
   b. If you want the report to display a new page for each value in the first break, select **New page for each value**.
   
   c. Specify up to two more breaks.
   
   d. If you do not want labels to appear with each value, then clear the **Label each value** option.

**Display 6.2  Step 2 in the Report Wizard**

9. Click **Next** to go to the next wizard page.

10. Add at least one view element to display the results of the query, either a table or a graph (a bar chart, a line graph, or a pie chart). The data items that you selected in step 1 are shown as selected to display. Either accept the default data item
assignments or deselect the Show check box to hide the data items that you do not want to display.

- If you select the Table option, select the type of table. If your data source is multidimensional, then your only option is Crosstab.
- If you select the Graph option, select the type of graph.

**Display 6.4  Step 4 in the Report Wizard**

11. Click Next to go to the next wizard page.

12. (Optional) To add a header or a footer, complete these steps for each feature that you want to include in your report:
   
a. From the Banner drop-down list, select an image to use for the banner. The images that are available are provided by your system administrator. If there are no images available, then your only selection is None.

   **Display 6.5  Step 5 in the Report Wizard**

   b. Type the text that you want to include in the header or footer. You cannot use these characters: < > & #

c. To include the date that the section query was last run, select Display date that query was last refreshed.

13. Click Finish to display the report in the Edit tab.

14. Select File → Save. For information about how to complete the Save As dialog box, see “Save a Report” on page 59.
15. Click the **View** tab to see the results.

**Display 6.6  A Completed Report from the Report Wizard**

![Completed Report from the Report Wizard](image)

**Base a New Report on a Stored Process Report**

To save a new report from a stored process report, complete these steps:

1. Run a stored process by selecting one of the last six viewed stored processes from the **File** menu or the Welcome window, using the Open dialog box (shown) or using the File Management window.

   **Note:** For more information about the **File** menu and the File Management window, see Chapter 3, “The SAS Web Report Studio Interface,” on page 11.
2. If a prompt window appears, provide the requested information, and then click View Report.

3. Select File ⇒ Save. For information about how to complete the Save As dialog box, see “Save a Report” on page 59.

Note: By completing the Save As dialog box, you create a new saved report, either with the same name as the stored process or with a new name. The original stored process continues to exist in addition to the new saved report.

For more information about saved reports that use stored processes, see Chapter 9, “Including Stored Process Output,” on page 77.

Base a New Report on a Report Template and Then Add Data

Report templates can contain more than just report objects placed in certain positions. Properties and, in some cases, linking can also be part of a template. In addition, templates can contain multiple report sections, each with a unique layout design.

To create a saved report by using a template, complete these steps:

1. Select File ⇒ New ⇒ New Using Template. You can also select New using Template in the Welcome window. Templates can have multiple sections. If you use this method to start building a new report, then all sections from a template containing multiple sections are used.

2. Click one of these tabs:

   General templates
   Select this tab to use the default templates that come with SAS Web Report Studio.

   Shared templates
   Select this tab to use the templates that can be viewed and used across your company.
My templates
Select this tab to use the templates that can be viewed only by you and your system administrator.

3. Select a template.

*Display 6.8*  How the General Templates Tab Appears in the Select a Template Dialog Box

4. Click **OK**. Your selected layout is displayed in the **Edit** tab.

The following display is an example of what Edit mode looks like if you select the **Table over graph** template.

*Display 6.9*  How Edit Mode Appears When You Select the Table over Graph Template

5. Define the query by selecting data items from a data source. For more information, see Chapter 12, “Defining Queries to Obtain Results,” on page 91.
6. Select **File** ⇒ **Save**. For more information about how to complete the Save As dialog box, see “Save a Report” on page 59.

**Tip** You can also apply a template to a report section when you are in Edit mode. However, when you apply a template to a report section, only the first section in the template is used.

**Base a New Report on Opening a Data Source Directly**

A new report can be based on opening a data source directly. The report uses either a crosstabulation or a list table to present the results. For more information about which tables are created for a data source, see “Opening Data Sources Directly” on page 40.

**Note:** Your data administrator determines what data sources you are authorized to view.

To create a report by opening a data source directly, complete these steps:

1. Double-click an information map, table, or cube in the **Open** dialog box. The new report opens in View mode.

   Display 6.10 A New Report Based on Ad Hoc Output from an Information Map

   ![A New Report Based on Ad Hoc Output from an Information Map](image)

2. Select **File** ⇒ **Save**. For more information about how to complete the Save As dialog box, see “Save a Report” on page 59.

You can use Edit mode to update a saved report based on opening a data source directly. To create a saved report from ad hoc output from an information map, table, or cube and then make changes, complete these steps:

1. Select an information map, table, or cube in the **Open** dialog box; click in the **Actions** column and then select **Edit**. If the report was opened in View mode, click the **Edit** tab to switch to Edit mode.

2. In Edit mode, make any customizations that you want. For example, you might want to add a header or a footer.

   Display 6.11 A New Report Based on Ad Hoc Output from an Information Map in Edit Mode

   ![A New Report Based on Ad Hoc Output from an Information Map in Edit Mode](image)
3. Select File ⇒ Save. For information about how to complete the Save As dialog box, see “Save a Report” on page 59.

**Base a New Report on an Existing Report**

If there is an existing saved report that closely matches the report that you want to create, you can save the existing report under a new name, which is the only step that is required to create a new saved report. However, you might want to use Edit mode to make some customizations. To base a new report on an existing report, complete these steps:

1. View the existing saved report by doing one of the following:
   - Select File ⇒ Open Recent and then select the report.
   - Use the Open dialog box.
   - Use the File Management window.
2. If a prompt window appears, provide the requested information, and then click View Report.
3. Select File ⇒ Save As and complete the Save As dialog box, giving the report a new name. For more information, see “Save a Report” on page 59.

**Use Edit Mode to Create a Report**

You can use Edit mode to create a report. To create a new report from scratch, complete these steps:

1. To access Edit mode, do one of the following:
   - Select File ⇒ New to access Edit mode.
   - Select New or New report in the Welcome window.
2. Choose your data source and then design the layout of the new report.
You can perform most of the required tasks in either Edit or View mode. Tasks that are specific to Edit mode include linking reports, adding group breaks, positioning objects (such as tables, graphs, geographical maps, and images), and working with the layout grid (for example, splitting and merging cells). For differences between using the two modes, see “Your First Look at the SAS Web Report Studio User Interface” on page 11.

You can drag report and graph objects and drop them onto the layout.

The steps for defining queries and designing layouts are explained in the following chapters:

- Chapter 8, “Adding Images and Text,” on page 71.
- Chapter 12, “Defining Queries to Obtain Results,” on page 91.
- Chapter 13, “Subsetting Query Results,” on page 107.
- Chapter 14, “Grouping Query Results,” on page 125.
- Chapter 15, “Displaying Query Results in a Table, Graph, or Geographical Map,” on page 131.

---

Save a Report

Note: In addition to enabling you to save automatically or manually refreshed reports, the Save As dialog box is also used to save report templates (see “Creating Report Templates” on page 248) and static content that can be published to a publication channel (see “Publish a Report to Publication Channels” on page 269).

To save a report, complete these steps:

1. Select **File** → **Save**. If you are saving a new report, then the Save As dialog box is displayed.
2. For new reports, type a Name. Names cannot use these characters: \ / : * ? " ' | @ # &

For information about valid names, see “Naming Reports, Folders, and Templates” on page 309.

If you are saving an existing report, then the name of that report is listed here. You can either leave the name as it is and overwrite the existing report, or you can change the name to create a new report.

3. From the Type drop-down list, select either Data is automatically refreshed or Data can be manually refreshed. Automatically refreshed reports always include the most current data in the underlying data source that the user is authorized to see. Manually refreshed reports can be archived and usually render more quickly than automatically refreshed reports.

For more information about these options, see “Data Refresh: Manual Versus Automatic” on page 323 and “Publish a Report to Publication Channels” on page 269.

4. Navigate to a Location. The default location is determined by your preference for saving reports. For more information, see “Specify Preferences for Opening and Saving Reports” on page 25.

To create a new folder, click . For more information about the folder options, see “Overview of Shared Locations” on page 265.

5. (Optional) Type a report Description. Report descriptions can be displayed in the Open dialog box and the File Management window. Users can search for reports with specified text in the description. You cannot use these characters: < > & #

6. (Optional) Type Keywords. Users can view the report keywords in the Open dialog box or the File Management window before they view the report. They can also search for reports with specified text in the keywords. Separate multiple keywords with a comma. Keywords cannot use these characters: < > & # / \.

Note: Keywords do not apply to report templates.

For information about valid keywords, see “Naming Reports, Folders, and Templates” on page 309.
7. (Optional for manually refreshed reports) Select **Retain previous instance of output not to exceed**, and then type the number of archived reports that you want to maintain.

*Note:* The ability to archive reports is an advanced feature. You might be authorized to save reports but not to archive reports. For more information, see “Archiving Reports” on page 243.

8. (Optional) Select the **Automatically replace if file already exists** option if you want to replace an existing report without being prompted to confirm this action.

9. (Optional) Select the **Make read-only** option to prevent other users (including system administrators) from deleting, modifying, renaming, or moving this report. (You can still perform these actions on your own report.)

10. Click **OK**.

In the following display, the new report is saved in a folder called **Orion Star Sports**. The **Automatically replace if file already exists** and **Make read-only** options are also selected.

*Display 6.14  How the Save As Dialog Box Appears with Two Options Selected*
Part 3

Designing Layouts

Chapter 7
Designing Headers and Footers ............................................... 65

Chapter 8
Adding Images and Text .......................................................... 71

Chapter 9
Including Stored Process Output ............................................. 77

Chapter 10
Positioning Objects in the Layout Grid ....................................... 81

Chapter 11
Using Synchronized Objects ..................................................... 87
Chapter 7
Designing Headers and Footers

Overview of Creating a Header and a Footer for a Report Section

You can use headers and footers to include corporate standards, such as logos and text that indicates confidentiality, in your reports. As a global preference, you can choose an image and static text to appear in every section of all new reports that you create.

You can also override the global settings for individual report sections. Additional header and footer features that are available for individual sections include the following:

• dynamic text, such as prompt values or the date that the report was last refreshed
• dividing lines
• the ability to change the font, font size, font style, background color, foreground color, and paragraph alignment

This chapter discusses how to create a header and a footer for an individual report section in Edit mode.

Note: For more information about how to set global preferences, see Chapter 4, “Specifying Your Preferences,” on page 25.

About Dynamic Text in Headers and Footers

Dynamic text acts a placeholder for text that will be generated from data when the report is viewed. You can include dynamic text in a header or a footer, which enables you to include information such as prompt values, the name and description of the data source for the report, the date that the report was last refreshed, and the report author. Table 7.1
Table 7.1 Dynamic Text Options and Examples

<table>
<thead>
<tr>
<th>Dynamic Text</th>
<th>Information Displayed</th>
<th>Example in View Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Source Name</td>
<td>The name of the relational or multidimensional data source that is being used to provide data for the tables, graphs, and geographical maps in the report section. The dynamic text option does not provide the data source name for a stored process.</td>
<td>OrionStarOrders</td>
</tr>
<tr>
<td>Data Source Description</td>
<td>If available, the description of the relational or multidimensional data source that is being used to provide data for the tables, graphs, and geographical maps in the report section. The dynamic text option does not provide the data source description for a stored process.</td>
<td>Performance information for Orion customers from 2007 to 2012. Includes sales revenue and costs for geographic, product, time, and customer demographic breakdowns. Created for Sales and Marketing.</td>
</tr>
<tr>
<td>Date the data was last refreshed</td>
<td>The date and time that the query for data was last sent to the underlying source of data.</td>
<td>Wednesday, February 22, 2012 3:07:57 PM EST</td>
</tr>
<tr>
<td>Report Author</td>
<td>If available, the name of the report author. Otherwise, the user ID of the report author is used.</td>
<td>Marcel Dupree</td>
</tr>
<tr>
<td>Date Modified</td>
<td>The date and time that the report was last saved.</td>
<td>Wednesday, February 22, 2012 1:42:46 PM EST</td>
</tr>
<tr>
<td>Report Description</td>
<td>If available, the description of the report.</td>
<td>Provides U.S. management with a high-level view of delivery performance across all products.</td>
</tr>
<tr>
<td>Report Name</td>
<td>The name of the report.</td>
<td>Delivery Performance for US Gold Customers in 2012</td>
</tr>
</tbody>
</table>

Create a Header or a Footer

For an individual report section, a header and a footer can contain a banner image, static text, dynamic text, and a dividing line. An image in a header or a footer can link to a URL. All content is optional.
Below the optional, full-width banner image, each header or footer is divided into three content areas (left, middle, and right). Each content area can contain a single image, rich text, or nothing. Images and text cannot be combined within the same content area.

Here is how the content in a header or footer might appear in a report:

<table>
<thead>
<tr>
<th>Banner image</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text, image, or blank</td>
</tr>
<tr>
<td>Horizontal line</td>
</tr>
</tbody>
</table>

To create a header or a footer, complete these steps:

1. Perform one of these tasks:
   - Click Header and select Edit to open the Edit Header dialog box.
   - Click Footer and select Edit to open the Edit Footer dialog box.

2. (Optional) Select the name of an image from the Banner image drop-down list and specify an alignment. The alignment icons align the banner image relative to the whole report. A thumbnail of the selected image displays.
   
   Note: The images in this list are provided by your system administrator. You cannot alter the banner image in any way using SAS Web Report Studio.

3. Select the Left content, Middle content, or Right content tab. These three tabs control the content and width of each content area.
   
   The Middle content tab displays initially with a width of 100%, and the Left content and Right content tabs have no content and a width of 0%. Fractional percentages are not allowed.

4. Use the Width field to specify the percentage for the content area. The Left content, Middle content, or Right content tab automatically updates with the new width. The width for the content areas are minimum, not maximum, values.
Note: Width values are not validated until you click OK. It is possible to exceed 100% while you are working on each content area.

Note: The width value does not change the size of images or distort them. Only a system administrator can alter images for the footer.

5. Specify the Content using the drop-down list. Text appears by default. You can also select None or one of the available images.

6. Enter text into the field. You can type static text, you can select dynamic text, or you can use a combination of both. For more information about dynamic text, see Step 9 on page 69.

Note: You cannot enter text if you selected to display an image in the Content drop-down list.

7. Use the formatting tools to change the font, font size, font style, background color, foreground color, and alignment. For images, you can use the alignment icons to set the horizontal alignment within the overall width of the content area.

8. (Optional) Link an image to an existing report, a stored process, or a URL. When you follow a Web link, a new browser window opens. The source report is not closed, so there is no link to return you to it. When you follow a link to another report or stored process in SAS Web Report Studio, the target object appears in the primary SAS Web Report Studio window, and a Return to previous report link is available.

To link an image, follow these steps:

a. Select the image name in the Content drop-down list.

b. Click to display the Report Linking dialog box.

Display 7.2 Report Linking Dialog Box for Headers and Footers

In the Report Linking dialog box, select the Make text a link check box.

Specify the Link destination. If you are linking the image to a Web page, then type the address in the Web page URL field.

You can also select the Use the current window option for the Window destination. When you select this option, SAS Web Report Studio passes your
Remove a Header or a Footer

To remove a header or a footer from a report, complete these steps:

1. Perform one of these tasks:
   - Click **Header** and select **Edit** to open the Edit Header dialog box.
   - Click **Footer** and select **Edit** to open the Edit Footer dialog box.

Remove a Header or a Footer
2. Clear all of the selections in the dialog box to completely remove the header or footer. For example, you might select None for the Banner image and delete all of the text.

3. Click OK.
Chapter 8
Adding Images and Text

Overview of Using Images and Text

Similar to headers and footers, you can use images and text to include corporate standards, such as logos and text that indicates confidentiality, in your reports. One of the differences is the ability to insert multiple images and text objects wherever you want them to appear in the layout. You can also link images and text to another report or to a Web page.

You can insert images from a repository or from your local machine. If you select an image from your local machine, it is saved to the repository. You can also add tooltip text to an image. Text objects can be used to display static text, dynamic prompt values, and measure values.

If you are authorized to save reports, you should be able to save images to the repository for use in the body of a report. (This is different from the header and footer images, which only system administrators can update.) If you cannot save images, contact your system administrator.

This chapter discusses how to use images and text in Edit mode.

Place an Image in a Report Section

To insert an image into your report, complete these steps:

1. In Edit mode, click on the horizontal toolbar. An empty placeholder object for an image is placed in the next available cell in the layout grid.

For more information about how to position objects in the layout grid, see “Overview of Positioning Report Objects” on page 81.
2. Right-click in the image, and then select **Edit** to open the **Edit Image** dialog box.

3. Select the image from one of the following locations:
   
   **Local machine**
   Select this option to choose an image from your local machine. Click **Browse** to choose a file on your local machine. The path to the selected image appears in the **Image source** field. Click **Select a Folder** to choose a destination for the image in the repository. In the Select Folder dialog box, you can create a new folder by clicking ![Folder icon]. Click **OK**.
   
   **Note:** If you are authorized to save reports, you should be able to save images to the repository. If you cannot save images to the repository, contact your system administrator.
   
   **Repository**
   Select this option to choose an image that is stored on the same server as the reports. Click **Select image** to open the Select Image dialog box. (Only images appear in the Select Image dialog box. No other types of data sources appear.) Select an image. Click **OK**. You will see the image displayed below the **Select image** button in the Edit Image dialog box.

4. Specify a size for the selected image. The user-defined selections are **Set height (maintain scale)**, **Set width (maintain scale)**, and **Set width and height**.
5. (Optional) For Tool-tip text, type up to 60 characters that will appear when the user places the pointer over the image. You cannot use these characters: < > & #

6. Click OK.

Include Text in a Report Section

To insert text into your report, complete these steps:

1. Click on the horizontal toolbar. An empty placeholder object for the text object is placed in the next available cell in the layout grid.

2. Right-click in the text object, and then select Edit to open the Edit Text dialog box.

3. Enter text into the text box. There are three methods that you can use, and you can use a combination of all three methods:
   - You can type the text.
   - You can insert a measure value.
     Select the name of the measure in the Measure value drop-down list, and then click Insert to place the measure name into the text box at the insertion point. Type at least one character or one space before entering any additional measure value. When you view the report, the text in the rendered report displays the aggregated value of the measure.
     Note: If you remove the inserted measure from the report, then the measure is also removed from the text.
   - You can insert a prompt value.
     Select the name of the prompt in the Prompt value drop-down list, and then click Insert to place the prompt name into the text box at the insertion point. Type at least one character or one space before entering any additional prompt value. The text in the rendered report displays the value that you entered for the prompt.
     Note: You can always type text, but the availability of prompts and measures depends on the data items that are selected for the report section.

Display 8.3  Text Entered in the Edit Text Dialog Box

4. (Optional) Use the formatting tools to change the text. For more information, see, “Format Text in Reports” on page 74.
5. (Optional) Create a hypertext link that can open another report or Web page. For step-by-step instructions on creating a link to another report or Web page, see “Access the Report Linking Dialog Box for Text Objects” on page 282.

6. Click **OK**.

---

**Format Text in Reports**

SAS Web Report Studio provides text formatting tools in the Edit Text dialog box, as well as the Edit Header and Edit Footer dialog boxes, which work like a basic word processor. Select the text that you want to format and then use the tools to change the font, font size, font style, background color, foreground color, and alignment. If you click between characters in the text and then use the tools, the change applies only to new text that you enter immediately thereafter.

**Display 8.4**  *Edit Text Dialog Box with a Dynamic Text Item and a Hypertext Link*

The text formatting tools can be affected by your browser and by the HTML that represents the text that you type and review. Here are some guidelines to follow:

- Pressing **ENTER** starts a new paragraph.
- You cannot apply a style change across paragraphs. However, you can select each paragraph and apply the same style to each one.
- Text alignment is applied to the currently selected paragraph, not to all of the text in the dialog box. When you view a report, the visual effect of center or right alignment depends on the context of the report. For example, if you have a text object above a narrow table, the text might appear to be left-aligned because the report is only as wide as the widest element that it contains.

For header and footer text, the alignment applies within the left, middle, or right content area and the percent width that is assigned to the content area. For more information about headers and footers, see “Create a Header or a Footer” on page 66.

- The hyperlink feature is available only for text objects in the report body, not in headers or footers. For more information about adding hyperlinks, see “Access the Report Linking Dialog Box for Text Objects” on page 282.
- A dynamic item, such as a measure, can be inserted at the current cursor location when you select the dynamic item from the drop-down list below the text entry box. Click **Insert**.
In a text object, dynamic items might not be available, depending on your selected data. In the Edit Header and Edit Footer dialog boxes, some dynamic items can always be inserted. These dynamic items are generally related to report properties. When you view your report, remember that some dynamic items, such as Report Name, will not be meaningful until you save the report.

*Note:* You cannot insert a dynamic item when the cursor is immediately adjacent to another dynamic item. Instead, insert a space after one dynamic text item before you insert another dynamic text item.

- Due to browser limitations, the underline style cannot be removed once it has been applied. Use of the underline tool is also discouraged because underlined text is easily confused with a link.
- The default value for the automatic background color is transparent.

For example, you select a text string that says 75% of overall sales since 2002 and set the background color to yellow. Then you select the year 2002 and select Automatic in the background color palette. It appears that the second change has no visual effect. That is because the yellow color is behind the transparent color and shows through as illustrated in the following display.

**Display 8.5  Edit Text Dialog Box with a Background Color for Text**

You can apply any other background color to see a change.

- Only plain text should be pasted into the Edit Text, Edit Header, and Edit Footer dialog boxes. Pasting formatted text from an application like Microsoft Word can have unpredictable results. When you paste formatted text, SAS Web Report Studio attempts to remove any text formatting and replace any tabs, line feeds, and line breaks with blanks. This limitation helps avoid security violations. The browser might also modify the content in unexpected ways before SAS Web Report Studio receives it.

- The Edit Text, Edit Header, and Edit Footer dialog boxes are intended for small amounts of plain text (less than 10,000 characters). Attempting to edit or paste large amounts of text can result in unacceptable delays, unpredictable behavior, or memory shortages in the browser.

For information about troubleshooting issues with the text formatting tools, see “Working with Text Objects, Headers, and Footers” on page 318.
Remove an Image or a Text Object

To delete a text or image object, complete these steps:

1. Select the text or image object in the layout grid.

2. Complete one of these tasks:
   • Click on the vertical toolbar.
   • Right-click in the image or text object, and then select Remove Image or Remove Text.
   • Press Delete on the keyboard.

3. Click OK in the confirmation message box that appears.
Overview of Stored Processes

Stored process output in a report can include queries, prompted filters, titles, images, and statistical analyses. Some stored process output might support chart tips, tooltips, and drilling.

There are two ways to use stored processes:

- Stored processes can be included as part of a larger saved report, as explained in this chapter.
- Stored processes can be rendered directly, as explained in “Viewing Stored Process Reports” on page 37.

When you include a stored process in a saved report, you can perform some additional layout design tasks that are independent of the stored process output. For example, you can add text, images, headers, and footers. In the same report section, you can also include the output of a query that uses data items from a data source. If you add an additional data source (other than the stored process), then you can also add graphs, tables, and, possibly, geographical maps.

This chapter discusses how to work with stored processes in Edit mode.

Insert a Stored Process

To insert one or more stored processes into a report layout, complete these steps:

1. Perform one of these tasks to insert a stored process object:
   - Drag the stored process tool from the toolbar into a specific cell.
   - Click on the horizontal toolbar.

An empty placeholder object for a stored process is placed in the next available cell in the layout grid.
For more information about how to position objects in the layout grid, see “Place Objects in the Layout Grid” on page 84.

2. Right-click on the stored process, and then select Edit to open the Insert a Stored Process dialog box.

3. Select a folder Location and navigate to the stored process that you want to use.
   Note: Only stored processes appear in the Insert a Stored Process dialog box. No other types of data sources appear.

4. (Optional) To sort the list of stored processes, click Name, Date, or Description.

5. Select the stored process that you want to use.

6. Click OK. The name of the stored process appears in the stored process object.

   Display 9.1 Stored Process Object in the Layout Grid

7. (Optional) To insert another stored process, repeat steps 1 through 6.

8. (Optional) Specify group break parameters for the stored process. For more information, see “Add Group Breaks” on page 125.
   Note: You cannot complete this step if no stored process has been assigned to the stored process report object, if no group breaks are defined in the section that contains the stored process, or if the stored process does not contain any parameters.

   a. Right-click on the stored process, and then select Assign Group Breaks to open the Assign Group Breaks To Stored Process Prompts dialog box.

   b. Specify the Group break levels. Note that a group break value can be passed only to a compatible prompt. For example, a group break value on a character item can be passed only to a text prompt. A group break value on a date category can be passed only to a date prompt, and so on.
c. Click OK.

9. (Optional) Add other report elements (for example, images or text) that are independent of the inserted stored processes.

---

**Remove a Stored Process**

To remove a stored process from the current report section, complete these steps:

1. Select the stored process object.
2. Complete one of these tasks:
   - Click \( \times \) on the vertical toolbar.
   - Right-click in the stored process object, and then select **Remove Stored Process**.
   - Press Delete on the keyboard.
3. In the confirmation message box that appears, click OK.
Overview of Positioning Report Objects

Edit mode contains a layout grid for placing and arranging objects in the body of the report section. The grid consists of cells into which you place tables, graphs, geographical maps, stored processes, text, and images. By default, the layout grid has these features:

• It does not contain any report objects.
• It contains four cells.
• Cells are left-aligned.
• The option for synchronizing objects is disabled.
You can add cells, merge cells, and delete empty cells. You can also realign cell content, reposition objects, and synchronize objects.

Add Cells, Columns, and Rows to the Layout Grid

To add more cells to the layout grid, click these buttons on the vertical toolbar.

<table>
<thead>
<tr>
<th>Button</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Column Icon]</td>
<td>inserts a column to the left of the selected column</td>
</tr>
<tr>
<td>![Column Icon]</td>
<td>inserts a column to the right of the selected column</td>
</tr>
<tr>
<td>![Row Icon]</td>
<td>adds a row above the selected row</td>
</tr>
<tr>
<td>![Row Icon]</td>
<td>adds a row below the selected row</td>
</tr>
<tr>
<td>![Split Vertical Icon]</td>
<td>splits a selected cell vertically</td>
</tr>
<tr>
<td>![Split Horizontal Icon]</td>
<td>splits a selected cell horizontally</td>
</tr>
</tbody>
</table>

Align Cell Content in the Layout Grid

To change the alignment of an object in a cell, select the object and then click one of the alignment buttons on the vertical toolbar.

<table>
<thead>
<tr>
<th>Button</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Align Left Icon]</td>
<td>aligns the object to the left of the cell</td>
</tr>
<tr>
<td>![Align Center Icon]</td>
<td>aligns the object to the center of the cell</td>
</tr>
</tbody>
</table>

Display 10.1  Layout Grid That Does Not Contain Any Objects
<table>
<thead>
<tr>
<th>Button</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Align Right]</td>
<td>aligns the object to the right of the cell *</td>
</tr>
<tr>
<td>![Align Top]</td>
<td>aligns the object to the top of the cell</td>
</tr>
<tr>
<td>![Align Middle]</td>
<td>aligns the object to the middle of the cell</td>
</tr>
<tr>
<td>![Align Bottom]</td>
<td>aligns the object to the bottom of the cell</td>
</tr>
</tbody>
</table>

* This alignment setting does not apply to text, which instead uses the alignment settings in the Edit Text dialog box.

---

**Delete an Empty Column or Row from the Layout Grid**

You can delete empty columns and rows from the layout grid. You cannot delete individual empty cells or rows and columns that contain objects.

To select the empty cells in a row or column, perform one of these tasks:

- Select cells by dragging your mouse.
- Press CTRL while clicking on each cell.
- Press SHIFT while clicking to specify the beginning and end of a region.

To delete the selected cells, click ✗ on the vertical toolbar.

---

**Delete Objects in the Layout Grid**

To delete one or more objects from the layout grid, complete these steps:

1. In the layout grid, select the object or objects that you want to delete.
2. Complete one of these tasks:
   - Click ✗ on the vertical toolbar.
   - Right-click in the object, and then select **Remove Table** for a table object or **Remove Graph** for a graph object.
   - Press Delete on the keyboard.
3. In the confirmation message box that appears, click **OK**.
Merge Cells in the Layout Grid

To merge two or more selected cells in the same row or column in the layout grid, click on the vertical toolbar. You can merge empty cells or empty cells and one cell with content, because each cell can contain only one element.

Place Objects in the Layout Grid

These are the objects that you can place in the layout grid of a report section. To place an object, you can click on its button on the horizontal toolbar, or you can drag and drop the object from the toolbar into a cell.

<table>
<thead>
<tr>
<th>Button</th>
<th>Object</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>list table</td>
</tr>
<tr>
<td></td>
<td>crosstabulation table</td>
</tr>
<tr>
<td></td>
<td>bar chart</td>
</tr>
<tr>
<td></td>
<td>line graph</td>
</tr>
<tr>
<td></td>
<td>bar-line chart</td>
</tr>
<tr>
<td></td>
<td>progressive bar chart</td>
</tr>
<tr>
<td></td>
<td>scatter plot</td>
</tr>
<tr>
<td></td>
<td>bubble plot</td>
</tr>
<tr>
<td></td>
<td>pie chart</td>
</tr>
<tr>
<td></td>
<td>tile chart</td>
</tr>
<tr>
<td></td>
<td>geographical map</td>
</tr>
<tr>
<td></td>
<td>text</td>
</tr>
<tr>
<td></td>
<td>image</td>
</tr>
<tr>
<td></td>
<td>stored process</td>
</tr>
</tbody>
</table>
Reposition Objects in the Layout Grid

You can drag and drop objects from one cell in the layout grid to another.

If you attempt to drop a new object into a cell that already contains an object, then a warning message appears. If you click OK, then the current object is replaced by the moved object.

If you attempt to move an existing object into a cell that already contains an object, then a warning message appears. If you click OK, then the current object switches places with the moved object.
Overview of Synchronized Filtering, Sorting, Drilling, and Expanding

For report sections that use data items from a data source, you can synchronize the objects that you insert into the body. Synchronized tables and graphs share category or hierarchy filters, sorting (but not prioritizing), drilling, and expanding.

Note: All tables and graphs within a section are either synchronized or not synchronized. You cannot choose to synchronize some elements in a section and not others.

By default, report sections that are based on multidimensional data sources contain synchronized objects. The report section is synchronized as soon as you select data items from the data source. If you change the data source to relational, then the objects in the report section automatically are not synchronized.

To synchronize objects that are currently not synchronized, when in Edit mode, select either Data ⇒ Synchronized Objects or Options ⇒ Synchronized Objects.

Note: This menu option is not available if your report section contains a stored process.

When you switch objects from not synchronized to synchronized, the following actions are taken on any tables, graphs, and geographical maps:

• All filters and rankings are removed.
• All sorting is removed.
• Tables, graphs, and geographical maps are reset to the highest level drill state.
• Any percent of total calculations are removed.

In Edit or View mode, synchronized objects are indicated in the Section Data panel by this icon: 📊. The synchronize icon also appears on the toolbar next to the navigational indicator.
Display 11.1  Synchronized Data Icon in the Section Data Panel and on the Toolbar

Maintain Tables, Graphs, and Geographical Maps That Are Not Synchronized

By default, report sections that are based on relational data sources contain objects that are not synchronized. The report section is set to contain objects that are not synchronized as soon as you select data items from the data source. If you change the data source to multidimensional, then the objects in the report section automatically become synchronized (unless the report section contains a stored process).

To remove synchronization in Edit mode, select Data $\Rightarrow$ Synchronize Objects or in the Select Data panel, select Options $\Rightarrow$ Synchronize Objects. Then clear the check box.

Display 11.2  Synchronize Objects Menu Item

When you switch objects from synchronized to not synchronized, the following actions are taken on the individual tables, graphs, and geographical maps:

- All filters and rankings are removed.
- All sorting is removed.
- Tables, graphs, and geographical maps are reset to the highest level drill state.
Part 4

Defining Queries and Displaying Results

Chapter 12
Defining Queries to Obtain Results ............................................. 91

Chapter 13
Subsetting Query Results ............................................................. 107

Chapter 14
Grouping Query Results ............................................................... 125

Chapter 15
Displaying Query Results in a Table, Graph, or Geographical Map ............................................................... 131
Specially prepared information maps provide a metadata layer between the nontechnical business user and the complexities of database structure and query languages.

Information maps are created by a data source administrator in a centrally managed location so that you can easily define a report. Authorized users who might be more advanced can access tables and cubes directly. All data sources contain data items, which can refer to calculations or physical data (tables or cubes). Data items in information maps are described in common business terms that enable both casual and professional report authors to easily build queries that return consistent results. Reports can include query results from more than one data source.

Each information map includes one or more data items. For example, an information map named Order Information might include standard data items such as Order ID, Product ID, Unit Cost, Order Date, and Order Amount. You decide which data items to use. You can select all of the data items in the data source or a subset of data items.
Information map data sources can also contain predefined prompts and filters. For more information, see “Overview of Section Filters” on page 107.

You can also create two types of custom data items:

• You can calculate a new measure that is based on one or more existing measures.

• If the data source includes a time hierarchy from a multidimensional data source, then you can create one or more custom data items that are based on relative time.

In addition to explaining how to use both standard and custom data items, this chapter explains how to modify the query in these ways:

• by changing the format used for one or more data items

• by using detail data instead of grouped and aggregated data

• by changing the aggregation method used for one or more measures

You can also subset and group query results. For more information about these tasks, see Chapter 13, “Subsetting Query Results,” on page 107 and Chapter 14, “Grouping Query Results,” on page 125.

After you select the data source and data items, you must add one or more view elements, such as a table or graph, to contain the results. For more information, see Chapter 15, “Displaying Query Results in a Table, Graph, or Geographical Map,” on page 131.

Using Standard Data Items in a Query

About Standard Data Items

Each data source includes one or more standard data items. You decide which data items to use to define a query for a report section. You can use all the data items in the data source or a subset of data items. Each standard data item is classified as either a category, a hierarchy, or a measure.

Category

A data item whose distinct values are used to group and aggregate measures. There are four types of categories: alphanumeric, date, timestamp, and time. Alphanumeric categories can be made up of all letters, all digits, or a combination of the two. Categories that have values that are all digits might be physically stored as character or numeric data. The data type affects how values are handled in relation to some functionality, such as filtering, sorting, and formatting.

Examples of alphanumeric categories include data items such as Product ID, Country, Employee Number, and Employee Name. Date, timestamp, and time category examples are Order Year, Date of Sale, and Delivery Time.

Measure

A data item whose values can be used in computations. Usually, these values are numeric. Examples of measures include Sales Revenue, Units Sold, and Salary.

The default format of a measure is specified by the data source that contains it. You can modify the format of some measures.

Every measure has a default aggregation method, which is specified by the data source that contains it. In some cases, you can change the method. However, if you
use a measure as part of a custom data item, then the measure is always calculated by using the default aggregation method.

Hierarchy

An arrangement of the levels in a dimension from general to specific. The first level in the hierarchy is the root level.

For example, a common dimension in a multidimensional data source is **Time**. A dimension that is named **Time** might have a hierarchy named **YrQtrMth**. Such a hierarchy might enable you to look at data for each **Year** (the root level), drill down to see the data for each **Quarter** (second level) in a specific year, and then drill down to see the data for the three **Months** (third level) that make up a particular quarter.

Hierarchies are available only in multidimensional data sources.

**Select Standard Data Items**

To select the standard data items that you want to use in the query for the current report section, complete these steps:

1. In the **Section Data** panel, select **Options** ➤ **Select Data** to open the Select Data dialog box.

2. On the **Standard** tab, a data source is selected by default. If there are no data sources available, contact your data source administrator.

   To use a different data source, complete these steps:
   
a. Click **Select Data Source**.

   b. In the Select Data Source dialog box, navigate to the location of the data source that you want to use. Each data source appears with an icon that indicates its type.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Type of Data Source</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="icon" alt="relational or multidimensional information map" /></td>
<td>relational or multidimensional information map</td>
</tr>
<tr>
<td><img src="icon" alt="relational information map" /></td>
<td>relational information map</td>
</tr>
<tr>
<td><img src="icon" alt="multidimensional information map" /></td>
<td>multidimensional information map</td>
</tr>
<tr>
<td><img src="icon" alt="table" /></td>
<td>table</td>
</tr>
<tr>
<td><img src="icon" alt="cube" /></td>
<td>cube</td>
</tr>
</tbody>
</table>

   c. Click **OK**.

3. (Optional) To find a data item in the selected data source, complete these steps:

   a. Click ![Standard tab](icon) on the **Standard** tab.

   b. Type your search term.

   c. Click **Find Next** to locate each instance of the data item.

   d. Click **Cancel**.
4. In the **Available data items** list box, select one or more data items, and then click \( \text{ } \) to move them to the **Selected data items** list box. This adds the data item or items to the query. Some users will be able to move all data items in the data source by clicking \( \text{ } \).

**Display 12.1** Select Data Dialog Box Showing Four Categories and Three Measures Selected from a Multidimensional Data Source

Note: To view the data type and description for a data item, select a single data item in the **Available data items** list box, and then click \( \text{ } \).

Note: For relational data sources, you can select the same measure multiple times, rename each instance of the measure (see step 7), and apply a different aggregation to each instance of the measure (see “Modify How a Measure Is Aggregated” on page 102).

5. (Optional) Reorder the data items in the **Selected data items** list box. To move a selected data item up or down in the list, use \( \text{ } \) and \( \text{ } \). The order in which the data items appear in this box is used to assign the data items to default functions in graphs and tables.

Note: Existing tables and graphs are not affected by reordering data items.

6. (Optional) To rename a category or measure, select it in the **Selected data items**, and then click \( \text{ } \).

Note: You cannot rename hierarchies.

7. (Optional) Clear the **Add new data items to existing tables automatically** check box if you do not want new data items automatically added to existing tables. (Adding new data items to tables might affect existing filters, percent of total calculations, and conditional highlighting.) If you clear this check box, then new data items that are added to the **Selected data items** list box are hidden from existing tables. If you want to move a hidden data item to a row or a column in an existing table, then use the Assign Data dialog box to make that change.

Note: This option is not available if there are no existing tables.

For existing crosstabulation tables that have at least one category assigned to **Columns**, additional data items are assigned to the **Rows** function. If you add
measures, the additional measures are assigned to whatever function the current measures are assigned to. That is, if measures are currently assigned to Rows, then the additional measures are also assigned to Rows. For list tables, if this option is selected, new data items are added to the Columns function.

8. Click OK.

Display 12.2  Section Data Panel Showing the Standard Data Items Selected for the Query

Note: To collapse the Section Data panel, click 

You can modify the data item selection. For more information, see the following topics:

• “Modify the Format of a Standard Data Item” on page 100.
• “Modify How a Measure Is Aggregated” on page 102.
• “Use Detail Data Instead of Grouped and Aggregated Data” on page 103.

Rename a Standard Data Item

Note: You cannot rename hierarchies.

To change the name of a category or measure, complete these steps:

1. In the Section Data panel, select Options \(\Rightarrow\) Select Data to open the Select Data dialog box.
2. Click the Standard tab.
3. Select a data item in the Selected data items list box.
4. Click .
5. In the Rename Data Item dialog box, type the new name, and then click OK.
6. Click OK.

Remove Standard Data Items

To remove a standard data item from the Section Data panel, complete these steps:

1. In the Section Data panel, select Options \(\Rightarrow\) Select Data to open the Select Data dialog box.
2. Select the Standard tab.
3. Select a data item in the Selected data items list box.
4. Click \( \times \) to remove the data item from the **Selected data items** list box. Here are some consequences of removing data items from a section query:

- If you remove a time hierarchy, then any custom data items that are based on time functions are removed from all objects in the report section.
- If you remove a data item that has been assigned to a table or a graph, that data item is simultaneously removed from the table or the graph.
- If you remove the geographic hierarchy, then any geographical map in the section becomes invalid.
- If you remove a category or hierarchy that is being used in a report linking prompt, then the prompt association is removed. The link to the target report will still work. However, you must complete the prompt window to display the report.
- If you remove a data item that is being used in a percent of total calculation, then the percent of total calculation is removed from the table.
- If you remove a measure that is being used with a group break or in text, then the measure information is removed from the report section. For example, if you included Profit with a group break for Product, then the Profit information is removed.

5. Click **OK**.

---

**Using Custom Data Items in a Query**

**About Custom Data Items**

When a data source does not contain a calculation that you want to use in a query, you can use the measures that are contained in the data source to create a custom data item. There are two types of custom data items that you can create:

- You can use one or more measures in a selected data source to create a new calculation. For example, you could create a custom data item called Profit, which is created by using this expression: \([\text{Revenue}] - [\text{Cost}]\), where Revenue and Cost are measures in a data source. You also could create this expression: \([\text{Total_Retail_Price}] / 1000000\), where Total_Retail_Price is the measure divided by 1 million. For more information, see “Create a Custom Data Item By Entering an Expression” on page 97.

- If your query includes a time hierarchy from a multidimensional data source, then you can create a custom data item that is based on relative time. For example, you might create these expressions: \(\text{Percent change (parallel periods)} [\text{Revenue}]\), where \([\text{Revenue}]\) is the selected measure, or \(\text{Rolling Total (period to date)} [\text{COST_N}]\), where \([\text{COST_N}]\) is the selected measure. For more information, see “Create a Custom Data Item That Is Based on Relative Time” on page 98.

Measures used in a custom data item expression are always calculated by using the default aggregation method. (Within SAS Web Report Studio, it is not possible to produce a detailed calculation.)
Create a Custom Data Item By Entering an Expression

To create a custom data item by entering an expression, complete these steps:

1. In the Section Data panel, select Options ⇒ Select Data to open the Select Data dialog box.
2. Select the Custom tab.
3. A data source is selected by default. If you want to use a different data source, complete these steps:
   a. Click Select Data Source.
   b. In the Select Data Source dialog box, select a new data source. This will also change the data source for standard data items.
   c. Click OK.
4. Type the Name of the custom data item. You cannot use these characters: < > ( ) & # \.
5. Type an arithmetic expression into the Expression field. The expression is evaluated based on the aggregated values of the measures that you selected. (Within SAS Web Report Studio, it is not possible to produce a detailed calculation.)
6. After you have written the expression, click Add to add your custom data item to the Custom items box. A custom data item displays with this icon: 📅.
7. Click OK.

The following table contains some items that you can include in an expression.

### Table 12.1 Items That Can Be Included in a Custom Data Item Expression

<table>
<thead>
<tr>
<th>Items</th>
<th>Examples</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>measure names, enclosed in square brackets</td>
<td>[Profit] [Cost of Goods Sold]</td>
<td>If you select a measure from the Available measures list box and click [ ] to move it to the Expression field, then the brackets are automatically included.</td>
</tr>
<tr>
<td>parentheses</td>
<td>2 * ([COST_N] + [Sales_Cost])</td>
<td>Use parentheses when you need to perform a calculation outside of the normal order of operations.* You can type the parentheses or highlight the appropriate part of the expressions and then click [ ].</td>
</tr>
<tr>
<td>the following symbols: + (plus sign), - (minus sign), * (multiplication sign), and / (division sign)</td>
<td>[Retail_Price] - [Cost]</td>
<td>You can type the symbols or use the symbol buttons: + - * / .</td>
</tr>
<tr>
<td>numeric constants</td>
<td>[Total_Retail_Price] / 1000000</td>
<td>You cannot create a data item that is a constant value such as 500 or 500+300.</td>
</tr>
</tbody>
</table>

* In the normal order of operations, working from left to right, multiplication and division are performed first, followed by addition and subtraction.
The custom data item that you created is listed in the Section Data panel with any other selected or created data items.

*Create a Custom Data Item That Is Based on Relative Time*

If your query includes a time hierarchy from a multidimensional data source, then you can create a custom data item that is based on relative time. Complete these steps:

1. In the Section Data panel, select Options ➔ Select Data to open the Select Data dialog box.
2. Select the Custom tab.
3. A data source is selected by default. If you want to use a different data source, complete these steps:
   a. Click Change Source.
   b. In the Select Data Source dialog box, select a new data source.
   c. Click OK.
4. Type the Name of the custom data item. You cannot use these characters: < > ( ) & # \.
5. Select a measure in the Available measures field.
6. Select one of the options in the Relative time-based functions drop-down list. You can create the following calculations for the selected measure:

   **Difference (consecutive periods)**
   the difference between the previous period and the current period.

   **Difference (parallel periods)**
   the difference between the current period and the equivalent period from the previous year. For example, you might calculate the difference between the third quarter of the current year and the third quarter of the previous year.

   **Percent change (consecutive periods)**
   the difference between the previous period and the current period, expressed as a percentage of the previous period’s value.

   **Percent change (parallel periods)**
   the difference between the current period and the equivalent period from the previous year, expressed as a percentage of the previous year’s value. For example, you might calculate the percentage change between the third quarter of the current year and the third quarter of the previous year.

   **Rolling Total (period to date)**
   the sum of the values for the current period and all of the preceding periods. (This function starts over with each calendar year.)
7. Click to place your relative time expression in the Expression field. The expression is evaluated based on the aggregated values of the measures that you selected. (Within SAS Web Report Studio, it is not possible to produce a detailed calculation.)

8. Click Add to add your custom data item to the Custom items box.

9. Click OK.

The custom data item that you created is listed in the Section Data panel with any other selected or created data items.
Modify a Manually Entered Expression

*Note:* You cannot modify an expression that uses a relative time function. However, you can click **Clear** to clear it from the **Expression** field.

To modify a custom data item, complete these steps:

1. In the **Section Data** panel, select **Options** ⇒ **Select Data** to open the Select Data dialog box.
2. Select the **Custom** tab.
3. Select a custom data item in the **Custom items** box.
4. Click **Clear** and then retype the expression. Then click **Change**.
5. Click **OK**.

Remove a Custom Data Item

To remove a custom data item from a report section, complete these steps:

1. In the **Section Data** panel, select **Options** ⇒ **Select Data** to open the Select Data dialog box.
2. Select the **Custom** tab.
3. Select a custom data item in the **Custom items** box, and then click **Remove**.
   *Note:* If you remove a custom data item, it is no longer available to use in the report. If you change your mind, you must re-create the custom data item. For a list of consequences associated with removing data items, see “Remove Standard Data Items” on page 95.
4. Click **OK**.

Modifying How a Data Item Is Formatted

Modify the Format of a Standard Data Item

To change the default format of a standard data item, complete these steps:

1. In the **Section Data** panel, right-click a data item, and then select **Format** to open the Define a Format dialog box.
   *Note:* Although data source administrators can control access to which user-defined formats can be selected by report authors, they cannot control access to the standard formats that are provided by SAS Web Report Studio, such as currency and number formats for measures and date formats for date categories.
2. Select a **Type of format**.
3. Depending on which format type you selected, take the appropriate action, as shown in the following table.

<table>
<thead>
<tr>
<th>Format Selected</th>
<th>Data Item Type</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default*</td>
<td>all types</td>
<td>No action necessary.</td>
</tr>
<tr>
<td>Currency</td>
<td>measures and alphanumeric categories that are physically stored as numeric data</td>
<td>Select the number of digits to be displayed after the decimal point.</td>
</tr>
<tr>
<td>Date</td>
<td>date, time, or timestamp categories</td>
<td>Select the date format that you want to use for the data item.</td>
</tr>
<tr>
<td>Number</td>
<td>measures and alphanumeric categories that are physically stored as numeric data</td>
<td>Select the number of decimal places to be displayed and choose a format for negative numbers. You can also choose to use a thousands separator or to convert the value to a percentage. For relational data sources, you can use both options. For multidimensional data sources, you can select only one option.</td>
</tr>
<tr>
<td>Predefined**</td>
<td>alphanumeric categories that are physically stored as character data***</td>
<td>Select the predefined format that you want to apply to this data item.</td>
</tr>
<tr>
<td>Time</td>
<td>date, time, or timestamp categories</td>
<td>Select the time format that you want to use for this data item.</td>
</tr>
</tbody>
</table>

* The Default format is the one that is used in the data source that contains the data item.

** The Predefined format is available only if the data item is from a relational data source and only if the data item has been prepared by the data source administrator to offer predefined formats.

*** If an alphanumeric category that is physically stored as character data does not have any predefined formats available to choose from, then the Define a Format dialog box is not available.

4. Click OK.
Modify the Format of a Data Item

To change the format of a data item, complete these steps:

1. In the Section Data panel, right-click a data item, and then select Format to open the Define a Format dialog box.

2. Select a Type of format. For measure data items, the options are Default, Currency, and Number.

3. Depending on which format type you selected, take the appropriate action, as shown in the following table.

<table>
<thead>
<tr>
<th>Format Selected</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default*</td>
<td>No action necessary.</td>
</tr>
<tr>
<td>Currency</td>
<td>Select the number of digits to be displayed after the decimal point. If the data item is a custom data item, you can specify a currency symbol.</td>
</tr>
<tr>
<td>Number</td>
<td>Select the number of decimal places to be displayed and choose a format for negative numbers. You can also choose either to use a thousands separator or to convert the value to a percentage.</td>
</tr>
</tbody>
</table>

* The Default format is Number.

4. Click OK.

Modify How a Measure Is Aggregated

You might want a measure in a relational data source to use a different aggregation method than the default method. For example, your data source includes a measure named Unit Cost that uses the sum aggregation method. You want to use the maximum aggregation method instead.

To change the aggregation method of a measure in a relational data source, complete these steps:

1. Select Data ➔ Summarization Options to open the Summarization Options dialog box.

2. In the Aggregation drop-down list that is next to the name of the measure that you want to change, select a new aggregation method.

   Note: Your data source administrator determines whether you can change the aggregation method.
3. Click **OK**.

4. (Optional) Change the name of the measure to better reflect the new aggregation method. For example, you could change **Customer Spend** to **Average of Customer Spending**. For more information, see “Rename a Standard Data Item” on page 95.

**TIP** Sometimes changing how a measure is aggregated can give you a different view of the underlying data. For example, the measure **Supplier IDs** contains one unique ID for each supplier. The default aggregation method for **Supplier IDs** is sum. If you change the aggregation method to count, the query returns a numerical value that represents the number of suppliers. In this case, you would change the name of the measure to something more appropriate, such as **Number of Suppliers**. For more information, see “Rename a Standard Data Item” on page 95.

**Note:** For multidimensional data sources, records are always grouped and the aggregation method of a measure cannot be changed.

---

**Use Detail Data Instead of Grouped and Aggregated Data**

By default, the records in a relational data source are grouped and aggregated. This means that there is a single record for each unique combination of values across all categories in the report section. The aggregation setting is for the entire section, not for a single object.

For multidimensional data, you cannot change the grouping or aggregation. For relational data, you cannot use detail data if the report section contains any of these items:

- a crosstabulation table or a graph, with the exception of scatter plots that use relational data
• one or more custom data items

In all other circumstances, to use detail data, complete these steps:

1. Select **Data ⇒ Summarization Options** to open the Summarization Options dialog box.

2. Select one of these options:
   
   **Show every row (Detail data)**
   Select this option to show every record in the data source.

   **Show every row, excluding duplicates (Detail data)**
   Select this option to show every record in the data source and to exclude duplicate records (records where the value for the category data item or data items is identical).

   *Note:* To base a scatter plot or bubble plot on data that is not aggregated, select one of the detail data options.

3. Click **OK**.

---

**Preview or Export Query Results**

To preview or export the results of a query that you have defined, complete these steps:

1. In Edit mode, select **Data ⇒ Preview Section Data** to open the Preview Data dialog box. All columns and up to 100 rows are displayed at one time.

   *Display 12.7 Preview Data Dialog Box*

   ![Preview Data Dialog Box](image)

   *Note:* Sometimes, instead of the data, you see the message **No values were returned for this table.** This means that the section filters that you have applied have filtered out all the data from your information map, table, or cube. In this case, click **Close Window** to return to Edit mode and change the filters that you are using.

2. (Optional) To export the data to a Microsoft Excel spreadsheet or to a Microsoft Word document, click **Export** to open the Export dialog box. To export the data, click **OK**. When prompted, choose either to open the file or to save it. For more information, see “Exporting Reports and Report Data” on page 299.
3. Click **Close Window**.
Chapter 13
Subsetting Query Results

Overview of Section Filters

Filters are used to restrict the data that is returned from a query to a data source. Some relational and multidimensional data sources include predefined filters that you can select for a specific category. For relational data sources, you can also create custom category filters in SAS Web Report Studio.

There are three types of section filters that you can select or create:

- filters that are applied without prompting. Values for these types of filters are supplied when the filter is created or edited. When a report section is viewed, these filters are applied without prompting. If the filter was created by using SAS Web Report Studio, then you can edit the filter to use different values. You cannot modify filters that are defined with the data source, but you can remove them from the query.

- prompted, or interactive, filters. The values within prompted filters are obtained right before the report section is run. Typically, the prompts within the filters have default values. Before the report can be displayed, you must complete a prompt window. After the report is displayed, you can change the prompt values to see different results. The prompt style (drop-down list, selection list, text box) depends on how

Creating Section Filters

Create a Section Filter for an Alphanumeric Category
Create a Section Filter for a Date, Time, or Timestamp Category

Creating Prompted Section Filters

Create a Prompted Section Filter for an Alphanumeric Category
Create a Prompted Section Filter for a Date Category

Creating Cascading Prompted Filters Within a Section

Defining and Applying Prompted Filters
Ordering Prompted Filters
Defining Dependencies Between Two Prompted Filters
Supplying Values for a Cascading Prompt

Apply Existing Section Filters

Combine Section Filters

Deselect a Predefined or Custom Section Filter

Remove a Custom Section Filter
you or the data source administrator created the filter. To change the prompt values, refresh the report data as described in “Refreshing the Data in a Viewed Report” on page 46.

- cascading, prompted filters provide different filter choices depending on a previously selected filter value. These filters are a special type of prompted filter. For example, if you select Clothing as the value for a Product Category filter, then the subsequent filter for Product Name might be restricted to choices such as Eclipse Sportswear, Tracker T-shirts, and Green Tomato Knitwear. However, if you select Camping Gear as the value for the Product Category filter, then the Product Name filter might be restricted to choices such as Orion Trekking Poles, Eclipse Sleeping Bags, and Tracker Backpacks.

**T I P** Before creating a new section filter, review “Creating Section Filters” on page 313.

---

**Creating Section Filters**

**Create a Section Filter for an Alphanumeric Category**

To create a section filter for an alphanumeric category in a relational data source, complete these steps:

1. At the top of the Section Data panel, click Options \ Section Filters. This opens the Section Filters dialog box. Click New to open the Create Custom Filter dialog box.

**Display 13.1  Create Custom Filter Dialog Box**
2. In the Filter name field, accept the default name or provide a different name. For example, if the filter will restrict results to Canada, type a name such as Country Filter for Canada. The filter name appears in the Apply custom filters box in the Section Filters dialog box.

3. From the Data item drop-down list, select the alphanumeric data item that you want to filter. Recall that alphanumeric categories can be made up of all letters, all numbers, or a combination of the two. They can be physically stored as character or numeric data.

4. From the Operator drop-down list, specify how you want to filter the values from the data source. For example, you might want users to see results that are equal to the filter values.

   Different operators might be available based on whether you choose to filter against character values or non-character values. Formatted values are always recognized as character values. However, unformatted values can be character, numeric, dates, or some other type.

5. (Optional) If the selected data item enables you to filter on formatted values, then you can select the Filter on formatted values option. Regardless of your selection, the results show formatted values.

6. If you selected Is missing or Is not missing, then you have created the filter. For all other operators, see the following table.

\[\text{Table 13.1 Operators and Required Information}\]

<table>
<thead>
<tr>
<th>Operator</th>
<th>Required Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Is equal to or Is not equal to</td>
<td>If the data item supports displaying values, click Get Values to load values into the Available values box. Click (\rightarrow) or (\leftarrow) to move values from the Available values box into the Selected values box. You can also create your own list of values or add to a dynamically generated list. Type each value into the Type a value to add field and then click (\rightarrow) next to the field to add the value into the Selected values box.</td>
</tr>
<tr>
<td>Is between values (inclusive) or Is not between values (inclusive)</td>
<td>If the data item supports displaying values, click Get Values to load values into the Minimum value and Maximum value fields. You can also type the minimum and maximum values.</td>
</tr>
<tr>
<td>Contains or Does not contain</td>
<td>This operator is not available for unformatted numeric values.</td>
</tr>
<tr>
<td></td>
<td>In the Value field, type the text that you want the filter to match. For example, if you type Assist for a filter on the job title, then the results will contain (or not contain) values such as Concession Assistant I and Marketing Assistant I.</td>
</tr>
<tr>
<td>Match pattern or Does not match pattern</td>
<td>This operator is not available for unformatted numeric values.</td>
</tr>
<tr>
<td></td>
<td>In the Value field, type the text that you want the filter to match. Use an asterisk (<em>) to represent multiple characters or use a question mark (?) to represent any single character. For example, if you type Sales</em> for a filter on the job title, then the query results will match (or not match) values such as Sales Manager and Sales Rep. I.</td>
</tr>
</tbody>
</table>

---

1 The data type is a factor in whether the data item supports filtering on formatted values. This is true for the date, time, or timestamp data types, because formatted values are not permitted for these types even if a format has been applied to the data item.

2 Filtering on formatted values can sometimes adversely affect query performance. If you have questions about whether you should select this option, contact your data source administrator.
<table>
<thead>
<tr>
<th>Operator</th>
<th>Required Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Is less than or Is less than or equal to</td>
<td>One numeric value is required.</td>
</tr>
<tr>
<td>Is greater than or Is greater than or equal to</td>
<td>One numeric value is required.</td>
</tr>
</tbody>
</table>

7. You can also select **Browse** or **Search** to find available values. For more information, see “Browsing or Searching for Filter Values” on page 201.

8. Click **OK**.

9. When you access the Create Custom Filter dialog box from the Section Filters dialog box, then the filter that you just created is automatically selected in the **Apply custom filters** box. When the filter name is selected, the filter expression is shown in the **Expression** box.

**TIP** Custom filters can be saved for future use. To turn off the filter, clear the check box next to the filter name. For more information, see “Apply Existing Section Filters” on page 121.

To save the new section filter and exit the Section Filters dialog box, click **OK**.

**Note:** If you click **Cancel**, your new section filter is discarded.

New section filters are automatically added to the existing filter combination expression. By default, new section filters are joined using the AND operator, which means that the query results must match all selected section filters. For more information, see “Combine Section Filters” on page 122.

**Create a Section Filter for a Date, Time, or Timestamp Category**

To create a section filter for a date, time, or timestamp category in a relational data source, complete these steps:

1. At the top of the **Section Data** panel, click **Options** ⇒ **Section Filters**. This opens the Section Filters dialog box. Click **New** to open the Create Custom Filter dialog box.

2. In the **Filter name** field, accept the default name or provide a different name. For example, if you want to filter the query to return data before a specified time, type a name such as **Data Entered Before 5:00 pm**. The filter name appears in the **Apply custom filters** box in the Edit Filters dialog box.

3. From the **Data item** drop-down list, select the date, time, or timestamp data item that you want to filter.

4. From the **Operator** drop-down list, specify how you want to filter the values from the data source. For example, you might want users to see query results that are before or equal to the filter values.

5. If you selected **Is missing** or **Is not missing**, then you have created the filter. For all other operators, see the following table.
### Table 13.2  Operators, Category Types, and Required Information

<table>
<thead>
<tr>
<th>Operator</th>
<th>Category Type</th>
<th>Required Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Is equal to, Is not equal to, Is after, Is after or equal to, Is before, and Is before or equal to</td>
<td>Dates</td>
<td>Use the <strong>Date</strong> field to type a date or click [\text{Open}] to use the date picker. Note that the list of valid formats depends on your locale and language.</td>
</tr>
<tr>
<td></td>
<td>Times</td>
<td>Use the <strong>Time</strong> drop-down lists to select an hour, a minute, and a second in 24-hour time. For example, to specify 5 p.m., select (17, 00, \text{and } 00).</td>
</tr>
<tr>
<td></td>
<td>Timestamps</td>
<td>Use the <strong>Date</strong> field to type a date or click [\text{Open}] to use the date picker. Use the <strong>Time</strong> drop-down lists to select an hour, a minute, and a second in 24-hour clock time.</td>
</tr>
<tr>
<td>Is between values (inclusive) and Is not between values (inclusive)</td>
<td>Dates</td>
<td>Use the <strong>Minimum</strong> and <strong>Maximum</strong> drop-down lists to specify the minimum and maximum dates. Use the <strong>Date</strong> fields to type a minimum and maximum date or click [\text{Open}] to use the date picker. Note that the list of valid formats depends on your locale and language.</td>
</tr>
<tr>
<td></td>
<td>Times</td>
<td>Use the <strong>Minimum</strong> and <strong>Maximum</strong> drop-down lists to select a minimum and maximum hour, minute, and second in 24-hour clock time.</td>
</tr>
<tr>
<td></td>
<td>Timestamps</td>
<td>Use the <strong>Minimum</strong> and <strong>Maximum</strong> drop-down lists to specify the minimum and maximum dates and times. Use the <strong>Date</strong> fields to type a date or click [\text{Open}] to use the date picker. Note that the list of valid formats depends on your locale and language. Use the <strong>Time</strong> drop-down lists to select the hours, minutes, and seconds in 24-hour clock time.</td>
</tr>
</tbody>
</table>

6. Click **OK**.

7. When you access the Create Custom Filter dialog box from the Section Filters dialog box, the filter that you just created is automatically selected in the **Apply custom filters** box. When the filter name is selected, the filter expression is shown in the **Expression** box.

   **Tip**: Custom filters can be saved for future use. To turn off the filter, clear the check box next to the filter name. For more information, see “Apply Existing Section Filters” on page 121.

To save the new section filter and exit the Section Filters dialog box, click **OK**.

*Note*: If you click **Cancel**, your new section filter is discarded.
New section filters are automatically added to the existing filter combination expression. By default, new section filters are joined using the AND operator, which means that the query results must match all selected section filters. For more information, see “Combine Section Filters” on page 122.

Creating Prompted Section Filters

Create a Prompted Section Filter for an Alphanumeric Category

To create a prompted section filter for an alphanumeric category in a relational data source, complete these steps:

1. To access the Create Custom Filter dialog box, perform one of these tasks:
   • At the top of the Section Data panel, click Options ⇄ Section Filters to open the Section Filters dialog box.
   • Select Data ⇄ Section Filters.
   • In the Report Wizard (Step 2), click Section filters to open the Section Filters dialog box.
   • In the Section Data panel in Edit mode, select Options ⇄ Section Filters.
Display 13.3  Section Filters Dialog Box with Predefined Filters

2. Click New to open the Create Custom Filter dialog box.

Display 13.4  Create Custom Filter Dialog Box

3. In the Filter name field, accept the default name or provide a different name. For example, if you are creating a prompted filter that will enable users to select a country, type a name such as Prompted Country Selection. The filter name appears in the Apply custom filters box in the Section Filters dialog box.

4. From the Data item drop-down list, select the alphanumeric data item that you want to filter. Recall that alphanumeric categories can be made up of all letters, all numbers, or a combination of the two. They can be physically stored as character or numeric data.

5. (Optional) Select the Prompt user to enter values option.
a. Specify a Prompt type. The choices for prompt type are Dynamically generate values, Create a list of values, and Request user to type values.

b. For all operator types, in the Prompt text field, type instructions for using the prompt. For example, you might type Select one or more countries to include in the report. There is no limit to the number of characters that you can type. The prompt text appears in the prompt window.

c. For all operator types, in the Prompt name field, accept the default name or type a new name for the prompt. The prompt name appears in the prompt window and in the Report Linking dialog box.

d. Select the Allow user to specify multiple values check box.

e. Select the Include “all possible values” as a value check box. This option is limited to prompts that enable users to specify more than one value when filling in a prompt in View mode.

   Note: This option is limited to the Dynamically generate values and Create a list of values prompt types. If the prompt type is Dynamically generate values, then “all possible values” acts as if there is no filter and all values are shown in the results. If the prompt type is Create a list of values, then “all possible values” refers to all the values in the list that the prompt author created. If there are values for that data item that do not exist in the list, then they will not appear in the results.

6. (Optional) If the selected data item enables you to filter on formatted values, then you can select the Filter on formatted values option. Regardless of your selection, the query results show formatted values. ¹

7. From the Operator drop-down list, specify how the prompt values should be used to filter the values from the data source. For example, you might specify that you want users to see query results that are equal to the entered prompt values.

   Different operators might be available based on whether you choose to filter against character values or non-character values. Formatted values are always recognized as character values. However, unformatted values can be character, numeric, dates, or some other type.

8. Your next steps depend on the operator that you selected.

   If you selected Contains, Does not contain, Matches pattern, or Does not match pattern, then complete these steps:

   a. If you are creating a prompt with the type of Create a list of values, then at least one value must appear in the Selected values list. The first item in the Selected values list becomes the default value. When the report is run, the prompts window will verify that a valid value has been supplied before the report can be viewed.

      Tip: If you can view the report when it appears that no default value has been supplied, use the Backspace key in the Default value field to make sure that the field is not blank. (Blank is a valid value for a prompted filter.)

   b. (Optional) Select the Ignore case check box.

¹ Filtering on formatted values can sometimes adversely affect query performance. If you have questions about whether you should select this option, contact your data source administrator.
If you selected *Is equal to*, *Is not equal to*, *Is between values (inclusive)* or *Is not between values (inclusive)*, then your next steps depend on the type of prompt that you selected. The steps are explained in the following table.

*Note:* The data source administrator determines whether the Dynamically generate values option is available.

**Table 13.3  Operators and Prompt Types**

<table>
<thead>
<tr>
<th>Operator</th>
<th>Request user to type values</th>
<th>Create a list of values</th>
<th>Dynamically generate values</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Is equal to</strong> or <strong>Is not equal to</strong></td>
<td>(Optional) Type a default value. Specify whether users can select multiple values.</td>
<td>If the data item supports displaying values, click <strong>Get Values</strong> to load values into the <strong>Available values</strong> box. Click <strong>or</strong> to move values from the <strong>Available values</strong> box into the <strong>Selected values</strong> box. You can also create your own list of values or add to a dynamically generated list. Type each value into the <strong>Type a value to add</strong> field and then click <strong>next to the field to add the value into the Selected values box.</strong> The default value is the first value in the <strong>Selected values</strong> list. Specify whether users can select multiple values.</td>
<td>(Optional) Type a default value. Specify whether users can select multiple values.</td>
</tr>
<tr>
<td><strong>Is between values</strong> (inclusive) or <strong>Is not between values</strong> (inclusive)</td>
<td>Select or type defaults for the minimum and maximum values. If the data item supports displaying values, click <strong>Get Values</strong> to load values into the drop-down lists.</td>
<td>If the data item supports displaying values, click <strong>Get Values</strong> to load values into the <strong>Available values</strong> box. Click <strong>or</strong> to move values from the <strong>Available values</strong> box into the <strong>Selected values</strong> box. You can also create your own list of values or add to a dynamically generated list. Type each value into the <strong>Type a value to add</strong> field and then click <strong>next to the field to add the value into the Selected values box.</strong> The default value is the first value in the <strong>Selected values</strong> list.</td>
<td>Type defaults for the minimum and maximum values.</td>
</tr>
</tbody>
</table>
If you selected **Create a list of values**, then complete these steps:

a. Either select values from the **Available values** list and move them to the **Selected values** list or enter a value in the **Type a value to add** field and move it to the **Selected values** list.

b. (Optional) Select the **Allow user to specify multiple values** check box.

9. You can also select **Browse** or **Search** to find available values. For more information, see “Browsing or Searching for Filter Values” on page 201.

10. Click **OK**.

11. If you accessed the Create Custom Filter dialog box from the Section Filters dialog box, then you can see that the filter you just created is now displayed and selected in the **Apply custom filters** box on the Section Filters dialog box. When the filter name is selected, the filter expression is shown in the **Expression** box.

**Tip**: Custom filters can be saved for future use. To turn off the filter, clear the check box next to the filter name. For more information, see “Apply Existing Section Filters” on page 121.

To save the new section filter and exit the Section Filters dialog box, click **OK**.

**Note**: If you click **Cancel**, your new section filter is discarded.

**Display 13.5**  
Section Filters Dialog Box Showing a New, Prompted, Selected Custom Filter for an Alphanumeric Category and Its Expression

New section filters are automatically added to the existing filter combination expression. By default, new section filters are joined using the AND operator, which means that the query results must match all selected section filters. For more information, see “Combine Section Filters” on page 122.

### Create a Prompted Section Filter for a Date Category

To create a prompted section filter for a date, time, or timestamp in a relational data source, complete these steps:

1. At the top of the **Section Data** panel, click **Options ⇒ Section Filters** or select **Data ⇒ Section Filters**. This opens the Section Filters dialog box. Click **New** to open the Create Custom Filter dialog box.

2. In the **Filter name** field, accept the default name or provide a different name. For example, if you are creating a prompted filter that will enable users to select a date
range, type a name such as Prompted Beginning and Ending Date. The filter name appears in the Apply custom filters box in the Section Filters dialog box.

3. From the Data item drop-down list, select the date data item that you want to filter.

4. From the Operator drop-down list, specify how the prompt values should be used to filter the values from the data source. For example, you might specify that you want users to see query results that are between the entered prompt values.

5. Select the Prompt user to enter values check box.

6. In the Prompt text field, type instructions for using the prompt. For example, you might type Display data for employees who were hired after your selected date. There is no limit to the number of characters that you can type. The prompt text appears in the prompt window.

7. In the Prompt name field, accept the default name or type a new name for the prompt. The prompt name appears in the prompt window and in the Report Linking dialog box.

8. Depending on which operator you selected, enter the required information.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Required Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Is equal to, Is not equal to, Is after, Is after or equal to, Is before, and Is before or equal to</td>
<td>In the Date field, type a date or click to use the date picker. Note that the list of valid formats depends on your locale and language. A default value is not required. You can backspace over the displayed date to erase it.</td>
</tr>
<tr>
<td>Is between values (inclusive) and Is not between values (inclusive)</td>
<td>In the Date fields, type a minimum date and a maximum date or click next to each field to use the date picker. Note that the list of valid formats depends on your locale and language. A default value is not required. You can backspace over the displayed date to erase it.</td>
</tr>
</tbody>
</table>

9. Click OK.

10. When you access the Create Custom Filter dialog box from the Section Filters dialog box, the filter that you just created is automatically selected in the Apply custom filters box. When the filter name is selected, the filter expression is shown in the Expression box.

   **TIP** Custom filters can be saved for future use. To turn off the filter, clear the check box next to the filter name. For more information, see “Apply Existing Section Filters” on page 121.

To save the new section filter and exit the Section Filters dialog box, click OK.

*Note:* If you click Cancel, your new section filter is discarded.
New section filters are automatically added to the existing filter combination expression. By default, new section filters are joined using the AND operator, which means that the query results must match all selected section filters. For more information, see “Combine Section Filters” on page 122.

Creating Cascading Prompted Filters Within a Section

Defining and Applying Prompted Filters

A prompted filter can be included in a cascade if it meets the following requirements:

- It is based on a relational data source.

- The data item associated with the prompt filter allows the user to see its values. (The data source creator sets this in the information map using SAS Information Map Studio. To verify this in SAS Information Map Studio, select Properties on a data item. In the Value-Generation Method tab, the User selects values from a dynamic list option should be selected.)

- The prompt type of the prompted filter allows the values of the data item associated with the prompted filter to be loaded dynamically.

In SAS Web Report Studio, you can set the prompt type to dynamic in the Custom Filter dialog box by selecting the Dynamically generate values option from the Prompt type drop-down list.

A non-prompted filter can be included in a cascade if it begins the cascade. However, it will not appear in the prompts window.

Prompted filters defined in either SAS Web Report Studio or SAS Information Map Studio can be used in a cascade. You have to select them in the Section Filters dialog box to participate in the cascade.
Ordering Prompted Filters

You can order all applied prompted filters, whether they participate in a cascade, using the Manage Prompts dialog box, which is available from the Section Filters dialog box.

*Note:* Only certain users can manage prompts. If you have questions about your authorization, contact your system administrator.

The Prompt Order section enables you to specify the order in which the prompts appear on the prompts window or any other window where values for prompts need to be filled in. To reorder, select the prompt that you want to move, and then click ◁ or ▶ to move the prompted filter up or down in the order. If prompts are in a cascade, the prompts should appear consecutively in cascade order. However, you can put the prompts in any order.

Defining Dependencies Between Two Prompted Filters

A cascade relationship is defined between a prompt contained in one prompted filter and another filter.

For example, Filter 1 is called *City Filter* and contains the prompt called *City Prompt*, and Filter 2 is called *State Filter* and contains the prompt called *State Prompt*. To define a cascade between the filters, you would specify that *City Prompt* depends on *State Filter*. Note that the information that would be displayed by the prompt is always a subset of what would be displayed by the filter.

You can define dependencies using the Manage Prompts dialog box in the Prompt Dependencies section. The *Prompt* drop-down list contains the names of the prompts that can participate in a cascade. The *Dependency* drop-down list contains the names of the filters that can participate in a cascade.

To define a cascade, complete these steps:

1. Select an entry from both the *Prompt* and *Dependency* drop-down lists.
2. Click **Add**. The prompt dependency appears in the Prompt Dependencies area.

3. Click **OK**.

The cascade definitions do not have to appear in any particular order. However, when you click **OK**, a check is performed to ensure that there are no circular dependencies or other illegal cascade definitions.

To remove a cascade, select an entry in the Prompt Dependencies area and then click **Remove**. If you remove a cascade that was a part of a chain, then the chain is not repaired to skip the missing item. For example, you have three cascade definitions where **ZIP code** depends on **City**, **City** depends on **State**, and **State** depends on **Region**. If you remove **City**, which depends on **State**, then the definition is not altered to make **ZIP code** somehow dependent on **Region**.

### Supplying Values for a Cascading Prompt

When cascading prompts appear on the prompts window, each dependent prompt is disabled until you supply the information for the filter that the prompt depends on.

In the following display, **CENTRAL** has been selected for the **Region** prompted filter, so the **State** prompt has been populated with states that are in the central region and the **State** prompted filter is enabled.

**Display 13.8  Example of a Cascading Prompt for Region**
In the following display, MN has been selected for the State prompted filter, so the City prompt is populated with the cities in Minnesota and the City prompted filter is enabled.

**Display 13.9  Example of a Cascading Prompt for State**

Next, a user can select cities and then click View Report to see the report based on the results of the cascaded prompt.

---

**Apply Existing Section Filters**

Your data source administrator can create filters or prompted filters for categories in relational data sources. You can also create and save custom filters for use at a later time.

To use one or more existing section filters, complete these steps:

1. Select either Options ⇒ Section Filters or Data ⇒ Section Filters to open the Section Filters dialog box.

2. In the Apply predefined filters or Apply custom filters box, select the check box for the filters that you want to apply to the section query. Select the name of a predefined filter to edit it or to view its description, which is displayed beneath the box. Select the name of a custom filter to edit it or to view its expression, which is displayed beneath the box.
If you select a prompted filter for the section query, the user sees a prompt window that must be completed before the report displays. The user can change the query results by selecting different values for the prompt. The filter creator determines the style of the prompt. For example, the prompt might appear as a drop-down list, a selection list, or a text box.

**Display 13.11  Prompted Filter for a Section Query**

---

**Combine Section Filters**

The default filter combination is **AND filters**. To modify the default filter combination, complete these steps:

1. Select either **Options → Section Filters** or **Data → Section Filters** to open the Section Filters dialog box.

2. Click **Combine Filters** to open the Filter Combination dialog box.
3. Select one of these options:

**AND filters**
Select this option if you want to see only observations that match all filters. If there are no observations that match all filters, then no data is returned. This option is the default.

**OR filters**
Select this option if you want to see any observation that matches any of the filters. Data is returned if at least one observation matches at least one filter.

**Custom**
If you choose this option, then you can write a simple, conditional expression that combines your selected filters. In the text field, you can type an expression that includes these items:

- the names of filters, enclosed in square brackets ( [ ] )
- parentheses
- the words **AND** and **OR** to join the names of the filters or items inside parentheses.

*Display 13.12 Combine Filters Dialog Box*

4. Click **OK**.

---

**Deselect a Predefined or Custom Section Filter**

If the check box next to a filter name is not checked, then the filter is not applied to the section query. To deselect a currently applied predefined or custom section filter, complete these steps:

1. Select either **Options** ⇄ **Section Filters** or **Data** ⇄ **Section Filters** to open the Section Filters dialog box.

2. In the Apply predefined filters or Apply custom filters box, select the check box next to the name of the filter that you do not want applied to the section query.
3. Click **OK**.

   **Note:** If you click **Cancel**, your actions are not performed.

---

**Remove a Custom Section Filter**

*Note:* If you want to keep the filter for use at a later time, deselect its check box.

To remove a custom section filter so that it no longer applies to the section query, complete these steps:

1. Select either **Options** ⇒ **Section Filters** or **Data** ⇒ **Section Filters** to open the Section Filters dialog box.

2. In the **Apply custom filters** box, select the name of the filter that you want to remove from the section query.

3. Click **Remove**.

4. Click **OK** in the message box to confirm the removal of the filter.

   **Note:** If you click **Cancel**, the filter is not removed.
Chapter 14
Grouping Query Results

Overview of Using Group Breaks

Each report section can be divided by one or more group breaks. Each group break is based on a category or hierarchy level. It groups the data for each distinct value of that category or hierarchy level. Group breaks are applicable when your report uses data items selected from a data source.

These features, discussed here, are options when you are creating a group break:
• You can include one or more measure values with each group break level.
• You can sort each level in ascending or descending order.
• If you select a page break to go with each group break, then the report displays a list of group break values in the Table of Contents panel for navigation.

The following advanced group break features are discussed in other parts of this documentation:
• You can link group break values to a report or to a Web page. For more information, see “Creating a Link for a Group Break” on page 287.
• Reports with group breaks can be distributed to targeted recipients based on the breaks. For example, you have a sales report with group breaks on regions. Each sales manager in the recipient list could receive information about his or her respective region only.

Add Group Breaks

The number of group break levels that you can create depends on how many categories or hierarchies are in the report section. For example, if you have three categories and two
hierarchies, then you can specify four breaks, which means that you will see one drop-down list for **Break by values of** and three drop-down lists for **Then by values of**.

*Note:* Group breaks cannot be used on different levels of the same hierarchy.

Data items that act as hyperlinks are not allowed to be group break variables, so they are always removed from the list.

To specify group breaks, complete these steps:

1. In Edit mode, select **Data ⇒ Group Breaks** or from the **Table of Contents** panel, select **Options ⇒ Group Breaks** to open the Group Breaks dialog box.

2. On the **Group Breaks** tab, complete these steps:
   a. Select the first group break level in the **Break by values of** list. The **Break by values of** list contains all the categories and hierarchy levels in the report section.
      *Note:* If you select a data item that is already assigned to a table or graph, it will be removed from that object.
   b. (Optional) Select additional group break levels from any available **Then by values of** list.
   c. Select a sort option for the category or hierarchy level values. The default is **Ascending**.
      *Note:* If the data cannot be sorted, this option is not available.
   d. (Optional) Select the **New page for each value** check box.
   e. (Optional) Use the formatting tools to change the default font, font size, font style, background color, and foreground color.
   f. (Optional) Select the **Label each value** option to label each group break with its category or hierarchy name. If you include a dynamic measure with one or more group breaks, then this option also applies to labeling measures.

For multidimensional data, select the **Label each value** option to label each group break with the hierarchy and level names, followed by the value (for example, `PRODHIER.PRODNAME: Furniture.Bed`).

*Display 14.1*  **Group Breaks Tab in the Group Breaks Dialog Box**

3. (Optional) Use the **Measure values** tab to complete these steps:
a. Select a group break in the **For group break level** drop-down list. The list contains the group breaks that you selected on the **Group Breaks** tab.

b. In the **Show measure value** list, select the measure value that you want to display for each group break level. For example, if you select **Country** as the group break level, you might select **Total Profit** as the data item value. The profit aggregated across each country is displayed at each group break level.

   *Note:* The measure value is an aggregation for each group break that you selected.

```
Display 14.2 Measure Values Tab in the Group Breaks Dialog Box
```

Note: If you remove the selected measure from the report, then the measure value is removed from the group break.

c. Click **Add** to add your **For group break level** and **Show measure value** selections to the **Group break level/value** box.

4. Click **OK**.

   For reports that contain tables, graphs, or geographical maps that have been filtered, drilled, or expanded, these actions are taken:
   
   • Filters and conditional highlighting that depend on a data item that you have selected as a group break are removed from the filtered table, graph, or geographical map.
   
   • Navigation (drilling or expanding) that has been performed on a data item that you have selected as a group break are removed from the drilled or expanded table, graph, or geographical map. (Expanding and drilling are performed in View mode.)

   In addition, if you create a group break that is based on any level in a geographic hierarchy, then any geographical map in the report section becomes invalid.

   *Note:* To collapse the **Group Breaks** section, click ☁.

   Here is an example of how group breaks appear in a report that is based on multidimensional data:
Remove Measure Values from Group Breaks

To remove measure values from group breaks, complete these steps:

1. In Edit mode, select Data ⇒ Group Breaks or from the Table of Contents panel, select Options ⇒ Group Breaks to open the Group Breaks dialog box.

2. Select the Measure values tab.

3. Select an item in the Group break level/value box.

4. Click Remove.

5. Click OK.

Remove Group Breaks

To remove group breaks, complete these steps:

1. In Edit mode, select Data ⇒ Group Breaks or from the Table of Contents panel, select Options ⇒ Group Breaks to open the Group Breaks dialog box.
2. Select **None** for the first level of group breaks that you want to remove. All subsequent breaks are also removed. For example, if four group break levels are available, you can remove the second, third, and fourth group breaks by selecting **None** as the second break.

3. Click **OK**.
Chapter 15
Displaying Query Results in a Table, Graph, or Geographical Map

Overview of Using Tables, Graphs, and Geographical Maps to Display Results . 132

Using Tables to Display Query Results .................................................. 133
Overview of the Table Types ................................................................. 133
Insert a Table into a Report Layout ......................................................... 134
Specifying How Data Items Are Used in Tables ....................................... 136
Replace a Category Data Item in a Crosstabulation Table ......................... 137
Create or Modify a Table Title ............................................................... 138
Specify the Number of Columns and Rows to Display in a Table ............... 139
Specify the Border Color of a Table ....................................................... 140
Add Row Numbers to a List Table ......................................................... 141
Specify Style Properties for Headings, Subheadings, and Cells ................. 142
Specify Style Properties for Total and Subtotal Values ........................... 144
Copy the Formatting of a Selected Table ............................................... 145
Change the Currently Selected Table Type ............................................. 145
Move Columns and Rows in Tables in View Mode .................................. 146
Resize Columns in a Table ...................................................................... 147
Align Values in Columns or Rows in Tables in View Mode ......................... 147

Using Hyperlink Data Items ................................................................. 147

Using Graphs to Display Query Results ................................................ 149
Overview of the Graph Types ............................................................... 149
Insert a Graph into a Report Layout ....................................................... 153
Specifying How Data Items Are Used in Graphs ..................................... 155
Create or Modify a Graph Title ............................................................. 164
Specify the Size of a Graph ................................................................. 165
Specify the Border and the Border Color of a Graph ............................... 166
Specify the Background Color of a Graph ............................................. 166
Turn Grid Lines On or Off .................................................................... 166
Specify the Scale Type and Style of the Axis ........................................ 167
Add, Modify, or Remove Reference Lines .............................................. 168
Specify the Position, Label Style, and Background Color of the Legend .... 170
Copy the Formatting of a Selected Graph ............................................... 171
Change the Currently Selected Graph Type .......................................... 172
Specifying Properties That Are Specific to a Graph Type ......................... 172

Using Geographical Maps to Display Query Results .............................. 176
About Geographical Maps .................................................................... 176
Insert a Geographical Map ................................................................. 177
Select a Measure for a Geographical Map ............................................. 177
Change the Measure Used in a Geographical Map ................................. 178
Zoom and Pan a Geographical Map ...................................................... 179
Overview of Using Tables, Graphs, and Geographical Maps to Display Results

After selecting your data items and filters, you will want to add one or more view elements to display the results. For more information about selecting data items and filters, see Chapter 12, “Defining Queries to Obtain Results,” on page 91.

SAS Web Report Studio enables you to select two different table types: crosstabulation tables and list tables. For more information about using tables, see “Using Tables to Display Query Results” on page 133.

SAS Web Report Studio provides eight different graph types: bar charts, line graphs, bar-line charts, pie charts, scatter plots, bubble plots, progressive bar charts, and tile charts. For more information about using graphs, see “Using Graphs to Display Query Results” on page 149.

Geographical maps enable you to consider spatial proximity as part of your analysis. You can add geographical maps to reports that use data items from a multidimensional data source that has been enabled for geographical mapping. For more information about using geographical maps, see “Using Geographical Maps to Display Query Results” on page 176.
Using Tables to Display Query Results

Overview of the Table Types

About List Tables
A list table is a two-dimensional representation of data in which the data values are arranged in unlabeled rows and labeled columns. List tables are applicable when you select data items from a relational data source.

Display 15.1 A List Table

<table>
<thead>
<tr>
<th>Name</th>
<th>Gender</th>
<th>Age</th>
<th>Height</th>
<th>Weight</th>
<th>BMI</th>
</tr>
</thead>
<tbody>
<tr>
<td>Phillip</td>
<td>M</td>
<td>16</td>
<td>72.0</td>
<td>150.0</td>
<td>20.34</td>
</tr>
<tr>
<td>Ronald</td>
<td>M</td>
<td>15</td>
<td>67.0</td>
<td>133.0</td>
<td>20.83</td>
</tr>
<tr>
<td>Mary</td>
<td>F</td>
<td>15</td>
<td>66.5</td>
<td>112.0</td>
<td>17.00</td>
</tr>
<tr>
<td>William</td>
<td>M</td>
<td>15</td>
<td>66.5</td>
<td>112.0</td>
<td>17.00</td>
</tr>
<tr>
<td>Janet</td>
<td>F</td>
<td>15</td>
<td>62.5</td>
<td>112.5</td>
<td>20.25</td>
</tr>
<tr>
<td>Henry</td>
<td>M</td>
<td>14</td>
<td>63.5</td>
<td>102.5</td>
<td>17.07</td>
</tr>
<tr>
<td>Judy</td>
<td>F</td>
<td>14</td>
<td>64.3</td>
<td>98.0</td>
<td>15.30</td>
</tr>
<tr>
<td>Carol</td>
<td>F</td>
<td>14</td>
<td>62.8</td>
<td>102.5</td>
<td>18.27</td>
</tr>
<tr>
<td>Alfred</td>
<td>M</td>
<td>14</td>
<td>69.0</td>
<td>112.5</td>
<td>16.61</td>
</tr>
<tr>
<td>Barbara</td>
<td>F</td>
<td>13</td>
<td>65.3</td>
<td>96.0</td>
<td>16.16</td>
</tr>
<tr>
<td>Jeffrey</td>
<td>M</td>
<td>13</td>
<td>62.5</td>
<td>84.0</td>
<td>15.12</td>
</tr>
<tr>
<td>Alex</td>
<td>F</td>
<td>13</td>
<td>56.5</td>
<td>84.0</td>
<td>18.50</td>
</tr>
<tr>
<td>Jane</td>
<td>F</td>
<td>12</td>
<td>59.6</td>
<td>84.5</td>
<td>16.61</td>
</tr>
<tr>
<td>James</td>
<td>M</td>
<td>12</td>
<td>57.3</td>
<td>83.0</td>
<td>17.77</td>
</tr>
<tr>
<td>Louise</td>
<td>F</td>
<td>12</td>
<td>56.3</td>
<td>77.0</td>
<td>17.08</td>
</tr>
<tr>
<td>John</td>
<td>M</td>
<td>12</td>
<td>59.0</td>
<td>99.5</td>
<td>20.09</td>
</tr>
<tr>
<td>Robert</td>
<td>M</td>
<td>12</td>
<td>64.8</td>
<td>126.0</td>
<td>21.43</td>
</tr>
<tr>
<td>Joyce</td>
<td>F</td>
<td>11</td>
<td>51.3</td>
<td>50.0</td>
<td>13.49</td>
</tr>
<tr>
<td>Thomas</td>
<td>M</td>
<td>11</td>
<td>57.5</td>
<td>85.0</td>
<td>18.07</td>
</tr>
</tbody>
</table>

For more information about sorting columns, see “Sorting Data in a List Table” on page 213.

About Crosstabulation Tables
A crosstabulation table shows an aggregate metric for the intersections of two or more categories. In a crosstabulation table, categories are typically displayed on both the columns and the rows, and each cell value represents the aggregated measure from the intersection of the categories on the specific row and column. This uses less space than a list table and is easier to read because data is grouped both horizontally and vertically.

Display 15.2 A Crosstabulation Table That Is Based on Data Items from a Relational Data Source

<table>
<thead>
<tr>
<th>Order Year</th>
<th>2004</th>
<th>2005</th>
<th>2006</th>
<th>2007</th>
<th>2008</th>
</tr>
</thead>
<tbody>
<tr>
<td>Retail Sale</td>
<td>$2,068,764.87</td>
<td>$2,121,486.88</td>
<td>$1,455,528.09</td>
<td>$1,174,659.87</td>
<td>$1,401,107.20</td>
</tr>
<tr>
<td>Catalog Sale</td>
<td>$118,571.05</td>
<td>$128,763.12</td>
<td>$140,545.12</td>
<td>$129,206.99</td>
<td>$102,243.87</td>
</tr>
<tr>
<td>Internet Sale</td>
<td>$89,532.85</td>
<td>$87,450.68</td>
<td>$110,471.03</td>
<td>$113,828.73</td>
<td>$135,289.84</td>
</tr>
</tbody>
</table>
For crosstabulation tables that are based on multidimensional data sources, the hierarchy level names are displayed in the table, rather than the hierarchy names. In the following display, *Year* is a level in a hierarchy named *Time* and *Continent* is a level in a hierarchy named *Geography*.

**Display 15.3**  
A Crosstabulation Table That Is Based on Data Items from a Multidimensional Data Source, Drilling and Expanding Are Enabled

![Crosstabulation Table](image)

**Insert a Table into a Report Layout**

If the section query is based on a relational data source, you can display the query results in a list table or a crosstabulation table. If the section query is based on a multidimensional data source, you can display the results in a crosstabulation table.

To insert a table into a report layout, perform one of these tasks:

- Click the table tool on the horizontal toolbar above the layout grid to insert the table in the next available cell.
- Drag the table tool from the toolbar into a specific cell.

The following table lists the available table tools:

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>list table</td>
<td></td>
</tr>
<tr>
<td>crosstabulation table</td>
<td></td>
</tr>
</tbody>
</table>

Data items in the section query are given the following default assignments in a new table:

- For list tables, all data items are assigned to the columns.
- For crosstabulation tables, data items are assigned this way:
  - If multiple categories or hierarchies have been selected from the data source, then the first category or hierarchy and all of the measures are assigned to the columns.
  - If only one category or hierarchy is selected from the data source, then the category or hierarchy is assigned to the rows and the measures are assigned to the columns.
You can change the initial assignments. For example, you might want to make these changes:

- A list table is displaying values for an Employee Salary measure. You want to hide the salary information.
- A crosstabulation table has gender information about the rows. You want to move the Gender category from the rows to the columns.

For more information, see “Specifying How Data Items Are Used in Tables” on page 136.

Tables also have default properties that you can change. For example, by default, tables do not have titles. To create a title, open the Properties dialog box and enter text in the Title field on the General tab. For more information, see “Specify Style Properties for Total and Subtotal Values” on page 144.

**T I P** In general, the defaults for properties that are related to style (for example, font and color) depend on the currently applied report style. For more information, see “Modifying Report Properties” on page 250.

For more information about how to make other table modifications, see the following topics:

- “Create or Modify a Table Title” on page 138.
- “Specify the Number of Columns and Rows to Display in a Table” on page 139.
- “Specify the Border Color of a Table” on page 140.
- “Add Row Numbers to a List Table” on page 141.
- “Specify Style Properties for Headings, Subheadings, and Cells” on page 142.
- “Specify Style Properties for Total and Subtotal Values” on page 144.
- “Copy the Formatting of a Selected Table” on page 145.
- “Move Columns and Rows in Tables in View Mode” on page 146.
- “Align Values in Columns or Rows in Tables in View Mode” on page 147.

The following chapters contain additional information:

- Chapter 17, “Filtering and Ranking,” on page 187.
- Chapter 18, “Drilling and Expanding,” on page 207.
Assign Data Items to List Tables
To assign data items to a list table, complete these steps:

1. Select Data ⇒ Assign Data or right-click the list table and select Assign Data to open the Assign Data dialog box.

2. Perform one of these tasks to assign data items:
   - Use drag and drop features to assign data items either to Columns or to Hidden.
   - Use the Move Items drop-down list to assign each data item either to Columns or to Hidden.

Data items that are assigned to Hidden do not appear in the table but can be used in filtering. For more information, see “Hiding Data Items” on page 312.

3. Click OK.

Assign Data Items in Crosstabulation Tables
To assign data items in a crosstabulation table, complete these steps:

1. Right-click the crosstabulation table, and then select Assign Data to open the Assign Data dialog box.

   Note: For crosstabulation tables that use relational data, some data items are not supported and do not appear in the Assign Data dialog box.

2. Perform one of these tasks to assign each data item:
   - Use drag and drop features to assign data items to Rows, Columns, or Hidden.
   - Use the Move Items drop-down list to assign each data item to Rows, Columns, or Hidden.

Data items that are assigned to Hidden do not appear in the table but can be used in filtering. For more information, see “Hiding Data Items” on page 312.

3. Click OK.
Here are some filtering consequences of moving data items to different data roles in a crosstabulation table:

- If you add or hide a category or hierarchy column, then any row filters and rankings that are based on a column measure are removed.
- If you add or hide a category or hierarchy row, then any column filters and rankings that are based on a row measure are removed.
- Filters are retained if you move all the data items that are currently on rows to the columns and all the data items that are currently on the columns to the rows. In this case, any existing filters remain and are evaluated based on the new positions.

Replace a Category Data Item in a Crosstabulation Table

You can replace a category data item in a crosstabulation table in View mode.

For crosstabulation tables that use relational or multidimensional data, you can replace a category data item with another category data item that has been selected in the Assign Data dialog box, but does not appear in the table. To replace a category data item in a table that uses relational or multidimensional data, complete these steps:

1. Right-click the category data item that you want to replace.
2. In the pop-up menu, select **Change `<category-data-item-1>` to `<category-data-item-2>`**, where `<category-data-item-1>` is the name of the data item that you selected in the table and `<category-data-item-2>` is the name of the data item you want to use as the replacement. The new data item appears in the same place as the item that you replaced.

   *Note:* The **Change** menu item affects only the crosstabulation table where you make the selection.

For crosstabulation tables that use multidimensional data, you can replace a category data item with another category data item from the same dimension in your data set. For example, the cube providing the data might enable you to group geographic items into either regions or states. The Assign Data dialog box does not allow more than one of these data items to be selected at a time. Neither the **Change** menu item nor the Assign Data dialog box can replace one category data item with another from the same dimension.

To replace a category data item in a table that uses multidimensional data, complete these steps:

1. Right-click the category data item that you want to replace.
2. In the pop-up menu, select **Switch `<category-data-item-1>` to `<category-data-item-2>`**, where `<category-data-item-1>` is the name of the data item that you selected in the table and `<category-data-item-2>` is the name of the data item you want to use as the replacement. The new data item appears in the same place as the data item that you replaced.

   *Note:* The **Switch** menu item has a global effect on both the data items selected in the Select Data dialog box, as well as on all the tables and graphs in the report section.
Create or Modify a Table Title

By default, new tables do not have titles. To create a new title or modify an existing title, complete these steps:

1. Right-click the table, and then select Properties to open the Properties dialog box. The General tab is displayed by default.

2. Under Title, complete these steps:
   a. Type or modify the content in the Text field.
      You cannot use these characters: < > & #
   b. Specify the font, font size, font style, font color, and alignment.

Display 15.5 A Table Title Specified in the Properties Dialog Box

3. Click OK.

In View mode, the formatted title appears above the table. In Edit mode, the title appears in the table object.

Display 15.6 A Crosstabulation Table with a Title
**Specify the Number of Columns and Rows to Display in a Table**

To specify how many columns and rows the table should display, complete these steps:

1. Right-click the table, and then select **Properties** to open the Properties dialog box.
   
   The **General** tab is displayed by default.

2. Under **Table size**, complete these steps:
   
   a. Select one of these options for displaying columns in the table:
      
      **Show all columns (up to system limit)**
      
      Select this option to display all columns in the table, up to the system limit (which is managed by your system administrator). If necessary, the table will scroll to the right.
      
      **Limit the number of columns displayed at once**
      
      Select this option and type a value in the box to specify the number of columns that you want to view before scrolling is enabled. This option is the default.
      
      *Note:* If you type a value that is the same as (or greater than) the current system limit, then the value automatically changes to the system limit. The next time you open the Properties dialog box, the **Show all columns (up to system limit)** option is selected.
      
      **Tip:** In View mode, you can use your mouse to manually resize table columns.
   
   b. Select one of these options for displaying rows in the table:
      
      **Show all rows (up to system limit)**
      
      Select this option to display all rows in the table, up to the system limit (which is managed by your system administrator). If necessary, the table will scroll down.
      
      **Limit the number of rows displayed at once**
      
      Select this option and type a value in the box to specify the number of rows that you want to view before scrolling is enabled. This option is the default.
      
      *Note:* If you type a value that is the same as (or greater than) the current system limit, then the value automatically changes to the system limit. The next time you open the Properties dialog box, the **Show all columns (up to system limit)** option is selected.
3. Click **OK**.

**Specify the Border Color of a Table**

To specify the color that is used for the border of a table, complete these steps:

1. Right-click the table, and then select **Properties** to open the Properties dialog box.
   The **General** tab is displayed by default.

2. Select the **Border** drop-down list to open the color palette. Then select a color for the table border. You can customize a color using the **Color value** field. For more information, see “Customizing Colors” on page 310.
3. Click **OK**.

In Display 15.8 on page 141, red was selected as the new border color. In View mode, all of the borders for this table change to red.

**Display 15.9**  
A Crosstabulation Table with a Title and Red Borders

\[
\begin{array}{c|cccc|c}
\hline
\text{Year} & \text{Total Sales Summary} \\
\hline
\text{Product Group} & \text{2006} & \text{2007} & \text{2008} & \text{2009} & \text{2010} \\
\hline
\text{Eclipse} & \$692,068.43 & \$744,092.03 & \$655,229.50 & \$694,656.60 & \$633,860.72 \\
\text{Shoes} & \$291,100.63 & \$328,341.81 & \$372,430.58 & \$367,168.02 & \$385,578.66 \\
\text{Tracker} & \$274,964.49 & \$317,228.38 & \$366,546.32 & \$303,014.12 & \$381,588.03 \\
\hline
\end{array}
\]

**Add Row Numbers to a List Table**

To add row numbers to a list table, complete these steps:

1. Right-click the list table, and then select **Properties** to open the Properties dialog box.
   
   The **General** tab is displayed by default.

2. Select the **Add row numbers** check box.
3. Click **OK**. The row numbers appear in the list table.

**Display 15.11  A List Table with Row Numbers**

<table>
<thead>
<tr>
<th>Name</th>
<th>Gender</th>
<th>Age</th>
<th>Height</th>
<th>Weight</th>
<th>BMI</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Alfred</td>
<td>M</td>
<td>14</td>
<td>66.0</td>
<td>122.5</td>
<td>18.61</td>
</tr>
<tr>
<td>2 Alice</td>
<td>F</td>
<td>13</td>
<td>58.5</td>
<td>84.0</td>
<td>18.50</td>
</tr>
<tr>
<td>3 Barbara</td>
<td>F</td>
<td>13</td>
<td>65.3</td>
<td>96.0</td>
<td>16.16</td>
</tr>
<tr>
<td>4 Carol</td>
<td>F</td>
<td>14</td>
<td>62.8</td>
<td>102.5</td>
<td>18.27</td>
</tr>
<tr>
<td>5 Henry</td>
<td>M</td>
<td>14</td>
<td>63.5</td>
<td>102.5</td>
<td>17.87</td>
</tr>
<tr>
<td>6 Jamaica</td>
<td>M</td>
<td>12</td>
<td>57.3</td>
<td>83.0</td>
<td>17.77</td>
</tr>
<tr>
<td>7 Jana</td>
<td>F</td>
<td>12</td>
<td>56.8</td>
<td>84.5</td>
<td>16.61</td>
</tr>
<tr>
<td>8 Janet</td>
<td>F</td>
<td>15</td>
<td>62.5</td>
<td>112.5</td>
<td>20.25</td>
</tr>
<tr>
<td>9 Jeffrey</td>
<td>M</td>
<td>13</td>
<td>62.5</td>
<td>84.0</td>
<td>15.12</td>
</tr>
<tr>
<td>10 John</td>
<td>M</td>
<td>12</td>
<td>59.0</td>
<td>96.5</td>
<td>20.09</td>
</tr>
<tr>
<td>11 Joyce</td>
<td>F</td>
<td>11</td>
<td>51.3</td>
<td>56.5</td>
<td>13.49</td>
</tr>
<tr>
<td>12 Jody</td>
<td>F</td>
<td>14</td>
<td>64.3</td>
<td>90.0</td>
<td>15.30</td>
</tr>
<tr>
<td>13 Louie</td>
<td>F</td>
<td>12</td>
<td>56.3</td>
<td>77.0</td>
<td>17.08</td>
</tr>
<tr>
<td>14 Mary</td>
<td>F</td>
<td>15</td>
<td>66.5</td>
<td>112.0</td>
<td>17.80</td>
</tr>
<tr>
<td>15 Philip</td>
<td>M</td>
<td>16</td>
<td>72.0</td>
<td>150.0</td>
<td>20.34</td>
</tr>
<tr>
<td>16 Robert</td>
<td>M</td>
<td>12</td>
<td>64.5</td>
<td>128.0</td>
<td>21.43</td>
</tr>
<tr>
<td>17 Ronal</td>
<td>M</td>
<td>15</td>
<td>67.0</td>
<td>133.0</td>
<td>20.93</td>
</tr>
<tr>
<td>18 Thomas</td>
<td>M</td>
<td>11</td>
<td>57.5</td>
<td>85.0</td>
<td>18.07</td>
</tr>
<tr>
<td>19 William</td>
<td>M</td>
<td>15</td>
<td>66.5</td>
<td>112.0</td>
<td>17.80</td>
</tr>
</tbody>
</table>

**Specify Style Properties for Headings, Subheadings, and Cells**

All tables have headings and cells. Crosstabulation tables also have subheadings.

- **Headings** are the category, hierarchy level, and measure labels. Two examples are **State** and **Retail Price**.

- **Subheadings** are the values of the categories, hierarchy levels, and measures. For example, **Alabama** and **North Carolina** might be subheadings for a **State** heading.

- **Table cells** contain data values. For example, **$228.88** and **$46.43** might be values for a **Retail Price** measure.
To specify style properties such as font, alignment, and color for headings, subheadings, and cells, complete these steps:

1. Right-click the table, and then select **Properties** to open the Properties dialog box. The **General** tab is displayed by default.

2. Select the **Text** tab.

3. Under **Headings, Subheadings** (crosstabulation tables only), and **Cells**, specify a font, font size, font style, and font color. For headings and subheadings, specify an alignment.

   Select the **Background fill** drop-down list to open the color palette. Then select a background fill color. You can customize a color using the **Color value** field. For more information, see “Customizing Colors” on page 310.

**Display 15.12**  New Headings and Subheading Colors Specified in the Properties Dialog Box for a Crosstabulation Table

4. Click **OK**.

In the following display, navy blue was selected as the new heading color and green was selected as the new subheading color. In View mode, the headings and subheadings change to the new colors.
Specify Style Properties for Total and Subtotal Values

To specify properties such as the font and the color for total and subtotal values, complete these steps:

1. Right-click the table, and then select Properties to open the Properties dialog box. The General tab is displayed by default.
2. Select the Totals tab.
3. Under Totals and Subtotals (crosstabulation tables only), specify a font, font size, font style, and font color.

Select the Background fill drop-down list to open the color palette. Then select a background fill color. You can customize a color using the Color value field. For more information, see “Customizing Colors” on page 310.

Note: If you selected the Parent totals option in the Total dialog box for a multidimensional crosstabulation table, then you will not see font and color...
changes. This happens because the parent totals and subtotals come from the cube.

4. Click OK.

Note: You can choose to show or hide totals in a table. For more information, see “Show or Hide Totals and Subtotals for Crosstabulation Tables” on page 221.

Display 15.15  A Crosstabulation Table with Totals in Color

Copy the Formatting of a Selected Table

To copy the formatting of a selected table to other tables in the report section, complete these steps:

1. Right-click the table, and then select Properties to open the Properties dialog box.

   The General tab is displayed by default.

   If the report section has more than one table, the Apply formatting to existing tables in the section check box is available to select no matter which tab is displayed.

2. Select the Apply formatting to existing tables in the section check box.

   The title, heading, subheading, cell, total, subtotal, and border styles are copied to all of the tables in the section. Only the relevant information is copied. For example, the subheading style does not apply to list tables.

3. Click OK.

Change the Currently Selected Table Type

To change the currently selected table type, complete these steps:

1. Right-click the table, and then select Properties to open the Properties dialog box.

   The General tab is displayed by default.

   The Table type radio buttons are available to use no matter which tab is displayed.

2. For the Table type radio buttons, select either List or Crosstab, depending on the current table type. However, you cannot change the table type if the current table meets either of these conditions:

   • a crosstabulation table that uses multidimensional data cannot be changed to a list table.
   • a list table that does not include at least one category and one measure cannot be changed to a crosstabulation table.
3. Click OK.

The data item assignments and properties are changed to match the new table type.

**Move Columns and Rows in Tables in View Mode**

The following tasks can be performed in View mode:

<table>
<thead>
<tr>
<th>Task</th>
<th>Action</th>
</tr>
</thead>
</table>
| Move measures from rows to columns or from columns to rows | • Use drag and drop features to move rows or columns.  
• Right-click a measure heading, and then select **Move** ⇒ **Measures to Rows** or **Move** ⇒ **Measures to Columns**. |
| Move measures up or down                      | • Use drag and drop features to move measures.  
• Right-click a measure heading, and then select **Move** ⇒ **Measures Up** or **Move** ⇒ **Measures Down**. |
| Rotate a table so that the columns are moved to the rows and the rows are moved to the columns | Right-click a row or column heading, and then select **Rotate Table**. |
| Move a category or hierarchy level from a column to a row or from a row to a column | • Use drag and drop features to move a column to a row or a row to a column.  
• Right-click a category or hierarchy level heading, and then select **Move** ⇒ `<column-name>` to Rows or **Move** ⇒ `<row-name>` to Columns, where `<column-name>` or `<row-name>` is the name of the column or row that you selected. |
| Move a column to the left or right in a list table | • Use drag and drop features to move columns.  
• Right-click a column heading, and then select **Move to Left** or **Move to Right**. Note that the leftmost column cannot be moved left and the rightmost column cannot be moved right. |
| Move a column to the left or right in a crosstabulation table | • Use drag and drop features to move columns.  
• Right-click a column heading, and then select **Move** ⇒ `<column-name>` Left or **Move** ⇒ `<column-name>` Right, where `<column-name>` is the name of the column that you selected. Note that the leftmost column cannot be moved left and the rightmost column cannot be moved right. |
| Move a row up or down (in crosstabulation tables that have more than one row) | • Use drag and drop features to move a row.  
• Right-click a row heading, and then select **Move** ⇒ `<row-name>` Up or **Move** ⇒ `<row-name>` Down, where `<row-name>` is the name of the row that you selected. Note that the top row cannot be moved up and the bottom row cannot be moved down. |
Display 15.16  Example Menu Selection for Moving Rows to Columns

Resize Columns in a Table

You can use drag and drop features to make the columns in a table wider or narrower.

Align Values in Columns or Rows in Tables in View Mode

To align values in columns or rows in tables in View mode, right-click the measure or the category table heading, and then select **Align <heading-name> Left**, **Align <heading-name> Right**, or **Align <heading-name> Center**, where `<heading-name>` is the name of the column or row that you selected. For example, in the following display, the Catalog column was selected, so you might select **Align Catalog Right**. If the values in the column or row are already aligned, then the corresponding menu item is not available.

Display 15.17  Example Menu Selection for Aligning Column Values

Using Hyperlink Data Items

When an information map for relational data is created, your data administrator can indicate that a given category data item contains HTML string values that define hyperlinks. An example of a database value associated with a hyperlink data item might be the following: `<a ref="http://www.abc.com/coffeecompany.html">Coffee Company</a>`. This example is an HTML string that indicates that the item should appear online as **Coffee Company** and that it should be underlined to indicate that it is a hyperlink to an HTML document.
The following display shows an example of hyperlink data items in a list table.

**Display 15.18  A List Table That Contains Hyperlink Data Items**

<table>
<thead>
<tr>
<th>Company</th>
<th>Employees</th>
<th>State</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blue Ridge Transport</td>
<td>22921</td>
<td>TN</td>
</tr>
<tr>
<td>Coastal Super Market</td>
<td>142004</td>
<td>FL</td>
</tr>
<tr>
<td>International Hotels</td>
<td>123403</td>
<td>VA</td>
</tr>
<tr>
<td>Coffee Company</td>
<td>432303</td>
<td>DC</td>
</tr>
<tr>
<td>Infinite Clothing</td>
<td>49758</td>
<td>VA</td>
</tr>
<tr>
<td>Radio Software</td>
<td>47545</td>
<td>VA</td>
</tr>
<tr>
<td>Natural Food Co.</td>
<td>41905</td>
<td>TX</td>
</tr>
<tr>
<td>University Clinic</td>
<td>41004</td>
<td>MN</td>
</tr>
<tr>
<td>DRI Investments</td>
<td>38017</td>
<td>NV</td>
</tr>
<tr>
<td>Red Apple Markets</td>
<td>37520</td>
<td>NV</td>
</tr>
</tbody>
</table>

The following display shows an example of hyperlink data items in a relational crosstabulation table.

**Display 15.19  A Crosstabulation Table That Contains Hyperlink Data Items**

<table>
<thead>
<tr>
<th>State</th>
<th>Company</th>
<th>Employees</th>
</tr>
</thead>
<tbody>
<tr>
<td>TN</td>
<td>Blue Ridge Transport</td>
<td>22921</td>
</tr>
<tr>
<td>FL</td>
<td>Coastal Super Market</td>
<td>142004</td>
</tr>
<tr>
<td>DC</td>
<td>International Hotels</td>
<td>123403</td>
</tr>
<tr>
<td>VA</td>
<td>Coffee Company</td>
<td>432303</td>
</tr>
<tr>
<td></td>
<td>Infinite Clothing</td>
<td>49758</td>
</tr>
<tr>
<td></td>
<td>Radio Software</td>
<td>47545</td>
</tr>
<tr>
<td>TX</td>
<td>Natural Food Co.</td>
<td>41905</td>
</tr>
<tr>
<td>MH</td>
<td>University Clinic</td>
<td>41004</td>
</tr>
<tr>
<td>NY</td>
<td>DRI Investments</td>
<td>38017</td>
</tr>
<tr>
<td></td>
<td>Red Apple Markets</td>
<td>37520</td>
</tr>
</tbody>
</table>

When you click the underlined hyperlink item, the action specified by the HTML is performed. In most cases, the browser opens a Web page.

SAS Web Report Studio does not allow you to place hyperlink data items into a graph. The hyperlink data item is mainly intended for use in relational tables.
Using Graphs to Display Query Results

Overview of the Graph Types

**About Bar Charts**
A bar chart consists of a grid and some vertical or horizontal bars. Each bar represents quantitative data.

**Display 15.20** A Bar Chart

**About Bar-Line Charts**
A bar-line chart is a bar chart with an overlaid line graph.

**Display 15.21** A Bar-Line Chart
About Line Graphs
A line graph shows the relationship of one variable to another, often as movements or trends in the data over a period of time. Line graphs summarize source data and typically are used to chart response values against discrete categorical values.

Display 15.22  A Line Graph

About Pie Charts
A pie chart is a circular chart that is divided into slices by radial lines. Each slice represents the relative contribution of each part to the whole.

Display 15.23  A Pie Chart

About Progressive Bar Charts
A progressive bar chart shows how the initial value of a measure increases or decreases during a series of operations or transactions. The first bar begins at the initial value, and each subsequent bar begins where the previous bar ends. The length and direction of a bar indicates the magnitude and type (positive or negative, for example) of the operation.
or transaction. The resulting chart is a stepped cascade that shows how the transactions
or operations lead to the final value of the measure.

Display 15.24 A Progressive Bar Chart

About Scatter Plots
A scatter plot is a two-dimensional plot that shows the joint variation of two data items.
In a scatter plot, each marker (represented by symbols such as dots, squares, and plus
signs) represents an observation. The marker position indicates the value for each
observation.

Display 15.25 A Scatter Plot

About Bubble Plots
A bubble plot is a variation of a scatter plot in which the markers are replaced with
bubbles. In a bubble plot, each bubble represents an observation. The location of the
bubble represents the value for the two measure axes; the size of the bubble represents
the value for the third measure. A bubble plot is useful for data sets with dozens to
hundreds of values or when the values differ by several orders of magnitude. You can
also use a bubble plot when you want specific values to be more visually represented by different bubble sizes.

**Display 15.26  A Bubble Plot**

**About Tile Charts**

A tile chart is divided into rectangular areas. The color of each area represents the value of the first measure in the query. The size of each area represents the value of the second measure in the query. For example, a tile chart might be used to represent sales data where the tile sizes vary according to the number of orders invoiced and the tile colors are derived from a color gradient that represents low to high sales figures.

**Display 15.27  A Tile Chart**
Insert a Graph into a Report Layout

To insert a graph into a report layout, perform one of these tasks:

- Click the graph tool on the horizontal toolbar above the layout grid to insert the graph into the next available cell.
- Drag the graph tool from the horizontal toolbar into a specific cell.

The following table lists the available graph tools:

<table>
<thead>
<tr>
<th>Graph Type</th>
<th>Measures</th>
<th>Categories/Hierarchies</th>
</tr>
</thead>
<tbody>
<tr>
<td>bar charts</td>
<td>bar height</td>
<td>hidden</td>
</tr>
<tr>
<td>progressive bar charts</td>
<td>hidden</td>
<td>hidden</td>
</tr>
<tr>
<td>bar-line charts</td>
<td>bar height</td>
<td>line height</td>
</tr>
</tbody>
</table>

Note: If you selected either of the detail data options in the Summarization Options dialog box, then the only graph types available are a scatter plot or a bubble plot. For more information, see “Use Detail Data Instead of Grouped and Aggregated Data” on page 103.

Data items in the section query are given the default assignments (see the following table) in a new graph.

Table 15.1 Default Data Assignments in New Graphs

<table>
<thead>
<tr>
<th>Graph Type</th>
<th>Measured by</th>
<th>Categories/Hierarchies</th>
</tr>
</thead>
<tbody>
<tr>
<td>bar charts</td>
<td>bar height</td>
<td>hidden</td>
</tr>
<tr>
<td>progressive bar charts</td>
<td>hidden</td>
<td>hidden</td>
</tr>
<tr>
<td>bar-line charts</td>
<td>bar height</td>
<td>line height</td>
</tr>
<tr>
<td>Graph Type</td>
<td>First Measure</td>
<td>Second Measure</td>
</tr>
<tr>
<td>-------------</td>
<td>---------------</td>
<td>----------------</td>
</tr>
<tr>
<td>bubble plots</td>
<td>horizontal</td>
<td>vertical axis</td>
</tr>
<tr>
<td></td>
<td>axis</td>
<td>axis</td>
</tr>
<tr>
<td>line graphs</td>
<td>line height</td>
<td>hidden</td>
</tr>
<tr>
<td>pie charts</td>
<td>segment size</td>
<td>hidden</td>
</tr>
<tr>
<td>scatter plots</td>
<td>horizontal</td>
<td>vertical axis</td>
</tr>
<tr>
<td></td>
<td>axis</td>
<td>axis</td>
</tr>
<tr>
<td>tile charts</td>
<td>size</td>
<td>color</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

You can change the default data assignments. For example, a bar chart uses a Sales measure to determine the bar height. You also want to assign Unit Cost, which has been hidden by default, to bar height. For more information, see “Specifying How Data Items Are Used in Graphs” on page 155.

Graphs also have default properties that you can change. For example, by default, graphs do not have titles. To create a title, open the Properties dialog box and enter text in the Title field on the General tab. For more information, see “Create or Modify a Graph Title” on page 164.

**Tip** In general, the defaults for properties that are related to style (for example, font and color) depend on the currently applied report style.

For more information about how to make other graph modifications, see the following chapters and topics:

- “Use Detail Data Instead of Grouped and Aggregated Data” on page 103 (scatter plots only).
- Chapter 17, “Filtering and Ranking,” on page 187.
- Chapter 18, “Drilling and Expanding,” on page 207.
Specifying How Data Items Are Used in Graphs

Assign Data Items to Bar Charts
To assign data items to a bar chart, complete these steps:

1. Select Data ⇒ Assign Data or right-click in the bar chart, and then select Assign Data to open the Assign Data dialog box.

2. Perform one of these tasks to assign data items:
   - Use drag and drop features to assign data items.
   - Use the Move Items drop-down list to assign data items.

The following data assignments are available for bar charts:

Bar Height (Axis 1)
Select at least one measure that will determine the height of each bar. You can add additional measures to Bar Height (Axis 1). However, if you assign more than one measure to Bar Height (Axis 1), then you cannot add a category or hierarchy to Bar Subgroup. Bar Height (Axis 1) is required.

Typically, Bar Height (Axis 1) appears on the left and Bar Height (Axis 2) appears on the right of the bar chart. However, if the orientation property for the bar chart is set to Horizontal bars, then Bar Height (Axis 1) appears on the top and Bar Height (Axis 2) appears on the bottom of the bar chart.

Bar Height (Axis 2)
Specify one or more measures that will determine the height of each bar. You can add additional measures to Bar Height (Axis 2). Bar Height (Axis 2) is optional.

Typically, Bar Height (Axis 1) appears on the left and Bar Height (Axis 2) appears on the right of the bar chart. However, if the orientation property for the bar chart is set to Horizontal bars, then Bar Height (Axis 1) appears on the top and Bar Height (Axis 2) appears on the bottom of the bar chart.

Bars (Limit 1)
Select a category or hierarchy, each value of which will be represented by one or more bars. Bars is required.

Bar Subgroup (Limit 1)
You can subdivide each bar across the values assigned to the category or the hierarchy. However, you cannot assign a category to Bar Subgroup if you have assigned more than one measure to Bar Height.

Horizontal Series
You can create separate bar charts for each value of a selected category or hierarchy. The charts appear side by side. For example, if you select a Gender category for the horizontal series, a chart for each value of Gender is displayed side by side.

Vertical Series
You can create separate bar charts for each value of a selected category or hierarchy. The charts appear stacked one on top of the other. For example, if you select a Gender category for the vertical series, a chart for each value of Gender is stacked vertically.
Hidden

Data items that are assigned to Hidden do not appear in the bar chart but can be used in filtering. For more information, see “Hiding Data Items” on page 312.

Display 15.28  Assign Data Dialog Box for Bar Charts with the Move Items Menu

3. Click OK.

Assign Data Items to Bar-Line Charts

To assign data items to a bar-line chart, complete these steps:

1. Select Data ⇒ Assign Data or right-click in the bar-line chart, and then select Assign Data to open the Assign Data dialog box.

2. Perform one of these tasks to assign data items:
   - Use drag and drop features to assign data items.
   - Use the Move Items drop-down list to assign data items.

The following data assignments are available for bar-line charts:

Bar Height

Specify one or more measures that will be used to determine the height of each bar. Bar Height is required.

Line Height

Select one or more measures that will be used to determine the height of the line at each bar. Line Height is required.

Category (Limit 1)

Select a category or hierarchy, each value of which will be represented by one or more bars and one or more lines. Category is required.

Horizontal Series

You can create separate bar-line charts for each value of a selected category or hierarchy. The charts appear side by side. For example, if you select a Gender category for the horizontal series, a chart for each value of Gender is displayed side by side.

Vertical Series

You can create separate bar-line charts for each value of a selected category or hierarchy. The charts appear stacked one on top of the other. For example, if you
select a *Gender* category for the vertical series, a chart for each value of *Gender* is stacked vertically.

**Hidden**
Data items that are assigned to *Hidden* do not appear in the bar-line chart but can be used in filtering. For more information, see “Hiding Data Items” on page 312.

*Display 15.29  Assign Data Dialog Box for Bar-Line Charts*

3. Click **OK**.

**Assign Data Items to Bubble Plots**
To assign data items to a bubble plot, complete these steps:

1. Select **Data ➔ Assign Data** or right-click in the bubble plot, and then select **Assign Data** to open the Assign Data dialog box.

2. Perform one of these tasks to assign data items:
   - Use drag and drop features to assign data items.
   - Use the **Move Items** drop-down list to assign data items.

The following data assignments are available for bubble plots:

**Vertical Axis (Limit 1)**
Specify the measure that will be used to determine the vertical position of each bubble. **Vertical Axis** is required.

**Horizontal Axis (Limit 1)**
Select the measure that will be used to determine the horizontal position of each bubble. **Horizontal Axis** is required.

**Bubble Groups (Limit 1)**
Select a category or hierarchy, each value of which will be a set of bubbles. **Bubble Groups** is required for multidimensional data sources. If detail data is used, then this assignment groups and colors the data points. If aggregated data is used, there is one point for each data value in the category or hierarchy.

**Bubble Size (Limit 1)**
Select the measure that will be used to determine the size of each bubble. **Bubble size** is required.

**Horizontal Series**
You can create separate bubble plots for each value of a selected category or hierarchy. The charts appear side by side. For example, if you select a *Gender*
category for the horizontal series, a chart for each value of Gender is displayed side by side.

**Vertical Series**
You can create separate bubble plots for each value of a selected category or hierarchy. The charts appear stacked one on top of the other. For example, if you select a Gender category for the vertical series, a chart for each value of Gender is stacked vertically.

**Hidden**
Data items that are assigned to Hidden do not appear in the bubble plot but can be used in filtering. For more information, see “Hiding Data Items” on page 312.

**Display 15.30**  Assign Data Dialog Box for Bubble Plots

3. Click OK.

**Assign Data Items to Line Graphs**
To assign data items to a line graph, complete these steps:

1. Select Data ⇒ Assign Data or right-click in the line graph, and then select Assign Data to open the Assign Data dialog box.

2. Use the Move Items drop-down list to assign data items.

   Perform one of these tasks to assign data items:

   • Use drag and drop features to assign data items.

   • Use the Move Items drop-down list to assign data items.

The following data assignments are available for line graphs:

**Line Height (Axis 1)**
Select at least one measure that will determine the height of each plot point along the line. There is no limit to the number of measures that you can assign to Line Height (Axis 1). However, consider graph appearance and report performance when assigning multiple measures to this data role. In addition, if you assign more than one measure to Line Height (Axis 1), then you cannot assign a category or hierarchy to Multiple Lines. Line Height (Axis 1) is required.

*Note:* If you assign a category or hierarchy to Multiple Lines, then you can assign only one measure to Line Height (Axis 1).
Line Height (Axis 2)
Select one or more measures that will determine the height of each plot point along the line. There is no limit to the number of measures that you can assign to Line Height (Axis 2). However, consider graph appearance and report performance when assigning multiple measures to this data role. Line Height (Axis 2) is optional.

Line (Limit 1)
Select a category or hierarchy, each value of which will be represented by a plot point on the lines shown in this graph. Line is required.

Multiple Lines (Limit 1)
You can subdivide the line into several lines, one for each value of the category or hierarchy that you assign to this data role. However, you cannot use Multiple Lines if you have assigned more than one measure to Line Height (Axis 1).

Horizontal Series
You can create separate line graphs for each value of a selected category or hierarchy. The charts appear side by side. For example, if you select a Gender category for the horizontal series, a chart for each value of Gender is displayed side by side.

Vertical Series
You can create separate line graphs for each value of a selected category or hierarchy. The charts appear stacked one on top of the other. For example, if you select a Gender category for the vertical series, a chart for each value of Gender is stacked vertically.

Hidden
Data items that are assigned to Hidden do not appear in the line graph but can be used in filtering. For more information, see “Hiding Data Items” on page 312.

**Display 15.31 Assign Data Dialog Box for Line Graphs**

3. Click OK.

**Assign Data Items to Pie Charts**
To assign data items to a pie chart, complete these steps:

1. Select Data ⇒ Assign Data or right-click in the pie chart, and then select Assign Data to open the Assign Data dialog box.

2. Use the Move Items drop-down list to assign data items.
Perform one of these tasks to assign data items:

- Use drag and drop features to assign data items.
- Use the **Move Items** drop-down list to assign data items.

The following data assignments are available for pie charts:

**Segment Size**
Select at least one measure that will determine the size of each segment. There is no limit to the number of measures that you can assign to Segment Size. However, consider graph appearance and report performance when assigning multiple measures to this data role. In addition, if you assign more than one measure to Segment Size, then you cannot add a category or hierarchy to **Pie Subgroup**. Segment Size is required.

**Segments (Limit 1)**
Select a category or hierarchy, each value of which will be represented by a segment. Segments is required.

**Pie Subgroup (Limit 1)**
You can subdivide the pie chart into a stack of pie charts, one for each value of the category or hierarchy that you assign to Pie Subgroup. However, you cannot use Pie Subgroup if you have assigned more than one measure to Segment Size.

**Horizontal Series**
You can create separate pie charts for each value of a selected category or hierarchy. The charts appear side by side. For example, if you select a Gender category for the horizontal series, a chart for each value of Gender is displayed side by side.

**Vertical Series**
You can create separate pie charts for each value of a selected category or hierarchy. The charts appear stacked one on top of the other. For example, if you select a Gender category for the vertical series, a chart for each value of Gender is stacked vertically.

**Hidden**
Data items that are assigned to Hidden do not appear in the pie chart but can be used in filtering. For more information, see “Hiding Data Items” on page 312.

**Display 15.32 Assign Data Dialog Box for Pie Charts**

3. Click **OK**.
**Assign Data Items to Progressive Bar Charts**

To assign data items to a progressive bar chart, complete these steps:

1. Select **Data ➔ Assign Data** or right-click in the progressive bar chart, and then select **Assign Data** to open the Assign Data dialog box.

2. Perform one of these tasks to assign data items:
   - Use drag and drop features to assign data items.
   - Use the **Move Items** drop-down list to assign data items.

   The following data assignments are available for progressive bar charts:

   **Bar Height (Limit 1)**
   Specify the measure that will be used to determine the height of each bar. **Bar Height** is required.

   **Bars (Limit 1)**
   Select a category or hierarchy, each value of which will be represented by a bar. **Bars** is required.

   **Horizontal Series**
   You can create separate progressive bar charts for each value of a selected category or hierarchy. The charts appear side by side. For example, if you select a **Gender** category for the horizontal series, a chart for each value of **Gender** is displayed side by side.

   **Vertical Series**
   You can create separate progressive bar charts for each value of a selected category or hierarchy. The charts appear stacked one on top of the other. For example, if you select a **Gender** category for the vertical series, a chart for each value of **Gender** is stacked vertically.

   **Hidden**
   Data items that are assigned to **Hidden** do not appear in the progressive bar chart but can be used in filtering. For more information, see “Hiding Data Items” on page 312.

**Display 15.33  Assign Data Dialog Box for Progressive Bar Charts**

3. Click **OK**.
Assign Data Items to Scatter Plots

To assign data items to a scatter plot, complete these steps:

1. Select Data ⇒ Assign Data or right-click in the scatter plot, and then select Assign Data to open the Assign Data dialog box.

2. Perform one of these tasks to assign data items:
   - Use drag and drop features to assign data items.
   - Use the Move Items drop-down list to assign data items.

The following data assignments are available for scatter plots:

**Vertical Axis (Limit 1)**
Specify the measure that will be used to determine the vertical position of each marker. **Vertical Axis** is required.

**Horizontal Axis (Limit 1)**
Select the measure that will be used to determine the horizontal position of each marker. **Horizontal Axis** is required.

**Marker Groups (Limit 1)**
Select a category or hierarchy, each value of which will be a set of markers. If detail data is used, then **Marker Groups** groups and colors the data points. If aggregated data is used, then there is one point for each data value in the category or hierarchy. **Marker Groups** is required for multidimensional data.

**Marker Size (Limit 1)**
Select the measure that will be used to determine the size of each marker.

*Note:* You can also use the Markers tab in the Properties dialog box to specify a marker size that will be constant for all markers in the graph.

**Horizontal Series**
You can create separate scatter plots for each value of a selected category or hierarchy. The charts appear side by side. For example, if you select a Gender category for the horizontal series, a chart for each value of Gender is displayed side by side.

**Vertical Series**
You can create separate scatter plots for each value of a selected category or hierarchy. The charts appear stacked one on top of the other. For example, if you select a Gender category for the vertical series, a chart for each value of Gender is stacked vertically.

**Hidden**
Data items that are assigned to **Hidden** do not appear in the scatter plot but can be used in filtering. For more information, see “Hiding Data Items” on page 312.
3. Click OK.

**Assign Data Items to Tile Charts**

To assign data items to a tile chart, complete these steps:

1. Select Data ⇒ Assign Data or right-click in the tile chart, and then select **Assign Data** to open the Assign Data dialog box.

2. Use the **Move Items** drop-down list to assign data items.

   Perform one of these tasks to assign data items:
   - Use drag and drop features to assign data items.
   - Use the **Move Items** drop-down list to assign data items.

   The following data assignments are available for tile charts:

   **Categories**
   - Select one or more categories or hierarchies whose values determine the number of tiles and their arrangement. Each tile is associated with a value for each of the categories that it represents. There is no limit to the number of categories or hierarchies that you can assign to **Categories**. However, consider graph appearance and report performance when assigning multiple categories or hierarchies to this data role. **Categories** is required.

   **Size (Limit 1)**
   - Select the measure whose values are used to determine the size of each tile. **Size** is required.

   **Color (Limit 1)**
   - Select the measure whose values are used to create the gradient colors in the chart. To specify colors for low, medium, and high values, use the Properties dialog box. The default colors are based on the currently applied report style. If you do not assign a measure to **Color**, then the measure that is assigned to **Size** is also used to determine the colors.

   **Auxiliary Data Tips**
   - Select one or more measures whose values you want to display as data tips. There is no limit to the number of measures that you can assign to **Auxiliary Data Tips**. However, consider report performance when assigning many measures to this data role. Data tip values for the categories, color and size
measures, and auxiliary data tip measures appear when you move the mouse over a tile.

**Hidden**

Data items that are assigned to **Hidden** do not appear in the tile chart but can be used in filtering. For more information, see “Hiding Data Items” on page 312.

**Display 15.35  Assign Data Dialog Box for Tile Charts**

3. Click **OK**.

**Create or Modify a Graph Title**

By default, new graphs do not have titles. To create a new title or to modify an existing title, complete these steps:

1. Right-click in the chart, and then select **Properties** to open the Properties dialog box. The **General** tab is displayed by default.

2. Under **Title**, complete these steps:
   a. Type or modify the content in the **Text** field.
      You cannot use these characters: `< > & #
   b. Specify the font, font size, font style, font color, and alignment.
3. Click **OK**.

   In View mode, the formatted title appears above the graph. In Edit mode, the title appears in the graph object.

**Specify the Size of a Graph**

To change the size of a graph, complete these steps:

1. Right-click in the graph, and then select **Properties** to open the Properties dialog box.

   The **General** tab is displayed by default.

2. Under **Graph size**, select one of these options (depending on the graph type):

   **Automatic (adjust to fit data)** (all graph types except tile charts)
   
   Select this option to produce a graph that best fits the size of the current window. This option is the default.

   **Fixed size (can be manually adjusted while viewing reports)** (for all graph types except tile charts)
   
   Select this option if you want to specify a fixed size for the graph. From the drop-down list, select **Small**, **Medium**, **Large**, or **Custom**. If you select **Custom**, you can type the width and height in pixels. The maximum width is 1200 pixels. The maximum height is 900 pixels.

   **Tip** If you select the **Fixed size** option, you can use your mouse to resize the graph in View mode. In View mode, point to the bottom right corner or to the
bottom or right border. When the pointer becomes a horizontal, vertical, or diagonal bar, you can drag the graph to the new size and then release the mouse button.

3. Click OK.

Specify the Border and the Border Color of a Graph

By default, graph borders are turned off. To specify a border and border color of a graph, complete these steps:

1. Right-click in the graph, and then select Properties to open the Properties dialog box.
   The General tab is displayed by default.
2. Select the Border check box. Clear the check box if you no longer want the graph to have a border.
3. (Optional) Select the Border drop-down list to open the color palette. Then select a border color for the graph. You can customize a color using the Color value field. For more information, see “Customizing Colors” on page 310.
4. Click OK.

Specify the Background Color of a Graph

You can specify a background color for all graph types except tile charts. To specify a background color, complete these steps:

1. Right-click in the graph, and then select Properties to open the Properties dialog box.
   The General tab is displayed by default.
2. Select the Background drop-down list to open the color palette. Then select a background color for the graph. You can customize a color using the Color value field. For more information, see “Customizing Colors” on page 310.
3. Click OK.

Turn Grid Lines On or Off

Grid lines are available for all graph types except pie charts and tile charts. To turn grid lines on or off and to specify a color for the lines, complete these steps:

1. Right-click in the graph, and then select Properties to open the Properties dialog box.
   The General tab is displayed by default.
2. Select or clear the Grid lines check box, depending on whether you want to hide or show grid lines on the graph. Grid lines are turned on by default.
3. If you are showing grid lines, select the Grid lines drop-down list to open the color palette. Then select a color. You can customize a color using the Color value field. For more information, see “Customizing Colors” on page 310.
4. Click OK.
Specify the Scale Type and Style of the Axis

You can specify axis properties for all graph types except pie charts and tile charts. To specify properties, complete these steps:

1. Right-click in the graph, and then select Properties to open the Properties dialog box.
   The General tab is displayed by default.

2. Select the Axis tab.

3. (Optional) You can select Display an additional axis for the second measure for a bar chart or a line chart or Display separate axes for bars and lines for a bar-line chart, and one of the following conditions is true for the currently selected graph:
   • It is a bar chart and exactly two measures are assigned to the bar height.
   • It is a line graph and exactly two measures are assigned to the line height.
   • It is a bar-line chart.

4. Under Scale, select Automatic or Fixed. The default is Automatic.
   When you have group breaks, the axis on one chart (or graph) might differ from the axis on another chart (or graph). For example, one measure axis on a bar chart might have values from 10 to 400, while another axis might have values from 10 to 600 coming from the data source. When you select Fixed, you can set the minimum and maximum values so that the axes on both bar charts become the same. Then, when you look at the height of the bars in both charts, you will be making a similar comparison.

5. If you selected Fixed for Scale, then enter any combination of a minimum value, maximum value, baseline value, and tick mark increment for the indicated axis or axes.
   • For bar charts, line graphs, bar-line charts, and progressive bar charts, enter values for the first (or only) measure axis.
   • For bar charts and line graphs, if you selected Display an additional axis for the second measure for a bar chart or a line chart or Display separate axes for bars and lines for a bar-line chart, then you can also enter values for the second measure axis.
   • For scatter plots and bubble plots, enter values for the vertical axis, the horizontal axis, or both.

Tip Before entering fixed values, find out what the default scale values are by displaying the graph in View mode.
6. Under **Labels**, select a font, font size, font style, font color, and orientation for the axis labels. The default orientation is **Horizontal**.

   *Note:* The orientation option is not available for bar charts that use horizontal bars.

7. Under **Values**, select a font, font size, font style, and font color for the axis values.

8. Click **OK**.

### Add, Modify, or Remove Reference Lines

You can add, modify, or remove reference lines for all graph types, except pie charts or tile charts. For example, a reference line could be added to indicate a sales goal or a voting age.

**TIP** Before entering reference lines, find out what the default scale values are by displaying the graph in View mode.

To add reference lines, complete these steps:

1. Right-click in the graph, and then select **Properties** to open the Properties dialog box.

   The **General** tab is displayed by default.

2. Select the **Reference Lines** tab.

3. Under **Reference Lines**, complete these steps:

   a. Type the text in the **Label** field. The text appears below the reference line, near the axis that displays the selected measure.
A blank is not valid. If you want only the reference line to appear, then type a space.

You cannot use these characters: < > & #

b. Select a measure from the Based on drop-down list.

c. Enter a Value.

d. Specify the font, font size, font style, alignment, and color.

e. Specify a color and width for Line style.

Display 15.38 Reference Lines Tab in the Properties Dialog Box for a Line Chart

f. Click Add. The new reference line is added to the list box to the left of the Add, Change, and Remove buttons.

4. (Optional) Add another reference line or lines to the graph.

5. (Optional) Modify the properties of a reference line. For example, you might change the Label. Select the reference line in the list, and then modify the text of the label. Click Change.

6. (Optional) Remove a reference line by selecting it in the list of existing reference lines. Click Remove.

7. Click OK.
Specify the Position, Label Style, and Background Color of the Legend

Legend properties are available for all graph types except progressive bar charts. However, bar charts, bubble plots, line graphs, scatter plots, and tile charts must meet certain requirements for the legend properties to be available, as follows:

<table>
<thead>
<tr>
<th>Graph Type</th>
<th>Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bar charts</td>
<td>A category must be assigned to <strong>Bar Subgroup</strong> or the bar chart must use more than one measure.</td>
</tr>
<tr>
<td>Bubble plots</td>
<td>For bubble plots that use relational data, a category must be assigned to <strong>Bubble Groups</strong>. (Legend properties are always available for bubble plots that use multidimensional data.)</td>
</tr>
<tr>
<td>Line graphs</td>
<td>A category must be assigned to <strong>Multiple Lines</strong> or the line graph must use more than one measure.</td>
</tr>
<tr>
<td>Scatter plots</td>
<td>For scatter plots that use relational data, a category must be assigned to <strong>Marker Groups</strong>. (Legend properties are always available for scatter plots that use multidimensional data.)</td>
</tr>
<tr>
<td>Tile charts</td>
<td>A category or hierarchy must be assigned.</td>
</tr>
</tbody>
</table>

To specify legend properties, complete these steps:

1. Right-click in the graph, and then select **Properties** to open the Properties dialog box.  
   The **General** tab is displayed by default.
2. Select the **Legend** tab.
3. Under **Position**, select **Above**, **Below**, **Left**, or **Right**. The default is **Below**.  
   **Tip**: To leave more horizontal room for the graph, position the legend above or below the graph.
4. Under **Labels**, select a font, font size, font style, and font color for the labels in the legend.
5. For bar charts, pie charts, bar-line charts, line graphs, and scatter plots, select the **Background** drop-down list to open the color palette. Then select a background color for the graph. You can customize a color using the **Color value** field. For more information, see “Customizing Colors” on page 310.  
   **Note**: You cannot select a background color for tile charts or for bar charts, pie charts, and line graphs that use multidimensional data.
6. (Optional) Select the **Border** drop-down list to open the color palette. Then select a border color for the graph. You can customize a color using the **Color value** field. For more information, see “Customizing Colors” on page 310.
7. Click **OK**.

**Copy the Formatting of a Selected Graph**

To copy the formatting of a selected graph to other graphs in the report section, complete these steps:

1. Right-click in the graph, and then select **Properties** to open the Properties dialog box.

   The **General** tab is displayed by default.

   The option to copy formatting appears on all of the tabs in the Properties dialog box.

2. Select the check box to specify that you want the formatting applied to other graphs in the section. Depending on the graph type, one of these options will display:

   **Apply formatting to existing graphs in the section** (all graph types except tile charts)

   Formatting properties that are copied include title style, background color, border color, marker size, bar shape, the option to display a second measure axis, measure label orientation, the option to display data labels, and legend style.

   Only relevant properties are copied. For example, the bar shape property is not copied to pie charts, and legend style properties are not copied to progressive bar charts, which do not support legends.

   **Apply formatting to existing tile charts in this section** (tile charts only)

   Formatting properties are copied only to other tile charts in the section.
3. Click OK.

**Change the Currently Selected Graph Type**

Except for tile charts, you can change a selected graph from one type to another. Complete these steps:

1. Right-click in the graph, and then select Properties to open the Properties dialog box.
   
The **Graph type** drop-down list is available to use no matter which tab is displayed.
2. From the **Graph type** drop-down list, select the new graph type.
3. Click OK.

The data item assignments and properties are changed to match the new graph type. For example, suppose that you have a pie chart and a *Year* data item is assigned to *Pie Subgroup* in the Assign Data dialog box. If you change the pie chart to a progressive bar chart, the *Year* data item becomes hidden because a progressive bar chart does not have a subgroup data role.

**Specifying Properties That Are Specific to a Graph Type**

**Specify Properties That Are Specific to a Bar Chart**

To specify properties that are specific to a bar chart, complete these steps:

1. Right-click in the bar chart, and then select Properties to open the Properties dialog box.
   
The **General** tab is displayed by default.
2. Select the **Bar** tab.
3. Under **Orientation**, specify whether you want to use **Vertical bars** or **Horizontal bars**. The default is **Vertical bars**.
4. Under **Subgroup**, specify whether you want to display **Stacked bars** or **Clustered bars**. Clustered bars, the default, are grouped next to each other along the horizontal axis.
   
   **Note:** This property is available only if a data item is assigned to **Bar Subgroup** in the Assign Data dialog box.
5. From the **Shape** drop-down list, select **Two-dimensional bar**, **Three-dimensional bar**, or **Three-dimensional cylinder**. The default is **Two-dimensional bar**.
6. (Optional) Select the **Show data values** option to display a value above each vertical bar or to the right of each horizontal bar.
7. Click OK.

**Specify Properties That Are Specific to a Bar-Line Chart**

To specify properties that are specific to a bar-line chart, complete these steps:

1. Right-click in the bar-line chart, and then select Properties to open the Properties dialog box.
   
The **General** tab is displayed by default.
2. Select the Bar-line tab.

3. Under Shape and Size, specify these options:
   a. From the Bar shape drop-down list, select a shape for the bars. Your choices are Two-dimensional bar, Three-dimensional bar, or Three-dimensional cylinder. The default is Two-dimensional bar.
   b. From the Line thickness drop-down list, select a point size. Sizes range from 1 to 5 points. The default is 2 pt.
   c. From the Marker size drop-down list, select a marker size. On each line in the graph, there is a marker for each tick mark on the horizontal axis. Your choices are No marker, Small, Medium, and Large. The default is Small.

4. (Optional) Select the Show data values option to display a value above each marker.

5. Click OK.

**Specify Properties That Are Specific to a Bubble Plot**

To specify properties that are specific to a bubble plot, complete these steps:

1. Right-click in the bubble plot, and then select Properties to open the Properties dialog box.
   The General tab is displayed by default.

2. Select the Bubble tab.

3. For Transparency, the Show transparent bubbles check box is selected by default.
   The default size for Enter transparent percent is 50.

4. (Optional) Select the Show data values option to display the Y-axis data value above each marker.

5. Click OK.

**Specify Properties That Are Specific to a Line Graph**

To specify properties that are specific to a line graph, complete these steps:

1. Right-click in the line graph, and then select Properties to open the Properties dialog box.
   The General tab is displayed by default.

2. Select the Line tab.

3. Under Size, specify these options:
   a. From the Line thickness drop-down list, select a point size. Sizes range from 1 to 5 points. The default is 2 pt.
   b. From the Marker size drop-down list, select a marker size. On each line in the graph, there is a marker for each tick mark on the horizontal axis. Your choices are No marker, Small, Medium, and Large. The default is Small.

4. (Optional) Select the Show data values option to display data values above each point of the line.

5. Click OK.
Specify Properties That Are Specific to a Pie Chart
To specify properties that are specific to a pie chart, complete these steps:

1. Right-click in the pie chart, and then select Properties to open the Properties dialog box.
   The General tab is displayed by default.
2. Select the Pie tab.
3. Under Shape, select a shape for the pie. Your choices are Two-dimensional or Three-dimensional. The default is Two-dimensional.
4. Under Multiple measures, specify whether you want to display Multiple pies or Stacked pies.
   Note: This option is not available for pie charts that use only one measure or if a category or hierarchy is assigned to Pie Subgroup in the Assign Data dialog box.
5. Under Labels, specify a font, font size, font style, and font color.
6. (Optional) Under Values, specify one or more of these options, and then specify the font, font size, font style, and font color:
   - Combine minimal values into a slice labeled "Other"
     This option is selected by default. You can also specify the percent to use as minimal value. The default value is 4%. For example, if you specify 2% and there are two or more pie slices that each have less than 2% of the total, then these slices are combined into a single slice labeled "Other".
   - Show data values
     Select this option to display a value along with each segment.
   - Show data values as a percent of the total
     Select this option to display a percentage value along with each segment.
7. Click OK.

Specify Properties That Are Specific to a Progressive Bar Chart
To specify properties that are specific to a progressive bar chart, complete these steps:

1. Right-click in the progressive bar chart, and then select Properties to open the Properties dialog box.
   The General tab is displayed by default.
2. Select the Progressive Bar tab.
3. (Optional) Under Initial Bar, select the Set an initial value option to specify an initial value for the first bar in the chart. If you use this option, then you can type an optional label in the Initial bar label field. By default, this option is not selected.
4. (Optional) Under Final bar, select the Show the final (cumulative) value option to display the value for the final bar. This option is selected by default. If you use this option, then you can type an optional label in the Final bar label field. The default label is Final.
5. Under the Colors heading, select a color for each type of bar that appears in the chart. Select the Positive bars, Negative bars, Initial bar, or Final bar drop-down list to open the color palette. Then select a color for the bar. You can customize a color using the Color value field. For more information, see “Customizing Colors” on page 310.
The **Positive bars** and **Negative bars** drop-down lists are always available. The **Initial bar** and **Final bar** drop-down lists are available only if you have selected the corresponding options.

*Note:* For progressive bar charts, the Plateau report style uses the color blue for positive values and the color green for negative values. For the Seaside, Festival, and Meadow report styles, the positive values are green and the negative values are red.

6. (Optional) Select the **Show trend line** option to overlay a trend line on the progressive bar chart.

7. (Optional) Select the **Show data values** option to display a value above each bar.

8. Click **OK**.

**Specify Properties That Are Specific to a Scatter Plot**
To specify properties that are specific to a scatter plot, complete these steps:

1. Right-click in the scatter plot, and then select **Properties** to open the Properties dialog box.
   
The **General** tab is displayed by default.

2. Select the **Markers** tab.

3. From the **Marker size** drop-down list, select a marker size. There is a marker for each tick mark on the horizontal axis. Your choices are **No marker**, **Small**, **Medium**, and **Large**. The default is **Small**.
   
   *Note:* If you assigned a measure to **Marker size** in the Assign Data dialog box, then the **Size** selection in this dialog box is ignored.

4. (Optional) Select the **Show data values** option to display a value above each marker.

5. Click **OK**.

**Specify Properties That Are Specific to a Tile Chart**
To specify properties that are specific to a tile chart, complete these steps:

1. Right-click in the tile chart, and then select **Properties** to open the Properties dialog box.
   
The **General** tab is displayed by default.

2. Select the **Tile** tab.

3. From the **Layout type** drop-down list, select one of these options:

   - **Standard**
     
     Specifies a standard layout tile chart that ignores sort order and keeps the tiles as close to squares as possible.
   
   - **Toggle**
     
     Specifies a simple layout that divides a variable’s associated tiles in a single dimension, and switches the orientation as each level is placed. This layout works best with small amounts of data. For large amounts of data, use **Flow**.
   
   - **Flow**
     
     Specifies a layout in which the available space is divided into a number of rows of similar but not equal heights. The number of rows is computed based on the number of tiles that will be displayed in conjunction with the aspect ratio of the available space. Then, the ordered tiles are placed in the rows from top to bottom and left to right. At each level, you can read the tiles like a page in a book.
4. For tile charts that are based on relational data sources, you can specify the levels of data that you want to appear. From the Show data levels drop-down list, specify the number of levels of detail (that is, the number of times that the chart is divided). You can show 1 or 2. The default is 2, unless there is only one category. In that case, the default is 1.

5. Under the Color heading, select a color for the low, medium, and high values in the tile chart. Select the Low value, Medium value, or High value drop-down list to open the color palette. Then select a color for the value. You can customize a color using the Color value field. For more information, see “Customizing Colors” on page 310.

6. Under the Labels heading, select a font, font size, font style, and font color to control how the labels display.

7. Click OK.

---

**Using Geographical Maps to Display Query Results**

**About Geographical Maps**

A geographic information system (GIS) is a tool for organizing and analyzing data that can be referenced spatially (that is, data that can be tied to physical locations). Many types of data have a spatial aspect, including demographics, marketing surveys, and customer addresses. A GIS helps users analyze data in the context of location.

For example, if report viewers need to evaluate population data for U.S. Census tracts, a report author could render the information in a table. However, it would be easier and more effective for viewers to see the information in the context of the geography of the tracts. When evaluating information that has a spatial component, viewers might find it easier to recognize relationships and trends in the data if they see the information in a spatial context.

You can insert geographical maps only if the report query uses data items from a multidimensional data source that is enabled for geographic mapping.

**Display 15.40** A Geographical Map Based on a Geographic Hierarchy That Contains U.S. Census Data
For information about plotting your own multidimensional data into an interactive geographic map, see the “Configuring the Esri Map Component” appendix in SAS Intelligence Platform: Web Application Administration Guide.

**Insert a Geographical Map**

If the current report section uses data items from a multidimensional data source that is enabled for geographic mapping and that contains a geographic hierarchy, then you can insert a geographical map into the layout.

To insert a geographical map into the layout of a report section, perform one of these tasks:

- Click on the horizontal toolbar above the layout grid to insert the geographical map in the next available cell.
- Drag the geographical map tool from the toolbar into a specific cell.

*Note:* For more information about how to position objects in the layout grid, see “Overview of Positioning Report Objects” on page 81.

You can also perform one or more of these tasks:

- Change the default measure assigned to the geographical map. For more information, see “Select a Measure for a Geographical Map” on page 177
- Change the default properties.
- Filter or rank geographical map values. For more information, see “Filtering and Ranking a Geographical Map” on page 200.

*Note:* These tasks can also be performed in View mode.

**Select a Measure for a Geographical Map**

*Note:* You can also complete this task in View mode by selecting a measure from the drop-down list in the geographical map legend.

By default, the first measure selected from the data source is used for the geographical map. To specify a different measure (if one is available), complete these steps:

1. In Edit mode, select Data ⇒ Assign Data or right-click in the geographical map, and then select Assign Data to open the Assign Data dialog box.
2. Perform one of these tasks to assign data items:
   - Use drag and drop features to assign data items.
   - Use the Move Items drop-down list to assign data items.

The following data assignments are available for geographical maps:

**Category (Limit 1)**
- Select a category or hierarchy. **Category** is required.

**Measure (Limit 1)**
- Select a measure. **Measure** is required.

**Hidden**
- Data items that are assigned to **Hidden** do not appear in the geographical map but can be used in filtering. For more information, see “Hiding Data Items” on page 312.
3. Click **OK**.

**Change the Measure Used in a Geographical Map**

A report section can contain a geographical map if the section query uses data items from a data source that is enabled for geographic mapping. The geographical map is rendered by using two data items from the data source: one measure and the geographic hierarchy.

To change the measure that is used in a geographical map (if there are other measures available), select the new measure in the drop-down list that is located above the geographical map's legend.

**Display 15.42  A Geographical Map with Average Predicted Population Selected as the Measure**
**Zoom and Pan a Geographical Map**

To focus on a specific geographical map area or zoom in or out on a selected region, click the buttons on the geographical map toolbar, as shown in the following table:

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Zoom In" /></td>
<td>Zooms in on a selected area. Click and drag the mouse to select the area that you want to zoom in on.</td>
</tr>
<tr>
<td><img src="image" alt="Zoom Out" /></td>
<td>Zooms out from a point. Click a point on the geographical map to zoom out and center on that point.</td>
</tr>
<tr>
<td><img src="image" alt="Pan" /></td>
<td>Moves the geographical map content within the viewing area. Click and drag the map until the viewer shows the area that you want to see.</td>
</tr>
<tr>
<td><img src="image" alt="Reset" /></td>
<td>Resets the zoom level to undo any previous zooming or panning.</td>
</tr>
</tbody>
</table>

**Specify Properties for a Geographical Map**

To specify properties for a geographical map, complete these steps:

1. In Edit mode, right-click in the geographical map, and then select **Properties** or in View mode, click on the map toolbar to open the Properties dialog box. The **Map** tab is displayed by default.

2. On the **Map** tab, accept or modify these properties:
   a. If you want a **Title** to appear above the geographical map, type the text, and then specify the font, font size, font style, alignment, and color. You cannot use these characters: `< > & #`
   b. From the **Size** drop-down list, choose **Custom, Small, Medium, or Large**. If you select **Custom**, type the **Width** and **Height** pixel values. **Tip** You can also resize the geographical map by using your mouse. Point to the bottom right corner or to the bottom or right border. When the pointer becomes a diagonal or horizontal bar, drag the geographical map to the new size and then release the mouse button.
   c. Choose one of the following methods to color the regions of the geographical map:
      - **Equivalent intervals** Each color in the geographical map is defined by the range of the data divided by the number of colors.
      - **Natural breaks** Each color in the geographical map is defined by natural breaks (or interruptions) in the data. The breaks are based on a histogram of data distributions.
      - **Quantiles** The measure values are sorted and an equal number (data points) are assigned to each color according to their sorted value.
**Standard deviations**

The mean and the standard deviation values for the measure are calculated. The number of regions on the geographical map is determined by adding or subtracting the standard deviation to the mean value.

d. Select the **Number of colors** to use for the coloration method that you chose. The default is 5. The maximum is 12. Regardless of your selection, the geographical map legend does not contain more colors than there are members in the currently displayed hierarchy level.

The colors used depend on the currently applied report style.

e. Select the **Border** drop-down list to open the color palette. Then select a border color for the geographical map. You can customize a color using the **Color value** field. For more information, see “Customizing Colors” on page 310.

**Display 15.43  The Map Tab in the Geographical Map Properties Dialog Box**

3. On the **Layers** tab, select the layers that you want to include in the geographical map. The **Layers** tab lists which, if any, information layers have been created by your data administrator. Examples include **Major roads**, **Schools**, **Lakes and reservoirs**, and **Elevation**.

4. Click **OK**.

---

**Removing a Table, Graph, or Geographical Map**

To delete a table, graph, or geographical map from the layout of a report section in Edit mode, complete these steps:

1. Select one or more objects in the layout grid. Use the SHIFT or CTRL key to select multiple objects.
2. Click \( \times \) on the vertical toolbar or press Delete.

3. In the confirmation message box that appears, click OK.
Part 5

Analyzing Results

Chapter 16
Finding Data Items in Multidimensional Crosstabulation Tables . . 185

Chapter 17
Filtering and Ranking .................................................. 187

Chapter 18
Drilling and Expanding .................................................. 207

Chapter 19
Sorting ............................................................................. 213

Chapter 20
Adding Total, Subtotal, and Percent of Total Calculations ......... 219

Chapter 21
Applying Conditional Highlighting .................................... 227

Chapter 22
Displaying Information About the Data ................................. 235
Chapter 16
Finding Data Items in Multidimensional Crosstabulation Tables

Overview of Finding Data Items in Multidimensional Crosstabulation Tables

The Find option is available only from the context menu for multidimensional crosstabulation tables in View mode. For example, if you search for the value 100, the crosstabulation table will re-draw and position itself with the cell that contains the value 100 in the top left corner. There is no visual indication that the value was found other than the table repositioning itself. If no more values in the crosstabulation table match 100, then a message reports that the search value was not found.

The Find option is not case-sensitive. You can use it to search either forward or backward in a multidimensional crosstabulation table.

Working in a Multidimensional Crosstabulation Table

Suppose that you have a report that contains a table with many rows. The table contains columns for product groups and products. You cannot see a specific product in the table's viewable rows. You can use the Find option to bring the row that contains the first occurrence of the product into view. You can also find the next occurrence of the string, or you can close the Find window.

To use the Find option, complete these steps:

1. Right-click a multidimensional crosstabulation table, and then click Find.
2. In the Find dialog box, select Cell values by row.
3. Make sure that Equal to is selected for Condition.
4. Type the value that you want to find (for example, 100).
5. Click **Find Next**. The table repositions when it finds the value.

6. (Optional) To find other occurrences of the same value, click **Find Next** again. If no other matching values are found, a message displays.
### How Filtering and Ranking Can Help with Analysis

SAS Web Report Studio enables you to filter and rank the data in tables, graphs, and geographical maps. The filters that are applied to a report are different from the filters that are applied to an information map, table, or cube. For more information about filters that are applied to data sources, see “Overview of Section Filters” on page 107.
Filters are simply a set of rules, or conditions, that you specify to subset the data that is displayed in a table, graph, or geographical map. The goal is to display only the data that you need to see to perform your analysis. For example, you might have a crosstabulation table that shows all sales in a variety of countries for the years 2009 and 2010. Spending is split between males and females. For a promotional mailing, you might want to filter the table so that it only contains information for 2009 where females spent more than $100,000.

The following display shows an example of the Filter and Rank dialog box when a filter has been applied to a specific geography. Notice that the following funnel icon appears next to Geography in the Categories list: 🪜. This icon tells you that a filter or rank has been defined for that data item. If you have performed a drill or expand operation on a data item that has masked the effect of the filter, then this icon becomes dimmed. This tells you that the filter is defined, but it is not currently in effect.

**Display 17.1 How the Filter and Rank Dialog Box Appears with a Filter on Geography**

The **Browse** and **Search** tabs for relational data are currently used in the Filter and Rank dialog box for list tables, crosstabulation tables, and graphs when the data source is relational. You do not specify an operator in this case. However, the implied operator is **Equal to**. For more information, see “Browsing or Searching for Filter Values” on page 201.

The **Browse** and **Search** tabs for multidimensional data are currently used in the Filter and Rank dialog box. They let you select filter values for a multidimensional data item. You do not specify an operator in this case. However, the implied operator is **Equal to**. For more information, see “Browsing or Searching for Filter Values” on page 201.

You can apply a filter when you are viewing a table. Select a row or a column and then right-click and select **Isolate**. In the following display, the right-click menu shows **Isolate Europe** for the total sales summary for retail sales in the crosstabulation table.

**Note:** The **Isolate** option is available for multidimensional data sources only.
After you isolate the row or column, the Filter and Rank dialog box shows that category as having a filter. For the preceding example, the Geography category in the Categories list displays with this icon: 🌍.

For crosstabulation tables based on relational data sources, you can apply a filter value by selecting Filter by the Column, Filter by this Row, Rank by this Column, or Rank by this Row.

Rankings order observations according to values of particular measure data items. In this case, the goal is to provide a different view of the data to help you perform your analysis. For example, a bar chart might show revenue for two sales channels for the years 2006, 2007, 2008, 2009, and 2010. You want to rank the chart so that it shows where the top 10% of sales came from in each year. The ranked graph might show that the top 10% of sales for each year came from catalog sales. Based on this information, your company might want to expand catalog mailings.

Depending on your role, you can save the filtered or ranked report under the same name or under a different name.
Filtering and Ranking a List Table

Create a Filter or Ranking for a List Table

To create a filter for a list table, complete these steps:

1. Right-click on the list table, and then select **Filter and Rank** to open the Filter and Rank dialog box.

2. Select the data item that you want to filter from the **Categories** list. This field displays the data items that are used in the list table. Any currently active filters display with this icon: 🔃.

3. Select a **Type**. The two filter types for alphanumeric categories are **No filter (show all values)** and **Filter**. Measure data items have an additional **Rank** type.

   *Note:* You cannot create rankings if the list table is part of a synchronized group. The list table also does not include categories that are assigned to group breaks or percent of total calculations.

4. If you selected a category data item, click **Get Values** for a list of available values. In the list of **Available values**, you can use either the **Browse** or **Search** tabs to find the values that you want to select. For more information, see “Browsing or Searching for Filter Values” on page 201.

5. (Optional) If the selected data item enables you to filter on formatted values, then you can select the **Filter on formatted values** option. Regardless of your selection, the query results show formatted values.¹

6. Depending on your filter type selection, take the appropriate action, as shown in the following table:

<table>
<thead>
<tr>
<th>Data Item Type</th>
<th>Filter Type</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>any type</td>
<td>No filter</td>
<td>None. No filter will be applied to the selected data item.</td>
</tr>
<tr>
<td>alphanumeric category</td>
<td>No filter (show all values) or Filter</td>
<td>Selecting the filter opens a widget in which you can either select or type in values. If you are not allowed to view the values, then you can type in values. Select one or more items from the Available values list and move them to the Selected values list. Type a value° and click Add to add it to the Selected values box. Repeat this procedure for each value that you want to filter for. You cannot use these characters: &lt; &gt; ( ) . To remove a value, select it in the Selected values box and click X.</td>
</tr>
</tbody>
</table>

¹ Filtering on formatted values can sometimes adversely affect query performance. If you have questions about whether you should select this option, contact your data source administrator.
<table>
<thead>
<tr>
<th>Data Item</th>
<th>Filter Type</th>
<th>Action</th>
</tr>
</thead>
</table>
| date category  | Filter                   | If you are entering a date, then the Fixed radio button should be selected. If you are entering a relative period, then the Relative radio button should be selected. Use one of these methods:**  
• Select a date using the calendar.  
• Select an Operator and enter a Day, Month, and Year.  
• Select an Operator, and then select a relative time period. Options include Today, Previous quarter, and a user-specified number of periods. |
| timestamp category | Filter on this date      | If you are entering a date, then the Fixed radio button should be selected. If you are entering a relative period, then the Relative radio button should be selected. Select an Operator and enter a Date, Hour, Minute, and Second. |
| time category   | Filter                   | Use one of these methods:**  
• Select an Operator and enter an Hour, Minute, and Second.  
• Select an Operator, and then select a relative time period. The options are Current hour, Previous hour, and a user-specified number of periods. |
| measure†        | Filter                   | Select an Operator and enter a Value. For the is between values (inclusive) and is not between values (inclusive) operators, type a Minimum and Maximum value. You do not type a value for the Is missing and Is not missing operators. |

**Select Top or Bottom from the Show field. Then, type a value next to the option that you chose. The percent check box is not available for relational data. To exclude tied rankings, select the Exclude ties option. For example, by default, if you request the top five products and there are three products tied for fifth place, then seven products are returned. If you select the Exclude ties option, then only five products are returned.  

Note: Rank is not available if the section is synchronized.

* If you are filtering on unformatted (actual) values, then you must enter values that match the casing of the values in the data source unless you have selected the Ignore case check box. If you select the Filter on formatted values option, then you must enter the formatted values. If the filter does not return any results, then try using a different casing.

** The data source administrator controls whether you can select category values.

*** Filtering by relative time means that the filter is relative to the time that the report is run, not the time that the filter is imposed on the table.

† Enter values in the number format that is appropriate for the locale that is set for the browser.

7. Click OK.
Remove a Filter or Ranking from a List Table

To remove a filter or ranking from a list table, complete these steps:
1. Right-click on the list table, and then select Filter and Rank to open the Filter and Rank dialog box.
2. In the Data Item list, for each data item that should not be filtered, select No filter (show all values) as the Type.
3. Click OK.

Filtering and Ranking a Crosstabulation Table

You cannot create measure filters or rankings for crosstabulation tables in Edit mode. If there are existing measure filters or rankings (which might be true for existing reports), then the Measure Filter or Rank tab lists the filters or rankings. To keep the filters or rankings, click OK in the dialog box. To delete the filters or rankings, select the Delete Filters or Rankings option, and then click OK.

Create a Category or Hierarchy Filter for a Crosstabulation Table

To create a category or hierarchy filter, complete these steps:
1. Right-click on the crosstabulation table, and then select Filter and Rank to open the Filter and Rank dialog box.
2. In the Categories list, select a category or hierarchy. This field displays the categories and hierarchies that are used in the table (including hidden categories and hierarchies). Any currently active filters display with this icon: 🌡️.
   
   Note: The list does not include categories and hierarchies that are assigned to group breaks or percent of total calculations.
3. Select a Type. The two filter types for category and hierarchies are No filter (show all values) and Filter. Hierarchies in the Time dimension of a multidimensional data source have an additional Filter (relative time) type.
4. Depending on your filter type selection, take the appropriate action, as shown in the following table:

Table 17.2 Data Item Types, Filter Types, and Available Actions for Crosstabulation Tables

<table>
<thead>
<tr>
<th>Data Item</th>
<th>Filter Type</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>any type</td>
<td>No filter</td>
<td>None. No filter will be applied to the selected data item.</td>
</tr>
</tbody>
</table>
Filtering and Ranking a Crosstabulation Table

Create a Measure Filter for a Crosstabulation Table

To create a measure filter, complete these steps:

1. Perform one of these tasks to open the Filter and Rank dialog box:
   - Right-click on the table, and then select Filter and Rank.
• Click a measure heading in a row or column, and then select Filter by this Row or Filter by this Column.

*Note:* You cannot filter on percent of total calculations.

2. Select the Measure Filter or Rank tab. This feature is available only in View mode.

3. Select the Filter option.

4. In the Show values of drop-down list, select an option.

5. Depending on your Show values of selection, specify the criteria for the filter, as shown in the following table:

<table>
<thead>
<tr>
<th>Show Values Selection</th>
<th>Criteria</th>
</tr>
</thead>
<tbody>
<tr>
<td>(rows)*</td>
<td>Select a value for each category or hierarchy level on the columns. Then, select a Measure and an Operator, and type a Value.**</td>
</tr>
<tr>
<td>(columns)***</td>
<td>Select a value for each category or hierarchy level on the rows. Then, select a Measure and an Operator, and type a Value.***</td>
</tr>
<tr>
<td>Outermost category or hierarchy on the rows</td>
<td>Select a Measure and an Operator, and type a Value.***</td>
</tr>
<tr>
<td>Outermost category or hierarchy on the columns</td>
<td>Note: These values are not available when a section is synchronized.</td>
</tr>
</tbody>
</table>

* If the measures are on the columns, then a (rows) option is available.

** Do not include a currency symbol in the Value field. In addition, enter values in the number format that is appropriate for the locale that is set for the browser.

*** If the measures are on the rows, then a (columns) option is available.

6. Click OK.

**Create a Ranking for a Crosstabulation Table**

To create a ranking for a measure in a crosstabulation table, complete these steps:

1. Perform one of these tasks to open the Filter and Rank dialog box:
   • Right-click on the table, and then select Filter and Rank.
   • Click a measure heading in a row or column, and then select Rank by this Row or Rank by this Column.

   *Note:* You cannot filter on percent of total calculations.

2. If you are in View mode, select the Measure Filter or Rank tab.

3. Select the Rank option.

4. In the Show field, select Top or Bottom, and then type a value next to the option that you chose.

5. (Optional) Choose one of these options:
   • To evaluate the data as a percentage, select the percent(%) option, and then enter a value. The value cannot exceed 100.

   *Note:* This option is not available for relational data sources.
• To exclude tied rankings, select the **Exclude ties** option. For example, by default, if you request the top five products and there are three products tied for fifth place, then seven products are returned. If you select the **Exclude ties** option, then only five products are returned.

6. In the **Show values of** drop-down list, select an option.

7. Depending on your **Show values of** selection, specify the criteria for the ranking, as shown in the following table:

   **Table 17.4 Ranking Criteria Options for Crosstabulation Tables**

<table>
<thead>
<tr>
<th>Show Values Selection</th>
<th>Criteria</th>
</tr>
</thead>
<tbody>
<tr>
<td>(rows)*</td>
<td>Select a value for each category or hierarchy level on the columns, and then select a Measure.</td>
</tr>
<tr>
<td>(columns)**</td>
<td>Select a value for each category or hierarchy level on the rows, and then select a Measure.</td>
</tr>
</tbody>
</table>

* Outermost category or hierarchy on the rows
** Outermost category or hierarchy on the columns

* If the measures are on the columns, then a (rows) option is available.
** If the measures are on the rows, then a (columns) option is available.

8. Click **OK**.

---

**Create a Member Property Filter for a Crosstabulation Table**

*Note:* This capability is available only for multidimensional categories with child filters. Not all cubes have member properties, so this capability is not available if either the cube or the selected category does not have member properties. You cannot filter on member properties with a relative time filter.

To create a filter for member properties, complete these steps:

1. Perform one of these tasks to open the Filter and Rank dialog box:
   - Right-click on the table, and then select **Filter and Rank**.
   - Right-click a measure heading in a row or column, and then select **Filter by this Row** or **Filter by this Column**.

2. If you are in View mode, select the **Category** tab.

3. Select the **Filter** radio button.

4. Select the **Based on member property** check box. The **Operator** drop-down list and the **Value** field appear. The following display is an example of the **Category Filters** tab when the **Based on member property** check box is selected.
5. Select the **Operator**. The choices are either **Is equal to** or **Is not equal to**.

6. Enter a filter value in the **Value** field.

7. Click **OK**.

---

**Remove a Filter or Ranking from a Crosstabulation Table**

To remove a filter or ranking from a crosstabulation table, complete these steps:

1. Right-click on the table, and then select **Filter and Rank** to open the **Filter and Rank** dialog box.

2. Remove category and hierarchy filters, measure filters, or rankings as follows:
   - On the **Category Filters** tab, for each data item that should not be filtered, select **No filter (show all values)** as the **Type**.
   - On the **Measure Filter or Rank** tab, select **No filter (show all values)**.

   **Note:** If you already have a measure filter on a crosstabulation table in Edit mode, then you can select the **Delete Filters or Rankings** check box on the **Measure Filter or Rank** tab. Then, click **OK**.

3. Click **OK**.
Filtering and Ranking a Graph

Create a Category or Hierarchy Filter for a Graph

To create a category or hierarchy filter, complete these steps:

1. Right-click on the graph, and then select **Filter and Rank** to open the Filter and Rank dialog box.
2. Select the **Category Filters** tab.
3. Select a category or hierarchy in the **Categories** list. This field displays the categories and hierarchies that are used in the graph along with any currently active filters. Data item names might wrap multiple lines.

   *Note:* The list does not include categories and hierarchies that are assigned to group breaks.

4. Select the **Type** option.
5. (Optional) If the selected data item is physically stored as character data and it is not using the default format, then you can select the **Filter on formatted values** option. In this case, formatted values are used in all parts of the current filter query.

   *Note:* If the selected data item uses the default format and this option is selected (which might be the true for reports that were created with a previous version of SAS Web Report Studio), then clear this option to improve query performance. However, if you cannot produce the desired results by using unformatted (actual) values, leave the option selected.

6. Depending on your selected category and filter type, follow the actions that are described in Table 17.2 on page 192.
7. Click **OK**.

Create a Measure Filter for a Graph

*Note:* Multidimensional graphs allow filter and ranking on rows and columns when the section is synchronized.

To create a measure filter, complete these steps:

1. Right-click on the graph, and then select **Filter and Rank** to open the Filter and Rank dialog box.
2. Select the **Measure Filter or Rank** tab.
3. Select the **Filter** option.
4. In the **Show values of** drop-down list, select an option.
5. Depending on your **Show values of** selection, specify the criteria for the filter, as shown in the following table:

   *Note:* The **Show values** drop-down list does not appear for relational graphs.
### Table 17.5 Filter Criteria Options for Each Graph Type

<table>
<thead>
<tr>
<th>Graph Type</th>
<th>Show Values Selection</th>
<th>Criteria</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bar chart or progressive bar chart</td>
<td>The category or hierarchy that is assigned to the bars.</td>
<td>Select the measure that is assigned to the bar height. Then, select an <strong>Operator</strong> and type a <strong>Value.</strong></td>
</tr>
<tr>
<td>Bar-line chart</td>
<td>The category or hierarchy that is assigned to the bars.</td>
<td>Select the measure that is assigned to the bar height or the measure that is assigned to the line height. Then, select an <strong>Operator</strong> and type a <strong>Value.</strong></td>
</tr>
<tr>
<td>Bubble plot</td>
<td>The category or hierarchy that is assigned to the bubble groups.**</td>
<td>Select the measure that is assigned to the vertical axis or the measure that is assigned to the horizontal axis. Then, select an <strong>Operator</strong> and type a <strong>Value.</strong></td>
</tr>
<tr>
<td>Line graph</td>
<td>The category or hierarchy that is assigned to the lines.</td>
<td>Select the measure that is assigned to the line height. Then, select an <strong>Operator</strong> and type a <strong>Value.</strong></td>
</tr>
<tr>
<td>Pie chart</td>
<td>The category or hierarchy that is assigned to the segments.</td>
<td>Select the measure that is assigned to the segment size. Then, select an <strong>Operator</strong> and type a <strong>Value.</strong></td>
</tr>
<tr>
<td>Scatter plot</td>
<td>The category or hierarchy that is assigned to the optional marker groups.**</td>
<td>Select the measure that is assigned to the vertical axis or the measure that is assigned to the horizontal axis. Then, select an <strong>Operator</strong> and type a <strong>Value.</strong></td>
</tr>
<tr>
<td>Tile chart</td>
<td>The category or hierarchy that is assigned to the tile chart.</td>
<td>Select the measure that is assigned to the size or color. Then, select an <strong>Operator</strong> and type a <strong>Value.</strong></td>
</tr>
</tbody>
</table>

* Do not include a currency symbol in the **Value** field. In addition, enter values in the number format that is appropriate for the locale that is set for the browser.

** If no category or hierarchy is assigned to the marker groups or the bubble groups, then you cannot create the filter.

6. Click **OK**.

### Create a Ranking for a Graph

**Note:** Multidimensional graphs allow rankings on rows and columns when the section is synchronized. Relational graphs do not allow rankings when the section is synchronized.

To create a ranking for a measure in a graph, complete these steps:

1. Right-click on the graph, and then select **Filter and Rank** to open the Filter and Rank dialog box.
2. Select the **Measure Filter or Rank** tab.
3. Select the **Rank** option.
4. In the **Show** field, select **Top** or **Bottom**, and then type a value next to the option that you chose.

5. (Optional) Choose one of these options:
   - To evaluate the data as a percentage, select the **percent(%)** option, and then enter a value. The value cannot exceed 100.

   **Note:** This option is not available for relational data sources.
• To exclude tied rankings, select the **Exclude ties** option. For example, by default, if you request the top five products and there are three products tied for fifth place, then seven products are returned. If you select the **Exclude ties** option, then only five products are returned.

6. In the **Show values of** drop-down list, select an option.

7. Depending on your **Show values of** selection, specify the criteria for the ranking, as shown in the following table:

   **Note:** The **Show values** drop-down list does not appear for relational graphs.

<table>
<thead>
<tr>
<th>Table 17.6</th>
<th>Ranking Criteria Options for Each Graph Type</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Graph Type</strong></td>
<td><strong>Show Values Selection</strong></td>
</tr>
<tr>
<td>Bar chart or progressive bar chart</td>
<td>The category or hierarchy that is assigned to the bars.</td>
</tr>
<tr>
<td>Bar-line chart</td>
<td>The category or hierarchy that is assigned to the bars.</td>
</tr>
<tr>
<td>Bubble plot</td>
<td>The category or hierarchy that is assigned to the optional bubble groups.*</td>
</tr>
<tr>
<td>Line graph</td>
<td>The category or hierarchy that is assigned to the lines.</td>
</tr>
<tr>
<td>Pie chart</td>
<td>The category or hierarchy that is assigned to the segments.</td>
</tr>
<tr>
<td>Scatter plot</td>
<td>The category or hierarchy that is assigned to the optional marker groups.*</td>
</tr>
<tr>
<td>Tile chart</td>
<td>The category or hierarchy that is assigned to the tile chart.</td>
</tr>
</tbody>
</table>

* If no category or hierarchy is assigned to the marker groups or the bubble groups, then you cannot create the ranking.

8. Click **OK**.

**Remove a Filter or Ranking from a Graph**

To remove a filter or ranking from a graph, complete these steps:

1. Right-click on the graph, and then select **Filter and Rank** to open the Filter and Rank dialog box.

2. Remove category and hierarchy filters, measure filters, or rankings as follows:
   - On the **Category Filters** tab, for each data item that should not be filtered, select **No filter** as the **Type**.
   - On the **Measure Filter or Rank** tab, select **No filter (show all values)**.

3. Click **OK**.
Filtering and Ranking a Geographical Map

Create a Filter for a Geographical Map

To create a filter for the geographic hierarchy in a geographical map, complete these steps:

1. In Edit mode, right-click in the geographical map, and then select Filter and Rank or in View mode, click on the map toolbar, and then select Filter and Rank. The Filter and Rank dialog box appears.
2. Select the Category Filters tab.
3. In the Categories list, select the geographic hierarchy. This field displays the geographic hierarchy along with any currently active filters.
4. Select the Filter option.
5. Select items in the Available values list. You can select and deselect items individually, or you can use the Select All or Deselect All buttons.
6. Click OK.

Create a Measure Filter for a Geographical Map

*Note:* The Measure Filter or Rank tab is not available in Edit mode.

To create a measure filter, complete these steps:

1. In View mode, click on the map toolbar, and then select Filter and Rank to open the Filter and Rank dialog box.
2. Select the Measure Filter or Rank tab.
3. Select the Filter option.
4. In the Show values of drop-down list, select the geographic hierarchy.
5. Select the Measure that is being used in the geographical map.
6. Select an Operator.
7. Enter a Value. (Do not include the currency symbol.)
8. Click OK.

Create a Ranking for a Geographical Map

*Note:* The Measure Filter or Rank tab is not available in Edit mode.

To create a ranking for the measure used in a geographical map, complete these steps:

1. In View mode, click on the map toolbar, and then select Filter and Rank to open the Filter and Rank dialog box.
2. Select the Measure Filter or Rank tab.
3. Select the **Rank** option.

4. In the **Show** field, select **Top** or **Bottom**, and then type a value next to the option that you chose.

5. (Optional) Choose one of these options:
   - To evaluate the data as a percentage, select the **percent(%)** option, and then enter a value. The value cannot exceed 100.
   - To exclude tied rankings, select the **Exclude ties** option. For example, by default, if you request the top five geographic areas for total revenue and there are three areas tied for fifth place, then seven geographic areas are shown on the geographical map. If you select the **Exclude ties** option, then only five geographic areas are shown on the geographical map.

6. In the **Show values of** drop-down list, select the geographic hierarchy.

7. Select the **Measure** that is being used in the geographical map.

8. Click **OK**.

---

**Remove a Filter or Ranking from a Geographical Map**

To remove a filter or ranking from a geographical map, complete these steps:

1. In Edit mode, right-click in the geographical map, and then select **Filter and Rank** or in View mode, click on the map toolbar, and then select **Filter and Rank**. The Filter and Rank dialog box appears.

2. Remove the geographic hierarchy filter, the measure filter, or the ranking as follows:
   - On the **Category Filters** tab, select the geographic hierarchy, and then select **No filter**.
   - On the **Measure Filter or Rank** tab, select **No filter (show all values)**.

3. Click **OK**.

---

**Browsing or Searching for Filter Values**

**About Browsing and Searching**

There are two ways to select values from a data item:

- You can browse all the values that are available and then select from a list.
- You can enter search arguments to narrow the list of values and then select from that list.

The **Browse** and **Search** tabs have a different appearance depending on whether the data items are in a relational data source or a multidimensional data source.

The **Browse** and **Search** tabs let you search for values when you are doing the following:

- constructing an unprompted filter that uses either the **Equal to** or **Not equal to** operators
• constructing a prompted filter whose prompt type is **Create a list of values** and whose operator is **Equal to**, **Not equal to**, **Between**, or **Not between**

The **Filter on formatted values** check box determines whether the search is for formatted or unformatted (actual) values.

### Browse for Relational Data Items

You can use the **Browse** tab to browse all the values that are available in the data source and then select one from a list. To browse the values in a relational data source, complete these steps:

1. Click **Get Values** to run a query and display the values.

   *Note:* The **Get Values** button is disabled if the data item does not allow values to be displayed, the data item values have already been retrieved, or the data item values cannot be retrieved.

2. Select a value (or values) from the **Browse** tab. Click \(\rightarrow\) to move one or more values to the **Selected values** list. You can select a range of values using the SHIFT or the CTRL key. Use \(\leftarrow\) to move all values in the **Browse** list to the **Selected values** list.

### Display 17.6 Filter and Rank Dialog Box with Values Moved from the Browse Tab to the List of Selected Values

If there are too many values to display, then a message displays. In this case, the **Search** tab is accessible, so you can search for the values.
Search for Relational Data Items

You can use the Search tab to enter search arguments to narrow the list of values and then select a value from that list. To search for the values in a relational data source, complete these steps:

1. Select a Search criteria from the drop-down list. The following operators are available:

<table>
<thead>
<tr>
<th>Search Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contains</td>
<td>Specifies that the value contains the search argument.</td>
</tr>
<tr>
<td>Exactly matches</td>
<td>Specifies that the value matches the search argument exactly.</td>
</tr>
<tr>
<td>Starts with</td>
<td>Specifies that the value starts with the search argument.</td>
</tr>
<tr>
<td>Ends with</td>
<td>Specifies that the value ends with the search argument.</td>
</tr>
<tr>
<td>Matches pattern</td>
<td>Lets you create a pattern for the search argument. Use the question mark (?) as a substitute for a single letter and an asterisk (*) as a substitute for zero or more letters.</td>
</tr>
</tbody>
</table>

The search argument is case-sensitive for formatted values and not case-sensitive for unformatted (actual) values.

2. Enter a value to search for in the field to the right of the Search criteria list.

3. Click Search. The search results display in the table below the button. If the table contains more than 50 entries, a page control appears above the table to let you move to the next or previous set of entries.

4. Select a value (or values) in the table. Click to move one or more values to the list of Selected values. You can select a range of values using the SHIFT or the CTRL key. Use to move all values to the list of Selected values.
Display 17.8 Moving Search Values to the Selected Values List in the Create Custom Filter Dialog Box

Browse for Multidimensional Data Items

When the **Browse** tab displays for multidimensional data, a tree representing the hierarchy of the data items expands to the first available level. Note that when portions of the tree are expanded, there might be a slight delay in populating the list, because the data in the tree is loaded on an as-needed basis.

To browse the values in a multidimensional data source, complete these steps:

1. Select a value (or values) from the **Browse** tab. Click \( \rightarrow \) to move one or more values to the list of **Selected values**. You can select a range of values using the SHIFT or the CTRL key. Double-clicking expands or collapses the tree, depending on the state of the tree node when you click it. Use \( \rightarrow \) to move all values in the **Browse** list to the list of **Selected values**. If an area of the tree is not expanded, then the values in the subtree under that tree value are not moved to the **Selected values** list.
2. (Optional) Remove values from the **Selected values** by clicking . You can also double-click a value to remove it. You can select a range of values using the SHIFT or the CTRL key. To remove all values, select all of the items and then click .

### Search for Multidimensional Data Items

You can use the **Search** tab to enter search arguments to narrow the list of values and then select a value from that list. To browse the values in a multidimensional data source, complete these steps:

1. Select a **Search criteria** from the drop-down list. The following operators are available:

<table>
<thead>
<tr>
<th>Search Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contains</td>
<td>Specifies that the value contains the search argument.</td>
</tr>
<tr>
<td>Exactly matches</td>
<td>Specifies that the value matches the search argument exactly.</td>
</tr>
<tr>
<td>Starts with</td>
<td>Specifies that the value starts with the search argument.</td>
</tr>
<tr>
<td>Ends with</td>
<td>Specifies that the value ends with the search argument.</td>
</tr>
<tr>
<td>Matches pattern</td>
<td>Lets you create a pattern for the search argument. Use the question mark (?) as a substitute for a single letter and an asterisk (*) as a substitute for zero or more letters.</td>
</tr>
</tbody>
</table>

The search argument is always case-sensitive, because multidimensional values are formatted.

2. Enter a value to search for in the field to the right of the **Search criteria** list.
3. Click **Search**. The search results display in the table below the button. If the table contains more than 50 entries, a page control appears above the table to let you move to the next or previous set of entries.

In the table, **Name** is the data item value and **Parent path** is a list of the levels from the top of the hierarchy to the value. Because multidimensional data sources are hierarchical, data values need to be placed into the context of the hierarchies in which they reside. For example, your cube could contain both [New York].[Rochester] and [Minnesota].[Rochester]. If you see just the value **Rochester**, you need additional information to know in which state the city is located. In this example, the **Parent path** for one data value will be **New York** and **Minnesota** for the other data value.

4. Select a value (or values) in the table. Click to move one or more values to the list of **Selected values**. You can select a range of values using the SHIFT or the CTRL key. Use to move all values to the list of **Selected values**.

**Display 17.10  Moving Multidimensional Search Values to the Selected Values List in the Filter and Rank Dialog Box**

5. (Optional) Remove values from the **Selected values** by clicking . You can also double-click a value to remove it. You can select a range of values using the SHIFT or the CTRL key. To remove all values, select all of the items and then click .
How Drilling and Expanding Can Help with Analysis

If you want to visibly compare parent and child values at the same time, then drilling and expanding values can help you analyze the data. For example, suppose you want to see the overall sales revenue for last year, as well as the quarterly sales revenue, for your company. You could use the drill and expand feature in a crosstabulation table to help analyze both the annual and quarterly revenue.

Drill or Expand Hierarchies in a Crosstabulation Table

You can perform these tasks on a crosstabulation table that is based on multidimensional data:

- Click to expand a member of a hierarchy level. You see the values for the current member and the values for the next hierarchy level down for that member.
In the Hierarchy Level Year, the Member 2007 Has Been Expanded to Display Values for the Quarter Hierarchy Level

- Click to drill a member of a hierarchy level. You see only the values for the next hierarchy level down for that member. Note that a bread crumb appears above the table when you drill down in a hierarchy. Use the bread crumb to move up a level in a hierarchy.

In the Hierarchy Level Year, the Member 2007 Has Been Drilled to Display Values for the Quarter Hierarchy Level

- Right-click a hierarchy level heading, and then select Expand All. In the display here, you would click on the hierarchy level Quarter.
- Right-click a hierarchy level heading, and then select Collapse All.

Drill or Expand Hierarchies in a Graph

You can drill in a graph that is based on multidimensional data. Right-click the name of a member in the graph, and then select Drill down on <member>. You see only the values for the next hierarchy level down for that member.

Note: If a section is synchronized, then a graph that exists in a synchronized section with a table expands if an expand operation is performed on the table. For more information about synchronization, see “Overview of Synchronized Filtering, Sorting, Drilling, and Expanding” on page 87.
In Display 18.3 on page 209, to undo the drilling, you select **Clothes & Shoes** above the graph, which is the next hierarchy level up. To go back to the top level of the hierarchy, select **Product**.

**Note:** You cannot drill into the X-axis category values for a progressive bar chart with a multidimensional data source if the chart includes an initial or final bar. However, you can still drill into the chart. You can remove the initial and final bars, drill into the chart, and then add back the initial and final bars. If your section is synchronized, you can drill into a different report element, because the drills are shared across report elements in a synchronized section. You can also drill into any horizontal or vertical series data items, because only the X-axis category value has drilling restrictions.

---

### Drill or Expand the Geographic Hierarchy in a Geographical Map

The following display is an example of a geographical map that has geographic hierarchies defined.

**Display 18.4** The US Regions Hierarchy Level
You can perform these tasks on a geographical map to drill or expand the geographic hierarchy:

- Click and then click a colored geographical map region (which is a member in the currently displayed geographic hierarchy level). The geographical map is redrawn to display the regions (members) for the next hierarchy level down while keeping the context of the current hierarchy level. For example, if you select the Midwestern states in Display 18.4 on page 209, then the geographical map retains the context of the selected region and uses that information to determine which states should appear in the following display. The legend to the right of the geographical map changes to display the values for the expanded region.

**Display 18.5** *In the US Regions Hierarchy Level, the West N. Central Member Has Been Expanded to Display Values for the State Hierarchy Level*

- Click and then click an expanded region to collapse it.

- Click and then click a colored geographical map region (which is a member in the currently displayed geographic hierarchy level). The geographical map is redrawn to display the regions (members) for the next hierarchy level down. For example, if you select the state of Iowa in Display 18.5 on page 210, then the geographical map retains the context of the selected state and uses that information to determine which counties should appear in the following display. The legend to the right of the geographical map changes to display the values for the drilled state.

**Display 18.6** *In the US Regions Hierarchy Level, the West N. Central Member Has Been Drilled to Display Values for the County Hierarchy Level*

- Click to remove the last drill-down action that you performed.
How Drilling and Expanding Affects Other Table, Graph, and Geographical Map Features

How Drilling and Expanding Affects Filtering and Ranking

SAS Web Report Studio shows if a filter or rank has been defined for a data item. In either the Categories or Data Item list in the Filter and Rank dialog box, you see the funnel icon (垨) if the filter is in effect. If you have performed a drill or expand operation on a data item that has masked the effect of the filter, then this icon becomes dimmed. This tells you that the filter is defined, but it is not currently in effect. If you select a data item with a disabled filter, a message tells you that the filter is not in effect and gives a general explanation of why.

How Drilling and Expanding Affects Conditional Highlighting in Tables and Graphs

When you define conditional highlighting, there is an option to apply the rule either to the selected levels of displayed dimensions or to any level of displayed dimensions. In the Conditional Highlighting dialog box, there are two selections for rule assignment: All hierarchy levels or Selected hierarchy levels.

Display 18.7  Conditional Highlighting Dialog Box with the Selected Hierarchy Levels Option Selected

Note that if you choose the Selected hierarchy levels option, then you can click Select to open the dialog box that lets you specify your selections. For more information, see “Managing Conditional Highlighting for Table Values” on page 228 or “Managing Conditional Highlighting for Graph Values” on page 233.

As you expand or drill and display different levels in a table or a graph, conditional highlighting rules continue to be applied based on the rule assignment that you specified.
How Drilling and Expanding Affects Totals and Subtotals in Tables

When you specify totals or subtotals, they are applied and affect every level of the displayed table. As you navigate the table by drilling and expanding, the total, subtotal, or both are reflected at the currently displayed level.

How Drilling and Expanding Affects Percent of Total Calculations in Tables

When you drill and expand in a table, any percent of total calculations are updated to reflect the values that are relevant to the currently displayed hierarchy level.

How Drilling and Expanding Affects Panning and Zooming in a Geographical Map

You can indirectly remove panning or zooming in a geographical map by drilling or expanding. For example, you drill into a region (or pan to a certain area) and then use the breadcrumb to drill up. The drill-up operation takes you back to the state that the geographical map was in before you performed the drill and pan operations. You are not positioned in the panned results when you drill up.
How Sorting Can Help with Analysis

Information is easier to understand when it appears in an expected order. Applying a sort order to one or more data items enables you to arrange rows and columns in tables and axis labels on charts in some order, such as alphabetically or highest to lowest numerically. Interactively changing the order of data can provide you with a different perspective that often facilitates valuable insight. For example, in a report, sales employees who are initially arranged alphabetically can be resorted by geography or by sales amount. Seeing the most recent year first in a table can help you find the most relevant information faster. However, you can spot trends more quickly in a line plot if you order the years ascending chronologically. You can also sort data by multiple data items to show sales employees who generated the most to the least revenue, within an alphabetical list of the region. SAS Web Report Studio enables report authors to easily set or change the sort order of the dates, the text, and the numbers that are presented in tables and graphs to facilitate understanding.

Sorting Data in a List Table

Sort Values in a List Table

To sort individual columns in a list table, the sort priority is in reverse selection order. For example, if you select Order Year descending, then Product Name ascending, and
then *Country* ascending, the priority will be *Country*, then *Product Name*, and then *Order Year*.

To specify a sort order for values in a list table, complete these steps:

1. Right-click a column heading in the list table, and then select either **Sort Ascending** or **Sort Descending**.

2. To sort additional columns in order of priority, right-click each column heading and then select either **Sort Ascending** or **Sort Descending**.

*Display 19.1  Sort Ascending and Sort Descending Menu Options for a List Table*

---

**Specify a Sort Priority for Values in a List Table**

If you are working with a relational list table in Edit or View mode, then you can specify a sort order for the values. To specify a sort priority for values in a list table, complete these steps:

1. Right-click in the table and select **Sort Priority**. This opens the Sort Priority dialog box.

*Display 19.2  Sort Priority Menu Item for List Tables in Edit Mode*
Display 19.3  Sort Priority Menu Item for List Tables in View Mode

2. In the Sort dialog box, specify which item you want sorted first. You can sort multiple columns. In the following display, the list table is sorted first by height and then by age.

Display 19.4  Sort Dialog Box with the Height and Age Columns Selected

Note: The Sort Priority option is not available for list tables in a synchronized group.

Sort Data in a Crosstabulation Table

In crosstabulation tables, right-click a column heading to sort data. You can also sort categories, rather than measures, by clicking the category name.

Note: If measures in the crosstabulation table have been placed on the rows instead of the columns, then you are sorting the rows.

To specify a sort for values in a crosstabulation table, complete these steps:

1. To sort by category values in a crosstabulation table, right-click a column or row heading and then select either Sort Ascending or Sort Descending.
2. To sort by measure values in a multidimensional crosstabulation table, right-click a column or row heading and then select **Sort Ascending**, **Sort Descending**, **Ascending across Hierarchies**, or **Descending across Hierarchies**.

*Note:* There is a difference between the **Sort Ascending** and **Sort Descending** options and the **Ascending across Hierarchies** and **Descending across Hierarchies** options. The **Ascending across Hierarchies** and **Descending across Hierarchies** options are available only for measures. You can sort either row or column data. However, the sort is relevant only for the measure that you select. For example, in the following display, the **Cost N** column for Canada is selected, so it will be the measure that is sorted when you select either the **Ascending across Hierarchies** or **Descending across Hierarchies** option. You can sort across a hierarchy or within a hierarchy depending on the measure that you select.

**Display 19.6  Sorting Options for a Multidimensional Crosstabulation Table**

---

**Sorting Data in a Graph**

**Sort Ascending or Descending Values in a Graph**

Right-click the name of a category or hierarchy level in a graph, and then select either **Sort Ascending** or **Sort Descending**.

To specify a sort order for values in a graph, complete these steps:

1. Right-click the name of a category or hierarchy level in a graph to sort the category or hierarchy level by the values of the measure used in the graph.
2. If the graph has more than one measure, you can choose which one to sort by.

**Sort by Measure Values in a Graph**

Right-click the name of a category or hierarchy level in a graph to sort the category or hierarchy level by the values of the measure used in the graph.

To specify a sort order for values in a graph, complete these steps:

1. Right-click the name of a category or hierarchy level in a graph to sort the category or hierarchy level by the values of the measure used in the graph. If the graph has more than one measure, you can choose which one to sort by.

2. To sort by measure values in a graph based on a multidimensional data source, select either Sort Ascending by `<column-name>` or Sort Descending by `<column-name>`, where `<column-name>` is the name of the column that you selected. For example, in the following display, the Sort Descending by Total Sales Summary option was selected.

---

**Remove All Sorting for Tables or Graphs**

You can remove all sorting that has been applied to a table or a graph. Right-click the name of a category or hierarchy level in the graph or table and select Remove All Sorting.
Chapter 20
Adding Total, Subtotal, and Percent of Total Calculations

How Totals, Subtotals, and Percent of Total Calculations Can Help with Analysis .................................................. 219
Understanding the Relationship between Totals, Subtotals, and Percent of Totals ..................................................... 220
Managing Totals and Subtotals in Tables ................................................................. 220
  About Totals and Subtotals ........................................................................ 220
  Show or Hide Totals and Subtotals for List Tables ................................ 221
  Show or Hide Totals and Subtotals for Crosstabulation Tables ............... 221
  Show or Hide Totals and Subtotals for Multidimensional Tables ............. 222
Managing Percent of Total Calculations in Tables ................................................. 223
  About the Different Calculations That You Can Create ....................... 223
  Add a Percent of Total Calculation to a Table ........................................... 223
  Modify the Number of Decimal Places for a Percent of Total Calculation 224
  Remove a Percent of Total Calculation from a Table .............................. 225

How Totals, Subtotals, and Percent of Total Calculations Can Help with Analysis

Summarizing data provides a fast way to understand how a group of data values are performing and how subgroups compare to one another. SAS Web Report Studio enables you to display the measures summarized, such as a summation or average, at one or multiple levels within tables. A summary for all values is called a total and a summary for a subgroup of values is called a subtotal. These totals and subtotals can be displayed above or below the group of values (for multidimensional data sources only).

You can choose to add totals and subtotals for rows, columns, or both. When you need to understand how an individual item contributes to a group of values, you can add table cells to display the percent that value represents of the overall total, subtotal, or both. Totals, subtotals, and percent of total calculations help you evaluate metrics at higher levels and compare groups at the same level to determine where to focus your analysis.
Understanding the Relationship between Totals, Subtotals, and Percent of Totals

For a multidimensional crosstabulation table, if you want to identify any percent of total items, then you also need the corresponding total or subtotal items. For example, if you create a percent of row subtotal data item, then you also need the row subtotals.

If you have not already specified any necessary total or subtotal values, then SAS Web Report Studio adds them automatically. For example, if you have not yet specified any totals or subtotals when you create a percent of row subtotal data item, then the Row Subtotals option is already selected when you open the Total dialog box.

If you use the Total dialog box to remove any totals or subtotals, then any percent of total data items that depend on these totals and subtotals are automatically removed. Before this occurs, however, you see a warning and must confirm that you want to remove the totals and subtotals.

Managing Totals and Subtotals in Tables

About Totals and Subtotals

Totals can be positioned at the top, at the bottom, on the left, or on the right of a table element (for multidimensional data sources). By default, total and subtotal values are displayed in boldface type. In addition, their table cells have a light blue background. For more information about how to change the properties for displaying totals, see “Specify Style Properties for Total and Subtotal Values” on page 144.

Display 20.1 Multidimensional Crosstabulation Table with Formatted Column Total Values
Show or Hide Totals and Subtotals for List Tables

To show or hide totals for list tables, complete these steps:

1. Right-click on the list table, and then select Total to open the Total dialog box.
2. Select or deselect the Totals check box.
3. Click OK.

Show or Hide Totals and Subtotals for Crosstabulation Tables

To show or hide totals for crosstabulation tables, complete these steps:

1. Right-click on the crosstabulation table, and then select Total to open the Total dialog box.
2. Select one or more of these options:
   
   **Row totals**
   Select this option to display row totals.

   **Row subtotals**
   Select this option to display row subtotals.

   **Column totals**
   Select this option to display column totals.

   **Column subtotals**
   Select this option to display column subtotals.
3. Click OK.
Show or Hide Totals and Subtotals for Multidimensional Tables

For multidimensional data, in addition to the choices listed here for crosstabulation tables, the Totals dialog box provides these additional options:

Display
You can choose where totals and subtotals appear. You can select either On top (left) or On bottom (right).

Type
You can choose whether totals and subtotals are based on all available multidimensional data or only the data that is being displayed. You can select either Parent totals (for totals and subtotals that include all data in the cube, not just what is shown in your table) or Visual totals (for totals and subtotals that are based on just the values being shown in your table). For example, if your table contains a filter so that it shows data from only 2009 but your cube contains data for 2006-2010, then Visual totals provides a total for just 2009 values, while Parent totals provides a total that includes data from all four years.

Itemize Values Across Hierarchies
If you specify any totals or subtotals, you see an Itemize values across hierarchies check box. If you select this check box and if you have more than one category on rows or columns, then in addition to grand totals, your table contains additional subtotal values for the outer categories.
Managing Percent of Total Calculations in Tables

About the Different Calculations That You Can Create

For tables that use relatioal data, you can add a column that shows a selected measure as a percentage of a grand total. For relational crosstabulation tables, you can show a selected measure as a percentage of a grand total, a column total, a row total, or a subtotal. For multidimensional crosstabulation tables, you can show a selected measure as a percentage of a grand total, a column total, a row total, a column subtotal, or a row subtotal.

Add a Percent of Total Calculation to a Table

To add a percent of total calculation to a table, complete these steps:

1. Right-click on the table, and then select Percent of Total to open the Percent of Total dialog box. The Percent of Total menu item is not available if either of these conditions exists:
   - The table does not contain any measures that can be used in a grand total.
   - The table is in a synchronized group.

2. In the For measure drop-down list, select a measure for the calculation. The list does not contain existing percent of total calculations.

3. In the Show percent of drop-down list, select an option, depending on the type of table:
   - For list tables, the Column Total option is the only type of percent of total that is supported.
   - For relational crosstabulation tables, for the selected measure, select the type of percentage that you want to show. Your predefined choices are Grand Total, Column Total, and Row Total. The drop-down list also contains these options:
     - one option for the subtotal of each category in the columns of the table. The options are listed in order from the top down.
     - one option for the subtotal of each category in the rows of the table. The options are listed in order from the outside inward.
   - For multidimensional crosstabulation tables, for the selected measure, select the type of percentage that you want to show. The available choices are Grand Total, Column Total, Column Subtotal, and Row Subtotal.

4. Type a Label for the calculation that you are creating. You can use a maximum of 30 characters. The Label field is initially blank. The Add button is not available until you enter a value into this field.

5. Click Add to add your percent of total calculation.

6. Click OK.

When the measure that is used in the calculation appears in a column, the new calculation appears immediately to the right of the measure. When the measure that is used in the calculation appears in a row, the new calculation appears immediately below the measure.
Note: If you add any percent of total items in a multidimensional crosstabulation table, you also see the corresponding total or subtotal items.

**Display 20.4 Crosstabulation Table with a Percent of Total Calculation**

If you use the Properties dialog box to convert a crosstabulation table to a list table, then the following happens:

- All percent of grand total items become percent of column items.
- Any other percent of total items are removed, because they are not supported for list tables. You are asked to confirm the removal of these percent of total items.

**Modify the Number of Decimal Places for a Percent of Total Calculation**

By default, percent of total calculations have two decimal places. To change the number of decimal places, complete these steps:

1. Right-click the percent of total column heading, and then select Format.
2. In the Define a Format dialog box, change the value in the Decimal places field.

In this example, the number of decimal places has changed from 2 to 4.

**Display 20.5 Define a Format Dialog Box for Numbers**

3. Click OK.
Remove a Percent of Total Calculation from a Table

To remove a percent of total calculation from a table, complete these steps:

1. Right-click on the table, and then select Percent of Total to open the Percent of Total dialog box.
2. Select a calculation.
3. Click Remove.
4. Click OK.

Note: If you use the Select Data dialog box to remove a data item from your query, then any percent of total calculations that depend on it are automatically removed from your table.
Chapter 21
Applying Conditional Highlighting

How Conditional Highlighting Can Help with Analysis

Conditional highlighting is used to direct a report viewer's attention to specific report results. For example, a report author might design a report on suppliers so that table cells that contain delivery times that are greater than 14 days are automatically highlighted with a red background. You can also add, modify, or delete conditional highlighting when you view a report. For example, you might want to highlight delivery times that are less than five days instead of greater than 14 days.

For tables, SAS Web Report Studio has a variety of options for highlighting results that meet the specified conditions. In addition, an image or user-supplied text can be placed to the right or left of the revenue value, or they can replace the revenue values.
In the following display, total sales values that are greater than $130,000 are bold.

**Display 21.1** Total Sales Values That Are Greater Than $130,000 Are Highlighted

Graphs use shading as the highlighting method. In the following display, shoe product groups with revenues that are between $1 million and $2 million are highlighted.

**Display 21.2** Shoes with Revenues That Are between One and Two Million Dollars Are Highlighted

---

**Managing Conditional Highlighting for Table Values**

**Add Conditional Highlighting to Table Values**

For tables, measure or category data items can be used in conditional highlighting.
Some conditional highlighting rules have priority over other rules. The conditional highlighting rules that you define for measures have the highest priority, regardless of where those measures appear in the table. Conditional highlighting rules that you define using a category on a row have a higher priority than a rule for a category on a column. In a crosstabulation table, conditional highlighting rules that you define using category A will have a higher priority than those that you define using category B, if category A is inside category B.

The styles that you specify for colors and fonts are not merged among conditional highlighting rules. However, if you add highlighting using an image or text, then those conditions are merged if they are not specified in a conditional highlighting rule with a higher priority.

To specify conditional highlighting for values in a table, complete these steps:

1. Right-click in the table, and then select **Conditional Highlighting** to open the Conditional Highlighting dialog box.

   **Display 21.3  Conditional Highlighting Dialog Box**

   ![Conditional Highlighting Dialog Box](image)

2. Click **New**.

   Three tabs appear in the Conditional Highlighting dialog box: **Rule**, **Color and Font**, and **Image and Text**.

   **Display 21.4  Rule Tab in the Conditional Highlighting Dialog Box for a List Table Using Relational Data**

   ![Rule Tab](image)
3. On the **Rule** tab, complete these steps:
   a. Select a category or a measure in the **Data Item** field.
   b. Select the **Condition** that you want the selected data item to match.
      
      *Note:* When a category data item is selected, the available conditions are **Is equal to** and **Is not equal to**.
   c. In the **Value** field, type in a value or select a measure in the drop-down list. When you click **Select** for a table that uses multidimensional data, you can select the specific values that the rule applies to.
      
      If you selected **Is between** as the condition, then type a **Min value** and a **Max value**. If you selected **Is missing value** as the condition, then this field is unavailable.
      
      *Note:* If you are creating a condition for percentages, you must enter the conditional value as a decimal number. For example, if you want to filter for values above 50%, enter `.5` as the conditional value.
   d. For list tables, the **Rule assignment** option lets you specify either **Highlight individual cells** or **Highlight entire row**.
      
      For multidimensional tables, the **Rule assignment** option lets you specify which hierarchy level the rule will be applied to.

**Display 21.5 Rule Tab in the Conditional Highlighting Dialog Box for a Table Using Multidimensional Data**

You can specify one of the following:

- **All hierarchy levels**, which applies the rule to all hierarchy levels.
- **Selected hierarchy levels**, which applies the rule only to the hierarchy levels that you specify. Click **Select**. Select the specific hierarchy levels for the rule. Click **OK**.
4. (Optional) On the **Color and Font** tab, complete these steps to change the default settings:

   a. Select the **Font**, including the font size and font color, that you want to use to highlight values that meet the specified condition. By default, the values that meet the conditional highlighting rule appear in bold.

   b. Select the **Font style** that you want to use to highlight values that meet the specified condition.

5. (Optional) On the **Image and Text** tab, complete these steps:

   a. Select the **Highlight by adding an image or text** option.

   b. Indicate whether you want to add an **Image** or **Text** when the specified conditions are met.

   c. Specify a **Position** for the image or text. Indicate whether you want the image or text to appear to the right or left of each cell that contains a value that meets the condition or in place of the value.
d. If you are using an image, select the **Image** that you want to use to highlight values that meet the specified condition.

**Display 21.8  Image and Text Tab in the Conditional Highlighting Dialog Box for Tables with an Image Selected**

![Conditional Highlighting dialog box with image selected]

```
Rule | Color and Font | Image and Text
---|---|---
● Highlight by adding an image or text
Add: | | □ Image
Position: | □ To right of cell value
Image: |
```

```
Preview
[example]
```

6. To finish creating or editing the conditional highlighting rule, click **OK**. The **Rules list** appears in the Conditional Highlighting dialog box.

e. If you are using text to highlight values, type the text into the **Text** field. Then select the **Font** and **Font style** information.

In the following display, an asterisk (*) is used as the text.

**Display 21.9  Image and Text Tab in the Conditional Highlighting Dialog Box for Tables with Text Specified**

```
Rule | Color and Font | Image and Text
---|---|---
● Highlight by adding an image or text
Add: | | □ Image
Position: | □ To right of cell value
Text: |
Font: | Times New Roman | 14 | B
```

```
Preview
[example] *
```

Display 21.10  Conditional Highlighting Dialog Box with Multiple Rules Displayed

7. To close the Conditional Highlighting dialog box, click OK.

Remove Conditional Highlighting from Table Values

To remove conditional highlighting from table values, complete these steps:

1. Right-click in the table, and then select Conditional Highlighting to open the Conditional Highlighting dialog box.
2. In the Rules list, select a rule.
3. Click Delete.
4. In the confirmation message box that appears, click OK to delete the rule.
5. Click OK.

Managing Conditional Highlighting for Graph Values

Add Conditional Highlighting to Graph Values

In graphs, conditional highlighting is measure-based. The graph must include at least one measure that can be used in the condition.

To specify conditional highlighting for values in a graph, complete these steps:

1. Right-click in the graph, and then select Conditional Highlighting to open the Conditional Highlighting dialog box.
2. Select a Measure.
3. Select the Condition that you want the selected measure to match.
4. In the Value field, type in a value or select a measure in the drop-down list. If you selected Is between as the condition, then type a Min value and a Max value. If you selected Is missing value as the condition, then this field is unavailable.
Note: If you are creating a condition for percentages, you must enter the conditional value as a decimal number. For example, if you want to filter for values above 50%, enter .5 as the conditional value.

Display 21.11  Conditional Highlighting for Values between a Minimum and a Maximum Value

5. For graphs, the Rule assignment option lets you specify which hierarchy level the rule will be applied to. You can specify one of the following:
   - All hierarchy levels, which applies the rule to all hierarchy levels.
   - Selected hierarchy levels, which applies the rule only to the hierarchy levels that you specify. Click Select. Select the specific hierarchy levels for the rule. Click OK.

Display 21.12  Conditional Highlighting Dialog Box for Select Levels

6. Click OK.

Remove Conditional Highlighting from Graph Values

To remove conditional highlighting from graph values, complete these steps:

1. Right-click in the graph, and then select Conditional Highlighting to open the Conditional Highlighting dialog box.
2. Click Clear.
3. Click OK.
Display Data Source, Data Item, and Filter Details for a Table or a Graph

To display information about a table or a graph, right-click inside the table or graph, and then select Data Source Details. The Data Source Details dialog box contains the following information about the selected object:

**Data source**

This section contains the following information:

**Name**

This field displays the name of the data source that is being used for this table or graph.

**Type**

This field displays the type of data source (Relational or Multidimensional). The data source type determines which options are available for building and viewing reports.

**Description**

This field displays a description of the data source, if one is available.

**Applied filters**

This field displays the following information:

- The filters that are applied to the current report section. These filters affect all of the tables and graphs in the section that you are viewing.
- The filters and rankings that are applied to this table or graph only.
- The expression that specifies how the filters and rankings are applied.

*Note:* For synchronized objects, the Applied filters text refers to the filters for the object and not the synchronized query.
Data item, Physical name, Description/expression
For each data item in this table or graph, this box lists the name of the data item as it appears in the data source that was prepared by the data source administrator, the name of the data item in the original data source, and either a description (standard data items) or an expression (calculated data items).

Display 22.1  Data Source Details Dialog Box

---

View the Detail Data Behind the Values in a Crosstabulation Table
Multidimensional data sources sometimes enable users to see the detail data behind a specific aggregated value or behind the aggregated values in an entire row or column. The data is displayed in a separate dialog box. You can export the data to a Microsoft Excel spreadsheet. Your data administrator determines whether detail data is available. If detail data is available, the aggregated values in the crosstabulation table will be underlined if they are linked. If report linking and drill-to-detail are enabled, then the aggregated values that are linked will not be underlined. You can right-click a cell value and then select either Click to view linked content or View Detail.

To view detail data, complete these steps:
1. Perform one of these tasks to open the View Detail dialog box:
   • To see the detail data behind an aggregated value in the crosstabulation table, click the value (which is underlined).
   • To see the detail data behind a row or a column in the crosstabulation table, right-click the row or column heading in the innermost level of the innermost hierarchy in the row or column, and then select Show Detail Data.
Display 22.2  Show Detail Data Option for the Sales Cost Column

Note: If report linking has been enabled for the values in the crosstabulation table, then when you click on a value, you are prompted either to view detail data or to follow the report link.

Display 22.3  View Detail Dialog Box

2. (Optional) For Column headers, select either Show column names or Show column labels.

3. (Optional) To export the data into a Microsoft Excel spreadsheet or to a Microsoft Word document, click Export to open the Export dialog box. To export the data, click OK. When prompted, choose either to open the file or to save it. For more information about exporting, see “Exporting Reports and Report Data” on page 299.

4. To exit the View Detail dialog box, click Close Window.
Display Field Names, Values, and Measure Information for a Region in a Geographical Map

To view information about a selected region on a geographical map, complete these steps:

1. On the geographical map toolbar, click and then click a geographical map region.

2. In the Region Information dialog box, view the details.

   Display 22.4 Region Information for a Geographical Map

   ![Region Information](image)

   In addition to details about the underlying data, such as field names and values, this dialog box displays the name and aggregated value for the measure currently being used.

3. Click Close.
Part 6

Managing Reports

Chapter 23  
**Maintaining and Organizing Reports** ............................................. 241

Chapter 24  
**Maintaining Multi-Section Reports** ............................................. 261

Chapter 25  
**Sharing Reports** ................................................................. 265

Chapter 26  
**Linking Reports** ................................................................. 281

Chapter 27  
**Scheduling Reports** ............................................................. 291

Chapter 28  
**Printing and Exporting** ......................................................... 299
Chapter 23
Maintaining and Organizing Reports

Overview of Managing Reports ........................................... 242
Archiving Reports .......................................................... 243
   About Report Archiving ............................................. 243
   Archive a Report .................................................... 243
   View an Archived Copy of a Report .......................... 244
   Delete an Archived Copy of a Report ...................... 245
Copying Reports ........................................................... 246
   Copy Individual Reports ....................................... 246
   Copy Multiple Reports ....................................... 247
Creating Report Templates ................................................... 248
   Overview of Report Templates ............................... 248
   Save a Report as a Template ............................... 248
Deleting Reports and Templates ............................................ 249
   Delete Individual Reports .................................... 249
   Delete Multiple Reports .................................... 249
   Delete a Report Template ................................... 249
Modifying Report Properties .............................................. 250
Moving Reports ............................................................ 253
   Move Individual Reports .................................... 253
   Move Multiple Reports .................................... 253
Organizing Reports ....................................................... 254
   About Folders ................................................... 254
   Create a Folder .................................................. 254
   Rename a Folder ................................................ 255
   Deleting Folders ................................................ 255
Rename a Report ............................................................ 256
Updating Resources in a Report ............................................ 257
Working with Comments in a Report ....................................... 258
Overview of Managing Reports

The File Management window enables you to complete many tasks related to managing reports. To access the File Management window, select File → Manage Files. The following tasks can be performed only from the File Management window:

• access a list of the reports that you have scheduled and distributed.
• from the Scheduled and Distributed Reports dialog box, schedule and distribute reports. You can also delete scheduled or distributed reports.
• move, copy, and delete multiple selected reports.
• delete multiple selected report folders.
• schedule all reports in a selected folder.

Note: You must have advanced permissions to copy, move, or delete multiple reports or folders. Contact your system administrator about permissions.

Note: Scheduling features are not available if a scheduling server is not available or if you do not have authorization to schedule reports.

Depending on your role and capabilities, the File Management window also enables you to do the following tasks:

• search for files
• update resources in a report
• print reports
• export reports
• e-mail reports
• add comments to reports or folders

Display 23.1  File Management Window
Archiving Reports

About Report Archiving

Authorized users can specify that they want to maintain an archive for a manually refreshed report. Archived reports are saved as PDF output and can be opened from the Open dialog box or from the File Management window. Files are named by using the date that they were archived; for example, output that was saved on May 19, 2010, would be named 2010_05_19.pdf.

Only one copy of a report can be saved per day. If a report is saved multiple times in one day, then only the next-to-last saved report is used as that day's archived copy. The earliest archived copy is automatically removed when the user-specified number of archived copies has been saved.

Anyone authorized to view reports can view an archived copy of a report.

Note: Your role might enable you to save reports but not to archive reports.

Archive a Report

Note: Users who have the capability to schedule reports can also archive reports as they schedule them.

To maintain an archive of a specific report, complete these steps:

1. Display the report that you want to archive in either Edit mode or View mode.
2. Select File ➔ Save As to open the Save As dialog box.
3. In the Type drop-down list, select Data can be manually refreshed.
4. Select Retain previous instances of output not to exceed, and then type the number of archived reports that you want to maintain.

Note: If you have the capability to schedule reports and have already specified a number of reports to retain, then the number that you enter here will overwrite the number you previously specified.
5. Click Save.

6. When you are prompted to replace the existing report, click OK. (The existing report is saved as PDF output.)

**View an Archived Copy of a Report**

To view an archived copy of a report, complete these steps:

1. From the Welcome window or Edit mode, perform one of these tasks:
   - Select File ⇒ Open to open the Open dialog box.
   - Select File ⇒ Manage Files to open the File Management window.

2. Next to the name of the report that has the archived copy that you want to view, click in the Actions column, and then select Archived Output.

*Note:* Archived reports are identified by this icon: 📁.
3. In the Archived Output dialog box, select the archived copy that you want to view and then click View.

4. To close the Archived Output dialog box, click Close.

**Delete an Archived Copy of a Report**

To delete an archived copy of a report, complete these steps:

1. From the Welcome window or Edit mode, perform one of these tasks:
   - Select File → Open to open the Open dialog box.
Select File ➤ Manage Files to access the File Management window.

2. Next to the name of the report that has the archived copy that you want to delete, click in the Actions column, and then select Archived Output. 

   Note: Archived reports are identified by this icon: 📂.

3. In the Archived Output dialog box, select the archived copy that you want to delete and then click Remove.

4. In the confirmation message box that appears, click OK to delete the archived copy.

5. Click Close.

---

**Copying Reports**

**Copy Individual Reports**

To copy an individual report, complete these steps:

1. From the Welcome window, Edit mode, or View mode, perform one of these tasks:
   - Select File ➤ Open to open the Open dialog box.
   - Select File ➤ Manage Files to access the File Management window.

2. Navigate to the folder that contains the report that you want to copy.

3. Next to the name of the report that you want to copy, click in the Actions column, and then select Copy to open the Copy Report dialog box.

   ![Copy Report Dialog Box](image)

4. Select a folder location, either My folders (your private folder area) or another folder in the SAS Folder tree.

   If you copy a report to the same folder that contains the original report, then the copied report is renamed by prepending Copy of to the report name. For example, if you copy a report named Orion Star Sales Forecast, then the copied report is renamed Copy of Orion Star Sales Forecast.
If you copy a report to a different folder that already contains a report with the same name, then you are asked if you want to replace the existing report with the copied report.

*Note:* When you copy a report, the name cannot have more than 56 characters. Trailing characters are truncated.

*Note:* To create a new folder, click 📚.

5. Click OK.

6. If you used the Open dialog box, click Close.

### Copy Multiple Reports

*Note:* Only advanced users can copy multiple reports. If you have questions about your authorization, contact your system administrator.

To copy multiple reports, complete these steps:

1. From the Welcome window or Edit mode, select File ➔ Manage Files to access the File Management window.

2. Select the check box next to each report that you want to copy.

3. At the top of the check box column, click and then select Copy.

*Display 23.6 File Management Window with Copy Menu Item Selected*

4. Select a folder location, either My folders (your private folder area) or another folder in the SAS Folder tree.

   If you copy the reports to the same folder that contains the original reports, then the copied reports are renamed by prepending Copy of to the report name. For example, if you copy a report named Orion Star Sales Forecast, then the copied report is renamed Copy of Orion Star Sales Forecast.

   If you copy the reports to a different folder that already contains reports with the same names, then you are asked if you want to replace the existing reports with the copied reports. If some of the reports have the same name but some do not, you can click Cancel in the message box to cancel copying the reports with the same name. Reports that do not have conflicting names are still copied.

   *Note:* To create a new folder, click 📚.

5. Click OK.
Creating Report Templates

Overview of Report Templates

You can save report templates that contain one or more sections. Report templates can contain the following content:

- tables, graphs, images, text, and their last saved properties
- links from images and text to Web sites and reports
- a header and a footer
- stored process objects (without the stored process selected)
- positioning information

SAS Web Report Studio comes with a selection of templates. You can also create your own templates that you can share or keep private.

This section explains how to save a template, delete and edit your own templates or shared templates that are not saved as read-only, and share or hide templates.

Note: Only authorized users can save templates. If you have questions about your authorization, contact your system administrator.

Save a Report as a Template

To save a report template that is based on the currently active report, complete these steps:

1. In Edit or View mode, select File → Save As to open the Save As dialog box.

2. Type the Name that you want to give to this new template. For more information about valid names, see “Naming Reports, Folders, and Templates” on page 309.

3. For the Type of report, select Template.

   Note: If you are viewing a manually refreshed report, then refresh the data to make the Template report type available.

4. Select a Location, either Shared templates or My templates (your private folder area).

   Report templates in the Shared templates folder can be used by other report users, and reports in the My templates folder can be used only by you and your system administrator.

5. (Optional) Type a template Description. The description is displayed in the Select a Template dialog box. You cannot use these characters: < > & #

6. (Optional) Select the Automatically replace if file already exists option if you want to replace an existing template without being prompted to confirm this action.

7. (Optional) Select the Make read-only option to prevent other users from deleting or modifying this template. (You will still be able to perform these actions on your own template.)

8. Click OK.
If you saved the template from View mode, the currently displayed report is replaced by the template. Because the template does not include any data selections, you might see invalid graph, table, and map icons, depending on which objects the report contained. At this point, you can click **Edit** to add data and create a new report based on the template that you created, or you can open another report.

---

### Deleting Reports and Templates

#### Delete Individual Reports

To delete an individual report, complete these steps:

1. From the Welcome window or Edit or View mode, perform one of these tasks:
   - Select **File** ⇒ **Open** to open the Open dialog box.
   - Select **File** ⇒ **Manage Files** to access the File Management window.

2. Navigate to the folder that contains the report. Next to the name of the report that you want to delete, click in the **Actions** column, and then select **Delete**.

3. In the confirmation message box that appears, click **OK** to delete the report.

4. If you used the Open dialog box, click **Close**.

*Note:* You cannot delete a report that is currently open.

#### Delete Multiple Reports

*Note:* Only advanced users can delete multiple reports. If you have questions about your authorization, contact your system administrator.

To delete multiple reports, complete these steps:

1. From the Welcome window or Edit or View mode, select **File** ⇒ **Manage Files** to access the File Management window.

2. Navigate to the folder that contains the report. Select the check box next to each report that you want to delete.

3. At the top of the check box column, click and then select **Delete**.

4. In the confirmation message box that appears, click **OK** to delete the reports.

*Note:* You cannot delete a report that is currently open.

#### Delete a Report Template

To delete one of your own report templates or a shared template that is not saved as read-only, complete these steps:

1. Perform one of these tasks to open the Select a Template dialog box:
   - From the Welcome window or Edit or View mode, select **File** ⇒ **New** ⇒ **New using Template**.
   - In Edit mode, select **Edit** ⇒ **Apply a template**.
2. Depending on which type of template you want to delete, select either the **Shared templates** tab or the **My templates** tab.

3. Select a template.

4. Click **Delete**.

5. In the confirmation message box that appears, click **OK**.

6. To close the Select a Template dialog box, click **Cancel**.

---

### Modifying Report Properties

To set or change the report style, filter display, keywords, and description for a viewed report, complete these steps:

1. In Edit or View mode, select **File ➪ Properties** to open the **Report Properties** dialog box.

2. If you are authorized to save changes to the report, on the **General** tab, set or modify keywords and the description. Separate multiple keywords with commas. Keywords cannot use these characters: `< > & # / \`

   For information about valid keywords, see “Naming Reports, Folders, and Templates” on page 309.

   **Display 23.7** **General Tab of the Report Properties Dialog Box**

   ![Image of Report Properties dialog box](image)

3. (Optional) On the **Format** tab, perform any of these tasks:

   **Note:** The **Format** tab is not available if the report needs to be refreshed.

   **Note:** Although only authorized users can save the changes, all users can make changes on the **Format** tab for viewing purposes.

   - Select one of four standard styles to use for the current report: **Plateau**, **Meadow**, **Seaside**, or **Festival**. Styles affect the color and font style used in graphs, tables,
and geographical maps. Style changes do not affect text formatted in group breaks, headers, and footers.

*Note:* Existing reports might use a **Custom** style. If you change the **Custom** style to one of the SAS Web Report Studio styles, then you cannot reset the report to the **Custom** style.

- Select a **Graph skin** to use for the current report. The following options are available: **None**, **Pressed**, or **Sheen**. **Pressed** is the default for new reports and **None** is the default for legacy reports.

  *Note:* A graph skin cannot be applied to the scatter plot, the bubble plot, the tile chart, or the geographic map.

- Specify whether you want to use the report style colors or customized colors. The report style colors are the default colors for the report. When the graph is rendered, the color that you selected is used for the bars, lines, and so on.

  For the **Use customized colors** option, select a color square to access the color palette. Then select a color. You can customize a color using the **Color value** field. For more information, see “Customizing Colors” on page 310. The color that you select fills the color square.

- Specify whether you want to display applied filter information with the report. You can also specify the text color for the filter text. The filter information is included in printed reports.

  Select **Display filter information** to show all of the filters that are active for a given report. Clear the **Display filter information** check box if you do not want the text to appear. The **Applied filters** field in the report displays the following information:

  - The filters that are applied to the current report section. These filters affect all of the tables and graphs in the section that you are viewing.
  - The filters and rankings that are applied to this table or graph only.
  - The expression that specifies how the filters and rankings are applied.

  The applied filter information displays above each table or graph that appears in a section. If there are no filters for a given table or graph or the section as a whole, the following text appears above the table or graph: **Applied filters: None**. The filter information is included in the printed reports.

  If the **Display filter information** check box is selected, then you can specify the color for the filter text in the report. Select the **Text** drop-down list to open the color palette. Then select a color for the filter text. You can customize a color using the **Color value** field. For more information, see “Customizing Colors” on page 310.
4. Click **OK**.

Here is an example of a bar chart that uses the **Plateau** report style and the **Pressed** graph skin.

*Display 23.9  A Bar Chart Using the Plateau Report Style and the Pressed Graph Skin*
Here is an example of the same bar chart that uses the **Plateau** report style without a graph skin.

**Display 23.10  A Bar Chart Using the Plateau Report Style Without a Graph Skin**

---

### Moving Reports

**Move Individual Reports**

To move an individual report, complete these steps:

1. From the Welcome window or Edit or View mode, perform one of these tasks:
   - Select **File** ⇒ **Open** to open the Open dialog box.
   - Select **File** ⇒ **Manage Files** to access the File Management window.

2. Next to the name of the report that you want to move, click in the **Actions** column, and then select **Move**.

3. In the Move Report dialog box, select a folder location, either **My folders** (your private folder area) or another folder in the **SAS Folder** tree.

   If you move a report to a folder that already contains a report with the same name, then you are asked if you want to replace the existing report with the moved report.

   **Note:** To create a new folder, click 

4. Click **OK**.

5. If you used the Open dialog box, click **Close**.

   **Note:** You cannot move a report that is currently open.

---

**Move Multiple Reports**

**Note:** Only advanced users can move multiple reports. If you have questions about your authorization, contact your system administrator.
To move multiple reports, complete these steps:

1. From the Welcome window or Edit or View mode, select **File ⇒ Manage Files** to access the File Management window.

2. Select the check box next to each report that you want to move.

3. At the top of the check box column, click ![check box](image) and then select **Move**.

4. In the Move Report dialog box, select a folder location, either **My folders** (your private folder area) or another folder in the **SAS Folder** tree.

   If you moved reports to a folder that already contains reports with the same names, then you are asked if you want to replace the existing reports with the moved reports.

   If some of the reports have the same name but some do not, you can click **Cancel** in the message box to cancel moving the reports with the same names. Reports that do not have conflicting names are still moved.

   *Note:* To create a new folder, click ![folder](image).

5. Click **OK**.

   *Note:* You cannot move a report that is currently open.

---

**Organizing Reports**

**About Folders**

You can use folders to organize reports. For example, you could create a folder to contain sales reports for a specific year and then create subfolders to hold reports for specific regions.

There are two types of folders: personal folders and shared folders. Personal folders are in the **My Folder** area. Your system administrator creates a secure folder structure for SAS Web Report Studio users who create new folders. For more information, see “Overview of Shared Locations” on page 265.

**Display 23.11**  A Folder Structure to Contain Orion Sales Reports by Year

**Create a Folder**

You can create a new folder when you copy a report, move a report, or save a report. You can also create a new folder by clicking ![folder](image) in the Open dialog box or in the File Management window.
**Rename a Folder**

To rename a folder, complete these steps:

1. From the Welcome window or Edit or View mode, perform one of these tasks:
   - Select File ➤ Open to open the Open dialog box.
   - Select File ➤ Manage Files to access the File Management window.
2. Next to the name of the folder that you want to rename, click in the Actions column, and then select Rename.
3. In the Rename Folder dialog box, type the new name. For more information about valid names, see “Naming Reports, Folders, and Templates” on page 309.

![Rename Folder Dialog Box](image)

4. Click OK.
5. If you used the Open dialog box, click Close.

*Note:* You cannot rename a folder that contains a report that is currently open.

**Deleting Folders**

**Delete Individual Folders**

To delete an individual folder, complete these steps:

1. From the Welcome window or Edit or View mode, perform one of these tasks:
   - Select File ➤ Open to open the Open dialog box.
   - Select File ➤ Manage Files to access the File Management window.
2. Next to the name of the folder that you want to delete, click in the Actions column, and then select Delete.
3. In the confirmation message box that appears, click OK to delete the folder.

![Delete Folder Confirmation Message Box](image)

4. If you used the Open dialog box, click Close.
Note: You cannot delete a folder that contains a report that is currently open.

**Delete Multiple Folders**

Note: Only advanced users can delete multiple reports. If you have questions about your authorization, contact your system administrator.

To delete multiple folders, complete these steps in the File Management window:

1. From the Welcome window or Edit or View mode, select **File ➔ Manage Files** to access the File Management window.

2. Select the check box next to each folder that you want to delete.

3. At the top of the check box column, click ![check box]](image) and then select **Delete**.

4. In the confirmation message box that appears, click **OK** to delete the folders.

Note: You cannot delete a folder that contains a report that is currently open.

---

**Rename a Report**

To rename a report, complete these steps:

1. From the Welcome window or Edit or View mode, perform one of these tasks:
   - Select **File ➔ Open** to open the Open dialog box.
   - Select **File ➔ Manage Files** to access the File Management window.

2. Next to the name of the report that you want to rename, click ![actions]](image) in the **Actions** column, and then select **Rename**.

3. In the Rename Report dialog box, type the new name of the report.

   ![Rename Report Dialog Box](image)

   For more information about valid names, see “Naming Reports, Folders, and Templates” on page 309.

4. Click **OK**.

5. If you used the Open dialog box, click **Close**.

Note: You cannot rename a report that is currently open.
Updating Resources in a Report

There are times when you might need to replace resources in a report. For example, if an information map referenced in a report has been moved, renamed, or both, then you will need to update resource information in your report.

Note: You must have advanced permissions to update resource information in reports. Contact your system administrator about permissions.

To update resource information in a report, complete these steps:

1. From the Welcome window or Edit mode, select **File** ➔ **Manage Files** to access the File Management window.
2. Next to the name of the report that you want to update, click ![ ] in the **Actions** column, and then select **Update resources**.
3. In the Update Resources dialog box, if message text saying **not found** appears beside the original information map, then the information map resources need to be updated. Click **Browse** to the right of the **Updated information map** label to open the Select Information Map dialog box.

   **CAUTION:**
   Do not use the **Browse** button to choose a different information map. Only use the **Browse** button to locate the original information map that has been moved or renamed.

   **Display 23.15 Update Resources Dialog Box**

4. Navigate through the tree structure and select the information map that was renamed or moved.
5. Click **OK**. The information map that you selected appears under the **Updated information map** label.
6. Click **OK**.
Working with Comments in a Report

There might be times when you want to add comments to a report that a co-worker has created. For example, you might want to suggest that some information be added to the report. Or, you might want to add comments to a report that you have created.

Note: Comments are not exported with a report.

To add a comment to a report, complete these steps:

1. In Edit or View mode, select File ▶ Comments.
2. In the SAS Comment Manager window, click New Comment.
3. Type a Subject and a Message.
4. (Optional) Click Attach Files to include files with the comment.

   Display 23.16 Compose a New Comment Dialog Box

5. Click OK.
6. Click Done to return to SAS Web Report Studio.

When a comment (or comments) have been added to a report, you will see the word comment in the Keywords column in the File Management window.
When you are in Edit or View mode, comments are indicated on the toolbar by this icon: 📔.

To respond to an existing comment in a report, complete these steps:

1. In Edit or View mode, select **File › Comments**.
2. In the **SAS Comment Manager** window, click **Reply**.
3. Type a **Subject** and a **Message**.
4. (Optional) Click **Attach Files** to include files with the comment.

5. Click **OK**.
6. Click **Done** to return to SAS Web Report Studio.

For information about appending comments to a printed report, see “**Print a Report**” on page 305.
Overview of Report Sections

Any report can have multiple sections. Multiple sections can be used to present different views of the data to the person who views the report. Each section has one information map data source. However, it can use data from many different sources by including multiple stored processes. There is no limit to the number of sections that can be included in a report. Once you have created sections in a report, you can choose to independently view, link to, or distribute a specific report section.

You can use a group break to divide report sections by distinct category or hierarchy level values when you are using a relational or multidimensional data source. When you set a group break, it applies to all elements in the section. For more information about group breaks, see Chapter 14, “Grouping Query Results,” on page 125.

Add a Section to a Report

You can add sections to any type of report, including reports that were created in another SAS reporting application. To add a new section to a report, complete these steps:

1. In the Table of Contents panel in Edit mode, select Options ⇒ Insert a New Section or select Insert ⇒ New Section to open the New Section dialog box.
2. In the New section name field, type a name for the section.
3. Under Data, select one of these options:
   - Get new data
     Select this option if you want the data for the new section to come from a different data source. For more information, see Chapter 12, “Defining Queries”.
Copy data from
Select this option if you want the new section to use the same data as another section in the report. Select the existing section from the drop-down list.

4. Under Header, select Blank if you do not want the new section to contain a header. To use the same header as an existing section, select Copy header from and select the section from the drop-down list.

5. Under Footer, select Blank if you do not want the new section to contain a footer. To use the same footer as an existing section, select Copy footer from and select the section from the drop-down list.

Display 24.1 New Section Dialog Box

6. Click OK.

Rename a Report Section

To rename a report section, complete these steps:

1. In the Table of Contents panel in Edit mode, select the section that you want to rename.

2. Select Options ➪ Rename Section.

3. In the Rename Section dialog box, type the new name.

Display 24.2 Rename Section Dialog Box

4. Click OK.
Copy a Report Section

SAS Web Report Studio enables authorized users to save the current view of one or more reports within a section. This is helpful for ad hoc analysis. For example, say that you want to save a view of the data as you filter and drill. As you explore the data source, you discover a potential problem. You can save this view as part of the same report and e-mail it to your co-workers to discuss.

When you copy a section, everything in the section is copied to a new section. However, if the section contains a stored process that has been run, then the new section will contain only a reference to the stored process as it appears in the report definition. If a section contains embedded data (for example, a report that is saved as a manually refreshed report or a scheduled report that has already run), then the section cannot be copied.

Note: You cannot copy sections that contain externally created content, such as section content created in SAS Enterprise Guide or generated from SAS Output Delivery System (ODS).

To copy an existing report section, complete these steps:

1. To open the Copy Section dialog box, perform one of these tasks:
   - In Edit mode, select Edit ⇒ Sections ⇒ Copy this Section or in the Table of Contents panel, select Options ⇒ Copy Section.
   - In View mode, in the Table of Contents panel, select Options ⇒ Copy Section or select Edit ⇒ Sections ⇒ Copy this Section.

   Note: The Copy Section option is not available for manually refreshed reports in View mode.

2. In the Copy Section dialog box, specify a Section name. Then specify which section it should come Before or After.

   Display 24.3 Copy Section Dialog Box

3. Click OK.
Reorder Report Sections

To change the order in which the report sections appear, complete these steps:

1. In the Table of Contents panel in Edit mode, select Options ➔ Reorder Sections.
2. In the Reorder Sections dialog box, move the sections.

Display 24.4  Reorder Sections Dialog Box

3. Click OK.

Delete a Section from a Report

To delete a section from a report, complete these steps:

1. In the Table of Contents panel in Edit mode, select the section that you want to delete.
2. Select Options ➔ Delete Section.

   Note: The Delete option is not available if the report has only one section.
3. In the confirmation message box that appears, click OK to delete the section.
Overview of Shared Locations

In general, reports in folders in the SAS Folder tree, except My Folder, can be viewed by other report users. Your system administrator can also create subfolders that are restricted to a specific group of users. For example, the administrator might create a subfolder named Human Resources that is restricted to human resources employees. For more information, see “Save a Report” on page 59.

Starting with the second maintenance release of SAS Web Report Studio 4.31, your administrator can set a property for a Company preferred folder. If the property is set, then this folder is the default for all users.

Reports in the My Folder area can be viewed only by you and your system administrator. The name of your personal folder is derived from your user ID and is visible only to your system administrator.

When you save, copy, or move a report, you can place the report either in a shared folder or in your personal folder.

E-mail a URL for a Report Definition Snapshot

Starting with the second maintenance release of SAS Web Report Studio 4.31, you can open a report, make modifications, and e-mail the URL for the report definition snapshot. The report definition snapshot is a customized report that is created from an
original SAS Web Report Studio report and then e-mailed to a recipient. Group break information is included in a snapshot.

Note: The e-mail option is available only for saved reports.

The report definition snapshot is always associated with the original report, but the original report remains unchanged when the snapshot is created with modified content and e-mailed to a recipient. If the original report is deleted, any snapshots that are associated with that original report are automatically deleted. This feature is useful when you want to create a custom report (without altering the original report) and share the customized report with other users by e-mailing them the URL for the snapshot.

In View mode, you can select File ➤ E-mail. The default e-mail application (for example, Microsoft Outlook) opens, and the generated URL for the report is automatically copied into an e-mail message. In this case, the section that you are currently viewing appears when the recipient clicks the link in the e-mail message. If prompt values exist, they are set to the values that you are using when you are viewing the snapshot. You will not see the Define Section and Prompt Values dialog box, unless a prompt has an unassigned value.

Here is an example of an e-mail message with the URL for a snapshot.

Display 25.1 An E-Mail Message with a URL for a Snapshot

Note: System administrators can set a system option, which specifies that standard text appears in e-mail messages with a generated URL for a snapshot. In this example, the standard text appears both before and after the generated URL.


When the recipient clicks on the URL in the e-mail, SAS Web Report Studio opens in their browser. If the recipient is not logged on, then they are prompted to enter their user ID and password. After logging on, the snapshot appears. The name of the report definition snapshot is displayed in this format:

Sales Report for Second Quarter 2012/Emailed/120724_131850
The filename includes a timestamp in the `YYMMDD_HHMMSS` format (which is `YearYearMonthMonthDayDay_HourHourMinuteMinuteSecondSecond`).

The snapshot filename also appears in the Welcome window and in the list of recent files when you select **File** ⇒ **Open Recent** for both the user who sent the snapshot and the recipient after they clicked on the link in the e-mail message.

Here is an example of how snapshots appear in the Welcome window.

![Display 25.2 Welcome Window with Snapshot Filenames](image)

---

**E-mail a URL for a Report Using the File Management Window**

Beginning with the second maintenance release of SAS Web Report Studio 4.31, the preferred way to e-mail a URL is using a report definition snapshot. For more information, see “E-mail a URL for a Report Definition Snapshot” on page 265. However, sending an e-mail from the File Management window is still supported.

*Note:* The e-mail option is available only for saved reports.

To e-mail the URL for a report using the File Management window, complete these steps:

1. In View mode, select **File** ⇒ **Manage Files** to access the File Management window.
2. Next to the name of the report that you want to e-mail, click in the Actions column, and then select E-mail.

If the report does not contain multiple sections or prompts, then the default e-mail application (for example, Microsoft Outlook) opens. The generated URL for the report is automatically copied into an e-mail message.

**Display 25.3** An E-Mail Message with the Generated URL for a Report

System administrators can set a system option, which specifies that standard text appears in e-mail messages with a generated URL for a report. In this example, standard text appears both before and after the generated URL.

**Display 25.4** An E-Mail Message with Standard Text

If the report has multiple sections or prompts, then instead of the default e-mail application, a dialog box appears. You can select a section, specify prompt values, or both. Complete these additional steps:

a. In the Define Section and Prompt Values dialog box, complete either of these tasks:
   - For a report that has multiple sections, select a section from the Open to section drop-down list. This is the section of the report that appears when the user clicks the link.
   - For a report with prompts, the prompt values are available for you to select. There will be scroll bars for multiple prompts. You can scroll to answer more prompts.
b. Click **E-mail Report**. The default e-mail application (for example, Microsoft Outlook) opens, and the generated URL for the report is automatically copied into an e-mail message.

If the URL with parameters, section information, or both is too long to send, then an error message displays. You can download a shortcut to a file that can be used to open the report.

*Display 25.5  Error Message If the URL Is Too Long*

You can either attach the downloaded file to an e-mail message or save the shortcut file to disk and then send a link to the shortcut. If you click **OK** in the error message, a File Download dialog box appears. Click **Save** to save the files to disk. The prefix of `OPEN_` is added to the filename. The file type is HTML. You can attach this file to an e-mail message.

3. Send the e-mail message.

---

**Publish a Report to Publication Channels**

A **publication channel** is an information repository that has been established by using the SAS Publishing Framework. It can be used to publish information to users and applications. (An administrator creates the publication channels.) If you publish your report to one or more publication channels, then authorized users and applications can access your report by subscribing to the channel.

In SAS Web Report Studio, you can control the life cycle of a published report. You can specify that a report be deleted from publication channels after a certain number of days. You can set the report's expiration date either in the Save As dialog box, in the Schedule Report Wizard (Step 1), or in the Recipients and Distribution Rules dialog box. For more information about the Schedule Report Wizard, see “Schedule a Report, Stored Process, or Folder for the First Time” on page 292. For information about the Recipients and Distribution Rules dialog box, see “Distribute a Report for the First Time” on page 271.

To publish a report to one or more publication channels (if they are available), complete these steps:

1. Select **File ➜ Save As** to open the Save As dialog box.

2. Type the **Name** that you want to give to this new report. Names cannot use these characters: `\ / : * ? " < > | @ # &`

   For more information about valid names, see “Naming Reports, Folders, and Templates” on page 309.

3. For the **Type** of report, select **Static report (.pdf format)**.

4. Select the **Publication Channel** to which you want to publish the report.

   **Note:** The **Publication Channel** settings are available only when your system administrator has defined publication channels and you set the report type to **Static report (.pdf format)**.
5. (Optional) Enter a number in the **Days until expiration** field. The default is 90 days. The number that you entered will be saved with your user profile. It will be filled in automatically the next time you open the **Save As** dialog box.

6. (Optional) Type a report **Description**. You cannot use these characters: `< > & #

7. (Optional) Type **Keywords**. Separate multiple keywords with a comma. Keywords cannot use these characters: `< > & / 

For information about valid keywords, see “Naming Reports, Folders, and Templates” on page 309.

**Display 25.6  How the Save As Dialog Box Appears with a Publication Channel Specified**

8. Click **Save**.

---

**Distributing Reports**

**About Distributing Reports**

The Distribute Report Wizard enables you to distribute reports by using e-mail with a PDF attachment or as embedded HTML. Reports can be distributed multiple times. Reports with group breaks can be distributed to targeted recipients based on the breaks. For example, you have a sales report with group breaks on regions. Each sales manager in the recipient list could receive information about his or her respective region only. A recipient list contains the e-mail addresses that you want to use for distributing a report.

**Note:** Only advanced users can distribute reports or manage recipient lists. If you have questions about your authorization, contact your system administrator.

The distributed output is external only; it is not saved to the report repository.
To distribute a report, a scheduling server must be available and you must have the authorization to distribute reports. If you have the capability to distribute any report, then you will see the distributions that you have created, as well as those created by other employees at your company. For more information about authorization and capabilities, contact your system administrator.

Prepare for Distribution

For information about preparing for report distribution, see the SAS Web Report Studio information in the **SAS Intelligence Platform: Web Application Administration Guide**.

Distribute a Report for the First Time

If a report does not have any distributions associated with it, then the first page of the Distribute Report Wizard lets you define the execution time, date, and recurrence. However, if one or more distribution plans are associated with a report, then the first page of the Distribute Report Wizard lets you choose a distribution. For more information, see “Edit or Delete a Distribution Using the Distribute Report Wizard” on page 278.

*Note:* You cannot prepare for distribution and distribute a report during the same report distribution process.

Follow these steps to distribute a report that has prompts but no distribution plans associated with it. The Distribute Report Wizard has only three steps when there are no prompts in the report.

1. To launch the Distribute Report Wizard, perform one of these tasks:
   - When a report is displayed in View mode, select **File ➔ Distribute**.
   - In the File Management window, next to the name of the report that you want to distribute, click ![Actions](image) in the **Actions** column, and then select **Distribute**.

   The first wizard page appears.

   *Note:* You cannot distribute a stored process.

2. Specify the interval for running the report.

   The rest of the information that you must provide depends on your selection. If you select **Now**, then you do not need to select any other options.

3. For any **Run report** option other than **Now**, specify the time that you want to run the report. You can also specify the starting and ending (if applicable) date range for the distribution.
4. Click **Next** to go to the next wizard page.

   *Note:* If the report has prompts that are not optional, then you must specify prompt values before exiting.

5. If the report has prompts, a wizard page displays those prompts.

6. After you enter the required prompt values, click **Next** to go to the next wizard page.

7. Specify whether you want to distribute the report as a PDF attachment or as embedded HTML.

8. (Optional) Enter text for the subject line of the e-mail.
9. Enter the **Sender e-mail** address. If your e-mail address is stored in metadata, then this field is automatically filled in. If you type another e-mail address here, then the address is stored in the repository and filled in the next time you distribute a report.

10. (Optional) Enter a **Sender display name**. If your e-mail address is stored in metadata, then this field is automatically filled in. If you type another display name here, then it is stored in the repository and filled in the next time you distribute a report.

11. (Optional) For **Message**, enter text for an e-mail message to accompany the report.

**Display 25.9  Distribute Report Wizard: Specify Output and Recipient Rules**

12. If you want to change a currently selected recipient list, the currently set group break division, or the section that a report is distributed on, then click **Recipients and Distribution Rules**.

   **Note:** If there is a recipient list already selected, the list name appears next to the **Recipients and Distribution Rules** button.

Complete these steps in the Recipients and Distribution Rules dialog box:

a. Select a recipient list. The contents of the list are displayed beneath the selection box. (Recipient lists are created by your system administrator.)
b. If the report has more than one section, select the section of the report that contains the group break information that you want to distribute. You can select the Include all sections check box to distribute all sections.

c. Either clear the Group break option, or select the option and choose a group break from the drop-down list. This option only appears if you selected a section that contains group breaks.

d. If you selected the Group break option, then assign each available group break to a column in the recipient list. The number of group breaks that are available depends on which group break level you selected in Step 12c. For example, if you selected the third group break level in Step 12c, then three group break levels are available to assign to columns. If you selected the first group break level, then only that level is available to assign to a column.
Display 25.11  Recipients and Distribution Rules Dialog Box with Group Break

Note: The associations between group breaks in the report and columns in the recipient list should make sense. For example, it makes sense to assign a Product Category group break to a Product Category column in the recipient list.

e. Click **OK** to return to the wizard page.

**Note:** If you are a system administrator, then the Recipients and Distribution Rules dialog box also contains a icon that opens the New Recipient List dialog box where you can create a recipient list based on the current report. The icon opens the Edit Recipient dialog box where you can edit the e-mail addresses and publication channel for a recipient list. The icon removes a recipient list. For more information about creating and removing recipient lists, see the SAS Web Report Studio information in *SAS Intelligence Platform: Web Application Administration Guide*.

13. Click **Next** to go to the next wizard page, or click **Finish**.

If you click **Next**, the summary page appears. The summary page might contain the following information, depending on your selections on the previous wizard pages:

- name of the report
- time (or times) that the report is scheduled to run
- any prompt values
- report section that contains the group break that you are using to divide the report
- group break that you are dividing the report on
- targeted recipient list
14. (Optional) Perform one or more of these tasks:
   
   • Send a copy of the distributed report to the **Sender e-mail** address that you selected on the previous wizard page.
   
   • Test your distribution settings. You can send the results to the **Sender e-mail** address, and you can view the results when the test is complete. Click **Run Test** to run the test.

   *Note:* To make changes to your selections on previous wizard pages, click **Back**.

15. Click **Finish** to save your settings and exit the wizard.

**View a List of Distributed Reports**

To view a list of the reports that you have distributed, complete these steps:

1. From the Welcome window or Edit mode, select **File ➤ Manage Files** to access the File Management window.

2. Open the Scheduled and Distributed Reports dialog box. The name of the link that opens the dialog box depends on your role:

   • If you do not have permission to schedule or distribute reports, you will not see a link.
   
   • If you can schedule but not distribute reports, then click **View my scheduled reports**.
   
   • If you can both schedule and distribute reports, then click **View my scheduled and distributed reports**.

The Scheduled and Distributed Reports dialog box contains the following information:
Last updated
This field displays the date that the list of scheduled and distributed reports was last updated.

Refresh lists
Select this option to update the list of reports.

Schedule, Actions, Schedule Definition
This field displays the name of each scheduled and distributed report and the time that each report is scheduled to run or be distributed. It also displays the prompt values if the report is prompted.

To see a menu of options for editing and deleting a specific distributed report, click in the Actions column.

Occurrence, Status, Date/Time
This field displays the status of the last three occurrences of each scheduled and distributed report, either Failed, Executed, or Running. The Date/Time column displays the date and time for each successful or failed execution. The number of occurrences for each report listed, not including occurrences with the status of Running, depends on the number specified in the Maximum number of history occurrences to display field.

If the status is Failed, take these actions to try to resolve the problem:

• rerun the schedule or distribution
• delete the schedule or distribution, re-create it, and then run it again
• contact your system administrator

Maximum number of history occurrences to display
This field specifies the maximum number of history occurrences that you want to retrieve. After you change the value, click Refresh lists to make sure the value takes effect. The value that you enter is stored with your user profile, so it will appear the next time the dialog box opens.

Note: The system limit for the value is 10. If the value is 0 (zero), then all history records are retrieved.

Note: The distributing features are not available if a scheduling server is not available or if you do not have authorization to distribute reports.
3. When you are finished viewing the information, click Close.

**Updating a Distribution Plan**

*Edit or Delete a Distribution Using the Distribute Report Wizard*

If there is at least one distribution associated with a report, then you can edit or delete the distribution using the Distribute Report Wizard.

**Note:** You cannot prepare for distribution and distribute a report during the same report distribution process.

To edit or delete a distribution for a report, complete these steps:

1. To launch the Distribute Report Wizard, perform one of these tasks:
   - When a report or stored process is displayed in View mode, select **File ➔ Distribute**.
   - In the File Management window, next to the name of the report that you want to distribute, click  in the **Actions** column, and then select **Distribute**.

The first wizard page appears.
Display 25.14  Distribute Wizard: Choose or Create a Distribution

2. (Optional) If you have the capability to distribute any report, then you can select the **View only my distributions** check box. For more information about authorization and capabilities, contact your system administrator.

3. To add a new distribution, click the **+** icon.

4. To edit the existing distribution, select the row and then click the **Edit** icon.

5. To delete a distribution, click the **X** icon.

**Edit or Delete a Distribution Using the Scheduled and Distributed Reports Dialog Box**

Note: Only authorized users can edit or delete reports that they have distributed. If you have questions about your authorization, contact your system administrator.

To edit or delete a distribution for a report, complete these steps:

1. From the Welcome window or Edit mode, select **File ⇒ Manage Files** to access the File Management window.

   Note: You can also use the Choose or Create a Distribution page in the Distribute Report Wizard to edit or delete distributions.

2. Open the Scheduled and Distributed Reports dialog box. The name of the link that opens the dialog box depends on your role.

   - If you do not have permission to schedule or distribute reports, you will not see a link.
   - If you can schedule but not distribute reports, then click **View my scheduled reports**.
   - If you can both schedule and distribute reports, then click **View my scheduled and distributed reports**.
3. Next to any report or folder of reports that you want to edit, click in the Actions column.

**Display 25.15  Scheduled and Distributed Reports Dialog Box**

4. If you want to edit the distribution for a report, select Distribute. Make your changes in the Distribute Report Wizard.

5. If you want to delete the distribution, select Delete Distribution. Click OK in the confirmation dialog box.

   *Note:* When you delete a distribution, all references to executing the distribution are also removed from the Occurrence, Status, Date/Time box.

6. Click Close.
Overview of Report Linking

Report links allow you single-step access to a report or Web page that is related to a report that you are currently viewing. For example, you might be looking at a bar chart which has sales information for each geographical region of your company. If you click the bar for the Northeast region, then a report link associated with the graph could take you to a different report that provides information about employees in each region. And, if the destination report contains a prompted filter, then it could open a table containing information about the Northeast region only. A link at the top of a destination report enables you to return to the previous report. If a destination report contains multiple sections, then you are able, when defining the link, to choose the initial section of the destination report that you want to open.

When you click the report link in the current report, values associated with what you clicked can be supplied as values to the prompts in the destination report.
Creating a Link to a Report, a Web Page, or Another SAS Application

Access the Report Linking Dialog Box for Images, Tables, or Graphs

You create report links by using the Report Linking dialog box while in Edit mode. To create a report link for images, tables, or graphs, complete these steps:

1. Right-click the report object, and then select Report Linking to open the Report Linking dialog box.

   Display 26.1  Report Linking Menu Item for a Tile Chart

2. For a link to an existing report, continue with the steps described in “Linking to an Existing Report or Stored Process” on page 283. For a link to a Web page, continue with the steps described in “Linking to a Web Page” on page 286.

Access the Report Linking Dialog Box for Text Objects

You create report links by using the Report Linking dialog box while in Edit mode. To create a report link for text objects, complete these steps:

1. In Edit mode, right-click on the text object, and then select Edit to open the Edit Text dialog box.

2. Enter the complete text that you want to display. Then highlight the text that you want to link from. Do not select anything other than plain text (no formatting changes).

   Tip: Be careful not to select all the text in a paragraph. Selecting the entire paragraph also selects the underlying HTML tags, which results in an error message stating that the selected text cannot be made into a link.
If you are using Internet Explorer, and you want to create a link from text that is already a Web address (such as www.mycompany.com) or an e-mail address (such as myname@mycompany.com), do this instead: First, type in a temporary name that is not a valid URL (for example, wwwXmycompany.com), and select it. Click and fill in the Report Linking dialog box as described in “Linking to a Web Page” on page 286. Then click OK. Finally, change the temporary name in the text to the desired text (for example, change wwwXmycompany.com to wwwmycompany.com).

3. Click to open the Report Linking dialog box.

4. To link to a Web page, continue with the steps described in “Linking to a Web Page” on page 286.

Choosing a Link Destination

Linking to an Existing Report or Stored Process

When you link reports, you can associate data item values and prompts so that the prompt window is bypassed for the target report and the target report is automatically subset based on the values in the source report. You can associate values and prompts in the Set Up Destination Report dialog box, which is explained in Step 6 here.

For multidimensional crosstabulation tables, SAS Web Report Studio can pass the following values to a prompt in a target relational report:

- category values that are visible in the table
- group break or filter criteria, if the data item is manually associated with a related prompt

For multidimensional reports only, you can also pass hidden data item values to the prompts in a linked report. The hidden values can be categories that are not visible in the table.

To link to an existing report or stored process, complete these steps:

1. Start with the steps described in

- “Access the Report Linking Dialog Box for Images, Tables, or Graphs” on page 282
- “Access the Report Linking Dialog Box for Text Objects” on page 282

2. Select the Include report links check box to confirm that you want to create a report link.
3. Select a link destination of **an existing report or stored process**.


   **Display 26.3  Report Linking Dialog Box for a Link to an Existing Report**

   ![Report Linking Dialog Box]

   **Note**: If the **Set Up Destination Report** button is dimmed, then you cannot add report links.

5. (Optional) Add content to the **Tool-tip text** field. The default tooltip text is **Click to view linked content**.

6. If the destination report contains multiple sections or prompts, then click **Set Up Destination Report** to open the Set Up Destination Report dialog box and assign data items in the source report to prompts in the target report.

   If the destination report contains multiple sections, the **Open to section** drop-down list contains the names of the sections in the destination report. Select the section that you want to appear when a user clicks to follow a link.

   If the destination report contains any prompts or if the report object in your source report contains suitable data items, then the box contains a drop-down list of **Data Items** for each prompt in the destination report. The data item that you select has to be compatible with the prompt. Data items that are incompatible cannot be assigned. For example, a character prompt for age groups, such as child and adult, cannot accept numeric data item values, such as 5 or 35. For more information about compatibility between prompts and data items, see “Defining Prompts in Report Linking” on page 315. If you do not assign a data item value to each prompt, the prompt window appears and you must confirm the current values or enter new ones.

   **Note**: You can select the same data item value for multiple prompts.

   If none of the available items in the drop-down list provides the intended value for a given prompt, then leave the drop-down list unchanged.
If you get unexpected results in the target report, here are some potential ways to remedy the situation:

- If a table or graph in the target report unexpectedly displays the message: **No values were returned**, then you can check the prompt values that were actually used by clicking the **Refresh Data** option. The prompt window for the current section of the target report appears with the values that were actually used. Sometimes the format of the values used by prompts can affect the results. In such cases, you should verify that the formats of the values delivered from the source report agree with the formats expected by the prompts. For example, unexpected results could occur if a target prompt expected values in uppercase and the source report delivered the values in lowercase. You could simply correct the values on the prompt screen. Alternatively, you could adjust the source or target or both reports so that the values passed from the source agree with the expectations for the target prompt or prompts.

- If the prompt window unexpectedly appears when you are linking to a target report and messages with particular prompts indicate their values are invalid, then review the set up of the source and target report. Here are some potential inconsistencies you might encounter:
  
  - A prompt that allows only one value is passed multiple values from a hidden data item in a source report.
  - A missing value is passed to a prompt that does not allow missing values.
  - A value that is 10 characters long is passed to a prompt that allows values with no more than 7 characters.

The following are special considerations for linking text and image objects:

- Text objects uniquely enable you to create multiple report links, but the **Set Up Destination Report** button does not appear in the Report Linking dialog box.
• For image objects, if the destination report has multiple sections or contains prompts, the Set Up Destination Report button is available, but you cannot specify the data items corresponding to prompts in the destination report.

Click OK to close the Set Up Destination Report dialog box.

7. Click OK to close the Report Linking dialog box.

**Linking to a Web Page**

Type the URL for the Web page that you want to link to. When the user clicks to follow the link, the Web page opens in a separate browser window. Complete these steps:

1. Start with the steps described in
   • “Access the Report Linking Dialog Box for Images, Tables, or Graphs” on page 282
   • “Access the Report Linking Dialog Box for Text Objects” on page 282

2. In the Report Linking dialog box, select the check box to make a link. (The name of the check box depends on the type of report object.)

3. Select A Web page for the Link destination.

4. Enter a value for the Web page URL.

5. (Optional) Add content to the Tool-tip text field. The default tooltip text is Click to view linked content.

6. Click OK to close the Report Linking dialog box.

**Display 26.5  Report Linking Dialog Box for a Graph**

![Report Linking Dialog Box for a Graph]

5. (Optional) Add content to the Tool-tip text field. The default tooltip text is Click to view linked content.

6. Click OK to close the Report Linking dialog box.

**Linking to Another SAS Application**

The ability to link to another SAS application is available only from tables and graphs that are based on information map data sources. This feature has to be set up in advance
by a system administrator. Only users with the appropriate role and capability can link to another SAS application. If you have questions about your role or capabilities, contact your system administrator.

To link to another SAS application, follow these steps:

1. Start with the steps described in
   - “Access the Report Linking Dialog Box for Images, Tables, or Graphs” on page 282
   - “Access the Report Linking Dialog Box for Text Objects” on page 282
2. In the Report Linking dialog box, select the check box to make a link. (The name of the check box depends on the type of report object.)
3. Select Another SAS application for the Link destination.
4. Select the SAS application(s).
5. (Optional) Add content to the Tool-tip text field. The default tooltip text is **Click to view linked content**.

Display 26.6  Report Linking Dialog Box for Another SAS Application

---

**Creating a Link for a Group Break**

To link to a report from a group break, complete these steps:

1. In the Table of Contents panel in Edit mode, select Options ➔ Group Breaks ➔ Report Linking to open the Report Linking dialog box.
2. Specify what you want to link to by selecting an item (or items) in the Assign link(s) to: list.
Identifying Links in Reports

Reports, stored processes, tables, graphs, geographical maps, images, or pieces of text can contain links. If linkable, text or the data cells in a table are underlined. For graphs, you must know whether the markers are linked. You also must know whether there is a link in a geographical map.

Understanding the Run-Time Behavior of Links

When you follow a link to another report or to a Web page, the way they display is different:

- When you follow a Web link, a new browser window opens. The source report is not closed, so there is no link to return you to it.
- When you follow a link to another report in SAS Web Report Studio, the target report displays in the primary SAS Web Report Studio window. A **Return to previous report** link is available. The return link also displays the name of the source report that you will return to. Click the link to return to the source report.
• When you follow a link to another SAS application, you might see a prompt window or a report might appear. A return link is available to return you to SAS Web Report Studio.
Chapter 27
Scheduling Reports

Overview of Scheduling Reports

Scheduling report generation automates the process of delivering updated content to report users. You can schedule reports to generate once or at recurring intervals, such as daily, multiple times daily, weekly, or monthly. In addition, scheduling reports gives you the ability to schedule a time to pre-generate content during non-peak hours. SAS Web Report Studio provides an easy-to-use interface for scheduling reports.

Scheduling Reports, Stored Processes, and Folders

About Scheduling

For faster rendering, you can schedule a time for queries to be pre-generated for selected reports and stored processes, including an entire folder of reports. If a report does not have any schedules associated with it, then the first page of the Schedule Report Wizard lets you define the execution time, date, and recurrence. However, if one or more schedules are associated with a report, then the first page of the Schedule Report Wizard lets you choose a schedule.

Scheduling always produces a manually refreshed report. If the report was originally saved as automatically refreshed and a schedule runs for that report, then the report becomes manually refreshed. Output from a scheduled report is always stored in the
same place. If you run multiple schedules on a report, then the report reflects the state of the last scheduled run.

To schedule a report, a scheduling server must be available and you must have the authorization to schedule reports. For more information, contact your system administrator.

**How the Preferred Locale for Reports Affects Scheduling**

*Note:* This feature is available starting with the second maintenance release of SAS Web Report Studio 4.31.

The locale preference that is specified in the SAS Preferences Manager is applied to SAS Web Report Studio. The SAS Preferences Manager is a Web application that provides a common mechanism for managing preferences for all SAS Web applications. In previous versions of SAS Web Report Studio, the locale preference specified in your browser was applied to the report.

If the preferred locale is not specified in the SAS Preferences Manager, then the locale specified in the browser is applied. If a locale is not specified in the browser, then the default locale for the Java environment is applied. For scheduling and distributing reports, your locale preference is applied. The browser default is not available for these operations, since there is no browser.

SAS Information Delivery Portal users can specify locale preference by selecting **Options ⇒ Preferences** and accessing the SAS Preferences Manager. For more information, see the Help for SAS Information Delivery Portal.

SAS Web Report Studio users can access the SAS Preferences Manager directly. To display the SAS Preferences Manager application and specify your preferred locale, use the following URL address: `http://server:port/SASPreferences`. Here is an example: `http://orion.com:8080/SASPreferences`.

To set the locale in the SAS Preferences Manager, follow these steps:

1. Select **Regional** in the left panel.
2. Under the **Regional** heading in the main panel, select a value in the **User locale** drop-down list.
3. Click **OK**. The SAS Preferences Manager closes, and returns you to the standard log on window for SAS applications.

For more information about the SAS Preferences Manager, see *SAS Intelligence Platform: Middle-Tier Administration Guide*.

**Schedule a Report, Stored Process, or Folder for the First Time**

To schedule a report, stored process, or folder, complete these steps:

1. To launch the Schedule Report Wizard, perform one of these tasks:
   - When a report or stored process is displayed in View mode, select **File ⇒ Schedule**.
   - In the File Management window, next to the name of the report, stored process, or folder that you want to schedule, click in the **Actions** column, and then select **Schedule**.

   The first wizard page appears.

2. Specify the interval for running the report, stored process, or folder.
The rest of the information that you must provide depends on your selection. If you select **Now**, then you do not need to select any other options.

3. For any **Run report** option other than **Now**, specify the time that you want to run the report. You can also specify the starting and ending (if applicable) date range for the schedule.

4. (Optional) To archive the report, select **Retain previous instances of output not to exceed**. Archived reports are saved as PDF output and can be opened from the Open dialog box or from the File Management window.

   **Note:** Only one copy of a report can be saved per day. If a report is saved multiple times in one day, then only the next-to-last saved report is used as that day’s archived report.

   **Note:** If you have the capability to archive reports and have already specified a number of report instances to retain for an archived report, then the number that you enter here will overwrite that number.

   **Note:** This option is not available for folders.

5. (Optional) If publication channels are defined, then select the **Publication Channel** to which the report should be saved. The list of available channels is supplied by your system administrator.

   **Note:** A publication channel is an information repository that has been established by using the SAS Publishing Framework. It can be used to publish information to users and applications. If you publish your report to a publication channel, then authorized users and applications can access your report by subscribing to the channel.

   Specify a number in the **Days until expiration** field. The default is 90 days. The number that you entered is saved with your user profile. It is filled in automatically the next time you open the Schedule Report Wizard.

   **Display 27.1 Schedule Report Wizard: Define Execution Time, Date, and Recurrence**

6. Click **Next** to go to the next wizard page.
Note: If the report has prompts that do not have defaults, then you must specify prompt values before exiting.

7. If the report has prompts, a wizard page appears, displaying those prompts.

   **Display 27.2  Schedule Report Wizard: Select Prompt Values**

8. After you enter the required prompt values, click **Next** to go to the next wizard page, or click **Finish**. The summary page displays the name of the report, the time or times that it is scheduled to run, and any prompt values.

   Note: To make changes to your selections on previous wizard pages, click **Back**.

   **Display 27.3  Schedule Report Wizard: Summary**

9. Click **Finish** to save your settings and exit the wizard.
Note: When you schedule a stored process, SAS Web Report Studio saves the results in a report with the same name as the stored process. The report is saved in the same folder as the stored process.

View a List of Scheduled Reports

To view a list of the reports that you have scheduled, complete these steps:

1. From the Welcome window or Edit mode, click File → Manage Files to access the File Management window.

2. Open the Scheduled and Distributed Reports dialog box. The name of the link that opens the dialog box depends on your role:
   - If you do not have permission to schedule or distribute reports, you will not see a link.
   - If you can schedule but not distribute reports, then click View my scheduled reports.
   - If you can both schedule and distribute reports, then click View my scheduled and distributed reports.

The Scheduled and Distributed Reports dialog box contains the following information:

- Last updated
  This field displays the date that the list of scheduled reports was last updated.

- Refresh lists
  Select this option to update the list of reports.

- Schedule, Actions, Schedule Definition
  This field displays the name of each scheduled report and the time that each report is scheduled to run. It also displays the prompt values if the report is prompted.

  To see a menu of options for editing and deleting a specific scheduled report, click in the Actions column.

- Occurrence, Status, Date/Time
  This field displays the status of each occurrence of each scheduled report, either Failed, Executed, or Running. The Date/Time column displays the date and time for each successful or failed execution.

  If the status is Failed, take these actions to try to resolve the problem:
   - rerun the schedule
   - delete the schedule, re-create it, and then run it again
   - contact your system administrator

- Maximum number of history occurrences to display
  Each report can have multiple occurrences listed, not including occurrences with the status of Running. The system limit for the value is 10. If the value is 0 (zero), then all history records are retrieved.

  After you change the value, click Refresh lists to make sure the value takes effect. The value that you enter is stored with your user profile, so it appears the next time the dialog box opens.
Note: You cannot use the scheduling features if a scheduling server is not available or if you do not have authorization to schedule reports.

Display 27.4 A List of Scheduled Reports

3. When you are finished viewing the information, click Close.

---

Updating a Schedule

Edit or Delete a Schedule Using the Schedule Report Wizard

If there is at least one schedule associated with a report, stored process, or folder, then you can update the schedule using the Schedule Report Wizard.

To edit or delete a schedule using the Schedule Report Wizard, complete these steps:

1. To launch the Schedule Report Wizard, perform one of these tasks:
   • When a report or stored process is displayed in View mode, select File ➔ Schedule.
   • In the File Management window, next to the name of the report or stored process that you want to schedule, click in the Actions column, and then select Schedule.
The first wizard page appears.

**Display 27.5  Schedule Report Wizard: Choose or Create a Distribution**

2. (Optional) If you have the capability to schedule any report, then you can select the View only my schedules check box. For more information about authorization and capabilities, contact your system administrator.

3. To add a new schedule, click the icon.

4. To edit the existing schedule, select the row and then click the icon.

5. To delete a schedule, click the icon.

**Edit or Delete a Schedule Using the Scheduled and Distributed Reports Dialog Box**

To edit or delete a schedule associated with a report, stored process, or folder, complete these steps:

*Note:* Only authorized users can edit or delete reports that they have scheduled. If you have questions about your authorization, contact your system administrator.

1. From the Welcome window or Edit mode, click File ➔ Manage Files to access the File Management window.

   *Note:* You can also use the Choose or Create a Distribution page in the Schedule Report Wizard to edit or delete schedules.

2. Open the Scheduled and Distributed Reports dialog box. The name of the link that opens the dialog box depends on your role:

   * If you do not have permission to schedule or distribute reports, you will not see a link.
   * If you can schedule but not distribute reports, then click View my scheduled reports.
• If you can both schedule and distribute reports, then click **View my scheduled and distributed reports.**

3. Next to any scheduled occurrence of the report or folder of reports that you want to edit, click **in the Actions column.**

![Scheduled and Distributed Reports Dialog Box](image)

4. If you want to edit the schedule for a report, select **Schedule.** Make your changes in the Schedule Report Wizard.

5. If you want to delete a schedule, select **Delete Schedule.** In the confirmation message box that appears, click **OK.**

   **Note:** When you delete a schedule, all references to executing the schedule are also removed from the **Occurrence, Status, Date/Time** box.

6. Click **Close.**
Overview of Printing and Exporting

SAS Web Report Studio provides several mechanisms that give you output that can be delivered to report consumers. Entire reports or targeted parts of a report can be saved as PDF output or in Microsoft Excel format for future viewing or printing. This output can be saved locally on disk or sent to a printer.

The report name and any applied filter information is exported with a table or a graph.

Note: Comments are not exported with a report.

Exporting Reports and Report Data

Export the Contents of an Entire Report

To export the entire contents of a viewed report, complete these steps:

1. To create the zipped file that contains all the necessary reporting elements, perform one of these tasks:
   - From the Welcome window or Edit mode, select File ⇒ Manage Files to access the File Management window.
Next to any report that you want to export, click in the Actions column, and then select Export.

- In View mode, select File ⇒ Export.

2. When you are prompted, save the zipped file to a location such as your hard drive or a network drive.

3. Extract the report files to a folder in a location such as your hard drive or a network drive.

After the extraction, the folder contains the following contents:

- **sasExport_files** contains the auxiliary files needed to display the report. You do not interact with the files in this folder.
- **sasExport.html** enables you to open the report in a Web browser.
- **sasExport.xls** enables you to open the report in a Microsoft Excel spreadsheet.

*Note:* When opening files in Microsoft Excel, you might receive a warning that the files are not in the expected location. Click Yes in the message box to acknowledge the warning.

For advanced layout options when exporting entire reports (for example, selecting which tables and graphs to display), use SAS Add-In for Microsoft Office. For more information, see the online Help for SAS Add-In for Microsoft Office. If you do not have SAS Add-In for Microsoft Office, contact your on-site SAS support personnel.

---

**Export Data from a Graph**

To export data from a graph, complete these steps in View mode:

1. Right-click in the graph and select Export Graph Data to open the Export dialog box.

   *Display 28.1 How the Export Dialog Box for Graphs Appears for Exporting to Microsoft Excel*

2. Choose one of the following export options:

   - With the Export to radio button selected, choose the Excel option to export the graph data to a Microsoft Excel spreadsheet.
   - With the Export to radio button selected, choose the Word option to export the graph data to a Microsoft Word document.
   - Select the Save as radio button. Then select either Tab separated values (.tsv) file or Comma separated values (.csv) file to create a data file.

3. Click OK.

4. When you are prompted, choose either to open the file or to save it.
Export Data from a Geographical Map

To export data from a geographical map, complete these steps in View mode:

1. Click \( \text{on the map toolbar to open the Export dialog box.} \)
2. Choose one of the following export options:
   - With the Export to radio button selected, choose the Excel option to export the graph data to a Microsoft Excel spreadsheet.
   - With the Export to radio button selected, choose the Word option to export the graph data to a Microsoft Word document.
   - Select the Save as radio button. Then select either Tab separated values (.tsv) file or Comma separated values (.csv) file to create a data file.
3. Click OK.
4. When you are prompted, choose either to open the file or to save it.

Export Data from a List Table

To export data from a list table, complete these steps in View mode:

1. Right-click in the list table and select Export Table to open the Export dialog box.
2. Choose one of the following export options for rows:
   - Select the All Rows radio button to export all rows.
   - Select the Rows radio button to specify a range of rows to export. Enter a number in the From and To fields.
3. Choose one of the following export options for columns:
   - Select the All columns radio button to export all columns.
Select the Selected columns radio button to specify which columns to export. Then select the check box to the left of the column or columns that you want to export. You can use \textup{[} or \textup{]} to change the order of the selected columns.

4. If you select the Export to radio button, then choose one of the following options:
   - Select \texttt{Excel (*.xlsx)} to export the table data to a Microsoft Excel spreadsheet.
   - Select \texttt{Excel (*.xls)} to export the table data to a Microsoft Excel spreadsheet.
   - Select \texttt{Word (*.doc)} to export the table data to a Microsoft Word document.

5. If you select the Save as radio button, choose one of the following options:
   - Select \texttt{Tab separated values (.tsv) file} to create a data file for Notepad.
   - Select \texttt{Comma separated values (.csv) file} to create a data file for Microsoft Excel.

6. Click \texttt{OK}.

7. When you are prompted, choose either to open the file or to save it.

\textbf{Export Detail Data from a Crosstabulation Table}

\textit{Note:} If you want to see the detail data before you export it, then see “View Detail Data in a Crosstabulation Table” on page 303.

To export detail data from a crosstabulation table, complete these steps in View mode:

1. Right-click in the crosstabulation table and select \texttt{Export Table} to open the Export dialog box.

\textbf{Display 28.3} How the Export Dialog Box for Crosstabulation Tables Appears for Exporting to Microsoft Excel

2. Choose one of the following export options for rows:
   - Select the All Rows radio button to export all rows.
   - Select the Rows radio button to specify a range of rows to export. Enter a number in the From and To fields.

3. If you select the Export to radio button, then choose one of the following options:
   - Select \texttt{Excel (*.xlsx)} to export the table data to a Microsoft Excel spreadsheet.
   - Select \texttt{Excel (*.xls)} to export the table data to a Microsoft Excel spreadsheet.
   - Select \texttt{Word (*.doc)} to export the table data to a Microsoft Word document.
4. If you select the **Save as** radio button, choose one of the following options:
   - Select **Tab separated values (.tsv) file** to create a data file for Notepad.
   - Select **Comma separated values (.csv) file** to create a data file for Microsoft Excel.

   You can also select (or deselect) the following check boxes related to the **Save as** option:
   - Specify **Formatted data** to save formatted data in the data file.
   - Specify **Repeat row labels if expanded** to repeat row labels for expanded levels in the data file.

5. Click **OK**.

6. When you are prompted, choose either to open the file or to save it.

---

**View Detail Data in a Crosstabulation Table**

*Note:* You cannot view detail data in a crosstabulation table if the data source has not been set up to support this feature by your data source administrator. In addition, whether the columns show the column label or the column name is controlled by a system administrator.

To view detail data in a crosstabulation table before you export it, complete these steps:

1. Perform one of these tasks to open the **View Detail** dialog box:
   - To see the detail data behind a value in a crosstabulation table, click the value (which will be underlined).
     *Note:* If report linking has been enabled for the values in the crosstabulation table, then when you click on a value, you are prompted either to view detail data or to follow the report link.
   - To see the detail data behind a row or a column in a crosstabulation table, click the row or column heading in the innermost hierarchy level in the row or column and then select **Show Detail Data**.

   **Display 28.4 View Detail Option for the Sales Cost Column**

2. In the **View Detail** dialog box, you can review the data by selecting either **Show column labels** or **Show column names**.

   You can also click **Export** to export the data.
3. Click **Close Window** to return to the report.

---

**Printing Reports**

**Specify Printing Preferences**

To specify printing preferences such as margins, page size, page orientation, and whether to print page numbers, complete these steps:

1. Select **File** ⇒ **Page Setup** to open the Page Setup dialog box.
2. For **Orientation**, specify **Portrait** or **Landscape**.
3. Select the **Size**.
4. (Optional) For **Fit**, specify **Wrap** or **Fit width**.
5. (Optional) Select a value from each drop-down list to specify **Margins** for the top, bottom, left, and right. You can enter values as inches or centimeters.
6. (Optional) Specify **Header and Footer** information. You can enter values as inches or centimeters.
   a. For the **Page numbers/Content**, specify 1, 2, 3; 1 of n, 2 of n; 1/n, 2/n, 3/n; or **None**.
   b. Select where the page numbers will appear.
   c. Select the alignment of the page numbers.
7. Click OK.

**Print a Report**

*Note:* New report sections that are added to reports that were originally created in SAS Enterprise Guide do not include a static report creation date in the printed output.

To print a report, complete these steps:

1. Depending on your location, perform one of these tasks to open the Print dialog box:
   - In View mode, select **File ➤ Print**.
   - In the File Management window, next to the name of the report that you want to print, click in the **Actions** column, and then select **Print**.

   *Note:* If this is a manually refreshed report, then you must refresh the data before you can select printing options. However, you can click **Print to PDF** in the Print dialog box to print the report with the current options.

2. Specify a **Print range** by using these options:
   - **Current page (includes all table rows and columns)**
     Select this option if you want to print only the content that is currently shown in View mode. This means that only the content within the currently displayed group break value (if the report author chose to break a new page for each value) and within the current section is printed.
   - **All pages**
     Select this option if you want to print the entire report.
   - **Page(s)**
     Select this option if you want to print a portion of the report. After you select this option, you can then select where you want the printed portion to begin and end by using the two drop-down lists.

3. (Optional) Select **Page breaks** to insert page breaks between report sections.
4. (Optional) Select **Append existing comments** to append comments to the end of the report.

5. To display the PDF output that you can print or save, click **Print to PDF**.

6. In Adobe Acrobat, complete these steps:
   a. Select **File** ➔ **Print** to open the Print dialog box.
   b. To send the report to the specified printer, click **OK**.
   c. To exit Adobe Acrobat, select **File** ➔ **Close**.

7. To close the Print dialog box, click **Close**.
Part 7

Appendixes

Appendix 1
  Tips and Guidelines ........................................ 309

Appendix 2
  Browsers and SAS Web Report Studio ......................... 321

Appendix 3
  Data Refresh: Manual Versus Automatic ...................... 323

Appendix 4
  Data Sources: Relational Versus Multidimensional .......... 325

Appendix 5
  What to Do If You Are Prompted for Credentials ........... 327

Appendix 6
  What to Do If Your Data Source Is Invalid ................. 331

Appendix 7
  Incomplete Tables and Graphs ............................... 333
Naming Reports, Folders, and Templates

Here is some information about naming conventions in SAS Web Report Studio:

**Uniqueness requirements**

Names are not case-sensitive. For example, you cannot have a report named 2012 Vendor Costs and a report named 2012 VENDOR COSTS in the same folder.

**Character restrictions**

Report, folder, and template names cannot contain these characters: \ / : * ? “ < > | @ # &

**Length requirements**

Report, folder, and template names must be 56 characters or less in length. Use spaces if your names are long. If you use a 56-character name with no spaces in it, then the browser cannot word-wrap the name to fit the normal-width Name column in the files.
list. You must resize the dialog box to make it wide enough to see all of the content and the OK button.

If you make a copy of a report that has a name longer than 56 characters, the trailing characters that exceed the maximum of 56 are dropped. For example, a report named `abcdefghijklmnopqrstuvwxyzabcdefghijklmnopqrstuvwxyzabcd` is saved as `Copy of abcdefghijklmnopqrstuvwxyzabcd`. You must resize the dialog box to make it wide enough to see all of the content and the OK button.

**Keywords**

Keywords must be 60 characters or less in length. Use spaces if your keywords are long. If you use a 60-character keyword with no spaces in it, then the browser cannot word-wrap the keyword to fit the normal width Name column in the files list. You must resize the dialog box to make it wide enough to see all of the content and the OK button.

Keywords cannot contain these characters: `< > & # / \`

*Note:* Keywords do not apply to report templates.

---

### Closing Dialog Boxes in SAS Web Report Studio

When you exit a dialog box without performing an action, such as saving changes, click the Cancel button instead of the button. Clicking Cancel enables the application to reclaim resources and memory.

### Customizing Colors

SAS Web Report Studio enables you to customize colors anywhere that you can change a color. For example, you might want to use a custom color if your company always uses a company-specific color in its reports.

You can customize a color using the Color value field in any color palette. The color value must be a six-digit, hexadecimal number specified in an RGB (red, green, and blue) format. The first two digits are the red value, the second two digits are the green value, and the last two digits are the blue value. You can specify a value from 000000 (black) to FFFFFF (white).

Type a value in the Color value field and press ENTER. You must press ENTER so that SAS Web Report Studio can validate the color. If there is a problem with the color value, then an error message appears, and the value returns to its previous state. If you do not press ENTER, then the customized color is not applied.

*Note:* A number sign (#) always appears before the six numbers or characters in the Color value field. The number sign is added when you type only six characters in the field.
In the following example, a user has specified a custom color for the border of a progressive bar chart.

**Display A1.1**  A Custom Color Specified in the Properties Dialog Box for a Progressive Bar Chart

---

**Working with Stored Process Prompts**

If you manually clear a non-required stored process prompt that has a default value, the cleared prompt filters the results based on the default value. If the prompt is set to use all possible values as its default, then the results are not filtered.

---

**Searching for Reports and Stored Processes**

Here is some information about searching for reports and stored processes in the Open dialog box or the File Management window:

**Case sensitivity**

The search is not case-sensitive. For example, if you search for `profit` in the report, your search results include results such as *Sports Equipment Profits* as well as *Company profits last year.*

**Results based on single words**
If you search for a single word, then SAS Web Report Studio assumes a wildcard character before and after the word. For example, if you perform a search with low in the Search for field, then the search results include results with names like Low Activity, Regions with Lowered Sales, and Monthly Allowance.

Scope of the search
Searching does not include content. If you end the search argument with an asterisk (*), then the "starts with" filter is used. If you place an asterisk at the beginning of a search argument, then the "ends with" filter is used.

Hiding Data Items

Here is some information about hiding data items in tables, graphs, and geographical maps:

Restrictions on hiding data items
Data items that are selected for group breaks are automatically hidden. You cannot assign the data items to different functions.

Consequences of hiding data items
• If you hide the geographic hierarchy in a report section that contains a geographical map, then the geographical map becomes invalid.
• If you hide a category that is used in a report-linking prompt, then the prompt association is removed. The report link still works, but the user must answer the prompts to display the target report.
• If you hide a data item that is used in a conditional highlighting rule, then the conditional highlighting rule is removed from the table or graph. If you hide a time hierarchy, then any custom data items that are based on relative time are also hidden.
• A crosstabulation table measure filter or ranking that is based on a category or hierarchy that is located on the outermost column or the outermost row is removed if the category or hierarchy is hidden. This is because the filter or ranking is tied to the location of the data item. If the data item is removed from that location, then the filter or ranking is also removed.
• If you hide a data item that is used in a sort, then the list table or graph is re-sorted, but the sorting information is saved with the data item. Here are some additional details:
  • If the hidden data item was the only sorted column, then the list table or graph is re-sorted to use its defaults as determined by the underlying data source. If you reassign the hidden data item to a function in the table or graph, the sort is restored.
  • For example, for list tables, if the hidden data item is the first out of three sorted columns, then the table is re-sorted so that the second sorted data item becomes the first priority and the third sorted data item becomes the second priority. If you reassign the first sorted data item to the Columns function, then the reassigned data item becomes the third priority in the sort.
Formatting Measure Data Items

You can right-click any measure in a table and select **Format** to change its format. Using the Define a Format dialog box, you can select a different format. For example, you can modify the number of decimal places for a percent of total calculation.

You can right-click any category on the X axis in a graph and select **Format** `<measure-name>` to change the format of a measure.

Creating Section Filters

Here is some information about creating section filters:

**Restrictions on filtering**

- You can create section filters only for categories in a relational data source.
- You cannot create section filters for data items that are defined as hyperlinks in an information map.
- You cannot use the characters `< >` in filter names, prompt names, or default values.

**Working with formatted and unformatted values**

Some data items enable you to apply the filter using formatted values instead of unformatted values. If the **Filter on formatted values** option is available and you select it, then formatted values are loaded into the **Available values** box when you click **Get Values**. In this case, any values that you type must also be formatted. To load unformatted values into the **Available values** box, deselect the **Filter on formatted values** option and click **Get Values** again. In this case, you must type unformatted values. Regardless of your formatting choice, the query results are formatted.

*Note:* Depending on how the data item is defined in the data source, the formatted values might be the same as the unformatted values.

**Using prompt names and prompt text**

Usually, the prompt name is the same as the filter name but not always. For example, the user might not need to know the location of a source city, but, as the filter creator, you need to distinguish between the two filters in the Section Filters dialog box. In this case, you might name the two filters *Canadian Source City* and *US Source City* but give them both the same prompt name of *Source City*.

Be as specific as possible when entering the prompt text for users. For example, if you use the **Not equal to** operator for the prompt, then users need to know that their selections will be excluded from the report. A descriptive prompt name also helps users enter the correct information.

**Filter expressions**

The filter combination expression is automatically updated as you select and deselect filters in the Section Filters dialog box. If your changes result in a filter combination expression that is not valid, you receive a warning. For more information about how to create a valid expression, see “Combine Section Filters” on page 122.
When you are creating a section filter that uses the Between values or Not between values operator, keep in mind that filters are evaluated based on the data type (character or numeric) of the selected data item and the locale that is currently active for the browser. For example, as a character string, the number 23 is considered higher than 1345 in the U.S. English locale. By default, filters are joined by the AND operator, which means that results are returned only if all selected filters are true.

When you can query for values

The data source administrator determines whether you can query data items in the data source for available filter values and whether you can create a filter that allows users to dynamically generate values.

Previewing filter results

To preview filtered results, select Data ➔ Preview Section Data to open the Preview Data dialog box. All columns and up to 100 rows are displayed at one time. For more information, see “Preview or Export Query Results” on page 104.

Working with Conditional Highlighting

Here is some information about applying conditional highlighting to tables and graphs:

Requirements

For graphs, conditional highlighting is measure-based. The graph must include at least one measure that can be used in the condition. For tables, conditional highlighting is based on measures or categories. The table must include at least one measure or category that can be used in the condition.

How conditions are evaluated

Highlighting conditions are evaluated based on raw values. The use of raw values affects how conditions are applied to rounded values. For example, in your table or graph, you have formatted product prices so that they are rounded up or down. The actual cost of a pair of Eclipse running shoes is $49.65. In the table or graph, the $49.65 price is rounded up to $50. If you specify that you want to highlight all products that cost less than $50, the Eclipse running shoes are highlighted because their actual price is less than $50.

Creating conditions for percentages

If you are creating a condition for percentages, you must enter the conditional value as a decimal number. For example, if you want to filter for values above 50%, enter .5 as the conditional value.

Creating rules

In general, there are two types of rules that you can create:

- Rules that compare a measure to a fixed value. For example, you might create a rule for Sales > 1000.
- Rules that compare one measure value relative to another measure value. For example, you might create a rule for Sales > Budget.

SAS Web Report Studio processes these rules in the following ways:
• For the first type of rule, the condition is applied at the current level of the data source. For example, if you drill down into the data and then specify conditional highlighting, the condition applies to the level that is currently displayed.
• For the second type of rule, the condition is applied at all levels of the data source, regardless of the current level.

Defining Prompts in Report Linking

Here is some information about defining prompts in report linking:

Restrictions on defining prompts

You can create a report based on a multidimensional data source as the source report in the report-linking operation. You can pass the parameters from the multidimensional report to a relational report.

When you create a link to pass values to parameters in a destination report or a stored process, the following constraints must be satisfied:

1. Prompts in destination reports have types. The common prompt types are character, numeric, date, time, and timestamp. There are other types, but they are not used in report linking.
2. Data items in the source report have types. Each data item has two types associated with it. If a data item has a format applied to it, then its formatted values are the character type. Unformatted values for data items can be character, numeric, date, time, or timestamp types.
3. Data types for the prompt and the source data item must be compatible. When you choose a parameter in a destination report to pass values to, the values must be a type that is compatible with a prompt. When you assign a data item to a prompt in the destination, the type associated with the data item's value must also be compatible with the prompt. Data items with incompatible types will not be presented in the drop-down menu for a given prompt.

Prompts are compatible in the following ways:

• Character prompts can accept the formatted values of all data items.
• Character prompts can accept the unformatted values of all character data items.
• Numeric prompts can accept the unformatted values of numeric data items (category or measure).
• Date prompts can accept the unformatted values of date data items.
• Time prompts can accept the unformatted values of time data items.
• Timestamp prompts can accept the unformatted values of timestamp data items.

Verifying prompt associations

SAS Web Report Studio does not check that your associations make sense, so make sure that you assign an appropriate data item value to each prompt. For example, you might link a Product Name group break in the primary report to a prompt for Product Name in the target report, but you would not link a Gender group break to a prompt for Order Year.
Conditions that cause the prompts window to appear

If you assign a value to each prompt in the target report, then the prompts window is bypassed when the user clicks the link in the primary report. If you do not assign a value to each prompt in the target report, then the prompts window appears. The user can then confirm the current prompt values or enter new ones.

If you remove or hide a category or hierarchy that is used in a report-linking prompt, then the prompt association is removed. The user must answer the prompts to display the target report.

Interaction with manually refreshed reports

If you link to a report that is manually refreshed, the prompt values sent from the primary report are not used for the target report. Instead, SAS Web Report Studio displays the results of the last query run for the target report.

Filtering and Ranking Tables, Graphs, and Geographical Maps

Here is some information about filtering and ranking tables, graphs, and geographical maps:

Working with formatted and unformatted values

If you are filtering on unformatted values, then you must enter values that match the casing of the values in the data source. If you select the **Filter on formatted values** option, then you must enter the formatted values. If the filter does not return any results, then try using a different casing. Note that you can select the **Ignore case** check box if you are working with relational data.

How time periods are counted

When filtering dates, times, and timestamps in tables and graphs, you can specify time periods such as days, weeks, months, and years. When SAS Web Report Studio counts by these time periods, it treats each period as a unit and begins counting from the beginning of the specified period type in which the current date falls. For example, if you use **Months** as the period type, SAS Web Report Studio counts the specified number of whole months from the current month, regardless of where the current date falls within the current month.

Here are two examples that illustrate how time periods are counted in this type of filter:

- Today is December 20, 2009, and you want to filter a table so that it includes sales that were posted before three months ago. If you use **Months** as the period type, the table includes data from sales that were posted before September 1, 2009. SAS Web Report Studio counts back three whole months from the current month and returns data before the first day of that month. To filter the table so that it includes sales that were posted 90 days before December 20, 2009 use **Days** as the period type. If you specify 90 days, the table includes sales that were posted before September 21, 2009.

- Today is December 20, 2009, and you want to filter a graph so that it includes employees who were born more than 10 years ago. If you use **Years** as the period type, the graph includes employees who were born before January 1, 1999. SAS Web Report Studio counts back 10 whole years from the current year and returns data before the first day of that year. To filter the graph so that it includes employees
who were born 3,650 days (365 * 10) before December 20, 2009, use **Days** as the period type. If you specify 3,650 days, the graph includes employees who were born before December 23, 1999.

**What time is used for time and date filters**

When you create time or date filters, the filter is relative to the time that the section query is generated, not to the time that the filter is imposed on the table or graph.

**When filters and rankings are applied**

When filtering a table or graph based on relational data, measure filters are applied after category filters. This behavior is explained in the Filter & Rank dialog box, which contains the following text: **The measure filter will be applied after any category filters.**

However, when filtering a table or graph based on multidimensional data, measure filters are applied to the values of the underlying cube instead of to the values that are visible in the table or graph. For this reason, you might see values in the table or graph that you would not see whether the measure filter had been applied based on visible category filters.

**Restrictions on filtering and ranking**

You cannot create filters that use categories and hierarchies that are assigned to group breaks.

You cannot filter data items that are defined as hyperlinks in an information map.

You cannot filter on percent of total values.

You cannot create a percentage ranking for relational data.

For scatter plots or bubble plots, you cannot create a measure filter or ranking if there is no category or hierarchy assigned to the optional marker group function.

**When you can select category values**

For data items in relational data sources, the availability of the **Get Values** button is controlled by your data administrator.

**Consequences of changing data assignments in a crosstabulation table**

If you add or hide a category or hierarchy column, then any row filters and rankings that are based on a column measure are removed. Filters are not affected by adding or hiding measures.

If you add or hide a category or hierarchy row, then any column filters and rankings that are based on a row measure are removed. Filters are not affected by adding or hiding measures.

Filters are retained if you move all the data items that are currently on rows to the columns and all the data items that are currently on the columns to the rows. In this case, any existing filters remain and are evaluated based on the new positions.

**Consequences of turning percent of totals off**

If a table contains percent of totals for rows that are based on row subtotal values, then those percent of totals are removed when you turn off subtotals for the table.

If a table contains percent of totals for rows that are based on row total values, then those percent of totals are removed when you turn off subtotals for the table.
If a table contains percent of totals for columns that are based on column subtotal values, then those percent of totals are removed when you turn off subtotals for the table.

If a table contains percent of totals for columns that are based on column total values, then those percent of totals are removed when you turn off subtotals for the table.

---

**Working with Text Objects, Headers, and Footers**

The text formatting tools in the Edit Text, Edit Header, and Edit Footer dialog boxes can be affected by your browser. Here is some information for working with text objects, headers, and footers:

**Restoring the default background color**

Once a block of text has been given a background color, if you select all or part of it and choose automatic (or if you select the transparent color in the drop-down palette), the background color does not change. Instead, apply the actual background color (white).

**Inserting text before or after a single dynamic item using the mouse**

If there is no text preceding a dynamic item in a paragraph, then clicking in front of the gray box selects the whole box instead of putting the caret in front of it. The same behavior happens if there is no text after a dynamic item. Instead, press the left or right arrow keys.

**Receiving an error message that selected text cannot be made into a link**

You might see this message if you select all of the text in a paragraph and then click. To work around this issue, type an extra space at the end of the paragraph and then do not include the extra space when you select the text for the hyperlink. This same error can occur if the selected text is immediately adjacent to a dynamic item. Always type at least one space after a dynamic item before you insert another one.

**Using SHIFT+TAB does not shift the focus out of the edit box**

Use the Tab key to navigate instead.

**Choosing a new foreground or background color seems to do nothing when the cursor is blinking**

When you change the style while you are at an insertion point, there will be no visible effect until you type a character. Note that if you move the insertion point (for example, using the mouse or arrow key) before Entering a character, then the pending style change is automatically canceled.

**Changing the color of a new empty line does not work**

When you press ENTER at the end of a line of colored text, the next line is the same color because you have created a new paragraph. You can change the color of individual paragraphs, but the paragraph must have at least one character so that you can select it. Be sure to select the entire paragraph. You can use SHIFT+END to do this. You can remove empty paragraphs at the end of the text by using the arrow keys to navigate to the end of the paragraph and then press Backspace.

**Receiving an error message that the format change cannot be made to more than one paragraph**
Pressing ENTER creates a new paragraph. You cannot apply a style change across paragraphs. However, you can select each paragraph and apply the same style to each one.

**Receiving an error message that a dynamic item cannot be inserted while another dynamic item is selected**

You cannot have one dynamic item immediately adjacent to another dynamic item. Instead, type a space between the existing dynamic item and where you want to insert another dynamic item.

**Clicking a dynamic item shows vertical gray bands at the ends of the dynamic item**

This is how the browser displays reverse-video selection for the particular HTML that is used to represent the dynamic item.

---

**Using Reports Created with a Previous Version of SAS Web Report Studio**

Here is some information about using reports that were created with a previous version of SAS Web Report Studio:

**How to use prompt names**

Prompted filters now have prompt names. The prompt name appears in both the prompts window and in the Report Linking dialog box when a prompted filter is in the destination report. In previous versions of SAS Web Report Studio, the prompt name was the data item label. SAS Web Report Studio now allows multiple filters per data item, which lets you customize the prompt name and lets the report viewer distinguish among prompted filters based on the same data item. New filters have the same filter name as the prompt name. Old prompted filters still have the data item label as the prompt name. If you change old filters to prompted filters, then the prompt name is blank. If the prompt name is blank and you save the filter, then the filter name is used as the prompt name.
Appendix 2
Browsers and SAS Web Report Studio

Browser Limitations

The Web browsers that are supported for use with the SAS Foundation are also supported for use with SAS Web Report Studio. For more information, see http://support.sas.com/resources/thirdpartysupport/.

You should not attempt to connect to SAS Web Report Studio in more than one tab of Firefox or Internet Explorer 7 or 8. (Internet Explorer 8 must be run in Internet Explorer 7 compatibility mode.) Also, you should not attempt to connect multiple browsers on the same computer to SAS Web Report Studio. Either of these situations causes unpredictable results.

In SAS Web Report Studio, use of the browser's Back button is not supported. If you use the Back button, you will get unexpected results when performing the following tasks:

- re-entering prompt values
- navigating linked reports
- returning to a previous drill state
- navigating between sections

To correctly perform these tasks, do the following:

- Click the Refresh Data link to redisplay the prompt window and then enter your new values.
- Click the Return to previous report link to return to the previous report.
- Use the drill icon in the table to return to a previous drill state.
- Use the Table of Contents panel.

Using Firefox with SAS Web Report Studio

Modal dialog boxes
If you use Firefox 3.0 or later as your browser, then you should configure Firefox as described here. Otherwise, you will have problems seeing dialog boxes in SAS Web Report Studio. You might see dialog boxes, but they will not be modal. This means that the main window will keep the focus and the dialog box will be behind the main window. You will be unable to make any selections in the dialog box.

To set your Firefox browser options to enable modal dialog boxes, follow these steps:

1. In Firefox, select Tools ⇒ Options to open the Options window. Select the Content tab if it is not selected by default.

2. In the Content tab, make sure that the Block pop-up windows check box is not selected. If this option is selected, then you will not be able to open any dialog boxes in SAS Web Report Studio, and you will probably see the following error message:

   **Display A2.1  Error Message for Pop-Up Windows**
   
   ![Error Message for Pop-Up Windows]

3. In the Content tab, make sure that the Enable JavaScript check box is selected. Click Advanced to open the Advanced JavaScript Settings dialog box.

4. In the Advanced JavaScript Settings dialog box, make sure that the following check boxes are selected:
   - Move or resize existing windows
   - Raise or lower windows
   - Disable or replace context menus

   These options are required for modal dialog boxes and context menus to work properly in SAS Web Report Studio.

   Click OK to close the dialog box. Then close the Options window.

**Access keys**

If you want to use a SAS Web Report Studio access key in the Firefox browser, then use SHIFT+ALT+access key.
Appendix 3

Data Refresh: Manual Versus Automatic

If you have permission, you can save a report either to be manually or automatically refreshed. If you have questions about your authorization, contact your system administrator. The following table explains the consequences of each option.

<table>
<thead>
<tr>
<th>Refresh Option Selected in the Save As Dialog Box</th>
<th>Consequences</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data is automatically refreshed</td>
<td>A large report might take a long time to open. However, it takes less time to save a large report.</td>
</tr>
<tr>
<td></td>
<td>When the report is opened (and any required prompts are answered), the report automatically includes the most current data in the underlying data source that the viewer is authorized to see.</td>
</tr>
<tr>
<td>Data can be manually refreshed*</td>
<td>A large report that contains a lot of data might open more quickly. However, a large report might take a long time to save.</td>
</tr>
<tr>
<td></td>
<td>The data that is shown in the report is updated to match the underlying data source only when the report viewer requests a refresh. Selecting Refresh Data in one section refreshes data in all report sections.</td>
</tr>
<tr>
<td></td>
<td>While viewing the report, users can perform certain actions only after they have refreshed the data. For example, the report viewer would apply a filter to a crosstabulation table after the report has been refreshed with data.</td>
</tr>
<tr>
<td></td>
<td>The report can be archived by authorized users.</td>
</tr>
</tbody>
</table>

* Reports that are pregenerated on a schedule are also manually refreshed. (Not all report authors are authorized to schedule or refresh reports.)
The following table compares some of the functionality that might be available when designing and viewing reports that are based on relational and multidimensional data sources.

**Table A4.1  Data Source Comparison**

<table>
<thead>
<tr>
<th>Functionality</th>
<th>Relational</th>
<th>Multidimensional</th>
<th>When Functionality Is Available</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filtering category values for section queries (by selecting predefined filters or by creating custom filters)</td>
<td>yes</td>
<td>yes, but only predefined section filters</td>
<td>designing</td>
<td>A data source administrator determines whether the data source supports this functionality.</td>
</tr>
<tr>
<td>Filtering and ranking data in tables, graphs, and geographical maps</td>
<td>yes</td>
<td>yes</td>
<td>viewing and designing</td>
<td>A data source administrator determines whether the data source supports this functionality. You cannot create measure filters or rankings for crosstabulation tables in Edit mode.</td>
</tr>
<tr>
<td>Sorting in tables and graphs</td>
<td>yes</td>
<td>yes</td>
<td>viewing and designing</td>
<td>A data source administrator determines whether the data source supports this functionality. When you are designing a report, only sorting for list tables is available. You cannot specify a sorting priority for multidimensional data.</td>
</tr>
<tr>
<td>Modifying detail and aggregation settings</td>
<td>yes</td>
<td>no</td>
<td>designing</td>
<td>For multidimensional data, records are always grouped and the aggregation method of a measure cannot be changed.</td>
</tr>
<tr>
<td>Viewing detail data</td>
<td>no</td>
<td>yes</td>
<td>viewing</td>
<td>A data source administrator determines whether the data source supports this functionality.</td>
</tr>
<tr>
<td>Functionality</td>
<td>Relational</td>
<td>Multidimensional</td>
<td>When Functionality Is Available</td>
<td>Comments</td>
</tr>
<tr>
<td>------------------------</td>
<td>------------</td>
<td>------------------</td>
<td>---------------------------------</td>
<td>----------</td>
</tr>
<tr>
<td>Drilling and expanding</td>
<td>no</td>
<td>yes</td>
<td>viewing</td>
<td>A data source administrator determines whether the data source supports this functionality.</td>
</tr>
</tbody>
</table>
Appendix 5
What to Do If You Are Prompted for Credentials

About the Request for Credentials

Some companies do not like to store user passwords in metadata. This is often true when third-party databases, such as Teradata, Oracle, or DB2, are used. For third-party databases, you might be given a credential directly in your metadata logon object or via a group membership with a shared credential. In either case, you will be notified that your database credential information is missing.

When you are denied access to view a report because of missing database credential information, SAS Web Report Studio gives you the opportunity to enter a valid user ID and password. When you enter your user ID and password, they are valid for the current session only because they are stored in memory, not in metadata.

Enter Credentials

If you are prompted for credentials when accessing a data source, an error message appears. Click Manage Credentials to open the Manage Credentials dialog box.

Display A5.1  Missing Report Element Error Message

When you encounter a missing credentials situation, a Manage Credentials menu item is also added to the File menu. This menu item remains on the File menu for the rest of
the current session. You can use the Manage Credentials menu item to access the Manage Credentials dialog box. By default, this menu item does not appear until it is needed. However, your system administrator can permanently enable this menu item.

Use the Manage Credentials dialog box to specify an authentication domain and to enter your user name and password. To enter your credentials, complete these steps:

1. Select an Authentication domain.

2. Enter your User name.

3. Enter your Password.

4. Confirm your password in the Password confirm field.

5. Click Add. Your Authentication domain and User name display in the dialog box.

6. (Optional) Add another authentication domain, user name, and password. Click Add.

7. Click Close.

Note: Your user ID and password are valid for the current session only. They are stored in memory, not in metadata.
Remove Credentials

If you entered credentials during a login session, then you can use the Manage Credentials dialog box to remove an authentication domain, your user name, and your password. Normally, it is not necessary to remove credentials since they will be discarded from memory when you log off. This feature is provided for the special case when you need to stop using a password that you just added.

To remove your credentials, complete these steps:

1. Select File ➪ Manage Credentials to open the Manage Credentials dialog box.

   Display A5.4  Manage Credentials Dialog Box with Credentials Displayed

   ![Manage Credentials Dialog Box with Credentials Displayed]

2. Click Remove in the row where your Authentication domain and User name are displayed. The row is removed.

   Display A5.5  Manage Credentials Dialog Box with No Credentials Entered

   ![Manage Credentials Dialog Box with No Credentials Entered]

3. (Optional) Remove another authentication domain, user name, and password by clicking Remove.

4. Click Close.
What to Do If Access Is Still Denied

If you follow the steps listed in “Enter Credentials” on page 327 and you still cannot enter your credentials, then contact your system administrator.
Appendix 6
What to Do If Your Data Source Is Invalid

About Invalid Data Sources and Data Items
Sometimes it is impossible to render one or more report elements in SAS Web Report Studio. These situations are usually related to one of these causes:
- A data source (information map) has been moved or renamed.
- A table or graph is incomplete. For more information, see “Incomplete Tables and Graphs” on page 333.
- A data item, filter, or prompt is missing.

When a Data Source Has Been Moved or Renamed
A data administrator can use folders to help organize a large number of data sources (information maps). The administrator can also move, rename, and delete existing data sources. If a data source is deleted, then users are unable to open any reports that access the data source. If a data source has been moved, renamed, or both, then users with the appropriate role and access to the File Management window can use the repair report option to find the correct data source and redirect the report to use it.

For more information, see “Updating Resources in a Report” on page 257.

When a Data Item, Filter, or Prompt Is Missing from a Report
A report cannot be opened when one or more data items, filters, or prompts that are referenced in the report are missing. For example, this might happen when a column has
been removed from the underlying table or when a filter is removed from an information map. Users with the appropriate capabilities can help recover a report when one or more data items that are referenced in the report are missing. If you have questions about capabilities, contact your system administrator.

The report recovery process only removes references to the missing data item (or items), so that the report can be opened in SAS Web Report Studio. It is up to the user to edit the report and to reference the correct data item (or items). Otherwise, error messages will appear when the report is viewed.

You are automatically notified that one or more data items, filters, or prompts are missing in these ways:

- The Update Resources dialog box appears if you selected File ⇒ Open or if you tried to open the report in Edit mode.
- The Report Resources Must Be Updated window appears if the File Management window or a recently used report triggers the error.

*Note:* Users are notified of missing data items even if they do not have the appropriate capability to recover the report.

For batch reports, the Report Resources Must Be Updated window is triggered when you attempt do either of the following:

- refresh the data for a report that references missing data items, filters, or prompts
- open the report in Edit mode

When the Update Resources dialog box or the Report Resources Must Be Updated window appears, you are asked if you want to remove the unresolved references and open the report. If you click No, then the attempt to open the report is abandoned. If you click Yes, then the references to the missing data items are removed and SAS Web Report Studio attempts to open the report again.

There are some times when SAS Web Report Studio cannot recover a report that has missing data items. In some cases, after SAS Web Report Studio removes the missing data item or data items, the report is valid but incomplete. For example, suppose that the missing data item is a measure in a bar chart. When prompted, you click Yes to have SAS Web Report Studio remove the missing data item from the report. Once SAS Web Report Studio removes the missing measure, your report is valid. However, a bar chart requires a measure, so the report is incomplete in its current state. You can switch to Edit mode and use the Assign Data dialog box to add a measure and make the bar chart complete.
Appendix 7
Incomplete Tables and Graphs

If a table or a graph (other than a geographical map) is missing one or more required role assignments, it appears with sample data and a message that indicates what is needed. The following display shows a crosstabulation table that cannot be fully rendered because no data items are assigned to the rows.

Display A7.1 Example of an Incomplete Table

![Table Example]

The following display shows a graph that cannot be fully rendered because no category data item is assigned to the X axis.

Display A7.2 Example of an Incomplete Graph

![Graph Example]

Here are the requirements for tables and graphs:

- All data item labels must be unique.
- All multidimensional tables and graphs (other than scatter plots and bubble plots) require a category.
- All multidimensional tables and graphs require at least one measure.
- All bar-line charts and scatter plots require at least two measures.
- All bubble plots require three measures.
- All relational scatter plots and bubble plots require a category.
- All geographical maps require a geographical data item in a data source (information map).
Here are some ways that you can update an incomplete report element in View mode so that the report renders correctly:

• Select a data item in the **Section Data** panel, and then drag it where you want it in the report element. Hotspots appear over the report element to indicate the appropriate places to drop the data item.

• For a crosstabulation table, select a data item in a table, and then drag and drop it onto another location in the table.

• Right-click in the report element, and then select **Assign Data** to open the Assign Data dialog box. Then use drag and drop features to assign any missing data items. You can also use the **Move Items** drop-down list to assign any missing data items.

• If your original data selection does not have enough data items to complete a report element, select **Data ⇒ Select Data** to open the Select Data dialog box. Then select additional data items from the list of available data items in the data source.

• If there are duplicate data item labels, use the **Section Data** panel to rename the labels and make them unique.

Categories that are used as group break items cannot also be used as visual data items in a report element in View mode. In some cases, you might need to remove a group break to make a category available. Once the category is available, you can make it visible to complete the report element.
aggregate function
a function that summarizes data and produces a statistic such as a sum, an average, a minimum, or a maximum.

aggregation
the act or process of grouping data, using an operation that produces a statistic such as a sum, average, minimum, or maximum. The term aggregation can also refer to the grouped data that results from such an operation. See also aggregate function.

alphanumeric character
any of the following types of characters: alphabetic letters, numerals, and special characters or blanks. Most computer systems store strictly numeric data differently from alphanumeric or textual data.

authentication domain
a SAS internal category that pairs logins with the servers for which they are valid. For example, an Oracle server and the SAS copies of Oracle credentials might all be classified as belonging to an OracleAuth authentication domain.

bar chart
a chart that consists of a grid and some vertical or horizontal columns (bars). Each column represents quantitative data.

bar-line chart
a bar chart with an overlaid line graph. See also bar chart and line graph.

category
a classification of data items. Category data items are used to group measure data items, using an applied aggregate function. For example, a category data item that contains the names of countries could be used to group a measure data item that contains population values.

child
within a dimension hierarchy, a descendant in level n-1 of a member that is at level n. For example, if a Geography dimension includes the levels Country and City, then Bangkok would be a child of Thailand, and Hamburg would be a child of Germany.

crosstabulation table
a two-dimensional table that shows frequency distributions or other aggregate statistics for the intersections of two or more categories. In a crosstabulation table,
categories are displayed on both the columns and rows, and each cell value represents the data result from the intersection of the categories on the specific row and column.

cube
a set of data that is organized and structured in a hierarchical, multidimensional arrangement. A cube includes measures, and it can have numerous dimensions and levels of data.

data item
an item in a data source that is either a logical view of a data field or a calculation. The author of a report decides which data items to use in a particular section of a report. There are three types of data items: hierarchies, categories, and measures.

data source
a collection of data items and filters that provides a user-friendly view of data. Users of query and reporting applications such as SAS Web Report Studio can easily build business reports by using data sources as the building blocks for their reports.

detail data
(1) for multidimensional data sources, nonaggregated data. (2) for relational data sources, every record in a selected data source. Duplicate records can be either excluded or included. See also multidimensional data source and relational data source.

dimension
a group of closely related hierarchies. Hierarchies within a dimension typically represent different groupings of information that pertains to a single concept. For example, a Time dimension might consist of two hierarchies: (1) Year, Month, Date, and (2) Year, Week, Day. See also hierarchy.

equivalent interval
one group in a range of data that has been divided into equal groups.

filter
criteria that restrict either the data that is returned from a query to a data source or the data that is displayed in a table, graph, or map.

geographic information system
a software application for organizing and analyzing data that can be referenced spatially - that is, data that can be associated with physical locations. Many types of data, such as data from marketing surveys and epidemiological studies, have a spatial aspect. Short form: GIS.

GIS
See geographic information system.

group break
a way to divide report sections by distinct category or hierarchy level values when you are using a relational or multidimensional data source.

hierarchy
an arrangement of members of a dimension into levels that are based on parent-child relationships. Members of a hierarchy are arranged from more general to more specific. For example, in a Time dimension, a hierarchy might consist of the members Year, Quarter, Month, and Day. In a Geography dimension, a hierarchy
might consist of the members Country, State or Province, and City. More than one hierarchy can be defined for a dimension. Each hierarchy provides a navigational path that enables users to drill down to increasing levels of detail. See also member and level.

**histogram**

a bar chart that displays the observed frequencies of data that have been binned (divided into contiguous, equally spaced intervals). The heights of the bars indicate the relative frequency of observations in each bin.

**information map**

See data source.

**level**

in a multidimensional database (or cube), an element of a dimension hierarchy. Levels describe the dimension from the highest (most summarized) level to the lowest (most detailed) level. For example, possible levels for a Geography dimension are Country, Region, State or Province, and City.

**line graph**

a graph that shows the relationship of one variable to another, often as movements or trends in the data over a period of time. Line graphs summarize source data and typically are used to chart response values against discrete categorical values.

**list table**

a two-dimensional representation of data, in which the data values are arranged in rows and columns.

**locale**

a setting that reflects the language, local conventions, and culture for a geographic region. Local conventions can include specific formatting rules for dates, times, and numbers, and a currency symbol for the country or region. Some examples of locale values are French_Canada, Portuguese_Brazil, and Chinese_Singapore.

**mean**

the arithmetic average, which is calculated by adding the values of a sample variable and dividing this sum by the number of observations.

**measure**

a classification of data items. The values of measure data items are aggregated (unless otherwise specified) and can be used in computations or analytical expressions. For example, a measure data item could contain age values that are grouped by gender and then averaged.

**member**

in a multidimensional database (or cube), a name that represents a particular data element within a dimension. For example, September 1996 might be a member of the Time dimension. A member can be either unique or non-unique. For example, 1997 and 1998 represent unique members in the Year level of a Time dimension. January represents non-unique members in the Month level, because there can be more than one January in the Time dimension if the Time dimension contains data for more than one year.

**multidimensional data source**

a collection of data items and filters that describes and provides a view of a cube. See also cube, data item, and data source.
338

Glossary

natural break
a boundary in a range of data as determined by a histogram of data distribution. See
also histogram.
operator
in a SAS expression, any of several symbols that request a comparison, a logical
operation, or an arithmetic calculation.
parent
within a dimension hierarchy, the ancestor in level n of a member in level n-1. For
example, if a Geography dimension includes the levels Country and City, then
Thailand would be the parent of Bangkok, and Germany would be the parent of
Hamburg. The parent value is usually a consolidation of all of its children's values.
pie chart
a circular chart that is divided into slices by radial lines. Each slice represents the
relative contribution of each part to the whole.
progressive bar chart
a type of bar chart that shows how the initial value of a measure data item increases
or decreases during a series of operations or transactions. See also bar chart.
prompted filter
a type of filter that enables a report viewer to select the criteria that will be used to
restrict the data that appears in a report.
publication channel
an information repository that has been established using the SAS Publishing
Framework and that can be used to publish information to users and applications.
quantile
any of the points or values that divide data into groups that contain equal numbers of
observations, or any of those groups.
query
a set of instructions that requests particular information from one or more data
sources.
ranking
the process of ordering observations according to values of particular measure data
items. The observations that are ordered depend on the object that contains the data.
For list tables, observations correspond to rows. For crosstabulation tables, if the
measures are on the columns, then the ordered observations can be on the individual
rows or on the row that contains the outermost category data item. For graphs,
observations generally correspond to data points along a particular axis. See also
category, crosstabulation table, data item, list table, and measure.
relational data source
a collection of data items and filters that describes and provides a view of twodimensional physical data, in which the data values are arranged in rows and
columns. See also data item and data source.
report definition snapshot
a copy of a report definition that is fixed at the time that a report is requested.
Snapshots can be shared with users by email.


**SAS report**

a report that has been stored in the SAS Report Model format. A SAS report might be available for viewing in the portal if your organization has installed SAS Web Report Studio.

**scatter plot**

a two-dimensional plot that shows the joint variation of two data items.

**standard deviation**

a statistical measure of the variability of a group of data values. This measure, which is the most widely used measure of the dispersion of a frequency distribution, is equal to the square root of the variance.

**stored process**

a SAS program that is stored on a server and that can be executed as requested by client applications such as SAS Web Report Studio. The embedded SAS code can contain instructions for rendering report elements as part of a larger report or for rendering a complete report that includes queries, prompted filters, titles, images, and statistical analyses.

**tile chart**

a graph that represents the relative values of data by using rectangular areas. The color of each area represents the value of one measure in the query. The size of each area represents the value of the another measure in the query. The academic term for a tile chart is 'treemap.'

**Time dimension**

a dimension that divides time into levels such as Year, Quarter, Month, and Day.

**timestamp**

a data type or value that represents both a date and a time.

**tooltip**

descriptive text that appears when a cursor is placed over certain elements of a graphical user interface, such as the tool icons in a toolbar.
A
access denied 330
Actions menu 20
aggregated data, using detail data instead of 103
aggregation, modifying for measures 102
alphanumeric categories 92
prompted section filters for 112
section filters for 108
analysis 3
conditional highlighting and 227
drilling and expanding and 207
filtering and ranking and 187
sorting and 213
totals, subtotals, percent of total calculations and 219
archiving reports 243
deleting archived reports 245
viewing archived reports 244
axes, scale type and style 167

B
background color
graphs 166
legends 170
banner 27, 66
bar charts 149
assigning data items to 155
progressive 150, 161, 174
properties specific to 172
bar-line charts 149
assigning data items to 156
properties specific to 172
border color
graphs 166
tables 140
borders
tables 140
borders for graphs 166
browsers, limitations 321
browsing 201
for filter values 201
for multidimensional data items 204
for relational data items 202
bubble plots 151
assigning data items to 157
properties specific to 173

calculations 223
capabilities, access to 7
cascading prompted filters 107
creating 118
supplying values for 120
category data items 92
replacing in crosstabulation tables 137
category filters
for crosstabulation tables 192
for graphs 197
cells
adding to layout grid 82
aligning cell content in layout grid 82
in tables 142
merging in layout grid 84
charts
See also bar charts
bar-line charts 149, 156, 172
pie charts 150, 159, 174
tile charts 152, 163, 175
closing dialog boxes 310
colors
background color of graphs 166
background color of legends 170
border color of graphs 166
border color of tables 140
specifying custom values 310
columns
adding to layout grid 82
aligning values in tables 147
deleting empty columns from layout grid 83
moving in tables 146
number to display in tables 139
resizing in tables 147
comments
   adding or responding to 258
   printing 305
company preferred folder 25
conditional highlighting 227
   analysis and 227
   applying 314
   effects on drilling and expanding in tables and graphs 211
for graph values 233
for multidimensional data 314
for table values 228
copying
   report sections 263
   reports 246
credentials
   access denied 330
   entering 327
   removing 329
   request for 327
crosstabs tables 133
   assigning data items to 136
   category or hierarchy filters for 192
   drilling or expanding hierarchies in 207
   exporting detail data from 302
   filtering and ranking 192, 194
   finding data items in 185
   measure filters for 193
   member property filters for 195
   removing filter or ranking from 196
   replacing category data items 137
   showing or hiding totals and subtotals 221
   sorting data in 215
   viewing detail data 303
   viewing detail data behind values 236
cube, opening directly 40
custom colors 310
custom data items 92, 96
   based on relative time 96, 98
   creating with expressions 97
   in queries 96
   measures in 96
   modifying 100
   modifying default format 102
   removing 100
custom section filters
deselecting 123
   removing 124

D
data items
   See also custom data items
   See also standard data items
   assigning to bar charts 155
   assigning to bar-line charts 156
   assigning to bubble plots 157
   assigning to crosstabs tables 136
   assigning to line graphs 158
   assigning to list tables 136
   assigning to pie charts 159
   assigning to progressive bar charts 161
   assigning to scatter plots 162
   assigning to tile charts 163
   category data items 92
detail data for table or graphs 235
dragging and dropping 46
formatting 313
from data sources 49
hiding 136, 155, 312
hyperlink data items 147
   in graphs 155
   in tables 136
missing from report 331
   modifying default format 100
   multidimensional 204, 205
   queries based on 91
   relational 202, 203
   replacing 137
   replacing in crosstabs tables 137
   standard data items in queries 92
data refresh
   in viewed reports 46
   manual versus automatic 323
data security 7
Data Source Details dialog box 45, 235
data source reports 40
data sources
   data items from 49
   default 26
detail data for tables or graphs 235
   invalid 331
   modifying measure aggregation 102
   moved or renamed 331
   opening directly 40
   relational versus multidimensional 325
   selecting 93
date categories 92
   prompted section filters for 116
   section filters for 110
detail data
eventing from crosstabs tables 302
   for regions in geographical maps 238
   for tables or graphs 235
instead of grouped and aggregated data 103
viewing behind crosstabulation table values 236
viewing in crosstabulation tables 303
dialog boxes, closing 310
display filter information 250
Distribute Report wizard 271
distributed reports
  adding distribution plans 271
  editing or deleting distribution plans 278
  updating distribution plans 278
viewing a list of 276
distributing reports 270
dragging and dropping data items 14, 46
  graph objects 16, 59
  report objects 16, 59, 84
drilling and expanding 207
  analysis and 207
effects on conditional highlighting in tables and graphs 211
effects on filtering and ranking 211
effects on panning and zooming in geographical maps 212
effects on percent of total calculations in tables 212
effects on totals and subtotals in tables 212
hierarchies in crosstabulation tables 207
hierarchies in graphs 208
hierarchy in geographical maps 209
synchronized 87
dynamic text
  in headers and footers 65

graph data 300
list table data 301
query results 104
reports and report data 299
viewing detail data in crosstabulation tables 303
expressions
  creating custom data items with 97
  modifying 100
externally created reports 41

F
File Management window 242
  searching for files with 34
files, searching for 18, 34
filters
  consequences of moving data items in a crosstabulation table 137
filters and filtering
  See also prompted filters
  See also section filters
  analysis and 187
  applying without prompting 107
  browsing and searching for filter values 201
  cascading prompted filters 107, 118, 120
category filters 192, 197
combining section filters 122
creating 108
custom section filters 123, 124
detail data for tables or graphs 235
effects of drilling and expanding on 211
for alphanumeric categories 108
for crosstabulation tables 192, 196
for date, time, or timestamp categories 110
for geographical maps 200, 201, 316
for graphs 197, 199, 316
for list tables 190
for tables 316
hierarchy filters 192, 197
measure filters 193, 197, 200
member property filters 195
predefined filters 123
prompted section filters 112
section filters 313
synchronized filtering 87
viewing a summary of applied filters 45
Find option 185
finding data items
  in multidimensional crosstabulation tables 185
Firefox 321
folders 254
  creating 254
  deleting 255
in Open dialog box 19
  naming 309
  renaming 255
  scheduling 292
footers
  creating 65, 66
  default 26
  dynamic text in 65
  removing 69
  working with 318
formats
  modifying for custom data items 102
  modifying for data items 100
  modifying for standard data items 100
formatting data items 313
formatting text 74

g
geographical maps 176
  detail information for regions 238
  displaying query results 176
  drilling or expanding geographic hierarchy 209
  effects of drilling and expanding on panning and zooming 212
  exporting data from 301
  filtering and ranking 200, 316
  inserting into report layout 177
  measure filters for 200
  measures for 177, 178
  panning 179, 212
  properties 179
  removing 180
  removing filters or rankings 201
  unsynchronized 88
  zooming 179, 212
  graph skins 250
  graph types 149
    changing current type 172
    properties specific to 172
graphs
See also bar charts
  axis scale type and style 167
  background color 166
  bar-line charts 149, 156, 172
  border color 166
  borders of 166
  bubble plots 151, 157, 173
  category or hierarchy filters for 197
  conditional highlighting for values 233
  copying the formatting of 171
  data items in 155
displaying detail data 235
displaying query results 149
drilling or expanding hierarchies in 208
effects of drilling and expanding on conditional highlighting 211
  exporting data from 300
  filtering and ranking 197, 316
  grid lines 166
  incomplete 333
  inserting into report layout 153
  legends 170
  line graphs 150, 158, 173
  measure filters for 197
  modifying skin 250
  pie charts 150, 159, 174
  progressive bar charts 150, 161, 174
  ranking 198
  reference lines 168
  removing 180
  removing all sorting 217
  removing filter or ranking from 199
  scatter plots 151, 161, 175
  size of 165
  sorting ascending or descending values 216
  sorting by measure values 216
  tile charts 152, 163, 175
  titles 164
  unsynchronized 88
  grid lines on graphs 166
  group breaks 125
    adding 125
    removing 128
    removing measure values 128
  grouped data
    detail data instead of 103
    grouping query results
      adding group breaks 125
      group breaks 125
      removing group breaks 128
      removing measure values from group breaks 128
H
headers
  creating 65, 66
  default 26
  dynamic text in 65
  removing 69
  working with 318
headings in tables 142
Help 5
hiding
  data items 312
  totals and subtotals 221, 222
hierarchies
  drilling or expanding in crosstabulation tables 207
  drilling or expanding in geographical maps 209
  drilling or expanding in graphs 208
hierarchy data items 93
hierarchy filters
  for crosstabulation tables 192
  for graphs 197
highlighting
  See conditional highlighting
hyperlink data items
  displaying query results 147

I
images 71
  placing in report sections 71
  removing 76
incomplete tables and graphs 333
information maps 3
  opening directly 40
interactive filters 107
interface 11
invalid data sources 331

K
keywords 60, 310

L
labels for legends 170
layout grid
  adding cells 82
  adding columns 82
  adding rows 82
  aligning cell content 82
  deleting empty columns or rows 83
  deleting objects 83
  merging cells 84
  placing objects in 84
  positioning report objects 81
  repositioning objects 85
legends on graphs 170
line graphs 150
  assigning data items 158
  properties specific to 173
linking
  hyperlink data items 147
prompts in report linking
  315
reports 281
to another SAS application 282
to reports, Web pages, or another SAS application 282
list tables 133
  adding row numbers 141
  assigning data items to 136
  exporting table data from 301
  filtering and ranking 190
  showing or hiding totals and subtotals 221
  sort values 213
  sorting data 213
  sorting priority for values 214
logging off 9
logging on 8

M
maps
  See geographical maps
  See information maps
measure data items 92
measure filters
  for crosstabulation tables 193
  for geographical maps 200
  for graphs 197
measures
  for geographical maps 177, 178
  in custom data items 96
  modifying aggregation of 102
  removing values from group breaks 128
  sorting by measure values in graphs 216
member property filters
  for crosstabulation tables 195
menus 13
merging cells in layout grid 84
missing data item 331
modify decimal places 224
multidimensional data
  conditional highlighting for 314
  multidimensional data items
    browsing for 204
    searching for 205
  multidimensional data sources
    versus relational 325
  multidimensional tables
    showing or hiding totals and subtotals 222
multiple
  distribution plans 270
  schedules 291

N
naming guidelines
  for reports, folders, templates 309
navigation
  viewed reports 42
with Open dialog box
navigation pane

O
objects
deleting in layout grid
placing in layout grid
repositioning in layout grid
synchronized
unsynchronized
Open dialog box
accessing
Actions menu
folders in
navigating locations with
searching for files with
opening data sources directly
organizing reports

P
panning
effects of drilling and expanding on
geographical maps
passing hidden data items
passwords
percent of total calculations
adding to tables
analysis and
effects of drilling and expanding in tables
modifying decimal places
relationship with totals and subtotals
removing from tables
pie charts
assigning data items to
properties specific to
“other” slice
plots
bubble plots
scatter plots
predefined filters
deselecting
preferences
default data source, report style, header, and footer
default time zone
defaults for opening and saving reports
preferred locale
previewing query results
printing
comments
preferences
reports
progressive bar charts
assigning data items to
properties specific to
prompted filters
cascading
defining and applying
defining dependencies between
ordering
prompted section filters
for alphanumeric categories
for date categories
prompts
defining in report linking
in stored processes
properties
display filter information
modifying for reports
publication channels
publishing reports to
publishing reports

Q
queries
based on data items
custom data items in
standard data items in
query results
displaying
displaying in geographical maps
displaying in graphs
displaying in hyperlink data items
displaying in tables
grouping
previewing or exporting
subsetting

R
ranking
analysis and
crosstabulation tables
effects of drilling and expanding
geographical maps
graphs
list tables
removing from crosstabulation tables
removing from geographical maps
removing from graphs
tables
reference lines
refreshing data
in viewed reports
manual versus automatic 323
relational data items
  browsing for 202
  searching for 203
relational data sources
  versus multidimensional 325
relative time
  custom data items based on 96, 98
renamed data sources 331
renaming
  folders 255
  report sections 262
  reports 256
  standard data items 95
report definition snapshot 265
report layout
  inserting geographical maps 177
  inserting graphs 153
  inserting tables 134
report schedules
  creating 292
  editing or deleting 296
  updating 296
  viewing a list of 295
report sections 261
  adding 261
  copying 263
  creating headers and footers for 65
  deleting 264
  including text objects 73
  placing images in 71
  renaming 262
  reordering 264
  synchronized objects 87
  unsynchronized objects 88
report styles
  default 26
  modifying 250
report templates 55, 248
  deleting 249
  saving 248
report wizard 51
reporting elements 49
reporting resources 7
reports 242
  adding sections 261
  archiving 243
  comments 258
  copying 246
  created with previous version of Web Report Studio 319
data source 40
defaults for opening and saving 25
  deleting 249
  deleting sections 264
description 59, 269
descriptions 250
design 3
distributing 270
e-mailing URL for 267
e-mailing URL for a snapshot 265
editing or deleting distribution plans 278
exporting entire report 299
exporting reports and report data 299
externally created 41
inserting stored processes 77
keywords 59, 250, 269
linking 281, 282
menus 13
modifying data in viewed reports 46
modifying properties 250
moving 253
naming 59, 269, 309
navigating viewed reports 42
organizing 254
positioning report objects 81
printing 304, 305
prompts in links 315
publishing to publication channels 269
refreshing data in viewed reports 46
renaming 256
saving 59
scheduling 291, 292
searching for 311
shared locations 265
stored process reports 37
updating resources 257
viewing 33
  a list of distributed reports 276
  a list of scheduled reports 295
  saved reports 34
roles 7
row numbers in list tables 141
rows
  adding to layout grid 82
  aligning values in tables 147
  deleting empty rows from layout grid 83
  moving in tables 146
number to display in tables 139
S
SAS applications, linking to 282
SAS Comment Manager 258
SAS Intelligence Platform
  SAS Web Report Studio and 5
SAS Web Report Studio 3
  access to capabilities 7
  benefits of 4
Firefox with 321
how it works 4
logging off 9
logging on 8
previous versions 319
roles 7
SAS Intelligence Platform and 5
saved reports 34
saving reports 25, 59
scatter plots 151
assigning data items to 162
properties specific to 175
Schedule Report wizard 292
Scheduled and Distributed Reports dialog box 276, 295
scheduled reports
updating 296
viewing a list of 295
scheduling 291, 296
folders 292
preferred locale 292
reports 291, 292
stored processes 292
searching 201
for descriptions 18, 34
for files 18, 34
for filter values 201
for keywords 18, 34, 250
for multidimensional data items 205
for report names 18, 34
for reports and stored processes 311
section filters 107
applying 121
creating 313
custom 123, 124
prompted 112
security 7
select data source 93
shared locations 265
sharing reports 265
snapshot 265
sorting
and analysis 213
ascending or descending values in
graphs 216
by measure values in graphs 216
data in crosstabulation tables 215
data in list tables 213
list table values 213
removing all sorting 217
sorting priority for list table values 214
synchronized 87
standard data items 92
category data items 92
detail data versus grouped and
aggregated data 103
hierarchy data items 93
measure data items 92
modifying default format 100
removing 95
renaming 95
selecting 93
stored process reports 37
stored processes 49, 77
inserting in reports 77
prompts 311
removing 79
running 54
scheduling 292
searching for 311
viewing 37
style properties
for headings, subheadings, and cells
142
for total and subtotal values 144
subheadings in tables 142
subsetting query results 107
applying section filters 121
combining section filters 122
creating cascading prompted filters 118
creating prompted section filters 112
creating section filters 108
deselecting predefined or custom
section filters 123
removing filters 124
section filters 107
subtotals 144, 220
analysis and 219
effects of drilling and expanding 212
relationship with totals and percent of
totals 220
showing or hiding for crosstabulation
tables 221
showing or hiding for list tables 221
showing or hiding for multidimensional
tables 222
synchronized
drilling and expanding 87
filtering 87
objects 87
sorting 87
T
table, data source
opening directly 40
table types 133
changing currently selected type 145
tables
See also crosstabulation tables
aligning values in columns or rows 147
border color 140
### Index

<table>
<thead>
<tr>
<th>Effect/Action/Feature</th>
<th>Page(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cells</td>
<td>142</td>
</tr>
<tr>
<td>Changing current table type</td>
<td>145</td>
</tr>
<tr>
<td>Conditional highlighting</td>
<td>211, 314</td>
</tr>
<tr>
<td>Conditional highlighting for values</td>
<td>228</td>
</tr>
<tr>
<td>Copying the formatting of data items</td>
<td>136</td>
</tr>
<tr>
<td>Displaying detail data</td>
<td>235</td>
</tr>
<tr>
<td>Displaying query results in filtering and ranking</td>
<td>316</td>
</tr>
<tr>
<td>General properties</td>
<td>138</td>
</tr>
<tr>
<td>Headings</td>
<td>142</td>
</tr>
<tr>
<td>Incomplete</td>
<td>333</td>
</tr>
<tr>
<td>Inserting into report layout</td>
<td>134</td>
</tr>
<tr>
<td>List tables</td>
<td>133</td>
</tr>
<tr>
<td>Moving columns and rows</td>
<td>146</td>
</tr>
<tr>
<td>Number of columns and rows to display</td>
<td>139</td>
</tr>
<tr>
<td>Percent of total calculations</td>
<td>212, 223, 225</td>
</tr>
<tr>
<td>Removing</td>
<td>180</td>
</tr>
<tr>
<td>Removing all sorting</td>
<td>217</td>
</tr>
<tr>
<td>Resizing columns</td>
<td>147</td>
</tr>
<tr>
<td>Subheadings</td>
<td>142</td>
</tr>
<tr>
<td>Titles</td>
<td>138</td>
</tr>
<tr>
<td>Totals and subtotals</td>
<td>144, 212, 220</td>
</tr>
<tr>
<td>Unsynchronized objects</td>
<td>88</td>
</tr>
<tr>
<td>Templates</td>
<td>309</td>
</tr>
<tr>
<td>Naming report templates</td>
<td>55, 248, 249</td>
</tr>
<tr>
<td>Text</td>
<td>71</td>
</tr>
<tr>
<td>In headers and footers</td>
<td>74</td>
</tr>
<tr>
<td>Text, dynamic</td>
<td>65</td>
</tr>
<tr>
<td>In headers and footers</td>
<td>318</td>
</tr>
<tr>
<td>Text, formatting</td>
<td>318</td>
</tr>
<tr>
<td>In headers and footers</td>
<td>318</td>
</tr>
<tr>
<td>Text objects</td>
<td>71</td>
</tr>
<tr>
<td>Including in report sections</td>
<td>73</td>
</tr>
<tr>
<td>Removing</td>
<td>76</td>
</tr>
<tr>
<td>Working with</td>
<td>318</td>
</tr>
<tr>
<td>Tile charts</td>
<td>152</td>
</tr>
<tr>
<td>Assigning data items to properties specific to time categories</td>
<td>163</td>
</tr>
<tr>
<td>Time categories</td>
<td>92</td>
</tr>
<tr>
<td>Section filters for time zone, default</td>
<td>175</td>
</tr>
<tr>
<td>Time zone, default</td>
<td>28</td>
</tr>
<tr>
<td>Timestamp categories</td>
<td>92</td>
</tr>
<tr>
<td>Section filters for titles</td>
<td>110</td>
</tr>
<tr>
<td>Titles</td>
<td>164</td>
</tr>
<tr>
<td>In graphs</td>
<td>138</td>
</tr>
<tr>
<td>Totals</td>
<td>144, 220</td>
</tr>
<tr>
<td>Analysis and</td>
<td>219</td>
</tr>
<tr>
<td>Effects of drilling and expanding in tables</td>
<td>212</td>
</tr>
<tr>
<td>Relationship with subtotals and percent of totals</td>
<td>220</td>
</tr>
<tr>
<td>Showing or hiding for crosstabulation tables</td>
<td>221</td>
</tr>
<tr>
<td>Showing or hiding for list tables</td>
<td>221</td>
</tr>
<tr>
<td>Showing or hiding for multidimensional tables</td>
<td>222</td>
</tr>
<tr>
<td>U</td>
<td>88</td>
</tr>
<tr>
<td>Updating resources in reports</td>
<td>257</td>
</tr>
<tr>
<td>URLs, e-mailing for report definition snapshot</td>
<td>265</td>
</tr>
<tr>
<td>URLs, e-mailing for reports</td>
<td>267</td>
</tr>
<tr>
<td>User interface</td>
<td>11</td>
</tr>
<tr>
<td>V</td>
<td></td>
</tr>
<tr>
<td>Values in table columns or rows, aligning</td>
<td>147</td>
</tr>
<tr>
<td>View mode</td>
<td>13</td>
</tr>
<tr>
<td>Moving columns and rows in tables</td>
<td>146</td>
</tr>
<tr>
<td>Viewed reports</td>
<td></td>
</tr>
<tr>
<td>Dragging and dropping data items</td>
<td>46</td>
</tr>
<tr>
<td>Modifying data in</td>
<td>46</td>
</tr>
<tr>
<td>Navigating</td>
<td>42</td>
</tr>
<tr>
<td>Refreshing data in</td>
<td>46</td>
</tr>
<tr>
<td>Viewing</td>
<td></td>
</tr>
<tr>
<td>Archived reports</td>
<td>244</td>
</tr>
<tr>
<td>Data sources</td>
<td>40</td>
</tr>
<tr>
<td>Detail data in crosstabulation tables</td>
<td>303</td>
</tr>
<tr>
<td>Externally created reports</td>
<td>41</td>
</tr>
<tr>
<td>List of distributed reports</td>
<td>276</td>
</tr>
<tr>
<td>List of scheduled reports</td>
<td>295</td>
</tr>
<tr>
<td>Reports</td>
<td>33</td>
</tr>
<tr>
<td>Saved reports</td>
<td>34</td>
</tr>
<tr>
<td>Stored process reports</td>
<td>37</td>
</tr>
<tr>
<td>Summary of applied filters</td>
<td>45</td>
</tr>
<tr>
<td>W</td>
<td>282</td>
</tr>
<tr>
<td>Web pages, linking to</td>
<td></td>
</tr>
<tr>
<td>Welcome window</td>
<td>11</td>
</tr>
<tr>
<td>Z</td>
<td></td>
</tr>
<tr>
<td>Zooming</td>
<td></td>
</tr>
<tr>
<td>Effects of drilling and expanding on geographical maps</td>
<td>212</td>
</tr>
</tbody>
</table>

---

This table represents the index of a document, listing various effects, actions, features, and page numbers associated with them. The content is extracted from the document and formatted into a structured list to facilitate easy reference.