## Contents

*About This Book* .......................................................................................................................... ix  
*What's New in SAS Web Report Studio 4.2* .................................................................................. xi

### PART 1  Introduction to SAS Web Report Studio

**Chapter 1 • About SAS Web Report Studio** .................................................................................. 3  
Benefits to Using SAS Web Report Studio ...................................................................................... 4  
How Does SAS Web Report Studio Work? ...................................................................................... 4  
How Does SAS Web Report Studio Fit into the SAS Intelligence Platform? ................................. 5  
How to Get Help for SAS Web Report Studio ................................................................................. 5  
Accessibility Features of SAS Web Report Studio .......................................................................... 5

**Chapter 2 • Managing Access to SAS Web Report Studio** ............................................................. 9  
Access to SAS Web Report Studio Capabilities .............................................................................. 9  
Access to Reporting Resources ....................................................................................................... 10  
Log On to SAS Web Report Studio as a Registered User ................................................................ 10  
Log Off of SAS Web Report Studio .................................................................................................. 11

**Chapter 3 • The SAS Web Report Studio Interface** ........................................................................ 13  
Your First Look at the SAS Web Report Studio User Interface ...................................................... 13  
The SAS Web Report Studio Menus .................................................................................................. 15  
View Mode ....................................................................................................................................... 19  
Edit Mode ......................................................................................................................................... 21  
The Open Dialog Box ....................................................................................................................... 23

**Chapter 4 • Specifying Your Preferences** ..................................................................................... 29  
Specify Defaults for Opening and Saving Reports ........................................................................... 29  
Specify a Default Data Source, Style, Header, and Footer ............................................................... 30  
Specify a Default Time Zone ............................................................................................................. 32

### PART 2  Introduction to Viewing and Creating Reports

**Chapter 5 • Viewing Reports** ....................................................................................................... 37  
Overview of Viewing Reports ........................................................................................................... 37  
Viewing Reports Created in SAS Web Report Studio ...................................................................... 38  
Viewing Stored Process Reports ...................................................................................................... 41  
Viewing Data Source Reports .......................................................................................................... 44  
Viewing Externally Created Reports ................................................................................................. 45  
Navigating Viewed Reports .............................................................................................................. 45  
Modifying the Data in a Viewed Report ............................................................................................. 48  
Refreshing the Data in a Viewed Report ............................................................................................. 48

**Chapter 6 • Creating Reports** ....................................................................................................... 49  
Overview of Creating Reports .......................................................................................................... 49
Using a Quick Start Method to Create a Report .............................................. 49
Use Edit Mode to Create a Report ................................................................. 59
Save a Report ................................................................................................ 60

PART 3  Designing Layouts  63

Chapter 7 • Designing Headers and Footers ..................................................... 65
Overview of Creating a Header and a Footer for a Report Section ....................... 65
About Dynamic Text in Headers and Footers .................................................. 65
Create a Header or a Footer .......................................................................... 66
Remove a Header or a Footer ....................................................................... 67

Chapter 8 • Adding Images and Text ............................................................... 69
Overview of Using Images and Text ................................................................ 69
Place an Image in a Report Section ............................................................... 69
Include Text in a Report Section .................................................................. 71
Remove an Image or a Text Object ................................................................ 72

Chapter 9 • Including Stored Process Output ............................................... 73
Overview of Stored Processes ...................................................................... 73
Insert a Stored Process ................................................................................. 73
Remove a Stored Process ............................................................................. 75

Chapter 10 • Positioning Objects in the Layout Grid ........................................ 77
Overview of Positioning Report Objects ......................................................... 77
Add Cells to the Layout Grid ...................................................................... 78
Align Cell Content in the Layout Grid .......................................................... 78
Delete an Empty Column or Row from the Layout Grid .............................. 79
Delete Objects in the Layout Grid ............................................................... 79
Merge Cells in the Layout Grid .................................................................. 79
Place Objects in the Layout Grid ............................................................... 80
Reposition Objects in the Layout Grid .......................................................... 80

Chapter 11 • Using Synchronized or Independent Objects ............................ 81
Overview of Synchronized Filtering, Sorting, Drilling, and Expanding .......... 81
Maintain Independent Tables, Graphs, and Geographical Maps .................... 82

PART 4  Defining Queries and Displaying Results  83

Chapter 12 • Defining Queries to Obtain Results ......................................... 85
Overview of Queries Based on Data Items ................................................... 85
Using Standard Data Items in a Query ......................................................... 86
Using Custom Data Items in a Query ........................................................... 90
Modifying How a Data Item Is Formatted .................................................. 94
Modify How a Measure Is Aggregated ......................................................... 96
Use Detail Data Instead of Grouped and Aggregated Data ......................... 97
Preview or Export Query Results ............................................................... 98

Chapter 13 • Subsetting Query Results ......................................................... 101
Overview of Section Filters ....................................................................... 101
Creating Filters ......................................................................................... 102
# Contents

## PART 7  Appendixes  271

### Appendix 1 • Tips and Guidelines  273

- Naming Reports, Folders, and Templates  273
- Searching for Reports and Stored Processes  274
- Hiding Data Items  274
- Creating Section Filters  275
- Applying Conditional Highlighting  276
- Defining Prompts in Report Linking  277
- Filtering and Ranking Tables, Graphs, and Geographical Maps  277
- Using Reports Created with a Previous Version of SAS Web Report Studio  279

### Appendix 2 • Browsers and SAS Web Report Studio  281

- Browser Limitations  281
- Using Firefox with SAS Web Report Studio  281

### Appendix 3 • Data Refresh: Manual Versus Automatic  283

### Appendix 4 • Data Sources: Relational Versus Multidimensional  285

### Appendix 5 • What to Do If You Are Prompted for Credentials  287

- About the Request for Credentials  287
- Enter Credentials  287
- Remove Credentials  289
- What to Do If Access Is Still Denied  290

### Appendix 6 • What to Do If Your Data Source Is Invalid  291

- About Invalid Data Sources  291
- When a Data Source Has Been Moved or Renamed  291

### Appendix 7 • Incomplete Tables and Graphs  293

### Glossary  295

### Index  301
About This Book

Audience

SAS Web Report Studio is designed for the following users:

• Persons responsible for designing and creating Web-based reports for their enterprise.
• Persons responsible for analyzing report data and making decisions based on that data.

You might be assigned to a specific role, which determines which tasks you can perform. For more information, see “Access to SAS Web Report Studio Capabilities” on page 9.

SAS Web Report Studio enables you to view reports that are created by using a variety of other SAS products. This documentation focuses on tasks that you can perform on reports that were created by using SAS Web Report Studio.

Prerequisites

Prerequisites for Using SAS Web Report Studio

Here are the prerequisites for using SAS Web Report Studio:

• A user ID and password for logging on to SAS Web Report Studio.
• A supported browser installed on your desktop client.
• Access to data sources or stored processes that can be used to obtain data for reports. (These items are created in SAS applications other than SAS Web Report Studio.)

If you have questions about whether you are ready to use SAS Web Report Studio, contact your system administrator.
What's New in SAS Web Report Studio 4.2

Overview

New and enhanced features in SAS Web Report Studio include the following:

• improved user interface
• improved prompts and filters
• enhanced role-based settings
• updated report features
• updated graph features
• enhanced ability to distribute reports via e-mail
• improved support for totals based on multidimensional data
• enhanced multidimensional data source capabilities
• improved printing capabilities
• enhanced geographical map functionality

Improved User Interface

The following enhancements were made to the user interface:

• The updated user interface provides users with a more traditional desktop-like experience in the browser.

• You can drag a data source item from the new Data Source pane and drop it on tables and graphs. This new drag-and-drop support is also available in the Assign Data dialog box (for visual elements) and when you are re-sizing graphs.

• Support for partial Web page refresh has been added.

• Object menus are available by right-clicking, instead of having a toolbar attached to the top of the object.

• The Logon screen and Welcome window have been redesigned.

• The new left-side panel lets you select data and navigate the Table of Contents.

• A small progress indicator to the right of the View tab is visible until the last element in a report is rendered on a page.

• The File menu has replaced the Reports menu.

• Users can open data sources (information maps) directly from the Open dialog box and the File Management window for a quick view of data.
In View mode, depending on your assigned role, you might be able to add group breaks, change the data items used in the section query, and delete objects (for example, tables and graphs). You can also interact with invalid objects to make them valid.

A calendar is available in view and design mode for prompting, filtering, and report scheduling.

Support is available for chart tips, tooltips, and hyperlinks from rendered stored process graph output (previously stored process output was static).

Improved Prompts and Filters

The following enhancements were made for prompts and filters:

- Prompts can now be cascading and hierarchical for relational data.
- Prompts can now be dependent on other prompts so that selection lists are dynamic.
- Search is available in the Filter dialog box for prompts and filters.
- You can use data source (information map) filters and prompts for multidimensional data sources.
- Filters and prompts are no longer required to be case-sensitive.
- The order of prompts can be controlled.
- There can be multiple filter conditions for a single data item.
- You can filter numeric category data items by unformatted data values, which exposes new operators.
- Section filters have been improved. You can save but not apply custom filters and prompt names.
- Data source (information map) filters that are based on physical columns can display in SAS Web Report Studio.

Enhanced Role-Based Settings

SAS Web Report Studio ships with three predefined roles – Report Viewing, Report Creation, and Advanced. These roles manage the availability of application features, called capabilities. Your role and the capabilities you can access are defined by your system administrator.

If you migrate from a previous release of SAS Web Report Studio and you need additional capabilities for your role, contact your system administrator.

Updated Report Features

The following enhancements were made to reports:
• A new default report style, Plateau, is available for reports and replaces the former default style, Seaside. New reports use the Plateau style; however, legacy reports use the same report style that they were saved with in SAS Web Report Studio 3.1.

• There are color differences in the geographic hierarchy in a geographical map for the Seaside, Festival, and Meadow report styles. Formerly, there was a fixed color specification that was independent of the report style that was used. Now each report style, including Plateau, has its own three-color specification.

• You can link directly to a SAS stored process.

• There can be hyperlinks in stored process output for graphs.

• You can link to a specific report section either within the same report or within a section in another report.

• You can add and review comments in a report, depending on your settings.

• You can e-mail a link to a report. You can also include parameter values in a URL.

• You can call a report directly from a URL.

• There can be data-driven hyperlinks in tables. For graphs, the links display as data.

• The Save As feature no longer warns you about overwriting a file when it is the same as the source file.

• You can create a group break that contains analytic results (a stored process or stored processes) and specify that when the results execute, certain stored process parameters are filled in with the appropriate group break value.

• In View mode, you can repair invalid table and graph elements. For example, a graph typically requires both a measure and a category value. Suppose that your graph is missing a measure. While in View mode, you can drag a measure from the left-side data pane and drop it on the graph to make it valid. In the previous release, you could repair only invalid table or graph elements in design mode.

• You can now specify time zone preferences. For example, you can specify a time zone for dynamic dates.

---

**Updated Graph Features**

The following enhancements were made to graphs:

• You can add vertical and horizontal reference lines with annotations to charts.

• You can change colors used collectively in all graphs within a report.

• Conditional highlighting is also available for geographic maps.

• You can set a uniform scale for measures across group breaks.

• You can manually set a scale across group breaks.

• You can display a percentage for pie charts. You can also remove the "other" slice.

• You can have multiple lines, multiple bars, or both on a bar-line chart.

• Graph borders are turned off by default.
A new tile chart is available.

---

**Enhanced Ability to Send Reports via E-mail**

The following enhancements were made for distributing reports via e-mail:

- You can e-mail a URL link to a report.
- You can e-mail parameterized URLs for reports.

---

**Improved Support for Totals Based on Multidimensional Data Sources**

The following improvements were made for supporting totals:

- You can select parent values or visual totals.
- You can show the percent of visual totals or of parent values.
- Secure parent values are now supported.
- Totals can be positioned at the top, at the bottom, on the left side, or on the right side of a table element.
- You can total across hierarchies.

---

**Enhanced Multidimensional Data Source Capabilities**

The following enhancements were made for multidimensional data source capabilities:

- You can control the display of missing multidimensional values.
- You can filter on multidimensional member properties when they are available.
- You can isolate a multidimensional member.

---

**Improved Printing Capabilities**

The following enhancements were made for printing:

- You can now specify that page \( X \) of \( Y \) appear for reports that are printed.
- There are additional page fit options.
- You can specify that page numbers restart after each section.
- There is more flexibility for entering margin settings.
Enhanced Geographical Map Functionality

If geographical mapping is enabled for a multidimensional data source that is used in a report section, you can insert a map object into the layout of the report. You can now have multiple geographical maps per section, and you can link from a geographical map to another report or to an external URL. In addition, you can also select multiple parameter values to be passed to a linked report.
Part 1

Introduction to SAS Web Report Studio

Chapter 1
   About SAS Web Report Studio ................................. 3

Chapter 2
   Managing Access to SAS Web Report Studio ...................... 9

Chapter 3
   The SAS Web Report Studio Interface .......................... 13

Chapter 4
   Specifying Your Preferences ................................... 29
What Is SAS Web Report Studio?

In most organizations, many information consumers need reports from business data, but relatively few people understand the data structures necessary to build the reports. SAS Web Report Studio bypasses the need to understand complex data structures. SAS Web Report Studio provides an intuitive user interface that enables users at all technical skill levels to create, view, and explore centrally stored reports.

Easy querying
Specially prepared information maps (called data sources in SAS Web Report Studio) provide a metadata (information) layer between the nontechnical business user and the complexities of databases and query languages. Data sources contain data items, which can refer to calculations or physical data. Data items are described in common business terms that enable both casual and professional report authors to easily build queries that return consistent results. Reports can include query results from more than one data source.

Easy report design
The casual report author can use the five-step Report Wizard to design a basic report layout with one table and one graph. More advanced report authors can use the full-featured report editor to design more complex layouts, choosing from two different types of tables and seven different types of graphs. In addition, headers, footers, images, and text can be used to include corporate standards, confidentiality messages, and even...
hyperlinks in the report. Reports can contain multiple sections. Reports can be rendered
as needed for one-time use or stored in a common repository for personal or shared
access.

Easy analysis
Report authors can design reports that, by default, filter, rank, and highlight the query
results based on specified conditions. These features and more also are available to
report viewers, who can select options from menus and toolbars to customize the default
output. Additional options that can help you analyze report data include drilling and
expanding, sorting, and creating percent of total calculations.

Other basic reporting tasks include printing, copying, moving, and exporting. Advanced
tasks include scheduling reports to run at a specified time and distributing reports via e-
mail as a PDF attachment or as an embedded HTML file.

---

**Benefits to Using SAS Web Report Studio**

SAS Web Report Studio provides users with the following benefits:

Empowers business users by giving them self-service access to query and reporting
capabilities
SAS Web Report Studio includes functionality designed to fit your needs by providing
easy access to accurate information. The product interface enables you to create your
own queries and generate your own reports. You can also include on-demand analytical
results without having to create sophisticated statistical models.

Improves the business value of IT and the corporate data it manages
SAS Web Report Studio provides you with easy, self-service access to corporate data.
The risk of inconsistent results is eliminated, and business managers get reliable
information they can trust.

Saves money on training and support costs
SAS Web Report Studio is so simple that you can quickly become self-sufficient.
Minimal IT support is required for the product, and there is no need for extensive
training. Once you start using the product, you will no longer be dependent on the IT
staff to create reports for you. Even if you and your co-workers are in different
geographic locations, you get consistent results.

---

**How Does SAS Web Report Studio Work?**

SAS Web Report Studio is a Web application that anyone can use to view, interact, create,
and distribute both public and private reports. You can interactively get the information
you need without having to understand a programming language. In addition, SAS
predictive analytical results can be used by business professionals across the enterprise via
their Web browsers.

The Report Wizard enables novice users to quickly create and distribute basic queries and
reports based on either relational or multidimensional data sources in five easy steps. More
advanced users can use additional layout and query capabilities that are available, including
the ability to define custom calculations and complex filter combinations, multiple queries,
and SAS analytical results into a single document. A gallery of predefined layout choices
expedites the report creation process, and an extensive range of advance report components
enable users to create and interact with reports from their Web browsers. Reports and the application can be branded to match a corporate style.

Reports can be shared with others or kept in private folders based on security settings. Certain pages of reports can be distributed to authorized users via e-mail or a subscription channel.

**How Does SAS Web Report Studio Fit into the SAS Intelligence Platform?**

As an integral part of the SAS Intelligence Platform, SAS Web Report Studio leverages the analytical power of SAS by using the common SAS Open Metadata Architecture, which reduces administration tasks, and SAS Management Console, which grants access to reports and data. SAS Web Report Studio uses SAS Information Maps, which are a business view of data created by SAS Information Map Studio, so that you do not have to understand complex data structures and databases. At the same time, SAS Web Report Studio ensures that enterprise data is used consistently. SAS Web Report Studio can leverage the work of analytical SAS tools, such as SAS Enterprise Guide, which makes it easy for a wide range of users to access SAS analytical intelligence. SAS solutions, which are domain-specific applications that are built on the SAS Intelligence Platform, leverage SAS Web Report Studio for reporting.

**How to Get Help for SAS Web Report Studio**

There are two ways to access Help from within SAS Web Report Studio:

- Select Help ⇒ Contents or Help ⇒ Using this Window.
- Click Help, which is available from any SAS Web Report Studio dialog box or wizard page.

**Accessibility Features of SAS Web Report Studio**

**Overview**

SAS Web Report Studio 4.2 includes the following accessibility and compatibility features that improve usability of the product for users with disabilities. These features are related to accessibility standards for electronic information technology that were adopted by the U.S. Government under Section 508 of the U.S. Rehabilitation Act of 1973, as amended.

If you have questions or concerns about the accessibility of SAS products, send e-mail to accessibility@sas.com.

**Accessibility Features of the Supported Browsers**

Here are the supported Web browsers for SAS Web Report Studio 4.2:
Keyboard Navigation

Standard Keyboard Navigation
SAS Web Report Studio 4.2 can be navigated by using the keyboard. The following table includes some guidelines:

<table>
<thead>
<tr>
<th>Task</th>
<th>Keyboard Control</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move forward through controls</td>
<td>TAB</td>
</tr>
<tr>
<td>Move backward through controls</td>
<td>SHIFT+TAB</td>
</tr>
<tr>
<td>Display drop-down list contents</td>
<td>ALT+down arrow</td>
</tr>
<tr>
<td>Display menus when they have focus</td>
<td>down arrow</td>
</tr>
<tr>
<td>Activate buttons and menu selections</td>
<td>ENTER</td>
</tr>
<tr>
<td>when they have focus</td>
<td></td>
</tr>
<tr>
<td>Open a context menu</td>
<td>SHIFT+F10</td>
</tr>
</tbody>
</table>

Exceptions to Standard Keyboard Navigation
In the Select Data Source dialog box, to display the contents of a subfolder, press CTRL + up/down arrow to select the subfolder and then press the right arrow key.

Web Report Studio does not follow the Microsoft Windows standard for keyboard navigation of a tabbed window. When the focus is on a tab heading, pressing the Tab key, rather than moving focus into the content of the tab, moves it to the next tab heading. Once you have cycled through the tab headings, pressing the Tab key moves the focus to the content of the tab.

Skip Navigation
For ease of use with a screen reader, SAS Web Report Studio includes an invisible link that enables you to bypass navigation links and go directly to the unique content on the page. Navigation links that are skipped include the links for Preferences, Log Out, and Help.

When the screen reader announces that you are focused on the Skip Navigation link, press ENTER or the spacebar to activate the link.

When you select the Skip Navigation link in the Edit Report window, the page refreshes before the screen reader can focus on the focus point.
Using SAS Web Report Studio 4.2 with JAWS

Tables Used for Screen Layout
When tables are used for screen layout in some dialog boxes, JAWS reads the table dimensional information. To ensure that all fields are read, set your JAWS reader to read one row at a time and use the standard JAWS keystrokes for reading a table.

The Edit Field
When using the keyboard to navigate to the Edit field, JAWS repeats the last valid item that it was able to read before a header or a footer.

Navigate the Layout Grid in the Edit Tab
The Edit tab contains a grid for arranging objects in the body of the report section. The layout grid consists of cells into which you place report objects (tables, graphs, geographical maps, stored processes, text, and images).

Here are some keyboard shortcuts for navigating the layout grid:
• Press ALT+Y to move forward between the cells. When a cell has focus, press ENTER to select it.
• Press ALT+Q to navigate between report objects. When the object has focus, a pop-up context menu is available for other actions.

In general, use the standard TAB and SHIFT+TAB to move through the controls to perform actions on the selected cells and objects.

High Contrast and Custom Color Styles
There is intermittent support for high contrast and custom color styles in SAS Web Report Studio.
Chapter 2
Managing Access to SAS Web Report Studio

Access to SAS Web Report Studio Capabilities ........................................... 9
Access to Reporting Resources ................................................................. 10
Log On to SAS Web Report Studio as a Registered User ....................... 10
Log Off of SAS Web Report Studio .......................................................... 11

Access to SAS Web Report Studio Capabilities

Different users might have access to different functionality depending on their assigned roles. Roles are mapped to capabilities. A capability, also known as an application action, defines the operations a user can perform.

Here are some of the capabilities that are typically restricted to more advanced roles:

• creating new reports
• scheduling reports
• printing reports
• refreshing reports
• exporting reports
• distributing reports
• adding and editing recipient lists

SAS Web Report Studio ships with three predefined roles — Report Viewing, Report Creation, and Advanced. A predefined set of capabilities are available for each role. Using SAS Management Console, a system administrator can modify these roles and specify the capabilities that meet the guidelines for your company. They can also define new roles. If you have questions about your assigned role, contact your system administrator.

For more information about the roles and capabilities that are available, see the SAS Web Report Studio chapter in the SAS Intelligence Platform: Web Application Administration Guide.
Access to Reporting Resources

Your SAS Web Report Studio role controls which application behavior is available. Metadata security on individual objects (data, reports, folders, or even servers) controls access to those objects. For example, your role might enable you to perform the task of e-mailing reports, but you can e-mail only those reports to which you have been granted access. Here are two examples of how data security might affect what an individual SAS Web Report Studio user can see and do:

- In a report that includes employee information, two users in the same role might not see the same output. For example, a user in the human resources department might have access to a salary column that cannot be seen by a user in the sales department who views the same report.
- In a data source that contains information about medical procedures, a user with the capability to create new reports might not have access to the data item for patient names.

If you have questions about data security, contact your system administrator.

Log On to SAS Web Report Studio as a Registered User

To log on to SAS Web Report Studio, complete these steps:

1. To display the SAS Web Report Studio logon window, click on the URL that is supplied by your system administrator or paste it into the address field of your browser. For example, you might enter http://server01.abc.com:8080/SASWebReportStudio/
Display 2.1  Log On Window for SAS Web Report Studio

2. To log on, complete these steps:
   a. In the User name field, type your user ID.
   b. In the Password field, type the password for the user ID that you just entered.
   c. Click Log On.

   The Welcome to SAS Web Report Studio window is displayed (see “Your First Look at the SAS Web Report Studio User Interface” on page 13).

   Note: Your password is case-sensitive. Your user ID might be case-sensitive, depending on the operating system that is used to host the Web application server. If you need assistance, contact your system administrator.

---

Log Off of SAS Web Report Studio

To log off of SAS Web Report Studio, click Log Off in the upper right corner of the user interface.

Note: When you select log off, you will be logged off all environments, including the SAS OLAP server and other Web environments.

If you are prompted about unsaved changes, click OK to exit without saving or click Cancel to return to SAS Web Report Studio. In SAS Web Report Studio, select File => Save. If you are saving a new report, you are prompted to complete the Save As dialog box. Click Log Off again to exit.

If you lose your connection to SAS Web Report Studio (for example, you time out), then you must begin again at the point where you last saved your work. By default, if there is no activity for 30 minutes, then SAS Web Report Studio automatically logs you off and
displays the logon window. Your system administrator can change the inactivity period. As a best practice, save your work frequently.

The following is an example of the message that appears when your session has timed out:

**Display 2.2  Session Timed Out Message for SAS Web Report Studio**

![Session Timed Out Message](image)
Chapter 3
The SAS Web Report Studio Interface

Your First Look at the SAS Web Report Studio User Interface

When you log on to SAS Web Report Studio, you see the following Welcome window:
1. Click Log Off to exit SAS Web Report Studio.

2. Click Preferences to personalize your use of SAS Web Report Studio.

3. Select the Help menu to get help on using SAS Web Report Studio. For more information, see “How to Get Help for SAS Web Report Studio” on page 5.

4. Click New report to create a new report using the Edit tab. For more information, see “Edit Mode” on page 21.

5. Click New using Report Wizard to access the Report Wizard. The wizard guides you in defining a query; selecting a table and graph for the layout; and adding optional features such as group breaks, a header, and a footer. For more information, see “Use the Report Wizard” on page 51.

6. Click New using Template to access the Select a Template dialog box. When you select a template, you start creating your report with a predefined layout.

7. Click More Reports to access the Open dialog box. The Open dialog box enables you to search for reports, and it lists reports, stored processes, folders, and information maps. For more information, see “The Open Dialog Box” on page 23.

8. Click Open to access the Open dialog box. The Open dialog box enables you to search for reports, and it lists reports, stored processes, and folders. For more information, see “The Open Dialog Box” on page 23.

9. Click New to create a new report using the Edit tab. For more information, see “Edit Mode” on page 21.

10. Select the File menu to access task options, such as Open and Manage Files.
The SAS Web Report Studio Menus

About the Availability of Menus and Menu Selections

All of the following conditions influence whether a menu or menu selection is available to use:

- Your authorization. By default, you must be an advanced user to schedule reports. The options you have can also depend on settings that your system administrator has selected.
- Your location in the SAS Web Report Studio application. For example, some tasks are available only if you are viewing a report.
- The type of report that you are viewing. For example, you cannot synchronize a stored process report.
- The currently selected object. For example, you cannot change a bar chart to a crosstabulation table.
- Whether the section query has been defined. For example, if the section query has not been defined, then you cannot create a section filter.
- The type of data that is being used. For example, you cannot use detail data if the report section is using multidimensional data.
- Whether the report is saved. For example, you cannot distribute a report that has not been saved.

About the Report Menus

The report menus contain options that apply to the entire report or the currently displayed report section, including the objects in the section. Actions include creating a new report, adding a new section, refreshing data, and synchronizing a section. The report menus are available on the main menu bar when a report is displayed.

The File Menu

Here are the options on the File menu:

New
opens the Edit tab so that you can begin creating a new report.

New Using Wizard
launches the Report Wizard. You can use the Report Wizard to create a one-section report with one table and one graph.

New From Template
enables you to select a template to use as the basis for a new report. All sections in the template are used.

Open
opens the Open dialog box. From the Open dialog box, you can perform tasks such as viewing, copying, and moving reports; running stored processes; and creating folders.
Open Recent
enables you to open a report or information map that you have viewed recently. The last four reports and stored processes that were opened by the current user display. Your selection displays in the View tab.

Close
closes the open report and displays the Welcome window.

Save
saves the currently displayed report. If the currently displayed report exists, then Save overwrites the report. If the currently displayed report has not previously been saved, then the Save As dialog box opens.

Save As
opens the Save As dialog box, where you can enter information for a new report, change information for an existing report, save a report to a publication channel, or save a report as a template.

Export
exports the contents of the currently open report as a zipped file whose contents can be opened in a Microsoft Excel spreadsheet or a Web browser.

E-mail
enables you to e-mail a URL address to a saved report.

Comments
launches the Comment Manager, which lets you add comments to reports and graphs.

Page Setup
enables you to set defaults for printing options such as margins.

Print
displays the current report as PDF output that you can print.

Manage Files
opens the File Management window where you can perform operations on reports, such as renaming, deleting, scheduling, and exporting.

Properties
enables you to set or modify report properties such as the description, keywords, and the report style and to display filter information.

The Edit Menu
Here are the options on the Edit menu:

Sections
enables you to select Delete this Section, Rename this Section, or Reorder Sections.

Apply a Template
enables you to apply a selected template to the currently displayed report.

Header
enables you to create or edit a header for the currently displayed report.

Footer
enables you to create or edit a footer for the currently displayed report.

Delete
deletes the selected object.
Change Table to
enables you to change a list table to a crosstabulation table and vice-versa.

Change Graph to
enables you to change a selected graph to any other graph type except a tile chart or a geographical map.

Properties
enables you to set or modify report properties such as the description, keywords, and the report style and to display filter information.

The View Menu
Here are the options on the **View** menu:

**Section**
enables you to select the section that you want to display. Up to 15 sections are available from this menu selection. If there are more sections, then you can click **More** to open a dialog box that lists all the report sections.

**Applied Filters**
when this menu item is selected, View mode displays information about the currently applied filter.

**Data Panel**
enables you to select the report style that you want to use for the currently displayed report.

The Insert Menu
Here are the options on the **Insert** menu:

**New Section**
enables you to create a new section for the current report.

**List**
inserts a list table in the next available position in the currently displayed report section.

**Crosstab**
inserts a crosstabulation table in the next available position in the currently displayed report section.

**Graph**
inserts the selected graph or geographical map in the next available position in the currently displayed report section.

**Text**
inserts an empty text object in the next available position in the currently displayed report section.

**Image**
inserts an empty image object in the next available position in the currently displayed report section.

**Stored Process**
inserts an empty stored process object in the next available position in the currently displayed report section.
**The Data Menu**

Here are the options on the **Data** menu:

**Select Data**

enables you to select a data source and the data items to be used in the report.

**Summarization Options**

enables you to specify if and how the data should be aggregated.

**Format**

enables you to select the format for displaying the data (for example, the number of decimal places that are used when displaying a number).

**Preview Section Data**

enables you to preview or export the results of the currently defined query.

**Section Filters**

enables you to create a filter that will restrict the data that is returned from a query.

**Include Members with Only Missing Values**

enables you to include members from a multidimensional data source. (This menu item is available only for multidimensional data sources.)

**Edit Group Breaks**

enables you to specify group breaks for the current report.

**Independent Objects**

enables you to make the tables, graphs, and maps in the currently displayed report section independent of one another.

**Synchronized Objects**

enables you to synchronize the tables, graphs, and maps in the currently displayed report section. (You cannot synchronize a stored process report or a section in a saved report that contains stored process output.)

**Assign Data**

enables you to change how data items are used in a selected table, graph, or map.

**Totals**

enables you to turn total and subtotal values on or off for the selected table.

**Filter and Rank**

enables you to filter and rank the data shown in all table and graph types. This option is always available for synchronized sections. If the objects are independent, then this option is available only when a single object is selected.

**Conditional Highlighting**

enables you to create or modify rules for highlighting data in tables and graphs that meet your specified conditions.

**Report Linking**

enables you to create or modify a link from the currently selected object to another report or to a Web page.

---

**The Help Menu**

Here are the options on the **Help** menu:
Contents


Using this Window

displays a Help topic that is specific to the currently active feature.

Technical Support

displays the Support Web page that provides information on the available support resources.

Submit Feedback

displays the Make a Suggestion to SAS Web page for providing feedback about SAS software or services.

SAS Home

displays the SAS corporate home page.

About SAS Web Report Studio

displays copyright and other information about SAS Web Report Studio.

---

**View Mode**

*The View Mode Interface*

Depending on how the report creator designed the report, View mode might contain the following items:

- a header
- one or more tables
- one or more graphs
- one or more geographical maps
- one or more images
- one or more stored processes
- text
- a footer
- a table of contents (for reports with separate pages for group breaks)

Display 3.1 on page 20 is an example of a report displayed in View mode. The report contains query results from a multidimensional data source. The main features of this specific report and the View tab are identified.
1. Select the **File**, **View**, or **Data** menu items to access options that apply to the entire report or the currently displayed report section, including the objects in the section.

2. Use these icons to create a new report, open an existing report, save the current report, print the current report, or export the current report.

3. Authorized users can click the **Edit** tab to open the viewed report in Edit mode.

4. The **View** tab is on top when View mode is active.

5. This navigational box indicates the section that you are editing, as well as the total number of sections in the report. To view a different section, either enter a number in the box or select **View** ➤ **Section** and select the section that you want to open.

6. The body contains the report or stored process.

7. Use the **Section Data** panel to select data and to view an indicator of whether objects are independent or synchronized. This panel can be collapsed horizontally or vertically.

8. Use the **Table of Contents** panel to work with both sections and group breaks. Use the **Options** menu in Edit mode to switch between sections and navigate between group breaks. This panel can be collapsed horizontally or vertically.

In View mode, you can drag a data item from the **Section Data** pane and drop it on tables and graphs.

*Note:* Some reports and stored processes require that you answer prompts before their output is rendered.

**Summary: Seven Ways to Access View Mode**

There are seven ways to access View mode:

- Click **Open** on the SAS Web Report Studio Welcome window.
- Select a report name on the SAS Web Report Studio Welcome window.
- Select **File ➤ Open** to display the Open dialog box. Select an existing report and click **Open** to display it in the **View** tab.
Edit Mode

The Edit Mode Interface

Authorized users can access the Edit tab to create new reports or to edit existing reports. Note that some options in Edit mode are not available for reports and stored processes that come from SAS Enterprise Guide. The available options in Edit mode also depend on the type of report you are editing.

Here are some of the main features of the Edit tab and Edit mode.

Display 3.2 The Edit Mode Interface

1. Select the File, Edit, View, Insert, or Data menu items to access options that apply to the entire report or the currently displayed report section, including the objects in the section.
2. Use these icons to create a new report, open an existing report, or save the current report.
3. The Edit tab is on top when Edit mode is active.
4. Click View when you are ready to view the report.
5. This navigational box indicates the section that you are editing, as well as the total number of sections in the report. To view a different section, either enter a number in the box or select View ⇧ Section and select the section that you want to open.
6. Use this horizontal toolbar to insert objects (such as tables, graphs, geographical maps, stored processes, text, and images).
7. Click Header to enter header information for the report section. For more information, see Chapter 7, “Designing Headers and Footers,” on page 65.
8. The body of the report section consists of a grid for arranging objects such as tables, graphs, and images, and two toolbars (one above the grid and one to the left of the grid). For more information, see “Overview of Positioning Report Objects” on page 77.

The body of the report can also include stored process objects that are used to obtain data and layout information for the report section.

9. Click Footer to enter footer information for the report section. For more information, see Chapter 7, “Designing Headers and Footers,” on page 65.

10. Use the Section Data panel to select data and to specify whether objects are independent or synchronized. This panel can be collapsed horizontally or vertically. An Options menu enables you to select data and to specify whether the objects are synchronized or independent. You can also work with section filters. The Section Filters menu option is always available for relational data. The option is available for multidimensional data only if the filters were predefined in SAS Information Map Studio.

After you select the data items, a context menu is available. Depending on the type of data source, you can use this menu to specify the format and data item properties. You might also be able to select or define filters and change the default format.

For more information about defining a query that uses data items, see Chapter 12, “Defining Queries to Obtain Results,” on page 85.

11. Use this vertical toolbar to delete and align objects and to merge, split, and add cells to the layout grid.

12. Use the Table of Contents panel to work with sections. Use the Options menu to add new sections, switch between sections, and rename, delete, or reorder existing sections. This panel can be collapsed horizontally or vertically. For more information, see Chapter 3, “The SAS Web Report Studio Interface,” on page 13.

If you select data items from a data source to define a query for the report section, then you can specify group breaks for the report section. For more information, see Chapter 14, “Grouping Query Results,” on page 119.

In Edit mode, you can drag report and graph objects and drop them on the layout.

**Summary: Six Ways to Access Edit Mode**

There are six ways to access Edit mode:

- Click New report on the Welcome window.
- Click New using Report Wizard on the Welcome window. After at least one data item is selected, click Finish on any wizard page to access Edit mode.
- Click New using Template on the Welcome window to select a report template from a gallery and display it in the Edit tab.
- Click Edit when a report is displayed in View mode.
- Select File ⇒ Open to display the Open dialog box. Next to the name of a report, click in the Actions column, and then select Edit.
- From the Welcome window or while editing a report, click File ⇒ Manage Files to access the File Management window. Navigate to the report that you want to edit. Next to the name of a report, click in the Actions column, and then select Edit.
The Open Dialog Box

The Open Dialog Box as a Multitask Interface

About the Open Dialog Box
The Open dialog box enables you to search for and open saved reports, stored processes, and information maps. For more information about searching for reports, see “View a Saved Report” on page 38.

However, the Open dialog box also enables you to create new folders and perform many other tasks on selected reports and folders.

Note: You must have advanced permissions to copy, move, or delete multiple reports or folders. Contact your system administrator about permissions.

Display 3.3  Open Dialog Box with Search Field Expanded

Searching for Files Using the Open Dialog Box
You can search for files, reports, or data sources using the Open dialog box.
To search for files, complete these steps:

1. If the Search for files section is not visible in the Open dialog box, click ➤.

2. In the Search for field, type the text for which you want to search. For searching tips, see “Searching for Reports and Stored Processes” on page 274.

3. In the Search what drop-down list, choose whether you want to search for the text in the Name, Description, or Keywords field.
   
   Note: You cannot search the content of a report.

4. In the Search where drop-down list, select a folder name.

5. (Optional) To also search for reports in folders that are contained in the folder you are searching, select Search subfolders.

6. (Optional) To limit your search by time, select Search for Files Modified in the Date/time limits drop-down list. Specify the time frame by using the fields that are below the drop-down list.

7. Click Search.
   
   If there are any reports that match your criteria, they are shown.
   
   Note: After a search, the report list also includes Path information for each located report. To clear the search results, select an option in the Location drop-down list.

The following topics contain additional information about searching:

• “View a Saved Report” on page 38.
• “View a Stored Process Report” on page 41.

Navigating Locations Using the Open Dialog Box

The Open dialog box enables you can navigate to find the information map or report that you need. For example, you might need to navigate through multiple folders to find a report.

Click ➤ for the Location to see where the current folder is located in the tree structure.

Click ➤ to move up a folder level. In the following example, you are looking at the items in the Orion Star Sports folder after you have moved up one level.
Working with Folders in the Open Dialog Box

You can work with folders in the Open dialog box. The icons for folders are located to the right of the Location drop-down list, as shown in Display 3.5 on page 25.

<table>
<thead>
<tr>
<th>Button</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Folder Icon]</td>
<td>moves up one level</td>
</tr>
<tr>
<td>![Folder Icon]</td>
<td>creates a new folder</td>
</tr>
<tr>
<td>![Folder Refresh Icon]</td>
<td>refreshes the items in the current location</td>
</tr>
</tbody>
</table>

You can also create a new folder when you copy a report, move a report, or save a report. For more information about folders and shared locations, see “Overview of Shared Locations” on page 239.

Using the Actions Menu in the Open Dialog Box

To open the Actions menu, click ![Actions Icon]. The menu lists only those options that you are authorized to perform. The actions for folders are **Delete** and **Rename**.
Different actions are available for reports. The menu lists only those options that you are authorized to perform. Display 3.7 on page 27 shows some of the actions that might appear for reports.
Note: There are no **Actions** menu items for stored processes.

The **Edit**, **Copy**, **Delete**, and **Move** options are also available from the File Management window.

When you are working with an information map, the available actions are different from the ones available for reports. **Display 3.8 on page 28** shows an action that might appear for an information map.
There are four ways to access the Open dialog box:

- Click ![on the toolbar.
- Click **Open** on the Welcome window.
- Click **More Reports** on the Welcome window.
- Select **File** ⇒ **Open** on the Welcome window or in Edit or View mode to display the Open dialog box.
Chapter 4
Specifying Your Preferences

Specify Defaults for Opening and Saving Reports

To specify preferences for opening and saving reports, complete these steps:

1. Click Preferences in the right corner of the user interface to open the Preferences dialog box.

2. On the General tab, complete these steps:
   a. Under Open, specify the folder that is open by default when you access the Open dialog box or the File Management window. The default is Last folder used. If you choose Preferred folder, then select the folder.
   b. Under Save, specify the folder that you want selected by default in the Save As dialog box when you save a new report. The default is Last folder used. If you choose Preferred folder, then select the folder.
   c. Select one of the Save reports as options for new reports. By default, new reports are saved as automatically refreshed. You can change your preference for specific reports when you save them.

      Note: For more information, see “Data Refresh: Manual Versus Automatic” on page 283.

3. Click OK.

Your preferences are used the next time that you open or save a report.

Note: To restore all of the options on the General tab to their default settings, click Reset Defaults.

In Display 4.1 on page 30, these preferences are selected:

• from the Open dialog box or the File Management window, always display the contents of the last folder used.
• save all new reports in a preferred folder.
• save all new reports as manually refreshed.
Specify a Default Data Source, Style, Header, and Footer

To specify a default data source, style, header, and footer for new reports, complete these steps:

1. Click Preferences in the right corner of the user interface to open the Preferences dialog box.

2. On the Report Creation tab, complete these steps:
   a. Under Data source, specify the data source that you want to use. The default is Last data source used. If you choose Preferred data source, then select the folder.
   b. From the Report style drop-down list, select the default style for creating new reports. The style that you select affects the color and font text of report objects such as tables and graphs. The four styles that are shipped with SAS Web Report Studio are Plateau (the default), Seaside, Festival, and Meadow.

   Note: You can also use the Report Properties dialog box to change the style of an individual report. For more information, see “Modifying Report Properties” on page 227.
c. For the Section header and Section footer, select one or both of the following options. Header and footer preferences are used for all sections of a new report.

**Banner**
Select the name of the image that you want to include in the header or footer. The list contains images that have been prepared for you by your system administrator. If you do not want to include an image in the header or footer, then select None. (If your system administrator did not make any images available, then None is your only choice for Banner.)

**Text**
Type the static text that you want to include in the header or footer.

*Note:* For individual report sections, you can override header and footer preferences. For more information, see Chapter 7, “Designing Headers and Footers,” on page 65.

3. Click OK.
Your preferences are used the next time that you create a new report.

*Note:* To restore all of the options on the Report Creation tab to their default settings, click Reset Defaults.

**Display 4.2 Report Creation Tab**
Specify a Default Time Zone

Your time zone preference is used when SAS Web Report Studio performs an action that involves time. For example, when you save a new report, your preference is used to assign the date and time of its creation. Your preference is also used when a header or footer includes the dynamic text option called Date the data was last refreshed. The displayed refresh date and time are based on your preference.

To specify a default time zone, complete these steps:

1. Click Preferences in the right corner of the user interface to open the Preferences dialog box.

2. On the Time Zone tab, complete these steps:

   a. If the zone that you want to use is not in the Time zone drop-down list, then select the Choose from all possible time zones check box.

   b. From the Time zone drop-down list, select the time zone that you want to use. For example, you might select (GMT–8:00) Pacific Standard Time.

   c. From the Zone ID drop-down list, select one of the IDs that are available for the time zone that you specified. Each time zone has a list of associated IDs. Most of the zone IDs are in the form Area/Location, where Area is a continent, a country, or an ocean and Location is a major population area within the specific location. For example, if you select (GMT–10:00) Hawaii Standard Time as the time zone, then you might select (GMT–10:00) Pacific/Honolulu as the zone ID. Other zone IDs in the (GMT–10:00) Hawaii Standard Time zone include (GMT–10:00) Pacific/Johnson, (GMT–10:00) System/VHST10, and (GMT–10:00) US/Hawaii.

3. Click OK.

Your preferences are used the next time SAS Web Report Studio performs an action that involves time.

*Note:* Changing the time zone does not affect reports that you manually refresh.

In Display 4.3 on page 33, (GMT+08:00) Western Standard Time (Australia) is selected for the Time zone and the Zone ID drop-down list shows (GMT+08:00) Antarctica/Casey. The two other available zone IDs are (GMT+08:00) Australia/Perth and (GMT+08:00) Australia/West.
Display 4.3  Time Zone Tab with Preferences Specified
Part 2

Introduction to Viewing and Creating Reports

Chapter 5

Viewing Reports .......................................................... 37

Chapter 6

Creating Reports .......................................................... 49
Chapter 5
Viewing Reports

Overview of Viewing Reports

The output that can be displayed in View mode can be placed into these four report categories:

Saved Reports
Saved reports are created by completing the Save As dialog box in SAS Web Report Studio.

Stored Process Reports
When a stored process is opened directly, it is a stored process report.

Data Source Reports
Data source reports are ad hoc reports that use a crosstabulation table to present the results of a query that is based on three standard data items from a selected data source.
Externally Created Reports
SAS Web Report Studio enables users to view and, in some cases, modify reports that are created by using a variety of other SAS products, including SAS Web OLAP Viewer for Java and SAS Enterprise Guide.

This chapter explains how to view each type of report and includes sample output.

---

**Viewing Reports Created in SAS Web Report Studio**

**About Reports Saved in SAS Web Report Studio**

Reports in SAS Web Report Studio are saved when you use the Save As dialog box. A saved report contains at least one section. Typically, that section uses at least one query method (data items from a data source or a stored process). If data items are used, then the section has at least one view element (a table, graph, or geographical map) to display the results of the query.

A report might be automatically or manually refreshed, shared or private, or read-only (which means that only the report author can make changes to it). It might also be prompted (which means that users must answer prompts before the report is rendered).

**View a Saved Report**

To view a saved report, you can select one of the last six viewed reports from the **File** menu, use the Open dialog box, or use the File Management window.

To use the Open dialog box or the File Management window, complete these steps:

1. Perform one of these tasks:
   - Select a report from the Welcome window, which also shows the last six viewed reports. If you are editing or viewing a report, click **File ➔ Close** to display the Welcome window.
   - Select **File ➔ Open** to display the Open dialog box.
   - Click **File ➔ Manage Files** on the Welcome window or in either Edit or View mode.

   The Open dialog box and the File Management window contain a **Search for files** section.
2. Double-click the name of a saved report to open it in View mode. Next to the name of the report, you can also click in the Actions column and then select Edit. To search for a report, complete these steps:
   a. If the Search for files section is not visible, click .
   b. In the Search for field, type the text for which you want to search. For searching tips, see “Searching for Reports and Stored Processes” on page 274.
   c. In the Search what drop-down list, choose whether you want to search for the text in the Name, Description, or Keywords field.
      
      Note: You cannot search the content of a report.
   d. In the Search where drop-down list, select a folder name.
   e. (Optional) To also search for reports in folders that are contained in the folder you are searching, select Search subfolders.
   f. (Optional) To limit your search by time, select Search for Files Modified in the Date/time limits drop-down list. Specify the time frame by using the fields that are below the drop-down list.
   g. Click Search.
      
      If there are any reports that match your criteria, they are shown.
      
      Note: After a search, the report list also includes Path information for each located report. To clear the search results, select an option in the Location drop-down list.
3. If necessary, respond to prompts and then click View Report.
If the currently displayed report section includes output from a stored process, you can select Help → View Log to view a log for the stored process.

**Example Report: Product Group Revenue Contributions by Age**

Display 5.2 on page 40 provides information about product group revenue and includes percentage contributions by order channel, gender, and age group. Exceptional conditions are highlighted for product group and age group combinations for a given channel where the revenue contribution is less than 5% or greater than 8%. This information could be used, for example, to decide which age groups to target for a promotional offering.

**Display 5.2  Example of a Saved Report That Contains Query Results From a Data Source**

For both multidimensional and relational data, you can hide a data item from the table or graph. For example, in the company report above, the data item for `Year-quarter-month` is hidden. You can hide data items using the Assign Data dialog box.
Viewing Stored Process Reports

About Stored Process Reports

A stored process is a SAS program that is stored on a server and that can be executed as requested by client applications such as SAS Web Report Studio. The embedded SAS code can contain instructions for rendering report elements as part of a larger report or for rendering a complete report that includes queries, prompted filters, titles, images, and statistical analyses. When a stored process is viewed directly in SAS Web Report Studio, it is a stored process report. Stored process reports contain only one section and are automatically refreshed. All users can run a shared stored process.

Note: Stored processes can also be included as part of a larger saved report. For more information, see Chapter 9, “Including Stored Process Output,” on page 73.

A stored process might be prompted, which means that users must answer prompts before the report is rendered. Authorized users can schedule a stored process report.

View a Stored Process Report

To run a stored process, you can select one of the last four viewed stored processes from the File menu, use the Open dialog box, or use the File Management window.

Note: Your data source administrator determines what data you are authorized to view.

To use the Open dialog box or the File Management window, complete these steps:

1. Perform one of these tasks:
   - Select File ➔ Open to display the Open dialog box.
   - Click File ➔ Manage Files on the Welcome window or in either Edit or View mode.
The Open dialog box and the File Management window contain a Search for files section and a list of reports, stored processes, and folders.

Display 5.4 The File Management Window with Stored Processes Listed

2. Double-click a stored process to view it. To search for a stored process, complete these steps. For searching tips, see “Searching for Reports and Stored Processes” on page 274.
   a. If the Search for files section is not visible, click the Search for files button.
   b. In the Search for field, type the text for which you want to search.
   c. In the Search what drop-down list, choose whether you want to search for the text in the Name, Description, or Keywords field.
      
      Note: You cannot search the content of a stored process.
   d. In the Search where drop-down list, select a folder name.
   e. (Optional) To also search for stored processes in folders that are contained in the folder you are searching, select Search subfolders.
   f. (Optional) To limit your search by time, select Search for Files Modified in the Date/time limits drop-down list. Then specify the time frame by using the fields that are below the drop-down list.
   g. Click Search.

      If there are any stored processes that match your criteria, they are shown.
      
      Note: After a search, the list also includes Path information for each located stored process. To clear the search results, select an option in the Location drop-down list.

3. If necessary, respond to prompts and then click View Report.

4. (Optional) To view a log for the stored process, select Help ⇒ View Log.

Example Report: Sales Forecast for Orion USA

The following example of a stored process report uses the predictive capabilities of SAS to give executives a glimpse into the company's financial future. After the user enters preferences for the country, forecast variable (cost, profit, or sales), and the number of months to forecast, SAS Web Report Studio displays a line plot by month, including...
confidence intervals, and a supporting list table with values for the year, month, actual sales, forecast, lower 95%, and upper 95%. The prompt window for this stored process is shown in Display 5.5 on page 43.

**Display 5.5  Prompt Window for the Stored Process Report Shown in Display 5.6**

**Display 5.6  Example of Stored Process Report**

Example Report: Sales Forecast for Orion USA

TIP Some stored process reports might support chart tips, tooltips, and drilling. Chart tips contain data details and appear when you move the mouse over particular areas on a graph. For example, moving the mouse over the bars in a bar chart displays the data values associated with the bars. A tooltip is a small pop-up informational element displayed when the user positions the mouse over a chart element. Stored process output can include hyperlinks.
Other than changing prompt values, you cannot modify the output of a stored process from within SAS Web Report Studio. For information about how to insert a stored process into a report, see “Insert a Stored Process” on page 73. If you insert a stored process into a report, you can perform some layout design tasks that are independent of the stored process report. For example, you can add images, headers, and footers.

---

### Viewing Data Source Reports

**About Data Source Reports**

Data source reports are ad hoc reports that use one crosstabulation table to present the results of a query that is based on the first two categories or hierarchies and the first measure in a selected data source. Data source reports contain only one section and are automatically refreshed. If the selected data source is multidimensional, then the report section is synchronized.

**View a Report Based on Ad Hoc Output From a Data Source**

To view a report based on ad hoc output from a data source, complete these steps:

*Note:* Your data source administrator determines what data you are authorized to view.

1. Double-click an information map in the Open dialog box. The new report opens in View mode.

   ![Example of a Data Source Report Based on a Multidimensional Data Source](image)

2. Select **File ➤ Save**. For information about how to complete the Save As dialog box, see “Save a Report” on page 60.
Viewing Externally Created Reports

SAS Web Report Studio enables users to view and, in some cases, modify reports that are created by using a variety of other SAS products, including SAS Web OLAP Viewer for Java, SAS Output Delivery System (ODS), and SAS Enterprise Guide. You view a shared, externally created report in the same way that you view a saved report.

There is no definitive list of default features for an externally created report because the features depend on the application that was used to create the report. Some externally created reports support the same features as a saved report. Other reports, such as those created by using SAS Enterprise Guide or ODS, cannot be modified, although report authors can use SAS Web Report Studio to add new sections. The added sections will support the standard editing features.

SAS Web Report Studio 4.2 supports the ability to open PDF output that is generated from ODS.

*Note:* A report generated from ODS is different than the reports that are created by SAS Web OLAP Viewer for Java and SAS Enterprise Guide.

SAS Web Report Studio opens PDF output from ODS in a separate window. However, HTML output from ODS, which is similar to output from SAS Web OLAP Viewer for Java and SAS Enterprise Guide, opens in a SAS Web Report Studio window.

You can access PDF output from ODS by using either the Open dialog box or the File Management window in SAS Web Report Studio.

*Note:* This documentation focuses on tasks that you can perform on reports that are created by using SAS Web Report Studio.

Navigating Viewed Reports

**About Navigation Features**

A report might have these navigation features:

- Group breaks divide report sections by distinct category or hierarchy level values. A table of contents is available for navigation.
- A report might be divided into one or more sections. Each section can use a different query method and have a different layout.
- A report might include links to another report or to a Web page.

**Use the Table of Contents**

To collapse the Table of Contents pane, click . Display 5.8 on page 46 is an example of a collapsed Table of Contents pane.
Display 5.8  A Collapsed Table of Contents Pane

To expand the Table of Contents pane, click ⬇️.

To collapse both the Table of Contents and the Section Data panes, click ⬅️. Display 5.9 on page 46 is an example of collapsed Table of Contents and Section Data panes.

Display 5.9  Collapsed Table of Contents and Section Data Panes

To expand both the Table of Contents and the Section Data panes, click ➤️. Display 5.10 on page 47 is an example of expanded Table of Contents and Section Data panes.
If you view a different section and then return to a section that contains group breaks, SAS Web Report Studio displays the most recently viewed group break category.

**View Different Report Sections**

A report can be divided into one or more sections. Each section can use a different query method and have a different layout. To view a report section, complete either of these tasks:

- Use the navigational box in the right corner. Enter a number in the box to change sections.
- Select View ➞ Section and then select the section that you want to open.

If you return to a previously viewed section that contains group breaks, SAS Web Report Studio displays the most recently viewed group break category.

**Follow Links to Other Reports or to a Web Page**

Reports, stored processes, tables, graphs, geographical maps, images, or pieces of text can contain links. If linkable, text or the data cells in a table are underlined. For graphs, you must know whether the markers are linked or not. You also must know whether there is a link in a geographical map.
Note: The links in a stored process cannot be created in SAS Web Report Studio. The links have to be added when the stored process is created in another product, such as SAS Enterprise Guide.

When you follow a link, to another report or to a Web page, the way they display is different. If the report contents open in the same browser window, there will be a link to return to the source report. However, a Web page will open in a new browser window, so there will not be a button or link to return to the source report.

For additional information, see Chapter 25, “Linking Reports,” on page 251.

---

### Modifying the Data in a Viewed Report

You can modify the data in a report that you are viewing. You can drag a data item from the Section Data pane and drop it on tables and graphs. Or you can complete these steps:

1. Select either **Data ⇒ Select Data** or **Options ⇒ Select Data** to open the Select Data dialog box.
2. Add or remove data items from the **Selected data items** list.
3. Click **OK**.

**Note:** Modifications to the data do not change the underlying report unless you have permissions to save over the original report.

For information about working with data items, see the following topics:

- “Specifying How Data Items Are Used in Tables” on page 127.
- “Move Columns and Rows in Tables in the View Mode” on page 135.
- “Specifying How Data Items Are Used in Graphs” on page 144.

---

### Refreshing the Data in a Viewed Report

The data in a report can be refreshed manually or automatically, depending on how the report was saved. For more information, see “Data Refresh: Manual Versus Automatic” on page 283.

Refresh the data in a viewed report when

- you want to change your prompt values. For example, you have been analyzing a report with prompted values for the Southeast region, but now you want to look at the Northeast region.
- you want an updated view of data for a report that contains a static snapshot of data.
- you suspect that the underlying data has changed since you viewed the report. Note that the values will not change if the underlying data source has not been updated.

To manually refresh the data in a report that you are viewing, select **Data ⇒ Refresh**. This refreshes the data in all report sections.
Chapter 6
Creating Reports

Overview of Creating Reports

This chapter explains the main steps required to perform the following tasks:

- Use a quick start method to create a report.
- Build a report by making selections in the Edit tab.

Detailed steps for creating reports are explained in the following chapters:

- Chapter 9, “Including Stored Process Output,” on page 73.
- Chapter 15, “Displaying Query Results in a Table, Graph, or Geographical Map,” on page 123.

Using a Quick Start Method to Create a Report

About the Quick Start Methods

There are five quick start methods for creating a new saved report. Table 6.1 on page 50 provides an overview of the advantages and considerations for each quick start method.

Note: For more information about saved reports, see “About Reports Saved in SAS Web Report Studio” on page 38.
When reviewing the considerations, keep in mind that you can use Edit mode to make modifications until the report is exactly the way that you want it.

### Table 6.1 Advantages and Considerations for Each Quick Start Method

<table>
<thead>
<tr>
<th>Quick Start Method</th>
<th>Advantages</th>
<th>Some Considerations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use the Report Wizard</td>
<td>The easy-to-use, five-step Report Wizard guides you in defining a query, selecting a table and graph for the layout, and adding optional features such as group breaks, section filters, a header, and a footer. You can also select the format for displaying the data (for example, the number of decimal places that are used when displaying a number). When you click Finish, you have a complete, one-section report. Because the resulting report is based on a data source, you have full access to all the report objects (tables, graphs, geographical maps, group breaks, headers, footers, images, and text).</td>
<td>You can choose only from three graph types (bar, line, and pie).</td>
</tr>
<tr>
<td>Open a stored process as a report</td>
<td>When you include a stored process in a report, you can use Edit mode to add a header, a footer, images, and text that are independent of the stored process. The result can be a much more robust report than just the stored process report itself.</td>
<td></td>
</tr>
<tr>
<td>Use a template for the layout and then add the data</td>
<td>When you select a template, you start creating your report with an already completed layout design. The layout can include the following:  • tables, graphs, images, text, and their last saved properties  • links from images and text to Web sites and reports  • a header and a footer  • stored process objects (without the stored process selected)  • positioning information  In addition, templates can contain multiple report sections, each with a unique design.</td>
<td>• You must define the query that will retrieve the data for the report.  • You must specify any group breaks.  • A layout design that exactly meets your needs might not be available. In this case, you can create your own template (or templates).</td>
</tr>
<tr>
<td>Save a report based on an information map</td>
<td>When you save a report based on an information map, you create a new report simply by selecting an information map. Because the resulting report is based on a data source, you have full access to all the report objects (tables, graphs, geographical maps, group breaks, headers, footers, images, and text).</td>
<td>• You do not choose the data items used in the default query (which includes only standard data items).  • You do not have any input into the default layout design.</td>
</tr>
</tbody>
</table>
**Quick Start Method**

| Base the new report on an existing report | If there is an existing report that closely meets your requirements, you might only have to make minor changes to the query and the layout to create a new saved report. The existing report might have multiple report sections. | Some changes might result in the loss of some existing functionality, such as conditional highlighting. If too many adjustments need to be made, it might be easier to create a custom report. |

* Images can include links from group break values to prompts in a target report; however, prompt associations cannot be saved in a template because templates cannot contain group break information.

---

**Use the Report Wizard**

The Report Wizard guides you through five steps to create a one-section report that uses standard data items.


2. Select a **Data Source**. The default data source is determined by the selection on the **Report Creation** tab in the Preferences dialog box. You can click **Change Source** to select a different data source.

3. Select the data items that you want to use in the report. In the **Available data items** box, select one or more data items and click ▶ to move them to the **Selected data items** box. To move all data items in the data source, click ▶.

**Display 6.1  Step 1 in the Report Wizard**

4. Click **Next** to go to the next wizard page.

**TIP** At this point, instead of clicking **Next**, you can click **Finish** to display the **Edit** tab. Defaults are used for any remaining unspecified required content. For example, if you are using a relational data source, a list table is automatically included. For
more information about how to save the report at this point, see “Save a Report” on page 60.

5. (Optional) Select or create a category filter. For more information, see Chapter 13, “Subsetting Query Results,” on page 101.

6. (Optional) Change the format of some data items. For more information, see “Modify the Format of a Standard Data Item” on page 94.

Display 6.2  Step 2 in the Report Wizard

7. Click Next to go to the next wizard page.

8. (Optional) To create group breaks, complete these steps:
   a. From the first Break by drop-down list, select a category or hierarchy to specify the first group break.
   b. If you want the report to display a new page for each value in the first break, select New page for each value.
   c. Specify up to two more breaks.
   d. If you want labels to appear with each value, then select the Label each value option.
9. Click **Next** to go to the next wizard page.

10. Add at least one view element to display the results of the query, either a table or a graph (a bar chart, a line graph, or a pie chart). The data items that you selected in step 1 are shown as selected to display. Either accept the default data item assignments or deselect the **Show** check box to hide the data items that you do not want to display.

- If you select the **Table** option, select the type of table. If your data source is multidimensional, then your only option is **Crosstab**.
- If you select the **Graph** option, select the type of graph.
11. Click **Next** to go to the next wizard page.

12. **(Optional)** To add a header or a footer, complete these steps for each feature that you want to include in your report:
   
a. From the **Banner** drop-down list, select an image to use for the banner. The images that are available are provided by your system administrator. If there are no images available, then your only selection is **None**.

b. Type the text that you want to include in the header or footer. You cannot use these characters: `< > & #`

c. To include the date that the section query was last run, select **Display date that query was last refreshed**.
13. Click **Finish** to display the report in the **Edit** tab.

14. Select **File** $\Rightarrow$ **Save**. For information about how to complete the Save As dialog box, see “Save a Report” on page 60.

15. Click the **View** tab to see the results.

**Display 6.6  A Completed Report from the Report Wizard**
Base a New Report on a Stored Process Report

To save a new report from a stored process report, complete these steps:

1. Run a stored process by selecting one of the last six viewed stored processes from the File menu or the Welcome window, using the Open dialog box (shown) or using the File Management window.


Display 6.7  Open Dialog Box Showing Two Stored Processes

2. If a prompt window appears, provide the requested information, and then click View Report.

3. Select File → Save. For information about how to complete the Save As dialog box, see “Save a Report” on page 60.

   Note: By completing the Save As dialog box, you create a new saved report, either with the same name as the stored process or with a new name. The original stored process continues to exist in addition to the new saved report.

For more information about saved reports that use stored processes, see Chapter 9, “Including Stored Process Output,” on page 73.

Base a New Report on a Report Template and Then Add Data

Report templates can contain more than just report objects placed in certain positions. Properties and, in some cases, linking can also be part of a template. In addition, templates
can contain multiple report sections, each with a unique layout design. To create a saved report by using a template, complete these steps:

1. Select **File ➔ New ➔ New Using Template**. You can also select **New using Template** on the Welcome window. Templates can have multiple sections. If you use this method to start building a new report, then all sections from a template containing multiple sections are used.

2. Click one of these tabs:
   - **General templates**
     Select this tab to use the default templates that come with SAS Web Report Studio.
   - **Shared templates**
     Select this tab to use the templates that can be viewed and used across your company.
   - **My templates**
     Select this tab to use the templates that can be viewed only by you and your system administrator.

3. Select a template.

*Display 6.8  How the General Templates Tab Appears in the Select a Template Dialog Box*

4. Click **OK**. Your selected layout is displayed in the **Edit** tab. *Display 6.9 on page 58* is an example of what Edit mode looks like if you select the Table over graph template.
5. Define the query by selecting data items from a data source. For more information, see Chapter 12, “Defining Queries to Obtain Results,” on page 85.

6. Select File \(\Rightarrow\) Save. For more information about how to complete the Save As dialog box, see “Save a Report” on page 60.

**T I P** You can also apply a template to a report section when you are in Edit mode. However, when you apply a template to a report section, only the first section in the template is used.

**Base a New Report on Ad Hoc Queries From an Information Map**

A new report based on ad hoc output from an information map uses one crosstabulation table to present the results of a query that is based on three standard data items from a selected information map. To create a report from an ad hoc query of an information map, complete these steps:

1. Double-click an information map in the Open dialog box. The new report opens in View mode.

**Display 6.10 A New Report Based on Ad Hoc Output from an Information Map**

2. Select File \(\Rightarrow\) Save. For more information about how to complete the Save As dialog box, see “Save a Report” on page 60.

To create a saved report from ad hoc output from an information map using Edit mode so that you can make changes, complete these steps:
1. Select an information map in the Open dialog box, click ✉️ in the Actions column and then select Edit. If the report was opened in View mode, then click the Edit tab.

2. In Edit mode, make any customizations that you want. For example, you might want to add a header or a footer.

   Display 6.11  A New Report Based on Ad Hoc Output From an Information Map in Edit Mode

3. Select File ⇨ Save. For information about how to complete the Save As dialog box, see “Save a Report” on page 60.

---

**Base a New Report on an Existing Report**

If there is an existing saved report that closely matches the report that you want to create, you can save the existing report under a new name, which is the only step that is required to create a new saved report. However, you will probably want to use Edit mode to make some customizations.

1. View the existing saved report by doing the following.
   - Select File ⇨ Open Recent and then select the report.
   - Use the Open dialog box.
   - Use the File Management window.

2. If a prompt window appears, provide the requested information, and then click View Report.

3. Select File ⇨ Save As and complete the Save As dialog box, giving the report a new name. For more information, see “Save a Report” on page 60.

---

**Use Edit Mode to Create a Report**

To create a new report from scratch, select File ⇨ New to access Edit mode. At this point, you must choose your data source and design the layout of the new report.
You can perform most of the required tasks in either Edit or View mode. Tasks that are specific to Edit mode include linking reports, positioning objects (such as tables, graphs, geographical maps, and images) and working with the layout grid (for example, splitting and merging cells). For differences between using the two modes, see “Your First Look at the SAS Web Report Studio User Interface” on page 13.

You can drag report and graph objects and drop them on the layout.

The steps for defining queries and designing layouts are explained in the following chapters:

- Chapter 8, “Adding Images and Text,” on page 69.
- Chapter 12, “Defining Queries to Obtain Results,” on page 85.
- Chapter 14, “Grouping Query Results,” on page 119.
- Chapter 15, “Displaying Query Results in a Table, Graph, or Geographical Map,” on page 123.

**Save a Report**

Note: In addition to enabling you to save automatically or manually refreshed reports, the Save As dialog box is also used to save report templates (see “Creating Report Templates” on page 225) and static content that can be published to a publication channel (see “Publish a Report to a Publication Channel” on page 241).

To save a report, complete these steps:

1. Select File ⇒ Save. If you are saving a new report, then the Save As dialog box is displayed.
2. For new reports, type a **Name**. For information about valid names, see “Naming Reports, Folders, and Templates” on page 273.

If you are saving an existing report, then the name of that report is listed here. You can either leave the name as it is and overwrite the existing report, or you can change the name to create a new report.

3. From the **Type** drop-down list, select either **Data is automatically refreshed** or **Data can be manually refreshed**. Automatically refreshed reports always include the most current data in the underlying data source that the viewer is authorized to see. Manually refreshed reports can be archived and usually render more quickly than automatically refreshed reports.

For more information about these options, see “Data Refresh: Manual Versus Automatic” on page 283 and “Publish a Report to a Publication Channel” on page 241.

4. Navigate to a **Location**. To create a new folder, click **New**. For more information about the folder options, see “Overview of Shared Locations” on page 239.

5. (Optional) Type a report **Description**. Report descriptions can be displayed in the Open dialog box and the File Management window. Users can search for reports with specified text in the description. You cannot use these characters: `< > & #

6. (Optional) Type **Keywords**. Users can view the report keywords in the Open dialog box or the File Management window before they view the report. They can also search for reports with specified text in the keywords. Separate each keyword with a comma.

You cannot use these characters: `< > & #

7. (Optional for manually refreshed reports) Select **Retain previous instance of output not to exceed**, and then type the number of archived reports that you want to maintain.

*Note:* The ability to archive reports is an advanced feature. You might be authorized to save reports but not to archive reports. For more information, see “Archiving Reports” on page 221.
8. (Optional) Select the **Automatically replace if file already exists** option if you want to replace an existing report without being prompted to confirm this action.

9. (Optional) Select the **Make read-only** option to prevent other users (including administrators) from deleting, modifying, renaming, or moving this report. (You can still perform these actions on your own report.)

10. Click **OK**.

In the following example, the new report is saved in a folder called **Orion Star sports**. The **Automatically replace if file already exists** and **Make read-only** options are also selected.

*Display 6.14  How the Save As Dialog Box Appears with Two Options Selected*
Part 3

Designing Layouts

Chapter 7  
*Designing Headers and Footers* ................................................. 65

Chapter 8  
*Adding Images and Text* ......................................................... 69

Chapter 9  
*Including Stored Process Output* ............................................. 73

Chapter 10  
*Positioning Objects in the Layout Grid* ....................................... 77

Chapter 11  
*Using Synchronized or Independent Objects* ............................... 81
Chapter 7
Designing Headers and Footers

Overview of Creating a Header and a Footer for a Report Section

You can use headers and footers to include corporate standards, such as logos and text that indicates confidentiality, in your reports. As a global preference, you can choose an image and static text to appear in every section of all new reports that you create.

You can also override the global settings for individual report sections. Additional header and footer features that are available for individual sections include the following:

- dynamic text such as the date that the report was last refreshed
- dividing lines
- the ability to change the font, font size, font style, background color, foreground color, and paragraph alignment

This chapter discusses how to create a header and a footer for an individual report section in Edit mode.

Note: For more information about how to set global preferences, see Chapter 4, “Specifying Your Preferences,” on page 29.

About Dynamic Text in Headers and Footers

A dynamic item is a placeholder for text that will be generated from data when the report is viewed. You can include dynamic text in a header or a footer, which enables you to include information such as the name and description of the data source that is supplying the data for the report, the date that the report was last refreshed, and the report author.

Table 7.1 on page 66 provides more information about each of the dynamic text choices.
Table 7.1  Dynamic Text Options and Examples

<table>
<thead>
<tr>
<th>Dynamic Text</th>
<th>Information Displayed</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data source name</td>
<td>The name of the relational or multidimensional data source that is being used to provide data for the tables, graphs, and maps in the report section. The dynamic text option does not provide the data source name for a stored process.</td>
<td>OrionStarOrders</td>
</tr>
<tr>
<td>Data source description</td>
<td>If available, the description of the relational or multidimensional data source that is being used to provide data for the tables, graphs, and maps in the report section. The dynamic text option does not provide the data source description for a stored process.</td>
<td>Performance information for Orion customers from 2003 to 2008. Includes sales revenue and costs for geographic, product, time, and customer demographic breakdowns. Created for Sales and Marketing.</td>
</tr>
<tr>
<td>Date the data was last refreshed</td>
<td>The date and time that the query for data was last sent to the underlying source of data.</td>
<td>Wednesday, February 20, 2008 3:07:57 PM GMT−05:00</td>
</tr>
<tr>
<td>Report author</td>
<td>If available, the name of the report author. Otherwise, the user ID of the report author is used.</td>
<td>Marcel Dupree</td>
</tr>
<tr>
<td>Report date</td>
<td>The date and time that the report was last saved.</td>
<td>Wednesday, February 20, 2008 1:42:46 PM EST</td>
</tr>
<tr>
<td>Report description</td>
<td>If available, the description of the report.</td>
<td>Provides U.S. management with a high-level view of delivery performance across all products.</td>
</tr>
<tr>
<td>Report name</td>
<td>The name of the report.</td>
<td>Delivery Performance for US Gold Customers in 2008</td>
</tr>
</tbody>
</table>

Create a Header or a Footer

For an individual report section, a header and a footer can contain a banner image, static text, dynamic text, and a dividing line. All content is optional. To create a header or a footer, complete these steps:

1. Perform one of these tasks:
   - Click **Header** and select **Edit** to open the Edit Header dialog box.
   - Click **Footer** and select **Edit** to open the Edit Footer dialog box.

2. Select the name of an image in the **Banner** drop-down list and specify an alignment.
3. Enter text into the **Text** field. You can type static text, you can select from the **Dynamic Text** drop-down list, or you can use a combination of both methods.

If you use the **Dynamic Text** drop-down list, click **Insert** to insert the selected text. For more information, see “About Dynamic Text in Headers and Footers” on page 65.

**TIP** After inserting a dynamic text item, type at least one character or space before inserting another dynamic text item.

4. Use the formatting tools to change the font, font size, font style, background color, foreground color, and alignment.

**TIP** Press ENTER between each paragraph. Text alignment is applied to the currently selected paragraph.

5. (Optional) Perform one of these tasks:
   - For a header, select the **Include a horizontal line between the header and report content** check box.
   - For a footer, select the **Include a horizontal line between the footer and report content** check box.

6. Click **OK**.

**Note:** To collapse the **Header** or **Footer** section, click 🎧. Collapsing the header, footer, or both in Edit mode does not change how the header or footer displays in View mode.

---

**Remove a Header or a Footer**

To remove a header or a footer from a report, complete these steps:

1. Perform one of these tasks:
   - Click **Header** and select **Edit** to open the Edit Header dialog box.
• Click Footer and select Edit to open the Edit Footer dialog box.

2. Clear all of the selections in the dialog box to completely remove the header or footer. For example, you might select None for the Banner image and delete text.

3. Click OK.
Chapter 8
Adding Images and Text

Overview of Using Images and Text

Similar to headers and footers, you can use images and text to include corporate standards, such as logos and text that indicates confidentiality, in your reports. One of the differences is the ability to insert multiple images and text objects wherever you want them to appear in the layout. You can also link images and text to another report or to a Web page.

You can insert images from a repository or from your local machine. If you select an image from your local machine, it is saved to the repository. You can also add tooltip text to an image. Text objects can be used to display static text, dynamic prompt values, and measure values.

Note: If you are authorized to save reports, you should be able to save images to the repository. If you cannot save images, contact your system administrator.

This chapter discusses how to use images and text in Edit mode.

Place an Image in a Report Section

To insert an image into your report, complete these steps:

1. In Edit mode, click on the horizontal toolbar. An empty placeholder object for an image is placed in the next available cell in the layout grid.

   For more information about how to position objects in the layout grid, see “Overview of Positioning Report Objects” on page 77.
2. Right-click in the image, and then select **Edit** to open the Edit Image dialog box.

**Display 8.2  Edit Image Dialog Box**

3. Select the image from one of the following locations:

**Local machine**
Select this option to choose an image from your local machine. Click **Browse** to choose a file on your local machine. The path to the selected image appears in the **Image source** field. Click **Select a Folder** to choose a destination for the image. In the Select Folder dialog box, you can create a new folder by clicking **Create New Folder**. Click **OK**. If you select an image from your local machine, it is saved to the repository.

**Note:** If you are authorized to save reports, you should be able to save images to the repository. If you cannot save images to the repository, contact your system administrator.

**Repository**
Select this option to choose an image that is stored on the same server as the reports. Click **Select image** to open the Select Image dialog box. (Only images appear in the Select Image dialog box. No other types of data sources appear.) Select an image. Click **OK**. You will see the image displayed below the **Select image** button in the Edit Image dialog box.
4. Specify a size for the selected image. The user-defined selections are **Set height (maintain scale)**, **Set width (maintain scale)**, and **Set width and height**.

5. (Optional) For **Tool-tip text**, type up to 60 characters that will appear when the user places the pointer over the image. You cannot use these characters: < > & #

6. Click **OK**.

For more information about linking the image to a Web page or to another report, see “Creating a Link to a Report or to a Web Page” on page 251.

---

### Include Text in a Report Section

To insert text into your report, complete these steps:

1. Click **T** on the horizontal toolbar. An empty placeholder object for the text object is placed in the next available cell in the layout grid.

2. Right-click in the text object, and then select **Edit** to open the Edit Text dialog box.

3. Enter text into the text box. There are three methods that you can use, and you can use a combination of all three methods:

   • You can type the text.

   • You can insert a measure value.

     Select the name of the measure in the **Measure value** drop-down list, and then click **Insert** to place the measure name into the text box at the insertion point. Type at least one character or one space before entering any additional measure value. The text in the rendered report displays the aggregated value of the measure.

     **Note**: If you remove the inserted measure from the report, then the measure is also removed from the text.

   • You can insert a prompt value.

     Select the name of the prompt in the **Prompt value** drop-down list, and then click **Insert** to place the prompt name into the text box at the insertion point. Type at least one character or one space before entering any additional prompt value. The text in the rendered report displays the value that you entered for the prompt.

     **Note**: You can always type text, but the availability of prompts and measures depends on the data items that are selected for the report section.

**Display 8.3  Text Entered in the Edit Text Dialog Box**

![Edit Text dialog box](image)
4. (Optional) Use the formatting tools to change the font, font size, font style, background color, foreground color, and alignment.

   *Note:* Press ENTER between each paragraph. Text alignment is applied to the currently selected paragraph.

   *Note:* You cannot apply a style change across paragraphs. However, you can select each paragraph and apply the same style to each one.

5. (Optional) Create a hypertext link that can open another report or Web page. For step-by-step instructions on creating a link to another report or Web page, see “Access the Report Linking Dialog Box for Text Objects” on page 252.

6. Click **OK**.

---

**Remove an Image or a Text Object**

To delete a text or image object, complete these steps:

1. Select the text or image object in the layout grid.

2. Complete one of these tasks:
   - Click **X** on the vertical toolbar.
   - Right-click in the image or text object, and then select **Remove Image** or **Remove Text**.
   - Right-click in the image or text object, and press Delete on the keyboard.

3. Click **OK** in the confirmation message box that appears.
Chapter 9
Including Stored Process Output

Overview of Stored Processes

Stored process output in a report can include queries, prompted filters, titles, images, and statistical analyses. Some stored process output might support chart tips, tooltips, and drilling.

There are two ways to use stored processes:

- Stored processes can be included as part of a larger saved report, as explained in this chapter.
- Stored processes can be rendered directly, as explained in “Viewing Stored Process Reports” on page 41.

When you include a stored process in a saved report, you can perform some additional layout design tasks that are independent of the stored process output. For example, you can add text, images, headers, and footers. In the same report section, you can also include the output of a query that uses data items from a data source. If you add an additional data source (other than the stored process), then you can also add graphs, tables, and, possibly, geographical maps.

This chapter discusses how to work with stored processes in Edit mode.

Insert a Stored Process

To insert one or more stored processes into a report layout, complete these steps:

1. Perform one of these tasks to insert a stored process object:
   - Drag the stored process tool from the toolbar into a specific cell.
   - Click 📧 on the horizontal toolbar.

   An empty placeholder object for a stored process is placed in the next available cell in the layout grid.
For more information about how to position objects in the layout grid, see “Place Objects in the Layout Grid” on page 80.

2. Right-click on the stored process, and then select Edit to open the Insert a Stored Process dialog box.

3. Select a folder Location and navigate to the stored process that you want to use.
   
   Note: Only stored processes appear in the Insert a Stored Process dialog box. No other types of data sources appear.

4. (Optional) To sort the list of stored processes, click Name, Date, or Description.

5. Select the stored process that you want to use.

6. Click OK. The name of the stored process appears in the stored process object.

   Display 9.1   A Stored Process Object in the Layout Grid

7. (Optional) To insert another stored process, repeat steps 1 through 6.

8. (Optional) Specify group break parameters for the stored process. For more information, see “Add Group Breaks” on page 119.
   
   Note: You cannot complete this step if no stored process has been assigned to the stored process report object, if there are no group breaks in the section that contains the stored process, or if the stored process does not contain any parameters.

a. Right-click on the stored process, and then select Assign Group Breaks to open the Assign Group Breaks To Stored Process Prompts dialog box.

b. Specify the Group break levels. Note that a group break value can be passed only to a compatible prompt. For example, a group break value on a character item can be passed only to a text prompt. A group break value on a date category can be passed only to a date prompt, and so on.
c. Click **OK**.

9. (Optional) Add other report elements (for example, images or text) that are independent of the inserted stored processes.

---

**Remove a Stored Process**

To remove a stored process from the current report section, complete these steps:

1. Select the stored process object.

2. Complete one of these tasks:
   - Click [X] on the vertical toolbar.
   - Right-click in the stored process object, and then select **Remove Stored Process**.
   - Right-click in the stored process object, and press the Delete key.

3. In the confirmation message box that appears, click **OK**.
Overview of Positioning Report Objects

Overview of Positioning Report Objects

Edit mode contains a layout grid for placing and arranging objects in the body of the report section. The grid consists of cells into which you place tables, graphs, maps, stored processes, text, and images. By default, the layout grid has these features:

- It does not contain any report objects.
- It contains four cells.
- Cell alignment is set to the left corner.
- The drop-down list for making objects independent or synchronized is not available.
You can add cells, merge cells, and delete empty cells. You can also realign cell content, reposition objects, and synchronize objects or make them independent.

Add Cells to the Layout Grid

To add more cells to the layout grid, click these buttons on the vertical toolbar.

<table>
<thead>
<tr>
<th>Button</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Add Column" /></td>
<td>adds a column to the right side of the grid</td>
</tr>
<tr>
<td><img src="image" alt="Add Row" /></td>
<td>adds a row to the bottom of the grid</td>
</tr>
<tr>
<td><img src="image" alt="Split Vertically" /></td>
<td>splits a selected cell vertically</td>
</tr>
<tr>
<td><img src="image" alt="Split Horizontally" /></td>
<td>splits a selected cell horizontally</td>
</tr>
</tbody>
</table>

Align Cell Content in the Layout Grid

To change the alignment of an object in a cell, select the object and then click one of the alignment buttons on the vertical toolbar.

<table>
<thead>
<tr>
<th>Button</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Align Left" /></td>
<td>aligns the content of the object to the left of the cell</td>
</tr>
<tr>
<td><img src="image" alt="Align Center" /></td>
<td>aligns the content of the object to the center of the cell</td>
</tr>
<tr>
<td><img src="image" alt="Align Right" /></td>
<td>aligns the content of the object to the right of the cell</td>
</tr>
</tbody>
</table>
Delete an Empty Column or Row from the Layout Grid

You can delete empty columns and rows from the layout grid. You cannot delete individual empty cells or rows and columns that contain objects.

To select the empty cells in a row or column, perform one of these tasks:
• Select cells by dragging your mouse.
• Press CTRL while clicking on each cell.
• Press SHIFT while clicking to specify the beginning and end of a region.

To delete the selected cells, click on the vertical toolbar.

Delete Objects in the Layout Grid

To delete one or more objects from the layout grid, complete these steps:
1. In the layout grid, select the object or objects that you want to delete.
2. Complete one of these tasks:
   • Click on the vertical toolbar.
   • Right-click in the object, and then select Remove <object-name>.
   • Right-click in the object, and press Delete on the keyboard.
3. In the confirmation message box that appears, click OK.

Merge Cells in the Layout Grid

To merge two or more selected cells in the same row or column in the layout grid, click on the vertical toolbar. You can merge together empty cells or empty cells and one cell with content, because each cell can contain only one element.
Place Objects in the Layout Grid

These are the objects that you can place in the layout grid of a report section. To place an object, you can click on its button on the vertical toolbar, or you can drag and drop the object from the toolbar into a cell.

<table>
<thead>
<tr>
<th>Toolbar Button</th>
<th>Object</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>list table</td>
</tr>
<tr>
<td></td>
<td>crosstabulation table</td>
</tr>
<tr>
<td></td>
<td>bar chart</td>
</tr>
<tr>
<td></td>
<td>line graph</td>
</tr>
<tr>
<td></td>
<td>bar-line chart</td>
</tr>
<tr>
<td></td>
<td>progressive bar chart</td>
</tr>
<tr>
<td></td>
<td>scatter plot</td>
</tr>
<tr>
<td></td>
<td>pie chart</td>
</tr>
<tr>
<td></td>
<td>tile chart</td>
</tr>
<tr>
<td></td>
<td>geographical map</td>
</tr>
<tr>
<td></td>
<td>text</td>
</tr>
<tr>
<td></td>
<td>image</td>
</tr>
<tr>
<td></td>
<td>stored process</td>
</tr>
</tbody>
</table>

Reposition Objects in the Layout Grid

You can drag and drop objects from one cell in the layout grid to another.

If you attempt to drop a new object into a cell that already contains an object, then a warning message appears. If you click OK, then the current object is replaced by the moved object.

If you attempt to move an existing object into a cell that already contains an object, then a warning message appears. If you click OK, then the current object switches places with the moved object.
Overview of Synchronized Filtering, Sorting, Drilling, and Expanding

For report sections that use data items from a data source, you can synchronize the objects that you insert into the body. Synchronized tables and graphs share category or hierarchy filters, sorting (but not prioritizing), drilling, and expanding. Tables, graphs, and geographical maps share filters, drilling, and expanding.

Note: All tables and graphs within a section are either synchronized or independent. You cannot choose to synchronize some elements in a section and not others.

By default, report sections that are based on multidimensional data sources contain synchronized objects. The report section is synchronized as soon as you select data items from the data source. If you change the data source to relational, then the objects in the report section automatically become independent, and the original data item assignment is lost.

To synchronize objects that are currently independent, when in Edit mode, select either Data ⇒ Synchronized Objects or Options ⇒ Synchronized Objects.

Note: This menu option is not available if your report section contains a stored process.

When you switch objects from independent to synchronized, the following actions are taken on any tables, graphs, and geographical maps:

- All filters and rankings are removed.
- All sorting is removed.
- Tables, graphs, and geographical maps are reset to the highest level drill state.
- Any percent of total calculations are removed.

In Edit or View mode, synchronized objects are indicated in the Section Data pane by this icon: 🛠️.
Maintain Independent Tables, Graphs, and Geographical Maps

By default, report sections that are based on relational data sources contain independent objects. The report section is set to contain independent objects as soon as you select data items from the data source. If you change the data source to multidimensional, then the objects in the report section automatically become synchronized (unless the report section contains a stored process), and the original data item assignment is lost.

To make synchronized objects independent, when in Edit mode, select Data ⇒ Independent Objects or Options ⇒ Independent Objects.

When you switch objects from synchronized to independent, the following actions are taken on the individual tables, graphs, and geographical maps:

- All filters and rankings are removed.
- All sorting is removed.
- Tables, graphs, and geographical maps are reset to the highest level drill state.
Part 4

Defining Queries and Displaying Results

Chapter 12

Defining Queries to Obtain Results ........................................ 85

Chapter 13

Subsetting Query Results ...................................................... 101

Chapter 14

Grouping Query Results ....................................................... 119

Chapter 15

Displaying Query Results in a Table, Graph, or Geographical Map . . 123
Overview of Queries Based on Data Items

Data sources are a collection of data items and filters that hide the technical complexity of databases while providing a business-relevant view of your company's data. They are created by a data source administrator so that you can easily define a report.

Each data source includes one or more data items. For example, a data source named Order Information might include standard data items such as Order ID, Product ID, Unit Cost, Order Date, and Order Amount. You decide which data items to use. You can select all of the data items in the data source or a subset of data items.

You can also create two types of custom data items:

- You can calculate a new measure that is based on one or more existing measures.
- If the data source includes a time hierarchy from a multidimensional data source, then you can create one or more custom data items that are based on relative time.
In addition to explaining how to use both standard and custom data items, this chapter explains how to modify the query in these ways:

• by changing the format used for one or more data items
• by specifying to use detail data instead of grouped and aggregated data
• by changing the aggregation method used for one or more measures

You can also subset and group query results. For more information about these tasks, see Chapter 13, “Subsetting Query Results,” on page 101 and Chapter 14, “Grouping Query Results,” on page 119.

After you select the data source and data items, you must add one or more view elements, such as a table or graph, to contain the results. For more information, see Chapter 15, “Displaying Query Results in a Table, Graph, or Geographical Map,” on page 123.

Using Standard Data Items in a Query

About Standard Data Items

Each data source includes one or more standard data items. You decide which data items to use to define a query for a report section. You can use all the data items in the data source or a subset of data items. Each standard data item is classified as either a category, a hierarchy, or a measure.

Category

A data item whose distinct values are used to group and aggregate measures. There are four types of categories: alphanumeric, date, timestamp, and time. Alphanumeric categories can be made up of all letters, all digits, or a combination of the two. Categories that have values that are all digits might be physically stored as character or numeric data. The data type affects how values are handled in relation to some functionality such as filtering, sorting, and formatting.

Examples of alphanumeric categories include data items such as Product ID, Country, Employee Number, and Employee Name. Date, timestamp, and time category examples are Order Year, Date of Sale, and Delivery Time.

Measure

A data item whose values can be used in computations. Usually these values are numeric. Examples of measures include Sales Revenue, Units Sold, and Salary.

The default format of a measure is specified by the data source that contains it. You can modify the format of some measures.

Every measure has a default aggregation method, which is specified by the data source that contains it. In some cases, you can change the method. However, if you use a measure as part of a custom data item, then the measure is always calculated by using the default aggregation method.

Hierarchy

An arrangement of the levels in a dimension from general to specific. The first level in the hierarchy is the root level.

For example, a common dimension in a multidimensional data source is Time. A dimension that is named Time might have a hierarchy named YrQtrMth. Such a hierarchy might enable you to look at data for each Year (the root level), drill down to
see the data for each *Quarter* (second level) in a specific year, and then drill down to see the data for the three *Months* (third level) that make up a particular quarter.

Hierarchies are available only in multidimensional data sources.

**Select Standard Data Items**

To select the standard data items that you want to use in the query for the current report section, complete these steps:

1. In the Section Data pane, select **Options ⇒ Select Data** to open the Select Data dialog box.

2. On the **Standard** tab, a data source is selected by default. If there are no data sources available, contact your data source administrator.

   To use a different data source, complete these steps:
   a. Click **Change Source**.
   b. In the Select Data Source dialog box, navigate to the location of the data source that you want to use. Each data source appears with an icon that indicates its type.
   c. Click **OK**.

3. (Optional) To search for a data item in the selected data source, complete these steps:
   a. Click [ ] on the **Standard** tab.
   b. Type your search term.
   c. Click **Find Next** to locate each instance of the data item.
   d. Click **Cancel**.

4. In the **Available data items** list box, select a data item, and then click [ ] to add the data item to the query. To move all items into the **Selected data items** box, click [ ].

   The data items that you select are listed in the **Selected data items** list box.
Display 12.1  Select Data Dialog Box Showing Four Categories and Two Measures
Selected from a Relational Data Source

Note: To view the data type and description for a data item, select it in the Available data items list box, and then click .

Note: For relational data sources, you can select the same measure multiple times, rename each instance of the measure (see step 7), and apply a different aggregation to each instance of the measure (see “Modify How a Measure Is Aggregated” on page 96).

5. (Optional) Reorder the data items in the Selected data items box. To move a selected data item up or down in the list, use and . The order in which the data items appear in this box is used to assign the data items to default functions in graphs and tables.
   Note: Existing tables and graphs are not affected by reordering data items.

6. (Optional) To rename a category or measure, select it in the Selected data items, and then click .
   Note: You cannot rename hierarchies.

7. (Optional) If you do not want new data items automatically added to existing tables, then clear the Add new data items to existing tables automatically option. (Adding new data items to tables might affect existing filters, percent of total calculations, and conditional highlighting.) If this option is not selected, then new data items are hidden in tables. This option is not available if there are no existing tables.

For existing crosstabulation tables that have at least one category assigned to Columns, additional data items are assigned to the Rows function. If you add measures, the additional measures are assigned to whatever function the current measures are assigned to. That is, if measures are currently assigned to Rows, then the additional measures are also assigned to Rows. For list tables, if this option is selected, new data items are added to the Columns function.
8. Click OK.

![Display 12.2 Section Data Pane in Edit Mode Showing the Standard Data Items Selected for the Query](image)

*Note:* To collapse the data pane, click ⌦.

You can modify the data item selection. For more information, see the following topics:

- “Modify the Format of a Standard Data Item” on page 94.
- “Modify How a Measure Is Aggregated” on page 96.
- “Use Detail Data Instead of Grouped and Aggregated Data” on page 97.

### Rename a Standard Data Item

To change the name of a category or measure, complete these steps:

*Note:* You cannot rename hierarchies.

1. In the Section Data pane, select Options ⇒ Select Data to open the Select Data dialog box.
2. Click the Standard tab.
3. Select a data item in the Selected data items list box.
4. Click  .
5. In the Rename Data Item dialog box, type the new name, and then click OK.
6. To close the Select Data dialog box, click OK.

### Remove Standard Data Items

To remove a standard data item from the Select Data pane, complete these steps:

1. In the Section Data pane, select Options ⇒ Select Data to open the Select Data dialog box.
2. Select the Standard tab.
3. Select a data item in the Selected data items list box.
4. Click  to remove the data item from the Selected data items list box. Here are some consequences of removing data items from a section query:
   - If you remove a time hierarchy, then any custom data items that are based on time functions are removed from all objects in the report section.
• If you remove the geographic hierarchy, then any map in the section becomes invalid.

• If you remove a category or hierarchy that is being used in a report linking prompt, then the prompt association is removed. The link to the target report will still work; however, the user must complete the prompt window to display the report.

• If you remove a data item that is being used in a percent of total calculation, then the percent of total calculation is removed from the table.

• If you remove a measure that is being used with a group break or in text, then the measure information is removed from the report section. For example, if you included Profit with a group break for Product, then the Profit information is removed.

5. Click OK.

Using Custom Data Items in a Query

About Custom Data Items

When a data source does not contain a calculation that you want to use in a query, you can use the measures that are contained in the data source to create a custom data item. There are two types of custom data items that you can create:

• You can use one or more measures in a selected data source to create a new calculation. For example, you could create a custom data item called Profit, which is created by using this expression: [Revenue] - [Cost], where Revenue and Cost are measures in a data source. You also could create this expression: [Total_Retail_Price] / 1000000, where Total_Retail_Price is the measure divided by 1 million. For more information, see “Create a Custom Data Item by Entering an Expression” on page 90.

• If your query includes a time hierarchy from a multidimensional data source, then you can create a custom data item that is based on relative time. For example, you might create these expressions: Percent change (parallel periods) [Revenue], where [Revenue] is the selected measure, or Rolling Total (period to date) [COST_N], where [COST_N] is the selected measure. For more information, see “Create a Custom Data Item That Is Based on Relative Time” on page 91.

Measures used in a custom data item expression are always calculated by using the default aggregation method. (Within SAS Web Report Studio, it is not possible to produce a detailed calculation.)

Create a Custom Data Item by Entering an Expression

To create a custom data item by entering an expression, complete these steps:

1. In the Section Data pane, select Options ➔ Select Data to open the Select Data dialog box.

2. Select the Custom tab.

3. A data source is selected by default. If you want to use a different data source, complete these steps:
   a. Click Change Source.
b. In the Select Data Source dialog box, select a new data source. This will also change the data source for standard data items.

c. Click OK.

4. Type the Name of the custom data item. You cannot use these characters: < > ( ) & # \.

5. Type an arithmetic expression into the Expression field. The expression is evaluated based on the aggregated values of the measures that you selected. (Within SAS Web Report Studio, it is not possible to produce a detailed calculation.)

Table 12.1 on page 91 contains some items that you can include in an expression.

<table>
<thead>
<tr>
<th>Items</th>
<th>Examples</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>measure names, enclosed in square brackets</td>
<td>[Profit] [Cost of Goods Sold]</td>
<td>If you select a measure from the Available measures list box and click the arrow button to move it to the Expression field, then the brackets are automatically included.</td>
</tr>
<tr>
<td>parentheses</td>
<td>2 * ([COST_N] + [Sales_Cost])</td>
<td>Use parentheses when you need to perform a calculation outside of the normal order of operations. You can type the parentheses or highlight the appropriate part of the expressions and then click ( ).</td>
</tr>
<tr>
<td>the following symbols: + (plus sign), - (minus sign), * (multiplication sign), and / (division sign)</td>
<td>[Retail_Price] - [Cost]</td>
<td>You can type the symbols or use the symbol buttons: + - * /</td>
</tr>
<tr>
<td>numeric constants</td>
<td>[Total_Retail_Price] / 1000000</td>
<td>You cannot create a data item that is a constant value such as 500 or 500+300.</td>
</tr>
</tbody>
</table>

* In the normal order of operations, working from left to right, multiplication and division are performed first, followed by addition and subtraction.

6. After you have written the expression, click Add to add your custom data item to the Custom items box.

7. Click OK.

The custom data item that you created is listed in the Section Data pane with any other selected or created data items.

Create a Custom Data Item That Is Based on Relative Time

If your query includes a time hierarchy from a multidimensional data source, then you can create a custom data item that is based on relative time. Complete these steps:

1. In the Section Data pane, select Options ⇒ Select Data to open the Select Data dialog box.

2. Select the Custom tab.
3. A data source is selected by default. If you want to use a different data source, complete these steps:
   a. Click **Change Source**.
   b. In the Select Data Source dialog box, select a new data source.
   c. Click **OK**.
4. Type the **Name** of the custom data item. You cannot use these characters: < > ( ) & # \  
5. Select a measure in the **Available measures** field.
6. Select one of the options in the **Functions** drop-down list. You can create the following calculations for the selected measure:

**Difference (consecutive periods)**
the difference between the previous period and the current period.

**Difference (parallel periods)**
the difference between the current period and the equivalent period from the previous year. For example, you might calculate the difference between the third quarter of the current year and the third quarter of the previous year.

**Percent change (consecutive periods)**
the difference between the previous period and the current period, expressed as a percentage of the previous period's value.

**Percent change (parallel periods)**
the difference between the current period and the equivalent period from the previous year, expressed as a percentage of the previous year's value. For example, you might calculate the percentage change between the third quarter of the current year and the third quarter of the previous year.

**Rolling Total (period to date)**
the sum of the values for the current period and all of the preceding periods. (This function starts over with each calendar year.)
7. Click to place your relative time expression in the Expression field. The expression is evaluated based on the aggregated values of the measures that you selected. (Within SAS Web Report Studio, it is not possible to produce a detailed calculation.)

Display 12.4  A Custom Data Item in the Select Data Dialog Box

8. Click Add to add your custom data item to the Custom items box.
9. Click OK.
   The custom data item that you created is listed in the Section Data pane with any other
   selected or created data items.

Modify a Manually Entered Expression

To modify a custom data item, complete these steps:

Note: You cannot modify an expression that uses a relative time function. However, you
can click Clear to clear it from the Expression field.

1. In the Section Data pane, select Options ⇒ Select Data to open the Select Data dialog
   box.
2. Select the Custom tab.
3. Select a custom data item in the Custom items box.
4. Click Clear and then retype the expression. Then click Change.
5. Click OK.

Remove a Custom Data Item

To remove a custom data item from a report section, complete these steps:

1. In the Section Data pane, select Options ⇒ Select Data to open the Select Data dialog
   box.
2. Select the Custom tab.
3. Select a custom data item in the Custom items box, and then click Remove.
   Note: If you remove a custom data item, it is no longer available to use in the report.
   If you change your mind, you must re-create the custom data item.
4. Click OK.

Modifying How a Data Item Is Formatted

Modify the Format of a Standard Data Item

To change the default format of a standard data item, complete these steps:

1. In the Section Data pane, right-click a data item, and then select Format to open the
   Define a Format dialog box.
   Note: The data source administrator controls whether you can change the format of a
   standard data item. If you are not permitted to change the format, then Format is
   not available.
2. Select a Type of format.
3. Depending on which format type you selected, take the appropriate action, as shown in Table 12.2 on page 95.

Table 12.2 Format Selections and Available Actions

<table>
<thead>
<tr>
<th>Format Selected</th>
<th>Data Item Type</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default*</td>
<td>all types</td>
<td>No action necessary.</td>
</tr>
<tr>
<td>Currency</td>
<td>measures and alphanumeric categories that are physically stored as numeric data</td>
<td>Select the number of digits to be displayed after the decimal point.</td>
</tr>
<tr>
<td>Date</td>
<td>date, time, or timestamp categories</td>
<td>Select the date format that you want to use for the data item.</td>
</tr>
<tr>
<td>Number</td>
<td>measures and alphanumeric categories that are physically stored as numeric data</td>
<td>Select the number of decimal places to be displayed and choose a format for negative numbers. You can also choose to use a thousands separator or to convert the value to a percentage. For relational data sources, you can use both options. For multidimensional data sources, you can select only one option.</td>
</tr>
<tr>
<td>Predefined**</td>
<td>alphanumeric categories that are physically stored as character data***</td>
<td>Select the predefined format that you want to apply to this data item.</td>
</tr>
</tbody>
</table>
Modify the Format of a Custom Data Item

To change the format of a data item, complete these steps:

1. In the Section Data pane, right-click a data item, and then select Format to open the Define a Format dialog box.

2. Select a Type of format. For custom data items, the options are Default, Currency, and Number.

3. Depending on which format type you selected, take the appropriate action, as shown in Table 12.3 on page 96.

<table>
<thead>
<tr>
<th>Format Selected</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default*</td>
<td>No action necessary.</td>
</tr>
<tr>
<td>Currency</td>
<td>Select the number of digits to be displayed after the decimal point and specify a currency symbol.</td>
</tr>
<tr>
<td>Number</td>
<td>Select the number of decimal places to be displayed and choose a format for negative numbers. You can also choose either to use a thousands separator or to convert the value to a percentage.</td>
</tr>
</tbody>
</table>

* The Default format is Number.

4. Click OK.

Modify How a Measure Is Aggregated

You might want a measure in a relational data source to use a different aggregation method than the default method. For example, your data source includes a measure named Unit Cost that uses the sum aggregation method. You want to use the maximum aggregation method instead.

To change the aggregation method of a measure in a relational data source, complete these steps:
1. Select **Data ⇒ Summarization Options** to open the Summarization Options dialog box.

2. In the **Aggregation** drop-down list that is next to the name of the measure that you want to change, select a new aggregation method.

   *Note:* Your data source administrator can disable the ability to change the aggregation method.

**Display 12.6 Summarization Options Dialog Box**

3. Click **OK**.

4. (Optional) Change the name of the measure to better reflect the new aggregation method. For more information, see “Rename a Standard Data Item” on page 89.

   **TIP** Sometimes changing how a measure is aggregated can give you a different view of the underlying data. For example, the measure **Supplier IDs** contains one unique ID for each supplier. The default aggregation method for **Supplier IDs** is sum. If you change the aggregation method to count, the query returns a numerical value that represents the number of suppliers. In this case, you would change the name of the measure to something more appropriate, such as **Number of Suppliers**. For more information, see “Rename a Standard Data Item” on page 89.

   *Note:* For multidimensional data sources, records are always grouped and the aggregation method of a measure cannot be changed.

---

**Use Detail Data Instead of Grouped and Aggregated Data**

By default, the records in a relational data source are grouped and aggregated. This means that there is a single record for each unique combination of values across all categories in the report section.
For multidimensional data, you cannot change the grouping or aggregation. For relational data, you cannot use detail data if the report section contains any of these items:

- a crosstabulation table or a graph, with the exception of scatter plots that use relational data
- one or more custom data items

In all other circumstances, to use detail data, complete these steps:

1. Select **Data ➤ Summarization Options** to open the Summarization Options dialog box.

2. Select one of these options:
   - **Summarize similar rows (Aggregated data)**
     - Select this option to roll the values into an aggregation instead of showing every row.
   - **Show every row (Detail data)**
     - Select this option to show every record in the data source.
     - *Note:* To base a scatter plot on data that is not aggregated, select this option.
   - **Show every row, excluding duplicates (Detail data)**
     - Select this option to show every record in the data source and to exclude duplicate records (records where the value for the category data item or data items is identical).

3. Click **OK**.

---

### Preview or Export Query Results

To preview or export the results of a query that you have defined, complete these steps:

1. In Edit mode, select **Data ➤ Preview Section Data** to open the Preview Data dialog box. All columns and up to 100 rows are displayed at one time.
Note: Sometimes, instead of the data, you see the message No values were returned for this table. This means that the filters that you have applied to this section have filtered out all the data from your data source. In this case, click Close Window to go back to Edit mode and change the filters that you are using.

2. (Optional) To export the data to a Microsoft Excel spreadsheet or to a Microsoft Word document, click Export to open the Export dialog box. To export the data, click OK. When prompted, choose either to open the file or to save it. For more information on exporting, see “Exporting Reports and Report Data” on page 263.

3. Click Close Window.
Chapter 13
Subsetting Query Results

Overview of Section Filters

Filters are used to restrict the data that is returned from a query to a data source. Some relational and multidimensional data sources include predefined filters that you can select for a specific category. For relational data sources, you can also create custom category filters in SAS Web Report Studio.

There are three types of section filters that you can select or create:

- filters that are applied without prompting. Values for these types of filters are supplied when the filter is created or edited. When a report section is viewed, these filters are applied without prompting. If the filter was created by using SAS Web Report Studio, then you can edit the filter to use different values. You cannot modify filters that are defined with the data source, but you can remove them from the query.

- prompted, or interactive, filters. The values within prompted filters are obtained right before the report section is run. Typically, the prompts within the filters have default values. Before the report can be displayed, you must complete a prompt window. After
the report is displayed, you can change the prompt values to see different results. The prompt style (drop-down list, selection list, text box) depends on how you or the data source administrator created the filter. To change the prompt values, refresh the report data as described in “Refreshing the Data in a Viewed Report” on page 48.

- cascading, prompted filters provide different filter choices depending on a previously selected filter value. Basically, these filters are a special type of prompted filter. For example, if you select Clothing as the value for a Product Category filter, then the subsequent filter for Product Name might be restricted to choices such as Eclipse Sportswear, Tracker T-shirts, and Green Tomato Knitwear. However, if you select Camping Gear as the value for the Product Category filter, then the Product Name filter might be restricted to choices such as Orion Trekking Poles, Eclipse Sleeping Bags, and Tracker Backpacks.

  **T I P** Before creating a new section filter, review “Creating Section Filters” on page 275.

---

**Creating Filters**

**Create a Filter for an Alphanumeric Category**

To create a filter for an alphanumeric category in a relational data source, complete these steps:

1. At the top of the Section Data pane, click **Options** ⇒ **Section Filters**. This opens the Section Filters dialog box. Click **New** to open the Create Custom Filter dialog box.
1. In the **Filter name** field, accept the default name or provide a different name. For example, if the filter will restrict results to Canada, type a name such as **Country Filter for Canada**. The filter name appears in the **Apply custom filters** box in the Section Filters dialog box.

2. From the **Data item** drop-down list, select the alphanumeric data item that you want to filter. Recall that alphanumeric categories can be made up of all letters, all numbers, or a combination of the two. They can be physically stored as character or numeric data.\(^1\)

3. (Optional) If the selected data item enables you to filter on formatted values, then you can select the **Filter on formatted values** option. Regardless of your selection, the results show formatted values.\(^2\)

4. From the **Operator** drop-down list, specify how you want to filter the values from the data source. For example, you might want users to see results that are equal to the filter values.

Different operators might be available based on whether you choose to filter against character values or non-character values. Formatted values are always recognized as

---

1. The data type is a factor in whether the data item supports filtering on formatted values. This is true for the date, time, or timestamp data types, because formatted values are not permitted for these types even if a format has been applied to the data item.

2. Filtering on formatted values can sometimes adversely affect query performance. If you have questions about whether you should select this option, contact your data source administrator.
character values. However, unformatted values can be character, numeric, dates, or some other type.

6. If you selected Is missing or Is not missing, then you have created the filter. For all other operators, see Table 13.1 on page 104.

Table 13.1 Operators and Required Information

<table>
<thead>
<tr>
<th>Operator</th>
<th>Required Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equal to or Not equal to</td>
<td>If the data item supports displaying values, click Get Values to load values into the Available values box. Use the arrow buttons to move values from the Available values box into the Selected values box. You can also create your own list of values or add to a dynamically generated list. Type each value into the Type a value to add field and then click the arrow button next to the field to add the value into the Selected values box.</td>
</tr>
<tr>
<td>Between values or Not between values</td>
<td>If the data item supports displaying values, click Get Values to load values into the Minimum value and Maximum value fields. You can also type the minimum and maximum values.</td>
</tr>
<tr>
<td>Contains or Does not contain</td>
<td>This operator is not available for unformatted numeric values. In the Value field, type the text that you want the filter to match. For example, if you type Assist for a filter on job title, then the results will contain (or not contain) values such as Concession Assistant I and Marketing Assistant I.</td>
</tr>
<tr>
<td>Match pattern or Does not match pattern</td>
<td>This operator is not available for unformatted numeric values. In the Value field, type the text that you want the filter to match. Use an asterisk (<em>) to represent multiple characters or use a question mark (?) to represent any single character. For example, if you type Sales</em> for a filter on job title, then the query results will match (or not match) values such as Sales Manager and Sales Rep. I.</td>
</tr>
<tr>
<td>Is less than or Is less than or equal to</td>
<td>One numeric value is required.</td>
</tr>
<tr>
<td>Is greater than or Is greater than or equal to</td>
<td>One numeric value is required.</td>
</tr>
</tbody>
</table>

7. You can also select Browse or Search to find available values. For more information, see “Browsing or Searching for Filter Values” on page 183.

8. Click OK.

9. When you access the Create Custom Filter dialog box from the Section Filter dialog box, then the filter that you just created is automatically selected in the Apply custom filters box. When the filter name is selected, the filter expression is shown in the Expression box.

   **TIP** Custom filters can be saved for future use. To turn off the filter, clear the check box next to the filter name. For more information, see “Apply Existing Section Filters” on page 114.

To save the new filter and exit the Section Filters dialog box, click OK.

Note: If you click Cancel, your new filter is discarded.
Create a Filter for a Date, Time, or Timestamp Category

To create a filter for a date, time, or timestamp category in a relational data source, complete these steps:

1. At the top of the Section Data pane, click Options → Section Filters. This opens the Section Filters dialog box. Click New to open the Create Custom Filter dialog box.

2. In the Filter name field, accept the default name or provide a different name. For example, if you want to filter the query to return data before a specified time, type a name such as Data Entered Before 5:00pm. The filter name appears in the Apply custom filters box in the Edit Filters dialog box.

3. From the Data item drop-down list, select the date, time, or timestamp data item that you want to filter.

4. From the Operator drop-down list, specify how you want to filter the values from the data source. For example, you might want users to see query results that are before or equal to the filter values.

5. If you selected Is missing or Is not missing, then you have created the filter. For all other operators, see Table 13.2 on page 105.

Table 13.2 Operators, Category Types, and Required Information

<table>
<thead>
<tr>
<th>Operator</th>
<th>Category Type</th>
<th>Required Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equal to, Not equal to, After, After or equal to, Before, and Before or equal to</td>
<td>Dates</td>
<td>Use the Date field to type a date or click to use the date picker. Note that the list of valid formats depends on your locale and language.</td>
</tr>
<tr>
<td></td>
<td>Times</td>
<td>Use the Time drop-down lists to select an hour, a minute, and a second in 24-hour time. For example, to specify 5 p.m., select 17, 00, and 00.</td>
</tr>
<tr>
<td></td>
<td>Timestamps</td>
<td>Use the Date field to type a date or click to use the date picker. Use the Time drop-down lists to select an hour, a minute, and a second in 24-hour clock time.</td>
</tr>
<tr>
<td>Between values and Not between values</td>
<td>Dates</td>
<td>Use the Minimum and Maximum drop-down lists to specify the minimum and maximum dates. Use the Date fields to type a minimum and maximum date or click to use the date picker. Note that the list of valid formats depends on your locale and language.</td>
</tr>
<tr>
<td></td>
<td>Times</td>
<td>Use the Minimum and Maximum drop-down lists to select a minimum and maximum hour, minute, and second in 24-hour clock time.</td>
</tr>
<tr>
<td></td>
<td>Timestamps</td>
<td>Use the Minimum and Maximum drop-down lists to specify the minimum and maximum dates and times. Use the Date fields to type a date or click to use the date picker. Note that the list of valid formats depends on your locale and language. Use the Time drop-down lists to select the hours, minutes, and seconds in 24-hour clock time.</td>
</tr>
</tbody>
</table>
6. Click **OK**.

7. When you access the Create Custom Filter dialog box from the Section Filter dialog box, then the filter that you just created is automatically selected in the **Apply custom filters** box. When the filter name is selected, the filter expression is shown in the **Expression** box.

   **TIP** Custom filters can be saved for future use. To turn off the filter, clear the check box next to the filter name. For more information, see “Apply Existing Section Filters” on page 114.

To save the new filter and exit the Section Filters dialog box, click **OK**.

**Note:** If you click **Cancel**, your new filter is discarded.

8. (Optional) New filters are automatically added to the existing filter combination expression. By default, new filters are joined using the AND operator, which means that the query results must match all selected filters. For more information, see “Combine Filters” on page 116.

**Display 13.2** Section Filters Dialog Box Showing a New, Selected Custom Date Filter and Its Expression

---

**Creating Prompted Section Filters**

**Create a Prompted Filter for an Alphanumeric Category**

To create a prompted filter for an alphanumeric category in a relational data source, complete these steps:

1. To access the Create Custom Filter dialog box, perform one of these tasks:
   
   • At the top of the Section Data pane, click **Options ➤ Section Filters** to open the Section Filters dialog box.
   
   • Select **Data ➤ Section Filters**.
   
   • In the Report Wizard (Step 2), click **Section filters** to open the Section Filters dialog box.
• In the Section Data pane in Edit mode, select **Options ➔ Section Filters**.

*Display 13.3*  **Section Filters Dialog Box with Predefined Filters**

2. Click **New** to open the Create Custom Filter dialog box.

*Display 13.4*  **Create Custom Filter Dialog Box**

3. In the **Filter name** field, accept the default name or provide a different name. For example, if you are creating a prompted filter that will enable users to select a country,
type a name such as **Prompted Country Selection**. The filter name appears in the **Apply custom filters** box in the Section Filters dialog box.

4. From the **Data item** drop-down list, select the alphanumeric data item that you want to filter. Recall that alphanumeric categories can be made up of all letters, all numbers, or a combination of the two. They can be physically stored as character or numeric data.

5. (Optional) If the selected data item enables you to filter on formatted values, then you can select the **Filter on formatted values** option. Regardless of your selection, the query results show formatted values.\(^1\)

6. Select the **Prompt user to enter values** option.

7. From the **Operator** drop-down list, specify how the prompt values should be used to filter the values from the data source. For example, you might specify that you want users to see query results that are equal to the entered prompt values.

Different operators might be available based on whether you choose to filter against character values or non-character values. Formatted values are always recognized as character values. However, unformatted values can be character, numeric, dates, or some other type.

8. Specify a **Prompt type**. The choices for prompt type are **Dynamically generate values**, **Create a list of values**, and **Request user to type values**.

9. For all operator types, in the **Prompt text** field, type instructions for using the prompt. For example, you might type **Select one or more countries to include in the report**. There is no limit to the number of characters that you can type. The prompt text appears in the prompt window.

10. For all operator types, in the **Prompt name** field, accept the default name or type a new name for the prompt. The prompt name appears in the prompt window and in the Report Linking dialog box.

11. Your next steps depend on the operator that you selected.

   If you selected **Contains**, **Does not contain**, **Matches pattern**, or **Does not match pattern**, then complete these steps:

   a. Type a value in the **Default value** field.

   b. (Optional) Select the **Ignore case** check box.

   If you selected **Equal to** or **Not equal to**, **Between values** or **Not between values**, then your next steps depend on the type of prompt that you selected. The steps are explained in Table 13.3 on page 109.

   \(\text{Note:}\) The data source administrator determines whether the **Dynamically generate values** option is available.

---

\(^1\) Filtering on formatted values can sometimes adversely affect query performance. If you have questions about whether you should select this option, contact your data source administrator.
Table 13.3 Operators and Prompt Types

<table>
<thead>
<tr>
<th>Operator</th>
<th>Prompt Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equal to or Not equal to</td>
<td>Request user to type values</td>
</tr>
<tr>
<td></td>
<td>Type a default value.</td>
</tr>
<tr>
<td>Between values or Not between values</td>
<td>Select or type defaults for the minimum and maximum values. If the data item supports displaying values, click Get Values to load values into the drop-down lists.</td>
</tr>
</tbody>
</table>

If you selected Create a list of values, then complete these steps:

c. Either select values from the Available values list and move them to the Selected values list or enter a value in the Type a value to add field and move it to the Selected values list.

d. (Optional) Select the Allow user to specify multiple values check box.

12. You can also select Browse or Search to find available values. For more information, see “Browsing or Searching for Filter Values” on page 183.

13. Click OK.
14. If you accessed the Create Custom Filter dialog box from the Section Filter dialog box, then you can see that the filter you just created is now displayed and selected in the **Apply custom filters** box on the Section Filter dialog box. When the filter name is selected, the filter expression is shown in the **Expression** box.

**TIP** Custom filters can be saved for future use. To turn off the filter, clear the check box next to the filter name. For more information, see “Apply Existing Section Filters” on page 114.

To save the new filter and exit the Section Filters dialog box, click **OK**.

*Note:* If you click **cancel**, your new filter is discarded.

15. (Optional) New filters are automatically added to the existing filter combination expression. By default, new filters are joined using the AND operator, which means that the query results must match all selected filters. For more information, see “Combine Filters” on page 116.

**Display 13.5** Section Filters Dialog Box Showing a New, Prompted, Selected Custom Filter for an Alphanumeric Category and Its Expression

---

**Create a Prompted Filter for a Date Category**

To create a prompted filter for a date, time, or timestamp in a relational data source, complete these steps:

1. At the top of the Section Data pane, click **Options** ⇒ **Section Filters** or select **Data** ⇒ **Section Filters**. This opens the Section Filters dialog box. Click **New** to open the Create Custom Filter dialog box.

2. In the **Filter name** field, accept the default name or provide a different name. For example, if you are creating a prompted filter that will enable users to select a date range, type a name such as **Prompted Beginning and Ending Date**. The filter name appears in the **Apply custom filters** box in the Section Filters dialog box.

3. From the **Data item** drop-down list, select the date data item that you want to filter.

4. From the **Operator** drop-down list, specify how the prompt values should be used to filter the values from the data source. For example, you might specify that you want users to see query results that are between the entered prompt values.

5. Select the **Prompt user to enter values** check box.
6. In the **Prompt text** field, type instructions for using the prompt. For example, you might type *Display data for employees who were hired after your selected date*. There is no limit to the number of characters that you can type. The prompt text appears in the prompt window.

7. In the **Prompt name** field, accept the default name or type a new name for the prompt. The prompt name appears in the prompt window and in the Report Linking dialog box.

8. Depending on which operator you selected, enter the required information.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Required Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equal to, Not equal to, After, After or equal to, Before, and Before or equal to</td>
<td>In the Date field, type a date or click ![calendar icon] to use the date picker. Note that the list of valid formats depends on your locale and language.</td>
</tr>
<tr>
<td>Between values and Not between values</td>
<td>In the Date fields, type a minimum date and a maximum date or click ![calendar icon] next to each field to use the date picker. Note that the list of valid formats depends on your locale and language.</td>
</tr>
</tbody>
</table>

9. Click **OK**.

10. When you access the Create Custom Filter dialog box from the Section Filter dialog box, then the filter that you just created is automatically selected in the **Apply custom filters** box. When the filter name is selected, the filter expression is shown in the **Expression** box.

    **TIP** Custom filters can be saved for future use. To turn off the filter, clear the check box next to the filter name. For more information, see “Apply Existing Section Filters” on page 114.

    To save the new filter and exit the Section Filters dialog box, click **OK**.

    **Note:** If you click **Cancel**, your new filter is discarded.

11. (Optional) New filters are automatically added to the existing filter combination expression. By default, new filters are joined using the AND operator, which means that the query results must match all selected filters. For more information, see “Combine Filters” on page 116.

**Display 13.6** Section Filters Dialog Box Showing a New, Prompted, Selected Custom Date Filter and Its Expression
Creating Cascading Prompted Filters

Defining and Applying Prompted Filters

A prompted filter can be included in a cascade if it meets the following requirements:

- It is based on a relational data source.
- The data item associated with the prompt filter allows the user to see its values. (The
data source creator sets this in the information map using SAS Information Map Studio.)
  To verify, select Properties on a data item. In the Value-Generation Method tab, the
  User selects values from a dynamic list option should be selected.
- The prompt type of the prompted filter allows the values of the data item associated
  with the prompted filter to be loaded dynamically.

In SAS Web Report Studio, you can set the prompt type to dynamic in the Custom Filter
dialog box by selecting the Dynamically generate values option from the Prompt
type drop-down list.

A non-prompted filter can be included in a cascade if it begins the cascade; however, it
will not appear in the prompts page.

Prompted filters defined in either SAS Web Report Studio or SAS Information Map Studio
can be used in a cascade. You have to select them in the Section Filters dialog box to
participate in the cascade.

Display 13.7  Manage Prompts Dialog Box Showing Prompts for Region, State, and City

Ordering Prompted Filters

You can order all applied prompted filters, whether they participate in a cascade, using
the Manage Prompts dialog box, which is available from the Section Filters dialog box.
Note: Only advanced users can manage prompts. If you have questions about your authorization, contact your system administrator.

The Prompt Order section enables you to specify the order in which the prompts appear on the Prompts page or any other page where values for prompts need to be filled in. To reorder, select the prompt that you want to move, and then click or to move the prompted filter up or down in the order. If prompts are in a cascade, the prompts should appear consecutively in cascade order; however, you can put the prompts in any order.

**Defining Dependencies Between Two Prompted Filters**

A cascade relationship is defined between a prompt contained in one prompted filter and another filter.

For example, Filter 1 is called City Filter and contains the prompt called City Prompt, and Filter 2 is called State Filter and contains the prompt called State Prompt. To define a cascade between the filters, you would specify that City Prompt depends on State Filter. Note that the information that would be displayed by the prompt is always a subset of what would displayed by the filter.

You can define dependencies using the Manage Prompts dialog box in the Prompt Dependencies section. The Prompt drop-down list contains the names of the prompts that can participate in a cascade. The Dependency drop-down list contains the names of the filters that can participate in a cascade.

To define a cascade, complete these steps:

1. Select an entry from both the Prompt and Dependency drop-down lists.
2. Click Add. The prompt dependency appears in the Prompt Dependencies area.
3. Click OK.

The cascade definitions do not have to appear in any particular order; however, when you click OK, a check is performed to ensure that there are no circular dependencies or other illegal cascade definitions.

To remove a cascade, select an entry in the Prompt Dependencies area and then click Remove. If you remove a cascade that was a part of a chain, then the chain is not repaired to skip the missing item. For example, you have three cascade definitions where ZIP code depends on City, City depends on State, and State depends on Region. If you remove City, which depends on State, then the definition is not altered to make ZIP code somehow dependent on Region.

**Supplying Values for a Cascading Prompt**

When cascading prompts appear on the Prompts page, each dependent prompt is disabled until you supply the information for the filter that the prompt depends on.

In Display 13.8 on page 114, CENTRAL has been selected for the Region prompted filter, so the State prompt has been populated with states that are in the central region and the State prompted filter is enabled.
In Display 13.9 on page 114, MN has been selected for the **State** prompted filter, so the **City** prompt is populated with the cities in Minnesota and the City prompted filter is enabled.

Next, a user can select cities and then click **View Report** to see the report based on the results of the cascaded prompt.

Apply Existing Section Filters

Your data source administrator can create filters or prompted filters for categories in relational data sources. You can also create and save custom filters for use at a later time.

To use one or more existing filters, complete these steps:
1. Select either Options ⇒ Section Filters or Data ⇒ Section Filters to open the Section Filters dialog box.

2. In the Apply predefined filters or Apply custom filters box, select the check box for the filters that you want to apply to the section query. Select the name of a predefined filter to edit it or to view its description, which is displayed beneath the box. Select the name of a custom filter to edit it or to view its expression, which is displayed beneath the box.

Display 13.10  Section Filters Dialog Box with Predefined Filters and a Custom Filter

If you select a prompted filter for the section query, the user sees a prompt window that must be completed before the report displays. The user can change the query results by selecting different values for the prompt. The filter creator determines the style of the prompt. For example, the prompt might appear as a drop-down list, a selection list, or a text box.

Display 13.11  A Prompted Filter for a Section Query
Combine Filters

The default filter combination is **AND filters**. To modify the default filter combination, complete these steps:

1. Select either **Options ⇒ Section Filters** or **Data ⇒ Section Filters** to open the Section Filters dialog box.
2. Click **Combine Filters** to open the Filter Combination dialog box.
3. Select one of these options:
   - **AND filters**
     Select this option if you want to see only observations that match all filters. If there are no observations that match all filters, then no data is returned. This option is the default.
   - **OR filters**
     Select this option if you want to see any observation that matches any of the filters. Data is returned if at least one observation matches at least one filter.
   - **Custom**
     If you choose this option, then you can write a simple, conditional expression that combines your selected filters. In the text field, you can type an expression that includes these items:
     - the names of filters, enclosed in square brackets ([ ])
     - parentheses
     - the words **AND** and **OR** to join the names of the filters or items inside parentheses.

4. Click **OK**.

Deselect a Predefined or Custom Section Filter

If the check box next to a filter name is not checked, then the filter is not applied to the section query. To deselect a currently applied predefined or custom section filter, complete these steps:
1. Select either **Options ⇒ Section Filters** or **Data ⇒ Section Filters** to open the Section Filters dialog box.

2. In the **Apply predefined filters** or **Apply custom filters** box, select the check box next to the name of the filter that you do not want applied to the section query.

3. Click **OK**.
   
   *Note:* If you click **Cancel**, your actions are not performed.

### Display 13.13 Section Filters Dialog Box with Selected and Deselected Filters

---

**Remove a Custom Section Filter**

To remove a custom section filter so that it can no longer be applied to the section query, complete these steps:

*Note:* If you want to keep the filter for use at a later time, deselect its check box.

1. Select either **Options ⇒ Section Filters** or **Data ⇒ Section Filters** to open the Section Filters dialog box.

2. In the **Apply custom filters** box, select the name of the filter that you want to remove from the section query.

3. Click **Remove**.

4. Click **OK** in the message box to confirm the removal of the filter.
   
   *Note:* If you click **Cancel**, the filter is not removed.

---

**View a Summary of Applied Filters**

To display a summary of applied filters that are active, right-click on the report object, and then select **Data Source Details**.
Click **OK** to close the Data Source Details dialog box.
Chapter 14
Grouping Query Results

Overview of Using Group Breaks

Each report section can be divided by one or more group breaks. Each group break is based on a category or hierarchy level. It groups the data for each distinct value of that category or hierarchy level. Group breaks are applicable when your report uses data items selected from a data source.

These features are options when creating a group break. They are discussed in this chapter:

- You can include a measure value with each group break level.
- You can sort each level in ascending or descending order.
- If you select a page break to go with each group break, the report displays a table of contents for navigation.

The following advanced group break features are discussed in other parts of this documentation:

- You can link group break values to a report or to a Web page. For more information, see “Creating a Link for a Group Break” on page 255.
- Reports with group breaks can be distributed to targeted recipients based on the breaks. For example, you have a sales report with group breaks on regions. Each sales manager in the recipient list could receive information on his or her respective region only.

Add Group Breaks

The number of group break levels that you can create depends on how many categories or hierarchies are in the report section. For example, if you have three categories and two hierarchies, then you can specify four breaks, which means that you will see one drop-down list for Break by values of and three drop-down lists for Then by values of.
Note: Group breaks cannot be used on different levels of the same hierarchy.

Data items that act as hyperlinks are not allowed to be group break variables, so they are always removed from the list.

To specify group breaks, complete these steps:

1. In Edit mode, select Data ⇒ Edit Group Breaks or from the Table of Contents pane, select Options ⇒ Group Breaks to open the Group Breaks dialog box.

2. On the Group Breaks tab, complete these steps:
   a. Select the first group break level in the Break by values of list. The Break by values of list contains all the categories and hierarchy levels in the report section.
   b. (Optional) Select additional group break levels from any available Then by values of list.
   c. Select a sort option for the category or hierarchy level values. The default is Ascending.
   d. (Optional) Select the New page for each value check box.
   e. (Optional) Use the formatting tools to change the default font, font size, font style, background color, and foreground color.
   f. (Optional) Select the Label each value option to label each group break with its category or hierarchy name. If you include a dynamic measure with one or more group breaks, then this option also applies to labeling measures.

Display 14.1 Group Break Tab in the Group Break Dialog Box

3. (Optional) Use the Measure values tab to complete these steps:
   a. Select a group break in the For group break level drop-down list. The list contains the group breaks that you selected on the Group Breaks tab.
   b. In the Show measure value list, select the measure value that you want to display for each group break level. For example, if you select Country as the group break level, you might select Total Profit as the data item value. The profit aggregated across each country are displayed at each group break level.

Note: The measure value is an aggregation for each group break that you selected.
Note: If you remove the selected measure from the report, then the measure value is removed from the group break.

c. Click Add to add your For group break level and Show measure value selections to the Group break level/value box.

4. Click OK.

For reports that contain tables, graphs, or geographical maps that have been filtered, drilled, or expanded, these actions are taken:

• Filters and conditional highlighting that depend on a data item that you have selected as a group break are removed from the filtered table, graph, or geographical map.

• Navigation (drilling or expanding) that has been performed on a data item that you have selected as a group break are removed from the drilled or expanded table, graph, or geographical map. (Expanding and drilling are performed in View mode.)

In addition, if you create a group break that is based on any level in a geographic hierarchy, then any geographical map in the report section becomes invalid.

Note: To collapse the Group Breaks section, click 📸.

---

Remove Measure Values from Group Breaks

To remove measure values from group breaks, complete these steps:

1. In Edit mode, select Data ⇒ Edit Group Breaks or from the Table of Contents pane, select Options ⇒ Group Breaks to open the Group Breaks dialog box.

2. Select the Measure values tab.

3. Select an item in the Group break level/value box.

4. Click Remove.
Remove Group Breaks

To remove group breaks, complete these steps:

1. In Edit mode, select Data ⇒ Edit Group Breaks or from the Table of Contents pane, select Options ⇒ Group Breaks to open the Group Breaks dialog box.

2. Select None for the first level of group breaks that you want to remove. All subsequent breaks are also removed. For example, if four group break levels are available, you can remove the second, third, and fourth group breaks by selecting None as the second break.

3. Click OK.
Chapter 15
Displaying Query Results in a Table, Graph, or Geographical Map

Overview of Using Tables, Graphs, and Geographical Maps to Display Results
Using Tables to Display Query Results
Using Hyperlink Data Items
Using Graphs to Display Query Results
Using Geographical Maps to Display Query Results
Overview of Using Tables, Graphs, and Geographical Maps to Display Results

After you select your data items and filters, you must add one or more view elements to contain the results. For more information about selecting data items and filters, see Chapter 12, “Defining Queries to Obtain Results,” on page 85.

SAS Web Report Studio enables you to select two different table types: crosstabulation tables and list tables. For more information about using tables, see “Using Tables to Display Query Results” on page 124.

SAS Web Report Studio enables you to select seven different graph types: bar charts, line graphs, bar-line charts, pie charts, scatter plots, progressive bar charts, and tile charts. For more information about using graphs, see “Using Graphs to Display Query Results” on page 137.

Geographical maps enable you to consider spatial proximity as part of your analysis. You can add geographical maps to reports that use data items from a multidimensional data source that has been enabled for geographical mapping. For more information about using geographical maps, see “Using Geographical Maps to Display Query Results” on page 162.

Using Tables to Display Query Results

Overview of the Table Types

About List Tables
A list table is a two-dimensional representation of data, in which the data values are arranged in unlabeled rows and labeled columns. List tables are applicable when you use data items selected from a relational data source.
Display 15.1  A List Table

<table>
<thead>
<tr>
<th>Order Year</th>
<th>Customer Profit</th>
<th>Customer Group</th>
</tr>
</thead>
<tbody>
<tr>
<td>2006</td>
<td>$8,166,688.00</td>
<td>Orion Club Gold members</td>
</tr>
<tr>
<td>2006</td>
<td>$1,297,045.65</td>
<td>Internet/Catalog Customers</td>
</tr>
<tr>
<td>2005</td>
<td>$6,441,198.70</td>
<td>Orion Club members</td>
</tr>
<tr>
<td>2007</td>
<td>$5,586,238.29</td>
<td>Orion Club members</td>
</tr>
<tr>
<td>2007</td>
<td>$5,967,398.20</td>
<td>Orion Club Gold members</td>
</tr>
<tr>
<td>2007</td>
<td>$1,206,403.53</td>
<td>Internet/Catalog Customers</td>
</tr>
<tr>
<td>2006</td>
<td>$1,478,223.64</td>
<td>Internet/Catalog Customers</td>
</tr>
<tr>
<td>2006</td>
<td>$6,640,757.12</td>
<td>Orion Club members</td>
</tr>
<tr>
<td>2006</td>
<td>$8,111,814.46</td>
<td>Orion Club Gold members</td>
</tr>
<tr>
<td>2005</td>
<td>$5,423,055.54</td>
<td>Orion Club members</td>
</tr>
<tr>
<td>2005</td>
<td>$6,660,402.50</td>
<td>Orion Club Gold members</td>
</tr>
<tr>
<td>2005</td>
<td>$1,168,342.57</td>
<td>Internet/Catalog Customers</td>
</tr>
<tr>
<td>2004</td>
<td>$4,704,975.00</td>
<td>Orion Club members</td>
</tr>
<tr>
<td>2004</td>
<td>$1,030,368.33</td>
<td>Internet/Catalog Customers</td>
</tr>
<tr>
<td>2004</td>
<td>$5,827,555.79</td>
<td>Orion Club Gold members</td>
</tr>
</tbody>
</table>

For more information, see “Using Tables to Display Query Results” on page 124.

About Crosstabulation Tables
A crosstabulation table shows frequency distributions or other aggregate statistics for the intersections of two or more categories. In a crosstabulation table, categories are displayed on both the columns and the rows, and each cell value represents the data result from the intersection of the categories on the specific row and column.

Display 15.2  A Crosstabulation Table That Is Based on Data Items From a Relational Data Source

<table>
<thead>
<tr>
<th>Order Year</th>
<th>2004</th>
<th>2005</th>
<th>2006</th>
<th>2007</th>
<th>2008</th>
</tr>
</thead>
<tbody>
<tr>
<td>Order Type</td>
<td>Customer Profit</td>
<td>Customer Profit</td>
<td>Customer Profit</td>
<td>Customer Profit</td>
<td>Customer Profit</td>
</tr>
<tr>
<td>Retail</td>
<td>$1,068,757.67</td>
<td>$1,211,466.58</td>
<td>$1,455,528.99</td>
<td>$1,174,859.87</td>
<td>$1,401,197.20</td>
</tr>
<tr>
<td>Catalog</td>
<td>$116,571.05</td>
<td>$129,753.12</td>
<td>$140,054.12</td>
<td>$129,220.99</td>
<td>$102,243.87</td>
</tr>
<tr>
<td>Internet</td>
<td>$89,532.05</td>
<td>$87,450.08</td>
<td>$110,471.03</td>
<td>$113,023.73</td>
<td>$135,239.94</td>
</tr>
<tr>
<td>Sale</td>
<td>$1,068,757.67</td>
<td>$1,211,466.58</td>
<td>$1,455,528.99</td>
<td>$1,174,859.87</td>
<td>$1,401,197.20</td>
</tr>
</tbody>
</table>
Display 15.3  In This Crosstabulation Table That Is Based on Data Items From a Multidimensional Data Source, Drilling and Expanding Are Enabled

![Crosstabulation Table]

**Tip**  For crosstabulation tables that are based on multidimensional data sources, the hierarchy level names are displayed in the table, rather than the hierarchy names. In Display 15.3 on page 126, Year is a level in a hierarchy named Time, and Continent is a level in a hierarchy named Geography.

**Insert a Table into a Report Layout**

If the section query is based on a relational data source, you can display the query results in a list table or a crosstabulation table. If the section query is based on a multidimensional data source, you can display results in a crosstabulation table.

To insert a table into a report layout, perform one of these tasks:

- Click the table tool on the layout grid toolbar to insert the table in the next available cell.
- Drag the table tool from the toolbar into a specific cell.

The following table lists the available table tools:

<table>
<thead>
<tr>
<th>Tool</th>
<th>Table Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>![List Table Icon]</td>
<td>list table</td>
</tr>
<tr>
<td>![Cross Table Icon]</td>
<td>crosstabulation table</td>
</tr>
</tbody>
</table>

Data items in the section query are given the following default assignments in a new table:

- For list tables, all data items are assigned to the columns.
- For crosstabulation tables, data items are assigned to functions in this way:
  - If multiple categories or hierarchies have been selected from the data source, then the first category or hierarchy and all of the measures are assigned to the columns.
  - If only one category or hierarchy is selected from the data source, then the category or hierarchy is assigned to the rows and the measures are assigned to the columns.
You can change the default assignments. For example, you might want to make these changes:

- A list table is displaying values for an **Employee Salary** measure. You want to hide the salary information.
- A crosstabulation table has gender information on the rows. You want to move the **Gender** category from the rows to the columns.

For more information, see “**Specifying How Data Items Are Used in Tables**” on page 127.

Tables also have default properties that you can change. For example, by default, tables do not have titles. To create a title, you open the Properties dialog box and enter text in the **Title** field on the **General** tab. For more information, see “**Specify Style Properties for Total and Subtotal Values**” on page 133.

**TIP** In general, the defaults for properties that are related to style (for example, font and color) depend on the currently applied report style. For more information, see “**Modifying Report Properties**” on page 227.

For more information about how to make other table modifications, see the following topics:

- “**Create or Modify a Table Title**” on page 128.
- “**Specify the Number of Columns and Rows to Display in a Table**” on page 129.
- “**Specify the Border Color of a Table**” on page 131.
- “**Specify Style Properties for Headings, Subheadings, and Cells**” on page 132.
- “** Specify Style Properties for Total and Subtotal Values**” on page 133.
- “**Copy the Formatting of a Selected Table**” on page 134.
- “**Move Columns and Rows in Tables in the View Mode**” on page 135.

The following chapters contain additional information:

- Chapter 10, “**Positioning Objects in the Layout Grid,**” on page 77.
- Chapter 11, “**Using Synchronized or Independent Objects,**” on page 81.
- Chapter 16, “**Filtering and Ranking,**” on page 169.
- Chapter 17, “**Drilling and Expanding,**” on page 189.
- Chapter 18, “**Sorting,**” on page 195.
- Chapter 19, “**Adding Total, Subtotal, and Percent of Total Calculations,**” on page 201.
- Chapter 20, “**Applying Conditional Highlighting,**” on page 207.
- Chapter 25, “**Linking Reports,**” on page 251.

**Specifying How Data Items Are Used in Tables**

**Assign Data Items to Functions in List Tables**

To assign data items to functions in a list table, complete these steps:

1. Select **Data** ➠ **Assign Data** or right-click the list table and select **Assign Data** to open the Assign Data dialog box.

2. Perform one of these tasks to assign data items:
• Use drag and drop features to assign data items to either Columns or to Hidden.
• Use the Move Items drop-down list to assign each data item either to Columns or to Hidden.

Data items that are assigned to Hidden do not appear in the table but can be used in filtering. For more information, see “Hiding Data Items” on page 274.

Display 15.4  Assign Data Dialog Box with the Move Items Drop-Down List Selected

3. Click OK.

Assign Data Items to Functions in Crosstabulation Tables

To assign data items to functions in a crosstabulation table, complete these steps:

1. Right-click the list table, and then select Assign Data to open the Assign Data dialog box.

   Note: For crosstabulation tables that use relational data, some data items are not supported and do not appear in the Assign Data dialog box. The data items that do not appear include measures that use the distinct aggregation type.

2. Perform one of these tasks to assign each data item:
   • Use drag and drop features to assign data items to Rows, Columns, or Hidden.
   • Use the Move Items drop-down list to assign each data item to Rows, Columns, or Hidden.

Data items that are assigned to Hidden do not appear in the table but can be used in filtering. For more information, see “Hiding Data Items” on page 274.

3. Click OK.

Create or Modify a Table Title

By default, new tables do not have titles. To create a new title or modify an existing title, complete these steps:

1. Right-click the table, and then select Properties to open the Properties dialog box.
The **General** tab is displayed by default.

2. Under **Title**, complete these steps:
   a. Type or modify the content in the **Text** field.
      You cannot use these characters: < > & #.
   b. Specify the font, font size, font style, font color, and alignment.

   **Display 15.5**  A Table Title Specified in the Properties Dialog Box

   ![Properties - Windows Internet Explorer provided by SAS](image)

   ![A Table Title Specified in the Properties Dialog Box](image)

   ![A Crosstabulation Table with a Title](image)

3. Click **OK**.

   In View mode, the formatted title appears above the table. In Edit mode, the title appears in the table object.

   **Display 15.6**  A Crosstabulation Table with a Title

   ![A Crosstabulation Table with a Title](image)

---

**Specify the Number of Columns and Rows to Display in a Table**

To specify how many columns and rows the table should display, complete these steps:
1. Right-click the table, and then select **Properties** to open the Properties dialog box. The **General** tab is displayed by default.

2. Under **Table size**, complete these steps:
   a. Select one of these options for displaying columns in the table:
      - **Show all columns (up to system limit)**
        Select this option to display all columns in the table, up to the system limit (which is managed by your system administrator). If necessary, the table will scroll to the right. This option is the default.
        - **Note:** If you type a value that is the same as the current system limit, then this option is reset to **Show all columns (up to system limit)**.
        - **Tip:** In View mode, you can use your mouse to manually resize table columns.
      - **Limit the number of columns displayed at once**
        Select this option and type a value in the box to specify the number of columns that you want to view before scrolling is enabled.
      - **Display 15.7 New Table Sizes Specified in the Properties Dialog Box**

      ![Properties dialog box](image)

   b. Select one of these options for displaying rows in the table:
      - **Show all rows (up to system limit)**
        Select this option to display all rows in the table, up to the system limit (which is managed by your system administrator). If necessary, the table will scroll down.
      - **Limit the number of rows displayed at once**
        Select this option and type a value in the box to specify the number of rows that you want to view before scrolling is enabled. This option is the default.
        - **Note:** If you type a value that is the same as the current system limit, then this option is reset to **Show all rows (up to system limit)**.
3. Click OK.

**Specify the Border Color of a Table**

To specify the color that is used for the border of a table, complete these steps:

1. Right-click the table, and then select Properties to open the Properties dialog box.
   
   The General tab is displayed by default.

2. From the Border color palette, select a color for the table border.

   *Display 15.8  New Border Color Specified in the Properties Dialog Box*

3. Click OK.

   In Display 15.8 on page 131, red was selected as the new border color. In View mode, all of the borders for this table change to red.
Specify Style Properties for Headings, Subheadings, and Cells

All tables have headings and cells. Crosstabulation tables also have subheadings.

- Headings are the category, hierarchy level, and measure labels. Two examples are State and Retail Price.
- Subheadings are the values of the categories, hierarchy levels, and measures. For example, Alabama and North Carolina might be subheadings for a State heading.
- Table cells contain data values. For example, $228.88 and $46.43 might be values for a Retail Price measure.

To specify style properties such as font, alignment, and color for headings, subheadings, and cells, complete these steps:

1. Right-click the list table, and then select Properties to open the Properties dialog box. The General tab is displayed by default.
2. Select the Text tab.
3. Under Headings, Subheadings (crosstabulation tables only), and Cells, specify a font, font size, font style, and font color. For headings and subheadings, specify an alignment. To select a background color, use the Background fill color palette.
4. **Click OK.**

In **Display 15.10** on page 133, navy blue was selected as the new heading color and green was selected as the new subheading color. In View mode, the headings and subheadings change to the new colors.

**Display 15.11**  
*A Crosstabulation Table with a Title and Colored Headings*

---

**Specify Style Properties for Total and Subtotal Values**

To specify properties such as fonts and colors for total and subtotal values, complete these steps:

1. Right-click the table, and then select **Properties** to open the Properties dialog box.

   The **General** tab is displayed by default.
2. Select the **Totals** tab.

3. Under **Totals** and **Subtotals** (crosstabulation tables only), specify a font, font size, font style, and font color. To select a background color, use the **Background fill** drop-down list.

**Display 15.12  New Color for Totals Specified in the Properties Dialog Box**

4. Click **OK**.

**Note:** You can choose to show or hide totals in a table. For more information, see “Show or Hide Totals and Subtotals for Crosstabulation Tables” on page 203.

**Display 15.13  A Crosstabulation Table with Totals in Color**

**Copy the Formatting of a Selected Table**

To copy the formatting of a selected table to other tables in the report section, complete these steps:

1. Right-click the table, and then select **Properties** to open the Properties dialog box.
The **General** tab is displayed by default.

If the report section has more than one table, the **Apply formatting to existing tables in the section** check box is available to select no matter which tab is displayed.

2. Select the **Apply formatting to existing tables in the section** check box.

The title, heading, subheading, cell, total, subtotal, and border styles are copied to all of the tables in the section. Only the relevant information is copied. For example, the subheading style does not apply to list tables.

3. Click **OK**.

### Change the Currently Selected Table Type

To change the currently selected table type, complete these steps:

1. Right-click the table, and then select **Properties** to open the Properties dialog box.

   The **General** tab is displayed by default.

   The **Table type** drop-down list is available to use no matter which tab is displayed.

2. For the **Table type** radio buttons, select either **List** or **Crosstab**, depending on the current table type. However, you cannot change the table type if the current table meets either of these conditions:

   - a crosstabulation table that uses multidimensional data cannot be changed to a list table.
   - a list table that does not include at least one category and one measure cannot be changed to a crosstabulation table.

3. Click **OK**.

The data item assignments and properties are changed to match the new table type. For example, not all data items are supported in crosstabulation tables that are based on relational data. So, if you change a list table to a crosstabulation table, then any measures that use the distinct aggregation type are removed. That is, they do not appear in the Assign Data dialog box.

### Move Columns and Rows in Tables in the View Mode

The following tasks can be performed in View mode:

<table>
<thead>
<tr>
<th>Task</th>
<th>Action</th>
</tr>
</thead>
</table>
| Move measures from rows to columns or from columns to rows | • Use drag and drop features to move rows or columns.  
   • Right-click on a measure heading, and then select **Move Measures to Rows** or **Move Measures to Columns**. |

<table>
<thead>
<tr>
<th>Task</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rotate a table so that the columns are moved to the rows and the rows are moved to the columns</td>
<td>Right-click on a row or column heading, and then select <strong>Rotate Table</strong>.</td>
</tr>
<tr>
<td>Task</td>
<td>Action</td>
</tr>
<tr>
<td>------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Move a category or hierarchy level from</td>
<td>• Use drag and drop features to move a column to a row or a row to a column.</td>
</tr>
<tr>
<td>a column to a row or from a row to a</td>
<td>• Right-click on a category or hierarchy level heading, and then select <strong>Move &lt;column name&gt; to Rows</strong> or <strong>Move &lt;row name&gt; to Columns</strong>.</td>
</tr>
<tr>
<td>column</td>
<td></td>
</tr>
<tr>
<td>Move a column to the left or right</td>
<td>• Use drag and drop features to move columns.</td>
</tr>
<tr>
<td></td>
<td>• Right-click on a column heading, and then select <strong>Move &lt;column name&gt; Left</strong> or <strong>Move &lt;column name&gt; Right</strong>. (Sometimes a move to the left or right is not valid, depending on the current location of the column.)</td>
</tr>
<tr>
<td>Move a row up or down (in crosstabulation</td>
<td>• Use drag and drop features to move a row.</td>
</tr>
<tr>
<td>tables that have more than one row)</td>
<td>• Right-click on a row heading, and then select <strong>Move &lt;row name&gt; Up</strong> or <strong>Move &lt;row name&gt; Down</strong>. Note that the top row cannot be moved up and the bottom row cannot be moved down.</td>
</tr>
</tbody>
</table>

**Display 15.14  Example Menu Selection for Moving Rows to Columns**

![Example Menu Selection for Moving Rows to Columns](image)

**Resize Columns in a Table**

You can use drag and drop features to make the columns in a table larger or smaller.

**Using Hyperlink Data Items**

When an information map for relational data is created, your data administrator can indicate that a given category data item contains HTML string values that define hyperlinks. An example of a database value associated with a hyperlink data item might be the following: `<a href=http://abc.com/sas.html>SAS Institute</a>`. This example is an
Display 15.15 on page 137 shows an example of hyperlink data items in a list table.

**Display 15.15  A List Table That Contains Hyperlink Data Items**

<table>
<thead>
<tr>
<th>Company</th>
<th>Employees</th>
<th>State</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blue Ridge Transport</td>
<td>228211</td>
<td>TN</td>
</tr>
<tr>
<td>Coastal Super Market</td>
<td>142004</td>
<td>FL</td>
</tr>
<tr>
<td>International Hotels</td>
<td>134013</td>
<td>WA</td>
</tr>
<tr>
<td>Coffee Company</td>
<td>123203</td>
<td>DC</td>
</tr>
<tr>
<td>Infinite Clothing</td>
<td>49769</td>
<td>WA</td>
</tr>
<tr>
<td>Radix Software</td>
<td>47645</td>
<td>WA</td>
</tr>
<tr>
<td>Natural Food Co.</td>
<td>41305</td>
<td>TX</td>
</tr>
<tr>
<td>University Clinic</td>
<td>41004</td>
<td>MN</td>
</tr>
<tr>
<td>D&amp;J Investments</td>
<td>35517</td>
<td>NY</td>
</tr>
<tr>
<td>Red Apple Markets</td>
<td>35302</td>
<td>NY</td>
</tr>
</tbody>
</table>

Display 15.16 on page 137 shows an example of hyperlink data items in a relational crosstabulation table.

**Display 15.16  A Crosstabulation Table That Contains Hyperlink Data Items**

<table>
<thead>
<tr>
<th>State</th>
<th>Company</th>
<th>Employees</th>
</tr>
</thead>
<tbody>
<tr>
<td>TN</td>
<td>Blue Ridge Transport</td>
<td>228211</td>
</tr>
<tr>
<td>FL</td>
<td>Coastal Super Market</td>
<td>142004</td>
</tr>
<tr>
<td>DC</td>
<td>International Hotels</td>
<td>123203</td>
</tr>
<tr>
<td>WA</td>
<td>Coffee Company</td>
<td>134013</td>
</tr>
<tr>
<td></td>
<td>Infinite Clothing</td>
<td>49769</td>
</tr>
<tr>
<td></td>
<td>Radix Software</td>
<td>47645</td>
</tr>
<tr>
<td>TX</td>
<td>Natural Food Co.</td>
<td>41305</td>
</tr>
<tr>
<td>MN</td>
<td>University Clinic</td>
<td>41004</td>
</tr>
<tr>
<td>NY</td>
<td>D&amp;J Investments</td>
<td>35517</td>
</tr>
<tr>
<td></td>
<td>Red Apple Markets</td>
<td>35302</td>
</tr>
</tbody>
</table>

When you click the underlined hyperlink item, the action specified by the HTML is performed. In most cases, the browser opens a Web page.

Although SAS Web Report Studio lets you place hyperlink data items into a graph, in most cases, it does not make sense to do so. The hyperlink data item is mainly intended for use in relational tables.

---

Using Graphs to Display Query Results

**Overview of the Graph Types**

**About Bar Charts**

A bar chart consists of a grid and some vertical or horizontal bars. Each bar represents quantitative data.
Display 15.17  A Bar Chart That Is Based on Data Items From a Relational Data Source

About Bar-Line Charts
A bar-line chart is a bar chart with an overlaid line graph.

Display 15.18  A Bar-Line Chart That Is Based on Data Items From a Relational Data Source

About Line Graphs
A line graph shows the relationship of one variable to another, often as movements or trends in the data over a period of time. Line graphs summarize source data and typically are used to chart response values against discrete categorical values.
**About Pie Charts**

A pie chart is a circular chart that is divided into slices by radial lines. Each slice represents the relative contribution of each part to the whole.
About Progressive Bar Charts
A progressive bar chart shows how the initial value of a measure increases or decreases during a series of operations or transactions. The first bar begins at the initial value, and each subsequent bar begins where the previous bar ends. The length and direction of a bar indicates the magnitude and type (positive or negative, for example) of the operation or transaction. The resulting chart is a stepped cascade that shows how the transactions or operations lead to the final value of the measure.
**Display 15.21  A Progressive Bar Chart That Is Based on Data Items From a Relational Data Source**

A scatter plot is a two-dimensional plot that shows the joint variation of two data items. In a scatter plot, each marker (represented by symbols such as dots, squares, and plus signs) represents an observation. The marker position indicates the value for each observation.

**Display 15.22  A Scatter Plot That Is Based on Data Items From a Multidimensional Data Source**

A tile chart is divided into rectangular areas. The color of each area represents the value of the first measure in the query. The size of each area represents the value of the second measure in the query. For example, a tile chart might be used to represent sales data where the tile sizes vary according to the size of product inventories and the tile colors are derived from a color gradient that represents low to high sales figures.
Display 15.23  A Tile Chart That Is Based on Data Items From a Multidimensional Data Source

Insert a Graph into a Report Layout

To insert a graph into a report layout, perform one of these tasks:

- Click the graph tool on the layout grid toolbar to insert the graph in the next available cell.
- Drag the graph tool from the toolbar into a specific cell.

The following table lists the available graph tools.

Note: If you selected either of the detail data options in the Summarization Options dialog box, then the only graph type available to insert is a scatter plot. For more information, see “Use Detail Data Instead of Grouped and Aggregated Data” on page 97.

<table>
<thead>
<tr>
<th>Tool</th>
<th>Graph Type</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="bar chart" /></td>
<td>bar chart</td>
</tr>
<tr>
<td><img src="image" alt="line graph" /></td>
<td>line graph</td>
</tr>
<tr>
<td><img src="image" alt="bar-line chart" /></td>
<td>bar-line chart</td>
</tr>
<tr>
<td><img src="image" alt="progressive bar chart" /></td>
<td>progressive bar chart</td>
</tr>
<tr>
<td><img src="image" alt="scatter plot" /></td>
<td>scatter plot</td>
</tr>
<tr>
<td><img src="image" alt="pie chart" /></td>
<td>pie chart</td>
</tr>
<tr>
<td><img src="image" alt="tile chart" /></td>
<td>tile chart</td>
</tr>
</tbody>
</table>
Data items in the section query are given the default assignments (see Table 15.1 on page 143) in a new graph.

### Table 15.1 Default Data Assignments in New Graphs

<table>
<thead>
<tr>
<th>Graph Type</th>
<th>Measures</th>
<th>Categories/Hierarchies</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>First Measure</td>
<td>Second Measure</td>
</tr>
<tr>
<td>bar charts and progressive bar charts</td>
<td>bar height</td>
<td>hidden</td>
</tr>
<tr>
<td>bar-line charts</td>
<td>bar height</td>
<td>line height</td>
</tr>
<tr>
<td>line graphs</td>
<td>line height</td>
<td>hidden</td>
</tr>
<tr>
<td>pie charts</td>
<td>segment size</td>
<td>hidden</td>
</tr>
<tr>
<td>scatter plots</td>
<td>horizontal axis</td>
<td>vertical axis</td>
</tr>
<tr>
<td>tile charts</td>
<td>size</td>
<td>color</td>
</tr>
</tbody>
</table>

You can change the default data assignments. For example, a bar chart uses a Sales measure to determine the bar height. You want to also assign Unit Cost, which has been hidden by default, to bar height. For more information, see “Specifying How Data Items Are Used in Graphs” on page 144.

Graphs also have default properties that you can change. For example, by default, graphs do not have titles. To create a title, open the Properties dialog box and enter text in the Title field on the General tab. For more information, see “Create or Modify a Graph Title” on page 152.

**T I P** In general, the defaults for properties that are related to style (for example, font and color) depend on the currently applied report style. For more information, see Chapter 4, “Specifying Your Preferences,” on page 29.

For more information about how to make other graph modifications, see the following chapters and topics:

- Chapter 11, “Using Synchronized or Independent Objects,” on page 81.
- “Use Detail Data Instead of Grouped and Aggregated Data” on page 97 (scatter plots only).
- Chapter 16, “Filtering and Ranking,” on page 169.
- Chapter 17, “Drilling and Expanding,” on page 189.
Specifying How Data Items Are Used in Graphs

Assign Data Items to Functions in Bar Charts
To assign data items to functions in a bar chart, complete these steps:

1. Select **Data** ⇒ **Assign Data** or right-click in the bar chart, and then select **Assign Data** to open the Assign Data dialog box.

2. Perform one of these tasks to assign data items:
   - Use drag and drop features to assign data items.
   - Use the **Move Items** drop-down list to assign data items.

You can assign each data item to one of these functions:

- **Bar Height**
  Specify at least one measure that will be used to determine the height of each bar. You can add additional measures to **Bar Height**; however, if you assign more than one measure to **Bar Height**, then you cannot add a category or hierarchy to **Bar Subgroup**. **Bar Height** is required.

- **Bars (Limit 1)**
  Select a category or hierarchy, each value of which will be represented by one or more bars. **Bars** is required.

- **Bar Subgroup (Limit 1)**
  You can subdivide each bar across the values of the category or hierarchy that you assign to this function. However, you cannot use this function if you have assigned more than one measure to **Bar Height**.

- **Horizontal Series**
  You can create separate bar charts for each value of a selected category or hierarchy. The charts appear side by side. For example, if you select a **Gender** category for the horizontal series, a chart for each value of **Gender** is displayed side by side.

- **Vertical Series**
  You can create separate bar charts for each value of a selected category or hierarchy. The charts appear stacked one on top of the other. For example, if you select a **Gender** category for the vertical series, a chart for each value of **Gender** is stacked vertically.

- **Hidden**
  Data items that are assigned to **Hidden** do not appear in the bar chart but can be used in filtering.

For more information, see “Hiding Data Items” on page 274.
3. Click OK.

**Assign Data Items to Functions in Bar-Line Charts**
To assign data items to functions in a bar-line chart, complete these steps:

1. Select **Data ⇒ Assign Data** or right-click in the bar-line chart, and then select **Assign Data** to open the Assign Data dialog box.

2. Perform one of these tasks to assign data items:
   - Use drag and drop features to assign data items.
   - Use the **Move Items** drop-down list to assign data items.

You can assign each data item to one of these functions:

**Bar Height**
Specify one or more measures that will be used to determine the height of each bar. **Bar Height** is required.

**Line Height**
Select one or more measures that will be used to determine the height of the line at each bar. **Line Height** is required.

**Category (Limit 1)**
Select a category or hierarchy, each value of which will be represented by one or more bars and one or more lines. **Category** is required.

**Horizontal Series**
You can create separate bar-line charts for each value of a selected category or hierarchy. The charts appear side by side. For example, if you select a **Gender** category for the horizontal series, a chart for each value of **Gender** is displayed side by side.

**Vertical Series**
You can create separate bar-line charts for each value of a selected category or hierarchy. The charts appear stacked one on top of the other. For example, if you select a **Gender** category for the vertical series, a chart for each value of **Gender** is stacked vertically.
Hidden

Data items that are assigned to Hidden do not appear in the bar-line chart but can be used in filtering.

For more information, see “Hiding Data Items” on page 274.

Display 15.25  Assign Data Dialog Box for Bar-Line Charts

3. Click OK.

Assign Data Items to Functions in Line Graphs

To assign data items to functions in a line graph, complete these steps:

1. Select Data ⇒ Assign Data or right-click in the line graph, and then select Assign Data to open the Assign Data dialog box.

2. Use the Move Items drop-down list to assign each data item to one of these functions.

   Perform one of these tasks to assign data items:

   • Use drag and drop features to assign data items.
   • Use the Move Items drop-down list to assign data items.

You can assign each data item to one of these functions:

Line Height

Select at least one measure that will determine the height of each plot point along the line. Although there is no limit to the number of measures that you can assign to Line Height, consider graph appearance and report performance when assigning multiple measures to this function. In addition, if you assign more than one measure to Line Height, then you cannot assign a category or hierarchy to Multiple Lines. Line Height is required.

Line (Limit 1)

Select a category or hierarchy, each value of which will be represented by a plot point on the lines shown in this graph. Line is required.

Multiple Lines (Limit 1)

You can subdivide the line into several lines, one for each value of the category or hierarchy that you assign to this function. However, you cannot use this function if you have assigned more than one measure to Line Height.
Horizontal Series
You can create separate line graphs for each value of a selected category or hierarchy. The charts appear side by side. For example, if you select a Gender category for the horizontal series, a chart for each value of Gender is displayed side by side.

Vertical Series
You can create separate line graphs for each value of a selected category or hierarchy. The charts appear stacked one on top of the other. For example, if you select a Gender category for the vertical series, a chart for each value of Gender is stacked vertically.

Hidden
Data items that are assigned to Hidden do not appear in the line graph but can be used in filtering.

For more information, see “Hiding Data Items” on page 274.

Display 15.26 Assign Data Dialog Box for Line Graphs

3. Click OK.

Assign Data Items to Functions in Pie Charts
To assign data items to functions in a pie chart, complete these steps:

1. Select Data ⇒ Assign Data or right-click in the pie chart, and then select Assign Data to open the Assign Data dialog box.

2. Use the Move Items drop-down list to assign each data item to one of these functions.
   Perform one of these tasks to assign data items:
   • Use drag and drop features to assign data items.
   • Use the Move Items drop-down list to assign data items.
   You can assign each data item to one of these functions:

Segment Size
Select at least one measure that will determine the size of each segment. Although there is no limit to the number of measures that you can assign to Segment Size, consider graph appearance and report performance when assigning multiple
measures to this function. In addition, if you assign more than one measure to **Segment Size**, then you cannot add a category or hierarchy to **Pie Stacks**. **Segment Size** is required.

**Segments (Limit 1)**
Select a category or hierarchy, each value of which will be represented by a segment. **Segments** is required.

**Pie Stacks (Limit 1)**
You can subdivide the pie chart into a stack of pie charts, one for each value of the category or hierarchy that you assign to this function. However, you cannot use this function if you have assigned more than one measure to **Segment Size**.

**Horizontal Series**
You can create separate pie charts for each value of a selected category or hierarchy. The charts appear side by side. For example, if you select a **Gender** category for the horizontal series, a chart for each value of **Gender** is displayed side by side.

**Vertical Series**
You can create separate pie charts for each value of a selected category or hierarchy. The charts appear stacked one on top of the other. For example, if you select a **Gender** category for the vertical series, a chart for each value of **Gender** is stacked vertically.

**Hidden**
Data items that are assigned to **Hidden** do not appear in the pie chart but can be used in filtering.

For more information, see “Hiding Data Items” on page 274.

**Display 15.27 Assign Data Dialog Box for Pie Charts**

3. Click **OK**.

**Assign Data Items to Functions in Progressive Bar Charts**
To assign data items to functions in a progressive bar chart, complete these steps:

1. Select **Data** ⇒ **Assign Data** or right-click in the progressive bar chart, and then select **Assign Data** to open the Assign Data dialog box.

2. Perform one of these tasks to assign data items:
• Use drag and drop features to assign data items.
• Use the Move Items drop-down list to assign data items.

You can assign each data item to one of these functions:

**Bar Height (Limit 1)**
Specify the measure that will be used to determine the height of each bar. **Bar Height** is required.

**Bars (Limit 1)**
Select a category or hierarchy, each value of which will be represented by a bar. **Bars** is required.

**Horizontal Series**
You can create separate progressive bar charts for each value of a selected category or hierarchy. The charts appear side by side. For example, if you select a Gender category for the horizontal series, a chart for each value of Gender is displayed side by side.

**Vertical Series**
You can create separate progressive bar charts for each value of a selected category or hierarchy. The charts appear stacked one on top of the other. For example, if you select a Gender category for the vertical series, a chart for each value of Gender is stacked vertically.

**Hidden**
Data items that are assigned to **Hidden** do not appear in the progressive bar chart but can be used in filtering.

For more information, see “Hiding Data Items” on page 274.

**Display 15.28  Assign Data Dialog Box for Progressive Bar Charts**

3. Click **OK**.

**Assign Data Items to Functions in Scatter Plots**
To assign data items to functions in a scatter plot, complete these steps:

1. Select **Data ⇒ Assign Data** or right-click in the scatter plot, and then select **Assign Data** to open the Assign Data dialog box.
2. Perform one of these tasks to assign data items:
   • Use drag and drop features to assign data items.
   • Use the Move Items drop-down list to assign data items.

You can assign each data item to one of these functions:

**Vertical Axis (Limit 1)**
Specify the measure that will be used to determine the vertical position of each marker. Vertical Axis is required.

**Horizontal Axis (Limit 1)**
Select the measure that will be used to determine the horizontal position of each marker. Horizontal Axis is required.

**Marker Groups (Limit 1)**
Select a category or hierarchy, each value of which will be a set of markers. Marker Groups is required for multidimensional data sources. If detail data is used, then this function groups and colors the data points. If aggregated data is used, there is one point for each data value in the category or hierarchy.

**Marker Size (Limit 1)**
Select the measure that will be used to determine the size of each marker.

*Note:* You can also use the Markers tab in the Properties dialog box to specify a marker size that will be constant for all markers in the graph.

**Horizontal Series**
You can create separate scatter plots for each value of a selected category or hierarchy. The charts appear side by side. For example, if you select a Gender category for the horizontal series, a chart for each value of gender is displayed side by side.

**Vertical Series**
You can create separate scatter plots for each value of a selected category or hierarchy. The charts appear stacked one on top of the other. For example, if you select a Gender category for the vertical series, a chart for each value of gender is stacked vertically.

**Hidden**
Data items that are assigned to Hidden do not appear in the scatter plot but can be used in filtering.

For more information, see “Hiding Data Items” on page 274.
3. Click OK.

Assign Data Items to Functions in Tile Charts

To assign data items to functions in a tile chart, complete these steps:

1. Select Data ⇒ Assign Data or right-click in the tile chart, and then select Assign Data to open the Assign Data dialog box.

2. Use the Move Items drop-down list to assign each data item to one of these functions.

   Perform one of these tasks to assign data items:
   
   • Use drag and drop features to assign data items.
   
   • Use the Move Items drop-down list to assign data items.

   You can assign each data item to one of these functions:

   Categories
   
   Select one or more categories or hierarchies whose values determine the number of tiles and the arrangement of the tiles. Each tile is associated with a value for each of the categories that it represents. For example, you might have a widget for a country with three categories that it is associated with. Although there is no limit to the number of categories or hierarchies that you can assign to Categories, consider graph appearance and report performance when assigning multiple categories or hierarchies to this function. Categories is required.

   Size (Limit 1)
   
   Select the measure whose values are used to determine the size of each tile. Size is required.

   Color (Limit 1)
   
   Select the measure whose values are used to create the gradient colors in the chart. To specify colors for low, medium, and high values, use the Properties dialog box. The default colors are based on the report’s currently applied style. If you do not assign a measure to this function, the measure that is assigned to Size is also used to determine the colors.
Auxiliary Data Tips
Select one or more measures whose values you want to display as data tips. Although there is no limit to the number of measures that you can assign to Auxiliary Data Tips, consider report performance when assigning many measures to this function. Data tip values for the categories, color and size measures, and auxiliary data tip measures appear when you move the mouse over a tile.

Hidden
Data items that are assigned to Hidden do not appear in the tile chart but can be used in filtering.

For more information, see “Hiding Data Items” on page 274.

Display 15.30  Assign Data Dialog Box for Tile Charts

3. Click OK.

Create or Modify a Graph Title
By default, new graphs do not have titles. To create a new title or to modify an existing title, complete these steps:

1. Right-click in the chart, and then select Properties to open the Properties dialog box. The General tab is displayed by default.
2. Under Title, complete these steps:
   a. Type or modify the content in the Text field.
      You cannot use these characters: < > & #
   b. Specify the font, font size, font style, font color, and alignment.
3. Click **OK**.

In View mode, the formatted title appears above the graph. In Edit mode, the title appears in the graph object.

**Specify the Size of a Graph**

To change the size of a graph, complete these steps:

1. Right-click in the graph, and then select **Properties** to open the Properties dialog box. The **General** tab is displayed by default.

2. Under **Graph size**, select one of these options (depending on the graph type):

   - **Automatic (adjust to fit data)** (all graph types except tile charts)
     - Select this option to produce a graph that best fits the size of the current window. This option is the default.

   - **Fixed size (can be manually adjusted while viewing reports)** (for all graph types except tile charts)
     - Select this option if you want to specify a fixed size for the graph. From the dropdown list, select **Small, Medium, Large**, or **Custom**. If you select **Custom**, type the width and height in pixels. The maximum width is 1200 pixels. The maximum height is 900 pixels.
To specify a fixed graph size, from the Size drop-down list, select Small, Medium, Large, or Custom. If you select Custom, type the width and height in pixels. The maximum width is 1200 pixels. The maximum height is 900 pixels. The default is Medium.

3. Click OK.

**T I P** If you select the Fixed size option, you can use your mouse to resize the graph in View mode. Point to the bottom right corner or to the bottom or right border. When the pointer becomes a horizontal, vertical, or diagonal bar, you can drag the graph to the new size and then release the mouse button.

### Specify the Border for a Graph

By default, graph borders are turned off. To specify that a graph has a border, complete these steps:

1. Right-click in the graph, and then select Properties to open the Properties dialog box. The General tab is displayed by default.
2. Select the Border check box. Clear the check box if you no longer want the graph to have a border.
3. Click OK.

### Specify the Border Color of a Graph

To specify the color that is used for the border of a graph, complete these steps:

1. Right-click in the graph, and then select Properties to open the Properties dialog box. The General tab is displayed by default.
2. From the Border drop-down list, select a border color for the graph.
3. Click OK.

### Specify the Background Color of a Graph

You can specify a background color for all graph types except tile charts. To specify a background color, complete these steps:

1. Right-click in the graph, and then select Properties to open the Properties dialog box. The General tab is displayed by default.
2. From the Background drop-down list, select a background color for the graph.
3. Click OK.

### Turn Grid Lines On or Off

Grid lines are available for all graph types except pie charts and tile charts. To turn grid lines on or off and to specify a color for the lines, complete these steps:

1. Right-click in the graph, and then select Properties to open the Properties dialog box.
The **General** tab is displayed by default.

2. Select or clear the **Grid lines** check box, depending on whether you want to hide or show grid lines on the graph. Grid lines are turned on by default.

3. If you are showing grid lines, then select a line color from the drop-down list.

4. Click **OK**.

---

**Specify the Scale Type and Style of the Axis**

You can specify axis properties for all graph types except for pie charts and tile charts. To specify properties, complete these steps:

1. Right-click in the graph, and then select **Properties** to open the Properties dialog box.

   The **General** tab is displayed by default.

2. Select the **Axis** tab.

3. (Optional) You can select **Display an additional axis for the second measure** if one of the following conditions is true for the currently selected graph:
   - It is a bar chart and exactly two measures are assigned to the bar height.
   - It is a line graph and exactly two measures are assigned to the measure axis.
   - It is a bar-line chart.

4. Under **Scale**, select **Automatic** or **Fixed**. The default is **Automatic**.

5. If you selected **Fixed**, then enter any combination of a minimum value, maximum value, baseline value, and tick mark increment for the indicated axis or axes.

   - For bar charts, line graphs, bar-line charts, and progressive bar charts, enter values for the first (or only) measure axis.

   - For bar charts and line graphs, if you selected **Display an additional axis for the second measure**, then you can also enter values for the second measure axis.

   - For scatter plots, enter values for the vertical axis, the horizontal axis, or both.

   **TIP** Before entering fixed values, find out what the default scale values are by displaying the graph in View mode.

6. Under **Labels**, select a font, font size, font style, font color, and orientation for the axis labels. The default orientation is **Horizontal**.

   **Note:** The orientation option is not available for bar charts that use horizontal bars.

7. Under **Values**, select a font, font size, font style, and font color for the axis values.

8. Click **OK**.

   **Note:** Tick marks are displayed next to each value of the data item.

---

**Add, Modify, or Remove Reference Lines**

You can add, modify, or remove reference lines for all graph types, except pie charts or tile charts.

To add reference lines, complete these steps:

1. Right-click in the graph, and then select **Properties** to open the Properties dialog box.
The **General** tab is displayed by default.

2. Select the **Reference Lines** tab.

3. Under **Reference Lines**, complete these steps:
   a. Type content in the **Label** field.
      You cannot use these characters: < > & #
   b. Select an item from the **Based on** drop-down list.
   c. Enter a **Value**.
   d. Specify the font, font size, font style, alignment, and color.
   e. Specify a color and width for **Line style**.

4. (Optional) Add another reference line or lines to the graph.

5. (Optional) Modify the properties of a reference line. For example, you might change the **Label**. Click **Change**.

6. (Optional) Remove a reference line by selecting it in the list of existing reference lines. Click **Remove**.

7. Click **OK**.
Specify the Position, Label Style, and Background Color of the Legend

Legend properties are available for all graph types except progressive bar charts. However, bar charts, line graphs, and scatter plots must meet certain requirements for the legend properties to be available, as follows:

<table>
<thead>
<tr>
<th>Graph Type</th>
<th>Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bar charts</td>
<td>A category must be assigned to the bar subgroup function or the bar chart must use more than one measure.</td>
</tr>
<tr>
<td>Line graphs</td>
<td>A category must be assigned to the multiple lines function or the line graph must use more than one measure.</td>
</tr>
<tr>
<td>Scatter plots</td>
<td>For scatter plots that use relational data, a category must be assigned to the marker groups function. (Legend properties are always available for scatter plots that use multidimensional data.)</td>
</tr>
</tbody>
</table>

To specify legend properties, complete these steps:

1. Right-click in the graph, and then select Properties to open the Properties dialog box.
   The General tab is displayed by default.
2. Select the Legend tab.
3. Under Position, select Above, Below, Left, or Right. The default is Below.
   **TIP** To leave more horizontal room for the graph, position the legend above or below the graph.
4. Under Labels, select a font, font size, font style, and font color for the labels in the legend.
   **Note:** You cannot format labels for bar-line charts that use multidimensional data.
5. For bar charts, pie charts, bar-line charts, line graphs, and scatter plots, select a color from the Background drop-down list.
   **Note:** You cannot select a background color for tile charts or for bar charts, pie charts, and line graphs that use multidimensional data.
6. (Optional) Select a color from the Border drop-down list.
7. Click OK.

Copy the Formatting of a Selected Graph

To copy the formatting of a selected graph to other graphs in the report section, complete these steps:

1. Right-click in the graph, and then select Properties to open the Properties dialog box.
   The General tab is displayed by default.
   The option to copy formatting appears on all of the tabs in the Properties dialog box.
2. Select the check box to specify that you want the formatting applied to other graphs in the section. Depending on the graph type, one of these options will display:

**Apply formatting to existing graphs in the section** (all graph types except tile charts)
Formatting properties that are copied include title style, background color, border color, marker size, bar shape, the option to display a second measure axis, measure axis label orientation, the option to display data labels, and legend style.

Only relevant properties are copied. For example, the bar shape property is not copied to pie charts, and legend style properties are not copied to progressive bar charts, which do not support legends.

**Apply formatting to existing tile charts in this section** (tile charts only)
Formatting properties are copied only to other tile charts in the section.

3. Click **OK**.

**Change the Currently Selected Graph Type**
Except for tile charts, you can change a selected graph from one type to another. Complete these steps:

1. Right-click in the graph, and then select **Properties** to open the Properties dialog box.

   The **General** tab is displayed by default.

2. From the **Graph type** drop-down list, select the new graph type.

3. Click **OK**.

   The data item assignments and properties are changed to match the new graph type.

**Specifying Properties That Are Specific to a Graph Type**

**Specify Properties That Are Specific to a Bar Chart**
To specify properties that are specific to a bar chart, complete these steps:

1. Right-click in the bar chart, and then select **Properties** to open the Properties dialog box.

   The **General** tab is displayed by default.

2. Select the **Bar** tab.

3. Under **Orientation**, specify whether you want to use **Vertical bars** or **Horizontal bars**. The default is **Vertical bars**.

4. Under **Subgroup**, specify whether you want to display **Stacked bars** or **Clustered bars**. Clustered bars, the default, are grouped next to each other along the horizontal axis.

   **Note**: This property is available only if a data item is assigned to the bar subgroup function in the Assign Data dialog box.

5. From the **Shape** drop-down list, select **Two-dimensional bar**, **Three-dimensional bar**, or **Three-dimensional cylinder**. The default is **Two-dimensional bar**.

6. (Optional) Select the **Show data values** option to display a value above each vertical bar or to the right of each horizontal bar.
7. Click OK.

**Specify Properties That Are Specific to a Bar-Line Chart**

To specify properties that are specific to a bar-line chart, complete these steps:

1. Right-click in the bar-line chart, and then select Properties to open the Properties dialog box.
   
   The General tab is displayed by default.

2. Select the Bar-line tab.

3. Under Shape and Size, specify these options:
   
   a. From the Bar shape drop-down list, select a shape for the bars. Your choices are Two-dimensional bar, Three-dimensional bar, or Three-dimensional cylinder. The default is Two-dimensional bar.
   
   b. From the Line thickness drop-down list, select a point size. Sizes range from 1 to 5 points. The default is 2 pt.
   
   c. From the Marker size drop-down list, select a marker size. On each line in the graph, there is a marker for each tick mark on the horizontal axis. Your choices are No marker, Small, Medium, and Large. The default is Small.

4. (Optional) Select the Show data values option to display a value above each marker.

5. Click OK.

**Specify Properties That Are Specific to a Line Graph**

To specify properties that are specific to a line graph, complete these steps:

1. Right-click in the line graph, and then select Properties to open the Properties dialog box.
   
   The General tab is displayed by default.

2. Select the Line tab.

3. Under Size, specify these options:
   
   a. From the Line thickness drop-down list, select a point size. Sizes range from 1 to 5 points. The default is 2 pt.
   
   b. From the Marker size drop-down list, select a marker size. On each line in the graph, there is a marker for each tick mark on the horizontal axis. Your choices are No marker, Small, Medium, and Large. The default is Small.

4. (Optional) Select the Show data values option to display above each point of the line.

5. Click OK.

**Specify Properties That Are Specific to a Pie Chart**

To specify properties that are specific to a pie chart, complete these steps:

1. Right-click in the pie chart, and then select Properties to open the Properties dialog box.
   
   The General tab is displayed by default.

2. Select the Pie tab.

3. Under Shape, select a shape for the pie. Your choices are Two-dimensional or Three-dimensional. The default is Two-dimensional.
4. Under **Multiple measures**, specify whether you want to display **Stacked pies** or **Multiple pies**.

   *Note:* This option is not available for pie charts that use only one measure or if a category or hierarchy is assigned to the pie stacks function in the Assign Data dialog box.

5. Under **Labels**, specify a font, font size, font style, and font color.

6. (Optional) Under **Values**, specify one or more of these options, and then specify the font, font size, font style, and font color:
   - **Combine minimal values into a slice labeled "Other"**
     - This option is selected by default.
   - **Show data values**
     - Select this option to display a value along with each segment.
   - **Show data values as a percent of the total**
     - Select this option to display a percentage value along with each segment.

7. Click **OK**.

**Specify Properties That Are Specific to a Progressive Bar Chart**

To specify properties that are specific to a progressive bar chart, complete these steps:

1. Right-click in the progressive bar chart, and then select **Properties** to open the Properties dialog box.

   The **General** tab is displayed by default.

2. Select the **Progressive Bar** tab.

3. (Optional) Under **Initial Bar**, select the **Set an initial value** option to specify an initial value for the first bar in the chart. If you use this option, then you can type an optional label in the **Initial bar label** field. By default, this option is not selected.

4. (Optional) Under **Final bar**, select the **Show the final (cumulative) value** option to display the value for the final bar. This option is selected by default. If you use this option, then you can type an optional label in the **Final bar label** field. The default label is Final.

5. Under **Colors**, select a color for each type of bar that appears in the chart. The **Positive bars** and **Negative bars** drop-down lists are always available. The **Initial bar** and **Final bar** drop-down lists are available only if you have selected the corresponding options.

   *Note:* For progressive bar charts, the Plateau report style uses the color green for positive values and the color blue for negative values. For the Seaside, Festival, and Meadow report styles, the positive values are green and the negative values are red.

6. (Optional) Select the **Show trend line** option to overlay a trend line on the progressive bar chart.

7. (Optional) Select the **Show data values** option to display a value above each bar.

8. Click **OK**.

**Specify Properties That Are Specific to a Scatter Plot**

To specify properties that are specific to a scatter plot, complete these steps:

1. Right-click in the scatter plot, and then select **Properties** to open the Properties dialog box.
The **General** tab is displayed by default.

2. Select the **Markers** tab.

3. From the **Marker size** drop-down list, select a marker size. There is a marker for each tick mark on the horizontal axis. Your choices are **No marker**, **Small**, **Medium**, and **Large**. The default is **Small**.

   **Note:** If you assigned a measure to the marker size function in the Assign Data dialog box, then the **Size** selection in this dialog box is ignored.

4. (Optional) Select the **Show data values** option to display a value above each marker.

5. Click **OK**.

---

**Specify Properties That Are Specific to a Tile Chart**

To specify properties that are specific to a tile chart, complete these steps:

1. Right-click in the tile chart, and then select **Properties** to open the Properties dialog box.
   
   The **General** tab is displayed by default.

2. Select the **Tile** tab.

3. From the **Layout type** drop-down list, select one of these options:
   
   **Standard**
   
   Specifies a standard layout tile chart that ignores sort order and keeps the tiles as close to squares as possible.

   **Toggle**
   
   Specifies a simple layout that divides a variable’s associated tiles in a single dimension, and switches the orientation as each level is placed. This layout works best with small amounts of data. For large amounts of data, try **Flow**.

   **Flow**
   
   Specifies a layout in which the available space is divided into a number of rows of similar but not equal heights. The number of rows is computed based on the number of tiles that will be displayed in conjunction with the aspect ratio of the available space. Then, the ordered tiles are placed in the rows from the top, down, and left to right. At each level, you can read the tiles like a page in a book.

4. From the **Show data levels** drop-down list, specify the number of levels of detail (that is, the number of times that the chart is divided). You can show 1, 2, or 3. The default is 2, unless there is only one category. In that case, the default is 1.

5. Under **Color**, select colors for the low, medium, and high values.

6. Under **Labels**, select a font, font size, font style, and font color to control how the labels display.

7. Click **OK**.
Using Geographical Maps to Display Query Results

About Geographical Maps

A geographic information system (GIS) is a tool for organizing and analyzing data that can be referenced spatially (that is, data that can be tied to physical locations). Many types of data have a spatial aspect, including demographics, marketing surveys, and customer addresses. A GIS helps users analyze data in the context of location.

For example, if report viewers need to evaluate population data for census tracts, a report author could render the information in a table. However, it would be easier and more effective for viewers to see the information in the context of the geography of the tracts. When evaluating information that has a spatial component, viewers might find it easier to recognize relationships and trends in the data if they see the information in a spatial context.

You can insert geographical maps only if the report query uses data items from a multidimensional data source that is enabled for geographic mapping.

Display 15.33  A Geographical Map Based on a Geographic Hierarchy That Contains U.S. Census Data

Insert a Geographical Map

If the current report section uses data items from a multidimensional data source that is enabled for geographic mapping and that contains a geographic hierarchy, then you can insert a geographical map into the layout.

To insert a geographical map into the layout of a report section, perform one of these tasks:

• Click on the layout grid toolbar to insert the geographical map in the next available cell.

• Drag the geographical map tool from the toolbar into a specific cell.

Note: For more information about how to position objects in the layout grid, see “Overview of Positioning Report Objects” on page 77.

You can also perform one or more of these tasks:
• Change the default measure assigned to the geographical map. For more information, see “Select a Measure for a Geographical Map” on page 163.

• Change the default properties.

• Filter or rank geographical map values. For more information, see “Filtering and Ranking a Geographical Map” on page 182.

Note: These tasks can also be performed in View mode.

Select a Measure for a Geographical Map

By default, the first measure selected from the data source is used for the geographical map. To specify a different measure (if one is available), complete these steps:

Note: You can also complete this task in View mode by selecting a measure from the drop-down list in the geographical map legend.

1. In Edit mode, select Data ⇒ Assign Data or right-click in the geographical map, and then select Assign Data to open the Assign Data dialog box.

2. Perform one of these tasks to assign data items:
   • Use drag and drop features to assign data items.
   • Use the Move Items drop-down list to assign data items.

You can assign a data item to one of these functions:

Category (Limit 1)
Select a category or hierarchy. Category is required.

Measure (Limit 1)
Select a measure. Measure is required.

Hidden
Data items that are assigned to Hidden do not appear in the geographic map but can be used in filtering.

For more information, see “Hiding Data Items” on page 274.

Display 15.34 Assign Data Dialog Box for Geographical Maps
3. Click OK.

**Change the Measure Used in a Geographical Map**

A report section can contain a geographical map if the section query uses data items from a data source that is enabled for geographic mapping. The geographical map is rendered by using two data items from the data source: one measure and the geographic hierarchy.

To change the measure that is used in a geographical map (if there are other measures available), select the new measure in the drop-down list that is located in the geographical map's legend.

**Display 15.35** A Geographical Map with Average Predicted Population Selected as the Measure

![A Geographical Map with Average Predicted Population Selected as the Measure](image)

**Zoom and Pan a Geographical Map**

To focus on a specific geographical map area or zoom in or out on a selected region, click the buttons on the geographical map toolbar, as shown in Table 15.2 on page 164.

**Table 15.2** Zoom and Pan Buttons for Geographical Maps

<table>
<thead>
<tr>
<th>Button</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Zoom In" /></td>
<td>Zooms in on a selected area. Click and drag the mouse to select the area that you want to zoom in on.</td>
</tr>
<tr>
<td><img src="image" alt="Zoom Out" /></td>
<td>Zooms out from a point. Click a point on the geographical map to zoom out and center on that point.</td>
</tr>
<tr>
<td><img src="image" alt="Pan" /></td>
<td>Moves the geographical map content within the viewing area. Click and drag the map until the viewer shows the area that you want to see.</td>
</tr>
<tr>
<td><img src="image" alt="Reset Zoom" /></td>
<td>Resets the zoom level to undo any zooming or panning that has been done.</td>
</tr>
</tbody>
</table>
Specify Properties for a Geographical Map

To specify properties for a geographical map, complete these steps:

1. In Edit mode, right-click in the geographical map, and then select Properties or in View mode, click on the map toolbar to open the Properties dialog box.

   The Map tab is displayed by default.

2. On the Map tab, accept or modify these properties:

   a. If you want a Title to appear above the geographical map, type the text, and then specify the font, font size, font style, alignment, and color. You cannot use these characters: < > & #

   b. From the Size drop-down list, choose Custom, Small, Medium, or Large. If you select Custom, type the Width and Height pixel values.

      Tip You can also resize the geographical map by using your mouse. Point to the bottom right corner or to the bottom or right border. When the pointer becomes a diagonal or horizontal bar, drag the geographical map to the new size and then release the mouse button.

   c. Choose one of the following methods to color the regions of the geographical map:

      Equivalent intervals
      Each color in the geographical map is defined by the range of the data divided by the number of colors.

      Natural breaks
      Each color in the geographical map is defined by natural breaks (or interruptions) in the data. The breaks are based on a histogram of data distributions.

      Quantiles
      The measure values are sorted and an equal number (data points) are assigned to each color according to their sorted value.

      Standard deviations
      The mean and the standard deviation values for the measure are calculated. The number of regions on the geographical map is determined by adding or subtracting the standard deviation to the mean value.

   d. Select the Number of colors to use for the coloration method that you chose. The default is 5. The maximum is 12. Regardless of your selection, the geographical map legend do not contain more colors than there are members in the currently displayed hierarchy level.

   The colors used depend on the currently applied style sheet.

   e. Select a Border color for the geographical map.
3. On the **Layers** tab, select the layers that you want to include in the geographical map. The **Layers** tab lists which, if any, information layers have been created by your data administrator. Examples include *Major roads*, *Schools*, *Lakes and reservoirs*, and *Elevation*.

4. Click **OK**.

---

### Removing a Table, Graph, or Geographical Map

To delete a table, graph, or geographical map from the layout of a report section in Edit mode, complete these steps:

1. Select one or more objects in the layout grid. Use the **SHIFT** key to select multiple objects.

2. Click ✗ on the vertical toolbar or press the **Delete** key.

3. In the confirmation message box that appears, click **OK**.
Part 5

Analyzing Results

Chapter 16
Filtering and Ranking ......................................................... 169

Chapter 17
Drilling and Expanding ....................................................... 189

Chapter 18
Sorting ................................................................. 195

Chapter 19
Adding Total, Subtotal, and Percent of Total Calculations ........... 201

Chapter 20
Applying Conditional Highlighting ........................................ 207

Chapter 21
Displaying Information About the Data ................................... 213
How Filtering and Ranking Can Help with Analysis

SAS Web Report Studio enables you to filter and rank the data in tables, graphs, and geographical maps.

Filters are simply a set of rules, or conditions, that you specify to subset the data that is displayed in a table, graph, or geographical map. The goal is to display only the data that you need to see to perform your analysis. For example, you might have a crosstabulation table that shows all sales in a variety of countries for the years 2007 and 2008. Spending is split between males and females. For a promotional mailing, you might want to filter the...
table so that it only contains information for 2008 where females spent more than $100,000. You would specify criteria that filter out the data that you don't need, such as data about male spending.

Display 16.1 on page 170 shows an example of the Filter and Rank dialog box when a filter has been applied to a specific geography. Notice that a funnel-shaped icon appears next to Geography in the Categories list.

Display 16.1  How the Filter and Rank Dialog Box Appears with a Filter on Geography

The Browse and Search tabs for relational data are currently used in the Filter and Rank dialog box for list tables, crosstabulation tables, and graphs when the data source is relational. You do not specify an operator in this case; however, the implied operator is Equal to. For more information, see “Browsing or Searching for Filter Values” on page 183.

The Browse and Search tabs for multidimensional data are currently used in the Filter and Rank dialog box. They let you select filter values for a multidimensional data item. You do not specify an operator in this case; however, the implied operator is Equal to. For more information, see “Browsing or Searching for Filter Values” on page 183.

You can apply a filter when you are viewing a table. Select a row or a column and then right-click and select Isolate. In Display 16.2 on page 171, the right-click menu shows Isolate Female for the total sales summary for retail sales in the crosstabulation table.

Note: The Isolate option is available for multidimensional data sources only.
After you isolate the row or column, the Filter and Rank dialog box will show that category as having a filter. For the preceding example, the **Geography** category in the Categories list displays with this icon: 🍃.

For crosstabulation tables based on relational data sources, you can apply a filter value by selecting **Filter by the Column**, **Filter by this Row**, **Rank by this Column**, or **Rank by this Row**.

Rankings order observations according to values of particular measure data items. In this case, the goal is to provide a different view of the data to help you perform your analysis. For example, a bar chart might show revenue for two sales channels for the years 2004, 2005, 2006, 2007, and 2008. You want to rank the chart so that it shows where the top 10 percent of sales came from in each year. The ranked graph might show that the top 10
percent of sales for each year came from catalog sales. Based on this information, your company might want to expand catalog mailings.

Depending on your authorization, you can save the filtered or ranked report under the same name or under a different name.

## Filtering and Ranking a List Table

### Create a Filter or Ranking for a List Table

To create a filter for a list table, complete these steps:

1. Right-click on the list table, and then select **Filter and Rank** to open the Filter and Rank dialog box.

2. Select the data item that you want to filter from the **Categories** list. This field displays the data items that are used in the list table along with an indication of any currently active filters. Data item names might wrap multiple lines.

3. Select a **Type**. The two filter types for alphanumeric categories are **No filter (show all values)** and **Filter**. Measure data items have an additional **Rank** type.

   **Note:** You cannot create measure filters or rankings if the table is part of a synchronized group. If the table is in a synchronized group, then measures are not included in the list. The list also does not include categories that are assigned to group breaks or percent of total calculations.

4. If you selected a category data item, click **Get Values** for a list of available values. In the list of **Available values**, you can use either the **Browse** or **Search** tabs to find the values that you want to select. For more information, see “Browsing or Searching for Filter Values” on page 183.

5. (Optional) If the selected data item enables you to filter on formatted values, then you can select the **Filter on formatted values** option. Regardless of your selection, the query results show formatted values.¹

6. Depending on your filter type selection, take the appropriate action, as shown in Table 16.1 on page 172.

<table>
<thead>
<tr>
<th>Data Item</th>
<th>Filter Type</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>any type</td>
<td><strong>No filter</strong></td>
<td>None. No filter will be applied to the selected data item.</td>
</tr>
</tbody>
</table>

¹ Filtering on formatted values can sometimes adversely affect query performance. If you have questions about whether you should select this option, contact your data source administrator.
<table>
<thead>
<tr>
<th>Data Item</th>
<th>Filter Type</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>alphanumeric</td>
<td>No filter (show all values) or Filter*</td>
<td>Selecting the filter opens a widget in which you can either select or type in values. If you are not allowed to view the values, then you can type in values. Select one or more items from the Available values list and move them to the Selected values list. Type a value* and click Add to add it to the Selected values box. Repeat this procedure for each value that you want to filter for. You cannot use these characters: &lt; &gt; ( ) . To remove a value, select it in the Selected values box and click ✗.</td>
</tr>
</tbody>
</table>
| date               | Filter              | If you are entering a date, then the Fixed radio button should be selected. If you are entering a relative period, then the Relative radio button should be selected. Use one of these methods:*  
  • Select a date using the calendar.  
  • Select an Operator and enter a Day, Month, and Year.  
  • Select an Operator, and then select a relative time period. Options include Today, Previous quarter, and a user-specified number of periods. |
| timestamp          | Filter on this date | If you are entering a date, then the Fixed radio button should be selected. If you are entering a relative period, then the Relative radio button should be selected. Select an Operator and enter a Date, Hour, Minute, and Second. |
| time               | Filter              | Use one of these methods:*  
  • Select an Operator and enter an Hour, Minute, and Second.  
  • Select an Operator, and then select a relative time period. The options are Current hour, Previous hour, and a user-specified number of periods. |
**Table 16.1: Filter and Action Examples**

<table>
<thead>
<tr>
<th>Data Item</th>
<th>Filter Type</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>measure†</td>
<td>Filter</td>
<td>Select an Operator and enter a Value. For the BETWEEN operators, type a Minimum and Maximum value. You do not type a value for the Is missing and Is not missing operators.</td>
</tr>
<tr>
<td></td>
<td>Rank</td>
<td>Select Top or Bottom from the Show field. Then, type a value next to the option that you chose. The percent check box is not available for relational data. To exclude tied rankings, select the Exclude ties option. For example, by default, if you request the top five products and there are three products tied for fifth place, then seven products are returned. If you select the Exclude ties option, then only five products are returned.</td>
</tr>
</tbody>
</table>

* If you are filtering on unformatted values, then you must enter values that match the casing of the values in the data source unless you have selected the Ignore case check box. If you select the Filter on formatted values option, then you must enter the formatted values. If the filter does not return any results, then try using a different casing.

** The data source administrator controls whether you can select category values.

*** Filtering by relative time means that the filter is relative to the time that the report is run, not the time that the filter is imposed on the table.

† Enter values in the number format that is appropriate for the locale that is set for the browser.

7. Click OK.

---

**Remove a Filter or Ranking from a List Table**

To remove a filter or ranking from a list table, complete these steps:

1. Right-click on the list table, and then select Filter and Rank to open the Filter and Rank dialog box.

2. In the Data Item list, for each data item that should not be filtered, select No filter (show all values) as the Type.

3. Click OK.

---

**Filtering and Ranking a Crosstabulation Table**

**Create a Category or Hierarchy Filter for a Crosstabulation Table**

To create a category or hierarchy filter, complete these steps:

1. Right-click on the crosstabulation table, and then select Filter and Rank to open the Filter and Rank dialog box.

2. In the Categories list, select a category or hierarchy. This field displays the categories and hierarchies that are used in the table (including hidden categories and hierarchies) along with an indication of any currently active filters. Data item names might wrap multiple lines.

   **Note:** The list does not include categories and hierarchies that are assigned to group breaks or percent of total calculations.
3. Select a **Type**. The two filter types for category and hierarchies are **No filter (show all values)** and **Filter**. Hierarchies in the Time dimension of a multidimensional data source have an additional **Filter (relative time)** type.

4. Depending on your filter type selection, take the appropriate action, as shown in **Table 16.2 on page 175.**

**Table 16.2  Data Item Types, Filter Types, and Available Actions for Crosstabulation Tables**

<table>
<thead>
<tr>
<th>Data Item</th>
<th>Filter Type</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>any type</td>
<td>No filter</td>
<td>None. No filter will be applied to the selected data item.</td>
</tr>
<tr>
<td>categories from relational data sources</td>
<td>Filter</td>
<td>Selecting the filter opens a widget in which you can either select or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>type in values. If you are not allowed to view the values, then you</td>
</tr>
<tr>
<td></td>
<td></td>
<td>can type in values.**</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Type a value and click <strong>Add</strong> to add it to the <strong>Multiple values</strong> box.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Repeat this procedure for each value that you want to filter for. You</td>
</tr>
<tr>
<td></td>
<td></td>
<td>cannot use these characters: <code>&lt; &gt; ( ) \</code></td>
</tr>
<tr>
<td></td>
<td></td>
<td>To remove a value, select it in the <strong>Selected values</strong> box and click <code>X</code></td>
</tr>
<tr>
<td>hierarchies in the Time dimension of a multidimensional data source (for example, a Year hierarchy)</td>
<td>Filter (relative time)</td>
<td>Select a <strong>Period type</strong> and enter <strong>Show</strong> and <strong>Select</strong> criteria. In</td>
</tr>
<tr>
<td></td>
<td></td>
<td>the <strong>Date Range</strong> section, specify your starting and ending period</td>
</tr>
<tr>
<td></td>
<td></td>
<td>information.</td>
</tr>
<tr>
<td>date categories from relational data sources</td>
<td>Filter</td>
<td>Use one of these methods:**</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Select an <strong>Operator</strong> and enter a <strong>Day</strong>, <strong>Month</strong>, and <strong>Year</strong>.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Select an <strong>Operator</strong>, and then select a relative time period.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Options include <strong>Today</strong>, <strong>Previous quarter</strong>, and a user-specified</td>
</tr>
<tr>
<td></td>
<td></td>
<td>number of periods.</td>
</tr>
<tr>
<td>time categories from relational data sources</td>
<td>Filter</td>
<td>Select an <strong>Operator</strong> and enter an <strong>Hour</strong>, <strong>Minute</strong>, and <strong>Second</strong>.</td>
</tr>
<tr>
<td>timestamp categories from relational data sources</td>
<td>Filter</td>
<td>If you are entering a date, then the <strong>Fixed</strong> radio button should be</td>
</tr>
<tr>
<td></td>
<td></td>
<td>selected. If you are entering a relative period, then the <strong>Relative</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td>radio button should be selected.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Use one of these methods:**</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Select a date using the calendar.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Select an <strong>Operator</strong> and enter a <strong>Date</strong>, <strong>Hour</strong>, <strong>Minute</strong>, and</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Second</strong>.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Select an <strong>Operator</strong>, and then select a relative time period.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Options include <strong>Today</strong>, <strong>Previous quarter</strong>, <strong>Current hour</strong>, and a</td>
</tr>
<tr>
<td></td>
<td></td>
<td>user-specified number of periods.</td>
</tr>
</tbody>
</table>

* If you are filtering on unformatted values, then you must enter values that match the casing of the values in the data source, unless you selected the **Ignore case** check box. If you select the **Filter on formatted values** option, then you must enter the formatted values. If the filter does not return any results, then try using a different casing.

** For relational data sources, your data source administrator controls whether you can select category values.

*** Filtering by relative time means that the filter is relative to the time that the section query is generated, not the time that the filter is imposed on the table.

5. Click **OK**.
Create a Measure Filter for a Crosstabulation Table

To create a measure filter, complete these steps:

1. Perform one of these tasks to open the Filter and Rank dialog box:
   - Right-click on the table, and then select Filter and Rank.
   - Click a measure heading in a row or column, and then select Filter by this Row or Filter by this Column.

Note: You cannot filter on percent of total calculations.

2. Select the Measure Filter or Rank tab. This feature is available only in View mode if your data is not synchronized.

Note: The Measure Filter or Rank tab is not available if the table is part of a synchronized group. For more information, see Chapter 11, “Using Synchronized or Independent Objects,” on page 81.

3. Select the Filter option.

4. In the Show values of drop-down list, select an option.

5. Depending on your Show values of selection, specify the criteria for the filter, as shown in Table 16.3 on page 176.

Table 16.3 Filter Criteria Options for Crosstabulation Tables

<table>
<thead>
<tr>
<th>Show Value Selection</th>
<th>Criteria</th>
</tr>
</thead>
<tbody>
<tr>
<td>(rows)*</td>
<td>Select a value for each category or hierarchy level on the columns. Then, select a Measure and an Operator, and type a Value.”</td>
</tr>
<tr>
<td>(columns)**</td>
<td>Select a value for each category or hierarchy level on the rows. Then, select a Measure and an Operator, and type a Value.”</td>
</tr>
<tr>
<td>Outermost category or hierarchy on the rows</td>
<td>Select a Measure and an Operator, and type a Value.”</td>
</tr>
<tr>
<td>Outermost category or hierarchy on the columns</td>
<td></td>
</tr>
</tbody>
</table>

* If the measures are on the columns, then a (rows) option is available.

** Do not include a currency symbol in the Value field. In addition, enter values in the number format that is appropriate for the locale that is set for the browser.

*** If the measures are on the rows, then a (columns) option is available.

6. Click OK.

Create a Ranking for a Crosstabulation Table

To create a ranking for a measure in a crosstabulation table, complete these steps:

1. Perform one of these tasks to open the Filter and Rank dialog box:
   - Right-click on the table, and then select Filter and Rank.
• Click a measure heading in a row or column, and then select **Rank by this Row** or **Rank by this Column**.

*Note:* You cannot filter on percent of total calculations.

2. If you are in View mode, select the **Measure Filter or Rank** tab.

*Note:* The **Measure Filter or Rank** tab is not available if the table is part of a synchronized group. For more information, see Chapter 11, “Using Synchronized or Independent Objects,” on page 81.

3. Select the **Rank** option.

4. In the **Show** field, select **Top** or **Bottom**, and then type a value next to the option that you chose.

5. (Optional) Choose one of these options:
   - To evaluate the data as a percentage, select the **percent(%)** option, and then enter a value. The value cannot exceed 100.
     *Note:* This option is not available for relational data sources.
   - To exclude tied rankings, select the **Exclude ties** option. For example, by default, if you request the top five products and there are three products tied for fifth place, then seven products are returned. If you select the **Exclude ties** option, then only five products are returned.

6. In the **Show values of** drop-down list, select an option.

7. Depending on your **Show values of** selection, specify the criteria for the ranking, as shown in Table 16.4 on page 177.

**Table 16.4** Ranking Criteria Options for Crosstabulation Tables

<table>
<thead>
<tr>
<th>Show Values Selection</th>
<th>Criteria</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>(rows)</em></td>
<td>Select a value for each category or hierarchy level on the columns, and then select a Measure.</td>
</tr>
<tr>
<td><em>(columns)</em></td>
<td>Select a value for each category or hierarchy level on the rows, and then select a Measure.</td>
</tr>
<tr>
<td>Outermost category or hierarchy on the rows</td>
<td>Select a Measure.</td>
</tr>
<tr>
<td>Outermost category or hierarchy on the columns</td>
<td></td>
</tr>
</tbody>
</table>

* If the measures are on the columns, then a *(rows)* option is available.
** If the measures are on the rows, then a *(columns)* option is available.

8. Click **OK**.

**Create a Member Property Filter for a Crosstabulation Table**

*Note:* This capability is available only for multidimensional categories with child filters. Not all cubes have member properties, so this capability is not available if either the
cube or the selected category does not have member properties. You cannot filter on member properties with a relative time filter.

To create a filter for member properties, complete these steps:

1. Perform one of these tasks to open the Filter and Rank dialog box:
   - Right-click on the table, and then select **Filter and Rank**.
   - Right-click a measure heading in a row or column, and then select **Filter by this Row** or **Filter by this Column**.

2. If you are in View mode, select the **Measure Filter or Rank** tab.
   
   Note: The **Measure Filter or Rank** tab is not available if the table is part of a synchronized group. For more information, see Chapter 11, “Using Synchronized or Independent Objects,” on page 81.

3. Select the **Filter** radio button.

4. Select the **Based on member property** check box. The **Operator** drop-down list and the **Value** field appear. Display 16.5 on page 178 is an example of the **Category Filters** tab when the **Based on member property** check box is selected.

5. Select the **Operator**. The choices are either **Is equal to** or **Is not equal to**.

6. Enter a filter value in the **Value** field.

7. Click **OK**.

**Remove a Filter or Ranking from a Crosstabulation Table**

To remove a filter or ranking from a crosstabulation table, complete these steps:
1. Right-click on the table, and then select **Filter and Rank** to open the Filter and Rank dialog box.

2. Remove category and hierarchy filters, measure filters, or rankings as described next:
   - On the **Category Filters** tab, for each data item that should not be filtered, select **No filter (show all values)** as the **Filter type**.
   - On the **Measure Filter or Rank** tab, select **No filter (show all values)**.

   *Note:* If you already have a measure filter on a crosstabulation table in Edit mode, then you can select the **Delete Filters or Rankings** check box on the **Measure Filter or Rank** tab. Then, click **OK**.

3. Click **OK**.

---

### Filtering and Ranking a Graph

#### Create a Category or Hierarchy Filter for a Graph

To create a category or hierarchy filter, complete these steps:

1. Right-click on the graph, and then select **Filter and Rank** to open the Filter and Rank dialog box.

2. Select the **Category Filters** tab.

3. Select a category or hierarchy in the **Categories** list. This field displays the categories and hierarchies that are used in the graph along with any currently active filters. Data item names might wrap multiple lines.

   *Note:* The list does not include categories and hierarchies that are assigned to group breaks.

4. Select a filter **Type**.

5. (Optional) If the selected data item is physically stored as character data and it is not using the default format, then you can select the **Filter on formatted values** option. In this case, formatted values are used in all parts of the current filter query.

   *Note:* If the selected data item uses the default format and this option is selected (which might be the true for reports that were created with a previous version of SAS Web Report Studio), then clear this option to improve query performance. However, if you cannot produce the desired results by using unformatted values, leave the option selected.

6. Depending on your selected category and filter type, follow the actions that are described in Table 16.2 on page 175.

7. Click **OK**.

#### Create a Measure Filter for a Graph

*Note:* For multidimensional data sources, the **Measure Filter or Rank** tab is not available if the graph is part of a synchronized group. For more information, see Chapter 11, “Using Synchronized or Independent Objects,” on page 81.

To create a measure filter, complete these steps:
1. Right-click on the graph, and then select **Filter and Rank** to open the Filter and Rank dialog box.

2. Select the **Measure Filter or Rank** tab.

3. Select the **Filter** option.

4. In the **Show values of** drop-down list, select an option.

5. Depending on your **Show values of** selection, specify the criteria for the filter, as shown in Table 16.5 on page 180.

   *Note:* The **Show values** drop-down list does not appear for relational graphs.

<table>
<thead>
<tr>
<th><strong>Graph Type</strong></th>
<th><strong>Show Value Selection</strong></th>
<th><strong>Criteria</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Bar chart or progressive bar chart</td>
<td>The category or hierarchy that is assigned to the bars function.</td>
<td>Select the measure that is assigned to the bar height function. Then, select an <strong>Operator</strong> and type a <strong>Value.</strong></td>
</tr>
<tr>
<td>Bar-line chart</td>
<td>The category or hierarchy that is assigned to the bars function.</td>
<td>Select the measure that is assigned to the bar height function or the measure that is assigned to the line height function. Then, select an <strong>Operator</strong> and type a <strong>Value.</strong></td>
</tr>
<tr>
<td>Line graph</td>
<td>The category or hierarchy that is assigned to the lines function.</td>
<td>Select the measure that is assigned to the measure axis function. Then, select an <strong>Operator</strong> and type a <strong>Value.</strong></td>
</tr>
<tr>
<td>Pie chart</td>
<td>The category or hierarchy that is assigned to the segments function.</td>
<td>Select the measure that is assigned to the segment size function. Then, select an <strong>Operator</strong> and type a <strong>Value.</strong></td>
</tr>
<tr>
<td>Scatter plot</td>
<td>The category or hierarchy that is assigned to the optional marker group function.**</td>
<td>Select the measure that is assigned to the vertical axis function or the measure that is assigned to the horizontal axis function. Then, select an <strong>Operator</strong> and type a <strong>Value.</strong></td>
</tr>
<tr>
<td>Tile chart</td>
<td>The category or hierarchy that is assigned to the tile function.</td>
<td>Select the measure that is assigned to the tile function. Then, select an <strong>Operator</strong> and type a <strong>Value.</strong></td>
</tr>
</tbody>
</table>

* Do not include a currency symbol in the **Value** field. In addition, enter values in the number format that is appropriate for the locale that is set for the browser.

** If no category or hierarchy is assigned to the marker group function, then you cannot create the filter.

6. Click **OK**.

### Create a Ranking for a Graph

*Note:* For multidimensional data sources, the **Measure Filter or Rank** tab is not available if the graph is part of a synchronized group. For more information, see Chapter 11, “Using Synchronized or Independent Objects,” on page 81.

To create a ranking for a measure in a graph, complete these steps:

1. Right-click on the graph, and then select **Filter and Rank** to open the Filter and Rank dialog box.
2. Select the **Measure Filter or Rank** tab.
3. Select the **Rank** option.
4. In the **Show** field, select **Top** or **Bottom**, and then type a value next to the option that you chose.
5. (Optional) Choose one of these options:
   - To evaluate the data as a percentage, select the **percent(%)** option, and then enter a value. The value cannot exceed 100.
     
     **Note:** This option is not available for relational data sources.
   - To exclude tied rankings, select the **Exclude ties** option. For example, by default, if you request the top five products and there are three products tied for fifth place, then seven products are returned. If you select the **Exclude ties** option, then only five products are returned.
6. In the **Show values of** drop-down list, select an option.
7. Depending on your **Show values of** selection, specify the criteria for the ranking, as shown in **Table 16.6** on page 181.

   **Note:** The **Show values** drop-down list does not appear for relational graphs.

**Table 16.6 Ranking Criteria Options for Each Graph Type**

<table>
<thead>
<tr>
<th>Graph Type</th>
<th>Show Values Selection</th>
<th>Based on Values of Criteria</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bar chart or progressive bar chart</td>
<td>The category or hierarchy that is assigned to the bars function.</td>
<td>Select the measure that is assigned to the bar height function.</td>
</tr>
<tr>
<td>Bar-line chart</td>
<td>The category or hierarchy that is assigned to the bars function.</td>
<td>Select the measure that is assigned to the bar height function or the measure that is assigned to the line height function.</td>
</tr>
<tr>
<td>Line graph</td>
<td>The category or hierarchy that is assigned to the lines function.</td>
<td>Select the measure that is assigned to the measure axis function.</td>
</tr>
<tr>
<td>Pie chart</td>
<td>The category or hierarchy that is assigned to the segments function.</td>
<td>Select the measure that is assigned to the segment size function.</td>
</tr>
<tr>
<td>Scatter plot</td>
<td>The category or hierarchy that is assigned to the optional marker group function.*</td>
<td>Select the measure that is assigned to the vertical axis function or the measure that is assigned to the horizontal axis function.</td>
</tr>
<tr>
<td>Tile chart</td>
<td>The category or hierarchy that is assigned to the tile function.</td>
<td>Select the measure that is assigned to the tile function.</td>
</tr>
</tbody>
</table>

* If no category or hierarchy is assigned to the marker group function, then you cannot create the ranking.

8. Click **OK**.

**Remove a Filter or Ranking from a Graph**

To remove a filter or ranking from a graph, complete these steps:

1. Right-click on the graph, and then select **Filter and Rank** to open the Filter and Rank dialog box.
2. Remove category and hierarchy filters, measure filters, or rankings as described next:
   - On the **Category Filters** tab, for each data item that should not be filtered, select **No filter** as the **Filter type**.
   - On the **Measure Filter or Rank** tab, select **No filter (show all values)**.
3. Click **OK**.

---

**Filtering and Ranking a Geographical Map**

**Create a Filter for a Geographical Map**

To create a filter for the geographic hierarchy in a geographical map, complete these steps:

1. Right-click on the geographical map, and then select **Filter and Rank** to open the Filter and Rank dialog box.
2. Select the **Category Filters** tab.
3. In the **Categories** list, select the geographic hierarchy. This field displays the geographic hierarchy along with any currently active filters.
4. In the **Filter type** drop-down list, select **Filter**.
5. Select items in the **Available values** list. You can select and deselect items individually, or you can use the **Select All** or **Deselect All** buttons.
6. Click **OK**.

**Create a Measure Filter for a Geographical Map**

*Note:* The **Measure Filter or Rank** tab is not available if the geographical map is part of a synchronized group. For more information, see Chapter 11, “Using Synchronized or Independent Objects,” on page 81.

To create a measure filter, complete these steps:

1. Right-click on the geographical map, and then select **Filter and Rank** to open the Filter and Rank dialog box.
2. Select the **Measure Filter or Rank** tab.
3. Select the **Filter** option.
4. In the **Show values of** drop-down list, select the geographic hierarchy.
5. Select the **Measure** that is being used in the geographical map.
6. Select an **Operator**.
7. Enter a **Value**. (Do not include the currency symbol.)
8. Click **OK**.
Create a Ranking for a Geographical Map

Note: The Measure Filter or Rank tab is not available if the geographical map is part of a synchronized group. For more information, see Chapter 11, “Using Synchronized or Independent Objects,” on page 81.

To create a ranking for the measure used in a geographical map, complete these steps:

1. Right-click on the geographical map, and then select Filter and Rank to open the Filter and Rank dialog box.
2. Select the Measure Filter or Rank tab.
3. Select the Rank option.
4. In the Show field, select Top or Bottom, and then type a value next to the option that you chose.
5. (Optional) Choose one of these options:
   • To evaluate the data as a percentage, select the percent(%) option, and then enter a value. The value cannot exceed 100.
   • To exclude tied rankings, select the Exclude ties option. For example, by default, if you request the top five geographic areas for total revenue and there are three areas tied for fifth place, then seven geographic areas are shown on the geographical map. If you select the Exclude ties option, then only five geographic areas are shown on the geographical map.
6. In the Show values of drop-down list, select the geographic hierarchy.
7. Select the Measure that is being used in the geographical map.
8. Click OK.

Remove a Filter or Ranking from a Geographical Map

To remove a filter or ranking from a geographical map, complete these steps:

1. Right-click on the geographical map, and then select Filter and Rank to open the Filter and Rank dialog box.
2. Remove the geographic hierarchy filter, the measure filter, or the ranking as described next:
   • On the Category Filters tab, select the geographic hierarchy, and then select No filter.
   • On the Measure Filter or Rank tab, select No filter (show all values).
3. Click OK.

Browsing or Searching for Filter Values

About Browsing and Searching

There are two ways to select values from a data item:
• You can browse all the values that are available and then select from a list.
• You can enter search arguments to narrow the list of values and then select from that list.

The **Browse** and **Search** tabs have a different appearance depending on whether the data items are in a relational data source or a multidimensional data source.

The **Browse** and **Search** tabs let you search for values when you are doing the following:
• constructing an unprompted filter that uses either the **Equal to** or **Not equal to** operators
• constructing a prompted filter whose prompt type is **Create a list of values** and whose operator is **Equal to**, **Not equal to**, **Between**, or **Not between**

The **Filter on formatted values** check box determines whether the search is for formatted or unformatted values.

### Browse for Relational Data Items

You can use the **Browse** tab to browse all the values that are available in the data source and then select one from a list. To browse the values in a relational data source, complete these steps:

1. Click **Get Values** to run a query and display the values.
   
   **Note:** The **Get Values** button is disabled if the data item does not allow values to be displayed, the data item values have already been retrieved, or the data item values cannot be retrieved.

2. Select a value (or values) from the **Browse** tab. Click ➡️ to move one or more values to the **Selected values** list. You can select a range of values using the SHIFT or the CTRL key. Use ➡️ to move all values in the **Browse** list to the **Selected values** list.

**Display 16.6**  The Filter and Rank Dialog Box with Values Moved From the Browse Tab to the List of Selected Values
If there are too many values to display, then a message displays. In this case, the Search tab is accessible, so you can search for the values.

Display 16.7  Example of the Message When There are Too Many Values to Display

Search for Relational Data Items

You can use the Search tab to enter search arguments to narrow the list of values and then select a value from that list. To search for the values in a relational data source, complete these steps:

1. Select a Search criteria from the drop-down list. The following operators are available:

<table>
<thead>
<tr>
<th>Search Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contains</td>
<td>Specifies that the value contains the search argument.</td>
</tr>
<tr>
<td>Exactly matches</td>
<td>Specifies that the value matches the search argument exactly.</td>
</tr>
<tr>
<td>Starts with</td>
<td>Specifies that the value starts with the search argument.</td>
</tr>
<tr>
<td>Ends with</td>
<td>Specifies that the value ends with the search argument.</td>
</tr>
<tr>
<td>Matches pattern</td>
<td>Lets you create a pattern for the search argument. Use the question mark (?) as a substitute for a single letter and an asterisk (*) as a substitute for zero or more letters.</td>
</tr>
</tbody>
</table>

The search argument is case-sensitive when the values are formatted and not case-sensitive when the values are unformatted.

2. Enter a value to search for in the field to the right of the Search criteria list.

3. Click Search. The search results display in the table below the button. If the table contains more than 50 entries, a page control appears above the table to let you move to the next or previous set of entries.

4. Select a value (or values) in the table. Click to move one or more values to the list of Selected values. You can select a range of values using the SHIFT or the CTRL key. Use to move all values on the page to the list of Selected values.
**Display 16.8  Moving Search Values to the Selected Values List in the Create Custom Filter Dialog Box**

When the **Browse** tab displays for multidimensional data, a tree representing the hierarchy of the data items expands to the first available level. Note that when portions of the tree are expanded, there might be a slight delay in populating the list, because the data in the tree is loaded on an as-needed basis.

To browse the values in a multidimensional data source, complete these steps:

1. Select a value (or values) from the **Browse** tab. Click \(\rightarrow\) to move one or more values to the list of **Selected values**. You can select a range of values using the SHIFT or the CTRL key. Double-clicking expands or collapses the tree, depending on the state of the tree node when you click it. Use \(\rightarrow\) to move all values in the **Browse** list to the list of **Selected values**. If an area of the tree is not expanded, then the values in the subtree under that tree value are not moved to the **Selected values** list.

**Browse for Multidimensional Data Items**

When the **Browse** tab displays for multidimensional data, a tree representing the hierarchy of the data items expands to the first available level. Note that when portions of the tree are expanded, there might be a slight delay in populating the list, because the data in the tree is loaded on an as-needed basis.

To browse the values in a multidimensional data source, complete these steps:

1. Select a value (or values) from the **Browse** tab. Click \(\rightarrow\) to move one or more values to the list of **Selected values**. You can select a range of values using the SHIFT or the CTRL key. Double-clicking expands or collapses the tree, depending on the state of the tree node when you click it. Use \(\rightarrow\) to move all values in the **Browse** list to the list of **Selected values**. If an area of the tree is not expanded, then the values in the subtree under that tree value are not moved to the **Selected values** list.
Display 16.9  The Filter and Rank Dialog Box with Values Moved From the Browse Tab to the List of Selected Multidimensional Values

2. (Optional) Remove values from the **Selected values** by clicking \(\times\). You can also double-click a value to remove it. You can select a range of values using the SHIFT or the CTRL key. To remove all values, select all of the items and then click \(\times\).

### Search for Multidimensional Data Items

You can use the **Search** tab to enter search arguments to narrow the list of values and then select a value from that list. To browse the values in a multidimensional data source, complete these steps:

1. Select a **Search criteria** from the drop-down list. The following operators are available:

<table>
<thead>
<tr>
<th>Search Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Contains</strong></td>
<td>Specifies that the value contains the search argument.</td>
</tr>
<tr>
<td><strong>Exactly matches</strong></td>
<td>Specifies that the value matches the search argument exactly.</td>
</tr>
<tr>
<td><strong>Starts with</strong></td>
<td>Specifies that the value starts with the search argument.</td>
</tr>
<tr>
<td><strong>Ends with</strong></td>
<td>Specifies that the value ends with the search argument.</td>
</tr>
<tr>
<td><strong>Matches pattern</strong></td>
<td>Lets you create a pattern for the search argument. Use the question mark (?) as a substitute for a single letter and an asterisk (*) as a substitute for zero or more letters.</td>
</tr>
</tbody>
</table>
The search argument is always case-sensitive, because multidimensional values are formatted.

2. Enter a value to search for in the field to the right of the Search criteria list.

3. Click Search. The search results display in the table below the button. If the table contains more than 50 entries, a page control appears above the table to let you move to the next or previous set of entries.

4. Select a value (or values) in the table. Click \( \rightarrow \) to move one or more values to the list of Selected values. You can select a range of values using the SHIFT or the CTRL key. Use \( \rightarrow \) to move all values on the page to the list of Selected values.

Display 16.10  Moving Multidimensional Search Values to the Selected Values List in the Filter and Rank Dialog Box

5. (Optional) Remove values from the Selected values by clicking \( \times \). You can also double-click a value to remove it. You can select a range of values using the SHIFT or the CTRL key. To remove all values, select all of the items and then click \( \times \).
Chapter 17
Drilling and Expanding

How Drilling and Expanding Can Help with Analysis

If you want to visibly compare parent and child values at the same time, then drilling and expanding values can help you analyze the data. For example, suppose you want to see the overall sales revenue for last year, as well as the quarterly sales revenue, for your company. You could use a crosstabulation table to help analyze both the annual and quarterly revenue.

Drill or Expand Hierarchies in a Crosstabulation Table

You can perform these tasks on a crosstabulation table that is based on multidimensional data:

- Click to expand a member of a hierarchy level. You see the values for the current member and the values for the next hierarchy level down for that member.
Display 17.1  In the Hierarchy Level Year, the Member 2007 Has Been Expanded to Display Values for the Quarter Hierarchy Level

Display 17.2  In the Hierarchy Level Year, the Member 2007 Has Been Drilled to Display Values for the Quarter Hierarchy Level

• Click to drill a member of a hierarchy level. You see only the values for the next hierarchy level down for that member. Note that a bread crumb appears above the table when you drill down in a hierarchy. Use the bread crumb to move up a level in a hierarchy.

• Right-click a hierarchy level heading, and then select Expand All. In Display 17.2 on page 190, you would click on the hierarchy level Year.

• Right-click a hierarchy level heading, and then select Collapse All.

Drill Hierarchies in a Graph

You can drill in a graph that is based on multidimensional data. Click the name of a member in the graph, and then select Drill down on <member>. You see only the values for the next hierarchy level down for that member.

Note: If a section is synchronized, then a graph that exists in a synchronized section with a table expands if an expand operation is performed on the table. For more information about synchronization, see “Overview of Synchronized Filtering, Sorting, Drilling, and Expanding” on page 81.
In Display 17.3 on page 191, to undo the drilling, you select Clothes & Shoes above the graph, which is the next hierarchy level up. To go back to the top level of the hierarchy, select Product.

Note: You cannot drill into the X-axis category values for a progressive bar chart with a multidimensional data source if the chart includes an initial or final bar. However, you can still drill into the chart. You can remove the initial and final bars, drill into the chart, and then add back the initial and final bars. If your section is synchronized, you can drill into a different report element, because the drills are shared across report elements in a synchronized section. You can also drill into any horizontal or vertical series data items, because only the X-axis category has drilling restrictions.

---

**Drill or Expand the Geographic Hierarchy in a Geographical Map**

Display 17.4 on page 191 is an example of a geographical map that has geographic hierarchies defined.

**Display 17.4 The US Regions Hierarchy Level**
You can perform these tasks on a geographical map to drill or expand the geographic hierarchy:

- Click and then click a colored geographical map region (which is a member in the currently displayed geographic hierarchy level). The geographical map is redrawn to display the regions (members) for the next hierarchy level down while keeping the context of the current hierarchy level. The legend to the right of the geographical map changes to display the values for the expanded region.

**Display 17.5**  *In the US Regions Hierarchy Level, the West N. Central Member Has Been Expanded to Display Values for the State Hierarchy Level*

- Click and then click an expanded region to collapse it.

- Click and then click a colored geographical map region (which is a member in the currently displayed geographic hierarchy level). The geographical map is redrawn to display the regions (members) for the next hierarchy level down. The legend to the right of the geographical map changes to display the values for the drilled region.

**Display 17.6**  *In the US Regions Hierarchy Level, the West N. Central Member Has Been Drilled to Display Values for the County Hierarchy Level*

- Click to remove the last drill-down action that you performed.
How Drilling and Expanding Affects Other Table, Graph, and Geographical Map Features

How Drilling and Expanding Affects Filtering and Ranking

SAS Web Report Studio shows if a filter or rank has been defined for a data item. In either the Categories or Data Item list in the Filter and Rank dialog box, you see a blue filter icon if the filter is in effect. The icon is disabled if the filter is not in effect (for example, if it is covered over by either a drill or an expand). If you select a data item with a disabled filter, a message displays to tell you that the filter is not in effect and gives a general explanation of why the filter is not in effect.

How Drilling and Expanding Affects Conditional Highlighting in Tables and Graphs

When you define conditional highlighting, there is an option to apply the rule either to the selected levels of displayed dimensions or to any level of displayed dimensions. In the Conditional Highlighting dialog box, there are two selections for Rule assignment: All hierarchy levels or Selected hierarchy levels. Note that if you choose the Selected hierarchy levels option, then you can click Select to open the dialog box that lets you specify your selections.

Display 17.7 Conditional Highlighting Dialog Box with the Selected Hierarchy Levels Radio Button Selected

As you expand or drill and display different levels in a table or a graph, conditional highlighting rules continue to be applied based on the rule assignment that you specified.
How Drilling and Expanding Affects Totals and Subtotals in Tables

When you specify totals or subtotals, they are applied and affect every level of the displayed table. As you navigate the table by drilling and expanding; the total, subtotal, or both values are reflected at the currently displayed level.

How Drilling and Expanding Affects Percent of Total Calculations in Tables

When you drill and expand in a table, any percent of total calculations are updated to reflect the values that are relevant to the currently displayed hierarchy level.

How Drilling and Expanding Affects Panning and Zooming in a Geographical Map

You can indirectly remove panning or zooming in a geographical map by drilling or expanding. For example, you drill into a region (or pan to a certain area) and then use the breadcrumb to drill up. The drill-up operation takes you back to the state that the geographical map was in before you performed the drill and pan operations. You are not positioned in the panned results when you drill up.
Chapter 18
Sorting

How Sorting Can Help with Analysis

Information is easier to understand when it appears in an expected order. Applying a sort order to one or more data items enables you to arrange rows and columns in tables and axis labels on charts in some order, such as alphabetically or highest to lowest numerically. Interactively changing the order of data can provide you with a different perspective that often facilitates valuable insight. For example, in a report, sales employees who are initially arranged alphabetically can be resorted by geography or by sales amount. Seeing the most recent year first in a table can help you find the most relevant information faster. However, you can spot trends more quickly in a line plot if you order the years ascending chronologically. You can also sort data by multiple data items to show sales employees who generated the most to the least revenue, within an alphabetical list of the region. SAS Web Report Studio enables both report authors and viewers to easily set or change the sort order of the dates, the text, and the numbers that are presented in tables and graphs to facilitate understanding.

Sort Data in a List or Crosstabulation Table

To sort individual columns in a table, right-click the heading of the column that you want to sort, and then select Sort Ascending or Sort Descending.

For list tables, when you use this method to sort columns, the sort priority is in reverse selection order. For example, if you select Order Year descending, then Product Name ascending, and then Country ascending, the priority will be Country, then Product Name, and then Order Year.
Note: If measures in the crosstabulation table have been placed on the rows instead of the columns, then you are sorting the rows.

For crosstabulation tables, when you click to sort a column, it replaces any previous column sort that you have specified. You can also sort categories, rather than measures, by clicking the category name.

Specify a Sort and a Sorting Priority for Values in a List Table

To specify a sort and a sorting priority for values in a list table, complete these steps:

1. Right-click a column heading in the list table, and then select either Sort Ascending or Sort Descending.
2. To sort additional columns in order of priority, right-click each column heading and then select either Sort Ascending or Sort Descending.

Display 18.1 The Sort Ascending and Sort Descending Menu Options for a Table

Display 18.2 on page 196 shows a list table that has been sorted by the sales totals for each continent.

Display 18.2 A List Table That Has Been Sorted by the Sales Totals for Each Continent

If you are working with a relational list table in Edit or View mode, then you can right-click in the table and select Sort Priority. This opens the Sort Priority dialog box.
In the Sort dialog box, you can specify which item you want sorted first. You can sort multiple columns. In Display 18.5 on page 198, the list table is sorted first by height and then by age.
Note: The Sort Priority option is not available for list tables in a synchronized group.

---

Sort Ascending or Descending Values in a Graph

Right-click the name of a category or hierarchy level in a graph, and then select either Sort Ascending or Sort Descending.

---

Sort by Measure Values in a Graph

Right-click the name of a category or hierarchy level in a graph to sort the category or hierarchy level by the values of the measure used in the graph. If the graph has more than one measure, you can choose which one to sort by.
Remove All Sorting

If any sorting has been applied to a table or a graph, you can remove all sorting. Right-click the name of a category or hierarchy level in the graph or table and select Remove All Sorting.
Display 18.8  After Sorting: The Same Bar Chart with the Remove All Sorting Menu Item Selected
Chapter 19
Adding Total, Subtotal, and Percent of Total Calculations

How Totals, Subtotals, and Percent of Total Calculations Can Help with Analysis .................................................. 201

Understanding the Relationship Between Totals, Subtotals, and Percent of Totals ............................................ 202

Managing Totals and Subtotals in Tables ................................................................. 202
   About Totals and Subtotals ...................................................................................... 202
   Show or Hide Totals and Subtotals for List Tables .............................................. 203
   Show or Hide Totals and Subtotals for Crosstabulation Tables ......................... 203
   Show or Hide Totals and Subtotals for Multidimensional Tables ..................... 203

Managing Percent of Total Calculations in Tables .............................................. 204
   About the Different Calculations That You Can Create .................................... 204
   Add a Percent of Total Calculation to a Table .................................................... 204
   Remove a Percent of Total Calculation from a Table ......................................... 205

How Totals, Subtotals, and Percent of Total Calculations Can Help with Analysis

Summarizing data provides a fast way to understand how a group of data values are performing and how subgroups compare to one another. SAS Web Report Studio enables you to display the measures summarized, such as a summation or average, at one or multiple levels within tables. A summary for all values is called a total and a summary for a subgroup of values is called a subtotal. These totals and subtotals can be displayed above or below the group of values (for multidimensional data sources only). You can choose to add totals and subtotals for rows, columns, or both. When you need to understand how an individual item contributes to a group of values, you can add table cells to display the percent that value represents of the overall total, subtotal, or both. Totals, subtotals, and percent of total calculations help you evaluate metrics at higher levels and compare groups at the same level to determine where to focus your analysis.
Understanding the Relationship Between Totals, Subtotals, and Percent of Totals

For a multidimensional crosstabulation table, if you want any percent of total items, then you also need the corresponding total or subtotal items. For example, if you create a percent of row subtotal data item, then you also need the row subtotals.

If you have not already specified any necessary total or subtotal values, then SAS Web Report Studio adds them automatically. For example, if you have not yet specified any totals or subtotals when you create a percent of row subtotal data item, then the **Row Subtotals** option is already selected when you open the Total dialog box.

If you use the Total dialog box to remove any totals or subtotals, then any percent of total data items that depend on these totals and subtotals are automatically removed. Before this occurs, however, you see a warning and must confirm that you want to remove the totals and subtotals.

Managing Totals and Subtotals in Tables

*About Totals and Subtotals*

Totals can be positioned at the top, at the bottom, on the left, or on the right of a table element (for multidimensional data sources). By default, total and subtotal values are displayed in boldface type. In addition, their table cells have a light blue background. For more information about how to change the properties for displaying totals, see “Specify Style Properties for Total and Subtotal Values” on page 133.

Display 19.1  Multidimensional Crosstabulation Table with Formatted Column Total Values
Show or Hide Totals and Subtotals for List Tables

To show or hide totals for list tables, complete these steps:

1. Right-click on the list table, and then select Total to open the Total dialog box.
2. Select or deselect the Totals check box.
3. Click OK.

Show or Hide Totals and Subtotals for Crosstabulation Tables

To show or hide totals for crosstabulation tables, complete these steps:

1. Right-click on the crosstabulation table, and then select Total to open the Total dialog box.
2. Select one or more of these options:
   - **Row totals**: Select this option to display row totals.
   - **Row subtotals**: Select this option to display row subtotals.
   - **Column totals**: Select this option to display column totals.
   - **Column subtotals**: Select this option to display column subtotals.
3. Click OK.

Show or Hide Totals and Subtotals for Multidimensional Tables

For multidimensional data, in addition to the choices listed above for crosstabulation tables, the Totals dialog box provides some additional options:

- **Display**: You can choose where totals and subtotals appear. You can select either On top (left) or On bottom (right).
Type

You can choose whether totals and subtotals are based on all data or only the data that is being displayed. You can select either **Visual totals** (for totals and subtotals that are based on just the values being shown in your table) or **Parent totals** (for totals and subtotals that include all data in the cube, not just what’s shown in your table). For example, if your table contains a filter so that it shows data from only 2008 but your cube contains data for 2006-2009, then **Visual totals** provides a total for just 2008 values, while **Parent totals** provides a total that includes data from all four years.

Itemize Values Across Hierarchies

If you specify any totals or subtotals, you see an **itemize values across hierarchies** check box. If you select this check box and if you have more than one category on rows or columns, then in addition to grand totals, your table contains additional subtotal values for the outer categories.

---

**Managing Percent of Total Calculations in Tables**

**About the Different Calculations That You Can Create**

For tables that use relational data, you can add a column that shows a selected measure as a percentage of a grand total. For relational crosstabulation tables, you can show a selected measure as a percentage of a grand total, a column total, a row total, or a subtotal. For multidimensional crosstabulation tables, you can show a selected measure as a percentage of a grand total, a column total, a row total, a column subtotal, or a row subtotal.

**Add a Percent of Total Calculation to a Table**

To add a percent of total calculation to a table, complete these steps:

1. Right-click on the table, and then select **Percent of Total** to open the Percent of Total dialog box. The **Percent of Total** menu item is not available if either of these conditions exists:
   - The table does not contain any measures that can be used in a grand total.
   - The table is in a synchronized group.

2. In the **For measure** drop-down list, select a measure for the calculation. The following restrictions apply:
   - The list does not contain existing percent of total calculations.
   - The list contains only those measures that make sense for a grand total calculation.

3. In the **Show percent of** drop-down list, select an option, depending on the type of table:
   - For list tables, the **Column Total** option is the only type of percent of total that is supported.
   - For relational crosstabulation tables, for the selected measure, select the value that you want to calculate the measure as a percentage of. Your predefined choices are **Grand Total**, **Column Total**, and **Row Total**. The drop-down list also contains these options:
     - one option for the subtotal of each category in the columns of the table. The options are listed in order from the top down.
• one option for the subtotal of each category in the rows of the table. The options are listed in order from the outside inward.

• For multidimensional crosstabulation tables, for the selected measure, select the value that you want to calculate the measure as a percent of total of. The available choices are Grand Total, Column Total, Column Subtotal, and Row Subtotal.

4. Type a Label for the calculation that you are creating. You can use a maximum of 30 characters. The Label field is initially blank. The Add button is not available until you enter a value into this field.

5. Click Add to add your For measure, Show percent of, and Label selections to the box.

6. Click OK.

When the measure that is used in the calculation appears in a column, the new calculation appears immediately to the right of the measure. When the measure that is used in the calculation appears in a row, the new calculation appears immediately below the measure.

Note: If you ask for any percent of total items in a multidimensional crosstabulation table, you also see the corresponding total or subtotal items.

If you use the Properties dialog box to convert a crosstabulation table to a list table, then the following happens:

• All percent of grand total items become percent of column items.

• Any other percent of total items are removed, because they are not supported for list tables. You are asked to confirm the removal of these percent of total items.

Remove a Percent of Total Calculation from a Table

To remove a percent of total calculation from a table, complete these steps:

1. Right-click on the table, and then select Percent of Total to open the Percent of Total dialog box.

2. Select a calculation.

3. Click Remove.

4. Click OK.

Note: If you use the Select Data dialog box to remove a data item from your query, then any percent of total calculations that depend on it are automatically removed from your table.
Chapter 20
Applying Conditional Highlighting

How Conditional Highlighting Can Help with Analysis

Conditional highlighting is used to direct a report viewer's attention to specific report results. For example, a report author might design a report on suppliers so that table cells that contain delivery times that are greater than 14 days are automatically highlighted with a red background. You can also add, modify, or delete conditional highlighting when you view a report. For example, you might want to highlight delivery times that are less than five days instead of greater than 14 days.

For tables, SAS Web Report Studio has a variety of options for highlighting results that meet the specified conditions. In Display 20.1 on page 207, total sales values that are greater than $130,000 are bold. The revenue values also could have been replaced by an image or by user-supplied text.

**Display 20.1  Total Sales Values That Are Greater Than $130,000 Are Highlighted**
Graphs use shading as the highlighting method. In Display 20.2 on page 208, shoe product groups with revenues that are between $3 million and $6 million are highlighted.

**Display 20.2**  Shoes with Revenues That Are Between Three and Six Million Dollars Are Highlighted

![Graph showing product revenue groups with highlighting](image)

- **Applied filters:** None
- **Product:** > Clothes & Shoes > Shoes
- **Total Sales**
  - $6,000,000.00
  - $5,000,000.00
  - $4,000,000.00
  - $3,000,000.00
  - $2,000,000.00
  - $1,000,000.00
  - $0.00

- **Product Group:**
  - Eclipse Shoes
  - Shoes
  - Trolley Shoes

- **Gender:**
  - Female
  - Male

**Note:** Conditional highlighting is measure-based, so the table or graph must include at least one measure that can be used in the condition.

**TIP** For more information about conditional highlighting, see “Applying Conditional Highlighting” on page 276.

---

**Managing Conditional Highlighting for Table Values**

**Add Conditional Highlighting to Table Values**

To specify conditional highlighting for values in a table, complete these steps:

1. Right-click in the table, and then select **Conditional Highlighting** to open the Conditional Highlighting dialog box.

2. Click **New**.

Three tabs appear in the Conditional Highlighting dialog box: **Rule**, **Color and Font**, and **Image and Text**.

3. On the **Rule** tab, complete these steps:
   a. Select a **Measure**.
   b. Select the **Condition** that you want the selected measure to match.
   c. In the **Value** field, type in a value or select a measure in the drop-down list. If you selected **Is between** as the condition, then type a **Min value** and a **Max value**. If you selected **Is missing value** as the condition, then this field is unavailable.

   **Note:** If you are creating a condition for percentages, you must enter the conditional value as a decimal number. For example, if you want to filter for values above 50%, enter .5 as the conditional value.
Display 20.3 on page 209 is an example of the Conditional Highlighting dialog box that was used to create Display 20.1 on page 207.

Display 20.3  Rule Tab in the Conditional Highlighting Dialog Box for Tables

For multidimensional tables, the Rule Assignment option lets you specify which hierarchy level the rule will be applied to. You can specify one of the following:

- **All hierarchy levels**, which applies the rule to all hierarchy levels.
- **Selected hierarchy levels**, which applies the rule only to the hierarchy levels that you specify. Click Select. Select the specific hierarchy levels for the rule. Click OK.

Display 20.4  Selected Hierarchies in the Conditional Highlighting Dialog Box

4. (Optional) On the Color and Font tab, complete these steps to change the default settings:

   a. Select the Font, including the font size and font color, that you want to use to highlight values that meet the specified condition.
b. Select the **Font style** that you want to use to highlight values that meet the specified condition.

*Display 20.5  Color and Font Tab in the Conditional Highlighting Dialog Box for Tables*

5. (Optional) On the **Image and Text** tab, complete these steps:
   
a. Select the **Highlight by adding an image or text** option.

b. Indicate whether you want to add an **Image** or **Text** when the specified conditions are met.

c. Specify a **Position** for the image or text. Indicate whether you want the image or text to appear to the right or left of each cell that contains a value that meets the condition or in place of the value.

d. If you are using an image, select the **Image** that you want to use to highlight values that meet the specified condition.

*Display 20.6  Image and Text Tab in the Conditional Highlighting Dialog Box for Tables*
e. If you are using text, type the text into the Text field, and then select the Font and font style information.

6. To hide the tabs, click OK.

7. To close the Conditional Highlighting dialog box, click OK.

---

**Remove Conditional Highlighting from Table Values**

To remove conditional highlighting from table values, complete these steps:

1. Right-click in the table, and then select Conditional Highlighting to open the Conditional Highlighting dialog box.

2. In the Rules list, select a rule.

3. Click Delete.

4. In the confirmation message box that appears, click OK to delete the rule.

5. Click OK.

---

**Managing Conditional Highlighting for Graph Values**

---

**Add Conditional Highlighting to Graph Values**

To specify conditional highlighting for values in a graph, complete these steps:

1. Right-click in the graph, and then select Conditional Highlighting to open the Conditional Highlighting dialog box.

2. Select a Measure.

3. Select the Condition that you want the selected measure to match.

4. In the Value field, type in a value or select a measure in the drop-down list. If you selected Is between as the condition, then type a Min value and a Max value. If you selected Is missing value as the condition, then this field is unavailable.

   **Note:** If you are creating a condition for percentages, you must enter the conditional value as a decimal number. For example, if you want to filter for values above 50%, enter .5 as the conditional value.

Display 20.7 on page 212 is an example of the Conditional Highlighting dialog box that was used to create Display 20.2 on page 208.
Display 20.7  Conditional Highlighting for Values Between a Minimum and a Maximum Value

Remove Conditional Highlighting from Graph Values

To remove conditional highlighting from graph values, complete these steps:

1. Right-click in the graph, and then select Conditional Highlighting to open the Conditional Highlighting dialog box.
2. Click Clear.
3. Click OK.
Display Data Source, Data Item, and Filter Details for a Table or Graph

To display information about a table or a graph, right-click inside the table or graph, and then select Data Source Details. The Data Source Details dialog box contains the following information about the selected object:

**Data source**
This section contains the following information:

- **Name**
  This field displays the name of the data source that is being used for this table or graph.

- **Type**
  This field displays the type of data source (Relational or Multidimensional). The data source type determines which options are available for building and viewing reports.

- **Description**
  This field displays a description of the data source, if one is available.

**Applied filters**
This field displays the following information:

- The filters that are applied to the current report section. These filters affect all of the tables and graphs in the section that you are viewing.
- The filters and the rankings that are applied to this table or graph only.
- The expression that specifies how the filters and rankings are applied.

**Data item, Physical name, Description/expression**
For each data item in this table or graph, this box lists the name of the data item as it appears in the data source that was prepared by the data source administrator, the name of the data item in the original data source, and either a description (standard data items) or an expression (calculated data items).
Display 21.1  Data Source Details Dialog Box

Multidimensional data sources sometimes enable viewers to view the detail data behind a specific aggregated value or behind the aggregated values in an entire row or column. The data is displayed in a separate dialog box. You can export the data to a Microsoft Excel spreadsheet. Your data administrator determines whether detail data is available. If detail data is available, the aggregated values in the crosstabulation table are underlined.

To view detail data, complete these steps:

1. Perform one of these tasks to open the View Detail dialog box:
   
   - To see the detail data behind an aggregated value in the crosstabulation table, click the value (which is underlined).
   
   - To see the detail data behind a row or a column in the crosstabulation table, right-click the row or column heading in the innermost level of the innermost hierarchy in the row or column, and then select Show Detail Data.
**Display 21.2  View Detail Option for the Sales Cost Column**

![Image: Display 21.2 View Detail Option for the Sales Cost Column](image)

*Note:* If report linking has been enabled for the values in the crosstabulation table, then when you click on a value you are prompted either to view detail data or to follow the report link.

**Display 21.3  View Detail Dialog Box**

![Image: Display 21.3 View Detail Dialog Box](image)

2. (Optional) To export the data into a Microsoft Excel spreadsheet or to a Microsoft Word document, click **Export** to open the Export dialog box. To export the data, click **OK**. When prompted, choose either to open the file or to save it. For more information on exporting, see “Exporting Reports and Report Data” on page 263.

3. To exit the View Detail dialog box, click **Close Window**.

---

**Display Field Names, Values, and Measure Information for a Region in a Geographical Map**

To view information about a selected region on a geographical map, complete these steps:

1. On the geographical map toolbar, click ![Map](image) and then click a geographical map region.

2. In the Region Information dialog box, view the details.
In addition to details about the underlying data, such as field names and values, this dialog box displays the name and aggregated value for the measure currently being used.

3. Click **Close**.
Part 6

Managing Reports

Chapter 22
Maintaining and Organizing Reports .............................................. 219

Chapter 23
Maintaining Multi-Section Reports .............................................. 235

Chapter 24
Sharing Reports ................................................................. 239

Chapter 25
Linking Reports ............................................................... 251

Chapter 26
Scheduling Reports ............................................................ 257

Chapter 27
Printing and Exporting .......................................................... 263
Chapter 22
Maintaining and Organizing Reports

Overview of Managing Reports

The File Management window allows you to complete many tasks related to managing reports. To access the File Management window, select File \ Manage Files. The following tasks can be performed only from the File Management window:

- view a list of the reports that you have scheduled and distributed.
from the List of Scheduled Reports dialog box, schedule and distribute reports. You can also delete scheduled or distributed reports.

- move, copy, and delete multiple selected reports.
- delete multiple selected report folders.
- schedule all reports in a selected folder.

*Note:* You must have advanced permissions to copy, move, or delete multiple reports or folders. Contact your system administrator about permissions.

*Note:* Scheduling features are not available if a scheduling server is not available or if you do not have authorization to schedule reports.

Depending on your role and capabilities, the File Management window also allows you to do the following tasks:

- search for files
- repair reports
- print reports
- export reports
- e-mail reports
- add comments to reports or folders

*Display 22.1 File Management Window*
Archiving Reports

About Report Archiving

Authorized users can specify that they want to maintain an archive for a manually refreshed report. The archived copies are saved in PDF format. Files are named by using the date that they were archived; for example, output that was saved on September 19, 2008, would be named 2008_09_19.pdf.

Only one copy of a report can be saved per day. If a report is saved multiple times in one day, then only the next-to-last saved report is used as that day's archived copy. The earliest archived copy is automatically removed when the user-specified number of archived copies has been saved.

Anyone authorized to view reports can view an archived copy of a report.

Note: Your role might enable you to save reports but not to archive reports.

Archive a Report

To maintain an archive of a specific report, complete these steps:

1. Display the report that you want to archive in either Edit mode or View mode.
2. Select File ⇒ Save As to open the Save As dialog box.
3. In the Type drop-down list, select Data can be manually refreshed.
4. Select Retain previous instances of output not to exceed, and then type the number of archived reports that you want to maintain. Archived reports are saved in PDF format.
5. Click Save.

Display 22.2  Save As Dialog Box for Archiving a Report
6. When you are prompted to replace the existing report, click **OK**. (The existing report is saved as PDF output.)

*Note:* Authorized users can also specify to archive scheduled reports.

**View an Archived Copy of a Report**

To view an archived copy of a report, complete these steps:

1. From the Welcome window or Edit mode, perform one of these tasks:
   - Select **File ⇒ Open** to open the Open dialog box.
   - Select **File ⇒ Manage Files** to open the File Management window.

2. Next to the name of the report that has the archived copy that you want to view, click ![icon](icon.png) in the **Actions** column, and then select **Archived Output**.

*Note:* Archived reports are identified by this icon: ![icon](icon.png)

**Display 22.3  Open Dialog Box with the Archive Output Menu Item Selected**

3. In the Archived Output dialog box, select the archived copy that you want to view and then click **View**.
A PDF version of the report opens in a new Web browser window.

4. To close the Archived Output dialog box, click Close.

**Delete an Archived Copy of a Report**

To delete an archived copy of a report, complete these steps:

1. From the Welcome window or Edit mode, perform one of these tasks:
   - Select File → Open to open the Open dialog box.
   - Select File → Manage Files to access the File Management window.

2. Next to the name of the report that has the archived copy that you want to delete, click in the Actions column, and then select Archived Output.

   **Note:** Archived reports are identified by this icon: 📄

3. In the Archived Output dialog box, select the archived copy that you want to delete and then click Remove.

4. In the confirmation message box that appears, click OK to delete the archived copy.

5. Click Close.

**Copying Reports**

**Copy Individual Reports**

To copy an individual report, complete these steps:

1. From the Welcome window, Edit mode, or View mode, perform one of these tasks:
   - Select File → Open to open the Open dialog box.
• Select File ➜ Manage Files to access the File Management window.

2. Navigate to the folder that contains the report that you want to copy.

3. Next to the name of the report that you want to copy, click ⚡ in the Actions column, and then select Copy to open the Copy Report dialog box.

Display 22.5 Copy Report Dialog Box

4. Select a folder location, either My folders (your private folder area) or another folder in the SAS Folder tree.

   If you copy a report to the same folder that contains the original report, then the copied report is renamed by prepending Copy of to the report name. For example, if you copy a report named Orion Star Sales Forecast, then the copied report is renamed Copy of Orion Star Sales Forecast.

   If you copy a report to a different folder that already contains a report with the same name, then you are asked if you want to replace the existing report with the copied report.

   Note: To create a new folder, click 📦.

5. Click OK.

6. If you used the Open dialog box, click Close.

Copy Multiple Reports

To copy multiple reports, complete these steps:

Note: Only advanced users can copy multiple reports. If you have questions about your authorization, contact your system administrator.

1. From the Welcome window or Edit mode, select File ➜ Manage Files to access the File Management window.

2. Select the check box next to each report that you want to copy.

3. At the top of the check box column, click ⚡ and then select Copy.
4. Select a folder location, either My folders (your private folder area) or another folder in the SAS Folder tree.

If you copy the reports to the same folder that contains the original reports, then the copied reports are renamed by prepending Copy of to the report name. For example, if you copy a report named Orion Star Sales Forecast, then the copied report is renamed Copy of Orion Star Sales Forecast.

If you copy the reports to a different folder that already contains reports with the same names, then you are asked if you want to replace the existing reports with the copied reports. If some of the reports have the same name but some do not, you can click Cancel in the message box to cancel copying the reports with the same name. Reports that do not have conflicting names are still copied.

Note: To create a new folder, click .

5. Click OK.

Creating Report Templates

Overview of Report Templates

You can save report templates that contain one or more sections. Report templates can contain the following content:

• tables, graphs, images, text, and their last saved properties
• links from images and text to Web sites and reports
• a header and a footer
• stored process objects (without the stored process selected)
• positioning information

SAS Web Report Studio comes with a selection of templates. You can also create your own templates that you can share or keep private.

This section explains how to save a template, delete and edit your own templates or shared templates that are not saved as read-only, and share or hide templates.
Note:  Only authorized users can save templates. If you have questions about your authorization, contact your system administrator.

**Save a Report Template**

To save a report template that is based on the currently active report, complete these steps:

1. From the Welcome window or Edit mode, select **File ➤ Save As** to open the Save As dialog box.

2. Type the **Name** that you want to give to this new template. For more information about valid names, see “Naming Reports, Folders, and Templates” on page 273.

3. For the **Type** of report, select **Template**.
   
   *Note:* If you are viewing a manually refreshed report, then refresh the data to make the **Template** report type available.

4. Select a **Location**, either **Shared templates** or **My templates** (your private folder area).

   Report templates in the **Shared templates** folder can be used by other report users, and reports in the **My templates** folder can be used only by you and your system administrator.

5. (Optional) Type a template **Description**. The description is displayed in the Select a Template dialog box. You cannot use these characters: `< > & #

6. (Optional) Enter some **Keywords** for the template.

7. (Optional) Select the **Retain previous instances of output not to exceed** option and then enter a number.

8. (Optional) Select the **Automatically replace if file already exists** option if you want to replace an existing template without being prompted to confirm this action.

9. (Optional) Select the **Make read-only** option to prevent other users from deleting or modifying this template. (You will still be able to perform these actions on your own template.)

10. Click **OK**.

    If you saved the template from View mode, the currently displayed report is replaced by the template. Because the template does not include any data selections, you might see invalid graph, table, and map icons, depending on which objects the report contained. At this point, you can click **Edit** to add data and create a new report based on the template that you created, or you can open another report.

---

**Deleting Reports and Templates**

**Delete Individual Reports**

To delete an individual report, complete these steps:

1. From the Welcome window or Edit mode, perform one of these tasks:
   
   * Select **File ➤ Open** to open the Open dialog box.
   * Select **File ➤ Manage Files** to access the File Management window.
2. Next to the name of the report that you want to delete, click in the Actions column, and then select Delete.

3. In the confirmation message box that appears, click OK to delete the report.

4. If you used the Open dialog box, click Close.

Note: You cannot delete a report that is currently open.

**Delete Multiple Reports**

To delete multiple reports, complete these steps:

*Note:* Only advanced users can delete multiple reports. If you have questions about your authorization, contact your system administrator.

1. From the Welcome window or Edit mode, select File ➤ Manage Files to access the File Management window.
2. Select the check box next to each report that you want to delete.
3. At the top of the check box column, click and then select Delete.
4. In the confirmation message box that appears, click OK to delete the reports.

*Note:* You cannot delete a report that is currently open.

**Delete a Report Template**

To delete one of your own report templates or a shared template that is not saved as read-only, complete these steps:

1. Perform one of these tasks to open the Select a Template dialog box:
   - From the Welcome window or Edit mode, select File ➤ New ➤ New using Template.
   - In Edit mode, select Edit ➤ Apply a template.
2. Depending on which type of template that you want to delete, select either the Shared templates tab or the My templates tab.
3. Select a template.
4. Click Delete.
5. In the confirmation message box that appears, click OK.
6. To close the Select a Template dialog box, click Cancel.

---

**Modifying Report Properties**

To set or change the report style, filter display, keywords, and description for a viewed report, complete these steps:

1. In Edit or View mode, select File ➤ Properties to open the Report Properties dialog box.
2. If you are authorized to save changes to the report, on the **General** tab, set or modify keywords and the description. You can separate multiple keywords with commas. You cannot use these characters: `< > & #

**Display 22.7 General Tab of the Report Properties Dialog Box**

![](image)

3. On the **Format** tab, perform any of these tasks:

   **Note:** The **Format** tab is not available if the report needs to be refreshed.

   - Select one of four standard styles to use for the current report: **Plateau**, **Meadow**, **Seaside**, or **Festival**. Styles affect the color and font style used in graphs, tables, and geographical maps. Style changes do not affect text formatted in group breaks, headers, and footers.

   **Note:** Existing reports might use a **Custom** style. If you change the **Custom** style to one of the SAS Web Report Studio styles, then you will not be able to reset the report to the **Custom** style.

   - Specify whether you want to use the report style colors or customized colors. The report style colors are the default colors for the report. In the custom colors, select the first color square (with the darker border) to access the color palette. When you select a color from the palette, it is copied to the first color square. Later, when the graph is rendered, the color that you selected is used for the bars, lines, and so on.

   - Specify whether you want to display filter information with the report.

   If the report section contains independent objects, a filter text box appears above each object. If the report section contains synchronized objects, then one filter text box is displayed above the synchronized set. You can select a **Text** and **Border** color for the filter text and its surrounding box. The filter information is included in printed reports.
4. Click **OK**.

---

**Moving Reports**

**Move Individual Reports**

To move an individual report, complete these steps:

1. From the Welcome window or Edit mode, perform one of these tasks:
   - Select `File` ⇒ `Open` to open the Open dialog box.
   - Select `File` ⇒ `Manage Files` to access the File Management window.

2. Next to the name of the report that you want to move, click the **Actions** column, and then select **Move**.

3. In the Move Report dialog box, select a folder location, either **My folders** (your private folder area) or another folder in the **SAS Folder** tree.
   If you move a report to a folder that already contains a report with the same name, then you are asked if you want to replace the existing report with the moved report.

   *Note:* To create a new folder, click `folder`.

4. Click **OK**.

5. If you used the Open dialog box, click **Close**.

   *Note:* You cannot move a report that is currently open.

**Move Multiple Reports**

To move multiple reports, complete these steps:
Note: Only advanced users can move multiple reports. If you have questions about your authorization, contact your system administrator.

1. From the Welcome window or Edit mode, select File ➪ Manage Files to access the File Management window.
2. Select the check box next to each report that you want to move.
3. At the top of the check box column, click Add and then select Move.
4. In the Move Report dialog box, select a folder location, either My folders (your private folder area) or another folder in the SAS Folder tree.
   
   If you moved reports to a folder that already contains reports with the same names, then you are asked if you want to replace the existing reports with the moved reports.
   
   If some of the reports have the same name but some do not, you can click Cancel in the message box to cancel moving the reports with the same names. Reports that do not have conflicting names are still moved.
   
   Note: To create a new folder, click.
5. Click OK.

Note: You cannot move a report that is currently open.

---

Organizing Reports

About Folders

You can use folders to organize reports. For example, you could create a folder to contain sales reports for a specific year and then create subfolders to hold reports for specific regions.

There are two types of folders: personal folders and shared folders. Personal folders are in the My Folder area. Your system administrator creates a secure folder structure for SAS Web Report Studio users who create new folders. For more information, see “Overview of Shared Locations” on page 239.
Create a Folder

You can create a new folder when you copy a report, move a report, or save a report. You can also create a new folder by clicking in the Open dialog box or on the File Management window.

Rename a Folder

To rename a folder, complete these steps:

1. From the Welcome window or Edit mode, perform one of these tasks:
   - Select File ⇒ Open to open the Open dialog box.
   - Select File ⇒ Manage Files to access the File Management window.

2. Next to the name of the folder that you want to rename, click in the Actions column, and then select Rename.

3. In the Rename Folder dialog box, type the new name. For more information about valid names, see “Naming Reports, Folders, and Templates” on page 273.
4. Click **OK**.
5. If you used the Open dialog box, click **Close**.

*Note:* You cannot rename a folder that contains a report that is currently open.

**Deleting Folders**

**Delete Individual Folders**

To delete an individual folder, complete these steps:

1. From the Welcome window or Edit mode, perform one of these tasks:
   
   • Select **File** ⇨ **Open** to open the Open dialog box.
   
   • Select **File** ⇨ **Manage Files** to access the File Management window.

2. Next to the name of the folder that you want to delete, click ![delete](image) in the **Actions** column, and then select **Delete**.

3. In the confirmation message box that appears, click **OK** to delete the folder.

4. If you used the Open dialog box, click **Close**.

*Note:* You cannot delete a folder that contains a report that is currently open.

**Delete Multiple Folders**

To delete multiple folders, complete these steps in the File Management window:

*Note:* Only advanced users can delete multiple reports. If you have questions about your authorization, contact your system administrator.

1. From the Welcome window or Edit mode, select **File** ⇨ **Manage Files** to access the File Management window.

2. Select the check box next to each folder that you want to delete.

3. At the top of the check box column, click ![delete](image) and then select **Delete**.

4. In the confirmation message box that appears, click **OK** to delete the folders.

*Note:* You cannot delete a folder that contains a report that is currently open.
Rename a Report

To rename a report, complete these steps:

1. From the Welcome window or Edit mode, perform one of these tasks:
   • Select **File ⇒ Open** to open the Open dialog box.
   • Select **File ⇒ Manage Files** to access the File Management window.

2. Next to the name of the report that you want to rename, click ![Actions icon] in the **Actions** column, and then select **Rename**.

3. In the Rename Report dialog box, type the new name of the report.

   ![Rename Report Dialog Box](image)

   For more information about valid names, see “Naming Reports, Folders, and Templates” on page 273.

4. Click **OK**.

5. If you used the Open dialog box, click **Close**.

   *Note:* You cannot rename a report that is currently open.

---

Repairing Reports

There are times when you might need to repair a report. For example, if an information map referenced in a report has been moved, renamed, or both, then you will need to repair your report.

*Note:* You must have advanced permissions to repair reports. Contact your system administrator about permissions.

To repair a report, complete these steps:

1. From the Welcome window or Edit mode, select **File ⇒ Manage Files** to access the File Management window.

2. Next to the name of the report that you want to repair, click ![Actions icon] in the **Actions** column, and then select **Repair report**.
3. In the Repair Report dialog box, if `not found` appears beside the original information map, then the information map needs to be repaired. Click **Browse** to the right of the **Correct Information Map** label to open the Select Information Map dialog box.

**CAUTION:**

Do not use the **Browse** button to choose a different information map. Only use the **Browse** button to locate the original information map that has been moved or renamed.

*Display 22.12  Repair Report Dialog Box*

4. Navigate through the tree structure and select the information map that was renamed or moved.

5. Click **OK**. The information map that you selected appears under the **Correct Information Map** label.

6. Click **OK**.
Overview of Report Sections

Any report can have multiple sections. Multiple sections can be used to present different views of the data to the person who views the report. Each section has one information map data source; however, it can use data from many different sources by including multiple stored processes. There is no limit to the number of sections that can be included in a report. Once you have created sections in a report, you can choose to independently view, link to, or distribute a specific report section.

You can use a group break to divide report sections by distinct category or hierarchy level values when you are using a relational or multidimensional data source. When you set a group break, it applies to all elements in the section. For more information about group breaks, see Chapter 14, “Grouping Query Results,” on page 119.

Add a Section to a Report

You can add sections to any type of report, including reports that were created in another SAS reporting application. However, be aware that when you save your changes, you are creating a new saved report. If you replace an old report with a new report, the format might change slightly.

For example, if you display a report in Edit mode and then add one or more sections to it, you must complete the Save As dialog box to save your changes. By completing the Save As dialog box, you create a new saved report.

When you add a section, you can choose to use the same data, header, and footer as an existing section.

To add a new section to a report, complete these steps:
1. In the Table of Contents pane in Edit mode, select Options ⇒ Insert a New Section or select Insert ⇒ New Section to open the New Section dialog box.

2. In the New section name field, type a name for the section.

3. Under Data, select one of these options:
   - Get new data
     Select this option if you want the data for the new section to come from a different data source. For more information, see Chapter 12, “Defining Queries to Obtain Results,” on page 85 and Chapter 9, “Including Stored Process Output,” on page 73.
   - Copy data from
     Select this option if you want the new section to use the same data as another section in the report. Select the existing section from the drop-down list.

4. Under Header, select Blank if you do not want the new section to contain a header. To use the same header as an existing section, select Copy header from and select the section from the drop-down list.

5. Under Footer, select Blank if you do not want the new section to contain a footer. To use the same footer as an existing section, select Copy footer from and select the section from the drop-down list.

   Display 23.1  New Section Dialog Box

6. Click OK.

---

**Rename a Report Section**

To rename a report section, complete these steps:

1. In the Table of Contents pane in Edit mode, select the section that you want to rename.

2. Select Options ⇒ Rename Section.

3. In the Rename Section dialog box, type the new name.
4. Click **OK**.

---

### Reorder Report Sections

To change the order in which the report sections appear, complete these steps:

1. In the Table of Contents pane in Edit mode, select **Options ⇒ Reorder Sections**.
2. In the Reorder Sections dialog box, move the sections.

3. Click **OK**.

---

### Delete a Section From a Report

To delete a section from a report, complete these steps:

1. In the Table of Contents pane in Edit mode, select the section that you want to delete.
2. Select **Options ⇒ Delete Section**.
   
   *Note:* The **Delete** option is not available if the report has only one section.
3. In the confirmation message box that appears, click **OK** to delete the section.
Overview of Shared Locations

In general, reports in all folders in the SAS Folder tree, except My Folder, can be viewed by other report users. Your system administrator can also create subfolders that are restricted to a specific group of users. For example, the administrator might create a subfolder named Human Resources that is restricted to human resources employees. For more information, see “Save a Report” on page 60.

Reports in the My Folder area can be viewed only by you and your system administrator. The name of your personal folder is derived from your user ID and is visible only to your system administrator.

When you save, copy, or move a report, you can place the report either in a shared folder or in your personal folder.

E-mail a URL for a Report

To e-mail the URL for a report, complete these steps:

1. In View mode, perform one of these tasks:
   • Select File ⇒ Open to open the Open dialog box.
   • Select File ⇒ Manage Files to access the File Management window.
2. Next to the name of the report that you want to e-mail, click E-mail in the Actions column, and then select E-mail.

If the report does not contain multiple sections or prompts, then the generated URL for the report is automatically copied into an e-mail message.

**Display 24.1 An E-Mail Message with the Generated URL for a Report**

If the report has multiple sections or prompts, then you can select a section, specify prompt values, or both. Complete these additional steps:

a. In the Define Section and Prompt Values dialog box, complete either of these tasks:
   - For a report that has multiple sections, select a section from the Open to section drop-down list. This is the section that is sent in the e-mail message.
   - For a report with prompts, the prompt values are available for you to select. There will be scroll bars for multiple prompts. You can scroll to answer more prompts.

b. Click E-mail Report. The generated URL for the report is automatically copied into an e-mail message.

If the URL with parameters, section information, or both is too long to send, then an error message displays. You can download a shortcut to a file that can be used to open the report.

**Display 24.2 Error Message If the URL Is Too Long**

You can either attach the downloaded file to an e-mail message or save the shortcut file to disk and then send a link to the shortcut. If you click OK in the error message, a File Download dialog box opens. Click Save to save the files to disk. The prefix of OPEN_ is added to the filename. The file type is HTML. You can attach this file to an e-mail message.

3. Send the e-mail message.
A publication channel is an information repository that has been established by using the SAS Publishing Framework. It can be used to publish information to users and applications. (An administrator creates the publication channels.) If you publish your report to a publication channel, then authorized users and applications can access your report by subscribing to the channel. Users can view the report that is saved as a PDF file, if it is stored in the report repository. You can use the Open dialog box or the File Management window to navigate to the report and open it. For more information, see “Viewing Externally Created Reports” on page 45.

In SAS Web Report Studio 4.2, you can control the life cycle of a published report. You can specify that a report be deleted from the publication channel after a certain number of days. You can set the report's expiration date either in the Save As dialog box or in the Schedule Wizard (Step 1).

To publish a report to a publication channel (if one is available), complete these steps:

1. Select File \(\Rightarrow\) Save As to open the Save As dialog box.
2. Type the Name that you want to give to this new report. For more information about valid names, see “Naming Reports, Folders, and Templates” on page 273.
3. For the Type of report, select Static report (.pdf format).
   Note: The Publication Channel settings are available only when you set the report type to Static report (.pdf format).
4. Select the Publication Channel to which you want to publish the report.
5. (Optional) Enter a number in the Days until expiration field. The default is 90 days.
6. (Optional) Type a report Description. You cannot use these characters: < > ( ) & # \.
7. (Optional) Type Keywords. Separate each keyword with a comma. You cannot use these characters: < > ( ) & # \.
8. Click **OK**.

---

**Distributing Reports**

**About Distributing Reports**

The Distribute Report Wizard enables you to distribute reports by using e-mail as a PDF attachment or embedded HTML. Reports with group breaks can be distributed to targeted recipients based on the breaks. For example, you have a sales report with group breaks on regions. Each sales manager in the recipient list could receive information on his or her respective region only.

The distributed output is external only; it is not saved to the report repository.

To distribute a report, a scheduling server must be available and you must have the authorization to distribute reports. For more information, contact your system administrator.

*Note:* Only advanced users can distribute reports or manage recipient lists. If you have questions about your authorization, contact your system administrator.

**Prepare for Distribution**

For information about preparing for report distribution, see the SAS Web Report Studio chapter in *SAS Intelligence Platform: Web Application Administration Guide*. 

---

Display 24.3  How the Save As Dialog Box Appears with a Publication Channel Specified
Distribute a Report

Note: You cannot prepare for distribution and distribute a report during the same report distribution process.

1. To launch the Distribute Report Wizard, perform one of these tasks:
   • When a report or stored process is displayed in View mode, select File ➤ Distribute.
   • In the File Management window, next to the name of the report or stored process that you want to distribute, click  in the Actions column, and then select Distribute.
     The first wizard page appears.

2. Specify the interval for running the report.
   The rest of the information that you must provide depends on your selection. If you select Now, then you do not need to select any other options.

3. For any Run report option other than Now, specify the time that you want to run the report. You can also specify the starting and ending (if applicable) date range for the schedule.

Display 24.4 Distribute Report Wizard – Step 1

4. Click Next to go to the next wizard page, or click Finish.
   Note: If the report has prompts that are not optional, then you must specify prompt values before exiting.

5. If the report has prompts, a wizard page displays those prompts.
6. After you enter the required prompt values, click **Next** to go to the next wizard page.

7. Specify whether you want to distribute the report by using e-mail as a PDF attachment or as embedded HTML.

8. (Optional) Enter text for the subject line of the e-mail.

9. Enter the **Sender** address.

10. (Optional) Enter a display name for the **Sender** address. If your e-mail address is stored in metadata, then this field is automatically filled in. If you type another e-mail address here, then the address is stored in the repository and is filled in the next time you distribute a report.

11. (Optional) Enter text for an e-mail message to accompany the report.

12. If you want to change a currently selected recipient list or the currently set group break division, click **Recipients and Distribution Rules**.

   **Note:** If there is a recipient list already selected, the list name appears next to the **Recipients and Distribution Rules** button.

Complete these steps in the Specify Recipient Rules dialog box:

a. Select a recipient list. The contents of the list are displayed beneath the selection box. (Recipient lists are created by your system administrator.)
b. If the report has more than one section, select the section of the report that contains the group break information that you want to use for distribution. (All sections of the report will be distributed.)

c. Either clear the Group break option, or select the option and choose a group break from the drop-down list. This option only appears if you selected a section that contains group breaks.

d. If you selected the Group break option, then assign each available group break to a column in the recipient list. The number of group breaks that are available depends on which group break level you selected in step 6c. For example, if you selected the third group break level in step 6c, then three group break levels are available to assign to columns. If you selected the first group break level, then only that level is available to assign to a column.

Note: The associations between group breaks in the report and columns in the recipient list should make sense. For example, it makes sense to assign a Product Category group break to a Product Category column in the recipient list.

e. Click OK to return to the wizard page.

Note: If you are a system administrator, then this dialog box also contains a New icon and a Remove icon. For more information about creating and removing recipient lists, see the SAS Web Report Studio chapter in SAS Intelligence Platform: Web Application Administration Guide.
13. Click **Next** to go to the next wizard page, or click **Finish**.

14. If you click **Next**, the summary page appears. The summary page might contain the following information, depending on your selections on the previous wizard pages:
   - name of the report
   - time that the report is scheduled to run
   - any prompt values
   - report section that contains the group break that you are using to divide the report
   - group break that you are dividing the report on
   - targeted recipient list
15. (Optional) Perform one or more of these tasks:
   - Send a copy of the distributed report to the Sender address that you selected on the previous wizard page.
   - Test your distribution settings. You can send the results to the Sender address, and you can view the results when the test is complete. Click Run Test to run the test.
     
     *Note:* To make changes to your selections on previous wizard pages, click Back.

16. Click Finish to save your settings and exit the wizard.

**View a List of Distributed Reports**

To view a list of the reports that you have scheduled by using the Distribute Report Wizard, complete these steps:

1. From the Welcome window or Edit mode, select File ⇒ Manage Files to access the File Management window.

2. Open the List of Scheduled Reports dialog box. The name of the link that opens the dialog box depends on your role:
   - If you do not have permission to distribute reports, you will not see a link.
   - If you can schedule but not distribute reports, then click View scheduled reports.
   - If you can both schedule and distribute reports, then click View scheduled and distributed reports.

The List of Scheduled Reports dialog box contains the following information:

**Last updated**

This field displays the date that the list of scheduled and distributed reports was last updated.

**Refresh lists**

Select this option to update the list of reports.
Schedule, Actions, Schedule Definition
This field displays the name of each scheduled and distributed report and the time that each report is scheduled to run or be distributed.

To see a menu of options for editing and deleting a specific scheduled or distributed report, click in the Actions column.

Occurrence, Status, Date/Time
This field displays the status of the last three occurrences of each scheduled and distributed report, either Failed, Executed, or Running. The Date/Time column displays the date and time for each successful or failed execution. Each report can have up to three occurrences listed, not including occurrences with the status of Running.

If the status is Failed, take these actions to try to resolve the problem:
• rerun the schedule or distribution
• delete the schedule or distribution, re-create it, and then run it again
• contact your system administrator

Note: The scheduling and distributing features are not available if a scheduling server is not available or if you do not have authorization to schedule and distribute reports.

Display 24.9 A List of One Scheduled Report, One Distributed Report, and One Successful Execution

3. When you are finished viewing the information, click Close.

Edit a Distribution Plan
To edit a report schedule that you have scheduled by using the Schedule Report Wizard or distributed by using the Distribute Report Wizard, complete these steps:
1. From the Welcome window or Edit mode, select File ⇒ Manage Files to access the File Management window.

2. Open the List of Scheduled Reports dialog box. The name of the link that opens the dialog box depends on your role.
   • If you do not have permission to distribute reports, you will not see a link.
   • If you can schedule but not distribute reports, then click View scheduled reports.
   • If you can both schedule and distribute reports, then click View scheduled and distributed reports.

3. Next to any scheduled occurrence of the report or folder of reports that you want to edit, click in the Actions column.

4. Depending on which wizard you used to schedule the report, select Schedule or Distribute.

Display 24.10  Scheduled and Distributed Reports Dialog Box

5. Make your changes in the Schedule Report Wizard or the Distribute Report Wizard. For more information about how to use the wizards, click Help on any wizard page.

6. To close the List of Scheduled Reports dialog box, click Close.

Note: Only authorized users can edit reports that they have scheduled or distributed. If you have questions about your authorization, contact your system administrator.

Delete a Distribution Plan

To delete a report that you have scheduled by using the Schedule Report Wizard or distributed by using the Distribute Report Wizard, complete these steps:

1. Select File ⇒ Manage Files to access the File Management window.
2. Click **View scheduled and distributed reports** to open the List of Scheduled Reports dialog box.

3. Next to any scheduled occurrence of the report or folder or reports that you want to delete, click " ![ ]" in the **Actions** column, and then select **Delete Schedule** or **Delete Distribution**.

4. In the confirmation message box that appears, click **OK**.

   *Note:* When you delete a schedule or distribution, all references to executing the schedule or distribution are also removed from the **Occurrence, Status, Date/Time** box.

5. To close the List of Scheduled Reports dialog box, click **Close**.

*Note:* Only authorized users can delete reports that they have scheduled or distributed. If you have questions about your authorization, contact your system administrator.
Chapter 25
Linking Reports

Overview of Report Linking

Report links allow you single-step access to a report or Web page that is related to a report that you are currently viewing. For example, you might be looking at a bar chart which has sales information for each geographical region of your company. If you click the bar for the Northeast region, then a report link associated with the graph could take you to a different report that provides information about employees in each region. And, if the destination report contains a prompted filter, then it would open to a table containing only information about the Northeast region. A link at the top of a destination report enables you to return to the previous report. If a destination report contains multiple sections, then you are able, when defining the link, to choose the initial section of the destination report you want to open.

When you click the report link in the current report, the category values associated with what you click can be supplied as values to the prompts in the destination report.

Creating a Link to a Report or to a Web Page

Access the Report Linking Dialog Box for Images, Tables, or Graphs

You create report links by using the Report Linking dialog box while in Edit mode. To create a report link for images, tables, or graphs, complete these steps:

1. Right-click the report object, and then select Report Linking to open the Report Linking dialog box.
For a link to an existing report, continue with the steps described in “Linking to an Existing Report or Stored Process” on page 253. For a link to a Web page, continue with the steps described in “Linking to a Web Page” on page 254.

**Access the Report Linking Dialog Box for Text Objects**

You create report links by using the Report Linking dialog box while in Edit mode. To create a report link for text objects, complete these steps:

1. In Edit mode, right-click on the text object, and then select **Edit** to open the Edit Text dialog box.

2. Enter the complete text that you want to display. Then highlight the text that you want to link from. Do not select anything other than plain text (no formatting changes).

   **TIP** Be careful not to select all the text in a paragraph.

   ![Edit Text Dialog Box with Selected Text](image)

   **TIP** If you are using Internet Explorer, and you want to create a link from text that is already a Web address (such as [www.mycompany.com](http://www.mycompany.com)) or an e-mail address (such as myname@mycompany.com), do this instead: First, type in a temporary name that is not a valid URL (for example, [wwwXmycompany.com](http://wwwXmycompany.com)), and select it. Click **** and fill in the Text Linking dialog box as described in “Linking to a Web Page” on page 254. Then click **OK**. Finally, change the temporary name in the text to the desired text (for example, change [wwwXmycompany.com](http://wwwXmycompany.com) to [wwwmycompany.com](http://wwwmycompany.com)).

3. Click **** to open the Report Linking dialog box.
To link to a Web page, continue with the steps described in “Linking to a Web Page” on page 254.

Choosing a Link Destination

**Linking to an Existing Report or Stored Process**

To link to an existing report or stored process, complete these steps:

1. Start with the steps described in
   - “Access the Report Linking Dialog Box for Images, Tables, or Graphs” on page 251
   - “Access the Report Linking Dialog Box for Text Objects” on page 252

2. Select the **Include report links** check box to confirm that you want to create a report link.

3. Select a link destination of **An existing report**.


5. (Optional) Add tooltip text. The default tooltip text is **View linked content**.

6. If the destination report contains multiple sections or prompts, then click **Set Up Destination Report** to open the Set Up Destination Report dialog box and assign group break levels in the current report to prompts in the target report. If there are multiple sections, select one. If there are prompts, then specify the values that you want a report viewer to see when they link to the report.
If the destination report contains multiple sections, the **Open to section** drop-down list contains the names of the sections in the destination report. Select the section that you want for the initial section when a user clicks to follow a link.

If the destination report contains any prompts or if the report object in your source report contains any visible categories or occurs within a group break, a drop-down list displays for each prompt in the destination report. If none of the available items in the drop-down list provides the intended value for a given prompt, then leave the drop-down list unchanged.

**Display 25.4 Set Up Destination Report Dialog Box**

The following are special considerations for text and image objects:

- Text objects uniquely allow you to create multiple report links, but the **Set Up Destination Report** button does not appear in the Report Linking dialog box.

- For image objects, if the destination report has multiple sections or contains prompts, the **Set Up Destination Report** button is available, but you cannot specify the data items corresponding to prompts in the destination report.

Click **OK** to close the Set Up Destination Report dialog box.

7. Click **OK** to close the Report Linking dialog box.

**Linking to a Web Page**

Type the URL for the Web page that you want to link to. When the user clicks to follow the link, the Web page opens in a separate browser window.

1. Start with the steps described in
   - “Access the Report Linking Dialog Box for Images, Tables, or Graphs” on page 251
   - “Access the Report Linking Dialog Box for Text Objects” on page 252

2. In the Report Linking dialog box, select the check box to make a link. (The name of the check box depends on the type of report object.) Then select **A Web page** for the Link destination.

3. Select the **A Web page** option.
4. Enter a value for the **Web page URL**.

![Report Linking Dialog Box for a Text Object](image)

**Display 25.5** Report Linking Dialog Box for a Text Object

5. (Optional) Add tooltip text. The default tooltip text is **View linked content**.

6. Click **OK** to close the Report Linking dialog box.

---

**Creating a Link for a Group Break**

To link to a report from a group break, complete these steps:

1. In the Table of Contents pane in Edit mode, select **Options ⇒ Group Breaks Report Linking** to open the Report Linking dialog box.

2. Specify what you want to link to by selecting an item (or items) in the **Assign link(s) to** list.
3. For a link to an existing report, continue with the steps described in “Linking to an Existing Report or Stored Process” on page 253. For a link to a Web page, continue with the steps described in “Linking to a Web Page” on page 254.

**Understanding the Run-Time Behavior of Links**

When you follow a Web link, a new browser window opens. The source report is not closed, so there is no link to return you to it.

When you follow a link to another report in SAS Web Report Studio, the target report displays in the primary SAS Web Report Studio window. A **Return to previous report** link is available. The return link also displays the name of the source report that you will return to. Click the link to return to the source report.
Overview of Scheduling Reports

Scheduling report generation automates the process of delivering updated content to report users. You can schedule reports to generate once or at recurring intervals, such as daily, weekly, or monthly. In addition to automating the process of generating reports, scheduling reports gives authors the ability to schedule a time to pre-generate content during non-peak hours. Instead of waiting for a report to generate, the report can be scheduled to run during off-peak hours. SAS Web Report Studio provides an easy-to-use interface that allows users to schedule a report to run at any time.

Scheduling Reports, Stored Processes, and Folders

About Scheduling

For faster rendering, you can schedule a time for queries to be pre-generated for selected reports and stored processes, including an entire folder of reports.

To schedule a report, a scheduling server must be available and you must have the authorization to schedule reports. For more information, contact your system administrator.

Schedule a Report, Stored Process, or Folder

To schedule a report, stored process, or folder, complete these steps:
1. To launch the Schedule Report Wizard, perform one of these tasks:
   • When a report or stored process is displayed in View mode, select File ➤ Schedule.
   • In the File Management window, next to the name of the report, stored process, or folder that you want to schedule, click in the Actions column, and then select Schedule.
   The first wizard page appears.

2. Specify the interval for running the report, stored process, or folder.
   The rest of the information that you must provide depends on your selection. If you select Now, then you do not need to select any other options.

3. For any Run report option other than Now, specify the time that you want to run the report. You can also specify the starting and ending (if applicable) date range for the schedule.

4. (Optional) To archive the report, select Retain previous instance of output not to exceed. Archived reports are saved in PDF file format and can be opened from the Open dialog box or from the File Management window.
   Note: Only one copy of a report can be saved per day. If a report is saved multiple times in one day, then only the next-to-last saved report is used as that day's archived report.
   Note: Only authorized users can choose to archive a report. If you have questions about your authorization, contact your system administrator.
   Note: This option is not available for folders.

5. (Optional) If publication channels are defined, then select the Publication Channel to which the report should be saved. The list of available channels is supplied by your system administrator.
   Note: A publication channel is an information repository that has been established by using the SAS Publishing Framework. It can be used to publish information to users and applications. If you publish your report to a publication channel, then authorized users and applications can access your report by subscribing to the channel.
   Specify a number in the Days until expiration field. The default is 90 days.
6. Click **Next** to go to the next wizard page, or click **Finish**.

   **Note:** If the report has prompts that do not have defaults, you must specify prompt values before exiting.

7. If the report has prompts, a wizard page appears displaying those prompts.

   **Display 26.2  Schedule Report Wizard for Step 2**
8. After you enter the required prompt values, click **Next** to go to the next wizard page, or click **Finish**. The summary page displays the name of the report, the time that it is scheduled to run, and any prompt values.

*Note:* To make changes to your selections on previous wizard pages, click **Back**.

**Display 26.3  Schedule Report Wizard for Step 3**

9. Click **Finish** to save your settings and exit the wizard.

*Note:* When you schedule a stored process, SAS Web Report Studio saves the results in a report with the same name as the stored process. The report is saved in the same folder as the stored process.

---

**View a List of Scheduled Reports**

To view a list of the reports that you have scheduled by using the Schedule Report Wizard, complete these steps:

1. From the Welcome window or Edit mode, click **File → Manage Files** to access the File Management window.

2. Open the List of Scheduled Reports dialog box. The name of the link that opens the dialog box depends on your role:
   - If you do not have permission to distribute reports, you will not see a link.
   - If you can schedule but not distribute reports, then click **View scheduled reports**.
   - If you can both schedule and distribute reports, then click **View scheduled and distributed reports**.

The List of Scheduled Reports dialog box contains the following information:
Last updated
This field displays the date that the list of scheduled reports was last updated.

Refresh lists
Select this option to update the list of reports.

Schedule, Actions, Schedule Definition
This field displays the name of each scheduled report and the time that each report is scheduled to run.

To see a menu of options for editing and deleting a specific scheduled report, click in the Actions column.

Occurrence, Status, Date/Time
This field displays the status of each occurrence of each scheduled report, either Failed, Executed, or Running. The Date/Time column displays the date and time for each successful or failed execution. Each report can have up to three occurrences listed, not including occurrences with the status of Running.

If the status is Failed, take these actions to try to resolve the problem:

• rerun the schedule
• delete the schedule, re-create it, and then run it again
• contact your system administrator

Display 26.4 A List of One Scheduled Report, One Distributed Report, and One Successful Execution

Note: The scheduling features are not available if a scheduling server is not available or if you do not have authorization to schedule reports.

3. When you are finished viewing the information, click Close.
Edit a Report Schedule

To edit a report schedule that you have scheduled by using the Schedule Report Wizard, complete these steps:

1. From the Welcome window or Edit mode, click File ➪ Manage Files to access the File Management window.

2. Open the List of Scheduled Reports dialog box. The name of the link that opens the dialog box depends on your role:
   - If you do not have permission to distribute reports, you will not see a link.
   - If you can schedule but not distribute reports, then click View scheduled reports.
   - If you can both schedule and distribute reports, then click View scheduled and distributed reports.

3. Next to any scheduled occurrence of the report or folder of reports that you want to edit, click in the Actions column.

4. Depending on which wizard you used to schedule the report, select Schedule or Distribute.

   For more information about how to use the wizards, click Help on any wizard page.

6. To close the List of Scheduled Reports dialog box, click Close.

Note: Only authorized users can edit reports that they have scheduled. If you have questions about your authorization, contact your system administrator.

Delete a Report Schedule

To delete the report schedule using the Schedule Report Wizard, complete these steps:

1. From the Welcome window or Edit mode, click File ➪ Manage Files to access the File Management window.

2. Click View scheduled reports to open the List of Scheduled Reports dialog box.

3. Next to any scheduled occurrence of the report or folder or reports that you want to delete, click in the Actions column, and then select Delete Schedule.

4. In the confirmation message box that appears, click OK.
   
   Note: When you delete a schedule, all references to executing the schedule are also removed from the Occurrence, Status, Date/Time box.

5. To close the List of Scheduled Reports dialog box, click Close.

Note: Only authorized users can delete reports that they have scheduled. If you have questions about your authorization, contact your system administrator.
Overview of Printing and Exporting

SAS Web Report Studio provides several mechanisms that give you output that can be delivered to report consumers. Entire reports or targeted parts of a report can be saved as PDF output or in Microsoft Excel format for future viewing or printing. This output can be saved locally on disk or sent to a printer.

Exporting Reports and Report Data

Export the Contents of an Entire Report

To export the entire contents of a viewed report, complete these steps:

1. To create the zipped file that contains all the necessary reporting elements, from the Welcome window or Edit mode, select File ⇒ Manage Files to access the File Management window.

2. Next to any report that you want to export, click in the Actions column, and then select Export.

3. When you are prompted, save the zipped file to a location such as your hard drive or a networked drive.
4. Extract the report files to a folder in a location such as your hard drive or a networked drive.

After the extraction, the folder contains the following contents:

- `sasExport_files` contains the auxiliary files needed to display the report. You do not interact with the files in this folder.
- `sasExport.html` enables you to open the report in a Web browser.
- `sasExport.xls` enables you to open the report in a Microsoft Excel spreadsheet.

Note: When opening files in Microsoft Excel, you might receive a warning that the files are not in the expected location. Click Yes in the message box to acknowledge the warning.

Export Data from a Graph

To export data from a graph, complete these steps in View mode:

1. Right-click in the graph and select Export Graph Data to open the Export dialog box.

Display 27.1   How the Export Dialog Box for Graphs Appears for Exporting to Excel

2. Choose one of the following export options:
   - With the Export to radio button selected, choose the Excel option to export the graph data to Microsoft Excel.
   - With the Export to radio button selected, choose the Word option to export the graph data to Microsoft Word.
   - Select the Save as radio button. Then select either Tab separated values (.tsv) file or Comma separated values (.csv) file to create a data file.

3. To export the data, click OK.
4. When you are prompted, choose either to open the file or to save it.

Export Data from a Geographical Map

To export data from a geographical map, complete these steps in View mode:

1. Click the map toolbar to open the Export dialog box.

2. Choose one of the following export options:
   - With the Export to radio button selected, choose the Excel option to export the graph data to Microsoft Excel.
• With the **Export to** radio button selected, choose the **Word** option to export the graph data to Microsoft Word.

• Select the **Save as** radio button. Then select either **Tab separated values (.tsv) file** or **Comma separated values (.csv) file** to create a data file.

3. To export the data, click **OK**.

4. When you are prompted, choose either to open the file or to save it.

---

**Export Data from a List Table**

To export data from a list table, complete these steps in View mode:

1. Right-click in the list table and select **Export Table** to open the Export dialog box.

2. Choose one of the following export options for rows:
   - Select the **All Rows** radio button to export all rows.
   - Select the **Rows** radio button to specify a range of rows to export. Enter a number in the **From** and **To** fields.

3. Choose one of the following export options for columns:
   - Select the **All columns** radio button to export all columns.
   - Select the **Selected columns** radio button to specify which columns to export. Then select the check box to the left of the column or columns that you want to export. You can use **or** to change the order of the selected columns.

4. If you select the **Export to** radio button, then choose one of the following options:
   - Select the **Excel** option to export the graph data to Microsoft Excel.
   - Select the **Word** option to export the graph data to Microsoft Word.

5. If you select the **Save as** radio button, choose one of the following options:
   - Select **Tab separated values (.tsv) file** to create a data file for Notepad.
   - Select **Comma separated values (.csv) file** to create a data file for Microsoft Excel.
You can also select (or deselect) the following check boxes related to the **Save as** option:

- Specify **Formatted data** to save formatted data in the data file.
- Specify **Repeat row labels if expanded** to repeat row labels for expanded levels in the data file.

6. To export the data, click **OK**.
7. When you are prompted, choose either to open the file or to save it.

---

**Export Detail Data from a Crosstabulation Table**

To export detail data from a crosstabulation table, complete these steps in View mode:

*Note:* If you want to see the detail data before you export it, then see “View Detail Data in a Crosstabulation Table” on page 267.

1. Right-click in the crosstabulation table and select **Export Table** to open the Export dialog box.

**Display 27.3**  
*How the Export Dialog Box for Crosstabulation Tables Appears for Exporting to Excel*

2. Choose one of the following export options for rows:
   - Select the **All Rows** radio button to export all rows.
   - Select the **Rows** radio button to specify a range of rows to export. Enter a number in the **From** and **To** fields.

3. If you select the **Export to** radio button, then choose one of the following options:
   - Select **Excel** to export the graph data to Microsoft Excel.
   - Select **Word** to export the graph data to Microsoft Word.

4. If you select the **Save as** radio button, choose one of the following options:
   - Select **Tab separated values (.tsv) file** to create a data file for Notepad.
   - Select **Comma separated values (.csv) file** to create a data file for Microsoft Excel.

You can also select (or deselect) the following check boxes related to the **Save as** option:

- Specify **Formatted data** to save formatted data in the data file.
- Specify **Repeat row labels if expanded** to repeat row labels for expanded levels in the data file.

5. To export the data, click **OK**.

6. When you are prompted, choose either to open the file or to save it.

---

**View Detail Data in a Crosstabulation Table**

To view detail data in a crosstabulation table before you export it, complete these steps:

**Note:** You cannot view detail data in a crosstabulation table if the data source has not been set up to support this feature by your data source administrator. In addition, whether the columns show the column label or the column name is controlled by a system administrator.

1. Perform one of these tasks to open the View Detail dialog box:
   - To see the detail data behind a value in a crosstabulation table, click the value (which will be underlined).
     **Note:** If report linking has been enabled for the values in the crosstabulation table, then when you click on a value you are prompted either to view detail data or to follow the report link.
   - To see the detail data behind a row or a column in a crosstabulation table, click the row or column heading in the innermost hierarchy level in the row or column and then select **Show Detail Data**.

2. In the View Detail dialog box, you can review the data by selecting either **Show column labels** or **Show column names**.

   You can also click **Export** to export the data.
Display 27.5  View Data Dialog Box for a Crosstabulation Table

3. Click **Close Window** to return to the report.

**Printing Reports**

**Specify Printing Preferences**

To specify printing preferences such as margins, page size, page orientation, and whether to print page numbers, complete these steps:

1. Select **File ➤ Page Setup** to open the Page Setup dialog box.
2. For **Orientation**, specify **Portrait** or **Landscape**.
3. Select the **Size**.
4. (Optional) For **Fit**, specify **Wrap** or **Fit width**.
5. (Optional) Select a value from each drop-down list to specify **Margins** for the top, bottom, left, and right. You can enter values as inches or centimeters.
6. (Optional) Specify **Header and Footer** information. You can enter values as inches or centimeters.
   a. For the **Page numbers/Content**, specify **1, 2, 3, 1 of n, 2, of n, 1/n, 2/n, 3/n**, or **None**.
   b. Select where the page numbers will appear.
   c. Select the alignment of the page numbers.
   d. Select the **Restart page numbering for each section** option.
7. Click **OK**.

**Print a Report**

To print a report, complete these steps:

1. Depending on your location, perform one of these tasks to open the Print dialog box:
   - If you are in the View Edit view, select **File ⇒ Print**.
   - If you are in the File Management page, next to the name of the report that you want to print, click in the **Actions** column, and then select **Print**.

   *Note:* If this is a manually refreshed report, then you must refresh the data before you can select printing options. However, you can click **Preview and Print** to print the report with the existing printing options.

2. Specify a **Print range** by using these options:
   - **Current page (includes all table rows and columns)**
     Select this option if you want to print only the content that is currently shown in View mode. This means that only the content within the currently displayed group break value (if the report author chose to break a new page for each value) and within the current section is printed.
   - **All pages**
     Select this option if you want to print the entire report.
   - **Page(s)**
     Select this option if you want to print a portion of the report. After you select this option, you can then select where you want the printed portion to begin and end by using the two drop-down lists.

3. (Optional) Select **Page breaks** to insert page breaks between report sections.
4. To display the PDF output that you can print or save, click **Print to PDF**.

5. In Adobe Acrobat, complete these steps:
   a. Select **File ➔ Print** to open the Print dialog box.
   b. To send the report to the specified printer, click **OK**.
   c. To exit Adobe Acrobat, select **File ➔ Close**.

6. To close the Print dialog box, click **Close**.

*Note:* New report sections that are added to reports that were originally created in SAS Enterprise Guide do not include a static report creation date in the printed output.
Part 7

Appendixes

Appendix 1
Tips and Guidelines .................................................. 273

Appendix 2
Browsers and SAS Web Report Studio ............................. 281

Appendix 3
Data Refresh: Manual Versus Automatic ......................... 283

Appendix 4
Data Sources: Relational Versus Multidimensional ............ 285

Appendix 5
What to Do If You Are Prompted for Credentials ............. 287

Appendix 6
What to Do If Your Data Source Is Invalid .................... 291

Appendix 7
Incomplete Tables and Graphs .................................... 293
Appendix 1
Tips and Guidelines

Naming Reports, Folders, and Templates

Here is some information about naming conventions in SAS Web Report Studio:

**Uniqueness requirements**
Names are not case-sensitive. For example, you cannot have a report named **2008 Vendor Costs** and a report named **2008 VENDOR COSTS** in the same folder.

**Character restrictions**
Report, folder, and template names cannot contain these characters: \
/ : * ? " < > |
@ # &

**Length requirements**
Report, folder, and template names must be 56 characters or less in length. Use spaces if your names are long. If you use a 56-character name with no spaces in it, then the browser cannot word-wrap the name to fit the normal width Name column in the files list. You must resize the dialog box to make it wide enough to see all of the content and the OK button.

If you make a copy of a report that has a name longer than 56 characters, the trailing characters that exceed the maximum of 56 are dropped. For example, a report named abcdeghijklmnopqrstuvwxyzabcdeghijklmnopqrstuvwxyzabcdeghijklmnopqrstuvwxyzabcdeghijklmnopqrstuvwxyz is saved as **Copy of abcdeghijklmnopqrstuvwxyzabcdeghijklmnopqrstuvwxyzabcdeghijklmnopqrstuvwxyzabcdeghijklmnopqrstuvwxyz**.

**Keywords**
Keywords must be 56 characters or less in length. Use spaces if your keywords are long. If you use a 56-character keyword with no spaces in it, then the browser cannot word-wrap the keyword to fit the normal width Name column in the files list. You must resize the dialog box to make it wide enough to see all of the content and the OK button.

Searching for Reports and Stored Processes

Here is some information about searching for reports and stored processes in the Open dialog box or the Report Management page.

Case sensitivity
The search is not case-sensitive. For example, if you search for profit in the report, your search results include results such as Sports Equipment Profits as well as Company profits last year.

Results based on single words
If you search for a single word, then SAS Web Report Studio assumes a wildcard character before and after the word. For example, if you perform a search with low in the Search for field, then the search results include results with names like Low Activity, Regions with Lowered Sales, and Monthly Allowance.

The scope of the search
Searching does not include content. If you end the search argument with an asterisk (*), then the "starts with" filter is used. If you place an asterisk at the beginning of a search argument, then the "ends with" filter is used.

Hiding Data Items

Here is some information about hiding data items in tables, graphs, and geographical maps:

Restrictions on hiding data items
Data items that are selected for group breaks are automatically hidden. You cannot assign the data items to different functions.

Consequences of hiding data items
- If you hide the geographic hierarchy in a report section that contains a geographical map, then the geographical map becomes invalid.
- If you hide a category that is used in a report-linking prompt, then the prompt association is removed. The report link still works, but you must complete the prompt window before the target report is rendered.
- If you hide a data item that is used in a conditional highlighting rule, then the conditional highlighting rule is removed from the table or graph. If you hide a time hierarchy, then any custom data items that are based on relative time are also hidden.
- A crosstabulation table measure filter or ranking that is based on a category or hierarchy that is located on the outermost column or the outermost row is removed if the category...
or hierarchy is hidden. This is because the filter or ranking is tied to the location of the data item. If the data item is removed from that location, then the filter or ranking is also removed.

- If you hide a data item that is used in a sort, then the list table or graph is re-sorted, but the sorting information is saved with the data item. Here are some additional details:
  - If the hidden data item was the only sorted column, then the list table or graph is re-sorted to use its defaults as determined by the underlying data source. If you reassign the hidden data item to a function in the table or graph, the sort is restored.
  - For list tables, if the hidden data item is, for example, the first out of three sorted columns, then the table is re-sorted so that the second sorted data item becomes the first priority and the third sorted data item becomes the second priority. If you reassign the first sorted data item to the Columns function, then the reassigned data item becomes the third priority in the sort.

Creating Section Filters

Here is some information about creating section filters:

Restrictions on filtering
- You can create section filters only for categories in a relational data source.
- You cannot use the characters `<` > in filter names, prompt names, or default values.

Working with formatted and unformatted values

Some data items enable you to apply the filter using formatted values instead of unformatted values. If the Filter on formatted values option is available and you select it, then formatted values are loaded into the Available values box when you click Get Values. In this case, any values that you type must also be formatted. To load unformatted values into the Available values box, deselect the Filter on formatted values option and click Get Values again. In this case, you must type unformatted values. Regardless of your formatting choice, the query results are formatted.

Note: Depending on how the data item is defined in the data source, the formatted values might be the same as the unformatted values.

Using prompt names and prompt text

Typically, the prompt name is the same as the filter name but not always. For example, the user might not need to know the location of a source city, but, as the filter creator, you need to distinguish between the two filters in the Section Filters dialog box. In this case, you might name the two filters Canadian Source City and US Source City but give them both the same prompt name of Source City.

Be as specific as possible when entering the prompt text for users. For example, if you use the Not equal to operator for the prompt, then users need to know that their selections will be excluded from the report. A descriptive prompt name also helps users to enter the correct information.

Filter expressions

The filter combination expression is automatically updated as you select and deselect filters in the Section Filters dialog box. If your changes result in a filter combination expression
that is not valid, you receive a warning. For more information about how to create a valid expression, see “Combine Filters” on page 116.

When you are creating a section filter that uses the **Between values** or **Not between values** operator, keep in mind that filters are evaluated based on the data type (character or numeric) of the selected data item and the locale that is currently active for the browser. For example, as a character string, the number 23 is considered higher than 1345 in the U.S. English locale. By default, filters are joined by the **AND** operator, which means that results are returned only if all selected filters are true.

**When you can query for values**

The data source administrator determines whether you can query the data source for available filter values and whether you can create a filter that allows users to dynamically generate values.

**Previewing filter results**

To preview filtered results, select **Data → Preview Section Data** to open the Preview Data dialog box. All columns and up to 100 rows are displayed at one time. For more information, see “Preview or Export Query Results” on page 98.

---

**Applying Conditional Highlighting**

Here is some information about applying conditional highlighting to tables and graphs:

**Requirements**

Conditional highlighting is measure-based, so the table or graph must include at least one measure that can be used in the condition.

**How conditions are evaluated**

Highlighting conditions are evaluated based on raw values. The use of raw values affects how conditions are applied to rounded values. For example, in your table or graph, you have formatted product prices so that they are rounded up or down. The actual cost of a pair of Eclipse running shoes is $49.65. In the table or graph, the $49.65 price is rounded up to $50. If you specify that you want to highlight all products that cost less than $50, the Eclipse running shoes are highlighted because their actual price is less than $50.

**Creating conditions for percentages**

If you are creating a condition for percentages, you must enter the conditional value as a decimal number. For example, if you want to filter for values above 50%, enter .5 as the conditional value.

**Creating rules**

In general, there are two types of rules that you can create:

- Rules that compare a measure to a fixed value. For example, you might create a rule for Sales > 1000.
- Rules that compare one measure value relative to another measure value. For example, you might create a rule for Sales > Budget.

SAS Web Report Studio processes these rules in the following ways:
• For the first type of rule, the condition is applied at the current level of the data source. For example, if you drill down into the data and then specify conditional highlighting, the condition applies to the level that is currently displayed.

• For the second type of rule, the condition is applied at all levels of the data source, regardless of the current level.

---

### Defining Prompts in Report Linking

Here is some information about defining prompts in report linking:

**Restrictions on defining prompts**

You can define prompts only when the target report uses relational data. You can create a report based on a multidimensional data source as the source report in the report-linking operation. You can pass the parameters from the multidimensional report into a relational report.

**Verifying prompt associations**

SAS Web Report Studio does not check that your associations make sense, so make sure that you assign an appropriate data item value to each prompt. For example, you might link a Product Name group break in the primary report to a prompt for Product Name in the target report, but you would not link a Gender group break to a prompt for Order Year.

**Conditions that cause the Prompt window to appear**

If you assign a value to each prompt in the target report, then the prompt window is bypassed when the user clicks the link in the primary report. If you do not assign a value to each prompt in the target report, then the prompt window appears. The user can then confirm the current prompt values or enter new ones.

If you remove or hide a category or hierarchy that is used in a report-linking prompt, then the prompt association is removed. The link to the target report still works, but the user must answer the prompts to display the target report.

**Interaction with manually refreshed reports**

If you link to a report that is manually refreshed, the prompt values sent from the primary report are not used for the target report. Instead, SAS Web Report Studio displays the results of the last query run for the target report.

---

### Filtering and Ranking Tables, Graphs, and Geographical Maps

Here is some information about filtering and ranking tables, graphs, and geographical maps:

**Working with formatted and unformatted values**

If you are filtering on unformatted values, then you must enter values that match the casing of the values in the data source. If you select the Filter on formatted values option, then
you must enter the formatted values. If the filter does not return any results, then try using a different casing. Note that you can select the Ignore case check box if you are working with relational data.

How time periods are counted

When filtering dates, times, and timestamps in tables and graphs, you can specify time periods such as days, weeks, months, and years. When SAS Web Report Studio counts by these time periods, it treats each period as a unit and begins counting from the beginning of the specified period type in which the current date falls. For example, if you use Months as the period type, SAS Web Report Studio counts the specified number of whole months from the current month, regardless of where the current date falls within the current month.

Here are two examples that illustrate how time periods are counted in this type of filter:

- Today is December 20, 2008, and you want to filter a table so that it includes sales that were posted before three months ago. If you use Months as the period type, the table includes data from sales that were posted before September 1, 2008. SAS Web Report Studio counts back three whole months from the current month and returns data before the first day of that month. To filter the table so that it includes sales that were posted 90 days before December 20, 2008 use Days as the period type. If you specify 90 days, the table includes sales that were posted before September 21, 2008.

- Today is December 20, 2008, and you want to filter a graph so that it includes employees who were born more than 10 years ago. If you use Years as the period type, the graph includes employees who were born before January 1, 1998. SAS Web Report Studio counts back 10 whole years from the current year and returns data before the first day of that year. To filter the graph so that it includes employees who were born 3,650 days (365 * 10) before December 20, 2008, use Days as the period type. If you specify 3,650 days, the graph includes employees who were born before December 23, 1998.

What time is used for time and date filters

When you create time or date filters, the filter is relative to the time that the section query is generated, not to the time that the filter is imposed on the table or graph.

When filters and rankings are applied

Category and hierarchy filters are applied before rankings and measure filters.

Restrictions on filtering and ranking

You cannot create filters that use categories and hierarchies that are assigned to group breaks.

You cannot filter on percent of total values.

You cannot create a percentage ranking for relational data.

For scatter plots, you cannot create a measure filter or ranking if there is no category or hierarchy assigned to the optional marker group function.

When you can select category values

For relational data sources, the availability of the Get values button is controlled by your data administrator.

Consequences of changing data assignments in a crosstabulation table
If you add or hide a category or hierarchy column, then any row filters and rankings that are based on a column measure are removed. Filters are not affected by adding or hiding measures.

If you add or hide a category or hierarchy row, then any column filters and rankings that are based on a row measure are removed. Filters are not affected by adding or hiding measures.

Filters are retained if you move all the data items that are currently on rows to the columns and move all the data items that are currently on the columns to the rows. In this case, any existing filters will remain and be evaluated based on the new positions.

**Consequences of turning percent of totals off**

If a table contains percent of totals for rows that are based on row subtotal values, then those percent of totals are removed when you turn off subtotals for the table.

If a table contains percent of totals for rows that are based on row total values, then those percent of totals are removed when you turn off subtotals for the table.

If a table contains percent of totals for columns that are based on column subtotal values, then those percent of totals are removed when you turn off subtotals for the table.

If a table contains percent of totals for columns that are based on column total values, then those percent of totals are removed when you turn off subtotals for the table.

---

**Using Reports Created with a Previous Version of SAS Web Report Studio**

Here is some information on using reports that were created with a previous version of SAS Web Report Studio:

**How to use prompt names**

Prompted filters now have a prompt name. The prompt name appears on both the Prompts page and in the Report Linking dialog box when a prompted filter is in the destination report. In previous versions of SAS Web Report Studio, the prompt name was the data item label. SAS Web Report Studio now allows multiple filters per data item, which lets you customize the prompt name and lets the report viewer distinguish among prompted filters based on the same data item. New filters have the same filter name as the prompt name. Old prompted filters still have the data item label as the prompt name. If you change old filters to prompted filters, then the prompt name is blank. If the prompt name is blank and you save the filter, then the filter name is used as the prompt name.
Appendix 2
Browsers and SAS Web Report Studio

Browser Limitations

You should not attempt to connect to SAS Web Report Studio in more than one tab of Firefox or Internet Explorer 7. Also, you should not attempt to connect multiple browsers on the same computer to SAS Web Report Studio. Either of these situations causes unpredictable results.

Using Firefox with SAS Web Report Studio

Modal dialog boxes

If you use Firefox 2.0 or later as your browser, then you should configure Firefox as described here. Otherwise, you will have problems seeing dialog boxes in SAS Web Report Studio. You might see dialog boxes, but they will not be modal. This means that the main window will keep the focus and the dialog box will be behind the main window. You will be unable to make any selections in the dialog box.

To set your Firefox browser options to enable modal dialog boxes, follow these steps:

1. In Firefox, select Tools ⇒ Options to open the Options window. Select the Content tab if it is not selected by default.
2. In the Content tab, make sure that the Block pop-up windows check box is not selected. If this option is selected, then you will not be able to open any dialog boxes in SAS Web Report Studio, and you will probably see the following error message:

Display A2.1  Error Message for Pop-Up Windows
3. In the **Content** tab, make sure that the **Enable JavaScript** check box is selected. Click **Advanced** to open the Advanced JavaScript Settings dialog box.

4. In the Advanced JavaScript Settings dialog box, make sure that the following check boxes are selected:
   - **Move or resize existing windows**
   - **Raise or lower windows**
   - **Disable or replace context menus**

   These options are required for modal dialog boxes and context menus to work properly in SAS Web Report Studio.

   Click **OK** to close the dialog box. Then close the Options window.

**Access keys**

If you want to use a SAS Web Report Studio access key in the Firefox browser, then you need to use **SHIFT+ALT+access key**.
Appendix 3
Data Refresh: Manual Versus Automatic

If you have permission, you can save a report either to be manually or automatically refreshed. If you have questions about your authorization, contact your system administrator. Table A3.1 on page 283 explains the consequences of each option.

Table A3.1  Comparison of Refresh Options in the Save As Dialog Box

<table>
<thead>
<tr>
<th>Refresh Option Selected in the Save As Dialog Box</th>
<th>Consequences</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data is automatically refreshed</td>
<td>A large report might take a long time to open. However, it takes less time to save a large report. When the report is opened (and any required prompts are answered), the report automatically includes the most current data in the underlying data source that the viewer is authorized to see.</td>
</tr>
<tr>
<td>Data can be manually refreshed*</td>
<td>A large report that contains a lot of data might open more quickly. However, a large report might take a long time to save. The data that is shown in the report is updated to match the underlying data source only when the report viewer requests a refresh. Selecting Refresh Data in one section refreshes data in all report sections. While viewing the report, users can perform certain actions only after they have refreshed the data. For example, the report viewer would apply a filter to a crosstabulation table after the report has been refreshed with data. The report can be archived by authorized users.</td>
</tr>
</tbody>
</table>

* Reports that are pregenerated on a schedule are also manually refreshed. (Not all report authors are authorized to schedule reports.)
### Appendix 4

Data Sources: Relational Versus Multidimensional

Table A4.1 on page 285 compares some of the functionality that might be available when designing and viewing reports that are based on relational and multidimensional data sources.

**Table A4.1  Data Source Comparison**

<table>
<thead>
<tr>
<th>Functionality</th>
<th>Relational</th>
<th>Multidimensional</th>
<th>When Functionality Is Available</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filtering category values for section queries</td>
<td>yes</td>
<td>yes, but only predefined section filters</td>
<td>designing</td>
<td>A data source administrator determines whether the data source supports this functionality.</td>
</tr>
<tr>
<td>(by selecting predefined filters or by creating custom filters)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Filtering and ranking data in tables, graphs, and maps</td>
<td>yes</td>
<td>yes</td>
<td>viewing and designing</td>
<td>A data source administrator determines whether the data source supports this functionality.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>You cannot create measure filters or rankings for crosstabulation tables in Design mode.</td>
</tr>
<tr>
<td>Sorting in tables and graphs</td>
<td>yes</td>
<td>yes</td>
<td>viewing and designing</td>
<td>A data source administrator determines whether the data source supports this functionality.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>When designing a report, only sorting for list tables is available.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>You cannot specify a sorting priority for multidimensional data.</td>
</tr>
<tr>
<td>Modifying detail and aggregation settings</td>
<td>yes</td>
<td>no</td>
<td>designing</td>
<td>For multidimensional data, records are always grouped and the aggregation method of a measure cannot be changed.</td>
</tr>
<tr>
<td>Viewing detail data</td>
<td>no</td>
<td>yes</td>
<td>viewing</td>
<td>A data source administrator determines whether the data source supports this functionality.</td>
</tr>
<tr>
<td>Drilling and expanding</td>
<td>no</td>
<td>yes</td>
<td>viewing</td>
<td>A data source administrator determines whether the data source supports this functionality.</td>
</tr>
</tbody>
</table>
Appendix 5
What to Do If You Are Prompted for Credentials

About the Request for Credentials

Some companies do not like to store user passwords in metadata. This is often true when third-party databases, such as Teradata, Oracle, or DB2, are used.

When you are denied access to view a report because of missing database credential information, SAS Web Report Studio gives you the opportunity to enter a valid user ID and password. When you enter your user ID and password, they are valid for the current session only, because they are stored in memory and not in metadata.

Enter Credentials

If you are prompted for credentials when accessing a data source, an error message appears. Click Manage Credentials to open the Manage Credentials dialog box.

Display A5.1 Missing Report Element Error Message

When you encounter a missing credential situation, a Manage Credentials menu item is also added to the File menu. This menu item remains on the File menu for the rest of the current session. You can use the Manage Credentials menu item to access the Manage Credentials dialog box. By default, this menu item does not appear until it is needed; however, your system administrator can permanently enable this menu item.
Use the Manage Credentials dialog box to specify an authentication domain and to enter your user name and password. To enter your credentials, complete these steps:

1. Select an **Authentication domain**.

2. Enter your **User name**.

3. Enter your **Password**.

4. Confirm your password in the **Password confirm** field.

5. Click **Add**. Your **Authentication domain** and **User name** display in the dialog box.

6. (Optional) Add another authentication domain, user name, and password. Click **Add**.

7. Click **Close**.

**Note:** Your user ID and password are valid for the current session only. They are stored in memory, not in metadata.

Alternatively, you can select **File ➪ Manage Credentials** to open the Manage Credentials dialog box.
Remove Credentials

If you entered credentials during a login session, then you can use the Manage Credentials dialog box to remove an authentication domain, your user name, and your password. To remove your credentials, complete these steps:

1. Select **File ➠ Manage Credentials** to open the Manage Credentials dialog box.

   *Display A5.4  Manage Credentials Dialog Box with Credentials Displayed*

2. Click **Remove** in the row where your Authentication domain and User name are displayed. The row is removed.

   *Display A5.5  Manage Credentials Dialog Box with No Credentials Entered*

3. (Optional) Remove another authentication domain, user name, and password by clicking **Remove**.

4. Click **Close**.
What to Do If Access Is Still Denied

If you follow the steps listed in “Enter Credentials” on page 287 and you still cannot enter your credentials, then contact your system administrator.
Appendix 6
What to Do If Your Data Source Is Invalid

About Invalid Data Sources

Sometimes it is impossible to render one or more report elements in SAS Web Report Studio. These situations are usually related to one of these causes:

- A data source (information map) has been moved or renamed.
- A table or graph is incomplete. For more information, see “Incomplete Tables and Graphs” on page 293.

When a Data Source Has Been Moved or Renamed

A data administrator can use folders to help organize a large number of data sources (information maps). The administrator can also move, rename, and delete existing data sources. If a data source is deleted, then users are unable to open any reports that access the data source. If a data source has been moved, renamed, or both, then users with the appropriate role and access to the File Management window can use the repair report option to find the correct data source and redirect the report to use it.

For more information, see “Repairing Reports” on page 233.
Appendix 7
Incomplete Tables and Graphs

If a table or a graph (other than a geographical map) is missing one or more required role assignments, it appears with sample data and a message that indicates what is needed. Display A7.1 on page 293 shows a crosstabulation table that cannot be fully rendered because no data items are assigned to the rows.

**Display A7.1  An Example of an Incomplete Table**

Display A7.2 on page 293 shows a graph that cannot be fully rendered because no category data item is assigned to the X axis.

**Display A7.2  An Example of an Incomplete Graph**

Here are the requirements for tables and graphs:

- All multidimensional tables and graphs (other than scatter plots) require a category.
- All multidimensional tables and graphs require at least one measure.
- All bar-line charts and scatter plots require two measures.
- All geographical maps require a geographical data item in a data source (information map).

Here are some ways that you can update an incomplete report element in View mode so that the report renders correctly:

- Select a data item in the Section Data pane, and then drag it where you want it in the report element. Hotspots appear over the report element to indicate the appropriate places to drop the data item.
• For a crosstabulation table, select a data item in a table, and then drag and drop it on another location in the table.

• Right-click in the report element, and then select **Assign Data** to open the Assign Data dialog box. Then use drag and drop features to assign any missing data items. You can also use the **Move Items** drop-down list to assign any missing data items.

• If your original data selection does not have enough data items to complete a report element, select **Data ⇒ Select Data** open the Select Data dialog box. Then select additional data items from the list of available data items in the data source.

Categories that are used as group break items cannot also be used as visual data items in a report element in View mode. In some cases, you might need to remove a group break to make a category available. Once the category is available, you can make it visible to complete the report element.
Glossary

aggregate function
a function that summarizes data and produces a statistic such as a sum, an average, a minimum, or a maximum.

aggregation
the act or process of grouping data, using an operation that produces a statistic such as a sum, average, minimum, or maximum. The term aggregation can also refer to the grouped data that results from such an operation. See also aggregate function.

alphanumeric character
any of the following types of characters: alphabetic letters, numerals, and special characters or blanks. Most computer systems store strictly numeric data differently from alphanumeric or textual data.

bar chart
a chart that consists of a grid and some vertical or horizontal columns (bars). Each column represents quantitative data.

bar-line chart
a bar chart with an overlaid line graph. See also bar chart and line graph.

category
a classification of data items. Category data items are used to group measure data items, using an applied aggregate function. For example, a category data item that contains the names of countries could be used to group a measure data item that contains population values.

child
within a dimension hierarchy, a descendant in level n-1 of a member that is at level n. For example, if a Geography dimension includes the levels Country and City, then Bangkok would be a child of Thailand, and Hamburg would be a child of Germany.

crosstabulation table
a two-dimensional table that shows frequency distributions or other aggregate statistics for the intersections of two or more categories. In a crosstabulation table, categories are displayed on both the columns and rows, and each cell value represents the data result from the intersection of the categories on the specific row and column.
cube
a set of data that is organized and structured in a hierarchical, multidimensional arrangement. A cube includes measures, and it can have numerous dimensions and levels of data.

data item
an item in a data source that is either a logical view of a data field or a calculation. The author of a report decides which data items to use in a particular section of a report. There are three types of data items: hierarchies, categories, and measures.

data source
a collection of data items and filters that provides a user-friendly view of data. Users of query and reporting applications such as SAS Web Report Studio can easily build business reports by using data sources as the building blocks for their reports.

detail data
(1) for multidimensional data sources, nonaggregated data. (2) for relational data sources, every record in a selected data source. Duplicate records can be either excluded or included. See also multidimensional data source and relational data source.

dimension
a group of closely related hierarchies. Hierarchies within a dimension typically represent different groupings of information that pertains to a single concept. For example, a Time dimension might consist of two hierarchies: (1) Year, Month, Date, and (2) Year, Week, Day. See also hierarchy.

equivalent interval
one group in a range of data that has been divided into equal groups.

expression
a combination of data elements, literals, functions, and mathematical operators. An expression can be used to derive a value or to specify a condition that determines whether or how data is processed.

filter
criteria that restrict either the data that is returned from a query to a data source or the data that is displayed in a table, graph, or map.

format
an instruction that SAS uses to write data values. Formats are used to control the written appearance of data values, or, in some cases, to group data values together for analysis.

gis
a software application for organizing and analyzing data that can be referenced spatially - that is, data that can be associated with physical locations. Many types of data, such as data from marketing surveys and epidemiological studies, have a spatial aspect. Short form: GIS.

GIS
See geographic information system.

group break
a way to divide report sections by distinct category or hierarchy level values when you are using a relational or multidimensional data source.
hierarchy
an arrangement of members of a dimension into levels that are based on parent-child relationships. Members of a hierarchy are arranged from more general to more specific. For example, in a Time dimension, a hierarchy might consist of the members Year, Quarter, Month, and Day. In a Geography dimension, a hierarchy might consist of the members Country, State or Province, and City. More than one hierarchy can be defined for a dimension. Each hierarchy provides a navigational path that enables users to drill down to increasing levels of detail. See also member and level.

histogram
a bar chart that displays the observed frequencies of data that have been binned (divided into contiguous, equally spaced intervals). The heights of the bars indicate the relative frequency of observations in each bin.

information map
See data source.

level
in a multidimensional database (or cube), an element of a dimension hierarchy. Levels describe the dimension from the highest (most summarized) level to the lowest (most detailed) level. For example, possible levels for a Geography dimension are Country, Region, State or Province, and City.

line graph
a graph that shows the relationship of one variable to another, often as movements or trends in the data over a period of time. Line graphs summarize source data and typically are used to chart response values against discrete categorical values.

list table
a two-dimensional representation of data, in which the data values are arranged in rows and columns.

locale
a setting that reflects the language, local conventions, and culture for a geographic region. Local conventions can include specific formatting rules for dates, times, and numbers, and a currency symbol for the country or region. Some examples of locale values are French_Canada, Portuguese_Brazil, and Chinese_Singapore.

mean
the arithmetic average, which is calculated by adding the values of a sample variable and dividing this sum by the number of observations.

measure
a classification of data items. The values of measure data items are aggregated (unless otherwise specified) and can be used in computations or analytical expressions. For example, a measure data item could contain age values that are grouped by gender and then averaged.

member
in a multidimensional database (or cube), a name that represents a particular data element within a dimension. For example, September 1996 might be a member of the Time dimension. A member can be either unique or non-unique. For example, 1997 and 1998 represent unique members in the Year level of a Time dimension. January represents non-unique members in the Month level, because there can be more than one January in the Time dimension if the Time dimension contains data for more than one year.
multidimensional data source
a collection of data items and filters that describes and provides a view of a cube. See also cube, data item, and data source.

natural break
a boundary in a range of data as determined by a histogram of data distribution. See also histogram.

operator
in a SAS expression, any of several symbols that request a comparison, a logical operation, or an arithmetic calculation.

parent
within a dimension hierarchy, the ancestor in level n of a member in level n-1. For example, if a Geography dimension includes the levels Country and City, then Thailand would be the parent of Bangkok, and Germany would be the parent of Hamburg. The parent value is usually a consolidation of all of its children's values.

pie chart
a circular chart that is divided into slices by radial lines. Each slice represents the relative contribution of each part to the whole.

progressive bar chart
a type of bar chart that shows how the initial value of a measure data item increases or decreases during a series of operations or transactions. See also bar chart.

prompted filter
a type of filter that enables a report viewer to select the criteria that will be used to restrict the data that appears in a report.

publication channel
an information repository that has been established using the SAS Publishing Framework and that can be used to publish information to users and applications.

quantile
any of the points or values that divide data into groups that contain equal numbers of observations, or any of those groups.

query
a set of instructions that requests particular information from one or more data sources.

ranking
the process of ordering observations according to values of particular measure data items. The observations that are ordered depend on the object that contains the data. For list tables, observations correspond to rows. For crosstabulation tables, if the measures are on the columns, then the ordered observations can be on the individual rows or on the row that contains the outermost category data item. For graphs, observations generally correspond to data points along a particular axis. See also category, crosstabulation table, data item, list table, and measure.

region identifier
a data item that associates values in a table with regions on a geographical map.
relational data source
a collection of data items and filters that describes and provides a view of two-
dimensional physical data, in which the data values are arranged in rows and columns. See also data item and data source.

SAS report
a report that has been stored in the SAS Report Model format. A SAS report might be available for viewing in the portal if your organization has installed SAS Web Report Studio.

scatter plot
a two-dimensional plot that shows the joint variation of two data items.

standard deviation
a statistical measure of the variability of a group of data values. This measure, which is the most widely used measure of the dispersion of a frequency distribution, is equal to the square root of the variance.

stored process
a SAS program that is stored on a server and that can be executed as requested by client applications such as SAS Web Report Studio. The embedded SAS code can contain instructions for rendering report elements as part of a larger report or for rendering a complete report that includes queries, prompted filters, titles, images, and statistical analyses.

tile chart
a graph that represents the relative values of data by using rectangular areas. The color of each area represents the value of one measure in the query. The size of each area represents the value of the another measure in the query. The academic term for a tile chart is 'treemap.'

Time dimension
a dimension that divides time into levels such as Year, Quarter, Month, and Day.

timestamp
a data type or value that represents both a date and a time.

tooltip
descriptive text that appears when a cursor is placed over certain elements of a graphical user interface, such as the tool icons in a toolbar.
Index

A
access denied 290
accessibility features 5
Actions menu 25
aggregated data, using detail data instead of 97
aggregation, modifying for measures 96
alphanumeric categories 86
filters for 102
prompted section filters for 106
analysis 4
conditional highlighting and 207
drilling and expanding and 189
filtering and ranking and 169
sorting and 195
totals, subtotals, percent of total calculations and 201
archiving reports 221
deleting archived reports 223
viewing archived reports 222
axes, scale type and style 155

B
background color
graphs 154
legends 157
banners 31
bar charts 137
assigning data items to functions in 144
progressive 140, 148, 160
properties specific to 158
bar-line charts 138
assigning data items to functions in 145
properties specific to 159
border color
graphs 154
tables 131
borders for graphs 154
browsers
accessibility 5
limitations 281
browsing 183
for filter values 183
for multidimensional data items 186
for relational data items 184
calculations 204
capabilities, access to 9
cascading prompted filters 101
creating 112
supplying values for 113
category data items 86
category filters
for crosstabulation tables 174
for graphs 179
cells
adding to layout grid 78
aligning cell content in layout grid 78
in tables 132
merging in layout grid 79
charts
See also bar charts
bar-line charts 138, 145, 159
pie charts 139, 147, 159
tile charts 141, 151, 161
colors
background color of graphs 154
background color of legends 157
border color of graphs 154
border color of tables 131
styles 7
assigning to functions in crosstabulation tables 128
assigning to functions in line graphs 146
assigning to functions in list tables 127
assigning to functions in pie charts 147
assigning to functions in progressive bar charts 148
assigning to functions in scatter plots 149
assigning to functions in tile charts 151
category data items 86
detail data for table or graphs 213
from data sources 49
hiding 274
hyperlink data items 136
in graphs 144
in tables 127
modifying default format 94
multidimensional 186, 187
queries based on 85
relational 184, 185
standard data items in queries 86
Data menu 18
data refresh
  in viewed reports 48
  manual versus automatic 283
data security 10
Data Source Details dialog box 213
data source reports 44
data sources
data items from 49
default 30
detail data for tables or graphs 213
invalid 291
modifying measure aggregation 96
moved or renamed 291
relational versus multidimensional 285
date categories 86
filters for 105
prompted filters for 110
detail data
displaying behind crosstabulation table values 214
exporting from crosstabulation tables 266
for regions in geographical maps 215
for tables or graphs 213
instead of grouped and aggregated data 97
viewing in crosstabulation tables 267
distributed reports
deleting distribution plans 249
editing distribution plans 248
viewing a list of 247
distributing reports 242
drilling and expanding 189
analysis and 189
drilling hierarchies in graphs 190
  effects on conditional highlighting in tables and graphs 193
effects on filtering and ranking 193
effects on panning and zooming in geographical maps 194
effects on percent of total calculations in tables 194
effects on totals and subtotals in tables 194
hierarchies in crosstabulation tables 189
  hierarchy in geographical maps 191
synchronized 81
dynamic text
  in headers and footers 65
cascading prompted filters 101, 112, 113
category filters 174, 179
  combining filters 116
  creating 102
  custom section filters 116, 117
detail data for tables or graphs 213
effects of drilling and expanding on 193
  for alphanumeric categories 102
  for crosstabulation tables 174, 178
  for date, time, or timestamp categories 105
  for geographical maps 182, 183, 277
  for graphs 179, 181, 277
  for list tables 172
  for tables 277
  hierarchy filters 174, 179
  measure filters 176, 179, 182
  member property filters 177
  predefined filters 116
  prompted section filters 106
  section filters 275
  synchronized filtering 81
  viewing a summary of applied filters 117
Firefox 281
folders 230
  creating 231
  deleting 232
  in Open dialog box 25
  naming 273
  renaming 231
  scheduling 257
footers
  creating 65, 66
  default 30
dynamic text in 65
  removing 67
formats
  modifying for custom data items 96
  modifying for data items 94
  modifying for standard data items 94
functions
  assigning data items to, in bar charts 144
  assigning data items to, in bar-line charts 145
  assigning data items to, in crosstabulation tables 128
  assigning data items to, in line graphs 146
  assigning data items to, in list tables 127
  assigning data items to, in pie charts 147
assigning data items to, in progressive bar charts 148
assigning data items to, in scatter plots 149
assigning data items to, in tile charts 151

G
geographical maps 162
detail information for regions 215
displaying query results 162
drilling or expanding geographic hierarchy 191
effects of drilling and expanding on panning and zooming 194
exporting data from 264
filtering and ranking independent 82
inserting into report layout 162
measure filters for 182
measures for 163, 164
panning 164, 194
properties 165
removing 166
removing filters or rankings 183
zooming 164, 194
graph types 137
changing current type 158
properties specific to 158
graphs
See also bar charts
axis scale type and style 155
background color 154
bar-line charts 138, 145, 159
border color 154
borders of 154
category or hierarchy filters for 179
conditional highlighting for values 211
copying the formatting of 157
data items in 144
displaying detail data 213
displaying query results 137
drilling hierarchies in 190
effects of drilling and expanding on conditional highlighting 193
exporting graph data 264
filtering and ranking 179, 277
grid lines 154
incomplete 293
independent 82
inserting into report layout 142
legends 157
line graphs 138, 146, 159
measure filters for 179
pie charts 139, 147, 159
progressive bar charts 140, 148, 160
ranking 180
reference lines 155
removing 166
removing filter or ranking from 181
scatter plots 141, 149, 160
size of 153
sorting ascending or descending values 198
sorting by measure values 198
tile charts 141, 151, 161
titles 152
grid for layout
See layout grid
grid lines on graphs 154
group breaks 119
adding 119
removing 122
removing measure values 121
grouped data
detail data instead of 97
grouping query results
adding group breaks 119
group breaks 119
removing group breaks 122
removing measure values from group breaks 121

H
headers
creating 65, 66
default 30
dynamic text in 65
removing 67
headings in tables 132
Help
Help menu 18
hiding
data items 274
totals and subtotals 203
hierarchies
drilling in graphs 190
drilling or expanding in crosstabulation tables 189
drilling or expanding in geographical maps 191
hierarchy data items 86
hierarchy filters
for crosstabulation tables 174
for graphs 179
high contrast 7
highlighting
See conditional highlighting
hyperlink data items
displaying query results 136
images 69
   placing in report sections 69
   removing 72
incomplete tables and graphs 293
independent objects 82
Insert menu 17
interactive filters 101
interface 13
invalid data sources 291

J
JAWS 7

K
keyboard navigation
   accessibility 6

L
labels for legends 157
layout grid 7
   adding cells 78
   aligning cell content 78
   deleting empty columns or rows 79
   deleting objects 79
   merging cells 79
   placing objects in 80
   positioning report objects 77
   repositioning objects 80
legends on graphs 157
line graphs 138
   assigning data items to functions in 146
   properties specific to 159
linking
   hyperlink data items 136
   prompts in report linking 277
   reports 251
   to reports or Web pages 251
list tables 124
   assigning data items to functions in 127
   exporting table data 265
   filtering and ranking 172
   showing or hiding totals and subtotals 203
   sort and sorting priority for values 196
   sorting data 195
logging off 11
logging on 10

M
maps
   See geographical maps
measure data items 86
measure filters
   for crosstabulation tables 176
   for geographical maps 182
   for graphs 179
measures
   for geographical maps 163, 164
   in custom data items 90
   modifying aggregation of 96
   removing values from group breaks 121
   sorting by measure values in graphs 198
member property filters
   for crosstabulation tables 177
menus 15
merging cells in layout grid 79
multidimensional data
   conditional highlighting for 276
   multidimensional data items
   browsing for 186
   searching for 187
multidimensional data sources
   versus relational 285
multidimensional tables
   showing or hiding totals and subtotals 203

N
naming guidelines
   for reports, folders, templates 273
navigation
   keyboard 6
   skip navigation 6
   viewed reports 45
   with Open dialog box 24

O
objects
   deleting in layout grid 79
   independent 82
   placing in layout grid 80
   repositioning in layout grid 80
   synchronized 81
Open dialog box 23
   accessing 28
   Actions menu 25
   folders in 25
   navigating locations with 24
   searching for files with 24
   organizing reports 230

P
panning
effects of drilling and expanding on geographical maps 164
passwords 11
percent of total calculations adding to tables 204
analysis and 201
effects of drilling and expanding 194 in tables 204
relationship with totals and subtotals 202
removing from tables 205
pie charts 139
assigning data items to functions in plots specific to 147
scatter plots 141, 149, 160
predefined filters
deselecting 116
preferences
default data source, style, header, and footnote 30
default time zone 32
defaults for opening and saving reports 29
previewing query results 98
printing and exporting 263
detail data from crosstabulation tables 266
exporting entire report 263
exporting graph data 264
geographical map data 264
list table data 265
printing reports 268
reports and report data 263
viewing detail data in crosstabulation tables 267
printing preferences 268
printing reports 269
progressive bar charts 140
assigning data items to functions in properties specific to 148
prompted filters 101
cascading 101, 112, 113
defining and applying 112
defining dependencies between 113
for date categories 110
ordering 112
prompted section filters 106
for alphanumeric categories 106
prompts 42
defining in report linking 277
publication channels
publishing reports to 241
publishing reports 241
Q
queries 3
based on data items 85
custom data items in 90
standard data items in 86
query results
displaying 124
displaying in geographical maps 162
displaying in graphs 137
displaying in hyperlink data items 136
displaying in tables 124
grouping 119
previewing or exporting 98
subsetting 101
R
ranking
analysis and 169
crosstabulation tables 174, 176
effects of drilling and expanding 193
geographical maps 182, 277
graphs 179, 180, 277
list tables 172
removing from crosstabulation tables 178
removing from geographical maps 183
removing from graphs 181
tables 277
reference lines 155
refreshing data
in viewed reports 48
manual versus automatic 283
relational data items
browsing for 184
searching for 185
relational data sources
versus multidimensional 285
relative time
custom data items based on 90, 91
renamed data sources 291
renaming
folders 231
report sections 236
reports 233
standard data items 89
repairing reports 233
report layout
inserting geographical maps 162
inserting graphs 142
inserting tables 126
report schedules
deleting 262
editing 262
report sections 235
adding 235
creating headers and footers for 65
deleting 237
including text objects 71
independent objects 82
placing images in 69
renaming 236
reordering 237
synchronized objects 81
report templates 56, 225
deleting 226
saving 226
report wizard 51
reporting elements 49
reporting resources 10
reports 219
  adding sections 235
  archiving 221
  copying 223
  created with previous version of Web
  Report Studio 279
data source reports 44
defaults for opening and saving 29
deleting 226
deleting distribution plans 249
deleting sections 237
design 3
distributing 242
e-mailing URL for 239
editing distribution plans 248
exporting entire report 263
exporting reports and report data 263
externally created 45
inserting stored processes 73
linking 251
menus 15
modifying data in viewed reports 48
modifying properties 227
moving 229
naming 273
navigating viewed reports 45
organizing 230
positioning report objects 77
printing 268, 269
prompts in links 277
publishing to publication channels 241
refreshing data in viewed reports 48
renaming 233
repairing 233
saving 60
scheduling 257
searching for 274
shared locations 239
stored process reports 41
viewing 37
viewing a list of distributed reports 247
viewing a list of scheduled reports 260
viewing saved reports 38
roles 9
rows
deleting empty rows from layout grid 79
moving in tables 135
number to display in tables 129

S
SAS Intelligence Platform
SAS Web Report Studio and 5
SAS Web Report Studio 3
  access to capabilities 9
  accessibility features 5
  benefits of 4
  Firefox with 281
  how it works 4
  logging off 11
  logging on 10
  previous versions 279
  SAS Intelligence Platform and 5
  saved reports 38
  saving reports 29, 60
scatter plots 141
  assigning data items to functions in 149
  properties specific to 160
scheduled reports
  viewing a list of 260
  scheduling 257
  deleting report schedules 262
  editing report schedules 262
  folders 257
  reports 257
  stored processes 257
screen readers 6
searching 183
  for files 23
  for filter values 183
  for multidimensional data items 187
  for relational data items 185
  for reports and stored processes 274
section filters 101
  applying 114
  creating 275
  custom 116, 117
  prompted 106
security 10
shared locations 239
sharing
  reports 239
skip navigation 6
sorting
  analysis and 195
  ascending or descending values in graphs 198
by measure values in graphs 198
by measure values in graphs 198
data in list or crosstabulation tables 195
removing all sorting 199
sort and sorting priority for list table
values 196
synchronized 81
standard data items 86
category data items 86
detail data versus grouped and aggregated
data 97
hierarchy data items 86
measure data items 86
modifying default format 94
removing 89
renaming 89
selecting 87
stored process reports 41
stored processes 49, 73
inserting in reports 73
removing 75
running 41, 56
scheduling 257
searching for 274
style properties
for headings, subheadings, and cells 132
for total and subtotal values 133
styles, default 30
subheadings in tables 132
subsetting query results 101
applying section filters 114
combining filters 116
creating cascading prompted filters 112
creating filters 102
creating prompted section filters 106
deselecting predefined or custom section
filters 116
removing filters 117
section filters 101
viewing summary of applied filters 117
subtotals 133, 202
analysis and 201
effects of drilling and expanding 194
relationship with totals and percent of
totals 202
showing or hiding for crosstabulation
tables 203
showing or hiding for list tables 203
showing or hiding for multidimensional
tables 203
synchronized drilling and expanding 81
synchronized filtering 81
synchronized objects 81
synchronized sorting 81
T
Table of Contents pane 45
table types 124
changing currently selected type 135
tables
See also crosstabulation tables
border color 131
cells 132
changing current table type 135
conditional highlighting 193, 276
conditional highlighting for values 208
copying the formatting of 134
data items in 127
displaying detail data 213
displaying query results in 124
filtering and ranking 277
general properties 129
headings 132
incomplete 293
independent 82
inserting into report layout 126
list tables 124
moving columns and rows 135
number of columns and rows to display 129
percent of total calculations 194, 204,
205
removing 166
resizing columns 136
subheadings 132
titles 128
totals and subtotals 133, 194, 202
templates
naming 273
report templates 56, 225, 226
text, dynamic
in headers and footers 65
text objects 69
including in report sections 71
removing 72
tile charts 141
assigning data items to functions in 151
properties specific to 161
time categories 86
filters for 105
time zone, default 32
timestamp categories 86
filters for 105
titles
in graphs 152
in tables 128
totals 133, 202
analysis and 201
effects of drilling and expanding 194
in tables 202
relationship with subtotals and percent of totals 202
showing or hiding for crosstabulation tables 203
showing or hiding for list tables 203
showing or hiding for multidimensional tables 203

U
URLs, e-mailing for reports 239
user interface 13

V
View menu 17
View mode 19
moving columns and rows in tables 135
viewed reports
modifying data in 48
navigating 45
refreshing data in 48
viewing

archived reports 222
data source reports 44
detail data in crosstabulation tables 267
externally created reports 45
list of distributed reports 247
list of scheduled reports 260
reports 37
saved reports 38
stored process reports 41
summary of applied filters 117

W
Web pages, linking to 251
Welcome window 13

Z
zooming
effects of drilling and expanding on 194
geographical maps 164
Your Turn

We welcome your feedback.

- If you have comments about this book, please send them to yourturn@sas.com. Include the full title and page numbers (if applicable).
- If you have comments about the software, please send them to suggest@sas.com.